Subject: FVWM: configure fails at "argument types of select()"

From: Michael Hamlin <[email-masked]>
Date: Fri, 1 Jun 2001 17:26:19 -0400 (EDT)

Howdy

I am trying to compile latest stable build on a Solaris machine
where I don't have root.  I used the --prefix option with ./configure 
to specify my home directory.. but configure stops at:

checking argument types of select()... configure: error: can't determine
argument types

I spent an hour reading documentation various places (including 
on on autoconf) but I can't find any hints on how to get around this.
Any suggestions would be appreciated; please copy to 
email: [email-masked]

michael
----
"But then I won't be watching TV; you can see the bind I'm in."

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 01 Jun 2001 19:10:07 -0400

> Any suggestions would be appreciated; please copy to 

By latest stable build do you mean 2.2.5?

You should mention the Solaris release and
the compiler and compiler release.

On my Solaris 2.8 machine, with gcc 2.8.1, and fvwm 2.2.5,
configure does 3 checks for select(), this is the one that works:

#include <sys/types.h>
#include <sys/time.h>
#include <sys/select.h>
#include <sys/socket.h>
extern select(int, fd_set *, fd_set *, fd_set *, struct timeval *);
int main() {
; return 0; }

Try compiling that and see if it compiles OK.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].