Subject: FVWM: fvwm

From: Skliarouk Arie <[email-masked]>
Date: Mon, 25 Jun 2001 16:37:02 +0300

Hi!

Is there a way to embedd ICQ into fvwm modules?

PS: I'm not subscribed to the mailing list - cc me please.

-- 
Bye,  | ICQ: 43062358     | Fax: (972)-2-6796453
Arie  | Phone: (972)-5-4888832 | http://www.tkos.co.il

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: wing tung Leung <[email-masked]>
Date: Mon, 25 Jun 2001 17:16:08 +0200

> Is there a way to embedd ICQ into fvwm modules?

I think you can do that, but I think writing a regular application is
better suited. As far as I know, a fvwm module should do something
about window management, nothing less or more.

-- 
GnuPG public key: http://www.keyserver.net
fingerprint = A3C4 DE50 712D 4FA8 C564  4D96 5E06 C9CC ECFA 19C5
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 25 Jun 2001 16:18:22 +0000

> about window management, nothing less or more.

It is hard to understand the real intention from the question, but I think
Arie is not interesting in writting a new module and ICQ application, but
in configuring existing fvwm module and ICQ application.

There are modules FvwmButtons and FvwmWharf (see their man pages) that may
swallow a mini ICQ applet (say, 64x64 pixels, if you have one) or include
an ICQ icon, which can be used to launch the app, like in this screenshot:

  http://fvwm.org/screenshots/Tenebrae-desk-800x600.gif

If this answer does not help, alaborate on the question.

Regards,
Mikhael.

---

From: Tenebrae <[email-masked]>
Date: Mon, 25 Jun 2001 12:10:52 -0700 (PDT)

>   http://fvwm.org/screenshots/Tenebrae-desk-800x600.gif

Hey, that's mine!  :)
That's an FvwmButtons thang:

*FvwmButtons(Title licq, Icon licq-icon-sun.xpm, \
             Action 'Exec "licq" licq &')

I suck at fvwm configuration and just did search and replace type stuff
with the default fvwm95 rc file from ages ago.  Hey, if it works...
Trial and error.  :)

Only thing I have a problem with is odd eterm errors every now and then,
and I think it's fvwmtaskbar gradually taking up all my memory over time.
								-Tenebrae.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 26 Jun 2001 22:23:56 +0000

On 26 Jun 2001 10:29:21 +0300, Skliarouk Arie wrote:
> 
> On Monday 25 June 2001 19:18, you wrote:
> Sorry for not clarifying myself.
> I meant to ask:
>  Is there ICQ applet for FvwmButtons? (Not just to launch ICQ,
> but that would change it's status "Online/Offline/Message".
> Closest to gnomeicu - the better.

I myself don't use ICQ, maybe someone else on the list knows more.
I may suggest this page (just did a quick search on the web):

  http://www.portup.com/~gyandl/icq/

Regards,
Mikhael.