Subject: FVWM: Implementing a kiosk with FVWM

From: "Ripalda-Marin, Miguel-Angel" <[email-masked]>
Date: Fri, 22 Jun 2001 09:05:12 +0100

Hi everybody,

we are developing a kind of Kiosk over FVWM. Now I would like to perform
some 'strange' functionality:
1.- I have one window with the main buttons of my kiosk app.
2.- I have another window with plaympeg running some videos.
3.- The video window must stay on top as long as the user doesn't push any
button of the main window (the user can see the buttons because the main
window is elarged to the size of the screen, and the video window is
smaller, and plaed on the top-left corner).
4.- What I don't want is the video window to move back if the user clicks on
any visible part of the main window that doesn't belong to the buttons...

I have tried to set the video window style to sticky, but I doesn't seem to
work (I suppose that the thing that does not work is my brain ;-)

Best regards and thanks evrybody in advance,

Miguel Ángel
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Jun 2001 09:59:03 +0200

> Best regards and thanks evrybody in advance,

Since fvwm knows nothing about the contents of a window you have
to teach the buttons to explicitly raise or lower the windows.

 - Place the main window below the video window at first.

 - Use ClickToFocus on both windows and make sure that clicking
   in the window does not raise them:

     Style * ClickToFocus, ClickToFocusRaisesOff

   for 2.3.x or

     Style * ClickToFocus
     GlobalOpts ClickToFocusClickDoesntRaise
    
   for 2.2.x.

 - Make sure that the windows get no decorations or if they do
   that fo raise/lower actions are bound to any part of the
   decorations.

 - Start the FvwmCommandS module when fvwm starts up.

 - Now, make the buttons on the main window trigger this shell
   command in addition to whatever they normally do:

     FvwmCommand "Next (main_window_name) Raise"

   And for the hypothetical "Show video" button:

     FvwmCommand "Next (main_window_name) Lower"

This will not work too well if any of the windows are ever
closed and reopened.  In this case I recommend you the "Layer"
command of 2.3.x instead of Raise and lower:

  Raise -> Layer 0 6
  Lower -> Layer 0 2

I'd be interested to get feedback if you get this working.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]