Subject: RE: FVWM: fvwm2 on cygwin/XFree86

From: Jeff Walker <[email-masked]>
Date: Tue, 26 Jun 2001 09:53:04 -0600

Okay, xmodmap looks okay to me, except that only Alt_L and Alt_R are present
for mod1, no meta.  But the keycode is correct.  Xvnc has all four, alt and
meta tied to mod1.  Could this be the problem?  I don't really see how, but
I'm no xmodmap expert (or X keyboard expert).

Well, after writing that paragraph, I decided to try changing the modifier
in the "Mouse" line to "mod1" instead of meta and it works.  so here is my
new line:
Mouse 1 WTFSI 1 Move

I guess I don't understand why meta won't work, but I guess that is okay.
Well, I guess because Meta_L isn't there, but I don't know quite how to fix
that without breaking anything else.  I hope that is the only problem.  I
guess we will see....

Thanks.

-- 
Jeff Walker                   MatchLogic, Inc.
[email-masked]        7233 Church Ranch Blvd.
Voice 1 (303) 222-2105        Westminster, CO  80021
Fax   1 (303) 222-2001        www.matchlogic.com

-----Original Message-----
From: Dominik Vogt [mailto:[email-masked]]
Sent: Tuesday, June 26, 2001 1:27 AM
To: Jeff Walker; fvwm
Subject: Re: FVWM: fvwm2 on cygwin/XFree86

On Mon, Jun 25, 2001 at 02:24:39PM -0600, Jeff Walker wrote:
> Had anyone actually tried using fvwm2 on cygwin/xfree86?
> 
> It seems to work, but I am having trouble getting the alt key to really
> work.  I have it set-up so that the mouse button 1 and the alt key will
move
> the window:
> Mouse 1 WTFSI M Move 
> 
> This works via my vncserver (a xfree86 port), but not on cygwin/xfree86.
> 
> I'm not convinced that this is a fvwm problem, I am just wondering if
> someone has seen this.
> 
> BTW, I am seeing something strange in xev (under cygwin), but the
> cygwin/xfree86 folks seem to think it is okay.  I run xev, and when I
press
> and hold a modifier (any one, not just alt) it repeats like any other key
> (say, the letter "m").  I don't know if this is contributing to the
problem
> or not, other programs seem to understand that I hit, say "alt-q" instead
of
> just "q" (like vim).
> 
> Is this enough to go on?  Thanks.

Does the output of

  $ xmodmap

look okay?  The "Meta_L" key symbol should be mapped to Mod1.  If
not, this is probably your problem, if it is, try to find out
which key symbol is generated by the "Alt" key and use xmodmap to
tie it to Mod1.  If this does not help either I am out of ideas.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Wed, 27 Jun 2001 08:15:35 -0700

> that without breaking anything else.  I hope that is the only problem.  I

  use xev to see keycode and keysym, if the key does not have desired
keysym use xmodmap or XKEYBOARD extension or xkeycaps to add it.

  then use xmodmap to see which modifiers you have. example:

jojda:~>xmodmap
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_R (0x71)
mod2        Num_Lock (0x4d)
mod3      
mod4        Meta_L (0x73),  Meta_R (0x74)
mod5        Scroll_Lock (0x4e)

  from the above you can see that M or 1 can be used in keybindings as
alt key, 4 can be used for META_L or META_R (I used xev to see that it's
a key with MS Windows Logo on my keyboard). see man xmodmap for more
info (search for modifier, you can clear, add or remove modifier)

  not sure if you already tried the obve, if you it does not work there
is something wrong with cygwin...

  btw as far as autorepeating of keys goes you can set it up using xset
(individually per key), so if the modifiers do the autorepeat you can
turn it of, not sure if it would help your problem though...

	erik

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Jun 2001 01:46:56 +0200

On Tue, Jun 26, 2001 at 09:53:04AM -0600, Jeff Walker wrote:
> meta tied to mod1.

According to my documentation this is not even possible.
Somewhere I read that only two keys can be bound to a single
modifier.

> Could this be the problem?  I don't really see how, but

Er, it does?  It shouldn't.  In fvwm, the modifier "M" is
synonymous to "1", so if one fails, the other one can't work
either.  Now I'm puzzled.

> that without breaking anything else.  I hope that is the only problem.  I

Try

  $ xmodmap -e "clear Mod1"
  $ xmodmap -e "add Mod1 = Meta_L Alt_L"

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].