Subject: FVWM: fvwm2 on cygwin/XFree86

From: Jeff Walker <[email-masked]>
Date: Mon, 25 Jun 2001 14:24:39 -0600

Had anyone actually tried using fvwm2 on cygwin/xfree86?

It seems to work, but I am having trouble getting the alt key to really
work.  I have it set-up so that the mouse button 1 and the alt key will move
the window:
Mouse 1 WTFSI M Move 

This works via my vncserver (a xfree86 port), but not on cygwin/xfree86.

I'm not convinced that this is a fvwm problem, I am just wondering if
someone has seen this.

BTW, I am seeing something strange in xev (under cygwin), but the
cygwin/xfree86 folks seem to think it is okay.  I run xev, and when I press
and hold a modifier (any one, not just alt) it repeats like any other key
(say, the letter "m").  I don't know if this is contributing to the problem
or not, other programs seem to understand that I hit, say "alt-q" instead of
just "q" (like vim).

Is this enough to go on?  Thanks.

-- 
Jeff Walker                   MatchLogic, Inc.
[email-masked]        7233 Church Ranch Blvd.
Voice 1 (303) 222-2105        Westminster, CO  80021
Fax   1 (303) 222-2001        www.matchlogic.com

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jun 2001 09:26:45 +0200

> Is this enough to go on?  Thanks.

Does the output of

  $ xmodmap

look okay?  The "Meta_L" key symbol should be mapped to Mod1.  If
not, this is probably your problem, if it is, try to find out
which key symbol is generated by the "Alt" key and use xmodmap to
tie it to Mod1.  If this does not help either I am out of ideas.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].