Subject: FVWM: fvwm and mozilla

From: Felipe Leme <[email-masked]>
Date: Fri, 04 May 2001 17:02:32 -0700

Hello,

I'm a long time fvwm user, and as I started to use mozilla, I'm facing 
annoy problem: sometimes, when mozilla opens a popup window, that window 
does not show fvwm buttons 1. 4 and 2 (exactly the ones I use).

That's very annoy, because I can't close the window with 1 click (which 
is bound to my button 1). I  worked-around this pbm by adding the same 
action to button 3, but now I  have an unecessary button in all other 
applications, but I am curious to know the reason/solution of the problem.

I don't know if that is a fvwm or mozilla pbm (I believe in the 2nd 
option :), but I didn't find any mention to it anywhere (not even in the 
mailing list: 
http://www.hpc.uh.edu/cgi-bin/w3glimpse/fvwm?query=mozilla&errors=0&maxfiles=50&maxlines=10). 

The sample code below reproduces the problem:

--- test.html ----
<html>
<head>
<title>test</title>
<script language="javascript">
function popup() {
       var url="test.html";
       var opts = 
"toolbar=no,status=no,location=no,menubar=no,resizable=no,height=320,width=490,scrollbars=yes";
       closer = window.open("", "CloserLook", opts);
       closer.focus();
       closer.location = url;
  }
</script>
</head>
<body bgcolor="white">
<a href="javascript:popup()">popup</a>
</body>
</html>

Any help is appreciated.

Thanks,

Felipe

PS: please CC me the answer in private too, as I don't belong to the 
mailing-list

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 04 May 2001 20:16:21 -0400

> applications, but I am curious to know the reason/solution of the problem.

This is question 3.12 in the FAQ.  The FAQ mentions Netscape, but
Mozilla does the same things.

Try:

Style * DecorateTransient

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Felipe Leme <[email-masked]>
Date: Fri, 04 May 2001 18:17:47 -0700

I already have that defined, and it works fine with netscape 4.x and 
konqueror. It just doesn't work with mozilla/netscape 6. Besides, all 
other buttons work. It's really weird...

(I could send my .fvwm2rc, if necessary)

---

From: Michael Han <[email-masked]>
Date: Fri, 4 May 2001 18:29:07 -0700

> other buttons work. It's really weird...

How about setting "Style * NoDecorHint"?
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
Avoid cliches like the plague
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Felipe Leme <[email-masked]>
Date: Fri, 04 May 2001 22:36:15 -0700

> How about setting "Style * NoDecorHint"?

That worked, thanks (I was using MWMDecor before).

I didn't find any mention about it at the docs or man page, though 
(there is a good explanation about MWMDecor, but nothing about NoDecorHint).

Thanks again,

Felipe

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 May 2001 15:35:51 +0200

>From the latest man page:

  MwmDecor makes fvwm attempt to recognize and respect the mwm
  decoration hints that applications occasionally use.  To switch
  this style off, use the NoDecorHint style.
                          ^^^^^^^^^^^

The man page had some parts missing for earlier versions.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].