Subject: FVWM: The latest breakthrough in Alt-Tabbing

From: Cameron Kerr <[email-masked]>
Date: Tue, 01 May 2001 21:21:15 +1200

Greeting and most joyous jubilations!

Re: FVWM2 FAQ Question 3.3

It was with great satisfaction that I found a satisfactory
solution to the Alt-Tab solution.

Description: Alt-Tab should change the focus to the next
  window and raise it to the top. When modified with Shift,
  behaviour should be the same, with the exception of the
  previous window being the subject of the change.
    No window list is displayed. On each Alt-Tab event, the
  next window is brought into focus and raised. This behaivour
  traverses desktops by default, though I dear suggest that
  this could be contained with a condition. As an extra, Ctrl-Tab
  could switch between desktops, ala KDE.
    I have tried this with SloppyFocus and ClickToFocus, with
  success.

Solution:

(original lines commented out)
#Key Tab         A       MS     Prev Focus
Key Tab         A       MS      Function "shift-alt-tab"
#Key Tab         A       M      Next Focus
Key Tab         A       M       Function "alt-tab"

#
# This will create M$-Windows Alt-Tab behaivour. The next window
# will be brought into focus and raised to the top.
#
DestroyFunc "alt-tab"
AddToFunc "alt-tab"          "I" Next ( CurrentDesk CurrentPage ) Focus
+                            "I" Current Raise
DestroyFunc "shift-alt-tab"
AddToFunc "shift-alt-tab"    "I" Prev ( CurrentDesk CurrentPage ) Focus
+                            "I" Current Raise

Note that this is from a Slackware 7.1 installation.

Current Limitations:
  It would be nice for Alt-Tab to go to the last window I was
  in, rather than go in a circular loop. Any suggestion for making
  the old current window the the next Next window?

PS: May have found a performance bug.

AddToFunc "alt-tab" "I" Next ( CurrentPage CurrentDesk ) Focus
+                   "I" Current Raise

Is nice and speedy.

AddToFunc "alt-tab"
+                   "I" Next ( CurrentPage CurrentDesk ) Focus
+                   "I" Current Raise

Is considerably slower.

This is with Fvwm2.2.4

PPS. Congrats on a nice WM and great docs!

-- 
Cameron Kerr -- cameron.kerr @ paradise.net.nz
Praise Slackware, our baud and saviour!
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 03 May 2001 11:05:50 -0400

> Re: FVWM2 FAQ Question 3.3
...
> +                   "I" Next ( CurrentPage CurrentDesk ) Focus

I've updated the FAQ.  It now shows the current direction we
are taking with alt-tab.

I wasn't aware that the "Missing I" problem was in 2.2.4, but
I know its been fixed in the latest betas.

As I remember this bug, when the first line of the function was
empty, it was waiting for the double click timeout (or something
like that).

> PPS. Congrats on a nice WM and great docs!

On behalf of all the fvwm-workers, thanks.
-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].