Subject: RE: FVWM: when a menu is taller than the screen

From: Jeff Walker <[email-masked]>
Date: Wed, 9 May 2001 08:17:55 -0600

If I understand the question, that little arrow should be a sub menu.  Fvwm2
will cascade for as many sub menus as it needs if the list is too long.

-- 
Jeff Walker                   MatchLogic, Inc.
[email-masked]        7233 Church Ranch Blvd.
Voice 1 (303) 222-2105        Westminster, CO  80021
Fax   1 (303) 222-2001        www.matchlogic.com

-----Original Message-----
From: Keith Kaple [mailto:[email-masked]]
Sent: Wednesday, May 09, 2001 7:59 AM
To: [email-masked]
Subject: FVWM: when a menu is taller than the screen

how do I display the rest of it?

occasionaly on this nice powerful machine i have, I have enough windows open
to create a menu that is taller than the whole screen and has an arrow at
the bottom.

I can't seem to figure out how to pop out the rest of the entries from this
arrow...

thanks in advance,

Keith

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Keith Kaple <[email-masked]>
Date: Wed, 9 May 2001 10:30:07 -0400

Yea, it _looks_ like a submenu, it says "More..." with an underscore below the first . and has an arrow > at the right of it.  But scrolling to it and pressing enter or any mouse button or any arrow key just makes the whole menu disappear.

Normally, putting the mouse on a submenu makes it appear.  This "automatic" submenu doesn't...do I need to define an action for "More..."?  If so, what would I need to call the submenu it displays.

Fvwm Version 2.2.2

perhaps that's my problem, is this a known bug?

k

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 May 2001 11:26:59 +0200

> perhaps that's my problem, is this a known bug?

It may be some mis-calculation of the menu size.  For The 2.3.x
betas I rewrote the menu sizing code.  Could you try if this 
works for you?  Ptherwise, please send your config file along with
detailed instructions how to see the problem.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tenebrae <[email-masked]>
Date: Fri, 11 May 2001 05:42:23 -0700 (PDT)

> detailed instructions how to see the problem.

Not quite the same problem as I have sometimes, but I DO occasionally have
a menu that's too large for my screen that I can't expand because the part
that should say "More..." is offscreen.  Oh, I HATE that...
Version is fvwm2-2.2.4-4.
I have an fvwm95 holdover at the bottom of my screen of a taskbar-type
strip.  I guess it has some "Always on top to interfere with your large
menus" option set...

Another thing I've noticed is that "FvwmTaskbar" occasionally seems to
show up as being some freaky memory hog in "top."  It's the only thing I
ever get any FVWM-related errors with.  Is that what that aforementioned
strip at the bottom is called?
								-Tenebrae.

---

From: "Yngvi J'garseogn" <[email-masked]>
Date: Fri, 11 May 2001 13:49:52 -0700 (PDT)

Hei

   Just to add my two cents worth . . . I also have this problem.

--FVWM2 Version--

[FVWM][main]:  Fvwm Version 2.3.15 compiled on Mar 17 2000 at 16:58:55
[FVWM][main]:  with support for:  Stroke XPM

--WinList Invocation--

Mouse 3 R       CM      Module FvwmWinList Transient

--Problem Description--

Menu...                >
  "<Click>", "<Enter>", "<Right Arrow>" all do Nothing.

Other items on list:
  "<Click>", "<Enter>" warp to the window, as expected.

All Items on list:
  "<Left Arrow>"  list vanishes.
  "[0-9]" "[a-z]" "." warps (in turn) to each item with that "tag"
                        (no other action)

--.fvwm2rc--

   See attachment

--How to Reproduce--

   The following script does the trick for me:)

----- lots-of-xterms --------------
#!/bin/ksh
#
typeset -i XTERM=0
while [[ $XTERM -lt 60 ]]
 do
  xterm &
  ((XTERM+=1))
  sleep 1
 done
-----------------------------------

   For this test, I brought up FVWM2 with fvwmbuttons and 1 xterm
running, I then run the script above (lots-of-xterms).  Once it settles
down, I hold down the control key and poke mouse3, up pops the
FVWMWinList, I mouse&|scroll to "Menu..." and the only things I can do
that get any response is [0-9] [a-z] & [Left Arrow], and none of those
fire the "Menu" (so to speak).

Thanks!

=====
.----------------- ------------------------------------------------
|   Greg LeVee    | UNIX _is_ user friendly.                       |
| [email-masked] | It's just selective about who its friends are. |
 ----------------- ------------------------------------------------
<http://www.geocities.com/yngvi>

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 May 2001 20:28:11 +0200

> while [[ $XTERM -lt 60 ]]

Um, FvwmWinList does not have a "More..." entry.  You must be
confusing something.a  Do you mean

  Mouse 3 R       CM      WindowList

?

What screen resolution do you have?

Bye

Dominik ^_^  ^_^

---

From: "Yngvi J'garseogn" <[email-masked]>
Date: Tue, 29 May 2001 06:11:07 -0700 (PDT)

Oops,

   Sorry, I pasted the "CTRL-Meta-Mouse3" instead of the "Ctrl-Mouse3"

Mouse 3 R       C       WindowList

------

$ xdpyinfo
[...]
screen #0:
  dimensions:    1280x1024 pixels (330x250 millimeters)
  resolution:    99x104 dots per inch
[...]
    class:    PseudoColor
    depth:    8 planes
[...]

Thanks!