Subject: FVWM: swallowable date app?

From: Martin Maciaszek <[email-masked]>
Date: Thu, 3 May 2001 13:06:30 +0200

I want to swallow a date-app, similar to the app in the cde
panel, into my FvwmButtons panel. So far I couldn't find a
suitable app for this. wmdate looked promising but it somehow
doesn't like being swallowed. it's always displayed in a separate
window. Does someone know a date app? (No, I don't want xclock in
digital mode. I already swallowed xclock in a separate button)

Cheers
Martin

-- 
Due knot trussed yore spell chequer two fined awl miss steaks.

---

From: Dan Espen <[email-masked]>
Date: Thu, 03 May 2001 10:36:43 -0400

> digital mode. I already swallowed xclock in a separate button)

The only clock like app I see in the CDE panel is dtcm in its iconic
state.  You should be able to get FvwmButtons to swallow that.

If I did want to have a button bar with a clock in it on my desktop,
I would use "asclock".  I found it at the Afterstep site.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Maciaszek <[email-masked]>
Date: Thu, 3 May 2001 17:15:13 +0200

> state.  You should be able to get FvwmButtons to swallow that.
The Problem with dtcm is that I don't have CDE installed :( I'm
trying to mimic the look of a CDE Desktop on my fvwm system.
(fvwm-themes looks good but is way too complex for me. So I just
take the good ideas. *g*)

> I would use "asclock".  I found it at the Afterstep site.

I searched a bit for asclock but it seems that it always displays
the time. :(

Cheers
Martin

-- 
TIM:    Too late.
ARTHUR: What?
TIM:    There he is!
   [They all turn,, and see a large white RABBIT lollop a few yards out of the
   cave.  Accompanied by terrifying chord and jarring metallic monster noise.]
                 "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 4 May 2001 11:07:14 +0000

> take the good ideas. *g*)

Ok, then you already have fvwm-themes installed, it enhances your fvwm
instalation even if you don't use it. Try the following from FvwmConsole:

  FvwmScript FvwmApplet-Day
  FvwmScript FvwmApplet-DayClock
  FvwmScript FvwmApplet-DigitalClock

If you use colorsets, you may also give 2 colorset numbers as parameters.

Other 64x64 applets (including Date/Time) as candidates for swallowing:

  http://www.bensinclair.com/dockapp/showstyle.php3?show=name

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 4 May 2001 12:19:31 +0000

On 04 May 2001 13:40:38 +0200, Martin Maciaszek wrote:
> 
> On Fri, May 04, 2001 at 11:07:14AM +0000, Mikhael Goikhman wrote:
> [snip]
> Perfect! That's what I wanted. :) Where is this applet defined?
> (I did a quick rgrep though /usr/local/share/fvwm/themes/). Or
> how can I adjust the font of the applet?

It is in /usr/local/share/fvwm/FvwmApplet-Day; currently there are no many
options, you may manually change font/color/position for widgets 2 and 4.

Regards,
Mikhael.

---

From: Martin Maciaszek <[email-masked]>
Date: Fri, 4 May 2001 13:40:38 +0200

Cheers
Martin
-- 
/* Fuck me gently with a chainsaw... */
        2.0.38 /usr/src/linux/arch/sparc/kernel/ptrace.c