Subject: RE: FVWM: New problems since 2.3.6

From: "Adye, TJ (Tim) " <[email-masked]>
Date: Fri, 11 May 2001 14:06:28 +0100

Hi Dan,

> I'm not clear on why FvwmBacker is getting NEW_PAGE messages when
> a window is deiconified.  Can you look in your .fvwm2rc and find the
> key or mouse binding that you are using to deiconify the window?

I have the following definitions for selecting a window from the taskbar. I
guess the same function is used when I select the window from the WindowList
(and get the same behaviour that way).

  *FvwmTaskBarAction Click1 DeiconifyFocusAndRaise
  DestroyFunc DeiconifyFocusAndRaise
  AddToFunc DeiconifyFocusAndRaise I Iconify off
  +                                I Focus
  +                                I Raise

> I don't get NEW_PAGE messages when I deiconify.

I also use

  DeskTopSize 1x1

and define four desks in my pager. Is that relevant?

> I notice that I've got FvwmBacker configured like this:
> 
> DestroyModuleConfig FvwmBackerDesk
> *FvwmBackerDesk 0 Exec xsetroot -solid blue
> *FvwmBackerDesk 1 Exec xsetroot -solid midnightblue
> *FvwmBackerDesk 2 Exec xsetroot -solid yellow
> *FvwmBackerDesk 3 Exec xsetroot -solid black
> 
> Where you are using the built in background changing, like this:
> 
> DestroyModuleConfig FvwmBackerDesk
> *FvwmBackerDesk 0 -solid blue
> *FvwmBackerDesk 1 -solid midnightblue
> *FvwmBackerDesk 2 -solid yellow
> *FvwmBackerDesk 3 -solid black
> 
> So I now see where that annoying refresh comes from, around line
> 218 in FvwmBacker.c there is a call to XSetWindowBackground.
> Thats the call that actually causes the refresh.  I think the
> "Exec xsetroot" approach is preferrable until FvwmBacker gets
> better logic for setting the background.

Sorry, I don't understand this. What's wrong with the internal
XSetWindowBackground? I get the same refresh when I run xsetroot from an
xterm.

Thanks,
Tim.

==============================  cut here  ==============================
Tim Adye, BaBar/DELPHI Groups, Particle Physics Dept.,     _   /|
          Rutherford Appleton Laboratory, UK.              \'o.O'   Oop!
e-mail:   [email-masked] or VXCERN::ADYE (HEPNET/SPAN)  =(___)=  Ack!
WWW:      http://hepwww.rl.ac.uk/Delphi/Adye/homepage.html    U  Thphft!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 11 May 2001 09:14:11 -0400

> XSetWindowBackground? I get the same refresh when I run xsetroot from an

You're right.  Must have been too early.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].