Subject: FVWM: Xpm Problems

From: Administrator <[email-masked]>
Date: Wed, 9 May 2001 13:23:48 -0500

I have tried everything suggested in the FAQ and INSTALL files
and have been unable to get colored icons. I am not a programmer but am
very familiar with UNIX.  Enclosed is the information about the computer
and the error messages. 

	 <<xpm_problems.txt>> 
	I probably missed something simple but I need help please ?

		Sincerely 
				John O' Dowd

---

From: Dan Espen <[email-masked]>
Date: Wed, 09 May 2001 14:57:48 -0400

Administrator <[email-masked]> writes:
> Operating system
> SunOS ultra80 5.8 Generic sun4u sparc SUNW,Ultra-80
> 
> xpm version is xpm-3.4k-solaris
> 
> invoking configure
> 
> setenv LDFLAGS -R/usr/local/xpm
> 
> ./configure --with-xpm-library=/usr/local/xpm/lib --with-xpm-includes=/usr/lo
> cal/xpm/include
> 
> error output
> 
> Configuration:
> 
>   FVWM Version:                      2.3.27
> 
>   Have ReadLine support?             no
>   Have RPlay support?                no
>   Have Stroke support?               no
>   Have XPM support?                  no: Xpm library or header not found!
>   Have GTK support?                  no
>   Have GNOME Window Manager support? yes
>   Have Session Management support?   yes
>   Have GNOME support in FvwmGtk?     no
> 
> config.log
> 
> configure:2353: checking for XpmReadFileToXpmImage in -lXpm
> configure:2372: cc -o conftest -g  -R/usr/local/xpm conftest.c -lXpm -L/usr/l

I think the -lXpm before -L/usr/local/xpm/lib is the problem.

Since you are using Solaris 8, try this:

  --x-libraries=/usr/openwin/lib:/usr/local/xpm/lib

> ocal/xpm/lib -lXpm  -L/usr/openwin/lib -R/usr/openwin/l
> ib  -lSM -lICE -lX11 -lsocket  -lnsl  1>&5
> ld: fatal: library -lXpm: not found
> ld: fatal: File processing errors. No output written to conftest
> configure: failed program was:
> #line 2361 "configure"
> #include "confdefs.h"
> /* Override any gcc2 internal prototype to avoid an error.  */
> /* We use char because int might match the return type of a gcc2
>     builtin and then its argument prototype would still apply.  */
> char XpmReadFileToXpmImage();
> 
> int main() {
> XpmReadFileToXpmImage()
> ; return 0; }
> 
> 
> ------ =_NextPart_000_01C0D8B5.30EA4C80--
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 27 May 2001 09:13:16 -0400

> char XpmReadFileToXpmImage();

Trying this myself, I see that my first suggestion wasn't right.

This does seem to work:

export LD_OPTIONS="-L/usr/local/lib -R/usr/local/lib"
./configure --with-xpm-library=/usr/local/xpm/lib\
 --with-xpm-includes=/usr/local/xpm/include