Subject: FVWM: Focus policy for xvkbd

From: Norman Walsh <[email-masked]>
Date: 17 May 2001 15:34:40 -0400

I want to run xvkbd which has the odd property that it should never
steal focus. I think this worked under 2.2.*, but it doesn't seem to
be working (for all apps, anyway) under 2.3.32.

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | All knowledge is of itself of some
http://nwalsh.com/            | value. There is nothing so minute or
                              | inconsiderable, that I would not rather
                              | know it than not.--Dr. Johnson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 17 May 2001 15:51:18 -0400

> be working (for all apps, anyway) under 2.3.32.

Do you mean get focus?

Its probably setting the input focus property to false.

By default, Fvwm honors this ICCCM rule.
You can override that for individual windows with
the Lenience Style.  Perhaps you've done that?

If so, you can undo it for just xvkbd with a Style command.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Norman Walsh <[email-masked]>
Date: 18 May 2001 11:05:41 -0400

/ Dan Espen <[email-masked]> was heard to say:
| If so, you can undo it for just xvkbd with a Style command.

I found that

  Style "*" SloppyFocus

made things work OK. FWIW.

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | It is as bad as you think. And they are
http://nwalsh.com/            | out to get you.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].