Subject: RE: FVWM: bash PS1 fvwm2 titlebar problem

From: Jeff Walker <[email-masked]>
Date: Fri, 18 May 2001 14:35:04 -0600

It just occurred to me that this could be an xterm bug (or feature :-/)
In the version I have (XFree86 4.0.1c(146)) there is a compile-time option
to avoid "flicker" and not update the title when it is the same.  Maybe
xterm (erroneously) thinks that the title hasn't changed?

-- 
Jeff Walker                   MatchLogic, Inc.
[email-masked]        7233 Church Ranch Blvd.
Voice 1 (303) 222-2105        Westminster, CO  80021
Fax   1 (303) 222-2001        www.matchlogic.com

> -----Original Message-----
> From: Mikhael Goikhman [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 2:27 PM
> To: Martin Novak
> Cc: FVWM
> Subject: Re: FVWM: bash PS1 fvwm2 titlebar problem
> 
> 
> On 11 May 2001 21:36:49 +0200, Martin Novak wrote:
> > 
> > could anyone try to reproduce this behaviour, or give me a hint?
> > 
> > below is the .bash_profile part which defines my PS1.
> > it works fine, but fvwm seems to have a problem with the 
> titlebar, when a
> > new xterm is opened. the titlebar simply says 'xterm', 
> until i change to
> > some directory for the first time. from then on it works properly.
> > with twm the ps1 definition works without problems here.
> > 
> > thanks in advance
> > martin novak
> > 
> > info:
> > system:	freebsd 4.3s
> > bash:	2.05
> > fvwm:	2.2.5
> > i've had this behaviour since fbsd 3.x, bash 2.03, fvwm 2.??
> > 
> > .bash_profile part:
> > ...
> > case $TERM in
> >     xterm*) TITLEBAR='\[\e]1;\W\a\e]2;\h: ${PWD}\a'
> >             ;;
> >     *)      TITLEBAR=''
> >             ;;
> > esac
> > function prmpt1
> > {
> >     local GREEN="\[\e[1;32m\]"
> >     local   RED="\[\e[1;31m\]"
> >     local  CYAN="\[\e[1;36m\]"
> >     local  BLUE="\[\e[1;34m\]"
> >     local NOCOL="\[\e[0m\]"
> >     if awk 'BEGIN {"who am i" | getline;\
> >     if ((match($6, /(:.+\..+)/)) || ($6 == "")) exit 0; 
> else exit 1 }'
> >         then local HOSTCOL=$BLUE
> >         else local HOSTCOL=$CYAN
> >     fi
> >     if [ `id -u` -eq 0 ]
> >         then    local USERCOL=$RED
> >         else    local USERCOL=$GREEN
> >     fi
> > PS1="${TITLEBAR}\n\
> > ${USERCOL}[\
> > ${HOSTCOL}\h: ${BLUE}"'${PWD}'\
> > "${USERCOL}]\
> > \n${BLUE}\$${NOCOL} "
> > }
> > prmpt1
> 
> I can't reproduce this neither with fvwm-2.2.5 nor fvwm-2.3.32, window
> names are successfully changed from xterm without any cd command.
> 
> Use FvwmIdent and/or xwininfo to determine whether a window 
> title that you
> see is correct.
> 
> Regards,
> Mikhael.
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 May 2001 21:31:48 +0200

> xterm (erroneously) thinks that the title hasn't changed?

Can you compile xterm without this option and see what
happens?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].