Subject: FVWM: Low priority question/suggestion

From: Leigh Clayton <[email-masked]>
Date: Thu, 31 May 2001 00:09:10 +0000

Hi. I want to thank you all for fvwm -- I basically DISPISE the taskbar-oriented
model everyone seems to be going to (so much that when I must run MSWin I still
use NT 3.51 ;-( ). fvwm gives me (almost) exactly what I want in a WM.

 There is, tho, one trick my NT seat will do (with help from eXceed) that I haven't
been able to figure out how to get fvwm to do. It isn't a big deal, but I thought
I'd just ask whether it's possible or you'd consider adding it at some point.

 When I move the mouse off the screen while I have it over a focus-ed window which
isn't totally displayed, the window pans back into view. For example, if I have a
window which has half of itself out of sight past the right border of the screen,
moving the mouse "past" the right edge of the screen inside the window scrolls the
window left until (if I leave it there long enough) the right border of the window 
is on the edge of the screen.

 This is similar to your desktop/page-pan feature, and possibly incompatible with 
it, but I don't care for multiple-page or virtual screen real-estate. I prefer to
manage everything within the screen I can see, so I don't mind a solution that
rules out multiple desptop pages. 

 Thanks again for the great program; if this can't be done no hard feelings.	

 ../Leigh
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 31 May 2001 03:55:27 +0200

> is on the edge of the screen.

This can't be duplicated exactly without pathing the code.  But if
you can live with pressing a key or mouse button to scroll the
window back there is a solution:

  Mouse 1 tsfw CM PipeRead "move_into_view.sh $w $[w.x] $[w.y] $[w.width] $[w.height] $[vp.width] $[vp.height]"
  
Pressing Control-Alt-Button-1 over a window will call the
move_into_view.sh bourne shell script below and give it all
parameters it has to know to move the window into full view.
Unfortunately this click is passed to the application also.

--------------------- snip --------------------
#!/bin/sh

win=$1
x=$2
y=$3
w=$4
h=$5
vw=$6
vh=$7

newx=keep
newy=keep
must_move=

if [ $[x+w > vw] = 1 ]; then
  newx=-0
  must_move=1
elif [ $[x < 0] = 1 ]; then
  newx=0
  must_move=1
fi
if [ $[y+h > vh] = 1 ]; then
  newy=-0
  must_move=1
elif [ $[y < 0] = 1 ]; then
  newy=0
  must_move=1
fi
if [ "$must_move" = "1" ]; then
  echo WindowId $win Move $newx $newy
fi
--------------------- snip --------------------

Hope this helps

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].