Subject: FVWM: Need a tricky mappings

From: Max Ischenko <[email-masked]>
Date: Mon, 21 May 2001 11:37:37 +0300

Is it possible to define mapping for these:
- move the window with Left mouse btn + control
- resize the window with Left mouse btn + alt

-- 
You said I would get 98 windows with this computer. Where are they?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 21 May 2001 11:06:38 +0000

> - resize the window with Left mouse btn + alt

Why do you thing these bindings are tricky? Or the man page is not clear?

  Mouse 1 W C Move
  Mouse 1 W M Resize

You may notice that some apps (xterm, but not rxvt) do not pass
Ctrl-Mouse1, so Alt-Mouse2 would be preferable for Move, try this:

  Mouse 2 WTSF M MoveOrRaiseLower

  AddToFunc MoveOrRaiseLower
  + M Move
  + H Move
  + C RaiseLower
  #+ D Maximize

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 May 2001 13:24:43 +0200

> - resize the window with Left mouse btn + alt

Of course.  Assuming you want to click anywhere in the window to
move/resize it, add these lines to your .fvwm2rc file:

  Mouse 1 A C Move
  Mouse 1 A M Resize

If you want to bind that action only to some parts of the window
you have to replace the 'A' wit a different context (please refer
to the description of the 'Mouse' command in the man page).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].