Subject: RE: FVWM: New problems since 2.3.6

From: "Adye, TJ (Tim) " <[email-masked]>
Date: Mon, 7 May 2001 23:35:52 +0100

Hi Dominik, Mikhael, and Dan,

Thanks for your ideas...

> On 06 May 2001 14:46:31 +0200, Dominik Vogt wrote:
> > 
> > > > > 2) Deiconising or switching to a window (by menu or taskbar) does
an
> > > > > annoying full screen refresh. This doesn't happen when the window
is
> > > > > selected by just clicking on it.
> > > > 
> > > > I don't see this.  Are you using some kind of function to
> > > > deiconify that includes a refresh?
> 
> Maybe the problem is iconifying animation not working well under Exceed?
> You may turn it off in "Settings/Animation".

No, I have FvwmAnimate disabled.

Dan Espen <[email-masked]> wrote:
>
> I've used Exceed quite a bit and I don't see any full screen
> refreshes.
> 
> There are some settings that might affect this.
> [...]

I have mostly the same settings. I tried changing the rest (except for
"Enable System  Pixels", which doesn't seem to be in Exceed 6.2), but that
didn't fix the problem.

> I use FvwmAnimate with the builtin IconBox with no problem.

I tried the IconBox with the same result.

I did find one setting that would "solve" the problem: I turned off
FvwmBacker ("Settings | Background | Disable Background"). In fact all the
configurations that I've tried (eg. initial sample-95 settings, even with
MouseFocus) give this spurious screen refresh behaviour with FvwmBacker, and
the correct behaviour when FvwmBacker isn't running.

Of course one would expect the screen refresh when switching desktops, but
I'm getting it when I just select another window on the same desktop (or
even if I have just one desktop).

So, it looks like the bug is in FvwmBacker. Does anyone else see it, or is
it just me?

Thanks,
Tim.

==============================  cut here  ==============================
Tim Adye, BaBar/DELPHI Groups, Particle Physics Dept.,     _   /|
          Rutherford Appleton Laboratory, UK.              \'o.O'   Oop!
e-mail:   [email-masked] or VXCERN::ADYE (HEPNET/SPAN)  =(___)=  Ack!
WWW:      http://hepwww.rl.ac.uk/Delphi/Adye/homepage.html    U  Thphft!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 07 May 2001 19:10:51 -0400

> > > > > deiconify that includes a refresh?
...
> So, it looks like the bug is in FvwmBacker. Does anyone else see it, or is

So far, its still just you.

I just tried FvwmBacker and I don't notice anything.
I assume FvwmBacker is still configured to use solid colors?

In XConfig, under screens, on the screen 0 tab, when I click
Advanced, I have "Root Mouse Actions to X"
"Track Mouse" is not selected,
and Root Drawing is "background only".

Under Performance:

No  Exact zero width lines
Yes Accelerated Drawing Mode
Yes Draft Mode
No  Maximize X11Perf Results
Yes Batch Requests
Yes Save Unders
Max Backing store: when mapped
Default Backing store: when mapped
Max Backing store: None

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].