Subject: FVWM: is this a bug: what happened?

From: Neil Zanella <[email-masked]>
Date: Wed, 30 May 2001 11:42:56 -0230 (NDT)

Hello,

I was working on my remote PC's hard drive which happened to be running
fvwm2. Suddenly I could not ping my computer. When I walked to the remote
computer the network connection was OK but instead of X I found the
following messages on the text console. I don't know if these will be
any useful but just in case here they are (fvwm version 2.3.32).
By the way what is MFT? Thanks!

find_context: bad context or modifier c
find_context: bad context or modifier l
find_context: bad context or modifier c
find_context: bad context or modifier k
[FVWM][ParseBinding]: <<WARNING>> Illegal context in line F6 FakeClick release3

find_context: bad context or modifier r
find_context: bad context or modifier e
find_context: bad context or modifier e
find_context: bad context or modifier e
[FVWM][ParseBinding]: <<WARNING>> Illegal modifier in line F6 FakeClick release3

[FVWM][ParseBinding]: <<WARNING>> Binding specified AnyModifier and other modifers too. Excess modifiers will be ignored.
/usr/local/libexec/fvwm/2.3.32/FvwmEvent: error in loading shared libraries: librplay.so: cannot open shared object file: No such file or directory
Warning: Cannot allocate colormap entry for "#C0C0C0"
Warning:
    Cannot allocate colormap entry for default background

waiting for X server to shut down xterm:  fatal IO error 32 (Broken pipe) or KillClient on X server
":0.0"

[nzanella@tulip nzanella]$ Trying to open MFT
Trying to open MFT
010528 02:55:44  mysqld ended

Trying to open MFT
Trying to open MFT
Trying to open MFT
Trying to open MFT
Trying to open MFT
Trying to open MFT
Trying to open MFT

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 30 May 2001 10:55:46 -0400

Neil Zanella <[email-masked]> writes:
> [FVWM][ParseBinding]: <<WARNING>> Binding specified AnyModifier and other mod
> ifers too. Excess modifiers will be ignored.

These come from using the obsolete spelled out context modifiers,
like "click" instead of "C".  Current betas allow them again, but you
would do well to remove them.

> /usr/local/libexec/fvwm/2.3.32/FvwmEvent: error in loading shared libraries: 
> librplay.so: cannot open shared object file: No such file or directory

You need to get the -R option into configure since you have librplay.so
installed in a non-standard place.  Check the INSTALL.fvwm file for
instructions.

>     Cannot allocate colormap entry for default background

Looks like Netscape trying to allocate every color under the sun with
a limited colormap.  Ignore it.

> waiting for X server to shut down xterm:  fatal IO error 32 (Broken pipe) or 

Your X server wanted to die and it was waiting for xterm to go away?

> 010528 02:55:44  mysqld ended

These don't appear to be from fvwm.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 30 May 2001 15:22:39 +0000

> would do well to remove them.

No, this only means there is an incorrect line in the rc file:

  Key F6 FakeClick release3

instead of the correct:

  Key F6 A SC FakeClick release3

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 30 May 2001 23:31:12 +0200

> installed in a non-standard place.  Check the INSTALL.fvwm file for

Probably rplay is not istalled on the remote machine at all.  At
work I had to compile fvwm without rplay support because I have
fvwm installed in my home directory which is shared over the
network.  So, when I come to a machine without rplay installed I
can not even start fvwm because of the missing shared library.
Of course I could install rplay into my home directory too, but I
don't need it anyway.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].