Subject: RE: FVWM: New problems since 2.3.6

From: "Adye, TJ (Tim) " <[email-masked]>
Date: Tue, 8 May 2001 00:34:48 +0100

Hi Dan,

Thanks again for your help in trying to track down this problem.

> > So, it looks like the bug is in FvwmBacker. Does anyone 
> > else see it, or is it just me?
> 
> So far, its still just you.

Bum :-(      - for me, anyway :-)

> I just tried FvwmBacker and I don't notice anything.
> I assume FvwmBacker is still configured to use solid colors?

Yup. I use:-

*FvwmBackerCommand (Desk 0, Page * *) -solid \#3F5469
*FvwmBackerCommand (Desk 1, Page * *) -solid purple4
*FvwmBackerCommand (Desk 2, Page * *) -solid DarkOliveGreen4
*FvwmBackerCommand (Desk 3, Page * *) -solid brown4

but got the same with the sample-95 settings.

> In XConfig, under screens, on the screen 0 tab, when I click
> Advanced, I have "Root Mouse Actions to X"
> "Track Mouse" is not selected,
> and Root Drawing is "background only".
> 
> Under Performance:
> 
> No  Exact zero width lines
> Yes Accelerated Drawing Mode
> Yes Draft Mode
> No  Maximize X11Perf Results
> Yes Batch Requests
> Yes Save Unders
> Max Backing store: when mapped
> Default Backing store: when mapped
> Max Backing store: None

I had all of these apart from the last four (and "Accelerated Drawing Mode",
which isn't in my version; I assume you mean "Min Backing store" for this
last one). I tried changing those to no avail.

I wonder whether this isn't an X-server issue, since I don't get the problem
in 2.3.6 (with the same X-server)?

Tim.

==============================  cut here  ==============================
Tim Adye, BaBar/DELPHI Groups, Particle Physics Dept.,     _   /|
          Rutherford Appleton Laboratory, UK.              \'o.O'   Oop!
e-mail:   [email-masked] or VXCERN::ADYE (HEPNET/SPAN)  =(___)=  Ack!
WWW:      http://hepwww.rl.ac.uk/Delphi/Adye/homepage.html    U  Thphft!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 07 May 2001 19:56:28 -0400

> in 2.3.6 (with the same X-server)?

My Exceed version is 6.2.0.16 (Help, about).

I'm using W98SE.

Can you give more detail about what the annoying screen refresh looks
like?  What parts of the screen are redrawn.

In modules/FvwmBacker/FvwmBacker.c around line 365, change it to
look like this:

void ProcessMessage(unsigned long type, unsigned long *body)
{
  char *tline;

  switch (type)
  {
  case M_CONFIG_INFO:
    tline = (char*)&(body[3]);
    fprintf(stderr"FvwmBacker: config\n");
    ExecuteMatchingCommands(ParseConfigLine(tline));
    break;

  case M_NEW_DESK:
    current_desk = body[0];
    fprintf(stderr"FvwmBacker: new desk\n");
    ExecuteMatchingCommands(-1);
    break;

  case M_NEW_PAGE:
    current_desk = body[2];
    current_x = body[0]/MyDisplayWidth;
    current_y = body[1]/MyDisplayHeight;
    fprintf(stderr"FvwmBacker: new page\n");
    ExecuteMatchingCommands(-1);
    break;

  }
}

If you don't already know how to look at fvwm's stderr in real time,
start fvwm like this:

fvwm2 2>/tmp/fvwm.out

Then start:

tail -f /tmp/fvwm.out

then iconify a window to see if FvwmBacker is getting commands
during iconification.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].