Subject: FVWM: Removing the default builtin menu (2.3.32)

From: Cameron Kerr <[email-masked]>
Date: Wed, 09 May 2001 22:47:57 +1200

Hello, I just downloaded, comp'd, and installed fvwm 2.3.32, so
I could use my scroll wheel on FvwmButtons.

However, I've now got this annoying problem of a default builtin
menu when I scroll on the root window. (I'm using my old config
file).

I've tried removing that pesky thing with

Mouse 0 R A -
Mouse 1 R A -
Mouse 2 R A -
Mouse 3 R A -
Mouse 4 R A -
Mouse 5 R A -
DestroyFunc FuncFvwmRaiseLowerX

which is similar to what the man page for fvwm2 suggests,
but no such luck. How can this be done?

-- 
Cameron Kerr -- cameron.kerr @ paradise.net.nz
Praise Slackware, our baud and saviour!
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 May 2001 13:35:09 +0200

> but no such luck. How can this be done?

Try

  Mouse 0 R N -

The default binding is

  Mouse 0 R N Menu MenuFvwmRoot

To remove a binding the context and modifiers have to match the
original binding command.  What part of the man page do you refer
to?  Is there any outdated or incorrect information in the man
page?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Kerr <[email-masked]>
Date: Wed, 09 May 2001 23:52:08 +1200

Dominik Vogt wrote:

[snip]

>   Mouse 0 R N Menu MenuFvwmRoot

Thanks, that did the trick.

> to?  Is there any outdated or incorrect information in the man

In section "BUILT IN KEY AND MOUSE BINDINGS"

\begin{quote}
       You  can override or remove these bindings.  To remove the
       window list binding, use this:

            Key Tab A M -
\end{quote}