Subject: FVWM: Toggling a titlebar button

From: Norman Walsh <[email-masked]>
Date: 11 May 2001 08:50:28 -0400

Hmm. I'm confused. I want button 4 of my titlebar to display
'maximize.xpm' on a normal window and 'restore.xpm' on a maximized
window. What I get is 'maximize.xpm' on all windows.  I must be doing
something stupid, but I don't see what.

Here are the relevant lines from my .fvwm2rc file:

ButtonStyle 1 Pixmap /home/ndw/Graphics/pixmaps/menu.xpm
ButtonStyle 2 Pixmap /home/ndw/Graphics/pixmaps/close.xpm

# Why doesn't this work?
ButtonStyle 4 Pixmap /home/ndw/Graphics/pixmaps/maximize.xpm
ButtonStyle 4 ToggledActiveUp Pixmap /home/ndw/Graphics/pixmaps/restore.xpm
ButtonStyle 4 ToggledActiveDown Pixmap /home/ndw/Graphics/pixmaps/restore.xpm
ButtonStyle 4 ToggledInactive Pixmap /home/ndw/Graphics/pixmaps/maximize.xpm
ButtonStyle 4 - MwmDecorMax

ButtonStyle 6 Pixmap /home/ndw/Graphics/pixmaps/iconify.xpm

AddButtonStyle All -- Flat

Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	2    	A     	Close
Mouse 0	4    	A     	Maximize-Func
Mouse 0	6    	A     	Iconify

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | Anything more than the truth would be
http://nwalsh.com/            | too much.--Robert Frost
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 May 2001 15:50:47 +0200

> Mouse 0	4    	A     	Maximize-Func

This works perfectly for me.  What version of fvwm do you have?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Norman Walsh <[email-masked]>
Date: 11 May 2001 09:58:25 -0400

/ Dominik Vogt <[email-masked]> was heard to say:
| This works perfectly for me.  What version of fvwm do you have?

I'm running 2.3.32 at the moment.

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | A man who is 'of sound mind' is one who
http://nwalsh.com/            | keeps the inner madman under lock and
                              | key.--Val\'ery
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 May 2001 18:46:15 +0000

> something stupid, but I don't see what.

For this to work MwmDecorMax button hint is not enough, you should have:

  Style "*" MwmButtons

With Style "*" FvwmButtons, only maximize.xpm is used.

Regards,
Mikhael.

---

From: Norman Walsh <[email-masked]>
Date: 11 May 2001 14:52:14 -0400

/ Mikhael Goikhman <[email-masked]> was heard to say:
[...]
| For this to work MwmDecorMax button hint is not enough, you should have:
| 
|   Style "*" MwmButtons
| 
| With Style "*" FvwmButtons, only maximize.xpm is used.

Thank you. That did it!

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <[email-masked]> | The fact of having been born is bad
http://nwalsh.com/            | augury for immortality.--Santayana
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].