Subject: FVWM: simple (?) questions

From: Leonardo Machado da Rosa <[email-masked]>
Date: Mon, 14 May 2001 20:51:25 -0300 (EST)

Hi there

First, i'd like to say that FVWM is the best window manager (to me), no
other are so configurable... and FAST!!!

Well, i have two questions to ask:

1 - fvwm will have support to 'declare internal variables' - i.e., like in
a shell script, i would say "set color1 white" in the beginning of fvwm2rc
and use $color1 in the following commands.. or declare  "set shell
rxvt" to use "exec $shell..." (without fvwmcpp or fvwmm4) ??

2 - i'm writting a program using tcl/tk, and i'd like to access, form it,
functions of fvwm - like 'click in a button and open a fvwm's menu, or
change the screen'... - it's possible ???
(you know, everybody wants a personal 'panel cde-like'... i'm writting it
on tk...)

   Thanks,
        Leonardo Rosa

_______________________________
``_`````_`````_`````_`````_````
`(o-```(o-```(o-```(o-```(o-```
`//\```//\```//\```//\```//\```
`V_/_``V_/_``V_/_``V_/_``V_/_``
"""""""""""""""""""""""""""""""
 Nao Seja Pirata.  Seja Livre!
 GNU/LINUX - S L A C K W A R E

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 14 May 2001 21:16:30 -0400

> rxvt" to use "exec $shell..." (without fvwmcpp or fvwmm4) ??

These answers are based on the latest beta releases.

You can set variables like this:

SetEnv xx dan

You can then use variables like this:

Echo $[xx]

The square brackets are required.

>From the .fvwm2rc, start the Fvwm command server like this:

Module FvwmCommandS

Then from the command line or a script, you can do:

fork> FvwmCommand 'SetEnv xx dan'
fork> FvwmCommand 'Echo $[xx]'

which put this on stderr:

 [FVWM][Echo]:  dan

> (you know, everybody wants a personal 'panel cde-like'... i'm writting it

Personally, I like the window manager to be invisible, I don't even
run the pager, but as you pointed out, Fvwm is highly configurable
so we all get what we like.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].