Subject: FVWM: Xine fails with DestroyNotify

From: Felix Engel <[email-masked]>
Date: Thu, 3 May 2001 21:48:04 +0200

Hello,

to start off with some praise: xine is brilliant software and it works great 
for me - so is fvwm2 ;)

However - these two don't work together. Whenever I start xine, it exits 
as soon as it begins playing a Movie. With any other wm (I've tried a lot
of them, including old versions of fvwm2) it works just fine. And that only
happens when playing back via XFree4's XV-extension.

My machine is a P-III 450, 256M RAM, Matrox G200
XFree4.0.1, fvwm-2.3.3{0,2}, xine-0.4.{01,2} (I've tested both).
I'm running GNOME on a Mandrake-7.2 Distribution.

I've had a look into the source, however I don't know about X-Programming, so 
I couldn't even track the problem down to either fvwm or xine, so I posted 
this on both lists.
I have added the xine output, and if that helps I have the output produced
by strace online at 
http://gargamel.weh.rwth-aachen.de/xine/DestroyNotify.strace

Thanks for any help,

Felix

-- 
Why is it called a funny bone when it hurts so much?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 03 May 2001 16:12:35 -0400

> http://gargamel.weh.rwth-aachen.de/xine/DestroyNotify.strace

More than likely its a xine issue, but I couldn't access that URL.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Shawn Anderson <[email-masked]>
Date: Sun, 6 May 2001 18:21:53 -0600

> http://gargamel.weh.rwth-aachen.de/xine/DestroyNotify.strace

xine used to work properly with fvwm-2.3.25, Something broke it with 
fvwm >= 2.3.26.

HTH,
sa

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 May 2001 14:06:56 +0200

> xine used to work properly with fvwm-2.3.25, Something broke it with 

Hell, this is *buggy*.  I recommend to report this to the xine
developers.  It doesn't make much sense to adapt the window
manager to cope with applications of this level of quality.  Just
try to drag the setup window across the video window and you know
what I mean.

BTW, it does not crash on my system.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].