Subject: Markus Grunwald: Re: FVWM: Quick hint please...

From: Dan Espen <[email-masked]>
Date: Wed, 04 Apr 2001 08:29:39 -0400

Off the mailing list, Markus responded with these 2 mails:

From: Markus Grunwald <[email-masked]>
To: Dan Espen <[email-masked]>
Subject: Re: FVWM: Quick hint please...
Date: Wed, 4 Apr 2001 13:44:02 +0200

Hi !

> > > > After login, Numlock is off and I can't move any Window on the
> > > > screen. Menu on Mouseclick on the Background works fine.
> > > >
> > > > If press Numlock, I can move Windows, but cant access the
> > > > Mouse-Menu...
> > >
> >
> > Mouse	1	R	N	Menu	workpopup	Nop
> > Mouse	1	T	N	Function "MoveOrRaise"
> >
> > Not much Difference ...
>
> They both work for me with numlock on or off.
>
> You can also look at the IgnoreModifiers command which is new
> in the 2.3.x series.

I tried the IgnoreModifiers command, and Menus now work fine everywhere. But 
moving windows still wont.

BUT : Everything that is not working is defined by Functions (see 
"MoveOrRaise" above (and below):

AddToFunc MoveOrRaise
 +	"Click"	Raise 
 +	"Motion"	Raise 
 +	"Motion"	Move 
 +	"DoubleClick"	Lower 

# end function MoveOrRaise

Has the Syntax changed somehow ?

-- 
Markus Grunwald

From: Markus Grunwald <[email-masked]>
To: Dan Espen <[email-masked]>
Subject: Re: FVWM: Quick hint please...
Date: Wed, 4 Apr 2001 13:52:43 +0200

Hi !

It works now.  I overread the lines 
BUILT IN KEY AND MOUSE BINDINGS
       The following commands are built-in to fvwm:

            Key Help R A Popup MenuFvwmRoot
            Key F1 R A Popup MenuFvwmRoot
            Key Tab A M WindowList Root c c NoDeskSort
            Key Escape A MC EscapeFunc
            Mouse 1 TS A FuncFvwmRaiseLowerX Move
            Mouse 1 F  A FuncFvwmRaiseLowerX Resize
            AddToFunc FuncFvwmRaiseLowerX I Raise

in the manpage (rtfm) ;)

Erased/changes my calls to the functions and now it works. Thanks for all 
your Help :)

-- 
Markus Grunwald
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Apr 2001 08:48:50 -0500

> Has the Syntax changed somehow ?

You should get the message on your standard error: [FVWM][AddToFunction]:
<<ERROR>> Got 'Click' instead of a valid function specifier

The man page suggests to use M, H, C and D letters for specifiers.
I am not sure whether we should support the old syntax ("Click", "Motion").
In 2.2 versions even word "Close" would pass as "Click", now it does not.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 4 Apr 2001 17:08:52 +0200

> In 2.2 versions even word "Close" would pass as "Click", now it does not.

Well, using more than a single letter was never officially
supported, but many config files had it in the past.  I can't
remember when or why this was changed, but it probably happened by
accident.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].