Subject: FVWM: fvwm2 does not manage Rational RoseRT windows

From: Klaus Zeitler <[email-masked]>
Date: 20 Apr 2001 17:12:49 +0200

I'm running fvwm2 2.2.4 on HP-UX B.10.20.
We're currently evaluating Rational RoseRT as a development tool and I've
been playing with this tool for 2 weeks now. I can't remember when I was
so frustrated by a tool. Most people here use CDE, but I use fvwm2 and
sloppyfocus or should I say I have used it. Can't get fvwm2 to deal with
the RoseRT window(s).
I'm experiencing similar problems to what Neil Bird reported last October.
   Subject: Windows-alike override-redirect issue A
   From: Neil Bird <[email-masked]>
i.e. 
 - RoseRT window always stays on top
 - icon box is ignored
 - icon stays on top for a while and than all of a sudden is lowered (haven't
   figured out why) and I can't get it back to top
 - no usual frame, title etc.

in FAQ and in the message archive I found a note that setting either
  export MWWM=allwm
or
  export MWWM=MWM
should do the trick. But nothing changes at all.

So I'm trying to figure out the differences between his setup and mine.
I work under HP-UX and have an older fvwm version and there's one more
thing that may cause trouble: I have to start fvwm2 from a CDE session.

Appreciate any help and pointers.

Thanx Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
If you can't win, make the fight memorable.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 20 Apr 2001 11:28:34 -0400

> Appreciate any help and pointers.

Have you verified that MWWM really did get exported.  CDE doesn't
normally run your .profile.

Create an xterm/dtterm window from the Fvwm menus.  Inside the window
see what

echo $MWWM

displays.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Klaus Zeitler <[email-masked]>
Date: 23 Apr 2001 11:02:11 +0200

>>>>> Thus quoth Dan Espen <[email-masked]>:
    Dan>
    Dan> Have you verified that MWWM really did get exported.  CDE doesn't
    Dan> normally run your .profile.
    Dan> 
    Dan> Create an xterm/dtterm window from the Fvwm menus.  Inside the window
    Dan> see what
    Dan> 
    Dan> echo $MWWM
Yes I made sure that MWWM is set, tried both suggested values (allwm and MWM).
When I start an xterm as you suggested, MWWM is set.
To make sure that MWWM is set, I did set it in my .profile and also
in my sessionsetc. I've also set DTSOURCEPROFILE=true to source my
.profile.
I also stopped fvwm2 and started it anew from an xterm and than that damn
RoseRT. Made no difference.

Is it possible that is has something to do with me using version 2.2.4 of
fvwm2? Should I try to locally install a newer version?

Klaus

---

From: Dan Espen <[email-masked]>
Date: Mon, 23 Apr 2001 07:27:52 -0400

Klaus Zeitler <[email-masked]> writes:
>     Dan> Create an xterm/dtterm window from the Fvwm menus.  Inside the windo
>     Dan> see what
>     Dan> 
>     Dan> echo $MWWM
> Yes I made sure that MWWM is set, tried both suggested values (allwm and MWM)

Well, you might want to try one of our recent releases with:

BugOpts ModalityIsEvil

I just checked the MainWin knowledge base again and exporting
MWWM is still supposed to work.

Maybe someone did a local mod at your site and they are unsetting
that environment variable in a startup wrapper for the application?

Why don't you find out if RationalRose support or MainWin support
is as responsive as Fvwm support, and check with them?

---

From: Klaus Zeitler <[email-masked]>
Date: 23 Apr 2001 15:00:25 +0200

>>>>> Dan Espen writes:
    Dan> 
    Dan> Maybe someone did a local mod at your site and they are unsetting
    Dan> that environment variable in a startup wrapper for the application?
great idea (why didn't I think of that?). I checked and found out that the
RoseRT startup script explicitly sets MWWM to nothing. That wasn't any local
change by the way. It's in the official startup script. So maybe a note should
be added in the FAQ that the RoseRT startup script unsets this variable.
I'm going to report this to Rational and I'll follow up to this mail in case
they'll give me some useful feedback.
    Dan> 
    Dan> Why don't you find out if RationalRose support or MainWin support
    Dan> is as responsive as Fvwm support, and check with them?
well they certainly can't beat the support here :-). Can't be any quicker or
better.

You really made my day. Thanx a lot.

Klaus

---

From: Dan Espen <[email-masked]>
Date: Mon, 23 Apr 2001 09:16:01 -0400

> they'll give me some useful feedback.

Thats strange.  It seems to contradict what it says in their knowledge
base.   The knowledge base doesn't mention modifying their script.
I'll wait to hear from you  before I update  the FAQ.  When you
do  get back, I'd  like to identify the  script by name.  Is it really
RoseRT?  Probably the release would also be helpful.

> You really made my day. Thanx a lot.

Thank you.