Subject: FVWM: FVWM Client decorations

From: "Louis LaFontant" <[email-masked]>
Date: Mon, 23 Apr 2001 11:40:55 -0400

Is there a way to control the client decoration symbols ; the "minimize", "Maximize", and "Close" buttons located on
the upper right hand corner of a window/dialog box.  Alternatively, is there a way to re-display a dialog box until the user displays the correct entry.

What I would like to do within a FVWM Script is to display a dialog box until the user has entered the correct input.
When the user tries to exit the dialog box, using the "x' on upper right hand corner, an invalid entry mesage is displayed and the main menu appears gain. This repeats (loops) until the user select one of two entries.

Thanks in advance....

--Louis

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 23 Apr 2001 12:42:45 -0400

"Louis LaFontant" <[email-masked]> writes:
> the upper right hand corner of a window/dialog box.  Alternatively, is there 
> a way to re-display a dialog box until the user displays the correct entry.
> 
> When the user tries to exit the dialog box, using the "x' on upper right hand
>  corner, an invalid entry mesage is displayed and the main menu appears gain.
>  This repeats (loops) until the user select one of two entries.
> 
> Thanks in advance....

I  think you might be able   to do this with   MwmDecor (check the man
page), if you can get the application to set the appropriate Mwm decor
hints.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 23 Apr 2001 15:40:14 -0500

> When the user tries to exit the dialog box, using the "x' on upper right hand corner, an invalid entry mesage is displayed and the main menu appears gain. This repeats (loops) until the user select…

You may simply wrap your dialog into a while loop, something like:

  while test "`xmessage -buttons 'Yes:2,No:3' 'Correct?' -print`" == ""; do
    echo "Nothing chosen, repeating..."
  done

There is also an option to disable close and iconify buttons:

  Style xmessage NoButton 2, NoButton 6

Regards,
Mikhael.