Subject: Re: FVWM: FVWM Client decorations

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 24 Apr 2001 13:09:43 -0500

On 24 Apr 2001 11:37:41 -0400, Louis LaFontant wrote:
> 
> Thanks, the NoButton directive controlled displaying the min,max, and close buttons. 
> 
> I also need a way to wrap a long line of text to continue on next line in a widget. 

It is hard to answer without knowing which widget set you speak about.

Do you want to do it using a command line and external program (xmessage,
dialog) or using FVWM dialog modules (FvwmForm, FvwmScript, FvwmGtk)?
Or maybe you write a C program to display a dialog?

> Is there a way to capture environment variables?

The same answer here. Take a look at the man page of the tool you want to
use or elaborate in the next reply to the list, not to me personally. :)

> Please advise
> --Louis

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 28 Apr 2001 00:29:46 +0000

> Is there a way to capture environment variables?

In the private message Louis said he is asking about FvwmScript module.
He also asks:

> Is there a way to implement a "wait" ,using an FvwmScript module,
> dialog trigger ed until a specified process has started. What's being
> called for is to display a "wait' dialog which continues to display until
> a specified process has started. Once the process has started, the "wait"
> dialog disappears....

I know the answers on all 3 questions, but they are probably not full.
I prefer to wait for Olivier or someone else to answer more fully.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 28 Apr 2001 09:41:43 +0200

> In the private message Louis said he is asking about FvwmScript module.

About warping long line:
With ItemDraw it is not possible to warp long line. To Display 3 lines
you need to use 3 ItemDraw. However, with List widget you can
display long text (by separating the lines by some |).

To capture an environment variable in a FvwmScript you can do

	Set $cmd={echo $MyEnvVar}
	Set $ScriptVar=(GetOutput $cmd 1 -1)

and your env variable will be in $ScriptVar

> > a specified process has started. Once the process has started, the "wait"

DestroyFunc FuncMyStartApp
AddToFunc   FuncMyStartApp
+ I FvwmScript FvwmScript-MyWaitScript $1
+ I Wait "name of FvwmScript-MyWaitScript"
+ I Exec exec $0
+ I Wait "$1"
+ All (name of FvwmScript-MyWaitScript) Delete

So now to start an app with name app_name and execution cmd
line exec_name you should execute (FVWM sense):

FuncMyStartApp "exec_name" "app_name"

We use some things like that in fvwm-themes. Also, I assume that
you use fvwm-2.3.3x, but the above works probably with 2.2.x.

> I prefer to wait for Olivier or someone else to answer more fully.

I am not sure that my answers are better than if you answer. Also,
I am not sure to really understand the questions.

Hope this help. Olivier.