Subject: FVWM: xosview

From: Tim Hanson <[email-masked]>
Date: Thu, 15 Mar 2001 20:07:03 -0800

How do I get FvwmButtons to Swallow xosview?  I'm trying to get it to
use two frames.  I don't want to use Frame0 because that's where
FvwmPager sits.
-- 
"Why is it that we rejoice at a birth and grieve at a funeral?  It is
because we are not the person involved"
		-- Mark Twain
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andre Bonhote <[email-masked]>
Date: Fri, 16 Mar 2001 08:48:49 +0100

> use two frames.  I don't want to use Frame0 because that's where

hi tim!

this is not really easy to answer, because each fvwmbuttons-config looks
different (size, position, ...). could you send to the list what you
already have as config? it'd be easier to help you.

yours

andré

ps: you can look at my config. i am using xosview as well
    http://www.problemlos.ch/fvwm2rc looks like
    http://www.problemlos.ch/screenshot.jpg
-- 
Real software engineers work from 9 to 5, because that is the way the
job is described in the formal spec.  Working late would feel like
using an undocumented external procedure.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jan Theofel <[email-masked]>
Date: Fri, 16 Mar 2001 10:05:27 +0100

Hello Tim,

> use two frames.  I don't want to use Frame0 because that's where

here's a part of my ~/.fvwm2rc. Hope that helps:

--- snip ---
*FvwmButtonsFont                6x13
*FvwmButtonsFore                Black
*FvwmButtonsBack                grey67
*FvwmButtonsGeometry    +0+0
*FvwmButtonsRows                1
*FvwmButtons (2x1 Frame 0 Swallow(UseOld) "FvwmPager" "Module FvwmPager
0 0")
#*FvwmButtons - - Swallow "FvwmXeyes" Exec xeyes -name "FvwmXeyes"
-geometry +0+0 -bg grey67 &
*FvwmButtons - - Swallow "FvwmXclock" Exec xclock -name "FvwmXclock"
-geometry +0+0 -padding 1 -bg grey67 &
*FvwmButtons (2x1 Frame 0 Swallow "FvwmXosview" 'Exec xosview -geometry
+0+0 -name FvwmXosview -load +battery -net -page +disk -int -xrm
"xosview*captions:Flase xosview*background:grey67" &' )
*FvwmButtons Fvwm2 window3d.xpm Function barthiswmpopupfunc
*FvwmButtons Tools box_full_3d.xpm Function bartoolspopupfunc
*FvwmButtons Shells Shell.xpm Function barshellspopupfunc
*FvwmButtons (7x1 Frame 0 Swallow "goodstuffterm" "Exec xterm -geometry
+0+0 -name goodstuffterm -title goodstuffterm -sb -bg grey67 &" )
--- snap ---

It includes (form left to right): pager, clock, xosview, menues, xterm

Jan

-- 
   ETES - Espenhain & Theofel EDV-Systeme GbR
     Libanonstrasse 58 A * D-70184 Stuttgart
   Phone +49 711 4895550 * Fax +49 711 4809761
    EMail: [email-masked] --- URL: www.etes.de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Hanson <[email-masked]>
Date: Fri, 16 Mar 2001 17:52:39 -0800

>     http://www.problemlos.ch/screenshot.jpg

Using what both of you gave me I managed to cobble something together
that works:

http://tjhanson.org/.fvwm2rc

http://tjhanson.org/screenshot.jpg

Thanks!

-- 
'Tis the dream of each programmer,
Before his life is done,
To write three lines of APL,
And make the damn things run.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].