Subject: FVWM: No XPM support

From: Hyper Faze <[email-masked]>
Date: Fri, 2 Mar 2001 11:09:07 -0800 (PST)

Hello all,

I'm installing fvwm 2.2.4 on my ultra 10 box running
solaris 8.  After I run the configure script this is
what I get:

Configuration:

  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no

I have the XPM libraries installed properly in
/usr/local.  XPM version 3.4.  This is is how I'm
running the configure script:

./configure --prefix=/home/frosbyte/usr --without-cxx

I've even tried:
./configure --prefix=/home/frosbyte/usr
--with-xpm-library=/usr/local/lib
--with-xpm-include=/usr/local/include --without-cxx

I've also tried pointing config to /usr/local for my
xpm libs.  But I still get no support for xpm.

Here are some lines from configure output:

checking for X11/xpm.h... yes
checking for Xpm 3.4f or better... no

Any ideas on how I can get XPM support to say "yes"?

Thanks for all your help guys.  BTW this list has been
a life saver for me!  

-ariel

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 02 Mar 2001 14:36:16 -0500

> Any ideas on how I can get XPM support to say "yes"?

Try adding:

--x-libraries=/usr/openwin/lib:/usr/local/lib

I think its trying to run an xpm program and needs /usr/local/lib
in the load path.  I think the above will end up adding
-R/usr/openwin/lib:/usr/local/lib
to the compile command line.  If that doesn't do it, try
the technique described in INSTALL.fvwm.

> Thanks for all your help guys.  BTW this list has been

On behalf of all of us, thanks.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Hyper Faze <[email-masked]>
Date: Fri, 2 Mar 2001 14:01:40 -0800 (PST)

You're awesome man!!!  This is what I wanted to see...

Configuration:

  FVWM Version:             2.2.4

  Build extra modules?      no
  Have XPM support?         yes

Here's how I ran configure for any solaris users out
there:
./configure --prefix=/home/frosbyte/usr
--x-libraries=/usr/openwin/lib:/usr/local/lib
--withou-cxx

I'm running make now... Thanks again Dan.

-ariel

--- Dan Espen <[email-masked]> wrote:
> --without-cxx

---

From: Hyper Faze <[email-masked]>
Date: Fri, 2 Mar 2001 15:54:19 -0800 (PST)

It worked.  I got my buttons up and evertything looks
nice and pretty.  Thanks.

-ariel