Subject: Re: FVWM: logout verify box producing funny results

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Mar 2001 00:49:13 +0100

On Mon, Feb 26, 2001 at 12:06:49PM -0800, Thomas Adam wrote:
> Hello Again,
> 
> I have tried in vein to fix this, but have had no
> luck!! I logout from fvwm2 by using the command 
> 
> fvwmrestart logout verify

I can't find this in the configuration you sent.  Do you mean

  FvwmForm LogoutVerify

?

> and a window appears with buttons asking whether I
> want to logout, restart fvwm2, or cancel.
> 
> Usually, it appears in grey, which is nice. However,
> sometimes the whole thing appears in white. The
> pattern to this is weird, as I cannot find one. At
> best, it seems to be random.

I tried out your config and don't see any problem with it.  I have
ripped out the LogoutVerify form and tried this dozens of times
here, but it alway has the correct colours.

Could you try that with the latest beta release, please?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 19 Mar 2001 03:00:00 -0800 (PST)

Hi,

Dominik, I am sorry. In my haste to send this e-mail,
my syntax was incorrect! I did infact mean "FvwmForm
LogoutVerify" and NOT "fvwmrestart logout verify"
which is what I stated originally, so I am sorry for
that!!

I am still receiving problems with the colour of the
box, but not as frequently as I did before. I did read
somewhere about either fvwm2 or X mucking up the
colour palette or something, and if that happens it
has to be reset?????? Whether that is true or not I
don't know.

I have downloaded the sources of your beta release of
fvwm and shall be installing that shortly.

Thanks once again for your kind help,
Kind Regards,

Thomas Adam

--- Dominik Vogt <[email-masked]> wrote: > On
Mon, Feb 26, 2001 at 12:06:49PM -0800, Thomas
> Adam wrote:

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 19 Mar 2001 06:51:08 -0500

> has to be reset?????? Whether that is true or not I

Please post the output of the "xdpyinfo" command.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Tue, 20 Mar 2001 00:52:43 -0800 (PST)

Dear List,

On Dan Espen's request, I have posted the output that
the program "xdpyinfo" produced (see the text file
"xdpyinfo_output.txt" attached).

HTH :-)

Thomas Adam

--- Dan Espen <[email-masked]> wrote: > Thomas

=====
Thomas Adam

name of display:    :0.0
version number:    11.0
vendor string:    Linux Mandrake (XFree86 3.3.6, X-TT 1.3, patches)
vendor release number:    3360
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
keycode range:    minimum 8, maximum 134
focus:  window 0x200000e, revert to Parent
number of extensions:    20
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    Font-Cache
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SHAPE
    SYNC
    XC-APPGROUP
    XC-MISC
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    800x600 pixels (271x203 millimeters)
  resolution:    75x75 dots per inch
  depths (2):    1, 8
  root window id:    0x2a
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 1
  options:    backing-store YES, save-unders YES
  largest cursor:    64x64
  current input event mask:    0x58003d
    KeyPressMask             ButtonPressMask          ButtonReleaseMask
    EnterWindowMask          LeaveWindowMask          SubstructureNotifyMask
    SubstructureRedirectMask PropertyChangeMask
  number of visuals:    6
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x23
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x24
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x25
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x26
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    6 bits
  visual:
    visual id:    0x27
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    6 bits

---

From: Dan Espen <[email-masked]>
Date: Tue, 20 Mar 2001 06:27:58 -0500

> "xdpyinfo_output.txt" attached).

The output from xdpyinfo shows that you have 8 bit color.
That means you can only display 256 colors at a time.
Most likely, the reason you are having problems with the Quit-Verify
form is that all the colors are used up.

It looks to me like your hardware supports truecolor, so you should
see what you can do to convince XFree86 to make the default visual
truecolor (24 bit) instead of 8 bit.

If you can't do that, fvwm can help by limiting its color use
(see colorlimit), and there are a few other hints we can give you.
Get back to us if you really need to run in 8 bit mode.