Subject: Re: FVWM: Mozilla & Fvwm 2.3.28

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Mar 2001 17:10:46 +0100

On Thu, Mar 01, 2001 at 01:22:13PM +1100, Shao Zhang wrote:
> Hi,
> 
> Dominik Vogt [[email-masked]] wrote:
> > It's your lucky day :-)  I've just written the new styles
> > KeepWindowGroupsOnDesk / ScatterWindowGroups which solve your
> > problem.  If you upgrade to current CVS code, the next snapshot or
> > wait for 2.3.29, mozilla will work as you expext by default
> > (unless you use the KeepWindowGroupsOnDesk style).
> 
> Thanks heaps for this. Really appreciated your help espeacially that this is not
> the fvwm's fault.
> 
> I have tried the latest snapshort 20010228. The man pages have the new options
> that you mentioned. I tried with this:
> Style "Mozilla*" MiniIcon mini-nscape.xpm, ScatterWindowsGroups
> 
> But it still behaves the wrong way.
> 
> Step1: start mozilla on desk 0
> Step2: on desk 0, press Ctrl-N to start another mozilla window
> Step3: the seond mozilla window started on desk 0, use mouse to move to desk 1
> Step4: on desk 1, press Ctrl-N to start another mozilla window. (It is still
> going to be started on desk 0).

Gee, if you don't use the ScatterWindowsGroups style it works as
described.  Seems I accidentally reversed the option's behaviour.
You don't need that option anyway since ignoring window groups is
the default.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Shao Zhang <[email-masked]>
Date: Mon, 12 Mar 2001 12:30:10 +1100

Hi Dominik and lists,

First, thanks for implementing this feature. Really appreciated.

But there is one minor problem. By default, the ScatterWindowGroups option works
perfectly for mozilla. But it seems it stops working after I restart fvwm2.

Sometimes, I make some minor changes to my fvwmrc and then just restart fvwm
from the menu. And after that, if I start mozilla, it will place the new window
all over the place.

Thanks.

Shao.

-- 
Shao Zhang                          Tel:  (02) 9209 4838
Software Engineer                   Fax:  (02) 9209 4992
Redfern Broadband Networks (RBN)    Mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Mar 2001 13:09:58 +0100

> from the menu. And after that, if I start mozilla, it will place the new window

Are you *sure* the correct fvwm executable is restarted?  I guess
the restarted fvwm does not have this option.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Shao Zhang <[email-masked]>
Date: Tue, 13 Mar 2001 18:21:30 +1100

Hi,

Sorry. This is my fault again. My menu entry "quit" binds to Restart fvwm2, but I was using a
different fvwm2 binary which is not in the PATH.

Shao.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 13 Mar 2001 07:05:06 -0600

> different fvwm2 binary which is not in the PATH.

This is one of four reasons (see the man page) not to use "Restart fvwm2".
Please use Restart with no arguments to restart the same executable.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 14 Mar 2001 05:28:22 -0600

On 14 Mar 2001 02:15:01 +0100, Dominik Vogt wrote:
> 
> On Tue, Mar 13, 2001 at 07:05:06AM -0600, Mikhael Goikhman wrote:
> > 
> Gee, you never miss a chance to make that point, right? ;-)

Yes, my purpose is not to have users with "Restart fvwm2" in their files.
It is not only about a more correct form, this will also make it easier to
complete the renaming of fvwm2 to fvwm after 2.4.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Mar 2001 02:15:01 +0100

Bye

Dominik ^_^  ^_^