Subject: FVWM: fvwm-2.3.30 not able to compile on SUNOS

From: Thomas Bark <[email-masked]>
Date: Fri, 30 Mar 2001 13:08:58 +0200

Hello,
compiling fvwm2 om SunOS with gcc( version 2.7.2)
gives following errors:
############
Making all in FvwmCpp
cd ../.. \
  && CONFIG_FILES=modules/FvwmCpp/Makefile CONFIG_HEADERS= /bin/sh
./config.status
creating modules/FvwmCpp/Makefile
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../..  -I/usr/openwin/include  
-DFVWM_MODULEDIR=\"/home/ls21fnk/fvwm2/libexec/fvwm/2.3.30\"
-DFVWM_DATADIR=\"/home/ls21fnk/fvwm2/share/fvwm\"                       
-DFVWM_CPP='"/usr/ccs/lib/cpp"' -g -O2 -c FvwmCpp.c
In file included from FvwmCpp.c:38:
/tools/gnu/lib/gcc-lib/sparc-sun-solaris2.5/2.7.2pl6/include/sys/param.h:187:
warning: `NBBY' redefined
/usr/include/sys/select.h:45: warning: this is the location of the
previous definition
In file included from /usr/include/sys/stream.h:26,
                 from /usr/include/netinet/in.h:38,
                 from /usr/include/netdb.h:96,
                 from FvwmCpp.c:41:
/usr/include/sys/model.h:32: #error "No DATAMODEL_NATIVE specified"
*** Error code 1
make: Fatal error: Command failed for target `FvwmCpp.o'
###############

content of model.h:

#if	defined(_LP64)
#define	DATAMODEL_NATIVE	DATAMODEL_LP64
#elif	defined(_ILP32)
#define	DATAMODEL_NATIVE	DATAMODEL_ILP32
#else
#error	"No DATAMODEL_NATIVE specified"
#endif	/* _LP64 || _ILP32 */
#############

Does anybody knows, where this _LP64 or _ILP32 should be defined?
configure runs successfully, AFAIK.
The same error hapens with fvwm-2.2.5.

regards
Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 30 Mar 2001 08:53:09 -0500

> compiling fvwm2 om SunOS with gcc( version 2.7.2)

On my Solaris 8 system, I see a definition in
/usr/include/sys/isa_defs.h

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].