Subject: FVWM: Window decoration question

From: Jan Theofel <[email-masked]>
Date: Wed, 07 Mar 2001 10:47:38 +0100

Hello,

how can I start a program without any windows border?

I need this for a fullscreen-presentation program.

Thanks,
Jan

-- 
   ETES - Espenhain & Theofel EDV-Systeme GbR
     Libanonstrasse 58 A * D-70184 Stuttgart
   Phone +49 711 4895550 * Fax +49 711 4809761
    EMail: [email-masked] --- URL: www.etes.de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frank Derichsweiler <[email-masked]>
Date: Wed, 7 Mar 2001 09:53:05 +0100

> I need this for a fullscreen-presentation program.

What about

Style   "presentationprogram"       NoTitle

in your .fvwm2rc

HTH
Frank

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Mar 2001 06:23:36 -0500

> I need this for a fullscreen-presentation program.

Style fullscreen-presentation NoTitle, HandleWidth 0, BorderWidth 0

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jan Theofel <[email-masked]>
Date: Wed, 07 Mar 2001 16:46:51 +0100

> Style fullscreen-presentation NoTitle, HandleWidth 0, BorderWidth 0

Well, that didn't work 'ou-of-the-box'. :-)

What must I put for "fullscreen-presentation"?

I use the acrobat reader with the option ... -name "acroread":

--- snip ---
    -name <application name>
        Specifies the name under which resources for the application
        should be found.
--- snap ---

So I tried in my ~/.fvwm2rc the following line:

Style   "acroread"      NoTitle, HandleWidth 0, BorderWidth 0

But that didn't work.

Any more hints?

Thanks,
Jan

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Mar 2001 09:12:34 -0500

> Style   "acroread"      NoTitle, HandleWidth 0, BorderWidth 0

Yes, use FvwmIdentify to get the class, name or resource of the window.
Anyone of them will work.

In my test, it didn't look like -name did any good.

Try using "AcroRead".

---

From: Alex Wallis <[email-masked]>
Date: Thu, 08 Mar 2001 01:14:34 +1030

> In my test, it didn't look like -name did any good.
What about adding....

Style "acroread" Maximize, NoTitle, HandleWidth 0, BorderWidth 0
                 ^^^^^^^^
Or is that assumed here?

Alex

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Mar 2001 09:43:41 -0500

> Style "acroread" Maximize, NoTitle, HandleWidth 0, BorderWidth 0

Well, no one asked, but using -geometry works too.