Subject: FVWM: focus managing query

From: Ray Fung <[email-masked]>
Date: Tue, 13 Mar 2001 11:13:58 +0000 (GMT)

hi folks

i am trying to figure out whether the following
'focus-style' was possible in fvwm2 (i've been using
the 2.2.4 stable release); i would like that i can
have a keybinding, say meta-tab, to be able to switch
to the prev window that had focus but if meta is held
down and tab is pressed again, we get the prev-prev
window that had focus.

eg:

windows in order which gained focus most recently
(from lhs, and window 'a' currently has focus)
    [a b c d]

meta-tab would give me focus on windwo 'b' and the
windows-focus list would be:
    [b a c d]

however if i did meta-tab-tab now, i get focus on
window 'c' and the list being now
    [c b a d]

i wondered if this is possible?  i ask because a lot
of other window managers (enlightenement/kde) allow
this sort of behaviour and wondered if this was on an
enhancements/todo list.

many thanks
ray

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Mar 2001 14:32:46 +0100

> this sort of behaviour and wondered if this was on an

Try this configuration lines:

  AddToFunc AltTabFunc
  + I Raise
  + I Focus
  Key Tab A M Prev Function AltTabFunc

You may want to limit this to the current page or desk:

  Key Tab A M Prev (currentdesk) Function AltTabFunc

or

  Key Tab A M Prev (currentpage) Function AltTabFunc

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 15 Mar 2001 12:46:27 +0100

On Thu, Mar 15, 2001 at 11:31:43AM +0000, Ray Fung wrote:
> Dominik
> 
> thanks again for you 2nd reply.  I tried your
> suggestion, but the resulting functionality was not
> what i had wanted:
> 
> consider the windows on the current desktop
>   [a b c]
> 
> where window 'a' currently has focus.  using the 
> 
> >   AddToFunc AltTabFunc
> >   + I Raise
> >   + I Focus
> > 
> hitting alt-tab the 1st time gives me window 'b'
> focus.  hitting alt-tab again, gives me window 'c'
> with focus.
> 
> so it would appear that the current focused window is
> used a pivot.  this is not quite the behaviour i was
> trying to achieve.
> 
> Using something like kde/enlightenment, hitting
> alt-tab gives you a choice of which windows i can
> select from and whilst holding down alt and pressing
> tab moves along the list of available windows but
> without giving them focus.

The WindowList command in the current beta releases does exactly
this.  You can tell it to sort windows by the order in which they
had focus.

Please send replies always to the mailing list, never directly to
me so that others get a chance to reply too.

Bye

Dominik ^_^  ^_^