Subject: FVWM: Startup and Shutdown questions

From: Paul Powell <[email-masked]>
Date: Thu, 29 Mar 2001 09:40:49 -0800 (PST)

I am writing a custom init program which runs under a
bootable CD.  From withing my init program I start X
Windows by starting the X Server directly.

pidX = fork();
if (pidX == 0)
{
   execl("/usr/X11R6/bin/X", "X", NULL, env);
   exit(0);
}

Is there a way to automatically start FVWM once X is
initialized?  I don't use xinit so I can't use the
.Xsession files and such.  Is there another way?

Also, is there a good way to shut X and FVWM down
besides just killing the processes?  I've tried
killing the processes but something is hanging onto
the CDROM drive and I can't eject.  Linux reports the
device busy.

Thanks for your help,
Paul

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/?.refer=text
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "STEFFL, ERIK *Internet* (SBCSI)" <[email-masked]>
Date: Thu, 29 Mar 2001 12:02:22 -0600

> -----Original Message-----
> From: Paul Powell [mailto:[email-masked]]
> 

  from where you fork, after you verify that X runs ok simply fork/exec the
fvwm the same way you forked/execed X, you might want to use -display
option.

> besides just killing the processes?  I've tried

  I think sending TERM signal is a good way (usually 15) (which is killing
in a sense but not as harsh as 9 (KILL))

> the CDROM drive and I can't eject.  Linux reports the

  use lsof to find out what it is (grep /dev/cdrom or something as the
output of lsof is huge)

	erik