Subject: FVWM: Help: X11/xlib.h

From: [email-masked]
Date: Fri, 30 Mar 2001 20:25:54 -0500

Help:
I try to compile fvwm undeer cygwin and get this error message
I put this in fvwm.tmpl, still can not make it

#define FvwmCompilerFlags -g -Wall -I/usr/X11R6/include -B /usr/X11R6/lib

=========================================

making all in ./libs...
make[1]: Entering directory `/fvwm-2.0.42/libs'
gcc -g -Wall   -c -o CopyString.o CopyString.c
In file included from CopyString.c:4:
fvwmlib.h:3: X11/Xlib.h: No such file or directory
fvwmlib.h:4: X11/Xutil.h: No such file or directory
make[1]: *** [CopyString.o] Error 1
make[1]: Leaving directory `/fvwm-2.0.42/libs'
making all in ./fvwm...
make[1]: Entering directory `/fvwm-2.0.42/fvwm'
gcc -g -Wall   -c -o add_window.o add_window.c
In file included from add_window.c:44:
fvwm.h:40: X11/Xlib.h: No such file or directory
fvwm.h:41: X11/Xutil.h: No such file or directory
fvwm.h:42: X11/cursorfont.h: No such file or directory
fvwm.h:57: X11/Intrinsic.h: No such file or directory
add_window.c:45: X11/Xatom.h: No such file or directory

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 30 Mar 2001 22:02:05 -0500

> #define FvwmCompilerFlags -g -Wall -I/usr/X11R6/include -B /usr/X11R6/lib

The 2.0.42 release is way too old.
The current stable version is 2.2.5.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].