Subject: FVWM: specific loading of programs on specific pages of a desk

From: Thomas Adam <[email-masked]>
Date: Thu, 22 Mar 2001 00:46:15 -0800 (PST)

Dear List,

Just as an update, I managed to persuade XFree86 to
run in 24 bit mode, and I have not had any problems
with colours being used up thus far (I owe my thanks
to Dan Espen for his suggestions!).

I now have a completely separate issue that I would
appreciate some advice upon :-) 

Currently, when I load fvwm2, the following apps are
loaded:

xconsole (started iconically but using the style tag
"StickyOnTop")
xcpustate (started using a specific geometry, and also
a sticky window)
xclock (started using a specific geometry, and also a
sticky window)
Fvwm Pager module (2x2), still with the default
settings (I have not touched any of the settings
here!)

Each time I flip to a new page, the above windows
appear on it. My question is, is there a way of
specifying the above apps to load only on certain
pages and not on others?? Also, if this is possible,
how would I also unload the Pager Module???

I have thought about how I might do this, but I have
not been sucessful. Either the solution is quite
complex and my brain cannot cope with the complexity,
or the solution is simple, in which case I have
overlooked the obvious :-))!!

I really appreciate your help,
Thanks in Advance,

Thomas Adam
re: [email-masked]

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 22 Mar 2001 13:10:35 +0100

On Thu, Mar 22, 2001 at 12:46:15AM -0800, Thomas Adam wrote:
> pages and not on others?

Yes.  For example:

  Style Netscape* StartsOnPage 0 1, SkipMapping

Makes all new netscape windows appear on page 0 1.  With the
SkipMapping style fvwm will not switch to that page when the
window appears.

> Also, if this is possible, how would I also unload the Pager
> Module?

Either prevent that it is started at all.  Find the command
"FvwmPager ..." or "Module FvwmPager ..." in your config file and
remove it.  Or if you want to remove a running FvwmPager, there
are several possibilities.  You can close the pager like any other
window, e.g. from the window menu (it it has one).  Or you can
start an FvwmConsole window (from some menu) and type

  KillModule FvwmPager*

THe same can be done from any shell with FvwmCommand:

  FvwmCommand "KillModule FvwmPager*"

This requires that the FvwmCommandS module is started in your
config file.  Personally, I have a "kill" button on my button bar,
so whenever I want to get rid of any window I just click there and
then select the window to be killed.  You can find an old version
of my FvwmButtons configuration at the end of the FvwmButtons man
page.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 22 Mar 2001 14:23:06 -0500

> overlooked the obvious :-))!!

I don't think there is any simple way to do this.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].