Subject: FVWM: fvwm problems with xpm

From: Prabhu Valiveti <[email-masked]>
Date: Fri, 23 Mar 2001 14:32:29 -0600

Hi, 
	I am using fvwm 2.2.5 and seem to have successfully installed the
3.4k XPM lib (configure picks it up). I have also pointed ImagePath to the
location of these .xpm files. However, when fvwm2 starts up, I do not see my
specified icons for the buttons and the xterm styles. 

I had a very similar setup in 2.2.2 and my .fvwm2rc used to work (i used
iconpath and pixmappath then) 

Can somebody help me out.
Here are portions of my .fvwm2rc ---

ModulePath /proj/i2common/prabhu/fvwm-2.2.5/libexec/fvwm/2.2.5
#PixmapPath /proj/i2common/prabhu/fvwm-2.2.5/icons
#IconPath  /proj/i2common/prabhu/fvwm-2.2.5/icons
ImagePath /proj/i2common/prabhu/fvwm-2.2.5/icons

# button definitions
############################################################################
#

#ButtonStyle 1 MiniIcon
ButtonStyle 1 Pixmap mini.xterm.xpm
ButtonStyle 3 Pixmap mini.bomb.xpm
ButtonStyle 2 Pixmap mini.resize2.xpm
#ButtonStyle 4 Pixmap mini.winXX-iconify.xpm
ButtonStyle 4 Pixmap jresize.xpm

Style "xterm"       Icon xterm-sol.xpm, Color white/steelblue4
Style "emacs"       Icon xemacs.xpm, Color white/steelblue4

I do not see even the buttons with the right icons. 

Thanks a lot!
 -Prabhu

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 23 Mar 2001 15:55:45 -0500

> ImagePath /proj/i2common/prabhu/fvwm-2.2.5/icons

You need to have actions bound to the buttons, like:

Mouse 0 3 N Close

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].