Subject: FVWM: transparent fvwm-buttons?

From: Andre Bonhote <[email-masked]>
Date: Thu, 15 Feb 2001 12:05:14 +0100

hi there!

i am using windowmaker dock apps and other 'transparent' apps in my FvwmButtons. Now unfortunately those apps don't appear to be transparent, instead they're using the background color i defined for FvwmButtons.

how can i define them to be REALLY transparent? is this possible?

also, i would actually like FvwmPager to be transparent instead of grey. With my actual background image, it doesn't change much, but i am using other images with which it's really not very beautiful.

you'll find a screenshot here [1] to see what i mean.

thank you!

yours

andré

[1]	http://www.problemlos.ch/screenshot.jpg
-- 
Real programmers don't comment their code.  It was hard to write, it
should be hard to understand.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Feb 2001 00:38:22 +0100

On Thu, Feb 15, 2001 at 12:05:14PM +0100, Andre Bonhote wrote:
> hi there!
> 
> i am using windowmaker dock apps and other 'transparent' apps in
> my FvwmButtons. Now unfortunately those apps don't appear to be
> transparent, instead they're using the background color I
> defined for FvwmButtons.
> 

It seems that the original author of the transparency patch in
FvwmButtons forgot to handle shaped application windows.  I have
just committed a patch to resolve the problem.  Transparency will
work properly with the next beta release (2.3.29) , current CVS
or the next snapshot.

> also, i would actually like FvwmPager to be transparent instead
> of grey. With my actual background image, it doesn't change much,
> but i am using other images with which it's really not very
> beautiful.

With the current beta version you can give the Pager a transparent
background by using a transparent colour set (look for colorset in
the man pages of fvwm2, FvwmButtons and the FvwmTheme module. This
does not work well, though.  It's probably better to make a
snapshot of the background at the place where you put the pager
and use it as its background image.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andre Bonhote <[email-masked]>
Date: Mon, 19 Feb 2001 09:47:46 +0100

Hi dominik!

thank you for your quick answer. it's almost working right now.

i say "almost" cos there's still one app not really working. i am using a programm called asmail which is actually a mail notifier. it changes the icon when getting mail.

right now, it works fine with the transparency. when there's mail, the icon changes to an icon which is slightly bigger. when all my mail is read, it changes back to an empty mailbox icon. the problem is, that there's still some kind of shadow of the "newmail"-icon in fvwm-buttons (see screenshot [1]).

i don't know whether this is an fvwm problem or rather an asmail problem. i let you decide.

thank you

andré

ps: it's really not that urgent, but for 3.0 it'd be nice to be fixed ;)

[1] http://www.fvwm.ch/iconproblem.jpg

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 11:17:06 +0100

> right now, it works fine with the transparency. when there's mail, the icon changes to an icon which is slightly bigger. when all my mail is read, it changes back to an empty mailbox icon. the prob…

Hm, I thought I had taken care of changing shapes.  I must have
missed something.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Feb 2001 14:57:07 +0100

> right now, it works fine with the transparency. when there's mail, the icon changes to an icon which is slightly bigger. when all my mail is read, it changes back to an empty mailbox icon. the prob…

Fixed.

Bye

Dominik ^_^  ^_^