Subject: RE: FVWM: why my fvwm task bar stick to the top of the display

From: pzhao <[email-masked]>
Date: Sat, 3 Feb 2001 12:49:16 -0700

Hi,
	It doesn't work for me. Actually, I have tried
the +0-0 or +0-1. all fail.
	and even I delete the *FvwmTaskBarAutoStick option
, the bar still stick to the top. a little confused.
	Thanks

>===== Original Message From Glen Lee Edwards <[email-masked]> =====
>Try:
>
>*FvwmTaskBarGeometry +0-0
>
>Glen
>
>Yesterday, at 22:45, pzhao sent through the Star Gate:
>
>>Hi,
>>
>> My Fvwm task bar keeps staying on the upmost side
>>of my screen. I want it stay at the bottom.
>>
>>following is a part of my .fvwm2rc
>>
>>...
>>
>>Style "FvwmTaskBar" NoTitle,BorderWidth 4,HandleWidth
>>4,Sticky,StaysOnTop,WindowListSkip,CirculateSkip
>>
>>
>>*FvwmTaskBarGeometry +0+994
>>*FvwmTaskBarFore Black
>>*FvwmTaskBarBack #c3c3c3
>>*FvwmTaskBarTipsFore black
>>*FvwmTaskBarTipsBack bisque
>>*FvwmTaskBarFont -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*
>>*FvwmTaskBarSelFont -adobe-helvetica-bold-r-*-*-*-120-*-*-*-*-*-*
>>*FvwmTaskBarAction Click1 Iconify -1,Raise,Focus
>>*FvwmTaskBarAction Click2 Iconify
>>*FvwmTaskBarAction Click3 Module "FvwmIdent" FvwmIdent
>>*FvwmTaskBarUseSkipList
>>*FvwmTaskBarAutoStick
>>*FvwmTaskBarStartName Start
>>*FvwmTaskBarStartMenu StartMenu
>>*FvwmTaskBarStartIcon mini-exp.xpm
>>*FvwmTaskBarShowTips
>>*FvwmTaskBarMailCommand Exec nxterm -T Mail -ls -fn 8x13 -e pine -i
>>
>>....
>>
>>
>>How to deal with it?
>>
>>I  tried to modify *FvwmTaskBarGeometry option, but
>>it is useless.
>>
>>
>>Thanks.
>>
>>--
>>Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
>>To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
>>message to [email-masked].
>>To report problems, send mail to [email-masked].
>>
>
>--
>Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
>To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
>message to [email-masked].
>To report problems, send mail to [email-masked].

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Glen Lee Edwards <[email-masked]>
Date: Thu, 8 Feb 2001 22:59:18 -0600 (CST)

1) Check to see if there is another .FvwmTaskBarGeometry somewhere else in the
file.

2) If you start X from the console, try

startx 2> zzz

This will place any X messages in a file called "zzz".  You can check it for any
error messages that the FvwmTaskBar module might be kicking out.

3) Make sure you're editing the right .fvwm2rc file (I'm out of ideas <grin>).
I've had it happen more than once where changes I was making weren't doing
anything, only to find out that I was editing the wrong file.  If you've
recently switched to one of the newer beta versions from 2.2.4 ~/.fvwm2rc no
longer works. You need to edit ~/.fvwm/.fvwm2rc.

Glen

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 9 Feb 2001 16:44:48 -0600

> longer works. You need to edit ~/.fvwm/.fvwm2rc.

For the sake of correctness, ~/.fvwm2rc does work with betas.

But, of course, if you have two .fvwm2rc files, the one in the ~/.fvwm
directory wins.

Regards,
Mikhael.