Subject: FVWM: xfm problem

From: Thomas Adam <[email-masked]>
Date: Sun, 4 Feb 2001 09:45:09 -0800 (PST)

Dear List,

I have another problem for you to help me with!!! I am
using AnotherLevel (Lestiff WM) supplied from
Linux-Mandrake 7.0 (air). In the file
"/etc/X11/AnotherLevel/fvwm2rc.defstyles.m4" I have
the following items:

------------SNIP-------------
Style "xmailbox"   StartsOnPage 0 0, MinimalDecoration
Style "gxedit"	   StartsOnPage 1 0, SkipMapping,
NoPPosition
Style "dosemu"	   StartsOnPage 1 1, StartIconic,
CirculateSkip, SkipMapping
Style "xdos"	   StartsOnPage 1 1, StartIconic,
CirculateSkip, SkipMapping
------------End SNIP----------

This works fine, for the current DESK. However, I put
the following entry into the file so that xfm would
start on my other DESK at PAGE 1 0, thus:

Style "xfm"   StartsOnDesk 1 0, CirculateSkip,
SkipMapping, NoPPosition

However, each time I load "xfm", my viewpoint will
switch to that DESK and I do not want it to do this.
Even after adding the commands "SkipMapping" and
"NoPPosition" the viewpoint still switches. Can anyone
help me???

Thanks in Advance,

Thomas Adam
re: [email-masked]

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Sun, 04 Feb 2001 16:15:15 -0500

Thomas Adam wrote:
> 
>   ...I put the following entry into the file so that xfm
> would start on my other DESK at PAGE 1 0, thus:
> 

	There are several problems with the command syntax. First, you want to
be using StartsOnPage, not StartsOnDesk. StartsOnDesk only takes one
argument, the desk number; you can't specify a page with it. Second, the
syntax isn't right for StartsOnPage, either, to do what you want.
"StartsOnPage 1 0" would tell FVWM to put the window on page 1,0 of the
current desk. Third, specifying the string "xfm" only catches one of the
xfm windows: the Apps window has a resource name of "xfm", but the file
windows do not. However, they all have a Class name of "Xfm".

	So, what you really want to specify is

Style Xfm* StartsOnPage 1 1 0, SkipMapping, ...

to start it on Page 1,0 of Desk 1 (I assume that's what you mean by your
other desk).

Cheers,
Bob