Subject: FVWM: compile error

From: Ed Sylvis <[email-masked]>
Date: Tue, 20 Feb 2001 21:07:46 -0700

I'm using Slackware 7.1 on a PS/2 95 box and I'm having the following 
problem.

During the compile for fvwm.c I'm getting the following errors -

fvwm.c: In function 'main':
fvwm.c:264: warning: assignment from incompatible pointer type
fvwm.c At top level:
fvwm.c:884: conflicting types for 'Restart'
fvwm.h:364: previous declaration of 'Restart'
fvwm.c:1444: conflicting types for 'SigDone'
fvwm.h:363: previous declaration of SigDone'

It's been ages since I've done any c programming, but I did look at the 
source and tried to determine what was going wrong -- no luck. I made 
sure I had valid copies of fvwm.c and fvwm.h and checked for docs on the 
same problem but all in vain. If anyone could help me determine what's 
going wrong I'd sure appreciate it -- I'm sure it's something simple.

Thanks -

Ed Sylvis ([email-masked])

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 Feb 2001 05:15:57 -0600

> I'm using Slackware 7.1 on a PS/2 95 box and I'm having the following 

You did't specify your FVWM version. I suppose it is 2.2.x.

> fvwm.h:363: previous declaration of SigDone'

Yes, it seems like 2.2.x versions have this problem, 2.3.x don't have.

Try to fix the function declarations in fvwm.h:

  extern void SigDone(int);
  extern void Restart(int nonsense);

replace them with:

  extern RETSIGTYPE SigDone(int nonsense);
  extern RETSIGTYPE Restart(int nonsense);

Regards,
Mikhael.