Subject: Re: FVWM: another ICON problem

From: Abinash Yadav <[email-masked]>
Date: Wed, 7 Feb 2001 09:08:17 -0800 (PST)

Hi Guys,
sorry to bug on this again, but i am not able to get
through it.

I have compiled new version 2.3.28, with Xpm libraries
included :-))
(it complained at icons.c for color_reduced_pixmap not
found, i don't know and just commented the line */

and put the line (in .fvwm2rc)
Style Netscape* Icon
/tmp/icons/nscape.xpm,IconOverride

here is the error i got in fvwm_log file
[FVWM][GetXPMFile]: <<ERROR>> XpmReadFileToXpmImage
failed, pixmap /tmp/icons/nscape.xpm, rc -1
[FVWM][GetXPMFile]: <<ERROR>> XpmReadFileToXpmImage
failed, pixmap /tmp/icons/nscape.xpm, rc -1

any suggestion ?

thanks.
Abinash
--- Dan Espen <[email-masked]> wrote:
> Abinash Yadav <[email-masked]> writes:
> > Hi,
> > however same user when login in cde environment,
> icon
> > colour is perfact(blue and grey), what is turning
> that
> > in to white in case of FVWM ?
> 
> Fvwm is not turning the gray into white.  The icon
> is half blue
> and half TRANSPARENT.  There is a difference between
> white and
> transparent.  You are seeing the background thru the
> transparent
> parts of the icon.
> 
> Apparently, CDE doesn't support shaped icons and its
> providing its
> own background.
> 
> > 2.3.25, is probably not supporting icon
> over-riding as
> > i didn't see any change after doing this in
> .fvwm2rc
> > file.
> > 
> > and for some reason i want to stick to 2.3.25.
> > any other possibilties?
> 
> Huh?
> 
> If you want to override the Netscape icon and use
> fvwm,
> I think you are going to have to use the version of
> fvwm
> that contains that feature.
> 
> > regards
> > Abinash K. Yadav
> > 
> > > The icon you see is built into Netscape.
> > > Half the background is blue, the other half is
> > > transparent.
> > > 
> > 
> > > The latest betas will allow you to override the
> > > Netscape icon,
> > > do:
> > > 
> > > Style Netscape* icon myicon.xpm, IconOverride
> > > 
> > > if your version doesn't support that, try
> 2.3.28.
> > > 
> > > --
> > > Dan Espen
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail:
> [email-masked]
> Piscataway, NJ 08854                     Phone:
> (732) 699-5570
> --
> Visit the official FVWM web page at <URL:
> http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe
> fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to
[email-masked].

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices.
http://auctions.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Abinash Yadav <[email-masked]>
Date: Wed, 7 Feb 2001 09:16:22 -0800 (PST)

Hi,
Thanks problem fixed :-))
before you guys start bricking on me.

thanks to all.
Abinash

[email-masked].

---

From: Abinash Yadav <[email-masked]>
Date: Wed, 7 Feb 2001 12:20:57 -0800 (PST)

Hi,
I was thinking of notifying the user, status of
application(watch cursor or some other mean,like pop
up box) when he invokes it, and application takes time
to come up.

as there are many big applications which takes lots of
time to come-up and meantime user just thinks wheather
application is running or its dead.

is it possible with fvwm, how ?

regards
Abinash K.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 7 Feb 2001 19:45:56 -0600

> is it possible with fvwm, how ?

Yes, starting from 2.3.10 this is possible, for example:

  BusyCursor Wait True

  AddToFunc StartMyApp
  + I Exec exec $0
  + I Wait *

  StartMyApp "xterm -g 80x40"
  StartMyApp "xcalc"

NOTE: If your app was not started, press Ctrl-Alt-Esc to break out Wait.

But... The watch cursor is only shown on the root window, and not inside
existing windows. This can't be fixed without introducing X problems.

If your app comes slowly, you may use "pop-up" window (may work in 2.2.x):

  DestroyFunc StartMyVerySlowApp
  AddToFunc   StartMyVerySlowApp
  + I Exec exec xmessage -name "NotificationWindow" "Starting $0..."
  + I Wait NotificationWindow
  + I Exec exec $0
  + I Wait *
  + I Next (NotificationWindow) Close

Regards,
Mikhael.

---

From: Abinash Yadav <[email-masked]>
Date: Fri, 9 Feb 2001 07:12:44 -0800 (PST)

Thank You,
I could get busy cursor working :-))

but i don't have xmessage on my machine(Solaris 8.0),
i tried to get xmessage from sun.freeware.com, but
couldn't identify the format to extract binaries,
neither was able to compile source file(usually this
does not happen, when i try compiling other source
code).

will try more later,

thank you.

Abinash K.
[email-masked].

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rainer Koehler <[email-masked]>
Date: Fri, 9 Feb 2001 12:00:42 -0800

> couldn't identify the format to extract binaries,

I assume you're talking about "sunfreeware.com".  They tell you on the
first page in a very ugly color to read the Downloading/Installation
instructions before you download any software.

The instructions tell you to use Sun's pkgadd program, which must be
run as root, and won't tell what it is going to do.  I don't like to
mess with my system without knowing what's going on, so I usually get
the source code and compile it myself.  If it's on sunfreeware, it
must be possible to compile it on solaris after all.

Rainer