Subject: FVWM: dockapps

From: Sebastian Bolk <[email-masked]>
Date: Sun, 4 Feb 2001 01:50:54 +0100 (CET)

I'm using fvwm 2.2.4.
How can I use WindowMaker dockapps in FvwmButtons?

greetings
Seb

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 04 Feb 2001 22:38:40 +0100

> How can I use WindowMaker dockapps in FvwmButtons?

As any other applications. Here a simple example:

DestroyModuleConfig FvwmButtons-WMakerApplets*
*FvwmButtons-WMakerAppletsColumns 1
*FvwmButtons-WMakerApplets(Frame 1, Size 64 64, \
	Swallow "wmCalClock" 'Exec exec wmCalClock -24')
*FvwmButtons-WMakerApplets(Frame 1, Size 64 64, \
	Swallow "asmon" 'Exec exec asmon')
*FvwmButtons-WMakerApplets(Frame 1, Size 64 64, \
	Swallow "wmapm" 'Exec exec wmapm')

To start it
FvwmButtons FvwmButtons-WMakerApplets

Some times you have to use an other name than the exec name
in the Swallow option (use FvwmIdent).

Olivier