Subject: FVWM: How do I "Restart fvwm2" after exec another program?

From: Glen Lee Edwards <[email-masked]>
Date: Sat, 10 Feb 2001 21:13:26 -0600 (CST)

I have a script written that modifies some configuration settings for fvwm.
After executing the script I'd like to be able to have fvwm automatically
restart.  I've tried the following, but it isn't working (all on one line):

*Xemacs(1x1+0+0 Frame 4 Title "Use Emacs", Action Exec exec xterm -e
"/home/glenlee/.fvwm/emacs.cgi" Restart fvwm2

Any suggestions?

Glen

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Feb 2001 05:35:19 -0600

> "/home/glenlee/.fvwm/emacs.cgi" Restart fvwm2

You need a function to set more than one command, but even then you should
remember that Exec is asynchronous and you want some synchronization here.
PipeRead is good to synchronize non-interactive commands. Otherwise - Wait.

> Any suggestions?

  *Xemacs(1x1+0+0 Frame 4 Title "Use Emacs", Action Function EditAndRestart)

  AddToFunc EditAndRestart
  + I Exec xterm -e $FVWM_USERDIR/emacs.cgi; \
    xmessage -g +2000+2000 -name ReadyToRestart dummy
  + I Wait ReadyToRestart
  + I Next (ReadyToRestart) Close
  + I Restart

or:

  AddToFunc EditAndRestart
  + I PipeRead `xterm -e $FVWM_USERDIR/emacs.cgi >/dev/null`
  + I Restart

Please always use Restart without parameters to avoid any potential
problems.

Regards,
Mikhael.

---

From: Xucaen <[email-masked]>
Date: Sun, 11 Feb 2001 12:29:47 -0800 (PST)

Hi all.
I run fvwm on debian linux 2.2r2. I have a
question regarding menudefs.hook.

here is a snippet from my menudefs.hook in 
/etc/X11/fvwm/

DestroyMenu "/Debian/Apps/Editors"
AddToMenu "/Debian/Apps/Editors" "Editors" Title
Top
+ "&AbiWord" Exec exec /usr/bin/AbiWord
+ "&Xedit" Exec exec xedit
+ "&jed" Exec exec xterm  -T "jed" -e
/usr/bin/jed
+ "xje&d" Exec exec /usr/X11R6/bin/xjed
+ "&Emacs 20%/usr/share/emacs/20.7/etc/gnu.xpm%"
Exec exec /usr/bin/emacs20

The problem is that _only_ Xedit and Emacs shows
up in the menu.

I am not using any other window manager or
desktop manager.

thanks!

xucaen

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Glen Lee Edwards <>
Date: Sun, 11 Feb 2001 19:50:47 -0600 (CST)

Mikhael,

Thanks.  I used the later "PipeRead..."  Works like a charm.

Glen