Subject: FVWM: Further info on de-iconifying xconsole - - does not work!

From: Thomas Adam <[email-masked]>
Date: Fri, 9 Feb 2001 00:46:45 -0800 (PST)

Dear All,

As soon as I got home from school, I booted into fvwm2
and made the following changes (kindly supplied by
Dominik Vogt), thus:

*FvwmEvent icon_name Function DeiconifyXconsole
*FvwmEventPassID
AddToFunc DeiconifyXconsole
+ "I" WindowId $0 (xconsole\*) iconify off

Then, I put the above into the correct .m4 files (as
suggested by Thomas A Gardiner). I then rebooted
fvwm2, and piped a message to /dev/console. The
asterisk did appear by the icon (and consequently my
piped message), but alas the xconsole window did not
popup so that I could view what was being displayed!!
I then realised that I should of changed icon_name to
the icon name of "xconsole" and I did. However, even
after this reboot...xconsole would not deiconify, so
that I could see what I had piped to it.

So, I then remembered that fvwm2 produces a error file
in my home directory (/root/.FVWM2-errors) I loaded
this and found that the following error had been
logged to it:

FvwmEvent Version 2.2.2 should only be executed by
fvwm!

Does this bear any relation to the problem??

Secondly (and I forgot to mention this yesterday) if I
do get this FvwmEvent working, is there a way of then
telling xconsole to deiconify to a specific area on my
screen??

Your help is again, much appreciated!!
Kind Regards,

Thomas Adam

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 Feb 2001 12:09:00 +0100

> Does this bear any relation to the problem??

Yes.  You have to start the FvwmEvent module from your fvwm config
file.  Usually you add this to your InitFunction and
RestartFunction (or the StartFunction with 2.3.x):

  AddToFunc InitFunction
  + I Module FvwmEvent
  AddToFunc RestartFunction
  + I Module FvwmEvent

Or if you want to do it manually for the moment, run FvwmConsole
(e.g. from a menu) and type

  Module FvwmEvent

there.

> telling xconsole to deiconify to a specific area on my

This is a bug in 2.2.x.  When a window starts iconic, it is not
placed by the placement algorithm.  When it is deiconified it is
put whereever the application wanted it, which is usually +0+0.
With the latest beta (2.3.28) fvwm will place the window even when
started iconic, so you can use the normal methods to place it, for
example by putting a geometry resource in you .Xdefaults file:

  xconsole*geometry: +123+456

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Fri, 9 Feb 2001 04:50:07 -0800 (PST)

Hi,

I have added + "I" Module FvwmEvent to the files as
suggested, but still it does not work!! 

Any further ideas???

--- Dominik Vogt <[email-masked]> wrote: >
On Fri, Feb 09, 2001 at 12:46:45AM -0800, Thomas
> Adam wrote:

=====
Thomas Adam

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Fri, 9 Feb 2001 07:52:21 -0500 (EST)

Did you remember to add a line to the function "InitFunction" or
"SetupFunction" to start up FvwmEvent?

T.

---

From: Dan Espen <[email-masked]>
Date: Fri, 09 Feb 2001 08:02:45 -0500

> suggested, but still it does not work!!

First  report  what  you have in    your config file,  it should  look
something like:

AddToFunc "InitFunction"
+ "I" Module FvwmEvent

Then report any error message you are getting.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 9 Feb 2001 16:33:13 -0600

> FvwmEvent Version 2.2.2

The sample above only works with 2.3.x versions, not with AnotherLevel.

I would try the following for 2.2.x versions, but I didn't test this:

DestroyModuleConfig FvwmEvent*
*FvwmEvent icon_name Function DeiconifyXconsole

DestroyFunc DeiconifyXconsole
AddToFunc   DeiconifyXconsole
+ I Next (xconsole\*) Iconify -1

Regards,
Mikhael.