Subject: FVWM: automation of deiconifying xconsole

From: Thomas Adam <[email-masked]>
Date: Thu, 8 Feb 2001 00:55:53 -0800 (PST)

Dear List,

I have now, thanks to the help of Thomas A Gardiner,
Bob Woodside, et al, been able to customise FVWM2 very
efficiently. Thanks guys!! There is however one final
question that maybe you could help me with.

As you probably know, because I log in via Xdm,
xconsole is displayed. I have set in the file
fvwm.defstyles.m4 a style thus:

Style xconsole   StickyOnTop, StartIconic, WinListSkip

My question is this: While I am using fvwm2 I often
get information appearing in that window. Is it
possible to get fvwm2 to de-iconify that window (thus
restoring it) when information is piped into this
window???

You help is once again much appreciated.
Kind Regards,

Thomas Adam

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 08 Feb 2001 06:19:03 -0500

> restoring it) when information is piped into this

The best you can do with xconsole is start it with "-notify"
on the command line.  The icon name changes with this option.

There is a program called "contool" that does what you want
and a lot more.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Feb 2001 12:33:27 +0100

> restoring it) when information is piped into this

If xconsole is started with the "-notify" option, an asterisk is
appended to the icon title whenever new data arrives.  Then you
can set up FvwmEvent to notice this change in the icon title and
deiconify the window via an fvwm function, perhaps something like

  *FvwmEvent icon_name Function DeiconifyXconsole
  *FvwmEventPassID
  AddToFunc DeiconifyXconsole
  + I WindowId $0 (xconsole\*) iconify off

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 8 Feb 2001 03:57:37 -0800 (PST)

Hi,

As I am a complete newbie to all of this, could you
provide detailed instructions as to which file I put
the functions that you mentioned. I use the
AnotherLevel m4 preprocessor if that helps!!

Much obliged for your help,
Regards,

Thomas Adam
--- Dominik Vogt <[email-masked]> wrote: > On
Thu, Feb 08, 2001 at 12:55:53AM -0800, Thomas
> Adam wrote:
> fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-2

=====
Thomas Adam

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Thu, 8 Feb 2001 08:38:50 -0500 (EST)

Well, first you have to make sure that you start FvwmEvent, as the
AnotherLevel package is soo old that it still has configuration stuff for
FvwmAudio...  In fvwm2rc.init.m4 you will find the following function:

# SetupFunction gets run at Init and Restart
AddToFunc "SetupFunction"
+ "I" Exec xsetroot -solid BG_COLOR
ifdef(`WANT_SOUND_EVENTS',`+ "I" Module FvwmAudio
')dnl
ifdef(`USE_AUTO_RAISE',`+ "I" Module FvwmAuto AUTO_RAISE_SPEED
')dnl
+ "I" Module FvwmEvent

Add the bottom line to it like I've done to start FvwmEvent.

(By the way if you are wondering what SetupFunction does, look in
fvwm2rc.m4 and you will find that it simply added to the InitFunction and
RestartFunction used by Fvwm2.)

To make a long story short, the configuration stuff for modules, those
lines which start with *FvwmEvent go in fvwm2rc.modules.m4 and the
functions go in fvwm2rc.functions.m4 according to the AnotherLevel layout.

In the end, however, it really doesn't matter where you put it...

HTH,

Tom

>--- Dominik Vogt <[email-masked]> wrote:
>>

---

From: Dan Espen <[email-masked]>
Date: Thu, 08 Feb 2001 09:11:48 -0500

> In the end, however, it really doesn't matter where you put it...

I agree, it doesn't really matter...  I'll preach the contool religion
one more time.

Unless this is a specialized configuration you are setting up, I think
you are going to find that having your console pop open every time
something gets written to it is extremely annoying.

There  are so  many programs  that feel they   have  to announce every
little thing.

contool will  deiconify, when I  first installed  contool, thats what it
did.  contool lets you enter  patterns that match  the text written to
the console and choose any number of actions based on the match.

You can ignore the message, beep, change the icon, deiconify, make any
sound or  perform any other  action, including  launching programs and
sending mail.

Brethren, end of sermon.  Have a nice day.

:)

---

From: Thomas Adam <[email-masked]>
Date: Thu, 8 Feb 2001 06:25:16 -0800 (PST)

Hi,

Ok, here is what I plan to do!!

Having taken the advice of Dominik and Thomas A
Gardiner, et al, I shall first of all try and setup
xconsole. I have also gone and downloaded contool, and
I shall try that one out, and then tomorrow morning, I
shall let the list know which one I prefer :~))

Thanks to everyone who has advised me upon this...

Thomas Adam
--- Dan Espen <[email-masked]> wrote: > "Thomas
A. Gardiner" <[email-masked]>
> writes:
> Piscataway, NJ 08854                     Phone:
> (732) 699-557

=====
Thomas Adam