Subject: FVWM: small focus problem

From: wing tung Leung <[email-masked]>
Date: Sat, 17 Feb 2001 23:13:11 +0100

(using the current CVS version)

This is an extract from my config:
==
GlobalOpts SmartPlacementIsReallySmart
Style "*"               RandomPlacement, CleverPlacement, SloppyFocus

Style * NoPPosition

Style "UtilStyle"   RandomPlacement,NoTitle,NoHandles,BorderWidth 0,Sticky,\
    StaysOnTop, WindowListSkip, ClickToFocus
Style "xbiff"   UseStyle UtilStyle
==

Normally, xbiff is started automatically, and I don't see anything wrong. It
just happened that I killed xbiff manually, and restarted it by typing 'xbiff'
in an xterm.

The xbiff windows shows up, but it takes the focus away from my xterm. It
doesn't happen when I start another application within the same xterm.

I suppose this behaviour is caused the special Style flags for xbiff. It
doesn't bother me much, but I just though you ought to know.

Regards,

Tung

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Feb 2001 00:40:52 +0100

> doesn't bother me much, but I just though you ought to know.

That's the normal behaviour of applications that use ClickToFocus.
You can disable this by adding

  Style UtilStyle GrabFocusOff

(see man page for details about the GrabFocus... options).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].