Subject: FVWM: Bug in Placing Windows

From: Kristian <[email-masked]>
Date: Fri, 02 Feb 2001 16:00:40 +0100

Hi!

I have found a bug introduced in fvwm-2.3.27 concerning the KDE 1.1.2
File Manager (started with "kfm -w"). If I right-click on a file and
then on "Properties" the Popup-Window will stay lowered behind anything
else.

Kristian

   ~~ ~~ ~~ liebevolle elektronische Briefaspekte ~~ ~  ~
 ~
 ~ Korseby Online (http://www.korseby.net)
~  tom musics     (http://www.tomlab.de)
 ~
    ~ ~ ~~ ~ ~ reach me ([email-masked]) ~~ ~ ~  ~   ~

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Feb 2001 21:15:36 +0100

> then on "Properties" the Popup-Window will stay lowered behind anything

Yikes!  That's a bug of kwm.  The popup window sets the
transientfor hint to indicate it's transient nature, but the hint
points to itself instead of its 'parent' window.  Thus fvwm
chooses layer 0 to put the window on.  I have coded a workaround
in fvwm.  Could you please report this to the kfm developers?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].