Subject: FVWM: Default window placementent

From: "Ripalda-Marin, Miguel-Angel" <[email-masked]>
Date: Wed, 7 Feb 2001 11:15:11 +0100

Hi everybody,

First of all I would like to say that we have just started to work with
fvwm2 and we are very happy about that. It has a great balance between
performance, flexibility and GUI possibilities. I have been browsing the
FAQs, .fvwm2rc sample files, mailing list archives and have some doubts that
I have not been able to solve.

We are trying to setup our fvwm2 window manager in the following way: we
want that  every new window that is created by default has its upper-left
corner at (0,0) position... I would also like to know if we could set the
default initial size of each new window created.

The .fvwm2rc file at user's $HOME where I try to set up that default style
looks like follows:

# default Styles:
# Added by Miguel Angel Ripalda on December 19th, 2000
Style "*"           BorderWidth 0, HandleWidth 0, notitle, nohandles
Style "*"           Icon unknown1.xpm, Color lightgrey/dimgrey
Style "*"           MWMFunctions, MWMDecor, HintOverride
Style "*"           DecorateTransient, NoPPosition
Style "*"           IconBox 0 -10 -280 -1
Style "*"           FocusFollowsMouse
Style "*"           RandomPlacement, SmartPlacement
Style "xdaliclock"  StaysOnTop
Style "sxpm"        StaysOnTop

Thanks in advance and kind regards

Miguel Ángel Ripalda Marín 
Siemens Elasa S.A. 
T, I + D Sistemas 
Pol. Malpica, D-98 50016 Zaragoza, España
*	(34) 976 760 300 ext. 405
*	(34) 976 760 346
*	[email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Feb 2001 14:08:35 -0500

> Thanks in advance and kind regards

I don't think you would be happy with every window at 0,0.

Have you considered using X Resources, for example:

XTerm*vt100*geometry:	80x34+0+0

or from the command line or your .fvwm2rc:

Exec xterm -geometry 80x34+0+0

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].