Subject: FVWM: open xterm, place mouse pointer above ???

From: philipp <[email-masked]>
Date: Sun, 14 Jan 2001 21:02:43 +0100

i would like to open a new xterm and have the mouse pointer placed above
it immediatey. i am currently using a simple exec command triggered from
a menu to open the xterm, with random and smart placement, which is
fine, but i can't figure out how to move the pointer (causing the window
to have focus and be raised)

any help is apreciated.

please cc my email in answers to the list (i am not subscribing)

thanks,
.ps
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Glen Lee Edwards <[email-masked]>
Date: Sun, 14 Jan 2001 14:15:07 -0600 (CST)

Is there a way to bind the Tab key so that in moves through the WindowList as if
you were hitting the up or down arrows?

Thanks,

Glen

---

From: Dan Espen <[email-masked]>
Date: Sun, 14 Jan 2001 20:51:57 -0500

Glen Lee Edwards <[email-masked]> writes:
> Is there a way to bind the Tab key so that in moves through the WindowList as
> if you were hitting the up or down arrows?

The WindowList works as you want in the current beta releases.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 15 Jan 2001 13:14:24 -0600

> to have focus and be raised)

Please see FVWM FAQ, question 3.18, which deals with the "I want this and
this when a new window pops up" problem. The command to warp the pointer
to a window is WarpToWindow, try it with "50 50" or "30p 10p" parameters.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 17 Jan 2001 14:07:49 -0600

On 17 Jan 2001 11:20:40 +0100, philipp (in private message) wrote:
> 
> Thanks Mikhael,
> I read the FAQ, and applied the code for my version (2.2.4), but
> continue to have a bug.
> 
> When I open a window (via a menu I call <code>Exec xterm&</code>) the
> add_window event is triggered. However how do I get the WindowID of the
> newly created window. I tried:
> 
> DestroyModuleConfig FvwmEvent*
> *FvwmEvent add_window SetFocus2NewWindow
> 
> DestroyFunc SetFocus
> AddToFunc   SetFocus2NewWindow
> + I Next ("xterm") Focus
> + I Next ("xterm") WarpToWindow
> 
> Problem: If I have more than one xterm window, fvwm doesnt always warp
> to the newest one.
> 
> Is there a way to get the window ID of the last (=newest?) window in
> windowlist?
> 
> I suspect something like should work:
> 
> AddToFunc   SetFocus2NewWindow
> + I WindowID['currentwindow'] Focus
> + I WindowID['currentwindow'] WarpToWindow

Just like the FAQ says, using FvwmEvent in fvwm-2.2.x does not solve this
problem:

     3) If you have more than one app window, it is not guaranteed
        that the right one will be used.

Solving this problem is only possible in 2.3.x versions, where FvwmEvent
has PassId option, which does exactly what you suggest, by passing the id
of a new window to add_window event function. This id is available as $0.
Sorry, there is no full solution for 2.2.x versions that I can think about.

> Sorry to keep bothering with this rather unimportant stuff. Any help
> still apreciated.

I suppose this is important, for you at least. Feel free to ask the list.

Regards,
Mikhael.