Subject: greg shebert: Re: FVWM: referring to current pointer co-ords

From: Dan Espen <[email-masked]>
Date: Fri, 05 Jan 2001 15:40:08 -0500

Hi, folks. The snow here sure is pretty...oh yeah,

Greg sent this directly to me.
I don't have an answer for this one.

Date: Fri, 05 Jan 2001 13:51:17 -0600
From: greg shebert <[email-masked]>
To: Dan Espen <[email-masked]>
Subject: Re: FVWM: referring to current pointer co-ords

i want to do two things...

the FvwmForm thing works great but i want it to pop the form up right 
under the mouse with the upper left corner being the
current X,Y of the pointer...

i also want to use FvwmEvent to cause newly created windows to pop-up 
with their upper-left corner at the current X,Y of the pointer...

in order to do this i think that i need to be able to tell fvwm that X 
and Y arguments that are used to refer to screen coords should be the 
current X,Y of the mouse

-greg-

Dan Espen wrote:

> greg shebert <[email-masked]> writes:
> 
>> how would i refer to the current pointer X and Y coordinates in the 
>> .fvwm2rc file...
>> 
>> i have searched the FAQ and the examples but can't seem to locate it
>> 
>> sorry if this is a FAQ question and i am just missing it
> 
> 
> You don't need the window manager to give it to you,
> its available to any program.  Try "man XQueryPointer".
> 
> What is it you are trying to do?
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
> Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jan 2001 14:38:03 +0100

> current X,Y of the pointer...

The 'm' (for 'mouse relative') bit of the Move command does the
trick:

  AddToFunc MyFvwmForm
  + I FvwmForm <options>
  + I Wait <form window name>
  + I Next move m+0 m+0

> with their upper-left corner at the current X,Y of the pointer...

Simply call 'move m+0 m+0' from FvwmEvent on the new windows.

> and Y arguments that are used to refer to screen coords should be the 

The 'm' bits in the move command require one of the 2.3.x beta
releases.  This is not in 2.2.4.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jan 2001 14:38:03 +0100

AddToFunc MyFvwmForm
  + I FvwmForm <options>

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jan 2001 14:38:03 +0100

AddToFunc MyFvwmForm
  + I FvwmForm <options>

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jan 2001 14:38:03 +0100

AddToFunc MyFvwmForm
  + I FvwmForm <options>

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 Jan 2001 14:38:03 +0100

AddToFunc MyFvwmForm
  + I FvwmForm <options>

Bye

Dominik ^_^  ^_^