Subject: FVWM: Icon quetsions

From: "M.Kirillov" <[email-masked]>
Date: Sat, 27 Jan 2001 22:52:25 +0000 (/etc/localtime)

Hello.

I build one of the last version of 2.3.x and have some
questions about weird things which were not in 2.2.x.

1) Default Icon position

In the 2.2.x, icons were by default handles as in twm. In
the first time I iconify a window, it place the icon where
the pointer is - i.e., the "Iconify" button. Now, it is
placed in the "Default IconBox". As I could get from the
manual, the default iconbox cannot be destroyed. So, how can
I achieve the previous behavior?

2) Icons moving.

In the 2.2.x, I used this string to drag icons and windows:

Mouse 0 SFWTI M Move

Now, it doesn't work for Icons. What can I do to move icons
by mouse?

3) MinOverlapPlacement consider Icons

Well, it is like I said. New Window starts aside from icons,
I want it to cover them and avoid only overlaping with the
normal windows. "SnapAttraction 1 Windows" didn't help

And, question not concerning icons.

4) Smart placements places windows in a physical screen
instead of desktop - i.e. it failed is there is no space in
the screen (however it can place them in the desktop)

Thanks for your attention.
Max.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Jan 2001 18:28:43 +0100

> I achieve the previous behavior?

You can't.  Well, at least not untils you fetch the latest
copy from CVS.  I have added an option to the IconBox style.  Now
you can say

  Style * IconBox None

To disable the default icon box.

> Now, it doesn't work for Icons. What can I do to move icons

This should work.  Please post your config file so we can see
what's wrong.

> normal windows. "SnapAttraction 1 Windows" didn't help

Right now you don't have detailed control over the placement
policy other than using one of the predefined options.  In the
future we will probably add much more flexibility in window
placement.  However, you could place your icons on a lower
layer:

  AddToFunc my_iconify
  + I Iconify on
  + I Layer 1

  AddToFunc my_deiconify
  + I Layer default
  + I Iconify off

Then use my_(de)iconify everywhere to (de)iconify your windows.
With the modification I made to the MinOverlapPercentPlacement
style, windows/icons on lower layers will be covered more often
than windows/icons above them.  You will need the current
source code, though.

> the screen (however it can place them in the desktop)

Yes.  SmartPlacement has always worked this way.  New windows are
always placed on a specific page of the desktop.  This is normally
the current page unless other options override that.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Jan 2001 20:15:01 +0100

> placement.  However, you could place your icons on a lower
        ^^^^^^^

This is incorrect, sorry.  Use "Layer -1" instead.

Bye

Dominik ^_^  ^_^

---

From: "M.Kirillov" <[email-masked]>
Date: Sun, 28 Jan 2001 02:22:31 +0000 (/etc/localtime)

Thanks. I'll try the options you said

> This should work.  Please post your config file so we can see

It's after the message.
"Menu" is the output of wmconfig

Max.

----------------------------------------

EdgeScroll 3 3
EdgeThickness 1
EdgeResistance 1 1
DesktopSize 2x2

Style "*" SloppyFocus
Style "*" GrabFocus

Style "*" ForeColor LightGray, BackColor DarkSlateGray

Style "*"           Button 2
Style "*"	    Button 1364
Style "*"	    MinOverlapPercentPlacement
#Style "*"	    IconBox None

ImagePath /usr/share/icons/mini
ButtonStyle 2  Pixmap mini-bomb.xpm
ButtonStyle 4  Pixmap mini-move.xpm
ButtonStyle 6  Pixmap mini-lower.xpm
ButtonStyle 1  Pixmap mini-edit.xpm
ButtonStyle 3  Pixmap mini-raise.xpm

*FvwmPagerGeometry 100x30
*FvwmPagerSmallFont none
*FvwmPagerFont none
#Module FvwmPager 0 2
#Style "FvwmPager" Sticky, StaysOnTop, NoTitle
#Style "FvwmPager" NoTitle

*FvwmTalkGeometry 100x30-1-120
*FvwmTalkFont fixed
#Style "FvwmTalk" SmartPlacement
#Module FvwmTalk

#*FvwmButtonsGeometry +600+175
*FvwmButtonsGeometry -1-1
*FvwmButtonsBoxSize smart
*FvwmButtonsColumns 4
*FvwmButtons(3x1+1+0 Swallow "FvwmPager" "Module FvwmPager 0 2" Size 100 30)
*FvwmButtons(1x1 Swallow "xclock" `Exec exec xclock -padding 0 -update 1` Size 30 30)
#*FvwmButtons(1x1+4+0 Swallow "kikbd" `Exec exec kikbd`)
Style "FvwmButtons" Sticky, StaysOnTop, NoTitle, WindowListSkip
Style "FvwmWinList" Sticky, StaysOnTop, WindowListSkip
Module FvwmButtons

Module FvwmCommandS

AddToMenu WindowMenu	"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	Maximize 78 78
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"Refresh Window" RefreshWindow
Mouse 0 1 A		Popup WindowMenu
AddToFunc Right-Border		"C" Popup WindowMenu
+				"M" Move
Mouse 3 TSFI A			Right-Border

#AddToFunc my_iconify
#+ C Layer -1
#+ C Iconify on
#
#AddToFunc my_deiconify
#+ C Iconify off
#+ C Layer default
#
#AddToFunc my_iconify_now
#+ I Layer -1
#+ I Iconify on
#
#AddToFunc my_deiconify_now
#+ I Iconify off
#+ I Layer default

AddToFunc Resize-or-Raise	    "C" Raise
+				    "C" Focus
+				    "C" WarpToWindow 50 50
+				    "M" Resize

Mouse 0 SFWTI M Move
Mouse 1 SF A Resize-or-Raise

AddToFunc Title-1	    "D" Iconify
+			    "C" Raise
+			    "M" Move
Mouse 1 TI A Title-1

Mouse 0 2 A		    Close
Mouse 0 4 A		    Maximize 78 78
Mouse 0 6 A		    Iconify
Mouse 0 I A		    Iconify off
Mouse 0 3 A		    WindowShade

AddToMenu Quit-menu	"Restart"   restart
+			"Quit"	    quit

Read "Menu"

AddToMenu RootMenu	"xiterm"    Exec exec xiterm
+			"talk"	    FvwmTalk
+			"Red Hat"   popup Red_Hat_Linux
+			""	    Nop
+			"Quit"	    popup Quit-menu
+			"Setup" Exec exec gvim
/home/max/.fvwm2rc
Mouse 3 R A	    Menu RootMenu No

*FvwmWinListAction Click1 Iconify off, WarpToWindow 50 50
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Popup WindowMenu
*FvwmWinListUseSkipList
Style "FvwmWinList" Sticky, StaysOnTop
Mouse 2 R A	    Module FvwmWinList

Mouse 1 R A	    WindowList CurrentDesk NoGeometry

Key F1 A M	    Raise
Key F2 A M	    popup WindowMenu
Key F3 A M	    Lower
Key F4 A M	    Delete
#Key F5 A M	    ????
#Key F6 A M	    ????
Key F7 A M	    Move
Key F8 A M	    Resize
Key F9 A M	    Iconify
Key F10 A M	    Maximize 78 78

Key 1 A CM	    Desk 0 0
Key 2 A CM	    Desk 0 1
Key 3 A CM	    Desk 0 2

Key 1 A SCM	    MoveToDesk 0 0
Key 2 A SCM	    MoveToDesk 0 1
Key 3 A SCM	    MoveToDesk 0 2

Key Right A CM	    Desk 1 0 0 2
Key Left A CM	    Desk -1 0 0 2
Key Right A SCM	    MoveToDesk 1 0 0 2
Key Left A SCM	    MoveToDesk -1 0 0 2

Key Right A M	    CursorMove 3 0
Key Left A M	    CursorMove -3 0
Key Up A M	    CursorMove 0 -3
Key Down A M	    CursorMove 0 3

Key Right A SM	    Move w+5 w Warp
Key Left A SM	    Move w-5 w Warp
Key Up A SM	    Move w w-5 Warp
Key Down A SM	    Move w w+5 Warp

AddToFunc GoTo	"I" Iconify off
+		"I" Raise
+		"I" Focus

AddToFunc Alt_Tab   "I" Prev ("CurrentDesk") FlipFocus
+		    "I" WindowList ("CurrentDesk") Root c c NoDeskSort

Key Tab A M Alt_Tab

Key Escape A C Menu RootMenu
--------------------------------------------

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Jan 2001 16:58:22 +0100

> Mouse 3 TSFI A   Right-Border

Binds Right-Border to button 3 with any modifier.

> Mouse 0 SFWTI M  Move

Binds Move to all buttons with Meta.

> Mouse 1 TI A     Title-1

Binds Title-1 to button 1 with any modifier.  This overrides the
Meta-button 1 binding from the previous line.

> Mouse 0 I A      Iconify off

Binds "Iconify off" to all buttons with any modifier, thus
removing the bindings from above three lines.  You should specify
bindings in the opposite order:

  Mouse 0 I A      Iconify off
  Mouse 1 TI A     Title-1
  Mouse 0 SFWTI M  Move

The responsible code was changed between 2.2.x and 2.3.x to handle
this situation properly.  With 2.3.x, newer binding commands
override older commands so you can change them without restarting.

Bye

Dominik ^_^  ^_^

---

From: "M.Kirillov" <[email-masked]>
Date: Sun, 28 Jan 2001 23:35:02 +0000 (/etc/localtime)

> The order of the binding commands in your config file is

Yes, thank you. I rewrite my config and get the desired
behavior. But, placement trick you suggested seems not to
work (and MinOverlap_Percent_ is also not I wanted). Also,
default icon position could be selected more clever (I
think, it is possible to place the only IconBox by FvwmAuto
- I will try to do this). I rarely use fvwm2 for programs
which require large desktop size, and the gotten behavior is
good enough.

Thanks for your help.

Max.