Subject: FVWM: obtaining arbitrary text from user and referencing it in .fvwm2rc

From: greg shebert <[email-masked]>
Date: Fri, 05 Jan 2001 10:37:18 -0600

hi all...

i have a situation where i would like the window manager to prompt the 
user for some text input and then to use that input in subsequent menus 
specified in the .fvwm2rc

for example, lets say that i  want the user to be able to specify the 
color of the foreground of an xterm...
   the user selects 'xterm' from their mouse menu...
   they are then prompted for the foreground color...
   they then get a submenu that allows them to choose from a number of 
different fonts....
   the xterm pops up with the right color and font

is something like this possible?

i'd like to avoid, if at all possible, popping up an xterm to get the 
text input

thanks for any help,
-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 05 Jan 2001 12:16:48 -0500

> i'd like to avoid, if at all possible, popping up an xterm to get the 

Either FvwmForm or FvwmScript has the ability to get text from
a user and generate fvwm commands.

I think FvwmForm is a little easier to work with.
FvwmScript has more widgets and is more flexible.

Using either one you could redefine the menus, or you might want
to just create the xterm from the form.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].