Subject: FVWM: Newbie Question

From: "Vaughn Eisler" <[email-masked]>
Date: Mon, 29 Jan 2001 08:24:31 -0500

Wondering if someone can help me.

I have a Sun Ultra 10 and just installed X11R6.5 and fvwm 2.3.9.  When
attempting to xinit to start fvwm, I get the following error message:

Fatal server error:
Cannot open /dev/kbd, error 13

xinit:  Error 0 (errno 0):  Server error.

However, my console keyboard exists and is functioning:

$ cd /dev
$ ls -las kbd
   2 lrwxrwxrwx   1 root     root          31 Jan 20 16:49 kbd ->
../devices/pseudo/conskbd@0:kbd

Anyone know how I might be able to work through this error message?  Please
email me back at [email-masked]

Thanks,

Vaughn Eisler

--
Vaughn Eisler
dynamicsoft, Inc.
Sr. Systems Engineer
1900 Campus Commons, Suite 420, Reston, VA 20191
[email-masked]
Phone: (703) 860-9085
Fax: (703) 860-6599

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Jan 2001 08:45:37 -0500

> email me back at [email-masked]

You might like a more current beta than 2.3.9.

Of course that has nothing to do with a keyboard problem.
Errno 13 is a permission problem.

Take a look at the permissions on the file that /dev/kbd points to.
Heres what mine looks like:

pork> ls -al /devices/pseudo/conskbd@0:kbd    
crw-------  1 dane  mk    0,   0 Jun 15  2000 /devices/pseudo/conskbd@0:kbd

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Mon, 29 Jan 2001 08:13:36 -0800

doesn't look like fvwm problem but like X server problem.try to use
some other program instead of fvwm (xterm or whatever else) and see if X
will come up, once you have X running (no window manager) you can run
fvwm

	erik