Subject: Re: FVWM: another ICON problem

From: Abinash Yadav <[email-masked]>
Date: Tue, 30 Jan 2001 13:42:58 -0800 (PST)

Hi,
however same user when login in cde environment, icon
colour is perfact(blue and grey), what is turning that
in to white in case of FVWM ?

2.3.25, is probably not supporting icon over-riding as
i didn't see any change after doing this in .fvwm2rc
file.

and for some reason i want to stick to 2.3.25.

any other possibilties?

regards
Abinash K. Yadav

> The icon you see is built into Netscape.
> Half the background is blue, the other half is
> transparent.
> 

> The latest betas will allow you to override the
> Netscape icon,
> do:
> 
> Style Netscape* icon myicon.xpm, IconOverride
> 
> if your version doesn't support that, try 2.3.28.
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail:
> [email-masked]
> Piscataway, NJ 08854                     Phone:
> (732) 699-5570
> --
> Visit the official FVWM web page at <URL:
> http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe
> fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to
[email-masked].

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 30 Jan 2001 18:16:50 -0500

> in to white in case of FVWM ?

Fvwm is not turning the gray into white.  The icon is half blue
and half TRANSPARENT.  There is a difference between white and
transparent.  You are seeing the background thru the transparent
parts of the icon.

Apparently, CDE doesn't support shaped icons and its providing its
own background.

> and for some reason i want to stick to 2.3.25.

Huh?

If you want to override the Netscape icon and use fvwm,
I think you are going to have to use the version of fvwm
that contains that feature.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Wed, 31 Jan 2001 02:34:29 -0700

> Apparently, CDE doesn't support shaped icons and its providing its

You could try compiling fvwm2 with './configure --disable-shape'. It 
should give you some oldschool icons with no transparency :-).

sa

P.S. IconOverride is very nice, that default netscape icon was
pissing me off.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Jan 2001 10:44:06 +0100

> Apparently, CDE doesn't support shaped icons and its providing its

The shape extension can be disabled with the --disable-shape
option of configure.  You will have to recompile.

> > i didn't see any change after doing this in .fvwm2rc
 
The IconOverride style was introduced in 2.3.2.

> that contains that feature.

Well, if you insist on using a buggy, unstable version you will be
on your own fast, especially when talking about icon styles.  We
spent quite some time to get icon handling straight, and you are
insisting on one of the releases that had the responsible code
screwed up.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].