Subject: Re: FVWM: cannot see icons

From: Dan Espen <[email-masked]>
Date: Tue, 30 Jan 2001 14:46:05 -0500

Nancy Davis <[email-masked]> writes:
> > Nancy Davis <[email-masked]> writes:
> > > Hi FVWM folks,
> > > 
> > > I have recently installed fvwm2 on NetBSD.  I have something
> > > misconfigured, however.  I cannot see any icons within 
> > > programs, 
> > 
> > What does "icons within programs" mean?  Do you mean that you
> > can't see any icons when you minimize a program?
> 
> Well, the icon of the minimized program does not display as anything
> other than a shadow on the desktop...i.e., there is no icon, just
> a space where it should be.

I'm not sure what would cause that.  Sounds like you are displaying
icons, you just aren't displaying any color.

> Also icons that are displayed as part
> of the Xwindow (i.e., netscape "Back", "Home" et cetera) only show
> up as blank boxes.

Fvwm doesn't control the icons within Netscape.  Sounds like a more
general problem.

> > > For example, xbiff is installed and is supposed to show up
> > > on the window manager box, but I have a blank space.  Netscape
> > > fires up, but the buttons do not have any icons on them.
> > 
> > What is a "window manager box"?  Do you mean FvwmIconBox?
> 
> When I fire up FvwmIconBox as a separate process, I only see a 
> blank box.

That would be expected, if you are using desktop icons,
FvwmIconBox would have nothing to show.

> I'm not certain what the process is called upon startup,
> but I have a box that contains FvwmIconMan, a 2x2 desktop, a clock, 
> some type of system monitor and supposedly xbiff.  xbiff is just
> a blank space.

Sounds like you are running FvwmButtons with FvwmIconMan and some other
stuff inside it.  Its not clear whether xbiff is not in the button bar
or whether its just not displaying any color.

> I am wondering if this might be related to the ability to display
> colors from my video card and monitor settings.  Where might I find
> error messages of this type logged?

Its still hard to tell from what you've described.

Do you see any color on the screen at all?

What does the command "xdpyinfo" print?

I'm not familiar with the NETBSD setup.  If you are using "startx",
you might try:

startx 2>&1>/tmp/errors.out

All your error message should end up in /tmp/errors.out

Always cc the fvwm list.

Thanks,
--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nancy Davis <[email-masked]>
Date: Tue, 30 Jan 2001 13:08:30 -0700 (MST)

> Fvwm doesn't control the icons within Netscape.  Sounds like a more

I am beginning to think so too.....

> Do you see any color on the screen at all?

Yes.

> What does the command "xdpyinfo" print?

See below.
 
> startx 2>&1>/tmp/errors.out

I tried that, but there were no errors about being able to 
display or run any particular resolution....

> All your error message should end up in /tmp/errors.out

M'kay.  I was concerned about the filesize ;-)

Thanks much,

Nancy

xdpyinfo

name of display:    :0.0
version number:    11.0
vendor string:    The XFree86 Project, Inc
vendor release number:    3360
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
keycode range:    minimum 8, maximum 134
focus:  window 0x400000e, revert to Parent
number of extensions:    19
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SHAPE
    SYNC
    XC-APPGROUP
    XC-MISC
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1280x1024 pixels (433x347 millimeters)
  resolution:    75x75 dots per inch
  depths (2):    1, 8
  root window id:    0x2a
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 1
  options:    backing-store YES, save-unders YES
  largest cursor:    32x32
  current input event mask:    0x58003d
    KeyPressMask             ButtonPressMask          ButtonReleaseMask        
    EnterWindowMask          LeaveWindowMask          SubstructureNotifyMask   
    SubstructureRedirectMask PropertyChangeMask       
  number of visuals:    6
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x23
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x24
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x25
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x26
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x27
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Tue, 30 Jan 2001 12:20:00 -0800

> Nancy Davis <[email-masked]> writes:
...
> Fvwm doesn't control the icons within Netscape.  Sounds like a more

  I've heard about this problem few times, IIRC it had something to do
with specific depth (16 bpp?), or something like that, you might want to
try to search for solution to this particular problem... or simply try
different bpp...

	erik

---

From: Dan Espen <[email-masked]>
Date: Tue, 30 Jan 2001 15:34:05 -0500

> >  default number of colormap cells:    256

Ok, this part indicates  that you are  running with an 8 bit colormap.
This restricts the number of colors you can display at once to 256.

If you  expect that you  should  have more colors available,  then you
want to look at the way  you have XFree configured.  Try  to get it to
set the color depth to 16, 24, or 32 instead of 8.

If you expect to only have 8  bit color, you have to  try to deal with
your colormap.   The  first rule is to   always start Netscape  with a
private colormap, like this:

netscape -install

there are a lot of other  rules.  I suspect that you  don't want 8 bit
color.

> display or run any particular resolution....

I was wondering if we would see any messages about being unable to
allocate a color.

Like I said, I'm not familiar with NETBSD, but if you can find where
it starts fvwm (.xinitrc?), you can do the same trick with fvwm:

fvwm2 2>&1 >/tmp/fvwm.out

> M'kay.  I was concerned about the filesize ;-)

Yes, well you want to stay on the list, to get expert help from the
others that also read the list, and to have them spot my mistakes.