Subject: FVWM: Another newbie Question

From: "Vaughn Eisler" <[email-masked]>
Date: Mon, 29 Jan 2001 12:46:17 -0500

I wanted to thank everyone for helping me out this morning about starting up
fvwm2 and the permission problems with /dev/kbd.  Permissions were not being
setup correctly upon login to Solaris.

However, I am now running into another issue that you may be able to assist
me with.  I suppose it may be an X problem vs. an fvwm problem, but I
thought I would try here first.

When attempting to start up X via xinit, I am getting the error message:

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already
running

Unfortunately, I am not running another version of X.  I am running Solaris
2.8, which is running its own Desktop Login.  However, I have disabled that
and am logging in via the command line.

Any assistance you can provide is appreciated.

Thanks,

Vaughn Eisler

--
Vaughn Eisler
dynamicsoft, Inc.
Sr. Systems Engineer
1900 Campus Commons, Suite 420, Reston, VA 20191
[email-masked]
Phone: (703) 860-9085
Fax: (703) 860-6599

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Jan 2001 13:02:47 -0500

> Any assistance you can provide is appreciated.

You should tell us what you did and what message was generated.

You may want to check the permissions in /tmp, the Solaris X server
sets up some fifos there for X.

pork> ls -al /tmp/.X*
/tmp/.X11-pipe:
total 16
drwxrwxr-x  2 dane  root   176 Jan 17 11:21 ./
drwxrwxrwt  8 root  sys   2931 Jan 29 12:59 ../
prw-rw-rw-  1 dane  root     0 Jan 17 11:21 X0|

/tmp/.X11-unix:
total 16
drwxrwxr-x  2 dane  root   176 Jan 17 11:21 ./
drwxrwxrwt  8 root  sys   2931 Jan 29 12:59 ../
srwxrwxrwx  1 dane  root     0 Jan 17 11:21 X0=

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Vaughn Eisler" <[email-masked]>
Date: Mon, 29 Jan 2001 13:17:40 -0500

> You should tell us what you did and what message was generated.

I am sorry.  To generate this message, I logged in as a local user and typed
xinit.  I have an .xinitrc file which has one call to create an xterm and
calls fvwm2.

> srwxrwxrwx  1 dane  root     0 Jan 17 11:21 X0=

I checked that and I have no references to X at all.

Vaughn

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Jan 2001 13:55:44 -0500

> xinit.  I have an .xinitrc file which has one call to create an xterm and

One of the 2 commands in your .xinitrc has to hold the session.
(Ie. it can't have an ampersand at the end.)

> I checked that and I have no references to X at all.

Make sure /tmp is writable by you.

Heres how I start X:

  xinit -- -nobanner -ar1 200 -ar2 20 2>&1 | tee /tmp/xinit.out

The "tee" at the end allows me to capture any messages I might miss.

If you are logging in as root, you may be able to truss xinit and
see the problem:

  truss -f xinit -- -nobanner -ar1 200 -ar2 20 2>&1 | tee /tmp/xinit.out