Subject: FVWM: instances of Netscape in fvwm gets killed

From: Abinash Yadav <[email-masked]>
Date: Wed, 17 Jan 2001 08:08:14 -0800 (PST)

Hi,
here is problem description ...

my netscape application with multiple instances of
it(say 2-3 or even more nevigator windows or any other
netscape configuration screen), kills all open
instances of it on hitting X button on top bar,
instead of killing only this window.

when i run netscape from command line in background,
same was happening and error code return was : Exit
255

any suggestions on this.

thanks.
Abinash

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Wed, 17 Jan 2001 09:27:07 -0800 (PST)

> instead of killing only this window.

It sounds as if you may have the X button mapped to Netscape's
"Exit" (Alt-Q) command.  Have you tried changing it to "Close"
(Alt-W) instead?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul D. Smith" <[email-masked]>
Date: 17 Jan 2001 12:26:01 -0500

%% Abinash Yadav <[email-masked]> writes:

  ay> here is problem description ...

  ay> my netscape application with multiple instances of
  ay> it(say 2-3 or even more nevigator windows or any other
  ay> netscape configuration screen), kills all open
  ay> instances of it on hitting X button on top bar,
  ay> instead of killing only this window.

That means that button is bound to the FVWM "Destroy" function.

If you want it to only close that one window, bind the button to the
"Delete" function instead.  See the fvwm2 man page.

I actually set mine up so that a single click on the button does a
Delete, and a double-click does a Destroy:

  # Delete on click
  # Destroy on double-click
  #
  AddToFunc Delete-Func
  +	"M" Delete
  +	"C" Delete
  +	"D" Destroy

  # Title-bar mouse bindings (any modifier):
  #       Button	Context Modifi 	Function
  Mouse 0		1    	A      	Function Delete-Func

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].