Subject: FVWM: Re: my window shade vector button

From: Dominik Vogt <[email-masked]>
Date: Fri, 19 Jan 2001 22:56:04 +0100

On Fri, Jan 19, 2001 at 11:20:32AM -0700, Jeff Walker wrote:
> I designed this vector button.  It got complex because you can't pickup the
> "pencil" while drawing.  I use it to toggle the window shade.
> The second one is the same, but upside-down.  My idea was to write a
> function that would swap the direction of the arrow, depending on the state
> of the window (rolled-up or fully visible).  This worked fine, except for
> one thing, when I changed the face of the button, it changed it for all
> windows, not just the current window, thus new windows would take whatever
> direction was active when it was created (but existing windows stay the
> same, so I thought it worked for a few minutes).  Makes sense.  Anyway, here
> are the buttons.
> 
> # arrow pointing up at a bar across the top
> ButtonStyle 3               15 10x5@1 90x5@1 90x20@0 50x20@0 50x25@0 \
> 		80x55@0 60x55@0 60x90@0 40x90@0 40x55@1 20x55@1 50x25@1
> 50x20@0 \
> 		10x20@0 10x5@1 -- Flat
> AddButtonStyle 3 ActiveDown 15 10x5@0 90x5@0 90x20@1 50x20@1 50x25@1 80x55@1
> \
> 		60x55@1 60x90@1 40x90@1 40x55@0 20x55@0 50x25@0 50x20@1
> 10x20@1 \
> 		10x5@0 -- Flat
> 
> # arrow pointing down at a bar across the bottom
> AddButtonStyle 3               16 10x5@1 90x5@1 90x20@0 40x20@0 40x26@0
> 60x26@1 60x60@0 80x60@0 50x90@0 20x60@1 40x60@1 40x26@1 60x26@1 60x20@0
> 10x20@0 10x5@1 -- Flat
> AddButtonStyle 3 ActiveDown 16 10x5@0 90x5@0 90x20@1 40x20@1 40x26@1 60x26@0
> 60x60@1 80x60@1 50x90@1 20x60@0 40x60@0 40x26@0 60x26@0 60x20@1 10x20@1
> 10x5@0 -- Flat
> 
> I think they are a little unique from what I saw on the website or linked
> pages because, like I said above, there are two objects, and I had to do a
> little "magic" (played with the colors) to make them look like they aren't
> part of the same object.

The button styles are global and apply to all windows.  To get
what you want you need any 2.3.x beta release.  Try this:

ButtonStyle 3 - MWMDecorShade
AddButtonStyle 3 ActiveUp <first normal vector>
AddButtonStyle 3 ActiveUp <second normal vector>
AddButtonStyle 3 ActiveDown <first normal vector>
AddButtonStyle 3 ActiveDown <second normal vector>
AddButtonStyle 3 Inactive <first normal vector>
AddButtonStyle 3 Inactive <second normal vector>
AddButtonStyle 3 ToggledActiveUp <first reverse vector>
AddButtonStyle 3 ToggledActiveUp <second reverse vector>
AddButtonStyle 3 ToggledActiveDown <first reverse vector>
AddButtonStyle 3 ToggledActiveDown <second reverse vector>
AddButtonStyle 3 ToggledInactive <first reverse vector>
AddButtonStyle 3 ToggledInactive <second reverse vector>

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jeff Walker <[email-masked]>
Date: Fri, 19 Jan 2001 15:03:14 -0700

Wow, didn't even think that this was an option-to-be.  I just thought it was
an interesting mistake.
Thanks.
-- 
Jeff Walker                   MatchLogic, Inc.
[email-masked]        7233 Church Ranch Blvd.
Voice 1 (303) 222-2105        Westminster, CO  80021
Fax   1 (303) 222-2001        www.matchlogic.com

> -----Original Message-----
> From: Dominik Vogt [mailto:[email-masked]]
> Sent: Friday, January 19, 2001 2:56 PM
> To: Jeff Walker; fvwm
> Subject: FVWM: Re: my window shade vector button
> 
>