Subject: Re: FVWM: fvwm built-in function

From: Rainer Koehler <[email-masked]>
Date: Tue, 26 Dec 2000 17:36:49 -0800

Dominik Vogt writes:

> On Mon, Dec 25, 2000 at 04:17:46AM +1100, Shao Zhang wrote:
>> 
>> I want to bind Alt-Left(right, up, down) to move the window in the current
>> viewport to the viewport next to it. Eg. Alt-left will move the window to the
>> viewport in the left with exactly the same placements and go to the left
>> viewport as well.
>>
>> [...]

> You are looking for the MoveToPage command.  In 2.2.x, you can
> only give it an absolute page number, so what you want can not
> easily be accomplished.  In 2.3.x you can also use relative page
> offsets:

>   Key Left  A    M    MoveToPage -1p 0p
>   Key Up    A    M    MoveToPage 0p -1p
>   Key Right A    M    MoveToPage 1p 0p
>   Key Down  A    M    MoveToPage 0p 1p

I use the following with 2.2.4.  It makes the window under the mouse
sticky during the move, so you take it with you.  Bad things happen if
the window was already sticky...  Modifier 4 is the Windows-Key on my
keyboard, I use it for most window-manager related bindings.

DestroyFunc StickScroll
AddToFunc StickScroll	"I" Stick
+			"I" Scroll $0 $1
+			"I" Stick

# press arrow + control+win key, and take window with you
Key Left	A	C4	StickScroll -100 +0
Key Right	A	C4	StickScroll +100 +0
Key Up		A	C4	StickScroll +0   -100
Key Down	A	C4	StickScroll +0   +100

Rainer
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Dec 2000 03:41:59 +0100

> keyboard, I use it for most window-manager related bindings.

As an aside note: in 2.3.x, you can tell the stick command to make
a window sticky or not sticky regardless of its previous state:

  stick on
  stick off

This kind of boolean argument works with all commands that toggle
windows between two states (iconify, maximize, windowshade etc.).

> Key Down	A	C4	StickScroll +0   +100

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].