Subject: Re: FVWM: Pop-up windows

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 3 Dec 2000 12:58:56 +0200

On 24 Nov 2000 03:29:47 -0800, Harry Putnam wrote:
> 
> Not sure if this is the province of the window manager or what, but
> would like to `fix' an annoying behavior of long standing.
> 
> Certain applications like `control-panel',`tksysv',`netcfg' or others
> such as cbb [checkbook app], pop up secondary dialog windows for
> different aspects of usage.  With the large virtual desktop these
> secondary windows may appear in unexpected places or even out of
> sight.
> 
> I'd like to make any pop-up windows appear in the near vacinity of the parent
> window but have no idea how to control this.

There are several placement policies FVWM gives you to choose from.
I guess, you have one of these (some words are optional):

  Style * RandomPlacement, SmartPlacement, CleverPlacement
  Style * RandomPlacement, SmartPlacement, CleverPlacementOff

Both, being smart, try first to find a free place for a new window, and
you don't like this behaviour. So, you can try an active placement mode:

  Style * ActivePlacement, DumbPlacement

And, if you don't like to have to place windows yourself, you can use:

  Style * RandomPlacement, DumbPlacement

This will always arrange windows by "stairs", so new windows will appear
not too far from the previous ones.

The 4 examples above affect all windows; you can define individual
placement policies for different windows. Try, for example:

  Style Timetool ActivePlacement, DumbPlacement
  Style Tksysv RandomPlacement, DumbPlacement

I hope, this short introduction to placement policies helps.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Harry Putnam <[email-masked]>
Date: 03 Dec 2000 12:49:18 -0800

> I hope, this short introduction to placement policies helps.

Yes indeed, once I figured out where to put it.  The Redhat setup has
a somewhat confusing array of config files.
ls /etc/X11/AnotherLevel:
decors
fvwm2rc.apps.m4
fvwm2rc.decors.m4
fvwm2rc.defines.m4
fvwm2rc.defstyles.m4
fvwm2rc.forms.m4
fvwm2rc.functions.m4
fvwm2rc.hostmenus.m4
fvwm2rc.init.m4
fvwm2rc.keys.m4
fvwm2rc.m4
fvwm2rc.macros.m4
fvwm2rc.menus.m4
fvwm2rc.modules.m4
fvwm2rc.mouse.m4
fvwm2rc.xlock.m4
scripts

I run in FVWM95 so it was in decors/FVWM95

grep -rA1 'lacement' .AnotherLevel/decors/FVWM95

#Style "*"	SmartPlacement, ifdef(`INTERACTIVE_PLACEMENT',\
 `ActivePlacement', `RandomPlacement')

# added line below [HP -ed] Dec 03 12:24:21 2000
Style "*"	RandomPlacement, DumbPlacement, ifdef(`INTERACTIVE_PLACEMENT',\
`ActivePlacement', `RandomPlacement')

The line I added seems to be having the desired effect 
... thanks
-- 
"Boxes not Boxen" 
Join the growing movement to EtUUoPP (End the Useless Use of
Pretentious Plurals). Strike a blow for plain talk: 
Adopt the ultimate witty signature .. "Boxes not Boxen"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].