Subject: FVWM: Creating similar decors ?

From: Perry Hutchison <[email-masked]>
Date: Mon, 20 Nov 2000 13:53:44 -0800 (PST)

Is there a way to create a new decor which starts out as a copy of
an existing one rather than as a copy of the default?  Alternatively,
is it possible to change the definitions which comprise the default
decor (without recompiling FVWM)?

Fvwm Version 2.2.4 compiled on Feb  4 2000 at 03:41:44, Red Hat Linux 6.2
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 22 Nov 2000 00:08:25 +0200

> decor (without recompiling FVWM)?

You can emulate this using the following InitializeDecor function.

  DestroyFunc InitializeDecor
  AddToFunc   InitializeDecor
  + I DestroyDecor $0
  + I AddToDecor   $0
  + I + ButtonStyle ...
  + I + TitleStyle ...
  + I + BorderStyle ...
  + I + ...

  InitializeDecor MyNewDecor1
  AddToDecor MyNewDecor1
  + ...

  InitializeDecor MyNewDecor2
  AddToDecor MyNewDecor2
  + ...

Regards,
Mikhael.