Subject: FVWM: Resize grow

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 16 Nov 2000 12:34:03 -0800 (PST)

2.3.22
Solaris 5.5.1

I kludged together a (nonmaximized) Resize grow...

AddToFunc "Max2Size"
+	"I" Maximize
+	"I" ResizeMove $0p $1p $2p $3p
+	"I" Resize br w-10p w-27p	# correction

AddToFunc "Fit_Y"
+	"I" Resize keep 1p	# start from smallest size
+	"I" Maximize 0 grow
+	"I" Max2Size $[w.width] $[w.height] $[w.x] $[w.y]

questions:
Is there a less kludgy way?
Why is the final size too big that i need to make a correction?
Can i combine the Resize correction into the ResizeMove?
ResizeMove $0p $1p-27p $2p $3p doesnt work.

Thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 18 Nov 2000 12:58:05 +0200

> I kludged together a (nonmaximized) Resize grow...

I think I have finally understood what you intend to do. Please be more
descriptive next time.

> Is there a less kludgy way?

I don't think there is a better way. Your method is quite interesting.
You can start from Resize keep 0.

> Why is the final size too big that i need to make a correction?

Because $[w.*] size variables include borders, while Resize operates with
sizes of the application without borders, so since your border is 5 pixels
and your title width is 17, here goes the correction.

Probably we can later add variables returning size without borders/title.

> ResizeMove $0p $1p-27p $2p $3p doesnt work.

No, you can't, only one 'p' is allowed in an argument.
As I said, a better fix would be to introduce additional variables.

Regards,
Mikhael.