Subject: Re: FVWM: starting up FVWM2

From: Hyper Faze <[email-masked]>
Date: Mon, 27 Nov 2000 15:59:18 -0800 (PST)

I don't think it's my color mode because I have added
fvwm to my cde login prompt and I can log in from
there with no errors or anything.  I got the
instructions on how to do this from:

http://twirl.mcc.ac.uk/~zzassgl/wm.html

Like I said, these errors only happen when I launch
fvwm from command line login.

#/usr/openwin/bin/xinit
#/home/frosbyte/usr/bin/fvwm2 &

Any ideas?
Thanks for all your help and patience guys!

--- Dan Espen <[email-masked]> wrote:
> Hyper Faze <[email-masked]> writes:
> > What would be another way of starting up fvwm2?
> > 
> > I'm on an ultra 1 solaris 8 box running fvwm-2.2.4
> > 
> > The way I'm currently doing it is I'm loging in
> using
> > the command line login.  Then I execute
> > /usr/openwin/xinit which then launches a terminal
> > window in which I type
> /home/frosbyte/usr/bin/fvwm2 &
> > and it brings up fvwm2 fine.
> > 
> > The problem is I'm getting too many error msg's. 
> For
> > example if I open up dtmail I get the following:
> > 
> > libSDtMail: Warning: Xt Warning: Cannot allocate
> > colormap entry for "LightGoldenRodYellow"
> > 
> > Or if I open an xterm with colors I get the
> following
> > error
> >  Warning: Cannot allocate colormap entry for
> "green"
> 
> If you  only have 8  bit color, you  can expect to
> have  problems with
> color allocation.
> 
> You can tell how much color the X server  has by
> looking at the output
> of "xdpyinfo".
> 
> If you are restricted to 256 colors, (8 bit color),
> add this line to
> the front of your .fvwm2rc:
> 
> ColorLimit 61
> 
> If you are running Netscape, always start Netscape
> with the "-install"
> flag.
> 
> Your mail covered a lot of ground, but the only
> error messages
> I see have to do with color allocation.  If you have
> more issues,
> let us know.
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail:
> [email-masked]
> Piscataway, NJ 08854                     Phone:
> (732) 699-5570
> --
> Visit the official FVWM web page at <URL:
> http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe
> fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to
[email-masked].

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Nov 2000 19:14:27 -0500

> #/home/frosbyte/usr/bin/fvwm2 &

You had 2 suggestions to add the ColorLimit command to your .fvwm2rc.
With 2.2.4, ColorLimiting is not automatic.  Did you do that?

Do you know if you have 8 bit color or not?  Its possible, fvwm is
not using the right visual, but you're not supplying any information.
If you don't understand the question, just post the output of
xdpyinfo.

Fvwm will use more color than dtwm or olwm if you let it.
If you are using 8 bit color, make sure you don't try to decorate
anything with gradients, and make sure you use the ColorLimit command.
It must be at the front of your .fvwm2rc.

As for the 2 different methods of starting fvwm causing the problem, I
don't know.   But  right now, I   don't know which   problem you have,
(running  out of color, or  using the wrong  visual).  Maybe the error
messages are just hidden from you when you use the other method.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].