Subject: FVWM: starting up FVWM2

From: Hyper Faze <[email-masked]>
Date: Mon, 27 Nov 2000 10:49:03 -0800 (PST)

What would be another way of starting up fvwm2?

I'm on an ultra 1 solaris 8 box running fvwm-2.2.4

The way I'm currently doing it is I'm loging in using
the command line login.  Then I execute
/usr/openwin/xinit which then launches a terminal
window in which I type /home/frosbyte/usr/bin/fvwm2 &
and it brings up fvwm2 fine.

The problem is I'm getting too many error msg's.  For
example if I open up dtmail I get the following:

libSDtMail: Warning: Xt Warning: Cannot allocate
colormap entry for "LightGoldenRodYellow"

Or if I open an xterm with colors I get the following
error
 Warning: Cannot allocate colormap entry for "green"

Here's what I've got in my .fvwm2rc file for both
items:

+               "My Mail"       Exec
/usr/dt/bin/ttsession -c /usr/dt/bin/dtmail &

+               "Xgreen"        Exec xterm -fg green
-bg black -sb -sl 9000 -font 8x13 -geometry
=81x35+50+50 -s -rw &

A few months ago I ran into this website that showed
me how to add fvwm2 as one of my windows mgr in my cde
login screen,
(http://twirl.mcc.ac.uk/~zzassgl/wm.html).  I did what
the instructions said to do and I was launching fvwm
fine with no problems or errors.  The problem was that
in order to launch fvwm I had to be on this local
system and I couldn't launch it from another machine. 
So I started running /usr/openwin/bin/xinit then
/home/frosbyte/usr/fvwm2 & but like I said this has
been giving me too many errors.

BTW I don't have an .xinitrc file.  Could this be the
problem?  I really don't know if I'm starting up fvwm2
the right way, if there's a better way please advise. 
Thanks!

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Mon, 27 Nov 2000 11:00:39 -0800

> and it brings up fvwm2 fine.

Try the following .xinitrc file:

<<Eoxinitrc
#!/bin/sh
exec $HOME/usr/bin/fvwm2
Eoxinitrc
 
>  Warning: Cannot allocate colormap entry for "green"

These messages are totally unrelated. The problem is you're running
(I'll bet) in 8-bit color mode. I don't know what framebuffer you've
got, but if you're on an Ultra-1, I wouldn't be at all surprised if
that's the best it can do. Something is eating all your colors,
causing other applications not to be able to have the ones they want.
fvwm2 should automatically limit itself to a small number of colors,
via the ColorLimit command (I'm not sure this is true in 2.2.4). You
may want to consider using ColorLimit in your .fvwm2rc.

> the right way, if there's a better way please advise. 

Yup, that's the problem.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
The life uncaffeinated is not worth living.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Nov 2000 14:06:23 -0500

>  Warning: Cannot allocate colormap entry for "green"

If you  only have 8  bit color, you  can expect to have  problems with
color allocation.

You can tell how much color the X server  has by looking at the output
of "xdpyinfo".

If you are restricted to 256 colors, (8 bit color), add this line to
the front of your .fvwm2rc:

ColorLimit 61

If you are running Netscape, always start Netscape with the "-install"
flag.

Your mail covered a lot of ground, but the only error messages
I see have to do with color allocation.  If you have more issues,
let us know.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].