Subject: FVWM: XMMS Problems

From: Joe Wingbermuehle <[email-masked]>
Date: Mon, 6 Nov 2000 21:21:37 -0600

Hi,
Lately I have been having problems with the latest snapshots of FVWM and XMMS.
XMMS starts fine and everything, but when I try to move it, it moves very
slowly. Moving XMMS works just fine under other window managers. Does anyone
know what is happening and/or how to fix it?
Also of interest, when I restart FVWM, XMMS is dies.

--
Joe Wingbermuehle
http://joewing.calc.org
Outside of a dog, a book is a man's best friend. Inside of a dog,
it's too dark to read.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 12 Nov 2000 14:57:07 +0100

> Also of interest, when I restart FVWM, XMMS is dies.

I pinned down this problem in the xmms sources and sent a patch to the
developers.  Here it goes:

----------------------------- snip -----------------------------
--- main.c.orig Sun Nov 12 14:20:01 2000
+++ main.c      Sun Nov 12 14:33:23 2000
@@ -1094,6 +1095,8 @@
                draw_main_window(FALSE);
        }
        gdk_flush();
+       /* give the X server a chance to handle our requests */
+       xmms_usleep(1);

 }

----------------------------- snip -----------------------------

Apply this patch to the file xmms/main.c in the xmms sources.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joe Wingbermuehle <[email-masked]>
Date: Mon, 13 Nov 2000 09:12:01 -0600

> ----------------------------- snip -----------------------------

I tried that patch and it didn't seem to help much so I raised the delay to
500. I think this might have improved the situation, but it isn't an obvious
improvement. I have a dual PIII system so I don't think that the speed of my
computer is causing the problem.

--
Joe Wingbermuehle
http://joewing.calc.org
There are three types of people in this world: those who can count,
and those who can't.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Nov 2000 22:27:48 +0100

> computer is causing the problem.

Increasing the delay will not help.  The idea is to free the smallest
possible amount of CPU so that the scheduler taker care of letting
other tasks run.  Perhaps your xmms runs with a higher priority than
your X server?  Try starting (the patched version of) xmms with

  $ nice -20 xmms

(this does not help on my system, though).

Bye

Dominik ^_^  ^_^