Subject: FVWM: Secrets of FvwmCommand ?

From: Perry Hutchison <[email-masked]>
Date: Thu, 16 Nov 2000 19:45:48 -0800 (PST)

I want to discover the "resource" and "class" of several windows,
in hopes that those from a particular application (which do not
share a common window or icon name) will have _something_ in common
that I can use to identify them.

It appears that the send_windowlist operation of FvwmCommand will tell
me what I need to know.  However, I can't get FvwmCommand to work.

In FvwmConsole I typed "FvwmCommandS" and it created the FIFOs:

$ ls -l .FvwmCommand*
crw-------    1 phutchis phutchis 255, 255 Nov 16 19:03 .FvwmCommandC
crw-------    1 phutchis phutchis 255, 255 Nov 16 19:03 .FvwmCommandM

but FvwmCommand can't find them:

$ FvwmCommand -f .FvwmCommand send_windowlist
No such device FvwmCommand error in opening message fifo

The same thing happens with or without -f and/or -r.

The only clue I can find is that, when I type FvwmCommandS in
FvwmConsole, this gets appended to .xsession-errors:

    FvwmCommandS server error in opening command fifo, No such device

which doesn't make a lot of sense given that, as noted above, it
did in fact create the FIFOs.  What am I doing wrong?

Fvwm Version 2.2.4 compiled on Feb  4 2000 at 03:41:44
FvwmCommand 1.5, FvwmConsole Ver. 1.3, Red Hat Linux 6.2
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul D. Smith" <[email-masked]>
Date: 17 Nov 2000 00:34:00 -0500

Try FvwmIdentify.  That's what it's for.

HTH.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Fri, 17 Nov 2000 10:51:26 -0800 (PST)

> Try FvwmIdentify.  That's what it's for.

Thanks, that does take care of the immediate problem.  Still
interested in why FvwmCommand won't work, though.  Is anyone
using it successfully on Red Hat Linux?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (David S. Goldberg)
Date: 17 Nov 2000 14:15:18 -0500

> crw-------    1 phutchis phutchis 255, 255 Nov 16 19:03 .FvwmCommandM

Those don't look like FIFO's to me.  On all my "normal" UNIX systems,
including RH6.2, FIFO's are listed with a `p' in the first column.
Those look like character devices (note the `c' and the major and
minor numbers).  I have no idea why you're seeing this.
FvwmCommand/FvwmCommandS work just fine for me on RH6.2.  Fvwm 2.2.4
compiled from source by me.
-- 
Dave Goldberg
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 17 Nov 2000 14:38:16 -0500

Is the location of your pipes by any chance on NFS.  Pipes don't work
on NFS.  If you do FvwmCommandS /tmp/FvwmCommand
then use FvwmCommand /tmp/FvwmCommand

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Fri, 17 Nov 2000 12:16:05 -0800 (PST)

AHA!  That's it.

Suggestion for a future update:  FvwmCommandS and FvwmCommand
might check whether the home directory is NFS-mounted, and if
so use something like /tmp/$DISPLAY/.FvwmCommand as the default
FIFO set.  (I try to avoid global places like /tmp/FvwmCommand,
in case there might be another FVWM running on the same system,
e.g. for an Xterminal.)

In the meantime, it might be worth adding this tidbit to the
FvwmCommand manpage or the FAQ.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 18 Nov 2000 22:03:33 +0100

> FvwmCommand manpage or the FAQ.

In the 2.3.x betas the pipes are created in /var/tmp or in /tmp
and their name is always unique, even if there are multiple
instances of fvwm2 running.

==>
  /var/tmp $ ls -F
  FvwmCommand-DarkSun:0.0C|
  FvwmCommand-DarkSun:0.0M|

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 18 Nov 2000 22:03:33 +0100

==>
  /var/tmp $ ls -F

Bye

Dominik ^_^  ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 28 Nov 2000 08:54:52 -0500

I usally start it up as FvwmCommandS /tmp/FvwmCommand-$[DISPLAY]

That way I can't step on anybody else.

Brad