Subject: FVWM: keyboard macros

From: Cyprian Laskowski <[email-masked]>
Date: Thu, 16 Nov 2000 02:06:47 -0800 (PST)

Greetings All,

I'm a keyboard fanatic, and am wondering whether it
would be possible to define little fvwm functions
which would allow for dynamically binding a key to a
sequence of fvwm commands during an fvwm session.

The emacs template I have in mind goes like this: you
type "C-x (" to declare the beginning of a macro
definition, then you proceed along your merry way as
you would normally, and finally you declare end of
macro with "C-x )".  I'm curious whether you could do
a similar thing in fvwm.  Press F4 or something, fire
up a whole bunch of keyboard (or mouse) events, (some
of which it may pass to application programs, some of
which it handles itself), then end the sequence with
F5, and finally name the sequence Nonsense and bind F6
 to Nonsense for the remainder of the session. Of
course it would be up to the user to make sure that
the definition is sensible to repeat, but still, is it
possible?

Which brings up a related question: can you have
prefix keys in key bindings?

cyp

__________________________________________________
Do You Yahoo!?
Yahoo! Calendar - Get organized for the holidays!
http://calendar.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 16 Nov 2000 08:50:06 -0500

Cyprian Laskowski <[email-masked]> writes:
> Press F4 or something, fire

Fvwm (and any other window manager) never sees keystrokes
sent to applications.

For keyboard macro recording, you'd need something operating
at the X server level.

Currently there is no way to tell Fvwm to start recording
Fvwm keyboard events.  Since it doesn't see all events,  I'm
not sure such a feature would be useful.

> prefix keys in key bindings?

I think you are referring to repeat factors?

Fvwm binds actions to single keyboard events.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 16 Nov 2000 12:25:57 -0800

you might want to look into testing (QC) tools that enable you to
record X events, I do nopt have experience with such tools in unix, I
know such tools exist, not sure if there are any free ones.

	erik