Subject: FVWM: (uk) sun keyboard mappings?

From: Ray Fung <[email-masked]>
Date: Thu, 30 Nov 2000 11:28:25 +0000 (GMT)

hi

i have been trying to get my .fvwm2rc files
keybindings to work correctly for my sun keyboard. 
the keybindings are ok when i'm running the same rc
file on my linux (pc) box.

the problem is, i'm trying to get the ATL-Graph key
mapped to be a CONTROL-R key so that 'alt-graph plus
arrow' can move across the virtual desktops but am
having no fun using xkeycaps.  does anyone out there
have a successful .xmodmap that allows the alt-graph
key to work as a control (and also the left 'diamond'
key to be mapped to ALT)?

thanks in advance
ray

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 30 Nov 2000 08:49:23 -0500

> key to be mapped to ALT)?

I don't see the need to change the alt-graph mapping.
On my Sun Type 4 keyboard, AltGraph is known as "Mode_switch"
with "mod2" assigned as the modifier.

To have fvwm react to AltGraph/Left use:

Key Left A 2 <action>

The left Alt key seems to want to use the Modifier "M".

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].