Subject: Re: FVWM: Button Bar

From: Hyper Faze <[email-masked]>
Date: Tue, 31 Oct 2000 13:53:01 -0800 (PST)

I want the buttons to be bigger.  They're about 1/2
inch on all sides.  Here's the configuration I have
for my FvwmButtons:

# FvwmButtons
#
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack grey67 

# Font 
*FvwmButtonsFont        7x13

# Geometry-- really likes to pick its own size, but
giving a position is OK
*FvwmButtonsGeometry +0+0 

# Layout: specify rows or columns, not both
#*FvwmButtonsColumns 2 
*FvwmButtonsRows 2 

# Define the buttons to use.....
*FvwmButtons Move               arrows2.xpm     Move
*FvwmButtons Kill               skull.xpm      
Destroy
*FvwmButtons Quit               nuke.xpm        Popup
"Quit-Verify"
#*FvwmButtons 
#*FvwmButtons (de)Iconify       eyenew.xpm     
Iconify
#*FvwmButtons Restart eye2.xpm     Restart
#*FvwmButtons Xcalc   rcalc.xpm   Exec "Calculator"
xcalc &
#*FvwmButtons junk   3dx.xpm     Swallow "xload" 
xload -bg \#908090
#*FvwmButtons xmter x.xpm            Swallow "xmter"
xmter &
#*FvwmButtons "" 3dx.xpm Swallow "Time 3D" t3d -fg
\#908090 -mag .3 -wobber 0 &
*FvwmButtons - - Swallow "FvwmXclock" Exec xclock
-name "FvwmXclock" -geometry +0+0 -padding 1 -bg
grey67 &
*FvwmButtons(2x1, Swallow "FvwmPager" "FvwmPager 0 0
&")

Thanks guys.

--- "Paul D. Smith" <[email-masked]>
wrote:
> %% Hyper Faze <[email-masked]> writes:
> 
>   hf> This might be a dumb question but here it
> goes.  
>   hf> I'm trying to get a bigger button bar on my
> desktop
>   hf> but I can't seem to find what settings I need
> to
>   hf> change in my .fvwm2rc file to get a bigger
> button bar.
> 
> The FVWM button bar is created by the FvwmButtons
> module, so you want to
> look at the FvwmButtons man page for information on
> configuring it.
> 
> However, FvwmButtons sizes the button bar to be as
> large as is needed by
> the buttons it contains, including their pixmaps and
> labels (plus some
> border stuff, etc.)
> 
> What do you mean by "bigger button bar"?  You mean,
> you want the buttons
> to be bigger?  Or to have space between them?  Or
> the pictures to be
> larger?  Or what?
> 
> -- 
>
-------------------------------------------------------------------------------
>  Paul D. Smith <[email-masked]>   
> HASMAT--HA Software Methods & Tools
>  "Please remain calm...I may be mad, but I am a
> professional." --Mad Scientist
>
-------------------------------------------------------------------------------
>    These are my opinions---Nortel Networks takes no
> responsibility for them.

__________________________________________________
Do You Yahoo!?
Yahoo! Messenger - Talk while you surf!  It's FREE.
http://im.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul D. Smith" <[email-masked]>
Date: 31 Oct 2000 17:41:35 -0500

Well, the FvwmButtons man page on my system lists several options that
should be of interest to you:

  * FvwmButtonsButtonGeometry, which lets you set a geometry for a
    single button.  So, you can make each button be a specific size if
    you like.

  * Or, FvwmButtonsPadding can increase the padding between the edge of
    the button and its contents (normally this is 2 pixels).

There may be others; check the man page.

Or, you can find larger pixmaps and use those instead of the ones you
have, then FvwmButtons will automatically increase the size of your
button bar accordingly.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>    HASMAT--HA Software Methods & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 1 Nov 2000 02:32:04 +0200

On 31 Oct 2000 13:53:01 -0800, Hyper Faze wrote:
> 
> I'm trying to get a bigger button bar on my desktop

[...]

> *FvwmButtons(2x1, Swallow "FvwmPager" "FvwmPager 0 0 &")

You can replace this line with something like:

  *FvwmButtons(2x1, Size 150x80, Swallow "FvwmPager" "FvwmPager * *")

Or specify geometry for the full button bar:

  *FvwmButtonsGeometry 500x400-0+0

Regards,
Mikhael.