Subject: FVWM: Why did VM kill my fvwm2?

From: "Scott D. Anderson" <[email-masked]>
Date: Thu, 12 Oct 2000 13:45:06 -0400 (EDT)

Thanks to the hard work of the wizards here, I've used fvwm1 and 2 for
years, recently switching to fvwm2 on RedHat Linux 6.2.  It's run fine for
months, but this morning, I came in to find myself logged out.  Very odd.
I looked at the output of "dmesg" and I saw:

VM: killing process fvwm2

Who is VM? (Virtual Memory?) Why did it kill my fvwm2?  How can I prevent
a repeat of this?

Thanks,

Scott

-- 
Scott D. Anderson
Wellesley College, Wellesley, Massachusetts
[email-masked]
http://www.wellesley.edu/CS/sanderson.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 12 Oct 2000 22:13:35 +0200

On 12 October, 2000 - Scott D. Anderson sent me these 0.7K bytes:

> Who is VM? (Virtual Memory?) Why did it kill my fvwm2?

It's the virtual memory that ran out of memory and looked for a good
victim to get rid of.. Your fvwm2 ran out of luck and had to die. Linux'
Out-of-memory handler isn't very bright..

> How can I prevent a repeat of this?

Don't run out of memory ;P

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nix <[email-masked]>
Date: 13 Oct 2000 21:18:34 +0100

> Out-of-memory handler isn't very bright..

This will probably be much improved in Linux 2.4.x, when that comes out.

-- 
`Normally, we don't do people's homework around here, but Venice 
 is a very beautiful city, so I'll make a small exception.'
        --- Robert Redelmeier compromises his principles
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].