Subject: FVWM: installing 2.2.4

From: "Nikolaj G." <[email-masked]>
Date: Sun, 15 Oct 2000 23:38:32 +0200

Hi, I just installed the 2.2.4, but "all the stuff" stays in my download
directory.  The only thing that gets copied is the fvwm2 executable (as
it seems to me on a "locate"). I used

1. ./configure
2. make
3. make install

as root. Furthermore the machine starts up in "Afterstep" (because it
can't find fvwm2) - pretty anoying. I tried to catch it by editing the
.xinitrc (both home/me/.xinitrc and root/.xinitrc) but it still starts
in "Afterstep". Below is the Makefile, my first question on this one is
- did something goe wrong with the DESTDIR? (don't know the syntax for
makefiles). I use SuSE 6.3 and is setup to start fvwm2 in the rc.config.

Thanks in advance, nikolaj, copenhagen, denmark

---- Here's the top of the Makefile

SHELL = /bin/sh

srcdir = .
top_srcdir = .
prefix = /usr/local
exec_prefix = ${prefix}

bindir = ${exec_prefix}/bin
sbindir = ${exec_prefix}/sbin
libexecdir = ${exec_prefix}/libexec
datadir = ${prefix}/share
sysconfdir = ${prefix}/etc
sharedstatedir = ${prefix}/com
localstatedir = ${prefix}/var
libdir = ${exec_prefix}/lib
infodir = ${prefix}/info
mandir = ${prefix}/man
includedir = ${prefix}/include
oldincludedir = /usr/include

DESTDIR =

pkgdatadir = $(datadir)/fvwm
pkglibdir = $(libdir)/fvwm
pkgincludedir = $(includedir)/fvwm

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 16 Oct 2000 02:36:12 +0200

> it seems to me on a "locate"). I used

If 'make install' didn't give you an error, everything is installed well.
To find what stuff is installed where, you can read INSTALL.fvwm.

> makefiles). I use SuSE 6.3 and is setup to start fvwm2 in the rc.config.

Do you have /usr/local/bin (this is the default, can be configure'd)
in the PATH? Or do you use the full path to fvwm2 binary?

I am not familar with the SuSE setup, but I would think, it should respect
your ~/.xinitrc if you start X by xinit (or startx). Another possible
solution may be to have ~/.Xclients instead of ~/.xinitrc.
The contents of the file could be: exec /usr/local/bin/fvwm2

> DESTDIR =

This is ok.

Regards,
Mikhael.

---

From: Frank Derichsweiler <[email-masked]>
Date: Mon, 16 Oct 2000 10:21:28 +0200

> in the PATH? Or do you use the full path to fvwm2 binary?
SuSE uses an environment variable to determine which window manager
sFrom [email-masked]  Tue Oct 17 16:44:27 2000
Date: Tue, 17 Oct 2000 23:41:39 +0000
To: [email-masked]
Subject: FVWM: xmasseges....
Internet: http://www.billgotchy.de
pgp-key: http://www.billgotchy.de/bin/m.asc
OS: Linux Debian 2.2r0 - potato
Private-Debian-Site: http://www.linux-debian.de
From: Jan- Hendrik Palic <[email-masked]>
Sender: [email-masked]

Hi to all...

I turned over from SuSE to debian. Under SuSE, the fvwm2 had a console,
which was titles "xmessages", and I want this in my selfcompiled fvwm2 under
debian, too.

How can I realize that?

thnx for help!

Jan

-- 
One time, you all will be emulated by linux!

----
Jan- Hendrik Palic
Url:"http://www.billgotchy.de"
E-Mail: "[email-masked]"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].