Subject: FVWM: scrolling desktops with keys?

From: Martin Maciaszek <[email-masked]>
Date: Sat, 14 Oct 2000 19:49:44 +0200 (MEST)

So far I had a 9x9 desktop and the following key bindings:
Key 		Left	A	CM		Scroll -100 +0
Key		Right	A	CM		Scroll +100 +0
Key		Up	A	CM		Scroll +0 -100
Key		Down	A	CM		Scroll +0 +100

Now some considerations forced me to change my desktop to 3x3 disjoint
desktops. Unfortunately the keys won't work any more. Can I still get somehow
the same behaviour?

Regards
Martin

-- 
Sent through GMX FreeMail - http://www.gmx.net

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: An Thi-Nguyen Le <[email-masked]>
Date: Sat, 14 Oct 2000 13:02:50 -0500

On Sat, Oct 14, 2000 at 07:49:44PM +0200, Martin Maciaszek typed:
} So far I had a 9x9 desktop and the following key bindings:
} Key 		Left	A	CM		Scroll -100 +0
} Key		Right	A	CM		Scroll +100 +0
} Key		Up	A	CM		Scroll +0 -100
} Key		Down	A	CM		Scroll +0 +100
} 
} Now some considerations forced me to change my desktop to 3x3 disjoint
} desktops. Unfortunately the keys won't work any more. Can I still get somehow
} the same behaviour?

If you're using fvwm-2.2.x, use Desk.  If you're using fvwm-2.3.x, 
use GotoDesk.  Both are in the manpages for fvwm.  

Here you'd want to use (for fvwm-2.2):

# wrapping around between desks 0 and 8.
Key           Left      A       CM         Desk -1 0 8
Key           Right     A       CM         Desk  1 0 8
# going to current desk +/- number of desks in a row.
Key           Up        A       CM         Desk -3 0 8
Key           Down      A       CM         Desk  3 0 8

For fvwm 2.3.x, just replace Desk with GotoDesk.

-- 
An Thi-Nguyen Le
|Marriage is the only adventure open to the cowardly.
|		-- Voltaire