Subject: FVWM: Specifying geometry with Style

From: Les Martin <[email-masked]>
Date: 5 Oct 2000 17:09:03 -0000

Can I specify geometry with the Style command,
so that, for example

    Style "*rocmeter*"    Geometry 120x80+40+20

would make it so if I run procmeter3 from the
command line, it will come up though I had said

    procmeter3 -geometry 120x80+40+20

If not via the Style command, is there another
way I can tell the window manager to make sure
when a new window comes up which satisfies some
criteria it will be resized and repositioned to
a particular geometry?

- Les

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 6 Oct 2000 02:43:47 +0200

>     procmeter3 -geometry 120x80+40+20

Not using a style. Just add the following line into your ~/.Xdefault:

  procmeter*geometry: 120x80+40+20

> criteria it will be resized and repositioned to

Yes it is possible too using FvwmEvent, see:

  for 2.2:  http://www.hpc.uh.edu/fvwm/archive/0006/msg00393.html
  for 2.3:  http://www.hpc.uh.edu/fvwm/archive/0006/msg00382.html

Regards,
Mikhael.