Subject: FVWM: Restarting fvwm with xrootconsole

From: Stephane Gibier <[email-masked]>
Date: Fri, 6 Oct 2000 23:56:35 +0200

Hello,

Context : GNU/Linux, fvwm-2.3.21, XFree 3.3.5, glibc-2.0.7

I have installed xrootconsole, a small utility that displays its input in a
text box transparently on the root window. This fancy utility is available
on <URL:http://wso.williams.edu/~bgallowa/xrootconsole/>.

My background is a complex pixmap and I use xrootconsole to monitor the
/var/log/messages file with the following command :

DestroyFunction InitFunction
AddToFunction InitFunction
+ I Exec exec tail -f /var/log/messages | xrootconsole

All works like a charm, *except* when I restart fvwm with the Restart
command. The xrootconsole window stays always on top of all others windows
and this is very annoying. This problems does not appear with others window
managers like sawfish and twm.

The same effect can be reproduced when starting another xrootconsole
manually (from a xterm by example) and restarting fvwm.

Here's the xwininfo of xrootconsole :

xwininfo: Window id: 0x1c00002 (has no name)

Absolute upper-left X:  0
Absolute upper-left Y:  760
Relative upper-left X:  0
Relative upper-left Y:  760
Width: 792
Height: 104
Depth: 16
Visual Class: TrueColor
Border width: 0
Class: InputOutput
Colormap: 0x23 (installed)
Bit Gravity State: ForgetGravity
Window Gravity State: NorthWestGravity
Backing Store State: NotUseful
Save Under State: no
Map State: IsViewable
Override Redirect State: yes
Corners:  +0+760  -360+760  -360-0  +0-0
-geometry 792x104+0-0

Why this problem appears only when restarting fvwm and how to keep xrootconsole on the lowest layer ?

Thanks in advance.

-- 
Stéphane Gibier <[email-masked]>
La jouvencelle glisse dans la piscine
Yn wbhirapryyr cvffr qnaf yn tylpvar 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 7 Oct 2000 21:33:18 +0200

> Override Redirect State: yes
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

> Why this problem appears only when restarting fvwm and how to keep xrootconsole on the lowest layer ?

First the bad news: it is the fault of the application.  It makes
its window "override redirect" which means that the window manager
does not know about it and can not properly stack other windows
above or below it. According to th ICCCM2 (the document describing
how applications and the window manager have to interact), only
transient windows like menus may be declared "override redirect".
Obviously xrootconsole violates this rule by making a permanent
window use this hint.

Now the good news: Fvwm has an option to work around the flawed
application's bug.  Try

  BugOpts RaiseOverUnmanaged on

In your config file.

Anyway, could you perhaps forward the discription of the bug above
to the developers of xrootconsole?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephane Gibier <[email-masked]>
Date: Sun, 8 Oct 2000 10:19:45 +0200

>   BugOpts RaiseOverUnmanaged on

Thanks a lot, it works perfectly now :-) Does it mean that sawfish is not
fully ICCCM2 compliant ? This problem can not be reproduced with this wm.

> to the developers of xrootconsole?

Yes, of course. I will try some hacks, the xrootconsole source is very
small.

Thanks.

-- 
Stéphane Gibier <[email-masked]>
La jeune fille se tient sur la berge du ravin
Yn wrhar svyyr fr gvrag fhe yn iretr qh enoova 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Oct 2000 15:35:19 +0200

> fully ICCCM2 compliant ? This problem can not be reproduced with this wm.

Well, you will probably not find a single window manager and not a
single application that is completely ICCCM2 compliant.  The
problem that window manager authors have is that they have to work
with a multitude of buggy applications.  So we can not simply say
"fix it, your application is broken" because if we did this, only
one of two applications would run properly.  So we keep making
options to work around many bugs in applications but keep telling
the authors to fix them.

Bye

Dominik ^_^  ^_^