Subject: Re: FVWM: Cant' get pager to work (Dan)

From: Hyper Faze <[email-masked]>
Date: Thu, 26 Oct 2000 11:15:19 -0700 (PDT)

Well I'm not trying to start FvwmPager through the
command line.

I basically installed fvwm2 the way the directions
tell me to.  I haven't touched .cshrc and I don't have
a .profile, but I do have a .dtprofile.

I remember having a small problem running ./configure 
I was getting the following error:
configure: error: can not run test program while cross
compiling

So someone told me to run ./configure with the
following options:
./configure --without-cxx

He said that running this would eliminate a minor
module written in C++

The version of fvwm is 2.2.4

I was using fvwm on another system (ultra5) and the
way I used to launch fvwm was by login into command
line mode and then typing the command "startx" and
that would automatically launch fvwm.  But on this
system (ultra 1 solaris 8) when I execute startx it
says command not found, can't do a man startx either.

So I found a site that showed me how to add fvwm to my
CDE login screen.  So now when I'm at the login screen
I go to options/session/fvwm and wala fvwm comes up
fine but with no pager.

Here's the site that showed me how to add fvwm to my
win manager list

http://twirl.mcc.ac.uk/~zzassgl/wm.html

Could this be why?  Thanks for your help.

--- Dan Espen <[email-masked]> wrote:
> Hyper Faze <[email-masked]> writes:
> > I'm trying to get pager to work but it just will
> not
> > launch when I log into my system (ultra 1 Solaris
> 8). 
> > I'm fairly new at fvwm2 which makes it difficult
> to
> > understand why.  
> > 
> > I've tried using someone else's fvwm2rc who is
> using
> > Pager fine but it still will not launch. 
> > 
> > Could it be cuz my default shell is csh?  I
> noticed
> > that I don't have an .xinitrc file either.. could
> that
> > be the problem?  
> 
> csh should have nothing to do with it.  You don't
> start
> FvwmPager from the command line, nor do you "Exec"
> it from
> your .fvwm2rc.
> 
> You haven't supplied enough information.
> 
> What version of fvwm are you using.
> 
> How are you starting X?  What did you do about CDE?
> If you are starting X from your .profile, what
> command did
> you use?
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail:
> [email-masked]
> Piscataway, NJ 08854                     Phone:
> (732) 699-5570

__________________________________________________
Do You Yahoo!?
Yahoo! Messenger - Talk while you surf!  It's FREE.
http://im.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 26 Oct 2000 14:37:03 -0400

> a .profile, but I do have a .dtprofile.
...
> says command not found, can't do a man startx either.

Solaris doesn't come with startx.  No surprise there.

> Could this be why?  Thanks for your help.

The information at that site is good.
This explains why you don't need a .xinitrc, the script
adapts to that and starts fvwm2 instead.

To get FvwmPager to start with Fvwm2.4, you are going to need
a correct ModulePath and good configuration commands and
a command to start FvwmPager.

It will also help if we can see any error messages that might be
getting printed.

Modify the script described in Step 4 where it invokes fvwm2:

Before:  /usr/local/bin/fvwm2 &
After:   /usr/local/bin/fvwm2 2>&1 | tee /tmp/xinit.out&

Look in /tmp/xinit.out from time to time to spot problems.

Assuming FvwmPager is in /usr/local/fvwm  you need in your .fvwm2rc:

ModulePath /usr/local/fvwm
*FvwmPagerBack gray
*FvwmPagerFore black
*FvwmPagerFont 9x15bold
*FvwmPagerSmallFont 5x8bold
*FvwmPagerHilight lightblue
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Main
*FvwmPagerLabel 1 Alt
*FvwmPagerDeskColor 0 blue
*FvwmPagerDeskColor 1 green
*FvwmPagerMiniIcons
*FvwmPagerBalloons

AddToFunc "InitFunction" "I" Module FvwmPager 0 1

(The *FvwmPager lines can be whatever you want, I'm just giving you
what I have set.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 26 Oct 2000 15:38:36 -0400

...
> a command to start FvwmPager.

For all of you following along at home, Hyper Faze now reports
that FvwmPager is working for him.

---

From: Tenebrae <[email-masked]>
Date: Thu, 26 Oct 2000 13:45:28 -0700 (PDT)

> that FvwmPager is working for him.

heh
Thanks!
It's nice to see a happy ending to these threads.
Now, if I could just get sideways title bars, I'd be happy.  ;)
Still waiting...
( And here's my screenshot, for those who care -
http://www.sfgoth.com/~tenebrae/gallery/tenemiyuscreenshot.jpg )
								-Tenebrae.