Subject: FVWM: fvwm2 customisation (continued)

From: Thomas Adam <[email-masked]>
Date: Mon, 9 Oct 2000 14:47:19 -0700 (PDT)

Dear Dan,

Thankyou for your suggestions about kedit.... it seems
to work ok, it there are just two more things that I
would like your help with....

1. Is it possible to make that Function generic for
any K app that is loaded, i.e. maybe by using
wildcards?????

2. Secondly, because Kedit (with your function you
supplied) loads at startup, if I shut down that
program, and then load it up again, it starts on the
page it is meant to, but it does not load as an icon,
instead it loads up as a window. So my question is,
once I shutdown kedit, how do I re-envoke the Function
again????

Thanks for your help,
Regards,

Thomas Adam
re: [email-masked]

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - 35mm Quality Prints, Now Get 15 Free!
http://photos.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 09 Oct 2000 19:58:36 -0400

> once I shutdown kedit, how do I re-envoke the Function

OK, none of this is tested, but I think you will get the idea:

# Start program iconic, first arg is program name, class/resource name
DestroyFunc ksicon
AddToFunc ksicon
# I Style "$0" StartIconic
+ I Exec $0
+ I Wait $0
+ I Style "$0" StartNormal

AddToFunc InitFunction I ksicon kedit
AddToMenu Utilities "Start kedit" ksicon kedit

I made the function I gave you earlier generic, used the function from
the InitFunction and from a menu.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Oct 2000 08:28:43 +0200

> # I Style "$0" StartIconic
  ^

I guess this should be

  + I ...
  ^

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].