Subject: FVWM: ./configure won't work!

From: joe mama <[email-masked]>
Date: Thu, 12 Oct 2000 17:07:45 -0700 (PDT)

I'm trying to install fvwm2.2.4 on a solaris 2.6 ultra
10 machine.  But when I run ./configure it runs
through most of the checks until it gets to setvbuf. 
I get an error msg and it stops there.  Here's part of
the log:

checking for putenv... yes
checking for select... yes
checking for setvbuf... yes
checking for socket... no
checking for waitpid... (cached) yes
checking for strdup... yes
checking for strstr... yes
checking for strtol... yes
checking for memmove... yes
checking for memcpy... yes
checking for strchr... yes
checking for sysconf... yes
checking for uname... yes
checking for div... yes
checking for sigaction... yes
checking for siginterrupt... yes
checking for sig_atomic_t... yes
checking whether setvbuf arguments are reversed...
configure: error: can not run test program while cross
compiling

Any ideas?

__________________________________________________
Do You Yahoo!?
Get Yahoo! Mail - Free email you can access from anywhere!
http://mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Oct 2000 20:49:29 -0400

> configure: error: can not run test program while cross

It shouldn't think its "cross compiling".  Earlier it evaluates your
compiler.

You can compile with Sun's cc (if you've paid  for it, and its in your
path), or gcc.  Heres what I get on Solaris with gcc:

checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E

If it doesn't find gcc, it goes on to test cc.
What do you get?

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Pete Forman <[email-masked]>
Date: Fri, 13 Oct 2000 08:24:41 +0100 (BST)

Dan Espen writes:
 > You can compile with Sun's cc (if you've paid for it, and its in
 > your path), or gcc.  Heres what I get on Solaris with gcc:
 > 

And here's what I got with the native Sun compiler.

checking for gcc... no
checking for cc... cc
checking whether the C compiler (cc  ) works... yes
checking whether the C compiler (cc  ) is a cross-compiler... no
checking whether we are using GNU C... no
checking whether cc accepts -g... yes
checking how to run the C preprocessor... cc -E

-- 
Pete Forman                 -./\.- Disclaimer: This post is originated
Western Geophysical           -./\.-  by myself and does not represent
[email-masked]         -./\.-  the opinion of Baker Hughes or
http://www.crosswinds.net/~petef  -./\.-  its divisions.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Oct 2000 00:49:41 +0200

> configure: error: can not run test program while cross

fvwm-2.2 versions require also c++ (or g++, cxx, cc++) compiler.
It is possible that you have it, but it is not installed propertly.

If this is the case, specify ./configure --without-cxx .
You will not have one minor module, written in C++.

fvwm-2.3 versions do not use C++.

Regards,
Mikhael.