Subject: FVWM: iconic

From: Thomas Adam <[email-masked]>
Date: Sun, 8 Oct 2000 03:39:45 -0700 (PDT)

Dear All,

I am fairly new to fvwm2, but I am gradually getting
the hang of doing minor customisations to the fvwm2
config. files. This question may seem stupid, but here
goes....

1. I have tried to get a program such as "kedit" to
load as an icon when I start up fvwm2. I did this by
using Style "kedit" StartsOnDesk 1 2, StartIconic.

This sometimes worked, and sometimes did not, why????
Is it something that I am doing wrong???

2. Another annoying thing, is that after it had
worked, kedit would iconify other windows aswell, i.e.
when I went to File ---> open, that open window would
iconify as well, is there away around this???

3. kedit does not seem to like the -geometry command.
How then do I load kedit in a windows position that I
choose????

I hope that all this is not too "common place"

Waiting in Anticipation,

Thomas Adam

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - 35mm Quality Prints, Now Get 15 Free!
http://photos.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 8 Oct 2000 19:53:50 +0200

> using Style "kedit" StartsOnDesk 1 2, StartIconic.

This is ok, but the '2' in StartsOnDesk has no meaning, this is evaluated
to 'StartsOnDesk 1'. Or you mean StartsOnPage? You may try SkipMapping.

> Is it something that I am doing wrong???

If you start kedit at startup, for this to work, it is important that you
do this in InitFunction and not in .Xclients or .xinitrc.

Otherwise give more information. It works for me.

> iconify as well, is there away around this???

kedit sets not very helpful window and resource names for its windows.
You may try to check the names using FvwmIdent. Then use something like:

  Style "Open" StartNormal    # this should be after Style "kedit"

> How then do I load kedit in a windows position that I

Check other threads on this list. This will be in FAQ in several days.
But all kedit windows have resource name kedit and it seems impossible to
identify the main window, so you will have the same problems as in (2).

Also if you use FvwmEvent to set a geometry of kedit, you can call
'Next (kedit) Iconify true' in the same add_window event function.

You may want to ask kedit authors to implement -geometry, and to change
window name of the main window to "kedit - No File" or "kedit -
current.txt", so it would be possible to identify the main window only.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 09 Oct 2000 09:17:06 -0400

> Is it something that I am doing wrong???

This function seems to work for me:

DestroyFunc kedit
AddToFunc kedit
# I Style "kedit" StartIconic
+ I Exec kedit
+ I Wait kedit
+ I Style "kedit" StartNormal

I then start kedit using the function "kedit".

kedit seems to accept the command line flag "-iconic", but then ignores
it.  I don't know why.  Perhaps the KDE developers can explain why.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Oct 2000 16:04:43 +0200

> Is it something that I am doing wrong???

I don't know.  Generally, using KDE applications outside
of KDE is a bad idea.  All these programs support only
kwm, the window manager that comes with KDE.  Many of
them are very *very* buggy and ignore about everything
that applications have to do to cooperate nicely with
other window managers.  When I started kedit to check
your problem, it froze X completely several times, flickered
a lot, raised its own windows over other newly mapped windows
and so on.  I recommend you do not use any KDE applications
with fvwm that cause you trouble (or you could switch
completely to KDE).
 
> iconify as well, is there away around this???

That is because of the stupid naming scheme of kedit.  Under X,
every window has a name (which is "kedit"), a resource name
(also "kedit") and a class name (also "kedit").  When you
create a style "kedit", this applies to all windows with a
matching name, class or resource.  Unfortunately all kedit
sub windows get the resource and class "kedit", so your
style applies to all su windows also :-P  Possible solutions
are:

 1) Give the main kedit window and the style a different name.
    No idea how to do this since KDE traditionally comes without
    any usable command line documentation.
 2) Explicitly disable the StartIconic style for the sub windows:

      Style Open StartNormal
      Style "Select Font" StartNormal
      ...
    This would only be a last resort since you have to list all
    window names manually.

> How then do I load kedit in a windows position that I

I have no idea. kedit seems to ignore user preferences completely.
There is always the possibility to use FvwmEvent to move the newly
mapped window (try "man FvwmEvent).  Perhaps someone can provide
a sample config.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Oct 2000 23:21:23 +0200

> mapped window (try "man FvwmEvent).  Perhaps someone can provide

This is in the FVWM FAQ, question 3.18: http://fvwm.org/generated/FAQ.html
Of course, FAQ only accompanies a man page, not replaces it.

Regards,
Mikhael.