Subject: Re: FVWM: FVWM 2.2.4 vs Rational Rose (Solaris)

From: Raymond Toy <[email-masked]>
Date: 01 Sep 2000 08:31:41 -0400

>>>>> "Mikhael" == Mikhael Goikhman <[email-masked]> writes:

    Mikhael> On 28 Aug 2000 10:52:28 -0400, Raymond Toy wrote:

    >> Hmm, this is weird.  When I run it under dtwm, xwininfo says Override
    >> Redirect State: no.  I wonder how rose knows how to set this?  Can
    >> rose figure out what window manager is running?  Note that I start
    >> dtwm and fvwm both via startx.  The only difference is that I set
    >> USE_CDE=yes to choose dtwm instead of fvwm

    Mikhael> Probably your application can know about dtwm running by USE_CDE or other
    Mikhael> dtwm-documented methods (X Atoms?).

I'm know just about zero about X.  What are X Atoms?  USE_CDE is some
shell variable I made up for my own use.  The only variable that seems
to get set (at least in shells) is DTDATABASESEARCHPATH.  I tried this
and it made no difference.  Oh well, more hunting.

    >> Is there a way to tell FVWM to ignore this hint for a window anyway?

    Mikhael> No, fvwm simply is not notified by X Server about such windows.
    Mikhael> Some info in: http://www.hpc.uh.edu/fvwm/archive/9903/msg00958.html

    >> I don't want to use dtwm, so any hints on getting this to work with
    >> FVWM would be most appreciated.  (I'm too lazy to switch, and I like
    >> fvwm.) 

    Mikhael> You can use "BugOpts RaiseOverUnmanaged on" in the betas to improve the
    Mikhael> situation, but the real solution is to ask the app authors to fix it.

Does this allow me to lower a window underneath an unmanaged window?
If not, then this doesn't really help either.

I'll ask support to see if they can tell me how rose determines how to
set override redirect.

Thanks for you suggestions,

Ray
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 4 Sep 2000 19:15:01 +0200

On Fri, Sep 01, 2000 at 08:31:41AM -0400, Raymond Toy wrote:
> I'm know just about zero about X.  What are X Atoms?

You can think about X Atoms as variables stored on the X Server that
all clients can read.  dtwm certainly sets a few custom Atoms that
applications can read to detect that they are running under CDE.

> If not, then this doesn't really help either.

With this option turned on you still can not access the unmanaged window
in any way, but you can raise managed windows above it or lower them
below it. 

> I'll ask support to see if they can tell me how rose determines how to

I bet Rational sells their products as "CDE only" and they do not
care about the conventions that apply to any X applications.  Thus,
if they do not detect CDE, they simply make the window "override
redirect" and control it themselves.  This violates the X conventions
for client behaviour (the ICCCM2) and makes their programs virtually
unusable on any other setup.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Raymond Toy <[email-masked]>
Date: 05 Sep 2000 09:09:33 -0400

>>>>> "Dominik" == Dominik Vogt <[email-masked]> writes:

    >> I'm know just about zero about X.  What are X Atoms?

    Dominik> You can think about X Atoms as variables stored on the X Server that
    Dominik> all clients can read.  dtwm certainly sets a few custom Atoms that
    Dominik> applications can read to detect that they are running under CDE.

Ok, I'll try to see what Atoms dtwm sets.

    >> If not, then this doesn't really help either.

    Dominik> With this option turned on you still can not access the unmanaged window
    Dominik> in any way, but you can raise managed windows above it or lower them
    Dominik> below it. 

Well that's good enough for what I want.  The Rose window already
comes "predecorated" with window manager buttons exactly like Windows
95, so I can iconify it as needed.  I just need to raise and lower
windows over it.  (Well, I can always iconify it, but that's a pain.)

    >> I'll ask support to see if they can tell me how rose determines how to

    Dominik> I bet Rational sells their products as "CDE only" and they do not
    Dominik> care about the conventions that apply to any X applications.  Thus,
    Dominik> if they do not detect CDE, they simply make the window "override
    Dominik> redirect" and control it themselves.  This violates the X conventions
    Dominik> for client behaviour (the ICCCM2) and makes their programs virtually
    Dominik> unusable on any other setup.

Certainly sounds like it.  It's unfortunate.  I hope it's an oversight
since their other applications (Clearcase, Soda) don't suffer from
this affliction.

Thanks for you help,

Ray