Subject: FVWM: fvwm2.3.17 problems still in 2.3.21

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 4 Sep 2000 15:56:05 -0700 (PDT)

running xview tools...

clicktofocus: window w/ focus loses focus while mouse over root.

This bug has always been broken, but a patch exists and is only half
implemented.

the missing patch to events.c ...

change the appropriate line to add the NumberOfScreens check.

if (ewp->window == Scr.Root && Scr.NumberOfScreens > 1)

================================

Clicking on another window has ambiguous change of focus.
This started w/ 2.3.17

Normally, in xview, a black focal point indicates that window has focus.
A grey point indicates where the focal point is, but window doesnt actually have the focus.

In 2.3.21, the first click removes focus from the previous window (leaving a
grey focal point) and sets a grey focal point in new window, leading me to
believe it doesnt have focus yet. At that point, i cant actually tell which
window has it till i start typing.

A 2nd click in the window will result in the black type-in point.
This problem didnt exist in 2.3.16.

Thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Sep 2000 22:23:10 +0200

> if (ewp->window == Scr.Root && Scr.NumberOfScreens > 1)

I think I have made some progress on this one too.  As I
mentioned before, the fix was very broken and only cured
the symptoms.  Playing with textedit w/ ClickToFocus I
noticed this:

 1) Style * ClickToFocus

 2) Open two windows (any non-xview windows will do) and
 a textedit window.

 3) Click in one of the non-textedit windows to focus it.

 4) Click inside the textedit window until it accepts focus.

 5a) Move the mouse over the root window
 or
 5b) Move the mouse over the window that had the focus before.

==> The textedit window loses focus.

This does not happen if you move the mouse over the other
window that did not have focus before.

Elliot, is this what you mean?

I am poking around to see if I can do something about it.
Probably we can fix (5b), but perhaps we can not prevent
the textedit window from releasing focus in case of (5a).

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Sep 2000 22:59:54 +0200

> clicktofocus: window w/ focus loses focus while mouse over root.

As promised I have made a patch.  I was not able to reproduce
focus loss when entering the root window, but the patch fixes
focus loss over the previously focused window.  Elliot, please
try this patch, and if any problems persists, try to describe
them as detailed as possible.

Bye

Dominik ^_^  ^_^