Subject: RE: FVWM: fvwm installation;

From: Farhad Jalilvand <[email-masked]>
Date: Fri, 18 Aug 2000 09:44:09 -0700

Here is my command line from exceed client starter:

/home/fjalilva/fvwm-2.2.4/fvwm/bin/fvwm2 -display @d &

This is the host reply from exceed dialog box before I get a "Connection
Closed(closed timeout)"

stty: : Invalid argument
[1] 9228
[FVWM][executeModule]: <<ERROR>> No such module 'ClickToFocus' in ModulePath
'/usr/local/libexec/fvwm/2.2.4'
[FVWM][executeModule]: <<ERROR>> No such module 'FvwmAuto' in ModulePath
'/usr/local/libexec/fvwm/2.2.4'
[FVWM][executeModule]: <<ERROR>> No such module 'FvwmButtons' in ModulePath
'/usr/local/libexec/fvwm/2.2.4'

Your help is appreciated? Thanks!

Farhad

-----Original Message-----
From: Erik Steffl [mailto:[email-masked]]
Sent: Wednesday, August 16, 2000 6:19 PM
To: Farhad Jalilvand
Cc: [email-masked]'
Subject: Re: FVWM: fvwm installation;

  the way I do it:

  don't include anything on the unix side,

  on windows NT side do the following

  configure exceed like this:

  in configuration, screen definition:
    window mode: single
    root size: full screen

  create Xstart for fvwm, I use following command line:

/export/home/users/esteffl/local/bin/fvwm2 -display @d &

  (exceeds replaces @d by its display (=you workstation ip + ':.0.0')

  create Xsession
  include above Xstart in Xsession,

  you can create more Xstart files for otgher clients that you want to
start and include them in Xsession...

  start exceed by running the created x session (that's not fundamental
for fvwm usage, I just find it convenient)

	erik

Farhad Jalilvand wrote:
> 
> Any idea how I can start FVWM on Win NT with Hummingbird (Exceed)? Please
> see below for details...
> 
> Thanks,
> Farhad
> 
> -----Original Message-----
> From: Farhad Jalilvand
> Sent: Friday, August 11, 2000 5:27 PM
> To: [email-masked]
> Subject: RE: FVWM: fvwm installation;
> 
> Hi there,
> 
> I have installed the FVWM in my home directory and want to launch it using
> Exceed version 5.1.3.0.
> 
> I have also created a .xinitrc in home directory with the following
content:
> =============
> #! /bin/csh -f
> # .xinitrc
> #
> # REVISIONS:
###########################################################################
> 
> fvwm2 &
> ===========
> 
> Any help is very much appreciated.
> 
> Thanks
> Farhad
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Fri, 18 Aug 2000 10:06:26 -0700

you need to set the ManPath in your .fvwm2rc to point to where the
modules are (or don't use modules).

  if you're at loss as to where the modules are, try:

  locate FvwmAuto

  if that does not help, try (it will probably take long time (few
minutes)):

  find / -name FvwmAuto -print > find.log
  cat find.log

	erik

---

From: Dan Espen <[email-masked]>
Date: Fri, 18 Aug 2000 13:33:37 -0400

>   you need to set the ManPath in your .fvwm2rc to point to where the

Erik means ModulePath.

> modules are (or don't use modules).
...
> > /home/fjalilva/fvwm-2.2.4/fvwm/bin/fvwm2 -display @d &

Looks OK, but I don't think you need the trailing ampersand.

> > This is the host reply from exceed dialog box before I get a "Connection

In my experience, you get this when Exceed never sees the prompt string
that it waits for after running your profile.  (Assuming you are using the
"rlogin" method of connection.

However, since it ran your command, I think it did see the prompt string.

> > stty: : Invalid argument

Something in your profile attempted to execute the "stty" comamnd.
It should only do this when the shell is interactive.  Like this:

case $- in
*i*)    #interactive shell
  stty ...
esac

> > [1] 9228
> > [FVWM][executeModule]: <<ERROR>> No such module 'ClickToFocus' in ModulePat

Look for a syntax error in your .fvwm2rc containing ClickToFocus.

> > [FVWM][executeModule]: <<ERROR>> No such module 'FvwmAuto' in ModulePath

These are related to your ModulePath.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Fri, 18 Aug 2000 10:45:44 -0700

> >   you need to set the ManPath in your .fvwm2rc to point to where the

  :-) you're reading my mind! yes, of course I mean ModulePath, sorry
for confusion...

	erik