Subject: Re: FVWM: Starting programs on different pages

From: Frank Derichsweiler <[email-masked]>
Date: Thu, 10 Aug 2000 07:08:12 +0200

On Wed, Jul 26, 2000 at 04:32:17PM -0400, Dan Espen wrote:
> 
> Frank Derichsweiler <[email-masked]> writes:
> > Hi fvwm-User,
> > 
> > I would like to start applications on different pages during start up
> > of fvwm 2.2.4.
> > I tried the following in my .fvwm2rc
> > AddToFunc InitFunction
> >  +      "I"     GotoPage 0 0
> >  +      "I"     Exec <FirstApplication>
> >  +      "I"     Exec <SecondApplication>
> >  +      "I"     GotoPage 0 1
> >  +      "I"     Exec <ThirdApplication>       
> > 
> > Unfortunately it does not work. All apps are started on page 0 1. How
> > can I do that? 
> 
> In the latest Betas we have better ways to do this, but
> this worked for me:

Hi Dan,

Can you please elaborate the better ways in the beta. I downloaded
2.3.20 and read the man page / faq but I did not find a new method.
A pointer is just fine.

TIA
Frank

> 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
> Piscataway, NJ 08854                     Phone: (732) 699-5570
---end quoted text---

-- 
Frank Derichsweiler 
University of the German Federal Armed Forces
Department of Computer Science - Institute for Software Technology
Public Key at http://ist.unibw-muenchen.de/People/deri/FD.publickey
Fingerprint C10F 2E9E 7457 3E6B 6C26 AD24 D632 4FE8 2D4A 7500
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Wed, 9 Aug 2000 22:13:51 -0700

> 2.3.20 and read the man page / faq but I did not find a new method.

Look into StartsOnPage/StartsOnDesk, as well as various Placement
options and the SkipMaping Style. The manpage entries and the FAQ
should get you going.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
You pay for what you get, but you might not get what you pay for.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frank Derichsweiler <[email-masked]>
Date: Fri, 11 Aug 2000 13:55:38 +0200

On Wed, Aug 09, 2000 at 10:13:51PM -0700, Michael Han wrote:
> options and the SkipMaping Style. 
Thanks for that tip, but AFAIK affect those options all programs which
have the named window label.
E.g. Setting a StartsOnPage for Netscape means that Netscape will
always start on that page. My apps have one instance which has to be
started during the startup of my fvwm session, but another instance
can be started later within the fvwm session, this instance should
stay on the actual page and not on that for the former one. 
OK, I can change the window label specially for the first instance,
but I do not like that.

Frank

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 15 Aug 2000 13:57:33 +0300

> OK, I can change the window label specially for the first instance,

There is one more solution, not using GotoPage or StartsOnPage.
Use the following or similar function to start your specific app.

AddToFunc StartNetscape
+ I Exec exec netscape
+ I Wait Netscape
+ I Next (Netscape) MoveToPage 0 1

This should solve your problem without switching pages. It's also possible
to use None and an additional function if you want even more complex logic.

Regards,
Mikhael.