Subject: Re: FVWM: window background color

From: robert_wilhelm_land <[email-masked]>
Date: Fri, 18 Aug 2000 17:02:54 +0200

Vivek wrote:

> Typically: /usr/X11R6/lib/X11/rgb.txt
>
> It should be mentioned in your XF86Config file:
> [ /etc/X11/XF86Config, /usr/X11R6/lib/X11/XF86Config /etc/XF86Config
>   it depends on your system ]

I found this file - and puh, what a amount of colors!
The only file mentioned in  /usr/X11R6/lib/X11/XF86Config.eg or
/etc/X11/XF86Config is rgb (not the txt version)

> 'locate rgb.txt' should tell you where it is, assuming updatedb has been
> run at some point. You should run updatedb regularly. updatedb and locate
> are your friends :)

"locate" is indeed my best friend, wouldn't know what to do without this tool.

How do I set other parameters like a smaller window width on a Xterm startup? -
the XF86Config file doesn't seem to control that. I looked at the fvwm2 config
files and searched for everything containing a "width" or a "height" but found
nothing responsable for these settings.

Additionally I replaced twm with fvwm2 in the VNC ~/xstartup script and
everytime now VNC is launched with "vncserver" on the terminal before starting
X11,  the program parsing the fvwm2 configuration file seems to go into a
endless loop and I have to Crtl+c to get a prompt again.

Would be awful nice if someone would help with this.

Robert

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: dbarber <[email-masked]>
Date: Fri, 18 Aug 2000 11:19:30 -0400 (EDT)

Robert,

To start xterm with a different geometry, use xterm -geometry +50+50x40x80

The +50+50 tells it where to start on your window manager and the x40x80
tells it what size to be.

Most options specific to a programs settings are controlled by the
individual program.  You can use "xterm -h" or "xterm -" or, of course,
"man xterm" to see those options. 

Dan

---

From: Vivek <[email-masked]>
Date: Fri, 18 Aug 2000 16:21:55 +0100 (BST)

On Fri, 18 Aug 2000, robert_wilhelm_land wrote:

> How do I set other parameters like a smaller window width on a Xterm
> startup? - the XF86Config file doesn't seem to control that. I looked
> at the fvwm2 config files and searched for everything containing a
> "width" or a "height" but found nothing responsable for these
> settings.

If you just want to control the xterms started from menus, you should
change your WM config, but I'm guessing you knew that: typically this sort
of thing is controlled by x resources: [see man xrdb]
 
typically you want a command something like 

xrdb -merge ~/.Xresources

somewhere in your startup. [Xresources are [I believe] a property of the
X display itself, so xrdb must have access to a valid display to work:
this is automatically Ok in x clients and .xinitrc/.xsession]

Here's a selection from my .Xresources file: [! introduces a comment]
Netscape*fileSelector.pattern:  *
YTalk.reverse:  true
YTalk.font:     7x14
Xless*customization: -color
Xless*sizeToFit: true
vt100*activeIcon:       TRUE
xterm*activeIcon:       TRUE
xterm*colorBDMode:      FALSE
xterm*colorBLMode:      FALSE
xterm*colorULMode:      FALSE
!Emacs*pane.menubar.background: #000000
!Emacs*pane.menubar.foreground: #0088aa

The man page for each particular app should explain what resources the app
understands. I think you want 

xterm*geometry: 80x25

or similar

-- 
"I don't want to go to the movies to be horrified and depressed."
"No, I suppose you've got real life to do that."

---

From: Michael Han <[email-masked]>
Date: Fri, 18 Aug 2000 08:27:28 -0700

On Fri, Aug 18, 2000 at 05:02:54PM +0200, robert_wilhelm_land wrote:
> How do I set other parameters like a smaller window width on a Xterm startup?

Well, you're referring to the window geometry. Look at the manpage for
xterm. There are standard toolkit options that most programs accept,
such as -bg, -fg and -geometry. A useful book is O'Reilly's X Window
System in a Nutshell.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
"I will not be a snickerpuss." - Lisa
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tenebrae <[email-masked]>
Date: Fri, 18 Aug 2000 18:52:42 -0700 (PDT)

> endless loop and I have to Crtl+c to get a prompt again.

Hmmm...
I always launch vncserver from an Eterm (after I've started X).
My vncserver xstartup file reads like this:

[tenebrae@pointy .vnc]$ cat xstartup
#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -bg black -fg LightGrey -ls -title
"$VNCDESKTOP Desktop" &
fvwm2

I've never had a problem with it, except trying to figure out how to get
my starting xterm to have reverse video enabled!  I finally gave up and
just set the background and foreground colours.
I also dunno what the xrdb $HOME/.Xresources line is for (I can't find one
anywhere).  Oh well...at least it works.
								-Tenebrae.