Subject: FVWM: triangle in sub-menu

From: Keith Kaple <[email-masked]>
Date: Thu, 10 Aug 2000 12:14:12 -0400

What command colors the triangle for submenus?

____________
|           |
|           |
|           |
|           |
|       ->__|___
|_________|_|   |
          |     |
          |     |
          |     |
          -------

I have black menus and the arrow isn't visible, not sure how to change this...

 COLORS and FONTS
# Set the fore and back border colors for the window that has focus
HilightColor            black  "cornflower blue"
# Set fore/back border colors for all other windows
Style "*" Color white/DimGrey
#Style "xcpu"  Color white/blue
# Style "*term"  Icon xterm.xpm
Style "*"      Icon missing.xpm
MenuStyle * Foreground Orange, Background Black
MenuStyle * ActiveFore green, Font lucidasanstypewriter-12
WindowFont lucidasanstypewriter-12
IconFont lucidasanstypewriter-12

Style "*"          IconBox -200 -700 -1 -200
#Style "*" NoIcon
# If you want ALL icons to follow you around the desktop (Sticky)
Style "*" StickyIcon
# FOCUS Setup
#
ColormapFocus FollowsFocus
Style "*term"           SloppyFocus

thanks
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 Aug 2000 22:29:41 +0300

> What command colors the triangle for submenus?

I guess you use 2.2.4, please always specify your fvwm version.
The triangle is constructed as a 3d relief unless you use TrianglesSolid.
In 2.2 versions the shadow and hilight colors of a black background are
black (just like GTK does it by default), so the triangle is invisible.

In the latest betas the default triangle for a black background is
visible, and its exact colors can be specified using colorsets.

Regards,
Mikhael.