Subject: Re: FVWM: window background color

From: robert_wilhelm_land <[email-masked]>
Date: Sat, 19 Aug 2000 18:59:46 +0200

dbarber wrote:

> Robert,
>
> To start xterm with a different geometry, use xterm -geometry +50+50x40x80
>
> The +50+50 tells it where to start on your window manager and the x40x80
> tells it what size to be.
>
> Most options specific to a programs settings are controlled by the
> individual program.  You can use "xterm -h" or "xterm -" or, of course,
> "man xterm" to see those options.

Thanks for all helping me.

One main thing I learned now was that programs define their window parameters in
their own conf files.
Xterm however really confuses me, of course I can start xterm with the "-geometry"
option and I did so in the popupmenu file fvwm2 uses - but contrary to  the color
option I placed in the ~/Xdefaults file, the geometry option was not noticed (didn't
even cause an error).

There's one file which looks like a configuration file which I'm rather hesitating to
edit, /usr/X11R6/lib/X11/etc/xterm.terminfo. The settings there are looking quite
cryptic. Anyone familiar with this file?

Unfortunatly my system seems only to use the ~/.Xdefaults file, no Xresources file in
any home directory. As far as I have understood "man xrdb" correctly (there's one
nice URL http://www.tronche.com/gui/x/xlib/resource-manager/), thanks to Richard for
providing the really helpful URL http://www.rahul.net/kenton/xsites.html , Xresources
is only optional and extends rather Xdefaults.

When fvwm2 loads , it places two xterms right at the beginning which have a different
size than just launching a xterm by command. The only line which could be responsable
seems to be in system.fvwm2rc.m4-2:

# RLOGIN machine fg bg
AddToFunc RLOGIN "I" Exec xterm -fg $1 -bg $2 -e rlogin $0 -8
- but no size parameters used there ...

Any further help would be nice

Robert

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: dbarber <[email-masked]>
Date: Sun, 20 Aug 2000 13:02:00 -0400 (EDT)

It's possible your xinitrc file is starting those other xterms.  xinitrc
is where I place all of my commands for starting programs at X
startup.  The default location on slackware is: 
/var/X11R6/lib/xinit/xinitrc

check for a .xinitrc in your home directory too.  

Dan

---

From: Tenebrae <[email-masked]>
Date: Sun, 20 Aug 2000 13:56:57 -0700 (PDT)

> check for a .xinitrc in your home directory too.  

My ~/.xinitrc merely contains the line, "fvwm2".  That's all.  Nothing
else.
Oh, duh.  Silly me.
I found where to set reverse video.  I was doing it right, but I forgot to
capitalize the T in XTerm!  Picky, picky, picky...
*blink*  Don't you hate it when you're in Pine (or worse, a POP
client) and you try to save/send an e-mail message by typing :wq?  
I need a vacation...heh
								-Tenebrae.