Subject: FVWM: meta-key doesn't work with Num-Lock on

From: [email-masked]
Date: Thu, 10 Aug 2000 18:21:25 -0700

Hi
My Meta key (CTRL) doesn't work when Num Lock is turned on. 
For instance I am not able to move between virtual desktops with
ctrl-arrow.
And when I try to use ctrl-S in nedit (save file) I get a <dc3> instead,
and a <etb> when punching ctr-w (close).

Is this a problem with fvwm?
I run redhat 6.2 on a P2. The keyboard is standard IBM-style Keytronic.
It has a converter from 5 pin DIN to PS2 to fit the machine.

/riccardo
__
email: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Louis LeBlanc <[email-masked]>
Date: Fri, 11 Aug 2000 08:20:29 -0400

What are the modifiers on your mouse definitions?
I am using A, which means that wether the num lock is up or down, it works
the
same.  Here is the section defining mouse clicks on the root window
(context R)
from my .fvwm2rc:

############################################################################

# MOUSE Setup
#
# First, the root window. Button 1 brings up the Main Menu. B2 is the
# window operations list, and B3 is the winlist module
#     Button    Context Modifi  Function
Mouse 1         R       A       Menu RootMenu Nop
Mouse 2         R       A       Menu Window-Ops Nop
Mouse 3         R       A       WindowList UseIconName NoGeometry

This causes the function to be called regardless of the modifier (CTRL,
Shift,
NumLock, etc).  If you have seperate function for shift-button1, and
button1
without a modifier, just make 2 entries for each function.  One would have
just
the modifier you want (like C for ctrl), the other would have the modifier
and
3 (like C3).
Look at another section for keys that I use:

############################################################################

# KEYBOARD Setup
#
# press arrow + control anywhere, and scroll by 1 page
Key Left        A       C       Scroll -100 +0
Key Right       A       C       Scroll +100 +0
Key Up          A       C       Scroll +0   -100
Key Down        A       C       Scroll +0   +100
Key Left        A       C3      Scroll -100 +0
Key Right       A       C3      Scroll +100 +0
Key Up          A       C3      Scroll +0   -100
Key Down        A       C3      Scroll +0   +100

This is used to scroll to other pages within a desktop.  The 'duplicate'
definitions allow the same functionality in the event the NumLock is on.

Regards
Lou

--
Louis LeBlanc - Software Engineer - Mirror Image Internet, Inc.
http://www.mirror-image.com       [email-masked]
Phone: 781.376.1186                            Fax:781.376.1110

---

From: [email-masked]
Date: Sat, 12 Aug 2000 10:50:56 -0700

Hi Louis
I'm not sure I understand your solution. The mouse works fine whether
NumLock is on or off. 
I also noticed that the arrows on the numeric pad don't work when
NumLock is off. Below I attach my key and mouse bindings.
/r.

####################### Keyboard bindings
###############################
Key Tab	A	M	Next [*] focus
Key Tab	A	C	Prev [*] focus
Key Left	A	M	Scroll -100 0
Key Up		A	M	Scroll +0 -100
Key Right	A	M	Scroll +100 +0
Key Down	A	M	Scroll +0 +100
Key Left	A	C	Scroll -100 0
Key Up		A	C	Scroll +0 -100
Key Right	A	C	Scroll +100 +0
Key Down	A	C	Scroll +0 +100
Key Left	A	C3	Scroll -100 0
Key Up		A	C3	Scroll +0 -100
Key Right	A	C3	Scroll +100 +0
Key Down	A	C3	Scroll +0 +100
Key Left	A	SC	Scroll -10 +0
Key Right	A	SC	Scroll +10 +0
Key Up		A	SC	Scroll +0   -10
Key Down	A	SC	Scroll +0   +10
#Key Left	A	SC	CursorMove -1 0
#Key Right	A	SC	CursorMove +1 +0
#Key Up		A	SC	CursorMove +0   -1
#Key Down	A	SC	CursorMove +0   +1
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10
Key KP_F1	A	M	Popup "Workplace"
Key KP_F2	A	M	Popup "Window-Ops"
Key KP_F3	A	M	Module FvwmWinList 
Key KP_F4	A	M	Iconify
Key F5	A	M	Move        100p 100p
Key F6	A	M	Resize   10 10
Key F10 	A	A	Next [CurrentDesk rxvt]Focus
Key F11 	A	A	Prev [CurrentDesk rxvt]Focus
Key F15		FTIWS	A	Raise

# Mouse Settings
Mouse 1	R   	A       WindowList
Mouse 2	R    	A      	Menu Window-Ops Nop
Mouse 3	R    	A      	Menu Workplace Nop
Mouse 0	1    	A      	Menu Window-Ops2 Close
#Right side buttons on title bar
Mouse 0 2 	A 	Close
Mouse 0	4    	A     	Maximize-Func
Mouse 0	6    	A     	Iconify

Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	A	Move-or-Raise
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops Nop
Mouse 3	TSIF	A	RaiseLower

-------------------
Riccardo Bommarco | [email-masked]

---

From: Louis LeBlanc <[email-masked]>
Date: Mon, 14 Aug 2000 12:11:25 -0400

I understand your problem now.  Are you sure you don't have both a control and
meta key?  On my keyboard, the ALT key is the meta key.  On Sun keyboards, it is
the one with the little diamond.
But that isn't the problem.
I noticed you have the left, right, up, and down keys to scroll a whole page if
the control key is used, wether or not the numlock is down.  You also have them
set to scroll a page if the meta key is used, but not if the num lock is down.
If you duplicate the following lines:
Key Left        A       M       Scroll -100 0
Key Up          A       M       Scroll +0 -100
Key Right       A       M       Scroll +100 +0
Key Down        A       M       Scroll +0 +100

Like this:
Key Left        A       M3       Scroll -100 0
Key Up          A       M3       Scroll +0 -100
Key Right       A       M3       Scroll +100 +0
Key Down        A       M3       Scroll +0 +100

then you should have no problem.

As for the <CTRL>S - <CTRL>W problem in nedit, I'm afraid I can't explain it.
You might want to see if there is a newer version of nedit available, though
I doubt a bug that fundamental would make it to any release.
I don't know of any way to bind the CTRL key in any context, but if you do have
your CTRL and META keys switched, that might explain it.

Hope this helps.
Lou