Subject: FVWM: .fvwm2rc and Styles for childs - userspecified

From: "Wolfgang Fritzsche" <[email-masked]>
Date: Thu, 17 Aug 2000 12:45:50 +0200

Hi,

first of all I have to say Thnaks for the active discussion of the desktop security by blocking mouse or keyboard.
Now solved it on another way by my running programm wich doesn't react to users keystrokes until there is "permission".

the .fvwm2rc file could by different for every user, e.g. /home/user/.fvwm2rc ??? or are the settings global?

a style specified for a Windowname and all of his childs works like:

Style "myapp" something,....
Style "myapp-2" something,..
Style "myapp-3" something,...

where myapp-2/3 are the childs from myapp ???

Thanks

---

From: "Wolfgang Fritzsche" <[email-masked]>
Date: Thu, 17 Aug 2000 13:20:59 +0200

in the users home directory .fvwm2rc works-  just tried  :-))

the other problem I'm still fighting with the manuals
  -----Ursprüngliche Nachricht----- 
  Von: Wolfgang Fritzsche 
  An: Fvwm 
  Gesendet: Donnerstag, 17. August 2000 12:45
  Betreff: FVWM: .fvwm2rc and Styles for childs - userspecified

  Hi,

  Thanks

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 1 Sep 2000 01:36:08 +0200

> where myapp-2/3 are the childs from myapp ???

I don't think I fully understand your question.

Every window (son or uncle) has its own name, resource name and class.
All three names can be used for the first parameter of the Style command.
To determine the window names, execute FvwmIdent on the window.
For example, press Shift-Mouse3 on the window title after the binding:

  Mouse 3 T S FvwmIdent

In case some windows have similar names, you can use a patern, like:

  Style "myapp*" StyleOption1, StyleOption2...

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].