Subject: FVWM: num lock on... root menus off... why?

From: greg shebert <[email-masked]>
Date: Wed, 23 Aug 2000 15:25:21 -0500

hi there

one of my users had num lock on today and the window manager seemed to
be disregarding all keyboard input and mouse button input...

is there something special that i have to put into my fvwm2rc file to
make sure that the root mouse menus work even when numlock is on?
-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Todd T. Fries" <[email-masked]>
Date: Wed, 23 Aug 2000 15:50:51 -0500

think of the numlock as an alt key.  It is a modifier.  And most of the
sequences are specific to a set of modifiers with the numlock off.

If you wish to have the same behavior with and without the numlock, then
simply duplicate all keybindings and have the 2nd set react when the nulock is
set.

-- 
Todd Fries .. [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Aug 2000 16:56:08 -0400

> > make sure that the root mouse menus work even when numlock is on?

Check the FAQ for more details.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Vivek <[email-masked]>
Date: Thu, 24 Aug 2000 10:49:49 +0100 (BST)

> make sure that the root mouse menus work even when numlock is on?

Num lock is a modifer. xmodmap will tell you which one, eg:

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40)
mod2        Num_Lock (0x4d)
mod3        Mode_switch (0x71)
mod4        Super_L (0x73),  Super_R (0x74)
mod5        Scroll_Lock (0x4e)

You can `xmodmap -e 'clear Mod2'`, but that will disable num lock, or you
can duplicate all your key/mouse bindings with and without Mod2 (tedious).
I believe the latest betas have an IgnoreModifier thingy you can also use.

-- 
"They're unfriendly, which is fortunate, really.  They'd be difficult
to like."
                -- Avon