Subject: Re: FVWM: window background color

From: robert_wilhelm_land <[email-masked]>
Date: Tue, 22 Aug 2000 13:44:53 +0200

Richard Lister wrote:

> Do a find for Xclients or .Xclients. You may have one in ~ or in
> somewhere like /etc/X11/xinit/Xclients.

Only a sample.Xclients file on the hdd. The distribution I'm using didn't configure this kind of file to the system.
You asked for the distr.:
It is a 2.0.35 distribution from "DLD", in the meantime bought by RedHat. After reading some magazines I get the
impression that this distribution is quite nearby to the old 5.x RedHat distr. The configuration files and scripts
are quite like the ones used by RedHat.

> Actually, your best bet
> is to poke around in /usr/X11R6/lib/X11 or similar and figure out
> what scripts do what. Tell me your OS and whether you run xdm or
> xinit or startx and I can probably give you more direct help.

This is one thing I would like to ask you. The system is set to runlevel 3. When logging as root I start X11 on the
commandline via "startx". Contrary when logging in as a user I get a messagebox in a VGA screen"Would you like To
start the X11 system?" followed by yes/no buttons  - althought the entries in /etc/inittab explictly require runlevel
3!
I therefor cannot judge by what X11 is started. Which files can be responsable for this behaviour?

> Most X apps use geometry to set size in pixels. Xterm does it
> in characters, so the following:
>
>   XTerm.vt100.geometry:           80x48
>
> sets an xterm 80 chars wide and 48 high. It should change size if
> it changes font.
>
> The vt100 widget is the one where the text appears. Xterm also does
> tektronix emulation but noone uses that anymore. The widgets for
> menus are vtMenu, fontMenu and mainMenu.

Grepping all files in /usr/XLLR6 for "xterm" gave a vast amount of files.
- But I would like to remind of the file /usr/X11R6/lib/X11/etc/xterm.terminfo.  Would you concern, would you like to
have a look at this file?

There's one thing which I would really like to solve, how do I know in which order all those scripts are loaded - is
there a file which lists like /var/log/messages ?

I wouldn't like to bother the people here in this newsgroup with a topic that is only near to fvwm and doesn't
concern fvwm directly - so please let me know - Richard - would you like to handle this via email?

Thanks for your patience

Robert

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Tue, 22 Aug 2000 08:48:00 -0400 (EDT)

>have a look at this file?

I don't think this is what you're looking for.  Just a wild shot, check
the file /usr/X11R6/lib/X11/app-defaults/XTerm or anything like it for
geometry information.

Tom