Subject: RE: FVWM: fvwm installation;

From: Farhad Jalilvand <[email-masked]>
Date: Fri, 18 Aug 2000 11:20:26 -0700

I am still have the same problem after including the path for modules. Here
is my top portion of my .fvwm2rc file.
=======================================

# Configuration file for FVWM2 2.0.44/45
#
# Auto-generated by the Fvwm2 Dotfile Module (version 1.1)
# Mon Jun  5 09:29:14 PDT 2000
#
 
#---------->Search Paths<----------
#FJ: commented out^M
# Search paths for icons and modules.
#IconPath       /usr/share/X11common/icons:/usr/share/X11common/icons
#PixmapPath     /usr/share/X11common/icons:/usr/share/X11common/icons
ModulePath /home/fjalilva/fvwm-2.2.4/modules
===================================

and here is what's in the following directory:
/home/fjalilva/fvwm-2.2.4/modules

> ls fvwm-2.2.4/
AUTHORS        Makefile       acconfig.h     config.h.in    configure~*
install-sh*    sample.fvwmrc/ 
COPYING        Makefile.am    acinclude.m4   config.log     docs/
libs/          stamp-h        
ChangeLog      Makefile.in    aclocal.m4     config.status* extras/
missing*       stamp-h.in     
INSTALL        NEWS           config.cache   configure*     fvwm/
mkinstalldirs* tests/         
INSTALL.fvwm   README         config.h       configure.in   icons/
modules/       utils/         
> ls fvwm-2.2.4/modules/
ChangeLog      FvwmAuto/      FvwmButtons/   FvwmForm/      FvwmIdent/
FvwmRearrange/ FvwmScroll/    Makefile 
FvwmAnimate/   FvwmBacker/    FvwmCpp/       FvwmIconBox/   FvwmM4/
FvwmSave/      FvwmTalk/      Makefile.am 
FvwmAudio/     FvwmBanner/    FvwmEvent/     FvwmIconMan/   FvwmPager/
FvwmSaveDesk/  FvwmWinList/   Makefile.in 
> ls fvwm-2.2.4/modules/

Thanks,
Farhad

-----Original Message-----
From: Dan Espen [mailto:[email-masked]]
Sent: Friday, August 18, 2000 12:34 PM
To: Farhad Jalilvand; [email-masked]'
Subject: Re: FVWM: fvwm installation; 

Erik Steffl <[email-masked]> writes:
>   you need to set the ManPath in your .fvwm2rc to point to where the

Erik means ModulePath.

> modules are (or don't use modules).
...
> 	erik
> 
> Farhad Jalilvand wrote:
> > 
> > Here is my command line from exceed client starter:
> > 
> > /home/fjalilva/fvwm-2.2.4/fvwm/bin/fvwm2 -display @d &

Looks OK, but I don't think you need the trailing ampersand.

> > This is the host reply from exceed dialog box before I get a "Connection
> > Closed(closed timeout)"

In my experience, you get this when Exceed never sees the prompt string
that it waits for after running your profile.  (Assuming you are using the
"rlogin" method of connection.

However, since it ran your command, I think it did see the prompt string.

> > stty: : Invalid argument

Something in your profile attempted to execute the "stty" comamnd.
It should only do this when the shell is interactive.  Like this:

case $- in
*i*)    #interactive shell
  stty ...
esac

> > [1] 9228
> > [FVWM][executeModule]: <<ERROR>> No such module 'ClickToFocus' in
ModulePat

Look for a syntax error in your .fvwm2rc containing ClickToFocus.

> > '/usr/local/libexec/fvwm/2.2.4'
> > [FVWM][executeModule]: <<ERROR>> No such module 'FvwmAuto' in ModulePath

These are related to your ModulePath.

> > '/usr/local/libexec/fvwm/2.2.4'
> > [FVWM][executeModule]: <<ERROR>> No such module 'FvwmButtons' in
ModulePath
> > '/usr/local/libexec/fvwm/2.2.4'
> > 
> > Your help is appreciated? Thanks!
> > 
> > Farhad
> > 
> > -----Original Message-----
> > From: Erik Steffl [mailto:[email-masked]]
> > Sent: Wednesday, August 16, 2000 6:19 PM
> > To: Farhad Jalilvand
> > Cc: [email-masked]'
> > Subject: Re: FVWM: fvwm installation;
> > 
> >   the way I do it:
> > 
> >   don't include anything on the unix side,
> > 
> >   on windows NT side do the following
> > 
> >   configure exceed like this:
> > 
> >   in configuration, screen definition:
> >     window mode: single
> >     root size: full screen
> > 
> >   create Xstart for fvwm, I use following command line:
> > 
> > /export/home/users/esteffl/local/bin/fvwm2 -display @d &
> > 
> >   (exceeds replaces @d by its display (=you workstation ip + ':.0.0')
> > 
> >   create Xsession
> >   include above Xstart in Xsession,
> > 
> >   you can create more Xstart files for otgher clients that you want to
> > start and include them in Xsession...
> > 
> >   start exceed by running the created x session (that's not fundamental
> > for fvwm usage, I just find it convenient)
> > 
> >         erik
> > 
> > Farhad Jalilvand wrote:
> > >
> > > Any idea how I can start FVWM on Win NT with Hummingbird (Exceed)?
Please
> > > see below for details...
> > >
> > > Thanks,
> > > Farhad
> > >
> > > -----Original Message-----
> > > From: Farhad Jalilvand
> > > Sent: Friday, August 11, 2000 5:27 PM
> > > To: [email-masked]
> > > Subject: RE: FVWM: fvwm installation;
> > >
> > > Hi there,
> > >
> > > I have installed the FVWM in my home directory and want to launch it
usin
> g
> > > Exceed version 5.1.3.0.
> > >
> > > I have also created a .xinitrc in home directory with the following
> > content:
> > > =============
> > > #! /bin/csh -f
> > > # .xinitrc
> > > #
> > > # REVISIONS:
> > >
> >
###########################################################################
> > >
> > > fvwm2 &
> > > ===========
> > >
> > > Any help is very much appreciated.
> > >
> > > Thanks
> > > Farhad
> > > --
> > > Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> > > To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> > > message to [email-masked].
> > > To report problems, send mail to [email-masked].
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 18 Aug 2000 14:31:31 -0400

> is my top portion of my .fvwm2rc file.

These are the wrong directories.  This is the area the build takes place
in.

Do a "make install" and look at where the modules are installed.

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Fri, 18 Aug 2000 14:39:39 -0400 (EDT)

This is exactly the problem.  ModulePath should be (for the basic
installation) a path to a directory in which all of the fvwm modules have
been installed.

I'd suggest that you do the following to save yourself some headaches.  It
appears that you built this in your home directory.  I'd suggest that you
re-compile, this time using the -prefix option to the configure step.
It's explained in the README or INSTALLATION notes; I can't remember
which.  Don't forget to remove the previous configure log.  Then do a make
all and make install.  This will build all of the modules in their
respective directories, which is what you are listing below, and the make
install will move the executeables to the directory that you specify with
the -prefix compile option.

If I remember right if you set prefix to your home directory then
configure will create the directory ~/libexex/fvwm/2.2.4/ and put the
modules there.  Set ModulePath to that directory and you're set.

Tom

---

From: Erik Steffl <[email-masked]>
Date: Fri, 18 Aug 2000 11:57:50 -0700

see below,

> is my top portion of my .fvwm2rc file.

  note that those are directories, not the actual modules (the modules
are files). you have to put the actual modules somewhere and point the
ModulePath to that 'somewhere'

  generally, to avoid this kind of troubles, I created local directory
under my home directory and install all the programs there, using:

./configure --prefix=$HOME/local
make
make install

  that does the proper installation, I just added ~/local/bin to my PATH
(+ some other minor stuff like MANPATH etc.), here's relevant part of
.tcshrc

setenv PATH ${HOME}/local/bin:/other/stuff
setenv MANPATH ${HOME}/local/man:/other/stuff
setenv LD_LIBRARY_PATH /other/stuff:${HOME}/local/lib

  above works for csh derivatives, if you use sh/bash/ksh/...:

export PATH=${HOME}/local/bin:/other/stuff
export MANPATH=${HOME}/local/man:/other/stuff
export LD_LIBRARY_PATH=/other/stuff:${HOME}/local/lib

  there might be some errors in above but I guess you get the idea...

	erik