Subject: RE: FVWM: fvwm installation;

From: Farhad Jalilvand <[email-masked]>
Date: Thu, 27 Jul 2000 15:28:43 -0700

Hi there,

When I run the "make install" (step 4 in INSTALL) here is what I get:

fjalilva@olive:/home/fjalilva/fvwm-2.2.4:( 65 )%make install
Making install in libs
Making install in fvwm
/bin/sh ../mkinstalldirs /usr/local/bin
mkdir /usr/local
mkdir: Failed to make directory "/usr/local"; Permission denied
mkdir /usr/local/bin
mkdir: Failed to make directory "/usr/local/bin"; No such file or directory
*** Error code 2
make: Fatal error: Command failed for target `install-binPROGRAMS'
Current working directory /home/fjalilva/fvwm-2.2.4/fvwm
*** Error code 1
make: Fatal error: Command failed for target `install-am'
Current working directory /home/fjalilva/fvwm-2.2.4/fvwm
*** Error code 1
make: Fatal error: Command failed for target `install-recursive'
fjalilva@olive:/home/fjalilva/fvwm-2.2.4:( 66 )%

What I have done so far is to run the following commands:

> ./configure --without-cxx

and

> make

and 

> make install

All from the following path:
/home/fjalilva/fvwm-2.2.4/

I have not made any changes to my environment or any of the supplies files
for fvwm yet...

Any idea why I am getting this error and if all the steps so far are
correct?

I am installing this on my home directory.

Do I need to modify the configure file for the ac_default_prefix?
# Defaults:
ac_help=
ac_default_prefix=/usr/local

And put my home path where I am installing the fvwm:
/home/fjalilva/fvm-2.2.4/fvwm

Thanks,
Farhad

-----Original Message-----
From: Mikhael Goikhman [mailto:[email-masked]]
Sent: Tuesday, July 25, 2000 9:56 PM
To: Farhad Jalilvand
Cc: [email-masked]
Subject: Re: FVWM: fvwm installation;

On 25 Jul 2000 14:53:15 -0700, Farhad Jalilvand wrote:
> 
> checking whether setvbuf arguments are reversed... configure: error: can
not
> run test program while cross compiling

Chances you have broken C++ development kit. Try: ./configure --without-cxx

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Jul 2000 18:59:06 -0400

> mkdir: Failed to make directory "/usr/local"; Permission denied
...
> I am installing this on my home directory.

Don't change the configure file, when you run configure, add
"--prefix=/home/fjalilva/fvm-2.2.4/fvwm".

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].