Subject: FVWM: Buttons/Left click menu

From: Martin Eyles <[email-masked]>
Date: Mon, 10 Jul 2000 15:33:09 +0100

I'm just starting in the world of .fvwm2rc configuration files, and am
trying to get buttons on my button bar to open up remote logins with the
xrsh protocol, and to run netscape and nedit. I am also trying to put
these in my menu (left click on the desktop) too.

However the buttons don't work. Can you help?
The  .fvwm2rc file is attached

--
Martin Eyles
[email-masked]
http://www.warwick.ac.uk/~phudu/
http://www.jreyles.freeserve.co.uk/martin/

# this is a sample .fvwmrc file for fvwm-2.
# Apparantly, you can retrieve sample .fvwmrc's from 
# 	ftp://ftp.best.com/pub/tdgilman/Fvwmrcs
# you can also submit your favourite .fvwmrc to
#	[email-masked] 
# if you want to.

# small up triangle
ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0

# some other ButtonStyles:
# large up triangle
#ButtonStyle 2 4 50x25@1 75x75@0 25x75@0 50x25@1
# large down triangle
#ButtonStyle 4 4 50x75@1 25x25@1 75x25@1 50x75@0
# big box
#ButtonStyle 2 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# little box
#ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# tall box
#ButtonStyle 6 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# dot
#ButtonStyle 4 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# an up arrow:
#ButtonStyle 2 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# an X
#ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0

EdgeResistance 250 10
WindowFont		-adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
IconFont		-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
EdgeScroll 100 100

ModulePath /usr/local/X11/lib/fvwm2
PixmapPath /usr/local/X11/include/X11/pixmaps/:/usr/openwin/include/X11/pixmaps
IconPath   /usr/local/X11/include/X11/bitmaps/:/usr/openwin/include/X11/bitmaps

HilightColor black palevioletred
DeskTopSize 2x2
MenuStyle maroon grey60 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* fvwm
ClickTime 750

ColormapFocus FollowsMouse

Style "*"           BorderWidth 5, HandleWidth 5
Style "*"           Icon unknown1.xpm, Color Black/#40a0c0
Style "*"           ActivePlacement, SmartPlacement
Style "*"           MWMFunctions,MWMDecor,HintOverride
Style "*"           DecorateTransient,IconBox 0 -10 -280 -1
Style "Fvwm*"       NoTitle, NoHandles, Sticky, WindowListSkip,
Style "Fvwm*"       BorderWidth 0,CirculateSkipIcon
Style "Fvwm Pager"  StaysOnTop
Style "FvwmPager"   StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "FvwmButtons" NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmButtons" BorderWidth 0, CirculateSkip
Style "FvwmButtons" Icon toolbox.xpm,ClickToFocus
Style "*lock"       NoTitle, NoHandles, Sticky, WindowListSkip
Style "*lock"	    RandomPlacement
Style "xbiff"       NoTitle, Sticky, WindowListSkip,ClickToFocus
Style "rxvt"        Icon  term.xpm,SloppyFocus,IconBox -70 1 -1 -140
Style "XTerm"       Icon xterm.xpm,IconBox -70 1 -1 -140
Style "XTerm"       Color black/#aa80aa,MWMBorder,MWMButtons
Style "Appointment" Icon datebook.xpm, NoButton 2, NoButton 4,ClickToFocus
Style "xcalc"       Icon xcalc.xpm, NoButton 2,RandomPlacement,ClickToFocus
Style "xmh"         Icon mail1.xpm, NoIconTitle,StickyIcon
Style "xmh"	    RandomPlacement, StartsOnDesk 2, NoButton 2
Style "xman"	    Icon xman.xpm,RandomPlacement,ClickToFocus
Style "xvgr"	    Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "matlab"	    Icon math4.xpm,ClickToFocus
Style "xmag"	    Icon mag_glass.xpm,RandomPlacement, ClickToFocus
Style "xgraph"      Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "sppeed6"     Icon math3.xpm,NoTitle,ClickToFocus
Style "sppeed6_user" Icon math4.xpm,NoTitle

Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100
Key Left	A	M	Scroll -10 +0
Key Right	A	M	Scroll +10 +0
Key Up		A	M	Scroll +0   -10
Key Down	A	M	Scroll +0   +10
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10
Key KP_F1	A	M	Popup "Utilities"
Key KP_F2	A	M	Popup "Window-Ops"
Key KP_F3	A	M	Module FvwmWinList 
Key KP_F4	A	M	Iconify
Key F5	A	M	Move        100p 100p
Key F6	A	M	Resize   10 10
Key F7	A	M	Next [*] focus
Key F8	A	M	Prev [*] focus
Key F10 	A	A	Next [CurrentDesk rxvt]Focus
Key F11 	A	A	Prev [CurrentDesk rxvt]Focus
Key F15		FTIWS	A	Raise

Mouse 1	R   	A       Menu Utilities Nop
Mouse 2	R    	A      	Menu Window-Ops Nop
Mouse 3	R    	A      	WindowList
Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	2    	A     	Maximize-Func
Mouse 0	4    	A     	Iconify
Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	A	Move-or-Raise
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops2 Nop
Mouse 3	TSIF	A	RaiseLower

########################Initialization Functions ############################
AddToFunc InitFunction 	  "I" Module FvwmButtons
+			  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

AddToFunc RestartFunction "I" Module FvwmButtons
+			  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

########################Menus ########################################
AddToMenu Utilities	"Utilities"	Title 	
+			"Xterm"		Exec  exec xterm
+			"Remote Logins"	Popup Remote-Logins
+			"Top"		Exec  exec rxvt -T Top -n Top -e top &
+			"Calculator"	Exec  exec xcalc &
+			"Xman"		Exec  exec xman &
+			"Xmag"		Exec  exec xmag &
+			"emacs"		Exec  exec xemacs &
+                       "Mail"          MailFunction xmh "-font fixed"
+			""		Nop
+			"Modules"	Popup Module-Popup
+			""		Nop		
+			"Exit Fvwm"	Popup Quit-Verify
AddToMenu Window-Ops	"Window Ops"	Title		
+			"Move"		Move-or-Raise2
+			"Resize"	Resize-or-Raise2
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	maximize_func
+			""		Nop  
+			"Delete"	Delete	 
+			"Close"		Close	 
+			"Destroy"	Destroy
+			""		Nop		
+			"Refresh Screen" Refresh		
AddToMenu Window-Ops2	"Move"		Move-or-Raise
+			"Resize"	Resize-or-Raise
+			"Raise"		Raise   	
+			"Lower"		Lower   	
+			"Iconify"	Iconify 	
+			"(Un)Stick"	Stick		
+			""		Nop     	
+			"Delete"	Delete	
+			"Close"		Close	  	
+			"Destroy"	Destroy 	
+			""		Nop 		
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction

AddToMenu Remote-Logins	"Remote Login" Title
+			"Primrose"	Exec	exec xrsh primrose
+			"Mimosa"	Exec	exec xrsh mimosa

AddToMenu Module-Popup	"Modules"	Title	
+			"Button-Bar"	Module	FvwmButtons
+			"Clean-Up"	Module	FvwmClean
+			"Identify"	Module	FvwmIdent
+			"SaveDesktop"	Module  FvwmSave
+			"Debug"		Module	FvwmDebug
+			"Pager"		Module  FvwmPager 0 1
+			"WinList"	Module  FvwmWinList
+			"Background"	Module  FvwmBacker
+			"IconBox"	Module	FvwmIconBox
+			"Banner"	Module	FvwmBanner
+			"Talk"  	Module	FvwmTalk
+			"Prompt"	Module	FvwmPrompt "hello" raise

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
+		      	"Yes, Really Quit"  Quit	
+		      	"Restart Fvwm"	    Restart fvwm	
+		      	"Start twm"         Restart twm
+		      	"Start mwm"    	    Restart mwm
+	      	    "Start olwm"        Restart /usr/openwin/bin/olwm
+		        "Start tvtwm"       Restart vtwm
+		      	"Start dummy"       Restart xterm
+		      	""		    Nop	
+		      	"No, Don't Quit"    Nop	

########################Functions ########################################

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] focus
+			   "I" None [$0] Exec $0 $1

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Move-or-Raise2	"M" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Maximize-Func		"M" Maximize	 0 100
+				"C" Maximize	 0 80
+				"D" Maximize	 100 100

AddToFunc Move-or-Iconify	"I" Raise
+				"M" Move
+				"D" Iconify

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

################## FvwmButtons button-bar ################################
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #908090

# Font
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -1-1

# Layout: specify rows or columns, not both
*FvwmButtonsColumns 2

# xterm or rxvts on remote machines can be done like this
# Output re-direction is csh style, not sh style
# You will want to substitute your own hosts here!

*FvwmButtons Primrose   	Exec /usr/local/X11/bin/xrsh primrose &
*FvwmButtons Mimosa  	Exec "Mimosa" /usr/local/X11/bin/xrsh mimosa &

*FvwmButtons Netscape	Exec "Netscape" '/usr/local/bin/netscape'
*FvwmButtons Nedit	Exec "Nedit" '/usr/local/bin/nedit &'

*FvwmButtons(2x2) - whatever Swallow "FvwmPager" Module FvwmPager 0 0

*FvwmButtons(2x3) - whatever2 Swallow "Clock" '/usr/openwin/bin/xclock'

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Misc
*FvwmPagerLabel 1 Maker
*FvwmPagerLabel 2 Mail
*FvwmPagerLabel 3 Matlab
*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green
	
############################################################
############################################################
# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     "*"  NoIcon

############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file specifications
#
# Mostly, you don't have to specify icon files, as FvwmIconBox now
# reads icon files specified in Style commands.
#
*FvwmIconBox            "Fvwm*"         -

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 15 Jul 2000 03:46:23 +0300

> these in my menu (left click on the desktop) too.

I suppose running xrsh via a corresponding submenu of your root menu works
for you. To run netscape, add it to one of your menus (say, Utilities).

> The  .fvwm2rc file is attached

You use an incorrect syntax. The correct syntax for a single button is:

*FvwmButtons(1x1, Icon mini-term.xpm, Action `Exec exec xrsh mimoza`)

You can use many other options, like Title together or instead of Icon,
see 'man FvwmButtons' for details.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 Jul 2000 13:55:55 +0200

> However the buttons don't work. Can you help?

Yes.

The correct (obsolete) syntax of button lines is:

  *FvwmButtons <button title> <icon file> <action>

> *FvwmButtons Primrose Exec /usr/local/X11/bin/xrsh primrose &
               ^^^^^^^^ ^^^^ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
               title    icon action

> *FvwmButtons Mimosa  	Exec "Mimosa" /usr/local/X11/bin/xrsh mimosa &
               ^^^^^^   ^^^^ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
               title    icon action

The correct lines are:

  *FvwmButtons Primrose - Exec /usr/local/X11/bin/xrsh primrose &
  *FvwmButtons Mimosa   - Exec "Mimosa" /usr/local/X11/bin/xrsh mimosa &
                       ^^^

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].