Subject: FVWM: how to move focus on current page

From: Keith Kaple <[email-masked]>
Date: Thu, 6 Jul 2000 18:41:23 -0400

I'm trying to map a key like:

Key     n       A       C       Next [CurrentPage !Iconic] focus

to cycle through all the windows/apps on the current page, skipping icons.  This only half works, sort of, if I focus several windows and then try it, it might go through two then it stops.  In the event it goes through all of them, it stops on the last and won't go to the "first" again.  How do I make it jump back to the first without a Previous?  I'd rather just have one key....

thanks

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 7 Jul 2000 02:45:47 +0300

On 06 Jul 2000 18:41:23 -0400, Keith Kaple wrote:
> to cycle through all the windows/apps on the current page, skipping
> icons.  This only half works, sort of, if I focus several windows and
> then try it, it might go through two then it stops.  In the event it
> goes through all of them, it stops on the last and won't go to the
> "first" again.  How do I make it jump back to the first without a
> Previous?  I'd rather just have one key....

This should normally work by circulating all windows.
But if you have No-Input-Focus windows, they may break the circulation.
So, just make these windows CirculateSkip to restore it.

  Style xclock CirculateSkip

Regards,
Mikhael.