Subject: FVWM: Starting programs on different pages

From: Frank Derichsweiler <[email-masked]>
Date: Wed, 26 Jul 2000 14:03:42 +0200

Hi fvwm-User,

I would like to start applications on different pages during start up
of fvwm 2.2.4.
I tried the following in my .fvwm2rc
AddToFunc InitFunction
# show FVWM logo
 +      "I"     Module FvwmBanner
 +      "I"     Exec xosview -geometry 175x135-20-30
 +      "I"     Exec xpmroot /usr/X11R6/include/X11/susexpm/normal/wall_suse.xpm
 +      "I"     GotoPage 0 0
 +      "I"     Exec <FirstApplication>
 +      "I"     Exec <SecondApplication>
 +      "I"     GotoPage 0 1
 +      "I"     Exec <ThirdApplication>       

Unfortunately it does not work. All apps are started on page 0 1. How
can I do that? 

Mayby it is a FAQ, but I did not find the approprite FAQ entry. 
A pointer into the doc or similar is enough.

Thanks a lot in advance,
Frank

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 26 Jul 2000 16:32:17 -0400

> Unfortunately it does not work. All apps are started on page 0 1. How

In the latest Betas we have better ways to do this, but
this worked for me:

DestroyFunc test
AddToFunc test
+ I GotoPage 0 1
+ I exec xterm -name one
+ I wait one
+ I GotoPage 1 1
+ I exec xterm -name two
+ I wait two
test

(You need to wait for the "Exec" to happen.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].