Subject: FVWM: Pager only shows desk 0. expecting current desktop to show as different buttons selected

From: Jan Vanderspool <[email-masked]>
Date: Fri, 21 Jul 2000 17:44:39 -0500

In fvwm, I get 5 areas for each button.  In fvwm2, I get Desk 0 only.
Selecting another button removes highlight from Desk 0.  Clicking on
any of the 5 areas for Desk 0 returns to button zero.

In FvwmPager, if I use 0 9 rather than * *, then the pager becomes 9
wide with 10 desktops always shown.

I have tried all combinations that I can think of to circumvent.  Is
this the expected behavior of fvwm2?  Can the "Desk 0, Desk 1, etx."
be removed?

Here are applicable parts of my .fvwm2rc

DeskTopSize 5x1

*FvwmButtons Work  foobar.xpm	Desk 0 0
*FvwmButtons Whom	 foobar.xpm	Desk 0 1
*FvwmButtons Gen	 foobar.xpm	Desk 0 2
*FvwmButtons CCT	 foobar.xpm	Desk 0 3
*FvwmButtons Docs  foobar.xpm	Desk 0 4
*FvwmButtons Test1  foobar.xpm	Desk 0 5
*FvwmButtons Test2  foobar.xpm	Desk 0 6
*FvwmButtons Test3  foobar.xpm	Desk 0 7
*FvwmButtons Test4  foobar.xpm	Desk 0 8
*FvwmButtons Test5  foobar.xpm	Desk 0 9

*FvwmPagerGeometry +0+965

*FvwmPagerDeskTopScale 32

Style "FvwmPager" NoTitle

Style FvwmPager WindowListSkip

Style "FvwmPager" Sticky

AddToFunc InitFunction 	  "I" Module FvwmButtons
+			  "I" exec xsetroot -grey
+                         "I" Module FvwmPager * *
AddToFunc RestartFunction "I" Module FvwmButtons
+			  "I" exec xsetroot -grey
+                         "I" Module FvwmPager * *

Regards,
Jan Vanderspool
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 22 Jul 2000 05:04:17 +0300

On 21 Jul 2000 17:44:39 -0500, Jan Vanderspool wrote:
> this the expected behavior of fvwm2?

Which fvwm version do you speak about, 2.2.4?

What you are describing happens when you start FvwmPager without
parameters or with 0 as its parameter. If you start it using * (or * *),
it should show the current desk, as you may expect.

When you are at desk 0 open FvwmTalk or FvwmConsole and enter commands:

  FvwmPager * *
  Desk 0 3

If the pager started by the first command does not show desk 3 after the
second command, there is a bug in your fvwm version. Upgrade.

> Can the "Desk 0, Desk 1, etx." be removed?

You can specify your own desk labels, see the FvwmPager man page.

Regards,
Mikhael.