Subject: FVWM: Style sced MaxWindowSize 100 100

From: Neil Zanella <[email-masked]>
Date: Sun, 23 Jul 2000 07:55:59 -0230 (NDT)

Hello,

I am running fvwm2 2.3.20 and I cannot get the application sced
to be entirely contained within my 800x600 display although I
have the following line in my .fvwm2rc:

Style sced MaxWindowSize 100 100

This line works with other applications like xterm but not with sced?

Why?

Thanks,

Neil

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Sun, 23 Jul 2000 13:25:18 -0700

> This line works with other applications like xterm but not with sced?

Could you supply the output of 'xwininfo -all' on the oversized
window? My guess is that sced uses funny WM hints or is otherwise
broken. The GIMP used to be very bad about allowing itself to be
placed by fvwm, for example.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
A closed mouth gathers no foot
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Zanella <[email-masked]>
Date: Mon, 24 Jul 2000 00:42:43 -0230 (NDT)

> placed by fvwm, for example.

Here is the output of sced & xwininfo -all

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x240006a "Scene Window"

  Root window id: 0x2a (the root window) (has no name)
  Parent window id: 0x8007bf (has no name)
     1 child:
     0x240006b (has no name): ()  786x567+0+0  +-8+-8
        17 children:
        0x240007e (has no name): ()  95x17+4+4  +-4+-4
        0x240007d (has no name): ()  95x17+4+43  +-4+35
        0x240007c (has no name): ()  95x17+4+66  +-4+58
        0x240007b (has no name): ()  95x17+4+89  +-4+81
        0x240007a (has no name): ()  95x17+4+128  +-4+120
        0x2400079 (has no name): ()  95x17+4+167  +-4+159
        0x2400078 (has no name): ()  95x17+4+190  +-4+182
        0x2400077 (has no name): ()  95x17+4+213  +-4+205
        0x2400076 (has no name): ()  95x17+4+252  +-4+244
        0x2400075 (has no name): ()  95x17+4+275  +-4+267
        0x2400074 (has no name): ()  95x17+4+298  +-4+290
        0x2400073 (has no name): ()  95x17+4+337  +-4+329
        0x2400072 (has no name): ()  95x17+4+376  +-4+368
        0x240006f (has no name): ()  675x534+105+4  +97+-4
           3 children:
           0x2400070 (has no name): ()  660x519+0+0  +98+-3
              1 child:
              0x2400071 (has no name): ()  689x560+0+0  +98+-3
           0x240009a (has no name): ()  14x519+660+-1  +758+-4
           0x2400099 (has no name): ()  660x14+-1+519  +97+516
        0x240006e (has no name): ()  95x17+4+544  +-4+536
        0x240006d (has no name): ()  95x17+105+544  +97+536
        0x240006c (has no name): ()  574x17+204+544  +196+536

  Absolute upper-left X:  -8
  Absolute upper-left Y:  -8
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 786
  Height: 567
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +-8+-8  -22+-8  -22-41  +-8-41
  -geometry 786x567+-15+-34

  Bit gravity: NorthWestGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      EnterWindow
      LeaveWindow
      StructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      User supplied size: 800 by 600
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined