Subject: FVWM: overriding EdgeScroll/EdgeResistance

From: greg shebert <[email-masked]>
Date: Thu, 13 Jul 2000 13:34:29 -0500

under normal circumstances i do not want my users to be able to drag
windows off of the screen... i also do not want them to be able to page
around via dragging the mouse

therefore i have put
EdgeScroll 0 0
EdgeResistance 10000 10000
EdgeThickness 0

into my fvwmrc file...

what i would like to see happen is, if the user presses the alt key and
then drags a window, that they then be able to drag it partially off of
the screen (basically an unconstrained move)

is there a way to temporarily override those values when moving the
window with alt pressed?

thanks for any help
-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 13 Jul 2000 22:19:59 +0300

> the screen (basically an unconstrained move)

Well, UnconstrainedMove command is something that I always wanted,
it should be able to ignore SnapAttraction, EdgeResistance and more.
Maybe this command can be added after 2.4.

> is there a way to temporarily override those values when moving the

For now, you can use your hard-coded version of UnconstrainedMove:

DestroyFunc UnconstrainedMove
AddToFunc   UnconstrainedMove
+ I EdgeResistance 0 0        
+ I SnapAttraction -1 All
+ I Move
# restore your default behaviour foe Move here
+ I EdgeResistance 10000 10000
+ I SnapAttraction 10 Windows

Mouse 2 TSF S UnconstrainedMove

> -greg-

Regards,
Mikhael.