Subject: Re: FVWM: Window Placement Problem

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Jul 2000 11:32:25 +0200

On Wed, May 31, 2000 at 10:55:40AM +0100, Ben Cohen wrote:
> On Wed, 31 May 2000, Dominik Vogt wrote:
> 
> >> (FVWM version 2.2.4)
> >> 
> >> I found the following post in the mailing list archives after having the
> >> similar problems.  Firstly, a new window on an empty screen will appear at
> >> (2,2) not (0,0).  Also, a Netscape window (say) that is the full
> >> screen-size will also appear at (2,2) not (0,0).
> >
> >Ah, now that you rephrase that bug report I finally understand
> >what the problem is.  This is still happening with 2.3.19.
> 
> Thanks -- that fixes the first problem (of a new window on an empty
> screen). 
> 
> However, I am still having the problem with Netscape:  I have NS set up to
> open its window at the maximum size for the screen.  So I would hope that
> fvwm positions it from (0,0) so that it fills the screen exactly with no
> edge-gaps.  But it actually appears at (2,2).  This still happens after
> applying the patch you sent.  The patch I sent yesterday (where I subtract
> 2 from tmp_win->attr.x and y) seems to stop this problem, but as I said I
> don't think it is the correct fix.

Hm, what did you do to make netscape this big?  Simply enlarge the
window and then close it to store the geometry?

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ben Cohen <[email-masked]>
Date: Tue, 4 Jul 2000 11:41:55 +0100 (BST)

>window and then close it to store the geometry?

Yes, that is how I did it---either by manually resizing or using the
maximise button.  I just noticed that you can make it *slightly* by
resizing which seems to solve it.  (On my screen maximise makes the window
1266x985, whereas the largest I can resize manually is 1268x987.)

So the problem occurs with 
  netscape -geometry 1267x986+0+0& 
but not with
  netscape -geometry 1268x987+0+0& 

(This is on a 1280x1024 screen with BorderWideth 7.)

I don't now know whether this is a problem or not.  I think it could
either be solved by adjusting the size fvwm uses for maximise,  or the
position the window is placed in (as in the patch mentioned above).

Thanks,
Ben.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 5 Jul 2000 11:26:34 +0200

> position the window is placed in (as in the patch mentioned above).

Please send me your fvwm config file.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].