Subject: FVWM: Raising FvwmButtons (fvwm-2.2.4)

From: Philippe POINCOT <[email-masked]>
Date: Sat, 22 Jul 2000 16:33:30 +0200

Hi,

	I vould like to make a Raise_Buttons functionlike this:

############################## Raise_Buttons
#########################
AddToFunc Raise_Buttons
     + I None (FvwmButtons) Module FvwmButtons
     + I Next (FvwmButtons) Raise 

but this doesn't work: the NEXT statement is never reached even if
the FvwmButtons module is running... I have tried several things
like this:

+ I Next (*FvwmButtons*) ...
+ I Next (*Buttons*) ...

but maybe the problem is not here?

Thank's to every one who could help me.

-- 
Philippe POINCOT 
Observatoire Astronomique de Strasbourg
11, rue de l'Universite, 67000 STRASBOURG FRANCE.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 23 Jul 2000 00:41:08 +0300

On 22 Jul 2000 16:33:30 +0200, Philippe POINCOT wrote:
> the FvwmButtons module is running...

You probably have CirculateSkip style option for FvwmButtons.

If true, try this function instead (maybe without two None lines first):

  AddToFunc Raise_Buttons
  + I None (FvwmButtons CirculateHit) Module FvwmButtons
  + I None (FvwmButtons CirculateHit) Wait FvwmButtons
  + I Next (FvwmButtons CirculateHit) Raise

Regards,
Mikhael.

---

From: Philippe POINCOT <[email-masked]>
Date: Sun, 23 Jul 2000 18:21:50 +0200

> You probably have CirculateSkip style option for FvwmButtons.

Yes, my problem was due to this option. 
Thank's a lot! (I think I would have spent years before I would have
found this :-) )

Philippe.