Subject: FVWM: Exec fails sometimes

From: Johannes Zellner <[email-masked]>
Date: Sun, 23 Jul 2000 12:55:57 +0200

Hello,

I've a problem with Exec:

    Key KP_Add A C Exec exec rxvt -e w3m

won't work. The rxvt appears and disappears immediately again.
If I type this command from the shell it works.
This happens only for some commands, e.g. if I use lynx instead
of w3m it works!

I tried also to specify a full path, e.g. /usr/bin/w3m, no success.

Does anybody have an idea what's going wrong here, or how I could
debug this ?

-- 
   Johannes
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Al Bolduc <[email-masked]>
Date: Sun, 23 Jul 2000 08:11:16 -0400 (EDT)

> This happens only for some commands, e.g. if I use lynx instead

The problem is not with fvwm.  the command w3m prints a diagnostic and
exits.  You could try 'w3m -v' or 'w3m URL or FILE.

Al

#  Al Bolduc - [email-masked] - [email-masked] - [email-masked]

---

From: Johannes Zellner <[email-masked]>
Date: Sun, 23 Jul 2000 14:23:38 +0200

> exits.  You could try 'w3m -v' or 'w3m URL or FILE.

ahh. The problem is that WWW_HOME is not set (because I set it in .profile)
when doing the Exec from fvwm. Thanks!