Subject: FVWM: Shade and hilight colors

From: Jos <[email-masked]>
Date: Thu, 08 Jun 2000 15:46:39 +0200

Hi

For use in an 'fvwm2 theme' 
I'd like to know if there is a possibility to
retreive the values of the shade and hilight 
colors as calculated by fvwm2, when a certain 
back ground color is given. 

I also noticed that the shade and hilight colors 
of the 'motif-style' window decorations are not the 
same as in the motif window manager. In fvwm2 the 
hilight colors seem to light. Doesn't fvwm use the 
same color calculations as motif? 

best regardz

jos
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 09 Jun 2000 13:21:19 +0100

> back ground color is given.

Version 2.3.8 and later let's you use $[hilight.cs0] and $[shadow.cs0]
in functions. You have to use FvwmTheme to manage the colorsets but once
you figured out that you can get at the colors by e.g.

AddToFunc getcolors I Exec echo $[hilight.cs0] $[shadow.cs0] > shade.txt

> same color calculations as motif?

Until very recently the Motif shade calculations were secret.  Anyway
Motif has changed the algorithm with every new version. Now that Motif
source is available I guess we could use it (it's probably a small
enough % to get away with fair use) or even figure out how to get fvwm
to interact with the CDE color server.

Cheers,
Tim.