Subject: Re: FVWM: Window position

From: [email-masked]
Date: Wed, 28 Jun 2000 13:24:20 EDT

In a message dated 6/27/00 4:53:26 PM Eastern Daylight Time, 
[email-masked] writes:
>  *FvwmEventPassID
>  *FvwmEvent window_name winame_event
>  
>  AddToFunc winame_event
>  +    "I" WindowID $0 ("Mail Tool*Compose*")  Geometry 576 0  566 597

Thanks to both you and Mikhael for responding to my question.  I have tried 
to use both of your suggestions and can't seem to get them to work.  
Wondering if you might have any ideas as to what I am doing wrong?

When I used your code (above) I got the following error:
"FvwmEvent: incomplete event definition *FvwmEventPassID"

I am using version 2.2.4 of fvwm2 and FvwmEvent.  

When I tried Mikhael's suggestion:
----------------------
*NewWindowEventCmd
*NewWindowEventPassId
*NewWindowEvent add_window FuncFocusWindow

AddToFunc FuncFocusWindow
+ I WindowId $0 ("My Special Window") Move 200p 100p
+ I WindowId $0 Focus
+ I WindowId $0 WarpToWindow

FvwmEvent NewWindowEvent
-----------------------
I didn't get any errors, but the window was not moved.  I am wondering if I 
may have an older version that doesn't support some of these event calls or 
something?  I read the man page over and over and checked my code for typos a 
bunch - can't seem to figure it out.  

Any suggestions are appreciated - and thanks again to both of you for your 
responses.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 29 Jun 2000 01:20:08 +0300

> Wondering if you might have any ideas as to what I am doing wrong?

You are right, PassId option of FvwmEvent was introduced only in 2.3.
And in FvwmEvent 2.2.4 there is no alias support, only symlinks, so you
normally can only have one event module if you use this version.

It is possible to invent an example working with 2.2.4, but it may be
less relable. Replace "My Window" with your real window name.

# ----------------
DestroyModuleConfig FvwmEvent*
*FvwmEvent add_window SetGeometryForMyWindow

AddToFunc SetGeometryForMyWindow
+ I Next ("My Window") Move 200p 100p

# choose one of 2 invocations (the second is preferable)
Module FvwmEvent
#AddToFunc StartFunction I Module FvwmEvent
# ================

This works with 2.3.20 and should work with 2.2.4, I hope.

Regards,
Mikhael.