Subject: Re: FVWM: xrdb

From: Neil Zanella <[email-masked]>
Date: Wed, 28 Jun 2000 20:07:40 -0230 (NDT)

Why doesn't the following work?

AddToFunc AddResource "I" Exec echo $0 | /usr/X11R6/bin/xrdb -merge
AddToFunc InitFunction "I" AddResource "Netscape*selectBackground: #FFFF66"

On the other hand the following did work:

AddToFunc AddResource
[...]
+ "I" Exec echo "Netscape*selectBackground: #FFFF66" | /usr/X11R6/bin/xrdb
-merge

Thanks,

Neil

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 28 Jun 2000 19:25:29 -0400

> + "I" Exec echo "Netscape*selectBackground: #FFFF66" | /usr/X11R6/bin/xrdb

You just need a little more quoting to stop the "#" fomr being interpreted
by the shell as a comment.

This works:

AddToFunc AddResource "I" Exec echo "$0" | /usr/X11R6/bin/xrdb -merge

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Zanella <[email-masked]>
Date: Thu, 29 Jun 2000 00:55:55 -0230 (NDT)

Hi,

Thanks for your comment. There are so many special symbols and ways to
escape them to look out for!

Thanks!

Neil