Subject: FVWM: FvwmIconMan, Menu Popup

From: Eric Raijmakers <[email-masked]>
Date: Fri, 30 Jun 2000 12:00:53 +0200

Hi,

I want to achieve the following:

When the right mouse button is pressed over a button in FvwmIconMan,
a menu pops up, giving access to operations on the window.

Anyone has an idea of how to achieve this.

I succeeded in popping up a menu, but the menu items did not apply to
the window corresponding with the pressed FvwmIconMan button.

Greetings,
Eric

------------------------------------------------------------------------

Eric Raijmakers

ir. Eric Raijmakers MTD
Oce-Technologies B.V.
Room 3N40
P.O. Box 101
5900 MA Venlo
Phone: +31 77 359 5871
E-mail: [email-masked]
 _______________
|ooo oooo oo o =|  "Bla bla, bla bla bla bla, bla bla",
|¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯|
|   MARSHALL    |  Tom Arraya (Slayer),
|               |
|               |  Dynamo Open Air 1996
._______________.

http://listen.to/takedeath

---------------------------------------------------------------------------------
This note does not necessarily represent the  position  of 
Océ-Technologies B.V.
Therefore no liability or responsibility for whatever will be accepted.
---------------------------------------------------------------------------------

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 30 Jun 2000 13:38:56 +0300

> the window corresponding with the pressed FvwmIconMan button.

The syntax is (menu position hints, i.e. last 3 words, are optional):

*FvwmIconMan*action Mouse 3 N sendcommand "Popup WindowOps2 Mouse c -102m"

But there is a bug you described. It is fixed in the developement version.

Regards,
Mikhael.