Subject: Re: FVWM: FvwmEvent: killing netscape windows

From: Neil Zanella <[email-masked]>
Date: Wed, 21 Jun 2000 22:50:02 -0230 (NDT)

Thanks for your feedback.

What is this WindowID stuff? If WindowID is a keyword then
it should be showing up either in the fvwm2 man page or in
the FvwmEvent man page but it is not. On the other hand
it cannot be a parameter since window ID's seem to vary
from time to time. So, what does WindowID do?

Also, on line 2, do you mean *FvwmEvent add_window winame_event?

Thanks,

Neil

> 
> *FvwmEventPassID
> *FvwmEvent add_window add_event
> 
> AddToFunc winame_event
> +	"I" WindowID $0 ("*Free*AOL*")			Close
> +	"I" WindowID $0 ("Netscape: Netscape Plug-ins")	Close
> +	"I" WindowID $0 ("Netscape: subprocess diagnostics*") Close
> 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Zanella <[email-masked]>
Date: Thu, 22 Jun 2000 01:35:48 -0230 (NDT)

Thanks for your feedback...

So I solved part of my problem with the following:

Module FvwmEvent
*FvwmEventPassID
*FvwmEvent add_window AddWindowFunc

AddToFunc AddWindowFunc 
+       "I" WindowID $0 ("Netscape: Error") Close

...

However this does not get me past the License agreement.
If I had included the following:

+       "I" WindowID $0 ("Netscape: License Agreement") Close

The License Agreement comes up each time I delete everything
under ~/.netscape and I do this on a regular basis since this
seems to be the only way I can keep netscape working the right
way each time (I really don't like its caching policies).

So, what I would like to be able to do is have fvwm2 send the
licence agreement an enter keystroke automatically. Is this
possible? This would also be handy for handling other tedious
forms of similar nature.

Thanks,

Neil

---

From: Tim Phipps <[email-masked]>
Date: Thu, 22 Jun 2000 09:44:51 +0100

> way each time (I really don't like its caching policies).

You can tune netscapes caching by using Edit/Preferences, clicking the
arrow by Advanced and the clicking Cache. Deleting everything under
.netscape is a bit severe and will slow down netscape's startup as it
will generate all those files each time.

Cheers,
Tim.

---

From: Erik Steffl <[email-masked]>
Date: Thu, 22 Jun 2000 07:54:59 -0700

Neil Zanella wrote:
...
> way each time (I really don't like its caching policies).

  do just rm -r ~/.netscape/cache/*

  at least that's working for me. you can also selectively delete other
info - history, newsgroups etc. you don't have to delete everything,
that way you don't loose all your preferences and you are not bothered
by licence agreement.

  I found out that the cache limit for netscape does not work, whatever
you specify, the cache seems to grow (I specified 5 MB and often the
cache would grow to 20+ MB before I "rm -r"-ed it).

  sorry, can't answer your main question but the above might help you a
bit anyway...

	erik

---

From: Peter S Galbraith <[email-masked]>
Date: Thu, 22 Jun 2000 13:20:44 -0400

> cache would grow to 20+ MB before I "rm -r"-ed it).

Man, I just looked and got 275 MB!

Peter

---

From: Neil Zanella <[email-masked]>
Date: Thu, 22 Jun 2000 19:38:01 -0230 (NDT)

> will generate all those files each time.

As I already mentioned this does not work very well for me and neither
do some other Netscape things. Hopefully these will be fixed in 6.0
although I doubt that any web browser will ever be bug free.

Thanks,

Neil

---

From: Neil Zanella <[email-masked]>
Date: Thu, 22 Jun 2000 19:40:12 -0230 (NDT)

> that way you don't loose all your preferences and you are not bothered

What preferences? I cannot even set the highlight color from when I
search for something or higlight colors with the mouse. So when I
search for something I cannot see the higlighted text because of
that default dim yellow! That's the end of my complaining about Netscape.

Bye,

Neil