Subject: Re: FVWM: some newbie questions...

From: Keith Kaple <[email-masked]>
Date: Thu, 1 Jun 2000 10:00:44 -0400

> 
> 10.Im in the xterm - how can I send a html-file to an existing Netscape
> window, without opening a new one (same as quesion #1)?

Take a look at: http://home.netscape.com/newsref/std/x-remote.html for more info...

Depending on your shell, (mine is tcsh), try:

netscape -remote openFile\(/path/file.html\)  or
netscape -remote openURL\(www.yahoo.com\)

I alias this with 'ns' to be:

ns:      aliased to /opt/netscape/netscape -remote openURL\(http://!*\)

so,
 
ns www.yahoo.com

opens yahoo wherever netscape is running...

Cheers

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Jun 2000 23:59:30 +0200

On Wed, May 31, 2000 at 04:54:24PM -0700, Erik Steffl wrote:
> "Nikolaj G." wrote:
> > 
> > Been using Linux with fvwm2 for some weeks now and came up with this
> > list of questions:
> > 
> 
> > 2. How can I save a file (or shortcut) on the desktop (like Win95),
> > without using some kind of filemanager (like tkdesk).
> 
>   AFAIK you cannot put files on the desktop, the desktop in fvwm is not
> a folder (like it is in win95).

This is usually the job of a file manager.

> > 3. Im using "Alt+Tab" to get the windowlist. Is it possible cycle
> > through the windowlist like Win95 or Enlightenment with flipping windows
> > on each "Tab"-hit - and recycle when "Shift" is down.
> 
>   it is not possible but you can hit the number (or letter, if there's
> too many items) to  focus on particular p[rogram (to switch to
> particular program).

It *is* possible, but it's a bit different that with Windows.
The recent beta versions of fvwm come with a proper
configuration for Alt-Tab (currently 2.3.18).

> > 4. How can I - or what is the command to minimize and maximize all
> > windows back (like in Win95 with "Windows_Key + m" and "Shift +
> > Windows_Key + m") ?
> 
>   I guess you can do that somehow (write a function?) but there's no
> dire need to do it since you can send windows to back (so that they are
> not on top but hidden behind other widows) and you can go to another
> screen (or desktop) if you have too many windows on particular screen.

Yes, usually it's easier to switch pages or desktops.  Look at the
man page sections fo DeskTopSize, GotoDesk and GotoPage for details.
You can still easily implement this:

  Key m a m all iconify off
  Key m a sm all iconify on

This binds 'iconify all' to shitf-alt-m and 'deiconify all' to
alt-m.

> > 7. Asclock is the only thing I want in FvwmButtons, but it get
> > "minimized" (only the upper left corner) - what's the exactly "Swallow
> > string" - and how do I remove edges around FvwmButtons.

I'm not sure what you mean.  Here is an example:

  *FvwmButtons(2x2, swallow xclock `Exec exec xcloca`k)

To remove the border around the FvwmButtons window:

  Style FvwmButtons NoTitle, HandleWidth 0

To remove borders around the buttons:

  *FvwmButtonsPadding 0 0

> > 9. Where is the file with PATH?
> 
>   you set the PATH in the startup script for you shell, the name of the
> file depends on shell you're using.

If you use bash (the standard Linux shell) it should be /etc/profile
or some file named /etc/bash...

> > 11. How do I keep the normal cursor when in the "desktop-menu" - don't
> > like this left horizontal left arrow (default).

Use the CursorStyle command with the MENU context.  Or simply
change to a newer fvwm release.  The cursor has been changed
a while ago.

> > 12. How can I make an "shutdown -h now" from the menu as "non-root" -
> > only using Fvwm2, and therefore don't have the "shutdown" posibility in
> > the default "window-manager login window".

You can use a program like 'sudo' which allows you to execute
certain commands with root permissions.

> > 13. Where can I add/remove buttons in the caption bar (system, close,
> > minimize and maximize) - ps know how to change the ButtonStyle.
> 
>   see example .fvwmrc files, read the manual.
> 
> > 14. How do I make a dynamic (recursive) "*.txt, *.c, *.cpp" filelist of
> > ~/ in the menu - already tried the fvwm2/new-features example, but
> > couldn't make it work. Even better - lets say I found the file
> > (whatever) in the dynamic menu... and then press "Crtl+<something>" and
> > a menu-program-list pops up to choose from - is that possible? I mean
> > sometimes I want to use "emacs" other times "xjed" is better.

I'm not sure which example you mean since you don't say which release
you use.  I have this in my config file:

  AddToMenu BrowseMenu
  + DynamicPopupAction Piperead 'fvwm_make_browse_menu.sh BrowseMenu'

(fvwm_make_browse_menu.sh is a script coming with the current beta
releases.)

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].