Subject: FVWM: question: focus to new window

From: Stefan Klinger <[email-masked]>
Date: Tue, 27 Jun 2000 18:08:46 +0200

Hi!

I want to use SloppyFocus, but I also want the focus to be given automatically to a new window when it appears (perhaps move the curser to that window?). How can I achieve this?

  Thanks, Stefan
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 28 Jun 2000 02:30:30 +0300

On 27 Jun 2000 18:08:46 +0200, Stefan Klinger wrote:
> 
> I want to use SloppyFocus, but I also want the focus to be given
> automatically to a new window when it appears (perhaps move the curser
> to that window?). How can I achieve this?

*NewWindowEventCmd
*NewWindowEventPassId
*NewWindowEvent add_window FuncFocusWindow

AddToFunc FuncFocusWindow
+ I WindowId $0 ("My Special Window") Move 200p 100p
+ I WindowId $0 Focus
+ I WindowId $0 WarpToWindow

FvwmEvent NewWindowEvent

"Move" line is not needed, it is the answer to NancySumner1 question.
I will add this to FAQ.

Regards,
Mikhael.