Subject: re: FVWM: xinitrc

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 26 Jun 2000 17:54:28 -0700 (PDT)

exitting fvwm (2.3.16) still hangs even w/ this .xinitrc ...

dis=`hostname`
DISPLAY=$dis":0"
export DISPLAY

if [ -f $HOME/.Xdefaults ]; then
    xrdb $HOME/.Xdefaults &		# Load Users X11 resource database
else
    xrdb $OPENWINHOME/lib/Xdefaults &	# Load Default X11 resource database
fi
$OPENWINHOME/lib/openwin-sys &		# OpenWindows system initialization

xset s 7200  # screenblank delay

if [ -f /usr/local/bin/fvwm2 ]; then
  echo fvwm2
elif [ -f /usr/local/bin/fvwm ]; then	# fvwm Window Manager
	/usr/local/bin/fvwm &
elif [ -f /cad/bin/olvwm ]; then	# OpenLook Window Manager
	/cad/bin/olvwm -2d  &
else
	olwm  &
fi

if [ -x $HOME/.openwin-init ]; then
    $HOME/.openwin-init			# Custom OpenWindows tools
else
    $OPENWINHOME/lib/openwin-init   	# Default OpenWindows tools
fi

xhost + > /dev/null

if [ -f /usr/local/bin/fvwm2 ]; then	# fvwm2 Window Manager
	fvwm2
fi
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 26 Jun 2000 22:22:51 -0400

> exitting fvwm (2.3.16) still hangs even w/ this .xinitrc ...

You would be better off just setting $DISPLAY to ":0".

> xset s 7200  # screenblank delay

OK.

> elif [ -f /cad/bin/olvwm ]; then	# OpenLook Window Manager

Its impossible for us to tell which of the above would get executed,
since we don't know which of these files exist.

The "echo fvwm2" part doesn't make much sense.

It doesn't seem like you would want to start a background window manager
at this point, based on the stuff done later on.

I suggest deleting the whole section.

>     $OPENWINHOME/lib/openwin-init   	# Default OpenWindows tools

Since I don't know if you have a $HOME/.openwin-init,
I can't tell what this section might do.
The "else" part seems OK.

> xhost + > /dev/null

Weak security, but thats up to you.

> if [ -f /usr/local/bin/fvwm2 ]; then	# fvwm2 Window Manager

If you did get this  far, executing fvwm2 would be  the last thing you
did in your  .xinitrc, and you would  be  using the window  manager to
keep your X Session active.  If you correctly exited fvwm, then your X
session would end.

Try removing the piece above.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Mon, 26 Jun 2000 21:22:39 -0700

On Mon, Jun 26, 2000 at 10:22:51PM -0400, Dan Espen wrote:
> [snip a bunch of good suggestions from Dan]
> 

Err, should it be an exec fvwm2? I've always understood X startup to
prefer to exec the window manager as the final system call.
-- 
[email-masked]                            http://www.mikehan.com/
coffee achiever                              San Francisco, California
"It is better for people to think your [sic] a fool, than for you to
open your mouth and remove all doubts." - some fool
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 27 Jun 2000 06:39:29 -0400

> prefer to exec the window manager as the final system call.

exec is better. It eliminates an unnecessary process.

I don't think that not using exec would cause a hang.