Subject: FVWM: xinitrc, ie5 and hanging apps locking screen

From: Elliot Sowadsky <[email-masked]>
Date: Tue, 13 Jun 2000 15:03:16 -0700 (PDT)

Is there a setting that prevents an application from owning the whole screen?
So that if a window hangs, i can still access everything else?

-------
Does anyone use ie5 on solaris?
Do you find that it likes to dive to the bottom when popping up windows...or for some other reason?

Does fvwm complain about its icons unless you set NoIcon?

-------

When i exit fvwm (2.3.16), i dont return to "dos prompt".

xinitrc...

if [ -f $HOME/.Xdefaults ]; then
    xrdb $HOME/.Xdefaults &		# Load Users X11 resource database
else
    xrdb $OPENWINHOME/lib/Xdefaults &	# Load Default X11 resource database
fi
$OPENWINHOME/lib/openwin-sys &		# OpenWindows system initialization

xset s 7200  # screenblank delay
if [ -f /usr/local/bin/fvwm2 ]; then	# fvwm2 Window Manager
	fvwm2 &				# local 2.2.4 or 2.0.42
elif [ -f /usr/local/bin/fvwm ]; then	# fvwm Window Manager
	/usr/local/bin/fvwm &
elif [ -f /cad/bin/olvwm ]; then	# OpenLook Window Manager
	/cad/bin/olvwm -2d  &
else
	olwm  &
fi
if [ -x $HOME/.openwin-init ]; then
    $HOME/.openwin-init			# Custom OpenWindows tools
else
    $OPENWINHOME/lib/openwin-init   	# Default OpenWindows tools
fi
xhost + > /dev/null
wait
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 13 Jun 2000 18:34:25 -0400

> So that if a window hangs, i can still access everything else?

If the application does an X Server grab, theres nothing fvwm
can do about it.

> Does fvwm complain about its icons unless you set NoIcon?

Can't try IE right now.

> 	fvwm2 &				# local 2.2.4 or 2.0.42

As your .xinitrc shows, you are running fvwm2 detached from your .xinitrc.
(In the background.)
If fvwm2 exits, you are without a window manager.

>     $OPENWINHOME/lib/openwin-init   	# Default OpenWindows tools

Your .xinitrc is held by this "wait" command.  If the wait command were to
end, then your X Session would end and you would be back at the command
prompt.

If you wanted the window manager to hold your X Session, you would put it
last in your .xinitrc and not put an ampersand at the end.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Jun 2000 04:58:00 +0200

> So that if a window hangs, i can still access everything else?

Try the MaxWindowSize style.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Wed, 14 Jun 2000 07:45:12 -0400 (EDT)

What version of fvwm2 is this in?

Tom

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Jun 2000 14:03:40 +0200

> What version of fvwm2 is this in?

 It's in the beta series since 2.3.7

Bye

Dominik ^_^