Subject: Re: FVWM: FvwmEvent: killing netscape windows

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 21 Jun 2000 17:31:12 -0700 (PDT)

<<
I would like to know how I can use fvwm2 (possibly FvwmEvent)
to do the following:

When a window with window name "Netscape: Error" pops up fvwm2
automatically clicks OK for me.

When a window with window name "Netscape: Licence Agreement" pops
up fvwm2 automatically clicks Accept for me. Alternatively,
passing a Return keystroke to the above mentioned nasty netscape
windows would also do.

I tried the following but it did not work (I did not find the
FvwmEvent man page as clear as the other pages).

Module FvwmEvent
*FvwmEvent "Netscape: Error" Destroy

Here's mine (2.3.16)...

*FvwmEventPassID
*FvwmEvent add_window add_event

AddToFunc winame_event
+	"I" WindowID $0 ("*Free*AOL*")			Close
+	"I" WindowID $0 ("Netscape: Netscape Plug-ins")	Close
+	"I" WindowID $0 ("Netscape: subprocess diagnostics*") Close
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---



<<

Module FvwmEvent

Here's mine (2.3.16)...

*FvwmEventPassID
*FvwmEvent window_name winame_event

AddToFunc winame_event

---

From: Neil Zanella <[email-masked]>
Date: Wed, 21 Jun 2000 23:51:29 -0230 (NDT)

Ah, I searched for WindowID but the man page lists WindowId.
While Fvwm2 is not case sensitive my man page reader is.
I should have expected that.

Thanks,

Neil

On Wed, 21 Jun 2000, Elliot Sowadsky wrote:

> 
> WindowID is in the fvwm2 man page
>

---

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 22 Jun 2000 10:28:53 -0700 (PDT)

< >   I found out that the cache limit for netscape does not work, whatever
< > you specify, the cache seems to grow (I specified 5 MB and often the
< > cache would grow to 20+ MB before I "rm -r"-ed it).
< 
< Man, I just looked and got 275 MB!

I know this isnt the netscape list....but i just set disk-caching to 0.
Netscrap caching doesnt work anyway.

I tried IE5 on Solaris.....but it ammoyingly keeps ducking to the bottom
and i must NoIcon or fvwm will complain....and theres no "Images" button.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].