Subject: FVWM: implementing squeeze title bars

From: greg shebert <[email-masked]>
Date: Fri, 09 Jun 2000 19:44:56 -0500

hi there...

i was wondering if any of the fvwm coding gurus would point me in the
right direction in order to implement the SqueezeTitleBars funtionality
that is in twm...

basically SqueezeTitleBars makes the title bar about 1/3rd the width of
the window...

i've tried poking around with this a bit but have had no success

thanks much
-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Jun 2000 17:05:45 +0200

> i've tried poking around with this a bit but have had no success

Well, this enhancement request is waiting to be done for a while
now.  I thought a bit about a possible implementation, and the
best design I could come up with is this:

 1) Use the Shape X extension to hide the right half of the
    title bar.
 2) Modify the border drawing and button placement code in
    borders.c.
 3) Adapt animated window shade and opaque resizing to these
    changes.
 4) Introduce a new style (style.c, update.c, style.h, fvwm.h,
    window_flags.h).

(this all refers to the latest beta versions).

Overall this feature will become very difficult to implement.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].