Subject: FVWM: xterm, viewport, and size

From: Neil Zanella <[email-masked]>
Date: Mon, 5 Jun 2000 20:01:10 -0230 (NDT)

Hello,

I would like fvwm2 to resize xterm windows that get mapped onto
the desktop for the first time as follows: if the xterm has a
font such that its height or width is larger than the viewport
height or width then fvwm2 resizes the xterm so that it fits
entirely inside the viewport.

Is this possible?

Thanks,

Neil

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 7 Jun 2000 00:34:23 +0200

> entirely inside the viewport.

Try using the MaxWindowSize style.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Zanella <[email-masked]>
Date: Wed, 7 Jun 2000 02:35:20 -0230 (NDT)

> Try using the MaxWindowSize style.

Perhaps I should have been a little bit clearer. The MaxWindowSize style
will indeed resize the xterm window so that it is entirely contained in
the viewport but if I later decide to resize xterm so that it spans two
or more viewports then I cannot do it. It would be nice if there were
a Style option called MaxWindowStartupSize which would act exactly like
MaxWindowSize except for once the window pops up the user can resize it
to any size. The MaxWindowStartupSize would only affect the geometry of
the window when it gets mapped onto the desktop for the first time.

Thanks,

Neil