Subject: Re: FVWM: Newbie question

From: "Dave (Grizz) Glaser" <[email-masked]>
Date: Thu, 1 Jun 2000 13:20:06 -0400 (EDT)

> What exactly does "puked on me" mean?  It's impossible to help without
> proper descriptions of behavior.
> 
> I suspect the problem is that .xinitrc is a traditional Bourne shell
> script.  The >& token is a C shell (bletch ptooey) feature... although
> some Bourne-based shells, like bash, allow it too.
> 
> The equivalent to the above, in sh syntax, is:
> 
>   .../fvwm2 > fvwm-errors 2>&1

I found the problem. The syntax of FvwmButtons changed slightly between 2.0.42 and 2.2.4. I did some editing and fixed it.

Now the only problem I have is with xpm. It doesn't seem to be able to be found by the configure scripts. I followed the suggestions in the mail archive, INSTALL.fvwm, and the FAQ but to no avail.

I am trying to install on solaris 2.7. I have xpm installed in /usr/dept/xpm. I grabbed the binary package and installed it.

Here is the command I am trying to use to get it to work:

$ LDFLAGS=-R/usr/dept/xpm ./configure --with-xpm-includes=/usr/dept/xpm --with-xpm-library=/usr/dept/xpm

Dave

> 
> -- 
> -------------------------------------------------------------------------------
>  Paul D. Smith <[email-masked]>         Network Management Development
>  "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
> -------------------------------------------------------------------------------
>    These are my opinions---Nortel Networks takes no responsibility for them.
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 

 David S. Glaser  AKA Grizz	|        
 M&M Systems Administrator      | Forget virus scanning. Its all about "re-
 U201 M&ME Building 	  	| education". Preferably in a parking lot with
 Houghton, MI 49931	 	| a tire iron.   - BOFH
 [email-masked] 		|  

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 01 Jun 2000 13:58:11 -0400

"Dave (Grizz) Glaser" <[email-masked]> writes:
> I found the problem. The syntax of FvwmButtons changed slightly between 2.0.4
> 2 and 2.2.4. I did some editing and fixed it.
> 
> Now the only problem I have is with xpm. It doesn't seem to be able to be fou
> nd by the configure scripts. I followed the suggestions in the mail archive, 
> INSTALL.fvwm, and the FAQ but to no avail.
> 
> I am trying to install on solaris 2.7. I have xpm installed in /usr/dept/xpm.
>  I grabbed the binary package and installed it.
> 

Hmm, does a binary package come with header files?
There should be a file named
/usr/dept/xpm/X11/xpm.h around.

You need to tell us what error message you got.

These are my opinions---Even I take no responsibility for them

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Dave (Grizz) Glaser" <[email-masked]>
Date: Thu, 1 Jun 2000 14:10:43 -0400 (EDT)

> /usr/dept/xpm/X11/xpm.h around.

it is in /usr/dept/xpm/include/X11/xpm.h

> You need to tell us what error message you got.

Here is the error message(s) from config.cache

configure:4384: checking for XpmReadFileToXpmImage in -lXpm
configure:4403: gcc -o conftest -g -O2  -R/usr/dept/xpm conftest.c -lXpm -lXpm  
 -lSM -lICE -lX11 -lsocket  -lnsl  1>&5
ld: fatal: file /usr/dept/R6/lib/libXpm.a: unknown type, unable to process using
 elf(3E) libraries
ld: fatal: library -lXpm: not found
ld: fatal: file /usr/dept/R6/lib/libXpm.a: unknown type, unable to process using
 elf(3E) libraries
ld: fatal: library -lXpm: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
#line 4392 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char XpmReadFileToXpmImage();

int main() {
XpmReadFileToXpmImage()
; return 0; }

Don't know if this helps much.

Dave

---

From: Dan Espen <[email-masked]>
Date: Thu, 01 Jun 2000 14:39:19 -0400

> Don't know if this helps much.

Sure it helps.

The linker (ld) is looking at your archive (libXpm.a) and
saying its not a valid archive for the platform your are on.

There could be lots of causes:

. when you downloaded, you didn't download using binary mode.
. The file you downloaded is not the one your OS or OS version uses.

Tell use what OS you are using, and the steps you followed,

-or-

look in INSTALL.fvwm which points you to a source distribution of
xpm, and download and build it yourself.

Another way to check the validity of an archive is:

nm /usr/dept/R6/lib/libXpm.a

---

From: "Dave (Grizz) Glaser" <[email-masked]>
Date: Thu, 1 Jun 2000 14:52:03 -0400 (EDT)

<snip>
> Tell use what OS you are using, and the steps you followed,

Actually, it seems that somehow configure is looking at the libXpm.a file in /usr/dept/R6/lib rather than the new version of libXpm.a in /usr/dept/xpm/lib. Is there anyway to convince configure to get the right one? It is like it is not taking my config options.

I am trying to build on solaris 2.7

> xpm, and download and build it yourself.

I downloaded the binary version from the distribution in the install.fvwm file.

> nm /usr/dept/R6/lib/libXpm.a

This gives me a bunch of errors, but if I do it on /usr/dept/xpm/lib/libXpm.a it seems to work correctly.

Dave

---

From: Dan Espen <[email-masked]>
Date: Thu, 01 Jun 2000 15:09:53 -0400

"Dave (Grizz) Glaser" <[email-masked]> writes:
> Actually, it seems that somehow configure is looking at the libXpm.a file in 
> /usr/dept/R6/lib rather than the new version of libXpm.a in /usr/dept/xpm/lib
> . Is there anyway to convince configure to get the right one? It is like it i
> s not taking my config options.

Looking thru your earlier mail, I don't see how you ran configure.

You can try the way I do it:

./configure \
  --x-libraries=/usr/openwin/lib:/usr/dept/xpm/lib\
  --with-xpm-includes=/usr/dept/xpm/include \
  --with-xpm-library=/usr/dept/xpm/lib

or re-read the section in INSTALL.fvwm where it shows how to set LDFLAGS.

---

From: [email-masked] (Paul D. Smith)
Date: 01 Jun 2000 15:13:49 -0400

>> /usr/dept/xpm/X11/xpm.h around.

  dg> it is in /usr/dept/xpm/include/X11/xpm.h

Then you need to set --with-xpm-includes=/usr/dept/xpm/include, not just
/usr/dept/xpm.

  >> You need to tell us what error message you got.

  dg> Here is the error message(s) from config.cache

I assume you mean config.log here.

  dg> configure:4384: checking for XpmReadFileToXpmImage in -lXpm
  dg> configure:4403: gcc -o conftest -g -O2  -R/usr/dept/xpm conftest.c -lXpm -lXpm  
  dg>  -lSM -lICE -lX11 -lsocket  -lnsl  1>&5
  dg> ld: fatal: file /usr/dept/R6/lib/libXpm.a: unknown type, unable to process using elf(3E) libraries

It's failing because it's finding /usr/dept/R6/lib/libXpm.a instead of
/usr/dep/xpm/libXpm.a; presumably the one in /usr/dept/R6/lib isn't
correct for the architecture you're using.

I suggest changing the LDFLAGS setting to include both the -L and -R
options.

In summary, try this:

  $ LDFLAGS='-L/usr/dept/xpm -R/usr/dept/xpm' ./configure --with-xpm-includes=/usr/dept/xpm/include --with-xpm-library=/usr/dept/xpm

If that doesn't work, send the errors.  Also verify that libXpm.a is
indeed in /usr/dept/xpm, and not in /usr/dept/xpm/lib or somesuch.