Subject: Re: FVWM: java gui problem caused by WM?

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jun 2000 00:23:14 +0200

On Wed, May 31, 2000 at 05:13:21PM -0700, Peter Bismuti wrote:
> 
> 
> I'm having a problem with the WebLogic Admin console, one
> of the dialogue boxs pops up blank and cannot be killed 
> without killing the whole app.

This all looks like the dialog box crashes the whole
application.  Try using fvwm's 'Close' command to close
the window.  My guess is that the application does not
rdo anything in reply.  A 'Destroy' will certainly kill
the whole application.  Another thing you might try is
to resize the offending window (you may have to turn off
the MwmFunctions or MwmHints style - can't remember which).

> The tech at BEA said that she had never heard of the
> problem before and suggested that it might be a problem
> with the Window Manager. 

That's rubbish.  The window manager can do nothing to prevent
an application from redrawing itself (other that not mapping
its windows or killing it).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 02 Jun 2000 10:06:36 +0100

Dominik Vogt wrote:
> do anything in reply.  A 'Destroy' will certainly kill
> the whole application.

Better yet use fvwm's 'Delete' command.  If nothing happens it means the
application doesn't support the delete protocol and consequently the
fvwm 'Close' command will revert to doing a 'Destroy'.

Cheers.
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jun 2000 14:20:33 +0200

> fvwm 'Close' command will revert to doing a 'Destroy'.

Ah, not necessarily.  A destroy can fail too if the
application claims it supports the delete protocol but
does not delete itself.  That's what I tried to find
out with my suggestion.

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 Jun 2000 23:16:32 +0300

> Ah, not necessarily.  A destroy can fail too if the
                          ^^^^^^^
Dominik meant 'close' here, of course.

> does not delete itself.  That's what I tried to find

Regards,
Mikhael.