Subject: FVWM: help interpreting output from xdpyinfo

From: Peter Bismuti <[email-masked]>
Date: Wed, 24 May 2000 16:09:01 -0700

I'm having problems with my colors, I was
told to run 'xdpyinfo', I'm not sure now
to interpret the results, what should
I be looking at?
name of display:    :0.0
version number:    11.0
vendor string:    The XFree86 Project, Inc
vendor release number:    3360
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    2
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 134
focus:  window 0x5c0000e, revert to Parent
number of extensions:    19
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RECORD
    SECURITY
    SHAPE
    SYNC
    XC-APPGROUP
    XC-MISC
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1152x864 pixels (390x293 millimeters)
  resolution:    75x75 dots per inch
  depths (1):    24
  root window id:    0x26
  depth of root window:    24 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x23
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 16777215
  options:    backing-store YES, save-unders YES
  largest cursor:    32x32
  current input event mask:    0x58003d
    KeyPressMask             ButtonPressMask          ButtonReleaseMask

    EnterWindowMask          LeaveWindowMask          SubstructureNotifyMask

    SubstructureRedirectMask PropertyChangeMask       
  number of visuals:    1
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits

Thanks!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Thu, 25 May 2000 09:49:22 +0100

> number of screens:    1

You have one screen

>   depths (1):    24

of depth 24

>   number of visuals:    1

You have one visual

>     depth:    24 planes

which is a TrueColor.

What this all means is that your graphics card can display bazillions of
colors and if something isn't displaying the correct colors it isn't
because the card has run out. It's more likely to be a configuration
problem with the client.

Cheers,
Tim.

---

From: Erik Steffl <[email-masked]>
Date: Thu, 25 May 2000 10:09:38 -0700

Peter Bismuti wrote:
...
>     depth:    24 planes

  you have enough colors (all colors, as far as computer is concerned,
that is)

>     significant bits in color specification:    8 bits

  what does this mean? is it per one color (for red, green or blue)?

	erik