Subject: FVWM: alternative pager module

From: greg shebert <[email-masked]>
Date: Thu, 18 May 2000 23:12:59 -0500

does anyone know where i can get a different pager module (besides
fvwmpager)...

i can't seem to configure the pager's desktop to be an arbitrary number
of screens in a MxN configuration... it seems that the pager's desktops
are only 4 screens in a 2x2 config...

also... there doesnt seem to be any way to change the key bindings to
allow me to switch between the screens of the desktop

-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Thu, 18 May 2000 10:22:28 -0700

Previously from greg shebert
>are only 4 screens in a 2x2 config...

Generally you want to tell FVWM itself that you want more pages. For
example:

DeskTopSize 1x12

Then Pager picks this up.

>allow me to switch between the screens of the desktop

man fvwm2
/GotoPage

Should do it for you. Were you looking in the docs for FvwmPager for
this? Again, it's in the fvwm2 core.

FvwmPager isn't responsible for virtualizing the desktop -- it just
shows you that you have them. fvwm itself creates the virtual
desktops.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"It is better for people to think your [sic] a fool, than for you to open
your mouth and remove all doubts." - some fool
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 18 May 2000 10:01:19 -0700

> does anyone know where i can get a different pager module (besides

  can't help with that.

> are only 4 screens in a 2x2 config...

  you can have as many desktops as you want (well, I guess there's some
limit) each having MxN screens.

  use:

how many desktops you want:

     *FvwmPagerRows rows
          Tells fvwm how many rows of desks to  use  when  laying
          out the pager window.

     *FvwmPagerColumns columns
          Tells fvwm how many columnss of desks to use when  lay-
          ing out the pager window.

how many screens each desktop has:

DeskTopSize 4x3

> allow me to switch between the screens of the desktop

  try these:

# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left	A	CM	Scroll -20 +0
Key Right	A	CM	Scroll +20 +0
Key Up		A	CM	Scroll +0   -20
Key Down	A	CM	Scroll +0   +20

# erik: Alt-Fn to go to a specific page (like on the Linux console)
Key F1		A	M	GotoPage 0 0
Key F2		A	M	GotoPage 1 0
Key F3		A	M	GotoPage 2 0
Key F4		A	M	GotoPage 3 0
Key F5		A	M	GotoPage 0 1
Key F6		A	M	GotoPage 1 1
Key F7		A	M	GotoPage 2 1
Key F8		A	M	GotoPage 3 1
Key F9		A	M	GotoPage 0 2
Key F10		A	M	GotoPage 1 2
Key F11		A	M	GotoPage 2 2
Key F12		A	M	GotoPage 3 2

  see manual page for more.

	erik