Subject: FVWM: managing environment variables

From: greg shebert <[email-masked]>
Date: Fri, 19 May 2000 03:24:43 -0500

hi there...

i know that fvwm already manages two environment variables...
DISPLAY
DISPLAY_HOST

i would like to be able to set an environment variable via fvwm menu
functions and have this variable passed on to fvwm's children as well

anyone know how i would go about doing this?
-greg-

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: R Tapia <[email-masked]>
Date: Thu, 18 May 2000 14:39:45 -0600 (MDT)

Look at the SetEnv command in the fvwm2 manpage.

	 SetEnv variable value

Cheers,

Ron

==

--
Look at the bright side...We got a microsoft suit to send slashdot an 
email with the word "blueunderwear" in it twice.

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 May 2000 16:41:14 -0400

> i know that fvwm already manages two environment variables...

Fvwm may read those variables.  I don't think "manage" is the
right word.

> anyone know how i would go about doing this?

"Normal" UNIX behavior is for a parent process to pass all environment
variables to its children.  You can export variables before you invoke
fvwm to get the variables to the process fvwm starts.

You haven't mentioned the release of fvwm you use, but
fvwm has had the "SetEnv" command for a long time,
check the man page for your version.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: greg shebert <[email-masked]>
Date: Fri, 19 May 2000 03:49:23 -0500

thanks... i just missed it in the man page

-greg-