Subject: RE: FVWM: WindowList questions

From: [email-masked] (Arya Behzad)
Date: Wed, 24 May 2000 11:33:37 -0700

Hi Dominik.

THanks again for your help below.  Just one problem...
WindowList (CurrentPage) works just fine
WindowList (xterm) also works fine

However,
WindowList (xterm, CurrentPage)
does not work (returns an empty list). Am I doing something wrong?

Also, where is the most uptodate man pages for these features.  The man
pages on the fvwm web site does not talk about these as I believe it is for
an older version of fvwm.

THanks again.

Arya

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Dominik Vogt
> Sent: Thursday, April 20, 2000 7:51 AM
> To: Arya Behzad; fvwm
> Subject: Re: FVWM: WindowList questions
>
>
> On Thu, Apr 20, 2000 at 07:55:16AM -0700, Arya Behzad wrote:
> > Hi,
> >
> > I am new to the list and to fvwm..Great Window Manager!
> > I have looked around for the answer to the following questions but could
> > not find the answer anywhere.  So here are the questions:
> >
> > 1) Can the builtin function WindowList show the window list of windows
> > in the current page only? I know that there is no direct option for this
> > but is there any work arounds? Any plans to add such an option?
>
> Try
>
>   WindowList (CurrentPage)
>
> > 2) Is it possible for the  WindowList to show oinly windows associated
> > with a certain style only (so that I can make it show windows of a
> > certain application only, e.g. frame maker)?
>
> Yes:
>
>   WindowList (my_window_name)
>
> > 3) Can I make the result of WindowList such that certain listings have a
> > different style (eg color) than others (so that for example all xterms
> > can show up with a blue background, framemaker stuff with green, etc.).
>
> Yes.  The MenuStyle command controls the look of the window list.
> The WindowList menu uses the menustyle 'WindowList'.  This can be
> changed between two invocations.
>
> e.g.
>
>   AddToFunc WindowListXterms
>   + MenuStyle WindowList <whatever styles you like>
>   + WindowList (xterm, currentpage)
>
>   AddToFunc WindowListEmacs
>   + MenuStyle WindowList <styles>
>   + WindowList (emacs)
>
> Start the WindowList by calling the appropriate function.
>
> All this only works with the 2.3.x beta releases, though.
>
> Bye
>
> Dominik ^_^
>
> --
> Dominik Vogt, Agilent Technologies, Dept. BVS
> Herrenberger Str.130, 71034 Boeblingen, Germany
> phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
>

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Arya Behzad)
Date: Thu, 25 May 2000 08:17:07 -0700

Hi All,

I am trying to define various styles for various applications. In doing so I
have a line like:

Style "Cadence" Icon .....

The way fvwm seems to recognize the window as belonging to this class is by
the "Resource" field (if you do an identify on that window). My question is:
is there a way to recognize a particular class by looking at the "Name"
field?  THe reason is that my "Resource" forks out quite a few windows and I
want to have different Styles for these windows. The only way to do that is
to use the "Name" field.

THanks very much.

Arya

---

From: Dan Espen <[email-masked]>
Date: Thu, 25 May 2000 11:29:52 -0400

> want to have different Styles for these windows. The only way to do that is

          stylename can be a window's name,  class,  or  resource
          string.   It  may  contain  the  wildcards '*' and '?',
          which are matched in the usual  Unix  filename  manner.
          They  are  searched  in the reverse order stated.  When
          two conflicting styles apply to the  same  window,  the
          style that was changed last wins.

In a future release, we plan to enhance the style matching so that
you can control whether name, class, or resource is used in the
match.  (The above excerpt explains that they are all used currently.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 25 May 2000 10:16:44 +0200

> does not work (returns an empty list). Am I doing something wrong?

It's because of the comma (',') after the string "xterm" for some
obscure reason it is interpreted as part of the name.  This does
work:

  WindowList (xterm CurrentPage)
                  ^^

> an older version of fvwm.

The man page you have should always match the executable, i.e. if
something is not documented it is not there.  Well, I know that in
the past some features were not documented at all.  The man page on
the web site always refers to the latest stable release (i.e. 2.2.4
at the moment).  The very latest code and man page is in the current
beta release (2.3.17) or development snapshot.  You can find the
instructions how to download either on our 'downloads' page.

Bye

Dominik ^_^

---

From: [email-masked] (Arya Behzad)
Date: Mon, 29 May 2000 17:58:55 -0700

Hi Domink,

Thank again.  Your suggestion works.  One (hopefully!) last question on this
subject...

Is there a way to show windows with certain "ID"  AND others with a different ID
displayed?  In other words, if I want the windows with identifier = "Cadence" AND
windows with ID="xterm" to show up (such that the windowlist includes both such
entries), would that be possible?  I tried the obvious
windowlist (xterm* Cadence*)
windowlist (xterm* && Cadence*)
windowlist (xterm* || Cadence*)

Thanks very much.

Arya

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 May 2000 03:25:58 +0200

> windowlist (xterm* || Cadence*)

No, conditions can have only one string argument at the moment.
There is a workaround, but it won't work if you're using other
modules that list windows (e.g. FvwmIconMan):

  Style * WindowListSkip
  Style xterm* WindowListHit
  Style Cadence* WindowListHit

The first line prevents any windows from showing up in the
window list, the second and the third make xterm and
Cadence appear again.  Now you can simply invoke the window
list with

  WindowList

The drawback is that these styles also apply to many
modules, e.g. FvwmWinList, FvwmTaskBar, FvwmIconMan, ...
I.e. other windows won't show up in these modules either.
Well, you could write a function that switches these styles
before the window list is invoked:

  AddToFunc NormalWLSkip
  + i Style * WindowListHit
  + i Style FvwmIconMan WindowListSkip
  + i Style FvwmButtons WindowListSkip

  AddToFunc SpecialWLSkip
  + i Style * WindowListSkip
  + i Style rxvt* WindowListHit
  + i Style Cadence* WindowListHit
  + i UpdateStyles

  AddToFunc MyWindowList
  + i SpecialWLSkip
  + i WindowList $0 $1 $2 $3 $4 $5 $6 $7 $8 $9
  + i NormalWLSkip

Now invoke it with

  MyWindowList

Because I just coded the UpdateStyles command, this will not
work before the next beta release (2.3.19) or development snapshot
is available.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].