Subject: FVWM: Trouble configuring.

From: Jan Eliasen <[email-masked]>
Date: Thu, 4 May 2000 14:52:39 +0200 (MET DST)

Hi there.

I am having some trouble running the configure script;

Some of the output is;
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... yes
checking for Xpm 3.4f or better... no

Now, I used "--with-xpm-library=/pack/xpm/lib" and 
"--with-xpm-includes=/pack/xpm/include"
as parameters to configure and the version installed there is 3.4k (In
xpm.h it calculates the Version to 30411)

Any ideas?

-- 
Eliasen Jr.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 May 2000 09:03:36 -0400

> xpm.h it calculates the Version to 30411)

This is a guess:

You have another version of the xpm libraries installed that configure
sees first.

If thats not it, supply more info about your OS, etc.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jan Eliasen <[email-masked]>
Date: Thu, 4 May 2000 15:12:48 +0200 (MET DST)

> You have another version of the xpm libraries installed that configure
Well, there is a 3.4g installed, I think... It was installed before my
time - it says xpm-4.7?? But there is no way configure can see it - the
libraries are not in any paths. And anyway, the xpm.h for that version
says 30407.

I'm trying this on a sparc Solaris 2.6 machine.
Do I need to have any environments set? ie. LD_LIBRARY_PATH, LDFLAGS
etc.?

-- 
Eliasen Jr.
For god quote-skik, se http://www.usenet.dk/netikette/quote.html

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 May 2000 09:18:41 -0400

> Do I need to have any environments set? ie. LD_LIBRARY_PATH, LDFLAGS

Yes, you might.  Read the instructions in INSTALL.fvwm
regarding the xpm library.