Subject: FVWM: help on broken core files

From: Dominik Vogt <[email-masked]>
Date: Sat, 6 May 2000 08:59:49 +0200

I know it's not the right place to ask this question,
but according to my experiences I get 75% of my non-fvwm
related questions answered on this list and 0% on other
lists or newsgroups.

My problem is: since I upgraded from SuSE 6.2 to SuSE 6.4
(Linux 2.2.14, i386), all generated core files seem to be
corrupt.  Whenever I call gdb to get a stack trace all I
get is something like this:

  $ gdb <program> core
  warning: wrong size gregset struct in core file
  warning: wrong size fpregset struct in core file
  #0  0x0 in ?? ()
  (gdb) where
  #0  0x0 in ?? ()

I've already tried to recompile gdb, but to no avail.  With
my old SuSE 6.2 (kernel 2.2.10), fvwm's core dumps were
about 1.5 meg, but not they are only 300k.  I guess there
is a connection.  I can vaguely remember that there is some
way to reduce the information in a core file, but perhaps
this was on AIX.  BTW, of course I do not limit core dump
size with ulimit.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Jose' Manuel Pereira" <[email-masked]>
Date: Mon, 8 May 2000 20:09:48 +0100 (WEST)

"DV" == Dominik Vogt <[email-masked]> writes:

  DV> I know it's not the right place to ask this question, but according to
  DV> my experiences I get 75% of my non-fvwm related questions answered on
  DV> this list and 0% on other lists or newsgroups.

>:-)

  DV> My problem is: since I upgraded from SuSE 6.2 to SuSE 6.4 (Linux 2.2.14,
  DV> i386), all generated core files seem to be corrupt. Whenever I call gdb
  DV> to get a stack trace all I get is something like this:

  DV> $ gdb <program> core warning: wrong size gregset struct in core file
  DV> warning: wrong size fpregset struct in core file #0 0x0 in ?? () (gdb)
  DV> where #0 0x0 in ?? ()

Mm. You need to recompile gdb.

  DV> I've already tried to recompile gdb, but to no avail.

The plot thickens...

  DV> With my old SuSE 6.2 (kernel 2.2.10), fvwm's core dumps were about 1.5
  DV> meg, but not they are only 300k. I guess there is a connection. I can
  DV> vaguely remember that there is some way to reduce the information in a
  DV> core file, but perhaps this was on AIX. BTW, of course I do not limit
  DV> core dump size with ulimit.

Aha. You are using a new(er) gcc/egcs version. I remember reading something about
cleverer management of symbol tables in the last release (2.95.?)

Probably you'll need an updated version of gdb... AND of binutils (perhaps
upgrading this one will suffice).

Cumprimentos,
-- 
 Jose' Pereira				 		Tel. +351.21.841 9340
 DEEC - Dep. of Electrical and Computer Engineering	Fax. +351.21.841 7499
 Instituto Superior Tecnico - Technical University of Lisboa
 Av. Rovisco Pais - 1049-001 Lisboa - Portugal
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 May 2000 07:22:01 +0200

> upgrading this one will suffice).

THanks for the reply, my problem was already solved offline.
Downloading the latest gdb rpm from the SuSE support site
fixed the problem.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].