Subject: FVWM: Installation problems

From: Oleg Ilushin <[email-masked]>
Date: Tue, 04 Apr 2000 16:15:26 +0200

I have installed xpm-3.4k under /usr/local/xpm .
 I tried to run `configure` with:

           --with-xpm-library=/usr/local/xpm/lib
           --with-xpm-includes=/usr/local/xpm/include   ,

  but I still get "Xpm library or header not found!" message.

 (I have fvwm2 installed fvwm2 under /usr/local/fvwm2
   using option --prefix=/usr/local/fvwm2

  CONFIGURE OUTPUT:

creating cache ./config.cache
checking for a BSD compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable modal dialogs for applications... yes
checking whether to enable saveunders for pop-up menus... yes
checking whether to enable shape extensions... yes
checking whether to enable ActiveDown button state... yes
checking whether to enable Inactive button state... yes
checking whether to enable MiniIcon style option... yes
checking whether to enable vector button style... yes
checking whether to enable pixmap button style... yes
checking whether to enable gradient button style... yes
checking whether to enable stacked button styles... yes
checking whether to enable styled title-bars... yes
checking whether to enable BorderStyle command... yes
checking whether to enable UseDecor style option... yes
checking whether to enable WindowShade function... yes
checking whether to enable debugging messages... no
checking iconpath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... no
checking for cc... cc
checking whether the C compiler (cc  ) works... yes
checking whether the C compiler (cc  ) is a cross-compiler... no
checking whether we are using GNU C... no
checking whether cc accepts -g... yes
checking how to run the C preprocessor... cc -E
checking for POSIXized ISC... no
checking for minix/config.h... no
checking for stdarg.h... yes
checking for vfprintf... yes
checking for waitpid... yes
checking for c++... no
checking for g++... no
checking for gcc... no
checking for CC... CC
Using CC to compile C++ programs
checking for c++... (cached) CC
checking whether the C++ compiler (CC  ) works... yes
checking whether the C++ compiler (CC  ) is a cross-compiler... no
checking whether we are using GNU C++... no
checking whether CC accepts -g... yes
checking for X... libraries /usr/openwin/lib, headers
/usr/openwin/include
checking whether -R must be followed by a space... no
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... no
checking for gethostbyname in -lnsl... yes
checking for connect... no
checking for connect in -lsocket... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for cpp... /usr/ccs/lib/cpp
checking for a BSD compatible install... ./install-sh -c
checking whether ln -s works... yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... ranlib
checking for flex... no
checking for lex... lex
checking for flex... (cached) lex
checking for yywrap in -ll... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... no
checking for bison... no
checking for byacc... no
checking for ANSI C header files... yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for stdlib.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for unistd.h... yes
checking for getopt.h... no
checking for sys/select.h... yes
checking for sys/systeminfo.h... yes
checking for working const... yes
checking for inline... no
checking for off_t... yes
checking for pid_t... yes
checking for size_t... yes
checking return type of signal handlers... void
checking for strftime... yes
checking for gettimeofday... yes
checking for mkfifo... yes
checking for putenv... yes
checking for select... yes
checking for setvbuf... yes
checking for socket... no
checking for waitpid... (cached) yes
checking for strdup... yes
checking for strstr... yes
checking for strtol... yes
checking for memmove... yes
checking for memcpy... yes
checking for strchr... yes
checking for sysconf... yes
checking for uname... yes
checking for div... yes
checking for sigaction... yes
checking for siginterrupt... yes
checking for sig_atomic_t... yes
checking whether setvbuf arguments are reversed... no

checking for sys/types.h... yes
checking for sys/time.h... yes
checking for sys/select.h... (cached) yes
checking for sys/socket.h... yes
checking types of arguments for select()... int,fd_set *,struct timeval
*
checking for gethostname... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for strerror... yes
checking for usleep... yes
checking for atexit... yes
checking for XpmReadFileToXpmImage in -lXpm... no
checking for rplay_create in -lrplay... no
checking for readline in -lreadline... no
checking for readline in -lreadline... no
updating cache ./config.cache
creating ./config.status
creating Makefile
creating libs/Makefile
creating fvwm/Makefile
creating modules/Makefile
creating extras/Makefile
creating utils/Makefile
creating docs/Makefile
creating icons/Makefile
creating sample.fvwmrc/Makefile
creating tests/Makefile
creating modules/FvwmAnimate/Makefile
creating modules/FvwmAudio/Makefile
creating modules/FvwmAuto/Makefile
creating modules/FvwmBacker/Makefile
creating modules/FvwmBanner/Makefile
creating modules/FvwmButtons/Makefile
creating modules/FvwmCpp/Makefile
creating modules/FvwmEvent/Makefile
creating modules/FvwmForm/Makefile
creating modules/FvwmIconBox/Makefile
creating modules/FvwmIconMan/Makefile
creating modules/FvwmIdent/Makefile
creating modules/FvwmM4/Makefile
creating modules/FvwmPager/Makefile
creating modules/FvwmRearrange/Makefile
creating modules/FvwmSave/Makefile
creating modules/FvwmSaveDesk/Makefile
creating modules/FvwmScroll/Makefile
creating modules/FvwmTalk/Makefile
creating modules/FvwmWinList/Makefile
creating extras/FvwmCommand/Makefile
creating extras/FvwmConfig/Makefile
creating extras/FvwmConsole/Makefile
creating extras/FvwmDebug/Makefile
creating extras/FvwmGoodStuff/Makefile
creating extras/FvwmPipe/Makefile
creating extras/FvwmScript/Makefile
creating extras/FvwmScript/Scripts/Makefile
creating extras/FvwmScript/Scripts/some_nice_icons/Makefile
creating extras/FvwmScript/Widgets/Makefile
creating extras/FvwmTaskBar/Makefile
creating extras/FvwmWharf/Makefile
creating config.h

Configuration:

  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 5 Apr 2000 01:56:48 +0200

>   but I still get "Xpm library or header not found!" message.
...
> checking for XpmReadFileToXpmImage in -lXpm... no

Please post relavent lines about xpm from your config.log.

Regards,
Mikhael.