Subject: FVWM: Icons for application

From: Ali Faour <[email-masked]>
Date: Thu, 27 Apr 2000 13:50:04 -0400

I installed FVWM-2.2.4 and I would like to use xpm icons. How do I do
that?
In fvwm2rc I did the following:

    Style "XTerm"       Icon xterm1.xpm ....

but still, when I iconnify xterm it use the standard icon while
xterm1.xpm is
another icon.

Thanks for help

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Apr 2000 14:13:44 -0400

> but still, when I iconnify xterm it use the standard icon while

Whats the "standard icon"?

Order matters with Style statements.

You need to put the most general Style statements first:

Style "*" Icon default.xpm
Style "XTerm" Icon xterm1.xpm

Use FvwmIdent to find the names associated with your xterm window.
For me its:

Name: fork -- /u/dane
Class: XTerm
Resource: xterm

The style statement can match any one of these.

If I had:

Style "XTerm" Icon xterm1.xpm
Style "f*" Icon fork.xpm

the second one would be used.

Hope this helps.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].