Subject: Re: FVWM: 2.3.16 -- does not grant Eterm's -x option

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 Apr 2000 13:44:44 +0200

On Tue, Mar 07, 2000 at 10:34:09PM +0000, Andrey wrote:
> Eterm has a nice -x option, which causes it to have no borders, title or any
> other 'beautification' from the window manager. This option worked OK up until
> 2.3.13 (which is the second to last of the devels I have compiled). I just
> compiled 2.3.16 and the option ceased to work.
> 
> Also I tried using "Style <mytitle> NoHandles" shich did not work...
> "Style <mytitle> NoTitle" left the border intact, even though it removed the
> title (as it should)...

Tim Phipps wrote:

> The fact the Eterm could make borders disappear in 2.3.13 is a
> mis-feature of Eterm. It used to work because the window borders were a
> direct ancestor of the Eterm window and it fails now because they are
> now an aunt.
> 
> If an X program wants a borderless window it can use the Motif or
> OpenLook window manager hints (which have been working for years).
> Admittedly, it can't switch the borders on and off once it has started.

I finally had the time to check this myself.  The latest
cvs sources (fvwm) do grant Eterm's -x option.  Furthermore
I checked the latest stable Eterm versions (0.8.9 and 0.8.10).
Eterm *does* use Motif hints, so I think we don't have to do
anything here.  The problem probably was temporarily caused by
some of my 'Style' changes.  Or are there any reasons why this
still is a problem?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Mon, 17 Apr 2000 10:19:08 +0100

> some of my 'Style' changes.  Or are there any reasons why this

I got that wrong didn't I.  Eterm -x stopped working at just about the
same time as the the reparenting structure changed and I thought that
was the reason. Never mind, just ignore me, looks like this bug is
fixed.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Apr 2000 13:06:11 +0200

> was the reason. Never mind, just ignore me, looks like this bug is

Did you see this problem, Tim?  I didn't have the time to
test it when it was reported.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Mon, 17 Apr 2000 13:23:49 +0100

> test it when it was reported.

I honestly can't remember.

Cheers,
Tim.