Subject: FVWM: cannot find crt0.o

From: Ali Faour <[email-masked]>
Date: Wed, 19 Apr 2000 09:38:59 -0400

Hi,

   When running configure, I am getting in the config.log the following error:

/usr/local/sparc-sun-sunos4.1.3/bin/ld: cannot open crt0.o: No such file or
directory
collect2: ld returned 1 exit status
configure: failed program was:

Do you know how I can fix that?

Please reply to [email-masked]

Thanks

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 19 Apr 2000 10:22:02 -0400

%% Ali Faour <[email-masked]> writes:

  af> When running configure, I am getting in the config.log the
  af> following error:

  af> /usr/local/sparc-sun-sunos4.1.3/bin/ld: cannot open crt0.o: No such file or
  af> directory
  af> collect2: ld returned 1 exit status
  af> configure: failed program was:

  af> Do you know how I can fix that?

Not really.  Your GCC hasn't been properly installed.  This is a problem
for GCC folks, not us.  Once your compiler works, if you then have
problems building FVWM, please contact us again.  You should be able to
do this:

  $ cat > hello.c <<EOF
  #include <stdio.h>
  int main() { printf("Hello world!\n"); return 0; }
  EOF

  $ gcc -o hello hello.c

  $ ./hello
  Hello world!

Once that works, you know your compiler is OK.

BTW, you can get pre-built versions of most GNU tools, including GCC,
for most Sun platforms in Sun package format for easy installation at:

  http://www.sunfreeware.com/

HTH.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].