Subject: FVWM: Pixmap window buttons and bevels

From: Douglas Straub <[email-masked]>
Date: Sun, 02 Apr 2000 08:42:57 -0500

Hi,
    I can't seem to get rid of the bevels that go around the buttons on
window decorations.  I am using
pixmaps for the buttons, and the buttons are rectangular(not square).
Is this what -- flat is supposed
to do?  Any suggestions?  I am using 2.3.25, and here is the releveant
code:

DestroyDecor XMac
AddToDecor XMac
+ BorderStyle  Active (TiledPixmap border_pixel-active.xpm -- flat
HiddenHandles NoInset) Inactive (TiledPixmap border_pixel-inactive.xpm
-- flat HiddenHandles NoInset)
#+ ButtonStyle All (-- flat)
+ TitleStyle     Height 21 Top
     HilightColor   black,\
     WindowFont    -adobe-times-bold-r-*-*-8-*-*-*-*-*-*-*
+ TitleStyle ActiveDown (TiledPixmap title-active.xpm -- Flat) \
             ActiveUp (TiledPixmap title-active.xpm -- flat) \
             Inactive (TiledPixmap title-inactive.xpm -- Flat)
+ ButtonStyle 1 ActiveUp (Pixmap yellow-active.xpm -- flat) \
        ActiveDown (Pixmap yellow-pressed.xpm -- flat) \
        Inactive (Pixmap yellow-inactive.xpm -- flat)
+ ButtonStyle 2 ActiveUp (Pixmap green-active.xpm -- flat) \
        ActiveDown (Pixmap green-pressed.xpm -- flat) \
        Inactive (Pixmap green-inactive.xpm -- flat)
+ ButtonStyle 3 ActiveUp (Pixmap red-active.xpm -- flat) \
        ActiveDown (Pixmap red-pressed.xpm -- flat) \
        Inactive (Pixmap red-inactive.xpm -- flat)
+ ButtonStyle 4 ActiveUp (Pixmap clear-active.xpm -- flat) \
        ActiveDown (Pixmap clear-pressed.xpm -- flat) \
        Inactive (Pixmap clear-inactive.xpm -- flat)

Any help is appreciated.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 3 Apr 2000 11:03:42 +0200

On Sun, Apr 02, 2000 at 08:42:57AM -0500, Douglas Straub wrote:
> Is this what -- flat is supposed to do?

Yes.  The order in which you add the individual ButtonStyles may
have an effect if it works or not.  Try the ButtonStyle commands
in sample.fvwmrc/system.fvwm2rc-sample-95 as a starting point:

  TitleStyle ActiveUp (solid DarkBlue -- Flat)                                    
  TitleStyle ActiveDown (solid DarkBlue -- Flat)                                  
  TitleStyle Inactive (solid grey51 -- Flat)                                      
  ButtonStyle all -- UseTitleStyle Flat                                           
  AddButtonStyle 2 Pixmap mini.winXX-close.xpm                                    
  ...

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].