Subject: FVWM: Fvwm newbie's questions (problems with FvwmTaskBar)

From: [email-masked] (Gregory A. Shimansky)
Date: 13 Apr 2000 18:42:04 +0400

Hello here :)

I use FvwmTaskBar and encountered two strange things with it.

1. It does not display any mail button when I have new mail even though I have
#define MINI_ICONS 1
in config.h file.

2. When I press the Start button a menu is called but it stays depressed
untill I restart task bar.

My task bar settings are the following:

*FvwmTaskBarGeometry +0-0
*FvwmTaskBarAutoStick
*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAction Click1 Iconify -1,Raise, Focus
*FvwmTaskBarAction Click2 Module "FvwmIdent" FvwmIdent
*FvwmTaskBarAction Click3 Focus, Iconify
*FvwmTaskBarShowTips
#*FvwmTaskBarMailCommand Exec exec xterm -e pine
*FvwmTaskBarMailCommand Desk 2
*FvwmTaskBarSelFont 6x9
*FvwmTaskBarFont 6x9
*FvwmTaskBarStatusFont 7x13
*FvwmTaskBarFore navy
*FvwmTaskBarBack cadetblue
*FvwmTaskBarTipsBack lightyellow
#*FvwmTaskBarHighlightFocus
*FvwmTaskBarStartMenu RootMenu
*FvwmTaskBarBellVolume 100
*FvwmTaskBarMailBox /var/mail/gregory

Thanks in advance.
--
Gregory
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Apr 2000 09:34:29 +0200

> 1. It does not display any mail button when I have new mail even though I have

Please try if this still is the case with the latest beta releases.
I think there was a fix a while ago, but I'm not sure.

> untill I restart task bar.

This is fixed since the 2.3.1 beta release.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Gregory A. Shimansky)
Date: 14 Apr 2000 17:52:55 +0400

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

>> 1. It does not display any mail button when I have new mail even though I have

DV> Please try if this still is the case with the latest beta releases.
DV> I think there was a fix a while ago, but I'm not sure.

>> untill I restart task bar.

DV> This is fixed since the 2.3.1 beta release.

Thank you, I upgraded to fvwm
[FVWM][main]:  Fvwm Version 2.3.15 compiled on Apr 14 2000 at 15:07:02
[FVWM][main]:  with support for:  ReadLine RPlay Stroke XPM IMLIB Session
beta and a lot of things started to ork as I want them to :)

But... I encountered two new problems with task bar.

1. The mail mini icon started to appear when I get new mail but the action
that I want it to do (switch to desk 2 where my mailer lives) does not
work, it just makes the icon blank.

2. Something is wrong with task bar tips now. Instead of showing little
yellow window with window name it shows two strange lines, somewhat like
this:

                                    |
        ----------------------------+
---------------------------------------------------
[Start] [Netsca...] [Netsca...] [Netsca...] [18:00]
---------------------------------------------------
           ^
         Mouse pointer

The length of the bottom line seems to be the same as needed for the tip
but no text is drawn... :(

My task bar settings are the following.
# FvwmTaskBar
*FvwmTaskBarGeometry +0-0
*FvwmTaskBarAutoStick
*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAction Click1 Iconify -1,Raise, Focus
*FvwmTaskBarAction Click2 Module "FvwmIdent" FvwmIdent
*FvwmTaskBarAction Click3 Focus, Iconify
*FvwmTaskBarShowTips
*FvwmTaskBarDeskOnly
#*FvwmTaskBarMailCommand Exec exec xterm -e pine
*FvwmTaskBarMailCommand GotoDesk 0 2
*FvwmTaskBarMailCheck 5
*FvwmTaskBarSelFont 6x9
*FvwmTaskBarFont 6x9
*FvwmTaskBarStatusFont 7x13
*FvwmTaskBarFore navy
*FvwmTaskBarBack cadetblue
*FvwmTaskBarIconFore navy
*FvwmTaskBarIconBack grey
*FvwmTaskBarFocusFore navy
*FvwmTaskBarFocusBack gold
*FvwmTaskBarTipsBack lightyellow
*FvwmTaskBarTipsFore black
#*FvwmTaskBarHighlightFocus
*FvwmTaskBarBellVolume 100
*FvwmTaskBarMailBox /var/mail/gregory
*FvwmTaskBarStartName Start
*FvwmTaskBarStartMenu RootMenu
*FvwmTaskBarStartIcon mini.fvwm.xpm

Thanks in advance.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 15 Apr 2000 21:49:45 +0200

> But... I encountered two new  problems with task bar.

Hello,
I've tested your TaskBar config.

> work, it just makes the icon blank.

One click blank the icon (you see that a mail arrives and so you will see
if a new one arrives). Double click will do the action you want.

> yellow window with window name it shows two strange lines, somewhat like

I'm unable to reproduce this problem. The tip work normally on my machine
with your config. You say that you have two strange lines and that's all.
This is strange: do you have a black box that "fill" this 2 lines? May be
you can send a little screen shot to the [email-masked] mailing
list.

Answer to the following questions may help debugging
- What happen if you use 
*FvwmTaskBarTipsBack white
*FvwmTaskBarTipsFore black
- Do you have the same problem if netscape does not run. 
Say that you can make a test with only an xterm running. 
Netscape use a lot of colors and can cause problems. There are 
solutions to solve this but I do not know them.

Olivier

---

From: [email-masked] (Gregory A. Shimansky)
Date: 17 Apr 2000 15:43:25 +0400

>>>>> "OC" == Olivier Chapuis <[email-masked]> writes:

>> work, it just makes the icon blank.

OC> One click blank the icon (you see that a mail arrives and so you will see
OC> if a new one arrives). Double click will do the action you want.

Thanks, it works :)

>> yellow window with window name it shows two strange lines, somewhat like

OC> I'm unable to reproduce this problem. The tip work normally on my machine
OC> with your config. You say that you have two strange lines and that's all.
OC> This is strange: do you have a black box that "fill" this 2 lines? May be
OC> you can send a little screen shot to the [email-masked] mailing
OC> list.

Screenshot is in attachment.

OC> Answer to the following questions may help debugging
OC> - What happen if you use 
OC> *FvwmTaskBarTipsBack white
OC> *FvwmTaskBarTipsFore black
OC> - Do you have the same problem if netscape does not run. 
OC> Say that you can make a test with only an xterm running. 
OC> Netscape use a lot of colors and can cause problems. There are 
OC> solutions to solve this but I do not know them.

I changed FvwmTaskBarTipsBack and FvwmTaskBarTipsFore as you wrote and
restarted without netscape, tips still don't work though in xcmap I see a
lot of free colors. I don't think it problem is because of lack of colors.
Tips in FvwmPager work ok, on task bar they don't :(

I encountered one more problem with new task bar:

I have *FvwmTaskBarDeskOnly in my config. If windows made stiky by style
command, they are shown on task bar on every desk. If I have a window that
is not stiky originally and make it stiky by pressing one of the buttons on
the title bar

Mouse 0		3       A       Stick

and then move to the other desk, it's shown on the screen but not shown on
the task bar.

Thanks in advance.
--
Gregory.

P.S. I use
[FVWM][main]:  Fvwm Version 2.3.15 compiled on Apr 14 2000 at 15:07:02
[FVWM][main]:  with support for:  ReadLine RPlay Stroke XPM IMLIB Session
on SUN sparc workstation with openwindows 3.6.1.