Subject: FVWM: Geometry and GTK applications

From: Dave Dribin <[email-masked]>
Date: Fri, 14 Apr 2000 18:50:22 -0500 (CDT)

Hello,

I am using fvwm 2.2.2.  I am switching over from Enlightenment since I
would like something with a bit more configurability.  One thing I cannot
figure out.  It seems man GTK applications do not accept a -geometry
option.  How can you place a GTK application at a certain screen position
under fvwm2?  Is this a limitation of GTK applications?

Thanks,

-Dave

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 Apr 2000 05:18:30 +0300

> under fvwm2?  Is this a limitation of GTK applications?

I think this is a limitation of GTK applications. AFAIK, their ideology is
that a window manager should manage window placement. Some GTK applications
implement --geometry themselves (gtop, gless), but only size, not position.

You can use FvwmEvent module, something like this:

# ------------------------------------------------------
DestroyFunc PlaceMyGtkApps
AddToFunc   PlaceMyGtkApps
+ I Next (gtop) Move 100p 100p
+ I Next (gcalc) AnimatedMove 10 10
+ I Next (ghex) Move pointer
+ I Next (gtcd) Move -0 0 Warp

DestroyModuleConfig FvwmEvent*
*FvwmEventCmd
*FvwmEvent add_window Function PlaceMyGtkApps
Module FvwmEvent
# ======================================================

I didn't test this with 2.2.2, only with the current fvwm.

Regards,
Mikhael.