Subject: FVWM: Focus

From: Matteo <[email-masked]>
Date: Fri, 24 Mar 2000 16:53:39 +0100

Hi to all
I use fvwm and fvwm2 (version >= 2.2.2)
With fvwm when I switch the mouse from one window to another the new
window bring focus and comes on top
With fvwm2 the new one bring focus but stay back
how I can bring the window on top when it brings focus??
I tryed with all type of focus with the same result..
someone know a solution???
ThanX
tidi

--
 _____ _    _ _
|_   _(_) _| (_)
  | | | |/ _ | |
  |_| |_|\_,_|_|

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Mar 2000 11:06:31 -0500

> someone know a solution???

The FvwmAuto module is responsible for automatically raising windows.

"man FvwmAuto" should give you the information you need.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Fri, 24 Mar 2000 08:57:08 -0800

I was wondering why is it a module - I always thought of this as basic
functionality of window manager. all the rest of the window manipulation
moving / resizing / focus / raise / lower) is built in, why is the auto
raise functionality in separate module? can we expect more of the
'basics' to go out into modules?

	erik

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Mar 2000 12:05:07 -0500

> 'basics' to go out into modules?

Things go into modules when:

Performance will be okay

It will save memory in the main executable

Not everone uses it

Someone made the judgement that FvwmAuto qualified.
Seems like the right decision to me.