Subject: FVWM: Need help: can't open display

From: Vitit Kantabutra <[email-masked]>
Date: Thu, 02 Mar 2000 18:27:55 -0700

I just installed fvwm, apparently successfully.  I installed it while in
gnome, on RedHat Linux 6.1 running on a 450 MHz Pentium III computer.
After installing fvwm, I quit X windows, and typed startx again.  I got
gnome again, so I quit it and this time I typed fvwm.  But it complained
that it can't open the display.  I tried various other things, but I
haven't been able to get it to work.

What should I do?

Thanks in advance.

--
Vitit Kantabutra, Ph.D.
Associate Professor of Computer Science
College of Engineering
Idaho State University
Pocatello, Idaho 83209-8060
U.S.A.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 02 Mar 2000 17:38:33 -0800

what's going on:

  X window system: a server that can display graphics (primitives like
windows, lines etc.), it does not care about desktop (window
borders/icons/menus etc...)

  widget libraries: buttons, menus, icons, scroll bars and other parts
of user interface

  window manager: program that manages windows (provides borders, means
for user to move/resize windows, ...)

  desktop environment: higher level, usually provides combination of:
basic programs, widgets with common look/feel, window manager etc...

  gnome is desktop environment, it can use one or another window manager

  fvwm is window manger. it requires X server running.

  check the gnome docs on how to change window manager.

  to try if fvwm is working:

  from virtual console type:

setenv DISPLAY :0.0 # csh, tcsh, ...
export DISPLAY=:0.0 # sh, ksh, bash, ...

X&

  this runs an X server (plain)

  switch back to virtual console and run

fvwm&

  and you should get the fvwm running (switch back to X server window to
see it)... try to click in the root window, you should get some menu.

  depending on how your X is set you might have to be root to run X,
although it might run Xwrapper by default...

	erik

---

From: Richard Lister <[email-masked]>
Date: Fri, 03 Mar 2000 11:15:17 -0500

On Thu, 02 Mar 2000 18:27:55 -0700
Vitit Kantabutra <[email-masked]> 
> haven't been able to get it to work.

Vitit

Try creating a ~/.Xclients file to start various clients when xinit
is run.

Something like this should work:

  #!/bin/sh
  rxvt &
  panel &
  gmc &
  fvwm2

or better, the following which starts fvwm2 first, but waits for it to exit:

  #!/bin/sh
  fvwm2 & WMPID=$!
  rxvt &
  panel &
  gmc &
  wait ${WMPID}

The script probably need to be executable (chmod 755 .Xclients).
Then run startx.

If this doesn't work get back to me and we'll figure something out.

Cheers
Ric

Richard J Lister
Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878.
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].