Subject: FVWM: Gnome

From: Charles Parsels <[email-masked]>
Date: Thu, 23 Mar 2000 00:53:21 +0100 (CET)

Hi,
    I am new to Linux, and FVWM. My Red Hat Linux
distribution (that's 6.1) comes with fvwm2.x and I
would like to know how you configure the X Window
System to load FVWM instead of the gnome desktop
environment? Any suggestions?

Anything appreciated!

Thank you!

__________________________________________________________________
Do You Yahoo!?
Gesendet von Yahoo! Mail - http://mail.yahoo.de
Yahoo! Mail auf Ihrem Handy? - http://mobil.yahoo.de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Phil Jensen <[email-masked]>
Date: Wed, 22 Mar 2000 19:10:47 -0500 (EST)

> environment? Any suggestions?

I changed the file '/etc/sysconfig/desktop' to contain the
single line 'AnotherLevel', referring to RH's somewhat W95-ish
decor for fvwm2 (which I personally have hacked to make less
W95-ish).  This takes effect in the script '/etc/X11/xinit/Xclients'.

  Phil

---

From: Andrey <[email-masked]>
Date: Wed, 22 Mar 2000 18:20:19 +0000 (GMT)

> environment? Any suggestions?

I change /usr/X11R6/lib/X11/xinit/xinitrc to achieve the result:

right at the end of this file there is a command to execute the window
manager.

I add something like the following:

if [ -f $HOME/.wm_style ]; then
        exec `cat $HOME/.wm_style`
elif [ -x `which fvwm2` ]; then
        exec fvwm2
else
        twm &
        xclock -geometry 50x50-1+1 &
        xterm -geometry 80x50+494+51 &
        xterm -geometry 80x20+494-0 &
        exec xterm -geometry 80x66+0+0 -name login
fi                                                  

Which simply executes whatever window manager is listed in 
$HOME/.wm_style. If this file does not exist, I default to fvwm2 or twm.

This has been tested on RH6.0 (the latest one I used before moving to BSD)

Regards: Andrey

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Wed, 22 Mar 2000 20:44:09 -0500 (EST)

I noticed that a couple of other people have responded already as to how
they managed to do this.  What I personally think is the most simple way
to do this is to put a .xsession or .Xclients file in your home directory.
If you look at the file

/etc/X11/gdm/Sessions/Default

you will see

$ cat Default 
#!/bin/bash -login

/etc/X11/xdm/Xsession

(yep, that's it...)

Now if you look at this file you will find a bunch of stuff at the top
which handles the case in which the Xsession script was called with
arguments.  In the case that no arguments were supplied (which is what
we're interested in with the Default script) the script falls back onto
this

# otherwise, take default action
if [ -x "$HOME/.xsession" ]; then
    exec "$HOME/.xsession"
elif [ -x "$HOME/.Xclients" ]; then
    exec "$HOME/.Xclients"
elif [ -x /etc/X11/xinit/Xclients ]; then
    exec /etc/X11/xinit/Xclients
else
    exec xsm
fi

So, if you simply put a .xsession file in your home directory which runs
fvwm2 you're set!  Looking at this Xsession script will suggest that one
way to do this is to call switchdesk just as they do in the case that you 
choose AnotherLevel. Another way is to call 

/usr/X11/bin/RunWM._______

where the ______ is Fvwm95 or which the decors which you want.  I'm
assuming that it's still around in the base install of RH6.1 

Of course there are many other ways as well, but I think I've more than
answered your question. :-)

Tom