Subject: FVWM: icon manager window keeps raising

From: Julian Bradfield <[email-masked]>
Date: Tue, 7 Mar 2000 18:12:02 GMT

I'm using fvwm-2.2.4.

I have SloppyFocus set by default, and an FvwmIconMan running which is 
marked ClickToFocus.
I have GlobalOpts MouseFocusClickDoesntRaise
set.
In the icon manager, button1 is bound thus:
*FvwmIconMan*Action Mouse 1 N sendcommand "Iconify -1", 
    sendcommand Raise, sendcommand Focus

The thing that infuriates me is that whenever I click in the icon
manager to raise a window, the icon manager window itself raises as
well. 

I haven't yet managed to track down why this happens. Anybody
know it off the top of their head?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Tue, 07 Mar 2000 15:12:50 -0500

> know it off the top of their head?

	Try adding 

GlobalOpts ClickToFocusDoesntRaise

and see if that doesn't help. 

	Note that in the recent betas, all those GlobalOpts have been replaced
by corollary Style options, so that in future you'll be able to specify
this behavior for only FvwmIconMan, if you like.

Cheers,
Bob