Subject: FVWM: x2vnc and page moving...

From: Kendrick Vargas <[email-masked]>
Date: Tue, 15 Feb 2000 14:27:20 -0500 (EST)

Hi there,

I have two computers at my desk, two monitors, and a flakey Belkin
OmniCube to duplex out my keyb/mouse to both boxes. One box runs Linux
(the one I use the most) and the other runs NT. I run a VNC Server on the
NT box.

I run this program called x2vnc on the linux box which creates a 1 pixel
wide window all along the left side of my screen. When the mouse enters
the window, all mouse and keyboard data are sent to the VNC server on the
NT box, in effect letting me pan across both monitors with a single mouse
and keyboard and not having to switch the Belkin :-)

This works fine on the first page (the left most). If I switch to another
page, x2vnc stops responding unless I move a window on the new page. Then,
I can flip around between the non-first pages without issue. If I switch
back into the first page OR if I manually click a window's decorations OR
if I bring another window into the foreground, x2vnc once again stops
responding. 

Running xwininfo and selecting the furthest leftmost pixel on the screen
returns this. Note that blackbird is the name of the machine running the
vnc server, so I figure the title of the window is set to this.

xwininfo: Window id: 0x7000001 "blackbird"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1
  Height: 1024
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +0+0  -1279+0  -1279-0  +0-0
  -geometry 1x1024+0+0

Switching pages to a page where vnc isn't responding and running xwininfo
again returns this. Note that the window name is missing and the window
is 1 pixel larger:

xwininfo: Window id: 0x2c00057 (has no name)

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 2
  Height: 1024
  Depth: 0
  Visual Class: TrueColor
  Border width: 0
  Class: InputOnly
  Colormap: 0x0 (not installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -1278+0  -1278-0  +0-0
  -geometry 2x1024+0+0

Then moving a window in that page to get vnc once again responding, and
running xwininfo on it returns this:

xwininfo: Window id: 0x7000001 "blackbird"

  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1
  Height: 1024
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +0+0  -1279+0  -1279-0  +0-0
  -geometry 1x1024+0+0

I don't know if this is a problem with fvwm2 or with x2vnc (X11
maybe?) where it appears that the window is getting lost or something. In
any case is there someone else who's seen this or can help me? 

I am running the 20000214 cvs snapshot from the ftp server, XFree86 3.3.5
(shipped with RedHat 6.1), and a combination of Gnome and Fvwm.
			-peace

--- BEGIN GEEK CODE BLOCK ------------+-----------
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) | "In the morning glad I see
P>+ L+(++) E---- W+++ N+ o? K? w++++  |  My foe outstrech'd beneath the tree."
O--- M-- V PS+++@ PE Y-- PGP+ t++ 5   |               -The Poison Tree
X++ R- tv+ b DI++ D+ G e>*  h*(!) r-  |                William Blake
y*(+) ------ END GEEK CODE BLOCK -----+

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Tue, 15 Feb 2000 11:51:00 -0800

Previously from Kendrick Vargas
>if I bring another window into the foreground, x2vnc once again stops

It looks like the PanFrames are getting the stacking order out of
whack. I don't remember how (or if you can) fiddle with the PanFrames
anymore, but I know some work was done on this a while back. Maybe
there's a runtime option now pertaining to the PanFrames? I assume
you've setup EdgeResistance or the other EdgeMumble option are set not
to change pages at the screen edge. Basically, try to turn the
PanFrames off if you don't use the mouse to pan the display across the
virtual screen.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
To understand recursion you must first understand recursion.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kendrick Vargas <[email-masked]>
Date: Tue, 15 Feb 2000 15:14:54 -0500 (EST)

> PanFrames off if you don't use the mouse to pan the display across the

Thanx much!

I never wanted the Edge scrolling stuff to work in my configuration (I
found it annoying) so I set the EdgeResistance to some ridiculously high
number. Your post got me to looking at the Edge* stuff in the man page and
I noticed the EdgeThickness option. I set EdgeThinkness to 0 and all is
now good!

Thanx :-)
			-peace