Subject: FVWM: FVWM 2.3.14 - New Style usage?

From: "Brennan Cropper" <[email-masked]>
Date: Thu, 24 Feb 2000 10:03:51 +0000

Dominik,

I just compiled the new 2.3.14 release, and some of my Style commands
don't seem to be taking effect.  I checked the Changelog and noticed
that you changed the files dealing with styles yesterday.  Could you
shed some light on why the following config isn't working totally
correct?  The one thing that I noticed right away was that my
BorderWidth and HandleWidth commands aren't working.  Also, all of my
Fvwm* windows are coming up with titles and handles.  Any idea?

Thanks a bunch,
Brennan

P.S.  I get the debug statement "adding style '<style_name>'" for each
style command.

# Comment the above and uncomment one of the following if you prefer  
# focus follow mouse.
Style "*" SloppyFocus

# If we use the FvwmTaskBar we don't need the icons :-)
# Style "..." Icon are also commented below.
Style "*" NoIcon
Style "*" MWMFunctions
Style "*" HintOverride
Style "*" MWMDecor
Style "*" DecorateTransient

#
# RandomPlacement prevents user interaction while placing windows:
#
Style "*" RecaptureHonorsStartsOnPage, CaptureHonorsStartsOnPage
Style "*" SmartPlacement,RandomPlacement

#
# NoPPosition instructs fvwm to ignore the PPosition field in window
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
#
Style "*" NoPPosition

#
# Default border and handle widths
#
Style "*" BorderWidth 5, HandleWidth 5

# Set the decoration styles and window options
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.

# These commands should command before any menus or functions are
defined,
# and before the internal pager is started.

Style "Fvwm*"               NoTitle, Sticky, WindowListSkip
Style "Fvwm Pager"          StaysOnTop, NoHandles
Style "FvwmBanner"          StaysOnTop
Style "FvwmButtons"         NoTitle, NoHandles, Sticky, WindowListSkip,
BorderW>
Style "xlock"               NoTitle, NoHandles, Sticky, WindowListSkip
Style "workman"             Sticky, MiniIcon mini-cdlabel.xpm
Style "FvwmIconMan"         Sticky, Title, Handles, Icon
Style "FvwmTalk"            Sticky, Title, Handles, Icon
Style "xconsole"            Sticky, Title, Handles, Icon,
WindowListSkip, MiniI>
Style "Calculator"          Sticky, MiniIcon mini-calc.xpm
Style "Dtcm"                MiniIcon mini-book2.xpm

Style "QuikNotes*"          Sticky
Style "quiknotes*"          Sticky
Style "xvile"               MiniIcon mini-doc1.xpm
Style "vim"                 MiniIcon vim16x16.xpm
 
Style "xmeter"              Sticky, NoTitle, ClickToFocus
 
#
# Some mini-icons for the title bar
#
Style "*"         MiniIcon mini-x2.xpm
Style "*xterm*"   MiniIcon mini-term.xpm
Style "rxvt"      MiniIcon mini-term.xpm
Style "xcalc"     MiniIcon mini-calc.xpm
Style "xsession"  MiniIcon mini-bx2.xpm
Style "xv"        MiniIcon mini-xv.xpm
Style "Netscape*" StartsOnDesk 0,StartsOnPage 0 0,SkipMapping,MiniIcon
mini-nsc>
Style "Gtimer"    MiniIcon gtimer.xpm
Style "Vim"       MiniIcon vim16x16.xpm
Style "xmag"      MiniIcon mini-zoom.xpm
Style "textedit"  MiniIcon mini-edit.xpm
Style "tkps"      MiniIcon mini-run.xpm
Style "Ghostview" MiniIcon mini-gv.xpm
Style "Xcolorsel" MiniIcon mini-colors.xpm
Style "IDL*"      MiniIcon mini-zoom.xpm  
Style "xeyes"     MiniIcon mini-eyes.xpm
Style "*fm*"      MiniIcon mini-filemgr.xpm

# xman resource names
Style "topBox"        MiniIcon mini-book1.xpm
Style "help"          MiniIcon mini-book2.xpm
Style "manualBrowser" MiniIcon mini-book2.xpm

# xpaint resource names
Style "xpaint"        MiniIcon mini-paint.xpm
Style "Canvas"        MiniIcon mini-paint.xpm
Style "fatbits"       MiniIcon mini-paint.xpm
Style "filebrowser"   MiniIcon mini-ofolder.xpm

Style "FvwmFile"      MiniIcon mini-ofolder.xpm
Style "XDbx"          MiniIcon mini-bug2.xpm

Style "XCocos  "      MiniIcon mini-mail.xpm
Style "Synchronize"   MiniIcon mini-book2.xpm
Style "QuikNotes*"    MiniIcon mini-ray.xpm
Style "quiknotes*"    MiniIcon mini-ray.xpm
Style "Emacs"         MiniIcon mini-edit.xpm
Style "aruser"        MiniIcon mini-ars.xpm
Style "notifier"      MiniIcon mini-ars.xpm
Style "Maker"         MiniIcon mini-frame.xpm
Style "tramain"       MiniIcon mini-connect.xpm
Style "Acro*"         MiniIcon mini-pdf.xpm
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Feb 2000 11:56:32 +0100

On Thu, Feb 24, 2000 at 10:03:51AM +0000, [email-masked] wrote:
> correct?

It doesn't work because the new style merging logic was (or perhaps
still is) too aggressive.  All styles work fine, but under certain
circumstances the '*' style overrides all others, even if other
style commands are issued later.  I'm working on a fix.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 24 Feb 2000 09:29:49 -0500 (EST)

On 24 Feb, Dominik Vogt wrote:

>> don't seem to be taking effect.
> 

Since beta releases get seen by more people than the daily snapshots, could
you release a 2.3.15 version soon with this fix?

-- 
Larry Gensch                                          [email-masked]

                  "May I have ten thousand marbles, please?"