Subject: FVWM: title & border style

From: Johannes Zellner <[email-masked]>
Date: Sun, 13 Feb 2000 22:52:04 +0100 (CET)

Hello once more,

  ¹) how can I get the horizontal lines in all title bars as
     I get them for FvwmButtons title bar ?
  ²) can I change the border and handle width when a window looses
     focus? -- e.g. handle and border width to 0 if the window
     has no focus.
  ³) I like `focus follows mouse'. But: is there a focus policy
     which does the following:  If I move the pointer outside a
     window (to the root window (background)) the window where
     the pointer was in just before should keep focused as long
     as the pointer gets not moved to another window. This is
     the way wmx does.

Any help would be much appreciated.

-- 
   Johannes

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Sun, 13 Feb 2000 14:08:30 -0800

Previously from Johannes Zellner
>how can I remove the `Minimize' `Maximize' `Destroy' buttons
>from the window's decorations ?

Try:
Style * NoButton 2, NoButton 4, NoButton 6

See the man page "Style" section for more information.

>     I get them for FvwmButtons title bar ?

That's called StipledTitle, as in:

Style * StipledTitle

Stipled is misspelled, but I think there's some strange historical
reason for that. It may have been a GlobalOpt before. And it may only
have become an option in the latest betas.

>     focus? -- e.g. handle and border width to 0 if the window

In the latest betas you can. I'd hang out and wait for 2.4 for that.

>     as the pointer gets not moved to another window. This is

SloppyFocus:

Style * SloppyFocus

The man page keeps getting bigger, but it's better organized these
days. Everything you've asked about is in the man page.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
To understand recursion you must first understand recursion.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johannes Zellner <[email-masked]>
Date: Sun, 13 Feb 2000 23:27:43 +0100 (CET)

On Sun, 13 Feb 2000, Michael Han wrote:

[...]
> have become an option in the latest betas.
The man page mentions StipledTitles under GlobalOptions.
But it does not tell anywhere what this options means.
There's no Style StipledTitles at least in my fvwm2 which
comes with the latest debian potato.
But giving the keyword did help anyway.

> days. Everything you've asked about is in the man page.

thanks for your help!

-- 
   Johannes

---

From: Neil Zanella <[email-masked]>
Date: Sun, 13 Feb 2000 21:36:13 -0330 (NST)

Style * StipledTitle

>      focus? -- e.g. handle and border width to 0 if the window

Good question. To be honest I don't know. Try man fvwm2.

Style * SloppyFocus

Best Regards,

Neil

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 14 Feb 2000 10:01:56 +0100

On Sun, Feb 13, 2000 at 11:27:43PM +0100, [email-masked] wrote:
> > reason for that.

I've never thought about spelling when I made the former
GlobalOpt a style.  I see no reason why we should keep
the typo.  I'll fix it.

> > It may have been a GlobalOpt before. And it may only

Question 3.8 in the FAQ explains it.

> > days.

Glad that somebody notices :-)

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johannes Zellner <[email-masked]>
Date: Tue, 15 Feb 2000 10:21:01 +0100 (CET)

[...]
[...]

well, I got the latest source from cvs noticing that the man
page grew from 4000 (as it comes with debian) to over 6000
lines :-)
But I still didn't find out howto get zero with border
when the window looses focus.

btw. I've a vim syntax file
    http://www.zellner.org/vim/syntax/fvwmcpp.vim
which does correct syn highlighting for FvwmCpp config files.

-- 
   Johannes

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 11:06:16 +0100

> when the window looses focus.

You can't really do this.  You could let FvwmEvent modify
the style when windows are focused/unfocused, but that
will apply to all matching windows, not just the window
that has lost/acquired focus.  I'm planning to implement
state dependent styles after the 2.4 release.

Bye

Dominik ^_^

---

From: [email-masked] (Danny Dulai)
Date: 15 Feb 2000 15:07:37 -0000

>state dependent styles after the 2.4 release.

How can you change the style of a window (window name basis is ok until 2.4
allows me to avoid that) when it unfocuses? I got the focus part, I can't
get the unfocus part.

-- 
___________________________________________________________________________
Danny Dulai                                           Feet. Pumice. Lotion.
http://www.ishiboo.com/~nirva/                            [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 17:06:33 +0100

> allows me to avoid that) when it unfocuses? I got the focus part, I can't

The 'Prev' command should select the window last window that
had the focus.

Bye

Dominik ^_^