Subject: RE: FVWM: functions w/ params sluggish

From: "Pietralla, Siegfried" <[email-masked]>
Date: Fri, 18 Feb 2000 09:33:10 +1100

i think i've sussed this just by pure chance! it looks as though fvwm is
waiting for the (absence of the) second click before it can decide what it
is to do. i've noticed that certain functions seem to take a while for no
readily apparent reason. then i was playing around with the following:

Mouse 1      WTFSI  SC     Move-or-Lower
Mouse 3      WTFSI  SC     Move-or-Raise

AddToFunc Move-or-Raise
+         "I" Raise
+         "M" Move
+         "D" Lower

AddToFunc Move-or-Lower
+         "C" Lower
+         "M" Move

and i noticed that the mb3 function waits while mb1 is immediate - curious.
looking at the above the only thing i can imagine is that fvwm has to wait
for the double click timeout to expire to be sure whether it's a single or
double click. i hope someone can confirm this?

regards,
siegfried.

> ----------
> From: 	Elliot Sowadsky[SMTP:[email-masked]]
> Sent: 	Friday, 18 February 2000 09:07
> To: 	[email-masked]
> Subject: 	FVWM: functions w/ params sluggish
> 
> 
> I just changed my fvwm2rc to using one general function, feeding it
> parameters instead of having multple unique functions.
> 
> 
> AddToFunc "Clk-Dclk-HldMv" "C" $0
> +		"D" $1
> +		"H" $2
> +		"M" $2
> 
> Mouse 1		I	A	Clk-Dclk-HldMv Iconify Nop
> Winlistfunc
> 
> and i find that there's a noticeable delay if i do it this way instead of
> calling a unique function to do the same thing.
> 
> Even this is slow to (de)Iconify...
> 
> AddToFunc "Clk-Dclk-HldMv" "C" Iconify
> +		"D" $1
> 
> Mouse 1		I	A	Clk-Dclk-HldMv Nop
> 
> 
> 
> fvwm 2.3.13
> solaris 2.51 on ultra 1
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 18 Feb 2000 09:42:30 +0100

> double click. i hope someone can confirm this?

Exactly.  BTW, the delay only occurs if you hold the button but
don't start moving.  So, although the cursor doesn't change to the
move cursor, you can still start moving the window.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].