Subject: Re: FVWM: Re: MouseOver/Focus event handler?

From: [email-masked] (Danny Dulai)
Date: 15 Feb 2000 14:53:07 -0000

On 12/15/99, Brad Giaccio said:
>On Wed, Dec 15, 1999 at 10:55:53AM -0800, Nadim Saeed wrote:
>>  > *FvwmEventPassId
>>  > *FvwmEvent focus_change my_focusevent
>>  >
>>  > DestroyFunc my_focusevent
>>  > AddToFunc my_focusevent I WindowId $0 (!FvwmIconMan) AnimatedMove -1150p 0p
>>  > +                       I WindowId $0 (FvwmIconMan) AnimatedMove 0 0
>>  >
>>  > AddToFunc StartFunction I FvwmEvent
>>  >
>> 
>> This is beginning to sound very much like an AutoHide command.  Could someone
>> familiar enough with the code use the underlying ability noted above and
>> simply its specification and possibly create a true "autohide" command/style ?
>> 
>> It was be ideal to see something along the lines of,
>> 
>>    Style "Fvwm*"   AutoHide
>> 
>> BTW: this very much relates to PR#466 in the enhancements branch of FVWM's bug
>>      tracker.
>> 
>
>This is untested but if we the function was changed to 
>AddToFunc my_focusevent I WindowId $0 (!$1) AnimatedMove -1150p 0p
>+                       I WindowId $0 ($1) AnimatedMove 0 0
>
>and 
>*FvwmEvent focus_change my_focusevent FvwmIconMan

I'm trying to add title bars to my windows when they get focus, and remove
them when they leave focus, I have this so far:

*FvwmEvent focus_change my_focusevent
AddToFunc my_focusevent "I" WindowId $0 Style $n Title

Now the title gets added, but I'm not sure how to find out which window was
just unfocused so I can remove the titles. I'm using Sloppyfocus btw.

-- 
___________________________________________________________________________
Danny Dulai                                           Feet. Pumice. Lotion.
http://www.ishiboo.com/~nirva/                            [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johannes Zellner <[email-masked]>
Date: Tue, 15 Feb 2000 17:28:07 +0100 (CET)

> just unfocused so I can remove the titles. I'm using Sloppyfocus btw.

aah. great. exactly what I'd need. Remove Borders and Titles from
windows which don't have input focus.
If you manage to get this working would you mind sending me
the setup ? -- That would be great.

-- 
   Johannes

---

From: [email-masked] (Danny Dulai)
Date: 15 Feb 2000 16:35:00 -0000

*FvwmEvent        focus_change my_focusevent
AddToFunc my_focusevent "I" Current (!Fvwm*) Style $n Title
+                       "I" Prev (!Fvwm*) Style $n NoTitle

I don't want my Fvwm* windows having titles ever.

This is pretty annoying tho, since it moves the windows up and down :(

It'd be much cooler to be able to move the windows up and show the border,
but that flickers really bad :(

Anyone have any ideas on toggling the titlebars without moving the actual
window (just moving the windowmanager controled parent)?

---

From: Tim Phipps <[email-masked]>
Date: Tue, 15 Feb 2000 16:40:09 +0000

> window (just moving the windowmanager controled parent)?

Style * TitleAtBottom

---

From: [email-masked] (Danny Dulai)
Date: 15 Feb 2000 16:56:21 -0000

>> window (just moving the windowmanager controled parent)?

great, this works well :)

So now everything is almost working with titles showing only on the focused
window. 
Only thing left is that I'd like to just have the title show on the window
that has the focus, not any window with that same name. any suggestions?
Dominik hinted he might be doing something to allow Styles per window, if I
didnt misunderstand him. Is this possible in the latest snapshots?

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 18:08:18 +0100

> didnt misunderstand him. Is this possible in the latest snapshots?

No way.  This is a future enhancement that won't make it into
the next stable release.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Danny Dulai)
Date: 15 Feb 2000 17:25:32 -0000

>No way.  This is a future enhancement that won't make it into

How about unstable snapshots or even cvs?

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Feb 2000 09:41:09 +0100

> How about unstable snapshots or even cvs?

:-)  As I said: no way.  We're deep into feature freeze for
2.4 and such big changes won't be implemented anymore.

Bye

Dominik ^_^