Subject: RE: FVWM: fvwm2 on solaris 7

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 3 Feb 2000 14:54:45 -0600

how do you run the fvwm? from xterm?

  can you run other X programs?

  what happens when you explicitly use -display option?

  are you running the fvwm locally or on the other machine - chances are you
do not have right to connect to X server...

  in the error message - does it literally say hostname or is there the real
(correct) value there?

  you need to give some more information...

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> babu chakrapani
> Sent: Thursday, February 03, 2000 12:17 PM
> To: Dan Espen
> Cc: [email-masked]
> Subject: Re: FVWM: fvwm2 on solaris 7
> 
> 
> 
> 
> 
> Still seeing the same problem.. 
> version is 2.2.4.
> 
> Still says cannot open display. DISPLAY variable is ok
> and is exported.
> 
> Confused,
> BC.
> 
> --- Dan Espen <[email-masked]> wrote:
> > babu chakrapani <[email-masked]> writes:
> > > 
> > > Hello,
> > > 
> > > I installed fvwm2 under solaris 7. when I run
> > fvwm2,
> > > 
> > > I get an error 
> > > 
> > > [FVWM][main]: <<ERROR>> can't open display
> > > <hostname:0.0>
> > 
> > Is the name of your machine "hostname"?  I'm
> > guessing it isn't.
> > 
> > You should always tell us what version of fvwm you
> > are using.
> > I'm going to assume 2.2.4, our latest non-beta.
> > I doubt it matters.
> > 
> > The display name gets to fvwm either thru the "-d"
> > command line
> > argument, or thru X Library functions.  According to
> > my 2.6 man pages,
> > the X Library functions use $DISPLAY.
> > 
> > > I have set the display variable and dont see what
> > the
> > > problem is..
> > 
> > Make sure that $DISPLAY is "exported" (not just 
> > set) before fvwm gets
> > invoked.
> > 
> > > I can run openwin successfully..
> > 
> > They are both invoked thru your .xinitrc?
> > 
> > > Also I installed fvwm using --prefix=/home/sam
> > > option..
> > > copied the sample fvwm2rc file to
> > /home/sam/.fvwm2rc.
> > 
> > How you installed fvwm should not matter.
> > 
> > > Thanks in advance,
> > > -BC
> > 
> > --
> > Dan Espen
> > 444 Hoes Lane  Room RRC 1C-214           E-mail:
> > [email-masked]
> > Piscataway, NJ 08854                     Phone:
> > (732) 699-5570
> > 
> __________________________________________________
> Do You Yahoo!?
> Talk to your friends online with Yahoo! Messenger.
> http://im.yahoo.com
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: babu chakrapani <[email-masked]>
Date: Thu, 3 Feb 2000 16:21:06 -0800 (PST)

I log in as myself and run fvwm2.

I can run openwindows by typing "openwin" and it runs
successfully..

the exact error I get when I run fvwm2 is
[FVWM][main]: <<ERROR>> can't open display
<bombay.office.com:0.0>

my hostname is "bombay.office.com"..

-BC

--- "Steffl, Erik" <[email-masked]> wrote:
> > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > babu chakrapani

---

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 3 Feb 2000 18:55:31 -0600

it looks like the problem is that you do not have X running.

  openwin is a script that runs X server (using xinit) and all the clients
in xinitrc (system wide or ~/.xinitrc). at least on the sun box that we have
here.

  fvwm is window manager.

  to be able to run window manager you have to run X first.

  you can either run the X without all the openwin stuff and start fvwm
manually (just to get the feel of it and verify it works) or change the
xinitrc (either system or in your home dir).

  my openwinhome uses $OPENWINHOME/lib/Xinitrc or ~/.xinitrc

  check these files and replace olwm (or mwm or whatever window manager is
there) by fvwm.

  looking at the Xinitrc on my system I see that you can set the
$OW_WINDOW_MANAGER variable to override the olwm.

  check both openwin (it's a shell script) and Xinitrc for further info.

  (use which to find out where openwin is)

  hope this helps.

	erik

> From: babu chakrapani [mailto:[email-masked]]
> Sent: Thursday, February 03, 2000 4:21 PM
> To: Steffl, Erik; 'fvwm'
> Subject: RE: FVWM: fvwm2 on solaris 7
> 
> 
>