Subject: Re: FVWM: fvwm2 on solaris 7

From: babu chakrapani <[email-masked]>
Date: Thu, 3 Feb 2000 12:16:51 -0800 (PST)

Still seeing the same problem.. 
version is 2.2.4.

Still says cannot open display. DISPLAY variable is ok
and is exported.

Confused,
BC.

--- Dan Espen <[email-masked]> wrote:
> babu chakrapani <[email-masked]> writes:
> > 
> > Hello,
> > 
> > I installed fvwm2 under solaris 7. when I run
> fvwm2,
> > 
> > I get an error 
> > 
> > [FVWM][main]: <<ERROR>> can't open display
> > <hostname:0.0>
> 
> Is the name of your machine "hostname"?  I'm
> guessing it isn't.
> 
> You should always tell us what version of fvwm you
> are using.
> I'm going to assume 2.2.4, our latest non-beta.
> I doubt it matters.
> 
> The display name gets to fvwm either thru the "-d"
> command line
> argument, or thru X Library functions.  According to
> my 2.6 man pages,
> the X Library functions use $DISPLAY.
> 
> > I have set the display variable and dont see what
> the
> > problem is..
> 
> Make sure that $DISPLAY is "exported" (not just 
> set) before fvwm gets
> invoked.
> 
> > I can run openwin successfully..
> 
> They are both invoked thru your .xinitrc?
> 
> > Also I installed fvwm using --prefix=/home/sam
> > option..
> > copied the sample fvwm2rc file to
> /home/sam/.fvwm2rc.
> 
> How you installed fvwm should not matter.
> 
> > Thanks in advance,
> > -BC
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail:
> [email-masked]
> Piscataway, NJ 08854                     Phone:
> (732) 699-5570
> 
__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul D. Smith" <[email-masked]>
Date: 03 Feb 2000 15:40:14 -0500

%% babu chakrapani <[email-masked]> writes:

  bc> Still seeing the same problem.. 
  bc> version is 2.2.4.

  bc> Still says cannot open display. DISPLAY variable is ok
  bc> and is exported.

Why are you setting display to hostname:0.0 instead of just :0.0?

The former will always uses sockets to communicate between the clients
and the X server, while the latter will use shared memory which is
_much_ faster.

It sounds to me like you don't have permissions to access the server
using the hostname:0.0 method.  I've seen this before (just the other
day someone was using the elm backgrounder and it kept removing these
permissions!)

If you must stay with hostname:0.0, try using:

  xhost +hostname

before you invoke the window manager.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].