Subject: FVWM: xpm and compiling fvwm

From: Andre de Boer <[email-masked]>
Date: Sun, 27 Feb 2000 14:34:14 +0000

Hello,

Thanks Paul for your reaction.
A question: is it neccesary to have Xpm-library installed?

Below a piece of config.log

creating modules/FvwmWharf/Makefile
creating modules/FvwmWinList/Makefile
configure:1377: minix/config.h: No such file or directory
configure: failed program was:
#line 1376 "configure"
#include "confdefs.h"
#include <minix/config.h>
configure:1424: checking for X
configure:1491: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1487: X11/Intrinsic.h: No such file or directory
configure: failed program was:
#line 1486 "configure"
#include "confdefs.h"
#include <X11/Intrinsic.h>
configure:1567: gcc -o conftest -g -O2   conftest.c -lXt  1>&5
ld: cannot open -lXt: No such file or directory
configure: failed program was:
#line 1560 "configure"
#include "confdefs.h"

Bye,
Andre de Boer

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Sun, 27 Feb 2000 10:52:07 -0500 (EST)

Andre,

I have a RH5.2 system and fvwm2 has always compiled just fine for me.  It
is not necessary to have xpm support when you compile fvwm2, but it allows
shaped xpm's and I think is a nice feature.  On my system X11/Intrinsic.h
is located at

/usr/X11/include/X11/Intrinsic.h

and is part of the package

[tom]$ rpm -qf /usr/X11/include/X11/Intrinsic.h
XFree86-devel-3.3.3.1-1.1

I highly doubt that this is a recent version of X; I haven't bothered to
keep everything up to date since I plan to switch over to RH6.1 shortly.

I would suggest that first you use rpm to check the integrity of the
package and make sure nothing has been moved or deleted with --verify.

Hope this helps,
Tom