Subject: FVWM: xemacs and StartsOnPage

From: Douglas Straub <[email-masked]>
Date: Sat, 26 Feb 2000 17:05:34 -0500

Hi,
    Under fvwm2, I have four desks, and each desk has four pages.  I use
xemacs in the gnuserve/gnuclient mode.  When I start a new gnuclient
process, I would like the new window to show up
on page 0,0 of the current desk.   Instead, the new gnuclient window
always goes to page 0,0 of desk 0, which is where the original gnuclient
is placed upon initialization.   It seems like the following .fvwm2rc
lines should do the trick:
     Style "*macs*"          StartsOnPage 0 0
     Style "*gnuclient*"     StartsOnPage 0 0
However, if I start a new xemacs, non-gnuclient process, it does the
right thing.
Any suggestions?

Thanks,

Doug

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Feb 2000 14:22:31 +0100

> However, if I start a new xemacs, non-gnuclient process, it does the

The gnuclient window has the window group hint set to point
to the original frame.  Fvwm always keeps windows in the same
group on the same desk.  At present there is no option
controlling this.  You can disable the responsible code
explicitly by removing the following code:

  placement.c, lines 542 to 555 (in current CVS code):

    if((tmp_win->wmhints)&&(tmp_win->wmhints->flags & WindowGroupHint)&&
       (tmp_win->wmhints->window_group != None)&&
       (tmp_win->wmhints->window_group != Scr.Root))
    {
      /* Try to find the group leader or another window
       * in the group */
      for (t = Scr.FvwmRoot.next; t != NULL; t = t->next)
      {
	if((t->w == tmp_win->wmhints->window_group)||
	   ((t->wmhints)&&(t->wmhints->flags & WindowGroupHint)&&
	    (t->wmhints->window_group==tmp_win->wmhints->window_group)))
	  tmp_win->Desk = t->Desk;
      }
    }

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].