Subject: FVWM: Question: Layers: popping up windows "in between windows"

From: Neil Zanella <[email-masked]>
Date: Sun, 13 Feb 2000 16:47:51 -0330 (NST)

Hello,

I would like an aplication named xyz to start below the focused window
but also above every other window. I have been told I can do this with
layers but it seems to me that the man page is not very clear on how
layers work. Can someone tell me how layers work and how I can accomplish
the xyz task mentioned above?

Thanks,

Neil
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Feb 2000 10:11:49 +0100

> the xyz task mentioned above?

I don't think there's a reliable way to do this with layers.
If you don't mind the flichering you can youe FvwmEvent:
Whenever a new window is mapped, execute

  Current Raise

This will bring the focused window back to the top.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Zanella <[email-masked]>
Date: Tue, 15 Feb 2000 16:00:12 -0330 (NST)

> Whenever a new window is mapped, execute

Well, this might not necessarily work since the newly mapped window
may well aquire the focus as soon as it pops up.

Neil

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Feb 2000 09:45:29 +0100

> may well aquire the focus as soon as it pops up.

In this case:

  AddToFunc FocusAndRaise
  + i flipfocus
  + i raise

  Prev Function FocusAndRaise

or so.

Bye

Dominik ^_^