Subject: FVWM: Title bar pixmap question

From: [email-masked]
Date: Tue, 01 Feb 2000 20:30:07 -0500 (EST)

Hello Fellow FVWM users,

I am working on a new look for my desktop, trying to get a MAC OS look.
The problem I am running into is having a titlebar pixmap but I want destructive
text. Meaning that the titlebar text would have a colored background and not be
overlaided with the pixmap as background.  Any suggestions? I am using 2.2.4.

For example

pppppp titlebar text pppppp

p = pixmap

TIA

Garth
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Feb 2000 21:01:56 +0100

> pppppp titlebar text pppppp

I think that's not possible without writing a patch (which would
be easy to write because this is already done for monochrome X
servers).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
The adjuration to be "normal" seems shockingly repellent to me; I see neither
hope nor comfort in sinking to that low level.  I think it is ignorance that
makes people think of abnormality only with horror and allows them to remain
undismayed at the proximity of "normal" to average and mediocre.  For surely
anyone who achieves anything is, essentially, abnormal.
                -- Dr. Karl Menninger, "The Human Mind", 1930

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 3 Feb 2000 23:01:35 +0100

On 03 February, 2000 - Dominik Vogt sent me these 1.3K bytes:

> > I am working on a new look for my desktop, trying to get a MAC OS
> > look. The problem I am running into is having a titlebar pixmap but
> > I want destructive text. Meaning that the titlebar text would have a
> > colored background and not be overlaided with the pixmap as
> > background.  Any suggestions? I am using 2.2.4.
> > 
> > For example
> > 

Changing {Xmb,X}DrawString -> {Xmb,X}DrawImageString should fill the
background with the gc instead of "transparent" ..

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].