Subject: FVWM: Reading/writing environment variables

From: "Brennan Cropper" <[email-masked]>
Date: Thu, 24 Feb 2000 14:20:27 +0000

Hi,

I have a function bound to a key (F4) to goto a certain desk and page. 
I'd like to have another function that is bound to another key (F3) that
would take me back to the desk and page where I was before I pressed
F4.  Here's what I came up with, but it didn't work.  Any suggestions?

AddToFunc ReturnToPrevDeskPage
+ "I" GotoDesk 0 ${CUR_DESK}

AddToFunc GotoMyDeskPage
+ "I" SetEnv $d CUR_DESK
+ "I" GotoDesk 0 1
+ "I" GotoPage 0 0

Key F3    A N   ReturnToPrevDeskPage
Key F4    A N   GotoMyDeskPage

I couldn't find a variable which returned the current page!

Thanks,
Brennan
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Feb 2000 12:24:10 +0100

> I couldn't find a variable which returned the current page!

You don't need a variable to return to the last visited page.
Simply use

  GotoPage prev

This doesn't work with GotoDesk and GotoDeskAndPage yet.  I have
a mostly trivial patch to implement 'prev', but since we're in
feature freeze I won't commit it unless the OK from the
fvwm-workers list.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].