Subject: Re: FVWM: autohide for buttons?

From: [email-masked] (Danny Dulai)
Date: 23 Feb 2000 04:35:35 -0000

On 11/08/99, Dominik Vogt said:
>On Mon, Nov 08, 1999 at 01:51:24PM +0100, [email-masked] wrote:
>>   *FvwmButtonsGeometry 600x57+0-0
>>   ...
>>   *FvwmEvent focus_change "function showhidebuttons"
>>   ...
>>   AddToFunc showhidebuttons
>>   + "I" next (FvwmButtons) move 0p +765p
>>   + "I" current (FvwmButtons) move +0 -0
>> 
>>   AddToFunc InitFuction
>>   + "I" module FvwmEvent
>>   AddToFunc RestartFuction
>>   + "I" module FvwmEvent
>> 
>> My screen is 1024x768 pixels.  When any window gets focus, the
>> button bar will be moved down so that only a few pixels remain 
>> visible.  When FvwmButtons gets focus, it's moved back into view.
>> This works only with MosueFocus and SloppyFocus.  If you have a
>> swallowed modules in the button bar that can set focus they will
>> not work properly.  And you will see the button bar reaching into
>> lower pages on a pager.
>
>Adding this line should help with ClickToFocus and SloppyFocus:
>
>  Style FvwmButtons MouseFocus

I use SloppyFocus for everything. I added the Style FvwmButtons MouseFocus
line, and my functions works properly if i move from my fvwmbuttont to
another window, but if i just move to the root window, the fvwmbuttons
doesnt hide. the focus is lost, but for some reason, the move (to move it
off the stree) is not being called. any ideas?

-- 
___________________________________________________________________________
Danny Dulai                                           Feet. Pumice. Lotion.
http://www.ishiboo.com/~nirva/                            [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 23 Feb 2000 09:06:34 +0000

> off the stree) is not being called. any ideas?

You probably have a "Style FvwmButtons CirculateSkip" in your fvwm2rc
whihc is causing the "Next (FvwmButtons)" to not do anything. Try this:

AddToFunc showhidebuttons
+ "I" next (FvwmButtons CirculateHit) move 0p +765p
+ "I" current (FvwmButtons) move +0 -0

Cheers,
Tim.

---

From: [email-masked] (Danny Dulai)
Date: 23 Feb 2000 16:00:17 -0000

>+ "I" current (FvwmButtons) move +0 -0

ok, this gave me weird results.. when i moved into the buttons, it came up,
when i moved out and into another widnow, it hid itself. when i moved out
and into the root window, it hid itself and then showed itself again!

I got it working using your root window detection code with the following:

*FvwmEvent                      focus_change showhidebuttons
DestroyFunc showhidebuttons
AddToFunc showhidebuttons       "I" WindowID $0 (FvwmButtons) showbuttons
+                               "I" WindowID $0 (!FvwmButtons) hidebuttons
+                               "I" DestroyFunc root_focus
+                               "I" AddToFunc root_focus I hidebuttons
+                               "I" WindowId $0 DestroyFunc root_focus
+                               "I" AddToFunc root_focus I NOP
+                               "I" root_focus

AddToFunc hidebuttons           "I" All (CirculateHit FvwmButtons) AnimatedMove 0p 1197p
AddToFunc showbuttons           "I" All (CirculateHit FvwmButtons) AnimatedMove 0 -0