Subject: FVWM: toggling styles

From: [email-masked] (Danny Dulai)
Date: 23 Feb 2000 05:22:09 -0000

any way to toggle a style?

Right now I have a key bound to hide the window title, and a diff key bound
to showing it.

Is there a way I can toggle it with one key?

AddToFunc showtitle             "I" Pick Style $n Title
AddToFunc hidetitle             "I" Pick Style $n NoTitle

-- 
___________________________________________________________________________
Danny Dulai                                           Feet. Pumice. Lotion.
http://www.ishiboo.com/~nirva/                            [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 23 Feb 2000 22:22:23 -0500

> AddToFunc hidetitle             "I" Pick Style $n NoTitle

I haven't tried this but how about
AddToFunc showtitle             "I" Pick Style $n Title
AddToFunc showtitle             "I" Key a WSFT C hidetitle
AddToFunc hidetitle             "I" Pick Style $n NoTitle
AddToFunc hidetitle             "I" Key a WSFT C showtitle

of course changign key_sym and modifier to whatever you want.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Danny Dulai)
Date: 24 Feb 2000 04:59:57 -0000

>of course changign key_sym and modifier to whatever you want.

Ok, this works partially. It doesnt work if the key is set to
'hide' when the window you are trying toggling has the titles already
hidden, or set to 'show' and the window has its title shown.

Altho this is a clever trick, it doesnt solve the real problem, which is to
find out if Style is set. Thanks anyways!