Subject: Re: FVWM: StartsOnPage question

From: [email-masked]
Date: Fri, 14 Jan 2000 19:12:31 GMT

> David J. Kanter, [email-masked]

> When (re)starting fvwm2, I'd like mutt and slrn to start on page 0 1 and 0 2
> of desktop 0, respectively. I've written the below init-restart.hook file (I
> use Debian), but it doesn't do the trick: mutt and slrn start on page 0 0.
>
> What's wrong with my syntax?
>
> Thanks.
>
> # This stuff is started each time fvwm2 is either started OR restarted.
> # I'm going to have these always "on": 2 xterms, xjed and gkrellm. Also, I
> # want mutt and slrn to start up, but on different pages of the desktop.
>
> + "I" Exec xterm -rv
> + "I" Exec xjed
>
> Style gkrellm* Sticky
> + "I" Exec gkrellm -geometry -0+0
>   
> Style e-mail* StartsOnPage 0 1, SkipMapping
> + "I" Exec xterm -T "e-mail" -e mutt
>     
> Style news* StartsOnPage 0 2, SkipMapping
> + "I" Exec xterm -T "news" -e slrn

I don't think it's your syntax. If you are using ActivePlacement (probably)
then you might try adding

	GlobalOpts ActivePlacementHonorsStartsOnPage

This is supposed to be the default, but I have a feeling it isn't (it doesn't
appear to be for me right now in fvwm2-2.2.2-3).

Alternatively, you could add the RandomPlacement option on these Style lines:

	Style news* StartsOnPage 0 2, SkipMapping, RandomPlacement

Regards, John Latham
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "David J. Kanter" <[email-masked]>
Date: Fri, 14 Jan 2000 23:51:16 -0600

That did the trick! Thanks a lot.

---end quoted text---

-- 
David J. Kanter
[email-masked]