Subject: RE: FVWM: pinnable transient windows

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 27 Jan 2000 13:04:48 -0600

I do not think that's what the window manager does, that's the widget
toolkit's responsibility.

  note:

  - there are applications with tearable menus, they work fine under fvwm
(pavuk, check the www.freshmeat.net if you want to see it in action)

  - netscape has the find dialog, it stays on the screen until you close it
(and you can use netscape in the meantime), so it's basically 'pinned'

  - the openwin programs' menus are pinnable under fvwm (just tried it)

  the only think fvwm could do is to make it's own menus/dialogs pinnable.

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Dominik Vogt
> Sent: Thursday, January 27, 2000 2:30 AM
> To: [email-masked]
> Subject: Re: FVWM: pinnable transient windows
> 
> 
> On Wed, Jan 26, 2000 at 10:22:28AM -0800, [email-masked] wrote:
> > 
> > Anyone figure out a kludge (or write code) to do pinnable 
> transient windows
> > (ala OLWM)?  ie....keeping transients from being 
> so...so....transient.
> 
> Um, can you explain what you mean with 'pinnable windows'?  I don't
> have olwm handy right now.  You know, it's a fvwm list ;-)
> 
> Bye
> 
> Dominik ^_^
> 
> -- 
> Dominik Vogt, Agilent Technologies, Dept. BVS
> Herrenberger Str.130, 71034 Boeblingen, Germany
> phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 27 Jan 2000 11:39:22 -0800 (PST)

< I do not think that's what the window manager does, that's the widget
< toolkit's responsibility.

pushpins are part of the olwm decor....tho i dont know how it's
communicating w/ the openwin apps.

<   - the openwin programs' menus are pinnable under fvwm (just tried it)

How do you "pin" it up so that it stays up till you unpin it?

---

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 27 Jan 2000 14:04:05 -0600

> Elliot Sowadsky
...
> communicating w/ the openwin apps.

  if you are talking about the pins in the menus, they are definitely part
of the menus and not the olwm decors. run the openwin program (cmdtool, or
any other) in fvwm and you'll see the pins are there (right click in the
cmdtool main menu and try the menus, some have pins).

  there might be other pins that are part of olwm decors.

> How do you "pin" it up so that it stays up till you unpin it?

  using the pin, it is displayed no matter what window manager you use. only
for openwin programs, of course.

  for those who do not know/have olwm: in lot of menus there is a button
(with pin picture) as a first item in the menu, when you select it, the menu
stays open (as a regular window) even after you select other item (it is
usefull to have some menus handy all the time, like edit menu etc...)).

  if you use olwm these pinned window have pin in the title, you can use it
to close the window. in fvwm these have regular title, you can close it
using whatever method you use to close windows. I guess you could write a
special style for these pinned windows (to have pin icon in the title), but
I am not sure how would you find out the window is pinned.

	erik

---

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 27 Jan 2000 12:28:55 -0800 (PST)

> communicating w/ the openwin apps.

< if you are talking about the pins in the menus, they are definitely part
< of the menus and not the olwm decors.

Open the Find/Replace window (which you can get from the cmdtool menu.
In olwm, you can pin this F/R window, keeping it from vanishing after a find.

That pin is absent in fvwm.

---

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 27 Jan 2000 17:15:50 -0600

I see what you mean - some pins are in the widget themselves (in the
menus), some are in the decorations.

  still, it looks like the window itself controls if it is pinned (there is
no way for window manager to pin the window that is not aware of it). do you
plan to use a lot of openwin programs?

	erik

> Sent: Thursday, January 27, 2000 12:29 PM
> To: [email-masked]

---

From: "Steffl, Erik" <[email-masked]>
Date: Thu, 27 Jan 2000 19:26:27 -0600

> <   I see what you mean - some pins are in the widget 
> themselves (in the
> < menus), some are in the decorations.
> 
> <   still, it looks like the window itself controls if it is 
> pinned (there is
> < no way for window manager to pin the window that is not 
> aware of it).
> 
> Actually it is aware the window exists (in winlist). fvwm 
> just doesnt know
> the key to telling the app not to destroy it (unlike olwm)

  sorry, I ment the windows that is not pin-aware.

> < do you plan to use a lot of openwin programs?
> 
> almost exclusively.  I dont usually need the 
> push-pins.....but i was hoping that then times that i would 
> want them...

  hmm... I always thought that openwin is basically dead, even sun went to
CDE, even though you still get the openwin part, right? and nobody else
supports openwin much, or do they?

	erik