Subject: Re: FVWM: pinnable transient windows

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 27 Jan 2000 15:53:30 -0800 (PST)

<   I see what you mean - some pins are in the widget themselves (in the
< menus), some are in the decorations.

<   still, it looks like the window itself controls if it is pinned (there is
< no way for window manager to pin the window that is not aware of it).

Actually it is aware the window exists (in winlist). fvwm just doesnt know
the key to telling the app not to destroy it (unlike olwm)

< do you plan to use a lot of openwin programs?

almost exclusively.  I dont usually need the push-pins.....but i was hoping that then times that i would want them...
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Jan 2000 19:06:31 -0500

> the key to telling the app not to destroy it (unlike olwm)

Fvwm pays attention to all the Open Look hints its is aware of.

Check "Style * OLDecor".

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 28 Jan 2000 02:40:10 +0100

> Fvwm pays attention to all the Open Look hints its is aware of.

I've already tried it and it doesn't help.  I can't see a hint
in decorations.c that looks like it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].