Subject: FVWM: Bevel width/thickness

From: "Joe Smith" <[email-masked]>
Date: Thu, 27 Jan 2000 15:04:29 PST

I've been trying to make my windows look more MWM-like, in the sense that I 
want the bevel width around the borders to be 1 pixel. In MWM, the windows 
look almost flat, whereas the default in FVWM 2.2.2 is that they look more 
3D-like.

I have almost managed to do so, using:

Style "*" MWMBorder

which makes all bevels 1 pixel, except the one on the outside of a window 
(it's still 2 pixels wide).

Is there a parameter/option to explictly set the width of the bevels?
______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jos <[email-masked]>
Date: Fri, 28 Jan 2000 09:33:58 +0100

> (it's still 2 pixels wide).
 
Hey, I'd like that too! ;-)

Jos.

---

From: Sheldon Andrews <[email-masked]>
Date: Fri, 28 Jan 2000 10:56:09 -0330 (NST)

Would this work:

Style "*"           BorderWidth 1, HandleWidth 1

Gives me a nice one pixel border.
--
Sheldon
[email-masked]

---

From: Jos <[email-masked]>
Date: Fri, 28 Jan 2000 15:47:19 +0100

> Gives me a nice one pixel border.

I think Joe was referring to the width of the bevel, which is hilighted. 
(Color calculated from HilightBack, for a hilighted window) I might try 
some ascii art to show this:

**************************************  \
*                bevel                   |
*  ***********************************   | entire border
*  *             the other part          | 
*  *                                     |
*  *    ******************************  /
*  *    *
*  *    *
*  *    *
*  *    *
*  *    *
*  *    *

regards,

Jos.

---

From: JOHN MARTINSON <[email-masked]>
Date: Sun, 30 Jan 2000 18:18:26 -0700

--
•••••••••••••••••••••••••••
John S. Martinson
President & Chief Imagination Officer
China Mist Tea Company
7435 E Tierra Buena Ln
Scottsdale, AZ 85260

W: 480.998.8807
F: 480.596.0811

[email-masked]
•••••••••••••••••••••••••••••

---

From: JOHN MARTINSON <[email-masked]>
Date: Sun, 30 Jan 2000 18:19:06 -0700

W: 480.998.8807
F: 480.596.0811

---

From: Tim Phipps <[email-masked]>
Date: Mon, 31 Jan 2000 13:40:09 +0000

> (it's still 2 pixels wide).

I can't run mwm, but dtwm which is a close relative looks exactly like
this. The last time I looked at mwm it was this way too.

Cheers,
Tim.