Subject: Re: FVWM: Argument Passing?

From: [email-masked]
Date: Fri, 14 Jan 2000 19:33:24 GMT

> Is it possible to use the Restart function to do this
>
> Restart echo FvwmFoo > $HOME/.wm_style ; exec $HOME/RunWM
>
> This would be ideal.
>
> Tom
>

Does my suggested solution of yesterday (Thu, 13 Jan 2000 02:48:59 GMT) not
work?

        AddToMenu WindowManagers
        +  "" Title
        +  "Fvwm2 Win95-decors" Function SwitchDecor Fvwm95
        +  "Fvwm2 Mwm-decors" Function SwitchDecor Mwm
        +  "Thingy Foo" Function SwitchDecor Foo
        +  "Whatsit Bar" Function SwitchDecor Bar

        AddToFunc SwitchDecor
        + "I" Exec echo $0 > HOME/USER_WM_STYLE
        + "I" Restart HOME/bin/RunWM

I believe the Exec is guaranteed to finish before the Restart begins (can
anyone confirm this?).

John Latham
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Jan 2000 14:42:02 -0500

>From the man page:

          Note that this function doesn't  wait  for  command  to
          complete, so things like:

               Exec "echo AddToMenu ... > /tmp/file"
               Read /tmp/file

          won't work reliably.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].