Subject: RE: FVWM: help?

From: "Steffl, Erik" <[email-masked]>
Date: Tue, 11 Jan 2000 13:48:49 -0600

it looks like your gcc is not configured properly. the following program
should compile:

-----------cut here
#include <limits.h>
int main(void) {return 0;}
-----------cut here

using gcc file.c

  if it does not, check the gcc configuration (I am not sure how to
configure it, it usually is properly configured during installation, check
the installation instructions for gcc).

  if it does compile then it's a mystery...

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Thomas A. Gardiner
> Sent: Tuesday, January 11, 2000 10:10 AM
> To: Fvwm List
> Subject: FVWM: help?
> 
> 
> Hi,
> 
> Warning I'm about to plead for some help... I've got a Dell installed
> RedHat 6.1 system at work with gcc 2.95 installed (which has had some
> problems) and I'm having some trouble building fvwm2.2.4.
> 
> The configure tests report 
> ...
> checking for limits.h... no
> checking for malloc.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for unistd.h... yes
> checking for getopt.h... yes
> checking for sys/select.h... yes
> checking for sys/systeminfo.h... no
> ...
> 
> among other things.
> 
> On executing make all I get 
> ...
> 
> gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libs  
> -I/usr/X11R6/include    -g -O2
> -c windows.c
> In file included from
> /usr/lib/gcc-lib/i386-pc-linux/2.95.2/include/limits.h:117,
>                  from
> /usr/lib/gcc-lib/i386-pc-linux/2.95.2/include/syslimits.h:7,
>                  from
> /usr/lib/gcc-lib/i386-pc-linux/2.95.2/include/limits.h:11,
>                  from windows.c:18:
> /usr/include/limits.h:117: No include path in which to find limits.h
> make[2]: *** [windows.o] Error 1
> ...
> 
> Can someone tell me where configure searches for limits.h?  
> That is, what
> if limits.h is missing, then from where because I can find 
> limits.h on the
> system.
> 
> Thanks much,
> 
> Tom
> 
> Ps.   rpm -V `rpm -qa | grep c++`  reports all is a-okay.
> 
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Tue, 11 Jan 2000 16:32:53 -0500 (EST)

Thanks Erik and Michael,

Erik your little test below showed exactly the same compile errors as the
fvwm2 build. (i.e. you hit it right on the head.)  At least now my problem
has been narrowed down quite a bit!  What I still do not understand is
that the file /usr/include/limits.h exists and is part of the following
package: glibc-devel-2.1.1-6

Well, thanks a lot for getting me started, I'll head off and dig into the
docs and bug the sysadmin some...

Tom