Subject: FVWM: StartFunction, RestartFunction etc.

From: Jos <[email-masked]>
Date: Thu, 06 Jan 2000 09:56:25 +0100

Hi!

I'm trying to get an fvwm2 setup to work, in which I can switch
between different themes, without having to quit X and start up 
again. 

Now, I use an FvwmButtons instance in several themes, with a different 
lay out in each theme (different button size). It appears, that the 
FvwmButtons instance doesn't resize automatically on a restart. Only
when 
I kill the module by hand (using KillModule FvwmButtons from the
fvwm console) and then restart, the FvwmButtons module appears
correctly.

So I tried to add a 'KillModule *' to the StartFunction (and the 
RestartFunction,) but then, I don't see any modules at all: they
probably
get killed (why? shouldn't the StartFunction be executed before anything
else?)
Maybe I should also note that I use m4 processing. (which on a restart
does
seem to work, because other m4 dependent features of the theme do appear 
correctly.)

Maybe someone knows something else that I could try. In case you want to
look
at my setup, please go to http://www.xs4all.nl/~josvanr/fvwm.html . I'm
using
fvwm2.3.10 by the way.

regards,

Jos.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Jan 2000 00:02:50 +0100

On Thu, Jan 06, 2000 at 09:56:25AM +0100, Jos wrote:
> FvwmButtons instance doesn't resize automatically on a restart.

Restart what? X? fvwm? FvwmButtons?

> Only when 
> fvwm console) and then restart,

Restart what? X? fvwm? FvwmButtons?

> the FvwmButtons module appears
> correctly.
> 
> RestartFunction,)

You don't need that.  The modules are always killed anyway when
fvwm exits/restarts.  Any modules that do not exit can't talk to
fvwm anymore.

> but then, I don't see any modules at all: they > probably
> Maybe someone knows something else that I could try.

Mail the config file to me and I'll look into it (yes, I know
you have set it up on the web, but still).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].