Subject: FVWM: Move and resize question

From: Patrick Cevasco <[email-masked]>
Date: 24 Jan 2000 15:23:01 -0800

I'm using fvwm2-2.2.2-3

I have several programs (like Netscape) which I run during InitFunction and would like them to pop-up at specific locations and sizes on different desks within FVWMPager.  For example, I have Desks 0 thru 3 and would like Netscape to load to Desk 1 with a certain size and location without Focus moving to Desk 1.

I define the Style like:

Style   "Netscape"      Icon mini-nscape.xpm, SkipMapping, StartsOnDesk 1

...add a Function call within the InitFunction

DestroyFunc "InitFunction"
AddToFunc "InitFunction"
+       "I"     Function SpawnNetscape

...and have the Function defined as

DestroyFunc "SpawnNetscape"
AddToFunc "SpawnNetscape"
+       "I"  Next [Netscape] Move 12p 20p
+       "I"  Exec exec /usr/local/netscape/netscape
+       "I"  Prev [Netscape] Maximize 91 89

Netscape pop's up on the correct desk and focus doesn't change but the Move and Maximize commands are "ignored".  I've shuffled things around a couple of different ways like:

DestroyFunc "SpawnNetscape"
AddToFunc "SpawnNetscape"
+       "I"  Next [Netscape] Move 12p 20p
+       "I"  Next [Netscape] Maximize 91 89
+       "I"  Exec exec /usr/local/netscape/netscape

But that doesn't work either.  I also used FvwmIdent to find the correct Class (Netscape) and Resource (Navigator) and neither work.  Most programs are easy because of  "-geometry".

Thanks in advance for any advice.

Pat

______________________________________________________________

Free Internet Access from AltaVista: Get it, share it & win! 
http://freeaccess.altavista.com/pika/www/initweb.jsp

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 25 Jan 2000 02:09:20 +0100

> But that doesn't work either.  I also used FvwmIdent to find the correct Class (Netscape) and Resource (Navigator) and neither work.  Most programs are easy because of  "-geometry".

That's because fvwm doesn't wait for the netscape window to appear
before continuing the function.  The 'Wait' command can do this,
but it's a dangerous thing.  If no window with the given name
ever appears you can hang fvww (I think there's a key combination
to bug out of this, but I don't know which).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason Kibblewhite <[email-masked]>
Date: Tue, 25 Jan 2000 01:32:56 -0700

Subject: FVWM: Move and resize question
	Date: Mon, Jan 24, 2000 at 03:23:01PM -0800

Time to reply!

> I have several programs (like Netscape) which I run during InitFunction and would like them to pop-up at specific locations and sizes on different desks within FVWMPager.  For example, I have Desks…
--snip--
> But that doesn't work either.  I also used FvwmIdent to find the correct Class (Netscape) and Resource (Navigator) and neither work.  Most programs are easy because of  "-geometry".

Well unless I've not understood the question, but netscape just support the
-geometry argument.  Why not use that?
-- 
email: 	[email-masked]
        [email-masked]
ICQ:	52555063	
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 25 Jan 2000 15:15:40 +0100

Patrick, the mail address you use seems not to work.  If somebody
on the list replies to it, the mail is delivered to [email-masked]
instead.  Here is what he writes:

> this e-mail was incorrectly delivered to me probably by the addressee's pop.
> please contact addressee by phone and inform them of this problem. I have
> rec'd over 30 e-mails addressed to them since last week. I cannot contact
> them by e-mail because all e-mails are returned to me. I get about 10 per
> day now and just return to sender. if this is not resolved by Friday, I
> will just simply delete all future messages as I do not have time to return
> them. thank you. :-(

Please double check your mail setup.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 25 Jan 2000 12:18:30 -0600

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

DV> Patrick, the mail address you use seems not to work.  If somebody on
DV> the list replies to it, the mail is delivered to [email-masked]
DV> instead.

The linux-kernel lists were recently hit with a similar problem; someone
signed up and then started forwarding the mail to a bunch of other people.
This is impossible to prevent as we have no control over what happens to
the mail after it leaves the list host, but it is also trivial to track
down given a complete set of headers.  Complaints about mailing list mail
that don't include complete headers are essentially useless.
-- 
Jason L Tibbitts III - [email-masked] - 713/743-3486 - 660PGH - 94 PC800
   System Manager:  University of Houston Department of Mathematics 
         "You'll see the blood as we roll in it together..."
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 26 Jan 2000 14:33:18 +0000

> to bug out of this, but I don't know which).
It's not that dangerous. Fvwm will happily carry on managing windows
while it is waiting for the window to appear, you can pop up menus and
use key bindings.  All a Wait command does is to stick the rest of the
functions into a list of things to do when the window appears.  The root
cursor will change into a stopwatch while it is waiting and you can
interrupt it with Ctrl-Alt-Escape.

The function to massage netscape is:

DestroyFunc SpawnNetscape
AddToFunc SpawnNetscape I Exec exec /usr/local/netscape/netscape
+ I Wait Netscape
+ I Next [Netscape] Move 12p 20p
+ I Next [Netscape] Maximize 91 89

Cheers,
Tim.