Subject: FVWM: Quit does not really quit ?

From: "Steffl, Erik" <[email-masked]>
Date: Wed, 5 Jan 2000 12:16:23 -0600

> -----Original Message-----
> From: [email-masked] 
[mailto:[email-masked]]On Behalf Of
> Elliot Sowadsky
...
> Perhaps fvwm should kill -9 any windowing process that 
refuses to die
> gracefully.

  it is definitely not up to fvwm to automatically kill any 
other X programs.

  if you want the fvwm to exit the X you have to set up X, or 
write fvwm function (like was suggested in other post).

  fvwm is a window manager, not a session manager. let's not 
have all programs do everything... (but perhaps a session 
manager module for fvwm is not entirely bad idea).

  my point is that simply quitting fvwm should leave the rest 
of X (other programs) untouched - I might want to start 
another window manager, I might be using different session 
manager etc... (and that's what fvwm currently does, I am 
advocating status quo)

	erik
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Bird <[email-masked]>
Date: Thu, 06 Jan 2000 09:03:28 +0000

> manager etc... (and that's what fvwm currently does, I am

  AFAIUI, if 'fvwm2' is the last thing in your .xinitrc, then quitting it
will terminate that script and X will terminate (forcing your app.s to die
as well).

  I have to say, though, that (under Solaris at least) ISTR *sometimes*
getting a situation where for some reason a live child process caused X to
think the script hadn't terminated; it happens so rarely that I've never
bothered to investigate.

  I run 'fvwm2 &' myself, then run a noddy prog. 'X-session' at the end of
my .xinitrc that does nothing but sleep. This allows me to exit fvwm &
restart it or something else without logging out, and I've not had
problems for a couple of years or more with this method. Of course, your
main-menu 'Exit' needs to kill this process (I have a util. to effectively
'kill -9 `ps | grep foo | awk "print $1"`').

  All of which is rather OT ...

-- 
=====================- http://www.racaldefence.com/ -===================
  Neil Bird                      |
                                 |            This .signature is
    mailto:[email-masked]  |          certified Y2K compliant
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].