Subject: Operations on Focused Window

From: [email-masked]
Date: Sun, 26 Dec 1999 01:29:27 -0600 (CST)

Full_Name: Neil Zanella
Version: 2.3.11
CVS_Date: 
OS: Linux 2.2.13
X_Server: XFree86 3.3.2
Submission from: (NULL) (129.128.153.50)

Hello,

I would like to be able to perform operations on the focused window
by means of a key binding. The manual page says:

Current (conditions) command
Performs command on the current window if it satifies  all conditions.

I am assuming that current window here means focused window. In that
case I trY:

Key S A M Current WindowShade

but after restarting the focused window does not shade unless the pointer
is on top of the window.

Thanks,

Happy Holidays,

Neil Zanella
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 Dec 1999 10:50:09 +0100

> but after restarting the focused window does not shade unless the pointer

I can confirm that key bindings and input focus are broken with
shaded windows.  I even found the instruction that breaks it,
but I don't understand why.

>From builtins.c:

    /* All this stuff is necessary to prevent flickering */
    set_decor_gravity(tmp_win, grav, UnmapGravity, client_grav);
    XMoveResizeWindow(
      dpy, tmp_win->frame, small_g.x, small_g.y, small_g.width,
      small_g.height);
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    XResizeWindow(dpy, tmp_win->Parent, cw, 1);
    XMoveWindow(dpy, tmp_win->decor_w, 0, 0);
    XRaiseWindow(dpy, tmp_win->decor_w);
    XMapWindow(dpy, tmp_win->Parent);

Comment out the underlined statement and it works.  If I replace
that statement with 

    XMoveWindow(dpy, tmp_win->frame, small_g.x, small_g.y);
    XResizeWindow(dpy, tmp_win->frame, small_g.width, small_g.height);

The XResizeWindow() call causes the bug.  Furthermore, 'small_g.height'
can be replaced with any number and it's still broken.  But if I replace
it with the current height of the window (frame_g.height) it works.

Oh, and BTW, the problem seems to be that no key events are reported
at all, i.e. fvwm has no chance to do something.  The client window
doesn't get keyboard input either.  Any ideas what's wrong?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Thu, 30 Dec 1999 03:00:55 -0330 (NST)

> but I don't understand why.

I found another bug with WindowShade that may or may not have something
to do with it:
Sometimes, when I unshade a window after a while it's been shaded, it
only unshades to some length roughly the size of my titlebar or less.

Best Regards,

Neil

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 30 Dec 1999 10:44:46 +0100

> only unshades to some length roughly the size of my titlebar or less.

I think I have fixed that on 20th of December, i.e. 3 days
after the last beta release.  The problem happened when you
shede a window, recapture it, recapture it again and then
unshade it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]