Subject: HilightColorset causes core dump

From: [email-masked] (Tim Phipps)
Date: Mon, 20 Dec 1999 15:50:47 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.12
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.12
FVWM_USERHOME: unset

Description:
	With the removal of HilightColorset comes a core dump if you use
	HilightColorset outside of a decor i.e. directly in your .fvwm2rc.

Repeat-By:
	HilightColorset 1

Fix:
	Using HilightColorset in decors is handled with a warning, the warning
	should happen if decors aren't used.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 20 Dec 1999 17:07:36 +0100

> 	should happen if decors aren't used.

No.  HilightColor(set) ... is translated to the corresponding style
option.  The problem is that I trashed the pointer to the rest of
the command line before copying it.  I'll commit a fix in a minute.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]