Subject: CVS domivogt: * Fixed FvwmBacker desk changes.

From: CVS <[email-masked]>
Date: Wed, 15 Dec 1999 19:47:11 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/12/15 19:47:10

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c borders.c builtins.c events.c 
	                 functions.c fvwm.c geometry.c gnome.c gnome.h 
	                 icons.c modconf.c move_resize.c style.c 
	                 virtual.c 
	libs           : ColorUtils.c fvwmlib.h 
	modules        : ChangeLog 
	modules/FvwmBacker: FvwmBacker.c 
	modules/FvwmPager: FvwmPager.c 

Log message:
* Fixed FvwmBacker desk changes.
* Applied GNOME XA_WIN_AREA patch.
* Fixed title/notitle w/ shading bug.
* Fixed 'unknown gnome desk'.
* Fixed pager sizing bug.
* Fixed pager desktop scale bug.
* Release pointer grab at end of HandleButtonPress (why is this necessary
lately?)
* Improved hilight colour calculation of very dark colours and shadow colour
calculation of very bright colours.
* Another border drawing patch.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 16 Dec 1999 04:43:09 +0200

> * Fixed FvwmBacker desk changes.

Sorry, this is not the right fix, although it can work with a flickering.
Still if you are on (desk 1, page 2 3) and switch to (desk 4, page 5 6)
firstly the command for (desk 1, page 5 6) is executed, which is a bug.

The right thing is to fix M_NEW_PAGE. :)

Regards,
Mikhael.

---

From: Bob Woodside <[email-masked]>
Date: Thu, 16 Dec 1999 00:10:59 -0500

> * Fixed pager desktop scale bug.

	Well, not quite, but maybe it's progress.

	Now, instead of a random occurrence, it consistently comes up too big.
I've put up a couple of screen shots to illustrate at

	http://www.pcnet.com/~proteus/Fvwm/BigPager.tar.gz

I use

*FvwmPagerDeskTopScale 40

with a 1280 x 1024 screen.

Cheers,
Bob

---

From: Bob Woodside <[email-masked]>
Date: Thu, 16 Dec 1999 01:14:52 -0500

> firstly the command for (desk 1, page 5 6) is executed, which is a bug.

	No, it is impeccably correct. But the commands are not what you're
concerned with. You're interested in the notification of the results of
the commands, and you're asking to be notified of the results before
they have happened.

> The right thing is to fix M_NEW_PAGE. :)

	M_NEW_PAGE is not broken, and never was. However, if I'm interpreting
this correctly, it sounds like you're saying that Dominik's fix *does*
make the Backer work correctly with the current desk switch handling,
although I'll bet it's really an awful sight to behold if you're
switching desks and pages at the same time. If that's the case, then I
think it's time to change gotoDeskAndPage_func back to doing the cheat
of sending the desk switch notification prematurely in the M_NEW_PAGE
packet. But let's not forget that we're not doing it because it's the
Right Thing, but as a performance hack.

Cheers,
Bob

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 16 Dec 1999 15:12:59 +0200

On 16 Dec 1999 01:14:52 -0500, Bob Woodside wrote:
> packet.

Yes, without M_NEW_PAGE carrying the new desk, no hacks will help
FvwmBacker and other page-aware modules to behave right.

> But let's not forget that we're not doing it because it's the

I suggest to move this discussion to another thread.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Dec 1999 22:00:08 +0100

> with a 1280 x 1024 screen.

Let's see. 1280 / 40 = 32 pixels. I.e. each page should be
represented by a page that is 32 pixels wide in the pager.
You have 5 desks with 4 pages each = 20 pages.

  20 * 32 = 640

Now add one pixel for each separator and two for each border:

  640 + 19 + 4 = 663 pixels.

This is exactly the width of your pager (give or take a few
pixels).  So the new (big) size of your pager is the correct
size and the old size (around 460 pixels) was wrong. Phew!
you scared me for a moment. To get the old size again, the
correct scale is:

  *FvwmPagerDeskTopScale 55

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Thu, 16 Dec 1999 23:04:58 -0500

>   *FvwmPagerDeskTopScale 55

	Now there's a radical concept, using actual measurements! Wish I'd
thought of it.  :-)

	I'd never actually checked the size. I just tried a couple of numbers
and then said, "Yup, that looks about the size I'd like it", and I've
been using an incorrect scale for years.

	Thanks, and sorry to distract your attention from real bugs.

Cheers,
Bob