Subject: Re: GrabServer as a style option

From: Neil Zanella <[email-masked]>
Date: Sun, 5 Dec 1999 18:59:11 -0330 (NST)

Thanks for your feedback but I tried:

Style "Netscape: Find" GrabFocusTransient

as well as Style * GrabFocusTransient and Style * GrabFocus .
but it did not seem to do what I was looking for.

I would like the "Netscape: Find" window to have the focus as soon
as I pop it up so that I don't have to keep on moving the mouse
pointer back and forth.

Thanks for your help,

Best Regards,

Neil

On Tue, 23 Nov 1999, Dominik Vogt wrote:

> On Sun, Nov 21, 1999 at 02:08:37PM -0600, [email-masked] wrote:
> > Full_Name: Neil Zanella
> > Version: 2.3.9
> > CVS_Date: 
> > OS: Linux 2.0.38
> > X_Server: Xfree86 3.3.2
> > Submission from: (NULL) (129.128.88.47)
> > 
> > 
> > Hello,
> > 
> > It would be nice if it were possible to implement a style option 
> > named Focused/Unfocused so that when the window popped up it would
> > automatically steal the focus from another window or not receive
> > the focus at all, hence letting the user carry on typing in whichever
> > window the user was typing in.
> 
> Try 'Style * GrabFocus'
> 
> Bye 
> 
> Dominik ^_^
> 
> -- 
> Dominik Vogt, Agilent Technologies, Dept. BVS
> Herrenberger Str.130, 71034 Boeblingen, Germany
> phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
> 
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Dec 1999 00:21:28 +0100

> as I pop it up so that I don't have to keep on moving the mouse

There is one drawback: If you open the window with a mouse click
from a menu, the pointer and thus the focus (Mosue or Sloppy)
will immediately leave the newly mapped window again.  It
should work if you use the keyboard shortcut to open the window.
It should work too with ClickToFocus.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]