Subject: Notification: incoming/536

From: [email-masked]
Date: Fri, 24 Dec 1999 08:42:13 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/536

Message summary for PR#536
	From: [email-masked]
	Subject: PipeRead description too terse for inexperienced users
	Date: Fri, 24 Dec 1999 08:42:11 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 Dec 1999 00:17:38 +0100

On Fri, Dec 24, 1999 at 08:42:13AM -0600, [email-masked] wrote:
> PipeRead man page description is minimal and therefore, hard to
> understand.  Also, my version (2.2.2) is inconsistent with the
> example given in the FAQ (section 7).  The form of the command as
> shown in the man page on my version is "PipeRead cmd option".  It
> appears that the example in the FAQ is just "PipeRead cmd".

The 'option' is the same as for 'Read' and is optional.  I've
fixed the man page.

> Specifically, one thing I am trying to do is have a button that
> swallows the xclock and reports the output of "date +%b\ %d\ %Y"
> as its title.  Clicking on the date will then open ical.  I've
> acutally done that once before without using PipeRead (or SetEnv)
> but I can't figure out how and I lost my old .fvwm2rc.

Just write a shell script that prints a line like

  *FvwmButtons(Swallow xclock 'Exec exec xclock', Title "whatever you want")

E.g.:

  #!/bin/sh
  echo "*FvwmButtons(Swallow xclock 'Exec exec xclock', Title \"`date +%b\ %d\ %Y`\""

and then use

  PipeRead my_xclock_buttton_script

But as far as I know you can't bind actions to button presses over
a swallowed applications.  Of course you could use a second button
for this.

> Anyway, I think that the raw configurability of FVWM2 makes it the
> best window manger for Linux.  I'm hoping that mastering commands
> like PipeRead will make it possible to develop a form customizeable
> interface for my wife.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 27 Dec 1999 02:39:50 +0200

On 27 Dec 1999 00:17:38 +0100, Dominik Vogt wrote:
> 
> On Fri, Dec 24, 1999 at 08:42:13AM -0600, Joe Mooney wrote:
> 

You can use it directly without an additional script:

PipeRead `date '+*FvwmButton(Title "%b %d %Y", Action "ical")'`

And of course, if the computer is always off at night, this is enough,
otherwise this will not work, since a dynamical update of button title
is not implemented (and probably can't be implemented).

I suggest to use another clock application, displaying date, like asclock.
http://www.asclock.org/

Regards,
Mikhael.