Subject: Notification: incoming/540

From: [email-masked]
Date: Thu, 30 Dec 1999 09:07:58 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/540

Message summary for PR#540
	From: [email-masked]
	Subject: FvwmConfig compile problems
	Date: Thu, 30 Dec 1999 09:07:56 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Fri, 31 Dec 1999 21:08:59 -0500

[email-masked] writes:
> >From [email-masked]  Thu Dec 30 09:07:57 1999
> To: [email-masked]
> Full_Name: Brian Hauber
> Version: 2.2.4
> OS: Solaris 2.6
> X_Server: CDE/COSE
> Submission from: (NULL) (192.55.24.50)
> 
> When attempting to build fvwm 2.2.4 with gcc 2.95.2 under Solaris 2.6 I get
> 
> the following error:
> 
> Making all in FvwmConfig
> gmake[3]: Entering directory `/tmp/bhauber/fvwm-2.2.4/extras/FvwmConfig'
> c++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../libs -I/usr/local/include
> -I/usr/openwin/include    -g -O2 -c FvwmConfig.C
> In file included from WinBase.h:5,
>                  from FvwmConfig.C:9:
> /usr/openwin/include/X11/Xlib.h:2063: ANSI C++ forbids declaration
> `XSetTransientForHint' with no type

Note that all the error messages you sent us point to errors in
Sun's header files.  Not that I think there's something wrong with
Sun's header files.  More likely theres something wrong with your
gcc installation.

I just  rechecked and I'm not  having any problem building with "gcc".
(Solaris  2.6, gcc  2.8.1.  I don't  know  why, but "configure" picked
"g++", not "c++" in my case.

Unless theres  a specific reason you  want FvwmConfig, you  can bypass
this problem by adding --without-cxx to the "configure" command line.

I will close this problem report, it doesn't look like an fvwm problem.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]