Subject: to do for 2.4 (update 27)

From: Dominik Vogt <[email-masked]>
Date: Fri, 17 Dec 1999 03:05:09 +0100

Items with highest priority / most severe problems:

102, 103

New since last update:

105, 106

Closed since last update:

11, 64, 104

---------- Summary: ----------------------------------------------

 0 to be verified
 7 to do
 5 distribution issues
 9 testing
----------------------
21 open items
85 items done
106 items in total

---------- To be verified: ---------------------------------------

none

---------- To do: ------------------------------------------------

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]
100) Remove I18N patches since author seems to have lost interest
     in finishing the patch.
102) Patch 'UseDecor' and 'UseStyle' styles and various ...Style
     commands to apply without a recapture.
     [perhaps not for 2.4]
103) Add recent bug reports to to-do list.

---------- Distribution issues: ----------------------------------

 9)  Set up RPM packages.
     [???; Jason?]
 12) Set up bzip2 tarballs.
     [optional]
 48) Finish Windoze 95 like config file.
     [stalled (90%)]
 62) Write a new announcement.
     [in progress]
 90) Icon distribution.

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
105) Test binding code.
106) Test window position code.
 
========== Done: =================================================

 1)  Document the GNOME stuff (man page still missing).
 2)  Add screen shots to web page.
 3)  Add link to fvwm cats page to web page.
 4)  Add link to Mikhael' wm-icons page.
 5)  Update the links on our home page.
 6)  Remove several configure options.
 7)  Create an I18N fvwm package (from 2.2 or so).
     [see #100]
 8)  Add an explanation about the various packages and where to
     discuss them to the web page.
     (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 10) Remove 'PopupAsRootMenu' menu style (?).
     [rejected]
 11) Add FvwmKb module?
     [delayed until after 2.4]
 13) Use a 'busy' pointer during startup.
 15) Get restart straight (sometimes an application vanishes over restarts)
     [fixed]
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no bug; doesn't happen for 2.2 and up]
 19) Fix: KFM windows stay on top of normal fvwm windows.
     [done]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
     [no fix? or should we rather break 'xterm +ai'?]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
     [Eterm bug fixed, rxvt doesn't work very well with transparent
     background. I've reported to the rxvt mailing list]
 22) Investigate bug #290. (windows cannot be raised over others sometimes).
     [mail thread from April; confirmed by me (Dominik)]
     [fixed; there is a new style and the behaviour is a bit more intuitive]
 23) Check if bug #312 is still there.
 24) Investigate bug #314.
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [fixed; only in 2.2.2, caused by missing X error handler]
 26) Investigate bug #315. (Recapture doesn't work perfectly for changing the
     default decor).
     [mainly a documentation problem; man page was updated]
 27) Check if bug #334 is still a problem.
 28) Investigate FvemEvent core dumps.
     [fixed in 2.2.3, no bug in 2.3.4]
 29) Fix the pager bugs I reported recently.
 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
 31) 'Maximize grow grow' works only on the current page.
 37) Fix interaction of moving with autoraising icon titles.
 38) Investigate bug #389. (StartsOnDesk does not work)
     [configuration problem, added a warning to the code]
 39) Investigate bug #390
 40) Investigate bug #394. (Overlapping pages)
     [no bug; doesn't happen after a recompile]
 41) Fix hanging fvwm when moving GNOME menu bars (bug #395).
 42) Get bitmap icons working again.
 43) Several pager bugs (bug #379).
 44) Fix TaskBar crash caused by latest patch in RemoveButton().
 45) Remove the web pages from the distribution.
 46) Titlebars should not inherit the pixmap from the border style.
 47) Verify the TaskBar clock update problem.
     [given up; I think I could reproduce the problem - it was a
     configuration mistake, but the reporter didn't care to answer
     if my suggestion helped; Dominik]
 49) Implement a 'H'old trigger for complex functions.
 50) Implement a 'ButtonGeometry' option for FvwmButtons.
 51) Fix constraining the window size when a window is maximized or
     larger than MaxWindowSize when mapped.
 52) Allow to resize in client resize increment steps.
 53) Decide what to do with overlapping moved icons.
     [will be ignored]
 54) Find a better solution for raising/lowering of transients.
 55) FvwmGtk can't be killed with 'KillModule'.
 56) Mini icons may overlap menu titles.
 57) Fix autohiding and TaskBar tips.
 58) DeskTopSize is not honoured upon a restart (the old one is reused).
     [use Restart --dont-preserve-state]
 59) Get Raise/Lower of transients straight.
     [duplicate of item 54]
 60) Make MaxWindowSize a style (don't release a command that will
     change anyway).
 61) Get SidecPics working again.
 63) Fix stacking order in pager.
 64) Install the new web pages.
 65) Fix "maximize true ..." when a window is already maximized.
 66) Fix ddd problems.
     [fixed as far as possible; bug reported to ddd list]
 67) Add a Windoze95 like screenshot to the web page.
 68) Investigate 'Xlib: sequence lost' message.
     [went away with a newer snapshot]
 69) Fix window moving. Several people have reported that moving windows
     is slow or the windows don't follow the pointer well. This is really
     a big problem.
 70) Fix resize. On one hand it's not nice that you can drag the window
     border off screen, on the other hand it doesn't hurt if the shadow
     of the border is not on screen.
 71) Fix drawing of window titles.
 72) Finish implementing colour sets for modules.
     [item split up]
 73) Remove 'panel' feature from FvwmButtons and re-implement it in a
     less disruptive way.
 74) To fix: icons are not preserved over a Quit - Start for fvwm
 75) Implement colour sets in FvwmWharf.
 76) Implement colour sets in FvwmTaskBar.
 77) Implement colour sets in menu styles.
 78) Implement colour sets in window styles.
     [only colours used yet]
 79) Implement colour sets in FvwmConsole?
     [rejected]
 80) Implement colour sets in FvwmScript
 81) Change the way in which fvwm 'posts' menus with a click.
 82) Introduce a 'transient' option for FvwmButtons. This is needed
     to replicate the old panel behaviour.
 83) Fix FvwmIconMan crashes introduced by colour set support(?)
     [doesn't happen anymore]
 84) Implement colour sets in FvwmBacker.
 85) Add 'geometry' panel option in FvwmButtons.
     I think it's not worth the effort because it's similarly
     complicated as the menu position hints if I want to do it right.
     I can't see an easy solution that does something useful fast.
     [future enhancement]
 86) Finish code for setting backgrounds of other applications with
     colour sets.
 87) Describe what to do for colour set support in the module docs.
 88) Investigate 'pager out of sync' problem
     [fixed]
 89) Make FvwmScript use the same visual as fvwm (prerequisite for 80)
 91) Fix Xpm version problem (bug #463).
 93) Finish 'CREATING PANELS' section in FvwmButtons man page.
 96) Make flat titlestyle work again.
 97) Rewrite FvwmTheme 'Colorset' syntax ala MenuStyle.
 98) Allow using colours from colour sets in fvwm commands.
 99) Make HilightColors command colour set aware.
101) Finish current work on style changes w/o recapture in a
     consistent way. This doesn't necessarily mean that the
     feature has to be complete before 2.4.
104) Fix FvwmCommandS core dumps on X server shutdown.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 19 Dec 1999 12:42:18 +0100

>  48) Finish Windoze 95 like config file.

Hello, 

Here I suggest that we open two new "source" trees: fvwm-samples and fvwm-icons
with an autoconf install procedure.

fvwm-icons: This is easy to be done and in fact it is done on my machine.
 The advantage is that ./configure find the FVWM install-prefix and
 then "make install" install the icons in, say, install-prefix/share/fvwm/icons.

fvwm-samples: At first step it is easy to done. Just one directory "Windoze95"
 with the system-sample-95 file and the autoconf stuff that will be able to
 solve the "!!! use configure" problems.
 After, we may add other "configuration systems" and use configure to do
 intelligent jobs (e.g., internationalization and check for apps when building
 menus).  Moreover, each "config-sys" can have some icons, sounds, Forms, 
 Scripts that can be installed in  
 install-prefix/share/fvwm/{icons,sounds,forms,scripts}/config-sys/
 for example.

Of course I am volunteer to do a large part of the work, however, I do not
know how to create a new source tree.

Olivier

---

From: Dan Espen <[email-masked]>
Date: Sun, 19 Dec 1999 10:05:08 -0500

> >  48) Finish Windoze 95 like config file.

I forget why Icon distribution is still open.

> Hello, 
> 
> Here I suggest that we open two new "source" trees: fvwm-samples and
> fvwm-icons with an autoconf install procedure.
> 

Is that really any easier than the instructions at:

http://www.fvwm.org/icons.html

"Note, make a directory to  hold the icons and put  the "tgz" file  in
the directory before unpacking."

But my main point is that you haven't mentioned the existing icon
distribution, so if you are considering anything new, make sure your
plan includes the existing distribution.

>  install-prefix/share/fvwm/{icons,sounds,forms,scripts}/config-sys/

Most  of whats currently in "sample.fvwmrc"  is  now spread around the
source tree  in multiple "ConfigFvwmXXX"  files.   The main thing that
has not  been moved  out of this   directory are the   various "decor"
examples.  If we deal with the decors, we can just remove the whole
directory.

I think the stuff that Alex Wallis has been working on is the right
way to deal with the decors.  I don't know if "configure" is a good way
to deal with this.  A user should have some sort of GUI thats lets them
try out a decor and modify it.  (Thats what Alex's stuff does.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Mon, 20 Dec 1999 11:42:03 +1030

> try out a decor and modify it.  (Thats what Alex's stuff does.)
It'd be fairly easy to have a "set" of different "sample decors" and switch
between them with my GUI. Just have a basic user.fvwm2rc and the
decor stuff can be on separate configs to be read at Start/Restart.
Several configs can be read depending on what the user specifies.
You can even try out other peoples configs with minimal fuss.

Alex

Desktop themes for fvwm2.3.11 at www.dove.net.au/~awol/fvwm2

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 Dec 1999 05:52:07 +0200

On 19 Dec 1999 12:42:18 +0100, Olivier Chapuis wrote:
> fvwm-icons: This is easy to be done and in fact it is done on my
>  machine. The advantage is that ./configure find the FVWM install-prefix
>  and then "make install" install the icons in, say,
>  install-prefix/share/fvwm/icons.

I am neutral here. Since it is only one directory to install, the current
solution within fvwm-web is ok for me. Of course it is nice to have fvwm
and fvwm-icons to share the same paths, but this only matters if we supply
ready to use rc files which use these icons.

Until now OS distributions provided the fvwm-icons package ready to use
with fvwm and default rc files using these icons.
As fas as I know, in Debuan the upcoming fvwm package will go with the
wm-icons as the icons distribution for it.

>  install-prefix/share/fvwm/{icons,sounds,forms,scripts}/config-sys/

I already said before that fvwm-themes repository would be nice. You can
find some discussion in the summer on this topic. This matches well enough
what Alex is doing now. Also I know that Jason Kibblewhite
<[email-masked]> worked on similar issues.

> know how to create a new source tree.

New repository tree should be planned well first, it is difficult to move
files/directories in CVS. I will send soon to Alex a list of improvements,
covering the directory structure among other things.

After we have a good designed working example (probably based on Alex's
solution, but definitely with a better directory structure) we will ask
Jason to create fvwm-themes repository.

> Olivier

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 20 Dec 1999 09:40:04 +0100

> ready to use rc files which use these icons.

That the points: system-sample-95 is done for fvwm-icons (only need to
replace mini- by mini. in this config file). Moreover, it can be a base
set of icons for certain "config-system" in a future fvwm-themes branch
(others using wm-icons).

> Jason to create fvwm-themes repository.

I vote for this. So, we will have a place with more or less independent
directories as:

Windoze95/
awol/
...etc

and we can apply bazar techniques to improve all the stuff !

Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 20 Dec 1999 09:40:16 +0100

> plan includes the existing distribution.

My idea was to move the existing icon distribution to fvwm-icon. The
reason is to give a base set of icons for a future fvwm-{samples,themes}
source tree. Then, having an installation procedure is useful to place 
the icons in a standard place.

Olivier

---

From: Dan Espen <[email-masked]>
Date: Mon, 20 Dec 1999 12:53:15 -0500

> > Jason to create fvwm-themes repository.

We don't need Jason's help to create another source tree.

Somehow, after fvwm-web was created, I never got around to documenting
the commands, but  there should be sufficient  information in the mail
archives.  If we really decide  to go with another tree,  I can dig it
out.

I still don't see the need for another tree.  We have fvwm-web for the
static stuff, that users  don't  need to  download,  and fvwm for  our
source.

The forms and scripts needed should be in "fvwm" and any canned themes
would naturally end up in "fvwm-web". (My opinion.)

If we create another tree for themes, and expect that to propagate
onto our web pages, we are just creating another area that Jason has
to make propagation to the web pages work for.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 20 Dec 1999 15:20:34 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> If we create another tree for themes, and expect that to propagate onto
DE> our web pages, we are just creating another area that Jason has to make
DE> propagation to the web pages work for.

Just let me know what you end up deciding on.  I appreciate you folks
trying to save me effort, but this isn't a really a huge issue.  Pick what
organizes things the best.

Perhaps fvwm-web is just ill-named and it should have been instead a
collection of stuff that doesn't get built into the distribution.

 - J<

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 24 Dec 1999 09:53:13 +0100

>  48) Finish Windoze 95 like config file.

I would like to finish this. It seems that my previous message was
not clear. I try an other method:

from sample/system.fvwm2rc-sample-95:

#!!!use configure here
ImagePath /usr/local/lib/X11/pixmaps:/usr/local/lib/X11/mini-icons:/home/avatar/src/fvwm/icons:/home/avatar/src/fvwm95-2.0.43b/pixmaps:/home/avatar/src/fvwm/icons

How can we use configure here if the fvwm icons are not installed in a
standard place ? A proposed solution was that sample-95 came with its
own icons. But, I think it is reasonable to use the fvwm icons dist.

#!!!use configure here
DestroyMenu Documents
AddToMenu Documents \
  FVWM%mini.win95.xpm%		Exec netscape \
					/usr/local/lib/X11/fvwm95/index.html

A proposed solution was to use http://fvwm.math.uh.edu/ this is ok only for
machines with a permanent connection. Moreover, the doc depends on the
fvwm version, so it seems that fvwm-web is not the solution (note that in
fvwm-web we have the 2.2 man page but the 2.4 FAQ).

#!!!use configure here
*FvwmAudioPlayCmd /usr/bin/play
*FvwmAudioDir    /usr/local/lib/sounds
*FvwmAudioDelay 1
*FvwmAudio destroy_window crash.au
*FvwmAudio add_window  whip.au

Do we need to add sound stuff some where ?

#!!!use configure here
*FvwmScriptPath /usr/local/lib/X11/fvwm2/scripts

Problem: the Scripts are not installed and do not really works.

What are the solutions to all this problems ???
Here some solutions:

1. Users/Distribution have to solve all this problems itself.
Bad solution IMHO: the fvwm-wokers are the only guys that really
know FVWM.
 
2. a. Put back the icons in the fvwm dist and add --enable-icons
      options to ./configure
   b. Copy  the doc stuff of fvwm-web/generated in fvwm dist and
      add --enable-doc to ./configure
   c. add a directory Windoze95 to fvwm/sample and put the needed stuff
      in this directory (.fvwm2rc, Scripts/, (Sounds/)). 
      Add --enable-win95 to ./configure
Note: i. Most window managers work like this (with the options 
        enable by default)
      ii. Olivier why you want to die ?

3. Create packages in fvwm-web: 
fvwm-sample-win95-{2.4,2.5}, fvwm-docs-{2.4,2.5}
Reasonable IMHO, but since these stuff is version dependent this cause
some problems. Moreover:
  a. where we develop fvwm-sample-win95 ?
  b. How to solve the icons and docs path problems ?

4. Create a source tree fvwm-misc with:
  a. icons/, 
  b. the doc of fvwm-web/generated
  c. Windoze95/
  d. sounds/
Note: This is note an replacement of an eventual fvwm-themes source
      tree.

Sorry, for this to long message (I'm ready to get no answer). But I would
like to finish with a story:

 16 months ago I have installed Linux (RH 5.1) in my machine. The guys that
 install Linux for me put AfterStep as the default wm. Because of a bad config
 file (the winlist was StayOnTop with a geometry of 1024x(1line)+0+10 so some
 times it was impossible to move a window !) I tried fvwm2 (not anotherlevel)
 with the fvwm95 config file ... and now I a humble fvwm-worker.

 FVWM is surely one of the best window manager, however, there is an enormous
 gap between what it can do and the config file provided. sample-95 is not
 the definitive solution, IMHO a fvwm-themes source tree is the solution but
 this is an enormous work. So, for me "an automatic well installed sample-95" 
 is a reasonable temporary solution.

Olivier

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Dec 1999 15:08:46 -0500

Olivier Chapuis <[email-masked]> writes:
> ImagePath /usr/local/lib/X11/pixmaps:/usr/local/lib/X11/mini-icons:/home/avat
> ar/src/fvwm/icons:/home/avatar/src/fvwm95-2.0.43b/pixmaps:/home/avatar/src/fv
> wm/icons
> 

Ah, but the icons are installed by the same person that installed fvwm.
Since ImagePath is built in it should now either not be in the config
file at all, or look like this:

ImagePath $HOME/icons:+

(Thats my current Imagepath.)

> fvwm-web we have the 2.2 man page but the 2.4 FAQ).

I don't see much of an issue here, if we wanted to have a built in
documents menu leading to the fvwm documentation, using "www.fvwm.org"
would be "close enough" (in my opinion.)

"www.fvwm.org"  leads to  the man  pages for 2.2.3  (or  what ever the
latest non-beta release is.)  That should be correct for the majority
of users.

Most of us agree, there is no problem that the FAQ  is always from the
latest beta.    (Answers that rely on  beta  features are  supposed to
mention the beta release.)

My W98 Documents menu doesn't do this anyway.  (It doesn't lead to W98
documentation.)

> Do we need to add sound stuff some where ?

If we wanted to make sounds available, I think they should be in
fvwm-web, along with the icons.

On my system, the PlayCmd is "audioplay", and setting "AudioDir" is a
problem.  configure aleady knows a little about rplay.

> Problem: the Scripts are not installed and do not really works.

I think FvwmScript has to be changed to read from the same place
FvwmForm reads from.  Having the path in the .fvwm2rc is broken.

> Bad solution IMHO: the fvwm-wokers are the only guys that really

Ok.

>       ii. Olivier why you want to die ?

I guess you weren't on the list  when we took  the icons out.  Some of
the reasons:

Make install would take forever.

You'd be installing the same thing (the icons) over and over.
They never change.

2 downloads is no big deal.

Adding "--enable-icons" sounds, OK, but I think  we should just assume
that the icons are installed, and create menus and configs that assume
they  are there.   If  they  are not  there,   fvwm would  still  work
reasonably well.

> fvwm-sample-win95-{2.4,2.5}, fvwm-docs-{2.4,2.5}

2.5 would be a beta.  Beta users are supposed to be able to deal
with these issues.  I still think we only need themes and docs for
one release.

> Note: This is note an replacement of an eventual fvwm-themes source

I think we can  get a w95 theme  from fvwm-themes in a reasonable time
frame.

Until then, I have a story of my own.  One of my users asked for a w95
theme a  few  years  back.   I pulled   the  stuff out of  the  sample
directory and created a reasonable facsimile in less than 1 hour.

>  is a reasonable temporary solution.

I still think fvwm-themes is not that far away from completion if some
of us could pitch in.

Right  now,  we   have a   setup   form  that  creates  a    "working"
configuration.  Have  you considered adding   a button that says  "W95
appearance"?  I think you would find, that it would  be pretty easy to
make that change.

> Olivier

Thanks for bringing up these issues.  I agree we need more work
in the configurability area.  We have plenty of features, we need to
do more work bringing them within reach of the average user.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 27 Dec 1999 04:20:35 +0200

I want to inform that me and Olivier are working on creating fvwm-themes
framework (started some days ago).

The framework should allow both a great configurability and ease to use.

Due to enormous work to be done to standardize this framework and provide
working themes, the discussion will unlikely be on this mailing list.
I will post initial drafts and results from time to time though.
Anyone wishing to help (this includes at least converting own .fvwm2rc
to the continually updated new scheme) is welcome to email me.

> static stuff, that users  don't  need to  download,  and fvwm for  our

Let's have something which works (and works well) and then decide where
it belongs. My opinion is that fvwm-themes is different. I prefer to have
it live (not static) or not to have it at all. Once the framework is more
or less done, it could be maintained by a fvwm lover outside fvwm-workers.

> would naturally end up in "fvwm-web". (My opinion.)

fvwm.themes.org (currently dead) may be a perfect candidate for the main
fvwm-themes repository. It should be up, otherwise we are just loosing
a user base.

Regards,
Mikhael.