Subject: finished border drawing - request for comments

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Dec 1999 20:28:21 +0100

The new border drawing code is now finished.  I hope all
the problems reported earlier are now fixed.  Now I would
like to remove the new GlobalOpts BORDERCOLORPRIORITY
and BORDERRELIEFPRIORITY.  I've checked mwm/fvwm borders
with widths between 1 and 6 pixels and can hardly see a
difference.  I find the new BORDERCOLORPRIORITY style
gives a better 3d look except for MwmBorder with
HandleWidth 2.  In this case you don't need the
global option though but you can simply use a lighter
border colour.

There are two definite advantages of the new code:

 - thin borders have a colour closer to the
   colour that thick borders have
 - Shaded windows without a title don't look like
   a drawing bug.

So, is there any chance to convince you (Tim) that we
don't need this global option?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 17 Dec 1999 10:38:41 +0000

> don't need this global option?

You can get rid of it if you can come up with a way to have a two pixel
wide border just show the relief and none of the border color.  I do
this with NoInset and I find it useful for dialog boxes etc. that don't
need to be resized but look funny with no border at all.  Without the
globalopt you always get a pixel of border color which I don't want.

I know it's only a minor thing but it's a backwards incompatible one.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 10:33:34 +0100

> globalopt you always get a pixel of border color which I don't want.

I've made an exception from the new way for two-pixel borders.
That should save us a new global option.

Bye

Dominik ^_^