Subject: Errors with kde apps.

From: Alex Wallis <[email-masked]>
Date: Tue, 21 Dec 1999 12:04:59 +1030

I keep getting these errors whenever I use kde apps.

[FVWM][GetWindowSizeHints]: <<WARNING>> Select folder window 0x3c01c08 has broken (max_width) size hints
Please report this to [email-masked]
flags = 562
min_width = 170, min_height = 30, max_width = 4, max_height = 32767
width_inc = 0, height_inc = 1075898766
min_aspect = 1076967496/-2133819205, max_aspect = -1073745000/1076967496
base_width = 136529712, base_height = 69
win_gravity = 1

[FVWM][GetWindowSizeHints]: <<WARNING>> Select folder window 0x3c01c55 has broken (max_width) size hints
Please report this to [email-masked]
flags = 562
min_width = 170, min_height = 30, max_width = 4, max_height = 32767
width_inc = 0, height_inc = 1075898766
min_aspect = 1076967496/-2133819205, max_aspect = -1073745000/1076967496
base_width = 137999392, base_height = 69
win_gravity = 1
 
Thought someone might find them interesting.
The apps still work, but I keep getting a crosshair cursor and have to click
on a window before fvwm2 resumes. Then all goes well again.
Seems like it's getting an extra grab window or something.
Every kde transient causes this to happen too.
Otherwise kde apps work well with fvwm2

Netscape transients also produce the "grab window" syndrome.
This has been happening for awhile now. I've got the 991220 snap
but 2.3.11 and earlier did this too. It may be something with this 
installation. I'm picking up a new HD and probably OS too today.
Will see if it happens on a BSD install soon.

Alex
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 20 Dec 1999 22:15:34 -0500

> base_width = 136529712, base_height = 69
....
> Otherwise kde apps work well with fvwm2

Fvwm is trying to tell you these app windows are broken.
Having minimums greater than maximums is not a good sign.
You can verify this by typing "xwininfo -all" in an xterm
and then clicking on the window in question.

If you get the same kind of information from xwininfo, you might
consider forwarding the output to the responsible developer.

I'm not too sure what the crosshair is about.

> Will see if it happens on a BSD install soon.

Hmm, I have noticed I have to place Netscape transients also.
I just assumed I changed something in my configs to cause this.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 11:34:02 +0100

> min_width = 170, min_height = 30, max_width = 4, max_height = 32767
  ^^^^^^^^^^^^^^^                   ^^^^^^^^^^^^^

> Thought someone might find them interesting.

Can you report this to the KDE developers?

> on a window before fvwm2 resumes.

The crosshair has nothing to do with this message.  It is
probably caused by something in your config file (it may
still be a bug, though).  Please post your config file and
a description what I have to do to get this behaviour.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Wed, 22 Dec 1999 00:31:17 +1030

> a description what I have to do to get this behaviour.
Well my config is my Awol desktop theme I posted the site for the other day.
And here again now. But my old HD was pretty stuffed. I just got a new one.
I'm downloading the latest snap right now. I'll try and give you more details 
if I still get these happenings on a brand new install soon.

Thanks.

Alex

Desktop Themes for 2.3.11 at www.dove.net.au/~awol/fvwm2

---

From: Alex Wallis <[email-masked]>
Date: Wed, 22 Dec 1999 16:09:47 +1030

> if I still get these happenings on a brand new install soon.
Well I get the same kde errors on this install on a new drive.
Netscape still produces the crosshair select cursor too. Every time
a transient is created. Even without a config at all. Is it a bug? kmail does too.
This is on a SuSe 6.2 install. In the next couple of days I'll hopefully
have a Free-BSD and a Redhat to check this out on also.
I'll try out if using different configs also produces these strange effects.
Will let you know.

Alex

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 15:29:55 +0100

> if I still get these happenings on a brand new install soon.

Uh, can you please strip it down to a single file that shows the bug,
please?  I don't have the time to get complex theme examples running
now.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 09:39:39 +0100

> I just assumed I changed something in my configs to cause this.

This means that you should should update your config file:

  Module FvwmAuto 200 Raise Nop

is not the correct way to start FvwmAuto.  Shortly
after the transient menu is opened, FvwmAuto sends the 'Raise'
command for this window to fvwm.  Before fvwm receives the
request, the application (e.g. kfm) grabs the X server so
that fvwm freezes.  When you select something from the menu,
the menu is unmapped.  Since fvwm handles pending X events
always before pending module input, the window is unmapped
first.  Now fvwm reads the module packet, but since the window
therein has already died, fvwm asks the user for a window to
raise.  It was pure luck that this didn't happen before.

Solution: Use the 'silent' prefix as recommended in the man page.

  Module FvwmAuto 200 "Silent Raise" Nop

or even better:

  Module FvwmAuto 200

I have made a patch to prepend 'Silent' automatically when FvwmAuto
sends its commands to prevent this, but I still recommend to
fix your config, especially since it may serve as an example for
new users.  We don't want to teach them deprecated syntax, do we? ;-)

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Thu, 30 Dec 1999 03:33:35 +1030

>   Module FvwmAuto 200 Raise Nop
I just stuck that in as a temporary fix.
> new users.  We don't want to teach them deprecated syntax, do we? ;-)
Cool! I'll do that straight away. I'm preparing a new version of themes right now.
Thanks for the info.