Subject: CVS domivogt: * Fixed compilation error in gnome.c.

From: CVS <[email-masked]>
Date: Sun, 5 Dec 1999 17:50:38 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/12/05 17:50:37

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c events.c functions.c gnome.c 
	                 gnome.h 

Log message:
* Fixed compilation error in gnome.c.
* Grab buttons on client window instead of parent window.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 07 Dec 1999 17:05:07 +0000

> * Grab buttons on client window instead of parent window.

I think this is killing one of my programs. It's cutview (version 1.62)
and it fails if fvwm has grabbed meta-button 3:

Mouse 3 A M StrokeFunc EchoSequence Feedback DrawMotion

the error is:

X Error of failed request:  BadAccess (attempt to access private
resource denied)
  Major opcode of failed request:  28 (X_GrabButton)
  Serial number of failed request:  645
  Current serial number in output stream:  646

In the cutview source is:

static char defaultTranslations[] = "<Btn3Down>: menu()";
XtTranslations trans_table;

I don't know Xt so I don't know if this is an Xt bug.

Cheers,
Tim.

        trans_table = XtParseTranslationTable(defaultTranslations);
        XtOverrideTranslations(multi_buffer, trans_table);
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 7 Dec 1999 18:19:37 +0100

> I don't know Xt so I don't know if this is an Xt bug.

Probably not.  I guess it fails because two applications can't
have the same button grabbed on the same window.  Sigh, seems
I have to switch back to grabbing in Parent (==> Leave/EnterNotify
==> pager ballons flicker :( ).

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]