Subject: Notification: incoming/535

From: [email-masked]
Date: Fri, 24 Dec 1999 06:57:59 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/535

Message summary for PR#535
	From: [email-masked]
	Subject: motif 'options menu' problem in FVWM
	Date: Fri, 24 Dec 1999 06:57:56 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 05:35:02 +0100

On Fri, Dec 24, 1999 at 06:57:59AM -0600, [email-masked] wrote:
> >From [email-masked]  Fri Dec 24 06:57:58 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id GAA10165
> 	for <[email-masked]>; Fri, 24 Dec 1999 06:57:56 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: A.Nixon
> Version: 1.24r, 2.2.2, 2.2.4
> CVS_Date: 
> OS: Redhat Linux 4.2
> X_Server: XFree86's XF86_SVGA
> Submission from: (NULL) (202.54.64.15)
> 
> 
>    When ClickToFocus is the focus setting, we created options menu using
> Motif 2.1 libraries. When we select the options menu for the first time the
> focus behaviour becomes "focusfollowsmouse" and when we operate on the
> option menu the second time the window completely loses focus. The window
> or any text control in it does not get focus when we click on it. The
> clickToFocus behaviour is restored only when we click on the title bar.
>     NOTE: This behaviour is not present in twm and mwm. Also,it is not 
> there if the focus "follows mouse" option in .fvwmrc is enabled. 
> 
> I am enclosing an example program herewith. 
...

I tried to run this sample program, but all I get is this error
message:

  Error: attempt to add non-widget child "DropSiteManager" to parent "motiftest" which supports only widgets

caused by the statement

  top = XtVaCreateManagedWidget("MainWin", xmMainWindowWidgetClass, topShell, NULL);

(with lesstif 0.88.9)

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]