Subject: CVS dane: * FvwmScript/FvwmScript.1: Describe how scripts are located for

From: CVS <[email-masked]>
Date: Sun, 26 Dec 1999 13:45:20 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	99/12/26 13:45:20

Modified files:
	modules        : ChangeLog 
	modules/FvwmScript: FvwmScript.1 FvwmScript.c Makefile.am 

Log message:
* FvwmScript/FvwmScript.1: Describe how scripts are located for
reading.

* FvwmScript/FvwmScript.c: Read the input file from FVWM_USERHOME
or FVWM_CONFIGDIR in addition to old rules.  This makes
"*FvwmScriptPath" unnecessary.

* FvwmScript/Makefile.am: Pass configdir into FvwmScript.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 27 Dec 1999 07:25:28 +0100

> * FvwmScript/Makefile.am: Pass configdir into FvwmScript.

Great !
But, what do you think about reading the script in FVWM_CONFIGDIR/Scripts
(in the place of FVWM_CONFIGDIR) and install the example scripts in
this directory ? Of course I can do that if you are agree.
Olivier

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Dec 1999 06:18:29 -0500

> this directory ? Of course I can do that if you are agree.

I think we should use the same rules for everything we install.
We are currently installing config files and forms.

The config files are named:

ConfigFvwmSetup
ConfigFvwmBanner

The forms are named:

FormFvwmTalk.
FormFvwmSetup.

For scriptts we don't need the trailing dot, so scripts would be:

ScriptFvwmFileBrowser
ScriptFvwmFind

I think we should be using names like this so we don't conflict with
scripts a user is likely to write.

If you agree, I don't think the directory name helps, we would end up
with:

Script/ScriptFvwmFind

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 27 Dec 1999 20:12:36 +0100

> scripts a user is likely to write.

Yes, it is the good idea, I think I do not have it because it needs
more work :) I will do the change (and review the scripts).
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]