Subject: Chris Rankin: Re: FvwmAuto problem

From: Dan Espen <[email-masked]>
Date: Fri, 17 Dec 1999 17:36:38 -0500

This came to me but was meant for fvwm-workers:

From: Chris Rankin <[email-masked]>
Subject: Re: FvwmAuto problem
To: [email-masked] (Dan Espen)
Date: Sat, 18 Dec 1999 09:21:28 +1100 (EST)
In-Reply-To: <[email-masked]> from "Dan Espen" at Dec 17, 99 02:14:08 pm

> So far we've tried:
> 
> 1) breakpoints in gdb at the exit point and we had "nonsense" results.
> 
> 2) turning on debug which seemed to indicate that "DeadPipe" was being
> called by the modules signal handler.

Whoa! When I first saw this message, I thought "that's not how the
signal handling works". However, I have now looked at this module and
see that I haven't updated the signal handling here. I don't see that
it can be making too much difference since gdb does say that FvwmAuto
receives a SIGPIPE signal. (I handle signals; I don't send them.)
However, it does mean that we might all be using signal() here and
possibly using different semantics.

I can update the handling NOW, or after we discover where the SIGPIPE
is coming from; which do you feel would be more useful?

Cheers,
Chris.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 01:11:34 +0100

> is coming from; which do you feel would be more useful?

Since this problem seems to occur quite frequently I think you
should make the fix now.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]