Subject: Re: to do for 2.4 (update 26)

From: Olivier Chapuis <[email-masked]>
Date: Fri, 03 Dec 1999 15:41:32 +0100

Dominik Vogt wrote:
> 
> ---------- Testing: ----------------------------------------------
> 
>  95) Test new panel implementation in FvwmButtons.
> 

Hello Dominik,
I am volunteer to add the following feature to FvwmButton panel:

"position +/-x+/-y"

which modify in a *relative* way the position of the panel

Also we may add a "buttonsborder" option which do
 
position +0+win_border for a down panel
position +0-win_border for an up panel
position +win_border+0 for a right panel
position -win_border+0 for a left panel

where win_border is the border width of the Buttons not of the
panel (need to add M_ADD_WINDOW | M_CONFIGURE_WINDOW in the message
mask).

So I ask for an "authorization" for such options (since we are not
far from feature freeze (I hope) and since you are the author of
the new (good !) panel implementation).

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 Dec 1999 17:50:10 +0100

> the new (good !) panel implementation).

The reason why I'm reluctant is that the code is already implemented
for menu position hints.  I don't like the idea of duplicating the
code.  If you make a try, please use a similar syntax.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 9 Dec 1999 02:00:13 +0200

On 25 Nov 1999 12:20:32 +0100, Dominik Vogt wrote:
> 
>  58) DeskTopSize is not honoured upon a restart (the old one is reused).
>      [use Restart --dont-preserve-state]

It is honoured now without --dont-preserve-state.

Regards,
Mikhael.