Subject: GNOME_SetDesk message?

From: "Robert H. Ford II" <[email-masked]>
Date: Tue, 14 Dec 1999 15:40:33 -0600

I am running snapshot fvwm-snap-19991214 and now I am getting the following
"ERROR" message in my console on startup:

[FVWM][GNOME_SetCurrentDesk]: <<ERROR>> Attemped to change to desk gnome does
not know about
[FVWM][GNOME_SetDesk]: <<ERROR>> Attemped to set window to desk gnome does not
know about

What could have changed to make these messages start coming out? 

The previous snapshot I was running was fvwm-snap-19991201 since then, these are
the only "Gnome" related changes I see: 

1999-12-05  Dominik Vogt  <[email-masked]>

        * fvwm/gnome.c (HandleGnomePropRequest):
        use DrawDecorations() instead of old SetBorder()

1999-12-04  Dominik Vogt  <[email-masked]>

        * fvwm/gnome.h:
        * fvwm/gnome.c:
        applied gnome patches by Matt Rossmiller

Am I missing something?

Thank you for all the help and for a great window manager.

Bob

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matt Rossmiller <[email-masked]>
Date: Tue, 14 Dec 1999 16:43:37 -0600 (CST)

This message tells you that some desk change command has been issued for a desk
outside of the range you have told gnome to expect.  Using FvwmPager with Gnome
will cause this to happen as when changing between two desks, it first changes
to desk 1000, then to the new desk.

-Matt

---

From: Tim Phipps <[email-masked]>
Date: Wed, 15 Dec 1999 11:18:23 +0000

Matt Rossmiller wrote:
> 
> Using FvwmPager with Gnome

This is fixed in version 2.3.3 and anything more recent than 1999-05-25

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Dec 1999 02:11:33 +0100

> What could have changed to make these messages start coming out? 

I have just comitted a fix.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]