Subject: CVS hippo: Fixed: Netscape mail icon dissapearing from FvwmIconBox when it changes

From: CVS <[email-masked]>
Date: Fri, 10 Dec 1999 07:38:47 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/12/10 07:38:46

Modified files:
	modules        : ChangeLog 
	modules/FvwmIconBox: FvwmIconBox.c 

Log message:
Fixed: Netscape mail icon dissapearing from FvwmIconBox when it changes
There must be a bug in either the server (Exceed 6) or xlib (Solaris 2.6)
because all I did was add an XSync.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 10 Dec 1999 13:48:30 +0000

> because all I did was add an XSync.

Dominik: did you say once that you didn't know how to remove shaping
from a window? I think I remember you saying so in a discussion about
FvwmTheme shape masks.  Anyway FvwmIconBox unshapes the icon windows
when a client changes its icon pixmap. It uses

XShapeCombineMask(dpy, win, ShapeBounding, 0, 0, None, ShapeSet);

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 10 Dec 1999 17:51:09 +0100

> XShapeCombineMask(dpy, win, ShapeBounding, 0, 0, None, ShapeSet);

Thanks, I've just checked in the code to do this.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]