Subject: CVS migo: * fvwm-menu-headlines: a new configurable script in fvwm-menu family

From: CVS <[email-masked]>
Date: Thu, 16 Dec 1999 20:51:48 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	99/12/16 20:51:48

Modified files:
	.              : ChangeLog NEWS configure.in 
	utils          : .cvsignore ChangeLog Makefile.am 
	                 fvwm-menu-directory.1 fvwm-menu-directory.in 
	                 fvwm-menu-xlock.1 fvwm-menu-xlock.in 
Added files:
	utils          : fvwm-menu-headlines.1 fvwm-menu-headlines.in 

Log message:
* fvwm-menu-headlines: a new configurable script in fvwm-menu family
- Displays headlines of some popular web sites in fvwm menus.
- Supported FreshMeat, LinuxToday, Slashdot, Segfault, more to come.
* fvwm-menu-directory --special-dirs option now more configurable
* fvwm-menu-directory, fvwm-menu-xlock: renamed --format to --item, warning!
* fvwm-menu scripts (4 for now) are now installed.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 17 Dec 1999 05:07:14 +0200

> * fvwm-menu-headlines: a new configurable script in fvwm-menu family

I should warn you if you want to use this script.
It is not complete yet, I am planning to add a usual icon support
and some more features, but it is already usable.
And you should be online to get results, of course.

Now, the second usage as described in the man page (generated on fly)
crashes fvwm for me. The first and third usages should be ok thought.

Dominik, can you reproduce a crash? If not I will investigate it later.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 18 Dec 1999 19:27:34 +0200

On 17 Dec 1999 05:07:14 +0200, Mikhael Goikhman wrote:
> The second usage as described in the man page (generated on fly)
> crashes fvwm for me.

Ok, I have found the problem. This always happens with animated menus.
Dominik, it's your code, please verify that this is enough to fix it:

--- move_resize.c.orig  Sat Dec 18 19:13:37 1999
+++ move_resize.c       Sat Dec 18 19:13:52 1999
@@ -380,7 +380,8 @@
   XUngrabKeyboard(dpy, CurrentTime);
   XFlush(dpy);
 #ifdef GNOME
-  GNOME_SetWinArea(tmp_win);
+  if (tmp_win)
+    GNOME_SetWinArea(tmp_win);
 #endif
   return;
 }

Regards,
Mikhael.