Subject: Re: *FvwmPagerGeometry still broken (PR#516)

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 09:19:46 -0600 (CST)

> Full_Name: Neil Zanella
> Version: 2.3.10
> CVS_Date: 
> OS: Linux 2.2.13
> X_Server: XFree86 3.3.2
> Submission from: (NULL) (129.128.153.50)
> 
> 
> Hello,
> 
> It seems like *FvwmPagerGeometry is still broken. For example the
command
> 
> *FvwmPagerGeometry 115x79+3+3
> 
> gives me a pager size that is larger than the one I specify.

Can you please try again with 2.3.11?  If that doesn't help,
please post your complete pager config plus the lines you use to
start it.  Furthermore please run 'xwininfo' on the pager window
and post the output too.

Bye

Dominik ^_^--
Dominik Vogt <[email-masked]>
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Tue, 21 Dec 1999 22:48:33 -0330 (NST)

The *FvwmPagerGeometry bug looks like it's finally fixed...

Hello,

I have a virtual desktop with 4x4 = 16 viewports.
I want each viewport to have size 28x19 pixels.  
The pager draws a one pixel wide line between each viewport.
Hence the pager will have length:

length = 28 + 1 + 28 + 1 + 28 + 1 + 28 = 4(28) + 3(1) = 115
width  = 19 + 1 + 19 + 1 + 19 + 1 + 19 = 4(19) + 3(1) = 79 

I also want the upper left hand coordinate of my pager to be (4,4)=(3+1,3+1).

Hence I have the line:

I then measure the size of each individual viewport on my screen.
They are all the correct size.   

I now add a PagerButton. The PagerButton swallows the FvwmPager and 
unswallows
it when the PagerButton is killed.

Since the Buttons' padding is three pixels its size should be:

(3 + 115 + 3)x(3 + 79 + 3) = 121x85

Hence I put the following line in my configuration file:

*PagerButtonGeometry 121x85+0+0

Once again, after restarting everything seems to have the correct geometry.

So as far as my own configuration goes it looks like the *FvwmPagerGeometry 
bug is fixed in Fvwm 2.3.11.

Best Regards,

Neil