Subject: CVS domivogt: * Colorset shapes can be reset now (please watch out for performance problems

From: CVS <[email-masked]>
Date: Fri, 10 Dec 1999 10:52:58 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/12/10 10:52:57

Modified files:
	.              : ChangeLog 
	libs           : Colorset.c 
	modules/FvwmTheme: FvwmTheme.1 

Log message:
* Colorset shapes can be reset now (please watch out for performance problems
with colour sets - even without shapes).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ben Winslow <[email-masked]>
Date: Sun, 12 Dec 1999 02:34:36 -0500

On Fri, Dec 10, 1999 at 10:52:58AM -0600, CVS wrote:
# Date: Fri, 10 Dec 1999 10:52:58 -0600 (CST)
# From: CVS <[email-masked]>
# Message-Id: <[email-masked]>
# To: [email-masked]
# Reply-To: [email-masked]
# Subject: CVS domivogt: * Colorset shapes can be reset now (please watch out for performance problems
# Sender: [email-masked]
# Precedence: list
# X-Majordomo: 1.94.jlt7
# Status: RO
# Content-Length: 562
# Lines: 18
# 
# CVSROOT:	/home/cvs/fvwm
# Module name:	fvwm
# Changes by:	domivogt	99/12/10 10:52:57
# 
# Modified files:
# 	.              : ChangeLog 
# 	libs           : Colorset.c 
# 	modules/FvwmTheme: FvwmTheme.1 
# 
# Log message:
# * Colorset shapes can be reset now (please watch out for performance problems
# with colour sets - even without shapes).
# 
# --
# Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
# To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
# body of a message to [email-masked].
# To report problems, send mail to [email-masked]
This change can break non-shaped Colorsets (I had an FvwmButtons with a nice
array of colors-- none if which I chose :)  The offending line seems to be
Colorset.c:148.  I believe this patch fixes the problem while keeping the
intended functionality, but if it doesn't somebody else will just have to
fix it ;)

-- 
Ben Winslow           /   [email-masked]
bluecherry internet   /   http://www.bluecherry.net
|Rain| @ IRC          /   anynet: irc.anynet.org
 
Index: libs/Colorset.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/libs/Colorset.c,v
retrieving revision 1.25
diff -u -r1.25 Colorset.c
--- libs/Colorset.c	1999/12/10 16:52:56	1.25
+++ libs/Colorset.c	1999/12/12 07:32:57
@@ -143,7 +143,7 @@
     if (mask != None)
       XFreePixmap(dpy, mask);
   }
-  else
+  else if (!colorset->pixmap)
   {
     XShapeCombineMask(dpy, win, ShapeBounding, 0, 0, None, ShapeSet);
   }

---

From: Ben Winslow <[email-masked]>
Date: Mon, 13 Dec 1999 11:35:36 -0500

On Mon, Dec 13, 1999 at 12:23:56PM +0100, Dominik Vogt wrote:
# Received: from BlackHole.RainNet.Org ([email-masked] [192.168.1.3])
# 	by Portal.RainNet.Org (8.9.3/8.9.3/Debian/GNU) with ESMTP id LAA19085
# 	for <[email-masked]>; Mon, 13 Dec 1999 11:30:18 -0500
# Received: from bbnmg1.cns.hp.com (bbnmg1.net.external.hp.com [192.6.76.73])
# 	by BlackHole.RainNet.Org (8.9.3/8.9.3/Debian/GNU) with ESMTP id GAA21673
# 	for <[email-masked]>; Mon, 13 Dec 1999 06:24:44 -0500
# Received: from isoit644.bbn.hp.com (isoit644.bbn.hp.com [15.136.88.78])
# 	by bbnmg1.cns.hp.com (8.8.6 (PHNE_17135)/8.8.5tis) with ESMTP id MAA22989;
# 	Mon, 13 Dec 1999 12:24:26 +0100 (MET)
# Received: from bvstp038.bbn.hp.com ([email-masked] [15.136.153.26])
# 	by isoit644.bbn.hp.com (8.9.3 (PHNE_18979)/8.9.3 SMKit6.0.6 OpenMail) with ESMTP id MAA15252;
# 	Mon, 13 Dec 1999 12:24:25 +0100 (MET)
# Received: (from domivogt@localhost)
# 	by bvstp038.bbn.hp.com (8.9.3/8.9.3) id MAA06238;
# 	Mon, 13 Dec 1999 12:23:57 +0100
# Date: Mon, 13 Dec 1999 12:23:56 +0100
# From: Dominik Vogt <[email-masked]>
# To: [email-masked], [email-masked]
# Subject: Re: CVS domivogt: * Colorset shapes can be reset now (please watch out for performance problems
# Message-ID: <[email-masked]>
# Mail-Followup-To: [email-masked], [email-masked]
# References: <[email-masked]> <[email-masked]>
# Mime-Version: 1.0
# Content-Type: text/plain; charset=us-ascii
# X-Mailer: Mutt 0.95.4i
# In-Reply-To: <[email-masked]>; from [email-masked] on Sun, Dec 12, 1999 at 02:34:36AM -0500
# 
# On Sun, Dec 12, 1999 at 02:34:36AM -0500, [email-masked] wrote:
# > # * Colorset shapes can be reset now (please watch out for performance problems
# > # with colour sets - even without shapes).
# 
# > This change can break non-shaped Colorsets (I had an FvwmButtons with a nice
# > array of colors-- none if which I chose :)  The offending line seems to be
# > Colorset.c:148.  I believe this patch fixes the problem while keeping the
# > intended functionality, but if it doesn't somebody else will just have to
# > fix it ;)
# 
# What is the problem with my patch?  I don't understand why the shape
# shouldn't be reset if the colour set has a pixmap.
# 
# > -  else
# > +  else if (!colorset->pixmap)
# >    {
# >      XShapeCombineMask(dpy, win, ShapeBounding, 0, 0, None, ShapeSet);
# >    }
# 
# Bye
# 
# Dominik ^_^
# 
# -- 
# Dominik Vogt, Agilent Technologies, Dept. BVS
# Herrenberger Str.130, 71034 Boeblingen, Germany
# phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
	Well, this may not be the best fix (I was kind of tired at the time
I noticed this).  I just know that it fixed my problem ;)  Had it been
earlier in the day, I would have tried to figure out a better solution (this
was intended more as a bug report than a fix-- the fix was just a "hey, if I
got lucky and this is the right thing" patch).  I *do* know that certain
swallowed apps caused FvwmButtons to change to a dark shade of black or a
dark shade of blue (instead of having the colorset I assigned to them), and
my best guess is that something is uninitialized...

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 Dec 1999 12:23:56 +0100

> intended functionality, but if it doesn't somebody else will just have to

What is the problem with my patch?  I don't understand why the shape
shouldn't be reset if the colour set has a pixmap.

>      XShapeCombineMask(dpy, win, ShapeBounding, 0, 0, None, ShapeSet);

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Dec 1999 10:59:06 +0100

On Mon, Dec 13, 1999 at 11:35:36AM -0500, [email-masked] wrote:
> I noticed this).  I just know that it fixed my problem ;)

So, what *is* your problem?

Bye

Dominik ^_^

---

From: Ben Winslow <[email-masked]>
Date: Tue, 14 Dec 1999 07:52:58 -0500

On Tue, Dec 14, 1999 at 10:59:06AM +0100, Dominik Vogt wrote:
# Date: Tue, 14 Dec 1999 10:59:06 +0100
# From: Dominik Vogt <[email-masked]>
# To: [email-masked]
# Subject: Re: CVS domivogt: * Colorset shapes can be reset now (please watch out for performance problems
# Message-ID: <[email-masked]>
# Mail-Followup-To: [email-masked]
# References: <[email-masked]> <[email-masked]>
# Mime-Version: 1.0
# Content-Type: text/plain; charset=us-ascii
# X-Mailer: Mutt 0.95.4i
# In-Reply-To: <[email-masked]>; from [email-masked] on Mon, Dec 13, 1999 at 11:35:36AM -0500
# Sender: [email-masked]
# Precedence: list
# X-Majordomo: 1.94.jlt7
# Status: RO
# Content-Length: 1504
# Lines: 37
# 
# So, what *is* your problem?
# 
# Bye
# 
# Dominik ^_^
# 
# -- 
# Dominik Vogt, Agilent Technologies, Dept. BVS
# Herrenberger Str.130, 71034 Boeblingen, Germany
# phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
# --
# Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
# To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
# body of a message to [email-masked].
# To report problems, send mail to [email-masked]

This.  (See attached screenshot.)
Each button is assigned the same colorset, however, the change causes
buttons 2, 3, and 5 to have strange colors instead of the gradient.  These
colors are not my foreground nor background for the colorset.

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 14 Dec 1999 08:01:57 -0500

> colors are not my foreground nor background for the colorset.

I can confirm this with my setup as well.  And Ben's fix seemed to work
for me, I didn't have time to inspect what exactlly you changed though
Dominik.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Dec 1999 14:25:06 +0100

> colors are not my foreground nor background for the colorset.

Oh, I see.  Removing the shape doesn't work because the window
has its own shape.  So if the shape is removed, the window loses
all shaping, not only the shape imposed by the colour set.  Seems
that I have to remove the patch.

Bye

Dominik ^_^