Subject: M_FOCUS_CHANGE packets

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 Dec 1999 12:02:15 +0100

I've noticed that the M_FOCUS_CHANGE packet holds some weird
information that is probably completely useless:

 - if the focus change was caused by mouse interaction
 - the hilight colours

Can we safely scrap these arguments?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 03 Dec 1999 11:31:51 +0000

>  - if the focus change was caused by mouse interaction

Nooooo! FvwmWinList uses the mouse interaction flag so that it can
accurately display the windowlist order.  I think the focus colours are
used by the pager by default. The bit that is useless in most packets is
the address of the fvwm window structure (word 5). This is what was
replaced by the focus type in M_FOCUS_CHANGE.

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 3 Dec 1999 06:58:39 -0500

> replaced by the focus type in M_FOCUS_CHANGE.

And I can confirm that the pager uses the colors.  In fact I know quite
a few people that define different hilight colors for there windows and
like the fact that the pager reflects that color.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 Dec 1999 18:04:21 +0100

> > replaced by the focus type in M_FOCUS_CHANGE.

Okay.  I thought it was unused.

> like the fact that the pager reflects that color.

Sigh!  Then we should pass the colour set too.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 3 Dec 1999 12:14:19 -0500

> Sigh!  Then we should pass the colour set too.

Yes we probabbly should, that hadn't occured to me.  If you want you can
modify the packet and I can take care of modifying the pager code.

Brad