Subject: Notification: incoming/525

From: [email-masked]
Date: Wed, 15 Dec 1999 06:32:41 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/525

Message summary for PR#525
	From: [email-masked]
	Subject: Java windows migrate across screen at popup time
	Date: Wed, 15 Dec 1999 06:32:39 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 15 Dec 1999 12:04:04 -0500

On Wed, Dec 15, 1999 at 06:32:41AM -0600, [email-masked] wrote:

> During the popup process of a JAVA-window (JDK 1.2.2) under fvwm 2.2.4
> the
>
> window is displayed first and in a second step the entire window moves
> upwards. It does not change size, it moves. Even setting a position in
> the
>
> code has no effect, because the position will be changed through
> this jumping behavior of the window manager. The internal layout is
> not changed after popup-time.  Behavior seems to be ok under dtwm of
> CDE. So what is missing in fvwm??
>

Well you will find that behavior in quite a few window managers, except
dtwm and openwindows.  The reason: SUN has workarounds in the java code
for there own window managers.  The fix: I'v found a call to setBounds
before the call to show works better than setLocation, so you might try
that.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Gunnar von der Beck" <[email-masked]>
Date: Thu, 16 Dec 1999 10:32:18 +0100

Hello Brad!

Many thanks for your help!! I'll try that.

Gunnar