Subject: bug: FvwmTaskBar switches page during auto hide

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 15:03:19 +0100

There is a new(?) auto hide bug in task bar:

 - Start taskbar non-sticky and with auto hide configured.
 - Move the mouse over the taskbar so that it unhides.
 - Move the mouse out of the taskbar.
 - Before the taskbar starts to auto hide, switch to
   a different page.  Because the task bar is not sticky it
   is no longer vilible.

==> after the auto hide timeout interval has passed, the taskbar
    switches to the current page and starts to hide there.

Fix: The Alarm timer has to be switched off when fvwm switches
     the page.  The X server has to be grabbed during the hide/
     unhide animation to prevent fvwm from switching pages.

Olivier, can you look into this?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 29 Dec 1999 10:55:21 +0100

> Olivier, can you look into this?

Yes, I will look at this and the other "non-sticky autohide taskbar
bug". However, do you see any reason to use a non-sticky TaskBar (and
moreover autohide) ?

> Dominik Vogt wrote:
> 
> Another taskbar bug:
> 
>  - Start taskbar non-sticky, autohiding on page 0 0.
>  - Hide the taskbar.
>  - Switch to page 0 1. The taskbar is visible on the top
>    border of the screen.  Although this looks funny it is
>    not really a bug.

I do not think that I will try to fix this one ...

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 12:39:20 +0100

> bug". However, do you see any reason to use a non-sticky TaskBar (and

If I don't want it only on certain desks?  I'm aware that the TaskBar
will never work properly if it's not sticky.  Perhaps we should simply
force it to be sticky somehow.  I think we can't do much about autohiding
anyway since the taskbar would have to check for page switches
during the animation.  Only fvwm can handle this properly.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 12:47:46 +0100

> If I don't want it only on certain desks?  I'm aware that the TaskBar
       ^^^^^

delete this.

Bye

Dominik ^_^