Subject: FvwmTaskBar hangs if moved

From: [email-masked] (Tim Phipps)
Date: Fri, 17 Dec 1999 16:38:16 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.12
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.11
FVWM_USERHOME: unset

Description:
	FvwmTaskBar hangs when moved. It gets into a 100%cpu loop due to
	calling an Xlib function from a signal handler.

Repeat-By:
	StartFvwmTaskBar. Do an interactive opaque move that lasts for
	a few seconds before releasing the mouse button.

Fix:
	The Alarm() signal handler has this in it:

  if (trigger_event)
  {
    event.xmotion.x = -1;
    event.xmotion.y = -1;
    event.xany.type = MotionNotify;
    XSendEvent(dpy, win, False, EnterWindowMask, &event);
  }

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 17 Dec 1999 19:03:41 +0100

>         calling an Xlib function from a signal handler.

Do you have the same problem with  interactive resize ?
 
>         a few seconds before releasing the mouse button.

I am unable to repeat it. The thing I can see is a lot of crazy move
when autohide is enable. Do you have problem without autohide ?
With resize I see only one crazy move (I've work for that ... and decide
that the user has no need to move an autohide taskbar ...).
I've no crazy move with non opaque move/resize.
   
>     XSendEvent(dpy, win, False, EnterWindowMask, &event);

?

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 18 Dec 1999 16:39:23 +0100

>         calling an Xlib function from a signal handler.

I hope that I have fixed this. Can you try ?
Olivier

---

From: Tim Phipps <[email-masked]>
Date: Mon, 20 Dec 1999 15:14:01 +0000

> I hope that I have fixed this. Can you try ?

It is fixed now. Thanks.

Cheers,
Tim.