Subject: new motif shadow calculations

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 21 Dec 1999 14:27:45 +0200

Please don't get this message against a new motif-like shading
calculations, but why exactly we should change the old ones?

I think that the old GTK-like consistent calculations (where hilite color
is always brighter and shadow color is always darker) are good enough
(and IMHO better) and could remain a default.

Here is for example, in attachments, how bad look now my menus and
CompactButtons, which were ok in 2.1 to 2.3. Compare them to ones in
Mikhael-desk-1152x864.gif from fvwm-web. Of course I fixed them by
specifying sh & hi in the colorset. The point is that it could be
probably surprizing for users to get such metamorphose. Just an opinion.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Tue, 21 Dec 1999 10:42:18 -0500

> (and IMHO better) and could remain a default.

Since we can now specify exact colors using FvwmTheme, I don't think
2 choices in 3d calculations is warranted.

I don't know that you are implying that,  I'm just suggesting we pick
one or the other.

> probably surprizing for users to get such metamorphose. Just an opinion.

I could suggest waiting a few years.  Subtleties in shading will become
invisible to you.

> Mikhael.

I can live with either scheme.  The voting so far:

GTK  Lesstif
===  =======
  1        0

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 22 Dec 1999 10:01:42 +0100

> I can live with either scheme.  The voting so far:

$GTK++;

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 13:45:08 +0100

> calculations, but why exactly we should change the old ones?

Because they don't work.  E.g. the shadow and hilight colours
of black are black using the GTK code.

> (and IMHO better) and could remain a default.

No, the GTK code only guarantees that the hilight colour is never
darker and the shadow colour never brighter than the source colour.

> probably surprizing for users to get such metamorphose. Just an opinion.

Such changes will never go unnoticed.  When Dan rewrote the colour
code last time there was a lot of wailing too.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 17:02:34 +0100

> I can live with either scheme.  The voting so far:

Keeping the GTK stuff exclusively is no option.  It fails to calculate
different colours e.g. if the original colour is black or white.  You
end up with all three colours black or white.  Perhaps we can tune the
'brightness' calculation in the new code so that colours aren't
considered 'bright' not as easily.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 1 Jan 2000 03:17:17 +0100

> probably surprizing for users to get such metamorphose. Just an opinion.

I've slightly increased the limit before the hilight colour
is darker than the original colour. I think since this only
applies to bright shades of grey or colours with very high
red and green parts this should be okay.  I really don't
want to keep the buggy old code just because people have
gotten used to the bug.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]