Subject: Re: Move lock up

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Dec 1999 23:27:38 +0100

On Mon, Nov 01, 1999 at 07:21:09AM -0500, Brad Giaccio wrote:
> I haven't been able to track this down quite yet but I was wondering if
> any one else as seen it.  If I grab my title bar with the mouse to do
> a move I occasionally will lock up the fvwm.  If I check my debugger
> the stack looks like sigsuspend and then usleep.  I'm assuming this
> is the usleep in move_resize.c but I haven't confirmed it yet.  Has
> anyone else seen this I'm trying to reduce my config to the point where
> I can reproduce it but no luck yet, as this seems to be an intermittent
> problem.

Brad, does this still happen?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 17 Dec 1999 07:50:25 -0500

> Brad, does this still happen?

I beleive the day I sent this message was the last day it
happened. Hopefully it won't turn up again.  So I guess you can forget
it for now.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 17 Dec 1999 15:45:35 -0500

Dominik, if you are farmiliar with expression "knock on wood", that 
is what I should have done when sending my reply today.  I just saw it 
again.  This time it was a mapped java window, but it has happened with xterms and emacs frames as well.  I grabbed the stack trace maybe you can figure something out I'm missing.  And no I'm not running FvwmEvent or Auto.  
And this is current CVS minus your last commit for WindowList, Stlye cleanup, and Titlestyle stuff.

Brad

#0  0xff095c30 in _sigsuspend () from /usr/lib/libc.so.1
#1  0xff0568f8 in _usleep () from /usr/lib/libc.so.1
#2  0xfefdb274 in usleep () from /usr/lib/libthread.so.1
#3  0x35388 in moveLoop (tmp_win=0xeeea0, XOffset=-402, YOffset=-19, 
    Width=569, Height=458, FinalX=0xffbeeb34, FinalY=0xffbeeb30, 
    do_move_opaque=1, AddWindow=0) at move_resize.c:897
#4  0x33ff4 in InteractiveMove (win=0xffffffed, tmp_win=0xeeea0, 
    FinalX=0xffbeeb34, FinalY=0xffbeeb30, eventp=0x75cbc) at move_resize.c:246
#5  0x346d4 in move_window_doit (eventp=0x75cbc, w=8389981, tmp_win=0xeeea0, 
    context=2, action=0xbbd8c "", Module=0xffbeecdc, do_animate=0, 
    do_move_to_page=0) at move_resize.c:472
#6  0x34a34 in move_window (eventp=0x75cbc, w=8389983, tmp_win=0xeeea0, 
    context=2, action=0xbbd8c "", Module=0xffbeecdc) at move_resize.c:552
#7  0x49ab0 in ExecuteFunction (Action=0xbbd88 "Move", tmp_win=0xeeea0, 
    eventp=0x75cbc, context=2, Module=-2, expand_cmd=DONT_EXPAND_COMMAND)
    at functions.c:834
#8  0x4a750 in execute_complex_function (eventp=0x6d, w=8389981, 
    tmp_win=0xeeea0, context=2, action=0xfadf8 "Move-or-Raise", 
    Module=0xffbeeea4, desperate=0xffbeee0c, expand_cmd=DONT_EXPAND_COMMAND)
    at functions.c:1402
#9  0x49aec in ExecuteFunction (Action=0xfadf8 "Move-or-Raise", 
    tmp_win=0xeeea0, eventp=0x75cbc, context=2, Module=-1, 
    expand_cmd=EXPAND_COMMAND) at functions.c:841
#10 0x2f2f0 in HandleButtonPress () at events.c:1544
#11 0x2d33c in DispatchEvent (preserve_Tmp_win=0) at events.c:215
#12 0x2d3bc in HandleEvents () at events.c:253
#13 0x31698 in main (argc=478208, argv=0x76400) at fvwm.c:717

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 01:10:14 +0100

> #2  0xfefdb274 in usleep () from /usr/lib/libthread.so.1
                    ^^^^^^
>     do_move_opaque=1, AddWindow=0) at move_resize.c:897
                                                      ^^^
Funny, there no usleep() call anywhere near line 897.  In fact none
of the code anywhere near this line should trigger usleep().
I've got no idea what's happening.  Perhaps some unfortunate
interaction with a call of DispatchEvent()?  We need a way to
reproduce this.

Bye

Dominik ^_^