Subject: Re: CVS domivogt: * Tried to improve sliding panels.

From: Olivier Chapuis <[email-masked]>
Date: Fri, 03 Dec 1999 20:17:09 +0100

CVS wrote:
> 
> CVSROOT:        /home/cvs/fvwm
> Module name:    fvwm
> Changes by:     domivogt        99/11/25 10:17:22
> 
> Modified files:
>         .              : ChangeLog
>         fvwm           : fvwm.h
>         libs           : WinMagic.c fvwmlib.h
>         modules        : ChangeLog
>         modules/FvwmButtons: FvwmButtons.c
> 
> Log message:
> * Tried to improve sliding panels.

Hello,
I think that there some problems here (may be older than this commit).
One problem is that if the panel has some min width/height hints then
the firsts (or the lasts) setps of the sliding for a left/up panel may be
not has expected. Moreover, we may imagine other problem with width_inc
and height_inc. You may do some test with a multi desk FvwmPager as a Panel.
If you want I can try do somthing.
Olivier 

> * Removed old style bits from fvwm.h (commented out anyway).
> * A bit of clean up.
> 
> --
> Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
> body of a message to [email-masked].
> To report problems, send mail to [email-masked]

-- 
[email-masked]
"you have moved your mouse, please reboot to make this change take effect"

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 4 Dec 1999 10:09:08 +0100

> If you want I can try do somthing.

Feel free to play with it, but I don't think we'll get a nice solution
in FvwmButtons.  There are too many problems that will prevent it from
working properly with generic applications.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]