Subject: Changing style Icon -> NoIcon confuses FvwmAnimate

From: [email-masked] (Tim Phipps)
Date: Fri, 17 Dec 1999 13:09:30 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.12
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.11
FVWM_USERHOME: unset

Description:
	Doing an on the fly style change from "Style * Icon" to
	"Style * NoIcon" without a recapture seem to cause confusion.
	Iconifyinf after the style has changed to NoIcon causes FvwmAnimate
	to draw an animation to where the icon would have been.  The space
	seems to be occupied as no other icons appears there when windows
	are iconified.

Fix:
	It may be that the icon_width and icon_height aren't being reset
	to zero when the style NoIcon is applied.  I think theis is what
	FvwmAnimate uses to decide not to draw an animation.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 17 Dec 1999 16:13:21 +0100

> 	FvwmAnimate uses to decide not to draw an animation.

Bull's eye.  I've fixed it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]