Subject: Notification: incoming/539

From: [email-masked]
Date: Mon, 27 Dec 1999 08:06:09 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/539

Message summary for PR#539
	From: [email-masked]
	Subject: Synthetic MouseClicks
	Date: Mon, 27 Dec 1999 08:06:08 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Ben Winslow <[email-masked]>
Date: Thu, 30 Dec 1999 01:23:58 -0500

On 27 Dec 1999 08:06:09 -0600, [email-masked] wrote:
[snip]
> Would like if it was possible to fake Mouseclicks with keybindings.
> Something like:
> 
> Key Space A 4 Click 1
> 
> to make a button1 click
[snip]

I agree that this would be a nice feature-- it looks like it was even
intended to exist:  The man page calls for a 'MouseClick' function in the
CursorMove documentation, but I can't find any other mention in the
documentation or source.  Additionally, I was playing with some key binding
stuff, and couldn't find a way to have keybindings work in the context of a
modifier being turned *off*  (i.e. this key only works when num-lock is
off).  Perhaps I overlooked the way to do this, so if anyone could tell me
how, I'd appreciate it.  If there isn't currently a way to do this, consider
this my request to add such a feature.

-- 
Ben Winslow           /   [email-masked]
bluecherry internet   /   http://www.bluecherry.net
|Rain| @ IRC          /   anynet: irc.anynet.org

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 30 Dec 1999 07:58:18 +0100

On Thu, Dec 30, 1999 at 01:23:58AM -0500, Ben Winslow wrote:
> documentation or source.

Oops.  I forgot to remove this.  There won't be a MouseClick command.
Although it might work, we would run into great trouble regarding
button grabs, double clicks, holding buttons, etc.  The proper way
to do this is to use XKB as hited at in our FAQ.

> Additionally, I was playing with some key binding

Er, don't specify num-lock in the modifier list?  Or do you want
to bind something to all modifier combinations with num-lock
not pressed?  In this case you'd have to bind the action to every
possible combination of modifiers.  X wants it this way.  You
don't really want to do this because you would have to bind
hundreds of keys for each window.  Even if fvwm did this
automatically this would slow things down *dramatically*.
You can try this with the 'IgnoreModifiers' command. Say e.g.

  IgnoreModifiers 12345

and start fvwm and pour a hot cup of tea :-)

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]