Subject: Bug Testers Wanted! for awols Desktop Themes for fvwm2.3.12

From: Alex Wallis <[email-masked]>
Date: Sun, 19 Dec 1999 15:51:13 +1030

I have written a simple and small desktop themes package for
the latest development versions of fvwm ONLY! You must have 
the CVS or a current snapshot for this package to work.
IT WILL NOT WORK! on versions below 2.3.11!
The forms in this package use features not in the source code
a month or so back.

The basic package without sounds and pixmaps is a 45K tarball
but it unpacks to over 200k.
The package contains a suite of forms and all the config files you
need to start with. In most cases you can still use your old .fvwm2rc
file as all this package does is manipulate colors and sounds and
configs. You must therefore remove all references to such in your
.fvwm2rc  In fact there is provision to load several user.fvwm2rc
files for each theme. Each config configuration can be different for 
each theme. The same for window colors, sounds etc....

A makeshift README follows this message.

Some help with debugging this thing would be appreciated because
I know there are some bugs, I just forget where. I don't get errors mesages
so I hope you don't too. The FvwmBacker form IS broken, partly
because it's source was being changed only last week. So I thought
I'd wait a bit, maybe I'll get back to fixing it soon.
The system wide install section like other parts is still unfinished.
Apart from that, I think it works.

I like and use builtin-rplay as my FvwmEvent command and it works
fine for me. So it defaults to that. If you want a different command for
FvwmEvent, change it via the form. If you dont want FvwmEvent,
switch it off. The Backer module is off by default untill I fix the form.
I'd prefer to remove as many bugs as possible before making this 
public but like any work in progress they always creep in from time to time.
If someone wants to help on this please email me, and I'll send you an
ftp URL to get it. I'm about to upload now. 

awol

[email-masked]

P.S. I don't know how much longer I can work on this, my computer
is NOT Y2K compliant !   :(

####################################################################################################
README for awols Desktop Themes.  fvwm2.3.11-awols-themes.tar.gz by Alex Wallis <[email-masked]>

In this package you should find the following files and directories....

themer@awol:~/.fvwm2 > ls -al                                       All the user modifiable stuff is in
total 12                                                              the ConfigFvwm*/ directories
drwxr-xr-x  11 themer   users        1024 Dec 19 00:31 .
drwxr-xr-x   7 themer   users        1024 Dec 19 00:46 ..
-rw-r--r--   1 themer   users         488 Dec 19 00:45 .fvwm2rc   <---- New system only .fvwm2rc
drwxr-xr-x   2 themer   users        1024 Dec 18 23:56 .fvwm_config   <---- system only dotfile directory
drwxr-xr-x   2 themer   users        1024 Dec 19 00:18 ConfigFvwmEvent   <--- FvwmEvent configs
drwxr-xr-x   2 themer   users        1024 Dec 19 00:42 ConfigFvwmForm    <--- forms for awols themes
drwxr-xr-x   2 themer   users        1024 Dec 19 00:03 ConfigFvwmModules <--- module configs
drwxr-xr-x   2 themer   users        1024 Dec 19 00:04 ConfigFvwmRc      <--- user.fvwm2rc files
drwxr-xr-x   2 themer   users        1024 Dec 19 00:16 ConfigFvwmStyle   <--- files with colors for windows & modules
drwxr-xr-x   2 themer   users        1024 Dec 19 00:14 ConfigFvwmTheme   <--- files with colorsets & theme paths
drwxr-xr-x   2 themer   users        1024 Dec 19 00:06 icons      <---- you can add this to ImagePath
drwxr-xr-x   2 themer   users        1024 Dec 19 00:06 sounds     <---- a place to store sound files

INSTALLATION

I've been using $HOME/.fvwm2/ as my $FVWM_USERHOME so the package untars to that dir i.e. .fvwm2/
To install simply set $FVWM_USERHOME to some directory by editing ~/.profile
and entering the following lines

FVWM_USERHOME=/home/your/file/path/.fvwm2
export FVWM_USERHOME

Once done source the file or logout then back in again.

Then you can start fvwm2 in your usual manner. (e.g. startx or xdm)
If all goes well you should see different colors than the normal default.

If you want a system wide install simply comment the line in .fvwm2rc to read the forms.
Then untar the forms tarball into <prefix>/etc/fvwm/

There's a default rc-file that's essentially the default install file. If you want to use your own 
.fvwm2rc then copy it to ConfigFvwmRc/new.name.fvwm2rc  You must then edit it to remove ALL commands
related to colors, colorsets, AND any/all modules except for window colors that you want to remain
fixed between "themes". Module configs can be specified separately or together as parts of different
themes. If you have rplay support compiled in and you add the sample sounds/ files to rplay.conf
then you will hear sounds upon starting the window manager. Otherwise there might be errors in your
X server logs so switch the Events module off. I like builtin-rplay so I use it. I'm not sure if 
other commands will work as well with this themes package though. I've kept the actual *.wav's
in a separate tarball. 

All the user modifiable stuff is in the directories prefixed ConfigFvwm
All the system non-modifiable stuff is in .fvwm_config/

There's a spare tarball of dotfiles in .fvwm_config/ in case of trouble. If you get errors about
symbolic links, remove the link and copy a Default file to Current
The link should then replace the file once reset without problem.
It's best to save each theme at least once upon starting.

If you are not using the default user.fvwm2rc supplied with awols themes, then to some Menu add

AddToMenu SomeMenu "Desktop Themes" Module FvwmForm FormFvwmTheme. "ThemeFile=.fvwm_config/.ConfigFvwmThemeCurrent"

Then when you select "Desktop Themes" from that menu the form will always display the theme last 
'set to current'. The 'current theme' is always loaded at Starts and Restarts. 
Not always loaded are the Styles, Events, Backgrounds, and/or Modules. Each can be set to current or theme.

Different colors are easily assigned to windows, menus and modules for each theme.
Different colorsets can be created, tested, and saved for future use by each theme.
Different combinations of different configurations of different modules, can be...etc...

Hey! Everything's configurable.  ;)

To swap themes with your friends simply find the related .fvwm_config/.ConfigFvwm*$(ThemeName) files
and tar them up with your favourite sounds, backgrounds module configs etc...

Have fun with it! And let me know what you think.
Oh... And please send me bug reports. I know there's heaps,
I'm gonna fix 'em. I promise!

Alex Wallis
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 19 Dec 1999 11:21:30 -0500

> ftp URL to get it. I'm about to upload now. 

Alex,

  I think you should post the URL to the workers list.

  I downloaded the latest package, set FVWM_USERHOME to point at it,
and restarted fvwm.  Most of the themes stuff I tried seemed to work.
The number of things on the forms is overwhelming, I think its going
to take me a while to find everything.

  On the form that  lets me change  the menu  colorset, I changed  the
color set number and hit save.  I noticed that the menus didn't change
color.  If some of this changes on the spot, and some needs a restart,
I think the forms should show that.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]