Subject: Windows one pixel too far right/down

From: Dominik Vogt <[email-masked]>
Date: Thu, 11 Nov 1999 21:45:14 +0100

I just noticed that all my windows are mapped one pixel
too far down and right.  I.e. if I have a clean page and
open a window it appears at +1+1, not +0+0.  If a window
should be at -0-0, one pixel of the border is off screen.
Any ideas what could have caused this?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 11 Nov 1999 15:30:42 -0500

> should be at -0-0, one pixel of the border is off screen.
               ^^^^

I think you mean +0+0?

> Any ideas what could have caused this?

I never noticed, but I seem to get the same result with 2.2.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Thu, 11 Nov 1999 12:44:11 -0800

Previously from Dan Espen
>> should be at -0-0, one pixel of the border is off screen.

No, I would think it *is* in fact -0-0... We're talking about the
geometry being adjusted +1+1, so a window at -0-0 ends up pushing off
the bottom-right corner by one. Oops. I just noticed it this morning,
but forgot to think about it.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"I'm not paid to care." -ASR
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 11 Nov 1999 15:49:43 -0500

> but forgot to think about it.

Oops, sorry.  Ignore my comment about 2.2.  I misunderstood the issue,
and the testing I did was flawed.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Nov 1999 11:03:44 +0100

> > should be at -0-0, one pixel of the border is off screen.

No, I mean -0-0.

> > Any ideas what could have caused this?

Actually I noticed that this depends on gravity. A window
with NW gravity is shifted down and right while a window
with SE gravity is shifted up and left. Thus, what I said
was incorrect: a -0-0 window is shown at -1-1, not at
'-(-1)-(-1)' as I claimed. Notheless it is a bug.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]