Subject: auto Style updates

From: Brad Giaccio <[email-masked]>
Date: Fri, 19 Nov 1999 10:15:58 -0500

Dominik,
I just noticed this one and thaught I'd let you know that lines like 
Style "app" MiniIcon mini.xhippo.xpm
don't get updated until you do a recapture or recapturewindow.  I hadn't
heard you mention this before so I thought it might have been missed.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 19 Nov 1999 19:16:28 +0200

> heard you mention this before so I thought it might have been missed.

I can't confirm this. For me both Icon and MiniIcon style changes get
updated without recapture.

Not quite related to this. I wish to have time to implement a new command
ReloadIcons for reloading all icons (in case they were changed on disk).

Another thing. Maybe auto-style-update is not always good. What if you
have 1000 style lines in your config file?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Nov 1999 07:35:57 +0100

> ReloadIcons for reloading all icons (in case they were changed on disk).

Wow, if you ever have the time: good luck. Not quite the
easiest task to start with.

> have 1000 style lines in your config file?

The fvwm will wait until the file is completely read before
updating a single window.  I'm more worried about module
input if he module is not fast enough.  I haven't yet tried
this, but I guess the redraw-minimising code still need to
be improved.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Nov 1999 02:25:37 +0100

> heard you mention this before so I thought it might have been missed.

Brad, are you sure your version is up to date?  I definitely adapted
the MiniIcons code to handle updates at run time, and it works
for me with window buttons and all modules.  You mentioned another
problem with 'move' from a menu, and I don't see this problem either.
If this a real problem I need more information (bindings, focus
policy, where is the menu invoked from, globalopts affecting focus
policy, ...).

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 24 Nov 1999 07:17:39 -0500

> policy, where is the menu invoked from, globalopts affecting focus

You caught me my last build missed a c file for some reason so I did a clean build and all is well, so disregard.

Sorry,
Brad