Subject: CVS domivogt: * New style 'TitleAtBottom'.

From: CVS <[email-masked]>
Date: Sun, 14 Nov 1999 16:09:29 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/11/14 16:09:29

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : add_window.c add_window.h borders.c builtins.c 
	                 decorations.c decorations.h fvwm.h fvwm2.1 
	                 move_resize.c session.c style.c style.h 
	                 window_flags.h 

Log message:
* New style 'TitleAtBottom'.
* Windows without title can be shaded too.
* Shaded windows now have a full border.
* Changing decor related styles is much faster.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason Kibblewhite <[email-masked]>
Date: Sun, 14 Nov 1999 20:37:23 -0700

> * Changing decor related styles is much faster.

Dominik

I love you and want to have your children :), that titleatbottom is
fantastic and shades very smooth,  Now I can have Licq shaded at the
bottom of the screen and don't have to move the window around to see it
when I unshade it.  And the shaded windows look much cleaner also.

--
This is my .sig, pretty dull eh

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 15 Nov 1999 13:54:25 +0100

> * New style 'TitleAtBottom'.

Really a very good idea ! 
May be all your works on style, decoration, add window ... allows
to add the new style TitleOnTheLeft ? I think it will be "important"
that fvwm does such a style. Ok, I see a lot of potential problems
and we are not very far from the feature freeze, but such a style
will be so cool that ...

> * Changing decor related styles is much faster.

Yes it is fast now !
You say in previous changelog that "Most styles can be updates 
w/o recapture now (except UseStyle, HandleWidth and BorderWidth)"
However it seems that HandleWidth and BorderWidth works except
for the "resizing windows step". I am ready to modify the TaskBar 
(and eventually WinList) for that the things works well after a 
modification of the HandleWidth and BorderWidth.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Nov 1999 14:03:23 +0100

> Really a very good idea ! 

Not my idea. We got several requests for this feature.

> and we are not very far from the feature freeze, but such a style

Perhaps if I have time.

> for the "resizing windows step".

Yes, but this is the crucial step. The other code for it is
already written because of the other styles. BTW, title/notitle
suffer from the same cause.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Nov 1999 05:00:53 +0100

On Mon, Nov 15, 1999 at 02:04:00AM +0200, Mikhael Goikhman wrote:
> On 14 Nov 1999 16:09:29 -0600, CVS (dominik) wrote:
> > 
> Hey, this is fun. :-)
> The pager should be updated to handle shading + TitleAtBottom.
> Gnome pager is ok, however.
> There is also title blinking on shading + TitleAtBottom.

Hm, I have no problem with the pager. It's a bit confusing
because the shaded window seems to jump down a few pixels
if you have a small pager window, but that's caused by the
minimum window size in the pager.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]