Subject: Fvwm*IconMan* colour set problem

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Nov 1999 12:29:34 +0100

FvwmIconMan has a problem with the colour set implementation:
If it grows down because new windows are added, the colour set
pixmap is not stretched to fit the new box.  Just take a look
at the attached screenshots.  My config:

--------------- snip ---------------
*FvwmIconMan*Action Mouse 3 N sendcommand close
*FvwmIconMan*ButtonGeometry 57x11
*FvwmIconMan*FollowFocus true
*FvwmIconMan*Font FONTXXXS
*FvwmIconMan*Format "%t"
*FvwmIconMan*Resolution page
*FvwmIconMan*Title ""
*FvwmIconMan*UseWinList true
*FvwmIconMan*Action Mouse 2 N sendcommand Focus
*FvwmIconMan*Colorset 6
*FvwmIconMan*FocusColorset 2
*FvwmIconMan*FocusAndSelectColorset 2
*FvwmIconMan*PlainColorset 6
*FvwmIconMan*SelectColorset 6
*FvwmIconMan*TitleColorset 6
*FvwmIconMan*FocusButton up
*FvwmIconMan*PlainButton up
*FvwmIconMan*SelectButton flat
*FvwmIconMan*FocusAndSelectButton flat
*FvwmIconMan*TitleButton flat
--------------- snip ---------------

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 22 Nov 1999 10:20:05 -0500

> at the attached screenshots.  My config:

But if you use a nice circular gradient you get a nice looking repeating
effect.  I'll see if I can look at how to strech it on each window add and 
remove.  I guess I also need to look at multi column managers.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Nov 1999 11:42:45 +0100

> remove.  I guess I also need to look at multi column managers.

The code to do this should be in the ConfigureNotify handling code
already.  I think the 'resize_manager' function would be the right
place.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 24 Nov 1999 08:26:30 -0500

> already.  I think the 'resize_manager' function would be the right

Correct as usaul Dominik, here is the patch if you could apply for me. 

On another note if you and Tim still give your votes for CVS commit, I can
finally do it through my firewall.

Brad
------------------------
diff -u -b -B -r1.27 xmanager.c
--- xmanager.c  1999/11/20 09:48:57     1.27
+++ xmanager.c  1999/11/24 13:24:25
@@ -945,6 +945,7 @@
   ManGeometry *new;
   int oldwidth, oldheight, oldrows, oldcols;
   int dir;
+  int i;
 
   if (man->can_draw == 0)
     return;@@ -973,6 +974,28 @@
       resize_window (man);
     }   }+
+  for (i = 0; i < NUM_CONTEXTS; i++) {
+    if (man->pixmap[i])+      XFreePixmap(theDisplay, man->pixmap[i]);+    if (Colorset[man->colorsets[i]].pixmap) {
+      man->pixmap[i] = CreateBackgroundPixmap(theDisplay, man->theWindow,
+                       man->geometry.width, man->geometry.height,
+                       &Colorset[man->colorsets[i]],
+                       Pdepth, man->backContext[i], False);+      XSetTile(theDisplay, man->backContext[i], man->pixmap[i]);
+      XSetFillStyle(theDisplay, man->backContext[i], FillTiled);
+      if (i == DEFAULT)+      { +    XSetWindowBackgroundPixmap(theDisplay, man->theWindow,
+                   man->pixmap[i]); 
+      } 
+    } else {
+      man->pixmap[i] = None;
+      XSetFillStyle(theDisplay, man->backContext[i], FillSolid);
+    }  
+  }
+
 }

-----------
1999-11-24  Brad Giaccio  <[email-masked]>
    * FvwmIconMan/xmanager.c (resize_manager):
    if using a colorset gradient or pixmap it is now resized when
    then the manager changes sizes

---

From: Tim Phipps <[email-masked]>
Date: Wed, 24 Nov 1999 13:41:02 +0000

> finally do it through my firewall.

I certainly do.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 24 Nov 1999 09:08:47 -0500

> finally do it through my firewall.

One more vote in favor.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]