Subject: IconBox core dump

From: Olivier Chapuis <[email-masked]>
Date: Thu, 25 Nov 1999 01:49:47 +0100

Hello,
I've tried a little IconBox, it seems that the color stuff work
find. However, after a Recapture IconBox core dump quit fast ...

Here the gdb result:

Core was generated by `/usr/local/libexec/fvwm/2.3.10/FvwmIconBox 32 4 none 0 8'.
Program terminated with signal 11, Erreur de segmentation..
find_solib: Can't read pathname for load map: Erreur d'entrée/sortie.
#0  0x40147d2f in ?? () from /lib/libc.so.6
(gdb) where
#0  0x40147d2f in ?? () from /lib/libc.so.6
#1  0x804f611 in itemcmp (item1=0x8061020, item2=0x806d4f0)
    at FvwmIconBox.c:2532
#2  0x804f4b3 in SortItem (item=0x806d4f0) at FvwmIconBox.c:2455
#3  0x804eb0a in process_message (type=8192, body=0x8058004)
    at FvwmIconBox.c:2093
#4  0x804e42c in My_XNextEvent (dpy=0x8058648, event=0xbffff984)
    at FvwmIconBox.c:1955
#5  0x804a30f in Loop () at FvwmIconBox.c:339
#6  0x804a2cb in main (argc=6, argv=0xbffffab4) at FvwmIconBox.c:309

Here the output of the errors handler:

FvwmIconBox: Cause of next X Error.
   Error: 4 (BadPixmap)
   Major opcode of failed request:  128 (Unknown)
   Minor opcode of failed request:  2
   Resource id of failed request:  0x7c0007d
 Leaving a core dump now

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 25 Nov 1999 18:23:00 +0100

> find. However, after a Recapture IconBox core dump quit fast ...

Fixed by Dominik or/and Tim
Olivier