Subject: A bugs fix Patch to TaskBar

From: Olivier Chapuis <[email-masked]>
Date: Mon, 08 Nov 1999 13:50:52 +0100

Hello,
With the DeskOnly config command, when you switch between desk
the mini-icon disapear and the iconified state is forgeted.
The attached patch fixes these.

modules/ChangeLog:

* FvwmTaskBar/FvwmTaskBar.c (redraw_buttons, ProcessMessage):
* FvwmTaskBar/ButtonArray.c (AddButton):
Fix dispariton of mini-icons and iconified state with DeskOnly 
option.

Olivier

Index: modules/FvwmTaskBar/ButtonArray.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmTaskBar/ButtonArray.c,v
retrieving revision 1.14
diff -u -r1.14 ButtonArray.c
--- ButtonArray.c	1999/10/20 15:50:44	1.14
+++ ButtonArray.c	1999/11/08 12:46:55
@@ -358,6 +358,8 @@
   Button *new, *temp;
 
   new = ButtonNew(title, p, state, count);
+  if (iconified)
+    new->iconified = 1;
   if (array->head == NULL)
     array->head = new;
   else
Index:  modules/FvwmTaskBar/FvwmTaskBar.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmTaskBar/FvwmTaskBar.c,v
retrieving revision 1.26
diff -u -r1.26 FvwmTaskBar.c
--- FvwmTaskBar.c	1999/11/03 15:39:52	1.26
+++ FvwmTaskBar.c	1999/11/08 12:47:00
@@ -501,12 +501,13 @@
 #ifdef MINI_ICONS
   case M_MINI_ICON:
     if ((i = FindItem(&windows, body[0])) == -1) break;
+    p.picture = body[6];
+    p.mask    = body[7];
+    p.width   = body[3];
+    p.height  = body[4];
+    p.depth   = body[5];
+    UpdateItemPicture(&windows, i, &p);
     if (UpdateButton(&buttons, i, NULL, DONT_CARE) != -1) {
-      p.picture = body[6];
-      p.mask    = body[7];
-      p.width   = body[3];
-      p.height  = body[4];
-      p.depth   = body[5];
       UpdateButtonPicture(&buttons, i, &p);
       redraw = 0;
     }
@@ -633,7 +634,7 @@
     if (DeskNumber == item->Desk || IS_STICKY(item))
     {
       AddButton(&buttons, item->name, &(item->p), BUTTON_UP, item->count,
-		!!(item->tb_flags & F_ICONIFIED));
+		(item->tb_flags & F_ICONIFIED) ? 1 : 0);
 #ifdef DEBUG_DESKONLY
       /* print buttons.count, buttons.tw here */
       fprintf(stderr,"buttons.count = %i \t ",buttons.count);

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Nov 1999 14:02:40 +0100

> The attached patch fixes these.

Heck, do you still have no CVS write access?  I think I already
agreed that Jason gives you commit privileges (though that mail
may have got lost over the end of the daylight saving time a
few days ago).

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 08 Nov 1999 08:28:48 -0500

> may have got lost over the end of the daylight saving time a

The last mail on this subject was from Olivier.  He  felt that 2 votes
were not enough.

We don't have  any strict rules for this,   but I think 2  votes would
normally be enough.

Since no  one else has pointed it  out, Olivier seems  to have all the
necessary skills, and commitment, except that his  English is a little
rough.

I'll  throw in a third  vote, but  I'd ask  that  when Olivier commits
documentation  updates,  he  identify the   sections  of  the document
changed so that one of us can do a little proof reading.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 08 Nov 1999 18:10:04 +0100

> may have got lost over the end of the daylight saving time a
 
Hello, It seems that I do not get the message :o(
So, I continue to send patch :o)
Olivier

-- 
[email-masked]
"you have moved your mouse, please reboot to make this change take effect"

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 08 Nov 1999 18:14:09 +0100

> necessary skills, and commitment, except that his  English is a little

What is "rough" ? :o)

> changed so that one of us can do a little proof reading.

Ok. I will try to also make some progress in english ...
Olivier