Subject: CVS domivogt: * Optimized and restructured border/title/button drawing code. Please keep your

From: CVS <[email-masked]>
Date: Mon, 15 Nov 1999 19:35:45 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/11/15 19:35:45

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c borders.c borders.h builtins.c 
	                 colors.c events.c focus.c functions.c fvwm.c 
	                 icons.c menus.c menus.h move_resize.c screen.h 
	                 style.c 

Log message:
* Optimized and restructured border/title/button drawing code. Please keep your
eyes open for new problems.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 16 Nov 1999 08:24:12 +0100

> eyes open for new problems.

Hello,
I've got a core dump if I popup a menu by clicking on the frame
(in fact when I leave the menu).
the patch below solves this but I do not apply it because I do not
think it is the good solution.
Olivier.

--- events.c    Tue Nov 16 08:21:13 1999
+++ events.c.my Tue Nov 16 08:20:16 1999
@@ -1433,11 +1433,14 @@
       DrawDecorations(
         ButtonWindow, DRAW_BUTTONS, (Scr.Hilite == ButtonWindow), True,
         OldPressedW);
+    else if (LocalContext == C_FRAME)
+      DrawDecorations(
+        ButtonWindow, DRAW_FRAME, (Scr.Hilite == ButtonWindow),True,
+       OldPressedW);
     else
       DrawDecorations(
-        ButtonWindow, DRAW_FRAME, (Scr.Hilite == ButtonWindow),
-        (HAS_DEPRESSABLE_BORDER(Tmp_win) && HAS_BORDER(Tmp_win)),
-        (Tmp_win) ? Tmp_win->decor_w : 0);
+        ButtonWindow, DRAW_FRAME, (Scr.Hilite == ButtonWindow),False,
+       None);
   }
   ButtonWindow = NULL;
 }
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Nov 1999 13:25:41 +0100

> +++ events.c.my Tue Nov 16 08:20:16 1999
                                   ^^^^^^^                ^^^^^^^
Duh, of course I must use ButtonWindow here too.

> +        ButtonWindow, DRAW_FRAME, (Scr.Hilite == ButtonWindow),False,

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Nov 1999 13:28:02 +0100

> think it is the good solution.

I have made my own version of the fix. Can you try it, please?

Bye

Dominik ^_^