Subject: transparent rxvt problem (PR-472)

From: Nadim Saeed <[email-masked]>
Date: Tue, 2 Nov 1999 14:59:47 -0800 (PST)

I'm still experiancing PR-472 under fvwm-snap-19991013 (post-2.3.9) with
rxvt-2.6.1 (in the 'Notes' section of the Bug-Tracker its noted as "Already
fixed in 2.3.x").

  $ rxvt -inheritPixmap -rv &

I'm using exceed-6.1.0  --  I've included my .fvwm2rc file below.

Can anyone reproduce the problem ??

Thanks....

 - Nadim (please cc replies)

##########################################################################
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
# Created Dec 1996
#
#  - Nadim Saeed
#

##########################################################################
# PATH Setup 
#
# Colon seperated unix directory paths for Modules, xpm files, and bitmaps
#
#PixmapPath	/mft/home/nadim/.Fvwm/pixmaps:/usr/local/include/X11/pixmaps

ModulePath	/usr13/new/fvwm-2.2.2/modules/ALLmodules
PixmapPath	/usr19/people/nadim/.Fvwm/pixmaps:/usr13/new/fvwm-2.2.2/icons
IconPath        /usr/openwin/share/include/X11/bitmaps

#ModulePath	/usr13/new/FVWM/libexec/fvwm/2.3.10
#ImagePath	/usr19/people/nadim/.Fvwm/pixmaps:/usr13/new/fvwm-2.2.2/icons

############################################################################
# COLORS and FONTS
#
# Set the fore and back border colors for the window that has focus
HilightColor            White Red

# Set colors/font for pop-up menus
# Syntax: MenuStyle forecolor backcolor shadecolor font style(fvwm/mwm)
MenuStyle Black Moccasin Blue *-helvetica-bold-r-normal--18-* fvwm
#MenuStyle Black Moccasin grey40 *-helvetica-bold-r-normal--18-* fvwm
#MenuStyle black grey slategrey 7x13bold fvwm
 
# Set fonts to use on title bar and icon label
#WindowFont	-adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
WindowFont	*-helvetica-bold-r-normal--18-*
#IconFont	9x15
IconFont	-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
 
#Martin's hacks
#real poncy texture stuff
#TitleStyle	ActiveUp HGradient 28 red orange
#TitleStyle	Inactive HGradient 128 orange red
##TitleStyle     ActiveTexture /mft/home/nadim/News/marbles/red5mrb.xpm
##TitleStyle     InactiveTexture /mft/home/nadim/News/_marbles/cyan5mra.xpm
#TitleStyle     ActiveUp (TiledPixmap /mft/home/nadim/News/marbles/red5mra.xpm)
#TitleStyle     ActiveDown (TiledPixmap /mft/home/nadim/News/marbles/pur5mrb.xpm)
#TitleStyle     Inactive (TiledPixmap /mft/home/nadim/News/marbles/grey5mrb.xpm)

############################################################################
# ICON Setup
#
# Auto Place Icons is a nice feature (Left Top Right Bottom)
#Style "*" IconBox -215 200 -1 -100 
Style "*" IconBox 5 -80 -140 -5
 
# If you don't want icons for some or all windows (or all of them!)
# Style "*" NoIcon
 
# If you want ALL icons to follow you around the desktop (Sticky)
#Style "*" StickyIcon

############################################################################
# FOCUS Setup
#
# Does the window with focus control the colormap, or the one under the mouse
# ColormapFocus FollowsFocus
# ColormapFocus FollowsMouse
 
# Uncomment this to force you to click in a window to give it focus
#Style "*" ClickToFocus
 
# default: focus follows mouse
Style "*" MouseFocus
 
# If you knock your mouse out of xterm, it keeps focus while in root window
#Style "*term"           SloppyFocus

############################################################################
# MISC Setup
#
# click/release must occur in <n milliseconds to be a "click"
ClickTime 200
 
# if the window occupies less than n% of the screen, draw it opaque
OpaqueMoveSize 5
 
# flip by whole pages on the edge of the screen, but delay for a half second
EdgeScroll 100 100
EdgeResistance 500 100
 
# MWM Emulation: Don't ignore hints for functions and transient decoration
Style "*" MWMFunctions, MWMDecor
 
# Changes the look of the "rubberband" you see when moving windows (0 - 255)
XORvalue 255

###########################################################################
# PAGER Setup
#
# set the desk top size in units of physical screen size (width x height)

DeskTopSize 3 3

############################################################################
# WINDOW Placement
#

# SmartPlacement makes new windows pop-up in blank regions of screen 
#Style "*" SmartPlacement
 
# If SmartPlacement fails, this places it randomly instead of making you do it
#Style "*" RandomPlacement

# I will place my windows, thank you
Style "*" DumbPlacement, ActivePlacement

############################################################################
# STYLE Flag Setup (decorations and window options) 
# --> Order is important !!! <-- 
# If compatible styles are set, styles are ORed together. 
# If conflicting styles are set, the last one specified is used.
 
# Set fore/back border colors for all other windows 
# Style "*" HandleWidth x, Borderwidth y
Style "*" Color White/DimGray, WindowListSkip, NoHandles, DecorateTransient, BorderWidth 3

Style "Fvwm*"		Color Blue/Green, NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0
Style "FvwmTalk"	Title
Style "FvwmConsole"	Title
Style "FvwmPager"	StaysOnTop
Style "FvwmBanner"	StaysOnTop
Style "xbiff++"		Color Blue/Green, NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbiff"		Color Blue/Green, NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmButtons"	NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0
Style "FvwmWinList"	Color Black/Yellow
Style "*clock"		Color Blue/Green, NoTitle, NoHandles, Sticky, WindowListSkip
Style "xterm"		Color white/gray64, NoIcon, WindowListHit
Style "rxvt"		Color white/gray64, NoIcon, WindowListHit
#Style "xterm"		MiniIcon mini-xterm.xpm
Style "Datebook"	StartsOnDesk 0, Icon datebook.xpm, WindowListSkip
Style "emacs"		NoIcon, WindowListHit
#Style "xcalc"		Icon xcalc.xpm
Style "xman"		Icon xman.xpm
Style "xmh"		Icon mail1.xpm, StartsOnDesk 2
Style "rxvt"		Icon term.xpm
Style "xvgr"		Icon graphs.xpm
Style "matlab"		Icon math4.xpm
Style "xmag"		Icon mag_glass.xpm
Style "xgraph"		Icon graphs.xpm
Style "FvwmButtons"	Icon toolbox.xpm
Style "xmeter"		Title, NoHandles, WindowListSkip
Style "Debug*"		Icon question.xpm, WindowListSkip
#Style "*scape*"		Icon netscape-sm.xpm, WindowListSkip
Style "*/*"		Icon word_processor.xpm, WindowListSkip

######################################################################
## Section 5: Functions. 
######################################################################
##  "I" - Immediate, and is executed as soon as the function is invoked.
##  "M" - Motion, i.e. if the user starts moving the mouse.
##  "C" - Click,  i.e. if the user presses and releases the mouse in a 
##        short period of time (ClickTime milliseconds).
##  "D" - Double-click.  The action "I" will cause an action to be 
##        performed on the button-press, if the function is invoked with
##        prior knowledge of which window to act on.

#############################################################################
# START-UP Functions
#

AddToFunc "InitFunction"	
+	"I" Module	FvwmBanner
#+	"I" Exec	exec xsetroot -def
+	"I" Module	FvwmPager 0 0
+	"I" Module	FvwmButtons
+	"I" Module	FvwmWinList
+	"I" Module 	FvwmAuto 300
#+	"I" Exec	exec datebook -geometry 181x190+260+55
#+	"dclk" Exec    "dclk"	dclock -rv -geometry 150x75-55+0 &
+	"I" Desk	0 0

AddToFunc "RestartFunction"
+	"I" Module	FvwmButtons
+	"I" Module	FvwmPager 0 0
+	"I" Module	FvwmWinList
+	"I" Module 	FvwmAuto 400
#+	"I" Next	[!iconic CurrentScreen xterm] Focus
#+	"I" CursorMove 30 40

# Uncomment this to make windows auto-raise after [x] milliseconds 
# AddToFunc "InitFunction" "I" Module FvwmAuto 0

############################################################################
# BUTTON Setup
#
# Odd-numbered buttons are on the left, Evens are on the Right
# The Size is the geometery within the button
#
 
## Buttons actually being used (duplicated below)
# Standard X
ButtonStyle 1 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# Nested Right Angles (looks nice)
ButtonStyle 2 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1

## Triangles
#
# Small up Triangle
#ButtonStyle * 4 50x35@1 65x65@0 35x65@0 50x35@1
# Small down Triangle
#ButtonStyle * 4 50x65@1 35x35@1 65x35@1 50x65@0
# Large up Triangle
#ButtonStyle 6 4 50x25@1 75x75@0 25x75@0 50x25@1
# Large down Triangle
#ButtonStyle 8 4 50x75@1 25x25@1 75x25@1 50x75@0
 
## Boxes
#
# Big Box 
#ButtonStyle 0 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# Little Box
#ButtonStyle 9 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# Tall Box
#ButtonStyle 7 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# Dot
#ButtonStyle 5 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# Big Box with arrow to little box (iconify)
#ButtonStyle 4 14 20x20@1 20x70@1 70x70@0 70x20@0 20x20@1 60x60@0 60x50@0 60x60@0 50x60@0 60x60@0 60x80@0 80x80@0 80x60@0 60x60@0

## X's
#
# Standard X
#ButtonStyle 3 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# Funky X 
#ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
# Stylized X
#ButtonStyle 3 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
 
## Lightning Bolts
#
# Small Lightning Bolt (skinny at both ends)
#ButtonStyle 5 7 70x15@0 30x55@1 50x55@0 40x85@1 80x45@0 60x45@1 70x15@0
# Big Lighting Bolt (Fat at top, comes to a point)
#ButtonStyle 6 8 35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 75x15@0 35x15@1
 
## Miscellaneous Buttons
#
# Nested Right Angles (looks kinda crappy)
#ButtonStyle 5 13 10x0@1 80x0@1 80x10@1 80x80@0 0x80@0 0x60@1 10x65@1 70x65@0 70x0@0 55x0@1 55x10@1 55x55@0 10x55@0
# Nested Right Angles (looks nice)
#ButtonStyle 6 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
# 4 Horizontal bars (sticky)
#ButtonStyle 7 12 10x23@0 90x23@0 90x28@0 10x28@1 10x47@1 90x47@0 90x52@0 10x52@1 10x70@2 90x70@0 90x76@0 10x76@1
# Expanding Windows (iconify -- looks NICE)
#ButtonStyle 8 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1
 
## Arrows Galore
#
# Up Arrow
#ButtonStyle 3 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# Down Arrow
#ButtonStyle 3 8 40x20@1 40x50@1 20x50@1 50x80@1 80x50@0 60x50@0 60x20@0 40x20@1
# Left arrow  ( <- )
#ButtonStyle 7 8 80x40@1 50x40@1 50x20@1 20x50@1 50x80@0 50x60@0 80x60@0 80x40@0
# Right arrow ( -> )
#ButtonStyle 8 8 20x40@1 50x40@1 50x20@1 80x50@1 50x80@0 50x60@0 20x60@0 20x40@1
# Horizontal Line with arrowheads on left and right ( <-> )
#ButtonStyle * 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1
# Vertical Line with arrowheads on top and bottom
#ButtonStyle * 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1
# Diagonal Line with arrowheads on top and bottom ( / )
#ButtonStyle 5 11 80x15@1 45x15@1 55x25@1 25x55@1 15x45@1 15x80@1 50x80@0 40x70@0 70x40@0 80x50@0 80x15@0
# Diagonal Line with arrowheads on top and bottom ( \ )
#ButtonStyle 6 12 55x15@0 45x25@0 75x55@0 85x45@0 85x80@0 50x80@0 60x70@1 30x40@1 20x50@1 20x15@1 55x15@1 55x15@0
#
# the number "2"
#ButtonStyle 8 12 80x80@0 22x80@0 80x40@0 70x25@0 30x25@0 20x35@0 20x30@1 30x20@1 70x20@1 80x30@1 20x75@1 80x75@1

# From users (posts)
# 3 stacked square panels like stills of a window being minimized
#ButtonStyle 4 17 80x20@0 80x60@0 60x60@0 60x40@0 60x70@0 40x70@0 40x60@0 40x85@0 15x85@0 15x60@1 40x60@1 30x60@1 30x40@1 60x40@1 45x40@1 45x20@1 80x20@1

# 3 stacked rectangular panels like stills of a window being minimized
# could also represent windows being tiled
#ButtonStyle 4 17 95x20@0 95x60@0 75x60@0 75x40@0 75x70@0 55x70@0 55x60@0 55x85@0 15x85@0 15x60@1 55x60@1 30x60@1 30x40@1 75x40@1 45x40@1 45x20@1 95x20@1

# 2 stacked rectangular panels like stills of a window being maximized
#ButtonStyle 2 11 95x10@0 95x75@0 25x75@0 65x75@0 65x90@0 10x90@0 10x55@1 25x55@1 25x75@1 25x10@1 95x10@1

##############################################################################
# MENU Setup
#
 
# This menu is invoked as a sub-menu - it allows you to quit,
# restart, or switch to another WM.
AddToMenu Quit-Verify
+	"No, Don't Quit	"		Nop
+	""				Nop
+	"Yes, Really Quit	"	Quit

AddToMenu Quit-Verify-Long
+	"Really Quit Fvwm?	"	Title
+	"Yes, Really Quit	"	Quit
+	"Restart Fvwm2	" 		Restart fvwm2
+	"Restart Fvwm	" 		Restart fvwm
+	"Start twm	" 		Restart twm
+	"Start mwm	" 		Restart mwm
+	"Start olwm	" 		Restart /usr/openwin/bin/olwm
+	""				Nop     
+	"No, Don't Quit	"		Nop     

AddToMenu Sounds-Popup
+	"Sounds"	Title   
+	"Control-Tool"	Exec    exec audiotool &
+	"----------"	Nop     
+	"Back-off"	Exec    exec xplay /mft/home/nadim/personal/sound/bb_backoff.au 2> /dev/null &
+	"PeekAboo"	Exec    exec xplay /mft/home/nadim/personal/sound/bb_peekaboo.wav 2> /dev/null &
+	"Suck"		Exec    exec send_sound /u/sander/audio/beavis/sucksucksuck.wav &
+	"Threaten"	Exec    exec send_sound /u/sander/audio/beavis/threaten.wav &
+	"My Liver"	Exec    exec send_sound /u/sander/audio/beavis/myliver.wav &
+	"Burn"		Exec    exec send_sound /u/sander/audio/beavis/burnburn.wav &
+	"Chicken"	Exec    exec send_sound /u/sander/audio/beavis/chicken.au &
+	"Cronholio"	Exec    exec send_sound /u/sander/audio/beavis/crnhlio.wav &
+	"Fire"		Exec    exec send_sound /u/sander/audio/beavis/fire.wav &
+	"Go Away"	Exec    exec send_sound /u/sander/audio/beavis/goaway.wav &
+	"Hung"		Exec    exec send_sound /u/sander/audio/beavis/hunglike.wav &
+	"This Sucks"	Exec    exec send_sound /u/sander/audio/beavis/thissux.au &
+	"Score"		Exec    exec send_sound /u/sander/audio/beavis/youscore.wav &

AddToMenu module-Pager
+	"Pager ->  0"   Module  FvwmPager 0  0
+	"Pager -> +2"   Module  FvwmPager 0  2
+	"Pager -> -2"   Module  FvwmPager 0 -2

# Provides a list of modules to fire off
AddToMenu ModulesMenu
+	"Fvwm Modules"	Title   
+	"Banner"	Module  FvwmBanner
+	"AutoRaise"	Module  FvwmAuto 350
+	"Buttons"	Module  FvwmButtons
+	"Pager(s)"	Popup   module-Pager
+	"WinList"	Module  FvwmWinList
+ 	"IconMan"	Module 	FvwmIconMan
+	"Identify"	Module  FvwmIdent
+	"Audio"		Module	FvwmAudio
+	"Console"	Module	FvwmConsole
+	"Animate"	Module	FvwmAnimate
+	""		Nop
+	"Talk"		Module	FvwmTalk
+	"Backgrounds"	Module  FvwmBacker
+	"Cascade"	Module	FvwmCascade -incx 2
+	"Tile"		Module	FvwmTile
+	"IconBox"	Module	FvwmIconBox
+	"Scroll.bar"	Module  FvwmScroll
+	"Save"		Module  FvwmSave
+	"Save.Desktop"	Module  FvwmSaveDesk
+	"NoClutter"	Module  FvwmClean
+	"Debug"		Module  FvwmDebug

AddToMenu SUN-nodes
+	"Remote Logins"	Title 
+	"Otho"		Exec	exec xterm -n Otho	-title Otho	-display $DISPLAY -e rsh otho &
+	"Bones"		Exec    exec xterm -n Bones	-title Bones	-display $DISPLAY -e rsh bones &
+	"Colossus"	Exec    exec xterm -n Colossus	-title Colossus	-display $DISPLAY -e rsh colossus &
+	"Ahi"		Exec    exec xterm -n Ahi	-title Ahi	-display $DISPLAY -e rsh ahi &
+	"Loki"		Exec    exec xterm -n Loki	-title Loki	-display $DISPLAY -e rsh loki &
+	"Trilane"	Exec    exec xterm -n Trilane	-title Trilane	-display $DISPLAY -e rsh trilane &
+	"Magnus"	Exec    exec xterm -n Magnus	-title Magnus	-display $DISPLAY -e rsh magnus &
+	"Krusty"        Exec    exec xterm -n Krusty	-title Krusty	-display $DISPLAY -e rsh krusty &
+	"Metaflow"      Exec    exec xterm -n Metaflow	-title Metaflow	-display $DISPLAY -e rsh metaflow &
+	"Ahi2"		Exec    exec rsh -n ahi		xterm -n Ahi		-title Ahi	-display $DISPLAY &

AddToMenu ULTRA-nodes
+	"Vincent"	Exec  exec xterm	-n Vincent	-title Vincent 	-e rsh -8 vincent &
+	"Julius"	Exec  exec xterm	-n Julius 	-title Julius	-e rsh -8 julius &
+	"Herman"	Exec  exec xterm	-n Herman	-title Herman	-e rsh -8 herman &
+	"Eddie"		Exec  exec xterm	-n Eddie	-title Eddie	-e rsh -8 eddie &
+	"----------"	Nop
+	"Jake"		Exec  exec xterm	-n Jake		-title Jake	-e rsh -8 jake &
+	"Cosmo"		Exec  exec xterm	-n Cosmo 	-title Cosmo	-e rsh -8 cosmo &
+	"Dilbert"	Exec  exec xterm	-n Dilbert	-title Dilbert	-e rlogin -8 dilbert &
+	"Galba"		Exec  exec xterm	-n Galba	-title Galba    -e rsh -8 galba &
+	"Gallus"	Exec  exec xterm	-n Gallus	-title Gallus	-e rlogin -8 gallus &
+	"Zoe"		Exec  exec xterm	-n Zoe		-title Zoe	-e rlogin -8 zoe &

# This defines the most common window operations
AddToMenu WindowOps-Popup
+	"WindowOps"		Title      
+	"Previous Focus"        Prev [*] Focus
+	"Next Focus"            Next [*] Focus
+	"&Move"			Move       
+	"Resize"		Resize     
+	"Raise"			Raise      
+	"Lower"			Lower      
+	"Iconify"		Iconify    
+	"(Un)Stick"		Stick      
+	"(Un)Vertical"		Maximize 0 100
+	"(Un)Horizontal"	Maximize 100 0
+	"(Un)Ma&ximize"		Maximize   
+	"Window-list"   	WindowList 
+	"Identify"		Module FvwmIdent
+	"Refresh"		Refresh    
+	"Dump"			Exec exec xdpr -device ps &
+	"----------"		Nop        
+	"&Kill"			Destroy    
+	"----------"		Nop        

AddToMenu fvwmExtraMenu
+	"Fvwm Extras"	Title
+	"Fvwm Modules"	Popup ModulesMenu
+	"Forms"		Popup FormMenu
+	"Scrolling"	Popup ScrollMenu

AddToMenu ScrollMenu
+	"Mouse-Scroll Action"	Title
+	"ON"    		EdgeScroll 100 100
+	"OFF"   		EdgeScroll 0 0
+	"Vertical Only"         EdgeScroll 0 100
+	"Horizontal Only"       EdgeScroll 100 0
+	"Partial"               EdgeScroll 50 50

#AddToMenu MiniScrollMenu
#+	"ON"    		EdgeResistance 500 100
#+	"OFF"   		EdgeResistance 10000 10000

AddToMenu MiniScrollMenu
+	"ON"    		EdgeScroll 100 100
+	"OFF"   		EdgeScroll 0 0

# These are the forms available
AddToMenu FormMenu
+	"Form Modules"	Title
+	"rlogin"	Module	FvwmForm Rlogin
+	"Mytalk"	Module	FvwmForm MyFvwmTalk
+	"Quit ?"	Module	FvwmForm QuitVerify

# This menu will fire up some very common utilities
AddToMenu RootMenu
+	"Root Menu"			Title   
+	"WindowOps%arrows2.xpm%"	Popup   WindowOps-Popup
+	"Utilities"			Popup	Utilities
+	"Sounds"			Popup   Sounds-Popup
+	"----------"			Nop     
+	"Fvwm%fvwm.xpm%"		Popup   fvwmExtraMenu
+	"----------"			Nop     
+	"Restart"			Restart fvwm2
#+	"Exit"				Quit    
+	"Exit%exit.xpm%"		Popup   Quit-Verify-Long

# This menu will fire up some often used programs
AddToMenu Utilities
+	"Utilities"	Title
+	"Calc"		Exec    xcalc -rpn -bg white -fg black -display $DISPLAY &
+	"Calculator"	Exec    exec xcalc &
+	"XLock"         Exec    exec xlockmore -mode swarm -nice 20 -remote -allowaccess -delay 1000 &
+	"Elm"		Exec    xterm -n Elm -wf -display $DISPLAY -e elm &
+	"Netscape"	Exec    exec netscape &
+	"WorkMan"	Exec    exec workman -fg blue &
+	"Font.Sel"	Exec    exec xfontsel &
+	"Set-Keys"	Exec    exec xkeycaps &

# This defines the most common window operations
AddToMenu Window-Ops
+	"Window Ops"		 Title
+	"(Un)&Iconify	Alt+F9"	 Iconify 
+	"&Move	Alt+F7"		 Move    
+	"&Size	Alt+F8" 	 Resize  
+	"Raise"			 Raise   
+	"&Lower	Alt+F3"		 Lower   
+	"(Un)Ma&ximize	Alt+F10" Maximize
+	"Screen Full/Normal"	 Maximize
+	"Length Full/Normal"	 Maximize 0 100
+	"Refresh"		 RefreshWindow
+	""			 Nop     
+	"&Close	Alt+F4"		 Close   
+	""			 Nop     

AddToMenu Logins
+	"Logins"	Title   
+	"80x30"		Exec    exec xterm -geometry 80x30       -n `hostname` -title `hostname` &
+	"100x20"	Exec    exec xterm -geometry 100x20      -n `hostname` -title `hostname` &
+	"fullscreen"    Exec    exec xterm -geometry 125x62+1+-6 -n `hostname` -title `hostname` &
+	"console"       Exec    exec xterm -geometry 80x10 -C    -n console &
+	"----------"	Nop     
+	"Eddie"		Exec    exec xterm -n Eddie	-title Eddie	-display $DISPLAY -e rsh -8 eddie &
+	"Julius" 	Exec    exec xterm -n Julius	-title Julius	-display $DISPLAY -e rsh -8 julius &
+	"Vincent" 	Exec    exec xterm -n Vincent	-title Vincent	-display $DISPLAY -e rsh -8 vincent &
+	"Cosmo"		Exec	exec xterm -n Cosmo	-title Cosmo	-display $DISPLAY -e rsh -8 cosmo &
#+	"Bones"		Exec    rsh -n bones	xterm -n Bones	-title Bones	-display $DISPLAY &
+	"----------"	Nop     
+	"ULTRA-nodes"	Popup   ULTRA-nodes
+	"SUN-nodes"	Popup   SUN-nodes

############################################################################
# COMPLEX FUNCTIONS
#

# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc Move-or-Iconify
+	"M"	Move
+	"C"	Popup Window-Ops
+	"D"	Iconify

AddToFunc window-sizer
+	"M" 	PopUp Window-Ops
+	"C" 	Maximize 0 100
+	"D"	Maximize

AddToFunc shift-window-sizer
+	"C"	Maximize 100 0

AddToFunc control-window-sizer
+	"C"	Maximize 50 100
+	"D"	Maximize 50 100, Move 50 0
+	"D"	Move 50 0

AddToFunc meta-window-sizer
+	"C"	Maximize 100 50
+	"D"	Maximize 100 50
+	"D"	Move 0 50

AddToFunc Move-or-Raise
+	"M"	Move
+	"M"	Raise
+	"C"	Raise
+	"D"	Iconify

AddToFunc Move-or-Lower
+	"M"	Move
+	"C"	Raise
+	"D"	RaiseLower

AddToFunc Ops-or-Lower
+	"M"	PopUp Window-Ops
+	"C"	RaiseLower
+	"D"	WindowShade

AddToFunc Resize-or-Raise
+	"M"	Resize
+	"M"	Raise
+	"C"	Raise
+	"D"	RaiseLower

AddToFunc Resize-or-Lower
+	"M"	Resize
+	"C"	Lower
+	"D"	RaiseLower

AddToFunc FocusWindow
+	"I" Focus
+	"I" WarpToWindow 50 50

AddToFunc ToggleWindow
+	"I" FlipFocus
+	"I" Prev [!iconic] FocusWindow
#+	"I" None [!iconic] FocusWindow

AddToFunc ToggleNetscape
+	"I" None [Netscape*] Exec exec netscape.sol
+	"I" Next [Netscape]  Iconify

###
## TEST code below
AddToFunc my_cursorwarp
+	"I" WarpToWindow 50p 50p

AddToFunc my_warp
+	"I" Resize $1 $2
+	"I" Move $3 $4
+	"I" my_cursorwarp

AddToFunc my_topleft
+	"I" my_warp 616p 400p 0p 0p

AddToFunc goto_it
+	"I" iconify off
+	"I" raise
+	"I" focus
+	"I" warptowindow 50 50

######################  Key and mouse bindings ##########################
# FORMAT:
#  MOUSE/KEYBIND Setup
#
# Key   keyname context modifiers function
# Mouse button  context modifiers function
#       ------- ------- --------- --------
#          |       |        |
#          |       |        |- A = Any
#          |       |        |- C = Control
#          |       |        |- M = Meta (Esc or Alt)
#          |       |        |- S = Shift
#          |       |        |- N = No modifiers
#          |       |        |- 3 = super
#          |       |        |- 4 = hyper
#          |       |
#          |       |- 0-9 = Title bar buttons [1 3 5 7 9    0 8 6 4 2]
#          |       |- A   = Any place except buttons/title.bar
#          |       |- F   = Window frame corners
#          |       |- I   = Icon
#          |       |- R   = Root window
#          |       |- S   = Window sides, top, bottom
#          |       |- T   = Title bar
#          |       |- W   = Application window
#          |
#          |- 0  = Mouse: any    button
#          |- 1  = Mouse: left   button
#          |- 2  = Mouse: center button
#          |- 3  = Mouse: right  button
#
# MouseButton
# \		  Context
#  \		 /        
#   \		|         
#    |		|      Modifiers
#    |		|      \  

#     Button	Context Modifi 	Function
Mouse 1		R   	A       PopUp "RootMenu"
Mouse 2		R    	A      	PopUp "Logins"
Mouse 3		R    	A      	PopUp "Logins"
#Mouse 3	R    	A      	PopUp "Main Menu"

# Now, the Title-Bar buttons
# The numbering (context) is odd on the Left and Even on the Right
# Note the use of "Mouse 0" for AnyButton.

#     Button	Context Modifi 	Function
Mouse 0		1    	A      	Iconify
Mouse 0		2    	A     	Resize

# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-raise,
# and Resize-or-Raise. 
# Button 1 in the corner pieces, with any modifiers, gives resize or raise
Mouse 1		FS	A       Resize-or-Raise
Mouse 2		FS	A       Resize-or-Lower
Mouse 1		T	A       Ops-or-Lower
Mouse 2		TI	A       Move
Mouse 1		I 	A	Move-or-Iconify
Mouse 3		I	A	Move-or-Iconify

Mouse 3		FST    	N      	window-sizer
Mouse 3		FST	S      	shift-window-sizer
Mouse 3		FST	C      	control-window-sizer
Mouse 3		FST	M      	meta-window-sizer

############################################################################
# KEYBOARD Setup

# Arrow Keys
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 +0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left	A	M	Scroll -10  +0
Key Right	A	M	Scroll +10  +0
Key Up		A	M	Scroll +0   -10
Key Down	A	M	Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10
# kEYboard accelerators
#Key F1		A	A	Lower
#Key F1		A	M	RaiseLower
Key F1		A       C       ToggleWindow
Key F1		A	M	Prev [!iconic] Focus
Key F2		A	M	WindowList
Key F3		A	M	Popup Window-Ops
Key F4		A	M	Destroy
Key F5		A	M	CirculateUp
Key F6		A	M	CirculateDown
Key F7		A	M	Move
Key F8		A	M	Resize
Key F9		A	M	Iconify
Key F10		A	M	Maximize

#Key XK_KP_1	A	C	GotoPage 0 2
Key KP_Decimal	A	C	Prev [ CurrentPage !iconic] FlipFocus
Key KP_0	A	C	Prev [!CurrentPage !iconic] FlipFocus
Key KP_1	A       C       GotoPage 0 2
Key KP_2	A       C       GotoPage 1 2
Key KP_3	A       C       GotoPage 2 2
Key KP_4	A       C       GotoPage 0 1
Key KP_5	A       C       GotoPage 1 1
Key KP_6	A       C       GotoPage 2 1
Key KP_7	A       C       GotoPage 0 0
Key KP_8	A       C       GotoPage 1 0
Key KP_9	A       C       GotoPage 2 0

Key KP_7	A	M	my_topleft

Key KP_Add	A       C       Desk 1
Key KP_Subtract	A       C       Desk -1
Key KP_Enter	A	C	Maximize

Key s		R       M       Exec "xterm" xterm -sl 1000 -geometry 80x25 &
Key e		R       M       Exec "Emacs" emacs -bg black -fg white &
Key n		R       M       Exec "Netscape" netscape -install &
#Key u		W       M       Raise
#Key d		W       M       Lower

#PAGE Up/Dapge Down keys are used to scroll by one desktop page
# in any context, press page up/down + control
# in root context, just pressing page up/down is OK
# 
# I prefer the non-wrapping scroll. These are for example purposes only
#Key Next	A       C       Scroll 100000 0
#Key Next	R       N       Scroll 100000 0  
#Key Prior	A       C       Scroll -100000 0
#Key Prior	R       N       Scroll -100000 0

#Key Prior	A	M	Next [!Iconic CurrentDesk CurrentScreen !Fvwm*] FocusAndWarpToWindow
#Key Next	A	M	Prev [!Iconic CurrentDesk CurrentScreen !Fvwm*] FocusAndWarpToWindow
#Key Prior	A	MC	Next [!Iconic CurrentDesk !Fvwm*] FocusAndWarpToWindow
#Key Next	A	MC	Prev [!Iconic CurrentDesk !Fvwm*] FocusAndWarpToWindow
Key Prior	A	C	Next [!Iconic CurrentDesk CurrentScreen] FocusAndWarpToWindow
Key Next	A	C	Prev [!Iconic CurrentDesk CurrentScreen] FocusAndWarpToWindow
Key Prior	A	M	Next [!Iconic CurrentDesk] FocusAndWarpToWindow
Key Next	A	M	Prev [!Iconic CurrentDesk] FocusAndWarpToWindow

# Useful olwm type things for Sun keyboards.
Key L5		IW      N       RaiseLower
Key L5		IW      S       Lower
Key L5		IW      C       Raise
Key L7		IW      A       Iconify

# Win95 'alt-tab' short-cut
Key Tab 	R	M	WindowList Root c c CurrentDesk NoGeometry
Key Tab		R	C	WindowList Root c c NoDeskSort

############################################################################
############################################################################
##
## Module Definitions
##
############################################################################
############################################################################

############################################################################
# FvwmButtons
#
#*FvwmButtons (2x1) Load NULL      Swallow "xload" exec nice -16 xload -nolabel -bg grey60 -update 1 -geometry -1500-1500 
#*FvwmButtons (4x1) - NULL Swallow "xclock" exec xclock -g 255x30 -digital &
#*FvwmButtons - NULL Swallow "xbiff" exec xbiff -rv -geometry -1500-1500 
#*FvwmButtons XEmacs xemacs.xpm  Exec "XEmacs" exec xemacs &
#*FvwmButtons (6x1) - whatever Swallow Module "Fvwm Pager" FvwmPager 0 5

# Colors
*FvwmButtonsFore White
*FvwmButtonsBack Gray59

# Font
*FvwmButtonsFont fixed

# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry +420+0

# Layout: specify rows or columns, not both
#*FvwmButtonsColumns 1
*FvwmButtonsRows 1

# Define the buttons to use.....
*FvwmButtons Netscape	netscape-sm.xpm	ToggleNetscape
*FvwmButtons Xterm	rterm-sm.xpm	Module FvwmForm Rlogin
*FvwmButtons Kill	rbomb.xpm	Destroy
*FvwmButtons Paging	clamp.xpm	Popup MiniScrollMenu
*FvwmButtons Xcalc	rcalc.xpm	Exec "calctool" calctool &
*FvwmButtons Lock	lock.xpm	Exec "" xscreensaver-command -lock &
*FvwmButtons Logout	exit.xpm	Popup "Quit-Verify"
#*FvwmButtons Elm	mail2.xpm	Exec "Elm" xterm -n Elm -title Elm -wf -rv -display $DISPLAY -e /usr/local/bin/elm &
#*FvwmButtons - whatever  Swallow "xbiff" Exec /usr/local/bin/xbiff++ &
#*FvwmButtons(Title Move  ,Icon arrows2.xpm,Action Move )
#*FvwmButtons Netscape	netscape-sm.xpm	Exec "Netscape" netscape4.06 &
#*FvwmButtons Mesquite	rterm.xpm	Exec "mesquite" remsh mesquite -n xterm -sl 1000 -display $HOSTDISPLAY &
#*FvwmButtons Xterm	rterm.xpm	Exec "xterm"  exec xterm  -g 115x46+0+0 &
#*FvwmButtons Paging	clamp.xpm	TogglePage
#*FvwmButtons Logout	exit.xpm	Quit
#*FvwmButtons -		clock.xpm	Swallow "xclock" xclock -bg Gray59 -hl blue -geometry -1500-1500 -padding 0

# Pull-down paneling
# To include the panel in a button
#*FvwmButtons(Title Resize, Icon mail2.xpm, Panel(indicator 5, down, delay 0, steps 16) Panel1 "Module FvwmButtons Panel1")
#*FvwmButtons(Panel(indicator 20, down, delay 0, steps 16) Panel1 "Module FvwmButtons Panel1")
# To define the panel as an instance of
# FvwmButtons with a different name:
#*Panel1(Icon lock.xpm, Action Exec xlock)
#*Panel1(Icon clock.xpm, Action Move)

# Make the menu/panel look like CDE
#Style "FvwmButtonsWinOps" Title, NoHandles, BorderWidth 0
#Style "FvwmButtonsWinOps" NoButton 2, NoButton 4, Sticky

#*FvwmButtons(Title WinOps,Icon arrows2.xpm, Panel (down, indicator) WinOps)
#*FvwmButtons(Title Tools ,Panel (down) Tools)

# PANEL definition
#*FvwmButtonsWinOpsBack bisque2
#Style "FvwmButtonsWinOps" Title, NoHandles, BorderWidth 0
#Style "FvwmButtonsWinOps" NoButton 2, NoButton 4, Sticky

#*FvwmButtons(Title Resize,Icon resize.xpm ,Action Resize)
#*FvwmButtons(Title Move  ,Icon arrows2.xpm,Action Move  )
#*FvwmButtons(Title Lower ,Icon Down       ,Action Lower )
#*FvwmButtons(Title Raise ,Icon Up         ,Action Raise )
 
############################################################################
# FvwmIdent (Window-Identifier)
#
# Give us colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

############################################################################
# FvwmPager
#
*FvwmPagerBack			PeachPuff3
*FvwmPagerFore			Black
*FvwmPagerHilight		White
*FvwmPagerGeometry		x140-1-1
*FvwmPagerLabel			0	Desk-0
*FvwmPagerLabel			1	Desk-1
*FvwmPagerBalloons		Icon
*FvwmPagerBalloonYOffset	-2

# Setting the font to 0x0 or nil2 results in no text
*FvwmPagerSmallFont 5x8

############################################################################
# FvwmWinList
#
*FvwmWinListBack Gray59
*FvwmWinListFore Yellow
*FvwmWinListGeometry +0+0
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
#*FvwmWinListAction Click1 Iconify -1, Raise, Focus, WarpToWindow 50 50
*FvwmWinListAction Click1 function goto_it
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Iconify -1, move
*FvwmWinListUseSkipList
*FvwmWinListFocusFore Aquamarine
*FvwmWinListDontDepressFocus

############################################################################
# FvwmBacker
#
*FvwmBackerDesk 0 xsetroot -solid grey
*FvwmBackerDesk 1 xsetroot -solid steelblue
*FvwmBackerDesk 2 xsetroot -solid yellow
*FvwmBackerDesk 3 xsetroot -solid red

############################################################################
# FvwmIconMan
#
#*FvwmIconMan*geometry		200x0+200+0
#*FvwmIconMan*background		Gray59
#*FvwmIconMan*foreground		Yellow
# from .man file
Style "FvwmIconMan"  NoTitle, Sticky, WindowListSkip, BorderWidth 0
Style "FvwmIconMan"  HandleWidth 0
 
Key F8 A N SendToModule FvwmIconMan bif select 7, bif focus 3, gotomanager 0, select, ret, gotobutton focus, select, ret, gotobutton down, select
Key F9 A N SendToModule FvwmIconMan bif select 7, bif focus 3, gotomanager 0, select, ret, gotobutton focus, select, ret, gotobutton up, select
 
*FvwmIconMan*numManagers		2
*FvwmIconMan*Resolution			page
*FvwmIconMan*background			steelblue
*FvwmIconMan*foreground			white
*FvwmIconMan*font			7x13
*FvwmIconMan*usewinlist			true
*FvwmIconMan*drawicons			true
*FvwmIconMan*shape			true
*FvwmIconMan*followfocus		true
*FvwmIconMan*sort	 		true
*FvwmIconMan*plainbutton		up white steelblue
*FvwmIconMan*selectbutton		down white steelblue
*FvwmIconMan*focusbutton		up white brown
*FvwmIconMan*focusandselectButton	down white brown
*FvwmIconMan*titleButton		raisededge white steelblue

*FvwmIconMan*1*title           "Emacs windows"
*FvwmIconMan*1*iconname        "FvwmIconMan: Emacs"
*FvwmIconMan*1*format          "%i"
*FvwmIconMan*1*show            resource=emacs resource=gemacs
*FvwmIconMan*1*managergeometry 1x0-400+0
*FvwmIconMan*1*buttongeometry  200x0
 
*FvwmIconMan*2*title           "All windows"
*FvwmIconMan*2*iconname        "FvwmIconMan: all"
*FvwmIconMan*2*format          "%c: %i"
*FvwmIconMan*2*dontshow        icon=Untitled
*FvwmIconMan*2*managergeometry 2x4-0+0
*FvwmIconMan*2*buttongeometry  200x0
 
*FvwmIconMan*transient*geometry 194x100
*FvwmIconMan*transient*dontshow icon=Untitled
*FvwmIconMan*transient*action   Mouse 0 A sendcommand select select Iconify
 
*FvwmIconMan*action Mouse     1 N sendcommand Iconify
*FvwmIconMan*action Mouse     2 N sendcommand WarpToWindow
*FvwmIconMan*action Mouse     3 N sendcommand "Module FvwmIdent FvwmIdent"
*FvwmIconMan*action Key  Left  N gotobutton Left, select
*FvwmIconMan*action Key  Right N gotobutton Right, select
*FvwmIconMan*action Key  Up    N gotobutton Up, select
*FvwmIconMan*action Key  Down  N gotobutton Down, select
*FvwmIconMan*action Key  q     N quit

############################################################################
# FvwmAudio
#
*FvwmAudioPlayCmd play
*FvwmAudioDir /mft/misc/sounds
#*FvwmAudio startup goodmorning.au
#*FvwmAudio shutdown destruct.au
#*FvwmAudio unknown cat-1.au
#*FvwmAudio add_window oh_my_god.au
#*FvwmAudio destroy_window oh_my_god.au
#*FvwmAudio focus_change oh_my_god.au
*FvwmAudio iconify flush.au
*FvwmAudio deiconify bong.au

#*FvwmAudio add_window    ??
#*FvwmAudio toggle_paging ??

#*FvwmAudioDelay 3

#*FvwmAudio focus_change goodmorning.au
#*FvwmAudio raise_window goodmorning.au
#*FvwmAudio lower_window goodmorning.au

############################################################################
# FvwmForm
#

# FvwmForm alias - rlogin to host via xterm
*RloginWarpPointer
*RloginFont         *helvetica*m*r*n*14*
*RloginButtonFont   *helvetica*m*o*n*14*
*RloginInputFont    *cour*m*r*n*14*
*RloginFore	    White
*RloginBack         Blue
*RloginItemFore	    Wheat
*RloginItemBack	    Black
#*RloginFore         Yellow
#*RloginBack         Blue
#*RloginItemFore	    Wheat
#*RloginItemBack	    Black
# begin items
*RloginLine         center
*RloginText         "Login to Remote Host"
*RloginLine         center
*RloginText         "Host:"
*RloginInput        HostName  20   ""
*RloginLine         center
*RloginSelection    UserSel   single
*RloginChoice       Default   Default   on   "same user"
*RloginChoice       Custom    Custom    off  "user:"
*RloginInput        UserName  10   ""
*RloginLine         expand
*RloginButton       quit "Login" ^M
*RloginCommand	    Exec xterm  -T $(HostName) -e rlogin -8 $(Custom?-l $(UserName)) $(HostName)
*RloginButton       restart   "Clear"
*RloginCommand	    Beep
*RloginButton       quit "Cancel"
*RloginCommand	    Nop

#
# FvwmForm alias - query exit ala mwm
*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
#*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyButtonFont    7x13bold
*QuitVerifyFore          Black
*QuitVerifyBack          Light Gray
*QuitVerifyItemFore Wheat
*QuitVerifyItemBack Gray50
# begin items
*QuitVerifyLine          center
*QuitVerifyText          "Do you really want to exit FVWM?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      " Exit "
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"
*QuitVerifyCommand  Nop

#
# MyFvwmTalk Form - sticks around
*MyFvwmTalkWarpPointer
*MyFvwmTalkFont *helvetica*m*r*n*14*
*MyFvwmTalkButtonFont *helvetica*m*o*n*14*
*MyFvwmTalkInputFont *cour*m*r*n*14*
*MyFvwmTalkFore Red
*MyFvwmTalkBack Gray
*MyFvwmTalkItemFore Blue
*MyFvwmTalkItemBack Gray
*MyFvwmTalkLine center
*MyFvwmTalkText "Fvwm Function"
*MyFvwmTalkInput Func 40 ""
*MyFvwmTalkLine expand
*MyFvwmTalkButton restart "Run" ^M
*MyFvwmTalkCommand $(Func)
*MyFvwmTalkButton restart "Clear" ^R
*MyFvwmTalkCommand Nop
*MyFvwmTalkButton restart "Iconify" ^Z
*MyFvwmTalkCommand Next [MyFvwmTalk] Iconify
*MyFvwmTalkButton quit "Quit" ^C
*MyFvwmTalkCommand Nop

## NEW STUFF

# Way FVWMchanges colormap for things like Netscape (uses lot of colours) 
#ColormapFocus FollowsMouse

# Filter out names in IconManager ??
#*FvwmIconMan*format %t

#Style "*" SmartPlacement, RandomPlacement, NoPPosition
#GlobalOpts SmartPlacementIsReallySmart

AddToMenu "Logins" "Control Animation" Popup MenuFvwmAnimate

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Nov 1999 05:41:21 +0100

> Can anyone reproduce the problem ??

I must confess I was too lazy with this bug.  I tried it out
and did not get the problem with 2.3.x (but with 2.2.x) and
so simply marked it as 'fixed' within fvwm.  But I am quite
sure that it isn't a fvwm bug at all.  If the rxvt doesn't
redraw itself I can't see how it could be the fault of the
window manager.  fvwm does neither tell applications when to
redraw itself nor can it prevent them from doing so.  It's
solely an issue of communication between X server and
application.  I noticed that there is some code in Eterm
(which is similar to rxvt) to minimize redrawing of the
background.  This is probably too restrictive (on the other
hand I get excessive redraws myself when I move a 'transparent'
rxvt).

Could you please report this to the rxvt developers
([email-masked])?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]