Subject: FvwmTaskBar crashes

From: "Robert H. Ford II" <[email-masked]>
Date: Mon, 29 Nov 1999 15:57:28 -0600

I've just build the latest snapshot and now FvwmTaskBar crashes.

I've looked at the mail archive and noticed the following:

> to do for 2.4 (update 26)
> 
> (words cut for brevity)
> 
> 44) Fix TaskBar crash caused by latest patch in RemoveButton().
> 

Is this the reason I get this message:

*FvwmTaskBar: Cause of next X Error.
   Error: 9 (BadDrawable)
   Major opcode of failed request:  53 (CreatePixmap)
   Minor opcode of failed request:  0 
   Resource id of failed request:  0xa01 
 Leaving a core dump now

Is there any fix that I could try?

Can I do anything with the core file to help solve this problem?

Thank you for any and all help.

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 30 Nov 1999 06:42:34 +0100

> Can I do anything with the core file to help solve this problem?

Yes, you can do:

gdb modulepath/FvwmTaskBar core

and then type: "where"
I will be interseted to see the output.
Thanks, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 30 Nov 1999 09:30:52 +0100

> Thank you for any and all help.

Hello again,
Do you have the crashes if you use the option:
*FvwmTaskBarShowTips

If no I hope my last commit fix your crashes
(I have added the line:
  if (!ShowTips) return;
in the begining of void ShowTipWindow(int open)).

If yes can you send me your TaskBar config ?

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Nov 1999 08:54:15 +0100

> I will be interseted to see the output.

Remember that errors are handled asynchronously.  The stack trace
will most likely show some other position in the code.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 01 Dec 1999 00:47:53 +0100

> I've just build the latest snapshot and now FvwmTaskBar crashes.

Fixed in the current cvs
Olivier