Subject: Re: Recapture Bug

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 21 Nov 1999 17:53:38 +0200

On 20 Oct 1999 11:00:36 +0200, Mikhael Goikhman wrote:
> 
> On 18 Oct 1999 22:36:22 -0500, [email-masked] wrote:
> > 
> > Description:
> > 	The Recapture command causes the GNOME panel to disappear. It is
> > 	still running, but it is not visible on any page of the virtual
> > 	desktop.
> 
> For me the panel is visible, but in the wrong location.
> Also most of the windows do not preserve their geometry (appear on the
> page 0,0) and sometimes lose flags (shading, iconifying).
> 
> It only happens on the first Recapture, next ones do preserve everything
> except for shading. I will try to find what happens.

The problem was in the wrong calculating of xdiff/ydiff for windows
started by session manager (gnome-session). I was not sure how to fix it.

With the latest Dominik's changes, xdiff/ydiff were scrapped.
And now Recapture (and RecaptureWindow) works well for all windows.
Shading flag is not preserved though.

Actually there are still (yes) problems with session code, which can cause
"disappearing" on Restart (a wrong page).

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 21 Nov 1999 19:31:37 +0100

> started by session manager (gnome-session). I was not sure how to fix it.
 
That is why I rewrote the code :-)

> Shading flag is not preserved though.

WHat do you mean?  I didn't touch the 'shade' flag in the sessin
manager and it still works for me.  If you mean that the 'shade'
flag is not preserved without the SM: we have known that for
several months. The 'iconified' state isn't preserved either
(it's even on the to do list).

> "disappearing" on Restart (a wrong page).

I need a bit more details :) But in general I think that it's
not possible anymore that the SM screws window positions up
since it simply stores the absolute position now.  I didn't
address icon locations yet.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 22 Nov 1999 00:49:45 +0200

> (it's even on the to do list).

I mean that RecaptureWindow for a shaded window unshades it (this is not
related to your latest changes nor to a session code). RecaptureWindow for
iconified windows leaves them iconified.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Nov 1999 00:23:09 +0100

> iconified windows leaves them iconified.

Yes, recapture un-shades for the same reason that restart
un-shades.  Now that you mention it I wonder why it doesn't
iconify.  There's no real difference between a recapture and
a restart. or is it?

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 22 Nov 1999 03:32:19 +0200

> Yes, recapture un-shades for the same reason that restart

No, restart restores all flags (using a session code).
Quit and then Start inside X do not preserve iconified state, not Restart.

> iconify.  There's no real difference between a recapture and

There is a recapture on restart, but they are not the same operation.
You can do Recapture in the same executable (no session code involved,
because MatchWinToSM should always return False for Recapture by itself),
while Restart lanches another fvwm executable (saves/loads session state).

With your latest changes, Recapture probably has no much sence, it just
iterates over all windows and does (Re)CaptureWindow: destroy/add window.
As far as I understand (I do not), it was used mostly for style updates.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Nov 1999 04:11:05 +0100

> Quit and then Start inside X do not preserve iconified state, not Restart.

Yes, but without the session code it does not remember the shaded
state.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Nov 1999 14:18:29 +0100

On Mon, Oct 18, 1999 at 10:36:22PM -0500, [email-masked] wrote:
> Configuration Information [Automatically generated, do not change]:
> uname output: Linux dethstar 2.0.38 #2 Sun Sep 19 14:49:59 CDT 1999 i586 unknown
> Compiler: gcc
> Compilation CFLAGS: -g -O2
> prefix: /usr/local
> sysconfdir: /usr/local/etc
> libexecdir: /usr/local/libexec
> 
> FVWM Version: 2.3.10
> FVWM_CONFIGDIR: unset
> FVWM_MODULEDIR: unset
> FVWM_USERHOME: unset
> 
> Description:
> 	desktop. I think it might be iconified, because my iconify sound
> 	plays.
> 
> 	I reported this bug a while back with an old version of Gnome, and
> 	said I'd report back when I've updated. I'm running the latest
> 	versions of all the Gnome software (1.0.53).
> 
> Repeat-By:
> 	Execute the Recapture command while running the Gnome pager.

One of the commits from the last week should have fixed this.
Can you try this please?

Bye

Dominik ^_^

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Sat, 27 Nov 1999 17:13:56 -0600

On Sat, Nov 27, 1999 at 02:18:29PM +0100,
> One of the commits from the last week should have fixed this.

Yeah, it works now.

-- 
Eric Gillespie, Jr. <*> [email-masked]

"I thought I was in love once. Later I learned it was an inner ear
 infection."
 --Constable Benton Fraser (Due South)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]