Subject: to do for 2.4 (update 26)

From: Dominik Vogt <[email-masked]>
Date: Thu, 25 Nov 1999 12:20:32 +0100

Items with highest priority / most severe problems:

101, 103

New since last update:

102, 103, 104

Closed since last update:

74, 99, 101

---------- Summary: ----------------------------------------------

 1 to be verified
 8 to do
 7 distribution issues
 7 testing
----------------------
23 open items
81 items done
104 items in total

---------- To be verified: ---------------------------------------

 55) FvwmGtk can't be killed with 'KillModule'.
     [???]

---------- To do: ------------------------------------------------

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
     [couldn't reproduce this yet; can anybody who has netcool
     event manager try it?]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).
     [optional]
100) Remove I18N patches since author seems to have lost interest
     in finishing the patch.
102) Patch 'UseDecor' and 'UseStyle' styles and various ...Style
     commands to apply without a recapture.
     [perhaps not for 2.4]
103) Add recent bug reports to to-do list.
104) Fix FvwmCommandS core dumps on X server shutdown.

---------- Distribution issues: ----------------------------------

 9)  Set up RPM packages.
     [???; Jason?]
 11) Add FvwmKb module?
     [stalled; probably delayed until after 2.4; Mikhael?]
 12) Set up bzip2 tarballs.
     [optional]
 48) Finish Windoze 95 like config file.
     [stalled (90%)]
 62) Write a new announcement.
 64) Install the new web pages.
     [Jason]
 90) Icon distribution.

---------- Testing: ----------------------------------------------

 33) Test the GNOME patches.
 34) Update and run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 92) Test new session management code.
 94) Test colour set support in modules and fvwm.
 95) Test new panel implementation in FvwmButtons.
 
========== Done: =================================================

 1)  Document the GNOME stuff (man page still missing).
 2)  Add screen shots to web page.
 3)  Add link to fvwm cats page to web page.
 4)  Add link to Mikhael' wm-icons page.
 5)  Update the links on our home page.
 6)  Remove several configure options.
 7)  Create an I18N fvwm package (from 2.2 or so).
     [see #100]
 8)  Add an explanation about the various packages and where to
     discuss them to the web page.
     (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 10) Remove 'PopupAsRootMenu' menu style (?).
     [rejected]
 13) Use a 'busy' pointer during startup.
 15) Get restart straight (sometimes an application vanishes over restarts)
     [fixed]
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no bug; doesn't happen for 2.2 and up]
 19) Fix: KFM windows stay on top of normal fvwm windows.
     [done]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
     [no fix? or should we rather break 'xterm +ai'?]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
     [Eterm bug fixed, rxvt doesn't work very well with transparent
     background. I've reported to the rxvt mailing list]
 22) Investigate bug #290. (windows cannot be raised over others sometimes).
     [mail thread from April; confirmed by me (Dominik)]
     [fixed; there is a new style and the behaviour is a bit more intuitive]
 23) Check if bug #312 is still there.
 24) Investigate bug #314.
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [fixed; only in 2.2.2, caused by missing X error handler]
 26) Investigate bug #315. (Recapture doesn't work perfectly for changing the
     default decor).
     [mainly a documentation problem; man page was updated]
 27) Check if bug #334 is still a problem.
 28) Investigate FvemEvent core dumps.
     [fixed in 2.2.3, no bug in 2.3.4]
 29) Fix the pager bugs I reported recently.
 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
 31) 'Maximize grow grow' works only on the current page.
 37) Fix interaction of moving with autoraising icon titles.
 38) Investigate bug #389. (StartsOnDesk does not work)
     [configuration problem, added a warning to the code]
 39) Investigate bug #390
 40) Investigate bug #394. (Overlapping pages)
     [no bug; doesn't happen after a recompile]
 41) Fix hanging fvwm when moving GNOME menu bars (bug #395).
 42) Get bitmap icons working again.
 43) Several pager bugs (bug #379).
 44) Fix TaskBar crash caused by latest patch in RemoveButton().
 45) Remove the web pages from the distribution.
 46) Titlebars should not inherit the pixmap from the border style.
 47) Verify the TaskBar clock update problem.
     [given up; I think I could reproduce the problem - it was a
     configuration mistake, but the reporter didn't care to answer
     if my suggestion helped; Dominik]
 49) Implement a 'H'old trigger for complex functions.
 50) Implement a 'ButtonGeometry' option for FvwmButtons.
 51) Fix constraining the window size when a window is maximized or
     larger than MaxWindowSize when mapped.
 52) Allow to resize in client resize increment steps.
 53) Decide what to do with overlapping moved icons.
     [will be ignored]
 54) Find a better solution for raising/lowering of transients.
 56) Mini icons may overlap menu titles.
 57) Fix autohiding and TaskBar tips.
 58) DeskTopSize is not honoured upon a restart (the old one is reused).
     [use Restart --dont-preserve-state]
 59) Get Raise/Lower of transients straight.
     [duplicate of item 54]
 60) Make MaxWindowSize a style (don't release a command that will
     change anyway).
 61) Get SidecPics working again.
 63) Fix stacking order in pager.
 65) Fix "maximize true ..." when a window is already maximized.
 66) Fix ddd problems.
     [fixed as far as possible; bug reported to ddd list]
 67) Add a Windoze95 like screenshot to the web page.
 68) Investigate 'Xlib: sequence lost' message.
     [went away with a newer snapshot]
 69) Fix window moving. Several people have reported that moving windows
     is slow or the windows don't follow the pointer well. This is really
     a big problem.
 70) Fix resize. On one hand it's not nice that you can drag the window
     border off screen, on the other hand it doesn't hurt if the shadow
     of the border is not on screen.
 71) Fix drawing of window titles.
 72) Finish implementing colour sets for modules.
     [item split up]
 73) Remove 'panel' feature from FvwmButtons and re-implement it in a
     less disruptive way.
 74) To fix: icons are not preserved over a Quit - Start for fvwm
 75) Implement colour sets in FvwmWharf.
 76) Implement colour sets in FvwmTaskBar.
 77) Implement colour sets in menu styles.
 78) Implement colour sets in window styles.
     [only colours used yet]
 79) Implement colour sets in FvwmConsole?
     [rejected]
 80) Implement colour sets in FvwmScript
 81) Change the way in which fvwm 'posts' menus with a click.
 82) Introduce a 'transient' option for FvwmButtons. This is needed
     to replicate the old panel behaviour.
 83) Fix FvwmIconMan crashes introduced by colour set support(?)
     [doesn't happen anymore]
 84) Implement colour sets in FvwmBacker.
 85) Add 'geometry' panel option in FvwmButtons.
     I think it's not worth the effort because it's similarly
     complicated as the menu position hints if I want to do it right.
     I can't see an easy solution that does something useful fast.
     [future enhancement]
 86) Finish code for setting backgrounds of other applications with
     colour sets.
 87) Describe what to do for colour set support in the module docs.
 88) Investigate 'pager out of sync' problem
     [fixed]
 89) Make FvwmScript use the same visual as fvwm (prerequisite for 80)
 91) Fix Xpm version problem (bug #463).
 93) Finish 'CREATING PANELS' section in FvwmButtons man page.
 96) Make flat titlestyle work again.
 97) Rewrite FvwmTheme 'Colorset' syntax ala MenuStyle.
 98) Allow using colours from colour sets in fvwm commands.
 99) Make HilightColors command colour set aware.
101) Finish current work on style changes w/o recapture in a
     consistent way. This doesn't necessarily mean that the
     feature has to be complete before 2.4.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 26 Nov 1999 13:32:47 +0000

>  55) FvwmGtk can't be killed with 'KillModule'.

I think I've fixed this one. On Solaris closing the pipe to FvwmGtk
caused it to loop. The change is:

-  gtk_input_add_full (fvwm_fd[1], GDK_INPUT_READ, read_fvwm_pipe,
-                      NULL, NULL, NULL);
+  gtk_input_add_full (fvwm_fd[1], GDK_INPUT_READ | GDK_INPUT_EXCEPTION,
+                     read_fvwm_pipe, NULL, NULL, NULL);

read_fvwm_pipe() will exit if the pipe is closed.

> 100) Remove I18N patches since author seems to have lost interest

I think we should leave it in.  It doesn't affect stability for non I18N
users and we may get lucky and attract some testing/programming talent
if it's in a stable release.

>      commands to apply without a recapture.

Don't worry about fixing decors. It seems to me that decors are a
workaround for things like HilightColor/ButtonStyle etc. being globals
instead of styles. Now that we have no limits on the style set we could
obsolete decors by creating additional style settings.

>  35) Test the strokes patch.

I've had a play with it and I haven't found any bugs but had plenty of
difficulties:

*) It's hard to configure, I think it just needs more examples.
*) The number grid is upside down! It's like a telephone instead of a
keyboard numpad.
*) You get lots of different sequences if you try complex shapes.
*) It needs more feedback, using the Stroke command on its own gives no
feedback, the StrokeFunc helps a lot but it would be nice if it drew an
XOR line as you traced the shape.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 26 Nov 1999 14:51:27 +0100

> if it's in a stable release.

At the moment the I18N option is disabled.  You have to edit config.h
manually to enable it.  There was some bug report that it doesn't even
compile at the moment.  I'm not opposed to leave it in in principle
(remember I've applied the patch in the first place against the opinions
of several others), but I don't want that this style of code spreads
further through the sources.  BTW, I've only partially applied the
patch back then because it was a 2.2 patch and I didn't understand it
well enough to adapt some parts of it.

Bye

Dominik ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 27 Nov 1999 14:58:08 +0100

> *) The number grid is upside down! It's like a telephone instead of a

I have no opinion here ... Note that there are examples in the
libstroke distribution.

> *) You get lots of different sequences if you try complex shapes.

Here I think that the example for netscape in the man page shows how
to deal with complex sequence. An other problem with complex sequence
is that with an Intel arch the stroke binding store the stroke sequence
in an 32 bits integer as libstroke use store sequences in a string of 
length 20 (I imagine that with an alpha arch this is not a problem).
So, a question: do you think that we need to modify the stroke patch
so that the stroke binding store the sequences in a string of length 20 ?
I did not do that because this may take a lot of memory ???
 
> feedback, the StrokeFunc helps a lot 

It is one of the reasons I do the StrokeFunc ... Thanks. In fact I think
that this function is the good way to use libstroke. When I posted the
patch for this function I suggested to suppress completely the "old" way
to handle mouse stroke. Dominik discourage me to do that (in a private
message). I take the occasion of this message to ask again :)
The reason I wanted to do this is that we could suppress the Button*MotionMask
in the main fvwm2 event loop. May be this can give a better performance
to this loop ???

> but it would be nice if it drew an

I have absolutely no idea how to do this ... but I can try to do it (as
an option of the StrokeFunc).

Finally, I would like to say that I use the stroke patch since now 5 months 
and I think it works find.

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 27 Nov 1999 15:32:54 +0100

> I have no opinion here ... Note that there are examples in the

I'd like it the other way round too.

> in the main fvwm2 event loop. May be this can give a better performance

Hey, if I discouraged you you must have read something I didn't
(want to) write.  I just asked that you consider if we have to
keep backwards compatibility.  The strokes patch has been lying
around for years, so the users might not like if we remove the old
syntax.

> an option of the StrokeFunc).

Grab the X server, draw the line with the Scr.DrawGC graphics context.
(Heck, why isn't this called XorGC?). This is the GC used to draw the
outlines of windows when moving/resizing.

> and I think it works find.

I was thinking about a more detailed test than 'use it and see
if something comes up'.  A proper test checks all kind of extreme
cases as well.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 28 Nov 1999 11:07:53 +0100

Dominik Vogt wrote:
> Olivier Chapuis wrote:

I take some times to understand that it is second vote for the possibility
to use keyboard numpad grid in stroke binding. I will do something (keeping
backwards compatibility).

> around for years, so the users might not like if we remove the old

Sorry, sorry ... But we cannot keep backwards compatibility, since 
Stroke need an unbinding of the form "Mouse 3 R N" as the StrokeFunc
need a binding of the form  "Mouse 3 R N StrokeFunc [options]".
Anyway, I mad some performence test and I did not see any difference
between fvwm2 compiled with stroke or without stroke. 

Olivier