Subject: 2.2.4 build fails with native HPUX compiler

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Nov 1999 14:24:27 +0100

With HPUX 10.20 I can't build 2.2.4 out of the box.  When I use
the compiler coming with the system it starts producing errors
in the first source line compiled.

------------------------------------------------------------------
# ./configure --disable-shape
...
Configuration:

  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

# make
No suffix list.
        make  all-recursive
No suffix list.
Making all in libs
        cd .. \
          && CONFIG_FILES=libs/Makefile CONFIG_HEADERS= /bin/sh ./config.status
creating libs/Makefile
        cc -DHAVE_CONFIG_H -I. -I. -I.. -I..      -g -c ClientMsg.c
cc: "ClientMsg.c", line 20: error 1000: Unexpected symbol: "*".
cc: "ClientMsg.c", line 20: error 1000: Unexpected symbol: ")".
cc: "ClientMsg.c", line 20: error 1616: Unable to open intrinsic file "/usr/local/lib/sysintr".
cc: "ClientMsg.c", line 22: error 1000: Unexpected symbol: "ev".
cc: "ClientMsg.c", line 24: error 1000: Unexpected symbol: "if".
cc: "ClientMsg.c", line 24: error 1000: Unexpected symbol: "==".
cc: "ClientMsg.c", line 25: error 1000: Unexpected symbol: "_XA_WM_PROTOCOLS".
cc: "ClientMsg.c", line 27: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 28: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 29: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 30: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 31: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 31: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 32: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 32: error 1000: Unexpected symbol: ".".
cc: "ClientMsg.c", line 33: error 1000: Unexpected symbol: "0".
cc: "ClientMsg.c", line 33: error 1000: Unexpected symbol: "*".
cc: "ClientMsg.c", line 33: error 1000: Unexpected symbol: "&".
cc: "ClientMsg.c", line 34: error 1000: Unexpected symbol: "}".
cc: "ClientMsg.c", line 22: error 1584: Inconsistent type declaration: "XClientMessageEvent".
cc: "ClientMsg.c", line 22: warning 525: Redeclaration of identifier "XClientMessageEvent".
cc: "ClientMsg.c", line 24: error 1584: Inconsistent type declaration: "_XA_WM_PROTOCOLS".
cc: "ClientMsg.c", line 24: warning 525: Redeclaration of identifier "_XA_WM_PROTOCOLS".
cc: "ClientMsg.c", line 25: error 1588: "disp" undefined.
cc: "ClientMsg.c", line 24: error 1521: Incorrect initialization.
cc: "ClientMsg.c", line 28: error 1588: "w" undefined.
cc: "ClientMsg.c", line 28: error 1521: Incorrect initialization.
cc: "ClientMsg.c", line 29: error 1521: Incorrect initialization.
cc: "ClientMsg.c", line 31: error 1504: A zero or negative array size is illegal.
cc: "ClientMsg.c", line 31: error 1588: "a" undefined.
cc: "ClientMsg.c", line 31: error 1521: Incorrect initialization.
cc: "ClientMsg.c", line 32: warning 525: Redeclaration of identifier "l".
cc: "ClientMsg.c", line 32: error 1588: "timestamp" undefined.
cc: "ClientMsg.c", line 32: error 1521: Incorrect initialization.
cc: "ClientMsg.c", line 33: error 1584: Inconsistent type declaration: "XSendEvent".
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.
------------------------------------------------------------------

The first lines of ClientMsg.c are:

...
#include <X11/Xlib.h>
#include <X11/Xatom.h>
#include <X11/Xutil.h>

Atom _XA_WM_PROTOCOLS = None;

void send_clientmessage (Display *disp, Window w, Atom a, Time timestamp) <-- line 20
{
...
------------------------------------------------------------------

Does anybody have an idea what is happening.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 30 Nov 1999 12:59:47 -0500

I suspect the native HP-UX compiler isn't ANSI, but only K&R.

FVWM doesn't support building with pre-ANSI compilers, and hasn't since
the 2.1.x days.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]