Subject: FvwmGtk is lock on send

From: Olivier Chapuis <[email-masked]>
Date: Fri, 12 Nov 1999 18:27:00 +0100

Hello Matthias,
I currently work on the "Lock on send logic" in fvwm. In fact,
as Tim Phipps suggested, we are going to probably replace M_LOCKONSEND
in "message mask" by a separated mask (which defines on which messages
the fvwm-to-module communication need to be lock on send).
All the modules are ready except FvwmGtk. In fact I'm
quite surprised by the fact that FvwmGtk is lock on send. However I know
nothing about gtk programming and do not study in depth FvwmGtk ...
So, is FvwmGtk really need to be lock on send ? If yes, can you
say on which messages FvwmGtk need to be lock on send.
Many thanks, Olivier.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 12 Nov 1999 19:21:10 +0100

> say on which messages FvwmGtk need to be lock on send.

Unfortunatly my memory is a bit foggy, but I remember that I needed
LOCKONSEND since fvwm would otherwise not send the M_STRING message
triggering the menu popup until it has seen the button-release event.
This is of course bad, since FvwmGtk wants to have the button-release
event. Thus I guess M_STRING is the only one for which it needs 
LOCKONSEND, since that is the message which triggers the menu popup. 

I hope this helps.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Nov 1999 19:24:45 +0100

> say on which messages FvwmGtk need to be lock on send.

Matthias?

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]