Subject: Pointer warp when menu dissapears confuses Move

From: [email-masked] (Tim Phipps)
Date: Tue, 23 Nov 1999 13:22:25 GMT

Configuration Information [Automatically generated, do not change]:
uname output: SunOS tazmo 5.6 Generic sun4u sparc SUNW,Ultra-4
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /home/tim
sysconfdir: /home/tim/etc
libexecdir: /home/tim/libexec

FVWM Version: 2.3.10
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /home/tim/libexec/fvwm/2.3.10
FVWM_USERHOME: unset

Description:
	Key Help A N Menu StartMenu Root 0 o100
	AddToMenu StartMenu "Move" Move
	
	Focus on a window in the top right corner, hit the key to pop
	the start menu up, select the move command and hit enter.  The
	pointer warps back to where it was when the menu popped up but as
	soon as the pointer is moved the focussed window dissapears up and
	right and you have to move the pointer back to the StartMenu position
	to get the window back on screen.

Fix:
	It looks like the move is getting hold of the pointer position
	before the warp happens, or it's getting told the wrong coordinates.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Nov 1999 21:22:19 +0100

> 	before the warp happens, or it's getting told the wrong coordinates.

Fixed.  The menu code overwrites the global event struct.
After the final key press, the x/y coordinates of the event
have been still over the menu.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]