Subject: CVS domivogt: * Most styles can be updates w/o recapture now (except UseStyle, HandleWidth and BorderWidth).

From: CVS <[email-masked]>
Date: Sat, 13 Nov 1999 23:12:30 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/11/13 23:12:29

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c add_window.h borders.c borders.h 
	                 builtins.c events.c focus.c fvwm.h fvwm2.1 
	                 menus.c style.c style.h 
	modules        : ChangeLog 
	modules/FvwmIconMan: FvwmIconMan.1 FvwmIconMan.h xmanager.c 
	modules/FvwmTaskBar: FvwmTaskBar.c 
	modules/FvwmWinList: FvwmWinList.c 

Log message:
* Most styles can be updates w/o recapture now (except UseStyle, HandleWidth and BorderWidth).
* More cleanup in add_window.c.
* Fixed a bug with clicktofocus/grabfocusoff.
* Fixed bugs with mini icons in IconMan and WinList.
* Fixed focus policy changes w/o recapture.
* New alt-tab bindings.
* Fixed ClickToFocus broken with 'decor_w' patches.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 14 Nov 1999 16:27:59 +0200

> * Most styles can be updates w/o recapture now (except UseStyle, HandleWidth and BorderWidth).

Very nice.

> * Fixed ClickToFocus broken with 'decor_w' patches.

There are still problems with NoHandles windows, the border can be
accessed only when the window is going to change its focus state during
this click.

Also it seems strange to me that FvwmWinList is always NoHandles, even
with 'Style FvwmWinList Handles'. I don't remember seeing this before.

Regarding the new menu tab bidings - seems good with me except of one bug.
Here is a patch to menus.c to fix it:

RCS file: /home/cvs/fvwm/fvwm/fvwm/menus.c,v
retrieving revision 1.155
diff -u -r1.155 menus.c
--- menus.c	1999/11/14 05:12:24	1.155
+++ menus.c	1999/11/14 14:16:45
@@ -1072,6 +1072,6 @@
       case 1:
       case 3:
-	/* meta-tab, shift-tab */
-	items_to_move = 1;
+	/* shift-tab, shift-meta-tab */
+	items_to_move = -1;
 	break;
       case 4:

But my Shift combinations are ignored for me anyway, here is why:
  XK_Tab=65289
  keysym=65289 (tab)
  keysym=65505 (shift-tab)

so (case XK_Tab) is not handled.
BTW, shift-tab works just well in my motif (netscape).

Regards,
Mikhael.