Subject: Re: BusyCursor Patch

From: Olivier Chapuis <[email-masked]>
Date: Wed, 03 Nov 1999 23:31:52 +0100

Bob Woodside wrote:
> 
> Olivier Chapuis wrote:
> >
> > Mikhael Goikhman wrote:
> > >
> > > Also I think Olivier can get write access to apply his patches himself.
> > >
> > > What others think?
> > >
> > Maybe I am a little young with programming and with fvwm code (even if
> > I learned quite fast this last two months).
> 
>         We've all made mistakes and committed things that were broken. We just
> expect someone to demonstrate reasonable competence and to be reasonably
> conscientious. I think you've done both. If you have a particularly
> complex piece of work, you can *still* ask for opinions or make a patch
> for others to review before committing it. Even the "old-timers" do that
> occasionally. Remember that one advantage of being able to commit things
> yourself is that, if something goes in that is broken, you can fix it
> much more quickly.
> 
>         Olivier has my vote whenever he feels ready to request access from
> Jason.
> 

Thanks for your vote !
I took 4 days of holidays and I think I am ready now ...
Anyway, I will perfectly understand that 2 votes is not enough :o)
Yours, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 03 Nov 1999 23:32:23 +0100

Bob Woodside wrote:
> 
> Olivier Chapuis wrote:
> >
> > Mikhael Goikhman wrote:
> > >
> > > Now with this patch all xsetroot or similar calls in initialization
> > > functions are ignored. I don't know whether this is ok.
> > >
> > > It is not a problem to replace:
> > >         Exec xsetroot -cursor_name left_ptr -fg red -bg white
> > > with:
> > >         CursorStyle Root left_ptr red white
> > >
> > > But probably some users can be confused. The note about the initial
> > > xsetroot should be in the man page or/and NEWS.
> > >
> >
> > Yep, with the first versions of my patch this happen only if you use
> > BusyCursor Wait True. I think I can do so that this is the case with
> > the version I send (and so the doc is ok).
> 
>         I hope so. I don't like the idea of adding too many "you can't do this
> during init functions" restrictions.
>

Oops, the current patch is ok for this :o). The only way (I think) to kill
an xsetroot commands for the root cursor is to use BusyCursor Wait True and
use a Function with a Wait pause.

Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 4 Nov 1999 01:45:58 +0200

> use a Function with a Wait pause.

Not exactly. Any CursorStyle command resets the root cursor.
I will fix this now.

Regards,
Mikhael.