Subject: strange mouse reaction with Rxvt

From: [email-masked]
Date: Mon, 1 Nov 1999 09:42:34 +0100

Hi there,

I don't know when this exactly happen, but although when I
open a new rxvt the mouse works fine (select, paste, etc),
after a while (dunno how much) when I :

left-click  I get this : J1#J1 or D0#D0 or :7#:7
mid-click   I get this : !J1#J1 or !D/#D/ or !@5#@5
right-click I get this : "J1#J1 or "<6#<6 or "-3#-3
(there are more patterns than these, just a few examples)

Very funny. I just found out that as long as I remain in the
same rxvt window, the character pattern remain the same. If
I just move the pointer to another window (with autofocus) and
come back, then clicking gives another pattern. The only thing
that remain the same is the middle hash sign, and a ! if I use
the mid-click or a " if I use the right click.

Does anyone have an idea ? I can't find out if this comes from
Fvwm (2.3.9) or from Rxvt (2.7.1 XPM,utmp,menubar,graphics,.Xdefaults)

Thanks,
Stephane

-- 
SILICON GRAPHICS                 EUROPEAN MANUFACTURING CENTER
##############################################################
Stephane Rosa                     Tel :     +41 (0)32 843-3638
Business Analyst                  Fax :     +41 (0)32 843-3909
APS/FP  Project                   GSM :     +41 (0)79 448-5335
--------------------------------------------------------------
ircnoc.neu.sgi.com  SGI Intranet  IRC :   EuroOper on #irchelp
irc.stealth.net     Euro-IRCNet   IRC :   Clipper on #radionet

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 01 Nov 1999 10:38:51 -0500

> Fvwm (2.3.9) or from Rxvt (2.7.1 XPM,utmp,menubar,graphics,.Xdefaults)

If this is the correct Rxvt home page:

http://babayaga.math.fu-berlin.de/~rxvt/

it doesn't look like there is an rxvt 2.7.1.

I'm still running rxvt 2.4.5, but I couldn't recreate
the symptom you reported.
I can't see how this could be an fvwm issue.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ben Winslow <[email-masked]>
Date: Mon, 1 Nov 1999 10:46:17 -0500 (EST)

Around 10:38am on Nov 1, 1999, Dan Espen spoke unto me:

DE# [email-masked] writes:
DE# > Hi there,
DE# > 
DE# > I don't know when this exactly happen, but although when I
DE# > open a new rxvt the mouse works fine (select, paste, etc),
DE# > after a while (dunno how much) when I :
DE# > 
DE# > left-click  I get this : J1#J1 or D0#D0 or :7#:7
DE# > mid-click   I get this : !J1#J1 or !D/#D/ or !@5#@5
DE# > right-click I get this : "J1#J1 or "<6#<6 or "-3#-3
DE# > (there are more patterns than these, just a few examples)
DE# > 
DE# > Very funny. I just found out that as long as I remain in the
DE# > same rxvt window, the character pattern remain the same. If
DE# > I just move the pointer to another window (with autofocus) and
DE# > come back, then clicking gives another pattern. The only thing
DE# > that remain the same is the middle hash sign, and a ! if I use
DE# > the mid-click or a " if I use the right click.
DE# > 
DE# > Does anyone have an idea ? I can't find out if this comes from
DE# > Fvwm (2.3.9) or from Rxvt (2.7.1 XPM,utmp,menubar,graphics,.Xdefaults)
DE# 
DE# If this is the correct Rxvt home page:
DE# 
DE# http://babayaga.math.fu-berlin.de/~rxvt/
DE# 
DE# it doesn't look like there is an rxvt 2.7.1.
2.7.1 is the devel version

DE# 
DE# 
DE# I'm still running rxvt 2.4.5, but I couldn't recreate
DE# the symptom you reported.
DE# I can't see how this could be an fvwm issue.
DE# 
DE# > Thanks,
DE# > Stephane
DE# 
DE# --
DE# Dan Espen
DE# 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
DE# Piscataway, NJ 08854                     Phone: (732) 699-5570
DE# --
DE# Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
DE# To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
DE# body of a message to [email-masked].
DE# To report problems, send mail to [email-masked]
DE# 
	I think the problem is that something is putting the rxvt into
report-mouse mode, and then not turning it off (so the program that's doing
that is probably the culprit, not fvwm nor rxvt).  Try running 'reset' to
get it out of mouse mode...

-- 
Ben Winslow          / [email-masked]
freshmeat news squad / freshmeat: http://www.freshmeat.net
|Rain| @ IRC         / anynet: irc.anynet.org

---

From: [email-masked]
Date: Mon, 1 Nov 1999 17:05:24 +0100

>  2.7.1 is the devel version

Right. I run the latest CVS tree.

>  get it out of mouse mode...

Yes ! Thanks very much. An ^[[?9t fixed it (alt-mouse was running
fine by the way.)

I think that some grep through binary files issued escape sequences
to my terminal, because I never use mouse reporting (I think)...

Resolved. Thanks !
Stephane

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Nov 1999 12:19:55 +0100

On Mon, Nov 01, 1999 at 10:38:51AM -0500, [email-masked] wrote:
>...

No, it isn't.  This was the old address.  The new homepage is at

  http://www.rxvt.org

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]