Subject: strange X behaviour

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Nov 1999 10:33:19 +0100

In FvwmIconMan (x.c) there is some code:

      while (XPending(theDisplay) &&
         XCheckMaskEvent(theDisplay, ConfigureNotify, &theEvent))
      {
        ...
      }

For weeks I chased a bug that caused the icon man to use
a screded up internal geometry.  Finally I figured out
that this is because sometimes (perhaps once for thirty
icon managers), an EnterNotify event slips into the loop
body.  I can't understand how this can happen (other than
an X server bug).  I'm confused.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 22 Nov 1999 09:19:15 -0500

> an X server bug).  I'm confused.

It is possible for the xserver to combine to events in one event
structure, granted its very bad manners, but nothing says it can't.  So
what is happening is for some odd reason the xserver decided to put the
enter and the configure in one struct, the simplest solution would be to
verify that you don't have and enter struct once inside the while loop.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Nov 1999 16:45:47 +0100

> verify that you don't have and enter struct once inside the while loop.

Really? Yuck! Anyway, I wouldn't have noticed the problem if 
the values in the EnterNotify would make sense.  I don't have
the spec handy right now, but I think an EnterNotify and a
ConfigureNotiy event are incompatible because the event union
for EnterNotiy doesn't have all the fields that are necessary
for a ConfigureNotify (i.e. I got a screwed up height and 
y = -109000000 or so when I interpreted the event as a
ConfigureNotify.

If the X server did this it is definitely a bug.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]