Subject: debug - fvwm-snap-19991118

From: Nadim Saeed <[email-masked]>
Date: Thu, 18 Nov 1999 14:46:04 -0800 (PST)

version	: fvwm-snap-19991118
uname -a: SunOS cosmo 5.5.1 Generic_103640-17 sun4u sparc SUNW,Ultra-2
gcc	: version-2.7.2
exceed	: 6.1

Three (3) debug issues here:

1. With the same setup file that I've been using for awhile now (again, no
   changes at all in the config file), I get the following errors (the
   pixmaps are there).  When I switch to 2.3.9 everything is cool.

[FVWM][scanForPixmap]: <<WARNING>> Couldn't find pixmap arrows2.xpm
[FVWM][scanForPixmap]: <<WARNING>> Couldn't find pixmap fvwm.xpm
[FVWM][scanForPixmap]: <<WARNING>> Couldn't find pixmap exit.xpm

2. Noticed below noted error and investigated the 'make'.  It doesn't look
   like that module is being compiled in module/FvwmBanner.  Possible Makefile
   problem ?  I tried a "make" in that subdir and nothing (no executable...

[FVWM][executeModule]: <<ERROR>> No such module 'FvwmBanner' in ModulePath
'/usr13/new/snap-fvwm/libexec/fvwm/2.3.10'

3. Relating to the bug I reported awhile back on Oct 14, 1999,
   (http://www.hpc.uh.edu/fvwm/archive/9910/msg00378.html).  With Oliver's
   new printfs (good call), we are now at least getting some message outputs
   whenever FvwmWinList disappears (no core file)

[FVWM][HandleModuleInput]: <<ERROR>> Fail to read (Module: 2, read: 0, size: 4)
[FVWM][HandleModuleInput]: <<ERROR>> Fail to read (Module: 2, read: 0, size: 4)

let me know if you want 'em in fvwm's jitterbug (or bugzilla or whatever)

 - Nadim

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 19 Nov 1999 07:59:33 +0100

> [FVWM][HandleModuleInput]: <<ERROR>> Fail to read (Module: 2, read: 0, size: 4)

Find, my intution on your problem was almost good (almost because
I never had this error in my machine, but an other one which is very similar).
The message means that WinList is (probably) the 3th module that you run
at startup, that winlist "send a message of size 4" but that fvwm can
not read it (read 0 byte).
Now, the point is to know if the snap-19991118 contains or not my fix
to this problem (commit of olicha  99/11/18 15:08:54).
We can wait the next snap, but can you go in the source at libs/Module.h
and see if there are the word "SendFvwmPipe" in it ?
If not, please, try the next snap ... If yes @#!#*$¤!¤

Olivier

-- 
[email-masked]
"you have moved your mouse, please reboot to make this change take effect"

---

From: Nadim Saeed <[email-masked]>
Date: Fri, 19 Nov 1999 11:06:34 -0800 (PST)

On Friday - November.19.1999 [07:59:33 +0100],
 > > [FVWM][scanForPixmap]: <<WARNING>> Couldn't find pixmap exit.xpm

This was my mistake.  You'd think I'd remember to always

  setenv LDFLAGS "-R/usr13/new/xpm-3.4k-solaris/lib"

since xpm in not installed -- I still think 'configure' ought to take care of
this problem, oh well....
 
 > > '/usr13/new/snap-fvwm/libexec/fvwm/2.3.10'

This, along with the FvwmDragWell's missing header files, is fixed in
'fvwm-snap-19991119' (thanks Tim).

 > >    (http://www.hpc.uh.edu/fvwm/archive/9910/msg00378.html).  With Olivier's

Cool.  I wasn't able to get FvwmWinList to disappear (tried for a good 4-5
minutes - good work Olivier).  I am still noticing the occasional weird
geometry calculation though; here's a way to reproduce it,

Make sure you have a running FvwmWinList
1. iconfiy an xterm (any which way - middle button on FvwmWinList would do)
2. right mouse click on the iconified window in FvwmWinList (my settings are
   noted below) and you'll note the strange location geometry in the feedback
   window (something along the lines of "-315 +636831")
3. since one is unable to see the window to move it (ie. no skeleton), if one
   presses the middle button (or ESC) the window will reappear on the screen
   but not FvwmPager

NOTE: if you skip step #1 above everything works great..

Here are the relevant parts of my FvwmWinList setting,

# FvwmWinList
#

AddToFunc goto_it
+       "I" iconify off
+       "I" raise
+       "I" focus
+       "I" warptowindow 50 50

*FvwmWinListBack Gray59
*FvwmWinListFore Yellow
*FvwmWinListGeometry +0+0
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
#*FvwmWinListAction Click1 Iconify -1, Raise, Focus, WarpToWindow 50 50
*FvwmWinListAction Click1 function goto_it
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Iconify -1, move
*FvwmWinListUseSkipList
*FvwmWinListFocusFore Aquamarine
*FvwmWinListDontDepressFocus

Keep up the GREAT work guys...

 - Nadim

---

From: Dan Espen <[email-masked]>
Date: Fri, 19 Nov 1999 14:40:07 -0500

> this problem, oh well....

I think the status of this is that we agreed with this but its really
an issue for the "configure" developers, not fvwm.

I don't know if this will help you, but my "configure" command line
is way too long for me to consider typing it in by hand so I have it
in a shell.  I guess you could export LDFLAGS in the shell, but I did it
with this argument:

  --x-libraries=/usr/openwin/lib:/opt/public/lib\

The  "x-libraries" get put into  a "-R" argument  and my xpm libraries
are in /opt/public/lib.

Either way, a little automation should help you out.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Nov 1999 04:40:09 +0100

On Fri, Nov 19, 1999 at 11:06:34AM -0800, Nadim Saeed wrote:
>...
                            ^^^^^^^^^^^^^^^^

There are two problems:

 1) A bug in the module code; I've fixed this one, but I'm not
    sure if the fix is okay.

 2) Don't use a comma separated function list, use a fvwm
    function instead.

Furthermore you can now tell 'Move' to place the window at
the mouse position. Try this config:

  AddToFunc DeiconifyAndMove
  + i iconify off
  + i move m+0 m+0
  + i move

  *FvwmWinListAction Click3 function DeiconifyAndMove
  
Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]