Subject: CVS domivogt: * Revised drawing of thin borders. Can somebody check if the depressableborders

From: CVS <[email-masked]>
Date: Tue, 30 Nov 1999 04:07:00 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/11/30 04:07:00

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : borders.c icons.c 
	modules        : ChangeLog 
	modules/FvwmTaskBar: Goodies.c 

Log message:
* Revised drawing of thin borders. Can somebody check if the depressableborders
style with/without handle marks and inset is still okay?

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 30 Nov 1999 13:12:05 +0000

> style with/without handle marks and inset is still okay?

I think it's drawn the way you intend. I prefer the old behaviour of not
showing any border color when the width becomes very small. If I wanted
to have the border color override the relief I would use "borderstyle --
flat".  It's not important though.

I think there is a bug in the un-depresing of NoHandle borders. When
moved with a mouse the border is drawn pressed but is not unpressed when
the move is finished.  This doesn't happen with resize handle borders.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Nov 1999 14:44:58 +0100

> the move is finished.  This doesn't happen with resize handle borders.

This looks funny.  Is this the intended behaviour of nohandle,
depressableborder windows?  I mean, should the complete border
be drawn depressed when you press on the border?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 30 Nov 1999 16:56:56 +0000

> be drawn depressed when you press on the border?
I think it has always been that way.  I'm used to it but that doesn't
mean it's what it should look like.

Cheers,
Tim.