Subject: The simplest way to freeze fvwm ?

From: Olivier Chapuis <[email-masked]>
Date: Fri, 29 Oct 1999 16:57:28 +0200

Hello,

Try the following:

Read cir

where the file cir is:

AddToFunc CirC I Read cir
CirC

I have tried to fix this but do not succeed ...
Olivier

PS: "read me" where the file me is "Read me" does not freeze
fvwm.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Fri, 29 Oct 1999 11:30:37 -0400 (EDT)

> PS: "read me" where the file me is "Read me" does not freeze

Hmmmm...  maybe functions should have a "nesting limit" like file reading.

-- 
Larry Gensch					      [email-masked]

                  "May I have ten thousand marbles, please?"

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 29 Oct 1999 19:23:20 +0200

> Hmmmm...  maybe functions should have a "nesting limit" like file reading.

May be I miss something but the read limit come from the C language.
My opinion is that we have to forbid to a function to AddToFunc to
itself (but it seems that this does not suffice to fix the problem).
Any way, the problem is not a real one since I do not think that a normal
user do a thing like cir (I found cir by testing my BusyCursor patch :o).
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]