Subject: Menubar of transparent Eterm again

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 19 Oct 1999 12:58:01 +0200

I remember this or similar bug was already fixed (twice) 4 months ago,
but it is again here (for about two months already).

How to reproduce:
  Eterm --trans  (after Esetroot)
  unfocus, go to another page, return to the Eterm's page

Eterm's menubar is not redrawn (wrong colors) until it gets a focus.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 19 Oct 1999 13:45:15 +0200

> Eterm's menubar is not redrawn (wrong colors) until it gets a focus.

Hm, I don't see why it should be a fvwm bug if eterm doesn't
redraw it's menubar.  Or do you mean something differrent?
Can you provide screenshots?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 19 Oct 1999 22:51:22 +0200

> redraw it's menubar.  Or do you mean something differrent?

Ok, it is most probably Eterm bug, I can reproduce it with every fvwm
version. Here is that makes me think that this can be fvwm problem.

There was the same visual effect of wrong menubar update for *non*
transparent Eterm 4 months ago. And that event problem was fixed
then (see june archives for the discussion), but *non* transparent Eterm
worked with the previous fvwm versions unlike this one.

I still can send screenshots, although this can be easily reproduced
with Esetroot and Eterm 0.8.9. You get Eterm menubar with focused
background (wrong) and unfocussed shade/hilite colors (right).

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 20 Oct 1999 10:51:32 +0200

On Tue, Oct 19, 1999 at 10:51:22PM +0200, Mikhael Goikhman wrote:
> with Esetroot and Eterm 0.8.9.

Sigh! I wouldn't be asking for screenshots if I could reproduce it.

> You get Eterm menubar with focused

No, I don't.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 20 Oct 1999 11:22:35 +0200

> Sigh! I wouldn't be asking for screenshots if I could reproduce it.

We have different Eterm configurations then.
Here are screenshots, all for 'Eterm --trans --menu Eterm.menu'.
Note, if I add ' --borderless true', the bug disappears.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Oct 1999 21:45:40 +0200

> Note, if I add ' --borderless true', the bug disappears.

That sounds awfully like a bug related to the aterm problem
reported recently.  It seems that all terminal emulators
stem from rxvt and share more or less the same bugs :-)

This is really a bug in eterm.  Fvwm cannot prevent that
eterm gets the Expose event; thus it must be the fault of
eterm.

Bye

Dominik ^_^