Subject: CVS domivogt: * New style 'Colorset'.

From: CVS <[email-masked]>
Date: Sat, 16 Oct 1999 05:32:57 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/10/16 05:32:57

Modified files:
	.              : AUTHORS ChangeLog NEWS 
	fvwm           : add_window.c borders.c borders.h builtins.c 
	                 builtins.h events.c focus.c functions.c 
	                 functions.h fvwm.c fvwm.h fvwm2.1 icons.c 
	                 module_interface.c module_interface.h 
	                 move_resize.c move_resize.h screen.h style.c 
	                 style.h windowlist.c 
	libs           : Picture.c 

Log message:
* New style 'Colorset'.
* Window color changes (style) don't need a recapture.
* Fixed several recapture/restart/iconify bugs.
* AddToFunc doesn't expand '$[??.cs<n>] variables.
* Safety fixes to prevent server coredump with 'rgb:0000'
* Style 'Colors' handles rgb colour specs.
* New command 'HideSizeWindow'.
* Better default error message for unknown commands.
* Fixed coredump with commands consisting only of whitespace.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 16 Oct 1999 22:42:40 +0200

> * New command 'HideSizeWindow'.

Is the better name not HideFeadbackWindow or HideGeometryWindow?
Since it is used for Move too, not only for Resize.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Oct 1999 11:32:49 +0200

> Since it is used for Move too, not only for Resize.

Done.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 18 Oct 1999 08:31:26 -0400

Congratulations, I can now switch my entire colo scheme with out so
much as a recapture.  Very nice.  Now I can have a function that simply
changes all my colorsets to the new color scheme and then update my
HilightColor and TitleStyle, very slick.  Nice work.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 19 Oct 1999 08:40:45 +0200

> HilightColor and TitleStyle, very slick.  Nice work.

8-)

That's what we worked hard for.  I guess we have colour set support
completed for 2.4 when the HilightColorset command is done.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]