Subject: bug #488

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Oct 1999 06:31:20 +0200

> I think there is a geometry calculation bug within FvwmWinList.  I've
> also,
> after multiple hours of trial and error, have a sure-fire way of making
> WinList fail.
> 
> Here are the relevant parts of my .fvwm2rc file:
> 
> ###
> # FvwmWinList
> #
> *FvwmWinListBack Gray59
> *FvwmWinListFore Yellow
> *FvwmWinListGeometry +0+0
> *FvwmWinListFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
> *FvwmWinListAction Click1 Iconify -1, Raise, Focus, WarpToWindow 50 50
> *FvwmWinListAction Click2 Iconify
> *FvwmWinListAction Click3 Iconify -1, move
> *FvwmWinListUseSkipList
> *FvwmWinListFocusFore Aquamarine
> *FvwmWinListDontDepressFocus
> 
> 
> Here's how to make WinList fail:
>  1. Make sure you are in Desk-0, Page-0
>  2. start winlist
>  3. start an xterm
>  4. go to any other page within the same Desk
>  5. press mourebutton-3 on the xterm button in winlist
>  6. place the xterm anywhere on that page
>  4. repeat step 4-6; at least four-eight times
>  5. FvwmWinList will crash (fvwm does not note any error messages !!)
> 
> The reason I think there is a geometry problem can be clearly demonstrated
> if one were to inject an "iconify the xterm" between step-3 and step-4
> above.  After pressing mouse-button-3 note the feedback windows numbers
> (something along the lines "-328 +608388")
> 
> After the crash, if I were to restart FvwmWinList I get even stranger
> behavior (which leads me to believe that the crashed WinList kept some
> state that the newly created WinList latched onto).  Alas make sure to
> start a _new_ fvwm on each try (not restart).
> 
> I've also noticed instances in which if I were to de-iconify an xterm, it
> would deiconify on the wrong page with a placement geometry of +0+0 _AND_
> it would not show-up on the FvwmPager unless I change pages (I'll try to
> recreate this failure later).

Nadim, that' doesn't cause a crash on my system.  Everything works fine.
One thing I did notice though is that these comma separated function
lists don't work as they should (because fvwm has no chance to handle
generated events during that function sequence). It works a lot better
if you define fvwm functions and call them instead, e.g.

  *FvwmWinListAction Click1 function fwlb1
  addtofunc fwlb1
  + i iconify off
  + i raise
  + i focus
  + i warptowindow 50 50

I have made several fixes related with function execution from modules
so please try again and see if at least part of the strange behaviour
goes away.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Nadim Saeed <[email-masked]>
Date: Fri, 15 Oct 1999 11:01:51 -0700 (PDT)

On Friday - October.15.1999 [06:31:20 +0200],
 Dominik Vogt ([email-masked]) wrote:
 > Nadim, that doesn't cause a crash on my system.  Everything works fine.

Dom, I made the changes to the comma separated function list (which I don't
see how that might have an affect on this bug, but I changed 'em per your
suggestion anyway).  I can still get FvwmWinList to crash as described above.

Might there be some other setting my config file that affects the behavior ?

BTW: were you able to see the "strange" feedback geometry if you were to
     inject an "iconfiy" between steps #3 and step #4 above ?

Alas, the FvwmWinList crashes on me _consistently_ (and it also happens when
I don't use mouse-button-3 -- but that's much harder to narrow-down, simple
iconify/deiconify's)

Any suggestions ?  Has anyone else tried to reproduce the error ?

 - Nadim (please cc replies)

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 16 Oct 1999 12:44:07 +0200

> Might there be some other setting my config file that affects the behavior ?

Probably not.  But I'll try with your config file when I have
the time.

>      inject an "iconfiy" between steps #3 and step #4 above ?

No.

> I don't use mouse-button-3 -- but that's much harder to narrow-down, simple

Did you already check for a core file?  If there is one, what does
the stack trace say?  ('gdb FvwmWinList core' then 'where' on the
gdb prompt).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Nadim Saeed <[email-masked]>
Date: Mon, 18 Oct 1999 11:51:18 -0700 (PDT)

On Saturday - October.16.1999 [12:44:07 +0200],
 > >      inject an "iconfiy" between steps #3 and step #4 above ?

This was blatant and very easy to reproduce - curious that its not happening
to you.

 > the stack trace say?  ('gdb FvwmWinList core' then 'where' on the

It doesn't produce a core - FvwmWinList just quietly disappears (as noted, no
error messages either).

 - Nadim