Subject: FvwmTheme memory leaks

From: Brad Giaccio <[email-masked]>
Date: Fri, 22 Oct 1999 07:57:39 -0400

Tim or Dominik, I thought you might be able to track this down faster.
all of the leaks are coming from the same place, and its obvious pixel
is not being freed but I'm not sure that if it makes sense to free it or
where it should happen.

Brad

P.S. I now have purify for my deesktop machine so just ask and it can be
purified.

Memory leaked: 1024 bytes (5.53%); potentially leaked: 2560 bytes (13.8%)

MLK: 512 bytes leaked at 0xa2a28
  * This memory was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:42]
	AllocNonlinearGradient [Graphics.c:276]
	AllocAllGradientColors [Graphics.c:375]
	CreateGradientPixmapFromString [Graphics.c:803]
	parse_colorset [FvwmTheme.c:559]
	parse_config_line [FvwmTheme.c:187]
	parse_config   [FvwmTheme.c:922]
	main           [FvwmTheme.c:119]
	_start         [crt1.o]

MLK: 512 bytes leaked at 0xa3c98
  * This memory was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:42]
	AllocNonlinearGradient [Graphics.c:276]
	AllocAllGradientColors [Graphics.c:375]
	CreateGradientPixmapFromString [Graphics.c:803]
	parse_colorset [FvwmTheme.c:559]
	parse_config_line [FvwmTheme.c:187]
	main_loop      [FvwmTheme.c:153]
	main           [FvwmTheme.c:134]
	_start         [crt1.o]

PLK: 2048 bytes potentially leaked in 4 blocks
  * This memory was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:42]
	AllocNonlinearGradient [Graphics.c:276]
	AllocAllGradientColors [Graphics.c:375]
	CreateGradientPixmapFromString [Graphics.c:803]
	parse_colorset [FvwmTheme.c:559]
	parse_config_line [FvwmTheme.c:187]
	parse_config   [FvwmTheme.c:922]
	main           [FvwmTheme.c:119]
	_start         [crt1.o]
  * Block of 512 bytes (4 times); last block at 0xa33e8

PLK: 512 bytes potentially leaked at 0x9f8e0
  * This memory was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:42]
	AllocNonlinearGradient [Graphics.c:276]
	AllocAllGradientColors [Graphics.c:375]
	CreateGradientPixmapFromString [Graphics.c:803]
	parse_colorset [FvwmTheme.c:559]
	parse_config_line [FvwmTheme.c:187]
	main_loop      [FvwmTheme.c:153]
	main           [FvwmTheme.c:134]
	_start         [crt1.o]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Oct 1999 15:29:02 +0100

> is not being freed but I'm not sure that if it makes sense to free it or
CreateGradientPixmapFromString is the culprit, try it now.

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 22 Oct 1999 10:39:14 -0400

> CreateGradientPixmapFromString is the culprit, try it now.

ahh, I feel much better,
      Memory leaked: 0 bytes (0%); potentially leaked: 0 bytes (0%)

Thanks, it would have taken me a bit longer to find that.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]