Subject: Restart coredumps

From: [email-masked]
Date: Sat, 9 Oct 1999 18:47:57 -0500 (CDT)

Full_Name: Stuart Anderson
Version: 2.3.9
CVS_Date: 
OS: SunOS 5.6
X_Server: Openwindow
Submission from: (NULL) (131.215.115.246)

Executing the fvwm Restart command from a fvwm menu results in a coredump
of fvwm2 with gdb indicating a problem in t_splay() and xsession
logging "FVWM2 has been killed by a signal 10", or sometimes signal 11.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Oct 1999 00:33:05 +0200

> logging "FVWM2 has been killed by a signal 10", or sometimes signal 11.

Please post the complete output of gdb's where command to the
[email-masked] mailing list.  t_splay is not a function
directly called by fvwm.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Stuart Anderson <[email-masked]>
Date: Thu, 14 Oct 1999 16:17:45 -0700 (PDT)

> gdb /opt/pspm/bin/fvwm2 core
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "sparc-sun-solaris2.6"...
(no debugging symbols found)...
Core was generated by `fvwm2'.
Program terminated with signal 11, Segmentation Fault.
Reading symbols from /opt/pspm/lib/X11/libXpm.so.4.11...
(no debugging symbols found)...done.
Reading symbols from /opt/pspm/lib/libstroke.so.0...done.
Reading symbols from /usr/openwin/lib/libSM.so.6...done.
Reading symbols from /usr/openwin/lib/libICE.so.6...done.
Reading symbols from /usr/openwin/lib/libXext.so.0...done.
Reading symbols from /usr/openwin/lib/libX11.so.4...done.
Reading symbols from /usr/lib/libsocket.so.1...done.
Reading symbols from /usr/lib/libnsl.so.1...done.
Reading symbols from /usr/lib/libm.so.1...done.
Reading symbols from /usr/lib/libc.so.1...done.
Reading symbols from /usr/lib/libdl.so.1...done.
Reading symbols from /usr/lib/libmp.so.2...done.
Reading symbols from /usr/platform/SUNW,Ultra-30/lib/libc_psr.so.1...done.
#0  0x6fc4653c in t_splay () from /usr/lib/libc.so.1
(gdb) where
#0  0x6fc4653c in t_splay () from /usr/lib/libc.so.1
#1  0x6fc463ac in t_delete () from /usr/lib/libc.so.1
#2  0x6fc46080 in realfree () from /usr/lib/libc.so.1
#3  0x6fc467ec in _free_unlocked () from /usr/lib/libc.so.1
#4  0x6fc4673c in free () from /usr/lib/libc.so.1
#5  0x6fe299d4 in _XFreeDisplayStructure () from /usr/openwin/lib/libX11.so.4
#6  0x6fe22a60 in XCloseDisplay () from /usr/openwin/lib/libX11.so.4
#7  0x3084c in Done ()
#8  0x26cc8 in restart_function ()
#9  0x44398 in ExecuteFunction ()
#10 0x44490 in ExecuteFunctionSaveTmpWin ()
#11 0x1c224 in do_menu ()
#12 0x23330 in SetMenuCursor ()
#13 0x23388 in popup_func ()
#14 0x44398 in ExecuteFunction ()
#15 0x2cd10 in HandleButtonPress ()
#16 0x2b0a4 in DispatchEvent ()
#17 0x2b108 in HandleEvents ()
#18 0x2eea0 in main ()

-- 
Stuart Anderson  [email-masked]  http://www.srl.caltech.edu/personnel/sba