Subject: Re: fvwm 2.3.8 bugs (Was: Re: FVWM: WindowPlacement)

From: Dan Espen <[email-masked]>
Date: Thu, 07 Oct 1999 15:10:59 -0400

Staffan Hämälä <[email-masked]> writes:
> On Thu, 07 Oct 1999, Dominik Vogt wrote:
> 
> > Can you try if this bug persists with a current development
> > snapshot?  If it does, please describe your setup exactly. What
> > I need to know is which command your 'Restart WM' issues (there
> > are several options) and where exactly your icons and the
> > corresponding windows are placed (desk and page; do the
> > offending windows reach over the page boundaries?)
> 
> I've now downloaded the latest CVS, and am now running it.
> The problem persists. I've also done some testing to see
> exactly when it happens.
> 
> 1. Start X without starting unnecessary programs.
> 2. Start for example an rxvt and iconify it.
> 3. Switch to a virtual screen other than 0.
> 4. Restart windowmanager (I have Restart fvwm2 as a menu choice)
> 5. Voila. The iconified window is gone. It still shows up in
>    WindowList and in FvwmPager though.
> 
> How to get the icons to reappear:
> 
> Either get them to pop up by using WindowList, or:
> 
> 1. Switch to virtual screen number 0
> 2. Restart windowmanager.
> 
> 
> As far as I can see, the icons don't disappear as long as I
> look at screen 0 when I restart the windowmanager.
> 
> I have fvwm set up with eight virtual screens that are all
> the size of the physical screen.
> 
> Hope this helps, because I have absolutely no idea about where
> to start chasing this in the sourcecodes..

I think this thread belongs on fvwm-workers instead of "fvwm".  I
moved it.

Isn't this just another manifestation of the known problem, that is
still pending.  That is, on restart, windows are not restored to their
correct state?

I get another variation, on startup, fvwm completely misses some of my
windows.  Especially the ones that are supposed to be started iconic.
The sit there, opened and undecorated.  A restart clears it up.

> /Staffan
> --

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Staffan Hämälä <[email-masked]>
Date: Fri, 8 Oct 1999 08:06:13 +0200

> I think this thread belongs on fvwm-workers instead of "fvwm".  I

Ok. I'm not on that list (I didn't even know it existed).       

> still pending.  That is, on restart, windows are not restored to their

This didn't happen on 2.2.2.

> The sit there, opened and undecorated.  A restart clears it up.

I don't have any such windows (that are supposed to get opened
automatically), and that is probably why it doesn't happen for
me, so yes it's probably the same bug.
I find it strange that it just happens when I'm not looking at desktop
0 when I do the restart.

/Staffan

---

From: [email-masked] (Paul D. Smith)
Date: 08 Oct 1999 02:45:08 -0400

%% Staffan Hämälä <[email-masked]> writes:

  sh> I find it strange that it just happens when I'm not looking at desktop
  sh> 0 when I do the restart.

You are specifically talking about desktops here, and not pages, right?

If it were pages, I'd suspect the icons are being redrawn, just on page
0 instead of your current page.  That's why they "reappear" when you go
to page 0.

If you really mean desktops--never mind :).

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Staffan Hamala <[email-masked]>
Date: Fri, 8 Oct 1999 09:02:45 +0200

> 0 instead of your current page.  That's why they "reappear" when you go

They don't reappear when I move, but if I look at that desktop (or virtual
screen, or whatever) when I restart fvwm..

When looking in my configfile:

DesktopSize     1x1

Key 1 A M Desk 0 0
Key 2 A M Desk 0 1
Key 3 A M Desk 0 2
Key 4 A M Desk 0 3
Key 5 A M Desk 0 4  
Key 6 A M Desk 0 5  
Key 7 A M Desk 0 6  
Key 8 A M Desk 0 7  

I would guess they are called desktops, but that's only me... =)

/Staffan