Subject: Notification: incoming/490

From: [email-masked]
Date: Sat, 16 Oct 1999 21:20:17 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/490

Message summary for PR#490
	From: [email-masked]
	Subject: FvwmFormGrabServer: StaysOnTop
	Date: Sat, 16 Oct 1999 21:20:15 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 18 Oct 1999 12:16:51 +0200

On Sat, Oct 16, 1999 at 09:20:17PM -0500, [email-masked] wrote:
> >From [email-masked]  Sat Oct 16 21:20:16 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id VAA22075
> 	for <[email-masked]>; Sat, 16 Oct 1999 21:20:15 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Neil Zanella
> Version: 2.3.9
> CVS_Date: 
> OS: Linux 2.0.38
> X_Server: 3.3.2
> Submission from: (NULL) (129.128.88.47)
> 
> 
> Hello,
> 
> Whenever the *FvwmFormGrabServer option is used with FvwmForm, the form
> must
> be made StaysOnTop by default. Otherwise, suppose that I pop up a form and
> some other window pops up in front of it. Then my system will be virtually
> frozen because I will be unable to click on any of the FvwmForm's covered
> buttons.

Um, if this option really does what its name suggests it is impossible
that other windows are mapped while the form is up.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Mon, 18 Oct 1999 20:40:21 -0230 (NDT)

On Mon, 18 Oct 1999, Dominik Vogt wrote:

[...snip...]

> that other windows are mapped while the form is up.

Not true because some applications take very long to start.
As an example is it is possible for me to launch netscape, then
have FvwmFrom come up. Then after the from is up netscape comes up
on top of the form (netscape takes about 15 seconds to appear on my box).

Best Regards,

Neil

---

From: Mark Rainford <[email-masked]>
Date: Tue, 19 Oct 1999 09:34:05 +0100

> on top of the form (netscape takes about 15 seconds to appear on my box).

Well the manual page says that *FvwmFormGrabServer grabs the mouse
pointer, nothing more. It certainly does not prevent new windows from
being mapped, nor does it prevent keyboard input: I can switch desks
while a grab is in effect for my "logout confirmation" dialogue! Because
of this, I have to ensure it is configured to be both in the top layer
AND sticky.

On a related note, my users sometimes find they cannot even click on the
Form's buttons: the grab appears to be in effect but FvwmForm does not
respond to mouse clicks. Killing the FvwmForm process always releases
the grab. On one occasion there were two processes! Unfortunately I have
been unable to reproduce this on demand. Any ideas ?

-- 

Regards,  Mark.