Subject: Re: FvwmGtk patch

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Oct 1999 21:43:34 +0200

On Thu, Sep 30, 1999 at 02:45:37AM +0200, Dominik Vogt wrote:
> On Wed, Sep 29, 1999 at 03:20:18PM -0500, Eric Gillespie, Jr. wrote:
> > I sent a patch like this back in July, but it was never applied. Anyway,
> > all it does is change FvwmGtk's gtk_init to a gnome_init so that GNOME's
> > user preferences will apply to FvwmGtk.
> > 
> > Two autoconf macros are required for this to work; they are included in
> > the attached file gnome.m4.gz which should be uncompressed into the
> > toplevel directory.
> 
> Then I have to ask someone else to apply this.  I'm still completely
> illiterate when it comes down to autoconf :-)  The patch sound
> interesting however.

Or another option: provide a patches for configure.in.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Thu, 7 Oct 1999 19:27:30 -0500

On Sun, Oct 03, 1999 at 09:43:34PM +0200,
> Or another option: provide a patches for configure.in.

It *does* patch configure.in. No knowledge of autoconf is required.

-- 
Eric Gillespie, Jr. <*> [email-masked]

"Man is a rope, tied between beast and overman--a rope over an abyss.
 A dangerous across, a dangerous on-the-way, a dangerous looking-back,
 a dangerous shuddering and stopping."
 --Friedrich Nietzsche
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Thu, 7 Oct 1999 20:07:00 -0500

If someone's going to commit this, you need to use this patch instead. And
the gnome.m4 file is no longer needed, I put the macro in acinclude.m4 so
it's included in the patch. This patch also fixes a bug with Gnome's
session manager starting multiple copies of FvwmGtk.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Oct 1999 13:40:04 +0200

> session manager starting multiple copies of FvwmGtk.

I have applied the path (or better: will have in a few minutes).
One thing I noticed is that it calls a function (gnome_init())
from the fvwm core.  If this is necessary the gnome_init function
must be moved into the libs directory.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Fri, 8 Oct 1999 11:29:01 -0500

On Fri, Oct 08, 1999 at 01:40:04PM +0200,
> must be moved into the libs directory.

I don't understand what you mean. gnome_init is a function provided by
Gnome. Maybe you're confusing it with the GNOME_Init function in
fvwm/gnome.c?

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 9 Oct 1999 14:48:51 +0200

> Gnome. Maybe you're confusing it with the GNOME_Init function in

Yes.

Bye

Dominik ^_^