Subject: libstroke linking error

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Oct 1999 10:49:25 +0200

I just noticed this warning when I compile and link in the
fvwm directory:

  /usr/local/lib/libstroke.so: warning: multiple common of `point'
  events.o: warning: previous common is here

Can someone translate this into human understandable language?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 14 Oct 1999 10:28:44 -0400

%% Dominik Vogt <[email-masked]> writes:

  dv> I just noticed this warning when I compile and link in the
  dv> fvwm directory:

  dv>   /usr/local/lib/libstroke.so: warning: multiple common of `point'
  dv>   events.o: warning: previous common is here

Yikes, that is some _bad_ grammar there :)

It looks like the linker thinks there is a global symbol "point" in both
the libstroke library and in events.o

But I can't find one in events.c, or indeed anywhere else in the fvwm
exe directory.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Oct 1999 04:21:47 +0200

> But I can't find one in events.c, or indeed anywhere else in the fvwm

With 'ld -M events.o' I get:

  Allocating common symbols
  Common symbol       size              file

  ButtonWindow        0x4               events.o
  init_fdset          0x80              events.o
  point               0xc               events.o
  ^^^^^               ^^^

  [snip]

  .bss            0x0804ba80      0x540
   *(.dynbss)
   *(.bss)
   .bss           0x0804ba80       0x19 events.o
   *(COMMON)
   *fill*         0x0804ba99        0x7
   COMMON         0x0804baa0      0x520 events.o
                                    0x0 (size before relaxing)
                  0x0804baa0                ButtonWindow
                  0x0804bac0                init_fdset
                  0x0804bb40                point
                  ^^^^^^^^^^                ^^^^^

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 14 Oct 1999 22:50:50 -0400

>                                     0x0 (size before relaxing)

Did you cut some things out of the common symbol list?
If ButtonWindow is only 4 bytes, did init_fdset get to be 28 bytes beyond
due to some kind of quadruple word alignment?

I tried to figure out what in events.c could be 12 bytes long.
Apparently it is not called "point", unless its thru some macro.
It might be worthwhile looking at the preprocessor output.

It does seem to be sitting right behind "init_fdset" but I'm asking
about you cutting things out of the list, because the compiler doesn't
seem to be laying things out in the order encountered.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Oct 1999 05:10:33 +0200

> Did you cut some things out of the common symbol list?

No. I just omitted the symols after 'point'

> due to some kind of quadruple word alignment?

I've no idea.

> It might be worthwhile looking at the preprocessor output.

I have grep'ed ofer the whole sources in fvwm and libs and there
is only only occurence of the name 'point' in a local constant
variable in Graphics.c.  Although this can hardly be related to
this message, I renamed it, but that didn't help.

> seem to be laying things out in the order encountered.

I've attached the complete output of 'ld -M events.o'.  Note that
I get tons of unresolved symbols on stderr that are not included in
the file (guess that's okay).

Bye

Dominik ^_^