Subject: CVS domivogt: * Fixed several session management bugs.

From: CVS <[email-masked]>
Date: Thu, 14 Oct 1999 03:36:07 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/10/14 03:36:06

Modified files:
	.              : ChangeLog 
	fvwm           : add_window.c builtins.c decorations.c events.c 
	                 fvwm.h gnome.c session.c style.c window_flags.h 
	modules/FvwmPager: FvwmPager.c 

Log message:
* Fixed several session management bugs.
* Styles that have no immediate visual effect can be changed without Recapture
(e.g. Style * ClickToFocus). 'stickyicon/slipperyicon' don't work well yet.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 16 Oct 1999 22:13:21 +0200

On 14 Oct 1999 03:36:07 -0500, CVS wrote:
> Modified file: fvwm/session.c
> 
> Log message:

It is ok to comment 'if (Restarting)' optimization in matchWin().
But your fix in SaveWindowStates() is not good:

  if (XGetGeometry(dpy, ewin->w, &JunkRoot, &JunkX, &JunkY, &JunkWidth,
                   &JunkHeight, &JunkBW, &JunkDepth))
  {
      /* Don't save the state of windows that already died (i.e. modules)!
       */
      continue;
  }

I don't quite sure what this should do, but it just does not save the
state of ALL windows. Please redo this fix.

Also in the next commit you seem to move CloseICCCM2() in Done() too far,
so it is not called when restarting in session manager. I don't know
whether this is ok. (And MoveViewport & RestartInSession can't be swapped.)

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 17 Oct 1999 13:54:41 +0200

> But your fix in SaveWindowStates() is not good:

No, it's not an optimization, it's a bug ;-)

> state of ALL windows. Please redo this fix.

Oops, should have been

  if (!XGetGeometry...
     ^^^

> whether this is ok. (And MoveViewport & RestartInSession can't be swapped.)

Yuck, a function that doesn't return. I'll add it as soon as I
have the code on my disk working again.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]