Subject: [email-masked]

From: [email-masked]
Date: Wed, 13 Oct 1999 11:52:37 -0500 (CDT)

Full_Name: Neil Zanella
Version: 2.3.9
CVS_Date: 
OS: Linux 2.0.38
X_Server: XFree86 3.3.2
Submission from: (NULL) (129.128.88.47)

Restarting causes my StaysOnBottom FvwmButtons to become StaysOnTop.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Oct 1999 05:14:49 +0200

> Restarting causes my StaysOnBottom FvwmButtons to become StaysOnTop.

You should really write mor detailed bug reports than 'it does not work'.
When and how do you set the StaysOnBottom style for FvwmButtons (in
the config file or at run time?) What is the exact line you use?
Are there any other 'StaysOn...' or 'Layer' style lines in your
config file?  With which command do you restart fvwm?  If you send
me your config file I will look at it and see if I can find the
error.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Oct 1999 10:35:42 +0200

On Thu, Oct 14, 1999 at 04:37:33AM -0230, [email-masked] wrote:
> 
> Hi,
> 
> I have been configuring my ~/.fvwm2rc file. I thought the bug had disappeared
> until I lowered my window and restarted fvwm2. Upon restart the buttonboxes
> were placed above my window. I had to click on them for them to get lowered.
> 
> Here is my .fvwm2rc file.

Okay, I see the bug with your config file.  There was a problem in the
session management code (fixed now).

Some comments on your config file:

> AddToFunc ExitFunction "I" KillModule FvwmPager
> +                      "I" KillModule PagerButton
> +                      "I" KillModule FvwmButtons
> +                      "I" KillModule FvwmBacker

You don't need to explicitly kill modules when fvwm exits or restarts.
They can't survive a restart anyway.

> Module FvwmButtons PagerButton
...
> Module FvwmButtons

You shouldn't start modules from the .fvwm2rc file.  The right place to
start them is in your InitFunc and RestartFunc.

Bye

Dominik ^_^

---

From: [email-masked] (Paul D. Smith)
Date: 14 Oct 1999 09:43:14 -0400

>> Module FvwmButtons PagerButton
  dv> ...
  >> Module FvwmButtons

  dv> You shouldn't start modules from the .fvwm2rc file.  The right
  dv> place to start them is in your InitFunc and RestartFunc.

It should be simple to check for this in the parser; I wonder if this is
worth generating a warning about?

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 14 Oct 1999 15:23:09 +0100

> worth generating a warning about?

What is the problem with having modules being started by reading in a
file?  The long pause at startup problem has been fixed for a while now
(fvwm now only waits for modules started by command line arguments to
finish before running InitFunction).

Cheers,
Tim.

---

From: Neil Zanella <[email-masked]>
Date: Thu, 14 Oct 1999 04:37:33 -0230 (NDT)

Hi,

Best Regards,

Neil

> me your config file I will look at it and see if I can find the
# This is a ".fvwm2rc" configuration file for Fvwm Version 2.3.9.
# Best results are obtained when used on a TFT screen with a resolution of
# 800x600 pixels and a color depth of 16 bpp or higher.

# Please note that full functionality of the menus generated by this
# Places where particular packages may be downloaded from are documented
# throughout this configuration file.

#==============================================================================#
# Things to be done when initializing, restarting, and exiting.                #
#==============================================================================#

AddToFunc InitFunction "I" Exec /usr/X11R6/bin/xset b off
# Why is this not working?
#+                      "I" Exec /usr/bin/killall xconsole
# The following line is only good if you run Fvwm locally.
+                      "I" Exec /usr/X11R6/bin/xhost + > /dev/null
+                      "I" Exec /usr/X11R6/bin/xclock -geometry 50x50-0+0 -bw 0
#+                      "I" Exec /usr/X11R6/bin/xterm -geometry 28x3+123+0 -T "Date" -fg white -bg black -cr black -fn fixed +sb +ls -e /bin/sh -c "(echo; /bin/date; /bin/sleep 6)"
+                      "I" Exec /usr/X11R6/bin/xterm -geometry 80x24+123+51 -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls
#+                      "I" Exec /bin/sh -c "(/bin/sleep 3; /usr/X11R6/bin/xterm -geometry 80x24+123+51 -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls)"
+                      "I" Exec /bin/sh -c "if ! [ -e `cd; pwd`/.private ]; then /bin/mkdir `cd; /bin/pwd`/.private; echo hello; fi"

# AddToFunc RestartFunction

# Kill any other modules the user may have invoked.
#+                      "I" KillModule Fvwm*
# Kill clocks, etc...
#+                      "I" Kill *

#==============================================================================#
# Set some global options.                                                     #
#==============================================================================#

# After upgrading from Fvwm 2.0.46 to Fvwm 2.3.9 I had to change
# the ModulePath to reflect my new installation.

ModulePath /usr/local/libexec/fvwm/2.3.9

# After upgrading from Fvwm 2.0.46 to Fvwm 2.3.9 I decided to change the now
# obsoleted IconPath and PixmapPath commands to one single ImagePath command.
# Note that the file "/usr/X11R6/lib/X11/xfm/pixmaps/ghost.xbm" is an actual
# pixmap regardless of the ".xbm" extension. This is what I would consider a
# small bug in xfm 1.3.2. This might get fixed in the next release of xfm.

ImagePath /usr/share/icons:/usr/share/icons/mini:/usr/X11R6/lib/X11/xfm/pixmaps:/usr/X11R6/lib/X11/xfm/bitmaps

#WindowFont lucidasans-bold-12

DeskTopSize 4x4

EdgeResistance 0 0
EdgeScroll 100 100

OpaqueMoveSize 400

ClickTime 125

MenuStyle * TitleWarpOff

#==============================================================================#
# Set some global options.                                                     #
#==============================================================================#

Style *  DecorateTransient

# Default for HandleWidth was and is 7 pixels.
# Default for BorderWidth was 1 pixel and is 0 pixels.

Style * HandleWidth 7
Style * BorderWidth 0

Style * SloppyFocus

ColormapFocus FollowsFocus

#==============================================================================#
# Set some window attributes.                                                  #
#==============================================================================#

# If you have a version of Fvwm2 at least as recent as 2.2.4 then you may
# also enable the StaysOnBottom style option for FvwmButtons.

Style FvwmPager Sticky, NoHandles, NoTitle, ClickToFocus
#Style FvwmPager Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style FvwmButtons Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style PagerButton Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style oclock Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style rclock Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style xclock Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style xbiff Sticky, NoHandles, NoTitle, StaysOnBottom, ClickToFocus
Style xload Sticky, NoHandles, ClickToFocus
Style xman Sticky, NoHandles, NoTitle
Style xcalc StaysOnTop, ClickToFocus
Style xv NoHandles
Style "xv controls" Handles, Sticky
Style UserNet Sticky

Style Netscape Sticky

Style Date NoHandles, NoTitle

Style "Tk Checkers" NoHandles

#==============================================================================#
# Set global window colors and background color.                               #
#==============================================================================#

# DarkCyan and DarkPurple definitely match on a TFT screen.
# A grayish background seems to fit in nicely.

HilightColor Black DarkCyan
Style * Color Black / HoneyDew4

# This produces the same effect as having the command "xsetroot -solid gray"
# in a ".xsession" or ".xinitrc" file.

AddToFunc SetBackground "I" Module FvwmBacker
#+                       "I" KillModule FvwmBacker
*FvwmBackerDesk 0 -solid gray

SetBackground

#==============================================================================#
# Set up the FvwmPager module and its buttonbox.                               #
#==============================================================================#

# There seem to be some problems with the way the background pattern for the
# active page is drawn on the pager so I had to change the lines:
# *PagerButtonGeometry 121x85+0+0
# *FvwmPagerGeometry 115x79+3+3
# *FvwmButtonsGeometry 61x434+0+85
# in the obvious places.

*PagerButtonGeometry 121x84+0+0
*PagerButtonFrame 3
*PagerButtonPadding 0 0
*PagerButtonRows 1
*PagerButtonColumns 1
*PagerButtonBack MediumPurple4
*PagerButton(Swallow FvwmPager "Module FvwmPager 0 0")

*FvwmPagerGeometry 115x78+3+3
*FvwmPagerFont none
*FvwmPagerRows 1
*FvwmPagerColumns 1
*FvwmPagerFore Black
*FvwmPagerBack MediumPurple4
*FvwmPagerHilight NavyBlue
*FvwmPagerSmallFont -schumacher-clean-medium-r-normal--10-100-75-75-*-50-*-*
*FvwmPagerMiniIcons

# No hue of pink seemed to produce the effect I wanted with "*FvwmPagerHilight"
# so I stayed with NavyBlue.

#==============================================================================#
# Set up FvwmButtons as the buttonbox for everything else.                     #
#==============================================================================#

Module FvwmButtons

*FvwmButtonsGeometry 61x434+0+84
*FvwmButtonsRows 7
*FvwmButtonsColumns 1
*FvwmButtonsFrame 3
*FvwmButtonsBack MediumPurple4

*FvwmButtons(Icon penguin.xpm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls", Action (Mouse 2) RemoteXterm, Action (Mouse 3) RemoteSsh)
*FvwmButtons(Icon writeletter.xpm, \
#             Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T Pine -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/checkmail.exp i", \
             Action (Mouse 1) CheckMail
             Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T Pine -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/checkmail.exp c", \
#             Action (Mouse 3) "Exec /usr/X11R6/bin/xterm -T Xbiff -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -iconic -e /usr/local/bin/rxbiff.exp")
# RemoteXBiff              Action (Mouse 3) "Exec /usr/X11R6/bin/xterm -T Xbiff -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -iconic -e /usr/local/bin/rxbiff.exp")

*FvwmButtons(Icon math.xbm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T GAP -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap" Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T GAP -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap", Action (Mouse 3) "Exec /usr/X11R6/bin/xterm -T GAP -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap")
*FvwmButtons(Icon math4.xpm, Action "Exec /usr/X11R6/bin/xcalc -geometry 150x230-0+0")
*FvwmButtons(Icon nscape.xpm, Action (Mouse 1) "Exec /usr/bin/netscape", Action (Mouse 2) "Module FvwmForm BrowserForm", Action (Mouse 3) "Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/lynx")
*FvwmButtons(Icon mini-crosbone.xpm, Action "Exec /usr/X11R6/bin/xkill")
*FvwmButtons(Icon bomb.xpm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T Halt -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /sbin/halt", Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T Reboot -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /sbin/reboot", Action (Mouse 3) Quit)

#==============================================================================#
# Define the menus.                                                            #
#==============================================================================#

AddToMenu Xterms "Xterms"     Title
+                ""           Nop
+                "Local"      Exec /usr/X11R6/bin/xterm -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls
+                ""           Nop
+                "HP"         Popup HP
+                "AIX"        Popup AIX
+                ""           Nop
+                "DEC"        Popup DEC
+                "Sun"        Popup Sun
+                "HP"         Popup HP
+                "IRIX"       Popup IRIX
+                ""           Nop
+                "Linux"      Popup Linux
+                "FreeBSD"    Popup FreeBSD
+                ""           Nop
+                "Other"      Popup Other-Xterms
+                ""           Nop
+                "Root Shell" SuRoot
+                ""           Nop
+                ""           Nop
+                "Utilities"  PopUp Utilities
+                "Exit"       PopUp Exit

AddToMenu Utilities "Utilities"         Title
+                   ""                  Nop
+                   "Window Operations" Popup Window-Operations
+                   ""                  Nop
+                   "Documentation"     Popup Documentation-Utilities
+                   ""                  Nop
+                   "Mathematics"       Popup Mathematics
+                   ""                  Nop
+                   "Network"           Popup Network-Utilities
+                   ""                  Nop
+                   "Programming"       Popup Programming
+                   ""                  Nop
+                   "Graphics"          Popup Graphics
+                   ""                  Nop
+                   "Other"             Popup Other
+                   ""                  Nop
+                   "Connections"       PopUp Connections
+                   ""                  Nop
+                   "System"            PopUp System
+                   ""                  Nop
+                   "Personal"          PopUp Personal
+                   ""                  Nop
+                   ""                  Nop
+                   "Xterms"            Popup Xterms
+                   ""                  Nop
+                   "Exit"              PopUp Exit

AddToMenu Connections "UserNet"           Exec /usr/bin/usernet
+                     "MUN Ethernet"      Exec /usr/local/bin/muneth.exp
#+                     "Dial WST"          Exec /usr/local/bin/dialwst
+                     "Dial WST"          Exec /usr/X11R6/bin/xterm -T "Dial WST" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/dialwst
+                     "Hang Up WST"       Exec /usr/local/bin/hangupwst
+                     "Dial Up"           Exec /usr/X11R6/bin/xterm -T "Dial Up" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /usr/local/bin/dialup.sh
+                     "Hang Up"           Exec /usr/X11R6/bin/xterm -T "Hang Up" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /usr/local/bin/hangup.sh

# The xkeycaps program did not come with the Red Hat 5.2 Powertools bundle.
# It was downloaded from ....... and installed separately.

AddToMenu System "LinuxConf"     Exec /bin/linuxconf
+                "Control Panel" Exec /usr/bin/control-panel
+                "Glint"         Exec /usr/bin/glint
+                ""              Nop
+                "Top"           Exec /usr/X11R6/bin/xterm -geometry 80x80 -T "Top" -fg white -bg black -cr gray84 -fn 5x7 -e /usr/bin/top d 0.20
+                "Xload"         Exec /usr/X11R6/bin/xload -geometry 150x150-8-8 -nolabel -fg black -bg darkred
+                ""              Nop
+                "Xkeycaps"      Exec /usr/X11R6/bin/xkeycaps
+                ""              Nop
+                "Messages"      Exec /usr/X11R6/bin/xterm -T "Messages" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less +G /var/log/messages

AddToMenu Personal "TODO"               Exec /usr/X11R6/bin/xterm -T "TODO" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/TODO)"
+                  "QUESTIONS"          Exec  /usr/X11R6/bin/xterm -T "QUESTIONS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/QUESTIONS)"
+                  "BUGS"          Exec  /usr/X11R6/bin/xterm -T "BUGS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/BUGS)"
+                  "SUGGESTIONS"        Exec  /usr/X11R6/bin/xterm -T "SUGGESTIONS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/SUGGESTIONS)"
+                  "NOTES"            Exec  /usr/X11R6/bin/xterm -T "NOTES" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/NOTES)"
+                  "LINKS"              Exec  /usr/X11R6/bin/xterm -T "LINKS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/LINKS)"
+                  "SCRAP"              Exec  /usr/X11R6/bin/xterm -T "SCRAP" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/SCRAP)"
+                  "BOOKS"              Exec  /usr/X11R6/bin/xterm -T "BOOKS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/BOOKS)"
+                  "TYPOS"          Exec  /usr/X11R6/bin/xterm -T "TYPOS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/TYPOS)"

AddToMenu Other     "Ical"              Exec /usr/bin/ical
+                   ""                  Nop
+                   "Midnight Commander" Exec /usr/bin/mc
+                   "Xfm"               Exec /usr/X11R6/bin/xfm
+                   ""                  Nop
+                   "Oclock"            Exec /usr/X11R6/bin/oclock -geometry 120x120-18-18 -fg black -bg white -jewel white -bd navyblue
+                   "Xmag"              Exec /usr/X11R6/bin/xmag
+                   "Xbiff"             Exec /usr/X11R6/bin/xbiff -geometry -0+0
+                   "Xkill"             Exec /usr/X11R6/bin/xkill
+                   ""                  Nop
+                   "Window List"       WindowList
+                   ""                  Nop
+                   "Xmixer"            Exec /usr/X11R6/bin/xmixer
#+                   "Speak Freely"      Exec /usr/local/speak_freely-6.1e/CONTRIB/xspeakfree-0.7/bin/xspeakfree
+                   "RealPlayer"        Exec /usr/local/rvplayer5.0/rvplayer
+                   ""                  Nop
+                   "Xlock"             Exec /usr/X11R6/bin/xlock

#AddToMenu Network-Utilities "Netscape" Exec /usr/bin/netscape
AddToMenu Network-Utilities "Netscape" Exec /users/math/study1/nzanella/bin/expect/mynetscape
+                           "TiK AIM"  Exec /usr/local/tik/tik.tcl
+                           "Lynx"     Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/lynx
+                           "Pine"     Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/pine
+                           "Ftp"      Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ftp
+                           "XGopher"  Exec /usr/X11R6/bin/xgopher

AddToMenu Exit "Exit" Title
+              ""              Nop
+              "Fvwm Modules"  Popup Fvwm-Modules
+              ""              Nop
+              "Configure"     Exec /usr/X11R6/bin/xterm -T ".fvwm2rc" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(cd; /bin/vi /etc/X11/fvwm2/system.fvwm2rc; /bin/sh -login)"
#+              "Configure"     Exec /usr/X11R6/bin/xterm -T ".fvwm2rc" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(cd; /bin/vi .fvwm2rc; /bin/sh -login)"

+              ""              Nop
+              "Restart Fvwm2" Restart
+              "Other WMs"     Popup Other-WMs
+              "Recapture"     Recapture
+              "Report Bug"    Exec /usr/bin/netscape http://www.fvwm.org/cgi-bin/fvwm-bug
+              ""              Nop
+              "Exit Fvwm2"    Quit

AddToMenu Window-Operations "Window Operations"         Title
+                           ""                          Nop
+                           "Resize"                    Resize
+                           "Move"                      Move
+                           "Raise"                     Raise
+                           "Lower"                     Lower
+                           "(De)Iconify"               Iconify
+                           "(Un)Shade"                 WindowShade
+                           "(Un)Stick"                 Stick
+                           "(Un)Maximize"              Maximize
+                           "(Un)Maximize Vertically"   Maximize 0 100
+                           "(Un)Maximize Horizontally" Maximize 100 0
+                           ""                          Nop
+                           "Close"                     Delete

AddToMenu Documentation-Utilities "TeX" Popup         TeX-DOCS
+                                 "GAP"               Popup GAP-DOCS
+                                 "XPM"               Popup XPM-DOCS
+                                 "Gawk"              Popup Gawk-DOCS
+                                 "Sed"               Exec /usr/X11R6/bin/gv /usr/local/doc/sed.ps
+                                 ""                  Nop 
+                                 "Apache"            Exec /usr/bin/netscape file:/home/httpd/html/manual/index.html
+                                 ""                  Nop 
+                                 "VNC Documents"     Exec /usr/bin/netscape file:/usr/local/doc/vnc/docs.html
+                                 ""                  Nop 
+                                 "HTML"              Popup HTML-DOCS
+                                 "PostgreSQL"        Popup PostgreSQL-DOCS
+                                 ""                  Nop 
+                                 "Xv"                Exec /usr/X11R6/bin/gv /usr/doc/xv-3.10a/xvdocs.ps
+                                 "Xfig (HTML)"       Exec /usr/bin/netscape file:/usr/X11R6/lib/X11/xfig/html/index.html
+                                 "SGML Tools (HTML)" Exec /usr/bin/netscape file:/usr/doc/sgml-tools/html/guide.html
+                                 "CVS"               Popup CVS-DOCS
+                                 "Xforms"            Exec /usr/X11R6/bin/gv /usr/doc/xforms-0.88/forms_sngl.ps.gz
+                                 "F2C"               Exec /usr/X11R6/bin/gv /usr/doc/f2c-19970805/f2c.ps
+                                 "LILO"              Popup LILO-DOCS
+                                 "Pine (HTML)"       Exec /usr/bin/netscape file:/usr/doc/pine-4.04/tech-notes/index.html
+                                 ""                  Nop 
+                                 "FHS"               Exec /usr/X11R6/bin/gv /usr/local/doc/fhs/fhs.ps
+                                 "Linux FAQ"         Exec /usr/X11R6/bin/gv /usr/doc/FAQ/ps/Linux-FAQ.ps.gz
+                                 "PPP FAQ"           Exec /usr/X11R6/bin/gv /usr/doc/FAQ/ps/PPP-FAQ.ps.gz
+                                 ""                  Nop 
+                                 ""                  Nop 
+                                 "Xman"              Exec /usr/X11R6/bin/xman -geometry +0+0
+                                 ""                  Nop 
+                                 "XBanner (HTML)"    Exec /usr/bin/netscape file:/usr/doc/xbanner-1.31/index.html

AddToMenu TeX-DOCS "The TeX Directory Structure (TDS)"  Exec /usr/bin/xdvi /usr/share/texmf/doc/help/tds.dvi
+                  "The TeX Catalogue Online (HTML)"    Exec /usr/bin/netscape file:/usr/share/texmf/doc/help/Catalogue/catalogue.html
+                  "AmS-LaTeX User's Guide"             Exec /usr/bin/xdvi /usr/share/texmf/doc/ams/amslatex/amsldoc.dvi
+                  "The TeX System (HTML)"              Exec /usr/bin/netscape file:/usr/share/texmf/doc/helpindex.html
+                  "LaTeX 2e Help (HTML)"               Exec /usr/bin/netscape file:/usr/share/texmf/doc/latex/latex2e-html/index.html
+                  "The teTeX Document"                 Exec /usr/bin/xdvi /usr/share/texmf/doc/tetex/TETEXDOC.dvi
+                  "The teTeX Guide"                    Exec /usr/bin/netscape file:/usr/share/texmf/doc/newhelpindex.html
+                  "The teTeX FAQ"                      Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/share/texmf/doc/tetex/teTeX-FAQ
+                  ""                                   Nop
+                  "Array"                              Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/tools/array.dvi
+                  "Multicolumn"                        Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/tools/multicol.dvi

AddToMenu GAP-DOCS "GAP Manual (HTML)"      Exec /usr/bin/netscape file:/usr/local/lib/gap3r4p5/htm/index.htm
+                  "GAP Tutorial"           Exec /usr/X11R6/bin/ghostview /usr/local/lib/gap4b5/doc/tut/manual.ps
+                  "GAP Reference Manual"   Exec /usr/X11R6/bin/ghostview /usr/local/lib/gap4b5/doc/ref/manual.ps
+                  "GAP Programming Manual" Exec /usr/X11R6/bin/ghostview /usr/local/lib/gap4b5/doc/prg/manual.ps
+                  "Extending GAP"          Exec /usr/X11R6/bin/ghostview /usr/local/lib/gap4b5/doc/ext/manual.ps

AddToMenu XPM-DOCS "XPM 3 Paper"            Exec /usr/X11R6/bin/ghostview /usr/local/doc/xpm-3-paper.ps
+                  "XPM Tutorial"           Exec /usr/X11R6/bin/ghostview /usr/doc/xpm-devel-3.4j/xpm-tutorial.PS.gz
+                  "XPM Document"           Exec /usr/X11R6/bin/ghostview /usr/doc/xpm-devel-3.4j/xpm-doc-A4.PS.gz
+                  "XPM FAQ"                Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/doc/xpm-devel-3.4j/xpm.FAQ

AddToMenu Gawk-DOCS "Gawk Book"              Exec /usr/X11R6/bin/ghostview /usr/doc/gawk-3.0.3/gawk.ps
+                   "Awk Card"               Exec /usr/X11R6/bin/ghostview /usr/doc/gawk-3.0.3/awkcard.ps
+                   "Note on POSIX Standard" Exec /usr/X11R6/bin/xterm -T "POSIX.STD" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/doc/gawk-3.0.3/POSIX.STD

AddToMenu HTML-DOCS "HTML 4.0 Specification" Exec /usr/bin/xpdf /usr/local/doc/html40.pdf

AddToMenu PostgreSQL-DOCS "PostgreSQL"            Exec /usr/bin/netscape file:/usr/doc/postgresql-6.3.2/postgres/index.html
+                         "Tutorial"              Exec /usr/X11R6/bin/gv /usr/doc/postgresql-6.3.2/tutorial.ps.gz
+                         "User's Guide"          Exec /usr/X11R6/bin/gv /usr/doc/postgresql-6.3.2/user.ps.gz
+                         "Programmer's Guide"    Exec /usr/X11R6/bin/gv /usr/doc/postgresql-6.3.2/programmer.ps.gz
+                         "Administrator's Guide" Exec /usr/X11R6/bin/gv /usr/doc/postgresql-6.3.2/programmer.ps.gz
+                         "FAQ"                   Exec /usr/X11R6/bin/xterm -T "PostgreSQL FAQ" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/doc/postgresql-6.3.2/FAQ
+                         ""                      Nop
+                         "Database HOWTO"        Exec /usr/bin/netscape /usr/doc/postgresql-6.3.2/howto/Database-HOWTO.html

AddToMenu LILO-DOCS "User Guide"      Exec /usr/X11R6/bin/gv /usr/doc/lilo-0.20/doc/User_Guide.ps
+                   "Technical Guide" Exec /usr/X11R6/bin/gv /usr/doc/lilo-0.20/doc/Technical_Guide.ps

AddToMenu CVS-DOCS "CVS"        Exec /usr/X11R6/bin/gv /usr/doc/cvs-1.10.2/cvs.ps
+                  "CVS Paper"  Exec /usr/X11R6/bin/gv /usr/doc/cvs-1.10.2/cvs-paper.ps
+                  "CVS Client" Exec /usr/X11R6/bin/gv /usr/doc/cvs-1.10.2/cvsclient.ps
+                  "CVS FAQ"    Exec /usr/X11R6/bin/xterm -T "CVS FAQ" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/doc/cvs-1.10.2/FAQ

AddToMenu Mathematics "GAP"   Exec /usr/X11R6/bin/xterm -geometry +0+0 -T "GAP" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap
+                     "XCalc" Exec /usr/X11R6/bin/xcalc -geometry 150x230-0+0

AddToMenu Programming "Xxgdb"             Exec /usr/X11R6/bin/xxgdb
+                     "Editres"           Exec /usr/X11R6/bin/editres
+                     "Xev"               Exec /usr/X11R6/bin/xterm -T "X Event Tester" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/X11R6/bin/xev

AddToMenu Graphics "Xv"            Exec /usr/X11R6/bin/xv
+                  "Gimp"          Exec /usr/bin/gimp
+                  "Xpaint"        Exec /usr/X11R6/bin/xterm -T "Xpaint Message" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -iconic -e /usr/X11R6/bin/xpaint
+                  "Xfpovray"      Exec /usr/X11R6/bin/xfpovray
+                  "Electric Eyes" Exec /usr/bin/ee
+                  "Bitmap"        Exec /usr/X11R6/bin/bitmap
+                  ""              Nop
+                  "Cursors"       Popup Cursors
+                  "Fonts"         Popup Fonts
+                  "Colors"        Popup Colors
+                  "Backgrounds"   Popup Backgrounds

# The xcolorsel program did not come with Red Hat 5.2. It was downloaded as
# <ftp://tsx-11.mit.edu/pub/linux/sources/usr.bin.X11/xcolorsel-1.1a.tar.gz>
# and installed separately.

AddToMenu Colors "Xcolorsel" Exec /usr/X11R6/bin/xcolorsel
+                "Tcolor Demo" Exec /usr/lib/tk8.0/demos/tcolor
+                "ShowRGB" Exec /usr/X11R6/bin/xterm -T "ShowRGB" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(/usr/X11R6/bin/showrgb | /usr/bin/less)"
+                "XCMap"    Exec /usr/X11R6/bin/xcmap

# An awk script here would probably do much better.
AddToMenu Cursors "cursorfont.h" Exec /usr/X11R6/bin/xterm -T "cursorfont.h" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/include/X11/cursorfont.h
+               "Xfd" Exec /usr/X11R6/bin/xfd -fn cursor -center

AddToMenu Fonts "Xlsfonts" Exec /usr/X11R6/bin/xterm -T "Xlsfonts" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(/usr/X11R6/bin/xlsfonts | /usr/bin/less)"
+               "Xfontsel" Exec /usr/X11R6/bin/xfontsel

AddToMenu Backgrounds "Default"       Exec /usr/X11R6/bin/xsetroot -solid gray
+                     "Midnight Blue" Exec /usr/X11R6/bin/xsetroot -solid midnightblue
+                     "With Gradient" Exec /bin/sh -c "(/usr/X11R6/bin/bggen red green blue | /usr/X11R6/bin/xv -root -quit -)"
+                     "Other Colors" OtherColors

AddToFunc OtherColors "I" HilightColor Black BlueViolet
+                     "I" Style * Color Black/Brown4
+                     "I" Recapture

AddToMenu Shells "Shells" Title
+                "Ash"    Exec /usr/X11R6/bin/xterm -e /bin/ash
+                "Bash"   Exec /usr/X11R6/bin/xterm -e /bin/bash
+                "Ksh"    Exec /usr/X11R6/bin/xterm -e /bin/ksh
+                "Tcsh"   Exec /usr/X11R6/bin/xterm -e /bin/tcsh
+                "Zsh"    Exec /usr/X11R6/bin/xterm -e /bin/zsh

# Functionality for restarting other window managers from fvwm2 might be
# added in future releases.
AddToMenu Other-WMs "Other WMs"    Title
+                   "Twm"    Restart /usr/X11R6/bin/twm -f /etc/X11/twm/system.twmrc
+                   "Mwm"    Restart /usr/X11R6/bin/mwm -f /etc/X11/mwm/system.mwmrc
+                   "Fvwm"   Restart /usr/X11R6/bin/fvwm -f /etc/X11/fvwm/system.fvwmrc
+                   "Wmaker" Restart /usr/X11R6/bin/wmaker

AddToMenu Fvwm-Modules "Fvwm Modules" Title
+                      "FvwmAudio"    Module FvwmAudio
+                      "FvwmAuto"     Module FvwmAuto 465
+                      "FvwmBacker"   Module FvwmBacker
+                      "FvwmBanner"   Module FvwmBanner
+                      "FvwmButtons"  Module FvwmButtons SomeButtons
#+                      "FvwmCascade"
+                      "FvwmCommand"
#+                      "FvwmConfig"
#+                      "FvwmConsole"
##+                     "FvwmConsoleC"
#+                      "FvwmConsoleC.pl"
#+                      "FvwmCpp"
#+                      "FvwmDebug"
#+                      "FvwmForm"
#+                      "FvwmGoodStuff"
#+                      "FvwmIconBox"
#+                      "FvwmIconMan"
+                      "FvwmIdent"     Module FvwmIdent
#+                      "FvwmM4"
#+                      "FvwmPager"
#+                      "FvwmPipe"
#+                      "FvwmSave"
#+                      "FvwmSaveDesk"
#+                      "FvwmScript"
+                       "FvwmScroll"   Module FvwmScroll
+                       "FvwmTalk"     Module FvwmTalk
#+                      "FvwmTaskBar"
+                       "FvwmTile"     Module FvwmTile
#+                      "FvwmWharf"
#+                      "FvwmWinList"

#==============================================================================#
# Define some common functions.                                                #
#==============================================================================#

AddToFunc Raise-and-Move "M" Raise
+                        "M" Move
+                        "C" Raise

AddToFunc Lower-and-Move "M" Lower
+                        "M" Move
+                        "C" RaiseLower

AddToFunc Move-or-WindowShade "M" Move
+                             "C" WindowShade

#==============================================================================#
# Set up mouse and keyboard bindings.                                          #
#==============================================================================#

Mouse 1 R N Menu Xterms
Mouse 2 R N Menu Utilities
Mouse 3 R N Menu Exit

Mouse 1 R C Popup Shells
Mouse 2 R C Popup Fvwm-Modules
Mouse 3 R C Popup Window-Operations

Mouse 1 I N Move
Mouse 2 I N Stick
Mouse 3 I N Iconify

Mouse 0 F  N Resize
Mouse 1 TS N Raise-and-Move
Mouse 2 TS N Lower-and-Move
Mouse 3 S  N Resize
Mouse 3 T  N Move-or-WindowShade

Mouse 0 1 N Popup Window-Operations
Mouse 0 3 N Stick
Mouse 1 4 N Maximize 0 100
Mouse 2 4 N Maximize
Mouse 3 4 N Maximize 100 0
Mouse 1 2 N Module FvwmAuto 465
Mouse 2 2 N KillModule FvwmAuto
Mouse 3 2 N Iconify

Key h A M Scroll -100  0
Key j A M Scroll  0  100
Key k A M Scroll  0 -100
Key l A M Scroll  100  0

Key h A CM Scroll -25  0
Key j A CM Scroll  0  25
Key k A CM Scroll  0 -25
Key l A CM Scroll  25  0

Key h A SCM Scroll -1  0
Key j A SCM Scroll  0  1
Key k A SCM Scroll  0 -1
Key l A SCM Scroll  1  0

Key F1 A N PopUp Xterms
Key F2 A N PopUp Utilities
Key F3 A N PopUp Exit
Key F4 A N Exec /usr/X11R6/bin/xterm -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls
Key F4 A N PopUp Window-Operations

Key x A CM Exec /usr/X11R6/bin/xterm -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls

#==============================================================================#
#==============================================================================#

AddToMenu Linux "Birds"   Popup Linux-Birds
+               "Trees"   Popup Linux-Trees
+               "Society" Popup Linux-Society

AddToMenu Linux-Birds "Albatros"  Exec /usr/X11R6/bin/xterm -T Albatros  -fg white -bg black -cr gray84 -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.210
+                     "Auk"       Exec /usr/X11R6/bin/xterm -T Auk       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.211
+                     "Bittern"   Exec /usr/X11R6/bin/xterm -T Bittern   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.212
+                     "Bunting"   Exec /usr/X11R6/bin/xterm -T Bunting   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.213
+                     ""          Nop
+                     "Cardinal"  Exec /usr/X11R6/bin/xterm -T Cardinal  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.214
+                     "Crow"      Exec /usr/X11R6/bin/xterm -T Crow      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.215
+                     "Darter"    Exec /usr/X11R6/bin/xterm -T Darter    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.216
+                     "Dove"      Exec /usr/X11R6/bin/xterm -T Dove      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.217
+                     ""          Nop
+                     "Eagle"     Exec /usr/X11R6/bin/xterm -T Eagle     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.218
+                     "Eider"     Exec /usr/X11R6/bin/xterm -T Eider     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.219
+                     "Finch"     Exec /usr/X11R6/bin/xterm -T Finch     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.220
+                     "Flicker"   Exec /usr/X11R6/bin/xterm -T Flicker   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.221
+                     ""          Nop
+                     "Grebe"     Exec /usr/X11R6/bin/xterm -T Grebe     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.222
+                     "Grouse"    Exec /usr/X11R6/bin/xterm -T Grouse    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.223
+                     "Hawk"      Exec /usr/X11R6/bin/xterm -T Hawk      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.224
+                     "Heron"     Exec /usr/X11R6/bin/xterm -T Heron     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.225
+                     ""          Nop
+                     "Ibis"      Exec /usr/X11R6/bin/xterm -T Ibis      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.226
+                     "Jay"       Exec /usr/X11R6/bin/xterm -T Jay       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.227
+                     "Junco"     Exec /usr/X11R6/bin/xterm -T Junco     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.228
+                     "Kestrel"   Exec /usr/X11R6/bin/xterm -T Kestrel   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.229
+                     ""          Nop
+                     "Kite"      Exec /usr/X11R6/bin/xterm -T Kite      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.230
+                     "Lark"      Exec /usr/X11R6/bin/xterm -T Lark      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.231
+                     "Loon"      Exec /usr/X11R6/bin/xterm -T Loon      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.232
+                     "Mallard"   Exec /usr/X11R6/bin/xterm -T Mallard   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.233
+                     ""          Nop
+                     "Murre"     Exec /usr/X11R6/bin/xterm -T Murre     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.234
+                     "Nuthatch"  Exec /usr/X11R6/bin/xterm -T Nuthatch  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.235
+                     "Osprey"    Exec /usr/X11R6/bin/xterm -T Osprey    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.237
+                     "Owl"       Exec /usr/X11R6/bin/xterm -T Owl       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.236
+                     ""          Nop
+                     "Ptarmigan" Exec /usr/X11R6/bin/xterm -T Ptarmigan -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.239
+                     "Puffin"    Exec /usr/X11R6/bin/xterm -T Puffin    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.238
+                     "Quail"     Exec /usr/X11R6/bin/xterm -T Quail     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.240
+                     ""          Nop
+                     "Raven"     Exec /usr/X11R6/bin/xterm -T Raven     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.241
+                     "Robin"     Exec /usr/X11R6/bin/xterm -T Robin     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.242
+                     "Swan"      Exec /usr/X11R6/bin/xterm -T Swan      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.243
+                     "Swallow"   Exec /usr/X11R6/bin/xterm -T Swallow   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.244
#+                    ""          Nop
#+                    "Tern"      Exec /usr/X11R6/bin/xterm -T Tern      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.245
#+                    "Thrush"    Exec /usr/X11R6/bin/xterm -T Thrush    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.246
#+                    "Vireo"     Exec /usr/X11R6/bin/xterm -T Vireo     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.247
#+                    "Warbler"   Exec /usr/X11R6/bin/xterm -T Warbler   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.248
#+                    "Wren"      Exec /usr/X11R6/bin/xterm -T Wren      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.249

AddToMenu Linux-Trees "Ash"       Exec /usr/X11R6/bin/xterm -T Ash       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.150
+                     "Aspen"     Exec /usr/X11R6/bin/xterm -T Aspen     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.151
#+                    "Beech"     Exec /usr/X11R6/bin/xterm -T Beech     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.152
+                     "Birch"     Exec /usr/X11R6/bin/xterm -T Birch     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.153
+                     "Bonsai"    Exec /usr/X11R6/bin/xterm -T Bonsai    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.154
+                     "Cedar"     Exec /usr/X11R6/bin/xterm -T Cedar     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.155
+                     "Chesnut"   Exec /usr/X11R6/bin/xterm -T Chesnut   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.156
+                     "Dogberry"  Exec /usr/X11R6/bin/xterm -T Dogberry  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.157
+                     ""          Nop
+                     "Elm"       Exec /usr/X11R6/bin/xterm -T Elm       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.158
+                     "Fir"       Exec /usr/X11R6/bin/xterm -T Fir       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.159
+                     "Gum"       Exec /usr/X11R6/bin/xterm -T Gum       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.160
+                     "Hazel"     Exec /usr/X11R6/bin/xterm -T Hazel     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.161
+                     "Hemlock"   Exec /usr/X11R6/bin/xterm -T Hemlock   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.162
+                     "Hickory"   Exec /usr/X11R6/bin/xterm -T Hickory   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.163
+                     "Inkwood"   Exec /usr/X11R6/bin/xterm -T Inkwood   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.164
+                     "Ironwood"  Exec /usr/X11R6/bin/xterm -T Ironwood  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.165
+                     ""          Nop
+                     "Josha"     Exec /usr/X11R6/bin/xterm -T Josha     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.166
+                     "Juniper"   Exec /usr/X11R6/bin/xterm -T Juniper   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.167
+                     "Larch"     Exec /usr/X11R6/bin/xterm -T Larch     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.168
+                     "Linden"    Exec /usr/X11R6/bin/xterm -T Linden    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.169
+                     "Magnolia"  Exec /usr/X11R6/bin/xterm -T Magnolia  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.170
+                     "Mahogany"  Exec /usr/X11R6/bin/xterm -T Mahogany  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.171
+                     "Nutmeg"    Exec /usr/X11R6/bin/xterm -T Nutmeg    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.172
+                     "Oak"       Exec /usr/X11R6/bin/xterm -T Oak       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.173
+                     ""          Nop
+                     "Olive"     Exec /usr/X11R6/bin/xterm -T Olive     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.174
+                     "Pine"      Exec /usr/X11R6/bin/xterm -T Pine      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.175
+                     "Plum"      Exec /usr/X11R6/bin/xterm -T Plum      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.176
+                     "Poplar"    Exec /usr/X11R6/bin/xterm -T Poplar    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.177
+                     "Redwood"   Exec /usr/X11R6/bin/xterm -T Redwood   -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.178
+                     "Rowan"     Exec /usr/X11R6/bin/xterm -T Rowan     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.179
+                     "Spruce"    Exec /usr/X11R6/bin/xterm -T Spruce    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.180
+                     "Sumac"     Exec /usr/X11R6/bin/xterm -T Sumac     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.181
+                     ""          Nop
+                     "Tamarack"  Exec /usr/X11R6/bin/xterm -T Tamarack  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.182
+                     "Teak"      Exec /usr/X11R6/bin/xterm -T Teak      -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.183
+                     "Umbrella"  Exec /usr/X11R6/bin/xterm -T Umbrella  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.184
+                     "Walnut"    Exec /usr/X11R6/bin/xterm -T Walnut    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.185
+                     "Willow"    Exec /usr/X11R6/bin/xterm -T Willow    -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.186
+                     "Yew"       Exec /usr/X11R6/bin/xterm -T Yew       -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.187
+                     "Yucca"     Exec /usr/X11R6/bin/xterm -T Yucca     -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.188
+                     "Zebrawood" Exec /usr/X11R6/bin/xterm -T Zebrawood -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.189

AddToMenu Linux-Society "Lewis" Exec /usr/X11R6/bin/xterm -T Lewis -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.17.71
+                       "Weyl"  Exec /usr/X11R6/bin/xterm -T Weyl  -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.17.60

AddToMenu FreeBSD "Fermat"   Exec /usr/X11R6/bin/xterm -T Fermat   -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.17.78
+                 "Ganymede" Exec /usr/X11R6/bin/xterm -T Ganymede -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.39.1
+                 "Europa"   Exec /usr/X11R6/bin/xterm -T Europa   -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.39.2
+                 "Phobos"   Exec /usr/X11R6/bin/xterm -T Phobos   -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.1.3
+                 "Lyman"    Exec /usr/X11R6/bin/xterm -T Lyman    -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.1.14
+                 "Hibernia" Exec /usr/X11R6/bin/xterm -T Hibernia -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.17.5
+                 ""         Nop
+                 "Places"   Popup FreeBSD-Places

AddToMenu Sun "Maple"    Exec /usr/X11R6/bin/xterm -T Maple   -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.1.12 
+             "Mercury"  Exec /usr/X11R6/bin/xterm -T Mercury -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.1.130

AddToMenu DEC "Garfield" Exec /usr/X11R6/bin/xterm -T Garfield -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.1.1
+             "Riemann"  Exec /usr/X11R6/bin/xterm -T Riemann  -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.1.200
+             ""         Nop
+             "Plato"    Exec /usr/X11R6/bin/xterm -T Plato    -fg white -bg black -cr gray84 -fn fixed -sb -sl 5000 +vb -ls -e /usr/bin/ssh 134.153.2.151

AddToMenu IRIX "Orca" Exec /usr/X11R6/bin/xterm -T Orca -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 134.153.193.4

AddToMenu HP "Vega" Exec /usr/X11R6/bin/xterm -T "Vega" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.88.12

AddToMenu AIX "GPU 1" Exec /usr/X11R6/bin/xterm -T "GPU 1" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.125.10
+             "GPU 2" Exec /usr/X11R6/bin/xterm -T "GPU 2" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.125.12
+             "GPU 3" Exec /usr/X11R6/bin/xterm -T "GPU 3" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.125.13
+             "GPU 4" Exec /usr/X11R6/bin/xterm -T "GPU 4" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.125.18
+             "GPU 5" Exec /usr/X11R6/bin/xterm -T "GPU 5" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/ssh 129.128.125.19

AddToMenu Other-Xterms "MUN Unicorn" Exec /usr/X11R6/bin/xterm -T "MUN Unicorn" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/unicorn.exp

AddToMenu FreeBSD-Places "Deerlake" Exec /usr/X11R6/bin/xterm -T "Deerlake" -e /usr/bin/rsh 134.153.17.181
+                        "Cape"     Exec /usr/X11R6/bin/xterm -T "Cape"     -e /usr/bin/rsh 134.153.17.180
+                        "Mahers"   Exec /usr/X11R6/bin/xterm -T "Mahers"   -e /usr/bin/rsh 134.153.17.179
+                        "Manuels"  Exec /usr/X11R6/bin/xterm -T "Manuels"  -e /usr/bin/rsh 134.153.17.178
+                        ""         Nop
+                        "Kilbride" Exec /usr/X11R6/bin/xterm -T "Kilbride" -e /usr/bin/rsh 134.153.17.177
+                        "Topsail"  Exec /usr/X11R6/bin/xterm -T "Topsail"  -e /usr/bin/rsh 134.153.17.176
+                        "Bellevue" Exec /usr/X11R6/bin/xterm -T "Bellevue" -e /usr/bin/rsh 134.153.17.175
+                        "Catalina" Exec /usr/X11R6/bin/xterm -T "Catalina" -e /usr/bin/rsh 134.153.17.174
+                        ""         Nop
+                        "Colinet"  Exec /usr/X11R6/bin/xterm -T "Colinet"  -e /usr/bin/rsh 134.153.17.173
+                        "Tilton"   Exec /usr/X11R6/bin/xterm -T "Tilton"   -e /usr/bin/rsh 134.153.17.172
+                        "Rushoon"  Exec /usr/X11R6/bin/xterm -T "Rushoon"  -e /usr/bin/rsh 134.153.17.171
+                        "Burin"    Exec /usr/X11R6/bin/xterm -T "Burin"    -e /usr/bin/rsh 134.153.17.170
+                        ""         Nop
+                        "Gambo"    Exec /usr/X11R6/bin/xterm -T "Gambo"    -e /usr/bin/rsh 134.153.17.169
+                        "Brigus"   Exec /usr/X11R6/bin/xterm -T "Brigus"   -e /usr/bin/rsh 134.153.17.168
+                        "Fortune"  Exec /usr/X11R6/bin/xterm -T "Fortune"  -e /usr/bin/rsh 134.153.17.167
+                        "Dunville" Exec /usr/X11R6/bin/xterm -T "Dunville" -e /usr/bin/rsh 134.153.17.166
+                        ""         Nop
+                        ""         Nop
+                        "Gander"   Exec /usr/X11R6/bin/xterm -T "Gander"   -e /usr/bin/rsh 134.153.17.165
+                        "Colliers" Exec /usr/X11R6/bin/xterm -T "Colliers" -e /usr/bin/rsh 134.153.17.164
+                        "Lumsden"  Exec /usr/X11R6/bin/xterm -T "Lumsden"  -e /usr/bin/rsh 134.153.17.163
+                        "Lamaline" Exec /usr/X11R6/bin/xterm -T "Lamaline" -e /usr/bin/rsh 134.153.17.162
+                        ""         Nop
+                        "Foxtrap"  Exec /usr/X11R6/bin/xterm -T "Foxtrap"  -e /usr/bin/rsh 134.153.17.161
+                        "Argentia" Exec /usr/X11R6/bin/xterm -T "Argentia" -e /usr/bin/rsh 134.153.17.160
+                        "Calvert"  Exec /usr/X11R6/bin/xterm -T "Calvert"  -e /usr/bin/rsh 134.153.17.159
+                        "Torbay"   Exec /usr/X11R6/bin/xterm -T "Torbay"   -e /usr/bin/rsh 134.153.17.158
+                        ""         Nop
+                        "Renews"   Exec /usr/X11R6/bin/xterm -T "Renews"   -e /usr/bin/rsh 134.153.17.157
+                        "Paradise" Exec /usr/X11R6/bin/xterm -T "Paradise" -e /usr/bin/rsh 134.153.17.156
+                        "Newtown"  Exec /usr/X11R6/bin/xterm -T "Newtown"  -e /usr/bin/rsh 134.153.17.155
+                        "Holyrood" Exec /usr/X11R6/bin/xterm -T "Holyrood" -e /usr/bin/rsh 134.153.17.154
+                        ""         Nop
+                        "Goulds"   Exec /usr/X11R6/bin/xterm -T "Goulds"   -e /usr/bin/rsh 134.153.17.153
+                        "Fermeuse" Exec /usr/X11R6/bin/xterm -T "Fermeuse" -e /usr/bin/rsh 134.153.17.152
+                        "Branch"   Exec /usr/X11R6/bin/xterm -T "Branch"   -e /usr/bin/rsh 134.153.17.151
+                        "Cupids"   Exec /usr/X11R6/bin/xterm -T "Cupids"   -e /usr/bin/rsh 134.153.17.150

#=============================================================================================================================#
# Some diagrams.                                                                                                              #
#=============================================================================================================================#

#
#   Schematic  Diagram  of  Room  EN2036
#
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#   |               .               .               .               |                               |               .               .               .               |
#   |   albatros    .   auk         .   bittern     .   bunting     |                               |   cardinal    .   crow        .   darter      .   dove        |
#   |               .               .               .               |                               |               .               .               .               |
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#     134.153.1.210   134.153.1.211   134.153.1.212   134.153.1.213                                   134.153.1.214   134.153.1.215   134.153.1.216   134.153.1.217
#
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#   |               .               .               .               |                               |               .               .               .               |
#   |   eagle       .   eider       .   finch       .   flicker     |                               |   grebe       .   grouse      .   hawk        .   heron       |
#   |               .               .               .               |                               |               .               .               .               |
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#     134.153.1.218   134.153.1.219   134.153.1.220   134.153.1.221                                   134.153.1.222   134.153.1.223   134.153.1.224   134.153.1.225
#
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#   |               .               .               .               |                               |               .               .               .               |
#   |   ibis        .   jay         .   junco       .   kestrel     |                               |   kite        .   lark        .   loon        .   mallard     |
#   |               .               .               .               |                               |               .               .               .               |
#   +---------------------------------------------------------------+                               +---------------------------------------------------------------+
#     134.153.1.226   134.153.1.227   134.153.1.228   134.153.1.229                                   134.153.1.230   134.153.1.231   134.153.1.232   134.153.1.233
#
#
#   +---------------------------------------------------------------+                               +-----------------------------------------------+
#   |               .               .               .               |                               |               .               .               |
#   |   murre       .   nuthatch    .   osprey      .   owl         |                               |   ptarmigan   .   puffin      .   quail       |
#   |               .               .               .               |                               |               .               .               |
#   +---------------------------------------------------------------+                               +-----------------------------------------------+
#     134.153.1.234   134.153.1.235   134.153.1.237   134.153.1.236                                   134.153.1.238   134.153.1.239   134.153.1.240
#
#
#   +---------------------------------------------------------------+
#   |               .               .               .               |
#   |   raven       .   robin       .   swan        .   swallow     |
#   |               .               .               .               |
#   +---------------------------------------------------------------+
#     134.153.1.241   134.153.1.242   134.153.1.243   134.153.1.244
#

#==============================================================================#
# I left these here just so that you can try them out but perhaps it's really  #
# best to delete this section entirely.                                        #
#==============================================================================#

*FvwmBannerTimeout 3

# FvwmWharf uses more memory than FvwmButtons so I took this out.
#Module FvwmWharf
#*FvwmWharf xterm penguin.xpm Exec /usr/X11R6/bin/xterm
# darkred
# red3

# *FvwmBackerDesk 0 -solid chartreuse3
# *FvwmBackerDesk 1 -solid MediumVioletRed
# chocolate4

# *FvwmBackerDesk 0 -solid chartreuse3
# *FvwmBackerDesk 1 -solid MediumVioletRed
# chocolate4

#*FvwmBannerPixmap world.xpm
#*FvwmBannerTimeout 1

*SomeButtonsGeometry -0-80
*SomeButtonsRows 9
*SomeButtonsColumns 1
*SomeButtons(Icon penguin.xpm,  Action "Exec /usr/X11R6/bin/xterm")
*SomeButtons(Icon writeletter.xpm, Action "Exec /usr/X11R6/bin/xterm -e /usr/bin/pine")
*SomeButtons(Icon math.xbm, Action "Exec /usr/X11R6/bin/xterm -T GAP -e /usr/local/bin/gap")
*SomeButtons(Icon math4.xpm, Action "Exec /usr/X11R6/bin/xcalc -geometry 150x230-0+0")
*SomeButtons(Icon nscape.xpm, Action "Exec /usr/bin/netscape")
*SomeButtons(Icon rlogin.xpm,  Action "Exec /usr/X11R6/bin/xterm")
*SomeButtons(Action "Exec /usr/X11R6/bin/xkill")
*SomeButtons(Icon bomb.xpm, Action Quit)

# AddToDecor Black-Border
# + HilightColor Black Black
# Style FvwmButtons UseStyle Black-Border

#EdgeResistance 50 45
#EdgeScroll 100000 100000
#EdgeResistance 30 45
#EdgeScroll 25 25
#Module FvwmBacker
#*FvwmBackerDesk 1 "EdgeResistance 0 45"
#*FvwmBackerDesk 1 "EdgeScroll 1 1"

# Use this on river instead.
#*FvwmPagerDeskTopScale 29
#*FvwmPagerGeometry 105x81+0+0

#*FvwmPagerDeskTopScale 24
#*FvwmPagerGeometry +0+0
#*FvwmPagerGeometry 105x79+0+0
#*FvwmPagerGeometry 105x79+0+0
#*FvwmPagerGeometry 105x81+0+0
#*FvwmPagerBack MediumPurple
#*FvwmPagerBack darkviolet
#*FvwmPagerBack blueviolet
#*FvwmPagerStartIconic
#*FvwmPagerIconGeometry 1010x200+0+0
*FvwmPagerLabel 0 First Desktop
#*FvwmPagerLabel 1 Second Desktop
#*FvwmPagerDeskColor 1 MediumPurple3
#*FvwmButtons(Swallow(UseOld) "xload" 'Exec xterm)
#*FvwmButtons( Swallow(UseOld) "xload" 'Exec xload -nolabel -hl black -bg darkred -geometry -1500-1500 &')

#*FvwmButtons(Icon rlogin.xpm, Action "Exec /usr/X11R6/bin/xterm -e /usr/bin/ftp")
#*FvwmButtons(Icon xman.xpm, Action "Exec /usr/X11R6/bin/xman -geometry +0+0")
#*FvwmButtonsGeometry +0+78
#*FvwmButtonsGeometry 56x421+0+78
#*FvwmButtonsGeometry 57x429+0+78
#*FvwmPagerGeometry 111x74+2+2
#*FvwmButtonsGeometry 58x436+0+78
#*FvwmButtonsGeometry 58x436+0+78
#Style FvwmPager Sticky, NoHandles, NoTitle, ClickToFocus, WindowListSkip
#Style FvwmButtons Sticky, NoHandles, NoTitle, ClickToFocus, WindowListSkip
# *FvwmPagerHilight deeppink
# *FvwmPagerHilight pink2

#Module FvwmPager AnotherPager 0 0
#*AnotherPagerGeometry 100x100+300+300

#KillModule FvwmBacker

Key q A SCM Module FvwmForm QuitVerify

*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyFore          Black
*QuitVerifyBack          Blue
*QuitVerifyItemFore Blue
*QuitVerifyItemBack Black
# begin items
*QuitVerifyCommand  Beep
*QuitVerifyLine          center
*QuitVerifyText          "Do you really want to logout?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      "Logout"  ^M
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"  ^[
*QuitVerifyCommand  Nop
# Fvwm window style
Style "QuitVerify" NoTitle, NoHandles, BorderWidth 7

# These Style options will be added to the next release of Fvwm2.
# StaysOnBottom FvwmButtons

# /usr/X11R6/bin/xterm -T "xtermbutton" -fg black -bg black -cr black -fn fixed +sb +vb -ls -geometry 8x4

#Module FvwmForm BrowserForm
*BrowserFormPosition 61 332
*BrowserFormFore White
*BrowserFormBack MediumPurple4
*BrowserFormItemFore White
*BrowserFormItemBack Black
*BrowserFormLine expand
*BrowserFormText "Website to browse: "
*BrowserFormLine expand
*BrowserFormInput website 33
*BrowserFormButton quit "GO" ^M
*BrowserFormCommand Exec /usr/bin/netscape $(website!file:/home/httpd/html/index.html) $(website)
#*BrowserFormCommand Exec /usr/bin/netscape $(website!file:/home/httpd/html/index.html)
#*BrowserFormCommand Exec /usr/bin/netscape $(website)
#Style "BrowserForm" Title "Browser Form"
#Style "BrowserForm" NoTitle, NoHandles, BorderWidth 7

# /bin/mkdir -m 770 ~/.private ; /bin/touch ~/.private/.cs-passwd ; /bin/chmod 660 ~/.private/.cs-passwd
# Then prompt me for a password.

AddToFunc CheckMail "I" Exec /usr/X11R6/bin/xterm -T "Remote Pine" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set mailserver "134.153.1.1"; \
   set authfile ".cs.mun.ca"; \
   set username [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 0]; \
   set password [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 1]; \
   spawn /usr/bin/telnet $mailserver; \
   expect "login: "; \
   send "$username\r"; \
   expect "Password:"; \
   send "$password\r"; \
   expect ""; \
   send "pine \r"; \
   interact \
   '
AddToFunc RemoteXterm "I" Exec /usr/X11R6/bin/xterm -T "Garfield" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set server "134.153.1.1"; \
   set authfile ".cs.mun.ca"; \
   set username [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 0]; \
   set password [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 1]; \
   spawn /usr/bin/telnet $server; \
   expect "login: "; \
   send "$username\r"; \
   expect "Password:"; \
   send "$password\r"; \
   interact \
   '

AddToFunc RemoteSsh "I" Exec /usr/X11R6/bin/xterm -T "Vega" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set server "129.128.88.12"; \
   set authfile ".math.ualberta.ca"; \
   set username [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 0]; \
   set password [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 1]; \
   spawn /usr/bin/ssh -l $username $server; \
   expect "password: "; \
   send "$password\r"; \
   interact \
   '

AddToFunc SuRoot "I" Exec /usr/X11R6/bin/xterm -T "Root Shell" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set authfile ".rootpasswd"; \
   set password [exec /bin/cat [cd; pwd]/.private/.auth/$authfile]; \
   spawn /bin/su; \
   expect "Password: "; \
   send "$password\r"; \
   interact \
   '

#MenuStyle * WIN
#MenuStyle * Background plum3
#MenuStyle * Background DarkGoldenrod2
#MenuStyle * Background orange
#MenuStyle * Background DarkOrange
#MenuStyle * Background LightCoral
#MenuStyle * Background orange1
#MenuStyle * Background brown3
#MenuStyle * Background maroon1
##MenuStyle * Hilight3DOff

#The following feature was only added in Fvwm 2.2.0.
#MenuStyle * TitleWarpOff

#Style PlainXTerm Color white / white

Key p A M PlainColors

AddToFunc PlainColors "I" HilightColor White gray74
#+                     "I" Style * Color gray74 / White
#+                     "I" Style * Color White / DarkGray
#+                     "I" Style PlainXTerm NoTitle
+                     "I" Exec /usr/X11R6/bin/xterm -T PlainXTerm -fg black -bg white -cr black -fn 8x13bold +sb +vb -ls

# /usr/X11R6/bin/xterm -T "QUESTIONS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/QUESTIONS)"AddToFunc "I" Exec

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Oct 1999 03:32:04 +0200

> finish before running InitFunction).

The problem is that the style the new window gets depends on
if all the applicable styles have been defined before the window
finally maps.  This has nothing to do with modules alone though.

Bye

Dominik ^_^

---

From: Bob Woodside <[email-masked]>
Date: Thu, 14 Oct 1999 22:33:50 -0400

Tim Phipps wrote:
> >   dv> You shouldn't start modules from the .fvwm2rc file.

	This may sound a bit confusing. Maybe we should say something like "you
shouldn't start modules in open code - do it in a function" - the
InitFunc and RestartFunc are also part of the .fvwm2rc file
(conceptually, at least).

> >   dv>  The right place to start them is in your InitFunc and RestartFunc.
> 

	I suppose it's not usually a problem, but suppose I use FvwmConsole to
enter the command "Read .fvwm2rc" to reload my entire config without
doing a Restart. In this case I don't want a bunch of extra modules
started up.

Cheers,
Bob

---

From: Neil Zanella <[email-masked]>
Date: Fri, 15 Oct 1999 18:42:36 -0230 (NDT)

> They can't survive a restart anyway.

OK. These entries are gone from my config file.

> start them is in your InitFunc and RestartFunc.

But the FvwmButtons man page gives:

*FvwmButtons(Swallow "FvwmPager" "FvwmPager 0 0")

as an example. Am I supposed to do that in my InitFunc as well?

Thanks,

Neil

---

From: Dan Espen <[email-masked]>
Date: Fri, 15 Oct 1999 17:35:08 -0400

> as an example. Am I supposed to do that in my InitFunc as well?

No.

After FvwmButtons starts, it is sent all the previously entered commands
that start with *FvwmButtons, so there is no need to put that command
in your InitFunction.  To be safe you would want to make sure the above
command is processed before FvwmButtons is started.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Fri, 15 Oct 1999 20:20:54 -0230 (NDT)

> command is processed before FvwmButtons is started.

How do I ensure that the above command is processed before FvwmButtons is 
started. Will putting Module FvwmButtons in the InitFunc do?

I thought that the order in which the commands came in the .fvwm2rc file
did not matter.

Thanks,

Neil

---

From: Dan Espen <[email-masked]>
Date: Fri, 15 Oct 1999 20:20:46 -0400

> I thought that the order in which the commands came in the .fvwm2rc file

Sorry, I misled you on that.

Whether   you are  using the  new   StartFunction, or InitFunction  or
RestartFunction, they  are all run  after the initial .fvwm2rc file is
read.

I thought the man page said that the order of commands MOSTLY doesn't
matter, but I couldn't find any reference at all.  (I'm probably just
missing it).

Anyway, there are plenty of cases where the order of commands matters,
style commands with wild cards are one example.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 19 Oct 1999 09:39:48 +0200

On Mon, Oct 18, 1999 at 11:23:16PM -0230, [email-masked] wrote:
> 
> Hi,
> 
> I made the changes you told me but upon restart I sometimes still get the
> pager staysontop.

You have to upgrade to the latest snapshopt too.

> BTW, do I have to make swallowed applications 
> StaysOnBottom as well if the swallowing application is StaysOnBottom?

No.  The swallowed applications are not handled by fvwm anymore.

Bye

Dominik ^_^

---

From: Neil Zanella <[email-masked]>
Date: Mon, 18 Oct 1999 23:23:16 -0230 (NDT)

Hi,

I made the changes you told me but upon restart I sometimes still get the
pager staysontop. BTW, do I have to make swallowed applications 
StaysOnBottom as well if the swallowing application is StaysOnBottom?

Here is my configuration file (appended).

Thanks,

Neil

# This is a ".fvwm2rc" configuration file for Fvwm Version 2.3.9.
# Best results are obtained when used on a TFT screen with a resolution of
# 800x600 pixels and a color depth of 16 bpp or higher.
# This file assumes that the following packages and others have been
# installed on the system:
# Red Hat Linux 5.2 <http://www.redhat.com/>
# Fvwm 2.3.9 <http://www.fvwm.org/>
# Ssh 1.2.26 <http://www.replay.com/redhat/ssh.html>
# Expect 5.26 <http://expect.nist.gov/>

AddToFunc InitFunction "I" Module FvwmButtons PagerButton
+                      "I" Module FvwmButtons
+                      "I" Exec /usr/X11R6/bin/xset b off
#                      Why is the following line not behaving as expected?
#                      "I" Exec /usr/bin/killall xconsole
#                      The following line works only if Fvwm is run locally.
+                      "I" Exec /usr/X11R6/bin/xhost + > /dev/null
+                      "I" Exec /usr/X11R6/bin/xclock -geometry 50x50-0+0 -bw 0
+                      "I" Exec /usr/X11R6/bin/xterm -geometry 80x24+123+51 -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls
+                      "I" Exec /bin/sh -c "if ! [ -e `cd; pwd`/.private ]; then /bin/mkdir `cd; /bin/pwd`/.private; echo; echo A ~/.private directory called has been created.; echo; fi"

AddToFunc RestartFunction "I" Module FvwmButtons PagerButton
+                         "I" Module FvwmButtons

# AddToFunc ExitFunction

DeskTopSize 4x4

EdgeResistance 0 0
EdgeScroll 100 100

OpaqueMoveSize 400

ClickTime 125

MenuStyle * TitleWarpOff
MenuStyle * PopupImmediately
MenuStyle * PopupOffset 0 100

Style * HandleWidth 7
Style * BorderWidth 0

Style * SloppyFocus

Style Netscape Sticky

SetBackground

# Module FvwmButtons PagerButton

# Module FvwmButtons

*FvwmButtons(Icon penguin.xpm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T `/bin/hostname` -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls", Action (Mouse 2) RemoteXterm, Action (Mouse 3) RemoteSsh)
*FvwmButtons(Icon writeletter.xpm, \
             Action (Mouse 1) CheckMail, \
             Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T Pine -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/checkmail.exp c", \
             Action (Mouse 3) RemoteXBiff)

*FvwmButtons(Icon math.xbm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T 'GAP 4' -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap4", Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T 'GAP 3' -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/bin/gap3")
*FvwmButtons(Icon math4.xpm, Action (Mouse 1) "Exec /usr/local/maple/bin/xmaple", Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T 'Maple' -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/local/maple/bin/maple", Action (Mouse 3) "Exec /usr/X11R6/bin/xcalc -geometry 150x230-0+0")
*FvwmButtons(Icon nscape.xpm, Action (Mouse 1) "Exec /usr/bin/netscape", Action (Mouse 2) "Module FvwmForm BrowserForm", Action (Mouse 3) "Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/lynx")
*FvwmButtons(Icon mini-crosbone.xpm, Action "Exec /usr/X11R6/bin/xkill")
*FvwmButtons(Icon bomb.xpm, Action (Mouse 1) Module FvwmForm HaltVerify, Action (Mouse 2) Module FvwmForm RebootVerify, Action (Mouse 3) Quit)
#*FvwmButtons(Icon bomb.xpm, Action (Mouse 1) "Exec /usr/X11R6/bin/xterm -T Halt -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /sbin/halt", Action (Mouse 2) "Exec /usr/X11R6/bin/xterm -T Reboot -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/su -c /sbin/reboot", Action (Mouse 3) Quit)

+                "Ftp"        Popup Ftp
+                "Personal"   Popup Personal

AddToMenu Personal "NOTES"            Exec  /usr/X11R6/bin/xterm -T "NOTES" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/NOTES)"
+                  "TODO"               Exec /usr/X11R6/bin/xterm -T "TODO" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/TODO)"
+                  "QUESTIONS"          Exec /usr/X11R6/bin/xterm -T "QUESTIONS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/QUESTIONS)"
+                  "BUGS"          Exec  /usr/X11R6/bin/xterm -T "BUGS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/BUGS)"
+                  "SUGGESTIONS"        Exec /usr/X11R6/bin/xterm -T "SUGGESTIONS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/SUGGESTIONS)"
+                  "LINKS"              Exec /usr/X11R6/bin/xterm -T "LINKS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/LINKS)"
+                  "SCRAP"              Exec /usr/X11R6/bin/xterm -T "SCRAP" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/SCRAP)"
+                  "BOOKS"              Exec  /usr/X11R6/bin/xterm -T "BOOKS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi /home/`/usr/bin/whoami`/.private/BOOKS)"
+                  "TYPOS"          Exec  /usr/X11R6/bin/xterm -T "TYPOS" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /bin/sh -c "(vi -r /home/`/usr/bin/whoami`/.private/TYPOS)"

AddToMenu Other     "TkZip"              Exec /usr/local/bin/TkZip
+                   ""                   Nop

+                           "Wxftp"      Exec /usr/X11R6/bin/wxftp

+              ""              Nop

AddToMenu TeX-DOCS "The teTeX Documentation Guide (HTML)"          Exec /usr/bin/netscape file:/usr/share/texmf/doc/newhelpindex.html
+                  "The teTeX Installation and Maintenacnce Guide" Exec /usr/bin/xdvi /usr/share/texmf/doc/tetex/TETEXDOC.dvi
+                  "The TeX Directory Structure (TDS)"             Exec /usr/bin/xdvi /usr/share/texmf/doc/help/tds.dvi
+                  "AmS-LaTeX User's Guide"                        Exec /usr/bin/xdvi /usr/share/texmf/doc/ams/amslatex/amsldoc.dvi
+                  "The TeX Catalogue Online (HTML)"               Exec /usr/bin/netscape file:/usr/share/texmf/doc/help/Catalogue/catalogue.html
+                  "LaTeX 2e Help (HTML)"                          Exec /usr/bin/netscape file:/usr/share/texmf/doc/latex/latex2e-html/index.html
+                  "The teTeX FAQ"                                 Exec /usr/X11R6/bin/xterm -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/less /usr/share/texmf/doc/tetex/teTeX-FAQ
+                  "LaTeX News"                                    Popup LaTeX-News
+                  "The LaTeX3 Project"                            Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltx3info.dvi
+                  ""                                              Nop
+                  "Array"                                         Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/tools/array.dvi
+                  "Multicolumn"                                   Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/tools/multicol.dvi

AddToMenu LaTeX-News "Issue 1" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews01.dvi
+                    "Issue 2" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews02.dvi
+                    "Issue 3" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews03.dvi
+                    "Issue 4" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews04.dvi
+                    "Issue 5" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews05.dvi
+                    "Issue 6" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews06.dvi
+                    "Issue 7" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews07.dvi
+                    "Issue 8" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews08.dvi
+                    "Issue 9" Exec /usr/bin/xdvi /usr/share/texmf/doc/latex/base/ltnews09.dvi

Mouse 1 R N Menu Xterms

Mouse 1 R C Popup Shells

Mouse 1 I N Move
Mouse 2 I N Stick
Mouse 3 I N Iconify

Mouse 0 F  N Resize

Key h A M Scroll -100  0
Key j A M Scroll  0  100
Key k A M Scroll  0 -100
Key l A M Scroll  100  0

Key h A CM Scroll -25  0
Key j A CM Scroll  0  25
Key k A CM Scroll  0 -25
Key l A CM Scroll  25  0

Key h A SCM Scroll -1  0
Key j A SCM Scroll  0  1
Key k A SCM Scroll  0 -1
Key l A SCM Scroll  1  0

Key F1 A N PopUp Xterms

AddToMenu Ftp "Garfield" FtpGarfield
#+             "Metalab"  FtpMetalab

#

*FvwmBannerTimeout 3

#EdgeResistance 50 45

#KillModule FvwmBacker

*HaltVerifyGrabServer
#*HaltVerifyWarpPointer
*HaltVerifyFont          *helvetica*m*r*n*14*
*HaltVerifyButtonFont    *helvetica*m*o*n*14*
*HaltVerifyFore          Black
*HaltVerifyBack          Blue
*HaltVerifyItemFore Blue
*HaltVerifyItemBack Black
# begin items
*HaltVerifyCommand  Beep
*HaltVerifyLine          center
*HaltVerifyText          "Do you really want to halt the system?"
*HaltVerifyLine          expand
*HaltVerifyButton   quit      "Halt"  ^M
*HaltVerifyCommand  Halt
*HaltVerifyButton   quit      "Cancel"  ^[
*HaltVerifyCommand  Nop
# Fvwm window style
Style "HaltVerify" NoTitle, NoHandles, BorderWidth 7

*RebootVerifyGrabServer
#*RebootVerifyWarpPointer
*RebootVerifyFont          *helvetica*m*r*n*14*
*RebootVerifyButtonFont    *helvetica*m*o*n*14*
*RebootVerifyFore          Black
*RebootVerifyBack          Blue
*RebootVerifyItemFore Blue
*RebootVerifyItemBack Black
# begin items
*RebootVerifyCommand  Beep
*RebootVerifyLine          center
*RebootVerifyText          "Do you really want to reboot the system?"
*RebootVerifyLine          expand
*RebootVerifyButton   quit      "Reboot"  ^M
*RebootVerifyCommand  Reboot
*RebootVerifyButton   quit      "Cancel"  ^[
*RebootVerifyCommand  Nop
# Fvwm window style
Style "RebootVerify" NoTitle, NoHandles, BorderWidth 7

*QuitVerifyGrabServer
#*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyFore          Black
*QuitVerifyBack          Blue
*QuitVerifyItemFore Blue
*QuitVerifyItemBack Black
# begin items
*QuitVerifyCommand  Beep
*QuitVerifyLine          center
#*QuitVerifyText          "Do you really want to logout?"
*QuitVerifyText          "Do you really want to halt the system?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      "Halt"  ^M
*QuitVerifyCommand  Halt
*QuitVerifyButton   quit      "Cancel"  ^[
*QuitVerifyCommand  Nop
# Fvwm window style
Style "QuitVerify" NoTitle, NoHandles, BorderWidth 7

AddToFunc FtpGarfield "I" Exec /usr/X11R6/bin/xterm -T "Ftp Garfield" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set server "134.153.1.1"; \
   set authfile ".cs.mun.ca"; \
   set username [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 0]; \
   set password [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 1]; \
   spawn /usr/bin/ftp $server; \
   expect "Name (*): "; \
   send "$username\r"; \
   expect "Password:"; \
   send "$password\r"; \
   interact \
   '

   exec /bin/sleep 1; \
   expect "Password: "; \
   send "$password\r"; \
   interact \
   '

AddToFunc Halt "I" Exec /usr/X11R6/bin/xterm -T "Halt" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set authfile ".rootpasswd"; \
   set password [exec /bin/cat [cd; pwd]/.private/.auth/$authfile]; \
   spawn /bin/su -c "/sbin/halt"; \
   exec /bin/sleep 1; \
   expect "Password: "; \
   send "$password\r"; \
   expect ""; \
   exec /bin/sleep 1; \
   '

AddToFunc Reboot "I" Exec /usr/X11R6/bin/xterm -T "Halt" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -e /usr/bin/expect -c ' \
   set authfile ".rootpasswd"; \
   set password [exec /bin/cat [cd; pwd]/.private/.auth/$authfile]; \
   spawn /bin/su -c "/sbin/reboot"; \
   exec /bin/sleep 1; \
   expect "Password: "; \
   send "$password\r"; \
   expect ""; \
   exec /bin/sleep 1; \
   '

AddToFunc RemoteXBiff "I" Exec /usr/X11R6/bin/xterm -T "Remote X Biff" -fg white -bg black -cr gray84 -fn fixed -sb -sl 4096 +vb -ls -iconic -e /usr/bin/expect -c ' \
   set server "134.153.1.1"; \
   set authfile ".cs.mun.ca"; \
   set username [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 0]; \
   set password [lindex [exec /bin/cat [cd; pwd]/.private/.auth/$authfile] 1]; \
   set display [exec /bin/cat [cd; pwd]/.private/.display]; \
   spawn /usr/bin/telnet $server; \
   expect "login: "; \
   send "$username\r"; \
   expect "Password:"; \
   send "$password\r"; \
   expect ""; \
   send "/usr/bin/X11/xbiff -display 129.128.88.47:0.0 -geometry +121+0 &\r"; \
   exec /bin/sleep 2; \
   send "logout\r" \
   '
# /usr/bin/X11/xbiff
# send "/usr/bin/X11/xbiff -display $display -geometry 100x100+0+0\r"; \

#MenuStyle * WIN

Key p A M PlainColors

---

From: Neil Zanella <[email-masked]>
Date: Tue, 19 Oct 1999 20:03:29 -0230 (NDT)

I am running  fvwm-2.3.9

which I got at ftp://ftp.fvwm.org/pub/fvwm/version-2/ .

I could not find a newer version at the Fvwm site.

Thanks,

Neil

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 20 Oct 1999 01:25:26 +0200

> I could not find a newer version at the Fvwm site.

Try ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/

But it seems that there are problems with building snapshots again.
The latest is fvwm-snap-19991017.tar.gz .

> Neil

Regards,
Mikhael.