Subject: Re: FVWM: Mouse focus problems with xemacs

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Oct 1999 15:32:06 +0200

On Fri, Oct 01, 1999 at 11:42:43AM -0700, Richard Johnson wrote:
> Brian Servis writes:
>  > Fvwm 2.2, Xemacs 20.4 and SloppyFocus works for me on Debian 2.1.
> 
> That sounds like it matches my setup completely.  I don't get it.  I
> even removed my .emacs file in case I was doing something strange
> there and with a vanilla xemacs it still does it.
> 
> Oh well...  I give up for now.  Maybe I'll revisit it later.

Can you send me your config file, please?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Richard Johnson <[email-masked]>
Date: Sat, 2 Oct 1999 11:20:19 -0700 (PDT)

> Can you send me your config file, please?

Sure:

# be sure to customize these paths for your installation:
#ModulePath /usr/lib/X11/fvwm2
#PixmapPath /usr/include/X11/pixmaps
#IconPath   /usr/include/X11/bitmaps

EdgeResistance 500 40
EdgeScroll 50 50
ClickTime 750

# make sure these fonts exist on your system:
# WindowFont -adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
# IconFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

HilightColor black palevioletred
DeskTopSize 1x1
MenuStyle white grey60 grey40 fixed fvwm

ColormapFocus FollowsMouse

XORvalue 255

OpaqueMoveSize	5

# default Styles:
Style "*"           BorderWidth 7, HandleWidth 7
Style "*"           MWMFunctions, MWMDecor, HintOverride
Style "*"           NoPPosition
Style "*"           IconBox 0 200 2 -1, Color black/ivory3
Style "*"           StickyIcon
Style "*"           ActivePlacement, SmartPlacement

# PostItNote Icons along the bottom
Style "PostItNote"  IconBox 0 -75 -100 -1, StickyIcon, WindowListSkip, RandomPlacement

# Emacs Icons go in the upper right
Style "Emacs"	    IconBox -1 0 -0 200, StickyIcon

# Styles for various Fvwm modules:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style "FvwmPager"   StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "FvwmButtons" Icon toolbox.xpm, ClickToFocus

# Styles for your common terminal emulator programs:
Style "XTerm"       IconBox -1 100 -0 -50, StickyIcon

# Styles for various common programs:

Style "*lock"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "*lock"		ClickToFocus, BorderWidth 1, StaysOnTop
Style "xlbiff"		NoTitle, Sticky, WindowListSkip, Borderwidth 2, NoHandles
Style "xcalc"		NoHandles, RandomPlacement
Style "xman"		RandomPlacement
Style "xmag"		RandomPlacement
Style "xpostit+"	NoTitle, NoHandles, Sticky, WindowListSkip
Style "xpostit+"	BorderWidth 1
Style "xpostit"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "xpostit"		BorderWidth 1
Style "pat"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "pat"		BorderWidth 1
Style "xcal"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "xcal"		BorderWidth 1
Style "xbatt"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbatt"		StaysOnTop

# Router telnet icons
Style "*/28"		IconBox 0 -100 -100 -76, StickyIcon
Style "*-con"		IconBox 0 -100 -100 -76, StickyIcon

# some simple default key bindings:
# Key Next         A       SCM     Next [*] Focus
# Key Prior        A       SCM     Prev [*] Focus

# some simple default mouse bindings:
#   for the root window:

#   for the title bar buttons:
Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	2    	A     	Maximize-Func
Mouse 0	4    	A     	Iconify

#   for other parts of the window/borders/icons:
# Mouse 1	F	A	Resize-or-Raise
# Mouse 1	TS	A	Move-or-Raise
# Mouse 1	I	A	Move-or-Iconify
# Mouse 2	I	A	Iconify
# Mouse 2	FST	A	Menu Window-Ops2 Nop
# Mouse 3	TSIF	A	RaiseLower

Mouse 1	R   	A       Menu RootMenu Nop
Mouse 1 FS	A	Resize
Mouse 1 I	M	Iconify
Mouse 1	I	N	Iconify
Mouse 1 T	M	Move-Or-Raise
Mouse 1 T	N	Move-Or-Raise
Mouse 1 W	M	Move-Or-Iconify
Mouse 1 WIT	MS	Raise

Mouse 2 A	M	DeIconify-Focus "INBOX*"
#Mouse 2	R    	A      	Menu Utilities Nop
Mouse 2	T	N	Move

Mouse 3 A	S	WindowList
Mouse 3 R	A	Menu Window-Ops Nop
Mouse 3 FS	A	Menu Window-Ops Nop
Mouse 3 I	M	Move-Or-Lower
Mouse 3 T	M	Move-Or-Lower
Mouse 3 T	N	Move-Or-Lower
Mouse 3 W	M	Resize
Mouse 3 WIT	MS	Lower

######################## Initialization Functions ############################
# AddToFunc InitFunction 	  "I" Module FvwmButtons
# +			  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070
# 
# AddToFunc RestartFunction "I" Module FvwmButtons
# +			  "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070
# 

######################## Menus ###################
AddToMenu RootMenu	"Root Menu"	Title
+			"xterm"		exec exec xterm
+			"Remote Windows" Popup Remote-Logins
+			"Routers"	Popup Router-Logins
+			"Telnet"	Popup Telnet-Logins
+			""		Nop
+                       "Utilities"     Popup Utilities
+			""		Nop
+			"Fvwm Modules"	          Popup Module-Popup
+                       "Fvwm Window Ops"         Popup Window-Ops
+                       "Fvwm Simple Config Ops"  Popup Misc-Ops
+			""		Nop
+                       "Refresh Screen"   Refresh
+                       "Recapture Screen" Recapture
+			""		Nop
+			"Exit Fvwm"	Popup Quit-Verify

AddToMenu Utilities     "Utilities" Title
+			"Top"		Exec exec rxvt -T Top -n Top -e top
+			"Calculator"	Exec exec xcalc
+			"Xman"		Exec exec xman
+			"Xmag"		Exec exec xmag
+                       "Editres"       Exec exec editres
+			""		Nop
+			"XEmacs"	Exec exec xemacs
+                       "Mail"          MailFunction "INBOX*" "-font fixed"
+			""		Nop
+                       "XLock"         Exec exec xlock -mode random
+			""		Nop
+                       "Reset X defaults" Exec xrdb -load $HOME/.Xdefaults 

AddToMenu Misc-Ops "Misc Config Opts" Title
+                  "Sloppy Focus"        ChangeDefaultFocus SloppyFocus
+                  "Click To Focus"      ChangeDefaultFocus ClickToFocus
+                  "Focus Follows Mouse" ChangeDefaultFocus FocusFollowsMouse
+                  "" Nop
+                  "Colormap Follows Mouse" ColormapFocus FollowsMouse
+                  "Colormap Follows Focus" ColormapFocus FollowsFocus
+                  "" Nop
+                  "Full Paging ON"         EdgeScroll 100 100
+                  "All Paging OFF"         EdgeScroll 0 0
+                  "Horizontal Paging Only" EdgeScroll 100 0
+                  "Vertical Paging Only"   EdgeScroll 0 100
+                  "Partial Paging"         EdgeScroll 50 50
+                  "Full Paging && Edge Wrap" EdgeScroll 100000 100000

AddToMenu Window-Ops	"Window Ops"	Title		
+			"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	Maximize
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"Refresh Window" RefreshWindow

AddToMenu Window-Ops2	"&Move"		Move
+			"&Resize"	Resize
+			"R&aise"	Raise   	
+			"&Lower"	Lower   	
+			"(De)&Iconify"	Iconify 	
+			"(Un)&Stick"	Stick		
+                       "(Un)Ma&ximize" Maximize
+			""		Nop     	
+			"&Delete"	Delete	
+			"&Close"	Close
+			"Destroy"	Destroy 	
+			""		Nop
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction
+                       "Print Reverse" PrintReverseFunction

# be sure to fill these in with your correct machine names:
AddToMenu Remote-Logins	"rxvt"			Exec rxvt -display $DISPLAY &
+			"rjohnson-home-ss20"	Exec rcmd rjohnson-home-ss20 xterm -n rjohnson-home-ss20 &
+			"rast"			Exec rcmd rast xterm -n rast &
+			"kitab"			Exec rcmd kitab xterm -n kitab &
+			"flipper"		Exec rcmd flipper xterm -n flipper &
+			"irp-view6"		Exec rcmd irp-view6 xterm -n irp-view6 &
+			"irp-view7"		Exec rcmd irp-view7 xterm -n irp-view7 &
+			"rjohnson-ss20"		Exec rcmd rjohnson-ss20 xterm -n rjohnson-ss20 &
+			"klmj-ss20"		Exec rcmd klmj-ss20 xterm -n klmj-ss20 &
+			"greatdane"		Exec rcmd greatdane xterm -n greatdane &
+			"dirt"			Exec rcmd dirt xterm -n dirt &
+			"muesli"		Exec rcmd muesli xterm -n muesli &
+			"cider"			Exec rcmd cider xterm -n cider &
+			"irp-view3"		Exec rcmd irp-view3 xterm -n irp-view3 &
+			"puli"			Exec rcmd puli xterm -n puli &

AddToMenu Router-Logins	"Major"		Popup "Major"
+			"Minor"		Popup "Minor"
+			"Color"		Popup "Color"
+			"Shakespeare"	Popup "Shakespeare"
+			"Marine"       	Popup "Marine"
+			"Fresh"		Popup "Fresh"
+			"Unified"      	Popup "Unified"
+			"Caribbean"    	Popup "Caribbean"
+			"NoCal"		Popup "NoCal"
+			"So Cal"       	Popup "So Cal"
+			"Pleasant"     	Popup "Pleasant"
+			"Sick"       	Popup "Sick"
+			"Junkfood"      Popup "Junkfood"
+			"Monkey"        Popup "Monkey"
+			"Sanrio"        Popup "Sanrio"
+			"Thaifood"      Popup "Thaifood"

AddToMenu Telnet-Logins	"Router telnets" Title
+ "MJ Router" Exec exec xterm -T 'Our Router' -display :0 -e telnet 171.69.187.225 &
+ "Fred's Router" Exec exec xterm -T "Fred's Router" -e telnet 171.69.128.113 &
+ "Charles' Router" Exec exec xterm -T "Charles' Router" -e telnet 171.69.143.1 &

AddToMenu Module-Popup	"FvwmModules"	Title
+			"Identify"	Module	FvwmIdent
+			"Talk"  	Module	FvwmTalk
+			""		Nop
+			"Button-Bar"	Module	FvwmButtons
+			"Pager"		Module  FvwmPager 0 0
+			"Pager (2 desks)" Module  FvwmPager 0 1
+			"WinList"	Module  FvwmWinList
+			""		Nop
+			"Banner"	Module	FvwmBanner
+                       "ScrollBar"     Module  FvwmScroll 50 50
+			"Background"	Module  FvwmBacker
+                       "AutoRaise"     Module  FvwmAuto 200 Raise Nop
+                       "Stop AutoRaise" KillModule FvwmAuto
+			""		Nop
+			"IconBox"	Module	FvwmIconBox
+                       "IconMan"       Module  FvwmIconMan
+			""		Nop
+                       "Form - Rlogin"      Module FvwmForm Rlogin
+                       "Form - MyFvwmTalk"  Module FvwmForm MyFvwmTalk
+                       "Form - QuitVerify"  Module FvwmForm QuitVerify

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
+		      	"Yes, Really Quit"  Quit	
+		      	""		    Nop	
+                       "Restart Fvwm2"     Restart fvwm2
+		      	"Restart Fvwm"	    Restart fvwm
+		      	""		    Nop	
+		      	"Start twm"         Restart twm
+		      	"Start ctwm"        Restart ctwm
+		        "Start tvtwm"       Restart tvtwm
+		        "Start vtwm"        Restart vtwm
+		      	"Start mwm"    	    Restart mwm
+	      	      	"Start olwm"        Restart /usr/openwin/bin/olwm
+		      	""		    Nop	
+		      	"Start dummy"       Restart xterm
+		      	""		    Nop	
+		      	"No, Don't Quit"    Nop	

######################## Sample Functions ##########################

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] Focus
+			   "I" None [$0] Exec $0 $1

AddToFunc DeIconify-Focus	"I" Next ["INBOX*"] Iconify -1
+				"I" Next ["INBOX*"] Focus
+				"I" Next ["INBOX*"] Raise

AddToFunc Move-or-Raise		"M" Move
+  				"C" Raise

AddToFunc Move-or-Lower		"M" Move
+  				"C" Lower

AddToFunc Move-or-Raise2	"M" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Maximize-Func		"M" Maximize	 0 100
+				"C" Maximize	 0 80
+				"D" Maximize	 100 100

AddToFunc Move-or-Iconify	"M" Move
+				"C" Iconify

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc PrintReverseFunction  "I" Raise
+                               "I" Exec xdpr 1/2 -h -rv -id $w

AddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

# RLOGIN machine fg bg
AddToFunc RLOGIN "I" Exec xterm -fg $1 -bg $2 -e rlogin $0 -8

# TELNET machine fg bg
AddToFunc TELNET "I" Exec xterm -fg $1 -bg $2 -e telnet $0

AddToFunc FocusAndWarp "I" Focus
+                      "I" WarpToWindow 2p 2p

AddToFunc DeiconifyFocusAndWarp "I" Iconify -1
+                               "I" FocusAndWarp

AddToFunc ChangeDefaultFocus "I" Style "*" $0
+                            "I" Recapture

################## FvwmButtons button-bar ################################
*FvwmButtonsBack bisque3
*FvwmButtons(Frame 2 Padding 2 2 Container(Rows 2 Frame 1 Padding 10 0 \
                                           Swallow(Respawn)))
*FvwmButtons(NoSize Title Close, Icon bomb.xpm, Action Close)
*FvwmButtons(Title Resize Icon mini.resize.xpm Back bisque4 Action Resize)
*FvwmButtons(Frame -3 Swallow(Respawn,NoHints) xclock \
       `Exec exec xclock -bg darkolivegreen -padding 0 -geometry +2000+0`)
*FvwmButtons(3x1 Back darkolivegreen Fore white Frame 2 Padding 2 2 \
                 Container(Rows 1 Frame -2 Padding 1 1 Back darkolivegreen))
*FvwmButtons(Frame 2 Title(Side,Right) Mail Fore white \
         Swallow(UseOld,NoRespawn)\
         xbiff `Exec exec xbiff -bg darkolivegreen -geometry +200+200`)
*FvwmButtons(2x1 Swallow (NoHints) "FvwmTalk" "FvwmTalk")
*FvwmButtons(End)
*FvwmButtons(End)

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*,-*-fixed-medium-r-normal-*-12-*-*-*-*-*-*-*,-*-gothic-medium-r-normal-*-12-*-*-*-*-*-*-*,-*-mincho-medium-r-normal-*-12-*-*-*-*-*-*-*,-*-*-medium-r-normal-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-*-fixed-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-gothic-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-mincho-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-*-medium-r-normal-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Misc
*FvwmPagerLabel 1 Maker
*FvwmPagerLabel 2 Mail
*FvwmPagerLabel 3 Matlab
*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*,-*-fixed-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-gothic-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-mincho-medium-r-normal-*-10-*-*-*-*-*-*-*,-*-*-medium-r-normal-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green
	
############################################################
############################################################
# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     "*"  NoIcon

############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        fixed
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     0
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file specifications
#
# Mostly, you don't have to specify icon files, as FvwmIconBox now
# reads icon files specified in Style commands.
#
# *FvwmIconBox            "Fvwm*"         -

# FvwmForm alias - rlogin to host via xterm
*RloginWarpPointer
*RloginFont         *helvetica*m*r*n*14*
*RloginButtonFont   *helvetica*m*o*n*14*
*RloginInputFont    *cour*m*r*n*14*
*RloginFore         Black
*RloginBack         Light Gray
*RloginItemFore          Wheat
*RloginItemBack          Gray50
# begin items
*RloginLine         center
*RloginText         "Login to Remote Host"
*RloginLine         center
*RloginText         "Host:"
*RloginInput        HostName  20   ""
*RloginLine         center
*RloginSelection    UserSel   single
*RloginChoice       Default   Default   on   "same user"
*RloginChoice       Custom    Custom    off  "user:"
*RloginInput        UserName  10   ""
*RloginLine         expand
*RloginButton       quit "Login" ^M
*RloginCommand Exec xterm  -T xterm@$(HostName) -e rlogin $(HostName) $(Custom?-l $(UserName))
*RloginButton       restart   "Clear"
*RloginCommand Beep
*RloginButton       quit "Cancel"
*RloginCommand Nop

# FvwmForm alias - query exit ala mwm
*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
#*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyButtonFont    7x13bold
*QuitVerifyFore          Black
*QuitVerifyBack          Light Gray
*QuitVerifyItemFore Wheat
*QuitVerifyItemBack Gray50
# begin items
*QuitVerifyLine          center
*QuitVerifyText          "Do you really want to exit FVWM?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      " Exit "
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"
*QuitVerifyCommand  Nop

# MyTalk & MyFvwmTalk from Dave Goldberg
# MyTalk Form - dissappears after use
*MyTalkWarpPointer
*MyTalkFont *helvetica*m*r*n*14*
*MyTalkButtonFont *helvetica*m*o*n*14*
*MyTalkInputFont *cour*m*r*n*14*
*MyTalkFore Red
*MyTalkBack Gray
*MyTalkItemFore Blue
*MyTalkItemBack Gray
*MyTalkLine center
*MyTalkText "Fvwm Function"
*MyTalkInput Func 40 ""
*MyTalkLine expand
*MyTalkButton quit "Run" ^M
*MyTalkCommand $(Func)
*MyTalkButton restart "Clear" ^R
*MyTalkButton quit "Cancel" ^C
*MyTalkCommand Nop
# MyFvwmTalk Form - sticks around
*MyFvwmTalkWarpPointer
*MyFvwmTalkFont *helvetica*m*r*n*14*
*MyFvwmTalkButtonFont *helvetica*m*o*n*14*
*MyFvwmTalkInputFont *cour*m*r*n*14*
*MyFvwmTalkFore Red
*MyFvwmTalkBack Gray
*MyFvwmTalkItemFore Blue
*MyFvwmTalkItemBack Gray
*MyFvwmTalkLine center
*MyFvwmTalkText "Fvwm Function"
*MyFvwmTalkInput Func 40 ""
*MyFvwmTalkLine expand
*MyFvwmTalkButton restart "Run" ^M
*MyFvwmTalkCommand $(Func)
*MyFvwmTalkButton restart "Clear" ^R
*MyFvwmTalkCommand Nop
*MyFvwmTalkButton restart "Iconify" ^Z
*MyFvwmTalkCommand Next [MyFvwmTalk] Iconify
*MyFvwmTalkButton quit "Quit" ^C
*MyFvwmTalkCommand Nop

# to change banner pixmap
#*FvwmBannerPixmap fvwm3.xpm
#*FvwmBannerTimeout 2

AddToMenu Major	"Major"	Title
+ "Cmajor 7000"	Exec exec xterm -display :0 -T 'Cmajor-con' -e telnet cmajor-con &
+ "Gmajor 7000"	Exec exec xterm -display :0 -T 'Gmajor-con' -e telnet gmajor-con &
+ "Bmajor 2500"	Exec exec xterm -display :0 -T 'Bmajor-con' -e telnet bmajor-con &
+ "Fmajor 2500"	Exec exec xterm -display :0 -T 'Fmajor-con' -e telnet fmajor-con &
+ "Dmajor 4000"	Exec exec xterm -display :0 -T 'Dmajor-con' -e telnet dmajor-con &
+ "Amajor 3000"	Exec exec xterm -display :0 -T 'Amajor-con' -e telnet amajor-con &
+ "Emajor 3000"	Exec exec xterm -display :0 -T 'Emajor-con' -e telnet emajor-con &
+ "Eflat  2503"	Exec exec xterm -display :0 -T 'Eflat-con' -e telnet eflat-con &

AddToMenu Minor	"Minor"		Title
+ "Aminor 7000"	Exec exec xterm -display :0 -T 'Aminor-con' -e telnet aminor-con &
+ "Eminor 7000"	Exec exec xterm -display :0 -T 'Eminor-con' -e telnet eminor-con &
+ "Gsharp 4500"	Exec exec xterm -display :0 -T 'Gsharp-con' -e telnet gsharp-con &
+ "Bminor 4000"	Exec exec xterm -display :0 -T 'Bminor-con' -e telnet bminor-con &
+ "Fsharp 3000"	Exec exec xterm -display :0 -T 'Fsharp-con' -e telnet fsharp-con &
+ "Csharp 3000"	Exec exec xterm -display :0 -T 'Csharp-con' -e telnet csharp-con &

AddToMenu Color "Color"	Title
+ "Gray   AGS+"	Exec exec xterm -display :0 -T 'Gray-con' -e telnet gray-con &
+ "Violet AGS+"	Exec exec xterm -display :0 -T 'Violet-con' -e telnet violet-con &
+ "Green  AGS"	Exec exec xterm -display :0 -T 'Green-con' -e telnet green-con &
+ "Yellow MGS"	Exec exec xterm -display :0 -T 'Yellow-con' -e telnet yellow-con &
+ "Orange MGS"	Exec exec xterm -display :0 -T 'Orange-con' -e telnet orange-con &
+ "Red    2514"	Exec exec xterm -display :0 -T 'Red-con' -e telnet red-con &
+ "White  4000"	Exec exec xterm -display :0 -T 'White-con' -e telnet white-con &
+ "Brown  2514"	Exec exec xterm -display :0 -T 'Brown-con' -e telnet brown-con &

AddToMenu Shakespeare "Shakespeare"	Title
+ "Bottom   AGS"	Exec exec xterm -display :0 -T 'Bottom-con' -e telnet bottom-con &
+ "Snug     AGS"	Exec exec xterm -display :0 -T 'Snug-con' -e telnet snug-con &
+ "Puck     AGS+"	Exec exec xterm -display :0 -T 'Puck-con' -e telnet puck-con &
+ "Artemis  MGS"	Exec exec xterm -display :0 -T 'Artemis-con' -e telnet artemis-con &
+ "Cerdiwen MGS"	Exec exec xterm -display :0 -T 'Cerdiwen-con' -e telnet cerdiwen-con &
+ "Demeter  MGS"	Exec exec xterm -display :0 -T 'Demeter-con' -e telnet demeter-con &
+ "Ceres    MGS"	Exec exec xterm -display :0 -T 'Ceres-con' -e telnet ceres-con &
+ "Titania  MGS"	Exec exec xterm -display :0 -T 'Titania-con' -e telnet titania-con &

AddToMenu Marine "Marine"	Title
+ "Clown   AGS+"	Exec exec xterm -display :0 -T 'Clown-con' -e telnet clown-con &
+ "Damsel  AGS+"	Exec exec xterm -display :0 -T 'Damsel-con' -e telnet damsel-con &
+ "Trigger AGS+"	Exec exec xterm -display :0 -T 'Trigger-con' -e telnet trigger-con &
+ "Dog     2514"	Exec exec xterm -display :0 -T 'Dog-con' -e telnet dog-con &
+ "Puffer  2503"	Exec exec xterm -display :0 -T 'Puffer-con' -e telnet puffer-con &
+ "Zebra   2513"	Exec exec xterm -display :0 -T 'Zebra-con' -e telnet zebra-con &
+ "Moray   MGS"	Exec exec xterm -display :0 -T 'Moray-con' -e telnet moray-con &
+ "Jelly   MGS"	Exec exec xterm -display :0 -T 'Jelly-con' -e telnet jelly-con &

AddToMenu Fresh "Fresh"	Title
+ "Platty AGS+"	Exec exec xterm -display :0 -T 'Platty-con' -e telnet platty-con &
+ "Neon   AGS+"	Exec exec xterm -display :0 -T 'Neon-con' -e telnet neon-con &
+ "Guppy  AGS+"	Exec exec xterm -display :0 -T 'Guppy-con' -e telnet guppy-con &
+ "Danio  2514"	Exec exec xterm -display :0 -T 'Danio-con' -e telnet danio-con &
+ "Trout  2514"	Exec exec xterm -display :0 -T 'Trout-con' -e telnet trout-con &
+ "Discus 2503"	Exec exec xterm -display :0 -T 'Discus-con' -e telnet discus-con &
+ "Oscar  MGS"	Exec exec xterm -display :0 -T 'Oscar-con' -e telnet oscar-con &
+ "Mollie MGS"	Exec exec xterm -display :0 -T 'Mollie-con' -e telnet mollie-con &

AddToMenu Unified "Unified"	Title
+ "Kazakhstan AGS+"	Exec exec xterm -display :0 -T 'Kazakhstan-con' -e telnet kazakhstan-con &
+ "Kirghizia  AGS+"	Exec exec xterm -display :0 -T 'Kirghizia-con' -e telnet kirghizia-con &
+ "Ukraine    MGS"	Exec exec xterm -display :0 -T 'Ukraine-con' -e telnet ukraine-con &
+ "Georgia    MGS"	Exec exec xterm -display :0 -T 'Georgia-con' -e telnet georgia-con &
+ "Belarus    MGS"	Exec exec xterm -display :0 -T 'Belarus-con' -e telnet belarus-con &
+ "Turkmenia  MGS"	Exec exec xterm -display :0 -T 'Turkmenia-con' -e telnet turkmenia-con &
+ "Uzbekistan 2511"	Exec exec xterm -display :0 -T 'Uzbekistan-con' -e telnet uzbekistan-con &
+ "Armenia    2511"	Exec exec xterm -display :0 -T 'Armenia-con' -e telnet armenia-con &

AddToMenu Caribbean "Caribbean"	Title
+ "nevis    4500" Exec exec xterm -display :0 -T 'nevis-con' -e telnet nevis-con &
+ "Barbados 4500" Exec exec xterm -display :0 -T 'Barbados-con' -e telnet barbados-con &
+ "Bonaire  4500" Exec exec xterm -display :0 -T 'Bonaire-con' -e telnet bonaire-con &
+ "Caymans  4500" Exec exec xterm -display :0 -T 'Caymans-con' -e telnet caymans-con &
+ "Cuba     4500" Exec exec xterm -display :0 -T 'Cuba-con' -e telnet cuba-con &
+ "Haiti    4500" Exec exec xterm -display :0 -T 'Haiti-con' -e telnet haiti-con &
+ "Jamaica  4500" Exec exec xterm -display :0 -T 'Jamaica-con' -e telnet jamaica-con &

AddToMenu NoCal "NoCal"	Title
+ "Klamath  7000"	Exec exec xterm -display :0 -T 'Klamath-con' -e telnet klamath-con &
+ "Modoc    7000"	Exec exec xterm -display :0 -T 'Modoc-con' -e telnet modoc-con &
+ "Achumawi 4500"	Exec exec xterm -display :0 -T 'Achumawi-con' -e telnet achumawi-con &
+ "Yurok    4500"	Exec exec xterm -display :0 -T 'Yurok-con' -e telnet yurok-con &
+ "Tolowa   4500"	Exec exec xterm -display :0 -T 'Tolowa-con' -e telnet tolowa-con &
+ "Maidu    4500"	Exec exec xterm -display :0 -T 'Maidu-con' -e telnet maidu-con &
+ "Miwok    7000"	Exec exec xterm -display :0 -T 'Miwok-con' -e telnet miwok-con &
+ "Ohlone   ?"	Exec exec xterm -display :0 -T 'Ohlone-con' -e telnet ohlone-con &

AddToMenu SoCal "SoCal"	Title
+ "Costanoan 7000"	Exec exec xterm -display :0 -T 'Costanoan-con' -e telnet Costanoan-con &
+ "Yahi      7000"	Exec exec xterm -display :0 -T 'Yahi-con' -e telnet yahi-con &
+ "Paiute    4500"	Exec exec xterm -display :0 -T 'Paiute-con' -e telnet paiute-con &
+ "Kawaiisu  4500"	Exec exec xterm -display :0 -T 'Kawaiisu-con' -e telnet kawaiisu-con &
+ "Chumash   4500"	Exec exec xterm -display :0 -T 'Chumash-con' -e telnet chumash-con &
+ "Cahuilla  4500"	Exec exec xterm -display :0 -T 'Cahuilla-con' -e telnet cahuilla-con &
+ "Tipai     4500"	Exec exec xterm -display :0 -T 'tipai-con' -e telnet tipai-con &
+ "Mojave    ?"	Exec exec xterm -display :0 -T 'Mojave-con' -e telnet mojave-con &

AddToMenu Pleasant "Pleasant"	Title
+ "Sleazy 7000" Exec exec xterm -display :0 -T 'Sleazy-con' -e telnet sleazy-con &
+ "Lazy   7000" Exec exec xterm -display :0 -T 'Lazy-con' -e telnet lazy-con &
+ "Nasty  4500" Exec exec xterm -display :0 -T 'Nasty-con' -e telnet nasty-con &
+ "Slimy  4500" Exec exec xterm -display :0 -T 'Slimy-con' -e telnet slimy-con &
+ "Dirty  4500" Exec exec xterm -display :0 -T 'Dirty-con' -e telnet dirty-con &
+ "Stinky 4500" Exec exec xterm -display :0 -T 'Stinky-con' -e telnet stinky-con &

AddToMenu Sick "Sick"	Title
+ "Hanta     7000" Exec exec xterm -display :0 -T 'Hanta-con' -e telnet hanta-con &
+ "Malaria   7000" Exec exec xterm -display :0 -T 'Malaria-con' -e telnet malaria-con &
+ "Typhoid   4500" Exec exec xterm -display :0 -T 'Typhoid-con' -e telnet typhoid-con &
+ "Bubonic   4500" Exec exec xterm -display :0 -T 'Bubonic-con' -e telnet bubonic-con &
+ "Andromeda 4500" Exec exec xterm -display :0 -T 'Andromeda-con' -e telnet andromeda-con &
+ "Influenza 4500" Exec exec xterm -display :0 -T 'Influenza-con' -e telnet influenza-con &

AddToMenu Junkfood "Junkfood"	Title
+ "cheetos   7505" Exec exec xterm -display :0 -T 'cheetos-con' -e telnet cheetos-con &
+ "dingdongs 7505" Exec exec xterm -display :0 -T 'dingdongs-con' -e telnet dingdongs-con &
+ "ct12      cat1200" Exec exec xterm -display :0 -T 'ct12-con' -e telnet ct12-con &
+ "hohos     4700" Exec exec xterm -display :0 -T 'hohos-con' -e telnet hohos-con &
+ "bugles    4700" Exec exec xterm -display :0 -T 'bugles-con' -e telnet bugles-con &
+ "fritos    4700" Exec exec xterm -display :0 -T 'fritos-con' -e telnet fritos-con &

AddToMenu Monkey "Monkey"	Title
+ "orangutan 7505" Exec exec xterm -display :0 -T 'orangutan-con' -e telnet orangutan-con &
+ "chimp     7505" Exec exec xterm -display :0 -T 'chimp-con' -e telnet chimp-con &
+ "rhesus    4700" Exec exec xterm -display :0 -T 'rhesus-con' -e telnet rhesus-con &
+ "howler    4700" Exec exec xterm -display :0 -T 'howler-con' -e telnet howler-con &
+ "bonobo    4700" Exec exec xterm -display :0 -T 'bonobo-con' -e telnet bonobo-con &

AddToMenu Sanrio "Sanrio"	Title
+ "hello-kitty 7010" Exec exec xterm -display :0 -T 'hello-con' -e telnet hello-con &
+ "mimi        7010" Exec exec xterm -display :0 -T 'mimi-con' -e telnet mimi-con &
+ "keroppi     7505" Exec exec xterm -display :0 -T 'keroppi-con' -e telnet keroppi-con &
+ "pekkle      4500" Exec exec xterm -display :0 -T 'pekkle-con' -e telnet pekkle-con &
+ "pochacco    4500" Exec exec xterm -display :0 -T 'pochacco-con' -e telnet pochacco-con &
+ "winki-pinki 4500" Exec exec xterm -display :0 -T 'winki-con' -e telnet winki-con &
+ "pippo       4500" Exec exec xterm -display :0 -T 'pippo-con' -e telnet pippo-con &

AddToMenu Thaifood "Thaifood"	Title
+ "padthai   7010" Exec exec xterm -display :0 -T 'padthai-con' -e telnet padthai-con &
+ "tomkhakai 7010" Exec exec xterm -display :0 -T 'tomkhakai-con' -e telnet tomkhakai-con &
+ "tomyum    7505" Exec exec xterm -display :0 -T 'tomyum-con' -e telnet tomyum-con &
+ "tomklong  4500" Exec exec xterm -display :0 -T 'tomklong-con' -e telnet tomklong-con &
+ "kangpa    4500" Exec exec xterm -display :0 -T 'kangpa-con' -e telnet kangpa-con &
+ "mussaman  4500" Exec exec xterm -display :0 -T 'mussaman-con' -e telnet mussaman-con &
+ "kiewwan   4500" Exec exec xterm -display :0 -T 'kiewwan-con' -e telnet kiewwan-con &

AddToMenu Cocktail "Cocktail"	Title
+ "caesar    4500" Exec exec xterm -display :0 -T 'caesar-con' -e telnet caesar-con &
+ "daiquiri  4500" Exec exex xterm -display :0 -T 'daiquiri-con' -e telnet daiquiri-con &
+ "margarita ct12" Exec exex xterm -display :0 -T 'margarita-con' -e telnet margarita-con &
+ "gimlet    4500" Exec exex xterm -display :0 -T 'gimlet-con' -e telnet gimlet-con &
+ "mai-tai   7200" Exec exex xterm -display :0 -T 'mai-tai-con' -e telnet mai-tai-con &
+ "julep     7500" Exec exex xterm -display :0 -T 'julep-con' -e telnet julep-con &
+ "stinger   ct5k" Exec exex xterm -display :0 -T 'stinger-con' -e telnet stinger-con &
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Oct 1999 21:46:47 +0200

On Sat, Oct 02, 1999 at 11:20:19AM -0700, Richard Johnson wrote:
>...

Nope, doesn't happen on my system with your config file.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Oct 1999 03:05:20 +0200

>  > Can you send me your config file, please?

Sigh! Another of these problems that doesn't occur on my machine.
I'm really *really* fed up with such problems!

Please reporrt back if you can find out anything to isolate
it.

Bye

Dominik ^_^