Subject: CVS hippo: Colorset clean up

From: CVS <[email-masked]>
Date: Wed, 20 Oct 1999 10:50:47 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/10/20 10:50:47

Modified files:
	modules        : ChangeLog 
	modules/FvwmBacker: FvwmBacker.c 
	modules/FvwmButtons: FvwmButtons.c draw.c parse.c 
	modules/FvwmForm: FvwmForm.c 
	modules/FvwmIconBox: FvwmIconBox.c 
	modules/FvwmIdent: FvwmIdent.c 
	modules/FvwmPager: FvwmPager.c x_pager.c 
	modules/FvwmScript: FvwmScript.c Instructions.c script.c 
	                    script.h script.y 
	modules/FvwmScript/Widgets: CheckBox.c HDipstick.c HScrollBar.c 
	                            ItemDraw.c List.c Menu.c 
	                            MiniScroll.c PopupMenu.c 
	                            PushButton.c RadioButton.c 
	                            Rectangle.c Swallow.c TextField.c 
	                            VDipstick.c VScrollBar.c 
	modules/FvwmScroll: FvwmScroll.c GrabWindow.c 
	modules/FvwmTaskBar: ButtonArray.c FvwmTaskBar.c Goodies.c 
	modules/FvwmWharf: FvwmWharf.c icons.c 
	modules/FvwmWinList: FvwmWinList.c 

Log message:
Colorset clean up
Replaced Colorset[x % nColorsets] with Colorset[x]
Made sure Colorset[] is big enough by AllocColorset(x) in the right place

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 20 Oct 1999 16:54:19 +0100

> Made sure Colorset[] is big enough by AllocColorset(x) in the right place

There are a couple of places in fvwm/*.c where the [ % nColorsets]
construct is still used.  Dominik could you change these?  I think using
AllocColorset to make sure the colorset array is big enough will be
faster than doing a `% nColorsets' on every reference.

Cheers,
Tim.