Subject: CVS domivogt: * Added $[fg.cs<n>], $[bg.cs<n>], $[hilight.cs<n>] and $[shadow.cs<n>]

From: CVS <[email-masked]>
Date: Sun, 3 Oct 1999 14:23:49 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/10/03 14:23:48

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : functions.c fvwm2.1 move_resize.c 
	libs           : ColorUtils.c Parse.c Picture.c Picture.h 
	                 fvwmlib.h 
	modules        : ChangeLog 
	modules/FvwmBanner: Makefile.am 
	modules/FvwmButtons: FvwmButtons.c parse.c 
	modules/FvwmCpp: Makefile.am 
	modules/FvwmM4 : Makefile.am 
	modules/FvwmTaskBar: FvwmTaskBar.1 
	modules/FvwmTheme: FvwmTheme.1 FvwmTheme.c 

Log message:
* Added $[fg.cs<n>], $[bg.cs<n>], $[hilight.cs<n>] and $[shadow.cs<n>]
parameters to fvwm command lines to fetch colour set colours.
* Added extensive example to FvwmTheme man page.
* GetColor handles colour from coulour set s.
* Documented colour set support for FvwmTaskBar.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 5 Oct 1999 14:07:39 -0400

> parameters to fvwm command lines to fetch colour set colours.

Nice work one thing I noticed, and its possible I'm calling it wrong. Is
that using $[fg.cs<n>] (or any of these variables) in an AddToFunc
causes the variable to be expanded then not at function callign time.

So if I have a function AddToFunction xcpu "I" xcpustate -bg $[bg.cs0] \
-fg $[fg.cs1] -colors $[bg.cs0],.,.,.

It is fixed with the values put in during startup not the ones active
given the current colorset.  I'd be glad to take a look at this if you
would like but I didn't know where if you were still in the middle of
things or not.  

Let me know
Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Oct 1999 12:26:19 +0200

On Tue, Oct 05, 1999 at 02:07:39PM -0400, [email-masked] wrote:
> given the current colorset.

This is because the $[fg.cs1] is expanded as soon as it is encountered.
To get this in your function you will have to wuote the $: '$$[fg.cs1]'.
Not very nice, I agree.  Since the $[xx.cs<n>] variables are not
associated with a window I don't know what we can do about it (except
adding a warning in the man page). The expand() function determines if
it has to expand the variable by checking if a window is associated or
not.  The '$v' variable has the same problem, but since it never changes
you won't notice it.  Any idea is welcome.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 16 Oct 1999 06:55:38 +0200

> you won't notice it.  Any idea is welcome.

Okay, I did what I could.  This should work now.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 20 Oct 1999 08:00:09 -0400

> Okay, I did what I could.  This should work now.

yup nice work.