Subject: Notification: incoming/495

From: [email-masked]
Date: Sun, 24 Oct 1999 21:15:02 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/495

Message summary for PR#495
	From: [email-masked]
	Subject: cursor falls off title bar when moving windows
	Date: Sun, 24 Oct 1999 21:14:59 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Oct 1999 18:34:37 +0200

On Sun, Oct 24, 1999 at 09:15:02PM -0500, [email-masked] wrote:
> >From [email-masked]  Sun Oct 24 21:15:01 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id VAA06202
> 	for <[email-masked]>; Sun, 24 Oct 1999 21:14:59 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Ben Ross
> Version: 2.2.2
> CVS_Date: 
> OS: Linux 2.0.36/2.2.12
> X_Server: XFree86 3.3.5/3.3.1
> Submission from: (NULL) (203.102.212.6)
> 
> 
> This bug wasn't evident in fvwm-2.0.45.
> When a window is moved, the cursor moves off the title bar (or wherever
> it was originally when the window was moved) before the window starts
> moving i.e. the cursor ends up somewhere other than where it
> was first clicked. For some reason this is most noticable when moving the
> window vertically.
> I tracked the problem down to the function InteractiveMove() in move.c
> A fix involves replacing the following code:
> 
>   if (eventp->type == ButtonPress)
>     {
>       DragX = eventp->xbutton.x_root;
>       DragY = eventp->xbutton.y_root;
>     }
>   else
>     XQueryPointer(dpy, Scr.Root, &JunkRoot, &JunkChild, &DragX, &DragY,
>                   &JunkX, &JunkY, &JunkMask);
> 
> 
> with:
>   
>   DragX = eventp->xbutton.x_root;
>   DragY = eventp->xbutton.y_root;
> 
> However, I'm not sure how valid the check for the ButtonPress event is
> and whether this fix breaks something else.

This is a known bug in 2.2.x.  The fix is too complicated to make it
into the 2.2.x series however.  The problem is already fixed in the 2.3.x
betas.  And to comment on your fix:  yes, it *will* break something else,
i.e. if the move was triggered by an event that has no x_root/y_root
member in the event struct (yes, this does really happen sometime).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]