Subject: AIX compilation problem

From: [email-masked]
Date: Fri, 24 Sep 1999 05:09:22 -0500 (CDT)

Full_Name: Oleg Cherkasov
Version: 2.2.2
CVS_Date: 
OS: AIX 4.2.1.0
X_Server: X11R5
Submission from: (NULL) (193.214.111.226)

I have found a problem to compile fvwm2 on AIX 4.2.1.  AIX 4.2.1 does not
have Xmu library.  So some header files are missed on AIX.

I found '#include <X11/Xmu/WinUtil.h>' line in:

./modules/FvwmCpp/FvwmCpp.c
./modules/FvwmM4/FvwmM4.c
./modules/FvwmScroll/FvwmScroll.c

It should be replaced by:

#ifndef _AIX
#  include <X11/Xmu/WinUtil.h>
#endif

In this way FvwmCpp, FvwmM4 and FvwmScroll will be built without any
'missing header' error messages. _AIX is a compiler depended macro.
The compiler is IBM C/C++ 3.1.4.X

By the way the same problem was in fvwm 2.0.46.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 24 Sep 1999 15:27:59 +0200

> By the way the same problem was in fvwm 2.0.46.

I wonder why these include files are necessary. On my Linux FvwmCpp
compiles even without any Xmu includes. I guess FvwmM4 compiles as
well without testing it. FvwmScroll doesn't have any Xum includes
in the current development sources.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Oleg Cherkasov <[email-masked]>
Date: Fri, 24 Sep 1999 16:15:03 +0200

> in the current development sources.

I did not try go deeper to the sources but it could be a mess 'include'
statement.  Somebody simply forget delete it or it was copied with the rest of
stuff in the beginning. Sometimes it happens :-(

Oleg

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Sep 1999 11:00:03 -0400

> stuff in the beginning. Sometimes it happens :-(

I don't know whether the Xmu stuff is needed, but I recently ran
into a similar problem on one of our AIX 4.3 machines where it was
missing the Athena widget sets.  Turned out our support staff
failed to install one of the optional packages.

Now that I look at the machine, (after the package was installed),
the file in question IS on is the machine.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 24 Sep 1999 17:12:07 +0200

> stuff in the beginning. Sometimes it happens :-(

Yes, the symbols defined in the Xmu include files are never used.
I have removed them (but I'm still fighting to compile 2.2.2).

Bye

Dominik ^_^