Subject: CVS domivogt: * GNOME hints fix.

From: CVS <[email-masked]>
Date: Wed, 8 Sep 1999 20:01:15 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/09/08 20:01:15

Modified files:
	.              : AUTHORS ChangeLog NEWS 
	fvwm           : builtins.c functions.c functions.h fvwm.c 
	                 fvwm2.1 stack.c style.c style.h virtual.c 
	modules        : ChangeLog 
	modules/FvwmBacker: FvwmBacker.1 FvwmBacker.c Makefile.am 
	                    root_bits.c 
	modules/FvwmButtons: FvwmButtons.c 
	modules/FvwmWharf: FvwmWharf.c 

Log message:
* GNOME hints fix.
* Stacking order workaround (untested).
* FvwmButtons handles ClientMeassage again.
* FvwmWharf handles ClientMessage.
* FvwmBacker uses colour sets.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 10 Sep 1999 05:36:12 +0300 (IDT)

> * Stacking order workaround (untested).

Yes, this fixed funny problems with Mark's (?) patch.

Regarding the problem Eric reported. Yes, it was.
But now the following works:

  DefaultLayers 6 8 10

Of course, this only works for new windows, you must close existing ones,
since they keep the layer or change their layers using 'Layer 0 8'.

Alternatively, you can place the panel in the normal layer with:

  Style panel StaysPut

Since there is no option to quit panel only in the latest GNOME, you must
'killall panel' for this to be activated.

You can raise windows over the panel now. But any operation with the panel
seems to return it to layer 8, so for now only the first solution works.
And currently sometimes you must Raise/Lower panel first (the known
problem with all windows on startup/restart in session).

So, the problem is that fvwm allows the panel to set its layer other then
the one defined in Style.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 Sep 1999 12:31:35 +0200

> Regarding the problem Eric reported. Yes, it was.

Um, could you give me a hints what exactly you are talking about?
I've been out of touch for several days so I'm not sure about the
status of the various problems. I think Eric(?) already replied
that my patch didn't help with his GNOME panel problem.

> the one defined in Style.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Sep 1999 01:19:53 +0300 (IDT)

> > But now the following works:

Your first suggestion on the GNOME panel problem was 'Style panel StaysPut'.
This still works only until you do some operations with the panel.
After that it places itself to the layer 8 regardless of its style.
On the other thought, this is not a fvwm problem - StaysPut or Layer
style only refers to an initial placement.

One of the suggestions was to try 'DefaultLayers 6 8 10'. Eric reported
that this didn't help too. I tried to reproduce this and it really didn't
work well (supposedly the panel tried to always raise itself over another
window even though they both were on the same layer 8, but I am not sure).
This was a week ago. After the commit (that I am replying to) I have tried
again and now 'DefaultLayers 6 8 10' works well, the panel can be freely
lowered/raised over new windows.

So, unless a new option (ignoring layer hints) added, I think, you can
close this problem.

Regards,
Mikhael.

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Mon, 13 Sep 1999 23:45:47 -0500

On Tue, Sep 14, 1999 at 01:19:53AM +0300,
> lowered/raised over new windows.

Okay, I'll update again and try this. Am I also supposed to use the StaysPut
style?

-- 
Eric Gillespie, Jr. <*> [email-masked]

"Man is a rope, tied between beast and overman--a rope over an abyss.
 A dangerous across, a dangerous on-the-way, a dangerous looking-back,
 a dangerous shuddering and stopping."
 --Friedrich Nietzsche

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Sep 1999 08:54:23 +0300 (IDT)

> Okay, I'll update again and try this. Am I also supposed to use the StaysPut

No, you only need one of them. StaysPut is useless since the panel always
jumps to layer 8, so you must have all windows in this layer.

Regards,
Mikhael.

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Tue, 14 Sep 1999 11:47:28 -0500

Looks like it's working, except for one problem. I have to hide and show
the panel before it will behave. If this is unavoidable, I don't mind, but
I thought you should know anyway.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 15 Sep 1999 14:15:16 +0200

> I thought you should know anyway.

Okay, what have you done in your fvwm configuration? Diy you
use the staysput style or the defaultlayers command? And
how is your panel set up?

Bye

Dominik ^_^

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Wed, 15 Sep 1999 16:22:51 -0500

On Wed, Sep 15, 1999 at 02:15:16PM +0200,
> how is your panel set up?

At the moment, the panel has the "Keep panel below windows" unchecked, and
the relevant fvwm configuration lines are:

DefaultLayers 6 8 10
Style gmc	CirculateSkip, StaysPut
Style panel	CirculateSkip, StaysPut
Style login	StaysPut

It looked to me like fvwm was behaving one way sometimes, and differently
at other times. So, with the above configuration, I started X, tested
whether windows stayed above or below the panel or if they behaved properly,
and then logout. I did this over and over again. About half the time,
things behaved, the other half, the windows were stuck below the panel until
I hid/showed it.

I then tried the same thing without the StaysPut lines, and got the same
result. Since fvwm behaved differently with no changes in configuration,
I still think this is a bug, not a configuration issue.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Sep 1999 13:08:07 +0200

> Style panel	CirculateSkip, StaysPut

You should only use one, either StaysPut or the DefaultLayers command.
If you use both this will again prevent the apps from ending up on the
same layer as normal windows.

> I still think this is a bug, not a configuration issue.

The differences in behaviour are probably caused by panel. What you see
depends on the layer of the panel when fvwm starts up. I guess what you
see is a race condition between panel and fvwm competing to set the
layer hint. The randomness in behaviour should go away if you don't use
StaysPut (since fvwm will not try to modify the layer then).

Bye

Dominik ^_^

---

From: "Eric Gillespie, Jr." <[email-masked]>
Date: Thu, 16 Sep 1999 11:09:39 -0500

On Wed, Sep 15, 1999 at 04:22:51PM -0500,
> Style panel	CirculateSkip, StaysPut

What was happening was I was commenting out StaysPut like this:
Style panel CirculateSkip#, StaysPut. Of course this didn't work, it thought
CirclauteSkip# was an unknown option and when ahead and applied StaysPut.
Everything works now, thanks. Sorry for all the trouble.