Subject: CVS hippo: FvwmTheme: crashes really fast

From: CVS <[email-masked]>
Date: Fri, 17 Sep 1999 07:20:51 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/09/17 07:20:50

Modified files:
	modules/FvwmTheme: FvwmTheme.c 

Log message:
FvwmTheme: crashes really fast
There is some memory corruption going on here and I can't find it

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 17 Sep 1999 15:57:39 +0200

> There is some memory corruption going on here and I can't find it

Do you have some instructions how to produce a crash?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 17 Sep 1999 15:02:18 +0100

> Do you have some instructions how to produce a crash?

Just run it. It crashes for me on the first config line

*FvwmThemeColorSet 7 contrast average ygradient 200 4 blue 1 navy 1 blue
1 navy 1 blue

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 17 Sep 1999 10:08:18 -0400

> Do you have some instructions how to produce a crash?
 
Its actually under the Subject Re: CVS hippo: FvwmTheme can 
use read/write colors

But here is the quick run down.
The theme I'm loading is
*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000

and I'm running on a 24bit display.  I simply dump core when I start
FvwmTheme.  Tim, origionally thought it had something to do with the
contrast stuff, that got committed along with the ReadWrite stuff.

The core comes from a call to free in an XCreateImage.  So right now
Tim, is thinking we need to purify this stuff.  Unfortunatelly my prufiy
won't run under 2.7 so that means I need to rebuild some stuff for
Solaris 2.6 to check that out, but I don't have 2.6 box running 24 bit,
so I'm worried I may not get the same problem there.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 19 Sep 1999 21:44:45 +0200

> Its actually under the Subject Re: CVS hippo: FvwmTheme can 

I already deleted that thread.
 
> so I'm worried I may not get the same problem there.

Whatever. I son't get any crashes with neither Tim's nor
your config line (Linux 2.2.5, XFree 3.3.3).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]