Subject: New Panel question

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 22 Sep 1999 10:33:28 -0500

Dominik or anyone else who can answer my question,

I am now running Fvwm-2.3.9 and I have the Panels working now (thank you for
fixing transient).

Let me setup my question with how I have my panels defined.  Here is a sample:

(NoSize, Icon Monitor.xpm, Panel(right, delay 0, steps 2) LoginsPanel, \
        "Module FvwmButtons -transient LoginsPanel")

Now when I click on a button in this sub-panel it goes away as expected, but it
then restarts and disappears again.  Is this the expected result?  Am I doing
something else wrong?

I have each panel in its own file (for easy editing) and I have the following in
my $HOME/.fvwm2rc file:

###################### Button button-bar Files #######################
# FvwmButtons Configuration file
*FvwmButtonsFile /home/misha21/.fvwm/Buttons
*MainPanelFile /home/misha21/.fvwm/MainPanel
*LoginsPanelFile /home/misha21/.fvwm/LoginsPanel
*AppsPanelFile /home/misha21/.fvwm/AppsPanel
*ArtToolsPanelFile /home/misha21/.fvwm/ArtToolsPanel

Before I put everything in its own file I did have this all in my .fvwm2rc file
and I had the same results.

Any suggestions would be greatly appreciated.

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 22 Sep 1999 18:06:06 +0200

> then restarts and disappears again.  Is this the expected result?  Am I doing

Ugh, yes, it's the expected result. Obviously I should have tried it
myself. The reason is that 'Panel' works just like 'Swallow' with the
'respawn' option set. That means that the application is lurking in
the background as soon as FvwmButtons has been started (you can see
the panel flashing once when FvwmButtons starts up). When you click
in a transient FvwmButtons it exits. The parent module notices that
the panel has died and and restarts it so that the next press on the
panel button can map it - hence the new flash.

You can prevent the flashing by giving the panel a geometry in the
'void' (e.g. FvwmButtons -g -32767-32767 mypanel). I'd like to do
this automatically, but since FvwmButtons doesn't control where
the spawned application will be mapped I don't know what to do
about it. I have to think more about this. 

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 22 Sep 1999 14:46:09 -0500

> about it. I have to think more about this.

Dominik,

I tried your suggestion and it seemed to cause more problems.  Here is what I
did:

(NoSize, Icon Monitor.xpm, Panel(right, delay 0, steps 2) LoginsPanel, \
        "Module FvwmButtons -g -32767-32767 -transient LoginsPanel")

This made the sup-panel squeeze in from the sides and top and bottom.  It also
made it flash/pop up in the middle of my screen.  Oh well...

I would like to say that besides the flashing, I really like this new
implementation of the panels.  It is a lot easier to setup.  This and the
ability to set the button size has made my button bar look and behave almost
like FvwmWharf.

Thank you for the effort you and all the other developers have put into this
window manager.  It is greatly appreciated.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 23 Sep 1999 04:23:00 +0200

> > > then restarts and disappears again.  Is this the expected result?  Am I doing

I've made a new option '-transientpanel' that hides the window instead
of destroying the whole button bar. With this you can avoid the flashing.

> made it flash/pop up in the middle of my screen.  Oh well...

Hm, it seems to work with '-g +9999+9999'...

Argh, someone checked for a position > -30000. No wonder it didn't work.
It's fixed.

> implementation of the panels.

Hah! Finally I could convince you that the new implementation
is better 8-)

> It is a lot easier to setup.  This and the

:-) Thanks.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 24 Sep 1999 02:41:57 +0200

On Thu, Sep 23, 1999 at 03:14:30PM -0500, Robert H. Ford II wrote:
> Dominik,
> 
> I went and retrieved the files you updated:
> 
> > CVSROOT:        /home/cvs/fvwm
> > Module name:    fvwm
> > Changes by:     domivogt        99/09/22 21:26:02
> > 
> > Modified files:
> >         .              : ChangeLog NEWS 
> >         libs           : Makefile.am fvwmlib.h 
> >         modules        : ChangeLog 
> >         modules/FvwmButtons: FvwmButtons.1 FvwmButtons.c 
> >         modules/FvwmTheme: FvwmTheme.c 
> > 
> > Log message:
> > * Improved panels in FvwmButtons (several visual enhancements, -transientpanel
> > option, border width is handled).
> > * Small bugfixed in FvwmTheme.
> > * Renamed libs/Slide.c to libs/WinMagic.c.
> 
> For sanity sake I did a "make distclean" and then ran configure again.
> 
> I get the following error when I compile:
> 
> Undefined                       first referenced
>  symbol                             in file
> GetTopAncestorWindow                FvwmButtons.o

I guess this is just some unfortunate timing. The function
GetTopAncestorWindow and this is in the renamed file
libs/WinMagic.c. You will need a complete update of the source
tree.

Bye

Dominik ^_^