Subject: Re: FvwmPager sometimes disappears

From: Dominik Vogt <[email-masked]>
Date: Sun, 19 Sep 1999 21:50:41 +0200

On Sun, Aug 22, 1999 at 10:16:35PM +0200, TG wrote:
> 
> (latest CVS versions..)
> 
> Sometimes the pager disappears when I restart fvwm.
> 
> My RestartFunction is defined this way:
> 
> AddToFunc RestartFunction
> +	I	Module FvwmPager 0 3
> #+	I	Module FvwmCommandS
> 
> (FvwmCommandS is commented out.)
> 
> When the pager goes away, I can get it back with WindowList, but it has
> a very strange geometry. The y coordinate is just my screenheight, so it
> should appear in the page beneath the current one. But I DON'T have a
> page there, I'm only using two pages, one on the left and the other on
> the right side.
> 
> Another problem is I can't reproduce it many times. I can't find a
> reliable way to reproduce it, it just "happens" sometimes, not very
> often (less 10% of the restarts).
> 
> Hum.. I just discoverd "Recapture" brings the pager back.. (as well
> xbiff, which tends to go away too.)

Did you discover some way to make this happen since you reported
this bug?  I would look into this if I had the slightest hint where
to begin.  Can you provide the output of xwininfo -all of the pager
window when it has the screwed up geometry and after you recovered
it via recapture?

  xwininfo -name FvwmPager -all

or 
  
  xwininfo -id ... -all

(You can find out ther window id with 'xwininfo -root -tree').
 
Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: TG <[email-masked]>
Date: Tue, 28 Sep 1999 15:06:13 +0200

> window when it has the screwed up geometry and after you recovered

(Sorry it took so long for this reply, I had some exams lately and lost
track of some mail.)

It seems the bug is gone, I can't reproduce it anymore.

Regards,

Tung