Subject: Notification: incoming/457

From: [email-masked]
Date: Fri, 10 Sep 1999 05:22:33 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/457

Message summary for PR#457
	From: [email-masked]
	Subject: FvwmIconMan : inconsistency in navigation
	Date: Fri, 10 Sep 1999 05:22:31 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 19 Sep 1999 18:22:17 +0200

On Fri, Sep 10, 1999 at 05:22:33AM -0500, [email-masked] wrote:
> FvwmIconMan (1.3) seems to have a small inconsistency in the way that it
> handles the navigation of icons.
> 
> At the leftmost  icon, 'gotobutton Left'  does nothing.
> At the rightmost icon, 'gotobutton Right' moves to the leftmost icon.
> 
> The relevant portion of my .fvwm2rc file is:
> 
>    *FvwmIconMan*managergeometry 5x1+0-0
>    *FvwmIconMan*action Key Left  N gotobutton Left,  select
>    *FvwmIconMan*action Key Right N gotobutton Right, select
> 
> Repeatedly pressing the left-arrow key will move back to the leftmost icon
> and then stop, whereas repeatedly pressing the right-arrow key will keep
> on
> cycling through the icons, wrapping around from rightmost to leftmost
> icons.

It was a bug in the handling of the 'gotobutton right' function. When
the selected button was in the rightmost column is jumped back to the
button in the top left corner. I have fixed this in the development
code.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]