Subject: FvwmButtons suggestions

From: Nadim Saeed <[email-masked]>
Date: Thu, 2 Sep 1999 09:45:21 -0700 (PDT)

Dominik,
     since you are currently working on FvwmButtons, I had a couple of
questions/requests relating to that module.

 1. If one defines an FvwmButton with a panel, could you have fvwm
    automatically add a small arrow-like indicator inside that button to
    indicate the existence and direction of the panel (the arrow I'm talking
    about would be similar to Netscape's small black arrow-indicator inside
    its "Back" or "Forward" buttons)

 2. Is there a way to toggle an FvwmButton (pressed-in/out look) to indicate
    different states ?  In other words, if I wanted to have a button that
    would tell me whether "Paging" is enable or not; or if I wanted a button
    that would indicate if I have auto-locking enabled or not.

    AddToMenu MiniScrollMenu
    +       "ON"                    EdgeScroll 100 100 (PRESSED-LOOK)
    +       "OFF"                   EdgeScroll 0 0     (NON-PRESSED-LOOK)

    *FvwmButtons Paging clamp.xpm Popup MiniScrollMenu

    -OR-

    *FvwmButtons Paging clamp.xpm (Pressed EdgeScroll 100 100, EdgeScroll 0 0)

    -OR-

    any other format that would make sense (could be tied-in to panels)

Thanks

 - Nadim (please cc replies)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 Sep 1999 00:32:44 +0200

>     its "Back" or "Forward" buttons)

You can simply use an icon in the panel button (at least with the new
panel implementation, but I guess it's the same with the old one).

>     different states ?

No.

>     In other words, if I wanted to have a button that

Phew, how would FvwmButtons know what you want? Especially to watch
fvwm configuration options is nigh impossible without re-implementing
fvwm in FvwmButtons. I'm sure there must exist an applications that
can indicate generic state changes with pixmaps. Such an application
could simply be swallowed (e.g. to indicate new mail).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 Sep 1999 00:15:07 +0200

>     its "Back" or "Forward" buttons)

'k you can have it now:

  *FvwmButtons(Panel(indicator) ...)
                     ^^^^^^^^^

Bye

Dominik ^_^