Subject: New FvwmButtons Panel problems

From: "Robert H. Ford II" <[email-masked]>
Date: Fri, 10 Sep 1999 11:35:42 -0500

All,

I am running Fvwm Version 2.3.8 compiled on Sep  9 1999 at 14:24:56
(fvwm-snap-19990906).

First let me start off by saying that I like to have different files for all the
different Modules I use.  So I created the following files for FvwmButtons and
the associated Panels: $HOME/.fvwm/Buttons (main buttons file),
$HOME/.fvwm/Fvwm, $HOME/.fvwm/Logins, $HOME/.fvwm/Applications and
$HOME/.fvwm/ArtTools.

Here is what I have in my $HOME/.fvwm2rc for the Buttons:

###################### FvwmButtons Files #######################
# FvwmButtons and sub-panel Configuration file
*FvwmButtonsFile /home/misha21/.fvwm/Buttons
*FvwmButtonsFvwmFile /home/misha21/.fvwm/Fvwm
*FvwmButtonsLoginsFile /home/misha21/.fvwm/Logins
*FvwmButtonsApplicationsFile /home/misha21/.fvwm/Applications
*FvwmButtonsArtToolsFile /home/misha21/.fvwm/ArtTools

Here is the contents of my "$HOME/.fvwm/Buttons" file:
######################################################
Fore rgb:ff/ff/ff
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Frame 0
Geometry +0+152
ButtonGeometry 65x65
Columns 1
BoxSize smart
Font -*-helvetica-medium-r-*-*-12-*
Padding 0 0

(1x6,Swallow "FvwmPager" `FvwmPager 0 5`)
(Icon fvwm4.xpm, Panel(left, delay 3, steps 16) Fvwm, \
        "Module FvwmButtons -transient FvwmButtonsFvwm")
(Center,Padding 2,Swallow "ASClock" "Exec asclock -24 -led red -shape -exe 'Auto
LockerActive.sh' &")
(Center,NoSize,Icon monitor-e0.xpm,Action \
        'Exec "ihgp74x123"  exec xterm -title ihgp74x123 -bg antiquewhite -fg bl
ack -bd magenta4 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(NoSize,Icon hostmanager.xpm,Action "Function Find-or-Start tkrl")
(NoSize,Title Logins, Icon Monitor.xpm, Panel(left, delay 3, steps 16) Logins, \
        "Module FvwmButtons -transient FvwmButtonsLogins")
(NoSize,Icon tool.xpm, Panel(left, delay 3, steps 16) Applications, \
        "Module FvwmButtons -transient FvwmButtonsApplications")
(NoSize,Icon Gandalf48x48.xpm, Panel(left, delay 3, steps 16) ArtTools, \
        "Module FvwmButtons -transient FvwmButtonsArtTools")
######################################################

And here is the contents "$HOME/.fvwm/Fvwm":
######################################################
Fore rgb:ff/ff/ff
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Frame 0
Geometry +65+542
ButtonGeometry 65x65
Rows 1
BoxSize smart
Font -*-helvetica-medium-r-*-*-12-*
Padding 0 0
########## PANEL Fvwm
(Icon Jlock.xpm,  \
        Action(Mouse 1) 'Exec "" exec AutoLocker.sh &', \
        Action(Mouse 2) NOP, \
        Action(Mouse 1) 'Exec "" exec AutoLockerExit.sh &')
(NoSize,Icon adept.xpm, Action 'Exec "Adept" Radept &')
(NoSize,Icon power.xpm, Action Quit)
# (NoSize,Icon power.xpm, Action 'Exec "" exec /usr/dt/bin/dtaction ExitSession'
)
######################################################

The other "Panel" file are similar to this one, if needed I can post them.

Now when I start up my session I get the following error messages:

-transient: Couldn't open config file FvwmButtonsFvwm
-transient: No buttons defined. Quitting
-transient: Couldn't open config file FvwmButtonsLogins
-transient: No buttons defined. Quitting
-transient: Couldn't open config file FvwmButtonsArtTools
-transient: No buttons defined. Quitting
-transient: Couldn't open config file FvwmButtonsApplications
-transient: No buttons defined. Quitting

Without the "-transient" all the Panels start in the opened state.  If I close
the "Fvwm" Panel then click on the button that should open the panel the image
in that buttons goes away and the Panel never starts.

What am I doing wrong here?  I had no problems setting up the old Panels (except
for buttons sizes) but I sure am have tons of problems with this version.

Any and all help would be greatly appreciated.

BTW, thank you for the FvwmButtonsButtonGeometry option.  I can now use my Wharf
Pixmap without having to play the "What Size should I make this button" game
(now if I could only get these panels working).

Bob Ford II
-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 Sep 1999 13:21:09 +0200

On Fri, Sep 10, 1999 at 11:35:42AM -0500, [email-masked] wrote:
> ...

Could you try if it works if you have all the config lines in your main
.fvwm2rc?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Robert H. Ford II" <[email-masked]>
Date: Mon, 13 Sep 1999 11:24:21 -0500

> Could you try if it works if you have all the config lines in your main
Yes, unfortunately I tried this after I sent me message.  It behaved no
differently.  Sigh...  I went back to fvwm-2.3.7 until I or anyone else can
figure this out.

Bob

_/    _/   _/  _/   _/         _/_/_/_/_/_/     Email: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Sep 1999 11:47:20 +0200

> differently.  Sigh...  I went back to fvwm-2.3.7 until I or anyone else can

Ah, um, I think you got a version where -transient was not implemented.
I wrote the man page bofre the patch. Furthermore I made a cut-and-paste
error that would have caused it to fail if used together with the -g option.
It's all fixed now.

Bye

Dominik ^_^