Subject: CVS hippo: FvwmTheme can use read/write colors

From: CVS <[email-masked]>
Date: Tue, 14 Sep 1999 07:27:46 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/09/14 07:27:46

Modified files:
	libs           : ColorUtils.c Colorset.c fvwmlib.h 
	modules        : ChangeLog 
	modules/FvwmTheme: FvwmTheme.1 FvwmTheme.c 

Log message:
FvwmTheme can use read/write colors

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 16 Sep 1999 09:52:40 -0400

Tim, not to point fingers but you are the only one who made changes here
recentlly.  This is on startup of FvwmTheme and no there isn't another
one running

#0  0xff04590c in realfree () from /usr/lib/libc.so.1
#1  0xff0461d0 in cleanfree () from /usr/lib/libc.so.1
#2  0xff045398 in _malloc_unlocked () from /usr/lib/libc.so.1
#3  0xff0452b4 in malloc () from /usr/lib/libc.so.1
#4  0xff039aa4 in calloc () from /usr/lib/libc.so.1
#5  0xff220c50 in XCreateImage () from /usr/local/X11R6/lib/libX11.so.6.0
#6  0x17074 in CreateGradientPixmap (dpy=0x2cf08, d=191064, gc=0x2e6b0, type=67, 
    g_width=255, g_height=255, ncolors=128, pixels=0x2ed40, in_drawable=0, d_x=0, d_y=0, 
    d_width=0, d_height=0) at Graphics.c:599
#7  0x17ae8 in CreateGradientPixmapFromString (dpy=0x2cf08, d=54525953, gc=0x2e6b0, 
    type=67, action=0x2ed40 "", width_return=0xffbef2ec, height_return=0xffbef2e8)
    at Graphics.c:806
#8  0x139bc in parse_colorset (line=0x2b6d6 "128 #515178 #000000\n") at FvwmTheme.c:478
#9  0x12fcc in parse_config_line (
    line=0x2b6a8 "*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000\n")
    at FvwmTheme.c:191
#10 0x13f9c in parse_config () at FvwmTheme.c:602
#11 0x12ea0 in main (argc=6, argv=0xffbef5fc) at FvwmTheme.c:115

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 16 Sep 1999 16:02:01 +0100

> #3  0xff0452b4 in malloc () from /usr/lib/libc.so.1

Look like I've corrupted something. I had something like this when I
added
the ability to set the foreground color to "contrast" but I can't get it
to fail now. Could you hack out the two bits of code concerned with
"contrast" and see if it still fails?

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 16 Sep 1999 12:05:57 -0400

> "contrast" and see if it still fails?

Tim,  I commented out the stuff around line 540 dealing with contrast 
that was the only stricking thing I noticed dealing with contrast.  
Did I miss something else. The theme I'm loading is 
*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000
and I'm running on a 24bit display could this have something to do 
with the readwrite color stuff?

Brad

---

From: Tim Phipps <[email-masked]>
Date: Fri, 17 Sep 1999 13:23:31 +0100

> that was the only stricking thing I noticed dealing with contrast.

I don't think it's anything in the recent changes. I've just added a
free() of
something that was malloced and it crashes on the first config line. The
free() is just after InitGetConfig().

Hopefully this will now crash with everybody and someone with purify
will find the bug.

Cheers,
Tim.