Subject: CVS domivogt: * Fixed old bug with xterm (maximize; change fint; normalize).

From: CVS <[email-masked]>
Date: Sun, 19 Sep 1999 15:58:41 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/09/19 15:58:41

Modified files:
	.              : AUTHORS ChangeLog NEWS 
	docs           : ChangeLog FAQ TODO 
	fvwm           : builtins.c events.c fvwm.h fvwm2.1 
	                 move_resize.c style.c style.h window_flags.h 
	modules        : ChangeLog 
	modules/FvwmIconMan: fvwm.c x.c xmanager.c 
	modules/FvwmScroll: FvwmScroll.c 
	modules/FvwmWinList: FvwmWinList.1 FvwmWinList.c 

Log message:
* Fixed old bug with xterm (maximize; change fint; normalize).
* New style 'ResizeOpaque/ResizeOutline'.
* Removed debug messages in IconMan.
* Fixed bug in IconMan (two buttons hilighted at the same time).
* FvwmScroll quietly exits when asked to add scrollbars to the root window.
* Removed snprintf in FvwmWinList.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 Sep 1999 17:56:48 +0200

> * Removed snprintf in FvwmWinList.

Or I am missing something or there are these problems with ResizeOpaque:

* after 'Style * ResizeOpaque' opaque resizing works for xv or rxvt, but
  not for xterm or netscape

* only when opaque resizing works, ESC or other mouse button click does
  not work (cancel resizing)

* only when opaque resizing works, there is always a gap of one point on
  the right and bottom

* this can be related to the previous, when you try to resize xv operation
  window (name 'xv controls') from the left or/and top border, the effect
  is moving to the left or/and top by one pixel

* misspelling (redundant space and repeating) about ResizeOpaque/
  ResizeOutline in fvwm2.1 (sorry I have no time to fix)

* not a bug: ResizeOpaque is nice to have, thanks

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 20 Sep 1999 19:52:25 +0200

> Or I am missing something or there are these problems with ResizeOpaque:

Did I claim there were no bugs? :-)

>   not for xterm or netscape

? You need to be a bit more specific than simply stating that
'it does not work'.

>   not work (cancel resizing)

Fixed.

> * only when opaque resizing works, there is always a gap of one point on

A gap between the bottom of what and what else? The window was one pixel
less wide and high during the move. This is fixed.

>   is moving to the left or/and top by one pixel

Fixed.

>   ResizeOutline in fvwm2.1 (sorry I have no time to fix)

Fixed.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 Sep 1999 21:05:06 +0200

> Did I claim there were no bugs? :-)

No, but there is always a possibility of a user fault. :)

> ? You need to be a bit more specific than simply stating that

I mean I get outline resizing instead of opaque. This is my fault.
'Style * ResizeOpaque' starts to work for new windows only. You can guess,
which windows were new in my example.

> >   not work (cancel resizing)

Nice. Although, I think, there must be a call to draw window borders
and title text after pressing ESC (this is not needed for ResizeOutline).

> less wide and high during the move. This is fixed.

Between the bottom of the window and the screen edge. You fixed it.

> >   ResizeOutline in fvwm2.1 (sorry I have no time to fix)

Yes, everything is fixed.

> Dominik

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Sep 1999 02:18:39 +0200

> which windows were new in my example.

As always you have to do a recapture because of the way in
which styles are implemented.

> and title text after pressing ESC (this is not needed for ResizeOutline).

Uh, doesn't it do that? It definitely does on my setup.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 21 Sep 1999 07:55:59 +0200

> Uh, doesn't it do that? It definitely does on my setup.

I think that shots will describe it better than I can.
Even window buttons can be blank too, if I narrow window.

Regards,
Mikhael.