Subject: FvwmPager

From: Tomas Ogren <[email-masked]>
Date: Thu, 30 Sep 1999 16:57:48 +0200

I was looking through the code for FvwmPager and found a thing... in
FvwmPager.c around line 1550:

      if (flags & XValue)
      {
        window_x = g_x;
        usposition = 1;
      }
      if (flags & YValue)
      {
        window_y = g_y;
        usposition = 1;
      }
      if (flags & XNegative)
      {
        xneg = 1;
      }
      if (flags & YNegative)
      {
        window_y = g_y;
        yneg = 1;
      }

That flags & XNegative difference looks wrong.. is it? Shouldn't it also
have a window_x = g_x ?

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 30 Sep 1999 18:03:36 +0200

> FvwmPager.c around line 1550:

... which dom fixed ...

/Tomas