Subject: refresh of borderless transparent rxvt

From: [email-masked]
Date: Sun, 26 Sep 1999 20:51:10 -0500 (CDT)

Full_Name: David Plaut
Version: 2.2.2
CVS_Date: 
OS: RedHat Linux 5.1 (kernel 2.2.12)
X_Server: AcceleratedX LX (laptop) 4.1.2
Submission from: (NULL) (128.2.188.47)

When I generate a transparent rxvt (version 2.6.1) with -inheritPixmap and
with no border (BorderWidth 0, HandleWidth 0) under fvwm (version 2.2.2),
it works fine initially but then does not refresh if exposed by lowering 
a partially occluding window.  The newly exposed region is drawn grey.  
If I refresh with Control-L, the entire window is grey.  If I move the 
window, it again correctly displays the underlying root window pixmap.

Strangely, everything works fine if I used borders of width 2 (but not 1).

>From my .fvwm2rc:
Style "rxvt" Icon xterm.xpm, NoTitle, Sticky, HandleWidth 0, BorderWidth 0

To reproduce the problem, run "rxvt -inheritPixmap", then cover and
uncover
the window (doesn't seem to matter if you lower and raise the window
itself
or manipulate another window).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 Sep 1999 12:15:39 +0200

> or manipulate another window).

There were several such problems in the past (i.e. with older versions
of fvwm/rxvt). Today (i.e. with the fvwm beta 2.3.8 and with the
2.6PRE4 version of rxvt) you should encounter no such problem.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]