Subject: FvwmScript/scanner.l flex is jammed

From: Dan Espen <[email-masked]>
Date: Thu, 23 Sep 1999 10:14:58 -0400

I'm now  getting this on  both  my home  system and at  work.  Nothing
seems to have changed in scanner.l.  At home I'm using  lex, and I get
a different message suggesting I increase  a limit.  I tried that, and
it exceeds  some other limit.  I increased  that, and exceeded another
limit.

Anyway, I'm stuck.

gnumake[1]: Entering directory `/u/tools/dane/fvwm/build_version-2_3_9/modules/FvwmScript'
flex   ../../../version-2_3_9/modules/FvwmScript/scanner.l && mv lex.yy.c scanner.c
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: unrecognized rule
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 102: bad start condition name
flex scanner jammed

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 23 Sep 1999 15:23:56 +0100

> it exceeds  some other limit.  I increased  that, and exceeded another

I removed the files that lex/flex and yacc/bison generate while I'm
hacking FvwmScript. I'll put them back when I'm finished so this should
go away then.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 Sep 1999 09:57:22 -0400

> hacking FvwmScript. I'll put them back when I'm finished so this should

Well, I waited, and now with this mornings CVS, I'm still having
problems compiling scanner.l:

flex   ../../../version-2_3_9/modules/FvwmScript/scanner.l && mv lex.yy.c scanner.c
"../../../version-2_3_9/modules/FvwmScript/scanner.l", line 104: unrecognized rule

---

From: Tim Phipps <[email-masked]>
Date: Wed, 29 Sep 1999 15:11:52 +0100

> "../../../version-2_3_9/modules/FvwmScript/scanner.l", line 104: unrecognized rule

Oh dear.  I committed scanner.c later than scanner.l so I hoped that you
wouldn't have to build it.  Does anyone know of a way of getting CVS to
get the timestamps in order on scanner.l and scanner.c?

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 Sep 1999 11:08:30 -0400

> get the timestamps in order on scanner.l and scanner.c?

OK, I touched scanner.c and now I can build.

I'm not clear on why I'm getting these errors.  What did you do to get
scanner.l to create scanner.c?  If there is  a problem with scanner.l,
shouldn't it be solved?

---

From: Tim Phipps <[email-masked]>
Date: Wed, 29 Sep 1999 16:47:10 +0100

> scanner.l to create scanner.c?  If there is  a problem with scanner.l,

I don't have a problem. When I started hacking FvwmScript I modified
scanner.l and script.y and typed make.  The problem I had was that
scanner.c, script.c and script.h were generated files and in the CVS
repository. I couldn't `cvs update' because it would just replace the
new contents with the old ones.  I removed the generated files from CVS
and it solved my problems.  Then there were some reports of people being
unable to buil scanner.c.  I think this is due to different versions of
lex and yacc (I use flex and bison).  I then put the generated files
back hoping that anyone doing a `cvw update' would get the files
restored with newer dates and they wouldn't have to use lex or yacc, it
seems like this doesn't happen.

Maybe we should remove the lex and yacc'ing from the makefile. There is
nothing machine dependant in their outputs. The problem then is that
anyone editing the lex and yacc input files will have to run them by
hand to produce the output. I don't know how hard this would be to do,
it might all happen due to autoconf.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 Sep 1999 14:48:56 -0400

> it might all happen due to autoconf.

Doesn't  seem to me  to be a good idea.   I'm running flex 2.3.8.  I'd
like to upgrade if that will help.  Which version are you running?

---

From: Tim Phipps <[email-masked]>
Date: Thu, 30 Sep 1999 17:57:27 +0100

> like to upgrade if that will help.  Which version are you running?

2.5.4 but only because the Solaris 2.6 lex falls over on this file. I
don't think there is a problem with the file it's just that some lex's
aren't as tough as others.  I think this problem has been around since
FvwmScript was first created, it's just that the dates on the files are
different now and make it trying to recreate it.  What we need is a way
to make anyone using CVS to have a more recent scanner.c than their
scanner.l. We also need to make sure the timestamps in any tar files we
build are sensible.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Thu, 30 Sep 1999 14:31:44 -0400

> scanner.l. We also need to make sure the timestamps in any tar files we

Getting hold of 2.5.4 fixed my flex/lex problem.

Maybe I'm dense, but now I appreciate how this isn't a solution.

Here's a   guess,  if both   files are  committed  with changes,   the
timestamps will  always be set on  checkout  based on their alphabetic
order:

me> rm scanner*
me> cvs update
cvs server: Updating .
U scanner.c
U scanner.l
cvs server: Updating Scripts
cvs server: Updating Scripts/some_nice_icons
cvs server: Updating Widgets
me> ls  -altr scanner*
-rw-r-----  1 dane  bae   3658 Sep 30 14:08 scanner.l
-rw-r-----  1 dane  bae  72465 Sep 30 14:08 scanner.c