Subject: Re: Today's changes

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 10:30:23 +0200

On Wed, Sep 01, 1999 at 04:53:03AM +0300, [email-masked] wrote:
> After today's (31 Aug) changes I see two problems.
> 
> Dominik, when I press a button in FvwmButtons, it takes modulo 2 or
> substructs 2 when possible (I don't know which) from both x and y
> button positions (there are 4x4=16 buttons). I don't use panels.

Sorry, I don't understand what you want to tell me. Are you
saying that the contents of the buttons has shifted compared
to earlier versions? But I can't imagine you see all or some
of your buttons at x=0/1 y=0/1 (isn't that what x modulo 2
and y modulo 2 mean?).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 1 Sep 1999 13:46:25 +0300 (IDT)

> of your buttons at x=0/1 y=0/1 (isn't that what x modulo 2

The contents is ok, it is only the wrong button activated, when I
press buttons with x and y positions 2 and 3 (starting from 0).
So if I press (1,0) I get (1,0), but if I press (3,2) I get (1,0) too.

The configuration for the buttons is in
  http://wm-icons.dhs.org/data/wm-icons-current/etc/fvwm2rc-compact-buttons

Also maybe `locate Mikhael-desk-1152x864.gif` helps.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 14:53:53 +0200

>   http://wm-icons.dhs.org/data/wm-icons-current/etc/fvwm2rc-compact-buttons

Yes, I can confirm the problem. I'm on it.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 15:13:45 +0200

> So if I press (1,0) I get (1,0), but if I press (3,2) I get (1,0) too.

It's fixed now. Can you please verify if the fix works with
buttons in containers in containers too (both levels of containers
must not start in button 0/0 of the parent).

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 1 Sep 1999 17:14:47 +0300 (IDT)

> must not start in button 0/0 of the parent).

Yes, it works with two container levels non starting from (0,0) too.
Good work.

Regards,
Mikhael.