Subject: Notification: incoming/461

From: [email-masked]
Date: Mon, 13 Sep 1999 10:17:19 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/461

Message summary for PR#461
	From: [email-masked]
	Subject: Maximize 0 100 bug
	Date: Mon, 13 Sep 1999 10:17:18 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Bob Woodside <[email-masked]>
Date: Mon, 13 Sep 1999 21:17:43 -0400

[email-masked] wrote:
> 
> Something with the Maximize function seems to be broken.  Here's
> the line in the config file:
> 
> Mouse 1         T       A       Maximize 0 100
> 
> Start an xterm with xterm -geometry 80x25 and click its title bar.
> The window stretches to something like 90% of the screen height,
> with a gap at the bottom of the screen.  Interestingly enough,
> repeating the same test with Netscape brings it to a full 100%.

	This is because apps like xterm and its cousins constrain their window
sizes to increments of the character cell size, not pixels.

	To see this in action, try slowly drag-resizing a corner of your xterm
window. You'll see the rubber band resist moving, then suddenly junp
several pixels (the height or width of a character). Then try the same
thing with a Netscape window, and observe the rubber band moving
smoothly.

	The degree of imprecision in fitting your screen size depends on the
dimensions of the font you use, but it's simply a characteristic of the
application.

- Bob
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Sep 1999 08:46:58 +0300 (IDT)

On Mon, 13 Sep 1999, Bob Woodside wrote:

> > Start an xterm with xterm -geometry 80x25 and click itstitle bar.

The first my reaction was to write a similar answer, but I tested this and
yes, it always causes a window like Netscape to have a gap of two pixels
and in some cases it causes a window like xterm to have one line or column
less than maximally possible, so the gap seems to be large.
I have fixed this.

Lee, please test again. Supposing your font is 7x14, it is ok to have a
gap for xterm on X less than 7 and on Y less than 14 pixels.
For your resolution 800x600 it is larger than 99% for X and 97.7% for Y.

Regards,
Mikhael.