Subject: FvwmPager 'permanently' out of sync

From: Neil Bird <[email-masked]>
Date: Wed, 08 Sep 1999 12:59:15 +0100

OK, this problem that I've mentioned before is exacerbated under the
latest snapshot.

  With:

Style "dtcm"            Sticky, NoIcon

  and:

toolwait dtcm -geometry 754x666+187+50 -icon

  ... whenever I start up dtcm, it's open window appears in Fvwmpager, but
I never see the window itself (I wouldn't expect to, starting it iconic).
Why does FvwmPager get a map request? If it's supposed to, why not the
unmap? Iconising dtcm normally makes it go away from FvwmPager correctly.

  Quitting and restarting dtcm makes this happen everytime now.

  Any ideas what I can do to trace the problem?

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 115 days remaining
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Sep 1999 15:06:39 +0200

> unmap? Iconising dtcm normally makes it go away from FvwmPager correctly.

Ah, I guess fvwm forgets to tell the modules that the window is
iconified immediately. I'll have a look at the code.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Sep 1999 15:10:24 +0200

> unmap? Iconising dtcm normally makes it go away from FvwmPager correctly.

Fvwm sends the 'M_ICONIFY' package before the 'M_MAP' package. I guess
this is what confuses the pager.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Sep 1999 21:29:33 +0200

>   Any ideas what I can do to trace the problem?

Neil, please replace the beginning of the process_message function
in FvwmPager.c with this code and record the output when your problem
occurs.

void process_message( FvwmPacket* packet )
{
  unsigned long type = packet->type;
  unsigned long length = packet->size;
  unsigned long* body = packet->body;

  switch (type)
    {
    case M_ADD_WINDOW:
fprintf(stderr,"add window: 0x%x\n", packet->body[0]);
      list_configure(body);
      break;
    case M_CONFIGURE_WINDOW:
fprintf(stderr,"configure window: 0x%x\n", packet->body[0]);
      list_configure(body);
      break;
    case M_DESTROY_WINDOW:
fprintf(stderr,"destroy window: 0x%x\n", packet->body[0]);
      list_destroy(body);
      break;
    case M_FOCUS_CHANGE:
      list_focus(body);
      break;
    case M_NEW_PAGE:
      list_new_page(body);
      break;
    case M_NEW_DESK:
      list_new_desk(body);
      break;
    case M_RAISE_WINDOW:
      list_raise(body);
      break;
    case M_LOWER_WINDOW:
      list_lower(body);
      break;
    case M_ICONIFY:
fprintf(stderr,"iconify: 0x%x\n", packet->body[0]);
    case M_ICON_LOCATION:
      list_iconify(body);
      break;
    case M_DEICONIFY:
fprintf(stderr,"deiconify: 0x%x\n", packet->body[0]);
      list_deiconify(body);
      break;

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]