Subject: Another FvwmAuto problem

From: [email-masked]
Date: Mon, 13 Sep 1999 10:04:55 -0500 (CDT)

Full_Name: Lee Skinol
Version: Latest CVS
CVS_Date: Sept 12
OS: Linux 2.2.12
X_Server: XFree 3.3.2
Submission from: (NULL) (168.143.0.8)

Because you can never complain about FvwmAuto enough... ;)

It seems as though something isn't right with FvwmAuto, in that it doesn't
always raise a window.  With two overlapped xterms on-screen, click the
title bar on window #2.  It should be focuses and on top.  Then slide the 
mouse (medium speed) from window #2 to window #1.  Window #1 gets the 
focus, but doesn't raise.  Slide the mouse back to window #2, and then
back to window #1, and this time window #1 gets the focus and raises.

In playing with it, it seems as though a window won't raise until the
second time the mouse enters it.

Here's a small config file:

Key F3          A       M       Iconify

AddToFunc RestartFunction
 + I Module FvwmAuto 700

AddToFunc InitFunction
 + I Module FvwmAuto 700

######################## Menus ###################
DestroyMenu MenuFvwmRoot
AddToMenu MenuFvwmRoot  "Root Menu"             Title
+                       "&1. XTerm"             Exec exec xterm
+                       "&2. Rxvt"              Exec exec rxvt
+                       ""              Nop
+                       "&F. Refresh Screen"   Refresh
+                       "&C. Recapture Screen" Recapture
+                       ""              Nop
+                       "&X. Exit Fvwm" Popup MenuFvwmQuitVerify

DestroyMenu MenuFvwmQuitVerify
AddToMenu MenuFvwmQuitVerify "Really Quit Fvwm?" Title
+ "&Q. Yes, Really Quit" Quit
+ "&R. Restart Fvwm2"    Restart fvwm2
+ "&X. Just an Xterm"    Restart xterm
+ "&N. No, Don't Quit"   Nop

AddToFunc "InitFunction" I Module FvwmAnimate
AddToFunc "RestartFunction" I Module FvwmAnimate

Thanks,
Lee

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Sep 1999 12:08:11 +0200

> second time the mouse enters it.

Okay, it's fixed, but I'm not sure if one of the other bugs wil reappear
now. Could you please check this, Lee?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]