Subject: Re: Gnome: Bug(?)/questions (future Faq ?)

From: Dominik Vogt <[email-masked]>
Date: Thu, 9 Sep 1999 00:50:48 +0200

On Mon, Jul 05, 1999 at 12:02:44PM +0200, Olivier Chapuis wrote:
> 3. Save current setup.
> I think that the following procedure show a bug somewhere.
> a) Close the session saveing the current setup with, say, a
> Gnome-Terminal on Desk 0 and Page (3,2) with a geometry of +60+10.
> b) First restart: I've got my Gnome-Terminal at the good place (D 0,
> P (3,2) geo +60+10).
> c) Close the session again but without saving the current setup.
> d) startx again: I've got a Gnome-Terminal on Desk 0, page (1,1) and
> geometry +0+0.

I think I finally pinned it down. The gnome code in fvwm
is responsible for keeping certain GNOME hints (like the
desk the window is on). So it's important that the proper
GNOME_Set... function is called every time one of the
settings that GNOME is interested in changes. I guess this
is not alwasy done. In fact I already discovered one situation
where this is the case. Perhaps you could try the latest CVS
and see of the original problem is gone (the chance isn't
very high, but still).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 10 Sep 1999 07:59:25 +0200

> and see of the original problem is gone (the chance isn't

Hello,
I try again the procedure. No more problem :o). Perhaps this need
more tests, I will e-mail if I see some problems.
Note that I try also with the SaveQuitSession fvwm function
but it seems that this function save nothing or there is something
that I do not understand (do I need to say some thing to fvwm at
new session start for my saved session applied ?).
An other note: Gnome use a function with two options 
save-session [--kill --query] 
the --help option say
save-session options
  --kill                      Terminer la session (finish the session)
  --query                     Ask the user
"save-session --kill" do "SaveQuitSession"
I imagine that you know that, but these may be usefull for a fvwm-gnome-faq.
Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 11 Sep 1999 01:27:27 +0300 (IDT)

On Fri, 10 Sep 1999, Olivier Chapuis wrote:

> I try also with the SaveQuitSession fvwm function
> but it seems that this function save nothing

I have found out when it *does* save. After you save session using a gnome
facility (menu or save-session), SaveQuitSession and SaveSession start to
work (save current session). Otherwise, they don't work (a session is
saved, but gnome restores the previous session on the next start-up).

I will try to fix this, but currently I can only guess why this happens.
Maybe someone else, who knows XSMP, can help out here?

> "save-session --kill" do "SaveQuitSession"

Yes, and save-session without arguments is what SaveSession must do.

BTW, a comment in save-session.c says that "there is no way to request
a shutdown without a save". I don't remember that XSMP says that this
is impossible, but if this is true, QuitSession (without saving) is
impossible. Ok, currently it does not save anyway, only exits. :)

Regards,
Mikhael.