Subject: Notification: incoming/454

From: [email-masked]
Date: Thu, 2 Sep 1999 23:06:10 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/454

Message summary for PR#454
	From: [email-masked]
	Subject: Build breaks with Sun compiler
	Date: Thu, 2 Sep 1999 23:06:09 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: [email-masked] (Paul D. Smith)
Date: 03 Sep 1999 16:21:10 -0400

%% Regarding Notification: incoming/454;
%% [email-masked] writes:

  f> fvwm/fvwm.h uses __attribute__((__noreturn__)) which is a gcc
  f> specific extension, and is not available on at least Sun's
  f> compiler (and probably others).

Ouch.  __attribute__ is supposed to be tested for and turned into an
empty macro if unavailable.  This is done already in libs/fvwmlib.h, but
it either needs to also be added to fvwm/fvwm.h, or fvwm/fvwm.h needs to
#include libs/fvwmlib.h.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]