Subject: Re: FvwmIconMan and fvwm packets

From: Brad Giaccio <[email-masked]>
Date: Wed, 1 Sep 1999 08:33:38 -0400

On Tue, Aug 31, 1999 at 11:17:19PM +0200, Dominik Vogt wrote:
> First of all the IconMan looks really strange when I start it during
> fvwm startup. It creates four windows, the first two stretch all over
> the screen and the other two have the right size but are not on the
> current page (screenshot attached).  Is that on purpose? If I kill
> IconMan and restart it while fvwm is still running, all windows end up
> on the current page.
>

Actually you should get three that strech all the way across, and one of
the other two winds up on desk 0 page 1 1, and desk 1 page 0 1. and only
the three that stech are defined as sticky.  The idea is the one on page
1 1 is just for gimp windows which are defined as StartsOnPage 0 1 1.
The other does the same thing only for my gui builder.  So in a word yes
that is how it is supposed to look.

> 
> Yup, it really seems to be what I suspected. Since we implemented
> colour set support, a ConfigureNotify event triggers the function
> 
> force_manager_redraw() -> draw_manager() -> resize_manager() ->
> resize_window() -> XMoveResizeWindow!!
>                    ^^^^^^^^^^^^^^^^^
> 
> I made a patch that
> 
>  - eats up all ConfigureNotify events from the server before
>    doing anything
>  - only redraws if something has changed
> 
> Does that help?

I just tested your commit and it seems to have taken care of it.  I'll
use it through today and let you know.  As for your odd BadMatch message,
could it be something todo with that XMoveResizeWindow listed above.

Brad.

P.S. on a FvwmButtons note, another thread had mentioned some odd
behavior with buttons, I think a problem I'm having is related.  I just
have one button that performs an action (Close) defined.  And when I
click it nothing seems to happen, this may be related to the others
threads comment about some modulous stuff gone ary.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 16:15:34 +0200

> could it be something todo with that XMoveResizeWindow listed above.

I don't know. I've just checked in a patch that prints the contents of
each ConfigureNotify event in IconMan. Could you download it and see
if it shows something strange (especially if it crashes)?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 9 Sep 1999 07:09:51 -0400

> if it shows something strange (especially if it crashes)?

IconMan looks fine now, I haven't had any more troubles with it.  So you
can probably take the prints backk out of CVS.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 9 Sep 1999 17:28:38 +0200

> can probably take the prints backk out of CVS.

But I didn't do anything but insert that fprintf's since last
time I got the crash :-(

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 10 Sep 1999 07:14:15 -0400

> But I didn't do anything but insert that fprintf's since last

This fixed it for me.

1.27 - annotate Wed Sep 1 00:00:44 1999 UTC; 9 days, 11 hours ago by domivogt 
CVS Tags: version-2_3_7
Changed since 1.26: +17 -4 lines
Diffs to 1.26 (colored diff) 

* Tried to fix ConfigureNotify events in IconMan (without success).
* Small enhancements and bugfixes for new FvwmButtons panels.
* New shortcuts Meta-Up and Meta-Down in menus.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 Sep 1999 12:33:57 +0200

> * New shortcuts Meta-Up and Meta-Down in menus.

Yup, that fixed the problem with windows jumping around, but I got
a crash with your config. The fprintf's are supposed to debug the
crash. But I guess you didn't ever see that crash, right?

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 13 Sep 1999 09:23:41 -0400

> crash. But I guess you didn't ever see that crash, right?

Thats right,  it didn't crash once.