Subject: Notification: incoming/453

From: [email-masked]
Date: Thu, 2 Sep 1999 23:00:53 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/453

Message summary for PR#453
	From: [email-masked]
	Subject: --enable-kanji breaks build
	Date: Thu, 2 Sep 1999 23:00:51 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Sep 1999 03:32:36 +0200

On Thu, Sep 02, 1999 at 11:00:53PM -0500, [email-masked] wrote:
> >From [email-masked]  Thu Sep  2 23:00:52 1999
> Received: from localhost (localhost [127.0.0.1])
>  by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id XAA04507
>  for <[email-masked]>; Thu, 2 Sep 1999 23:00:51 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Danek Duvall
> Version: snapshot 19990831
> CVS_Date: 
> OS: Linux 2.2, Solaris 2.8
> X_Server: XFree86 3.1.3, Openwindows 3.6.2
> Submission from: (NULL) (209.233.33.110)
> 
> 
> If I run configure --enable-kanji, then FvwmWinList.c fails to
> compile.  What's happening is that it #defines XDrawString to
> XmbDrawString, and later #includes (indirectly) Xlib.h, resulting
> in this garbage:
> 
> "/usr/openwin/include/X11/Xlib.h", line 2690: syntax error before or at:
> ButtonFontset
> "/usr/openwin/include/X11/Xlib.h", line 2690: warning: undefined or missing
> type for: ButtonFontset
> "/usr/openwin/include/X11/Xlib.h", line 2684: warning: undefined or missing
> type for: GC
> "/usr/openwin/include/X11/Xlib.h", line 2685: warning: undefined or missing
> type for: int
> "/usr/openwin/include/X11/Xlib.h", line 2686: warning: undefined or missing
> type for: int
> "/usr/openwin/include/X11/Xlib.h", line 2687: warning: undefined or missing
> type for: const
> "/usr/openwin/include/X11/Xlib.h", line 2688: warning: undefined or missing
> type for: int
> "/usr/openwin/include/X11/Xlib.h", line 4329: identifier redeclared:
> XmbTextEscapement
>         current : function(pointer to struct _XOC {}, pointer to const
> char, int) returning int
>         previous: function(pointer to struct {pointer to struct _XExtData
> {..} ext_data, ulong fid, uint direction, uint min_char_or_byte2, ui... :
> "/usr/openwin/include/X11/Xlib.h", line 4021
> "/usr/openwin/include/X11/Xlib.h", line 4422: identifier redeclared:
> XmbDrawString
>         current : function(pointer to struct _XDisplay {}, ulong, pointer
> to struct _XOC {}, pointer to struct _XGC {}, int, int, pointer to c...
>         previous: function() returning int :
> "/usr/openwin/include/X11/Xlib.h", line 2680
> cc: acomp failed for FvwmWinList.c
> 
> I got it to compile if I moved the #ifdef I18N_MB paragraph to after
> all the #includes, though something more fine-grained might be
> appropriate.
> 
> BTW, shouldn't --enable-kanji be something less specific, like, say,
> --enable-multibyte?

Whatever. The author seems to have lost interest in getting his
patch working cleanly with 2.3.x, so I guess we'll disable it
before 2.4 anyway.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]