Subject: Notification: incoming/463

From: [email-masked]
Date: Tue, 14 Sep 1999 07:31:36 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/463

Message summary for PR#463
	From: [email-masked]
	Subject: configure doesn't check for correct XPM version
	Date: Tue, 14 Sep 1999 07:31:34 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Wed, 15 Sep 1999 09:38:34 +0100

>  Picture.c:188: `XpmReturnAllocPixels' undeclared (first use this
> function)
> 
> I used XPM version 3.4f which was fine for the configure script.
> version (3.4.11) has this function.
> 
> So I guess the configure script should be updated.

This is my fault. I added this bit to try to stop fvwm and the modules
leaking colors. I don't know what version of XPM would support this. If
it will cause major hassle to require everyone to upgrade their XPM I
can take it out and we can live with color leaks.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 15 Sep 1999 08:45:49 -0400

> can take it out and we can live with color leaks.

Hmm, a while back I fixed color leakage in rxvt without setting
that mask bit.  Instead after XFreePixmap I added:

 XFreeColors(Xdisplay, Xcmap,
           xpmAttr.pixels,
           xpmAttr.npixels, 0); /* free the colors in the old pixmap */

I don't have my Xpm docs handy so I don't know if I just missed
XpmReturnAllocPixels, but I believe this is another way to
free the colors.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 17 Sep 1999 13:44:41 +0100

>            xpmAttr.npixels, 0); /* free the colors in the old pixmap */

Does anyone know the difference between xpmAttr.pixels and
xpmAttr.alloc_pixels?
Are there any cases when .pixels contains more pixels than .alloc_pixels
and would freeing the extra ones do any harm?

If not then I'll chnage it to the above.

Cheers,
Tim.

---

From: Neil Bird <[email-masked]>
Date: Fri, 17 Sep 1999 13:55:55 +0100

> If not then I'll chnage it to the above.

  If I understand it correctly, libXpm will try to grab whatever colours
it needs according to the pixel values in the XPM. If it can't get
any/all, it'll either fail, or use the closest ones available (depending
upon what settings you have).

  So, assuming you have closeness allowed, .pixels will contain /all/ the
pixels being used by the XPM, and .alloc_pixels will conatin those
specifically allocated for the XPM, which will be a subset of .pixels,
ranging from none at all to all of them.

  At least, that's how I see it.

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 106 days remaining
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]