Subject: Purify results for FvwmPager

From: Brad Giaccio <[email-masked]>
Date: Tue, 28 Sep 1999 07:49:07 -0400

I just ran purify on the pager and suprise suprise I could only come up
with one leak. Here is the patch.

Index: x_pager.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmPager/x_pager.c,vretrieving revision 1.72
diff -u -b -B -r1.72 x_pager.c--- x_pager.c   1999/09/26 00:50:25     1.72
+++ x_pager.c   1999/09/28 11:49:02@@ -1255,6 +1255,7 @@
     }
 #endif
     XSetWMIconName(dpy,Scr.Pager_w,&name);
+    XFree(name.value);
   }
 }

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 28 Sep 1999 14:37:50 +0200

> with one leak. Here is the patch.

Applied.

You don't feel inclined to write a config file for FvwmPager in the
style of tests/purify/purify.fvwm2rc, do you?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 29 Sep 1999 08:37:23 -0400

> style of tests/purify/purify.fvwm2rc, do you?

Well I just used my config, which instanties most of the features.  Here it is if you would like to include it.

DeskTopSize 2x4
*FvwmPagerFont          -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmPagerHilight       orchid
*FvwmPagerFore          black
*FvwmPagerBack          #515178
*FvwmPagerPixmap        /home/bgiaccio/lib/graphics/blue_roc.xpm
*FvwmPagerLabel 0       Home
*FvwmPagerLabel 1       Pitcairn 
*FvwmPagerGeometry +0-53

*FvwmPagerBalloons            All
*FvwmPagerBalloonBack         Yellow
*FvwmPagerBalloonFont         -*-lucida\ sans\ typewriter-bold-*-*-*-12-*-*-*-*-*-*-*
*FvwmPagerBalloonYOffset      -2 

*FvwmPagerColorset 0 0
*FvwmPagerBalloonColorset 0 0
*FvwmPagerHilightColorset 0 1
*FvwmPagerColorset 1 0
*FvwmPagerBalloonColorset 1 0
*FvwmPagerHilightColorset 1 1

*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000
*FvwmThemeColorset 1 gray80 #515178 DGradient 128 #000000 #909078