Subject: Plain keys, XEmacs and 2.3.7

From: Dan Espen <[email-masked]>
Date: Wed, 11 Aug 1999 09:02:22 -0400

Its been over 2 weeks since I did a CVS update.

This morning, I built 2.3.7, and the only problem I see is XEmacs ignoring
all the regular keys, (A-Z, 1-9, F1-F12).  Special characters and
cursor keys are fine.  (I think it sees the keys, I have cursor blink mode
enabled, and the blinking seems to hesitate, it just doesn't do anything.)

If I exit  2.3.7, and use  2.3.6 from a few  weeks ago, the keys start
working again.  (Same XEmacs.)

The keys seem to work OK everywhere else, including a "gnuclient -nw"
attached to the same XEmacs.

I'm running XEmacs, 20.4 on Solaris 2.6.
-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 08:36:48 +0200

> attached to the same XEmacs.

Are you using SloppyFocus? Is the cursor over the window when you press
the keys? Do you have root window key bindings defined for your 'regular'
keys?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Aug 1999 08:26:23 -0400

> the keys? Do you have root window key bindings defined for your 'regular'

Focus policy:

Style "*" MouseFocus

The mouse pointer is over the window.

Just about every key on my keyboard has a root window binding.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 16:29:32 +0200

> Just about every key on my keyboard has a root window binding.

Do the keys work if you disable their bindings?

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Aug 1999 19:23:52 -0400

> Do the keys work if you disable their bindings?

I'll try to test this at home, (vacation again).  It might take
a while.

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Aug 1999 08:56:55 -0400

> I'll try to test this at home, (vacation again).  It might take

OK, it doesn't work at home either.

If I remove the root window bindings for a key, then that
key can be used by XEmacs.

I notice a few other things:

Keys don't work with "dclock" either.

"contool" iconifies 10 times slower than it used to.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 13 Aug 1999 16:45:53 +0200

> "contool" iconifies 10 times slower than it used to.

Can you send me a few of the offending binding lines and
all lines affecting your focus settings please?

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Aug 1999 16:17:59 -0400

> all lines affecting your focus settings please?

Sure:

Style "*"           MouseFocus
Style "xmag"	    ClickToFocus
Key j R A Beep
Key k R A Beep
Key l R A Beep
Key s R N Warp Workstation
Key s R C Exec set -A back 1 E I 8 9;rxvt -pixmap ${back[`random 5`]} -name Workstation -fg white -iconic
Key s R M Exec set -A back 1 E I 8 9;rxvt -pixmap ${back[`random 5`]} -name Workstation -fg white -iconic
Key s R S Exec set -A back 1 E I 8 9;rxvt -pixmap ${back[`random 5`]} -name Workstation -fg white

(removing the 4 "key s" lines made the "s" key start working.)