Subject: Re: FvwmWharf documentation error

From: Dominik Vogt <[email-masked]>
Date: Sun, 1 Aug 1999 07:06:55 +0200

On Sun, Jul 25, 1999 at 10:10:16PM -0400, Ben Winslow wrote:
> The FvwmWharf man page describes loading modules with 'SwallowModule',
> but the syntax FvwmWharf actually uses is 'Swallow ... Exec Module
> ...'.  I'll leave correcting that one to the maintainer(s), since
> documentation isn't my thing :)

Okay, I have removed the regarding pieces of text.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 2 Aug 1999 01:56:22 +0300 (IDT)

> Okay, I have removed the regarding pieces of text.

The note above is not correct. :)
To Ben Winslow: did you manage to run the module using Exec Module?
SwallowModule works without problems. I will restore the removed man page
line about SwallowModule and add an example usage line.

Regards,
Mikhael.

---

From: Ben Winslow <[email-masked]>
Date: Sun, 1 Aug 1999 22:53:18 -0400 (EDT)

On Mon, 2 Aug 1999, Mikhael Goikhman wrote:

# On Sun, 1 Aug 1999, Dominik Vogt wrote:
# 
# > On Sun, Jul 25, 1999 at 10:10:16PM -0400, Ben Winslow wrote:
# > > The FvwmWharf man page describes loading modules with 'SwallowModule',
# > > but the syntax FvwmWharf actually uses is 'Swallow ... Exec Module
# > > ...'. I'll leave correcting that one to the maintainer(s), since
# > > documentation isn't my thing :)
# > 
# > Okay, I have removed the regarding pieces of text.
# 
# The note above is not correct. :)
# To Ben Winslow: did you manage to run the module using Exec Module?
# SwallowModule works without problems. I will restore the removed man page
# line about SwallowModule and add an example usage line.
# 
# Regards,
# Mikhael.
# 

Exec Module was the only way I could get the module to actually run-- when I
used SwallowModule, FvwmWharf tried to run the module as if it were a
program in my $PATH (because it strncmp'd the Swallow, and ignored the
rest), so no communication between fvwm was set up, etc, etc, and it didn't
work.

-- 
Ben Winslow / [email-masked] / |Rain| / freshmeat news squad

Knowledge is of no value unless you put it into practice.
- Heber J. Grant

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 2 Aug 1999 14:44:18 +0300 (IDT)

> rest), so no communication between fvwm was set up, etc, etc, and it didn't

You are right in that Swallow and SwallowModule have the same meaning
(as far as I can understand from the source code). But if you put the word
Module (no need in Exec) you will launch a module, not an application.
I have added this to the man page.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Aug 1999 04:42:13 +0200

> line about SwallowModule and add an example usage line.

Um, there is no passage in the code that suggest that there is a
SwallowModule option. The only thing I could imagine that wharf
doesn't require whitespace after a recognized option and interprets

  *FvwmWharfSwallowModule foo

as

  *FvwmWharfSwallow Module foo

This would be much more consistent.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]