Subject: Notification: incoming/442

From: [email-masked]
Date: Mon, 23 Aug 1999 08:48:37 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/442

Message summary for PR#442
	From: [email-masked]
	Subject: *FvwmIconManColorset doesn't work
	Date: Mon, 23 Aug 1999 08:48:35 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 11:24:19 -0400

> *FvwmIconMan*Colorset 5
> *FvwmIconMan*FocusColorset 1
> *FvwmIconMan*FocusAndSelectColorset 1
> *FvwmIconMan*PlainColorset 0
> *FvwmIconMan*SelectColorset 2
> *FvwmIconMan*TitleColorset 3
> 
> This gives a 3 row iconman. When the number of windows on a desk is
> not a multiple of 3 there is a gap at the bottom.  The gap should be 
> drawn in colorset 5 but instead it's drawn with colorset 0 (but only
> the background color not the pixmap is set as the window background)
> 
> 

Tim, the problem was due to the fact that the origional IconMan didn't
handle it either Plainbutton would overide whatever colors were in Back
and Fore.So here is a patch to fix the problem.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Tim Phipps <[email-masked]>
Date: Mon, 23 Aug 1999 16:45:23 +0100

> and Fore.So here is a patch to fix the problem.

Thanks, it fixes the blank bits when first drawn but a Refresh still
causes the pixmap to be lost and replaced with the background color.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 17:54:35 +0200

> and Fore.So here is a patch to fix the problem.

Brad, did you ever think about getting commit rights for CVS?
I don't think there would be any objections.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 12:02:12 -0400

> I don't think there would be any objections.

Actually Tim, and I discussed that, and alas I can't actually commit at
the moment, due to some crazy firewall rules but I'm in the process of
getting a less restrictive machine setup and then I should be able too.
So in the mean time I hope you all don't mind throwing in the occasional
patch for me.

Brad

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 13:51:24 -0400

> causes the pixmap to be lost and replaced with the background color.
 
okay one more time this diff includes the last changes I sent, so start from cvs again.  This should also fix Dominik's problems with IconMan not handling resizes correcttly.

Brad

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 13:53:52 -0400

alright I'm ready to go home, can you tell, here is the patch this time.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 23:44:05 +0200

> So in the mean time I hope you all don't mind throwing in the occasional

Of course not. BTW, I have the same problem with firewalls from
my work. A colleague has written some kind of Java socks proxy
that takes me through. He's unwilling to put it under GPL though,
but I can ask him if I can give it to you.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Aug 1999 09:08:00 +0200

> okay one more time this diff includes the last changes I sent, so start from cvs again.  This should also fix Dominik's problems with IconMan not handling resizes correcttly.

Could we agree that Tim applies your patches? I'm getting a bit confused with
all the patches I'm already applying.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 25 Aug 1999 06:45:54 -0400

> all the patches I'm already applying.

I see that Tim applied my patch, could you both confirm that your
respective problems are now fixed, and Tim could you move your bug
report to fixed if in fact it is.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Aug 1999 20:20:23 +0200

> report to fixed if in fact it is.

Yup, FvwmPager and FvwmIconMan not get their background set properly.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Thu, 26 Aug 1999 12:14:16 +0100

> report to fixed if in fact it is.

Bug 442 is fixed and the bug report has been moved.

Cheers,
Tim.