Subject: right arrow for entering submenu

From: TG <[email-masked]>
Date: Sun, 22 Aug 1999 22:20:13 +0200

I like being able to browse menu's using the keyboard, and cancelling a
submenu using the left arrow is very handy, but wouldn't it be more
consistent to have the right arrow for entering it? (without disabling
the "enter" key for it, of course)

Regards,

Tung
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 00:18:21 +0200

> the "enter" key for it, of course)

Uh, it should always have worked this way. I see that it's broken at
the moment.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 00:21:21 +0200

> the "enter" key for it, of course)

Teehee, what a funny cut-and-üaste bug:

This code in menus.c

  case XK_Right:
  case XK_KP_6:
    if (!MST_USE_LEFT_SUBMENUS(mr))
    {
    }

should really have been:

  case XK_Right:
  case XK_KP_6:
    if (!MST_USE_LEFT_SUBMENUS(mr))
    {
      if (miCurrent && MI_IS_POPUP(miCurrent))
        return MENU_POPUP;
    }
    
:-)

Bye

Dominik ^_^

---

From: Neil Bird <[email-masked]>
Date: Mon, 23 Aug 1999 12:50:51 +0100

> the "enter" key for it, of course)

  Odd. I'm sure that it (right-arrow) used to work ...

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 131 days remaining
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]