Subject: CVS hippo: FvwmPager miniwindows drawn in 3d when *FvwmPagerWindowColorsets specified

From: CVS <[email-masked]>
Date: Wed, 11 Aug 1999 09:35:34 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/08/11 09:35:34

Modified files:
	modules        : ChangeLog 
	modules/FvwmPager: FvwmPager.h x_pager.c 

Log message:
FvwmPager miniwindows drawn in 3d when *FvwmPagerWindowColorsets specified

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 11 Aug 1999 20:06:10 +0200

> FvwmPager miniwindows drawn in 3d when *FvwmPagerWindowColorsets specified

Uh, oh, would it be possible to turn that 3d look off? On a small
pager it looks rather ugly! Apart from this the mini windows are
too small with the 3d look. If I have two windows directly adjacent
on the desktop (with SnapAttraction) there is a noticeable gap visible
im my pager.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 11 Aug 1999 20:11:56 +0200

> on the desktop (with SnapAttraction) there is a noticeable gap visible

Here's a screenshot so you can see what I mean.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Fri, 13 Aug 1999 10:13:15 +0100

Dominik Vogt wrote:
> too small with the 3d look.

I've made it configurable since I like it to be 3d.  The width of the
border is configurable too (ready for the day I get a 5000x4000
monitor).  Set the borderwidth positive and it uses the old style (the
default is 1), negative and it uses the hilight and shadow pixels from
the WindowColorsets.

The windows being too small is fixed too, I was being lazy and didn't
want to have to do the code to handle resizes during moves.

Cheers,
Tim.