Subject: That darn warping at interactive resize

From: Tomas Ogren <[email-masked]>
Date: Sun, 22 Aug 1999 00:05:41 +0200

Can we _please_ make it optional? I'm going insane! Please? Please?

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 00:28:30 +0200

> Can we _please_ make it optional? I'm going insane! Please? Please?

If I remember correctly this was the fix for some bug. Of course
the area wherre warping is done does not need to be *this* big.
I'll look into it when I have the time. Can you please
explain why you don't like it? I'm just interested and would like
to understand the usability issue behind this a bit better.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Mon, 23 Aug 1999 12:59:39 +0200

On 23 August, 1999 - Dominik Vogt sent me these 0,7K bytes:

> If I remember correctly this was the fix for some bug.

Uhm. What bug?

> Of course the area wherre warping is done does not need to be *this*
> big. I'll look into it when I have the time. Can you please explain
> why you don't like it? I'm just interested and would like to
> understand the usability issue behind this a bit better.

I don't like it when software tries to outsmart me.. "I'm sure you want
your mouse pointer over --> there".. No, I didn't!

Enlightenment has (or atleast had) a pretty sane way of handling
resizes, not sure how to explain it.. but I'll give it a try:

If you hotkey+mouse grab a window by the 'o' and drag down-right, you'll
get something like this:

+-------+    +----------------+
|    |  |    |           |    |
|----o  |    |           |    |
+-------+    |-----------o    |
             |                |
             +----------------+

Somekind of proportional grid/rubber mat... Which is IMO a better
behaviour than warping the mousepointer across the screen.

I took a quick poll in the room about the warping:

Like it or not:
5 - Most annoying, not usable, hate it
0 - I like it

Existance:
5 - If existing, very optional, Off by default
0 - On by default

The default of Fvwm shouldn't totally change behaviour in our opinion.

/Tomas