Subject: Re: FvwmButtonsPanel Problem

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 11 Aug 1999 13:10:06 -0500

I asked this question back on 07/26/1999, but received no feed back.

I am assuming it's because of my explanation of my problem.

I will try it again.

I have switched from FvwmWharf to FvwmButtons for a couple of reasons (which has
nothing to do with my current problem).

I am using FvwmButtonsPanel to simulate the way I had FvwmWharf setup.  Now my
problem is that when I click on a panel to expand it, 40% of the time it looks
normal:

|-------|-------|-------|-------|-------|
|       |       |       |       |       |
|       |       |       |       |       |
|       |       |       |       |       |
|_______|_______|_______|_______|_______|

The other 60% the panel looks like this:

|-------|-------|-------|-------|-------|
|       |       |       |       |       |
|-------|-------|-------|-------|-------|
|       |       |       |       |       |
|_______|_______|_______|_______|_______|

with the icons and actions shoved in the top set of buttons.

I have to close the panel and re-open it to get it to display correctly (some
times several tries are necessary).

I don't know if the cause is the way I have my buttons defined or a bug in
FvwmButtons.  I had to play games with the "Size" option to get my background
image to look correct (I liked the way FvwmWharf used an image for each button
rather then tile the image like FvwmButtons).

Anyway I have my entire FvwmButtons configurations below, if anyone has any
suggestions please let me know.

Also, I have a snapshot of what the button really looks like when it is messed
up.  If anyone needs to see it, I would be glad to forward it.

Thank for your help.

#### FvwmButtons configuration ###

CloseOnSelect
Fore rgb:ff/ff/ff
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Frame 0
Geometry +0+152
Columns 1
# BoxSize smart
Font -*-helvetica-medium-r-*-*-12-*
Padding 0 0

(1x6,Swallow "FvwmPager" `FvwmPager 0 5`, Frame 0)
(Size 65 65,Icon fvwm4.xpm,  Panel Fvwm)
(Center,Padding 2,Swallow "ASClock" "Exec asclock -24 -led red -shape -exe
'AutoLockerActive.sh' &")
(Center,NoSize,Icon monitor-e0.xpm,Action \
        'Exec "ihgp74x123"  exec xterm -title ihgp74x123 -bg antiquewhite -fg
black -bd magenta4 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(NoSize,Icon hostmanager.xpm,Action "Function Find-or-Start tkrl")
(NoSize,Icon Monitor.xpm, Panel Logins
(NoSize,Icon tool.xpm, Panel Applications
(NoSize,Icon Gandalf48x48.xpm, Panel ArtTools

########## PANEL Fvwm
Panel Fvwm
CloseOnSelect
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Fore rgb:ff/ff/ff
Geometry +65+66
Rows 1

(Size 56 54,Icon Jlock.xpm,  Action 'Exec "" exec AutoLockerActive.sh &')
(NoSize,Icon adept.xpm, Action 'Exec "Adept[FULL]" xterm -bg antiquewhite -fg
black -bd magenta4 -title Adept[FULL] -e adept -x &')
(NoSize,Icon power.xpm, Action Quit)
# (NoSize,Icon power.xpm, Action 'Exec "" exec /usr/dt/bin/dtaction ExitSession'
)

########## PANEL Logins
Panel Logins
CloseOnSelect
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Fore rgb:ff/ff/ff
Geometry +65+66
Rows 1
Padding 4
Frame 1
(Title IHLPQ,Size 54 56,Icon ihlpq.xpm,Action 'Module FvwmForm IHLPQterms', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title IHLBB2,Size 55 56,Icon ihlbb2.xpm,Action 'Exec "ihlbb2" exec xterm -name 
ihlbb2 -title ihlbb2 -bg antiquewhite -fg black -bd magenta4 -e rlogin -8 ihlbb2
 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title IHLBB3,Size 55 56,Icon ihlbb3.xpm,Action 'Exec "ihlbb3" exec xterm -name 
ihlbb3 -title ihlbb3 -bg antiquewhite -fg black -bd magenta4 -e rlogin -8 ihlbb3
 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title IHECMS,Size 55 56,Icon ihecms.xpm,Action 'Exec "ihecms" exec xterm -name 
ihecms -title ihecms -bg antiquewhite -fg black -bd magenta4 -e rlogin -8 ihecms
 &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title IXADM,Size 55 56,Icon xadm.xpm,Action 'Exec "xadm" exec xterm -bg antique
white -fg black -bd magenta4 -title xadm -e rlogin ihgp74x123 -l xadm &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title SSBUN,Size 55 56,Icon hamburger.xpm,Action 'Exec "ssbun" exec xterm -name
 ssbun -title ssbun -bg antiquewhite -fg black -bd magenta4 -e rlogin -8 ssbun &
', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title HAWK,Size 55 56,Icon hawk.xpm,Action 'Exec "hawk" exec xterm -name hawk
-title hawk -bg antiquewhite -fg black -bd magenta4 -e rlogin -8 hawk &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title Juice,Size 55 56,Icon juice.xpm,Action 'Exec "juice" exec
/home/ees/tools/bin/juice &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)

########## PANEL Applications
Panel Applications
CloseOnSelect
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Fore rgb:ff/ff/ff
Geometry +65+66
Rows 1
(Size 56 54,Icon netscape4.xpm,Action 'Function Find-or-Start Netscape')
(Size 57 54,Icon NScal.xpm,Action 'Function Find-or-Start NetscapeCalendar')
(Size 56 54,Icon calc.xpm,Action 'Function Find-or-Start calctool')
(Size 56 54,Icon OldFashionedRadio.xpm,Action 'Function Find-or-Start audiocontr
ol')
(Title xfontselect,Size 56 54,Icon a-z.xpm,Action 'Function Find-or-Start
xfontsel', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title xcolorselect,Size 56 54,Icon Brush.xpm,Action 'Function Find-or-Start
xcolorsel', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Size 54 54,Icon pilotmanager.xpm,Action 'Function Find-or-Start PilotManager')
(Title Answerbook,Size 56 54,Icon Info.xpm,Action 'Exec "answerbook" exec
answerbook &', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title Xmcd,Size 56 54,Icon CDrom.xpm,Action 'Function Find-or-Start xmcd', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Title JMM,Icon jmm.xpm,Size 56 54,Action 'Function Find-or-Start VendorShell', 
\
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Swallow "Perfmeter" "Exec perfmeter -d -t cpu -bg DarkSlateBlue -fg white &")

########## PANEL ArtTools
Panel ArtTools
CloseOnSelect
Pixmap ASBBlockBlue.xpm
Back rgb:64/62/94
Fore rgb:ff/ff/ff
Geometry +65+66
Rows 1

(Center,Size 57 55,Icon gimp.xpm,Action 'Exec exec gimp', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Size 57 55,Title Display,Icon 3dpaint.xpm,Action 'Exec exec display', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Size 57 55,Title Xpaint,Icon Paint5.xpm,Action 'Exec exec xpaint 2>/dev/null
1>&2', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Size 57 55,Icon xv2.xpm,Action 'Exec exec xv', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)
(Size 57 55,Icon vt2.xpm,Action 'Function Find-or-Start vthoughtx', \
        Font -adobe-helvetica-medium-r-*-*-8-*-*-*-*-*-*-*)

### End of configuration ###

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jui-Hsuan Joshua Feng <[email-masked]>
Date: Wed, 11 Aug 1999 13:52:22 -0500

On Wed, Aug 11, 1999 at 01:10:06PM -0500, Robert H. Ford II wrote:
[snip]
> problem is that when I click on a panel to expand it, 40% of the time it looks

[snip]

> (Size 65 65,Icon fvwm4.xpm,  Panel Fvwm)
                               
			       Panel(left) Fvwm

> (NoSize,Icon Gandalf48x48.xpm, Panel ArtTools
           ^^^^^^
	   try to tweak these numbers (+0+0 would be a good start) 

> # (NoSize,Icon power.xpm, Action 'Exec "" exec /usr/dt/bin/dtaction ExitSession'
[snip]

Other panels can be similarly adjusted. Hope this fix the problem.

-- 
J. Joshua Feng                            (O)608/262-3640
Electrical & Computer Engr., Univ. of Wisconsin - Madison
http://www.cae.wisc.edu/~fengj  [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 11 Aug 1999 14:52:37 -0500

Jui-Hsuan Joshua Feng wrote:

[snip]

[snip]

Thank you for these suggestions, but unfortunately this had no effect.  I have
the same problem/annoyance.

Bob

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 14 Aug 1999 01:20:11 +0200

> problem is that when I click on a panel to expand it, 40% of the time it looks
...

Robert, since the panels feature of FvwmButtons is causing a constant
stream of bug reports and complaints we are going to rewrite this in
a simpler way. I have seen the behaviour you describe myself and I
thought it was fixed. Obviously it is not, but under this circumstances
it is would be a waste of time to investigate the problem.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]