Subject: Re: Tool Demo Reminder

From: Nadim Saeed <[email-masked]>
Date: Mon, 23 Aug 1999 09:56:44 -0700 (PDT)

On Saturday - August.21.1999 [17:28:29 -0500 (CDT)],
 Neil Zanella ([email-masked]) wrote:
 > Hello,
 > 
 > I would like to suggest the followin .fvwm2rc options:
 > MaximizeRight, MaximizeLeft, MaximizeTop, and MaximizeBottom.
 > If bound to a titlebar button etc... then these would work
 > exactly like maximize but only one side of the window being
 > resized would expand: not both.
 > This is useful if you want for example a window to fill the
 > top part of the screen without obscuring the window below or
 > if you want a window to expand to the right leaving the buttonbox
 > visible.
 > 
 > Best Regards,
 > 
 > Neil Zanella
 > [email-masked]

These functions will do what you are asking for; try 'em out with
shift/Control/Meta single/double clicks and see the effects

(gotta love fvwm :-)

AddToFunc window-sizer
+       "M"     PopUp Window-Ops
+       "C"     Maximize 0 100
+       "D"     Maximize

AddToFunc shift-window-sizer
+       "C"     Maximize 100 0

AddToFunc control-window-sizer
+       "C"     Maximize 50 100
+       "D"     Maximize 50 100, Move 50 0
+       "D"     Move 50 0

AddToFunc meta-window-sizer
+       "C"     Maximize 100 50
+       "D"     Maximize 100 50
+       "D"     Move 0 50

Mouse 3         FST     N       window-sizer
Mouse 3         FST     S       shift-window-sizer
Mouse 3         FST     C       control-window-sizer
Mouse 3         FST     M       meta-window-sizer
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Mon, 23 Aug 1999 17:24:27 -0230 (NDT)

Hello,

Thanks for your sample functions but they do not do
what I had asked for. Your functions move the entire
window. I asked for a resizing function that pulls
only one side of the window. Repositioning should look
different for each position of the window.
See <http://www.cs.mun.ca/~nzanella/temp.html> to get an
idea of what I am suggesting.

Best Regards,

Neil Zanella
[email-masked]