Subject: CVS migo: fixed not propagating of missing_submenu_func for "More..." submenus

From: CVS <[email-masked]>
Date: Tue, 10 Aug 1999 18:25:33 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	migo	99/08/10 18:25:33

Modified files:
	.              : ChangeLog 
	fvwm           : menus.c 

Log message:
fixed not propagating of missing_submenu_func for "More..." submenus

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 08:26:01 +0200

> fixed not propagating of missing_submenu_func for "More..." submenus

Why did you do this? The missing_submenu_func must not be propagated
to the More... submenus as they are created when their 'parent' is
created, so they can never miss.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Aug 1999 16:00:57 +0300 (IDT)

> created, so they can never miss.

They can never miss, but their submenus can.
Try your fvwm_make_directory_menu.sh (which I am going to replace with
fvwm-menu-directory among with other fvwm-menu-* scripts very soon)
and open a directory with many subdirectories (for example /proc),
"More..." entries were not functional in 2.3.6, this was fixed.

Regards,
Mikhael.