Subject: pager forgets colour sets when switching desks

From: Dominik Vogt <[email-masked]>
Date: Sat, 14 Aug 1999 12:32:52 +0200

Try this:

 1) Configure colour sets for FvwmPager desk 0.
 2) Start fvwm on desk 0.
 3) Start FvwmPager to with 'Module FvwmPager * *'.
    The colour sets are used as they should.
 4) Switch to desk 1 with the 'GotoDesk 0 1' command.
    Pager displays desk one and uses a white background
    for the desktop. No problem so far.
 5) Switch back to desk 0 with 'GotoDesk 0 0'. Pager still
    uses the white background instead of the one configured
    for desk 0.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 14:04:03 -0400

>     uses the white background instead of the one configured
Dominik,

I can no longer reproduce this can you confirm.  It may have gotten
fixed along the way.  However I did find won bug if you don't use
balloons and change colorserts.

here is the one line fix, could you take care of it when you get a chance?  
Index: x_pager.c
========================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmPager/x_pager.c,v retrieving
revision 1.68 diff -u -B -b -r1.68 x_pager.c
--- x_pager.c   1999/08/19 20:27:18     1.68
+++ x_pager.c   1999/08/23 18:03:18
@@ -2773,7 +2773,7 @@
 
     }
 
-    if (Desks[i].ballooncolorset == colorset)
+    if (ShowBalloons && Desks[i].ballooncolorset == colorset)
     {
       attributes.border_pixel = Colorset[colorset % nColorsets].fg;
       XChangeWindowAttributes(dpy, Desks[i].balloon.w, CWBorderPixel,

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Aug 1999 00:07:48 +0200

> balloons and change colorserts.

Yup, I already fixed it (twice :-) ).

> here is the one line fix, could you take care of it when you get a chance?  

As good as done.

Bye

Dominik ^_^