Subject: outstandingcolour set support for modules?

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 1999 17:18:08 +0200

Now that colour set support for FvwmButtons is complete, which
modules are still outstanding?

Done:

FvwmButtons
FvwmIconMan
FvwmIdent
FvwmTheme
FvwmPager

Not necessary (no GUI):

FvwmCommand
FvwmConsole
FvwmCpp
FvwmDebug
FvwmEvent
FvwmM4
FvwmRearrange
FvwmSave
FvwmSaveDesk

What about these modules?

FvwmBanner
FvwmForm
FvwmGtk
FvwmIconBox
FvwmScript
FvwmScroll
FvwmTaskBar
FvwmWharf
FvwmWinList

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Aug 1999 11:23:48 -0400

On Mon, Aug 30, 1999 at 05:18:08PM +0200, Dominik Vogt wrote:
> To Do

I'm not sure if we need to do FvwmBanner but the other four do need to
be completed.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Aug 1999 11:35:52 -0400

Brad Giaccio <[email-masked]> writes:
> I'm not sure if we need to do FvwmBanner but the other five do need to
> be completed.

Since all FvwmBanner does is display a pixmap, its not a candidate.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 1999 18:26:09 +0200

> I'm not sure if we need to do FvwmBanner but the other four do need to

Brad, would you patch FvwmTaskBar? Since you wrote the colour set
support for FvwmWinList this shouldn't be difficult for you (TaskBar
has been spawned off from the WindowList code). I guess we can safely
skip FvwmBanner. I'll look into FvwmWharf then.
 
Bye

Dominik ^_^

---

From: Jason Kibblewhite <[email-masked]>
Date: Tue, 31 Aug 1999 00:10:11 -0600

> modules are still outstanding?

I personally believe that FvwmConsole should have it, I know it's almost
like running FvwmCommandS and then an xterm as it follows .Xdefaults for
color and such but I'd think it would be more then cool to have that
nifty YGradient in the background

---

From: Tim Phipps <[email-masked]>
Date: Tue, 31 Aug 1999 12:38:47 +0100

> What about these modules?
These sre done

> FvwmGtk
Instead of making FvwmGtk follow the fvwm colorsets I was thinking that
FvwmGtk could provide colorsets like FvwmTheme so that fvwm and the
modules could take on a GTK appearance and get their colors from the
.gtkrc file. Looking at the .gtkrc examples it seems that 4 colorsets
might be good (set by the normal, selected, active and insensitive parts
of a gtkrc style).

> FvwmScript
This one doens't even share the Fvwm visual yet.

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 08:15:18 -0400

> nifty YGradient in the background

Well FvwmConsole really does use an xterm for its window and we don't
get any sort of handle to the window, so I'm not sure how we could set
its background.  Tim, Dominik, any ideas?

Brad

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 08:17:40 -0400

> skip FvwmBanner. I'll look into FvwmWharf then.

Actually Tim did the WinList so I let him take first crack at it, and given Tim's comments on Script and Gtk, I'll take a look at IconBox.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 1999 14:35:53 +0200

> its background.  Tim, Dominik, any ideas?

Uh, it could be done the way I do it in FvwmButtons, but I'm not
sure if this is worth the effort (i.e. by forcing the background
upon the xterm).

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 08:48:07 -0400

> sure if this is worth the effort (i.e. by forcing the background

The problem is we don't actually ever get the window we just do an exec xterm -e <args to connect pipe>

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 1999 14:52:18 +0200

> The problem is we don't actually ever get the window we just do an exec xterm -e <args to connect pipe>

Same with FvwmButton. It is informed of windows being mapped.
You could wait for the xterm with the appropriate title being
mapped.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 08:53:17 -0400

> You could wait for the xterm with the appropriate title being

Alright I'll give it a shot then, and let you know if I get stuck.
Right after I finish with FvwmIconBox.

Brad

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 31 Aug 1999 14:56:08 +0200

> sure if this is worth the effort (i.e. by forcing the background

Hello,
If you do somethimg perhaps you can take the occasion to add a config
option for the user can use an other terminal than xterm with
FvwmConsole. 
Eterm can be a "user" solution for theme with FvwmConsole.
Of course it is only an humble suggestion in the real discussion ...
Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 31 Aug 1999 14:09:11 +0100

> > You could wait for the xterm with the appropriate title being

Xterm sets the $WINDOWID variable before it spawns the FvwmConsoleC
command so you could look for that and send it from FvwmConsoleC to
FvwmConsole.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 1999 15:22:19 +0200

> Right after I finish with FvwmIconBox.

I think the code to change other applications' backgrounds should
go into the library. This could be used as a graphics plug-in in
fvwm too.

Bye

Dominik ^_^