Subject: Re: Notification: incoming/416

From: Dominik Vogt <[email-masked]>
Date: Sun, 1 Aug 1999 13:03:03 +0200

On Mon, Jul 12, 1999 at 10:53:56AM +0100, Tim Phipps wrote:
> Dominik Vogt wrote:
> > I have noticed that too. The code responsible for that is in
> > ConstrainSize() in move_resize.c. If the resize operation is
> > interactive the window size is rounded up to the next multiple
> > of the resize inc. This is done only with interactive resize.
> > Does anybody remember why we made it work this way?
> 
> I put this in. It was to enable resizes to start with one keypress. If
> you execute a function like
> 
> WarpToWindow 100 100
> Resize
> 
> moving the mouse back towards the middle of the window will shrink the
> window.  Before the change you had to move the mouse outside the frame
> before moving it in.

The good news is that since the cursor is warped to the edge
of the window when resizing from a keystroke we don't need
rounding up anymore. I will remove it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 05 Aug 1999 10:57:02 +0100

> rounding up anymore. I will remove it.

I think I got this wrong, sorry. The reason for rounding up is to do
with resizing xterms with the mouse with sloppyfocus/mousefocus.  If the
resize rubberband is rounded down in size there is a high probability
that when the resize is finished the pointer will be outside the window
and the focus will change.

I did the round-up change at the same time as the start-resize-immediate
change and forgot which change was for what.

Could we put the round-up back and fix the resize off the edge of the
screen some other way?

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Aug 1999 06:02:06 +0200

> and the focus will change.

:-(

> Could we put the round-up back and fix the resize off the edge of the

Sure. Do you feel inclined to do it?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 06 Aug 1999 14:59:37 +0100

> Sure. Do you feel inclined to do it?

OK, try it now.

Cheers,
Tim.