Subject: FvwmButtons colorsets

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Aug 1999 10:17:44 -0400

A couple of problems with the recent set of commits for Button
colorsets.  First even if I don't set the global colorset option or
the one for the swallow of my pager the pager (showing two desks) gets
displayed incorrectlly, the first desk is displayed in some color, but
the second is fine.  Second I only have one pixmap button 
(Title Kill, Icon bomb.xpm, Size 60 30, Action Close, Colorset 0) 
and it gets a small rectangle with the gradient in the upper left corner 
and the rest of the square is black, the same is true for my xdaliclock 
and xbiff++, however xload and xbuffy seem to be okay.

Brad

P.S. the xcpustates use motif widgets, and I know they won't get colorsets

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 1999 17:29:42 +0200

> and xbiff++, however xload and xbuffy seem to be okay.

I need the colorset lines from FvwmTheme and the lines from FvwmButtons
to debug this.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Aug 1999 11:48:13 -0400

> I need the colorset lines from FvwmTheme and the lines from FvwmButtons

You can just ignore the xcpu stuff at the bottom.

*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000
*FvwmButtonsFile /home/bgiaccio/.fvwm2Buttons

BoxSize smart
Geometry -1+1
Columns 1
Rows 20
Fore rgb:51/51/78
Back rgb:51/51/78

(Swallow(NoClose,UseOld) "xdaliclock" `Exec delayed-start xdaliclock -transparent -geometry
 120x30 &`,Size 120 30, Colorset 0)

(1x4,Container (Columns 1, Rows 1))
(Swallow(NoClose,UseOld) "FvwmPager" `Module FvwmPager 0 1`,Size 118 145 )
(End)

(1x4,Container (Columns 2, Rows 1))
(Container (Columns 1, Rows 3))
(1x1,Swallow(NoClose,UseOld) "xbiff++" `Exec exec xbiff++ -fg rgb:90/90/78 -bg rgb:51/51/78
 -update 20 &`,Size 30 30, Colorset 0)
(1x1,Swallow(NoClose,UseOld) "xload" `Exec xload -bg rgb:51/51/78 -fg red -hl blue -update
1 &`,Size 60 30, Colorset 0)
(Title Kill, Icon bomb.xpm, Size 60 30, Action Close, Colorset 0)
(End)
(1x1,Swallow(NoClose,UseOld) "xbuffy" `Exec xrsh jojo xbuffy -fg ivory -bg rgb:51/51/78 &`,
Size 60 145, Colorset 0)
(End)

(Container (Columns 1, Rows 2))
(Swallow(NoClose,UseOld) "xcpu colt" `Exec xrsh colt rxcpu.sh colt &`,Size 120 15, Colorset
 0)
(Swallow(NoClose,UseOld) "xcpu boyce" `Exec xrsh boyce rxcpu.sh boyce &`,Size 120 15, Color
set 0)
(End)
(Swallow(NoClose,UseOld) "xcpu pitcairn" `Exec xrsh pitcairn.psrw.com rxcpu.sh pitcairn & >
/dev/null`,Size 120 30 , Colorset 0)
(Swallow(NoClose,UseOld) "xcpu humbolt" `Exec xrsh humbolt rxcpu.sh humbolt &`,Size 120 30,
 Colorset 0)
(Swallow(NoClose,UseOld) "xcpu jojo" `Exec xrsh jojo rxcpu.sh jojo &`,Size 120 30 ,Colorset
 0)
(Swallow(NoClose,UseOld) "xcpu lal" `Exec xrsh lal rxcpu.sh lal &`,Size 120 30 ,Colorset 0)

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 1999 18:09:55 +0200

> and xbiff++, however xload and xbuffy seem to be okay.

Does it work better now?

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Aug 1999 12:24:19 -0400

> > and xbiff++, however xload and xbuffy seem to be okay.

Yup, your last commit fixed it, Thanks.