Subject: "Next [!XXX] Focus" ignores "!"-entries

From: [email-masked]
Date: Mon, 9 Aug 1999 16:04:39 -0500 (CDT)

Full_Name: Volker Moell
Version: 2.3.6
CVS_Date: 
OS: Linux(2.2.10/glibc)
X_Server: X11R6
Submission from: (NULL) (131.246.177.86)

I use in fvwm2rc the line
  Key  KP_Begin  A  N  \
      Next [!iconic !xosview !ipwatch !FvwmButtons CurrentScreen] Focus
to rotate the focus of X11 applications.

But fvwm2 ignored in this context some entries: Iconified apps
and xosview both are correctly ignored while rotating, but the 
following "!"-entries ("!ipwatch", "!FvwmButons") have no in-
fluence - both applications get the focus.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 07:08:43 +0200

> fluence - both applications get the focus.

You can't use more than one application name in a condition. If you
specify multiple names, all but the first one is ignored. You should
use the WindowListSkip style for these applications instead:

  Style xosview WindowListSkip
  Style FvwmButtons WindowListSkip
  Style ipwatch WindowListSkip

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]