Subject: SidePics look bad if they are bigger than the menu

From: [email-masked]
Date: Wed, 11 Aug 1999 11:10:08 -0500 (CDT)

Full_Name: 
Version: 2.3.6
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (194.202.174.20)
Submitted by: hippo

A tall SidePic with a short menu shows some errors in the clipmask
used to render the sidepic. It looks like the sidepic is centred but the
clip_y_origin isn't adjusted

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 07:39:26 +0200

> clip_y_origin isn't adjusted

I don't think we can do anything about it. Sidepics will alway look
ugly if the menu is too short. The sidepic is always anchored at the
bottom of the menu, it's *not* centered. I do see a off-by-one bug
however. The sidepic reaches one pixel into the border of the menu
at the bottom. You can see it clear as day with

  MenuStyle * BorderWidth 1

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 07:59:17 +0200

On Thu, Aug 12, 1999 at 07:39:26AM +0200, [email-masked] wrote:
> I do see a off-by-one bug

No, sorry, that is a problem of my monitor/graphics board
combination. Certain colours are not centered well on monitor's
dot mask. With xmag I can see there is no 'real' bug.

Bye

Dominik ^_^