Subject: Notification: incoming/428

From: [email-masked]
Date: Sat, 7 Aug 1999 11:30:01 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/428

Message summary for PR#428
	From: [email-masked]
	Subject: ShapeNotify events for non-shaped windows
	Date: Sat, 7 Aug 1999 11:29:59 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Aug 1999 09:33:41 +0200

On Sat, Aug 07, 1999 at 11:30:01AM -0500, [email-masked] wrote:
> Description:
> When a shape notify event is received for a window
> that is _not_ shaped, the shape of the window is
> propagated to the parent, causing window decorations
> to be truncated.
> 
> How to replicate:
> 
> Switch GTK+ themes using the GNOME control center.
> (among other ways). This may be fvwm2rc dependent
> (otherwise it would have been noticed before, I
> would guess).
> 
> Fix:
> 
> SetShape should unset the shape if the window is
> not shaped, instead of setting it. A patch against
> latest CVS follows:

Okay, I've applied the patch.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]