Subject: fvwm2 crashes with "Menustyle * SidePixmap fred.xpm

From: [email-masked]
Date: Wed, 11 Aug 1999 11:08:13 -0500 (CDT)

Full_Name: 
Version: 2.3.6
CVS_Date: 
OS: 
X_Server: 
Submission from: (NULL) (194.202.174.20)
Submitted by: hippo

I know it's SidePic not SidePixmap but just crashing is a bit rude,
how about an error message instead?

(gdb) where
#0  0xef424614 in strlen () from /usr/lib/libc.so.1
#1  0xef45a4ac in _doprnt () from /usr/lib/libc.so.1
#2  0xef463514 in fprintf () from /usr/lib/libc.so.1
#3  0x243d0 in OldMenuStyle (eventp=0x6ac08, w=42, tmp_win=0x0, context=8,

    action=0xafba2 "* SidePixmap fred.xpm\n", Module=0xefffe264) at
menus.c:5717
#4  0x245e0 in SetMenuStyle (eventp=0x6ac08, w=42, tmp_win=0x0, context=8,

    action=0xafba2 "* SidePixmap fred.xpm\n", Module=0xefffe264) at
menus.c:5761
#5  0x42d00 in ExecuteFunction (Action=0xafb98 "MenuStyle * SidePixmap
fred.xpm\n", 
    tmp_win=0x0, eventp=0x6ac08, context=8, Module=8, expand_cmd=356036)
    at functions.c:657
#6  0x4dd68 in run_command_stream (f=0x6b000, eventp=0x6ac08, tmp_win=0x0,
context=8, 
    Module=8) at read.c:78

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 08:15:47 +0200

> how about an error message instead?

Hey! You scared me for a moment. 2.3.6 does *not* crash. It's
the current CVS code, i.e. 2.3.7. I forgot a debug statement in
there. It's fixed.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]