Subject: icon_entered bugfix

From: Ben Winslow <[email-masked]>
Date: Mon, 9 Aug 1999 16:31:50 -0400 (EDT)

Currently, if a window is deiconified with the mouse, IS_ICON_ENTERED(x) is
still set to 1, so when the window is iconified again, IS_ICON_ENTERED(x) is
still set to 1, so the full window title is drawn.  This is really a problem
when multiple windows are iconified when they all have IS_ICON_ENTERED set,
they start drawing over top of each other, and then try and redraw because
of that, which ends up chewing lots of CPU until you stop it.  Anyway, the
patch is attached, a whopping 1 line difference :)

-- 
Ben Winslow / [email-masked] / |Rain| / freshmeat news squad

Knowledge is of no value unless you put it into practice.
- Heber J. Grant
diff -ru fvwm.orig/fvwm/icons.c fvwm-2.3.6/fvwm/icons.c
--- fvwm.orig/fvwm/icons.c	Sun Aug  1 23:39:16 1999
+++ fvwm-2.3.6/fvwm/icons.c	Mon Aug  9 16:20:07 1999
@@ -1001,6 +1001,7 @@
 	  SetMapStateProp(t, NormalState);
 	  SET_ICONIFIED(t, 0);
 	  SET_ICON_UNMAPPED(t, 0);
+	  SET_ICON_ENTERED(t, 0);
 	  /* Need to make sure the border is colored correctly,
 	   * in case it was stuck or unstuck while iconified. */
 	  tmp = Scr.Hilite;

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Aug 1999 08:11:04 +0200

> patch is attached, a whopping 1 line difference :)

Okay, thanks. I have applied the fix.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]