Subject: [Fwd: CurrentDesk no WindowList option?]

From: TG <[email-masked]>
Date: Mon, 30 Aug 1999 17:29:17 +0200

TG wrote:
> 
> Hello,
> 
> (using lateste CVS versions..)
> 
> I have bound my middle mouse button to WindowList, but it doesn't work
> I'd like it to. And I think it did it's job right a few weeks ago.
> 
> This is the binding:
> 
> Mouse 2         R       N       WindowList CurrentDesk Transient
> 
> And this is what shows up at stderr:
> 
> [FVWM][WindowList]: <<ERROR>> Unknown option 'CurrentDesk'
> 
> Or did I do something stupid? ;-(

Hum, next time I should do a search through the mailing list archive
first... grr.

But shouldn't the man page be updated about the changed WindowList
options?

Tung
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Bird <[email-masked]>
Date: Tue, 31 Aug 1999 10:32:17 +0100

> But shouldn't the man page be updated about the changed WindowList

  This change shouldn't, AFAICS, have invalidated the existing syntax -
merely added the option of a [] condition class.

  <fx: checks cvs>

  Hmm. A mistake on my part, methinks. The patchfile I sent Dominik had
too much information :-(

  The following really ought to still be in windowlist.c:

--- windowlist.c.orig   Tue Aug 24 11:14:41 1999
+++ windowlist.c        Mon Aug 31 10:32:27 1999
@@ -158,6 +130,11 @@
          flags &= ~SHOW_ALLDESKS;
        }
       }
+      else if (StrEquals(tok,"CurrentDesk"))
+      {
+        desk = Scr.CurrentDesk;
+        flags &= ~SHOW_ALLDESKS;
+      }
       else if (StrEquals(tok,"NotAlphabetic"))
         flags &= ~SHOW_ALPHABETIC;
       else if (StrEquals(tok,"Alphabetic"))

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 123 days remaining
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 1999 02:38:18 +0200

> But shouldn't the man page be updated about the changed WindowList

No. The man page is correct. I'm not sure if this option was removed
on purpose. I've re-added it again.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]