Subject: make in fvwm/utils fails

From: Tim Phipps <[email-masked]>
Date: Tue, 24 Aug 1999 09:42:28 +0100

After this morning update (Tuesday August 24 09:37:09 BST 1999) "make
install" fails in the utils directory:

Making install in utils
make[1]: Entering directory `/export/disk1/tim/src/fvwm/utils'
cd .. && CONFIG_FILES=utils/fvwm-menu-xlock CONFIG_HEADERS= /bin/sh
./config.status
cd .. && CONFIG_FILES=utils/fvwm-menu-directory CONFIG_HEADERS= /bin/sh
./config.status
pod2man --center "Fvwm Utility" fvwm-menu-xlock     > fvwm-menu-xlock.1
2>/dev/null
BUILDER=${USER-${LOGNAME-`whoami`}} && \
sed -e 's,xCCx,gcc,'  -e 's,xCFLAGSx,-g -O2,' \
    -e 's,xprefixx,/home/tim,' -e 's,xsysconfdirx,/home/tim/etc,' \
    -e 's,xlibexecdirx,/home/tim/libexec,' -e "s,xBUILDERx,$BUILDER," \
    fvwmbug.sh > fvwmbug
rm: conftest.s2 not removed: No such file or directory
creating utils/fvwm-menu-xlock
creating utils/fvwm-menu-directory
make[1]: *** [fvwm-menu-xlock.1] Error 2
make[1]: *** Waiting for unfinished jobs....
sed: Cannot open pattern-file: conftest.s1
make[1]: Leaving directory `/export/disk1/tim/src/fvwm/utils'
make: *** [install-recursive] Error 1

Second time around it works with no errors.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 24 Aug 1999 10:18:20 +0100

> Second time around it works with no errors.
I can make it produce the error by cd'ing to utils and touching *.in. 
The error
doesn't happen with make but does with `MAKE="make -j 5" make -j 5' i.e.
a parallel make so it looks like one of the scripts isn't producing a
uniquely named temporary file

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 25 Aug 1999 00:51:46 +0300 (IDT)

> > Second time around it works with no errors.

The second (parallel) make will not fail, but the state is not good, any
of 7 generated from .in files can have a zero size.

> The error doesn't happen with make but does with `MAKE="make -j 5" make
> -j 5' i.e. a parallel make so it looks like one of the scripts isn't
> producing a uniquely named temporary file

I don't know how to fix this problem, but it happens because AFAICS
../config.status, used to generate fvwmbug.sh and all fvwm-menu-(word)
scripts, is not designed to be run in parallel with itself. If I am right
this must be probably reported to autoconf developers.

I wonder, how faster or slower a parallel make is than a normal one.
A normal make always takes all my CPU.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Aug 1999 10:51:22 +0200

> A normal make always takes all my CPU.

I guess it's slower if you only have one CPU :-)

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 25 Aug 1999 06:25:05 -0400

> I guess it's slower if you only have one CPU :-)

A parallel make should be faster even on a single processor machine. The
idea is gcc spends most of its time in I/O not actually computation, so
while one gcc is blocked another can use the cpu.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 26 Aug 1999 12:43:31 +0100

> A normal make always takes all my CPU.

It's about three times faster on a 4 way ultra-sparc.

cd fvwm/libs
time make:
 
real    0m17.779s
user    0m11.940s
sys     0m2.740s

time make -j 5:

real    0m6.212s
user    0m12.200s
sys     0m3.120s

uname -a:

SunOS tazmo 5.6 Generic sun4u sparc SUNW,Ultra-4

It gets less impressive on the modules that only have few .c files to
compile.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 26 Aug 1999 13:50:36 +0200

> It gets less impressive on the modules that only have few .c files to

Not bad. After Brad's suggestion I tried to compile some old
version on a one processor machine in parallel and serial.

Parallel make:

  60 seconds

Serial make:

  57 seconds

Bye

Dominik ^_^