Subject: CVS hippo: PrintXErrorAndCoredump() prints the name of the request code

From: CVS <[email-masked]>
Date: Mon, 23 Aug 1999 06:57:25 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/08/23 06:57:25

Modified files:
	libs           : XError.c 

Log message:
PrintXErrorAndCoredump() prints the name of the request code

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 14:02:36 +0200

> PrintXErrorAndCoredump() prints the name of the request code

Can you give an example of the output? Or better: if you know
what's wrong, can you fix it (it's a rather simple function)?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 23 Aug 1999 13:08:30 +0100

> what's wrong, can you fix it (it's a rather simple function)?

It used to print

*FvwmWinList: Cause of next X Error.
   Error: 9 (BadDrawable (invalid Pixmap or Window parameter))
   Major opcode of failed request:  53
   Minor opcode of failed request:  0 
   Resource id of failed request:  0xc00010 
 Leaving a core dump now

now it prints

*FvwmWinList: Cause of next X Error.
   Error: 9 (BadDrawable (invalid Pixmap or Window parameter))
   Major opcode of failed request:  53 (CreatePixmap)
   Minor opcode of failed request:  0 
   Resource id of failed request:  0xc00010 
 Leaving a core dump now

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 14:21:36 +0200

>    Major opcode of failed request:  53 (CreatePixmap)
                                         ^^^^^^^^^^^^^^
>    Resource id of failed request:  0xc00010 

?????????????????

It ***can't*** print this. THe resonsible line from XError.c:

  fprintf(stderr, "   Major opcode of failed request:  %d \n",
	  error->request_code);

How could a '%d'-printf argument print a string? BTW, if it
prints this additional information now - great, but I'd like
to understand why. Which module is printing this?

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Mon, 23 Aug 1999 13:28:41 +0100

Try a cvs update.  XError.c does the number to string translation, this
thread started from the CVS commit message that implemented it. I'm not
sure that there is not a better way of doing it, 
XGetErrorDatabaseText() might work but I couldn'e understand the man
page.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 14:42:25 +0200

> XGetErrorDatabaseText() might work but I couldn'e understand the man

Uh, sorry! I thought the message was from Jitterbug, not CVS. Please
forget everything I said about it :-)

Bye

Dominik ^_^