Subject: horizontal grow has problem with sticky windows

From: TG <[email-masked]>
Date: Tue, 17 Aug 1999 22:18:21 +0200

Using latest CVS versions, I encountered next problem with this command:

Maximize grow 100

Let R be the window to be resized and S a sticky window which frame
forms the boundary for R's grow and both windows have no overlapping
area.

Problems arise in the two following situations:

1 - Window S is spread over the west and north-east area of window R

             ---------
             |       |
             |   S   |
---------    |       |
|       |    ---------
|   R   |
|       |
---------

Using "Maximize grow 100" on window R grows it ignoring window S.

2 - Window S is in the south-east area of window R

---------
|       |
|   R   |
|       |
---------

             ---------
             |       |
             |   S   |
             |       |
             ---------

R stops growing till the x coordinate of the left side of window S.

Note: these problems don't arise with vertical grows.

Regards,

Tung
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 18 Aug 1999 01:35:13 +0200

> 1 - Window S is spread over the west and north-east area of window R

The fastest bugfix in history :) Took about one minute.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]