Subject: SIGHUP for restart

From: TG <[email-masked]>
Date: Tue, 03 Aug 1999 22:54:43 +0200

Some time ago, fvwm2 hanged and the only way I could stop it was to kill
the X server with Ctrl+Alt+Back.

I just wondered, wouldn't it be nice if we could restart fvwm2 by
sending a SIGHUP signal from the console?

Greetings,

Tung
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Neil Bird <[email-masked]>
Date: Wed, 04 Aug 1999 08:34:51 +0100

> sending a SIGHUP signal from the console?

  I'd [tentatively - not having looked at what that would incur!] go along
with that.

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 150 days remaining
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 4 Aug 1999 06:49:04 -0400

>   I'd [tentatively - not having looked at what that would incur!] go along

After a quick look at the code, HUP performs the quit function but USR1 does a restart, so you could just use that signal from the console instead.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Chris Rankin <[email-masked]>
Date: Wed, 4 Aug 1999 20:51:31 +1000 (EST)

>   I'd [tentatively - not having looked at what that would incur!] go along

It wouldn't be too difficult to do. SIGHUP currently terminates fvwm2,
but a small change could associate it with the Restart() handler
function instead. Actually, SIGUSR1 currently causes fvwm2 to restart
so maybe you could try this and tell us whether this is what you had
in mind?

Cheers,
Chris.