Subject: Notification: incoming/430

From: [email-masked]
Date: Mon, 9 Aug 1999 16:04:41 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/430

Message summary for PR#430
	From: [email-masked]
	Subject: "Next [!XXX] Focus" ignores "!"-entries
	Date: Mon, 9 Aug 1999 16:04:39 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 11 Aug 1999 09:59:39 +0200

> FVWM Bug Tracking notification
...
> 
> I use in fvwm2rc the line
>   Key  KP_Begin  A  N  \
>       Next [!iconic !xosview !ipwatch !FvwmButtons CurrentScreen] Focus
> to rotate the focus of X11 applications.
> 
> But fvwm2 ignored in this context some entries: Iconified apps
> and xosview both are correctly ignored while rotating, but the 
> following "!"-entries ("!ipwatch", "!FvwmButons") have no in-
> fluence - both applications get the focus.

You can't use more than one application name in a condition. If you
specify multiple names, all but the first one is ignored. You should
use the WindowListSkip style for these applications instead:

  Style xosview WindowListSkip
  Style FvwmButtons WindowListSkip
  Style ipwatch WindowListSkip

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]