Subject: colour set bugs (Pager and IconMan)

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 14:16:23 +0200

Both modules don't update their backgrounds when they are
resized. I didn't try the other modules with colour set support,
but I assume they have the same problem.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 08:23:10 -0400

Huh?? here is my pager I started them both as FvwmPager 0 1 then resized
one of them.  As for IconMan mine doesn't resize.  

On Mon, Aug 23, 1999 at 02:16:23PM +0200, Dominik Vogt wrote:

> Both modules don't update their backgrounds when they are resized. I
> didn't try the other modules with colour set support, but I assume
> they have the same problem.
>
> Bye
>
> Dominik ^_^
>

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 14:36:54 +0200

> one of them.  As for IconMan mine doesn't resize.  

Use a colour set with a gradient as background and make the pager
bigger. You will see it clear as day. To resize IconMan you may
have to turn off the MWM styles.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 09:23:07 -0400

> have to turn off the MWM styles.

I am using a gradient and as you can see in my screen grab nothing
appear wrong.  I know for a fact it handles it because I know it was
broken when I was first creating the patch, I finally figure out that I
neede to reset the pixmap in the ReConfigure function in x.c.

here is my config, why don't you send me yours it is possible that I
missed a case.

*FvwmPagerColorset 0 0
*FvwmPagerBalloonColorset 0 0
*FvwmPagerHilightColorset 0 1
*FvwmPagerColorset 1 0
*FvwmPagerBalloonColorset 1 0
*FvwmPagerHilightColorset 1 1

*FvwmThemeColorset 0 gray80 #515178 CGradient 128 #515178 #000000
*FvwmThemeColorset 1 gray80 #515178 DGradient 128 #000000 #909078

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 15:45:40 +0200

On Mon, Aug 23, 1999 at 09:23:07AM -0400, [email-masked] wrote:
> appear wrong.

No, I can't. You didn't attach it :-)

> I know for a fact it handles it because I know it was

Screenshots attached. Screenshot 1 shows the original FvwmButtons
with a swallowed pager and iconman. Screenshot 2 show the same after
resizing.

> here is my config, why don't you send me yours it is possible that I

Okay, here we go (replace the C... macros with any colour name you like,
same with FONT...):

*FvwmThemeColorset 1 CFORE CBORDER
*FvwmThemeColorset 2 CFORE CFOCUS
*FvwmThemeColorset 3 CFORE CMENU
*FvwmThemeColorset 4 CFORE CMENU
*FvwmThemeColorset 5 CFORE CSHADED
*FvwmThemeColorset 6 CFORE CBACK VGradient 100 dtcolour5 CMENU
*FvwmThemeColorset 7 CFORE CHILIGHT
*FvwmThemeColorset 8 CFORE CBACK TiledPixmap my_kill.xpm
*FvwmThemeColorset 9 black white VGradient 100 dtcolour5 CMENU
*FvwmThemeColorset 10 red blue TiledShape empty_shape.xpm
*FvwmThemeColorset 11 red blue TiledPixmap empty_shape.xpm

*FvwmPagerRows         1
*FvwmPagerColumns      1
*FvwmPagerGeometry     +32767+32767
*FvwmPagerFont         none
*FvwmPagerSmallFont    FONTXXXS
*FvwmPagerWindowLabelFormat %r
*FvwmPagerSloppyFocus
*FvwmPagerBalloons
*FvwmPagerBalloonStringFormat %t
*FvwmPagerColorset 0 6
*FvwmPagerBalloonColorset 0 6
*FvwmPagerHilightColorset 0 7
*FvwmPagerWindowColorsets 1 2

*FvwmIconMan*Action Mouse 3 N sendcommand close
*FvwmIconMan*ButtonGeometry 57x11
*FvwmIconMan*FollowFocus true
*FvwmIconMan*Font FONTXXXS
*FvwmIconMan*Format "%t"
*FvwmIconMan*ManagerGeometry 2x5+32767+32767
*FvwmIconMan*Resolution page
*FvwmIconMan*Title ""
*FvwmIconMan*UseWinList true
*FvwmIconMan*Action Mouse 2 N sendcommand Focus
*FvwmIconMan*Colorset 6
*FvwmIconMan*FocusColorset 2
*FvwmIconMan*FocusAndSelectColorset 2
*FvwmIconMan*PlainColorset 6
*FvwmIconMan*SelectColorset 6
*FvwmIconMan*TitleColorset 6
*FvwmIconMan*FocusButton up
*FvwmIconMan*PlainButton up
*FvwmIconMan*SelectButton flat
*FvwmIconMan*FocusAndSelectButton flat
*FvwmIconMan*TitleButton flat

*FvwmButtons(11x5, Swallow FvwmPager 'FvwmPager * * -geometry 40x40-2000-2000')
*FvwmButtons(14x5, Left, Swallow FvwmIconMan 'Module FvwmIconMan')

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 10:03:17 -0400

> *FvwmThemeColorset 11 red blue TiledPixmap empty_shape.xpm

Alright lets try a couple of things here, 

one could you run M4 for with -debug it rights your rc file in /tmp with
all the macros filled in.

two try running a pager unswallowing your pager for me. and see if it is still broken.

three here is the screenshot, I had forgetton it.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 17:32:28 +0200

> all the macros filled in.

I'll use FvwmCpp instead. Complete config file attached.

> two try running a pager unswallowing your pager for me. and see if it is still broken.

This fixes the pager, but iconman still fails (note that I can only
resize it horizontally).

> three here is the screenshot, I had forgetton it.

I see.

Bye

Dominik ^_^

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Aug 1999 12:49:32 -0400

> I'll use FvwmCpp instead. Complete config file attached.
FvwmCpp also has a -debug option

> This fixes the pager, but iconman still fails (note that I can only

Tell me when you resize IconMan what do you want to see.  
blank squares or do you want all of the buttons to resize themseleves??

I was able to reproduce your problem while working on Tim's and they
are related so what is the correct behavior right now you are left with
empty squares, however if you update one of the colorsets after a resize
it will fill in the area empty area by resizing all the buttons.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Aug 1999 23:38:31 +0200

> blank squares or do you want all of the buttons to resize themseleves??

Good point. Probably the bug is that FvwmIconMan doesn't properly resize
at all. Another bug seems to be that FvwmButtons doesn't resize swallowed
apps when it's resized itself.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]