Subject: colorset support for FvwmIconBox

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 11:53:04 -0400

Here is the patch for FvwmIconBox, I beleive we agreed Tim would apply
these for me.  I didn't get use of the pixmaps working as background for
the icons and labels, it seemed to create to much flicker.  If you want
to try your hand at it look for the XSetBackground calls in RedrawIcon.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 1999 18:05:40 +0200

> to try your hand at it look for the XSetBackground calls in RedrawIcon.

Do you have a ChangeLog entry too, Brad?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 31 Aug 1999 12:32:53 -0400

> Do you have a ChangeLog entry too, Brad?

Oops, emacs went nuts and put it in another open Changelog.
here it is:
1999-08-31  Brad Giaccio  <[email-masked]>

	* FvwmIconBox/FvwmIconBox.c (main):
	(CreateWindow):
	(process_message):
	(change_colorset): first cut at colorset support in FvwmIconBox,
	no pixmap backgrounds used on icon but main window does get the pixmap