Subject: Bug in Pager with Colorset Config

From: Olivier Chapuis <[email-masked]>
Date: Sat, 07 Aug 1999 08:10:27 +0200

Configuration Information [Automatically generated, do not change]:
uname output: Linux snoopy.parislyon.fr 2.2.10 #1 mer jun 16 06:29:51 CEST 1999 i586 unknown
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /usr/local
sysconfdir: /usr/local/etc
libexecdir: /usr/local/libexec

FVWM Version: 2.3.7
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /usr/local/libexec/fvwm/2.3.7
FVWM_USERHOME: /home/olivier/.fvwms

Description:
	Hello,
	I use a FvwmPager called SimplePager which is a symbolic
	link to FvwmPager. When, I use the new options 
	*SimplePager*Colorset * n
	then if I call "SimplePager" I've got the pager for the current
	desk and everything is ok. But if I run this pager with "options",
	say:

	SimplePager * *
	or
	SimplePager 0 3

	the pager does not start (no process, no error to stderr).
	I do not have this problem if I remove the Colorset config
	line. Below my config.

Repeat-By:
       	cd $FVWM_MODULEDIR
	ln -s FvwmPager SimplePager
	Add the following in your .fvwm2rc:

Style "SimplePager"  NoTitle, Sticky, NoHandles, WindowListSkip, MouseFocus
DestroyModuleConfig SimplePager
*SimplePagerColorset * 3
*SimplePagerWindowColorsets 0 2
*SimplePagerHilightColorset * 1 
*SimplePagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*SimplePagerMiniIcons
*SimplePagerGeometry 155x96-0+210
*SimplePagerSmallFont 5x8
*SimplePagerLabel 0 Bureau
*SimplePagerLabel 1 Bureau1
*SimplePagerLabel 2 Bureau2
*SimplePagerLabel 3 Bureau3

	My FvwmTheme Config:

DestroyModuleConfig FvwmTheme
*FvwmThemeColorset 0 white grey45
*FvwmThemeColorset 1 Black white
*FvwmThemeColorset 2 white RoyalBlue3
*FvwmThemeColorset 3 black grey60
*FvwmThemeColorset 4 yellow RoyalBlue3
*FvwmThemeColorset 8 red RoyalBlue3
*FvwmThemeColorset 9 red yellow

	So, now: Module FvwmTheme, Module SimplePager * * 
	Do you have the SimplePager ?

Execpte this litle problem I am quite happy with the new module
FvwmTheme, Thanks !

Olivier
-- 
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Aug 1999 11:38:25 +0200

> 	I do not have this problem if I remove the Colorset config

There were several places where a NULL pointer was accessed.
Fixed now.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]