Subject: Re: killmodule FvwmGtk does not kill

From: Dominik Vogt <[email-masked]>
Date: Wed, 7 Jul 1999 01:08:24 +0200

On Tue, Jun 22, 1999 at 10:04:32PM +0200, Olivier Chapuis wrote:
> Configuration Information [Automatically generated, do not change]:
> uname output: Linux snoopy.parislyon.fr 2.2.10 #1 mer jun 16 06:29:51
> CEST 1999 i586 unknown
> Compiler: gcc
> Compilation CFLAGS: -g -O2
> prefix: /usr/local
> sysconfdir: /usr/local/etc
> libexecdir: /usr/local/libexec
> 
> FVWM Version: 2.3.3 and the "last" cvs
> FVWM_CONFIGDIR: unset
> FVWM_MODULEDIR: /usr/local/libexec/fvwm/2.3.3
> FVWM_USERHOME: unset
> 
> Description:
>  KillModule FvwmGtk does not kill FvwmGtk on my machine. Even
>  whorse after the killmodule, FvwmGtk take 100% of the CPU ... 
> 
> Repeat-By:
>   Module FvwmGtk
>   KillModule FvwmGtk

I don't see this problem with the current code. Is this fixed?
If not, can you post your config lines for FvwmGtk?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 08 Jul 1999 22:49:26 +0200

> If not, can you post your config lines for FvwmGtk?

Hello,
Unfortunately I still have this problem.
It does not seem that the configuration is a problem
(for this ...). I've got this problem with an empty config
file for FvwmGtk, or with this very simple one:

*FvwmGtkDestroy test
*FvwmGtkMenu test
*FvwmGtkTitle "This a test !"
*FvwmGtkSeparator
*FvwmGtkItem "xterm" "Exec exec xterm"

Perhaps it is a problem of gtk+ version:
[olivier@snoopy olivier]$ rpm -qa | grep gtk+
gtk+-1.1.2-2 (for gimp)
gtk+10-1.0.6-4
gtk+-1.2.0-1 (for gnome)
gtk+-devel-1.2.0-1

[olivier@snoopy olivier]$ ldd /usr/local/libexec/fvwm/2.3.6/FvwmGtk 
	libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x40007000)
	libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40014000)
	libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x4001f000)
	libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40034000)
	libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40040000)
	libm.so.6 => /lib/libm.so.6 (0x400e3000)
	libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x400fc000)
	libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x4021f000)
	libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x40251000)
	libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40255000)
	libdl.so.2 => /lib/libdl.so.2 (0x40278000)
	libgdk_imlib.so.1 => /usr/lib/libgdk_imlib.so.1 (0x4027b000)
	libc.so.6 => /lib/libc.so.6 (0x4029f000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x2aaaa000)

Moreover, When I start FvwmGtk I've got the following error:

** CRITICAL **: file menu.c: line 265 (menu_title): assertion `argc > 0' failed.

** CRITICAL **: file menu.c: line 265 (menu_title): assertion `argc > 0' failed.

** CRITICAL **: file menu.c: line 265 (menu_title): assertion `argc > 0' failed.

But I do not think that this is linked with the problem. I have take a look
at the code, my very humble opinion is that the problem is in fvwm/module.c
and that perhaps there is a problem for exiting a gtk_loop (but my level in
C is "Hello World").

Olivier.