Subject: Bug in FormFvwmRootCursor.

From: Olivier Chapuis <[email-masked]>
Date: Mon, 05 Jul 1999 10:29:21 +0200

Configuration Information [Automatically generated, do not change]:
uname output: Linux snoopy.parislyon.fr 2.2.10 #1 mer jun 16 06:29:51 CEST 1999 i586 unknown
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /usr/local
sysconfdir: /usr/local/etc
libexecdir: /usr/local/libexec

FVWM Version: 2.3.6
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: /usr/local/libexec/fvwm/2.3.6
FVWM_USERHOME: /home/olivier/.fvwms

Description:
There is a problem with FormFvwmRootCursor., the file contains the 
following configuration line:

*FormFvwmRootCursor.WarpPointer

So we cannot test the cursors (we need to "finish" to see the new
cursor if we have set it one). Even more, since this Form is very
big, in my 800x600 screen, it may happen that I cannot clic on
the finish button and so with the above config line I need to kill
the form via an other (virtual) console...

Repeat-By:
	FvwmFrom FormFvwmRootCursor. :o)

Fix: Remove the line *FormFvwmRootCursor.WarpPointer from the
file /home/cvs/fvwm/fvwm/modules/FvwmForm/FormFvwmRootCursor.

Olivier

-- 
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Jul 1999 17:05:35 +0300 (IDT)

On Mon, 5 Jul 1999, Olivier Chapuis wrote:

> cursor if we have set it one).

WarpPointer does not prevent you from moving your mouse outside the form.

> Even more, since this Form is very

For me FormFvwmRootCursor takes 606x680, so there is a real problem with
the 800x600 screen. There is still root space at the right or left to
test a cursor. The form must be reduced in size, but with the current
state of FvwmForm it seems to be impossible. Maybe FvwmGtk is better...

For you I can suggest to use FvwmScroll to swallow this big form.
Although there is a problem with it. It uses black on black colors for
scroll bars by default, so include this line into your config:
  read ConfigFvwmScroll

> file /home/cvs/fvwm/fvwm/modules/FvwmForm/FormFvwmRootCursor.

I fail to see how removing this line can help. If you say that this helps,
I will remove it.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 06 Jul 1999 07:21:53 +0200

> WarpPointer does not prevent you from moving your mouse outside the form.

Oops, I am really sorry I made a mistake some where, every thing is ok ...
 
> state of FvwmForm it seems to be impossible. Maybe FvwmGtk is better...

A solutions: 5 cursor per line. This gives a 755x584 Form.
Almost good for all screen ?
Moreover, 
with a 6x12 font :  750x563
with a 6x10 font :  740x521 (but the font is probably to small for big
screen).

Thanks for your answers (to my stupide bug ...).

Olivier
-- 
[email-masked]