Subject: CVS hippo: New module FvwmTheme

From: CVS <[email-masked]>
Date: Fri, 16 Jul 1999 11:55:35 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/07/16 11:55:35

Modified files:
	.              : ChangeLog NEWS configure.in 
	fvwm           : add_window.c builtins.c colors.c functions.c 
	                 functions.h fvwm.c fvwm2.1 misc.h screen.h 
	libs           : Graphics.c Makefile.am fvwmlib.h 
	modules        : Makefile.am 
	modules/FvwmButtons: Makefile.am 
	modules/FvwmIconBox: Makefile.am 
	modules/FvwmScroll: Makefile.am 
Added files:
	libs           : Colorset.c Colorset.h 
	modules/FvwmTheme: .cvsignore FvwmTheme.1 FvwmTheme.c 
	                   Makefile.am 

Log message:
New module FvwmTheme
Doesn't do anything visible yet apart from generate an error from fvwm2.
New libarary files Colorset.{c,h} for managing colorsets.
Moved AllocGradient & CreateGradientPixmap from fvwm2 to fvwmlib.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 20 Jul 1999 06:36:55 -0400

If I'm reading the man page correctlly I should be able to say
"DefaultColors" with no args, right now if I do that I get "Cannot parse
color Segmentation Fault - core dumped " this is on a 24bit server.

#0  0xff036c5c in strlen () from /usr/lib/libc.so.1
#1  0xff07ec20 in _doprnt () from /usr/lib/libc.so.1
#2  0xff08064c in fprintf () from /usr/lib/libc.so.1
#3  0x4ec60 in GetColor (name=0x0) at Picture.c:461
#4  0x2816c in SetDefaultColors (eventp=0x69200, w=55, tmp_win=0x0, context=8, 
    action=0x52f48 "-", Module=0xffbeeb5c) at builtins.c:1652
#5  0x42180 in ExecuteFunction (Action=0xa8e50 "DefaultColors\n", tmp_win=0x0, 
    eventp=0x69200, context=8, Module=6, expand_cmd=349388) at functions.c:574
#6  0x3e4b4 in HandleModuleInput (w=0, channel=6) at module_interface.c:412
#7  0x2ed20 in My_XNextEvent (dpy=0x18, event=0x6) at events.c:2002
#8  0x2c450 in HandleEvents () at events.c:240
#9  0x2ffd0 in main (argc=427008, argv=0x69400) at fvwm.c:689

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Tue, 20 Jul 1999 16:30:43 +0100

> color Segmentation Fault - core dumped " this is on a 24bit server.

Fixed. It was setting the background instead of the foreground if the
foreground was blank.

Cheers,
Tim.