Subject: Gnome: Bug(?)/questions (future Faq ?)

From: Olivier Chapuis <[email-masked]>
Date: Mon, 05 Jul 1999 12:02:44 +0200

Hello,
I test the gnome patch since its appeared in the cvs (I used the panel
since 3 months with 2.2.2). Here a report on this (latest cvs). I mention
only the problems, almost everything work very well.
I do not send this message before because I hoped for a gnome man page. 
However, since it seems that this man page perhaps never appears, I send 
this message now (I think that if gnome is not more documented, you
will receive a lot of message as this one, perhaps a fvwm2-gnome FAQ
will be a good thing (better than a man page ??)). 
Probably, some of the bugs that follow are gnome bugs...
I use rpm package for gnome:
[olivier@snoopy olivier]$ rpm -qa | grep gnome 
gnome-audio-1.0.0-2
gnome-libs-1.0.3-4
gnome-objc-1.0.1-1
gnome-utils-1.0.1-1
gnome-core-1.0.4-12rh

1. Restart.
When I restart, the panel restart in a curious way: I've got a
curious panel in the right bottom of the screen, I need to clic
on this panel for that my true panel restart (I use a corner panel
in the top left). This is a bug or a feature ? To restart I use
simply the function "Restart". Is this the good way to restart
with gnome ? 
I have also noticed that just before my panel really restart,
some other panels appear and disappear at once. It seems to me that
the reason of this is that the file $HOME/.gnome/panel.d/default/panel
contains configuration for panels that are not used.
Note that the above phenomenas do not occur at startup.
I use a laptop, and gnome use a lot of resource. So, I do not
use gnome when the machine is ac off-line. I will be interested
to switch from a gnome-session (with fvwm2) to fvwm2 without gnome,
without leaving X and startx again. Can I do that ?

2. Panel Style.
When I FvwmIdentify my panel I obtain Name: panel, Class: Panel, 
Resource: panel. However, Style "*anel*" BorderWidth 0, does not work.
I presume that not all the usual Style can apply to the panel, However,
Style * BordWidth 0 gives me a panel with BordWidth 0. So, How can I
use styles for the panel ? 
I do not know why the gnome workers do that but: either the panel is 
"StaysOnTop" or "StaysOnBottom" ! Can fvwm2 do something against this absurd
dichotomy ?

3. Save current setup.
I think that the following procedure show a bug somewhere.
a) Close the session saveing the current setup with, say, a
Gnome-Terminal on Desk 0 and Page (3,2) with a geometry of +60+10.
b) First restart: I've got my Gnome-Terminal at the good place (D 0,
P (3,2) geo +60+10).
c) Close the session again but without saving the current setup.
d) startx again: I've got a Gnome-Terminal on Desk 0, page (1,1) and
geometry +0+0.

Yours Sincerely, Olivier
-- 
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Jul 1999 17:57:16 +0300 (IDT)

> simply the function "Restart". Is this the good way to restart

Yes, "Restart" must always work.
I remember seeing something similar before, but currently I can't
reproduce this. Deeper testing is needed.
But I can reproduce other strange things with panels, like the second
panel takes away applets from the first one, really gnome bug.

> Note that the above phenomenas do not occur at startup.

Seems to be features of gnome, but this must be tested with enlightenment,
I think.

> without leaving X and startx again. Can I do that ?

If you have gnome-session as the last line of your .xinitrc or similar,
you can't quit gnome-session without quiting X. You can try some trick
like putting your own script as the last line of .xinitrc, which executes
gnome-session and then fvwm2 in cycle (untested). Remember to define
both Session{Init|Restart}Function and {Init|Restart}Function for this.
And you must quit the gnome-session using the panel, of cause. There is
currently no QuitSession fvwm command.

> 2. Panel Style.
> When I FvwmIdentify my panel I obtain Name: panel,Class: Panel,

For me BorderWidth 0 has no effect, since the panel is borderless.
I use this line:
  Style "panel" ClickToFocus, Sticky, WindowListSkip

> "StaysOnTop" or "StaysOnBottom" ! Can fvwm2 do something against this absurd

I think no, since the panel dynamically puts itself in the highest
(lowest) layer and fvwm respects this. Although I don't understand
anything in layers yet. :)

> d) startx again: I've got a Gnome-Terminal on Desk 0, page (1,1) and

I will comment on this later.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 04:25:18 +0200

On Mon, Jul 05, 1999 at 12:02:44PM +0200, Olivier Chapuis wrote:
> simply the function "Restart".

Fixed.

> Is this the good way to restart with gnome ? 

Yes.

> "StaysOnTop" or "StaysOnBottom" ! Can fvwm2 do something against this absurd

Yes. Try

  DefaultLayers 6 8 10

This put normal windows on the same layer as the panel (8). It can then
be raised/lowered normally (staysontop and staysbelow won't work however).

> d) startx again: I've got a Gnome-Terminal on Desk 0, page (1,1) and

What must I do to save and restart a session? I could not figure this
out.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 09 Jul 1999 00:38:48 +0200

> > "StaysOnTop" or "StaysOnBottom" ! Can fvwm2 do something against this absurd

Yes, this works, Fantastic !
 
> What must I do to save and restart a session? I could not figure this

It seems that the feature "save the current session" appears with
gnome-core-1.0.4 (discussion with Mikhael G.).
When I close the session I've got a windows like this

           _________________________________
          |                                 |
          |    Really logout ?              |
          |                                 |
          |    o save the current setup     |
          |                                 |
          |_________________________________|
          |                                 |
          |   Yes                No         |
          |                                 |
          |_________________________________|
          
Where the "o" is a buttons unpressed by default (= do not save ...).
If I press this buttons, I save the current setup and this works well
at the first restartx, but badlly after. Seems that "save the current setup"
meens something like "SaveDesk". We can also find the "save the current
setup" somewhere in the gnome menu. Note that I have no more:
"o Ask next time" ... 

Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 Jul 1999 04:31:58 +0200

> > > use styles for the panel ?

You have to use HandleWidth:

  Style *ane* HandleWidth 0

> gnome-core-1.0.4 (discussion with Mikhael G.).

I have 1.0.3 :-) Mikhael, can you look into this?

Bye

Dominik ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 9 Jul 1999 06:19:29 +0300 (IDT)

> I have 1.0.3 :-) Mikhael, can you look into this?

I will. Just upgraded from 1.0.3 to 1.0.7! :-)
But it seems that this bug has nothing to do with the ability to save or
not to save the current state. fvwm sometimes ignores window states for
some windows on startup (my guess: windows with client_id set).

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 11 Jul 1999 04:58:50 +0200

> > simply the function "Restart".

Yes, it is :o}   
Olivier