Subject: Bug in RaiseLower

From: Tim Phipps <[email-masked]>
Date: Thu, 08 Jul 1999 10:51:38 +0100

I don't know what the fix is going to be but the reason that RaiseLower
doesn't work with partially offscreen windows is pretty clear:

void raiselower_func(F_CMD_ARGS)
{
  if (IS_FULLY_VISIBLE(tmp_win))
    {
      LowerWindow(tmp_win);
    }
  else
    {
      RaiseWindow(tmp_win);
    }
}

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 21:35:16 +0200

>   if (IS_FULLY_VISIBLE(tmp_win))

Uh, yes. I think we have a little communications problem here.
I'm fully aware of that problem. I want to solve this while
adapting Mark Rainford's patch to find a working solution for 
trandient handling. I guess I didn't make it clear enough that
I know where the problem is. Sorry.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]