Subject: Notification: incoming/410

From: [email-masked]
Date: Sat, 3 Jul 1999 08:55:15 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/410

Message summary for PR#410
	From: [email-masked]
	Subject: "Sticky" windows broken in 2.3.5
	Date: Sat, 3 Jul 1999 08:55:13 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 01:53:40 +0200

On Sat, Jul 03, 1999 at 08:55:15AM -0500, [email-masked] wrote:
> This bug report is going to be fairly vague, because it has suddenly
> started working
> again - (hate that!). When I initially restarted fvwm with the new fvwm
> binary, my
> FvwmButtons window lost its "Sticky" property. This behaviour continued
> over several
> restarts. When I launched a second FvwmButtons window from a menu-option,
> that one
> was properly sticky. When I subsequently declared another window to be
> sticky in my
> .fvwm2rc file (xconsole) and restarted, then FvwmButtons became sticky
> again.
> 
> I have now put everything back the way it was, and suddenly FvwmButtons is
> sticky
> again after a restart. (xconsole doesn't iconify itself on restart any
> more, either).
> 
> Does anyone have a clue what this all means? ('cos I don't ;-)).

Is is possible that you made FvwmButtons slippery in a previous
session (with the old version) by accident? If you had one of the
versions where the ~/.fvwm-restart file was not deleted after a
restart the 'slippery' state would have been written into the
file and override the value from your config file upon restart.
Making FvwmButtons sticky and then restarting would have fixed
things as you experienced.

If this is the case you should be able to reproduce this
behaviour by downgrading fvwm to your old fvwm version,
make FvwmButtons slippery, Restart, upgrade to new version
and Restart again.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]