Subject: Raising Netscape windows

From: Dan Espen <[email-masked]>
Date: Thu, 01 Jul 1999 16:00:05 -0400

With todays CVS, I can no longer raise Netscape windows.

I have the Sun "front" key bound like this:

Key F15   FSTWI0123456789 N RaiseLower
Key F15   R A Beep

With 2.2.2, I can shuffle through stacks of windows.

With todays  CVS this doesn't seem  to work with  a  stack of Netscape
windows.  Rxvt windows work  OK.  I can  also raise a Netscape  window
with the mouse  pointer over a  visible part of  a overlapped Netscape
window.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jul 1999 11:43:53 +0200

> with the mouse  pointer over a  visible part of  a overlapped Netscape

I made a mistake with RaiseLower. Raise and Lower should work. When
a window is partially off screen it is never lowered with RaiseLower
but always raised. Dan, can you verify my theory and tell me if there
is more you can not explain with it?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 02 Jul 1999 11:02:14 -0400

> is more you can not explain with it?

Lower works.

Raise works, but so does raiselower.  (Raise or raiselower will raise
the window when I click on the visible part.)  Its only when I use
raiselower on the top window that it fails.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jul 1999 17:40:50 +0200

> raiselower on the top window that it fails.

Does it fail always or only if the top window is partially off screen?

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Fri, 02 Jul 1999 17:23:11 -0400

> Does it fail always or only if the top window is partially off screen?

You're obviously on to the solution.
The failure only happens when the window is partially off screen.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Jul 1999 02:41:56 +0200

> with the mouse  pointer over a  visible part of  a overlapped Netscape

Hm, there seems to be a problem with lowering netscape windows
with RaiseLower. I will revisit the changes I made to the
stacking order code.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]