Subject: Notification: incoming/417

From: [email-masked]
Date: Thu, 15 Jul 1999 10:57:26 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/417

Message summary for PR#417
	From: [email-masked]
	Subject: Next/Prev appear to be broken
	Date: Thu, 15 Jul 1999 10:57:24 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 17 Jul 1999 09:59:28 +0300 (IDT)

On Thu, 15 Jul 1999 [email-masked] (Stephen Riehm) wrote:

> Version: 2.0.46 - 2.2.2

> Until recently, I've been using fvwm-2.0.45, and I've been using
> SloppyFocus and
> keyboard shortcuts to jump between windows in the current page.
> now, changing the keyboard macros don't work in two ways:
> 
> 	shifting the focus to another window doesn't raise the window

It is supposed to be so.
You can define FocusAndRaise function and use it instead of just Focus.

> 	shifting the focus doesn't work if the mouse is positioned over the
> window
> 		you're leaving, because fvwm instantly moves the focus to the mouse.
> 
> 	(as an aside, Next/Prev now take several seconds to complete, on a 450MHz
> 	linux box, they used to be instantaneous on a 60MHZ AIX machine)

Can you please send exact commands which take several seconds to complete?
Full or relevant part of your configuration can help too.

> in fvwm-2.0.45 I had the following:
> 	AddToFunc NextWindow
> 	+ "I" Next [CurrentScreen, CurrentDesk, !Iconic] Focus
> 
> in fvwm 2.0.46 and 2.2.2 I've tried all sorts of tricks, but none appear to
> work.
> 
> 	AddToFunc NextWindow
> 	+ "I" Next (CurrentPage, CurrentDesk, !Iconic) Focus
> 	+ "I" Raise
> 
> Should this example work? Do the "I"'s take place in sequence, ie: first
> find the new
> window, then raise it?

No, "I" is Immediate (unconditional). Conditional commands, like "Next"
are valid to their line only.

> or do I need to do something like this (also doesn't
> work):
> 
> 	AddToFunc NextWindow
> 	+ "I" Next (CurrentPage, CurrentDesk, !Iconic) Focus
> 	+ "I" Next (CurrentPage, CurrentDesk, !Iconic) Raise

This works with pairs of windows, not what you want, I suppose.

> Has anyone else had this problem? I can confirm it on Linux and AIX.

Personally, I don't like raising on focusing, and see no problem here at
all, but if you like, you can set your bindings like this:

DestroyFunc FuncFocusAndRaise
AddToFunc FuncFocusAndRaise
 + I Focus
 + I Raise
#+ I WarpToWindow 7p 7p
Key Tab  A  M    Prev (CurrentDesk, !Iconic) FuncFocusAndRaise
Key Tab  A  MS   Next (CurrentDesk, !Iconic) FuncFocusAndRaise

Does this help?

Regards,
Mikhael.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]