Subject: Bug ?: Title with icon in Menu

From: Olivier Chapuis <[email-masked]>
Date: Thu, 01 Jul 1999 08:41:34 +0200

Configuration Information [Automatically generated, do not change]:
uname output: Linux snoopy.parislyon.fr 2.2.10 #1 mer jun 16 06:29:51 CEST 1999 i586 unknown
Compiler: gcc
Compilation CFLAGS: -g -O2
prefix: /usr/local
sysconfdir: /usr/local/etc
libexecdir: /usr/local/libexec

FVWM Version: 2.3.5 ("lastest" cvs)
FVWM_CONFIGDIR: unset
FVWM_MODULEDIR: unset (bug in fvwmbug it is set: /usr/local/libexec/fvwm/2.3.5)
FVWM_USERHOME: unset

Hello,
If I inserte a mini-icon in a Title of a menu, then if the labels of the
items of the menu is small (relatively to the Title name), the intersection 
of the mini-icon and of the menu title  is non-empty. Ok this is not clear ...
So, try to the folowing menu

AddToMenu test "This is a test for a bug report%mini-modules.xpm%" Title
+ "A%mini-bbal.xpm%" Exec exec xterm
+ "B%mini-bbal.xpm%" Exec exec xterm
+ "C%mini-bbal.xpm%" Exec exec xterm
+ "D%mini-bbal.xpm%" Exec exec xterm

Here is my MenuStyle:
MenuStyle * ItemFormat "%.4s%.1|%.7i%.5l%.5c%.5r%.5i%5.2>%1|" 
MenuStyle * mwm
MenuStyle * Font lucidasans-italic-12
MenuStyle * TitleWarp
MenuStyle * PopupOffset -6 100
MenuStyle * Foreground White, Background grey45
MenuStyle * ActiveFore Black

I have the same problem without the ItemFormat line. I am sorry if
I do not understand something, in particular, why the itemformat does
not apply to the "Title name" ?
A simple fix at a user level is to add a TAB followed by "\ " after
the title (and before the %).

Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Jul 1999 12:08:32 +0200

> of the mini-icon and of the menu title  is non-empty. Ok this is not clear ...

Oops. I forgot to consider this case.
> not apply to the "Title name" ?

There is a special case with title formatting: if there is only *one*
title label (i.e. no tabs), the title is centered. This can't be done
with the ItemFormat. But obviously I forgot to include the mini
icons in the size calculations.

> the title (and before the %).

Yes. If there is a tab in the title it uses the ItemFormat. I was
thinking about a TitleFormat, but that didn't seem incredibly useful
to me.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 3 Jul 1999 16:13:47 +0200

> the title (and before the %).

Fixed. Having a mini icon in the title forces a formatted title.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]