Subject: Fvwm-2.3.5 Xlib: sequence lost

From: "Robert H. Ford II" <[email-masked]>
Date: Thu, 08 Jul 1999 12:50:51 -0500

I have (as suggested by Dominik) upgraded to Fvwm-2.3.5.  Now my xdaliclock will
display, the process is running and the clock does show up now and then for a
second or two but the it disappears again.

While this is all happening my console is rolling in Xlib errors:

Xlib: sequence lost (0x10007 > 0x4cd) in reply type 0x11!
Xlib: sequence lost (0x10007 > 0x53f) in reply type 0x16!
Xlib: sequence lost (0x10007 > 0x5a3) in reply type 0xc!
Xlib: sequence lost (0x10007 > 0x627) in reply type 0xc!
Xlib: sequence lost (0x10007 > 0x985) in reply type 0xc!
Xlib: sequence lost (0x10007 > 0x9f6) in reply type 0x12!
Xlib: sequence lost (0x10007 > 0xa5a) in reply type 0xc!
Xlib: sequence lost (0x10007 > 0xaca) in reply type 0xc!
Xlib: sequence lost (0x10007 > 0xb2d) in reply type 0xc!

So OK I kill xdaliclock and the errors stop, or at least I thought.  Now this
error randomly appears in my console.  It seems to happen if I iconify a window,
switch desktops, blow my nose, etc..., not every time but as I mentioned
randomly.

I can't seem to duplicate this error at will.  Is there some way I can collect
information that would help in debugging this problem.

Thank You
-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Robert H. Ford II" <[email-masked]>
Date: Thu, 08 Jul 1999 13:42:56 -0500

A couple of other things that I have noticed.

I start fvwm2 with -blackout and on a restart the display is not "blacked out". 
Has this been removed.  It is still in the man page.

On a restart all the windows in my current desktop get iconified?  Is this
supposed to happen?

Thank for any insights.

Bob

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 21:45:05 +0200

On Thu, Jul 08, 1999 at 01:42:56PM -0500, Robert H. Ford II wrote:
> Has this been removed.

Not yet, but it's not nedded any longer. If it causes problems now I will
remove it.

> On a restart all the windows in my current desktop get iconified?  Is this

No. Should be fixed in CVS.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 23:53:27 +0200

> switch desktops, blow my nose, etc..., not every time but as I mentioned

According to the X FAQ this error occurs if Xlib functions are
called from an error handler. This is not necessarily fvwm's
fault. Please try to shut down your fvwm modules and application
one by one until the messages finally stop (if you have shut down
everything it must be fvwm itself). What is the guilty application?

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Jul 1999 23:50:01 +0200

> Has this been removed.  It is still in the man page.

Okay, I have removed it completely now. It didn't work
anyway, just used up code.

> On a restart all the windows in my current desktop get iconified?  Is this

If this is not fixed with the next release, please report this again.

Bye

Dominik ^_^

---

From: "Robert H. Ford II" <[email-masked]>
Date: Mon, 12 Jul 1999 12:49:32 -0500

> everything it must be fvwm itself). What is the guilty application?

I updated to fvwm-snap-19990708 and this problem has gone away.

Thank you for the help.