Subject: CVS dane: * NEWS: Describe the default iconbox.

From: CVS <[email-masked]>
Date: Sun, 11 Jul 1999 10:49:31 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	99/07/11 10:49:30

Modified files:
	.              : ChangeLog NEWS 
	docs           : ChangeLog TODO 
	fvwm           : fvwm2.1 icons.c 

Log message:
* NEWS: Describe the default iconbox.

* fvwm/fvwm2.1 (iconbox): Describe the default iconbox.

* fvwm/icons.c: Create a global icon box that covers the screen.
This is used whenever the "style xxx" iconboxes run out of room
or if you never defined an iconbox at all.
This should fix the icons piling up at 0,0 problem.

* TODO (Bugfixes): Remove TODO items: "Allow env var to specify
an additional read directory ($FVWMRCDIR or $FVWMHOME or something
similiar)?"  (Its done.)
"Add better overall icon handling options?"
(I can only guess what it meant, but I think the default box covers it.)
"Support for passwords in FvwmForm"
You can set the fg/bg color on a field by field basis.
"Fix line spacing in FvwmForm for lines that have only text (no buttons)
so that FvwmForm can be used as a "Help" form."
Done.
"Run profiling on FVWM to see if I can speed it up any more"
Its been done.
(We could dispense with the TODO file completely and rely on
Jitterbug instead.)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Jul 1999 20:59:05 +0200

> (We could dispense with the TODO file completely and rely on

Yes! I didn't dare to remove the TODO file yet because there
are *so many* items in there. Perhaps we could make a temporary
directory 'old_todo' in Jitterbug and dump everything in there
for a start

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Jul 1999 23:08:22 +0300 (IDT)

> You can set the fg/bg color on a field by field basis.

AFAIK password field is a text input field, where stars replace a real
text, not invisible text.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 12 Jul 1999 08:27:03 -0400

> text, not invisible text.

I've read somewhere that typing  in a password  field should cause  no
visible affect at all on    the screen.  The reasoning being   echoing
stars would give anyone looking over  your shoulder the length of your
password, making it that much easier to guess.

Still, if anyone really wants stars,  go for it.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]