Subject: GMONE_GetStyle function

From: Dominik Vogt <[email-masked]>
Date: Sun, 4 Jul 1999 16:47:30 +0200

Matthias, I see you have written this function a while ago.
There are several places where it directly writes into
style structures. This is really a *must not*. The only
files where style structures may be accessed are add_window.c
and style.c. The reason is 'information hidig'. If we allow
the knowledge of the internal layout of the styles to creep
from module to module the style code will soon be a mess again
as it was before the GSFR.  Could you please look into that?

BTW, there was a bug in desk number assignment:
desk numbers > -1 have to be increased by one before they are
stored in the style.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 5 Jul 1999 11:35:40 +0200

> style structures. This is really a *must not*. The only

Sorry, but I simply copied that from other places in the same file.

> as it was before the GSFR.  Could you please look into that?

Will take some time, I'm buried in other obligations.

> desk numbers > -1 have to be increased by one before they are

Never heard of that before. 

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jul 1999 12:38:00 +0200

> Never heard of that before. 

I didn't remember that myself until I found it in the code when
debugging that Gnome menu bar bug. Hm, what we need is a clean
interface to the styles. A comment in one of the header files
not to access the structures directly isn't enough. I wonder how
we can prevent bugs like this in the future. You simply can't know
such things without reading the (non existing) documentation.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 7 Jul 1999 10:34:46 -0400

On Mon, Jul 05, 1999 at 12:38:00PM +0200, Dominik Vogt wrote:
> interface to the styles. A comment in one of the header files not
> to access the structures directly isn't enough. I wonder how we can
> prevent bugs like this in the future. You simply can't know such
> things without reading the (non existing) documentation.
>
> Bye
>
> Dominik ^_^
>

The usual practice is to have a 
style.h
styleP.h
where styleP is your pricate header with all your data structures, style.h
contains the appropriate getttersr, setters and testers.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]