Subject: Notification: incoming/416

From: [email-masked]
Date: Fri, 9 Jul 1999 03:31:22 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/416

Message summary for PR#416
	From: [email-masked]
	Subject: Window resize misalignment
	Date: Fri, 9 Jul 1999 03:31:20 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 Jul 1999 19:36:13 +0200

On Fri, Jul 09, 1999 at 03:31:22AM -0500, [email-masked] wrote:
> Some X programs like xterm misalign the window border if dragged to the
> screen border.
> 
> Detailed instructions:
> 1) open xterm
> 2) i.e. drag right window border completely to the right side of the
> screen
> 3) release mouse button
>  -> Result: right window border is off screen some pixels
> 
> This bug does not appear with every X program. xlogo has no problem with
> this.
> 
> fvwm 2.0.42 did not have this bug!

I have noticed that too. The code responsible for that is in
ConstrainSize() in move_resize.c. If the resize operation is
interactive the window size is rounded up to the next multiple
of the resize inc. This is done only with interactive resize.
Does anybody remember why we made it work this way?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 12 Jul 1999 10:53:56 +0100

> Does anybody remember why we made it work this way?

I put this in. It was to enable resizes to start with one keypress. If
you execute a function like

WarpToWindow 100 100
Resize

moving the mouse back towards the middle of the window will shrink the
window.  Before the change you had to move the mouse outside the frame
before moving it in.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Jul 1999 19:05:52 +0200

> window.  Before the change you had to move the mouse outside the frame

Can we do something about it (e.g. round up only in case of a keyboard
event?). A comment in the source code might help too.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 12 Jul 1999 18:20:45 +0100

> event?). A comment in the source code might help too.

I think the best solution is to not resize off the edge of the screen.

Cheers,
Tim.