Subject: Re: BorderWidth and HandleWidth

From: Tim Phipps <[email-masked]>
Date: Fri, 04 Jun 1999 15:45:12 +0100

Brad Giaccio wrote:
> It seems the discrepincy is that HandleWidth 0 used to work and now it
> doesn't NoHandles must be used.  So I guess my real question is why did we switch the behavior?

This is my fault.  What changed is that FvwmIdent does not set itself up
as a transient window. It used to and the default style of
NakedTransient gives a border with no handles.  Now that it isn't a
transient it gets the default of a border with handles.  Your styles for
FvwmIdent end up as

Style FvwmIdent HandleWidth 0, BorderWidth 4

which is why it used to get a 4 pixel border and now it gets 0.

I can't remember why I changed it, I may have just accidentally removed
the line in question. I'll put it back if you like.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 4 Jun 1999 11:08:46 -0400

On Fri, Jun 04, 1999 at 03:45:12PM +0100, Tim Phipps wrote:
> Brad Giaccio wrote:
>
> > It seems the discrepincy is that HandleWidth 0 used to work and now
> > it doesn't NoHandles must be used.  So I guess my real question is
> > why did we switch the behavior?
>
> This is my fault.  What changed is that FvwmIdent does not set
> itself up as a transient window. It used to and the default style of
> transient it gets the default of a border with handles.  Your styles
> for FvwmIdent end up as
>
> I can't remember why I changed it, I may have just accidentally
> removed the line in question. I'll put it back if you like.
>
> Cheers, Tim.

Well I don't really need it put back as long as nothing else breaks, I'll
just have to get used to the new syntax.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]