Subject: CVS domivogt: * Set version number to 2.3.5.

From: CVS <[email-masked]>
Date: Wed, 23 Jun 1999 17:45:22 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/06/23 17:45:21

Modified files:
	.              : ChangeLog configure.in 
	fvwm           : fvwm2.1 module_interface.c move_resize.c 

Log message:
* Set version number to 2.3.5.
* Removed forgotten fprintfs.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 24 Jun 1999 02:07:24 +0200

>         fvwm           : fvwm2.1 module_interface.c move_resize.c

Hello,

I do not think that the changes mad in fvwm2.1 about Stroke are the good
one. At least this does not work on my machine. The following patch give 
some thing that works good one my machine (and I think on the machine 
of Ke Huang). Moreover, I change the examples to more natural examples 
(for me).Of course it is only a humble proposition since I have not take 
any look on the code (I experiment cvs to ...).

Yours, Olivier

Index: fvwm/fvwm2.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/fvwm2.1,v
retrieving revision 1.150
diff -u -b -B -u -r1.150 fvwm2.1
--- fvwm/fvwm2.1        1999/06/24 00:02:09     1.150
+++ fvwm/fvwm2.1        1999/06/24 00:06:27
@@ -2949,19 +2949,24 @@
 Because of the default button menu in fvwm, you may need to
dis-associate
 a mouse button binding before using the stroke
 .EX
-Mouse 0 R N -
+Mouse 3 R A
 .EE

 Also, you can still use Stroke sequence 0 to simulate a click
 .EX
-Stroke 0 2 R A Menu Window-Ops Nop
+Stroke 0 3 R A WindowList
 .EE

-The following example binds the built in window list to pop up when
-mouse drag in 'L' with button 2 pressed donw, no matter where the mouse
-pointer is:
+The following example start xterm when mouse drag in 'I' on the root
+window with button 3 pressed down:
 .EX
-Stroke 1478963 2 A A WindowList
+Stroke 14789  3  R  A  Exec exec xterm
+.EE
+An example for Netscape:
+.EX
+Stroke 7415963    3  R  A  Exec exec netscape
+Stroke 74148963   3  R  A  Exec exec netscape
+Stroke 74158963   3  R  A  Exec exec netscape
+Stroke 7418963    3  R  A  Exec exec netscape
+Stroke 415963     3  R  A  Exec exec netscape
 .EE

 .IP "Style \fIwindowname options\fP"

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Jun 1999 04:24:14 +0200

> +Mouse 3 R A

If that doesn't work there must be some binding in your config file
already. Masking that binding with an empty one is not the way to go.
I don't understand why this is an issue anyway. If you have a binding
that interferes with a previous binding, the newer one overrides the
older. Why is this different with strokes?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 27 Jun 1999 09:50:36 +0200

> already. Masking that binding with an empty one is not the way to go.

Hello,
Mouse 0 R N - gives me the bultin menu even if there is no other 
mouse binding in my config file.
 
> older. Why is this different with strokes?

The man page instructions for Stroke still do not work on my machine
(but it works find with Mouse * R A and ... Stroke * * R A ...)

Yours, Olivier