Subject: Re: 2.3.3: Transparency for Eterm broken

From: Tim Phipps <[email-masked]>
Date: Tue, 08 Jun 1999 16:41:18 +0100

Amir Chossrow Akhavan wrote:
> 
> Hi!
> 
> (CVS snapshot June 4 & June 5):
> The transparency for Eterminals as provided by
> 
> # Esetroot background_image.gif
> # Eterm --trans
> 
> seems to be broken.
> 
Well, it works for me (CVS on June 8th). At least the part that fvwm
plays in this works.  Esetroot seems to have problems if run more than
once and Eterm is broken by design 8-).

What do you think is broken?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 8 Jun 1999 23:37:08 +0300 (IDT)

> What do you think is broken?

I can confirm this. The transparency is really broken (seems like Eterm 
gets wrong window coordinates on move from fvwm).

And without a transparency the background image of Eterm does not appear
until the first window move.

Regards,
Mikhael.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 09 Jun 1999 10:12:05 +0100

> gets wrong window coordinates on move from fvwm).
Hmmm, I can see a pronlem but only with large background images, a small
tile works fine but with a large picture Eterm gets the wrong origins
for the main window and the scrollbars. As soon as you move it though it
fixes itself.  Maybe we're missing sending a synthetic window configure
event on map since the window won't map where it positioned itself but
somewhere else. It gets the size it wants so I guess the server does not
send a message when fvwm reparents it to another place. Maybe it was
just luck that the small tile repeat just matched the offset

> until the first window move.
This sounds like an Eterm bug, it feels like a buggy app: when it first
appears there is no menu bar but when I move it the menubar appears;
Esetroot only works once, I had to remove the ESETROOT_PMAP_ID &
_XROOTPMAP_ID properties from the root to get it to run again.

CHeers,
Tim.

---

From: Lee Willis <[email-masked]>
Date: 10 Jun 1999 12:50:22 +0100

> _XROOTPMAP_ID properties from the root to get it to run again.

Just as an aside it works fine under 2.0.46 :)
Eterm  -- version 0.8.8 --

Lee.
-- 
I was doing object-oriented assembly at 1 year old ...  
For some reason my mom insists on calling it "Playing with blocks"
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]