Subject: more menu enhancements

From: Dominik Vogt <[email-masked]>
Date: Sat, 5 Jun 1999 17:03:00 +0200

I have done more work on the menu code

 - fixed lots of bugs
 - %[ and %] in ItemFormat string have been replaced ba %|
 - menus 'bounce' off the screen border, i.e. if one menu
   is put left of its parent because it was too close to
   the border, all of its children will go left too.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 5 Jun 1999 23:05:35 +0200

>    the border, all of its children will go left too.

Oh, and in case anybody notices it: I've replaced that
ugly menu cursor with a north-west arrow (the same one as
over window titles).

Bye

Dominik ^_^

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 6 Jun 1999 01:55:06 +0200

> X-Authentication-Warning: DarkSun.nodomain: avatar set sender to [email-masked] using -f
> Date: Sat, 5 Jun 1999 23:05:35 +0200
> From: Dominik Vogt <[email-masked]>
> Mail-Followup-To: [email-masked]
> Content-Type: text/plain; charset=us-ascii
> Sender: [email-masked]
> Precedence: list
> X-Majordomo: 1.94.jlt7
> 

Not that I have any strong feelings about this, but why
change a default that can be changed anyway (using CursorStyle)?
-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 6 Jun 1999 15:14:51 +0300 (IDT)

> change a default that can be changed anyway (using CursorStyle)?

The default must be nice if you want to attract new users.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 Jun 1999 17:36:33 +0200

> change a default that can be changed anyway (using CursorStyle)?

Because it looks terrible, obscures the text and the average user
does not know how to change it.

Bye

Dominik ^_^