Subject: sticky windows lost off desktop upon restart

From: Dominik Vogt <[email-masked]>
Date: Sat, 5 Jun 1999 17:15:40 +0200

I can confirm a previous report of windows being lost during
a restart:

  1) I use a sticky FvwmButtons
  2) GotoPage 1 0
  3) Restart

==> FvwmButtons is never seen again. Unfortunately this is not
    enought to reproduce the problem in 100% of the cases.

(I start FvwmButtons from InitFunc/RestartFunc).

Another problem:

  Restarts with an open FvwmIdent window are slower. There is a
  noticable delay before the decorations are drawn. May be a
  FvwmIdent problem.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Albrecht Kadlec <[email-masked]>
Date: 08 Jun 1999 18:25:21 +0200

> (I start FvwmButtons from InitFunc/RestartFunc).

don't know if it's related / already fixed:

1) back in 2.0.47 there was the need to wait a little bit during restart.
   Especially on slow machines (had a sparc ipc then), there was the need
   for hidden (or swallowed) windows to be remapped, so that the new
   windowmanager recognized them and added them to the stacking order &
   other structures. 

   The wait was usually one or two banner calls in RestartFunction.
   (Depending how slow your machine was. Could be that it dosn't occur
   often on todays machines.)
   If anybody cared to fix it, it never got incorporated (up to 2.0.47d) 

2) it's possible to have a window moved completely off page.
   If you (like me) have an 4x2 desktop, there are sometimes windows, which
   are on page 0 -1 (!)

3) another artefact is a sticky window on the _next_ page.
   if you move to the next page, it moves, _too_, since it's sticky.
   so you can never catch it, as it's always on the _next_ page.
   You can see it in the pager, but you can never reach it by switching to
   that page.
   You can move it in the pager via the middle mouse button, though.

   I don't know how I produced that. (you might experiment with style
   sticky and big placement values to see the effect, though that wasn't
   the case for my observations.
	e.g: xclock -geometry +1200+1200
   produced that effect - xclocks are sticky for me)

   It's happened several times over the years after restarts.

CC' me on replies, if you need prompt answers. (mailfilter in use)
-- 
Albrecht Kadlec
Vienna University of Technology / Department of Automation
----------------------------------------------------------
There must be some mistake,
I never meant to let them take,
Away my soul.	  	-- Pink Floyd
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]