Subject: Something bad happened to menus

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jun 1999 11:15:04 +0100

With todays CVS (28th June) the height of menu items is wrong. Items
with no mini-icon only get about 2 pixels and the text is drawn too far
down.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jun 1999 13:41:13 +0200

> with no mini-icon only get about 2 pixels and the text is drawn too far

Tim, I don't get this on my machines. Could you recomplie everything
and try again? What configure options do you use? If the problem persists,
please prepare a minimal comfig file and mail it to me.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jun 1999 14:41:03 +0100

> please prepare a minimal comfig file and mail it to me.

my configure line is:
./configure  --prefix=/home/tim --with-readline-library=/home/tim/lib
--with-readline-includes=/home/tim/include --without-cxx --enable-gnome

I think it's something to do with the I18N patch. I just noticed that
the feedback window is the wrong size.  Line 1473 of builtins.c has the
setting of Scr.StdFont.height commented out which probably explains why
the window ends up very short.

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 28 Jun 1999 09:45:38 -0400

> the window ends up very short.

I can confirm the feedback window being to short, by menus seem to be fine.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jun 1999 16:05:41 +0200

> the window ends up very short.

Yup, I've seen that too. The fix is already in CVS.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jun 1999 15:07:37 +0100

> Yup, I've seen that too. The fix is already in CVS.

The fix to the feedback window has also fixed my menu problems.
Thanks,
Tim.