Subject: CVS chrisr: Modified FvwmTaskBar:

From: CVS <[email-masked]>
Date: Fri, 25 Jun 1999 08:02:07 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	chrisr	99/06/25 08:02:07

Modified files:
	modules/FvwmTaskBar: ButtonArray.c FvwmTaskBar.c FvwmTaskBar.h 
	                     List.c Mallocs.c Mallocs.h 

Log message:
Modified FvwmTaskBar:
* Added new signal handling to FvwmTaskBar.
* Fixed a linked-list problem that crashed the Bar whenever the first
button in the list was removed.
* Fixed implementation of saferealloc()
* Turned ShutMeDown() into an exit-procedure (installed via atexit).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jun 1999 15:25:47 +0200

> button in the list was removed.

Bless you, Chris. I was trying to fix RemoveButton for weeks now.
FvwmWinList has the same problem (I copied the code there). Would
you fix that too?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]