Subject: A Man Page Patch

From: Olivier Chapuis <[email-masked]>
Date: Sun, 27 Jun 1999 10:16:02 +0200

Hello,
Attached to this message a patch for the man pages.
This patch corrects misprints of "formatting" nature
(see below for details). One thing I have do is to add some 
"example" environment (.EX/.EE or .nf .sp/.sp .fi)
where their miss (this is mostly non visible, however, rman, 
a popular man2everything under linux, work better with this).
This patch is against the cvs-tree (cvs update, cvs diff > ManPatch,
juste before sending this message). 

Yours, Olivier.

Files that the patch will modifies if applied (with comments):

ChangeLog (fvwm2.1: corrected misprints)

fvwm:

fvwm2.1 :  Correct .fvwm2rc and .Xdefaults "bugs". Add an EX/EE environment
arround the Stroke grid. Correct two other misprints of troff nature.

modules:

ChangeLog (corrected some misprints in FvwmAnimate.1, FvwmButton.1,
FvwmCommand.1, FvwmConsoleC.pl.1, FvwmEvent.1, FvwmForm.1, FvwmPager.1,  FvwmWarf.1, FvwmSaveDesk.1) 

FvwmAnimate.1 : one misprint

FvwmButton.1: misprints and .nf .sp/.sp .fi environments.

FvwmCommand.1: misprints in a sed command.
 
FvwmConsoleC.pl.1: a \c --> \\c

FvwmEvent.1: 
- Modification of some formatting (may be you do not like it, but I think
it is ok and you probably see nothing).
- Correction of the second http address for rplay (I do not find rplay
at the first one).

FvwmForm.1: some \" need to be \\" in an example (a cut-and-past
from a .fvwm2rc file).

FvwmPager.1: a fo need to be a to

FvwmWarf.1: replace some .nf/.fi environments by .nf .sp/.sp .fi
environements.

FvwmSaveDesk.1: add .nf .sp/.sp .fi environements. A "," problem.
add a S at the end of COPYRIGHT

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 28 Jun 1999 09:48:50 +0200

Dominik Vogt wrote:
>
> A few days ago you sent a patch for the strokes part of the
> manpage. I must have deleted it by accident. I can't find it
> in my mail box and the mail archive on the fvwm web page seems
> to delete attachments. Could you please give me that patch again?
> 

Hello Dominik and Ke
I have attached that patch to this message. In fact I do a little more:

Modified files:
                : ChangeLog
                : INSTALL.fvwm
    fvwm2       : fvwm2.1

Log message:
  * INSTALL.fvwm2: Added LibStroke in the optional libraries section.
  * fvwm2.1: Corrected Stroke entries.

Ke, It is perhaps good that you look at that patch since you know a lot
more about stroke than me (I am just a tester and since stroke is not 
a module it is difficult to read the code). Note that I have add the 
following: "At the present time it is preferable to use R as context 
and A as modifier." However, I think that this patch is good and I hope
that it will save time for you.

Yours Sincerely, Olivier

Index: ChangeLog
===================================================================
RCS file: /home/cvs/fvwm/fvwm/ChangeLog,v
retrieving revision 1.513
diff -u -b -B -r1.513 ChangeLog
--- ChangeLog	1999/06/27 23:05:46	1.513
+++ ChangeLog	1999/06/28 07:46:00
@@ -1,3 +1,8 @@
+1999-06-28 Olvier Chapuis <[email-masked]>
+
+	* INSTALL.fvwm2: Added LibStroke in the optional libraries section.
+	* fvwm/fvwm2.1: Corrected Stroke entries.
+
 1999-06-28  Mikhael Goikhman  <[email-masked]>
 
 	* fvwm/session.c (my_module): fixed
Index: INSTALL.fvwm
===================================================================
RCS file: /home/cvs/fvwm/fvwm/INSTALL.fvwm,v
retrieving revision 1.17
diff -u -b -B -r1.17 INSTALL.fvwm
--- INSTALL.fvwm	1999/06/17 16:17:13	1.17
+++ INSTALL.fvwm	1999/06/28 07:46:01
@@ -113,9 +113,9 @@
 ===============================
 
 FVWM can optionally be compiled to use the following libraries: Xpm,
-rplay, and readline.  By default, these are probed for, and used if
-found.  If you want to use any of them, install the library before
-configuring FVWM.
+rplay, readline and LibStroke.  By default, these are probed for, 
+and used if found.  If you want to use any of them, install the library 
+before configuring FVWM.
 
 Xpm allows the use of coloured icons.  See the Xpm web page at
 http://www.inria.fr/koala/lehors/xpm.html for all the latest info and
@@ -132,6 +132,10 @@
 command-line editing, a history buffer, etc.  It is GNU software, and
 should be found on any GNU site, such as ftp://ftp.gnu.org/gnu/readline/.
 
+LibStroke allows interpretation by fvwm2 of mouse strokes (i.e., motions
+of the mouse). For more informations see the  LibStroke web page at   
+http://www.etla.net/~willey/projects/libstroke/ and the fvwm2 man page.
+
 If configure doesn't do the right thing, try one or more of the
 following flags (examples assume library is named "foo"):
 
@@ -147,6 +151,7 @@
     xpm		X11/xpm.h
     readline	readline/readline.h
     rplay	rplay.h
+    libstroke   stroke.h
 
 Only one version of the --with-foo-library flag may be specified.
 
Index: fvwm/fvwm2.1
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/fvwm2.1,v
retrieving revision 1.154
diff -u -b -B -r1.154 fvwm2.1
--- fvwm/fvwm2.1	1999/06/27 17:58:12	1.154
+++ fvwm/fvwm2.1	1999/06/28 07:46:24
@@ -2972,9 +2972,10 @@
 or removes the binding if \fIFunction\fP is '-'.  Definition is the same
 as for a mouse binding except that \fIsequence\fP is inserted in front of
 the button number. The \fIContext\fP and \fIModifiers\fP fields are defined
-as in the mouse binding.
+as in the mouse binding. At the present time it is preferable to use
+R as context and A as modifier.
 
-strokes are defined in a grid like this:
+Strokes are defined in a grid like this:
 .EX
  1  2  3
 
@@ -2985,19 +2986,29 @@
 Because of the default button menu in fvwm, you may need to dis-associate
 a mouse button binding before using the stroke
 .EX
-Mouse 0 R N -
+Mouse 3 R A
 .EE
-
 Also, you can still use Stroke sequence 0 to simulate a click
 .EX
-Stroke 0 2 R A Menu Window-Ops Nop
+Stroke 0 3 R A Menu WindowList Nop
 .EE
-
-The following example binds the built in window list to pop up when
-mouse drag in 'L' with button 2 pressed donw, no matter where the mouse
-pointer is:
+The following example start xterm when mouse drag in 'I' on the root
+window with button 3 pressed down:
+.EX
+Stroke 258  3  R  A  Exec exec xterm
+.EE
+An example for Netscape:
+.EX
+Stroke 7415963    3  R  A  Exec exec netscape
+Stroke 74148963   3  R  A  Exec exec netscape
+Stroke 74158963   3  R  A  Exec exec netscape
+Stroke 7418963    3  R  A  Exec exec netscape
+Stroke 415963     3  R  A  Exec exec netscape
+.EE
+Note: You need LibStroke installed and fvwm2 compiled with stroke
+support. LibStroke can be obtained via anonymous ftp at
 .EX
-Stroke 1478963 2 A A WindowList
+http://www.etla.net/~willey/projects/libstroke/
 .EE
 
 .IP "Style \fIwindowname options\fP"

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 28 Jun 1999 11:43:31 +0200

Dominik Vogt wrote: (from a private message)
> 
> Thanks! I have applied it immediately. You mentioned a perl script
> to make a book from the man page in a previous mail. Would you
> contribute it to the distribution?

Hello again,
Ok, but I need some time for cleaning the code (I learned perl during
writing this script).
I take the occasion for some questions on the docs directory.
Why the docs directory is not installed (says in prefix/doc/fvwm) 
by make install ? Ok, for example, the rpm package do this, but ...
I have look at run_man2html.sh and it seems that we need to run it
in the source tree (run_man2html.sh prefix/man/man1 somewhere,
will format all the man page of prefix/man/man1).  It seems that 
there are also some shell compatibility problems :o)
Do you want I work on this ? In fact my idea is to provide
a perl script that do all the html job. There is a number of good man2html
(as rman -f HTML ...), however, I can use "my" fvwman2book.pl to
do something pretty. 

Yours, Olivier
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ke Huang <[email-masked]>
Date: Mon, 28 Jun 1999 08:02:58 -0500 (CDT)

>that it will save time for you.

The documentation looks good. The examples should work with stroke as it is.
Thanks for catching the INSTALL.fvwm file fix. This must be the first time in a
long time that I looked at it. :)

-- Ke Huang
------------------------------------------
e-mail:  [email-masked]  (preferred)
         [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 29 Jun 1999 13:56:55 -0400

> (as rman -f HTML ...), however, I can use "my" fvwman2book.pl to

The pages aren't installed automatically since you would normally go
to fvwm.org to read them.  If you don't normally have internet access,
you might find it useful to install them locally.

You don't say which release you are looking at, but the requirement to
put   the man pages  in a  "prefix/man/man1" environment, was recently
removed.

As always, if you want to try your hand at making improvements, make
sure you are working from the current CVS, and are subscribed to the
fvwm-workers list.  Also, be sure to read the "docs/DEVELOPERS" file.

We are always interested in improvements.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]