Subject: maximize toggle

From: TG <[email-masked]>
Date: Mon, 28 Jun 1999 17:27:52 +0200

When maximize my window horizantally, I can't immediately maximize it
vertically. I need to resize it manually first.

Are there any plans to change this to a more consistent behaviour?

Mouse 2 	2       N       Maximize true 0 grow
Mouse 3 	2       N       Maximize true grow 0

Greetings,

Tung

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jun 1999 21:03:34 +0200

> Are there any plans to change this to a more consistent behaviour?

It is absolutely consistent if you understand that a maximized window
is not simply bigger than usual but that it is in a different state.
Using 'Maximize' on a maximized window unmaximizes it, regardless
of the arguments. I agree that this is a bit unintuitive, but I don't
really know what we could do about it without redesigning maximizing
completely.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 29 Jun 1999 11:59:51 +0200

> is not simply bigger than usual but that it is in a different state.

Well, *absolutely* is perhaps a bit strong here... With the many
possibilities for influencing the size to which the window is maximized,
a simple state switch with just one saved geometry is not optimal.

> really know what we could do about it without redesigning maximizing

One could think about a stack of saved geometries...

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]