Subject: restart drops command line arguments

From: Peter Daum <[email-masked]>
Date: Thu, 17 Jun 1999 00:00:45 +0200 (MEST)

Hi,

I just tried the latest CVS version and notized that at least in
my setup (fvwm started with "-cmd FvwmM4"), fvwm drops all
command line arguments on restarts. (In fvwm 2.3.3, this was
still working)

regards,
               Peter
-- 
                                             __o  
     Peter Daum <gator at cs.tu-berlin.de> _'\<_ 
       - pgp messages welcome -       ____(_)/(_)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Jun 1999 00:29:59 +0200

> command line arguments on restarts. (In fvwm 2.3.3, this was

I've just checked in a patch (for something else). Can you check again?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Jun 1999 01:50:10 +0300 (IDT)

> command line arguments on restarts. (In fvwm 2.3.3, this was

What is your:
  * fvwm executable name,
  * Restart command,
  * ChangeLog time?

For now, "Restart fvwm2" is not a special case and does not add arguments.
It will be, probably, changed to be more like in the previous versions,
but personaly I don't think it is good to have special cases in Restart
command.

As a general solution, Restart without arguments must do what you want.

Regards,
Mikhael.

---

From: Peter Daum <[email-masked]>
Date: Thu, 17 Jun 1999 10:39:09 +0200 (MEST)

qHi,

> but personaly I don't think it is good to have special cases in Restart

I guess, I should have been more specific - sorry.
After looking more closely at the sources, I guess, the "bug"
that I reported probably is a feature :-)

I have several different versions of fvwm2 floating around (I
don't think this is too abnormal: one stable version to do real
work, other versions for testing & experimenting). They have
names like "fvwm2.3.4". 

So far, it was enough that the name of the executable contained
"fvwm2" as a substring for the Restart command to assume a
"native" restart. Now it seems to be intended to only do a "native"
restart, if there is no argument at all or the argument matches
the name of the currently running executable - which makes it at
least pretty difficult to alternatively use different versions.

Furthermore, if "Restart" has no arguments at all, it is always
assumed that the name of the executable is "fvwm2" (IMHO, it
would be more logical, to use the path of the currently running
executable instead; so far I got around this by constructing the
full path of the current version with an M4 macro, but this will
drop all command line arguments now - fatal if you rely on
preprocessing).

Regards,
            Peter

(P.S.: I am referring to the CVS version from Jun 17 7:30 GMT)

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Jun 1999 12:42:57 +0300 (IDT)

> work, other versions for testing & experimenting). They have

No, it is not too abnormal, instead, it is normal for a developer.

> least pretty difficult to alternatively use different versions.

No, it is not difficult. Restart them using the command:
  Restart fvwm2.3.4 -cmd FvwmM4

I don't think that guessing anything about the program from its name is
correct. I know at least one developer having names fvwm-2.3.4. Is this
fvwm1, fvwm2, other window manager? There is no way to know from the name.

> assumed that the name of the executable is "fvwm2" (IMHO, it

There is no hardcoded "fvwm2" anywhere IIRC. It just uses your original
command arguments (fvwm2 -cmd FvwmM4) with no changes at all.

Regards,
Mikhael.

---

From: Peter Daum <[email-masked]>
Date: Fri, 18 Jun 1999 00:41:20 +0200 (MEST)

Hi,

[about restarting different versions of fvwm]
> fvwm1, fvwm2, other window manager? There is no way to know from the name.

I agree, that it is questionable to deduce the window manager
type from its name. Having to duplicate the command line
arguments in the configuration file, however, is even worse,
because it lies in the nature of command line args, that they are
not constant. You would have to remember changing the
configuration file, too, whenever you want to user different
arguments.

IMHO, it would be better if the restart command had an optional
argument for telling it the type of wm (actually, I guess, all it
really needs to know is whether to propagate the original command
line)

Regards,
            Peter

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 18 Jun 1999 08:31:21 -0400

> really needs to know is whether to propagate the original command

I second that idea. something like 
Restart wm propogate

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 18 Jun 1999 15:37:00 +0300 (IDT)

> really needs to know is whether to propagate the original command

Does addining the switch "--original-arguments" or similar solve
your problem? If so, I will add it, so you can write:
  Restart --original-arguments fvwm2.3.3

You can suggest a shorter name for the switch.

Regards,
Mikhael.

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 18 Jun 1999 08:41:59 -0400

> You can suggest a shorter name for the switch.
How about 
   Restart --pass-args fvwm2.3.3

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 18 Jun 1999 15:52:58 +0300 (IDT)

>  Restart --pass-args fvwm2.3.3

Ok, if everyone happy with this name.
And sorry, Brad, if I said something bad previously.

Regards,
Mikhael.