Subject: to do for 2.4 (update 6)

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jun 1999 03:36:02 +0200

In progress:

 1) Document the GNOME stuff (man page still missing).
    [in progress]
 2) Add screen shots to web page.
    [in progress; Dan]
 9) Set up RPM packages.
    [in progress; Jason]
 15) Get restart straight (sometimes an application vanishes over restarts)
     [in progress; Mikhael, Matthias]

To do (must):

 7) Create an I18N fvwm package (from 2.2 or so).

To do (optional)

 6) Remove several configure options.
 10) Remove 'PopupAsRootMenu' menu style (?).
     [comments wanted]
 11) Add FvwmKb module?
     [comments wanted]
 12) Set up bzip2 tarballs.

Fixes (high priority):

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
 19) Try to reproduce that KFM windows stay on top of normal fvwm windows.
     [reported by Andrew Morton <[email-masked]> on 16-May-1999]
     [may be the same as 22/bug #290]
 22) Investigate bug #290. (windows cannot be raised over others sometimes).
     [mail thread from April; confirmed by me (Dominik)]
 26) Investigate bug #315. (Recapture doesn't work perfectly for changing the
     default decor).
 41) Fix hanging fvwm when moving GNOME menu bars (bug #395).
     [confirmed by me (Dominik)]
 42) Get bitmap icons working again.
 44) Fix TaskBar crash caused by latest patch in RemoveButton().
     [Dominik]

Fixes (optional):

 31) 'Maximize grow grow' works only on the current page.
     [reported by me (Dominik)]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).

Testing:

 33) Test the GNOME patches.
 34) Run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 
=====

Done:

 3) Add link to fvwm cats page to web page.
 4) Add link to Mikhael' wm-icons page.
 5) Update the links on our home page.
 8) Add an explanation about the various packages and where to
    discuss them to the web page.
    (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 13) Use a 'busy' pointer during startup.
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no bug; doesn't happen for 2.2 and up]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
     [no fix? or should we rather break 'xterm +ai'?]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
     [Eterm bug fixed, rxvt doesn't work very well with transparent
     background. I've reported to the rxvt mailing list]
 23) Check if bug #312 is still there.
     [fixed]
 24) Investigate bug #314.
     [fixed]
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [fixed; only in 2.2.2, caused by missing X error handler]
 27) Check if bug #334 is still a problem.
     [fixed]
 28) Investigate FvemEvent core dumps.
     [fixed in 2.2.3, no bug in 2.3.4]
 29) Fix the pager bugs I reported recently.
 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
 37) Fix interaction of moving with autoraising icon titles.
     [fixed]
 38) Investigate bug #389. (StartsOnDesk does not work)
     [configuration problem, added a warning to the code]
 39) Investigate bug #390
     [fixed]
 40) Investigate bug #394. (Overlapping pages)
     [no bug; doesn't happen after a recompile]
 43) Several pager bugs (bug #379).
     [fixed]

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

----- End forwarded message -----

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

----- End forwarded message -----

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

----- End forwarded message -----

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

----- End forwarded message -----

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 25 Jun 1999 12:01:54 +0200

>      [mail thread from April; confirmed by me (Dominik)]

Does this only happen with RaiseLower or also with Raise ? It may be
related to a change in RaiseLower which I did sometime back. I'll
investigate, although it is a bit hard without a safe way to reproduce
the problem. 

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jun 1999 13:14:13 +0200

On Fri, Jun 25, 1999 at 12:01:54PM +0200, Matthias Claasen wrote:
> related to a change in RaiseLower which I did sometime back.
> I'll investigate, although it is a bit hard without a safe way to reproduce
> the problem. 

I don't know yet. I saw it twice yesterday. Both times I tried to debug
it from a second X server, but both times accidentally killed the
offending window. Debugging a running fvwm from a second X server is
really helpful sometimes:

  exec xinit /bin/sleep 100000 -- :1

To start the second server.

  fvwm2 -d :1

To start the second fvwm. Then switch to display :1 and attach gdb
to the running fvwm (or module). This way you can set breakpoints
without halting the debugger too.

Bye

Dominik ^_^

-

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 25 Jun 1999 21:02:06 +0200

> really helpful sometimes:

I usually do it from a different virtual console (under Linux). I also
had some fun attaching a debugger to fvwm from an xterm being managed
by fvwm. You just have to be very careful about not loosing keyboard
focus when a breakpoint comes around :-)

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Jun 1999 15:59:08 +0200

> investigate, although it is a bit hard without a safe way to reproduce

I scanned through my mailbox and saw that bug #290 seems to be different
from what I have been experiencing with XEmacs/Rxvt. I can make strange
things happen with ddd (a GPLed frontend to gdb et al.):

 1) Fire up ddd.
 2) Open a backtrace window from the status menu. The new window is above
    the main ddd window.
 3) "Lower" the ddd window: main window lowers behind all others.
 4) "Raise" the ddd window: it raises above all but the backtrace window.
 5) "RaiseLower" the ddd window: nothing happens. Fvwm thinks the window
    is not on to and tries to raise it, but doesn't raise above the
    backtrace window.
 6) "Lower" the backtrace window: ok.
 7) "Raise" the ddd window: the backtrace window pops back to the top.

Steps 4, 5 and 7 don't do what I would expect. Looking at the
RaiseWindow() function in stack.c I would bet it has something
to do with the code in '#ifndef DONT_RAISE_TRANSIENTS' :-)
Hm, how would this work:

 case 1 (main window on top of the stack and above the transient):

   "Raise" raises the transient to the top
   "RaiseLower" lowers the main window

 case 2 (main window on top of the stack but below the transient):

   "Raise" raises the main window above the transient
   "RaiseLower" does the same

 case 3 (main window not on top of the stack and above the transient):

   "Raise" raises the main window to the top and the transient above it
   "RaiseLower" does the same
   
 case 4 (main window not on top of the stack and below the transient):

   "Raise" raises the main window to the top (over the transient)
   "RaiseLower" does the same

 case 5 (main window above transient 1 and below transient 2):

   "Raise" raises the main window to the top and transient 2 above it
   "RaiseLower" does the same.

Additionally I'd prefer to have this DONT_RAISE_TRANSIENTS stuff
as a style option.

Bye

Dominik ^_^

P.S.: That does *not* solve the other problem I am experiencing.

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 27 Jun 1999 22:50:10 +0200

> to do with the code in '#ifndef DONT_RAISE_TRANSIENTS' :-)

Yes, but this is old behaviour. The same should happen with 2.0.
When I reworked the stack manipulation functions to work with
layers, I left that part untouched.