Subject: FvwmGtk doesn't compile...

From: [email-masked] (Paul D. Smith)
Date: 25 Jun 1999 10:22:01 -0400

Compiling the latest CVS as of a few minutes ago, I get:

  gcc -DHAVE_CONFIG_H -I. -I../../../fvwm/modules/FvwmGtk -I../.. -I../../../fvwm  -I/usr/X11R6.3/include     -I/usr/global/lib/glib/include -I/usr/global/include -I/usr/X11R6.3/include     -g -O2 -c ../../../fvwm/modules/FvwmGtk/FvwmGtk.c
  ../../../fvwm/modules/FvwmGtk/FvwmGtk.c: In function `main':
  ../../../fvwm/modules/FvwmGtk/FvwmGtk.c:486: `g_int_hash' undeclared (first use in this function)
  ../../../fvwm/modules/FvwmGtk/FvwmGtk.c:486: (Each undeclared identifier is reported only once
  ../../../fvwm/modules/FvwmGtk/FvwmGtk.c:486: for each function it appears in.)
  ../../../fvwm/modules/FvwmGtk/FvwmGtk.c:486: `g_int_equal' undeclared (first use in this function)

Can't find any reference to g_int_hash or g_int_equal; are those
supposed to be provided in the GTK includes?  Maybe I need a newer
version (mine is pretty old)?

In that case, what's the minimum version needed?  We should add
something to configure to test for it.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 25 Jun 1999 21:18:56 +0200

> version (mine is pretty old)?

They're supposed to be in glib.h

> something to configure to test for it.

configure currently checks for >=1.1.0, but I'm not sure about
the oldest version I have tested it with. 

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]