Subject: to do for 2.4 (update 1)

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jun 1999 17:56:49 +0200

Hm, my first message seemd to have gone to /dev/null, so here it is again.

----- Forwarded message from Dominik Vogt <[email-masked]> -----

To do (must):

 1) Document the GNOME stuff (man page still missing).
 2) Add screen shots to web page.
    [in progress]
 7) Create an I18N fvwm package (from 2.2 or so).
 8) Add an explanation about the various packages and where to
    discuss them to the web page.
    (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 9) Set up RPM packages.
    [in progress]

To do (optional)

 6) Remove several configure options.
 10) Remove 'PopupAsRootMenu' menu style (?).
     [comments wanted]
 11) Add FvwmKb module?
     [comments wanted]
 12) Set up bzip2 tarballs.
 13) Use a 'busy' pointer during startup.
     [in progress]

Fixes (high priority):

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 15) Get restart straight (sometimes an application vanishes over restarts)
     [in progress]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
 19) Try to reproduce that KFM windows stay on top of normal fvwm windows.
     [reported by Andrew Morton <[email-masked]> on 16-May-1999]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
 22) Investigate bug #290.
     [mail thread from April]
 23) Check if bug #312 is still there.
 24) Investigate bug #314.
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [in progress]
 26) Investigate bug #315.
 27) Check if bug #334 is still a problem.
 28) Investigate FvemEvent core dumps.
     [in progress]
 37) Fix interaction of moving with autoraising icon titles.
     [in progress]
 38) Investigate bug #389
 39) Investigate bug #390
 40) Investigate bug #394

Fixes (optional):

 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
     [reported by Dan, verified by me (Dominik)]
 31) 'Maximize grow grow' works only on the current page.
     [reported by me (Dominik)]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).

Testing:

 33) Test the GNOME patches.
 34) Run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 
=====

Done:

 3) Add link to fvwm cats page to web page.
 4) Add link to Mikhael' wm-icons page.
 5) Update the links on our home page.
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no, doesn't happen for 2.2 and up]
 29) Fix the pager bugs I reported recently.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jun 1999 21:51:47 +0200

>      [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]

Eterm sets the icon window hint instead of the icon pixmap hint as would
be correct. I have reported this to E.

>      the same problem).

The Eterm bug seems to be fixed already. I tries transparent rxvts with
afterstep and icewm. with icewm they don't work well either (the border is
transparent too), with afterstep it works, but the background does not move
while the window is moved.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jun 1999 00:37:35 +0200

> be correct. I have reported this to E.

No, after looking at the ICCCM again I see that this is okay. But then
there's no way to make Eterm users and xterm users happy at the same
time.

Bye

Dominik ^_^