Subject: InteractiveMove fix in 2.2.2 makes move act strangely

From: [email-masked]
Date: Wed, 9 Jun 1999 11:59:53 -0500 (CDT)

Full_Name: Joe Ramey
Version: 2.2.2
CVS_Date: 
OS: Solaris 2.5.1
X_Server: Sun X server
Submission from: (NULL) (192.94.94.1)

When I changed from 2.2 to 2.2.2, moving windows started acting strangely.
What I mean is this: when I click on the edge of a window to move it,
then begin moving it very soon after I click, the mouse pointer somehow
gets ahead of the window.  Normally (including with 2.2) when I click
on the edge of a window and then quickly move the mouse, the mouse pointer
remains firmly attached to the edge of the window.  With 2.2.2 though
there
seems to be some kind of delay between the mouse movement and the initial
window movement.  I can easily reproduce the problem just by clicking the
edge
of a window to move it and then move the mouse very quickly.

I found that if I removed the change to fvwm/move.c that was made between
2.2 and 2.2.2, the problem goes away.  The change between these versions
was very simple:
*** move.c-2.2  Tue Jun  8 17:14:33 1999
--- move.c-2.2.2        Tue Jun  8 17:14:17 1999
***************
*** 788,794 ****
        XFlush(dpy);
      }
  
!   if (eventp->type != KeyPress)
      {
        DragX = eventp->xbutton.x_root;
        DragY = eventp->xbutton.y_root;
--- 788,794 ----
        XFlush(dpy);
      }
  
!   if (eventp->type == ButtonPress)
      {
        DragX = eventp->xbutton.x_root;
        DragY = eventp->xbutton.y_root;

I added some debug code to print out the value of eventp->type when
InteractiveMove is called.  I don't understand this, but the value
printed was 5: according to my X.h file, 5 is ButtonRelease.  I would
think that ButtonPress would be the event here, but I'm not much of
an X programmer.  Maybe I'm missing something.

Anyway I made the following change which fixes the problem for me and
retains the sense of the change that was made from 2.2 to 2.2.2:

*** move.c-2.2.2        Tue Jun  8 17:14:17 1999
--- move.c      Wed Jun  9 11:40:06 1999
***************
*** 788,794 ****
        XFlush(dpy);
      }
  
!   if (eventp->type == ButtonPress)
      {
        DragX = eventp->xbutton.x_root;
        DragY = eventp->xbutton.y_root;
--- 788,794 ----
        XFlush(dpy);
      }
  
!   if (eventp->type == ButtonPress || eventp->type == ButtonRelease)
      {
        DragX = eventp->xbutton.x_root;
        DragY = eventp->xbutton.y_root;

Again, I really don't understand why this is happening though.

Joe

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 Jun 1999 19:13:44 -0600

> --- move.c-2.2.2        Tue Jun  8 17:14:17 1999

I can't remember the exact logic behind this right now, but the code

  if (eventp->type == ButtonPress || eventp->type == ButtonRelease)

is correct and the line we have in the current development code.
Unfortunately this bug fix dosn't seem to have made it into 2.2.2.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 09 Jun 1999 13:23:05 -0400

> Unfortunately this bug fix dosn't seem to have made it into 2.2.2.

Pending for 2.2.3:

1) Web page updates
2) Window moving problem

I think it might make sense to solve #1 with the proposed new
source tree for screenshots.  Maybe it should be the "fvwm-web"
source tree?

One problem is the "NEWS" and "FAQ" files in the source tree create
the NEWS.html and FAQ.html files, which sort of blows that idea
right out of the water.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]