Subject: Notification: incoming/406

From: [email-masked]
Date: Sun, 27 Jun 1999 05:30:15 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/406

Message summary for PR#406
	From: [email-masked]
	Subject: Changing geometry attributes through titlebar buttons
	Date: Sun, 27 Jun 1999 05:30:14 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Michael Han <[email-masked]>
Date: Sun, 27 Jun 1999 10:05:44 -0700

Previously...
>I would like to suggest a new feature for Fvwm2.
>It would be nice if one could bind to a button a
>reassignment of geometry to a particular window.
>Hence as an application one could click on a titlebar
>button and the window could move to position +0+0 or
>-0+0 etc... depending on the button binding.
>Hence you can sort of move smaller windows out of the
>way by the click of a button, and you can also make them
>small and of a particular size by the click of a button.

Have you looked at the manpage for the builtin function Move? I don't
really see that FVWM can't already do what you're asking. Did I miss
something in your request? For example, from your above request, let's
say you have titlebutton 10. It's trivial to create a binding like:

Mouse 1 10 N Move 0 0
Mouse 1 10 S Move 0 -0
Mouse 1 10 M Move -0 -0
Mouse 1 10 C Move -0 0

For button one to take the window to any of the corners. HTH.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"I had lately learned that another way of writing FALL IN LOVE is WALK THE 
PLANK." - Jeanette Winterson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]