Subject: xbm icons aren't working

From: Dan Espen <[email-masked]>
Date: Tue, 22 Jun 1999 15:48:32 -0400

It  looks like fvwm2  no longer accepts  "xbm"  (X11 bitmaps) files as
icons.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 28 Jun 1999 13:26:00 +0100

> It  looks like fvwm2  no longer accepts  "xbm"  (X11 bitmaps) files as

I think I broke this, I was assuming icon bitmaps had a depth of 1 not
0. I've fixed this bug but it may not be the cause of your problem.
Could you try again?

Cheers,
Tim.

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 28 Jun 1999 20:15:37 +0200

> 0. I've fixed this bug but it may not be the cause of your problem.

I'm surprised. What exactly are depth 0 pixmaps ? I always thought
bitmaps are just depth 1 pixmaps.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 29 Jun 1999 13:49:41 -0400

> 0. I've fixed this bug but it may not be the cause of your problem.

Another bug bites the dust.  (Its fixed.)

Anyone else notice their titlebar disappearing?  So far I have no clue what
causes it, but I've seen it twice in the last week.

---

From: Tim Phipps <[email-masked]>
Date: Wed, 30 Jun 1999 17:38:16 +0100

> bitmaps are just depth 1 pixmaps.

They are, but fvwm initialized the depth variable to 0 and didn't update
it when it had loaded a bitmap. I made a change to the icon drawing code
and put in a test for pixmaps of depth 1 and so messed up with bitmaps.

Cheers,
Tim.