Subject: Notification: incoming/397

From: [email-masked]
Date: Wed, 23 Jun 1999 10:53:54 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/397

Message summary for PR#397
	From: [email-masked]
	Subject: Iconify-and-Compact function wreaks havoc
	Date: Wed, 23 Jun 1999 10:53:53 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Jun 1999 01:44:02 +0200

On Wed, Jun 23, 1999 at 10:53:54AM -0500, [email-masked] wrote:
> Tim Phipps suggested a cool idea for allowing the deiconify
> operation to reorder the remaining icons, compacting them.
> I implemented it like this:
> 
>   AddToFunc Iconify-and-Compact
>   +       "C" Iconify
>   +       "C" All (CurrentDesk Iconic) RecaptureWindow
> 
>   Mouse 2   I   A   Function Iconify-and-Compact
> 
> However, now after the first time I deiconify with mouse-2,
> _every_ new window created thereafter is created in an iconified
> state.
> 
> Maybe the StartIconic flag gets set in all new windows, somehow?
> No clue.

Fixed.

The isIconicState variable was not properly reset before mapping
a new window. It was set upon RecaptureWindow and then used for all new
windows until is was set by the next RecaptureWindow. It's a two-line
fix in HandleMapRequestKeepRaised (events.c).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 23 Jun 1999 21:41:13 -0400

>> _every_ new window created thereafter is created in an iconified

  dv> Fixed.

Cool; you da man.

I'll test it tomorrow at work.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]