Subject: fvwm-web not a module?

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Jun 1999 14:17:23 -0600

Dan, I noticed the fvwm-web directory is a subdirectory in the fvwm module.
This has the unpleasant side effect that the screenshots are updated every
time I update the sources. I think the module should be anchored one level
up in the directory structure like fvwm-cats is.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Mon, 21 Jun 1999 13:32:20 +0100

> up in the directory structure like fvwm-cats is.

Another thing: does cvs know that these .gif aren't source code? It's
taking ages to do an update today and I'm wondering if the server is
trying to diff two revisions of a .gif.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Mon, 21 Jun 1999 09:14:38 -0400

> > up in the directory structure like fvwm-cats is.

Hmm...looks like I missed some mail.  I never saw the original of this.
If there was some other issue in the same mail, I missed it.
I'll see what I can do to move it.

> trying to diff two revisions of a .gif.

If you do a "status -v",  you will see they were  all added with "-kb"
which I believe  marks them as binary.   I  think that would  stop CVS
from trying to manage these with diffs.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 21 Jun 1999 09:35:22 -0400

> > up in the directory structure like fvwm-cats is.

Comparing the 2 repositories,  I don't see a difference:

fork> cd ../fvwm-cats
fork> pg CVS/Repository  
/home/cvs/fvwm/fvwm-cats
fork> cd ../fvwm-web
fork> pg CVS/Repository
/home/cvs/fvwm/fvwm-web

Here's what I did the first time:

mkdir fvwm-web
cd fvwm-web
cvs -d :pserver:[email-masked]:/home/cvs/fvwm import -m'create' \
  fvwm-web fvwm-web start

It responded:

No conflicts created by this import

cd somewherelse
cvs -d :pserver:[email-masked]:/home/cvs/fvwm checkout fvwm-web
cd fvwm-web
create first.file
cvs add -m'first file' first.file
cvs commit

If this isn't right, what should I be doing?

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Jun 1999 15:48:29 -0600

> If this isn't right, what should I be doing?

Looks exactly like what I have done to create fvwm-cats. Hm,
/home/cvs/fvwm is our root directory, so /home/cvs/fvwm/fvwm-web
shouldn't be visible in the fvwm module. Jason, do you have any
idea what happened there? Did you change something in the CVS
setup lately?

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Mon, 21 Jun 1999 10:01:25 -0400

> idea what happened there? Did you change something in the CVS

I just did an "update" and a "commit".  I didn't see any activity in
fvwm-web.  Where are you seeing the problem?

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Jun 1999 16:15:01 -0600

> fvwm-web.  Where are you seeing the problem?

Hrm, here at work a checkout doesn't touch fvwm-web, but at home it's
alwasy dumped into fvwm/fvwm-web. Is it possible that I checked out
fvwm-web into my source tree by accident and that it is updated every
time I do a checkout now? BTW, I can confirm the extremely long delays
before a gif is updated. It does indeed look as if CVS send the complete
file to compare it before doing the checkout. Cant't you tell CVS to
use only size and checksum?

Bye

Dominik ^_^

---

From: Jason L Tibbitts III <[email-masked]>
Date: 21 Jun 1999 09:43:35 -0500

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

DV> Jason, do you have any idea what happened there?

I'm no CVS expert, but:

XYX:epithumia:~/fvwm> cvs update -dPA
[...]
cvs server: Updating vms
cvs server: Updating xpmroot

XYX:epithumia:~/fvwm>  ls fvwm-web
ls: fvwm-web: No such file or directory

XYX:epithumia:~/fvwm>  ls fvwm-web
ls: fvwm-web: No such file or directory

XYX:epithumia:~/fvwm> cvs checkout fvwm-web
cvs server: Updating fvwm-web
U fvwm-web/Dan-desk-1280x1024.gif
U fvwm-web/Dan-desk-thumbnail.gif
U fvwm-web/Michael-desk-1152x900.gif
U fvwm-web/Michael-desk-thumbnail.gif
U fvwm-web/Mikhael-desk-1152x864.gif
U fvwm-web/Mikhael-desk-thumbnail.gif
U fvwm-web/Robert-desk-1280x1024.gif
U fvwm-web/Robert-desk-thumbnail.gif
U fvwm-web/black-stone1.jpg
U fvwm-web/index.html

XYX:epithumia:~/fvwm> rm fvwm-web/index.html

XYX:epithumia:~/fvwm> cvs update -dPA
[...]
cvs server: Updating fvwm
cvs server: Updating fvwm-web
U fvwm-web/index.html
cvs server: Updating icons
cvs server: Updating libs
[...]
cvs server: Updating vms
cvs server: Updating xpmroot

XYX:epithumia:~/fvwm> rm -rf fvwm-web

XYX:epithumia:~/fvwm> cvs update -dPA
[... No mention of fvwm-web]
cvs server: Updating vms
cvs server: Updating xpmroot

So: if you check out the fvwm-web sub-module in a subdirectory of the
master tree, it gets updated along with the master tree.

Solution: check it out in a separate directory, or delete it if you don't
want it.

DV> Did you change something in the CVS setup lately?

Nope, although I really need to move it to the new machine.

BTW, Dom, I think either your clock of your timezone is way off:

X-Sent: 7 hours, 11 minutes, 54 seconds in the future

 - J<