Subject: Re: to do for 2.4 (update 4)

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jun 1999 11:35:57 +0200

----- Forwarded message from [email-masked] -----

Date: Wed, 23 Jun 1999 09:04:38 +0200
Subject: Re: to do for 2.4 (update 4)
From: [email-masked]
To: [email-masked]

Dominik Vogt wrote:

>  35) Test the strokes patch.

Hello,
I have installed libstroke and compile the "last" cvs
(Strokes support : yes). Then strokes_test works very well.
So, following the fvwm2 man page I add this at the 
end of my .fvwm2rc

Mouse Mouse 2 R A - 
Stroke 14789 2 A A WindowList 

Unfortunately, this does not work and Mouse 2 R give me
the default button menu ... I try a number of config but
do not succeed to obtain something

Sorry if I have misunderstand something

Olivier

----- End forwarded message -----

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Jun 1999 08:03:29 -0400

> So, following the fvwm2 man page I add this at the 
  ^^^^^^^^^^^
?

The plural of mouse is mice.

(But you only want one.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Ke Huang <[email-masked]>
Date: Wed, 23 Jun 1999 10:05:00 -0500 (CDT)

>Stroke 14789 2 A A WindowList 

Ah, yes, this is a problem I noticed as well after I wrote the man page. The
problem is that '-' is supposed to disable a particular binding, but it
actually didn't work for me. So, the only way I can disable a binding is by
doing this:

Mouse 2 R A

the empty action will disable the binding as well. I am assuming the doubling
of the Mouse command is due to cut-and-paste. :)

btw, you do have to press button on the root to 'draw' the strokes.

>Sorry if I have misunderstand something

-- Ke Huang
------------------------------------------
e-mail:  [email-masked]  (preferred)
         [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 23 Jun 1999 20:05:43 +0200

> actually didn't work for me. So, the only way I can disable a binding is by

Yes that works very well, I appology because it was some where in the
archive ... I have noted that Modifier does not seem to work.
So for me context need to be R and the modifier need to be A and
evreythings seems to be great : my touch pad become a "pallet" !

A thing that it will be find to have is (esspecially for a touchpad) :
Stroke sequence M A M Function
i.e., Alt+mouse-move will work everywhere.

Many Thanks, Olivier.