Subject: Re: reporting a <<WARNING>>

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jun 1999 01:42:19 +0200

On Fri, May 21, 1999 at 09:07:17PM -0400, jason wrote:
> 
> Hi,
> 
>   I'm running 2.3.2, and I get the message:
> 
> [FVWM][GetWindowSizeHints]: <<WARNING>> X11Amp window 0x4800009 has broken size hints
> Please report this to [email-masked]
> 
> in the fvwm log file I keep.  A little experimentation shows that I get
> this message only when I un-shade it.  It doesn't appear when the window
> shades, just when it un-shades.  And I don't mean fvwm's shade, but its
> own internal "shade" function which can be activated, for example, by
> double-clicking the "titlebar" (not fvwm's titlebar, since it's
> NoTitle'd).  I'm running x11amp 0.9-beta1.1.  My x11amp style:
> 
> Style "x11amp*" BorderWidth 0, HandleWidth 0, NoTitle, WindowListSkip, \
>                 Sticky, SmartPlacement, Icon x11amp-icon17.xpm

Finally I found the time to confirm this. xmms (the former x11amp)
requests a maximum size smaller than the minimum size when unshading:

  # xwininfo -size 
  xwininfo: Window id: 0x2c00009 "XMMS"

    Normal window size hints:
        Program supplied minimum size: 275 by 116
        Program supplied maximum size: 275 by 14
    No zoom window size hints defined

I've reported this to the xmms developers.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 25 Jun 1999 09:42:16 +0200

> > Please report this to [email-masked]

[...]

> I've reported this to the xmms developers.

We got one! So putting in this message wasn't completely useless...
maybe we should implement a ICCCM-compliance testing mode, where
every failure to obey ICCCM would be reported (but change the
message to "Please report this to the author of the offending program")

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jun 1999 13:22:29 +0200

> message to "Please report this to the author of the offending program")

The messages are definitely valid, but I took me about two hours to debug the
problem. First I installed x11amp, but the version was too old, it had no shade
functionality. I tried www.x11amp.org, but the software was renamed to
xmms. I downloaded and compiled, but my gtk/glib was too old. So I
downloaded gtk/glib 1.2.3, compiled them, installed them, compiled xmms
and could finally verify the bug. And all this work only because we don't
print the size hints along with the warning :( Matthias, would you add
a printf that prints the application supplied hints and some indicator
in which code line(s) the broken_hints flag was set?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]