Subject: dead_modifiers code commented out

From: Dominik Vogt <[email-masked]>
Date: Sun, 13 Jun 1999 06:48:33 +0200

Dan, I just noticed you put an '#if 0' around a line in
GrabWindowButton() (libs/Bindings.c). Is there a particular
reason why you did this? If I remember correctly this line
should allow you to activate a binding even if you told fvwm
explicitly that one or more of the modifiers you used for
the bindings should be ignored. E.g. with

  IgnoreModifiers S
  Key F1 A S Beep

Nothing will happen with shift-F1 without that line, but
it will work with it. So, if you don't have such screwed
up bindings in you config file you won't notice any
difference.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 14 Jun 1999 16:47:36 -0400

> up bindings in you config file you won't notice any

This is the Changelog that goes with it:

  * libs/Bindings.c (AddBinding): Only add one entry to the binding
  table when a key generates the exact same information with more than
  one modifier.

We were trying to solve performance problems on iconification.

I'm pretty sure I applied that patch at your suggestion.

I don't have IgnoreModifiers in my config file.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jun 1999 11:47:54 -0600

> We were trying to solve performance problems on iconification.

Yes, I remember that part, but I can't see what the commented line
has to do with it. It has no effect if you don't use bindings with
modifiers that you have deactivated with IgnoreModifiers.

> I'm pretty sure I applied that patch at your suggestion.
 
I can only imagine that we tried to remove this command to see if
it helps but forgot to activate it again. Can you verify that
you lose performance when you put it back?

> I don't have IgnoreModifiers in my config file.

Neither do I. It's so much better to solve it in the Xmodmap.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 Jun 1999 21:03:08 -0400

> you lose performance when you put it back?

My  tests  show  that the   commented   out  code  has  no impact   on
performance.  All my keys seem to work the same with or without it.

I did an extensive search of the mail archives without determining why
the logic was commented out.

I did see one patch from you to me, but the actual patch didn't seem
to be in the archive.

I downloaded the complete archive for 4/99 but the raw archive
seems to be only the fvwm list.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Jun 1999 03:12:32 +0200

> performance.  All my keys seem to work the same with or without it.

I'll remove the '#if 0' then.

Bye

Dominik ^_^