Subject: autoraising icon titles and moving icons

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jun 1999 04:31:58 +0200

Matthias, autorising icon titles and moving icons doesn't play nicely
together. I tried to fix it but couldn't. Here are some instructions
to show the problem.

 1) Create a window wit a long icon title (e.g. netscape).
 2) Iconify it.
 3) Move the mouse over the icon. The title is expanded. The new icon size
    is not reflected in the pager (this is correct so far).
 4) Now drag the icon with the mouse, release the button and make sure
    you don't move the mouse afterwards.
 5) Now the icon title is collapsed again, but the pager got the wrong idea
    of the icon's size and now draws it as wide as the expanded title was.

The problem I see is that the width of the expanded title is really set
in the window structure. It should never be broadcast anywhere. Any ideas
how to fix it?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 22 Jun 1999 12:17:46 +0200

> in the window structure. It should never be broadcast anywhere. Any ideas

I'll have to look at the code.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]