Subject: cannot restart FvwmPager

From: TG <[email-masked]>
Date: Sun, 27 Jun 1999 14:37:55 +0200

OS: i386, RedHat 6.0
XServer: XFree86-3.3.1
fvwm2 version: cvs (1999-06-26)

I can't start up FvwmPager in my RestartFunction anymore. It used to
work a few days back. When I start fvwm2 the first time, the pager shows
up, but when I hit restart, it just disappears it does NOT come back. I
added some debug output in RestartFunction and it IS printed on stderr.
Launching FvwmPager from the console always works. And executing
RestartFunction in FvwmConsole just does it work.

-- functions.config --

AddToFunc "InitFunction"
+	"I"	FvwmPager 0 3

AddToFunc "RestartFunction"
+ 	"I" 	echo Beginning RestartFunc ..
+	"I" 	FvwmPager 0 3
+ 	"I" 	echo Ending RestartFunc ..

----

UPDATE:
I just found out I have to start the pager TWICE before it shows up. It
doesn't matter wether it is done in the RestartFunction or in the
console.

Tung

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 Jun 1999 16:29:34 +0200

> doesn't matter wether it is done in the RestartFunction or in the

That's a bug we are hunting for a couple of weeks now. We still have not
found a way to reproduce it. Please send us your config file. How often
does this happen?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 28 Jun 1999 02:14:52 +0300 (IDT)

On Sun, 27 Jun 1999, Dominik Vogt wrote:

> found a way to reproduce it.

Not exactly. I can reproduce it very easily.
Actually, you can find and drag your first pager using the second one (if
you have more than one page on a desk).

I think I finally fixed this bug with the latest commit.
TG: can you, please, try the latest CVS and check again?

Regards,
Mikhael.

---

From: TG <[email-masked]>
Date: Mon, 28 Jun 1999 12:54:27 +0200

Dominik Vogt wrote:
> found a way to reproduc. How often
> does this happen?
> 

With the attached config files, it always happen. I just start up fvwm2,
no extra apps, and I hit Ctrl+F4, r to restart and the pager disappears.

When I comment out line 10 from app.styles:
	Style "Fvwm*"           NoTitle, NoHandles, Sticky, WindowListSkip
there is no problem anymore.

My config files are ordered this way:
---
.fvwm2rc
.fvwm2rc.d
  |- config
      |- buttons.config
      |- functions.config
      |- pager.config  
      |- menus.config
      |- styles
           |- app.styles
           |- window.styles
---

I noticed some "strange" things:

FvwmPager DOES start up (I looked in top), but it doesn't show up on my
screen. And I can kill it with KillModule in FvwmConsole. Starting it a
second time and the pager pops up at the right place. 

DesktTopSize is set to 2x1, when I use 2x2, the pagers shows up
prefectly.

BTW, DeskTopSize doesn't get read in my fvwm2rc during restarts, I need
to type it in FvwmConsole or shut down fvwm2 and restart it manually.

Tung

#
# buttons.config
#
################################ Keyboard Setup ###############################
# Context:
#               R=root, W=window, T=titlebar, S=sides, 
#               F=frame (corners), I=icon, 0-9=buttons
# Modifiers
#               N=no modifiers, C=control,S=shift, M=Meta,
#               A=any modifier. For example, a modifier of  SM  will
#               apply  when  both the Meta and Shift keys are down.
###############################################################################

###############################################################################
# In the root window: Menu
###############################################################################

Mouse 1         R       A       Menu Applications Nop
#Mouse 2         R       N       WindowList NoGeometry CurrentDesk Transient
#Mouse 2         R       S       WindowList NoGeometry Transient
Mouse 2         R       N       WindowList CurrentDesk Transient
Mouse 2         R       S       WindowList Transient
Mouse 3         R       A       Menu UtilMenu Refresh

Key F1		RA	C       Menu Applications Root c c Nop
Key F4		RA	C		Menu UtilMenu Root c c Refresh

###############################################################################
# Switchting windows
###############################################################################

Key KP_1	A	C	Direction SouthWest Focus
Key KP_2	A	C	Direction South Focus
Key KP_3	A	C	Direction SouthEast Focus
Key KP_4	A	C	Direction West Focus
Key KP_6	A	C	Direction East Focus
Key KP_7	A	C	Direction NorthWest Focus
Key KP_8	A	C	Direction North Focus
Key KP_9	A	C	Direction NorthEast Focus

Key Escape	RA  C		WindowList Root c c NoGeometry Transient
Key Tab		RA  M		WindowList Root c c NoGeometry CurrentDesk Transient

###############################################################################
# Mouse in window
###############################################################################

Mouse 1         FS	A	Resize
Mouse 1         T	A	RefreshWindow
Mouse 2         FTS	A	Move

Mouse 1 	1       A       Delete
Mouse 2 	1       A       Close
Mouse 3 	1       A       Destroy

Mouse 1 	2       S       Maximize true
Mouse 1 	2       N       Maximize true grow grow
Mouse 2 	2       S       Maximize true 0 100
Mouse 2 	2       N       Maximize true 0 grow
Mouse 3 	2       S       Maximize true 100 0
Mouse 3 	2       N       Maximize true grow 0

Mouse 1 	4       A       Menu Move_To_Desk
Mouse 2 	4       A       WindowShade
Mouse 3 	4       A       Stick

# voor iconen
Mouse 2         I       A       Nop

Mouse 2         FST     A       Move

Mouse 3         TSF    A       RaiseLower
#Mouse 3         TSF    C       Stick

#####################################################################
# Window Ops Hotkeys
#####################################################################

Key F1		A	M	RaiseLower
Key F2		A	M	Resize
Key F3		A	M	Move
Key F4		A	M	Delete

Key v		A	CM	Maximize 0 grow
Key v		A	SCM	Maximize 0 100
Key h		A	CM	Maximize grow 0
Key h		A	SCM	Maximize 100 0
Key m		A	CM	Maximize grow grow
Key m		A	SCM	Maximize 100 100

Key s		A	CM	Stick

#####################################################################
# Desktop Ops Hotkeys
#####################################################################

Key F5		A	M	GotoDeskPage 0 0 0 0
Key F6		A	M	GotoDeskPage 0 0 1 0
Key F7		A	M	GotoDeskPage 0 1 0 0
Key F8		A	M	GotoDeskPage 0 1 1 0
Key F9		A	M	GotoDeskPage 0 2 0 0
Key F10		A	M	GotoDeskPage 0 2 1 0
Key F11		A	M	GotoDeskPage 0 3 0 0
Key F12		A	M	GotoDeskPage 0 3 1 0

Key Page_Up		A	M	GotoDesk -1 0 3
Key Page_Down	A	M	GotoDesk 1 0 3

Key Left        A       CM       Scroll -100 0
Key Left        A       SCM       Scroll -5 0
Key Right       A       CM       Scroll +100 +0
Key Right       A       SCM      Scroll +5 +0

#Key Up          A       CM       Scroll +0   -100
#Key Down        A       CM       Scroll +0   +100

#####################################################################
# Apps hotkeys
#####################################################################

Key t		RA	CM	Exec rxvt
Key w		RA	CM	Exec gvim /home/winger/.plan
Key r		RA	CM	Exec gnome-run
Key m		RA	CM	Exec gmix
Key c		RA	CM	Exec xchat

######################## Initialization AddToFuncs ############################

AddToFunc InitFunction
+	I	Module FvwmPager 0 3
+	I	Module FvwmCommandS

AddToFunc RestartFunction
+ 	I	echo Beginning RestartFunc ..
#+	I	Module FvwmCommandS
+	I	Module FvwmPager 0 3
+ 	I	echo Ending RestartFunc ..

AddToFunc "WindowListFunc"
+	I WindowId $0 Iconify off
+	I WindowId $0 FlipFocus
+	I WindowId $0 Raise
+	I WindowId $0 WarpToWindow 50 50

########################### Complex AddToFuncs ###############################

AddToFunc GotoDeskPage
+	I	GotoDesk $0 $1
+	I	GotoPage $2 $3

AddToMenu Move_To_Desk "Move To" Title
+	"&Work"	MoveToDesk 0 0
+	"&Alt"	MoveToDesk 0 1
+	"&Info"	MoveToDesk 0 2
+	"&Mail"	MoveToDesk 0 3

AddToMenu UtilMenu  "UtilMenu" Title
+	"Buttons"	Exec gvim /home/winger/.fvwm2rc.d/config/buttons.config
+	"Menus"		Exec gvim /home/winger/.fvwm2rc.d/config/menus.config
+	"Functions"	Exec gvim /home/winger/.fvwm2rc.d/config/functions.config
+	""				Nop
+	"FvwmScroll"	Module FvwmScroll
+	"FvwmTaskBar"	Module FvwmTaskBar
+	"FvwmGtk"		Module FvwmGtk
+	"FvwmIconBox"	Module FvwmIconBox
+	"FvwmCo&nsole"	Module FvwmConsole
+	"FvwmIdent"		Module FvwmIdent
+	"FvwmWinList"	Module FvwmWinList
+	""				Nop
+	"Re&fresh"		Refresh
+	"Re&capture"	Recapture
+	"&Restart"    	Restart fvwm2
+	""				Nop
+	"&Logout"  		PopUp Quit-Verify

AddToMenu Quit-Verify "Logout" Title
+        "&Yes, Really Logout"  Quit
+        ""			Nop
+        "&No, Don't Logout"	Nop

AddToMenu Applications "Applications" Title
+	"&Netscape" 	Exec netscape -no-about-splash
+	"&Lynx"		Exec rxvt -title Lynx -geometry 80x52 -e lynx
#+	"&Amaya"	Exec amaya
+	""		Nop
+	"G&Vim"		Exec gvim
+	"&Gaby"		Exec gaby
+	""		Nop
+	"Nieuws"	PopUp Nieuws
+	"Shells"	PopUp Shells
+	"Productivity"	Popup Productivity
+	"Graphics"	PopUp Graphics
+	"Multimedia"	PopUp Multimedia
+	"Games"		PopUp Games
+	"Misc"		Popup Misc
+	"SysAdmin"	PopUp Sysadmin

AddToMenu Nieuws "Nieuws" Title
+	"Freshmeat"	Exec rxvt -title Freshmeat -geometry 80x52 -e lynx http://nl.eu.mirrors.freshmeat.net
+	"Slashdot"	Exec rxvt -title Slashdot -geometry 80x52  -e lynx http://slashdot.org
+	"LinuxToday"	Exec rxvt -title LinuxToday -e lynx http://www.linuxtoday.com
+	"Skynet Status"	Exec rxvt -title "Skynet Status" -geometry 80x52 -e lynx http://belcast.skynet.be/status.phtml

AddToMenu Shells "Terminals" Title
+	"Xterm"		Exec xterm
+	"Rxvt"		Exec rxvt
+	"GTerm"		Exec gnome-terminal

AddToMenu Productivity "Productivity" Title
+	"GnomeCalendar"	Exec gnomecal
+	"Gnome Postit"	Exec gpostit
+	"TimeTracker"	Exec gtt

AddToMenu Graphics "Graphics" Title
+	"Electric Eyes"		Exec ee
+	"Gimp"			Exec gimp

AddToMenu Multimedia "Multimedia" Title
+	"Emusic"	Exec emusic
+	"Gnome-Mixer"	Exec gmix
+	"Gnome-CD"	Exec gtcd
+	"GnomoVision"	Exec gnomovision

AddToMenu Games  "Games" Title
+	"Gnome Mines"	Exec gnomine
+	"FreeCell"	Exec freecell
+	"SameGnome"	Exec same-gnome
+	"Aisleriot"	Exec aisleriot
+	"Mahjongg"	Exec mahjongg
+	"Phaser Chess"	Exec phaser-chess
+	"ScottFree"	Exec scottfree

AddToMenu Misc "Misc" Title
+	"Simple Calc"	Exec gcalc
+	"Genius Calc"	Exec genius
+	"Gnome Editor"	Exec gedit
+	"Hex Editor"	Exec ghex

AddToMenu Sysadmin "Admin Utils" Title
+	"CroMagnon"		Exec cromagnon
+	"Gnome-Top"		Exec gtop
+	"Gnome-Logview"		Exec logview --disable-sound
+	"Gnome-Shutdown"	Exec gshutdown

###
# FvwmPager configuration: pager.config
###

*FvwmPagerBack black
*FvwmPagerFore white
*FvwmPagerHilight darkgreen
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerSmallFont 5x8
*FvwmPagerGeometry 256x42+757+0
*FvwmPagerRows 1
*FvwmPagerColumns 4

*FvwmPagerLabel 0 Work
*FvwmPagerLabel 1 Alt
*FvwmPagerLabel 2 Info
*FvwmPagerLabel 3 Mail

*FvwmPagerBalloons
*FvwmPagerBalloonFore black
*FvwmPagerBalloonBack white
*FvwmPagerBalloonFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerBalloonYOffset -2

###
# basic stuff
###

Echo -Root rc file starts-

ModulePath /usr/local/libexec/fvwm/2.3.5
#ImagePath   /usr/include/X11/bitmaps

IconFont        -*-Helvetica-Medium-r-*-*-9-*-*-*-*-*-*-*

DeskTopSize 2x1
EdgeScroll 100 100
EdgeResistance 100 100

###
# import config files
###

Echo -FvwmPager-
Read .fvwm2rc.d/config/pager.config

#Echo -FvwmBacker-
#Read .fvwm2rc.d/config/backer.config

Echo -Styles-
Read .fvwm2rc.d/config/styles/app.styles
Read .fvwm2rc.d/config/styles/window.styles

Echo -Buttons & Keys-
Read .fvwm2rc.d/config/buttons.config

Echo -Menus-
Read .fvwm2rc.d/config/menus.config

Echo -Functions-
Read .fvwm2rc.d/config/functions.config

###

Echo -Root rc file ends-

---

From: TG <[email-masked]>
Date: Mon, 28 Jun 1999 13:37:58 +0200

> TG: can you, please, try the latest CVS and check again?

cvs from today, Jun 28.

The problem seems to be solved. Pager shows up each restart.

Thanks a lot.

Tung