Subject: to do for 2.4 (update 1)

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Jun 1999 13:41:23 +0200

To do (must):

 1) Document the GNOME stuff (man page still missing).
 2) Add screen shots to web page.
    [in progress]
 7) Create an I18N fvwm package (from 2.2 or so).
 8) Add an explanation about the various packages and where to
    discuss them to the web page.
    (stable, unstable (alpha), snapshots, ftp source tree, CVS).
 9) Set up RPM packages.
    [in progress]

To do (optional)

 6) Remove several configure options.
 10) Remove 'PopupAsRootMenu' menu style (?).
     [comments wanted]
 11) Add FvwmKb module?
     [comments wanted]
 12) Set up bzip2 tarballs.
 13) Use a 'busy' pointer during startup.
     [in progress]

Fixes (high priority):

 14) Figure out what the problem with Amaya is.
     [reported on 3-Jun-1999 by Rob Urban <[email-masked]>]
 15) Get restart straight (sometimes an application vanishes over restarts)
     [in progress]
 16) Try to fix the 'netscape stuck on page' problem.
     [reported on 17-May-1999 by <[email-masked]>]
 17) Fix the bug that causes icons to lose management (bug #352).
 19) Try to reproduce that KFM windows stay on top of normal fvwm windows.
     [reported by Andrew Morton <[email-masked]> on 16-May-1999]
 20) Check why no icon can be set for Eterm.
     [reported on 8-May-1999 by Amir Chossrow Akhavan <[email-masked]>]
 21) Fix the bug with eterm and transparent background (I think rxvt has
     the same problem.
 22) Investigate bug #290.
     [mail thread from April]
 23) Check if bug #312 is still there.
 24) Investigate bug #314.
 25) Investigate dying pager on desk-to-desk transfers (bug #358 et al.)
     [in progress]
 26) Investigate bug #315.
 27) Check if bug #334 is still a problem.
 28) Investigate FvemEvent core dumps.
     [in progress]
 37) Fix interaction of moving with autoraising icon titles.
     [in progress]
 38) Investigate bug #389
 39) Investigate bug #390
 40) Investigate bug #394

Fixes (optional):

 30) Fix the broken size hints of FvwmWinList (in fvwm itself).
     [reported by Dan, verified by me (Dominik)]
 31) 'Maximize grow grow' works only on the current page.
     [reported by me (Dominik)]
 32) Several applications are reported to not resize well under fvwm
     (Datek's "Streamer", CodeWarrior).

Testing:

 33) Test the GNOME patches.
 34) Run the purify script again (and update it).
 35) Test the strokes patch.
 36) Test the new menu styles (ItemFormat!)
 
=====

Done:

 3) Add link to fvwm cats page to web page.
 4) Add link to Mikhael' wm-icons page.
 5) Update the links on our home page.
 18) Check if there are still growing windows as reported for 2.13.
     [bug #184 reported by Michael Hughes <[email-masked]>]
     [no, doesn't happen for 2.2 and up]
 29) Fix the pager bugs I reported recently.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 22 Jun 1999 21:23:19 +0200

>  13) Use a 'busy' pointer during startup.

Dominik, I don't really know what to do about the clock disappearing too
early. I have already put the UngrabPointer as late as possible (at the end
of StartupStuff). It seems the initial apps come up after StartupStuff has
ended.

>  37) Fix interaction of moving with autoraising icon titles.

You can make the pager representation of the icon shrink again by
moving it in the pager... but never mind, I just committed a 
one-character (!) fix to avoid the problem. If we want to protect against
its later reapearance, we should change all broadcasts of icon geometries
to use icon_p_width instead of icon_w_width. I have done this only
in move_resize.c for now.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 22 Jun 1999 15:27:15 -0400

> of StartupStuff). It seems the initial apps come up after StartupStuff has

The solution as it stands is close enough for me.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jun 1999 01:03:59 +0200

> of StartupStuff). It seems the initial apps come up after StartupStuff has

Yes, you're right. I've looked at the code and I don't know wither.
Seems the watch make sense only with a slow machine :-) Perhaps
we should note in the man page that the startup cursor can not be changed.

> in move_resize.c for now.

It took me two minutes to get the large icon representations again :(
But don't worry, I've already made a patch.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 23 Jun 1999 09:54:01 +0100

> of StartupStuff). It seems the initial apps come up after StartupStuff has

Is it possible to find out if there are any pending functions (paused on
a Wait)? If there is you could move the ungrab pointer to the event
looop and only do it if there are no pending functions.  This would
allow users to put a Wait in their InitFunction.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jun 1999 11:17:27 +0200

> allow users to put a Wait in their InitFunction.

The old problem. Personally I don't care if all applications have started
before reverting the cursor, but it would be nice if at least the modules
would tell fvwm that they have reached their main loop.

Bye

Dominik ^_^