Subject: Notification: incoming/319

From: [email-masked]
Date: Mon, 3 May 1999 13:45:19 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/319

Message summary for PR#319
	From: Dan Espen <[email-masked]>
	Subject: My icons and windows are jumping around
	Date: Mon, 03 May 1999 14:28:44 -0400
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 3 May 1999 15:29:12 -0400

> I think the change for keeping an icon on the same page as the window
> is having some unforseen side effects.
> 
> When I move  a window  to  co-ordinates like  -1,  -1, (just  slightly
> offscreen),  and  then iconify the window,   the icon seems to  pick a
> location at  random, often on another page,  sometimes right on top of
> another icon.
> 
> Deiconifying can then put the window almost anywhere.
> 
> This is with the latest CVS.  (2.3.2,  05/03/99). I've seen this for a
> while now, I   just  came up with    a consistent way  to  produce the
> problem.
> 

Dan,

do you see some odd behavior as well when you drag a window across a
page boundary and then release it?  That is the behavior I see now and
I haven't been able to track down when it enterted the code yet (other
than sometime in 2.3)

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 03 May 1999 16:04:16 -0400

Brad Giaccio <[email-masked]> writes:
> I haven't been able to track down when it entered the code yet (other
> than sometime in 2.3)

Sorry, I don't see that problem.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 09:34:37 +0200

> I haven't been able to track down when it enterted the code yet (other

I have seen this one. It happens when you drag a window across a page
boundary and release it immediately when the page is flipped. The window
stays on the position it had on the old page:

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 4 May 1999 07:52:34 -0400

On Tue, May 04, 1999 at 09:34:37AM +0200, Dominik Vogt wrote:

> boundary and release it immediately when the page is flipped. The
> window stays on the position it had on the old page:
>
> Bye
>
> Dominik ^_^
>

Yes, it seems like it might have something to do with the snapattraction
stuff, because I normally see it if I move a window to another page and
then let it snap to another window, it will jump somewhere else.

Not sure if this is related but if I move one of my icons for rxvt it
will jump around a couple of times and lands about 100 pixels higher
than I placed it, but my xterm icons don't do it.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 14:29:41 +0200

> than I placed it, but my xterm icons don't do it.

How do the related config lines look like? (Snap..., Edge..., icon for
rxvt (which dimensions), other icon settings, etc.)

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 22:19:16 +0200

> location at  random, often on another page,  sometimes right on top of

I'm unable to reproduce this part. The icon goes into my icon box
as it should.

> while now, I   just  came up with    a consistent way  to  produce the

I see a problem with de-iconifying. When the x/y coordinates are < 0 for
a window that would be visible when de-iconified, the screen width/height
is added first putting the window too far down/right.

This part is fixed now.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 23:27:35 +0200

On Tue, May 04, 1999 at 08:42:26AM -0400, Brad Giaccio wrote:
> On Tue, May 04, 1999 at 02:29:41PM +0200, Dominik Vogt wrote:
> SnapAttraction 10 SameType
> Style "*"               NoIcon, MiniIcon jball.xpm, IconBox -135 -402 -0 -50
> Style "mutt"            NoTitle, Sticky, NoHandles, MiniIcon mini.letter.xpm, Icon
> Style "log"             Icon
> 
> 
> log are xterms started with 
> xterm -name log  where log sets a geometry and sets activeicon to true
> mutt is an rxvt window
> 
> the xterms are fine its the rxvt window that jumps around

I don't see this. What else could I try?

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Wed, 05 May 1999 09:29:40 -0400

> I'm unable to reproduce this part. The icon goes into my icon box

Well this part was somewhat inconsistent...

> is added first putting the window too far down/right.

You're right, this part seems to be fixed.  Now try putting an xterm
at -1, -1, (any negative coordinate), and maximizing it.

(For me, the window finds a new place to hide.)

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 5 May 1999 11:40:22 -0400

> I don't see this. What else could I try?

Well seeing your CVS commit on jumping icons I thought i would give it  
a shot but just to let you know you left a print in the enter leave     
code.  But if this helps 
when I click on the icon to move it I get:
entering icon 0x6e1d8
entering icon done

then I move it and release I see :
leaving icon 0x6e1d8
leaving icon done
leaving icon 0x6e1d8
leaving icon done
entering icon 0x6e1d8
entering icon done
entering icon 0x6e1d8
entering icon done
leaving icon 0x6e1d8
leaving icon done

I also tried starting up a couple of rxvt's and when I move their icons
they all land ontop of each other.  I've got some time now so I'm going
to had some prints and see if I can figure out what is happening.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 00:15:10 +0200

> at -1, -1, (any negative coordinate), and maximizing it.

Fixed. Please tell me if you see something like that again.

Bye

Dominik ^_^