Subject: #include "help.h" -> compiling the daily CVS snapshot

From: Amir Chossrow Akhavan <[email-masked]>
Date: Wed, 26 May 1999 14:05:40 -0700 (PDT)

Hi!

I have problems compiling the daily CVS snapshots since
May 22.
I never had a problem before May 21.
Obviously my last two mails about this went to the wrong bug-list
and ergo to nirvana. 
So this is another trial.

Ok, I download the daily snapshot from
ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/
  
Then I have
/home/amir/fvwm-snap-19990526.tar.gz

I unzip and untar it.

# cd /home/amir/fvwm-snap-19990526
# ./configure
  creating cache ./config.cache
...
a lot of output (see below for possibly meaningfull stuff)
...
  creating modules/FvwmWinList/Makefile
  creating modules/FvwmGtk/Makefile
  creating config.h

  Configuration:
  
    FVWM Version:             2.3.3
  
    Have ReadLine support?    yes
    Have RPlay support?       no
    Have XPM support?         yes
    Have GTK support?         yes
# make
  make  all-recursive
  make[1]: Entering directory `/home/amir/fvwm-snap-19990526'
  Making all in libs   
  make[2]: Entering directory `/home/amir/fvwm-snap-19990526/libs'   
  make[2]: *** No rule to make target `ClientMsg.h', needed by
  `Bindings.o'.
  Stop.
  make[2]: Leaving directory `/home/amir/fvwm-snap-19990526/libs'
  make[1]: *** [all-recursive] Error 1  
  make[1]: Leaving directory `/home/amir/fvwm-snap-19990526'
  make: *** [all-recursive-am] Error 2

There is no ClientMsg.h anywhere on my box, not in the
fvmw-snapshot directory nor elsewhere. 

I've had a look at the source in libs/ to figure out what is needed.
Some *.h files are not included (sic ;) ) in the ftp-tar-ball:

# cd libs/
# pwd
  /home/amir/fvwm-snap-19990526/libs
# ls ClientMsg.h ls ClientMsg.h fvwmsignal.h Grab.h safemalloc.h wild.h
  ls: ClientMsg.h: No such file or directory
  ls: fvwmsignal.h: No such file or directory
  ls: Grab.h: No such file or directory
  ls: safemalloc.h: No such file or directory
  ls: wild.h: No such file or directory
  
Don't they have to be there?
I have very little C experience, but I naively assume that
  #include "somefile.h"
means that somefile.h has to be really present in the same directory.
  
Could this be a compiler/make problem on my side?

./configure reports:
  checking for working makeinfo... missing
  checking for sys/systeminfo.h... no
  checking for dnet_ntoa in -ldnet... no
  checking for dnet_ntoa in -ldnet_stub... no
  checking for POSIXized ISC... no

but this all has never been a problem before May 22.
everything else looks fine to me.

RH 5.2
libc 2.0
make-3.76.1-2
automake-1.4-1

So, if anyone has successfully built fvwm2 from
the FTP-DOWNLOADED snapshot he/she may call me a fool,
but please, enlighten me!

Anyone?   

Otherwise I have to wait for the binary-rpms....sigh

thanx, 
Amir

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Wed, 26 May 1999 19:29:53 -0400 (EDT)

>   make[2]: *** No rule to make target `ClientMsg.h', needed by

Sorry, this is my fault.  Will be fixed momentarily.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 May 1999 11:41:38 -0600

> means that somefile.h has to be really present in the same directory.

No, that's incorrect. Quto from 'Kernighan Ritchie'

  "A control line of the form 

     #include <filename>
 
   [...] The named file is searched for in a sequence of implementation-
   dependent places."

Which usually means the include path is used.

  "Similarly, a control line of the form

     #include "filename"

   searches first in association with the original file (a deliberately
   implementation-dependent phrase), and if that search fails, then as
   if in the first form."

I.e. usually you look in the current directory first, and if it's not
there the include path is searched for the file.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]