Subject: Notification: incoming/364

From: [email-masked]
Date: Sun, 23 May 1999 19:35:34 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/364

Message summary for PR#364
	From: [email-masked]
	Subject: FvwmButtons core dumps
	Date: Sun, 23 May 1999 19:35:32 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Mon, 24 May 1999 14:21:06 +0100

> Full_Name: Peter D. Gray
> Version: 2.2.1
> The following input file causes FvwmButtons to crash
> 
> Columns 1
> Rows 1
> Fore white
> Frame 2
> Back grey
> (Title Machines, Panel Machines)
> #
> Panel Machines
> (Icon terminal.xpm, Action 'Exec terminal')
> #
> Panel Dummy
> #

When I run this with 2.2.1 I get:
FvwmButtons: No buttons defined. Quitting
With 2.3.3 it dumps core:

(gdb) where
#0  0x17020 in buttonFrameSigned (b=0x58444343) at button.c:111
#1  0x15678 in RecursiveLoadData (b=0x36628, maxx=0xeffff164,
maxy=0xeffff160)
    at FvwmButtons.c:1269
#2  0x15488 in RecursiveLoadData (b=0x36500, maxx=0xeffff20c,
maxy=0xeffff208)
    at FvwmButtons.c:1210
#3  0x14348 in main (argc=-1, argv=0x32800) at FvwmButtons.c:646

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 28 May 1999 00:21:34 +0200

> #3  0x14348 in main (argc=-1, argv=0x32800) at FvwmButtons.c:646

It's fixed now.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]