Subject: Notification: incoming/345

From: [email-masked]
Date: Sun, 16 May 1999 21:09:33 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/345

Message summary for PR#345
	From: [email-masked]
	Subject: FvwmForm: ! mechanism
	Date: Sun, 16 May 1999 21:09:31 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Fri, 28 May 1999 12:58:08 -0400

[email-masked] writes:
> >From [email-masked]  Sun May 16 21:09:32 1999
> To: [email-masked]
> Full_Name: Neil Zanella
> Version: 2.2.0
> OS: Linux 2.0.36
> X_Server: XFree86 3.3.2
> Submission from: (NULL) (134.153.1.13)
> 
> Hello.
> 
> I would like netscape to browse a website if specified, otherwise
> pop up showing a file if nothing is specified.
> The problem is that when something is specified, netscape pops up as if no
> argument had been specified. Otherwise, if nothing is specified then
> it shows up the appropriate "file:" page which I specified in the
> configuration file.
> 
> Is this a bug in FvwmForm or did I do something wrong?
> 
> Module FvwmForm BrowserForm
> *BrowserFormPosition 61 332
> *BrowserFormFore White
> *BrowserFormBack MediumPurple4
> *BrowserFormItemFore White
> *BrowserFormItemBack Black
> *BrowserFormLine expand
> *BrowserFormText "Website to browse: "
> *BrowserFormLine expand
> *BrowserFormInput website 31
> *BrowserFormButton quit "GO" ^M
> *BrowserFormCommand Exec /usr/bin/netscape
> $(website!file:/home/httpd/html/index.html)

The last line must have gotten chopped during the mailing process.

For FvwmForm to work as you request, the  last line would have to read
as follows:

*BrowserFormCommand Exec netscape -install \
  $(website!file:/home/httpd/html/index.html) $(website)

Note the additional $(website).

I think your assumption was, if website was filled in, it would use the
value of website instead of your file.  Here is the man page:

     $(name?string)  If name is a text input field and its  value
                     is  not  an  empty  string,  the  result  is
                     string, with recursive variable substitution
                     applied.   If  the input value is empty, the
                     result is empty.

                     If name is a choice and it is selected,  the
                     result  is  string,  with recursive variable
                     substitution applied.  If the choice is  not
                     selected, the result is empty.

     $(name!string)  The same as the above, except that the  con-
                     verse conditions are taken.

I've  only  been speaking  English (American) for   my  whole life.  I
haven't a clue  as to whether the  program is working as documented or
not.

I'll close the  bug  report, I think  the program  is doing the  right
thing, I'm not so sure  the documentation makes  sense, but that would
be another problem.

For remote control of Netscape you should check out:

http://home.netscape.com/newsref/std/x-remote.html

> Thanks,
> 
> Neil Zanella
> [email-masked]
> 
> --

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]