Subject: FVWM CVS: fvwm domivogt: * return focus to 'parent' when closing transients

From: CVS <[email-masked]>
Date: Thu, 6 May 1999 19:56:15 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/05/06 19:56:15

Modified files:
	.              : ChangeLog 
	fvwm           : events.c misc.c 

Log message:
* return focus to 'parent' when closing transients
* don't grab focus for transients if their 'parent' is not focused

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 10:21:03 +0100

> * return focus to 'parent' when closing transients

Is this turn off-able?  Being off by default for non-click-focus would
be nice.  I like to do my own thing via FvwmEvent so I can make it
conditional on the window name/class. This change is nice for apps like
netscape that have transients that are modal dialogs but I run some apps
that have concurrent transients that aren't modal and zooming back to
the main isn't always desirable.

Cheers,
Tim.