Subject: BorderWidth and HandleWidth

From: Brad Giaccio <[email-masked]>
Date: Mon, 17 May 1999 11:17:08 -0400

I noticed this a few weeks ago but just got around to looking at it.

HAs anyone else noticed that if you give a window a Borderwidth but no HandleWidth you don't get a border this used to work and I think is desired, since some windows don't need resize handles.

I specifically noticed it on FvwmIdent, the line was 
Style "FvwmIdent"       BorderWidth 4, Slippery  
but I needed to change it to 
Style "FvwmIdent"       BorderWidth 4, HandleWidth 4, Slippery  

Any guesses what change maid this happen or should I dig.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 02:23:53 +0200

> Any guesses what change maid this happen or should I dig.

I can only guess that Tim's changes in the border code may have
caused that. Tim, any ideas?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 02:23:53 +0200

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Mon, 24 May 1999 14:36:05 +0100

> > HAs anyone else noticed that if you give a window a Borderwidth but no
> > HandleWidth you don't get a border this used to work and I think is desired,
> > since some windows don't need resize handles.
> >
As far as I can tell nothing has changed. BorderWidth is only used for
windows that have no resize handles (either they have a NoHandles style
or they have WM hints to prevent resizing). FvwmIdent will have resize
handles by default and if you don't give it a handle width it will get
the default one of 7.

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 24 May 1999 10:30:17 -0400

> handles by default and if you don't give it a handle width it will get

I forgot a config line sorry 
Style "Fvwm*"           NoTitle, Sticky, WindowListSkip, BorderWidth 0, HandleWidth 0
Style "Fvwm*"           CirculateSkip, CirculateSkipIcon, ClickToFocus

then comes 

In 2.2.0 this works okay and I get the window with no resize handles and a
bw of 4
In 2.3.x I don't get a border at all with these same config lines.
I could add a NoHandles line to FvwmIdent but I just wasn't sure what 
caused the change.
Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Mon, 24 May 1999 14:07:31 -0400

Tim Phipps wrote:
> > Tim, any ideas?
> As far as I can tell nothing has changed.

	I just brought up 2.2, and got the same results. I had to add either a
HandleWidth or a NoHandles style to get the desired result. So it seems
that this hasn't changed since 2.2.

- Bob

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 24 May 1999 14:18:58 -0400

> that this hasn't changed since 2.2.

let me try this one more time my config contains the lines:

in fvwm2.0.46 through 2.2 I get a FvwmIdent window with a border of
width 4 and no handles (the desired result). Now in 2.3 I get a widnow
with no border and no handles (not the desired result).

It seems the discrepincy is that HandleWidth 0 used to work and now it
doesn't NoHandles must be used.  So I guess my real question is why did we switch the behavior?

Brad