Subject: DynamicPopupAction not working

From: Tim Phipps <[email-masked]>
Date: Thu, 06 May 1999 13:20:41 +0100

I've got this in my .fvwm2rc:

DestroyMenu StartMenu
AddToMenu StartMenu@130/side.fvwm99.xpm@
+ "&Edit conf   %mini-edit.xpm%"        Popup EditConfMenu

DestroyMenu EditConfMenu
AddToMenu EditConfMenu
+ DynamicPopupAction my_MakeEditConfMenu
+ DynamicPopdownAction FvwmBanner

DestroyFunc my_MakeEditConfMenu
AddToFunc my_MakeEditConfMenu I DestroyMenu ReCreate EditConfMenu
+ I PipeRead 'for i in .X/*; do echo AddToMenu EditConfMenu "&`basename
$i`" Exec fe $i; 
done'

.X/ is where I keep all my config files and `fe' is a script to pop up
an edit window and focus on it.

The StartMenu has the "Edit conf" item but no menu pops out when I go to
it.  If I run the my_MakeEditConfMenu function the submenu is there but
FvwmBanner does not appear when it posp down.  I know fvwm is
recognizing the Dynamic... keywords because if I run 2.2 the submenu has
just the two Dynamic... lines.

Any ideas?

Cheers,
Tim.

PS it's a shame that PipeRead doesn't use $SHELL
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 18:10:12 +0200

> + I PipeRead 'for i in .X/*; do echo AddToMenu EditConfMenu "&`basename

Quoting in the PipeRead might be a bit tricky. I'd start with writing
a shell script instead of a function. You can test a script without
running fvwm. I don't think it matters, but the single quotes after
+ I PipeRead '... are not closed again.

You should start with something more simple perhaps:

AddToMenu my_MakeEditConfMenu DynamicPopupAction Beep

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 06 May 1999 17:41:44 +0100

> + I PipeRead '... are not closed again.

It works with a script!  Must be something funny with the PipeRead line.
The quotes are matched up, my mailer split the line up.  I couldn't get

DestroyMenu ReCreate EditConfMenu

to work, is that how it's supposed to look?

> AddToMenu my_MakeEditConfMenu DynamicPopupAction Beep

I haven't got a beeper 8-)

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 19:28:58 +0200

> + I PipeRead 'for i in .X/*; do echo AddToMenu EditConfMenu "&`basename

Ah, it's so simple: You have to use an absolute path. .X/* works only
if you started fvwm in the proper directory. ~/.X/* should do the trick.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 19:19:17 +0200

> to work, is that how it's supposed to look?

Yes, that's right. I too have still a problem there. I wrote the code
between 1:30 and 4:30 AM, so it might not be completely clean right now :)
I'll clean everything up today.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 11:08:08 +0100

> I'll clean everything up today.

It's all working nicely today, Great work!

Cheers,
Tim.