Subject: Shifted keys in menus

From: Dan Espen <[email-masked]>
Date: Wed, 12 May 1999 15:42:51 -0400

According to the fvwm2 man page, under "Menu":

          Shift-Cursor-Up and Shift-Cursor-Down move to the first
          and  last  items,  respectively;

This doesn't work for me in current CVS or in 2.2.

I wouldn't mind this being pulled from the man page, the only reason
I care, is I was about to make tab advance thru menu entries, and
its logical for shift-tab to go backwards thru menus.  This doesn't
work with the current logic.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 May 1999 11:52:39 +0200

> work with the current logic.

It works on my system. Do you have some fancy keysyms bound to the cursor
keys in your xmodmap?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 May 1999 07:54:34 -0400

> It works on my system. Do you have some fancy keysyms bound to the cursor

Well, I'm not messing with KP_2 (Down) or KP_8 (Up). My xmodmap:

keycode 8=F14
keycode 10=F19 
keycode 33=Prior
keycode 75=KP_7 Home
keycode 77=KP_9
keycode 99=KP_5
keycode 102=Find
keycode 119=End KP_1
keycode 121=KP_3
clear Mod3
keycode 16=F11
keycode 18=F12
keycode 101=Insert KP_0

xkeycaps shows these keysyms:

UpArrow: Up F28 KP_8
DownArrow: Down F34 KP_2

But even shift JKPN have no effect on menus.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 May 1999 14:33:01 +0200

> But even shift JKPN have no effect on menus.

In the output of 'xmodmap -pk' you should get lines like these:

KeyCode     KeySyms
     98     0xff52 (Up) 
    100     0xff51 (Left)   
    102     0xff53 (Right)  
    104     0xff54 (Down)   

Are there additional KeySyms bound to the same KeyCode (with
shift)?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 18 May 1999 11:16:32 -0400

> Are there additional KeySyms bound to the same KeyCode (with

Yep:

mysys> xmodmap -pk
There are 5 KeySyms per KeyCode; KeyCodes range from 8 to 132.

    KeyCode	Keysym (Keysym)	...
    Value  	Value   (Name) 	...

     76    	0xff52 (Up)	0xffd9 (F28)	0xffb8 (KP_8)	
     98    	0xff51 (Left)	0xffdb (F30)	0xffb4 (KP_4)	
    100    	0xff53 (Right)	0xffdd (F32)	0xffb6 (KP_6)	
    120    	0xff54 (Down)	0xffdf (F34)	0xffb2 (KP_2)	

Now that this is finally  clear to me, I  guess its clear that  adding
tab and shift tab to menu navigation requires a little logic to adjust
things before entering the switch statement.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 May 1999 19:35:44 +0200

> things before entering the switch statement.

Did I ever mention that I *hate* the way UNIX and X handle the
keyboard? Grrr, after 20 years of UNIX can't you expect that
vendors have agreed on a common keyboard layout? (no answer
required)

Bye

Dominik ^_^