Subject: XTest stuff

From: Tomas Ogren <[email-masked]>
Date: Wed, 12 May 1999 20:14:13 +0200

Me and a friend hacked up a little program to "emulate" mouse-button
presses through the XTest extension... So I thought that I'd integrate
it with fvwm (checks if you have the extension etc ofcourse), but there
are some issues:

If you for example have ctrl-F1 to activate it, ctrl will also be
pressed when the mouse-event comes (unless you're fast enough to release
ctrl a few usecs later 8), which may or may not be desirable.

One (very lame) way would be to (optionally) send release-events for the
modifiers currently in use, but that would wreck numlock etc if you want
it on...

Anyone got any good ideas? It would be very nice to be able to send
mousebutton events from the keyboard, since we already have cursor
movement...

(currently it works fine for me, since I use it on a very slow box that
takes 0.5-1 sec to start the 'xbutton' program, enough time to release
any modifier)

http://www.ing.umu.se/~stric/code/xbutton/

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Wed, 12 May 1999 21:46:51 +0200

> mousebutton events from the keyboard, since we already have cursor

Use the XKEYBOARD extension. The x faq has a long explanation on
controlling the mouse with the numpad. 
 
-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 13 May 1999 02:00:15 +0200

> controlling the mouse with the numpad. 

Linux(XF86)/Irix: Got it
Solaris/SunOS/AIX: Nope (got XTest tho)

(Not on co-Xist on our NeXT cube either 8)

/Tomas

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 May 1999 11:54:31 +0200

> controlling the mouse with the numpad. 

Matthias, can you write something in the FAQ about this? We had this
question quite a few times now.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]