Subject: bitmap icons broken

From: Matthias Clasen <[email-masked]>
Date: Tue, 11 May 1999 19:30:09 +0200

Bitmap icons don't work with recent CVS.
Trying to iconify xv, I get 

[FVWM][GetIconBitmap]: <<ERROR>> Help! Bad client supplied icon pixmap

The reason is that fvwm wrongly looks for an icon pixmap of the same
depth as the root window and forgets to look for icons of depth 1,
which will be provided via WM_HINTS.
This may be a side-effect of trying to make pixmap icons work with visuals.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 12 May 1999 09:02:07 +0100

> [FVWM][GetIconBitmap]: <<ERROR>> Help! Bad client supplied icon pixmap
Should be fixed now.
Cheers,
Tim.