Subject: Who coded 'FvwmLook' in FvwmButtons?

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 May 1999 13:00:30 +0200

Someone wrote something called 'FvwmLook' in FvwmButtons
(Tim?, Bob?). I have fixed a bug in the relief drawing
of the buttons by using RelieveRectangle from the library
and noticed that this FvwmLook uses RelieveRectangle too.
Could the author check if the relief drawing code can be
simplified? I don't understand what else is done there.
My change is in draw.c, function RelieveButton).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 19 May 1999 12:35:20 +0100

Dominik Vogt wrote:
> (Tim?, Bob?).

It was me. I left the original parts alone when I put in the FvwmLook
stuff. Using RelieveRectangle requires 2 GC's which is OK with FvwmLook
since fvwm provides the two GC's but the original code used one GC. I
think you broke something with the change because FvwmButtons goes black
when I switch desks. I'll have a look to see if I can simplify things.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 May 1999 13:48:09 +0200

> when I switch desks.  I'll have a look to see if I can simplify things.  

Thanks. The 'going black' part has probably to do with another bugfix.
Because the drawing of (partially) empty buttons screwed up when resizing
windows we now clear the complete window before drawing the buttons.
This modifies NormalGC. I thought this was no problem because NormalGC
was changed in other places too, but this assumption seems to be wrong.
The code is in RedrawWindow in FvwmButtons.c. I introduced a ShadowGC
to be called with RelieveRectangle.

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Wed, 19 May 1999 13:03:16 +0100

> windows we now clear the complete window before drawing the buttons.

I changed the following at line 1079 in FvwmButtons.c:

    gcm = GCBackground;
    gcv.foreground = fore_pix;
    gcv.background = back_pix;
    XChangeGC(Dpy,NormalGC,gcm,&gcv);
    XFillRectangle(Dpy,MyWindow,NormalGC,0,0,Width,Height);

to: 

    XClearWindow(Dpy, MyWindow);

Does this work for you?

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 02:16:17 +0200

>     XClearWindow(Dpy, MyWindow);

Yes, looks good. Thank you.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]