Subject: FVWM CVS: fvwm domivogt: * fixed various bugs in dynamic menus; known problems:

From: CVS <[email-masked]>
Date: Thu, 6 May 1999 16:20:55 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/05/06 16:20:55

Modified files:
	.              : ChangeLog NEWS configure.in 
	fvwm           : fvwm2.1 menus.c 
	modules        : ChangeLog Makefile.am 
	modules/FvwmCommand: FvwmCommand.c 
	modules/FvwmEvent: Makefile.am 
	utils          : Makefile.am 

Log message:
* fixed various bugs in dynamic menus; known problems:
- will coredump if a sumbenu is selected and the popdown action destroys the menu
- menu position hints are not recalculated if the menu changes its size
* make BuildXLockMenu executable
* FvwmCommand is now much faster (but doesn't report errors any more)
* Removed FvwmAudio module (replaced with shell script)

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Thu, 6 May 1999 23:53:43 -0400 (EDT)

> * Removed FvwmAudio module (replaced with shell script)

Whoa Dominik,

You're moving too fast for me!  I was thinking about how to put FvwmAudio
compatibility into FvwmEvent, and >boom<, you did it.  So I worked out how
to make FvwmAudio a symlink to FvwmEvent.  Next thing I know, you've
changed FvwmEvent's Makefile.am too!

I committed my changes over top of yours because you did the cut'n'paste
just a little too quickly ;-)  [You forgot to change FvwmRearrange to
FvwmEvent]  

If you prefer the shell script approach, I don't mind.