Subject: Notification: incoming/354

From: [email-masked]
Date: Wed, 19 May 1999 17:23:05 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/354

Message summary for PR#354
	From: [email-masked]
	Subject: Icons changing screen on Restart
	Date: Wed, 19 May 1999 17:22:58 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 02:21:56 +0200

On Wed, May 19, 1999 at 05:23:05PM -0500, [email-masked] wrote:
> >From [email-masked]  Wed May 19 17:23:04 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id RAA15481
> 	for <[email-masked]>; Wed, 19 May 1999 17:22:58 -0500 (CDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Chris Rankin
> Version: 2.3.2
> CVS_Date: 19/5/99
> OS: Linux 2.2.9
> X_Server: XFree86 3.3.3.1
> Submission from: (NULL) (203.12.97.70)
> 
> 
> I restarted FVWM as part of the signal-handling testing, and saw all my
> icons appear
> on my current screen: I have a 3x3 desktop, with a bunch of xterms in (1,1)
> and
> Netscape in (2,1). Restarting FVWM put my minimised Netscape icons on my
> (1,1) screen,
> albeit in the same place apart from that. (I restarted from an xterm in the
> (1,1)
> screen).

Duh, I think that is because of the recent changes I made to force
iconification/deiconification on the current page if the window/icon
is visible. Matthias, do you have an idea what to do here?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Wed, 19 May 1999 23:59:10 -0400

Dominik Vogt wrote:
> 
> >    [Chris wrote: ]
> >
> > I restarted FVWM...and saw all my icons appear on my current screen....
> 

	Ouch!  It's worse than that. I just did an update and a new build a few
minutes ago (first time in a while). Then I did a Restart, and watched
half a dozen windows from desk 1 relocate themselves to desk 0 (where I
did the Restart from). None of these windows was iconic at the time.

	After tediously dragging everything back to where it was supposed to
be, I tried doing the Restart from desk 1, page 1,1 to see what would
happen. Strangely, everything looked ok. It felt so good, I tried it
again. This time, everything disappeared altogether. WindowList showed
that everything had migrated to desk 0, but all the windows were moved
to oddball locations outside of the 4x4 desktop.

	The same thing happens on a Recapture.

	I tried a few more times, with apparently random results. Once, nothing
unusual would happen. Another time, I had 3 or 4 (but not all) of the
windows from desk 0 move to desk 1.

	Icons...? Gee, I dunno, I haven't had the nerve to try to iconify
anything yet.  :-)

- Bob

---

From: Matthias Clasen <[email-masked]>
Date: Thu, 20 May 1999 09:26:22 +0200

Looks like I really broke something when I tried to make Restart come up
with the same viewport...

I can't promise to look into this before tomorrow night. So just don't restart
your fvwm until then :-)

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]