Subject: has bug #42 been fixed?

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 May 1999 20:25:29 +0200

(Recapture and Destroy in funcs can cause heap corruption)

Did the recent path allowing to reuse a FvwnWindow structure
fix this?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Wed, 19 May 1999 15:15:20 -0400

> Did the recent path allowing to reuse a FvwnWindow structure

	Umm...jein.

	This was a two-parter. The reuse-on-Recapture only addressed part 1:
Recapture from a func should be fine now.

	The other issue was what happens when a func tries to destroy itself. I
don't recall seeing anything about that one - has anyone been looking
into this?

- Bob

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 May 1999 21:29:10 +0200

> don't recall seeing anything about that one - has anyone been looking

I've fixed it for menus, but I can't remember if I did anything for
functions after I split the code from the menu code. I'll check that.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 02:15:15 +0200

> functions after I split the code from the menu code. I'll check that.

Functions can't delete themselves anymore, so this report can finally
be closed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]