Subject: minor menu bugs

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 13:52:54 +0100

With today's CVS with the right justified fixes it looks like text in
the titles is being used as the width of the left justified text
length.  Also multiple title lines seem to confuse the menu placement
code. I bind Alt-KP5 to this menu: (there are tabs before the &'s)

NewMenu(ResizeMenu)
+ "Which"			Title
+ "way"				Title
+ "Jim?"			Title
+ ""				Nop
+ "%xtrek_fed_e.xbm%	&7"	my_resize_dir   0   0
+ "%xtrek_fed_0.xbm%	&8"	my_resize_dir  50   0
+ "%xtrek_fed_2.xbm%	&9"	my_resize_dir 100   0
+ "%xtrek_fed_4.xbm%	&6"	my_resize_dir 100  50
+ "%xtrek_fed_6.xbm%	&3"	my_resize_dir 100 100
+ "%xtrek_fed_8.xbm%	&2"	my_resize_dir  50 100
+ "%xtrek_fed_a.xbm%	&1"	my_resize_dir   0 100
+ "%xtrek_fed_c.xbm%	&4"	my_resize_dir   0  50

with:

Key KP_5	WTSF	M	Popup ResizeMenu context c c

There seems to be too much of a gap between the mini-icons and the
hotkeys and when it pops up the pointer is warped to the Jim? title line
rather than the first non-title line. I have TitleUnderlines0 in my menu
style.

Not an important one.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 May 1999 04:26:42 +0200

> rather than the first non-title line. I have TitleUnderlines0 in my menu

Both bugs are fixed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]