Subject: Broken size hints?

From: Dan Espen <[email-masked]>
Date: Thu, 20 May 1999 09:58:27 -0400

This turned up on my console:

[FVWM][GetWindowSizeHints]: <<WARNING>>
   FvwmWinList window 0x5c00002 has broken size hints
Please report this to [email-masked]

Here's the size hint stuff:

fork> xwininfo -size

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x5c00002 "FvwmWinList"

  Normal window size hints:
      User supplied location: 913, 793
      Program supplied size: 367 by 231
      Program supplied x resize increment: 0
      Program supplied y resize increment: 0
      Program supplied window gravity: SouthEastGravity
  No zoom window size hints defined

Heres my FvwmWindowList config:

*FvwmWinListBack CadetBlue
*FvwmWinListFore White
*FvwmWinListFont 7x14bold
*FvwmWinListAction Click1 Iconify -1,WarpToWindow 50 50
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry -0-0

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 20 May 1999 15:20:00 +0100

>       Program supplied y resize increment: 0

This looks like FvwmWinLists way of asking not to be resized.  I don't
think it is sensible to change FvwmWinList to use Max and Min sizes
because it resizes itself, it might be easier to accept resize increment
of 0 to mean don't resize me.  FvwmWinList already sets the motif
no-resize hint so maybe 0 should be treated as 1.

Cheers,
Tim.