Subject: Re: FvwmAudio is obsolete, right?

From: Dominik Vogt <[email-masked]>
Date: Sun, 2 May 1999 01:48:13 +0200

On Fri, Apr 30, 1999 at 10:20:23AM -0700, Michael Han wrote:
> Previously...
> >Dominik Vogt <[email-masked]> writes:
> >> On Thu, Apr 29, 1999 at 10:44:04AM -0400, Steve Robins wrote:
> >> > On Thu, 29 Apr 1999, Dominik Vogt wrote:
> >> > 
> >> > > > If so, how about we make the change, ditch FvwmAudio, and fix up
> >> > > > sample.fvwm2rc not to refer to it anymore?
> >> > > 
> >> > > I have no objections. Of course users shouldn't be required to
> >> > > completely rewrite their config, so if there is a simple way
> >> > > like aliasing FvwmEvent to FvwmAudio...
> >> > 
> >> > Good point.
> >> > 
> >> > I believe that a symlink FvwmAudio -> FvwmEvent would do the trick.  I can
> >> > do the Makefile magic, but I can't test it, as I have no way to play
> >> > sounds... 
> >> 
> >> I can test this if someone sends me a configuration for FvwmAudio
> >> (I never used it myself).
> >
> >*FvwmAudioPlayCmd audioplay
> >*FvwmAudioDir $HOME/audio
> >*FvwmAudio startup doh.au
> >*FvwmAudio shutdown Goodbye.au
> >*FvwmAudio unknown doh.au
> >*FvwmAudio add_window drip.au
> >*FvwmAudio focus_change tap2.au
> >*FvwmAudio destroy_window beep_drop_of_water.au
> 
> IIRC, this won't work right now... It could probably be made to work,
> but I'm pretty sure that there's at least a little bit of twiddling
> that needs to be done to convert from the above to something that'd
> work in FvwmEvent... The situation's not helped by a couple
> documentation errors in the manpage, which are remnants from FvwmAudio
> I think, that are no longer true of FvwmEvent... Most importantly in
> the above, the PlayCmd doesn't exist... You now need to do something
> like
> 
> FvwmEventCmd Exec exec audioplay
> 
> And there's simply no equivalent to FvwmAudioDir...

Doesn't sound as if this backwards compatibilitiy was difficult to achieve.
Steve, would you like to try this?

> This is all based on memories from a couple months ago... I submitted
> a documentation patch way back to fix all these doco bugs, but it
> seems to have been dropped or partially applied.

Er, I though I did apply this. Which parts are missing?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sat, 01 May 1999 20:21:20 -0700

Previously...
>Steve, would you like to try this?

I thought that if FvwmEvent were invoked as FvwmAudio, it should add
the old syntax as options... Didn't seem like it should be too hard,
but I'm no C hacker.

>Er, I though I did apply this. Which parts are missing?

Looking more closely at what's in now (I noticed after you changed
FvwmEvent.1 my local tree still reported "M" status on that file),
there's *still* a bug claiming that you can

*FvwmEventCmd /rsynth/say

or somesuch. It should be:

*FvwmEventCmd Exec /rsynth/say

at the least. And since (last I'd heard) the preferred approach to
Fvwm's Exec was to "Exec exec foo" I also ran through the whole
manpage and replaced every instance of 'exec foo' with 'Exec exec
foo'. I can recreate a patch that does these things pretty easily, if
you agree that these changes are appropriate...
-- 
[email-masked]
Goldfish don't bounce
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 3 May 1999 11:02:20 +0200

> you agree that these changes are appropriate...

I think so. Please go ahead and make the patch.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Mon, 03 May 1999 12:14:17 -0700

Previously...
>> 1999-05-02  Michael Han  <[email-masked]>
>> 
>>         * FvwmEvent/FvwmEvent.c: changes to main(), config(), and
>>         execute_event() for FvwmAudio compatability, namely the
>>         PlayCmd and Dir commands.
>
>Can you create a patch for the FvwmEvent man page too?

Sure, I'll go ahead and make a new diff that includes a manpage patch
too. While I'm at it I'll change the internal "exec " string to "Exec
exec " (PlayCmd needs to have this seeded into the buffer).

>[about updating the manpage with a minor corrections and a correction
>for Exec exec in place of exec]

Okay, I'll roll this into the other manpage update.
-- 
[email-masked]
I will not do anything bad ever again
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 00:49:41 +0200

> Okay, I'll roll this into the other manpage update.

No, forget it. I've applied your patch (with a few modifications) and updated
the manpage already.

Bye

Dominik ^_^

---

From: Michael Han <[email-masked]>
Date: Mon, 03 May 1999 23:15:58 -0700

Previously...
>No, forget it. I've applied your patch (with a few modifications) and updated

Oh, good. Just two nits I thought I might pick, in execute_event(), in
the RPLAY #ifdef, it looks like you've removed PlayDir's compatability
when running with rplay support. Also, there's no handling for PlayDir
not ending in '/', that I could see.
-- 
[email-masked]
My name is not Dr. Death
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 09:29:20 +0200

> not ending in '/', that I could see.

The rplay stuff was not quite correct because you treated a 'RPLAY *'
like a 'char *'. However, RPLAY is a struct with more than a dozen
members. So I peeked at FvwmAudio and saw that the FvwmAudioPlayDir
isn't used for rplay at all and thus I removed it from FvwmEvent too.
The ending '/' is now hard coded into the sprintf command. This is
a byproduct of some meory leak and coredump fixes.

Mike, could you have a look at the man page? I hacked it in in a few
minutes. Is this understandable? Well, and since you seem to have
used FvwmAudio/FvwmEvent it would be nice if you helped testing.

Bye

Dominik ^_^