Subject: More about ConstrainSize

From: Matthias Clasen <[email-masked]>
Date: Fri, 7 May 1999 09:55:44 +0200

While playing with size hints, I found another small problem with 
ConstainSize. It can be called with a flag that tells it to
increase the size rather than decrease it. But this may not be
possible if the size you give it is already larger than the largest
preferred one. A (somewhat constructed ) example:

base 90 90
max 100 100
inc  30 30

if you try to resize the window interactively, fvwm will let you increase
the size up to 120 120, since you can get 100 100 as input to ConstrainSize
and it will then round up to base + inc.

There are two competing goals which cannot be satisfed at the same time:
* not decreasing the size 
* using a preferred size for the program

With the current implementation, the first goal wins, but I'd say we should
change this to let the second one win. Any objections ?

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 May 1999 14:26:03 +0200

> change this to let the second one win. Any objections ?

No, sound sensible.

What will happen when we write a MaxWindowSize option as suggested in a
different thread? Do you understand the implications, Matthias? (I.e.
I do not).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 18 May 1999 08:14:52 +0200

> different thread? Do you understand the implications, Matthias? (I.e.

I don't remember that. But I have changed your ResizeHintOverride
to override all resize hints, not just some. Maybe that is related ?

Or was MaxWindowSize about specifying different values for the hints
via a style option ?

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 May 1999 11:06:00 +0200

> Or was MaxWindowSize about specifying different values for the hints

I don't remember either. I had hoped you knew that code better after
looking into it recently.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 18 May 1999 11:21:56 +0200

> looking into it recently.

I know the code, just not what MaxWindowSize was supposed to do.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 May 1999 11:43:23 +0200

> I know the code, just not what MaxWindowSize was supposed to do.

Ah, it should limit the size of newly created windows (we discussed that
in a different thread).

Bye

Dominik ^_^