Subject: Re: Do all the man pages using "find" and generate the man page index.

From: Dan Espen <[email-masked]>
Date: Sat, 01 May 1999 09:44:30 -0400

Jason L Tibbitts III <[email-masked]> writes:
> >>>>> "DE" == Dan Espen <[email-masked]> writes:
> 
> DE> I'm just being compulsive with using full paths.
> 
> I usually am, too.  But then different operating systems like to put things
> all over the place, so for portable scripts I end up setting $PATH to the
> collection which works on all of the various platforms I have to use.
> 
> DE> Are find and cut in your path?  If so, the fix should be easy.
> 
> Yes.

Good.  The last committed fix assumes they are in your path.

> DE> The "cut" is needed to get the man page names to not include the ".1".
> 
> Hmmm.  I guess I've been using zsh way too long; doing stuff like that is
> an expansion:
> 
> XYX:epithumia:~> i=blah.1; echo ${i%.1} 
> blah

My original version was ksh based, I used the same technique.  Anyway,
it wasn't the cut not in the path, causing the ".1" to be left behind,
it was my error in the conversion from ksh.  This should be fixed.

> DE> No, "man" won't take a full path.
> 
> On Linux it does:
> 
> XYX:epithumia:~/fvwm/fvwm> man fvwm2.1
> No manual entry for fvwm2.1
> 
> XYX:epithumia:~/fvwm/fvwm> man ./fvwm2.1 
> 
> FVWM2(2.xx)                                           FVWM2(2.xx)
> 
> NAME
>        fvwm2 - F(?) Virtual Window Manager (version 2.xx) for X11

Hmm, one more portability trap.  Anyway, using "nroff" seems like a
better way to go.

> DE> I'm not sure what you mean about running this script for every new
> DE> release.
> 
> Well, every "release" release.  I.e. not testing or beta releases, at least
> after 2.2 came out.  Before then I did run it for every beta but now
> there's not much point.

Good.

Let me know if this latest attempt gives you any problems.

>  - J<
> --

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sat, 01 May 1999 20:26:30 -0700

Previously...
>DE> No, "man" won't take a full path.

On every platform I've ever worked on, 'man -M . foo.1' has worked
fine for me.
-- 
[email-masked]
I will remember to take my medication
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 01 May 1999 22:33:43 -0500

>>>>> "MH" == Michael Han <[email-masked]> writes:

MH> On every platform I've ever worked on, 'man -M . foo.1' has worked fine
MH> for me.

Not Solaris.  Solaris man is _horrible_.

 - J<

---

From: Tomas Ogren <[email-masked]>
Date: Mon, 3 May 1999 03:27:22 +0200

> On every platform I've ever worked on, 'man -M . foo.1' has worked

Every linux platform, or what? 8)

[ior] stric:~/gnome/man/man1>ls mc.1
mc.1
[ior] stric:~/gnome/man/man1>man -M . mc.1
No manual entry for mc.1.
[ior] stric:~/gnome/man/man1>uname -a
SunOS ior.acc.umu.se 5.6 Generic_105181-12 sun4m sparc

the same on AIX 4.3.2

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Sun, 02 May 1999 20:39:21 -0700

Previously...
>[And Jason said much the same thing]

bizarre... I could swear I've had this work for me on Solaris... and
probably IRIX too.

[refreshes memory]

Ah hah! that would have been 'man -M .. foo'.

michaelh@pine:/export/home/michaelh/man/man1
<22> ls vim.1
vim.1
michaelh@pine:/export/home/michaelh/man/man1
<23> uname -a
SunOS pine 5.5.1 Generic_103640-24 sun4u sparc SUNW,Ultra-2
michaelh@pine:/export/home/michaelh/man/man1
<24> man -M .. vim
Reformatting page.  Wait... done

No longer recall whether this is useful to know or not...
-- 
[email-masked]
No one is interested in my underpants
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]