Subject: [[email-masked]: [[email-masked]: Re: new button states]]

From: Matthias Clasen <[email-masked]>
Date: Sun, 23 May 1999 21:24:42 +0200

------- Start of forwarded message -------
X-Authentication-Warning: DarkSun.nodomain: avatar set sender to [email-masked] using -f
Date: Sun, 23 May 1999 15:47:20 +0200
From: Dominik Vogt <[email-masked]>
To: Matthias Clasen <clasen@pong>
Subject: [[email-masked]: Re: new button states]
Reply-To: [email-masked]
Content-Type: text/plain; charset=us-ascii

Sorry, nachdem Jason meine mail abgeklemmt hat muss ich das persoenlich an Dich
schicken. Kannst Du die Mail an die Liste forwarden?

Ciao

Domi ^_^

- ----- Forwarded message from Dominik Vogt <[email-masked]> -----

Date: Sun, 23 May 1999 15:00:19 +0200
From: Dominik Vogt <[email-masked]>
To: [email-masked]
Subject: Re: new button states
Reply-To: [email-masked]
Mail-Followup-To: [email-masked]
X-Mailer: Mutt 0.93.1i
In-Reply-To: <[email-masked]>; from Matthias Clasen on Sun, May 23, 1999 at 12:48:34AM +0200

On Sun, May 23, 1999 at 12:48:34AM +0200, Matthias Clasen wrote:
> 
> I have just committed a patch which adds three new button states to the 
> TitleButton struct. 
> This eats up most of the memory savings which I achieved by shrinking the 
> ButtonFace struct, but I think it is worth it. Since the toggled states
> will only be used for maximize, shade and stick buttons, it may be
> a good idea to change the TitleButton struct in a way so that button 
> states are only allocated for buttons which need them.  
> 
> Here is a little example showing the new button facilities in action: 
> 
> AddToDecor Default
>  + ButtonStyle 6 ActiveUp          Vector 4 50x25@1 85x75@0 15x75@0 50x25@1 
>  + ButtonStyle 6 ActiveDown        Vector 4 50x25@1 85x75@0 15x75@0 50x25@1 
>  + ButtonStyle 6 Inactive          Vector 4 50x25@1 85x75@0 15x75@0 50x25@1 
>  + ButtonStyle 6 ToggledActiveUp   Vector 4 50x75@0 85x25@1 15x25@0 50x75@0 
>  + ButtonStyle 6 ToggledActiveDown Vector 4 50x75@0 85x25@1 15x25@0 50x75@0 
>  + ButtonStyle 6 ToggledInactive   Vector 4 50x75@0 85x25@1 15x25@0 50x75@0 
>  + ButtonStyle 6 - MWMDecorShade
>  + ButtonStyle 8 - MWMDecorStick
> Mouse 0 6 N WindowShade
> Mouse 0 8 N Stick

Do I have to change my config for the Shade button now? At the
moment it looks like this:

  ButtonStyle 6    Vector 5 25x35@1 75x35@1 75x40@0 25x40@0 25x35@1
  ButtonStyle 6    - MWMDecorShade
 
Bye

Dominik ^_^

- --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

- ----- End forwarded message -----

Bye

Dominik ^_^

- --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
------- End of forwarded message -------

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 23 May 1999 14:58:00 -0500

>>>>> "MC" == Matthias Clasen <[email-masked]> writes:

MC> Sorry, nachdem Jason meine mail abgeklemmt hat muss ich das persoenlich
MC> an Dich schicken. Kannst Du die Mail an die Liste forwarden?

This is getting old.  I explicitly left [email-masked] unblocked
so Dominik could still post (which unfortunately resulted in both lists
getting spammed), and I've already set up things to unblock all of
01019freenet.de's dialups at fvwm.org.

At this point Dominik should be able to post.

 - J<