Subject: FVWM CVS: fvwm domivogt: * comment how to turn XORpixmap off.

From: CVS <[email-masked]>
Date: Tue, 4 May 1999 18:24:05 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/05/04 18:24:04

Modified files:
	.              : ChangeLog 
	fvwm           : builtins.c fvwm2.1 move_resize.c 
	utils          : BuildXLockMenu 

Log message:
* comment how to turn XORpixmap off.
* removed debugging code.
* access of freed pointer fixed.
* applied patch by Mikhael Goikhman to utils/BuildXLockMenu
* fixed move/page fix

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 6 May 1999 02:00:57 +0300 (IDT)

> * applied patch by Mikhael Goikhman to utils/BuildXLockMenu

Here is a patch, which restores commented pod (perl inline documentation)
and corrects typos in it.
Since a man page can be generated from this pod, I think that fvwm must
install also BuildXLockMenu.1 with BuildXLockMenu.

There are two solutions. Having a static man page file after executing:
  pod2man --center "fvwm utils" BuildXLockMenu >BuildXLockMenu.1
and then adding utils/BuildXLockMenu.1 to the current CVS and Makefile.am
or generating dynamically BuildXLockMenu.1 in a makefile.
I think the solution with a static man page is simpler and good enough.
                                                                      
Regards,
Mikhael.

This patch restores pod (perl inline documentation).
Pipe it to 'patch'.

You can get a man page from pod (if you have perl installed):
  pod2man --center "fvwm utils" BuildXLockMenu >BuildXLockMenu.1
  nroff -man BuildXLockMenu.1 | less

--- BuildXLockMenu.orig	Wed May  5 14:30:56 1999
+++ BuildXLockMenu	Thu May  6 00:59:56 1999
@@ -4,45 +4,48 @@
-#
-# NAME
-#
-#   BuildXLockMenu -
-#     builds xlock menu definition for Fine Virtual Window Manager
-#
-# SYNOPSIS
-#
-#   BuildXLockMenu [ --menu-name name ] [ --menu-title title ]
-#                  [ --menu-icon icon ] [ xlock params ]
-#
-# DESCRIPTION
-#
-#   A simple perl script which parses xlock's output to build an fvwm 2.xx
-#   menu definition of all xlock's modes.
-#
-# Argument list
-#
-#   Arguments used by the script (must be first):
-#
-#   --menu-name, --menu-title, --menu-icon - define menu name, title
-#   and mini-icon acordingly given in the following argument. Default is name
-#   "XLockMenu", title "XLock Modes" and no mini-icon.
-#
-#   Additional arguments will be passed to xload.
-#
-# USAGE
-#
-# # add these lines to .fvwm2rc:
-# PipeRead 'BuildXLockMenu --menu-name Screensaver --menu-title \
-#   "Screensaver" --menu-icon mini-bball.xpm -nice 20 -nolock'
-# PipeRead 'BuildXLockMenu --menu-name Screenlock --menu-title \
-#   "Lock Screen" --menu-icon mini-rball.xpm -nice 20'
-# AddToMenu "Utilities" "Screensaver%mini-monitor.xpm%" Popup Screensaver
-# AddToMenu "Utilities" "Screenlock%mini-lock.xpm%"     Popup Screenlock
-#
-# AUTHORS
-#
-#   Charles K. Hines <[email-masked]>, initial version.
-#   Mikhael Goikhman <[email-masked]>, 24 Feb 1999.
-#
-# BUGS
-#
-#   Depends on the output of 'xlock -h'. Will produce an empty menu, if the
-#   structure of the output is changed.
+
+=head1 NAME
+
+BuildXLockMenu - builds xlock menu definition for Fine Virtual Window Manager
+
+=head1 SYNOPSIS
+
+B<BuildXLockMenu> [B<--menu-name> name] [B<--menu-title> title]
+[B<--menu-icon> icon] [xlock params]
+
+=head1 DESCRIPTION
+
+A simple perl script which parses xlock's output to build an fvwm 2.xx
+menu definition of all xlock's modes.
+
+=head2 Argument list
+
+Arguments used by the script (must be first):
+
+B<--menu-name>, B<--menu-title>, B<--menu-icon> - define menu name, title
+and mini-icon accordingly given in the following argument. Default is name
+"XLockMenu", title "XLock Modes" and no mini-icon.
+
+Additional arguments will be passed to xlock.
+
+=head1 USAGE
+
+ # add these lines to .fvwm2rc:
+ PipeRead 'BuildXLockMenu --menu-name Screensaver --menu-title \
+   "Screensaver" --menu-icon mini-bball.xpm -nice 19 -nolock'
+ PipeRead 'BuildXLockMenu --menu-name Screenlock --menu-title \
+   "Lock Screen" --menu-icon mini-rball.xpm -nice 19'
+ AddToMenu "Utilities" "Screensaver%mini-monitor.xpm%" Popup Screensaver
+ AddToMenu "Utilities" "Screenlock%mini-lock.xpm%"     Popup Screenlock
+
+=head1 AUTHORS
+
+ Charles K. Hines <[email-masked]>, initial version.
+ Mikhael Goikhman <[email-masked]>, 24 Feb 1999.
+
+=head1 BUGS
+
+Depends on the output of xlock. Will produce an empty menu if the structure
+of the output is changed.
+
+=cut
+
+# ===========================================================================

---

From: Steve Robbins <[email-masked]>
Date: Fri, 7 May 1999 00:58:08 -0400 (EDT)

> I think the solution with a static man page is simpler and good enough.

I agree with the static man page.  I'm committing the makefile magic to do
so.

There are some other problems with utils/Makefile.am:

* someone added fvwm_make_browse_menu.sh but neglected to check the file
  in to CVS

* both BuildXLockMenu and fvwm_make_browse_menu.sh got added to
  bin_SCRIPTS meaning they will be installed into $prefix/bin

  Q: are these really something one wants installed into /usr/local/bin?  
  They don't appear to be something I'd be interested in running from my
  shell.  I'd rather stuff them into $moduledir with the rest of the 
  FVWM-only executables.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 10:15:09 +0100

>   shell.  I'd rather stuff them into $moduledir with the rest of the

I put BuildXLockMenu in the Makefile.am because it's a perl script and I
wanted to get the location of perl from autoconf.  I stole the stuff
from FvwmCommand.pl to do it. I don't mind where it gets installed but
it is not a module so putting in in $MODULEDIR would mean you have to
call it as "Exec $MODULEDIR/BuildXLockMenu".

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 7 May 1999 12:04:21 +0200

> * someone added fvwm_make_browse_menu.sh but neglected to check the file

Sorry, fixed.

>   shell.  I'd rather stuff them into $moduledir with the rest of the 

fvwm_make_browse_menu.sh is in bin_SCRIPTS simply because BuildXLockMenu
was there already. If there is a better place, feel free to change it.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Fri, 7 May 1999 09:41:45 -0400 (EDT)

On Fri, 7 May 1999, Tim Phipps wrote:

> from FvwmCommand.pl to do it.
       ^^^^^^^^^^^^^^ you meant FvwmConsoleC.pl, probably :-)

Right.  I'm not questioning this aspect of it.

However, you don't need to install the script in order to substitute 
the value of @PERL@.  You could list it as

	noinst_SCRIPTS = BuildXLockMenu

for example, to get it built but not installed.

BuildXLockMenu has never been installed before.  When I was converting
from Imakefiles, I took this as a sign that the script was intended mostly
as a demo of what could be achieved by ReadPipe.

Now, I don't _mind_ that it gets installed.  It could be useful to
someone.  But probably it is only useful if called from FVWM's PipeRead,
so it doesn't need to be put into ${prefix}/bin.

> I don't mind where it gets installed but

Yup.  Or we can stick $MODULEDIR onto the end of PATH during startup.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 15:05:33 +0100

>         noinst_SCRIPTS = BuildXLockMenu

I didn't know about the noinst_.  I'll change it.

Cheers,
Tim.