Subject: [[email-masked]: [[email-masked]: Re: InitFunc spawns new applications during a restart]]

From: Matthias Clasen <[email-masked]>
Date: Sun, 23 May 1999 21:27:14 +0200

------- Start of forwarded message -------
X-Authentication-Warning: DarkSun.nodomain: avatar set sender to [email-masked] using -f
Date: Sun, 23 May 1999 15:47:48 +0200
From: Dominik Vogt <[email-masked]>
To: Matthias Clasen <clasen@pong>
Subject: [[email-masked]: Re: InitFunc spawns new applications during a restart]
Reply-To: [email-masked]
Content-Type: text/plain; charset=us-ascii

(siehe Bemerkung zu meiner anderen Mail)

- ----- Forwarded message from Dominik Vogt <[email-masked]> -----

Date: Sun, 23 May 1999 14:38:42 +0200
From: Dominik Vogt <[email-masked]>
To: [email-masked]
Subject: Re: InitFunc spawns new applications during a restart
Reply-To: [email-masked]
Mail-Followup-To: [email-masked]
X-Mailer: Mutt 0.93.1i
In-Reply-To: <[email-masked]>; from Matthias Clasen on Sat, May 22, 1999 at 11:02:22PM +0200

On Sat, May 22, 1999 at 11:02:22PM +0200, Matthias Clasen wrote:
> 
> Sorry, I  can reproduce neither this nor any moving windows, icons
> or viewports when restarting. I have tried it with and without a
> session manager running. For me, restarting just works...
> It would be interesting to know the cmdline args handed over to
> the restarting instance of fvwm. Does the old instance create
> a proper ~/.fvwm_restart file ?

Without fvwm starting up at all I can't answer this right now.
I don't use session management. BTW, how do you enable session
management? The configure option seems to have gone, but SESSION
is defined in config.h. I don't know if ~/.fvwm_restart is created,
but I don't have it anywhere in my home directroy, so unless it's
deleted after the restart I guess that means it's never written.

Bye

Dominik ^_^

- --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

- ----- End forwarded message -----

Bye

Dominik ^_^

- --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
------- End of forwarded message -------

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 23 May 1999 21:34:51 +0200

> management? The configure option seems to have gone, but SESSION

autoconf detects the presence of libSM and libICE on your system
and defines SESSION accordingly. But the parts of session.c which are
needed for the new way of restarting are compiled in unconditionally.

> deleted after the restart I guess that means it's never written.

fvwm doesn't try to delete it.