Subject: Notification: incoming/331

From: [email-masked]
Date: Thu, 6 May 1999 08:37:08 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/331

Message summary for PR#331
	From: [email-masked]
	Subject: Align right in menus is buggy
	Date: Thu, 6 May 1999 08:37:06 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 23:48:17 +0200

On Thu, May 06, 1999 at 08:37:08AM -0500, [email-masked] wrote:
> The current man page states:
> 
>           All text up to the first  TAB  in  the  menu  label  is
>           aligned to the left side of the menu, all text right of
>           the first TAB is aligned to the right side.  All  other
>           TABs are replaced by spaces.
> 
> To me this implies that putting a leading TAB in front of the item name
> gives right-justification but it doesn't. Try the following (the big
> gaps are TABS and will probably come over as spaces)

I think the man page is misleading. Only the item with the widest text
behind the tab is right justified, all others have their 'right' text
beginning in the same column like this:

+------------------------------------+
|longest left text.                  |
|                 .longest right text|
|                 .another           |
|                 .item              |
|                 .with              |
|                 .right             |
|                 .aligned           |
|                 .text              |
|                 .                  |
+------------------------------------+

There were some other bugs, though. The man page should be less
ambiguous.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 07 May 1999 11:36:44 +0100

> beginning in the same column like this:

This is fixed now _except_ if you have a side pic. It looks like right
justified menu items have the width of the side pic added in twice.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 May 1999 04:07:34 +0200

> justified menu items have the width of the side pic added in twice.

Fixed.

Bye

Dominik ^_^