Subject: Signal handlers broken

From: Dominik Vogt <[email-masked]>
Date: Sat, 22 May 1999 17:40:16 +0200

The new signal handling code terminates my fvwm before
it even starts up properly. The only this it seems to
do is running FvwmCpp over my config file (started from
the command line), then it terminates without an error
message.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 23 May 1999 16:40:31 +0200

Hi Chris,

On Sun, May 23, 1999 at 08:08:43AM +1000, Chris Rankin wrote:
> What platform are you running on? Which autoconf macros does your
> configuration use? Does your system support sigaction(), or are you
> using signal()? The older signal() code hasn't been tested, but I am
> running the sigaction() stuff without difficulty. How far does your
> fvwm get before it quits? Can you see why its quitting?

I've stepped through the code with gdb and found it exits with a
broken pipe at fvwm.c (FlushQueue), line 1034:

  a = write(writePipes[module],&dptr[d->done], d->size - d->done);

FlushQueue is called from My_XNextEvent (events.c, line 1760).
So this might not be related to signal handling at all. Fvwm
starts properly if I don't run FvwmCpp from the command line.
Could you please forward this mail to the fvwm-workers list (I
can't send mail to the list at the moment).

Bye

Dominik ^_^