Subject: coredump in module.c

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 00:03:54 +0200

When I try to run FvwmEvent with 'Module FvwmEvent FvwmAudio' I
get a coredump in Module.c:

Core was generated by `/home/avatar/bin/fvwm2/FvwmEvent 11 4 none 0 8 FvwmAudio'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  0x40133df2 in chunk_alloc (ar_ptr=0x4018e300, nb=16) at malloc.c:2616
malloc.c:2616: No such file or directory.
(gdb) where
#0  0x40133df2 in chunk_alloc (ar_ptr=0x4018e300, nb=16) at malloc.c:2616
#1  0x40133d15 in __libc_malloc (bytes=1) at malloc.c:2561
#2  0x804aa56 in safemalloc (length=0) at safemalloc.c:33
                 ^^^^^^^^^^^^^^^^^^^^^
#3  0x80498db in ReadFvwmPacket (fd=4, header=0xbffff1f8, body=0x804e688)
    at Module.c:59
#4  0x8049a81 in GetConfigLine (fd=0x80509e4, tline=0xbffff23c) at Module.c:160
#5  0x8049301 in config () at FvwmEvent.c:429
#6  0x8048f74 in main (argc=7, argv=0xbffff784) at FvwmEvent.c:264

Is this caused by the gsfr related module code? I've made a dirty
hack to prevent this, this should be taken out when this is fixed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 May 1999 00:50:36 +0200

> get a coredump in Module.c:

Argh, forget it. I didn't want to send this mail, that was my
fault.

Bye

Dominik ^_^