Subject: CVS: clasen: fix unmaximization.

From: CVS <[email-masked]>
Date: Wed, 12 May 1999 14:45:44 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	clasen	99/05/12 14:45:44

Modified files:
	.              : ChangeLog 
	fvwm           : builtins.c 

Log message:
fix unmaximization.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 May 1999 00:21:59 +0200

> Changes by:	clasen	99/05/12 14:45:44

I'm not sure if this is something what you worked on, but now I see
this big:

  1) Enlarge a window until it is at least three pages wide.
  2) Move it off the left desk boundary until only a few pixels are
     left visible.
  3) Iconify it.
  4) Deiconify the window.

  ==> The window moves at least a full page to the right.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 17 May 1999 16:57:24 +0200

>   ==> The window moves at least a full page to the right.

No, I guess the prize for introducing this bug goes to you :-)
since according to the logs, you introduced IsRectangleOnThisPage
in AutoPlaceIcon. I've fixed it.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 May 1999 17:01:37 +0200

> in AutoPlaceIcon. I've fixed it.

Hah, I'm the undisputed bug-creating leader already. One more or
less doesn't really matter 8-)

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]