Subject: heterogenous monitor sizes: command line args to the .fvwm2rc

From: [email-masked]
Date: Wed, 19 May 1999 13:59:23 -0500 (CDT)

Full_Name: Neil Zanella
Version: 2.2.0
CVS_Date: 
OS: Linux 2.0.36
X_Server: XFree86 3.3.2
Submission from: (NULL) (134.153.17.78)

Hello,

It would be nice if the .fvwm2rc script took command line
arguments so that when I restarted I could pass it different
variables. These variables would then be used in the .fvwm2rc
file.

Consider the following scenario:
I have access to many Linux boxes, each one with a different
monitor size. To preserve the nice look of my desktop, each
time I use a different resolution I have to adjust the size of
the pager and the buttonbox so that they don't look too small 
or too big. The same applies to the size of window frames/borders
so that they may be easily grabbed without being too large.

If Fvwm had command line variables then I could restart it with
a different set of variables by choosing an appropriate screen size in
the restart menu. These could in turn be passwd to the M4 processor
or something so that all substitutions take place.

The worse thing is that when fvwm starts it has no way of 
determining the screen size. Not even dmesg or anything on the system will
tell you that, Of coursem, I could have M4 get an IP address and
assume that each IP address has a different monitor with a different
monitor size. This could be quite a lot to maintain.

There's gotta be a way to have a script maintain proportionality
when our home dir has the .fvwm2rc which is mounted with NFS
across a system with heterogenous monitor sizes.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 12:50:35 +0200

> across a system with heterogenous monitor sizes.

This is already possible by using the preprocessor modules.
You can give FvwmCpp/M4 command line arguments that allow to
define variables that are used in the preprocessor run:

  fvwm2 -cmd "Fvwmcpp -DDTWIDTH=1024 -DDTHEIGHT=768 $HOME/.fvwm2rc"

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 20 May 1999 08:12:06 -0400

>   fvwm2 -cmd "Fvwmcpp -DDTWIDTH=1024 -DDTHEIGHT=768 $HOME/.fvwm2rc"

Actually that won't help him, he'll need to put that in a script to
calculate width and height for each machine. instead you wan't FvwmM4.
from the man page:

     FvwmM4 defines some values  for  use  in  the  pre-processor
     file:

     WIDTH
          The screen width in pixels.

     HEIGHT
          The screen height in pixels.

So all I do is fvwm2 -cmd "FvwmM4 .fvwm2rc"

and from my rc I do this for example

*IconManButtons(Swallow(NoClose,UseOld) "All_windows" `Module \
FvwmIconMan`, Size WIDTH 14)

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 15:53:09 +0200

On Thu, May 20, 1999 at 08:12:06AM -0400, [email-masked] wrote:
> calculate width and height for each machine.

That was only an example. Of course you can write it like this:

  fvwm2 -cmd "Fvwmcpp -DDTWIDTH=`some_command` -DDTHEIGHT=`other_command` $HOME/.fvwm2rc"

Bye

Dominik ^_^

---

From: [email-masked]
Date: 20 May 1999 23:24:35 +0200

> So all I do is fvwm2 -cmd "FvwmM4 .fvwm2rc"
       ^^^

Don't forget to quote all words recognized as special by m4, or use
the m4_ prefix thing.

kai
-- 
Abort this operation?   [Abort]  [Cancel]