Subject: Re: Signal handlers broken (fwd)

From: Chris Rankin <[email-masked]>
Date: Mon, 24 May 1999 01:17:41 +1000 (EST)

Forwarded message:

---

From: Tim Phipps <[email-masked]>
Date: Mon, 24 May 1999 12:50:53 +0100

> From: Dominik Vogt <[email-masked]>
> I've stepped through the code with gdb and found it exits with a
> broken pipe at fvwm.c (FlushQueue), line 1034:
> 
>   a = write(writePipes[module],&dptr[d->done], d->size - d->done);

(I think you mean module_interface.c not fvwm.c) but anyway fvwm should
not be getting a SIGPIPE here, the pipe should be non-blocking and the
write should return a negative value. I've looked in FvwmCpp and it
doesn't close the pipes but it doesn't read either so the error should
be E_WOULDBLOCK.

Sorry I can't help,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]