Subject: [[email-masked]: Re: InitFunc spawns new applications during a restart]

From: Matthias Clasen <[email-masked]>
Date: Mon, 24 May 1999 21:44:16 +0200

------- Start of forwarded message -------
X-Authentication-Warning: DarkSun.nodomain: avatar set sender to [email-masked] using -f
Date: Sun, 23 May 1999 17:26:47 +0200
From: Dominik Vogt <[email-masked]>
To: Matthias Clasen <clasen@pong>
Subject: Re: InitFunc spawns new applications during a restart
Reply-To: [email-masked]
Content-Type: text/plain; charset=us-ascii
In-Reply-To: <[email-masked]>; from Matthias Clasen on Sat, May 22, 1999 at 11:02:22PM +0200

On Sat, May 22, 1999 at 11:02:22PM +0200, Matthias Clasen wrote:
> 
> Sorry, I  can reproduce neither this nor any moving windows, icons
> or viewports when restarting. I have tried it with and without a
> session manager running. For me, restarting just works...
> It would be interesting to know the cmdline args handed over to
> the restarting instance of fvwm. Does the old instance create
> a proper ~/.fvwm_restart file ?

(Please forward my reply to the list)

The problem is this:

I call Restart without parameters, but the command argument
to Done() is an empty string, not NULL, so the RestartInSession
function is not called and thus no .fvwm_restart file is
generated. Now the new fvwm thinks it's not been restarted and
calls InitFunc instead of RestartFunc. Creating an empty
.fvwm_restart file fixes my problem.

Bye

Dominik ^_^

- --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
------- End of forwarded message -------

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 24 May 1999 23:22:09 +0200

> function is not called and thus no .fvwm_restart file is

Ah, I've overlooked that. It's fixed now.
 
> .fvwm_restart file fixes my problem.

I don't think so...you would also have to make sure that the
new instance is started with -restore ~/.fvwm_restart. And even
even if the new instance detects that it is restarted, it won't be
able to restore a lot of state from an empty file...
but as i said, Restart without args should work now.

Matthias