Subject: Re: FvwmAudio is obsolete, right?

From: Michael Han <[email-masked]>
Date: Wed, 05 May 1999 22:04:50 -0700

Previously...
>> >Mike, could you have a look at the man page? I hacked it in in a few
>> >minutes. Is this understandable? Well, and since you seem to have
>> >used FvwmAudio/FvwmEvent it would be nice if you helped testing.

I found one typo. I figured the "bug" listed about not passing
event-specific parameters was fixed in PassID, so I removed the bug. I
also removed the old FvwmAudio Compatability notes, since it talks
about incompatabilities... it's now fully backwards compatible.
Finally, I moved the invocation section above config, as that makes
more (to me, at least) sense, and it's what the other module manpages
seem to do. This allows the Audio Compatability section to be closed
up with the rest of the config, making it generally a little better
organized, I think. Anyway, context diff is attached. Changelog entry
directly below:

1999-05-05  Michael Han  <[email-masked]>

        * modules/FvwmEvent/FvwmEvent.1: some updates to reflect the
        latest changes, as well as some reorganization.
-- 
[email-masked]
Nobody likes sunburn slappers
 - The collected wisdom of Bart Simpson

*** FvwmEvent.1.orig	Wed May  5 21:34:49 1999
--- FvwmEvent.1	Wed May  5 21:46:58 1999
***************
*** 44,49 ****
--- 44,67 ----
  \fIFvwmEvent\fP can also have builtin support for the rplay library.
  (heritage of FvwmAudio)
  
+ .SH INVOCATION
+ The invocation method was shown in the synopsis section. No command
+ line invocation is possible. \fIFvwmEvent\fP must be invoked by the
+ \fIfvwm2\fP window manager. \fIFvwmEvent\fP accepts a single
+ argument:
+ 
+ .IP \-audio
+ Enables FvwmAudio compatibility mode.
+ 
+ .IP alias
+ Makes FvwmEvent use \fIalias\fP as its name. This affects which lines
+ from the user's configuration file are used.
+ 
+ Invoking FvwmEvent as \fIFvwmAudio\fP (either by using an alias or
+ creating a symlink) enables FvwmAudio compatibility mode.
+ 
+ .sp
+ 
  .SH CONFIGURATION OPTIONS
  \fIFvwmEvent\fP reads the same \fI.fvwm2rc\fP file as \fIfvwm2\fP
  reads when it starts up, and looks for certain configuration options:
***************
*** 190,245 ****
  Specifies what volume will be assigned to the sounds when they are
  played.
  
- .SH INVOCATION
- The invocation method was shown in the synopsis section. No command
- line invocation is possible. \fIFvwmEvent\fP must be invoked by the
- \fIfvwm2\fP window manager. \fIFvwmEvents\fP accepts a single
- argument:
- 
- .IP \-audio
- Enables FvwmAudio compatibility mode.
- 
- .IP alias
- Makes FvwmEvent use \fIalias\fP as its name. This affects which lines
- from the user's configuration file are used.
- 
- Invoking FvwmEvent as \fIFvwmAudio\fP (either by using an alias or
- creating a symlink) enables FvwmAudio compatibility mode.
- 
- .sp
- 
- .SH FvwmAudio Compatibility
- 
- FvwmAudioPlayCmd used to call an external program.
- FvwmEventCmd calls an \fIfvwm2\fP function. External programs can be called
- using the \fIfvwm2\fP exec function "exec program".
- 
- FvwmAudioDir has been removed due to the fact that the parameters
- don't have to be files any more.
- use:
- .nf
- .sp
- 	DestroyFunc mysay
- 	AddToFunc mysay "I" exec /rsynth/say /rsynth/audiofiles/$1
- 
- 	*FvwmEventCmd mysay
- .sp
- .fi
- .SH BUGS
- It's REALLY noisy when \fIfvwm2\fP starts and restarts using an audio player.
- FvwmEventDelay helps a little bit.
- 
- The parameters inherent to several events are not accessible. This
- might be implemented in the future so that the command executed by
- fvwm2 looks like FvwmEventCmd FvwmEvent-parameters
- event-specific-parameters.
- 
- Simple \fIFvwmAuto\fP could then be emulated by:
- .nf
- 	*FvwmEventCmd
- 	*FvwmEvent raise-window Raise
- .sp
- .fi
  .SH FvwmAudio Compatibility Mode
  
  When invoked in FvwmAudio compatibility mode (see above), FvwmEvent
--- 208,213 ----
***************
*** 247,260 ****
  for FvwmAudio:
  
  .IP "*FvwmEventPlayCmd \fIcommand\fP"
! This is equivalent to using *FvwmEventCmd. This determines the
! independent audio player program that will actually play the sounds.
! If the play command is set to \fIbuiltin-rplay\fP then the builtin
! rplay support will be used.
  
  .IP "*FvwmAudioDir \fIdirectory\fP"
  Specifies the directory to look for the audio files.  This option is
  ignored when rplay is used.
  
  .SH COPYRIGHTS
  This module has evolved of \fIFvwmAudio\fP, which in term is heavily based
--- 215,232 ----
  for FvwmAudio:
  
  .IP "*FvwmEventPlayCmd \fIcommand\fP"
! This is equivalent to using *FvwmEventCmd to Exec commands. This
! determines the independent audio player program that will actually
! play the sounds. If the play command is set to \fIbuiltin-rplay\fP
! then the builtin rplay support will be used.
  
  .IP "*FvwmAudioDir \fIdirectory\fP"
  Specifies the directory to look for the audio files.  This option is
  ignored when rplay is used.
+ 
+ .SH BUGS
+ It's REALLY noisy when \fIfvwm2\fP starts and restarts using an audio player.
+ FvwmEventDelay helps a little bit.
  
  .SH COPYRIGHTS
  This module has evolved of \fIFvwmAudio\fP, which in term is heavily based

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 6 May 1999 11:23:26 +0200

> organized, I think. Anyway, context diff is attached. Changelog entry

The patch doesn't apply correctly. How did you make it? The correct way
is:

  diff -u FvwmEvent.1.orig FvwmEvent.1

or 

  diff -c FvwmEvent.1.orig FvwmEvent.1

(diff -u is preferred).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Thu, 06 May 1999 09:51:23 -0700

Previously...
>  diff -c FvwmEvent.1.orig FvwmEvent.1

I made my diff this way (context).

>(diff -u is preferred).

Perhaps I'm seeing why... I'll go home and make a unified instead...
We'll see if that one applies cleanly. Sorry.
-- 
[email-masked]
The Christmas pageant does not stink
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Thu, 06 May 1999 22:45:35 -0700

Previously...
>  diff -c FvwmEvent.1.orig FvwmEvent.1

As promised, here's a second try with that diff... Dunno what happened
with the context one...
-- 
[email-masked]
Nobody likes sunburn slappers
 - The collected wisdom of Bart Simpson

--- FvwmEvent.1.orig	Wed May  5 21:34:49 1999
+++ FvwmEvent.1	Wed May  5 21:46:58 1999
@@ -44,6 +44,24 @@
 \fIFvwmEvent\fP can also have builtin support for the rplay library.
 (heritage of FvwmAudio)
 
+.SH INVOCATION
+The invocation method was shown in the synopsis section. No command
+line invocation is possible. \fIFvwmEvent\fP must be invoked by the
+\fIfvwm2\fP window manager. \fIFvwmEvent\fP accepts a single
+argument:
+
+.IP \-audio
+Enables FvwmAudio compatibility mode.
+
+.IP alias
+Makes FvwmEvent use \fIalias\fP as its name. This affects which lines
+from the user's configuration file are used.
+
+Invoking FvwmEvent as \fIFvwmAudio\fP (either by using an alias or
+creating a symlink) enables FvwmAudio compatibility mode.
+
+.sp
+
 .SH CONFIGURATION OPTIONS
 \fIFvwmEvent\fP reads the same \fI.fvwm2rc\fP file as \fIfvwm2\fP
 reads when it starts up, and looks for certain configuration options:
@@ -190,56 +208,6 @@
 Specifies what volume will be assigned to the sounds when they are
 played.
 
-.SH INVOCATION
-The invocation method was shown in the synopsis section. No command
-line invocation is possible. \fIFvwmEvent\fP must be invoked by the
-\fIfvwm2\fP window manager. \fIFvwmEvents\fP accepts a single
-argument:
-
-.IP \-audio
-Enables FvwmAudio compatibility mode.
-
-.IP alias
-Makes FvwmEvent use \fIalias\fP as its name. This affects which lines
-from the user's configuration file are used.
-
-Invoking FvwmEvent as \fIFvwmAudio\fP (either by using an alias or
-creating a symlink) enables FvwmAudio compatibility mode.
-
-.sp
-
-.SH FvwmAudio Compatibility
-
-FvwmAudioPlayCmd used to call an external program.
-FvwmEventCmd calls an \fIfvwm2\fP function. External programs can be called
-using the \fIfvwm2\fP exec function "exec program".
-
-FvwmAudioDir has been removed due to the fact that the parameters
-don't have to be files any more.
-use:
-.nf
-.sp
-	DestroyFunc mysay
-	AddToFunc mysay "I" exec /rsynth/say /rsynth/audiofiles/$1
-
-	*FvwmEventCmd mysay
-.sp
-.fi
-.SH BUGS
-It's REALLY noisy when \fIfvwm2\fP starts and restarts using an audio player.
-FvwmEventDelay helps a little bit.
-
-The parameters inherent to several events are not accessible. This
-might be implemented in the future so that the command executed by
-fvwm2 looks like FvwmEventCmd FvwmEvent-parameters
-event-specific-parameters.
-
-Simple \fIFvwmAuto\fP could then be emulated by:
-.nf
-	*FvwmEventCmd
-	*FvwmEvent raise-window Raise
-.sp
-.fi
 .SH FvwmAudio Compatibility Mode
 
@@ -247,14 +215,18 @@
 for FvwmAudio:
 
 .IP "*FvwmEventPlayCmd \fIcommand\fP"
-This is equivalent to using *FvwmEventCmd. This determines the
-independent audio player program that will actually play the sounds.
-If the play command is set to \fIbuiltin-rplay\fP then the builtin
-rplay support will be used.
+This is equivalent to using *FvwmEventCmd to Exec commands. This
+determines the independent audio player program that will actually
+play the sounds. If the play command is set to \fIbuiltin-rplay\fP
+then the builtin rplay support will be used.
 
 .IP "*FvwmAudioDir \fIdirectory\fP"
 Specifies the directory to look for the audio files.  This option is
 ignored when rplay is used.
+
+.SH BUGS
+It's REALLY noisy when \fIfvwm2\fP starts and restarts using an audio player.
+FvwmEventDelay helps a little bit.
 
 .SH COPYRIGHTS