Subject: Notification: incoming/304

From: [email-masked]
Date: Wed, 14 Apr 1999 02:51:16 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/304

Message summary for PR#304
	From: [email-masked]
	Subject: Better window matching for Style
	Date: Wed, 14 Apr 1999 02:51:14 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Apr 1999 09:43:55 -0400

[email-masked] writes:
> I'd propose to change the syntax of the Style command to 
> something like
> 
> Style (conditions...) options
> 
> Where conditions could be the traditional name like in the
> old syntax or other conditions which we find useful for
> matching styles to windows more precisely. Currently I'm
> mainly thinking of Transient to allow to differentiate
> styles for transient vs. non-transient windows (rendering
> the special ...Transient style options unnecessary). 
> If window group support gets added to a future fvwm, it might
> also be interesting to decorate group leaders differently.
> 
> The old syntax should of course still be accepted. 
> 
> Matthias

You will want to check the archives on this, I think the thread
was "Style matching".  The syntax we came up with (as I remember)
was:

Style [ ] ...

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 16 Apr 1999 16:24:24 +0200

> was "Style matching".  The syntax we came up with (as I remember)

I did and didn't find anything. 

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 20 Apr 1999 10:35:11 -0400

> I did and didn't find anything. 

Try "regular expressions".

Most of the discussion was in Dec 98.

I have yet to find the culmination of the discussion, but as I
remember:

Style [name Netscape, class x*] ...

I added a note to enhancement 304.