Subject: Notification: incoming/318

From: [email-masked]
Date: Mon, 26 Apr 1999 22:26:08 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/318

Message summary for PR#318
	From: [email-masked]
	Subject: FvmvEvent dumps core
	Date: Mon, 26 Apr 1999 22:26:07 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Steve Robbins <[email-masked]>
Date: Tue, 27 Apr 1999 10:25:46 -0400 (EDT)

On Mon, 26 Apr 1999 [email-masked] wrote:

> Full_Name: Jason C. Wells
> Version: 2.2
> CVS_Date: 
> OS: FreeBSD 3.1-STABLE
> X_Server: 3.3.3.1 s3
> Submission from: (NULL) (128.208.37.26)
> 
> 
> I am not using rplay. If I leave
>  
> *FvwmEventRplayHost $HOSTDISPLAY  
> *FvwmEventRplayPriority 0  
> *FvwmEventRplayVolume 127
> 
> in .fvwm2rc then FvwmEvent will dump core. I Comment these lines from
> .fvwm2rc to prevent core dumping.
> 
> Fvwm should ignore these lines instead of dumping core if rplay is 
> not being used.

Hi,

I tried sending a reply from the BUG-tracking page, but I'm not sure I
succeeded.  Can you let me know if you got some response from it?

If not, here's the patch.  If you can check to see if it works, I'd
appreciate it.

Index: FvwmEvent.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmEvent/FvwmEvent.c,v
retrieving revision 1.13
diff -u -b -B -r1.13 FvwmEvent.c
--- FvwmEvent.c	1999/04/09 19:40:34	1.13
+++ FvwmEvent.c	1999/04/27 14:24:49
@@ -394,13 +394,10 @@
 {
     "Cmd",
     "Delay",
-    "PassID"
-#ifdef HAVE_RPLAY
-	,
+    "PassID",
     "RplayHost",
     "RplayPriority",
     "RplayVolume"
-#endif
 };	/* define entries here, if this list becomes unsorted, use LFindToken */

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: "Jason C. Wells" <[email-masked]>
Date: Tue, 27 Apr 1999 09:09:39 -0700 (PDT)

>succeeded.  Can you let me know if you got some response from it?

I got your message. I will check it out.

Catchya Later,		|	Give me UNIX or give me a typewriter.
Jason Wells		|	http://www.freebsd.org/