Subject: control-d on non-shell applications

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Apr 1999 21:42:25 +0200

A little brainstorming:

I want to close applications with ctrl-d like any shell.
My shell windows require to be properly shut down with
this sequence (or exit) so that they can save the command
history (multiple zsh's can easily share a common history
file without trashing the other shells history :) ). But
I want to be able to close any window with ctrl-d (or
to be honest I want to close all windows that don't interpret
ctrl-d in some way, but I could live without that).
For several reasons binding ctrl-D to Delete/Destroy is out
of the question (one being that I often have recursive shells
in one window and I don't want to close all of them at once).

Any ideas?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: 24 Apr 1999 12:35:08 +0200

> I want to close applications with ctrl-d like any shell.

There is already the Current function which allows you to define
different actions if the current window is an xterm, but what's
missing is a function which passes the event on to the underlying
application.

I think.

kai
-- 
Abort this operation?   [Abort]  [Cancel]