Subject: Notification: incoming/290

From: [email-masked]
Date: Wed, 7 Apr 1999 13:24:33 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/290

Message summary for PR#290
	From: [email-masked]
	Subject: raise is intermittent
	Date: Wed, 7 Apr 1999 13:24:32 -0500 (CDT)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Apr 1999 14:08:07 +0200

On Wed, Apr 07, 1999 at 01:24:33PM -0500, [email-masked] wrote:
> Hi,
>    I still haven't fully quantified this problem, but here are the
> initial indications.  Sometimes when clicking to raise a window, it
> won't raise.  This also occurs when using a key bound to the same 
> function.  The only way to raise a window that exibits this characteristic
> is to lower all the other windows that are on top of it.  This seems to
> work fine, but is a pain, and it doesn't seem like it should work that
> way.  I would be happy to try to pin it down more if you can give me
> some pointers where to look.

Can you try to find a step by step description to create this problem?
What might help is to lower the said window before raising it. Does
this help? This would indicate that fvwm thinks the window is already
raised and thus doesn't raise it again.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 Apr 1999 21:17:35 +0200

On Fri, Apr 09, 1999 at 11:47:07AM -0400, baker wrote:

This sounds vaguely familiar. Perhaps someone else can tell you
exactly about this raising/lowering stuff. There has been a lot
of work recently that may have affected this. I'll forward your
mail to the mailing list.

>    Right now the example I have is an application called Simplicity (a Java gui
> builder).
> One of the windows, when raised, will raise above several other windows
> (including
> some in the application), but not above one of the other windows in the same
> applicaion.
> I can lower then raise the window, and it never comes above the one that stays
> on top.
> I'm still trying to figure out if it is setup file related or not, as I have 2
> other people with
> the same problem, and 2 people that haven't noticed it.  It might be the
> applications
> they are running, or it might be the setup.
>    I'm working on getting my setup file out to you, it isn't a simple task, due
> to
> beaurocracy.
> 
> Stewart
> 
> Dominik Vogt wrote:
> 

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Apr 1999 23:35:04 +0200

> some pointers where to look.

Ah, now that I see a new bug report with something similar I remember where
I have seen it again. The problem might be that the window refuses to
raise over windows that were not raised by fvwm but by the application
itself. I think emacs does this some time. Can you check this?

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Apr 1999 21:21:29 +0200

On Mon, Apr 19, 1999 at 10:51:31AM -0400, baker wrote:
> Dominik,
>    My main complainer (I mean tester) is on vacation this week, but one problem
> that
> I can reproduce involves 2 windows in the Simplicity application.  One of them
> seems
> to be a child of the other.  There are two windows, I will call them 1 and 2.
> 
> Window 1 cannot be raised above window 2, no matter what.  It can be made to be
> above
>     window 2, but only by moving window 2.

The one window cannot be the child of the other one. A parent window can never
be raised above a child and a child can only be displayed inside its parent.

> Window 2 can be moved below window 1.
> Window 2 can be raised above window 1.
> When Window 2 is closed, it closes.
> When Window 1 is closed, both window 1 and window 2 close.

Can you send me the output of 'xwininfo -all' for both windows. It might
help too if you could capture the output of xev for these two windows
when you try to raise/move them.

Bye

Dominik ^_^

P.S.: Please do not reply to me personally. All replies should
      go to [email-masked] so all the other folks on the
      list have a chance to reply too.
--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 20 Apr 1999 12:12:35 +0200

> when you try to raise/move them.

It would also be really helpful to try to reproduce the problem with a
2.3 version of fvwm, since the stacking order handling has changed 
considerably. 

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: baker <[email-masked]>
Date: Thu, 22 Apr 1999 08:34:19 -0400

Okay,  one more rule for the operation:
   When Window 1 is moved, it pops behind Window 2 (I haven't found a way to stop
this).

   I tried all this on the latest snapshot (0411) and it performs exactly the same.

Below is xwininfo and xev:

(this window stays on top)
xwininfo: Window id: 0x94001c4 (has no name)

  Root window id: 0x29 (the root window) (has no name)
  Parent window id: 0x1400297 (has no name)
     1 child:
     0x88001d1 (has no name): ()  548x263+0+0  +5+620
        1 child:
        0x88001d2 (has no name): ()  548x263+0+0  +5+620
           1 child:
           0x88001d3 (has no name): ()  558x293+-5+-25  +0+595

  Absolute upper-left X:  5
  Absolute upper-left Y:  620
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 548
  Height: 263
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +5+620  -599+620  -599-17  +5-17
  -geometry 548x263+0-12

  Bit gravity: ForgetGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      KeyPress
      KeyRelease
      EnterWindow
      LeaveWindow
      Exposure
      StructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      Program supplied location: 0, 592
      Program supplied size: 548 by 263
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined

xwininfo: Window id: 0x94001b2 (has no name)

  Root window id: 0x29 (the root window) (has no name)
  Parent window id: 0x140027b (has no name)
     1 child:
     0x88001bf (has no name): ()  566x568+0+0  +94+206
        2 children:
        0x88001c4 (has no name): ()  566x539+0+29  +94+235
           1 child:
           0x88001c5 (has no name): ()  566x568+0+-29  +94+206
        0x88001c0 (has no name): ()  566x29+0+0  +94+206
           3 children:
           0x88001c3 (has no name): ()  36x19+5+5  +99+211
           0x88001c2 (has no name): ()  65x19+41+5  +135+211
           0x88001c1 (has no name): ()  45x19+106+5  +200+211

  Absolute upper-left X:  94
  Absolute upper-left Y:  206
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 566
  Height: 568
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +94+206  -492+206  -492-126  +94-126
  -geometry 566x568+89+178

  Bit gravity: ForgetGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      KeyPress
      KeyRelease
      EnterWindow
      LeaveWindow
      Exposure
      StructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      Program supplied location: -1, -1
      Program supplied size: 566 by 568
      Program supplied minimum size: 0 by 0
      Program supplied maximum size: 1152 by 871
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined

/app/X11R5/bin/xev -id 0x94001c4

FocusIn event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyNormal, detail NotifyNonlinear

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

EnterNotify event, serial 5, synthetic NO, window 0x94001c4,
    root 0x29, subw 0x94001c5, time 1365551104, (541,199), root:(546,819),
    mode NotifyNormal, detail NotifyVirtual, same_screen YES,
    focus YES, state 0

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyGrab, detail NotifyAncestor

VisibilityNotify event, serial 5, synthetic NO, window 0x94001c4,
    state VisibilityPartiallyObscured

FocusIn event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyGrab, detail NotifyAncestor

VisibilityNotify event, serial 5, synthetic NO, window 0x94001c4,
    state VisibilityUnobscured

FocusIn event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

LeaveNotify event, serial 5, synthetic NO, window 0x94001c4,
    root 0x29, subw 0x94001c5, time 1365556241, (599,218), root:(604,838),
    mode NotifyNormal, detail NotifyVirtual, same_screen YES,
    focus YES, state 0

FocusOut event, serial 5, synthetic NO, window 0x94001c4,
    mode NotifyNormal, detail NotifyNonlinear

/app/X11R5/bin/xev -id 0x94001b2

EnterNotify event, serial 5, synthetic NO, window 0x94001b2,
    root 0x29, subw 0x94001b3, time 1365589957, (560,456), root:(626,633),
    mode NotifyNormal, detail NotifyNonlinearVirtual, same_screen YES,
    focus NO, state 0

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusIn event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyNormal, detail NotifyNonlinear

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

FocusOut event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 5, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

LeaveNotify event, serial 5, synthetic NO, window 0x94001b2,
    root 0x29, subw 0x94001b3, time 1365594265, (569,447), root:(635,624),
    mode NotifyNormal, detail NotifyNonlinearVirtual, same_screen YES,
    focus YES, state 0

FocusOut event, serial 5, synthetic NO, window 0x94001b2,
    mode NotifyNormal, detail NotifyNonlinear