Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Fri, 9 Apr 1999 14:40:35 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/04/09 14:40:34

Modified files:
	.              : ChangeLog 
	fvwm           : Makefile.am add_window.c borders.c builtins.c 
	                 colormaps.c colors.c decorations.c defaults.h 
	                 events.c focus.c functions.c fvwm.c fvwm.h 
	                 fvwm2.1 fvwmdebug.c fvwmdebug.h gnome.c 
	                 icccm2.c icons.c menus.c menus.h misc.c misc.h 
	                 modconf.c module.c module.h move.c parse.h 
	                 placement.c read.c resize.c screen.h session.c 
	                 session.h style.c virtual.c windows.c 
	libs           : ClientMsg.c GetFont.c Grab.c Graphics.c 
	                 Module.c Parse.c Picture.c Picture.h Strings.c 
	                 System.c alloca.c atexit.c debug.c envvar.c 
	                 fvwmlib.h lang-strings.h safemalloc.c 
	                 strcasecmp.c strerror.c strncasecmp.c usleep.c 
	                 wild.c 
	modules        : ChangeLog 
	modules/FvwmAnimate: FvwmAnimate.c 
	modules/FvwmEvent: FvwmEvent.c 
Added files:
	fvwm           : icons.h 

Log message:
* New parsing functions GetNextFullOption and GetNextSimpleOption. Latter one
was called GetNextOption before.
* Removed unused variable in gnome.c.
* Rewrote style parsing to get rid of those horrible macros. On my machine
(gcc, i386) this saves 3696 bytes. Macros should be forbidden!!!
* Moved icon code and prototypes to icons.[ch]. icons.h is new.
* Added GPL notice to all .c and .h files in fvwm and libs.
* Reformatted comments in style.c. Can we agree to put comments always on a
separate line? It's much easier to change the code then.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 09 Apr 1999 16:07:35 -0400

> separate line? It's much easier to change the code then.

If its style.c, those must be my comments, inserted and lined up
like that by hitting M-; in XEmacs:

  if(lastptr != NULL)                   /* If not first entry in list */
    lastptr->next = nptr;               /* chain this entry to the list */
  else                                  /* else first entry in list */
    Scr.TheList = nptr;                 /* set the list root pointer. */
} /* end function */

Seems to me like a good way to code.  The comment doesn't simply
repeat the code, it explains what I thought I was doing.

I'll take a look at what you did to it.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Sat, 10 Apr 1999 11:19:48 -0400 (EDT)

> repeat the code, it explains what I thought I was doing.

One alternative is to simply put the comment in a line or two *before* the
stanza in question.  Some find it easier to read a sentence that explains
a clump of code, rather than short note at the end of each code line.

Also, I think you can assume that anyone reading the code understands what
a linked list is.  So you should be able to shorten the comment to 

  /* Add nptr to the end of [whatever Scr.TheList is] list */

--
Steve Robbins                              <[email-masked]>

There's a little bit of Elvis in everybody.
Except Michael J. Fox -- he's the anti-Elvis.