Subject: GIMP kills ButtonBar

From: [email-masked]
Date: Thu, 15 Apr 1999 14:54:29 -0500 (CDT)

Full_Name: Tim
Version: 2.0.46 and now on 2.2
CVS_Date: 
OS: Linux-2.2.5 (SuSE6.0)
X_Server: XF86 3.3
Submission from: (NULL) (62.144.245.123)

Most times I'am starting GIMP by a button on the ButtonBar the bar
crashes.
X-Windows gives this error Messages:

X Error of failed request:  BadDrawable (invalid Pixmap or Window
parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0x2c00002
  Serial number of failed request:  233
  Current serial number in output stream:  233
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  38 (X_QueryPointer)
  Resource id in failed request:  0x2800008
  Serial number of failed request:  8241
  Current serial number in output stream:  8241
X Error of failed request:  BadDrawable (invalid Pixmap or Window
parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0x2400010
  Serial number of failed request:  1590
  Current serial number in output stream:  1596
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0x140001a
  Serial number of failed request:  951
  Current serial number in output stream:  952

The bar's process seems to get killed -no zombi left in <ps aux>.

Thank You!
	Tim

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Apr 1999 11:36:50 +0200

> The bar's process seems to get killed -no zombi left in <ps aux>.

I have committed a fix to the FvwmButtons X error handler yesterday.
It *might* have some effect on this problem. Could you check this
with the latest development snapshot? (The development source is
quite unstable at the moment, so don't use this for work).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]