Subject: Another fvwmrc_convert patch

From: Julian Gilbey <[email-masked]>
Date: Fri, 30 Apr 1999 00:10:18 +0100 (BST)

It didn't properly account for the multipe Sticky* commands in FVWM 1.xx.
Here's a patch:

--- fvwmrc_convert.orig	Thu Apr 29 23:53:00 1999
+++ fvwmrc_convert	Fri Apr 30 00:07:32 1999
@@ -224,7 +224,10 @@
 ########## Placement & Focus styles ##########
 /^[ \t]*RandomPlacement[ \t]*/	{ print "Style \"*\" " $0; placement = TRUE; next; }
 /^[ \t]*SmartPlacement[ \t]*/	{ print "Style \"*\" " $0; placement = TRUE; next; }
-/^[ \t]*Sticky[ \t]*/		{ printf "Style \"%s\" Sticky\n", $2; next; }
+/^[ \t]*Sticky(Back|Fore)Color[ \t]*/ {
+      print "#! " $0 " (not supported in FVWM2)"; next;
+}
+/^[ \t]*Sticky[ \t]+/		{ printf "Style \"%s\" Sticky\n", $2; next; }
 /^[ \t]*NoPPosition[ \t]*/	{ print "Style \"*\" " $0; next; }
 /^[ \t]*ClickToFocus[ \t]*/	{ print "Style \"*\" " $0; next; }
 /^[ \t]*SloppyFocus[ \t]*/	{ print "Style \"*\" " $0; next; }

You can pipe this mail to the command:
   patch -d /path/to/the/fvwm/development/directory/utils
to apply it.

   Julian

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

  Julian Gilbey, Dept of Maths, QMW, Univ. of London. [email-masked]
             Debian GNU/Linux Developer.  [email-masked]
       -*- Finger [email-masked] for my PGP public key. -*-
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Apr 1999 12:57:39 +0200

> +++ fvwmrc_convert	Fri Apr 30 00:07:32 1999

Thanks, I've applied it. BTW, would you like to have commit privileges
for the CVS tree?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Julian Gilbey <[email-masked]>
Date: Fri, 30 Apr 1999 18:13:21 +0100 (BST)

> > +++ fvwmrc_convert	Fri Apr 30 00:07:32 1999

BTW, to whoever's handling 2.2.1, the current version of
fvwmrc_convert should go in it ;)

> Thanks, I've applied it. BTW, would you like to have commit privileges

That would be OK by me.  (Feel free to send me ID/passwd
PGP-encrypted.)  At the moment, I am still working through 2.2
Debian problems (there were a lot of them, you may recall, most of
which have thankfully turned out to be non-problems) and haven't even
looked at 2.3.  But that would come soon, I hope.

   Julian