Subject: libstroke: stroke recognition

From: Jason L Tibbitts III <[email-masked]>
Date: 10 Apr 1999 00:13:10 -0500

Has anyone seen the following:

http://www.etla.net/~willey/projects/libstroke/

It is a library for recognizing "gestures" made with the mouse and doing
things based on them.  It's a really neat technique.  But the interesting
thing is that a patch to FVWM (2.0.45, alas) is provided which enables
strokes.  A compressed .fvwm2rc excerpt:

# Strokes
#       num             button  context mod.    action
Stroke  14789           2       A       N       Exec exec xlock -mode blank&  
Stroke  258             2       A       N       Exec exec xterm&
Stroke  563214789       2       A       N       Exec exec exmh&
Stroke  7415963         2       A       N       Exec exec netscape&
Stroke  741236987       2       A       N       Destroy
Stroke  1478963         2       A       N       Popup "Apps"
Stroke  74123           2       A       N       Module "winlist" FvwmWinList transient
Stroke  74159           2       A       N       Move

Imagine a grid like:

  1  2  3

  4  5  6

  7  8  9

Then just plot those strings of digits on the grid and you have the stroke.

The author announced this way back when (two years ago) but things were
pretty dead then.  Perhaps someone might want to take another look at this;
the patch is actually pretty minimal and the parsing cleanups should make
it even smaller.

 - J<
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Apr 1999 00:36:03 +0200

> the patch is actually pretty minimal and the parsing cleanups should make

... and where can I find that patch?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Julian Gilbey <[email-masked]>
Date: Sun, 11 Apr 1999 03:00:55 +0100 (BST)

> ... and where can I find that patch?

According to Hamish Moffatt <[email-masked]>:

: It would be excellent if fvwm2 had support for strokes.
: www.etla.net/libstroke/ has the library libstroke (which I have already
: packaged as libstroke0) and patches for fvwm2.

I haven't checked it out myself, though.

   Julian

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

  Julian Gilbey, Dept of Maths, QMW, Univ. of London. [email-masked]
             Debian GNU/Linux Developer.  [email-masked]
       -*- Finger [email-masked] for my PGP public key. -*-
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 10 Apr 1999 23:50:28 -0500

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

[Quoting me]
>> http://www.etla.net/~willey/projects/libstroke/

DV> ... and where can I find that patch?

Hmmm.  It's linked directly from that URL, but if you want it directly,
it's at
http://www.etla.net/~willey/projects/libstroke/fvwm-2.0.45-stroke.patch

 - J<

---

From: Ke Huang <[email-masked]>
Date: Tue, 20 Apr 1999 02:39:31 -0500 (CDT)

I am not sure if this is a bug, but...

In fvwm/modules/FvwmGtk/FvwmGtk.c at line 1245, GetNextOption(...) is an
undefined function. After looking through other parts of the source, I think
this should have been replaced by GetNextSimpleOption(...). Right?

As right now, it gives a compilation error.

-- Ke Huang
------------------------------------------
e-mail:  [email-masked]  (preferred)
         [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Apr 1999 12:05:02 +0200

> As right now, it gives a compilation error.

Right. I changed the name of this function and didn't update the
modules that are not in the tarball.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 20 Apr 1999 12:20:48 +0200

> As right now, it gives a compilation error.

Yes, using GetNextOption became a bug at the time this function was removed.
I have forgotten to commit the trivial fix you mention, but I'll do it
eventually.

Matthias 

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]