Subject: Something changed my focus policy!

From: Dan Espen <[email-masked]>
Date: Wed, 28 Apr 1999 09:16:24 -0400

And for todays bug...

I'm not sure when this crept in, but for a while now, if I
deiconify a window by clicking on the icon, the window gets focus
even though my pointer is still on the root window.
This is how I've configured focus:

Style "*" MouseFocus
Style "xmag" ClickToFocus

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 28 Apr 1999 14:27:02 +0100

> even though my pointer is still on the root window.

Is it all windows or just transients?  The new style flag
GrabFocusTransient is on by default (I think it should be the same as
GrabFocus i.e. on for ClickFocus only) so that would explain any
transient windows getting focus on de-iconify.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 28 Apr 1999 09:35:27 -0400

> transient windows getting focus on de-iconify.

Its on all windows, including rxvt, xemacs.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Apr 1999 15:30:43 +0200

> Its on all windows, including rxvt, xemacs.

It's more likely to have something to do with the icon-label-raising
stuff. Matthias, any ideas?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Thu, 29 Apr 1999 16:45:06 +0200

> stuff. Matthias, any ideas?

I have only added 

  if (IS_ICONIFIED(Tmp_win))
    {
      SET_ICON_ENTERED(Tmp_win,1);
      DrawIconWindow (Tmp_win);
    }

to HandleEnterNotify and 

  if (Tmp_win && IS_ICONIFIED(Tmp_win))
    {
      SET_ICON_ENTERED(Tmp_win,0);
      DrawIconWindow (Tmp_win);
    }

to HandleLeaveNotify. I can't see this influencing focus anyhow.
Maybe the NoWarp changes had a bad influence somewhere ?

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 29 Apr 1999 11:41:46 -0400

> Maybe the NoWarp changes had a bad influence somewhere ?

I don't have an exact date, but this could have been happening
for more than 2 weeks.  I wouldn't normally notice it.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Apr 1999 13:42:15 +0200

On Thu, Apr 29, 1999 at 04:45:06PM +0200, Matthias Claasen wrote:
>...

How does mouse focus work anywway? I can't see any code in
HandleLeaveNotify for mouse focus.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: 30 Apr 1999 16:29:47 +0200

Tim Phipps <[email-masked]> writes:

  > GrabFocus i.e. on for ClickFocus only)

The old behavior of fvwm was that all new windows got focus anyway
when in ClickToFocus mode, wasn't it?

GrabFocusTransient is most useful for MouseFocus and SloppyFocus -- it
allows you to type Alt-F in Netscape, say, and then immediately enter
your search string in the popup window.  Without GrabFocusTransient,
you'd have to move the mouse first which kind of defeats the purpose
of a keyboard shortcut.

kai
-- 
Abort this operation?   [Abort]  [Cancel]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Apr 1999 16:28:21 +0200

> when in ClickToFocus mode, wasn't it?

GrabFocus shouldn't be applied when an application is de-iconified,
only if it's newly created.

Bye

Dominik ^_^

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 30 Apr 1999 23:44:24 +0200

> HandleLeaveNotify for mouse focus.

I guess we treat "leaving window x" as "entering root (or another)
window"... ie it is enough to handle focus changes in the enternotify
handler. 

Matthias