Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Thu, 1 Apr 1999 16:34:55 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/04/01 16:34:55

Modified files:
	.              : ChangeLog 
	fvwm           : builtins.c events.c focus.c resize.c 

Log message:
* Experimental resize patch.
* Fix ClickToFocusDoesntPassClick with no-inpout-focus windows
* Fixed bug in maximize.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 2 Apr 1999 07:33:36 -0500

> * Fix ClickToFocusDoesntPassClick with no-inpout-focus windows

I tried out the resize patch, and it seems to work ok, but I think you
need to make the percentages larger. You probablly want to try and
match the percentages to the 9 square grid that gets drawn when you are
actually doing the resize.  That grid seems to break things up nicelly
but your patch often forces me to still move to an edge even though I'm
not in the center square when the resize grid pops up.

Just a suggestion

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Apr 1999 15:04:51 +0200

> not in the center square when the resize grid pops up.

We'll have to experiment with the numbers a bit. I used 5% so
this is never triggered when you don't expect it, but perhaps
it's too strict. One problem is that if width and height are
too different the rectangle near the corners becomes confusing.
When I tried myself I could not get used to it. I was expecting
a square, not a rectangle.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]