Subject: FVWM CVS: fvwm clasen

From: CVS <[email-masked]>
Date: Sat, 24 Apr 1999 17:50:24 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	clasen	99/04/24 17:50:23

Modified files:
	.              : ChangeLog NEWS 
	fvwm           : virtual.c gnome.c style.c add_window.c 
	                 session.c builtins.c fvwm.h gsfr.h move.c 
	                 fvwm2.1 events.c misc.c misc.h focus.c icons.c 
Added files:
	fvwm           : stack.c stack.h 

Log message:
Move all stack manipulation functions to stack.[ch].

New style option FixedPosition/VariablePosition (I don't actually know if this
is a very good idea, but it is nice to have it for the GNOME panel)

GNOME stuff improvements:
* setting the _WIN_STATE, _WIN_LAYER and _WIN_WORKSPACE hints works now
(ie fvwm obeys the hints if the client sets them before mapping - unless
fvwm styles override them)
* _WIN_WORKSPACE_COUNT is no longer fixed to 1
* more hint updates when fvwm changes window configuration

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Sun, 25 Apr 1999 00:15:00 -0400

> Move all stack manipulation functions to stack.[ch].

	You forgot to put stack.c & stack.h in the Makefile.am. I'll do it in a
couple of minutes.

- Bob

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 25 Apr 1999 21:27:31 +0200

> 	You forgot to put stack.c & stack.h in the Makefile.am. I'll do it in a

I did that, just forgot to include Makefile.am in the commit. Thanks.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]