Subject: April 1 CVS

From: Brad Giaccio <[email-masked]>
Date: Thu, 1 Apr 1999 08:19:24 -0500

Well I've been out all week and have been trying to catch up on CVS changes,right now I can confirm that M$ finishes but some where in the initial capture I am having this problem:

(gdb) where
#0  0xef439590 in _libc_write ()
#1  0xef46dbc0 in _xflsbuf ()
#2  0xef460c04 in _doprnt ()
#3  0xef46ac4c in _fprintf ()
#4  0x36bcc in fvwm_msg (type=2, id=0x4a118 "FvwmErrorHandler", 
    msg=0x4a148 "Request %d, Error %d, EventType: %d") at misc.c:1177
#5  0x2d394 in FvwmErrorHandler (dpy=0x61738, event=0xefffea88) at fvwm.c:1688
#6  0xef637154 in _XError ()
#7  0xef635984 in _XReply ()
#8  0xef630f20 in XSync ()
#9  0x1b700 in SetupFrame (tmp_win=0x69548, x=-1270, y=1068, w=233, h=239, 
    sendEvent=1, curr_shading=0) at borders.c:1244
#10 0x186b0 in AddWindow (w=431428, ReuseWin=0xfffffb0a) at add_window.c:679
#11 0x27c50 in HandleMapRequestKeepRaised (KeepRaised=0, ReuseWin=0x0)
    at events.c:824
#12 0x2be44 in CaptureAllWindows () at fvwm.c:737
#13 0x2bbf4 in StartupStuff () at fvwm.c:632
#14 0x2919c in My_XNextEvent (dpy=0x61738, event=0x40) at events.c:1688
#15 0x26d8c in HandleEvents () at events.c:200
#16 0x2bba4 in main (argc=386056, argv=0x5e400) at fvwm.c:606

I can see that I'm getting hung on a fprintf but I have no idea why, can anyone shed some light on this.  Once I kill fvwm I get all the error messages from FvwmErrorHandler as expected.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 01 Apr 1999 14:59:39 +0100

> I can see that I'm getting hung on a fprintf but I have no idea why, can anyone shed some light on this.  Once I kill fvwm I get all the error messages from FvwmErrorHandler as expected.

Is stderr directed at an ordinary file? Could you send the output?

Cheers,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 1 Apr 1999 09:51:37 -0500

> Is stderr directed at an ordinary file? Could you send the output?
 
stderr and stdout go to /dev/console
the error I get over and over after I kill fvwm is:
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 1, Error 8, EventType: 0