Subject: Patch for GNOME

From: Michael Lausch <[email-masked]>
Date: Wed, 28 Apr 1999 09:34:58 +0200

Since i'm not subscribed to this list (I'm on too many mailingslists
already), please send comments to me directly.

This patch makes fvwm2 a better GNOME citizen. It sets the desktop
properties of windows when they are deiconified. I can iconify a
window on desk 0 and de-iconify it on desk 1. The window appears on
desk 1, but in the gnome-pager, the windows is still shown on desk 0.

Index: icons.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/icons.c,v
retrieving revision 1.41
diff -u -b -B -r1.41 icons.c
--- icons.c     1999/04/24 22:50:23     1.41
+++ icons.c     1999/04/28 07:26:04
@@ -926,7 +926,7 @@
          XRaiseWindow(dpy,t->w);
        }
     }
-
+  GNOME_SetDesk(tmp_win);
   RaiseWindow(tmp_win); /* moved dje */
 
   if(HAS_CLICK_FOCUS(tmp_win))

--
Michael Lausch
See my web page <http://www.lausch.at/> or query PGP key server for PGP key.
"Reality is that which, when you stop believing in it, doesn't go away".
                -- Philip K. Dick
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 30 Apr 1999 13:05:56 +0200

> desk 1, but in the gnome-pager, the windows is still shown on desk 0.

Matthias, can you decide if/how this patch should be applied?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]