Subject: the mysteries of computers?

From: Dominik Vogt <[email-masked]>
Date: Wed, 7 Apr 1999 04:18:01 +0200

It has happened again! I was using my current config file
for months no and suddenly it's broken. This worked for a
long time:

  AddToFunc SetDefaultBackground
   + "I" Exec echo -e $0 > $HOME/.fvwm2/background
                     ^^^^

But suddenly I have to use this:

  AddToFunc SetDefaultBackground
   + "I" Exec echo -e $$0 > $HOME/.fvwm2/background
                     ^^^^^

Then I checked with older fvwm version: I tried 2.2,
and 2.1.4 and with neither the first version worked.
Looking at the code I wonder how it could ever have
worked, but it *did*. Am I losing my mind? This is
exactly the same way my '//' stopped working: it
worked well for month and then one day the current
and all previous fvwm versions broke at the same time.
I'm utterly puzzled.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 07 Apr 1999 08:47:47 -0400

> and all previous fvwm versions broke at the same time.

Everything seems to point to your preprocessor changing, not
any part of fvwm2.  Possibly fvwm2 is finding a different
preprocessor than it did in the past, but you should be able
to coerce fvwm2 into using any preprocessor you like.

Me, I keep hoping I won't have to resort to using a
preprocessor.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 7 Apr 1999 09:03:00 -0400

> Me, I keep hoping I won't have to resort to using a

Well good news Dominik its not just you all my functions that use $<n>
fail now. Now I they did and still do work with yesterdays CVS, that is
before these three commits:

1999-04-07  Matthias Clasen  <[email-masked]>
   
    * acconfig.h:
    * INSTALL.fvwm: Finish the removal of the NO_SAVEUNDERS and
    WINDOWSHADE configure options.

1999-04-07  Dominik Vogt  <[email-masked]>
   
    * fvwm/functions.c (expand): some clean up
   
    * fvwm/Makefile.am (fvwm2_SOURCES): added gsfr.h
   
    * configure.in: changed version to 2.3.1
   
    * fvwm/repeat.h:
    * fvwm/repeat.c:
    * fvwm/functions.c:
    * fvwm/functions.h:
    moved all code for Repeat command to repeat.c and repeat.h
   
    * fvwm/Makefile.am (fvwm2_SOURCES): added bindings.h, repeat.c,
    repeat.h

1999-04-06  Dominik Vogt  <[email-masked]>
   
    * fvwm/fvwm.c (CaptureAllWindows):
    (CaptureOneWindow):
    fixed coredump
   .
   .
   .
   * fvwm/functions.c (ExecuteFunction):
    additional input parameter: expand_cmd (suppress expanding '$...' on
    the command line).

I'll try and back through them unless you want to fess up and tell us
what you broke, (not to point fingers but your name is all over those
commits).  The last comment I grabbed from the changelog sounds auwfully
suspicious.

I did check and my prepocess output for the 2 versions diff exactlly the
same, so that is not the culprit

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]