Subject: another icon bug

From: Dominik Vogt <[email-masked]>
Date: Sat, 17 Apr 1999 15:11:36 +0200

When I iconify a window and the bottom edge of the window
is not on the current page, the window simply vanishes.
No icon can be seen anywhere on the desktop. In the pager
I still see the full window. FvwmIconMan indicates the
window has been iconified. However, I wouldn't take
module behaviour too serious with the GSFR for modules
still not completed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 18 Apr 1999 10:01:38 -0400

> module behaviour too serious with the GSFR for modules

This is  probably the logic that  trys to determine the  percentage of
the window that is offscreen  and directs the icon  to the screen that
the window is mostly on.

Theres been a   bit of discussion of  this  before, although I   don't
remember any consensus.    It seems to  me   the intuitive  choice  is
iconify to the current screen, regardless of the window position.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 Apr 1999 01:49:01 +0200

> iconify to the current screen, regardless of the window position.

There are some other places where the current screen is used when at least
a single pixel is on the current screen. Maximize does it this way and
Iconify should do the same. But I noticed something else here: I can't
remember what I did exactly, but once the icon suddenly appeared on the
right page and position. It was as if the icon was invisible.

Bye

Dominik ^_^