Subject: trouble running FvwmCommand

From: Dominik Vogt <[email-masked]>
Date: Wed, 21 Apr 1999 02:40:28 +0200

This may or may not have something to do with FvwmCommand itself,
but after upgrading my Linux system to glibc I can't run FvwmCommand
anymore (yes, I did recompile everything). When I try to start
FvwmCommandS it just says 'FvwmCommandS: dead pipe' and exits.
Any ideas?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Julian Gilbey <[email-masked]>
Date: Wed, 21 Apr 1999 03:45:54 +0100 (BST)

> FvwmCommandS it just says 'FvwmCommandS: dead pipe' and exits.

I get the same message, but mine runs anyway.  Is it possible that you
already have FvwmCommandS running when you start the second one?

   Julian

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

  Julian Gilbey, Dept of Maths, QMW, Univ. of London. [email-masked]
             Debian GNU/Linux Developer.  [email-masked]
       -*- Finger [email-masked] for my PGP public key. -*-
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 21 Apr 1999 11:37:23 +0200

> already have FvwmCommandS running when you start the second one?

No. There's nothing in the process list and when I try to run
FvwmCommand I get an error message.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 22 Apr 1999 00:36:08 +0200

> FvwmCommandS it just says 'FvwmCommandS: dead pipe' and exits.

Brr, problem solved. This has come up in early Ferbruary. The
module pipe was close because a block of size zero was written
into it. I had applied a fix on 12-feb-1999 to SendText
(libs/Module.c), but some kind soul took it out again. In the
ChangeLog I find entries by Paul (PDS) and Matthias that could
have caused this. Was there a special reason to remove the
check for a zero length just before the final 'write'?
For now I fixed this FvwmCommandS.c, but it's still buggy.
On a 2.2.x Linux kernel a zero write seems to close the pipe,
so doing this is illegal. Perhaps we should put there an
error message if a module attemtps to do this.

Bye

Dominik ^_^