Subject: FVWM CVS: fvwm hippo

From: CVS <[email-masked]>
Date: Thu, 1 Apr 1999 09:37:33 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/04/01 09:37:32

Modified files:
	fvwm           : add_window.c fvwm.c icons.c menus.c 

Log message:
More hacks at non-default visuals. Specifying border_pixmap & back_pixmap as
none. resize handles use the root visuals.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 1 Apr 1999 12:05:16 -0500

> none. resize handles use the root visuals.

Tim,
I just tried it with this, and there is no change.

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 2 Apr 1999 07:07:04 -0500

> I just tried it with this, and there is no change.

Well I'm not sure what changed, but it all works for me now with no
warnings at all.  That is it works with a current update of CVS so it
seems one of the other commits last night fixed it.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Apr 1999 15:08:36 +0200

> seems one of the other commits last night fixed it.

Maybe that's my temporary fix in add_window.c? Could you try whatever
you were trying without it? Remove this line:

  valuemask &= ~(CWColormap | CWBorderPixmap);

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 2 Apr 1999 10:24:40 -0500

>   valuemask &= ~(CWColormap | CWBorderPixmap);

Without it the problem reapears so that must be the fix.  The only thing
I was trying was starting fvwm with an already running x server.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 3 Apr 1999 00:14:09 +0200

> I was trying was starting fvwm with an already running x server.

Tim, would you take a look at my patch then?

Bye

Dominik ^_^

---

From: Tim Phipps <[email-masked]>
Date: Thu, 08 Apr 1999 10:05:38 +0100

> Tim, would you take a look at my patch then?

I think you've done the right thing. I added to colormap and pixmap
flags for the frame and forgot that it got passed on down to the other
windows. I'll clean up add_window.c a bit though, there is no need to do
bit manipulation on this stuff when it is only going to generate a fixed
number. It should be easier to see what's going on if it is spelled out
explicitly.

Cheers,
Tim.