Subject: Re: FVWM: more and more questions

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 21:59:39 +0200

Any ideas what Bob can do here? Is there a cleaner way than writing
afunction that modifies the style and does a recapture on all windows?

----- Forwarded message from Bob van der Poel <[email-masked]> -----

Dominik Vogt wrote:
> 
> On Wed, Mar 31, 1999 at 11:51:28AM -0700, Bob van der Poel wrote:
> 
> > Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
>                                                         ^^^^^^^^^^^^^
> 
> Whith this style option you are telling fvwm to ignore FvwmButtons
> in the Next function. Either remove this or turn it off explicitly
> for FvwmButtons only:
> 
>   Style FvwmButtons CirculateHit
> 

Ahhh! Thanks. So, is it possible then to have only the command bound to
Pause ignore CirculateSkip? If I do the 'Style FvwmButtons CirculateHit'
as you suggest, then all the commands will recogize the buttons. Most of
the time (like skipping between different apps) skipping the buttons is
fine...I just want a hot-key to force it to the top.

Another thing: is is possible to have a function deiconify ALL the
iconified windows on a given page or desk? Something like 'Next [*...]
Iconify -1'. Does this make sense?

BTW, I'm starting to HATE fvwm2! It is so much fun to sit around
tweaking the rc file that I'm getting absolutely NO WORK done.

-- 
   __
  /  )      /         Bob van der Poel
 /--<  ____/__        [email-masked]
/___/_(_) /_)         http://www.kootenay.com/~bvdpoel

----- End forwarded message -----

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 2 Apr 1999 06:26:11 -0500

> Iconify -1'. Does this make sense?

The current CVS has a function called all, that takes same conditions as
Next/Prev but works on all matches 
All (Iconic,CurrentPage) Iconify off

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sat, 3 Apr 1999 21:03:07 +0200

> Iconify -1'. Does this make sense?

Use the All command with the proper condition to select only windows
on the given page/desk (I dont know that condition offhand).

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]