Subject: fvwm 2.3.1 cores during restart

From: Dan Espen <[email-masked]>
Date: Sat, 17 Apr 1999 12:17:18 -0400

Around  line 1760  in fvwm.c  there is logic  that  prints the restart
commands args to stderr.  If there are less than 10 args, its attempts
to print "NULL" with "%s".  This is not good.  I'd fix it, but I don't
understand why anything should be printed to stderr at that point.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sat, 17 Apr 1999 22:45:39 +0200

> understand why anything should be printed to stderr at that point.

This is probably debugging code I forgot when I changed Restart
to use the session save/load mechanism. I'd say that 
fprintf(stderr,...) is a sure sign of forgotten debugging code,
since normal fvwm messages should go through fvwm_msg, no ?

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 18 Apr 1999 02:56:53 +0200

> since normal fvwm messages should go through fvwm_msg, no ?

Only in theory. There are some places where ouputs are done with
fprintf(stderr, ...). But most or all of them should be in some
modules.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]