Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Wed, 7 Apr 1999 14:51:08 -0500 (CDT)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/04/07 14:51:08

Modified files:
	.              : ChangeLog 
	fvwm           : Makefile.am add_window.c builtins.c functions.c 
	                 fvwm.c gsfr.h misc.h screen.h style.c 
	modules        : ChangeLog 
	modules/FvwmPager: x_pager.c 
Added files:
	fvwm           : style.h 

Log message:
* Fixed $n in functions.
* Some more style rewrite preparations (new file style.h).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 8 Apr 1999 08:14:50 -0400

> 	modules/FvwmPager: x_pager.c 

Dominik, 
you seem to have missed a deletion when you applied the patch I sent, x_pager.c currentlly look like this at line 1534

      sx = 0;
      sy = 0;
      if(window_w != 0)
    sx = (100*(x*(Scr.VxMax+Scr.MyDisplayWidth)/window_w- Scr.Vx)) /
      Scr.MyDisplayWidth;
      if(window_h != 0)
    sy = (100*(y*(Scr.VyMax+Scr.MyDisplayHeight)/window_h - Scr.Vy)) /
      Scr.MyDisplayHeight;
#ifdef DEBUG
      fprintf(stderr,"[scroll]: %d %d %d %d %d %d\n", window_w, window_h, x,
          y, sx,sy);
#endif
      sy = (100*(y*(Scr.VyMax+Scr.MyDisplayHeight)/window_h - Scr.Vy)) /
    Scr.MyDisplayHeight;
      /* Make sure we don't get stuck a few pixels fromt the top/left border.
       * Since sx/sy are ints, values between 0 and 1 are rounded down. */
      if(sx == 0 && x == 0 && Scr.Vx != 0) sx = -1;
      if(sy == 0 && y == 0 && Scr.Vy != 0) sy = -1; 

if you look close sy gets set twice you want to delete the one after
the #ifdef DEBUG, this one doesn't matter to much sx was the one that
was giving me troubles because window_w was 0, but we should cover them
both.

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 8 Apr 1999 14:59:51 +0200

> was giving me troubles because window_w was 0, but we should cover them

Thanks. Unfortunately I couldn't apply this with the patch command.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]