Subject: gsfr.h - renaming

From: Bob Woodside <[email-masked]>
Date: Mon, 26 Apr 1999 16:33:58 -0400

Let's make this a separate thread - it's not shedding any light on
Jay's problem with STICKY not working.

	To recap our story thus far, we have the following suggestions:

Tomas:
	flags.h
	styleflags.h

Dominik:
	window_flags.h

Bob:
	window_flags.h
 
	I go along with Dominik's idea, because this header really deals with
window state flags as well as window style flags. Not only that, but it
deals with the flags contained in a structure called, oddly
enough...window_flags.

- Bob
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Mon, 26 Apr 1999 22:40:39 +0200

> 	To recap our story thus far, we have the following suggestions:
[conspiracy part]
> deals with the flags contained in a structure called, oddly

Hm.. Maybe window_flags is better/best afterall.. flags is too general
and there's more than style in the flags..

I hereby officially (and unofficially too) change my vote to
window_flags.h

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Apr 1999 12:00:44 +0200

> deals with the flags contained in a structure called, oddly

I don't care much about the name anyway as long as you can guess from the
name what is in the file. The main problem in my eyes is that it's
extramely difficult to separate the style/flags related types and
structures from fvwm.h. I would like to have all style/flags related
stuff in one or two separate files, but as long as it refers to things
like FvwmWindow of icon boxes this won't work.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]