Subject: core dump with PlaceAgain Anim

From: Tim Phipps <[email-masked]>
Date: Tue, 27 Apr 1999 15:05:59 +0100

Hi All,
        Title says it all. With the current CVS PlaceAgain without the
Anim option works fine, the Anim option makes fvwm dump core.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Apr 1999 16:10:47 +0200

On Tue, Apr 27, 1999 at 03:05:59PM +0100, Tim Phipps wrote:
>         Title says it all.

Hmm, my mailer must have cut the stack trace from the subject ;-)

> With the current CVS PlaceAgain without the

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 28 Apr 1999 01:11:25 +0200

> Anim option works fine, the Anim option makes fvwm dump core.

Ugh, that code had a good bug-to-lines ratio (in ten lines of code).
I assume that was hacked in really late :-)

 - Memory leak in PlaceAgain_func: token acquired with GetNextToken
   has to be free'd. Better use PeekToken (no need to free it and
   faster).
 - PlaceAgain_func called AnimatedMoveOfWindow which is documented
   not to work with FvwmWindow's.
 - AnimatedMoveAnyWindow happily referenced a NULL tmp_win
   (IS_FIXED()).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]