Subject: Notification: incoming/287

From: [email-masked]
Date: Tue, 30 Mar 1999 23:54:58 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/287

Message summary for PR#287
	From: Dominik Vogt <[email-masked]>
	Subject: modules in .fvwm2rc screw up fvwm
	Date: Tue, 30 Mar 1999 19:45:36  0200
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Wed, 31 Mar 1999 11:34:41 +0100

[email-masked] wrote:
> With current CVS source (30-Mar-1999), fvwm fails
> to start up properly if .fvwm2rc contains a 'Module'
> command. Is that
> related to the new startup logic (Tim, Dan)?

There is something very wrong with the functions.c that you just
commited (the Repeat patch).  It core dumps on me, I don't have a
working gdb so I can't tell you what's wrong.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 12:48:06 +0200

> working gdb so I can't tell you what's wrong.

When does it coredump? Before anything is started? After the config
file has been parsed? Any error messages about commands not found?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 31 Mar 1999 12:15:16 +0100

> file has been parsed? Any error messages about commands not found?

It's after the config, winodows get decorated but none of the
initfunction modules appear before the crash.

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 1999 08:01:00 -0500

> command. I tried this with FvwmWinList, FvwmTaskBar
> and FvwmButtons. With WinList no windows
> were mapped at all but some of my bindings worked
> (no menus but page flipping with function keys as
> well as the transient pager on mb2). With the
> Taskbar only the taskbar window appeared. Is that

Sounds like it, the new startup logic made it necessary for
me to move FvwmAnimate into the InitFunction instead of just
starting it.

> Dominik ^_^

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]