Subject: Notification: incoming/255

From: [email-masked]
Date: Sat, 20 Mar 1999 18:29:41 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/255

Message summary for PR#255
	From: [email-masked]
	Subject: transient pager vs. middle button
	Date: Sat, 20 Mar 1999 18:29:39 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 21 Mar 1999 14:15:09 +0100

On Sat, Mar 20, 1999 at 06:29:41PM -0600, [email-masked] wrote:
> The new transient pager feature doesn't work correctly with
> the middle mouse button. I can pop up a transient pager
> and then use mb2 to move the input focus between windows.
> This works for some time, then the pager vanishes, but leaves
> the pointer grabbed to the rectangle of the vanished pager window.
> It seems there is some
> 
> if (is_transient)
>  {
>    XUngrabPointer (dpy);
>    exit (0);
>  }
> 
> missing in the code path for button 2 release, but I'm not
> sure where to put it. Dominik ?

I can't see this bug but I put that missing code before all
calls to 'exit'. Does it work now? I had assumed that X would
release the grabs when the pager dies. Shouldn't it do that?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 21 Mar 1999 23:25:23 +0100

> release the grabs when the pager dies. Shouldn't it do that?

I think so, but the transient pager is still not entirely transient:
If I pop it up and use button 2 to move the focus between windows,
it will stay up until I click on the background. I think it should
exit after the first button release, regardless which button it was.
The leftover grabs are gone with your fix.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Mar 1999 08:37:20 +0100

> The leftover grabs are gone with your fix.

Duh, all buttons should behave like button 3 in the transient pager.
What exactly did you do? Which button pops up the pager? E.g. like this:

  - press button 3 to pop up the pager
  - keep button 3 down and click button 2 to focus a window

Is that what you did?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 22 Mar 1999 09:19:59 +0100

>   - keep button 3 down and click button 2 to focus a window

No, I did

AddToMenu StartMenu
+ "Transient pager" FvwmPager -transient

Then the button used to pop up the menu is already released when
the pager comes up. I can then use button 2 in the way I described.

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Mar 1999 09:28:26 +0100

> the pager comes up. I can then use button 2 in the way I described.

Ah, yes. I didn't think about this case at all. Well, I see no
reason why the transient pager should be limited to the button
3 action. Should be fairly easy to implement.

Bye

Dominik