Subject: Notification: incoming/229

From: [email-masked]
Date: Tue, 9 Mar 1999 10:39:13 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/229

Message summary for PR#229
	From: [email-masked]
	Subject: FvwmButtons: Restart and stacking order
	Date: Tue, 9 Mar 1999 10:39:11 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Tue, 09 Mar 1999 17:09:50 +0000

> The problem now persists with the FvwmButtons module, which when on the
> bottom, ends
> up on top upon restart rather than in its original position.

This happens because the modules do not survive a restart but are killed
and restarted which puts them at the top.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked]
Date: Tue, 9 Mar 1999 12:15:16 -0500 (EST)

On  9 Mar, [email-masked] wrote:

> Congratulations for fixing the problem from fvwm 2.0.46 concerning
> preservation of
> stacking order of xterms upon restart.
> 

This is to be expected, as a restart of fvwm2 will also cause the
"RestartFunction" to be executed, where you will probably find that
FvwmButtons is being (re)launched.  It is the "newest" window at this
point, which puts it on the top of the stacking order.

I don't foresee this being "fixed" since it isn't really a bug.

-- 
Larry Gensch					      [email-masked]

I would really appreciate it if the login command had a better sense of humor.

---

From: Neil Zanella <[email-masked]>
Date: Tue, 9 Mar 1999 14:17:30 -0330 (NST)

> point, which puts it on the top of the stacking order.

Perhaps something like

Style FvwmButtons StaysOnBottom

would work. At what stage is the implementation of the StaysOnBottom style
option in fvwm2? It does not show up in the man page and trying to use it
seems to cause an error in my .xsession-errors file.

[FVWM][ProcessNewStyle]: <<ERROR>> bad style command: StaysOnBottom

Thanks.