Subject: FVWM CVS: fvwm clasen

From: CVS <[email-masked]>
Date: Tue, 16 Mar 1999 18:28:22 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	clasen	99/03/16 18:28:22

Modified files:
	modules        : ChangeLog 
	modules/FvwmGtk: FvwmGtk.1 FvwmGtk.c 

Log message:
Fix segfaults, replace snprintf by g_snprintf, implement tear-off menus
and spin-buttons.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 16 Mar 1999 20:34:19 -0500

OK but... where is this mythical g_snprintf? :)

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Wed, 17 Mar 1999 13:16:30 +0100

> OK but... where is this mythical g_snprintf? :)

Its part of glib, thus part of gtk. It should be present if configure
thinks that gtk is there. (I'm not fond of the "g_"-madness going
on in glib, but using g_snprintf seems to be a cheap way to avoid
problems with snprintf in FvwmGtk. )

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]