Subject: GSFR and CVS?

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 1999 19:08:32 +0200

Now that Gnome support has been committed, how should we
handle the GSFR in CVS? Should we branch and do the work
off the main branch? Or is it better to do it there and
break the sources for several days (i.e. won't compile
for a while)?

I vote for doing it on the main branch since it is already
enough work without keeping up to date to the current
sources. And perhaps more people participate in the effort
when the new framework is ready.

Comments?

-----

Paul (PDS), would you write the macro prototypes to access
the style flags as you wanted them? I think it's best to
put all this in a new header file, perhaps styleflags.h?
(I want to move away from the one-header-for-everything
approach anyway). I volunteer to do all the renaming and
moving of the flags. When the new 'API' is ready we can
begin rewriting the code.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 31 Mar 1999 09:04:57 +0100

Dominik Vogt wrote:
> sources.

Me too,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 1999 08:03:13 -0500

> when the new framework is ready.

I see no problem if we can't compile for a while.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jay Kuri <[email-masked]>
Date: Wed, 31 Mar 1999 08:09:33 -0500 (EST)

> > break the sources for several days (i.e. won't compile

	Is it possible to build (right now) a fully functional FVWM with
Gnome support?  (are there any other major bugs in the current snapshot)
I ask because I know some people using gnome apps are itching to get off
of Enlightenment.  

If so, can we leave the last snapshot that works (with Gnome) somewhere
people can get it?  

Jay

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 15:19:28 +0200

> If so, can we leave the last snapshot that works (with Gnome) somewhere

No, not immediately. There are some pretty serious bugs in CVS right
now.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Wed, 31 Mar 1999 09:10:00 -0500 (EST)

> No, not immediately. There are some pretty serious bugs in CVS right

I know that people are itching to do the GSFR, but maybe the Gnome stuff
is a good reason to call a feature freeze and work towards a beta release?

--
Steve Robbins                              <[email-masked]>

I'd probably be famous now, if I wasn't such a good waitress.