Subject: outstanding patches

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Mar 1999 21:58:48 +0100

The following patches are still lying around on my disk:

1) FvwmStyle module (in perl)
2) A large FvwmScript example
3) 'Replace' function to re-place a window on the screen
4) FvwmWinList ButtonFrameWidth patch
5) Some FvwmBorder patch by Tim (I think Tim has already taken
   care of this).
6) Dropping windows into the pager. The patch is for 2.0.46.
   Perhaps we could convince the author (Toshi Isogai) to
   update it for 2.3.x.
7) A patch by Matthias to split SmartPlacement and CleverPlacement
   into separate functions (Personally I think one Smart/Clever/...
   placement style is enough).

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Thu, 04 Mar 1999 18:15:19 -0500

>    Perhaps we could convince the author (Toshi Isogai) to

	I'd kind of like to see this one make it into 2.3.1, if Toshi's
willing.

	Of course, I'd also like to see dragging windows *out* of the pager
fixed. (It got broken sometime in the last week. I haven't had time to
research it - lots of changes have happened that affect the move code.)

- Bob

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 5 Mar 1999 10:09:18 +0100

> The following patches are still lying around on my disk:

[...]

>    placement style is enough).

??? I didn't do this. I don't even know what Smart/Clever/whatever
placement do...

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Mar 1999 13:21:43 +0100

> ??? I didn't do this. I don't even know what Smart/Clever/whatever

Sorry, it was Chrin Rankin I think.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Mar 1999 01:30:13 +0100

> 2) A large FvwmScript example

Anybody out there willing to take a look at these?

> 3) 'Replace' function to re-place a window on the screen

Is this patch needed? The 'Replace' function should be renamed
if it is committed.

> 4) FvwmWinList ButtonFrameWidth patch

I've no opinion on this one. Tim, I think you did look at this
patch. Should it be committed (with the change that the border
width is not limited)?

>    Perhaps we could convince the author (Toshi Isogai) to

I'll try to convince Toshi to do it ;-)

>    placement style is enough).

Rejected. Didn't apply to 2.3.x, 2.2.x and 2.1.4, so I gave up.
Doesn't seem so useful anyway.

Bye

Dominik

---

From: Steve Robbins <[email-masked]>
Date: Tue, 9 Mar 1999 09:41:21 -0500 (EST)

> Anybody out there willing to take a look at these?

If #2 is the script from "Eddy J. Gurney" <[email-masked]>, then I have it
too, and I will get to it eventually.

--
Steve Robbins                              <[email-masked]>

The revolution will not be televised.

---

From: "Eddy J. Gurney" <[email-masked]>
Date: Tue, 9 Mar 1999 10:27:36 -0500

On Mar 9 at  9:41, Steve Robbins wrote:
,--
| > On Thu, Mar 04, 1999 at 09:58:48PM +0100, Dominik Vogt wrote:
| > > The following patches are still lying around on my disk:
| > >
| > > 1) FvwmStyle module (in perl)
| > > 2) A large FvwmScript example
| >
| > Anybody out there willing to take a look at these?
|
| If #2 is the script from "Eddy J. Gurney" <[email-masked]>, then I have it
| too, and I will get to it eventually.
`--
And if it is, then I can try to answer any questions about it. To refresh
the memory of anyone who is interested, the large FvwmScript sample I sent
is an "xterm customization tool". It opens a "dialog box" (for lack of a
better term) with a bunch of predefined colors the user can click on to
select foreground/background colors (along with R/G/B sliders to select a
color not listed). It has buttons to select from 5 or 6 "good" xterm fonts,
and text boxes to put in a window title, etc. It will also optionally save
the selected xterm configuration to a file as a menu in .fvwm2rc-sourceable
format. The nice thing about windows opened this way is that "FvwmSaveDesk"
correctly saves all of the xterm settings for each window since they are
specified on the command line.

Anyway, if anybody has any questions about it, just let me know. A lot of
people at my company find it useful, so I thought I would offer it as an
"advanced" example of "FvwmScript" that could be included (possibly) in the
sample .fvwm2rc.

Eddy

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Mar 1999 23:43:22 +0100

> too, and I will get to it eventually.

It is. I'll delete it from my disk then and leave that up to you, Steve.

Bye

Dominik

---

From: Tim Phipps <[email-masked]>
Date: Mon, 22 Mar 1999 16:44:37 +0000

> patch. Should it be committed (with the change that the border

Just committed,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Mar 1999 20:21:11 +0100

> > patch. Should it be committed (with the change that the border

Fine. The only one outstanding is the Pager-Drag-In patch then.

Bye

Dominik ^_^