Subject: Re: Ok to commit these ?

From: Matthias Clasen <[email-masked]>
Date: Mon, 1 Mar 1999 10:18:04 +0100

> 
> > 
> > #define WIN_LAYER_DESKTOP                0
> > #define WIN_LAYER_BELOW                  2
> > #define WIN_LAYER_NORMAL                 4
> > #define WIN_LAYER_ONTOP                  6
> > #define WIN_LAYER_DOCK                   8
> > #define WIN_LAYER_ABOVE_DOCK             10
> > #define WIN_LAYER_MENU                   12
> > 
> 
> Sounds like this is what we want to do, or at least follow internally. 
> Especially if we're moving towards "Gnome Compliance". 
> 
> Also, Matt, "Backwards compatible" != ignoring future enhancements. 
> Using layers 1 and 2 by default are just as backwards compatible as 0 &
> 1, while letting us automatically take (nearly) full advantage of
> /having/ layers.  
> 
> Let's not grow an extra leg and then chop off the foot here.  We need to
> make it as easy for novice/intermediate users as it is for experienced
> ones.

Since everybody tries to convince me, I'll change the default values 
to 4 and 6 (you can still override this with DefaultLayers).

I'm not so sure about adding StaysOnBottom as a shortcut Style option.
If we do so, we will have to think about extending the WindowList
options and command conditions in analogous ways (for completeness 
and symmetry). I thought that that was exactly the reason for the
existance of the preprocessor modules: you can easily do
define(`StaysOnBottom',`Layer 2') and feed your rc through FvwmM4
without putting everybodies favourite shortcuts into fvwm proper.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Patrick Rogan <[email-masked]>
Date: Mon, 01 Mar 1999 10:49:06 -0500

> without putting everybodies favourite shortcuts into fvwm proper.

I'd like a StaysOnBottom command to make it simpler for the user, not
harder...  I want to give them access to "full functionality" with the
most basic of .rc files.  

Not everyone has time to be a "windowmanager rocket scientist". 

~p@

-- 

Patrick Rogan
-----------------------------------
Systems Engineer

Lycos, Inc.
1 Oxford Centre
301 Grant Street, Suite 525
Pittsburgh, PA   15219-1408
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]