Subject: Imagepath problem and atomic send

From: Dan Espen <[email-masked]>
Date: Tue, 16 Mar 1999 17:16:01 -0500

Here's Purify   output on the latest  CVS.   The  "Array bounds write"
shows where  the image path problem is,  and I think the "Array bounds
reads" may have something to do with the atomic send problem.

I haven't studied either yet.  (I don't want to take all the fun
away.)

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 27201 at Tue Mar 16 17:06:27 1999)
  * Purify 4.1 Solaris 2, Copyright (C) 1992-1997 Rational Software Corp. All rights reserved. 
  * For contact information type: "purify -help"
  * For TTY output, use the option "-windows=no"
  * Command-line: /opt/public/src/fvwm/2.3.0/fvwm2 
  * Options settings: -cache-dir=/tmp -always-use-cache-dir=YES \
    -chain-length=20 -purify \
    -purify-home=/opt/pkg/Rational/purify-4.1-solaris2 
  * Purify licensed to BELLCORE
  * Purify checking enabled.

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 27201)  ****
ABW: Array bounds write (2 times):
  * This is occurring while in:
	sprintf        [libc.so.1]
	SendDataToModule [modconf.c:169]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]
  * Writing 1 byte to 0x2a8814 in the heap.
  * Address 0x2a8814 is 1 byte past end of a malloc'd block at 0x2a8778 of 156 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	SendDataToModule [modconf.c:168]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 27201)  ****
ABR: Array bounds read (2 times):
  * This is occurring while in:
	strlen         [rtlib.o]
	make_named_packet [module.c:524]
	SendName       [module.c:553]
	SendDataToModule [modconf.c:170]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]
  * Reading 157 bytes from 0x2a8778 in the heap (1 byte at 0x2a8814 illegal).
  * Address 0x2a8778 is at the beginning of a malloc'd block of 156 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	SendDataToModule [modconf.c:168]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 27201)  ****
ABR: Array bounds read (2 times):
  * This is occurring while in:
	strcpy         [rtlib.o]
	make_named_packet [module.c:533]
	SendName       [module.c:553]
	SendDataToModule [modconf.c:170]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]
  * Reading 157 bytes from 0x2a8778 in the heap (1 byte at 0x2a8814 illegal).
  * Address 0x2a8778 is at the beginning of a malloc'd block of 156 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	SendDataToModule [modconf.c:168]
	ExecuteFunction [functions.c:320]
	HandleModuleInput [module.c:375]
	My_XNextEvent  [events.c:1677]
	HandleEvents   [events.c:195]
	main           [fvwm.c:554]
	_start         [crt1.o]

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Tue, 16 Mar 1999 23:36:24 -0500

> reads" may have something to do with the atomic send problem.

	Good ol' Purify! Wish I had it. I hadn't read your message before I
sent my reply to Steve, but it certainly looks like we're on the trail
of the culprit now. I feel much more confident that I haven't been
hallucinating.

> I haven't studied either yet.  (I don't want to take all the fun

	Of course, I was too busy trying to figure out what was happening with
ImagePath to follow any atomic send discussion. Oh, well, back to the
archives...

- Bob

---

From: Steve Robbins <[email-masked]>
Date: Wed, 17 Mar 1999 00:20:07 -0500 (EST)

On Tue, 16 Mar 1999, Dan Espen wrote:

> shows where  the image path problem is,

Yes it does, thanks.  I hope this fixes Bob's problem. 

--
Steve Robbins                              <[email-masked]>

If mashed potatoes were security guards, they wouldn't get much done.

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 17 Mar 1999 09:02:35 -0500

> reads" may have something to do with the atomic send problem.

Well I checked against the current CVS and the atomic send problem is
still there.  But I don't to see any more array bound errors anymore
just UMR's from the XCalls at startup (as expected).

So either I'm not getting far enough into a config to see the array
problems or they have been fixed but either way

________________________________________________________________________
And to recap for those not following the problem was with the new atomic
SendText when I start up fvwm2 -cmd "FvwmM4 ..." I see a kiillModule 10
(left over printf in killModule), which means by M4 is getting killed
without doing anything at all, so I just get the builtin config.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous