Subject: mouse bindings

From: Brad Giaccio <[email-masked]>
Date: Thu, 4 Mar 1999 08:33:59 -0500

Before I spend to much time tracking this down, is anyone else noticing
a problem with their mouse bindings, i.e. not distinguishing between
click, motion, and double correctlly?

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Mar 1999 17:05:05 +0100

> click, motion, and double correctlly?

Yes, now that you say it. When I click on a window border it is
interpreted as a 'move', not a 'click'.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Mar 1999 17:42:02 +0100

> interpreted as a 'move', not a 'click'.

Allright, we had that bug before. Something in the fvwm startup logic
screwed up. A while ago I made a patch that set Scr.ClickTime to a
negative value during startup to speed it up. As it is now fvwm
ends up with this negative value in the main loop. I don't know what
has been changed there. Who made the recent startup changes? Tim?

Bye

Dominik

---

From: Tim Phipps <[email-masked]>
Date: Thu, 04 Mar 1999 16:57:50 +0000

> has been changed there. Who made the recent startup changes? Tim?

Looks like Scr.ClickTime = -Scr.ClickTime is missing from StartupStuff()

I'll add it in a mo,
Tim.

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 4 Mar 1999 19:54:31 -0500

> Looks like Scr.ClickTime = -Scr.ClickTime is missing from StartupStuff()

Tim make sure you wrap it in an if the problem is that towards the end
of main it gets maid positive but SetClick in builtins switches it back
to negative because finsStartup isn't false yet.

Something like,
if( Src.ClickTime < 0)
	Scr.ClickTime -= Scr.ClickTime

---

From: Tim Phipps <[email-masked]>
Date: Fri, 05 Mar 1999 08:22:16 +0000

>         Scr.ClickTime -= Scr.ClickTime

Ta, this is exactly what I moved into StartupStuff().

Cheers,
Tim.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 05 Mar 1999 09:10:22 +0000

> Ta, this is exactly what I moved into StartupStuff().

Don't panic. What I actually put in was
  if (Scr.ClickTime < 0)
    Scr.ClickTime = -Scr.ClickTime;

Cheers,
Tim.