Subject: Re: focus

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 06:06:20 +0200

On Sun, Mar 28, 1999 at 10:34:35PM -0500, Steve Robins wrote:
> Hi Dominik,
> 
> My focus is acting differently after some changes today.
> 
> The only focus setting in .fvwmrc that I can find is:
> 
> 	Style "*term"		SloppyFocus
> 
> plus some specific window styles (FvwmButtons, etc).
> 
> Before this afternoon, this mean that the focus follows my mouse, with no
> click necessary.  Now, however, it is unpredictable: some windows get
> focus when I put the mouse over them, but some don't.  This happens with
> both xterms and emacs windows.
> 
> Do you think that some of your changes from today affect this?  If so, how
> can I get the old behaviour back? 

Possibly. I tried to change the GrabFocus/GrabFocusOff default. Do you
use one of these? If yes, before or after the SloppyFocus style is set?
If not, could you try GrabFocusOff explicitly in all lines with SloppyFocus?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Mon, 29 Mar 1999 00:32:16 -0500 (EST)

On Mon, 29 Mar 1999, Dominik Vogt wrote:

> use one of these?

Nope.

> If not, could you try GrabFocusOff explicitly in all lines with SloppyFocus?

This didn't help.  There was only one line (quoted above) that had
SloppyFocus on it.

But my fvwmrc didn't have a wildcard focus style command; so I tried
adding one: 

	Style "*" SloppyFocus, GrabFocusOff

and that appears to work.

--
Steve Robbins                              <[email-masked]>

If I had a rocket launcher, some son of a bitch would die.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 07:53:53 +0200

> and that appears to work.

Uh, yes, I assumed 'ClickToFocus' was the default style and put
a corresponding command into fvwm.c. If that's incorrect, what
used to be the default focus style?

Bye

Dominik ^_^

---

From: Steve Robbins <[email-masked]>
Date: Mon, 29 Mar 1999 01:45:20 -0500 (EST)

> used to be the default focus style?

The man page says the default was MouseFocus; see the Style entry.

Don't know what I want, but I know how to get it.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 08:49:07 +0200

> The man page says the default was MouseFocus; see the Style entry.

Fixed.

Bye

Dominik ^_^