Subject: Notification: incoming/221

From: [email-masked]
Date: Sat, 6 Mar 1999 20:01:58 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/221

Message summary for PR#221
	From: [email-masked]
	Subject: trouble with FvwmForm
	Date: Sat, 6 Mar 1999 20:01:57 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Mon, 08 Mar 1999 08:54:35 -0500

[email-masked] writes:
> Hello,
> I am having trouble with FvwmForm. When I enter the site
> http://www.fvwm.org/
> in the input field from the following snippet, six netscape
> windows pop up instead of one. All show the following as the
> "Location:". Most of the "Location:"s are inexistent. These
> locations are, in order:
> 
> file:/root/18
> file:/root/4
> file:/etc/X11/fvwm2/system.fvwm2rc
> file:/root/0
> file:/root/8
> http://www.fvwm.org/
> 
> The same happens with any URL I enter at the input field.
> Plus, hitting RETURN at the input field doesn't seem to work.
> 
> Is this a bug or is there something wrong with my code?
> 
> Module FvwmForm BrowserForm

This should follow the form definition.  I assume it did.

Preceed the form definition with:

DestroyModuleConfig BrowserForm*

I'm guessing that this my be why you had multiple copies of Netscape
appear, but I'm guessing.

> *BrowserFormPosition 61 332
> *BrowserFormLine expand
> *BrowserFormText "Website to browse: "
> *BrowserFormLine expand
> *BrowserFormInput website 31
> *BrowserFormButton quit "GO" RETURN

Despite what the man page says, replace "RETURN" with "^M"
(2 characters).

> *BrowserFormCommand /usr/bin/netscape $(website)

With the "DestroyModuleConfig" and "RETURN" changed, the
form worked OK for me.
> --

I'll leave the problem report opened at least until the "RETURN"
problem is dealt with.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]