Subject: Notification: incoming/283

From: [email-masked]
Date: Mon, 29 Mar 1999 08:24:51 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/283

Message summary for PR#283
	From: [email-masked]
	Subject: MenuStyle * Greyed not restored
	Date: Mon, 29 Mar 1999 08:24:49 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 1999 19:15:10 +0200

On Mon, Mar 29, 1999 at 08:24:51AM -0600, [email-masked] wrote:
> >From [email-masked]  Mon Mar 29 08:24:50 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id IAA12753
> 	for <[email-masked]>; Mon, 29 Mar 1999 08:24:49 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: 
> Version: 
> CVS_Date: 
> OS: 
> X_Server: 
> Submission from: (NULL) (194.202.174.12)
> 
> 
> Menu items which are disabled are displayed with the Greyed colour,
> but if the item is hilighted with the pointer and then the pointer
> moved the disabled item is drawn in normal colours:
> 
> MenuStyle * MWM, Foreground White, BackGround Black, Greyed Black
> 
> Try this on FvwmWinlist which has Maximize and Resize disabled

No, the greyed items are never drawn in any other colour. Did you
fix this already or do you use some peculiar hilighting options?
What are your hilighting styles?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Wed, 31 Mar 1999 09:02:39 +0100

MenuStyle * MWM, Foreground White, BackGround Black, Greyed Black
MenuStyle * ActiveFore Pink, Animation, HilightBackOff
MenuStyle * Foreground Black, Greyed Gray, ActiveFore Blue
MenuStyle * MenuFace DGradient 128 3 magenta 33 cyan 34 yellow 33
magenta
MenuStyle * PopupOffset 0 100

Don't forget you need a `Style * MWMFunctions' to get the disabling from
MWM_hints to work. The man page isn't clear about this.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 00:20:52 +0200

> MWM_hints to work. The man page isn't clear about this.

Fixed (this was much more difficult than it seemed).

Bye

Dominik ^_^