Subject: FVWM CVS: fvwm hippo

From: CVS <[email-masked]>
Date: Thu, 18 Mar 1999 05:48:01 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	hippo	99/03/18 05:48:01

Modified files:
	.              : AUTHORS ChangeLog NEWS 
	fvwm           : builtins.c fvwm2.1 

Log message:
Patch from Neil Bird to add conditions to WindowId

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Thu, 18 Mar 1999 15:59:39 +0000

Dominik Vogt wrote:
> Hm, shouldn't this be an option to WindowShade instead
> of a global option?

Well, long term I see it as a style option and I thought GlobalOpts was
the place for future styles. I know I'd end up with something like:

+ I WindowId $w (oclock) WindowShade shrink
+ I WindowId $w (Eterm) WindowShade shrink
+ I WindowId $w (!oclock) WindowId $w (!Eterm) WindowShade scroll

this gets very wide if you have lots of names to test.

Cheers,
Tim.