Subject: Notification: incoming/276

From: [email-masked]
Date: Fri, 26 Mar 1999 06:48:32 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/276

Message summary for PR#276
	From: [email-masked]
	Subject: '//' broken in config files
	Date: Fri, 26 Mar 1999 06:48:31 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 26 Mar 1999 13:00:12 -0500

On Fri, Mar 26, 1999 at 06:48:32AM -0600, [email-masked] wrote:
> 
> Since recently when using FvwmCpp a '//' in the config file is
> interpreted as a comment. This breaks existing config files and
> in fact I spent about an hour debugging before I found out.
> I would prefer to change this back to the old behaviour. If it is
> so important it has to be at least documented prominently somewhere.
> 
> 

Dominik, 
This may also be related to my problem withnotr being able to
use \ to escape text anymore.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 26 Mar 1999 16:25:52 -0500

[email-masked] writes:
> >From [email-masked]  Fri Mar 26 06:48:31 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id GAA08837
> 	for <[email-masked]>; Fri, 26 Mar 1999 06:48:31 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Dominik Vogt
> Version: 2.3.0
> CVS_Date: Can't remember
> OS: 
> X_Server: 
> Submission from: (NULL) (192.6.76.68)
> Submitted by: domivogt
> 

  What do you want to document?

  The man page is clear that the actual parsing is done by an external
program.  Are you using /usr/lib/cpp, or gcc with some flag?  Is there
some flag you can pass to your pre-processor to stop it from accepting
C++ comments?

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 26 Mar 1999 23:44:34 +0100

>   What do you want to document?

That the behaviour has changed compared to earlier versions of FvwmCpp.
If you'd ask me I'd simply change it back and document nothing.

> some flag you can pass to your pre-processor to stop it from accepting

This was directed to Steve. He did something to activate this. I didn't
bother to check what.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 26 Mar 1999 22:52:32 +0100

> use \ to escape text anymore.

No. I know quite well, when and why this was changed by whom.
I just wanted to remind Steve to think about it ;-)

Bye

Dominik ^_^

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Mar 1999 00:46:06 -0500 (EST)

Dominik,

I haven't the faintest clue what you're on about.  I may well have broken
something, but I haven't touched FvwmCpp in recent memory.  Not since Jan
10, if the ChangeLog can be believed. 

So if you want to be helpful, please be more explicit about what the
problem is.

--
Steve Robbins                              <[email-masked]>

If I had a rocket launcher, some son of a bitch would die.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 00:08:43 +0100

> 10, if the ChangeLog can be believed. 

Oh, how embarassing, I've seen some commit message from CVS the day
after I found out what happened (I didn't read my mail that day) and
just saw 'removed' and '//' in the message and instantly assumed you
had changed something there:

  Mon Mar  8 17:21:09 1999  Steve ROBBINS  <[email-masked]>

          * FvwmTaskBar/FvwmTaskBar.c:
          (RedrawWindow): removed C++-style // comments.

I'm really sorry. On the other hand that raises the question how this
has changed. I don't think it's somewhere in the code but more likely
has something to do with the way FvwmCpp is built (?)

Bye

Dominik ^_^

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Mar 1999 22:59:58 -0500

> has something to do with the way FvwmCpp is built (?)

Configure is involved to the extent that it figures out which
"cpp" parser FVWM_CPP points to.
It looks thru "$PATH:/lib:/usr/lib:/usr/ccs/lib"
(in that order) for a "cpp" program.
You can look in "config.status" to find the cpp
that you are using.

Do ./configure --help to find out how to override configures
choice, it looks to me like you can just export FVWM_CPP.

FvwmCpp just invokes the preprocessor found by configure.

---

From: Steve Robbins <[email-masked]>
Date: Sun, 28 Mar 1999 11:21:01 -0500 (EST)

>           (RedrawWindow): removed C++-style // comments.

I removed a C++-style "//" comment from the C code file FvwmTaskBar.c.  I
guess gcc accepts this sort of thing, but not all C compilers do.  This I
discovered when compiling with SGI's /bin/cc. 

But surely this has nothing to do with FvwmCpp breaking!
 
> has something to do with the way FvwmCpp is built (?)

Can you give us more details about what is happening?  Maybe it will jog
some memories.  You say that you "found out what happened".  What do you
mean by that?  What exactly did you find out?

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 19:24:27 +0200

> mean by that?  What exactly did you find out?

I found out that I can't use `sed -e "s/foo//g"` anymore in my
config file anymore since FvwmCpp causes everything behind the
'//' to be removed before the file is passed to fvwm2. This did
work with 2.2.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 20:11:32 +0200

> FvwmCpp just invokes the preprocessor found by configure.

Thought as much. I've investigated this a bit further and now
I can't make '//' work the way it used to with 2.2 or even 2.0.46.
I tried to convince the preprocessor to ignore '//' with the
-lang-c option that explicitly describes this in the manpage but
it still comments the '//'. In my config.cache i found two lines:

  ac_cv_path_FVWM_CPP=${ac_cv_path_FVWM_CPP=/usr/bin/cpp}
  ac_cv_prog_CPP=${ac_cv_prog_CPP='gcc -E'}

/usr/bin/cpp is a link to /usr/lib/gcc-lib/i486-linux/2.7.2.1/cpp

Anyway, I don't think that matters since I used
'-Cppprog /usr/bin/cpp' in my .xinitrc file.  The only way I could
find to get the behaviour I'm used to is to put this line in my
.xinitrc:

  exec /home/avatar/bin/fvwm2/fvwm2 -cmd "FvwmCpp -Cppprog
  '/usr/bin/gcc -ansi -E -' $HOME/.fvwm2rc"

Or better: replace the -ansi with -C.

Bye

Dominik ^_^

---

From: Pete Forman <[email-masked]>
Date: Mon, 29 Mar 1999 08:25:32 +0100 (BST)

> '//' to be removed before the file is passed to fvwm2. This did

Use another separator character, e.g. `sed -e "s?foo??g"`.

This sort of problem was bound to come up sooner or later as more C
preprocessors start to grok C++ or C9X.
-- 
Pete Forman
Western Geophysical
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 09:58:33 +0200

> Use another separator character, e.g. `sed -e "s?foo??g"`.

Yes, I'm already doing that, but that's not the problem. I'm
not discussiong this because my config isn't running anymore
but because it's difficult to find and can give users a hard
(and unhappy) time debugging.

> preprocessors start to grok C++ or C9X.

The funny thing is that my preprocessor hasn't changed in about
a year.  I wonder how you will compile old code with new preprocessors
if they don't allow you to switch back to the old behaviour.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]