Subject: The GSFR might be hard enough without this

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 1999 10:16:03 -0500

Heres Purify output from this mornings CVS.  We've got FUMs, UMRs, and
FMRs.  fvwm2 won't start for me.

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365 at Wed Mar 31 10:10:23 1999)
  * Purify 4.1 Solaris 2, Copyright (C) 1992-1997 Rational Software Corp. All rights reserved. 
  * For contact information type: "purify -help"
  * For TTY output, use the option "-windows=no"
  * Command-line: /opt/public/src/fvwm/2.3.0/fvwm2 
  * Options settings: -cache-dir=/tmp -always-use-cache-dir=YES \
    -chain-length=20 -purify \
    -purify-home=/opt/pkg/Rational/purify-4.1-solaris2 
PureLA: 1 simple license, 2 users.  Please remedy.
  * Purify licensed to BELLCORE
  * Purify checking enabled.

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FUM: Freeing unallocated memory (25 times):
  * This is occurring while in:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:539]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Attempting to free block at 0x14a158 already freed.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	expand         [functions.c:305]
	ExecuteFunction [functions.c:510]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * There have been 4 frees since this block was freed from:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:522]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
UMR: Uninitialized memory read (106 times):
  * This is occurring while in:
	ParseBinding   [Bindings.c:376]
	key_binding    [bindings.c:51]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Reading 4 bytes from 0xefffd0ec on the stack.
  * Address 0xefffd0ec is local variable "button" in function ParseBinding.

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
UMR: Uninitialized memory read (95 times):
  * This is occurring while in:
	ParseBinding   [Bindings.c:376]
	key_binding    [bindings.c:51]
	ExecuteFunction [functions.c:524]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Reading 4 bytes from 0xefffcecc on the stack.
  * Address 0xefffcecc is local variable "button" in function ParseBinding.

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FUM: Freeing unallocated memory (22 times):
  * This is occurring while in:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:539]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Attempting to free block at 0x14c338 in the heap, not obtained from malloc.
  * Address 0x14c338 is 31 bytes past end of a malloc'd block at 0x14c308 of 18 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	stripcpy       [Strings.c:106]
	AddToMenu      [menus.c:2879]
	add_another_item [builtins.c:647]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FUM: Freeing unallocated memory (9 times):
  * This is occurring while in:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:522]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Attempting to free block at 0x25b8e0 already freed.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	expand         [functions.c:305]
	ExecuteFunction [functions.c:510]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * There have been 5 frees since this block was freed from:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:539]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FUM: Freeing unallocated memory:
  * This is occurring while in:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:522]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Attempting to free block at 0x266020 already freed.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	expand         [functions.c:305]
	ExecuteFunction [functions.c:510]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * There have been 3 frees since this block was freed from:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:539]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FMR: Free memory read (4 times):
  * This is occurring while in:
	AddToDecor     [builtins.c:3878]
	add_item_to_decor [builtins.c:4014]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Reading 1 byte from 0x274e17 in the heap.
  * Address 0x274e17 is 31 bytes into a freed  block at 0x274df8 of 32 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	expand         [functions.c:305]
	ExecuteFunction [functions.c:510]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * There have been 7 frees since this block was freed from:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:522]
	AddToDecor     [builtins.c:3881]
	InitFvwmDecor  [fvwm.c:1305]
	add_item_to_decor [builtins.c:4005]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FMR: Free memory read (4 times):
  * This is occurring while in:
	AddToDecor     [builtins.c:3879]
	add_item_to_decor [builtins.c:4014]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Reading 1 byte from 0x274e17 in the heap.
  * Address 0x274e17 is 31 bytes into a freed  block at 0x274df8 of 32 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	expand         [functions.c:305]
	ExecuteFunction [functions.c:510]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * There have been 7 frees since this block was freed from:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:522]
	AddToDecor     [builtins.c:3881]
	InitFvwmDecor  [fvwm.c:1305]
	add_item_to_decor [builtins.c:4005]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
FUM: Freeing unallocated memory:
  * This is occurring while in:
	free           [rtlib.o]
	update_last_string [functions.c:221]
	ExecuteFunction [functions.c:539]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ComplexFunction2 [functions.c:936]
	ExecuteFunction [functions.c:531]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]
  * Attempting to free block at 0x266020 in the heap, not obtained from malloc.
  * Address 0x266020 is 59 bytes past end of a malloc'd block at 0x265fc8 of 30 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	safemalloc     [safemalloc.c:18]
	stripcpy       [Strings.c:106]
	AddToFunction  [functions.c:766]
	add_another_item [builtins.c:653]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	ReadSubFunc    [read.c:178]
	ReadFile       [read.c:198]
	ExecuteFunction [functions.c:524]
	main           [fvwm.c:509]
	_start         [crt1.o]

****  Purify instrumented /opt/public/src/fvwm/2.3.0/fvwm2 (pid 23365)  ****
Process 23368 about to exec /bin/sh as "sh".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 18:02:56 +0200

> FMRs.  fvwm2 won't start for me.

Can you mail me a config file that shows the problem? When I'm home
the first thing I'll do is fix this (well, after feeding and stroking
my remaining cats ^_^).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 19:07:10 +0200

> FMRs.  fvwm2 won't start for me.

Both problems from the log are fixed. If there's another problem
please tell me.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 1999 15:45:23 -0500

With the current CVS, some root keybindings don't work until I pull
up a menu with a mouse.

Some of my menu keybindings don't work, for example, the first hotkey
in a sub-menu.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 01:00:38 +0200

> With the current CVS, some root keybindings don't work until I pull

Can you give an example?

> Some of my menu keybindings don't work, for example, the first hotkey

Probably fixed now (at least I can't see this after the patch
I committed).

Bye

Dominik ^_^