Subject: Re: coredump in virtual.c

From: [email-masked]
Date: Fri, 5 Mar 1999 08:25:36 -0500

Dominik Vogt <[email-masked]> wrote:

>  I don't know how to reproduce this...

     Well, it's clearly the result of the window chains' getting somehow
corrupted or out of sync. I suspect it'll go away after Matthias commits
his new version of layer-aware raising.

     After the layer code has had a few days of stabilizing, we should
revisit this and really try to confuse FVWM with a flurry of
raising/lowering/page-switching/window-creation-and-destruction activity.

- Bob

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 5 Mar 1999 23:52:48 +0100

> his new version of layer-aware raising.

I just committed a new version. Hopefully it's better. It
should also make the ideas of fvwm and the pager about the stacking
order more similar...please have a look at that, too, when you
go confusing your wm. I also hope to have fixed the bug report
about the pager ignoring stacking order changes when clients
raise their own windows.

One more thing to test (I think Dan reported these):
* I have added a definition for XUrgencyHint to events.c in
  case it isn't defined by the X headers.
* I tried to add a check for SM to configure.in; the
  --disable-session is gone.   

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Sat, 6 Mar 1999 01:31:36 +0100

> about the pager ignoring stacking order changes when clients

FvwmPager dies when I Raise/Lower any window (they're on the same
layer) or create new windows...

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  12 (X_ConfigureWindow)
  Serial number of failed request:  1795
  Current serial number in output stream:  1797

Current cvs (+ some local windowshade patches, not activated/used when
crashing), solaris 2.6/sparc.

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 8 Mar 1999 18:27:58 +0100

> crashing), solaris 2.6/sparc.

Thomas, do you still see this ? I think I have squashed this bug. 

Matthias

---

From: Tomas Ogren <[email-masked]>
Date: Mon, 8 Mar 1999 18:30:30 +0100

> Thomas, do you still see this ? I think I have squashed this bug. 
   ^ eeeek! 8)

No, it's fixed... the only bug I know of right now (except for my
shading stuff I haven't checked in yet 8( ) is that the pixmaps in
titlebar buttons aren't drawn until the window gets activated...

Also.. it goes away if you move a window above it...

/Tomas

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Mar 1999 17:32:32 +0100

> Thomas, do you still see this ? I think I have squashed this bug. 

I've fixed that one.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Mar 1999 01:43:04 +0100

> about the pager ignoring stacking order changes when clients

Yes, the pager bus is fixed.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]