Subject: Notification: incoming/227

From: [email-masked]
Date: Sun, 7 Mar 1999 23:52:46 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/227

Message summary for PR#227
	From: [email-masked]
	Subject: FvwmButtons - container code
	Date: Sun, 7 Mar 1999 23:52:44 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Mar 1999 02:00:31 +0100

On Sun, Mar 07, 1999 at 11:52:46PM -0600, [email-masked] wrote:
> >From [email-masked]  Sun Mar  7 23:52:45 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id XAA05441
> 	for <[email-masked]>; Sun, 7 Mar 1999 23:52:44 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Peter Gray
> Version: 2.2
> CVS_Date: 
> OS: Solaris 6
> X_Server: 
> Submission from: (NULL) (130.130.68.4)
> 
> 
> FvwmButtons core dumps. I think the problem (or at least one of them)
> is in MakeContainer since it appears that there is the
> possibility that not all fields of the new structure are 
> initialised. In particular, I am not sure that the foreground
> and background colors are initialised in all cases.
> I think free is being called with garbage in parsecontainer.
> 
> I am still investigating this problem.
> 
> I am using the SUN compilers.
> 
> I hope I am not doing something stupid
> which is causing the problem.

I've fixed a coredump in FvwmButtons today that may be the thing you saw.
Could you check again with the current source?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]