Subject: doubleclicking icons broken

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 20:37:06 +0200

Did anybody ever notice that doubleclicking on an icon to
maximize is does not always work? About one time out of five
I get my root menu instead. The setting that might be related
to this are:

  ClickTime 250
  Style * SloppyFocus
  GlobalOpts MouseFocusClickRaises
  Mouse 1 I A Function "MenuOrIconify"
  AddToFunc MenuOrIconify
   + "Click"       Popup WindowMenu
   + "Motion"      Raise
   + "Motion"      Move
   + "DoubleClick" Iconify

This is nothing new, I see it for several months now. I'm not
even sure it ever worked as it should.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 05:34:27 +0200

On Mon, Mar 29, 1999 at 12:01:07AM +0300, [email-masked] wrote:
> On Sun, 28 Mar 1999, Dominik Vogt wrote:
> 
> > I get my root menu instead.
> 
> I am not sure if this is your case, but if the icon contains transparent
> color anywhere, you get root in this place. To check this you can run:
>   xsetroot -fg red
> 
> In the places where the pointer is black you will get move/maximize, and
> with red - root menu.

I don't think so, but I'll check that. It's more likely that
the problem has the same roots as the one that causes root menus
not being able to cope with doubleclicks always.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 00:31:57 +0200

> not being able to cope with doubleclicks always.

You were right. My netscape icon wants to be especially fancy:
not just that it has a transparent background, it even has a few
holes which blend perfectly into the background :(

Bye

Dominik ^_^