Subject: Re: FVWM: buttons

From: Dominik Vogt <[email-masked]>
Date: Sun, 7 Mar 1999 04:27:45 +0100

On Sun, Mar 07, 1999 at 12:07:36AM +0000, Andre De Boer wrote:
> Hello all,
> 
> Can somebody tell me why in the next configuration in my button-bar a
> buttonpress doesn't work:
> 
> 
> *FvwmButtons(2x2, Swallow "xload" "Exec exec xload" \ 
>   Action (Mouse 1) "Exec exec xosview -cua0 -net 200 -ul
> -l                        -geometry 325x325", \
>   Action (Mouse 2) "Exec exec xcpustate -interval 1
> -bg                           "#a4978e" -fg black", \  
>   Action (Mouse 3) "Exec exec /usr/local/bin/rxvt -fg
> khaki                       -bg darkolivegreen \
>                         -fat -n top -T Top -7 -e top" )
> *FvwmButtons(2x2, Swallow "xbiff" "Exec exec xbiff -bg SlateGray3 -fg
> black -update 60", \
>                            -file ~/Mail/inbox/Inbox", \
>   Action (Mouse 1) "Exec exec from | xmessage -file ~/Mail/inbox/Inbox"
> )

You should have a look at the X error output. The syntax you use
is not quite correct. But this has nothing to do with your bindings.

After a bit of debugging I found out that FvwmButtons
hangs in FvwmButtons.c (My_XNextEvent) in this line:

  if (select(fd_width,SELECT_TYPE_ARG234 &in_fdset, 0, 0, NULL) > 0)

What is select waiting for here? Some input from fvwm itself?
I noticed that the binding itself works if you click on the
topmost row of pixels (it's a bit hard to aim). This looks as
if fvwm had put an input only window over the application that
eats up all button presses. The parent window isn't supposed to
do this, right? Or does FvwmButtons not know about the parent
window?

Any ideas?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 14 Mar 1999 14:26:53 +0100

>   Action (Mouse 1) "Exec exec from | xmessage -file ~/Mail/inbox/Inbox"

Finally I figured out what is happening. It's very simple. Binding
buttons to swallowed windows simply hasn't been implemented. The
problem is that you'd have to grab the buttons in a rectangle
within the buttons window. I guess if we're going to change that
we need to reparent the application a second time so that
FvwmButtons can grab different buttons for each swallowed window.

I see two possibilities:

1) Change the manpage/FAQ to reflect the current state (easy, fast
   but not very nice).

2) Someone else tries to implement it (sorry, I still couldn't fetch
   a copy of those X books, so I could only guess what to do).

I'd prefer (2). Is anybody willing to do this?

Bye

Dominik