Subject: xterm with active icon completely broken

From: Dominik Vogt <[email-masked]>
Date: Fri, 26 Mar 1999 22:47:04 +0100

Iconifying xterms with is badly broken. First of all, when
you start an xterm with '+ai' (active icon), you don't get
an active icon at all. Second, if you move an iconified
xterm and then deiconify it the xterm is screwed up.
Although it is the right size it seems to think it is
still only the size of an icon, i.e. it draws only into
the first few dozen pixels in the top left edge.

Whoever will fix this (I guess it's Matthias' task), please
make sure that active icons work also: iconify an xterm and
move the icon around. With the old bug it would shrink to
the size of one character.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sat, 27 Mar 1999 02:28:44 +0100

> an active icon at all. Second, if you move an iconified

I got one. You just have to make sure there is no applicable
Style command with an Icon or NoIcon  option.  

> the size of one character.

Well, I didn't break it, but I just committed a change that
fixed it for me. The culprit seems to be a piece of code
that was added as ETERM_SUPPRORT. It sends synthetic ConfigureNotify 
events during opaque moves, but unfortunately, it always sends them
to tmp_win->w, even if we're moving the icon!

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 28 Mar 1999 22:51:56 +0200

Dominik,

one way to get an active icon xterm should be:

fvwm2 -cmd 'Style xterm StartIconic' & xterm +ai

Works for me.

Matthias 
_

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 22:02:17 +0200

> fvwm2 -cmd 'Style xterm StartIconic' & xterm +ai

My problem is not that I can't get the active icon (see
previous posting) but that it's broken. I don't use
active icons.

Bye

Dominik ^_^

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 28 Mar 1999 23:09:23 +0200

> previous posting) but that it's broken. I don't use

What exactly is broken with them ? I don't use active
icons for xterms either, so I don't know how they should
look like.

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 1999 05:21:29 +0200

> icons for xterms either, so I don't know how they should

Argh, these parallel mail threads are driving me nuts :)
I can't get an active icon as long as I explicitly define
an 'Icon' style for xterms:

  Style xterm Icon foo.xpm

==> no active icon

Without this line I get the active icon. This is not how
is should work. Defining a default icon must not prevent
applications from providing their own pixmap (this is not
the same as providing their own icons). This is different
from how 2.2 worked.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]