Subject: WindowShadeAnimate

From: Bob Woodside <[email-masked]>
Date: Tue, 02 Mar 1999 22:48:12 -0500

Tomas, did you ever get commit privileges? I've been hoping to see
WindowShadeAnimate show up in the CVS tree, but I haven't yet.

- Bob
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 02 Mar 1999 22:11:46 -0600

>>>>> "BW" == Bob Woodside <[email-masked]> writes:

BW> Tomas, did you ever get commit privileges?

He hasn't sent me an id/password pair.

 - J<

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 3 Mar 1999 22:49:19 +0100

> WindowShadeAnimate show up in the CVS tree, but I haven't yet.

Now I have.. and the 4-state thingie screwed it up for me a bit.. but I
got almost everything fixed.. just one issue right now which I haven't
been able to nail.. maybe someone knows how to fix...

How to reproduce:
Shade window
Maximixe in any direction (to fullscreen shows best)
Unshade window

While animating, the contents of the window is the same size as it was
when shading it...

It gets fixed if I call SetupFrame() before the actual animation, but
then it flashes to the correct size, back to title-only and animates
out... Looks butt ugly...

When trying to figure out what SetupFrame does that fixes this, my brain
gets lost.. could anyone with better knowledge look through it?

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Wed, 3 Mar 1999 23:33:11 +0100

> out... Looks butt ugly...

This is from glancing at the code of SetupFrame (l.1500ff)

#ifdef WINDOWSHADE
  if (!shaded) {
#endif
      XResizeWindow(dpy, tmp_win->w, tmp_win->attr.width,
		    tmp_win->attr.height);
      XMoveResizeWindow(dpy, tmp_win->Parent, cx,cy,
                        tmp_win->attr.width, tmp_win->attr.height);
#ifdef WINDOWSHADE
  }
#endif

Thus, if you maximize a shaded window, Maximize calls SetupFrame, 
but the client window is not actually resized (since "shaded" is true).
This is not a problem for non-animated WindowShade, since the call
to SetupFrame in WindowShade after resetting the "shaded" flag will
get it right). 

I'm not 100% sure what the proper fix is. Will it work to
simply remove the "if (!shaded)" in the cited place ? If not,
you could try to just use the two XMove calls instead of a full
SetupFrame...

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]