Subject: Re: Strange Behavior (core dumped) of FvwmButtons

From: Dominik Vogt <[email-masked]>
Date: Sun, 7 Mar 1999 18:40:56 +0100

On Fri, Feb 26, 1999 at 12:34:49AM -0600, [email-masked] wrote:
> Full_Name: Guangyong Xu
> Version: 2.2
> CVS_Date: 
> OS: Linux-2.0.36
> X_Server: XFree86-3.3.2
> Submission from: (NULL) (207.172.195.149)
> 
> 
> Hi, I've seen quite a few messages concerning the strange behavior of
> FvwmButtons. 
> Mine is quite interesting and I really cann't figure out what makes the
> difference
> here (when it worked or failed):
> I have a ButtonPanel in my FvwmButtons:
> 
> *FvwmButtonsPanel Chinese							
> *FvwmButtonsGeometry +0+0							
> *FvwmButtonsRows 1								
> *FvwmButtonsBack #d6d5fe							
> *FvwmButtonsFore red
> *FvwmButtonsFont -adobe-helvetica-bold-r-*-*-13-*-*-*-*-*-*-*
> #*FvwmButtonsFont -hku-fixed-medium-r-normal--0-0-72-72-c-0-big5.et-0
> #*FvwmButtonsPixmap pattern14.xpm
> *FvwmButtonsPixmap blue1.xpm
> 
> *FvwmButtons(Title GB,Icon gb.xpm, Action  `Exec cxterm -name cxterm -T
> "CXterm (GB)" &`)
> *FvwmButtons(Title Big5,Icon b5.xpm, Action  `Exec /usr/local/bin/cxterm
> -name cxtermb5 -T "CXterm (BIG5)" &`) 
> *FvwmButtons(Title HZ,Icon hz.xpm, Action `Exec /usr/local/bin/cxterm -name
> cxterm  -T "CXterm (HZ)" -e /usr/local/bin/hztty &`) 
> 
> 
> This caused FvwmButtons to dump core. I have located the problem to be at
> the last 
> setence (if I comment it out, FvwmButtons worked). Now, the strange thing
> is,
> if I change the last setence to :
> *FvwmButtons(Title HZ,Icon hz.xpm, Action `Exec cxterm -name cxterm  -T
> "CXterm (HZ)" -e /usr/local/bin/hztty &`) 
> just getting rid of the absolute path "/usr/local/bin", it would work!!!
> Anyone has an idea why?

Works on my system. If you have a coredump, could you please fetch us a
stack trace like this:

  # gdb fvwm2 core
  (gdb) where

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Guangyong Xu <[email-masked]>
Date: Wed, 10 Mar 1999 01:23:45 -0500 (EST)

> Works on my system. If you have a coredump, could you please fetch us a

Hi, the following is the stack trace you asked when it dumps the core:

------------------------------------------------------------------------
GDB is free software and you are welcome to distribute copies of it
 under certain conditions; type "show copying" to see the conditions.
There is absolutely no warranty for GDB; type "show warranty" for details.
GDB 4.16 (i486-slackware-linux), Copyright 1996 Free Software Foundation,
Inc...

warning: core file may not match specified executable file.
Core was generated by `/opt/libexec/fvwm/2.2/FvwmButtons 8 4 .fvwm2rc 0
8'.
Program terminated with signal 11, Segmentation fault.
#0  0x40139612 in ?? ()
(gdb) where
#0  0x40139612 in ?? ()
#1  0x805e390 in InitFvwmDecor (fl=Cannot access memory at address
0x4560206e.
) at fvwm.c:1234
Cannot access memory at address 0x45602066.
(gdb) 
------------------------------------------------------------------------

I can send you my .fvwm2rc file if you need it. Thanks.

All the best,
Guangyong Xu

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Mar 1999 09:14:39 +0100

> > Works on my system. If you have a coredump, could you please fetch us a

Oops, sorry, of course you had to fetch the stack trace for
FvwmButtons, not fvwm. Could you do it again, please?

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Guangyong Xu <[email-masked]>
Date: Wed, 10 Mar 1999 10:13:02 -0500 (EST)

> > Core was generated by `/opt/libexec/fvwm/2.2/FvwmButtons 8 4 .fvwm2rc 0

Sorry, I wasn't familiar with using gdb to fetch stack trace. The
following is what I got :

(my prompt) gdb /opt/libexec/fvwm/2.2/FvwmButtons core
GDB is free software and you are welcome to distribute copies of it
 under certain conditions; type "show copying" to see the conditions.
There is absolutely no warranty for GDB; type "show warranty" for details.
GDB 4.16 (i486-slackware-linux), Copyright 1996 Free Software Foundation,
Inc...
Core was generated by `/opt/libexec/fvwm/2.2/FvwmButtons 8 4 .fvwm2rc 0
8'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11/lib/libSM.so.6...done.
Reading symbols from /usr/X11/lib/libICE.so.6...done.
Reading symbols from /usr/X11/lib/libXext.so.6...done.
Reading symbols from /usr/X11/lib/libX11.so.6...done.
Reading symbols from /lib/libc.so.5...done.
Reading symbols from /lib/ld-linux.so.1...done.
#0  0x40139612 in __libc_free (mem=Cannot access memory at address
0x4560208a.
)
(gdb) where
#0  0x40139612 in __libc_free (mem=Cannot access memory at address
0x4560208a.
)
#1  0x805e390 in ?? ()
Cannot access memory at address 0x45602066.
(gdb) 

..................................................
All the best,
Guangyong Xu

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Mar 1999 15:48:56 +0100

> Cannot access memory at address 0x45602066.

Hmm, doesn't help much. Unless I can reproduce this somehow (which I can't)
I can do nothing. However I checked in a fix for a FvwmButtons coredump
recently into the source tree. Could you check again with the current
CVS source? I'll send you the current FvwmButtons sources in a private
email.

Bye

Dominik

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Mar 1999 20:57:54 +0200 (IST)

On Wed, 10 Mar 1999, Guangyong Xu wrote:

> Core was generated by `/opt/libexec/fvwm/2.2/FvwmButtons 8 4 .fvwm2rc 0 8'.

Too bad, signal 11. It seems to be hardware problem and there is not much
to be done. Take a look at http://www.bitwizard.nl/sig11/ hope it helps.

Migo.

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 10 Mar 1999 21:08:57 +0100

> to be done. Take a look at http://www.bitwizard.nl/sig11/ hope it helps.

Uh.. you get a segmentation fault if you fiddle with someone elses
memory as well, it's not a "hardware problem" signal...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]