Subject: FVWM CVS: fvwm clasen

From: CVS <[email-masked]>
Date: Wed, 17 Mar 1999 14:19:30 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	clasen	99/03/17 14:19:30

Modified files:
	.              : AUTHORS NEWS ChangeLog 
	fvwm           : builtins.c 

Log message:
Enhanced CursorStyle to do colors and pixmap cursors.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 18 Mar 1999 08:05:05 -0500

> Enhanced CursorStyle to do colors and pixmap cursors.

you forgot the man page update for this, and I can't seem to make it
work the way I think it should.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Thu, 18 Mar 1999 16:03:38 +0100

> work the way I think it should.

Oops yes, that will follow tonight. In short, the new syntax is

CursorStyle context cursor-num-or-xpm [ fg bg ] 

cursor-num-or-xpm can either be a number, indicating a standard
X glyph cursor, or the name of an xpm file. fg/bg are the colors
(defaulting to B/W).

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Thu, 18 Mar 1999 16:03:38 +0100

---

From: [email-masked] (Paul D. Smith)
Date: 18 Mar 1999 10:16:00 -0500

%% Matthias Clasen <[email-masked]> writes:

  mc> cursor-num-or-xpm can either be a number, indicating a standard
  mc> X glyph cursor, or the name of an xpm file. fg/bg are the colors
  mc> (defaulting to B/W).

I wonder, is there any programmatic way to allow the X glyph cursors to
be selected by name, as well as number?  That seems like a very nice
user-friendly feature.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Thu, 18 Mar 1999 16:24:21 +0100

> be selected by name, as well as number?  That seems like a very nice

grep cursor-name /usr/include/X11/cursorfont.h | sed -e 's/.*XC_.* \(.*\)/\1/'

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 18 Mar 1999 16:33:55 +0100

> grep cursor-name /usr/include/X11/cursorfont.h | sed -e 's/.*XC_.* \(.*\)/\1/'

Just a note:

This works not on every platform. Some implementations of grep/sed require
the backslash befor '(' and ')' and some require that it's not there.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]