Subject: FVWM CVS: fvwm dane

From: CVS <[email-masked]>
Date: Sat, 20 Mar 1999 14:08:48 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	99/03/20 14:08:47

Modified files:
	modules        : ChangeLog Makefile.am 
	modules/FvwmCommand: Makefile.in 
	modules/FvwmConsole: Makefile.in 
	modules/FvwmDebug: Makefile.in 
	modules/FvwmForm: FvwmForm.1 FvwmForm.c FvwmForm.h Makefile.am 
	                  ReadXServer.c 
	modules/FvwmScript: Makefile.in 
Added files:
	modules/FvwmForm: FormFvwmCapture. FormFvwmForm. 
	                  FormFvwmQuitVerify. FormFvwmRlogin. 
	                  FormFvwmTalk. FormFvwmTalkHelp. 
Removed files:
	modules/FvwmForm: .FormFvwmCapture .FormFvwmQuitVerify 
	                  .FormFvwmRlogin .FormFvwmTalk. 
	                  .FormFvwmTalkHelp. DefineMe.c 
	modules/FvwmTalk: .cvsignore FvwmTalk.1 FvwmTalk.c FvwmTalk.h 
	                  Makefile.am 

Log message:
* FvwmTalk: If I did this right, the FvwmTalk directory should
disappear.

* FvwmForm/ReadXServer.c: Paste tab as a space when the input form
only has one input field.

* FvwmForm/FvwmForm.c (main): Remove the builtin customization form,
there is now a way to do this with a standalone form definition.
Add "UseData" command.

* FvwmForm/FvwmForm.1: Add FvwmTalk, other cleanups.

* FvwmForm/FormFvwmTalkHelp.: New naming rule.

* FvwmForm/FormFvwmTalk.: New naming rule.

* FvwmForm/FormFvwmRlogin.: New naming rule.

* FvwmForm/FormFvwmQuitVerify.: New naming rule.

* FvwmForm/FormFvwmForm.: New naming rule.

* FvwmForm/FormFvwmCapture.: New naming rule.

* FvwmForm/Makefile.am (config_DATA): Remove DefineMe.c, rename forms,
provide FvwmTalk replacement shell.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 20 Mar 1999 21:55:16 -0500

%% CVS <[email-masked]> writes:

  c> 	modules        : ChangeLog Makefile.am 
  c> 	modules/FvwmCommand: Makefile.in 
  c> 	modules/FvwmConsole: Makefile.in 
  c> 	modules/FvwmDebug: Makefile.in 
  c> 	modules/FvwmScript: Makefile.in 

What the hell is going on here?  Why do these @#$%&* Makefile.in files
keep re-appearing?

I just don't get it.  It must be a bug in CVS.  What version of CVS are
you using?

Have you tried removing and checking out a brand new copy recently?  Do
you use the "-P" option on your update line, or have it in your ~/.cvsrc
file?

It seems like once a week or so a commit adds back some of the .in
files.  Extremely aggravating.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Sun, 21 Mar 1999 04:21:19 +0100

> What the hell is going on here?  Why do these @#$%&* Makefile.in files

Because the CVS/Entries still list them for people.

EVERYONE: Hunt down those Makefile.in in CVS/Entries everywhere.. zap
those lines.

Should be taken care of by CVS, but doesn't seem to... so we have to do
it manually.. (or do rm -rf;cvs co ...)

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {cs,ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 21 Mar 1999 10:47:32 -0500

> What the hell is going on here?  Why do these @#$%&* Makefile.in files

Beats me.

> I just don't get it.  It must be a bug in CVS.  What version of CVS are

Concurrent Versions System (CVS) 1.10 `Halibut' (client/server)

> you use the "-P" option on your update line, or have it in your ~/.cvsrc

-P is my way of my .cvsrc:

Me> cat ~/.cvsrc
update -dP
diff -uBb

I'll check out a fresh copy.  It's been a few weeks since the last one.

> files.  Extremely aggravating.

Sorry.  Eventually it'll get under control.
I looked for it, but didn't see it happening.

> -- 
>  Paul D. Smith <[email-masked]>         Network Management Developmen

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Sun, 21 Mar 1999 13:12:33 -0500 (EST)

> What the hell is going on here?  Why do these @#$%&* Makefile.in files

I keep wondering if there was some strange interaction when I removed the
Makefile.in's but then added .cvsignore files containing Makefile.in at
nearly the same time.

Perhaps if the .cvsignore file got created first, then the command to
remove Makefile.in was ignored?

At any rate, everyone should try

	find . -name Entries -print | xargs grep Makefile.in

to see if there are any leftovers.  If so, you'll have to remove both
Makefile.in *and* .cvsignore, then

	cvs remove Makefile.in && cvs commit -m 'removing Makefile.in'

... or just pull down a fresh copy of the entire tree.

--
Steve Robbins                              <[email-masked]>

Well, you tried it just once, and found it alright for kicks,
Now you found out that it's a habit that sticks,
And you're an orgasm addict.

---

From: [email-masked] (Paul D. Smith)
Date: 21 Mar 1999 15:06:25 -0500

'S not your fault, Dan.

It's unquestionably a bug in CVS.  If you update to the latest, then
there's no way files that were deleted in that latest should "reappear"
in the tree, under any circumstances unless you explicitly add them
back.

Still, it's aggravating :)

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 21 Mar 1999 14:01:08 +0100

On Sat, Mar 20, 1999 at 02:08:48PM -0600, CVS wrote:
>...
>...
>...

What exactly have xou done with FvwmTalk, Dan? Did you reimplement
it with FvwmForm?

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 21 Mar 1999 20:01:43 -0500

> What exactly have xou done with FvwmTalk, Dan? Did you reimplement

Exactly.