Subject: Notification: incoming/230

From: [email-masked]
Date: Tue, 9 Mar 1999 11:29:29 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/230

Message summary for PR#230
	From: [email-masked]
	Subject: recursive invocation of menus
	Date: Tue, 9 Mar 1999 11:29:27 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Tue, 09 Mar 1999 14:52:19 -0500

[email-masked] writes:
> Hello,
> Fvwm2 just feels so much better when it comes to menus... extra large menus
> that
> don't fit on the screen have the "More..." menu and when they are opened by
> the edge
> of the screen my pointer is not moved, the menu opens on the correct side,
> etc...
> Thank you all. What a great job!
> 
> I discovered a new potential bug in the menus which I will illustrate with
> the following example:
> 
> 
> AddToMenu Utilities "Utilities"         Title
> ...
> +                   "Applications"      Popup Applications
> ...
> 
> AddToMenu Applications "Applications" Title
> ...
> +                      "Utilities"    PopUp Utilities
> ...
> 
> This configuration can be useful when menus are just full of menus and
> submenus
> and one wants to have some repetition to make finding things a little
> easier.
> 
> With this configuration, if I PopUP Utilities, then Applications, and then
> try to
> PopUp Utilities again from within the Applications submenu then nothing
> pops up.

Actually, I find that if  you click on  the  submenu in question,  the
original menus drop down,  and then the  new menu pops  up as a  fresh
menu.

I didn't try it with another menu in between...

I like the word "feature" better than "Potential bug".

If this is documented behavior, I'm all for it.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]