Subject: Notification: incoming/282

From: [email-masked]
Date: Sat, 27 Mar 1999 18:16:37 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/282

Message summary for PR#282
	From: [email-masked]
	Subject: Move bugs
	Date: Sat, 27 Mar 1999 18:16:36 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 21:11:14 +0200

On Sat, Mar 27, 1999 at 06:16:37PM -0600, [email-masked] wrote:
> >From [email-masked]  Sat Mar 27 18:16:36 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id SAA10897
> 	for <[email-masked]>; Sat, 27 Mar 1999 18:16:36 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: Move bugs
> 
> Full_Name: Tomas Ögren
> Version: 2.3.x
> CVS_Date: mar23
> OS: Solaris 2.6
> X_Server: Xsun
> Submission from: (NULL) (130.239.117.81)
> 
> 
> Ok.. pretty straight-forward and easy to reproduce..
> Start a single-window session (just one xterm, no more, no less).
> fvwm2 -f the_file_from_below
> And then move the xterm named 'Move_me' down across the page border, the
> xterm you
> started fvwm2 from will follow (but not 'Ignore_me'). Move it back and move
> the
> fvwm2-start-xterm window instead, 'Move_me' will follow ('Ignore_me'
> won't.)
> (The titles are just cosmetic, won't affect anything)

Nope, I can't reproduce this. It works fime on my machine.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 30 Mar 1999 23:32:49 +0200

> Nope, I can't reproduce this. It works fime on my machine.

I *do* see the described behaviour/bug. Perhaps "follows" is not
a very exact description; when moving "Move_me" across a page
boundary, the original xterm behaves as if it was sticky.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Wed, 31 Mar 1999 01:34:53 +0200

> Date: Tue, 30 Mar 1999 23:32:49 +0200
> X-Authentication-Warning: peano.mathematik.uni-freiburg.de: clasen set sender to [email-masked] using -f
> From: Matthias Clasen <clasen@pong>
> CC: [email-masked]
> Sender: [email-masked]
> Precedence: list
> X-Majordomo: 1.94.jlt7
> 
> > > 

I have fixed one typo in MoveViewport now, improving the situation
somewhat. But there is still a problem with window_being_moved:
Try the following: move a large window (large enough to exceed 
OpaqueMoveSize) to a new page (ie watch the window stay where it
was and the rubberband move to the new page) without releasing the
button. Now move it back to the original page, still holding the button.
The window being moved has disappeared! It wont appear again until
you release the button.

With Tomas setup, I get a different problem: During moves, the
windows behave as if they were sticky: If I move the rubberband
to a new page, the window appears in its original position on the new page
and canceling the action with esc leaves the window on the new page.
I have no idea why this happens in Tomas minimal setup.

Matthias

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 23:56:37 +0200

> I have no idea why this happens in Tomas minimal setup.

My fault. That was a bugfix to prevent the window to flicker to
its original position when flipping pages. Doesn't work with
rubberband moves, however. It's fixed.

Bye

Dominik ^_^