Subject: Parse.c just checked in

From: Brad Giaccio <[email-masked]>
Date: Tue, 23 Mar 1999 08:41:14 -0500

here is what I get from the Parse.c that was just checked in 
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..  -I/usr/local/X11R6/include    -g -O2 -c Parse.c
Parse.c: In function `DoGetNextToken':
Parse.c:275: `t' undeclared (first use this function)
Parse.c:275: (Each undeclared identifier is reported only once
Parse.c:275: for each function it appears in.)
Parse.c:276: `c' undeclared (first use this function)
Parse.c: At top level:
Parse.c:286: parse error before `else'
Parse.c:294: `t' undeclared here (not in a function)
Parse.c:294: warning: data definition has no type or storage class
Parse.c:295: parse error before `if'
Parse.c:298: `start' undeclared here (not in a function)
Parse.c:298: warning: initialization makes integer from pointer without a cast
Parse.c:298: initializer element is not constant
Parse.c:298: warning: data definition has no type or storage class
Parse.c:299: warning: initialization makes pointer from integer without a cast
Parse.c:299: initializer element is not constant
Parse.c:299: warning: data definition has no type or storage class
Parse.c:300: parse error before `if'
Parse.c:317: parse error before `++'
Parse.c:327: parse error before `++'
Parse.c:330: conflicting types for `text'
Parse.c:298: previous declaration of `text'
Parse.c:330: warning: data definition has no type or storage class
Parse.c:331: parse error before `if'
Parse.c:337: redefinition of `token'
Parse.c:299: `token' previously defined here
Parse.c:337: warning: data definition has no type or storage class
Parse.c:338: parse error before `}'

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 23 Mar 1999 08:52:08 -0500

> Parse.c: In function `DoGetNextToken':

Brad,

  You are too quick.  Thats me and PCL-CVS not getting along.
Plus it detected some conflict markers I left in by mistake, but
finished the commit anyway.

  I believe CVS should be OK now.

  I know, I know.
Compile, test, "cvs update", compile, test, "cvs commit".
Or something like that.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 23 Mar 1999 08:57:12 -0500

> Compile, test, "cvs update", compile, test, "cvs commit".

Dan, 
I was to quick I did get the file with the conflicts first then I
got the file again and after receiving this message I tried once more
and what is currentlly in CVS is giving me the compile errors it looks
like you are missing/loosing some variable declerations.

Brad

---

From: Dan Espen <[email-masked]>
Date: Tue, 23 Mar 1999 09:07:49 -0500

Brad Giaccio <[email-masked]> writes:
> > > gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..  -I/usr/local/X11R6/include    -g -
> O2 -
> > > c Parse.c

Mental note to Dan, finish your coffee before commiting changes.

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 23 Mar 1999 09:10:17 -0500

> Mental note to Dan, finish your coffee before commiting changes.

Just for your piece of mind it works now, well Parse.c builds now I'll
move onto checking the resto f my problems.