Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Tue, 30 Mar 1999 11:45:05 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/03/30 11:45:04

Modified files:
	.              : ChangeLog 
	fvwm           : menus.c 
	libs           : Bindings.c 
	modules        : ChangeLog 
	modules/FvwmCpp: FvwmCpp.1 

Log message:
* Fixed UMR in Bindings.c
* Applied multiple menu hotkey patch by Mike Han
* Updated FvwmCpp BUGS section

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael Han <[email-masked]>
Date: Tue, 30 Mar 1999 10:26:12 -0800

Previously...
>* Updated FvwmCpp BUGS section

Ugh, could you please back out my hotkey patch? I've got a few pending
problems with it, including a coredump... Only discovered them after
submitting the patch and was quietly hoping they'd disappeared into
the ether... Alas.
-- 
[email-masked]
I will not use abbrev.
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 06:39:41 +0200

> submitting the patch and was quietly hoping they'd disappeared into

Why? If there are problems we'll fix them. What do you think is
broken?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 06:39:59 +0200

Bye

Dominik ^_^

---

From: Michael Han <[email-masked]>
Date: Tue, 30 Mar 1999 22:22:10 -0800

Previously...
>Why? If there are problems we'll fix them. What do you think is

I'm currently trying to track down two problems I know of with my
changes:

1)  PopUp a menu; move the mouse out of the menu area; hit a shortcut
key -- you should dump core just as menuShortcuts() enters the block
of code I added.

2) I get inconsistent (and wrong) behavior if there are *exactly* two
instances of a shortcut key, and one of them falls at either end of
the menu... This may actually generalize to problems with two menu
items duplicating, which sounds an awful lot like an "off-by-one", but
if it is, I haven't yet figured it out... It's driving me nuts,
actually. An example of a menu that should demonstrate the problem
might be:

"&A"
"&B"
"&A2"
"&C"
-- 
[email-masked]
I will not go near the kindergarten turtle

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 1999 09:01:07 +0200

> key -- you should dump core just as menuShortcuts() enters the block

Coredumps are easy to fix. I'll look at this at home.

> actually. An example of a menu that should demonstrate the problem

The menu code always gets inconsistent when you touch it. In its
current state its nearly impossible to do something without
breaking something else. It's rather touchy.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 00:19:51 +0200

> actually. An example of a menu that should demonstrate the problem

Well, you can stop tracking. The coredump was caused by miCurrent
being zero. Your other problem was the exit condition of the for
loop. You had to make sure the body was executed at least once
before comparing with miCurrent. A simple do-while loop does this
well.

Bye

Dominik ^_^

---

From: Michael Han <[email-masked]>
Date: Wed, 31 Mar 1999 21:31:57 -0800

Previously...
>before comparing with miCurrent. A simple do-while loop does this

Ah... Cool. And I see you fixed the problem I forgot, that it failed
to hit the first item in menus... Also having to do with the exit
condition in the loop, I imagine. Well, thanks for fixing my bugs!
-- 
[email-masked]
My homework was not stolen by a one-armed man
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]