Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Sat, 6 Mar 1999 20:40:52 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/03/06 20:40:52

Modified files:
	.              : ChangeLog 
	docs           : ChangeLog mod_f2m_communication.html 
	                 mod_initialization.html 
	extras         : ChangeLog 
	extras/FvwmCommand/scripts: focus-link.pl 
	extras/FvwmConfig: FvwmConfig.C 
	extras/FvwmDebug: FvwmDebug.1 FvwmDebug.c 
	extras/FvwmGoodStuff: FvwmGoodStuff.c 
	extras/FvwmScript: FvwmScript.c 
	extras/FvwmTaskBar: FvwmTaskBar.c 
	extras/FvwmWharf: FvwmWharf.c 
	extras/fvwmperl: FvwmDebug.pl FvwmForm.pl MiniPerl.pl 
	                 fvwmmod.doc fvwmmod.pl 
	extras/fvwmpython: Fvwm.py 
	extras/fvwmpython/Manual: fvwm_man.html 
	fvwm           : Makefile.am builtins.c complex.c functions.c 
	                 fvwm.c menus.c menus.h misc.h parse.h screen.h 
	                 windows.c 
	libs           : Module.c 
	modules        : ChangeLog 
	modules/FvwmBacker: FvwmBacker.c 
	modules/FvwmButtons: FvwmButtons.c 
	modules/FvwmForm: FvwmForm.c 
	modules/FvwmIconBox: FvwmIconBox.c 
	modules/FvwmIconMan: FvwmIconMan.c 
	modules/FvwmIdent: FvwmIdent.c 
	modules/FvwmPager: FvwmPager.c 
	modules/FvwmRearrange: FvwmRearrange.c 
	modules/FvwmSave: FvwmSave.c 
	modules/FvwmSaveDesk: FvwmSaveDesk.c 
	modules/FvwmWinList: FvwmWinList.c 

Log message:
* removed patches that changed names of Send_windowList, Send_Config_Info
and set_mask

* fixed sort order bug (CygWin) by forcing function table names to be
upper case

* fixed coredump when a menu/function tries to delete itself

* merged functions.c and complex.c

* moved the code for function handling from menus.c to functions.c (this is a
bit more code but saves a lot of bytes for each item of a function).

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Sun, 7 Mar 1999 04:30:55 +0100

> Changes by:	domivogt	99/03/06 20:40:52
[...]
> 	                 fvwm.c menus.c menus.h misc.h parse.h screen.h 

You forgot functions.h, included by misc.h

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]