Subject: FVWM CVS: fvwm clasen

From: CVS <[email-masked]>
Date: Mon, 29 Mar 1999 17:34:17 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	clasen	99/03/29 17:34:16

Modified files:
	fvwm           : fvwm2.1 

Log message:
Make the line about '^^' appear in the man output, add a reference
to style options to Iconify explanation.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 30 Mar 1999 01:50:32 +0200

There was some discussion about the behaviour of icons wrt
deiconification and focus recently. I have spent some time
tonight to investigate the issues and I'm not sure there is 
any bug to fix; maybe we just need a more thorough explanation
of icon behaviour in the man page...

Here is what i found:

If you iconify a nonsticky app, the icon will deiconify to the
old location (which may well be on another page if the icon is moved)

An icon takes the focus only if it represents a window on the current 
page - ie after moving the icon across a page boundary it will become
unfocusable.

Icons of sticky apps or icons with stickyicon style will deiconify to
the current page and thus they are focusable on all pages. 

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]