Subject: FVWM2 Configuration

From: David Frye <[email-masked]>
Date: Sat, 06 Mar 1999 14:27:56 -0500

I am trying to get FVWM2 to look like WindowMaker. I can duplication the
color schemes, but have thus far been unable to duplicate the "Look" of
the Title Bar. I am also trying to figure out how to use Control-Tab to
rotate (autocirculate) through the  windows on the screen and have the
window on top automatically receive focus without having to click in/on
it with the mouse. Can someone help here ?
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Michael C Tilstra <[email-masked]>
Date: Sat, 6 Mar 1999 23:24:16 -0600

On Sat, Mar 06, 1999 at 02:27:56PM -0500, David Frye wrote:
> the Title Bar.
[snip]
> Can someone help here ?

here's something I barrowed from the fvwm2gnome ppl sometime ago.  You can
find their stuff at http://fvwm2gnome.fluid.cx/ 

DestroyDecor CopyStep
AddToDecor CopyStep
+	WindowFont      -*-lucida-medium-r-normal-*-10-*-*-*-*-*-iso8859-1
+	BorderStyle Simple -- HiddenHandles NoInset
+	TitleStyle LeftJustified Height 22 -- Top Left Flat
+	AddTitleStyle (HGradient 99 #5d699b Black -- Flat)
+	AddTitleStyle Pixmap titletexture.xpm -- Top Left Flat
+	AddTitleStyle Pixmap left.xpm -- Top Left Flat
+	AddTitleStyle Pixmap right.xpm -- Top Right Flat  
+	HilightColor #ccd8f2 Black
+	ButtonStyle Reset
+	ButtonStyle 1 Pixmap maximise.xpm -- Top Left Flat
+	ButtonStyle 2 Pixmap close.xpm -- Top Left Flat

Style "*" UseDecor CopyStep, ForeColor black, BackColor black
Style "*" Button 1, Button 2
Style "*" BorderWidth 5, HandleWidth 3
Mouse 0 1 A	Iconify
Mouse 0	2 A	Close

(I'll attach the icons)

-- 
Mike Tilstra                                         Tadpol
[email-masked]        http://www.tc.umn.edu/~tils0007/
"Is this *idiocy*?  Or something so brilliant that it just *looks* stupid?"
			-Gary Kasparov