Subject: FVWM CVS: fvwm dane

From: CVS <[email-masked]>
Date: Tue, 23 Mar 1999 15:22:10 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	99/03/23 15:22:09

Modified files:
	libs           : Parse.c 

Log message:
* libs/Parse.c (GetSuffixedIntegerArguments): Correctly initialize
"suffixes" variable to correct a UMR detected by Purify.
(DoPeekToken): Made tmptok static since its address is being returned.
This is probably not the right way to fix this.
(GetSuffixedIntegerArguments): Remove extra code from suffixlist change.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Tue, 23 Mar 1999 16:38:23 -0500

> This is probably not the right way to fix this.

This change resolves the BSR I reported earlier.  I simply changed an
automatic variable to static.  The change removes the BSR but I doubt
making the variable static is what the author had in mind.

The change seems to help with the unrecognized commands, but I don't
think everything is back to normal yet.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Mar 1999 12:02:21 +0100

> think everything is back to normal yet.

Of course. Data read from uninitialised stack space is a bit
random. I wonder how this could run for me.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 24 Mar 1999 08:06:43 -0500

> think everything is back to normal yet.

This seems to have taken care of all my unrecognized commands,
now I just have some escape problems.  Now this always worked
before so, I have 
*FvwmPagerBalloonFont -*-lucida\ sans\ typewriter-bold-*-*-*-12-*-*-*-*-*-*-* 

in my config, and this previouslly always worked now it complains font
not found.  I also use to call fvwm with args like this 
-m4-squote \{ -m4-equote \} 
but now I have to do this 
-m4-squote { -m4-equote } 
which make things difficult if I try and switch back and forth between
2.2 and 2.3

Any thoughts on what could have changed this?

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Mar 1999 15:54:09 +0100

On Wed, Mar 24, 1999 at 08:06:43AM -0500, [email-masked] wrote:
> Now this always worked before so, I have 

I have tinkered with parsing a bit to make it more consistent.
There may still be a few problems.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 28 Mar 1999 19:18:09 +0200

On Wed, Mar 24, 1999 at 03:54:09PM +0100, Dominik Vogt wrote:
> > not found.

I can't follow you. When should this have worked? I've checked 2.3.x,
2.2, 2.1.4 and 2.0.46 and they all show the same behaviour. Neither the
code in fvwm2 nor the code in FvwmPager.c has changed as far as this
behaviour is concerned.

> > I also use to call fvwm with args like this 

Fixed.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]