Subject: coredump in virtual.c

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Mar 1999 22:42:17 +0100

With current CVS I get this coredump:

  (gdb) where
  #0  MoveViewport (newx=1024, newy=0, grab=1) at virtual.c:543
  #1  0x806b907 in PlaceWindow (tmp_win=0x809e578, tflag=1073686528, Desk=0, 
      PageX=2, PageY=1) at placement.c:564
  #2  0x804ba02 in AddWindow (w=20971522) at add_window.c:333
  #3  0x805b94d in HandleMapRequestKeepRaised (KeepRaised=0) at events.c:788
  #4  0x805b8da in HandleMapRequest () at events.c:767
  #5  0x805ac8a in DispatchEvent () at events.c:161
  #6  0x805acd6 in HandleEvents () at events.c:189
  #7  0x805df00 in main (argc=3, argv=0xbffff818) at fvwm.c:551
  #8  0x804b39e in ___crt_dummy__ ()

excerpt from virtual.c:

  538     if (t1 != &Scr.FvwmRoot)
  539       {
  540         /*
  541             If the window is not moving into the viewport...
  542         */
  543         txl = t1->frame_x;
  544         tyt = t1->frame_y;
  545         txr = t1->frame_x + t1->frame_width;
  546         tyb = t1->frame_y + t1->frame_height;

And above that I find this comment:

  /*
      RBW - 11/13/1998  - new:  chase the chain bidirectionally, all at once!
      The idea is to move the windows that are moving out of the viewport from
      the bottom of the stacking order up, to minimize the expose-redraw overhead.
      Windows that will be moving into view will be moved top down, for the same
      reason. Use the new  stacking-order chain, rather than the old
      last-focussed chain.
  */

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Thu, 04 Mar 1999 17:51:29 -0500

Dominik Vogt <[email-masked]> wrote:
>           ...

	I'm gonna have to stop leaving my initials in the code!  :-)

	Nice to see you back, Dominik!

	What are you doing when this happens? From the trace, I presume you're
creating a non-SkipMapping, StartsOnPage window on a page other than the
current one, and it's not during Startup or Restart, but what else has
been going on? This looks like an FvwmWindow struct has been improperly
deleted from the Great Chain of Being.

- Bob

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Mar 1999 13:40:37 +0100

> deleted from the Great Chain of Being.

I don't know how to reproduce this. I was working with fvwm, i.e.
popping netscape, mutt and several rxvt's up and down. The coredump
happened when I switched from page (1,0) to page (0,0) via a
key binding. I had a netscape open on page (1,0). It *may* have
created a new window at the same moment, but I'm not sure. It may
also have something to do with transients (find window) of netscape,
but again I can't remember.

Bye

Dominik