Subject: Can I add this to CVS ?

From: Matthias Clasen <[email-masked]>
Date: Sat, 13 Mar 1999 03:21:52 +0100

Hi,

I have a reasonably complete version of a FvwmGtk
module. It implements menus, dialogs and window-list
using gtk. I'd like to add it to CVS, but there is 
a little gotcha: Since the configure.in will then
contain AM_PATH_GTK, building from CVS on gtk-less
machines will need a call to aclocal -I modules/FvwmGtk
(I'll include gtk.m4 in the module dir). Is that
acceptible or is there a better way to handle this.
Rebuilding without touching configure should be
no problem.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Steve Robbins <[email-masked]>
Date: Sat, 13 Mar 1999 11:42:33 -0500 (EST)

> acceptible or is there a better way to handle this.

Will configure remember that I used the -I flag once upon a time, or will
I have to now run aclocal by hand (instead of relying on the makefile)
each time configure.in, or acheader (or whatever) gets modified?

If the latter, I know that *I*'ll keep forgetting the -I flag.

Is there no other way?  For example, is gtk.m4 too huge to be stuck into
acinclude.m4? 

--
Steve Robbins                              <[email-masked]>

If I had a rocket launcher, some son of a bitch would die.

---

From: Matthias Clasen <[email-masked]>
Date: Sat, 13 Mar 1999 23:01:28 +0100

> each time configure.in, or acheader (or whatever) gets modified?

I don't know.

> Is there no other way?  For example, is gtk.m4 too huge to be stuck into

clasen:[fvwm-devel] >wc -c acinclude.m4 
   6598 acinclude.m4

clasen:[fvwm-devel] >wc -c modules/FvwmGtk/gtk.m4 
   8117 modules/FvwmGtk/gtk.m4

so including gtk.m4 in acinclude.m4 would more than double
its size, but it still wouldn't be too huge. I you think 
doing it this way is better, I'll do it.

Matthias