Subject: Key binding problem, 2.1.6+

From: Lee Skinol <[email-masked]>
Date: 10 Feb 99 22:36:32 EDT

->On Tue, Feb 09, 1999 at 10:05:40PM -0400, [email-masked] wrote:
->> ->On Sun, Feb 07, 1999 at 02:39:46AM -0400, Lee Skinol wrote:
->> ->> This worked in 2.1.5, but stopped in 2.1.6 and above.  It may
->> ->> be a bug.
->> ->>
->> ->> Key KP_7 A M do-something
->>
->> ->Please try this with 2.1.6 but replace fvwm/bindngs.c with the
->> ->file from 2.1.5. Does this work?
->>
->> Dominik,
->>
->> Yes, with the 2.1.5 bindings.c, it works.

->Huh? Now I'm really confused. Perhaps you could help me here
->(since none of the maintainers sees this problem). What I ask
->you to do is in no way trivial and required some experience
->in C programming and debugging:

->What I need is to know where the differences between the two
->bindings.c versions are (not the diffs of course). The function
->ParseBindEntry has changed. It seems that the 2.1.6 file does
->not bind the same keys as the 2.1.5 file. I don't know why.
->The set of bindings in 2.1.6 should be a super set of 2.1.5.

In bindings.c, in the 2.1.6 code, there's the following
loop:

  for (i=min; i<=max; i++)
    if (!fKey || XKeycodeToKeysym(dpy, i, 0) == keysym)
    {
      /* Code to add binding, I think */
    }

In my .fvwm2rc, I have:

  Key KP_7        A       M       GotoPage 0 0

With the new code, fKey is 1, min is 8, max is 134, and
(XKeycodeToKeysym(dpy, i, 0) == keysym) is never true, so
the key doesn't get added.  In the 2.1.5 code, the add
is done (and it *is* done) at the end of the procedure.

Anything else I should look at?

Thanks,
Lee
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 11 Feb 1999 10:22:59 +0100

> Anything else I should look at?

Bummer, I'd never have thought of that. Could you find
out what value keysym has and what the corresponding
keycode should be? This looks as if the XDisplayKeycodes
function is broken on your system. Theoretically you
should have had the same problem with 2.0.46 (?) as
it used the same call. And perhaps you could post the
output of 'xmodmap -pk' and 'xmodmap -pke'.

What OS/Xserver do you have?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].