Subject: FVWM CVS: fvwm dane

From: CVS <[email-masked]>
Date: Sat, 27 Feb 1999 12:00:01 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	99/02/27 12:00:01

Modified files:
	modules        : ChangeLog Makefile.in 
	modules/FvwmAnimate: Makefile.in 
	modules/FvwmAudio: Makefile.in 
	modules/FvwmAuto: Makefile.in 
	modules/FvwmBacker: Makefile.in 
	modules/FvwmBanner: Makefile.in 
	modules/FvwmButtons: Makefile.in 
	modules/FvwmCpp: Makefile.in 
	modules/FvwmEvent: Makefile.in 
	modules/FvwmForm: FvwmForm.1 FvwmForm.c Makefile.am README 
	modules/FvwmIconBox: Makefile.in 
	modules/FvwmIconMan: Makefile.in 
	modules/FvwmIdent: Makefile.in 
	modules/FvwmM4 : Makefile.in 
	modules/FvwmPager: Makefile.in 
	modules/FvwmRearrange: Makefile.in 
	modules/FvwmSave: Makefile.in 
	modules/FvwmSaveDesk: Makefile.in 
	modules/FvwmScroll: Makefile.in 
	modules/FvwmTalk: Makefile.in 
	modules/FvwmWinList: Makefile.in 
Added files:
	modules/FvwmForm: .FormFvwmCapture .FormFvwmQuitVerify 
	                  .FormFvwmRlogin DefineMe.c FvwmForm.h 
	                  ReadXServer.c 

Log message:
- Removed form limitations including:
number of lines in a form.
number of items in a form.
number of items in a line.
number of selections in a choice.
number of commands on a button.
Colors can be changed anywhere in a form.
Fonts can be changed anywhere in a form.

- Changed the general organization of the module to match FvwmAnimate.
See comments in FvwmAnimate to see what it mimicks.
Some parts of this module have comments containing "FvwmAnimate"
are common module/macro candidates.
Changed debugging technique to match FvwmAnimate with the
additional ability to Debug to File.

- Configurability updates:
Form appearance can be configured globaly:
Form defaults are read from .FvwmForm.
There is a built in Default setting/saving dialogue.
Forms can be read in directly from a file.
The file is the alias with a leading dot.
The file is in $HOME or the system configuration directory.
Comes with forms installed in the system configuration directory.

- Operability:
You can tab to previous input field with ^P, Up arrow, shift tab.

- This module now has a configuration proceedure:
AddToMenu "Module-Popup" "FvwmForm Defaults" FvwmForm FormFvwmForm

- Use FvwmAnimate command parsing.
The part of the command after the module name is no longer case sensitive.
Use command tables instead of huge "else if".

- Misc:
Avoid core when choice not preceeded by a selection.
Rename union member "select" so it doesn't conflict with the function.
You can now control vertical spacing on text.  By default text is spaced
vertically the way you would want it for buttons.
This is for compatibility.  Now you can change the spacing to zero as
you might want for a help panel.
A button can execute a synchronous shell command.  The first use I
put this is a form that writes its new definition to a file and
reinvokes itself.
Use SendText instead of writes to pipe.
Changed button press-in effect from 1 sec to .1 sec.  Didn't seem to
do anything on a slow machine...
Added preload arg, and Map, Stop and UnMap commands for fast forms.
(FvwmForm is now parsing commands during form display.)
Add "Message" command, display "Error" and "String" messages from fvwm.
Removed CopyNString, strdup replaces it.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Feb 1999 13:15:13 -0500

> Add "Message" command, display "Error" and "String" messages from fvwm.

I neglected to mention, the "preload" and "message" features
are not documented, since I'm not satisfied with the way they currently
work.  Consider them prototypes.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]