Subject: 2.2 vs 2.1.13

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 00:32:34 +0100

Heck, I can't find the mail where we were discussing 2.2
vs 2.1.13. Here is a short summary of pro's and con's for
making 2.2 immediately and calling the next release
2.2.0.prerelease.something:

pro

- We'll stop fixing bugs now.
- The name of the release speaks for itself.

con

- Beta tests are for finding-and-fixing bugs, not for
  finding-and-ignoring them.
- We need a bit of testing for the most recent fixes.

So here is what I propose:

I'll make 2.1.13 and upload it to testing without
announcing it (in fact I only need to upload it). In the
end 2.1.13 is just a name. We allow three days to pass in
which we all try to test these fixes as best we can. If no
absolutely critical bug comes up we rename 2.1.13 to 2.2.

The things to be tested are:

1) New menu position hints syntax
2) Key binding bugfix
3) All this Iconify/Raise/StartsOn... stuff
4) The FvwmConsole fix
5) The FvwmCommand coredump fix
6) FvwmWinList

For the fixes I made (1, 2 and 5) I'd prefer if you
review the code. 1 Has to be tested too, however. I
understand that FvwmWinList has been tested thoroughly
already.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 17 Feb 1999 09:49:58 +0000

> 1) New menu position hints syntax

It hasn't broken anything in my default set up (not that it does much),
I used to use "root 0 -24p" to get a menu just above the FvwmButtons (24
pixels high) now I have to use "root 0 o100-24p". I don't know if this
is an intended change.

> 2) Key binding bugfix

I can't test this.

> 3) All this Iconify/Raise/StartsOn... stuff

Being unable to raise a window over icons has been fixed. A
not-worth-fixing-yet bug is that when the icon title is expanded it
isn't raised to the top.  If you have very long icon titles and icons
packed close together you can get the expanded icon title going
underneath other icon titles. Looks a bit weird but easily fixed with "+
I Current (Iconic) Raise" in a focus event function.

> 5) The FvwmCommand coredump fix

All fixed.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 14:25:36 +0100

> pixels high) now I have to use "root 0 o100-24p". I don't know if this

Yes, this is intended to get the syntax consistent.

> I can't test this.

If you could try all your key bindings it might suffice.

> > 5) The FvwmCommand coredump fix

Thanks, Tim. Anyone who wants to take a look at the code?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 17 Feb 1999 09:37:55 -0500

> Yes, this is intended to get the syntax consistent.

I played with the new stuff seems to work but I can't quite remember
what the requirment was for the syntx change.

> If you could try all your key bindings it might suffice.

I ran this on a sparc 2, and the added looping doesn;t seem to slow
things down noticbley and all my bindings still work so I say keep it in
if it fixes the multi keysym problem. The code itself seems fine, not
crazy about the indentation style but, its fine.

> > > 5) The FvwmCommand coredump fix
All seems well and I good reproduce the coredumps and I can't now.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 14:40:15 +0100

> what the requirment was for the syntx change.

That is because I didn't announce the reason in length :) The old
syntax just didn't allow to place a menu everywhere you wanted (e.g.
not 8 pixels above the mouse pointer). And there was a conflict between
the old syntax and negative offsets being interpreted like in a geometry.
You would have had to say +-8 or -+8 or so to get the mentioned
behaviour. And since the syntax was new in 2.1.x I saw no reason to
fix it after people are used to it.

> crazy about the indentation style but, its fine.

I'd like to know if it is OK to try all modifiers until the first one
has no binding. Is this correct?

Bye

Dominik

---

From: Patrick Rogan <[email-masked]>
Date: Wed, 17 Feb 1999 10:53:37 -0500

It my gut feeling that we should wait more than 3 days to see if anyone
has problems with 2.1.13.

I'm thinking officially announce 2.1.13 as a "golden beta".  Wait a week
or two.  "Ignore" any non crtical bug reports, then ship it out as v.
2.2.

During those weeks everybody gets busy and starts writing configuration
examples to put on the website to showcase FVWM2's functionality.  

Like you guys talk about stuff like "looping to try all modifiers until
the first one has no binding".  What the hell is that?  Sounds like
something neat, maybe even usefull.  But I never heard of it -- don't
know what it means.

I'm sure the developers and core testers all have one or two neat custom
things in their setups that would make great examples. (eg.  I use an
fvwmbuttons and two wharfs)

~p@

---

From: Patrick Rogan <[email-masked]>
Date: Wed, 17 Feb 1999 11:13:14 -0500

(oops.  The "Send" button is NOT the same a teh "Spelcheck" buton...)

:)

~p@

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 "To understand guys, it is essential to remember that, deep down
 inside, they are biological creatures, like jellyfish or trees, 
 only less likely to clean the bathroom."            --Dave Barry

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 16:24:53 +0100

> or two.  "Ignore" any non crtical bug reports, then ship it out as v.

I know that what you say is right and I feel the same. But over the last
weeks we're all getting more and more frustrated because of all the work
that gets queued up. Personally I have just given up resistance against
making 2.2 fast.

> something neat, maybe even usefull.  But I never heard of it -- don't

This one is just an implementation internal, nothing the user can do
in his config file.

> fvwmbuttons and two wharfs)

That's why I started to make this docs/configuration-hints.txt file.
I hope all the developers take a sweep at it and hack in their tips
and tricks.

Bye

Dominik

---

From: [email-masked] (Paul D. Smith)
Date: 17 Feb 1999 12:03:28 -0500

%% Patrick Rogan <[email-masked]> writes:

  pr> It my gut feeling that we should wait more than 3 days to see if
  pr> anyone has problems with 2.1.13.

  pr> I'm thinking officially announce 2.1.13 as a "golden beta".  Wait
  pr> a week or two.  "Ignore" any non crtical bug reports, then ship it
  pr> out as v.  2.2.

I strongly disagree.  People have been waiting, literally, years for
this release.  What we have now is head-and-shoulders above any previous
release of fvwm2 in terms of stability.

The whole point of open-source software is to allow people to get their
hands on the code; these releases don't have to be 100%.  They never
will be!  If we find something horrible, no problem, we can spin a new
version in a matter of hours.  I know it sucks to have to do that but
it's better than _never_ getting 2.2.0 out.  Everyone familiar with OSS
will know not to jump on a .0 release unless they're willing to hop to
the .1 release quickly thereafter!

Besides, there's no question this release will be just perfect for the
_large_ majority of users, since it works great for all of us.  Only
those using odd little features will be affected, if anyone.

I say, ship it!!

  pr> During those weeks everybody gets busy and starts writing
  pr> configuration examples to put on the website to showcase FVWM2's
  pr> functionality.

I think you'd be surprised how trivial most of our config files are :)
Anyway, this is a great idea but we _certainly_ shouldn't hold the
release for it!

Dominik: I agree we need some better config examples since the config
language has both gotten a lot more complex, and we've deprecated
several old uses.

However, I also don't think a new file in docs is the way to go.
Personally, whenever I get a package that has 10-15 text files in a doc
directory I rarely if ever read them: it's too much.

I'd much prefer to see two things: (1) a much-expanded FAQ; I don't mind
seeing single, really big FAQ docs!, and (2) more sample configs!  One
thing we might consider doing before 2.2.0 is going through the existing
sample configs and either updating them to the "new" syntax we've added
(MenuStyle, Decors, etc.) or removing them.  I'd like to see maybe 4 or
5 sample configs: maybe an fvwm-basic, which is simple and fast and
doesn't use a ton of colors, an fvwm-fancy with gradients, etc., a
MWM/CDE-ish one, and a MS-Windows-y looking one.  Comment them
liberally, and use "best-practices".  Then people can look there or even
start with one verbatim (they should be _useful_, good-looking configs,
not just showcase configs with everything thrown in willy-nilly, I
think).  We can put screenshots on the web page.

I don't know what the licensing is on the fvwm95 pixmaps, but I was
poking around over there and they have a lot of nice pixmaps!  Esp. they
have a good selection of mini-icons.  I would love to steal some of
those, and clean out our pixmaps directory.

And I'd really like to see a nice "fvwm2" or "fvwm-2.2" side pixmap,
done in the style of the side pixmaps in fvwm95.  This may be too much
to ask before 2.2, though.

Also, we might try to decide on "standard sizes" for icons.  Normal
icons seem to be 48x48 or so, mini-icons seem quite standard at 16x16
but we should make that official, and we should take a look at various
side pixmaps and try to come up with a recommendation for those.  Put
this, plus the naming conventions (foo.xpm, mini-foo.xpm, and
side-foo.xpm) into the FAQ.

Blah blah blah...

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 17:27:00 +0100

> side-foo.xpm) into the FAQ.

Whew, what a long speech :) Some things I want to comment on:

1) As I said I don't care if we have a separate configuration-hints
   file or whatever. I just needed a place to put that stuff for
   the moment. I will take a shot at restructuring the FAQ and
   integrate that.

2) I'm not so sure all the maintainers' config files are so simple.
   I'm convinced at least Dan and Tim have some 'dirty tricks' in
   there.

3) I'd be willing to write a CDE-like config file. But what is
   needed most is a volunteer for a %$@#&$-like file.

Bye

Dominik

---

From: Michael Han <[email-masked]>
Date: Wed, 17 Feb 1999 09:39:23 -0800

Previously...
>[snip]

Gotta agree here.

>directory I rarely if ever read them: it's too much.

Hmm, this sounds familiar.

>think).  We can put screenshots on the web page.

On the FAQ, after looking at it again for the first time in a while, I
realize that 50 items in no particular order is pretty unhelpful... it
really invites grep'ing which in turn might lose to spelling errors or
incorrect keyword... I'd be willing to take a look at revising the FAQ
to do the whole:
1. About Fvwm
    1.1 What does FVWM stand for?
    ...
2. Compilation & Installation
    2.1 Where can I get XPM?
etc.
thing. Good? Bad? My preference is for single-file FAQs. Also like
HTML ones, to help go from questions to answers.

On the configs, couldn't agree more. Especially the emulation
configs, which could help convince fvwm2-95 users to use the One True
FVWM ;-)
-- 
[email-masked]
I will not squeak chalk
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 17 Feb 1999 17:56:56 +0000

>    I'm convinced at least Dan and Tim have some 'dirty tricks' in

Excuuuuuse me!!! 8-) Nothing dirty in my config thanks very much.  My
functions are a bit hairy and I do use FvwmEvent to get around some
things I couldn't do with just functions. I have given over the keypad
to fvwm entirely (I don't type numbers if I can help it). I thought
about attaching it but it's 24K so here's just the keys and functions.

Cheers,
Tim.

/* Global Key bindings */

/* Key keysymdef.h [RWTSFI|A] [N|CSM|A]	Action */

/* keypad bindings */

/* Alt-Keypad = Alter current window size and position */
Key KP_7	WTSF	M	my_topleft
Key KP_8	WTSF	M	my_topmid
Key KP_9	WTSF	M	my_topright
Key KP_4	WTSF	M	my_midleft
Key KP_5	WTSF	M	my_midmid
Key KP_6	WTSF	M	my_midright
Key KP_1	WTSF	M	my_botleft
Key KP_2	WTSF	M	my_botmid
Key KP_3	WTSF	M	my_botright
Key KP_0	WTSF	N	my_maxwidth

/* Cntl-keypad = resizing with the key pad */
Key KP_5	WTSF	C	Popup ResizeMenu context c c
Key KP_7	WTSF	C	my_resize_dir   0   0
Key KP_8	WTSF	C	my_resize_dir  50   0
Key KP_9	WTSF	C	my_resize_dir 100   0
Key KP_6	WTSF	C	my_resize_dir 100  50
Key KP_3	WTSF	C	my_resize_dir 100 100
Key KP_2	WTSF	C	my_resize_dir  50 100
Key KP_1	WTSF	C	my_resize_dir   0 100
Key KP_4	WTSF	C	my_resize_dir   0  50

/* keypad = shift focus with keypad */
Key KP_7	A	N	my_go_upleft
Key KP_8	A	N	my_go_up
Key KP_9	A	N	my_go_upright
Key KP_6	A	N	my_go_right
Key KP_3	A	N	my_go_downright
Key KP_2	A	N	my_go_down
Key KP_1	A	N	my_go_downleft
Key KP_4	A	N	my_go_left

Key KP_5	WTSFI	N	my_updown

/* kp_decimal toggles iconic state */
Key KP_Decimal	WTSF	A	my_iconify
Key KP_Decimal	I	A	my_deiconify

/* kp_enter accesses the windowlist */
Key KP_Enter	A	N	WindowList Root c c CurrentDesk NoGeometry my_dbltab
Key KP_Enter	A	C	WindowList Root c c NoDeskSort "Prev FlipFocus"
Key KP_Enter	A	S	my_dbltab

/* navigate arounf the windowlist */
Key KP_Add	A	N	my_next
Key KP_Add	A	S	my_next_s
Key KP_Subtract	A	N	my_prev
Key KP_Subtract	A	S	my_prev_s
Key KP_Multiply	A	N	my_nexticon
Key KP_Multiply	A	S	my_nexticon_s
Key KP_Divide	A	N	my_previcon
Key KP_Divide	A	S	my_previcon_s
Key Num_Lock	A	N	my_updown /* grabbed by NT */

/* move windows to desk */
Key F9		A	SM	my_movetodesk 0
Key F10		A	SM	my_movetodesk 1
Key F11		A	SM	my_movetodesk 2
Key F12		A	SM	my_movetodesk 3

/* Desk navigation controls */
Key F9		A	M	my_gotodesk 0
Key F10		A	M	my_gotodesk 1
Key F11		A	M	my_gotodesk 2
Key F12		A	M	my_gotodesk 3

/* refresh control */
Key Print	A	N	Refresh

/* Pop main menu up */
Key Help	A	N	Menu StartMenu Root 0 o100-24p my_term

/* Pause/Break closes windows */
Key Pause	A	N	my_kill
/* Function definitions */

/* AddToFunc Name (\n +) (IMCD) action  */

DestroyFunc my_resize_dir
AddToFunc my_resize_dir I Debug my_resize_dir $0 $1
+ I Raise
+ I WarpToWindow $0 $1
+ I Resize

DestroyFunc my_defanim
AddToFunc my_defanim I SetAnimation 200 -.01 0 .01 .03 .08 .18 .3 .45 .6 .75 .85 .90 .94 .97 .99 1.0

DestroyFunc my_bounceanim
AddToFunc my_bounceanim I SetAnimation 20 .01 .03 .08 .18 .3 .45 .6 .8 .99 .8 .7 .65 .66 .65 .75 .85 .90 .94 .97 .99 1.0

DestroyFunc my_hide_tl
AddToFunc my_hide_tl I Debug my_hide_tl
+ I my_bounceanim
+ I Next (toolManagerLog CirculateHit) AnimatedMove +12p -1012p
+ I my_defanim

DestroyFunc my_hide_tm
AddToFunc my_hide_tm I Debug my_hide_tm
+ I my_bounceanim
+ I Next (toolManager CirculateHit) AnimatedMove -1268p +12p
+ I my_defanim

DestroyFunc my_blank
AddToFunc my_blank I Debug my_blank
+ I Exec kfork bkgs xv
+ I Exec xsetroot -solid ""BG""

DestroyFunc my_logout
AddToFunc my_logout I Debug my_logout
+ I my_blank
+ I Quit
+ I Exec dtaction ExitSession

DestroyFunc my_cursorwarp
AddToFunc my_cursorwarp I Debug my_cursorwarp
+ I Current (TaskBar) WarpToWindow 55p 10p /* Start button */
+ I Current (!TaskBar) WarpToWindow 35p 50p /* top left Motif button */
+ I Current (rxvt) WarpToWindow 98 90 /* scrollbar */
+ I Current (xterm) WarpToWindow 3 90 /* sb on left */

DestroyFunc my_resizemove
AddToFunc my_resizemove I Debug my_warp $0 $1 $2 $3
+ I Raise
+ I Resize $0 $1
+ I AnimatedMove $2 $3
+ I my_cursorwarp

DestroyFunc my_moveresize
AddToFunc my_moveresize I Debug my_warp $0 $1 $2 $3
+ I Raise
+ I AnimatedMove $2 $3
+ I Resize $0 $1
+ I my_cursorwarp

/* move and resize the window (should be recoded for generic screen width) */
DestroyFunc my_topleft
AddToFunc my_topleft I my_moveresize 616p 460p 0p 0p
DestroyFunc my_topmid
AddToFunc my_topmid I my_moveresize 616p 460p 320p 0p
DestroyFunc my_topright
AddToFunc my_topright I my_moveresize 616p 460p 640p 0p
DestroyFunc my_midleft
AddToFunc my_midleft I my_moveresize 616p 960p 0p 0p
DestroyFunc my_midmid
AddToFunc my_midmid I my_moveresize 616p 960p 320p 0p
DestroyFunc my_midright
AddToFunc my_midright I my_moveresize 616p 960p 640p 0p
DestroyFunc my_botleft
AddToFunc my_botleft I my_resizemove 616p 460p 0p 500p
DestroyFunc my_botmid
AddToFunc my_botmid I my_resizemove 616p 460p 320p 500p
DestroyFunc my_botright
AddToFunc my_botright I my_resizemove 616p 460p 640p 500p

/* max width toggle */
DestroyFunc my_maxwidth
AddToFunc my_maxwidth I Debug my_maxwidth
+ I Maximize 100 0
+ I my_cursorwarp

/* keeps up to two OnBottom windows down */
DestroyFunc my_tidy
AddToFunc my_tidy I Debug my_tidy
+ I Next (*OnBottom* CurrentDesk CirculateHit) Lower
+ I Prev (*OnBottom* CurrentDesk CirculateHit) Lower

DestroyFunc my_focus
AddToFunc my_focus I Debug my_focus
+ I Focus
+ I Raise
+ I my_cursorwarp
+ I my_tidy

/* this one goes to previous window and reorders window list */
DestroyFunc my_flipfocus
AddToFunc my_flipfocus I Debug my_flipfocus
+ I FlipFocus
+ I Raise
+ I my_cursorwarp
+ I my_tidy

DestroyFunc my_flip
AddToFunc my_flip I Debug my_flip
+ I Prev (!Iconic CurrentDesk) FlipFocus
+ I None (!Iconic CurrentDesk) my_prev

DestroyFunc my_deiconify
AddToFunc my_deiconify I Debug my_deiconify
+ I Iconify -1
+ I my_flipfocus

/* focus movement (warps cursor) */
DestroyFunc my_home
AddToFunc my_home I Debug my_home
+ I Next (TaskBar CirculateHit CirculateHitIcon) my_deiconify
DestroyFunc my_nexticon
AddToFunc my_nexticon I Debug my_nexticon
+ I Next (Iconic CurrentDesk) my_focus
+ I None (Iconic CurrentDesk) my_home
DestroyFunc my_nexticon_s
AddToFunc my_nexticon_s I Debug my_next_icon_s
+ I Next (Iconic CurrentDesk CirculateHitIcon) my_focus
+ I None (Iconic CurrentDesk CirculateHitIcon) my_home
DestroyFunc my_previcon
AddToFunc my_previcon I Debug my_previcon
+ I Prev (Iconic CurrentDesk) my_focus
+ I None (Iconic CurrentDesk) my_home
DestroyFunc my_previcon_s
AddToFunc my_previcon_s I Debug my_previcon_s
+ I Prev (Iconic CurrentDesk CirculateHitIcon) my_focus
+ I None (Iconic CurrentDesk CirculateHitIcon) my_home
DestroyFunc my_next
AddToFunc my_next I Debug my_next
+ I Next (!Iconic CurrentDesk) my_focus
+ I None (!Iconic CurrentDesk) my_nexticon
DestroyFunc my_next_s
AddToFunc my_next_s I Debug my_next_s
+ I Next (!Iconic CurrentDesk CirculateHit) my_focus
+ I None (!Iconic CurrentDesk CirculateHit) my_nexticon
DestroyFunc my_prev
AddToFunc my_prev I Debug my_prev
+ I Prev (!Iconic CurrentDesk) my_focus
+ I None (!Iconic CurrentDesk) my_previcon
DestroyFunc my_prev_s
AddToFunc my_prev_s I Debug my_prev_s
+ I Prev (!Iconic CurrentDesk CirculateHit) my_focus
+ I None (!Iconic CurrentDesk CirculateHit) my_previcon

/* transport window and follow it */
DestroyFunc my_movetodesk
AddToFunc my_movetodesk I Debug my_movetodesk
+ I MoveToDesk 0 $0
+ I WindowID $w my_flipfocus

/* go to a particular desk, restore focus to previous */
DestroyFunc my_gotodesk
AddToFunc my_gotodesk I Debug my_gotodesk
+ I my_home /* prevent spurious focuses when desk changes from altering windowlist */
+ I Desk 0 $0
+ I Prev (CurrentDesk !Iconic) my_flipfocus

/* raise and lower window */
DestroyFunc my_updown
AddToFunc my_updown I Debug my_updown
+ I RaiseLower
+ I my_tidy

/* iconify and go to previous window */
DestroyFunc my_iconify
AddToFunc my_iconify I Debug my_iconify
+ I Current (MailThread) Exec netscape -noraise -remote compressFolders
+ I Iconify 1
+ I my_prev

/* desktop navigation */
DestroyFunc my_go_upleft
DestroyFunc my_go_up
DestroyFunc my_go_upright
DestroyFunc my_go_right
DestroyFunc my_go_downright
DestroyFunc my_go_down
DestroyFunc my_go_downleft
DestroyFunc my_go_left
AddToFunc my_go_upleft I Debug my_go_upleft
+ I Direction NorthWest (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_up I Debug my_go_up
+ I Direction North (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_upright I Debug my_go_upright
+ I Direction NorthEast (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_right I Debug my_go_right
+ I Direction East (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_downright I Debug my_go_downright
+ I Direction SouthEast (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_down I Debug my_go_down
+ I Direction South (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_downleft I Debug my_go_downleft
+ I Direction SouthWest (CurrentDesk !Iconic) my_flipfocus
AddToFunc my_go_left I Debug my_go_left
+ I Direction West (CurrentDesk !Iconic) my_flipfocus

DestroyFunc my_kill
AddToFunc my_kill I Debug my_kill
+ I Current (Dtpad) Delete
+ I Current (!Dtpad) Close
+ I my_prev

DestroyFunc my_moveraiselower
AddToFunc my_moveraiselower I Debug my_moveraiselower
+ "M" Raise
+ "M" Move
+ "C" RaiseLower

DestroyFunc my_hidemoveraiselower
AddToFunc my_hidemoveraiselower I Debug my_moveraiselower
+ "M" Raise
+ "M" Move
+ "C" WindowShade 2
+ "C" RaiseLower
+ "D" WindowShade

DestroyFunc my_resizeiconify
AddToFunc my_resizeiconify I Debug my_resizeiconify
+ "M" Raise
+ "M" Resize
+ "C" my_iconify

DestroyFunc my_bkgs
AddToFunc my_bkgs I Debug my_bkgs
+ I Exec bkgs $0 $1 $2 $3 $4 $5 $6 $7 $8 $9
+ I Wait XVinfo
+ I Next (XVinfo) Close
+ I Exec sleep 10; fv "Next (xv*controls) MoveToDesk 0 4"

DestroyFunc my_Xdefaults
AddToFunc my_Xdefaults I Debug my_Xdefaults
+ I Exec sh -c "cat .X/resources/* | xrdb; xrdb -q > .Xdefaults"

DestroyFunc my_term
AddToFunc my_term I Debug my_term
+ I Exec target
+ I Wait XTerm
+ I Next (XTerm) my_flipfocus

/* function called by double clicking on alt-tab/enter */
DestroyFunc my_dbltab2
AddToFunc my_dbltab2 I Debug my_dbltab2 $w
+ I WindowListFunc $w
DestroyFunc my_dbltab
AddToFunc my_dbltab I Debug my_dbltab $w
+ I Prev (CurrentDesk) my_dbltab2

/* functions called on events */

DestroyFunc my_netscape
AddToFunc my_netscape I Debug my_netscape
+ I Next (Netscape) Exec netscape -noraise -remote openBrowser
+ I None (Netscape) Exec target netscape
+ I None (Netscape) Wait Netscape
+ I Next (CurrentDesk Netscape) my_flipfocus

DestroyFunc my_url
AddToFunc my_url I Debug my_url $0
+ I Next (Netscape) Next (Navigator) Exec netscape -noraise -remote "openURL($0, new-window)"
+ I Next (Netscape) None (Navigator) Exec netscape -noraise -remote "openURL($0)"
+ I None (Netscape) Exec target netscape $0
+ I Wait Netscape
+ I Next (CurrentDesk Netscape) my_flipfocus

DestroyFunc my_mailbox
AddToFunc my_mailbox Debug my_mailbox $0
+ I Next (Netscape) Exec netscape -noraise -remote compactFolder; netscape -noraise -remote openInboxAndGetNewMessages; netscape -noraise -remote "openURL($0)"; netscape -noraise -remote nextUnreadMessage
+ I None (Netscape) Exec target netscape $0
+ I None (MailThread) Wait MailThread
+ I None (CurrentDesk MailThread) Next (MailThread) MoveToDesk 0
+ I Next (CurrentDesk MailThread) my_flipfocus

DestroyFunc my_mail
AddToFunc my_mail Debug my_mail
+ I my_mailbox IMAP://mailhost/Inbox

DestroyFunc my_compose
AddToFunc my_compose Debug my_compose
+ I None (Netscape) Exec target netscape
+ I None (Netscape) Wait Netscape
+ I Next (Netscape) Exec netscape -noraise -remote composeMessage
+ I None (Composition) Wait Composition
+ I Next (CurrentDesk Composition) my_flipfocus

DestroyFunc my_edit
AddToFunc my_edit I Debug my_edit $0 $1
+ I None ($0) Exec target dtpad -noBlocking -noReadOnlyWarning $1
+ I None ($0) Wait dtpad
+ I Next ($0) Iconify -1
+ I Next ($0) my_flipfocus

DestroyFunc my_focusevent /* handle auto hide windows */
AddToFunc my_focusevent I Debug my_focusevent $0
+ I Current (!toolManager) my_hide_tm
+ I Current (!toolManagerLog) my_hide_tl
+ I Current (toolManager) AnimatedMove +0 +12p
+ I Current (toolManagerLog) AnimatedMove +12p +0

DestroyFunc my_addwindow /* hide log windows, autofocus on dialogs */
AddToFunc my_addwindow I Debug my_addwindow
+ I my_hide_tl
+ I Next (toolManagerOptions Transient CirculateHit) my_hide_tm

/* functions called by FVWM */
DestroyFunc InitFunction
AddToFunc InitFunction I Debug InitFunction
+ I my_blank
+ I RestartFunction

DestroyFunc RestartFunction
AddToFunc RestartFunction I Debug RestartFunction
+ I my_Xdefaults
+ I FvwmBanner
+ I Wait FvwmBanner
+ I my_defanim
+ I decor_fvwm
+ I FvwmAnimate
+ I FvwmButtons
+ I FvwmButtons TaskBar
+ I FvwmCommandS
+ I FvwmEvent

DestroyFunc my_restart
AddToFunc my_restart I Debug my_restart
+ I my_Xdefaults
+ I my_defanim
+ I decor_fvwm

DestroyFunc ExitFunction
AddToFunc ExitFunction I Debug ExitFunction
+ I KillModule "*"
+ I FvwmBanner
+ I Wait FvwmBanner

DestroyFunc WindowListFunc
AddToFunc WindowListFunc I Debug WindowListFunc $0
+ I WindowId $0 WindowShade 2
+ I WindowId $0 Iconify -1
+ I WindowId $0 my_flipfocus

---

From: Dan Espen <[email-masked]>
Date: Wed, 17 Feb 1999 13:23:29 -0500

> %% Patrick Rogan <[email-masked]> writes:

I agree, its as ready as it ever will be.

> side-foo.xpm) into the FAQ.

There is a README in the "icons" directory that addresses just a little
of this.

> -- 
>  Paul D. Smith <[email-masked]>         Network Management Developmen

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 17 Feb 1999 13:30:42 -0500

> HTML ones, to help go from questions to answers.

I particularly liked qvwm's FAQ:

http://www-masuda.is.s.u-tokyo.ac.jp/~kourai/qvwm/howto-en.html#faq

The overall organization is:

 1.Concepts 
 2.Installation 
 3.Functions 
 4.Configurations 

not that I think its perfect, just a whole  lot better than our linear
arrangement.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 18:44:37 +0100

On Wed, Feb 17, 1999 at 05:56:56PM +0000, Tim Phipps wrote:
> Excuuuuuse me!!! 8-) Nothing dirty in my config thanks very much.

Of course I meant 'clean and elegant tricks' :-)

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Wed, 17 Feb 1999 14:06:38 -0500

> Of course I meant 'clean and elegant tricks' :-)

Well, I'm not sure I have anything anyone  else would want.  I'll take
a look again sometime soon.   At the risk of having  you all think I'm
completely out of my mind, I will share this.

Generally,  I  keep only one window  open  at a   time.  Usually thats
XEmacs,  but I do have  to log  onto  remotes.  I  have remotes called
"aurora", "cleo", etc.  I want to type in an "a"  to open the "aurora"
window, Ctrl-a to  create the window iconified,  and Shift-a to create
the window open.

Here are the functions to support that:

AddToFunc Rloginxvt "I" Exec exec rxvt $1 -name $0 -n $0 -title "$USER@$0" $2 -e rlogin $0  $3 $4

# Function to add a system to the "Systems" menu:
# arg 0 Letter
# arg 1 Desc
# arg 2 Command
AddToFunc AddToSystemMenu "I" AddToMenu "Systems" "%mini.xterm.xpm%&$0. $1" $2

# Utility func for rlogin key definintions to all our hosts:
# Defines key actions, and updates System menu.
# $0: key
# $1: system
# $2: Optional arg to rxvt (Eg. -pixmap or -e)
# $3: Optional system description for menu (with leading blank)
# $4: Optional arg to rlogin (Eg. -l username)
AddToFunc rloginrxvtkeys "I" Key $0 R N Warp "$1"
+ "I" Key $0 R S Rloginxvt $1 "" "$2" "$4"
+ "I" Key $0 R C Rloginxvt $1 -iconic "$2" "$4"
+ "I" AddToSystemMenu $0 "$1$3" "Rloginxvt $1 '' '$2' '$4'"

And then to use this mess:

rloginrxvtkeys a aurora "" " (HPUX 11)"
rloginrxvtkeys b aurora "" " (HPUX 11) as someone" "-l someone"
rloginrxvtkeys c cleo "" " (Sun 5.6)"

Told you you wouldn't be interested...

---

From: [email-masked] (Paul D. Smith)
Date: 17 Feb 1999 14:11:24 -0500

%% Dominik Vogt <[email-masked]> writes:

  dv> 3) I'd be willing to write a CDE-like config file. But what is
  dv>    needed most is a volunteer for a %$@#&$-like file.

Seems to me that if we grab some of the fvwm95 icons and config file
info, we should be quite a ways there.  As I mentioned on the fvwm list
a few days ago, the major unknown (for me) is FvwmTaskBar; how does the
fvwm2 one compare with the fvwm95 one?

---

From: Dan Espen <[email-masked]>
Date: Wed, 17 Feb 1999 14:31:07 -0500

> info, we should be quite a ways there.  As I mentioned on the fvwm list

Actually,  after  I execute  the stuff in sample.fvwmrc/decor_examples
I'm as close to a %$@#&$-like feel as I want  to be.  The "mini.winXX"
icons that that  decor uses are already in  the distribution.  I don't
think we are missing any necessary icons.

> fvwm2 one compare with the fvwm95 one?

Until you  start  digging deep,  its identical.   You  can  drag it to
either the top or  bottom of the  screen  (like %$@#&$), but  it won't
drag to the edges like it does in %$@#&$.

---

From: Patrick Rogan <[email-masked]>
Date: Thu, 18 Feb 1999 17:16:28 -0500

I'd be more than willing to turn the cofiguration samples file into one
or more web pages.

~p@

-- 

Patrick Rogan
-----------------------------------
Systems Engineer

Lycos, Inc.
1 Oxford Centre
301 Grant Street, Suite 525
Pittsburgh, PA   15219-1408
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Patrick Rogan <[email-masked]>
Date: Thu, 18 Feb 1999 17:18:22 -0500

> I agree, its as ready as it ever will be.

ok. let's ship it, then.

Oh, check out the "favorite wm" poll on shashdot!  We're #2 (or #3
depending on how you look at it).

~p@

-- 

Patrick Rogan

Lycos, Inc.
1 Oxford Centre

---

From: Patrick Rogan <[email-masked]>
Date: Thu, 18 Feb 1999 17:31:45 -0500

I have several icons + mini icon pairs.  I'll tar 'em up and spam all of
you with them.

(ok, I'll just put them on my website :)

~p@

-- 

Patrick Rogan

Lycos, Inc.
1 Oxford Centre

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 19 Feb 1999 00:12:27 +0100

> I'd be more than willing to turn the cofiguration samples file into one

If you mean the configuration-hints file: I have merged it
into the FAQ already. It's not really a file with configuration
samples anyway but with several hints for efficient behaviour
of fvwm2. Creating the configuration samples will be way more
work we should nonetheless start soon.

Bye

Dominik

---

From: Patrick Rogan <[email-masked]>
Date: Thu, 18 Feb 1999 18:33:26 -0500

I don't know if i alreay said this, or if anyone cares, but,

"ship it".

I guess :)

~p@

-- 

Patrick Rogan

Lycos, Inc.
1 Oxford Centre