Subject: `Direction' core dumps

From: [email-masked]
Date: Fri, 5 Feb 1999 04:42:44 -0600 (CST)

Full_Name: Ives Aerts
Version: 2.1.10
CVS_Date: 
OS: IRIX 6.3
X_Server: 
Submission from: (NULL) (193.74.243.52)

Due to the word wrapping of my editor, I ended up with the
following line in my .fvwm2rc:

  key h   A       MC      Direction West      (!Iconic CurrentPage

I restarted fvwm2 and got a proper complaint:

  [FVWM][CreateConditionMask]: <<ERROR>> Conditionals require closing
parenthesis

but when I tried meta-control-h anyway (I hadn't read the
mesage yet), fvwm2 core dumped on me.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ives Aerts <[email-masked]>
Date: Mon, 8 Feb 1999 11:29:57 +0100

On Sun, Feb 07, 1999 at 06:37:45PM +0100, Dominik Vogt wrote:
> On Fri, Feb 05, 1999 at 04:42:44AM -0600, [email-masked] wrote:
> It doesn't coredump on my Linux box (I tried both, current CVS
> code and 2.1.10). Can you fetch a stack trace?

I hope this helps:

  ives@lynch.~> gdb `type -path fvwm2` core
  GDB is free software and you are welcome to distribute copies of it
   under certain conditions; type "show copying" to see the conditions.
   There is absolutely no warranty for GDB; type "show warranty" for
   details.
   GDB 4.16 (mips-sgi-irix5.3), Copyright 1996 Free Software Foundation,
   Inc...
   Core was generated by `fvwm2'.
   Program terminated with signal 11, Segmentation fault.
   Reading symbols from /usr/local/lib/libXpm.so4.10...done.
   Reading symbols from /usr/lib/libXt.so...done.
   Reading symbols from /usr/lib/libXext.so...done.
   Reading symbols from /usr/lib/libX11.so.1...done.
   Reading symbols from /usr/lib/libc.so.1...done.
   #0  ExecuteFunction () at functions.c:228
   functions.c:228: No such file or directory.
   (gdb) where
   #0  ExecuteFunction () at functions.c:228
   #1  0x425f10 in DirectionFunc () at builtins.c:4592
   #2  0x42d75c in ExecuteFunction () at functions.c:265
   #3  0x42a04c in HandleKeyPress () at events.c:399
   #4  0x429918 in DispatchEvent () at events.c:156
   #5  0x429984 in HandleEvents () at events.c:184
   #6  0x42ebe0 in main () at fvwm.c:518
   #7  0x408f98 in __start () at crt1text.s:165

Cheers,
-Ives
______________________________________________________________________
Ives Aerts (R&D Software engineer)           Sony DNSE-Brussels
[email-masked]                       St.Stevens Woluwestr. 55
`In this house, we obey the laws of          B-1130 Brussels, Belgium
 thermodynamics !!!'                         PHONE : +32 2 724 86 11
                             (Homer Simpson) FAX   : +32 2 724 86 88
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Feb 1999 13:36:10 +0100

On Mon, Feb 08, 1999 at 11:29:57AM +0100, [email-masked] wrote:
>...

Lines 228-230 are (current CVS):

  if (Action[0] == 0 || Action[1] == 0){/* impossibly short command */
    return;                             /* done */
  }

Could you change this to

  fprintf(stderr, "Action = 0x%08x\n", Action);
  if (Action[0] == 0 || Action[1] == 0){/* impossibly short command */
    return;                             /* done */
  }

And see if Action is a NULL pointer?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ives Aerts <[email-masked]>
Date: Mon, 8 Feb 1999 14:11:27 +0100

On Mon, Feb 08, 1999 at 01:36:10PM +0100, Dominik Vogt wrote:
> [snip]

It seems to be even worse:

  [FVWM][CreateConditionMask]: <<ERROR>> Conditionals require closing
  parenthesis
  Action = 0x00000009
  ÿÿÿÿSegmentation fault (core dumped)

Cheers,
-Ives