Subject: Release goals

From: Bob Woodside <[email-masked]>
Date: Tue, 23 Feb 1999 10:35:11 -0500

Let's make this one a new thread.

	Paul's suggestions:

>  * remove auto*-built files from CVS
>  * remove modules/extras distinction
>  * remove icons to a separate distribution
>  * move code duplicated in many modules into a library
>  * experiment with shared library for libfvwm

	Some of mine:

	* Turn on the GSFR code and fix whatever it breaks.
	* Evaluate the backlog of new style ideas.
	* Add animated windowshade.
	* Reuse FvwmWindow struct on Recapture.
	* The GNOME hint stuff.

- Bob
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Tue, 23 Feb 1999 10:40:04 -0500 (EST)

> Let's make this one a new thread.

Paul's suggestions?  He may have suggested many of the same things, but
that is _my_ message you're quoting!  ;-)

--
Steve Robbins                              <[email-masked]>

I was looking back to see
if you were looking back at me
to see me looking back at you.

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 25 Feb 1999 22:31:17 +0100

> Let's make this one a new thread.
[...]
> 	* Add animated windowshade.

I'll clean this up and send it in as soon as I get rid of the fever/flu
combo I've been struggling with this week...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 26 Feb 1999 08:42:28 +0000

> combo I've been struggling with this week...

If you can get the latest CVS there is a bit of code in
fvwm/resize.c:AnimatedMoveFvwmWindow() that sends modules messages
during the move. It would be nice if you adapted this for AnimatedShade
so the pager could follow the motion.

Cheers,
Tim.

---

From: Tomas Ogren <[email-masked]>
Date: Sat, 27 Feb 1999 16:13:32 +0100

> so the pager could follow the motion.

Hm.. I found that, yes.. but I found a different, pretty nasty thing..
can anyone confirm this:
Shade a window
Move the remains

Does it disappear with a X_ConfigureWindow - BadValue (integer parameter
out of range) ?

cvs fvwm 2.3/solaris 2.6

/Tomas