Subject: I'm dumb

From: Dan Espen <[email-masked]>
Date: Fri, 26 Feb 1999 16:48:58 -0500

I did this:

/u/tools/dane/fvwm/version-2_3_1/modules/FvwmForm> cvs update
cvs server: Updating .
A .FormFvwmCapture
A .FormFvwmQuitVerify
A .FormFvwmRlogin
A DefineMe.c
U FvwmForm.1
U FvwmForm.c
A FvwmForm.h
U Makefile.am
U Makefile.in
U README
A ReadXServer.c

Then put new  versions of FvwmForm.1,  FvwmForm.c, etc in place,  then
did this:

/u/tools/dane/fvwm/version-2_3_1/modules/FvwmForm> cvs commit ../ChangeLog .Form* DefineMe.c FvwmForm.1 FvwmForm.c FvwmForm.h Makefile.am README ReadXServer.c
cvs server: Up-to-date check failed for `FvwmForm.1'
cvs server: Up-to-date check failed for `FvwmForm.c'
cvs server: Up-to-date check failed for `Makefile.am'
cvs server: Up-to-date check failed for `README'
cvs [server aborted]: correct above errors first!
cvs commit: saving log message in /tmp/cvsBAA0Mppml

What is it checking that makes this fail?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214             E-mail: [email-masked]
Piscataway, NJ 08854                       Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: [email-masked] (Paul D. Smith)
Date: 26 Feb 1999 17:09:40 -0500

%% Dan Espen <[email-masked]> writes:

  de> /u/tools/dane/fvwm/version-2_3_1/modules/FvwmForm> cvs commit ../ChangeLog .Form* DefineMe.c FvwmForm.1 FvwmForm.c FvwmForm.h Makefile.am README ReadXServer.c
  de> cvs server: Up-to-date check failed for `FvwmForm.1'
  de> cvs server: Up-to-date check failed for `FvwmForm.c'
  de> cvs server: Up-to-date check failed for `Makefile.am'
  de> cvs server: Up-to-date check failed for `README'
  de> cvs [server aborted]: correct above errors first!
  de> cvs commit: saving log message in /tmp/cvsBAA0Mppml

  de> What is it checking that makes this fail?

Timestamps?

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 26 Feb 1999 17:36:41 -0500

----------
[email-masked] (Paul D. Smith) writes:
>   de> /u/tools/dane/fvwm/version-2_3_1/modules/FvwmForm> cvs commit ../Change
> Log .Form* DefineMe.c FvwmForm.1 FvwmForm.c FvwmForm.h Makefile.am README Rea
> dXServer.c

I thought that might be it, so I touched each of the files and
got the same result.

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Feb 1999 11:16:13 -0500 (EST)

> What is it checking that makes this fail?

Is it possible that someone snuck in a new version of one of those files
between the "update" and "commit" steps?

Did you try doing "cvs update" again before committing?

--
Steve Robbins                              <[email-masked]>

I was looking back to see
if you were looking back at me
to see me looking back at you.

---

From: Dan Espen <[email-masked]>
Date: Sat, 27 Feb 1999 13:10:39 -0500

----------
Steve Robbins <[email-masked]> writes:
> > /u/tools/dane/fvwm/version-2_3_1/modules/FvwmForm> cvs commit ../ChangeLog 
> .Form* DefineMe.c FvwmForm.1 FvwmForm.c FvwmForm.h Makefile.am README ReadXSe
> rver.c

Yes I did.

Just now, I tried again.   It looks like my changes  got in this time.
I first did "cvs update  -dP", then a  "cvs commit" from the "modules"
directory.  I have a vague memory of being told not to try to commit
with ../ChangeLog type file references.  I don't know if thats
what was behind this.

After the "update", I noticed   that not all the "Makefile.in"   files
were gone from the source tree.  After the commit, I saw lots of stuff
like this:

Checking in FvwmWinList/Makefile.in;
/home/cvs/fvwm/fvwm/modules/FvwmWinList/Attic/Makefile.in,v  <--  Makefile.in
new revision: 1.20; previous revision: 1.19

which doesn't look too good.  Sorry if I'm causing a mess, but between us,
I figure we will sort it out.

I'm going to get some lunch, I'll check in later...

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Feb 1999 13:22:42 -0500 (EST)

> with ../ChangeLog type file references.  I don't know if thats

Hmmm, yeah that might be it.  

> I figure we will sort it out.

I don't understand this.  My advice is to do 

	find . -name Makefile.in -print | xargs rm
	cvs update
	autoreconf

from the top of the source tree.

Is there something wrong with this?
I don't see how there possibly could be:
The waterbed's on fire, 
but everything else is as it should be.

---

From: [email-masked] (Paul D. Smith)
Date: 27 Feb 1999 14:10:06 -0500

%% Steve Robbins <[email-masked]> writes:

  sr> I don't understand this.  My advice is to do 

  sr> 	find . -name Makefile.in -print | xargs rm
  sr> 	cvs update
  sr> 	autoreconf

  sr> from the top of the source tree.

I wonder if a better idea, now that you've checked in all those fvwmform
changes, might not be to release the checked out module and check out
another, virgin copy going forward.