Subject: Re: List of Debian FVWM bugs

From: Bob Woodside <[email-masked]>
Date: Tue, 23 Feb 1999 11:23:31 -0500

Paul D. Smith <[email-masked]> may or may not have written:

>  jg> 11824a ...
> I believe some changes were made to 2.2 to alleviate this.

	All the reported instances I know of should be corrected by the fix (in
2.2) to keep FVWM from raising FVWM-managed windows above
override_redirect windows.

>  jg> 20444  Restarting fvwm seems to shift some windows slightly
> Good lord, I hope this is fixed but I suspect there may still be
> some shifting probs lurking :(.

	There are. Position the pager exactly in the lower right hand corner of
the screen, do a few restarts, and watch it wander upward and leftward. 
:-(

- Bob
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Wed, 24 Feb 1999 23:22:25 -0500 (EST)

Tim Phipps <[email-masked]> wrote:
> Bob Woodside wrote:
> > The answer to this one is that the feature is not supportable
> > within FVWM's current architecture.
> 
> Ahem. Not only is it possible, it is in the latest CVS, but only for
> opaque moves (and AnimatedMove's just for fun).

	My, it's amazing what you miss when you only superficially scan
the CVS logs for one day!

> You are right that it's impossible with rubberband windows. We could
> ungrab the server between undrawing the rubberband and redrawing it
> and assume the XServer will let the pager catch up but I don't think
> it's worth it.

	I gave that a quick try this evening, with no success. I don't
think it's worth pursuing further. Actually, I like the aesthetic of
not moving the pager icon while doing a rubberband move - to me, the
pager seems to mirror the actual appearance of the desktop better this
way.

	I wonder if we should make this feature optional...? When you
move the pager itself, it looks a mite jittery now.

- Bob

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Fri, 26 Feb 1999 10:22:25 -0500

Julian Gilbey <[email-masked]> wrote:
> > >  8954  FvwmPager should allow windows to be moved in
> > >  it => windows
>      ...
> I haven't been able to move windows in the pager.  Is there
> an option to do this?

	If you drag the little window icon with mouse button 2, the window it
represents will be moved. You can drag a window across page or desktop
boundaries, or even out of the pager and onto the current page.

> > >  9769  ClickToFocus and SkipMapping don't interact properly.
> >
> > Any more details here?
> 
> To quote the original report:
> 
>   The ClickToFocus and SkipMapping styles don't interact properly.
>  Replace your ~/.fvwm2rc with these two lines
>
>    Style *     ClickToFocus
>    Style test  StartsOnDesk 1, SkipMapping
>
>  then start an xterm as "xterm -name test".  The display stays at
>  desk 0 as it should, but the current window loses focus.

	Just try to reproduce this; go on, I dare ya'! (It's fixed.  :-) )

- Bob