Subject: RedHat FAQ diff

From: Michael Han <[email-masked]>
Date: Thu, 11 Feb 1999 23:35:27 -0800

Hi all, here's something we're in bad need of. An FAQ entry for all
the RedHat users out there who can't figure out what's going on with
FVWM. I think the answer I wrote sums things up pretty well... I
attached a diff.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
Why do we still live here in this repulsive town? All our friends are in New
York." Stephen Merritt

Index: docs/FAQ
===================================================================
RCS file: /home/cvs/fvwm/fvwm/docs/FAQ,v
retrieving revision 1.9
diff -c -r1.9 FAQ
*** docs/FAQ	1999/02/04 20:46:09	1.9
--- docs/FAQ	1999/02/12 07:28:17
***************
*** 103,108 ****
--- 103,111 ----
         47) How do I get Alt-Tab behaviour like another GUI?
         48) What's the difference between the Focus and FlipFocus commands?
         49) Why won't the StartIconic style work with {Netscape, etc.}?
+        50) I use FVWM on a RedHat Linux machine and can't figure out how to
+            my FVWM configuration. I've read the FVWM manpage but my changes
+ 	   don't seem to have any effect. What gives?
  
  ======================================================================
  
***************
*** 1169,1171 ****
--- 1172,1186 ----
     flag.)
  
  ----------------------------------------------------------------------
+ 
+ 50) I use FVWM on a RedHat Linux machine and can't figure out how to my
+     FVWM configuration. I've read the FVWM manpage but my changes don't
+     seem to have any effect. What gives?
+ 
+ A: RedHat Linux installs the X server accompanied (by default) with a
+    configuration management system. In earlier releases it was called
+    TheNextLevel and in more recent releases it's called AnotherLevel.
+    For further information about TheNextLevel, consult RedHat's
+    documentation in /usr/doc/TheNextLevel/. For information about
+    AnotherLevel, do a 'man AnotherLevel'.
+

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Feb 1999 11:06:52 +0100

> FVWM. I think the answer I wrote sums things up pretty well... I

Yup, I'll commit that at home.

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 12 Feb 1999 09:00:54 -0500 (EST)

^^^^^^^^^

I'm sorry.  This doesn't parse.  "How to my?"

How about inserting the word "configure" before the word "my?"

-- 
Larry Gensch					      [email-masked]

       "I suggest a new strategy, R2:  Let the Wookiee win." -- C-3PO

---

From: Michael Han <[email-masked]>
Date: Fri, 12 Feb 1999 09:33:41 -0800

Previously...
>How about inserting the word "configure" before the word "my?"

Err. You are right of course. Though rather than "configure" I'd say
"change" or "edit." I've reattached another diff, this time corrected.
Also made one other minor fix (accompanied by rather than accompanied
with). Sorry 'bout that.
-- 
[email-masked]
I will not snap bras
 - The collected wisdom of Bart Simpson

Index: docs/FAQ

***************
*** 1169,1171 ****
--- 1172,1186 ----
     flag.)
  
  ----------------------------------------------------------------------
+ 
+ 50) I use FVWM on a RedHat Linux machine and can't figure out how to change
+     my FVWM configuration. I've read the FVWM manpage but my changes don't
+     seem to have any effect. What gives?
+ 
+ A: RedHat Linux installs the X server accompanied (by default) by a
+    configuration management system. In earlier releases it was called
+    TheNextLevel and in more recent releases it's called AnotherLevel.
+    For further information about TheNextLevel, consult RedHat's
+    documentation in /usr/doc/TheNextLevel/. For information about
+    AnotherLevel, do a 'man AnotherLevel'.
+

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 12 Feb 1999 20:59:55 +0100

> Also made one other minor fix (accompanied by rather than accompanied
[...]
> +            my FVWM configuration. I've read the FVWM manpage but my changes

Maybe you should change it in both places?

> +     my FVWM configuration. I've read the FVWM manpage but my changes don't

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 12 Feb 1999 15:23:24 -0500

Here's a thought: we have a number of holes in our FAQ numbering now,
due to old questions no longer being relevant.

Should we try to fill those holes with new FAQs, like this, or just
leave them as holes for posterity?

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Fri, 12 Feb 1999 12:40:53 -0800

Previously...
>leave them as holes for posterity?

I'd wondered the same, but since the practice has been to append,
rather than to fill holes, I followed. Thoughts? I'd be happy to fill
the first available hole with my (hopefully) finally-fixed FAQ entry
(like the alliteration?).
-- 
[email-masked]
I will not charge admission to the bathroom
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 12 Feb 1999 16:03:36 -0500

> leave them as holes for posterity?

Glad to see I'm not the only one bothered by the holes.
By all means, fill them in.

> -- 
>  Paul D. Smith <[email-masked]>         Network Management Developmen

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Fri, 12 Feb 1999 23:49:56 -0800

>Maybe you should change it in both places?

Aargh!

Okay all, here what I hope is the last iteration of this entry.
Verified the duplicate text is really duplicate, fixed some stylistic
things, and moved the entry to the first vacant slot, 15.
-- 
[email-masked]
They are laughing at me, not with me
 - The collected wisdom of Bart Simpson

Index: docs/FAQ
===================================================================
RCS file: /home/cvs/fvwm/fvwm/docs/FAQ,v
retrieving revision 1.9
diff -c -r1.9 FAQ
*** docs/FAQ	1999/02/04 20:46:09	1.9
--- docs/FAQ	1999/02/13 07:38:12
***************
*** 2,8 ****
                     FVWM Frequently Asked Questions
  ======================================================================
  
! Last updated 02 Feb 1999 for release 2.2.0.
  
  INDEX
  
--- 2,8 ----
                     FVWM Frequently Asked Questions
  ======================================================================
  
! Last updated 12 Feb 1999 for release 2.2.0.
  
  INDEX
  
***************
*** 29,37 ****
             can I get XPM support?
         14) I'm trying to compile FVWM under SunOS using cc, but the compiler
             is having lots of problems.  What gives?
! 
!        15) (Question gone)
! 
         16) I'd really like to see neat feature XYZ in FVWM.
             Wouldn't that be cool?  I even have a patch.  When can it
             be added?
--- 29,37 ----
             can I get XPM support?
         14) I'm trying to compile FVWM under SunOS using cc, but the compiler
             is having lots of problems.  What gives?
!        15) I use FVWM on a RedHat Linux system and can't figure out how to
!            change my FVWM configuration. I've read the FVWM manpage but when
!            I edit my .fvwm2rc nothing seems to happen. What's going on ?
         16) I'd really like to see neat feature XYZ in FVWM.
             Wouldn't that be cool?  I even have a patch.  When can it
             be added?
***************
*** 548,553 ****
--- 548,566 ----
  
  A: cc under SunOS is not an ANSI C compiler.  Try using acc or gcc
     instead.
+ 
+ ----------------------------------------------------------------------
+ 
+ 15) I use FVWM on a RedHat Linux system and can't figure out how to
+     change my FVWM configuration. I've read the FVWM manpage but when
+     I edit my .fvwm2rc nothing seems to happen. What's going on?
+ 
+ A: RedHat Linux installs the X server accompanied (by default) by a
+    configuration management system. In earlier releases it was called
+    TheNextLevel and in more recent releases it's called AnotherLevel.
+    For further information about TheNextLevel, consult RedHat's
+    documentation in /usr/doc/TheNextLevel/. For information about
+    AnotherLevel, do a 'man AnotherLevel'.