Subject: Another interesting problem with focus

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 10 Feb 1999 14:13:28 -0600

I am seeing another problem with focus raising a window to the top.

Here is the scenario:

I am in a desktop with at least 10 terminal sessions and several icons.  I
changed to another desktop then go back to the one with the previous one.  I
move focus to a window on the bottom (I can see just the top third of this xterm
window), it gets the focus but does not pop on top of the other windows and
icons.  Now if I focus on other windows and icons (at least the icons that have
titles) then re-focus on my xterm window, it will now pop on top of the windows
and icons that I had just focused on but not on top of the windows and icons I
didn't.

Did I confuse anyone or just myself ;)

Something else for you to chew on Bob :)

I don't know if turning debug on would show anything useful.  If you think it
would I'll do it.

By the way I am running 2.1.11 on Solaris 2.5.1, X11R6.1.  I use SloppyFocus and
"FvwmAuto 500".

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 10 Feb 1999 15:26:11 -0500

> By the way I am running 2.1.11 on Solaris 2.5.1, X11R6.1.  I use SloppyFocus 

Looks like you  didn't apply this mornings stacking  order patch.  You
will need 2.1.12 (the current CVS).  Please apply this patch:

--- events.c	Tue Feb  9 21:00:01 1999
+++ events-fixed.c	Tue Feb  9 20:58:51 1999
@@ -1672,6 +1672,10 @@
 	        {
 	          break;
 	        }
+              else if (t1->icon_pixmap_w == children[i])
+	        {
+	          break;
+	        }
             }
           else
             {
--- focus.c	Tue Feb  9 21:41:53 1999
+++ focus-fixed.c	Tue Feb  9 21:41:31 1999
@@ -162,8 +162,21 @@
 	  }
       Scr.Ungrabbed = Fw;
     }
+/*
   if((Fw)&&(Fw->flags & ICONIFIED)&&(Fw->icon_w))
     w= Fw->icon_w;
+*/
+  if((Fw)&&(Fw->flags & ICONIFIED))
+    {
+      if (Fw->icon_w)
+        {
+          w = Fw->icon_w;
+        }
+      else if (Fw->icon_pixmap_w)
+        {
+          w = Fw->icon_pixmap_w;
+        }
+    }
   
   if((Fw)&&(Fw->flags & Lenience))
     {
--- misc.c	Tue Feb  9 21:00:01 1999
+++ misc-fixed.c	Tue Feb  9 22:18:56 1999
@@ -984,11 +984,26 @@
          Motif menus. Instead raise wins[0] only above the topmost window
 	 which is managed by us. 
       */
-     if (wins[0] != Scr.FvwmRoot.stack_next->frame && wins[0] != Scr.FvwmRoot.stack_next->icon_w) 
+     if (wins[0] != Scr.FvwmRoot.stack_next->frame && wins[0] != Scr.FvwmRoot.stack_next->icon_w && wins[0] != Scr.FvwmRoot.stack_next->icon_pixmap_w) 
       { 
         if (Scr.FvwmRoot.stack_next->flags & ICONIFIED)
           {
-            changes.sibling = Scr.FvwmRoot.stack_next->icon_w;
+            /*
+                RBW - use the icon window or pixmap if there is one; but
+                there may not be (NoIconTitle or NoIcon) --
+            */
+            if (Scr.FvwmRoot.stack_next->icon_w)
+              {
+                changes.sibling = Scr.FvwmRoot.stack_next->icon_w;
+              }
+            else if (Scr.FvwmRoot.stack_next->icon_pixmap_w)
+              {
+                changes.sibling = Scr.FvwmRoot.stack_next->icon_pixmap_w;
+              }
+            else
+              {
+                changes.sibling = Scr.FvwmRoot.stack_next->frame;
+              }
           }
         else
           {

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Robert H. Ford II" <[email-masked]>
Date: Wed, 10 Feb 1999 14:42:26 -0600

The only problem I have is that I do not seem to be able to do CVS from behind
our firewall.  I always get server unknown or some such message :(

---

From: Bob Woodside <[email-masked]>
Date: Wed, 10 Feb 1999 22:39:45 -0500 (EST)

"Robert H. Ford II" <[email-masked]> wrote:
> The only problem I have is that I do not seem to be able to do CVS from
> behind our firewall.  I always get server unknown or some such message :(
> 
> Dan Espen wrote:

	The patch should work if you have the 2.1.11 tarball installed. I
don't believe any actual code changes have been committed since then (yet),
though lots of proposed patches have been floating around.

- Bob