Subject: Ok to commit these ?

From: Matthias Clasen <[email-masked]>
Date: Sun, 28 Feb 1999 20:18:17 +0100

With my session and layer stuff in the tree,
I'd like to ask how the team thinks about
the following items:

 * Pick command (to avoid annoying multiple selections 
   with complex functions from root context) - TINY PATCH
 
 * All command (to execute a function for all windows
   matching certain conditions) - TINY PATCH

 * the "cube of wm-private states" (cf a thread back in jan.)
   ie shaded maximized windows and resizing of shaded windows.
   - LARGER

 * ICCCM2 compliance (the most visible thing here is probably 
   the ability to "take over" from a running ICCCM2-compliant WM)

Should I commit any of these to the main branch now ?
   
   Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Tomas Ogren <[email-masked]>
Date: Sun, 28 Feb 1999 20:32:57 +0100

> With my session and layer stuff in the tree,

I was just gonna test that one..
Btw.. is it so wise to use layer 0 and 1 for "normal" and StaysOnTop
windows? There's no room for "StaysOnBottom" styled layers then...

I'd like more like this:
0 - Bottom
5 - Normal
9 - Top

Ideas?

>    with complex functions from root context) - TINY PATCH

Hm.. I don't really get it...

>    matching certain conditions) - TINY PATCH

Sounds like a nice thing..

>    ie shaded maximized windows and resizing of shaded windows.

The ability to shade maximized windows would be very nice..

>    the ability to "take over" from a running ICCCM2-compliant WM)

How large is it? Anyhow, I think it would be nice to be more compliant..

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 28 Feb 1999 20:36:19 +0100

> windows? There's no room for "StaysOnBottom" styled layers then...

Do a 

DefaultLayers 9 5

0 and 1 are just the  "factory preset " values which are good
enough for backwards compatibility with old rc files.

---

From: Tomas Ogren <[email-masked]>
Date: Sun, 28 Feb 1999 20:44:57 +0100

> enough for backwards compatibility with old rc files.

Well.. with 5 and 9, it's like the old values (almost) but shifted up a
bit to allow room beneath... I think it's bad for the defaults to have
no room under the default layer...

On a slightly different issue, it would be nice if WinList and/or
Identify could tell me which layer a window is at now...

Shouldn't be too hard to hack in tho..

And it would be nice if 'Layer' supported
+number   - relative, higher layer
-number   - relative, lower layer
number    - absolute

/Tomas

---

From: Matthias Clasen <[email-masked]>
Date: Sun, 28 Feb 1999 21:01:07 +0100

> no room under the default layer...

I won't fight about this. But 0 and 1 are somehow canonical choices if
you want to cater for the old StaysOnTop/StaysPut model (there is *no*
StaysOnBottom to support there)

> -number   - relative, lower layer

This is already there:

Layer number  is a relative layer change,
Layer 0 number  is absolute
Layer 0 -1  is a special case (goes back to the
            layer the window started in)

At least this it what it should do. Tell me if it doesn't
or if I failed to describe this understandably in the man page.

---

From: Jay Painter <[email-masked]>
Date: Sun, 28 Feb 1999 13:23:44 -0800 (PST)

With regard to the layers stuff, GNOME already defines the meaning of the
layers.  As long as it's configurable we don't have any problems, but if
you want to go with what is already in use here are the definitions:

#define WIN_LAYER_DESKTOP                0
#define WIN_LAYER_BELOW                  2
#define WIN_LAYER_NORMAL                 4
#define WIN_LAYER_ONTOP                  6
#define WIN_LAYER_DOCK                   8
#define WIN_LAYER_ABOVE_DOCK             10
#define WIN_LAYER_MENU                   12

normal windows get set to layer 4 under this scheme.

Regards,
Jay

-----------------------------------------------------------------------
Jay Painter -- [email-masked] -- [email-masked] -- [email-masked]
http://www.serv.net/~jpaint/

---

From: Patrick Rogan <[email-masked]>
Date: Sun, 28 Feb 1999 20:24:48 -0500

I would REALLY like to have a "StaysOnBottom" style that places windows
in Layer 0 as a user-friendly shortcut.  Let's not use layer 0 as a
"factory preset " value.

~p@

---

From: Patrick Rogan <[email-masked]>
Date: Sun, 28 Feb 1999 22:10:45 -0500

> #define WIN_LAYER_MENU                   12

Sounds like this is what we want to do, or at least follow internally. 
Especially if we're moving towards "Gnome Compliance". 

Also, Matt, "Backwards compatible" != ignoring future enhancements. 
Using layers 1 and 2 by default are just as backwards compatible as 0 &
1, while letting us automatically take (nearly) full advantage of
/having/ layers.  

Let's not grow an extra leg and then chop off the foot here.  We need to
make it as easy for novice/intermediate users as it is for experienced
ones.

~p@