Subject: Re: FVWM: Restart of fvwm2 -- sometimes it works and sometimes it does not

From: Dan Espen <[email-masked]>
Date: Mon, 22 Feb 1999 09:54:27 -0500

"Plowman, Paul PW" <[email-masked]> writes:
> Howdy,
> 
> I am using fvwm2 Version 2.0.45
> 
> I use the following command to start it:
> 
> /usr/local/X11/bin/fvwm2 -f /home/ahplop/fvwm/fvwm2rc
> 
> When I use the restart, it hangs with an empty window
> on the screen and the cursor is a "<="

I've trimmed the  reply list  to just  fvwm-workers, and the  original
reporter.

If I'm  not mistaken, the logic  in fvwm/fvwm.c  SigDone() only passes
the "-s" argument into the  restarted fvwm2.  Since the "-f"  argument
is not passed along, "Restart" is doomed not to work.

Am  I  missing something?  Wouldn't  restarting  trying to  use "-cmd"
suffer the same fate?

In Paul's case, copying or linking /home/ahplop/fvwm/fvwm2rc to
~/.fvwm2rc is a workaround.

> - Paul Plowman
> --

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 22 Feb 1999 10:16:22 -0500

> Am  I  missing something?  Wouldn't  restarting  trying to  use "-cmd"

I use -cmd to run FvwmM4 and pass it a ton of args and in my rc
is just do
Restart <path>/fvwm2
and everything gets parsed and I since i give M4 -debug I do get 
another fvwmrc$@#$!@!#$ in /tmp so I know it is running m4

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].