Subject: Re: DGradient - One mo' bug

From: Jay <[email-masked]>
Date: Mon, 1 Feb 1999 23:57:06 -0500 (EST)

> > These ones seem to be bugs. If the menu is n times m
> > pixels wide/high, the biggest valid x/y values are n-1 and
> > m-1. I.e. x = mr->width and y = mr->height are not inside the
> > menu. Wasn't there some discussions recently if the end points
> > of a line are drawn (XDrawLine)? The same applies to other
> > parts of the diagonal gradient code.
> 
> 	I should think so. But this is the only area where I saw the
> problem occurring, so it's the only one I tinkered with. I'm really
> curious whether anyone else can duplicate the problem.

	I can duplicate it.  If I use DGradient I get that extra band
along the side every so often.  I think that it may actually be a bug in
the AcceleratedX server (which I too am using).  I bet it is.  I'll look
tomorrow at work and see if I get the same thing on my 'normal' XFree86
system.

	I think they are bugs in the Xserver, because if they were just
math errors, I would think that the Xserver would not let it off of the
window it was drawing on.  My guess is that it has something to do with
the line-drawing code in AcceleratedX.

	I'll check it tomorrow and report.

Jay

PS- I use gcc on FreeBSD

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Feb 1999 11:07:49 +0100

> the line-drawing code in AcceleratedX.

Sounds sensible. I propose that we incorporate Tim's 45 degree
drawing code and be done with it for now. In the future I'd
like to document such bugs and ignore them otherwise.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jay <[email-masked]>
Date: Tue, 2 Feb 1999 09:08:55 -0500 (EST)

> like to document such bugs and ignore them otherwise.

	I've confirmed it... (to my satisfaction) Using the same config
that I get all sorts of ugly lines left behind on my home machine
(running AcceleratedX), it works fine on my workstation, running XFree.

Jay

PS- I updated this morning, and I think the 45 degree code looks great.
And it has no ugly residue ;P