Subject: FVWM CVS: fvwm steve

From: CVS <[email-masked]>
Date: Fri, 26 Feb 1999 21:18:29 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	steve	99/02/26 21:18:29

Modified files:
	.              : ChangeLog 
	docs           : ChangeLog DEVELOPERS cvs.html 
Added files:
	.              : .cvsignore 
	extras         : .cvsignore 
Removed files:
	.              : Makefile.in aclocal.m4 config.h.in configure 
	                 install-sh missing mkinstalldirs stamp-h.in 
	docs           : Makefile.in 
	extras         : Makefile.in 
	extras/FvwmCommand: Makefile.in 
	extras/FvwmConfig: Makefile.in 
	extras/FvwmConsole: Makefile.in 
	extras/FvwmDebug: Makefile.in 
	extras/FvwmGoodStuff: Makefile.in 
	extras/FvwmPipe: Makefile.in 
	extras/FvwmScript: Makefile.in 
	extras/FvwmTaskBar: Makefile.in 
	extras/FvwmWharf: Makefile.in 
	extras/fvwmperl: Makefile.in 
	extras/fvwmpython: Makefile.in 
	fvwm           : Makefile.in 
	icons          : Makefile.in 
	libs           : Makefile.in 
	modules        : Makefile.in 
	modules/FvwmAnimate: Makefile.in 
	modules/FvwmAudio: Makefile.in 
	modules/FvwmAuto: Makefile.in 
	modules/FvwmBacker: Makefile.in 
	modules/FvwmBanner: Makefile.in 
	modules/FvwmButtons: Makefile.in 
	modules/FvwmCpp: Makefile.in 
	modules/FvwmEvent: Makefile.in 
	modules/FvwmForm: Makefile.in 
	modules/FvwmIconBox: Makefile.in 
	modules/FvwmIconMan: Makefile.in 
	modules/FvwmIdent: Makefile.in 
	modules/FvwmM4 : Makefile.in 
	modules/FvwmPager: Makefile.in 
	modules/FvwmRearrange: Makefile.in 
	modules/FvwmSave: Makefile.in 
	modules/FvwmSaveDesk: Makefile.in 
	modules/FvwmScroll: Makefile.in 
	modules/FvwmTalk: Makefile.in 
	modules/FvwmWinList: Makefile.in 
	sample.fvwmrc  : Makefile.in 
	tests          : Makefile.in 
	utils          : Makefile.in 

Log message:
Removing the files built by automake & autoconf.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Sat, 27 Feb 1999 00:31:28 -0500 (EST)

CVS <[email-masked]> wrote:
> ...

	Steve...Help!  I updated my CVS directory shortly after you did
the great autoconf change, and now I'm at a loss to know how to build
Fvwm.

	I have autoconf 2.13 and automake 1.4 - never used them before.
Per the instructions in docs/DEVELOPERS, I issued the command

	automake --add-missing 

and got the following:

>>  automake: configure.in: installing `./install-sh'
>>  automake: configure.in: installing `./mkinstalldirs'
>>  automake: configure.in: installing `./missing'
>>  configure.in: 6: required file `./config.h.in' not found

It went downhill from there, of course. Copying in a config.h.in from
yesterday's CVS update, just to see what would happen,  didn't produce
stunning results. Automake and autoconf ran; autoconf gave these
warnings:

>>  configure.in:159: warning: AC_TRY_RUN called without default to allow
>>  cross compiling 
>>  configure.in:215: warning: AC_TRY_RUN called without default to allow 
>>  cross compiling

and then attempting to run ./configure yielded this:

>>  ./configure: line 532: syntax error near unexpected token `AM_INIT_AUTOMAKE(fvwm,'
>>  ./configure: line 532: `AM_INIT_AUTOMAKE(fvwm, 2.3.0)'

	So how does one *really* get this thing to build with autoconf?

- Bob "Clueless in Connecticut"

---

From: [email-masked] (Paul D. Smith)
Date: 27 Feb 1999 00:46:59 -0500

You need to run multiple tools the first time (after that the makefile
will keep things up-to-date).

I think the right order is:

  aclocal
  autoheader
  autoconf
  automake

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Sat, 27 Feb 1999 01:39:54 -0500 (EST)

> will keep things up-to-date).

	Thanks, Paul! I'm back in business.

- Bob

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Feb 1999 10:47:26 -0500 (EST)

> I think the right order is:

I thought that 'autoreconf' does all of the above for you.  No?

In any event, it is important to *also* run automake --add-missing at some
point, to get the COPYING, install-sh, and some other file.

--
Steve Robbins                              <[email-masked]>

Istanbul was Constantinople,
now it's Istanbul, not Constantinople.
Why did Constantinople get the works?
That's nobody's business but the Turks'!

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Feb 1999 10:52:02 -0500 (EST)

> >>  configure.in: 6: required file `./config.h.in' not found

Yeah, these you can ignore.

Did I forget to mention "autoreconf" in docs/DEVELOPERS?  Aigh!  Sorry
about that!  (I did mention it other places: cvs.html, and the ChangeLog,
I think)

Anyone who does a "cvs update" will find a bunch of files deleted out from
under them.  Do this:

	automake --add-missing
	autoreconf

Then "make" will take care of things.

I'm a member of the Elvis Death Cult.

---

From: [email-masked] (Paul D. Smith)
Date: 27 Feb 1999 12:44:30 -0500

%% Steve Robbins <[email-masked]> writes:

  sr> I thought that 'autoreconf' does all of the above for you.  No?

Maybe... the docs are quite unclear about it.  They only mention running
autoconf: it seems to be more geared towards deep packages where you
have lots of configure.in's; autoreconf will autoconf all of them.

Maybe it does the other stuff, too.

---

From: Steve Robbins <[email-masked]>
Date: Sat, 27 Feb 1999 13:24:36 -0500 (EST)

> Maybe it does the other stuff, too.

It does.  I just tried it from my machine at home.  After "cvs update",
all the stuff I removed last night got deleted.  Then

	automake --add-missing
	autoreconf

was enough to restore all the generated files.  

[It is too bad that autoreconf doesn't support passing the "--add-missing"
on to the automake it spawns.]

When love is gone, there's always justice.
And when justice is gone, there's always force.
And when force is gone, there's always Mom.