Subject: Notification: incoming/187

From: [email-masked]
Date: Sun, 21 Feb 1999 19:05:35 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/187

Message summary for PR#187
	From: [email-masked]
	Subject: PopupOffset with Animation doesn't work
	Date: Sun, 21 Feb 1999 19:05:33 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Feb 1999 02:49:54 +0100

On Sun, Feb 21, 1999 at 07:05:35PM -0600, [email-masked] wrote:
> >From [email-masked]  Sun Feb 21 19:05:34 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id TAA12595
> 	for <[email-masked]>; Sun, 21 Feb 1999 19:05:33 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Nathan Froyd
> Version: 2.1.13
> CVS_Date: 
> OS: Linux 2.0.35
> X_Server: XFCom 2.0.0
> Submission from: (NULL) (137.112.205.56)
> 
> 
> I have PopupOffset 1 100 (as suggested in the manpage) and Animation
> specified
> for all my menus. If I popup a menu (A) that needs to be animated, it still
> overlaps
> the parent menu. This behavior persists for all menus that are narrower
> than menu
> A. Once I popup a wider submenu, all the narrower menus work perfectly.

Hmm, yes. Animation moves the parent menu only until it's
unobscured. It doesn't honour the PopupOffset, and I don't
think is should. It's more a a bug in the manpage. Anyway
the passage suggesting to use 'PopupOffset' is a bit out
of date. Do you have any problems with the gradients or
did you just try if this changes something?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Froyd <[email-masked]>
Date: Sun, 21 Feb 1999 21:06:14 -0500 (EST)

> did you just try if this changes something?

I'm not entirely sure I understand the last part of the last
sentence. I don't have gradients on my menus (pixmap backgrounds), so
I don't know if there's a problem there. The issue is mostly cosmetic, 
I suppose. I'm curious as to why you think it shouldn't honor the
PopupOffset -- it's not like the variable doesn't apply in that
special case.
-- 
Nathan -- [email-masked] -- [email-masked] -- CS/MA 02
Evolution is a million line computer program falling into place by accident.
God went through hell so we don't have to.        ICQ:18861764 AOL:myrlyn007
                    http://www.rose-hulman.edu/~froydnj/
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Feb 1999 16:37:18 +0100

On Sun, Feb 21, 1999 at 09:06:14PM -0500, Nathan Froyd wrote:
> I don't know if there's a problem there.

If you don't have gradients I wonder why you use
PopupOffset 1 100 at all. Excerpt from the manpage:

    If you encounter performance problems with gradient
    backgrounds you can try one or all of  the  follow
    ing:

    ...

    Make sure submenus do not overlap the parent  menu.
    This  can  prevent menus being redrawn every time a
    submenu pops up or down.

         MenuStyle <stylename> PopupOffset 1 100

> The issue is mostly cosmetic, 

Well, it has to be honoured if your PopupOffset makes your menus
overlapping by default. But what would you do if you use
'PopupOffset 50 100'. Surely you wouldn't want the parent menu
animated when the gap is only 25 pixels instead of 50? I've
optimised the code to do no unnecessary animation (e.g. if the menus
overlap only a few pixels) since it takes time.

Bye

Dominik