Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Thu, 11 Feb 1999 16:31:38 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	99/02/11 16:31:37

Modified files:
	.              : ChangeLog Makefile.in NEWS 
	docs           : Makefile.in 
	extras         : Makefile.in 
	extras/FvwmCommand: Makefile.in 
	extras/FvwmConfig: Makefile.in 
	extras/FvwmConsole: Makefile.in 
	extras/FvwmDebug: Makefile.in 
	extras/FvwmGoodStuff: Makefile.in 
	extras/FvwmPipe: Makefile.in 
	extras/FvwmScript: Makefile.in 
	extras/FvwmScript/Scripts: Makefile.in 
	extras/FvwmScript/Scripts/some_nice_icons: Makefile.in 
	extras/FvwmScript/Widgets: Makefile.in 
	extras/FvwmTaskBar: Makefile.in 
	extras/FvwmWharf: Makefile.in 
	fvwm           : Makefile.in builtins.c functions.c fvwm2.1 
	                 misc.c 
	icons          : Makefile.in 
	libs           : Makefile.in 
	modules        : Makefile.in 
	modules/FvwmAnimate: Makefile.in 
	modules/FvwmAudio: Makefile.in 
	modules/FvwmAuto: Makefile.in 
	modules/FvwmBacker: Makefile.in 
	modules/FvwmBanner: Makefile.in 
	modules/FvwmButtons: Makefile.in 
	modules/FvwmCpp: Makefile.in 
	modules/FvwmEvent: Makefile.in 
	modules/FvwmForm: Makefile.in 
	modules/FvwmIconBox: Makefile.in 
	modules/FvwmIconMan: Makefile.in 
	modules/FvwmIdent: Makefile.in 
	modules/FvwmM4 : Makefile.in 
	modules/FvwmPager: Makefile.in 
	modules/FvwmRearrange: Makefile.in 
	modules/FvwmSave: Makefile.in 
	modules/FvwmSaveDesk: Makefile.in 
	modules/FvwmScroll: Makefile.in 
	modules/FvwmTalk: Makefile.in 
	modules/FvwmWinList: Makefile.in 
	sample.fvwmrc  : Makefile.in 
	tests          : Makefile.in 
	utils          : Makefile.in 

Log message:
Will this Makefile.in story never end? :(

Coredump fixes in 'Direction' et al.
menu position hints syntax change
manpage updated for @@, %%, ** and ^^ in menu (item) names

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 11 Feb 1999 19:30:30 -0500

%% CVS <[email-masked]> writes:

  c> Will this Makefile.in story never end? :(

It'll end as soon as you edit your automake script and change the line:

  TAR=gtar

to:

  TAR=tar

just as I said last time this happened :).  Note you'll have to remember
to re-do this change every time you reinstall automake, or install a new
version.

Of couse, once 2.2.0 is cut I hope the very first commit to 2.3.x will
be Steve or someone removing all these files anyway--then you won't be
able to build without having autoconf and automake installed (and GCC
and GNU make) but at least we won't have this problem anymore.

IMO a good practice whenever you're about to commit changes is to run
"cvs update" first, and look at the files marked "M"; these are ones CVS
thinks you've modified and the ones that it will check in as changed.
If you see odd things in there (like every Makefile.in when you didn't
change configure.in or any Makefile.am's) you can investigate then
before you commit.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 12 Feb 1999 01:39:57 +0100

> change configure.in or any Makefile.am's) you can investigate then

Don't run 'cvs commit' but 'cvs commit <thefilesyouwanttocommit>'.. that
will take care of all these "Oops.. there they go again"...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 11 Feb 1999 19:47:13 -0500

%% Tomas Ogren <[email-masked]> writes:

  to> Don't run 'cvs commit' but 'cvs commit <thefilesyouwanttocommit>'.. that
  to> will take care of all these "Oops.. there they go again"...

True... but you run the risk of forgetting to check in some changes.

YMMV, but I prefer my method (cvs update, check the "M"odified files to
make sure they're reasonable, then cvs commit).

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Feb 1999 02:06:38 +0100

> to re-do this change every time you reinstall automake, or install a new

Yes, of course. I didn't reapply this when I installed automake-1.4.
I'm such an idiot.

> change configure.in or any Makefile.am's) you can investigate then

Yes, I know. I just forgot it this time.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]