Subject: Re: documentation trivia

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Feb 1999 02:31:29 +0100

On Sat, Feb 20, 1999 at 11:48:05PM +0100, Matthias Clasen wrote:
> 
> Little things I noted while skimming over the docs:
> 
> docs/fvwm.lsm:  s/distributied/distributed/
> 
> man page:
> There are a few command prototypes (ColormapFocus, Emulate,
> EdgeThickness), which use [ x | y | z ] to denote a required
> argument with possible values x, y or z while all others use
> [ opt ] to denote an optional argument. This is inconsistent
> (although it is never explicitly mentioned that [ ] means
> optional args).

I think this is because there is no way to say 'x or y or z'
without the braces. In the standard manpage terminology you
can't say 'command x | y | z'. Is this right? How should it
look like?

> Popup: the command prototype has double-click-action,
> but the text speaks about default-action.
> 
> Read: the "option" argument is optional, thus it should be
> put in brackets in the prototype. Its occurrence in the text
> should be highlighted.
> 
> SetAnimation: put the optional fractions-to-move-list in brackets
> 
> SnapAttraction: put the optional behavior in brackets. The text
> mentions a "SnapGrid option". That would better be a "SnapGrid command".
> 
> UpdateDecor: put the optional decor in brackets

I'll take care of these when 2.2 is out.

> With the fvwm version being 2.2 now, why is the man page still
> named fvwm2.1 ? :-)

I'm not sure if we should promote fvwm from 'Executable programs'
to 'System calls' ;-)

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 22 Feb 1999 08:36:59 -0500

> > (although it is never explicitly mentioned that [ ] means

Looking at the Manpage ColormapFocus is the only one I see that uses
brackets. Emulate and EdgeThickness don't

> can't say 'command x | y | z'. Is this right? How should it
 
I would say that these three convey their point correctlly.

Brad
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].