Subject: Notification: incoming/171

From: [email-masked]
Date: Mon, 15 Feb 1999 07:38:40 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/171

Message summary for PR#171
	From: [email-masked]
	Subject: Whitespace from modules crashes fvwm2
	Date: Mon, 15 Feb 1999 07:38:39 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Steve Robbins <[email-masked]>
Date: Mon, 15 Feb 1999 13:17:00 -0500 (EST)

On Mon, 15 Feb 1999 [email-masked] wrote:

> Full_Name: 
> Version: 2.1.11
> CVS_Date: 
> OS: 
> X_Server: 
> Submission from: (NULL) (194.202.174.12)
> 
> 
> Found this while pasting into FvwmConsole:
> 
> A line typed into FvwmConsole that just has whitespace causes fvwm to core
> dump.

Yup, and I can reproduce it in 2.1.13 too.

The problem as I see it is that code is not careful about checking
function return values. 

In this case, I can fix this by adding the lines marked "+" in
ExecuteFunction (fvwm/functions.c): 

  taction = expand(Action,arguments,tmp_win);
  action = GetNextToken(taction,&function);

+  if ( function == NULL )
+      return;

> So does FvwmCommand "  ".  Reading a file with spaces does not.

This I cannot reproduce.  I just get a cryptic error message:

	steve@hilbert{steve}FvwmCommand "  "
	No such file or directory FvwmCommand error in opening message fifo

I don't understand this.  But maybe you could check if the above fix takes
care of FvwmCommand, too. 

--
Steve Robbins                              <[email-masked]>

I was looking back to see
if you were looking back at me
to see me looking back at you.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Feb 1999 12:01:58 +0100

> Yup, and I can reproduce it in 2.1.13 too.

Um, I hope not. I repaired it for the 2.1.12 tarball.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Tue, 16 Feb 1999 18:01:49 -0500 (EST)

> Um, I hope not. I repaired it for the 2.1.12 tarball.

That's not what the ChangeLog says:

1999-02-15  Dominik Vogt  <[email-masked]>

        * fvwm/functions.c (FindBuiltinFunction):
        (ExecuteFunction): NULL pointer coredump fixed

	[...]

1999-02-14  Dominik Vogt  <[email-masked]>

        * configure.in: Change version to 2.1.13

If I had a rocket launcher, some son of a bitch would die.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 17 Feb 1999 14:23:30 +0100

>         (ExecuteFunction): NULL pointer coredump fixed

Yes, I didn't explain it very well, but it should be the same bug.

Bye

Dominik