Subject: Notification: incoming/144

From: [email-masked]
Date: Mon, 25 Jan 1999 15:19:36 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/144

Message summary for PR#144
	From: [email-masked]
	Subject: builds on IRIX 5.3, but fails to run on IRIX 6.2
	Date: Mon, 25 Jan 1999 15:19:34 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Dan Espen <[email-masked]>
Date: Mon, 25 Jan 1999 16:37:09 -0500

[email-masked] writes:
> >From [email-masked]  Mon Jan 25 15:19:35 1999
> Received: from localhost (localhost [127.0.0.1])
> 	by larry.math.uh.edu (8.9.1/8.9.1) with ESMTP id PAA06731
> 	for <[email-masked]>; Mon, 25 Jan 1999 15:19:34 -0600 (CST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Full_Name: Håvard Fosseng
> Version: 2.1.10
> CVS_Date: 
> OS: IRIX 6.2
> X_Server: 
> Submission from: (NULL) (129.240.92.80)
> 
> 
> My local machine, running IRIX 6.2, is not set up to build 
> software. I do that on another computer running IRIX 5.3.
> 
> When building 2.1.10, "configure", "make" and "make install"
> all had exit status 0. The only thing that on the face of it
> seemed suspicious was the following output from "configure":
> 
> checking for Xpm 3.4f or better...  9814:./conftest: rld: Fatal Error:
> cannot map soname 'libXpm.so.4.11' using any of the filenames
> /usr/lib/libXpm.so.4.11:/lib/libXpm.so.4.11:/lib/cmplrs/cc/libXpm.so.4.11:/us
> r/lib/cmplrs/cc/libXpm.so.4.11:
> -- either the file does not exist or the file is not mappable (with reason
> indicated in previous msg)
> no
> 
> (Note, however, that configure continued running and finished
> with exit status 0.)

As it should, although you won't be happy with the result.
It couldn't "map?" the Xpm library so you won't be able to display
Xpms.  Make sure the XPM library is installed and executable by
you.  You may have to make configure look for it in a special place.
Try "./configure --help" for more information.

> When trying to run what I had built (on IRIX 6.2), I got the
> following message:
> 
> 22704:/usit/sauron/u4/havardf/bin/fvwm2: rld: Fatal Error: Cannot
> Successfully Map soname 'libSM.so.6.0' under any of the filenames
> /usr/lib/libSM.so.6.0:/usr/lib/internal/libSM.so.6.0:/lib/libSM.so.6.0:/lib/c
> mplrs/cc/libSM.so.6.0:/usr/lib/cmplrs/cc/libSM
> 
> Both the computer where I built 2.1.10 and the computer where
> I tried to run them had files named "/usr/lib/libSM.so".
> 
> On the 5.3 computer:
> -rw-r--r--   1 root     root       823380 May 21  1995 /usr/lib/libSM.so
> 
> On the 6.2 computer:
> -rw-r--r--   1 root     root       798544 May  9  1998 /usr/lib/libSM.so

Its looking for libSM.so.6.0, you don't say anything about its presence.
                        ^^^^
> 
> I successfully built and ran 2.1.7 on the same combination of computers.
> I guess you will need more information, but short of including the entire 
> ouput from "configure", "make" and "make install" I don't know what
> will be helpful.
> 
> --

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Hevard Fosseng <[email-masked]>
Date: 25 Jan 1999 22:58:42 +0100

> Try "./configure --help" for more information.

But should this "only" mean that fvwm will be built without XPM support?

> Its looking for libSM.so.6.0, you don't say anything about its presence.

On the computer where I built it:

$ /local/gnu/bin/find /lib /usr/lib -follow  -iname \*libsm\* 2>/dev/null
/usr/lib/libSM.so
/usr/lib/libSM.a

On the computer where I tried to run it:

$ /local/gnu/bin/find /lib /usr/lib -follow  -iname \*libsm\* 2>/dev/null
/usr/lib/libSM.so

Is the non-presence of /usr/lib/libSM.a on my desktop computer likely to
be the culprit?

- H}vard Fosseng

---

From: [email-masked] (Paul D. Smith)
Date: 25 Jan 1999 17:06:33 -0500

%% Hevard Fosseng <[email-masked]> writes:

  >> Try "./configure --help" for more information.

  hf> But should this "only" mean that fvwm will be built without XPM support?

  >> Its looking for libSM.so.6.0, you don't say anything about its presence.

  hf> On the computer where I built it:

  hf> $ /local/gnu/bin/find /lib /usr/lib -follow  -iname \*libsm\* 2>/dev/null
  hf> /usr/lib/libSM.so
  hf> /usr/lib/libSM.a

  hf> On the computer where I tried to run it:

  hf> $ /local/gnu/bin/find /lib /usr/lib -follow  -iname \*libsm\* 2>/dev/null
  hf> /usr/lib/libSM.so

Please use "ls -l /usr/lib/libSM.so".  Is this really a symlink to some
other directory pointing to a file "libSM.so.6.0"?

Do the same on the system where it doesn't work; is it a different
library or in a different place?

  hf> Is the non-presence of /usr/lib/libSM.a on my desktop computer likely to
  hf> be the culprit?

Not likely, no.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Hevard Fosseng <[email-masked]>
Date: 25 Jan 1999 23:25:18 +0100

$ ls -l /usr/lib/libSM.so 
lrwxr-xr-x   1 root     root            8 May 21  1995 /usr/lib/libSM.so -> libXt.so
$ ls -l /usr/lib/libXt.so 
-rw-r--r--   1 root     root       823380 May 21  1995 /usr/lib/libXt.so

$ ls -l /usr/lib/libSM.so 
lrwxr-xr-x   1 root     root            8 Dec 11  1996 /usr/lib/libSM.so -> libXt.so
$ ls -l /usr/lib/libXt.so 
-rw-r--r--   1 root     root       798544 May  9  1998 /usr/lib/libXt.so

- H}vard Fosseng

---

From: Dan Espen <[email-masked]>
Date: Tue, 26 Jan 1999 09:41:18 -0500

> -rw-r--r--   1 root     root       798544 May  9  1998 /usr/lib/libXt.so

Try doing "ls /usr/lib/libSM*".  You should see libSM.so.6 somewhere in
the output.  Here is a Solaris 2.6 example:

fork> ls -al /usr/lib/libSM*
lrwxrwxrwx  1 root  root  12 Jul 07  1998 /usr/lib/libSM.so@ -> ./libSM.so.6
lrwxrwxrwx  1 root  root  25 Jul 07  1998 /usr/lib/libSM.so.6@ -> ../openwin/lib/libSM.so.6

---

From: [email-masked] (Paul D. Smith)
Date: 26 Jan 1999 09:57:17 -0500

hf> $ ls -l /usr/lib/libSM.so 
  hf> lrwxr-xr-x   1 root     root            8 May 21  1995 /usr/lib/libSM.so -> libXt.so
  hf> $ ls -l /usr/lib/libXt.so 
  hf> -rw-r--r--   1 root     root       823380 May 21  1995 /usr/lib/libXt.so

  hf> $ ls -l /usr/lib/libSM.so 
  hf> lrwxr-xr-x   1 root     root            8 Dec 11  1996 /usr/lib/libSM.so -> libXt.so
  hf> $ ls -l /usr/lib/libXt.so 
  hf> -rw-r--r--   1 root     root       798544 May  9  1998 /usr/lib/libXt.so

I don't know what to say, except rebuild it on the second and hopefully
it will work.

I don't understand why the loader is looking for libSM.so.6.0 if only
libSM.so exists, and why it finds it on one system but not the other.

But, anyway, this definitely seems to be an "interesting" quirk of your
operating system and not anything to do with fvwm (that I can see).

Perhaps there's a USENET group or something where you could ask this of
people familiar with your OS?