Subject: Icon problem

From: "Robert H. Ford II" <[email-masked]>
Date: Mon, 25 Jan 1999 11:50:41 -0600

I am running fvwm-2.1.10 on Solaris 2.5.1.

The problem I am seeing is this:  If I move the focus to an icon it pops to the
top as expected (I use FvwmAuto), but if I then move the focus to let's say a
xterm window behind this icon, the icon does not drop behind.  I can manually
"lower" the icon but should it not drop behind a newly focused window it self?

I looked through the man page for any "Style" changes that might have an effect
on this, but have found nothing.

Is anyone else have this problem.

On a side note.  Who, if anyone, is maintaining FvwmWharf?  I've been trying to
merge the newer AfterStep "Wharf" for use in fvwm2, but I am having a ton of
problems.  This version Wharf has some nice features including a "balloon"
option.

Thank you for any and all help.
-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 25 Jan 1999 13:07:35 -0500

> problems.  This version Wharf has some nice features including a "balloon"

I think its safe to say, FvwmWharf is in  our source tree, but none of
the current developers has taken a special interest in it.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Mon, 25 Jan 1999 20:11:08 -0500 (EST)

> "lower" the icon but should it not drop behind a newly focused window it self?

	I think it should. Can you tell us what was the last release you used
that didn't exhibit this behavior? It would be a great help if we can get an
idea when it crept in.

	Without any further investigation, I would suspect that Matthias and
I introduced this, um, feechur, with the "don't raise above override-redirect
windows" fix. It's the only recent change I'm familiar with that might have
caused this, but I'm not sure how.

	I'll look into it.

- Bob

---

From: Bob Woodside <[email-masked]>
Date: Mon, 25 Jan 1999 22:13:47 -0500 (EST)

Bob Woodside <[email-masked]> wrote:
> > If I move the focus to an icon it pops to the top as expected (I
> > use FvwmAuto), but if I then move the focus to let's say a xterm
> > window behind this icon, the icon does not drop behind.

> 	Without any further investigation, I would suspect that Matthias
> and I introduced this, um, feechur, with the "don't raise above
> override-redirect windows" fix.

	Yup, that was the culprit! The new raise code didn't recognize
the case when the top of the stack was an icon window instead of the
app window frame.

	Attached is the diff to fix this. In case you haven't been
following the workers list too closely, 2.2 is under a code freeze,
meaning that only bug fix changes are allowed, and then by consensus
of the workers.

	So, cast your votes, folks. I vote for inclusion.

- Bob
--- misc.c	Mon Jan 25 21:50:59 1999
+++ misc-fixed.c	Mon Jan 25 21:50:32 1999
@@ -976,7 +976,7 @@
 
   if(i > 0)
     {
-/*      XRaiseWindow(dpy,wins[0]);  */
+/**/      XRaiseWindow(dpy,wins[0]);  /**/
       /*
            [email-masked] - 01/01/1999 - 
          simply calling XRaiseWindow(dpy,wins[0]); here will put StaysOnTop
@@ -984,9 +984,16 @@
          Motif menus. Instead raise wins[0] only above the topmost window
 	 which is managed by us. 
       */
-     if (wins[0] != Scr.FvwmRoot.stack_next->frame) 
+     if (wins[0] != Scr.FvwmRoot.stack_next->frame && wins[0] != Scr.FvwmRoot.stack_next->icon_w) 
       { 
-        changes.sibling = Scr.FvwmRoot.stack_next->frame;
+        if (Scr.FvwmRoot.stack_next->flags & ICONIFIED)
+          {
+            changes.sibling = Scr.FvwmRoot.stack_next->icon_w;
+          }
+        else
+          {
+            changes.sibling = Scr.FvwmRoot.stack_next->frame;
+          }
         changes.stack_mode = Above;
         XConfigureWindow(dpy, wins[0], (CWSibling|CWStackMode), &changes);
       }

---

From: Bob Woodside <[email-masked]>
Date: Mon, 25 Jan 1999 22:38:12 -0500 (EST)

Bob Woodside <[email-masked]> wrote:
> 	Attached is the diff to fix this.

	Well, that one would fix the observable problem, but it wan't
quite the whole story. I didn't diff events.c, where the stacking
order chain rebuilder needed similar modification. Here's the full
fix...in-line this time. I'm not sure I trust what this funky mailer
is doing with attachments.

- Bob

--- events.c	Mon Jan 25 22:27:05 1999
+++ events-fixed.c	Mon Jan 25 22:24:59 1999
@@ -1666,10 +1666,20 @@
     {
       for (t1 = Scr.FvwmRoot.next; t1 != NULL; t1 = t1->next) 
 	{
-	  if (t1->frame == children[i]) 
-	    {
-	      break;
-	    }
+          if (t1->flags & ICONIFIED && (!(t1->flags & SUPPRESSICON)))
+            {
+	      if (t1->icon_w == children[i]) 
+	        {
+	          break;
+	        }
+            }
+          else
+            {
+	      if (t1->frame == children[i]) 
+	        {
+	          break;
+	        }
+            }
 	}
 
       if (t1 != NULL && t1 != t2) 
--- misc.c	Mon Jan 25 21:50:59 1999
+++ misc-fixed.c	Mon Jan 25 22:25:40 1999
@@ -976,7 +976,7 @@
 
   if(i > 0)
     {

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 11:51:11 +0100

> is doing with attachments.

Put it in. It makes no sense to introduce new bugs/'features' that
get changed immediately after 2.2. This will only create confusion.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 26 Jan 1999 08:07:59 -0500

> +++ misc-fixed.c	Mon Jan 25 22:25:40 1999

I'm all for the fix just please remove the comment marks from the XRaiseWindow Line, if you leave it as is the eye tells me it is commented when it fact it isn't.

Brad

---

From: Dan Espen <[email-masked]>
Date: Tue, 26 Jan 1999 09:27:53 -0500

I haven't had a chance to test any of the changes posted, but there is
an easy way to see an icon problem:

Create 2 XEmacs frames, iconify one, full screen the other.

The XEmacs icon will refuse to move under the full screen window.

---

From: Bob Woodside <[email-masked]>
Date: Tue, 26 Jan 1999 18:35:33 -0500 (EST)

Brad Giaccio <[email-masked]> wrote:
> 
> I'm all for the fix just please remove the comment marks from the
> XRaiseWindow Line, if you leave it as is the eye tells me it is
> commented when it fact it isn't.

	Actually, it really *is* supposed to be commented out. I got in
a hurry trying to make the diff before I was really quite through. And
yes, it really does work correctly without the XRaiseWindow, which is
what we were trying to eliminate in the first place!

- Bob