Subject: Status update

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Jan 1999 14:23:28 +0100

Things left to do before 2.2:
-----------------------------

Items marked with a '*' may be skipped if the reporters don't
cooperate.

1) the key/mouse binding problems (not all in Jitterbug)
*  [investigate bug reports]

9) FvwmCpp does not know where cpp is (bug #95)
   can you say something about this, Paul (PDS)?
   [in progress]

10) crash with xclock (bug #56)
    [investigation in progress]

12) this 'serious bug' RedHat found (I'd like to see the patch).
*   [investigation stalled]

13) the FvwmCommandS problem discussed recently
    [investigation in progress, probably not an fvwm bug]

15) gradient menus lose their colours under obscure
*   circumstances.
    [pending]

Fixed but not verified:
-----------------------

2) the XPM problems (probably in 'configure', bugs #31,
   #40 and perhaps others)
   [in progress]

5) verify the 'growing windows' bugfix
   [pending]

6) verify the num-lock/key binding bugfix (bug #54)
*  [pending]

Summary of open problems:
-------------------------

5 investigate (3 not mandatory for 2.2)
1 in progress 
3 verify fix  

There are three problems left where we don't have an idea
how to fix (or even reproduce) them (1, 10, 12).

Stuff done since last update:
-----------------------------

3) verify the XGetImage problem I encountered

4) apply latest signal handling patches

7) document install-strip problem (bug #33)

8) closing a panel closes FvwmButtons

11) hanging up asmodem kills FvwmButtons (perhaps related to 8)

14) Integrate this StaysOnTop related patch by Matthias Clasen
    [in progress (Bob W.)]

This looks pretty well, real work has to be done on
1, 5, 6, 10, 12 and 15.

Please, everybody should focus on these six problems left so
we can make 2.2 real soon.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 06 Jan 1999 09:47:15 -0500

> Things left to do before 2.2:

I think its clear that this problem no longer exists.
When it got down to the point that the way to produce
the symptom was to try to run 2 copies of FvwmCommandS,
the person reporting the problem said they re-installed
and no longer had the problem.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].