Subject: [[email-masked]: Re: [[email-masked]: Re: Notification: incoming/123]]

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Jan 1999 22:49:55 +0100

----- Forwarded message from "Joseph F. Prosser" <[email-masked]> -----

From: "Joseph F. Prosser" <[email-masked]>
To: "Dominik Vogt" <[email-masked]>
Subject: Re: [[email-masked]: Re: Notification: incoming/123]
Date: Wed, 20 Jan 1999 11:21:46 -0500
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 4.72.3155.0
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3155.0

Hi Mr. Vogt,
I tried your suggestions to no avail.  I recompiled on a Solaris 2.4 system
using a gcc 2.7.0 compiler.
I still have the problem with WinList disappearing just a few seconds after
start up on Solaris 2.4 and
2.6 machines.

I still cannot locate a core dump.  I issued a find command in my fvwm
library, looking for 'core' and I
searched the directory tree manually looking for any strange files.

I performed a clean reconfigure as follows:

make clean
make distclean
configure --prefix=<my_path>
make
make install

One thing I tried that works fine is that I copied the FvwmWinList
executable from fvwm 2.0.046 to
the fvwm 2.1.7 library.  WinList stayed up for my entire session of about 4
hours.

I will be happy to try any other suggestions you have in order to assist you
in pinpointing the problem.

Regards,
Joe Prosser

-----Original Message-----
From: Dominik Vogt <[email-masked]>
To: Joe_Prosser/[email-masked] <Joe_Prosser/[email-masked]>
Date: Friday, January 15, 1999 7:28 PM
Subject: [[email-masked]: Re: Notification: incoming/123]

>
>
>----- Forwarded message from Dominik Vogt <[email-masked]>
>-----
>
>Date: Thu, 14 Jan 1999 02:01:59 +0100
>From: Dominik Vogt <[email-masked]>
>To: [email-masked]
>Subject: Re: Notification: incoming/123
>Reply-To: [email-masked]
>Mail-Followup-To: [email-masked]
>X-Mailer: Mutt 0.93.1i
>In-Reply-To: <[email-masked]>; from fvwm-bug on
>Tue, Jan 12, 1999 at 05:35:16PM -0600
>Precedence: list
>X-Majordomo: 1.94.jlt7
>
>On Tue, Jan 12, 1999 at 05:35:16PM -0600, fvwm-bug wrote:
>> FVWM Bug Tracking notification
>>
>> new message incoming/123
>>
>> Message summary for PR#123
>>       From: [email-masked]
>>       Subject: FvwmWinList disappears
>>       Date: Tue, 12 Jan 1999 17:35:14 -0600 (CST)
>>       0 replies       0 followups
>>
>> ====> ORIGINAL MESSAGE FOLLOWS <====
>
>Try to answer these questions:
>
>1) Does FvwmWinList coredump?
>   If it does, fetch us a stack trace (e.g. with gdb):
>   # gdb FvwmWinList core
>   (gdb) where
>
>2) Can you try that on a 'real' X server?
>
>3) If you rebuild the 2.1.7 package in a fresh directory,
>   does it work then?
>
>Bye
>
>Dominik
>
>--
>Dominik Vogt, [email-masked]
>Reply-To: [email-masked]
>
>--
>Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
>To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
>body of a message to [email-masked].
>To report problems, send mail to [email-masked].
>
>----- End forwarded message -----
>
>
>Bye
>
>Dominik
>
>--
>Dominik Vogt, [email-masked]
>Reply-To: [email-masked]
>

----- End forwarded message -----

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 13:19:51 +0000

I just had a play with FvwmWinList and versions from 2.1.9 onward seem to be
broken.  Symptoms are:
Doesn't follow focus (use mousefocus and go onto the root); Hangs the server when
windows are added or removed; crashes.

I got a core but infortunatley gdb core dumped on me when I tried to get a stack
trace!

The only changes appear to be the signal handler patches and a different select
call.
This is on SunOS 5.6.

Cheers,
Tim.

---

From: Chris Rankin <[email-masked]>
Date: Fri, 22 Jan 1999 08:40:42 -0500 (EST)

> The only changes appear to be the signal handler patches and a different select

Can you post the config.log? SunOS 5.6 is "Solaris 2.??", so it must
support sigaction(). Does FvwmIconMan work under SunOS 5.6? What about
FvwmPager? The only difference I can think of between SunOS and Linux
is the sigact.sa_flags argument - I think that SunOS defines
SA_INTERRUPT. Is SA_INTERRUPT defined?

Cheers,
Chris.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 14:23:15 +0000

Just narowed it down a bit more. The problem following focus is fixed by putting the
previous version of MainEventLoop back in.  I think it something arund the new select
code that is causing events from fvwm to get missed.

Old code:

  while( !isTerminated ) {
    FD_ZERO(&readset);
    FD_SET(Fvwm_fd[1],&readset);
    FD_SET(x_fd,&readset);
    tv.tv_sec=0;
    tv.tv_usec=0;

    if (!select(fd_width,SELECT_TYPE_ARG234 &readset,NULL,NULL,&tv)) {
      XPending(dpy);
      FD_ZERO(&readset);
      FD_SET(Fvwm_fd[1],&readset);
      FD_SET(x_fd,&readset);
      select(fd_width,SELECT_TYPE_ARG234 &readset,NULL,NULL,NULL);
    }

    if (FD_ISSET(x_fd,&readset)) LoopOnEvents();
    if (!FD_ISSET(Fvwm_fd[1],&readset)) continue;
    ReadFvwmPipe();

    }

New code:

while( !isTerminated ) {
    FD_ZERO(&readset);
    FD_SET(Fvwm_fd[1],&readset);
    FD_SET(x_fd,&readset);

    /* This code restyled after FvwmIconMan, which is simpler.
     * The biggest advantage over the original approach is
     * having one fewer select statements
     */
    if (select(fd_width,SELECT_TYPE_ARG234 &readset,NULL,NULL,NULL) > 0) {

      if (FD_ISSET(x_fd,&readset) || XPending(dpy)) LoopOnEvents();
      if (FD_ISSET(Fvwm_fd[1],&readset)) ReadFvwmPipe();

    }

  } /* while */

Hope this helps,
Tim.

---

From: [email-masked] (Paul D. Smith)
Date: 22 Jan 1999 09:24:01 -0500

%% Tim Phipps <[email-masked]> writes:

  tp> I just had a play with FvwmWinList and versions from 2.1.9 onward
  tp> seem to be broken.  Symptoms are: Doesn't follow focus (use
  tp> mousefocus and go onto the root); Hangs the server when windows
  tp> are added or removed; crashes.

Hangs the server?  Ouch.

Do you have a reproducable problem you can provide a small, detailed
test case for (the follow focus thing, for example)?

  tp> I got a core but infortunatley gdb core dumped on me when I tried
  tp> to get a stack trace!

Hmm.  System config error?  Do you have the latest gdb?  Did you compile
with GCC?

  tp> The only changes appear to be the signal handler patches and a
  tp> different select call.  This is on SunOS 5.6.

Can you try attaching to the running FvwmWinList process, then using it
until it dies?

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 22 Jan 1999 09:32:07 -0500

tp> Just narowed it down a bit more. The problem following focus is
  tp> fixed by putting the previous version of MainEventLoop back in.  I
  tp> think it something arund the new select code that is causing
  tp> events from fvwm to get missed.

Does replacing that code solve the server hangs (I could see it; maybe
the server thinks FvwmWinList has a grab but FvwmWinList lost an event?)
and/or the core dumps?

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 14:50:38 +0000

>   tp> are added or removed; crashes.

My mistake. It was fvwm that was hanging. An XFlush() just before the select
nicely fixes my problems.

It seems that select() is only setting one bit in &readset.  I put a load of
printf's in and only one of ReadFvwmPipe() and LopOnEvents() is called per select.
Without  the XFlush() the event loop doesn't keep up and eventually fvwm stalls
waiting for it's pipe to FvwmWinList to get emptied.

Cheers,
Tim.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 15:11:35 +0000

Another update:

The addition of the XFlush fixes the fvwm hanging problem.
I'm getting a crash in ReadFvwmPipe when I pop up a transient.

Cheers,
Tim.

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 14:00:46 +0000

> SA_INTERRUPT. Is SA_INTERRUPT defined?

I've attached config.log and config.cache.  It does have sigaction but SA_INTERRUPT is
not defined. I have both IconMan and Pager working.

Cheers,
Tim.

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:610: checking for a BSD compatible install
configure:663: checking whether build environment is sane
configure:720: checking whether make sets ${MAKE}
configure:766: checking for working aclocal
configure:779: checking for working autoconf
configure:792: checking for working automake
configure:805: checking for working autoheader
configure:818: checking for working makeinfo
configure:853: checking whether to enable modal dialogs for applications
configure:874: checking whether to enable saveunders for pop-up menus
configure:895: checking whether to enable shape extensions
configure:919: checking whether to enable ActiveDown button state
configure:943: checking whether to enable Inactive button state
configure:967: checking whether to enable MiniIcon style option
configure:991: checking whether to enable vector button style
configure:1015: checking whether to enable pixmap button style
configure:1039: checking whether to enable gradient button style
configure:1063: checking whether to enable stacked button styles
configure:1087: checking whether to enable styled title-bars
configure:1111: checking whether to enable BorderStyle command
configure:1135: checking whether to enable UseDecor style option
configure:1159: checking whether to enable WindowShade function
configure:1183: checking whether to enable debugging messages
configure:1204: checking iconpath
configure:1231: checking for gcc
configure:1344: checking whether the C compiler (gcc  ) works
configure:1360: gcc -o conftest    conftest.c  1>&5
configure:1386: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1391: checking whether we are using GNU C
configure:1400: gcc -E conftest.c
configure:1419: checking whether gcc accepts -g
configure:1451: checking how to run the C preprocessor
configure:1472: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1532: checking for POSIXized ISC
configure:1554: checking for minix/config.h
configure:1564: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1560: minix/config.h: No such file or directory
configure: failed program was:
#line 1559 "configure"
#include "confdefs.h"
#include <minix/config.h>
configure:1607: checking for stdarg.h
configure:1617: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1646: checking for vfprintf
configure:1674: gcc -o conftest -g -O2   conftest.c  1>&5
configure:1706: checking for waitpid
configure:1734: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2057: checking for X
configure:2306: checking whether -R must be followed by a space
configure:2316: gcc -o conftest -g -O2   conftest.c  -R/usr/openwin/lib 1>&5
configure:2371: checking for dnet_ntoa in -ldnet
configure:2390: gcc -o conftest -g -O2   conftest.c -ldnet   1>&5
ld: fatal: library -ldnet: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
#line 2379 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2412: checking for dnet_ntoa in -ldnet_stub
configure:2431: gcc -o conftest -g -O2   conftest.c -ldnet_stub   1>&5
ld: fatal: library -ldnet_stub: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
#line 2420 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2460: checking for gethostbyname
configure:2488: gcc -o conftest -g -O2   conftest.c  1>&5
Undefined			first referenced
 symbol  			    in file
gethostbyname                       /tmp/ccY74vP_1.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 2465 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char gethostbyname(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gethostbyname();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_gethostbyname) || defined (__stub___gethostbyname)
choke me
#else
gethostbyname();
#endif

; return 0; }
configure:2509: checking for gethostbyname in -lnsl
configure:2528: gcc -o conftest -g -O2   conftest.c -lnsl   1>&5
configure:2558: checking for connect
configure:2586: gcc -o conftest -g -O2   conftest.c  1>&5
Undefined			first referenced
 symbol  			    in file
connect                             /tmp/cc0XYcOR1.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 2563 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char connect(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char connect();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_connect) || defined (__stub___connect)
choke me
#else
connect();
#endif

; return 0; }
configure:2607: checking for connect in -lsocket
configure:2626: gcc -o conftest -g -O2   conftest.c -lsocket  -lnsl  1>&5
configure:2650: checking for remove
configure:2678: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2742: checking for shmat
configure:2770: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2843: checking for IceConnectionNumber in -lICE
configure:2862: gcc -o conftest -g -O2   -L/usr/openwin/lib conftest.c -lICE -lsocket  -lnsl  1>&5
configure:2890: checking for cpp
configure:2940: checking for a BSD compatible install
configure:2993: checking whether ln -s works
configure:3014: checking whether make sets ${MAKE}
configure:3043: checking for ranlib
configure:3076: checking for flex
configure:3109: checking for flex
configure:3143: checking for yywrap in -lfl
configure:3162: gcc -o conftest -g -O2   conftest.c -lfl   1>&5
ld: fatal: library -lfl: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
#line 3151 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char yywrap();

int main() {
yywrap()
; return 0; }
configure:3185: checking lex output file root
configure:3206: checking whether yytext is a pointer
configure:3225: gcc -o conftest -g -O2   conftest.c   1>&5
Undefined			first referenced
 symbol  			    in file
yywrap                              /tmp/cc811HN_1.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 3218 "configure"
#include "confdefs.h"
/* A lexical scanner generated by flex */

/* Scanner skeleton version:
 * $Header: /home/daffy/u0/vern/flex/RCS/flex.skl,v 2.85 95/04/24 10:48:47 vern Exp $
 */

#define FLEX_SCANNER
#define YY_FLEX_MAJOR_VERSION 2
#define YY_FLEX_MINOR_VERSION 5

#include <stdio.h>

/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
#ifdef c_plusplus
#ifndef __cplusplus
#define __cplusplus
#endif
#endif

#ifdef __cplusplus

#include <stdlib.h>
#include <unistd.h>

/* Use prototypes in function declarations. */
#define YY_USE_PROTOS

/* The "const" storage-class-modifier is valid. */
#define YY_USE_CONST

#else	/* ! __cplusplus */

#if __STDC__

#define YY_USE_PROTOS
#define YY_USE_CONST

#endif	/* __STDC__ */
#endif	/* ! __cplusplus */

#ifdef __TURBOC__
 #pragma warn -rch
 #pragma warn -use
#include <io.h>
#include <stdlib.h>
#define YY_USE_CONST
#define YY_USE_PROTOS
#endif

#ifdef YY_USE_CONST
#define yyconst const
#else
#define yyconst
#endif

#ifdef YY_USE_PROTOS
#define YY_PROTO(proto) proto
#else
#define YY_PROTO(proto) ()
#endif

/* Returned upon end-of-file. */
#define YY_NULL 0

/* Promotes a possibly negative, possibly signed char to an unsigned
 * integer for use as an array index.  If the signed char is negative,
 * we want to instead treat it as an 8-bit unsigned char, hence the
 * double cast.
 */
#define YY_SC_TO_UI(c) ((unsigned int) (unsigned char) c)

/* Enter a start condition.  This macro really ought to take a parameter,
 * but we do it the disgusting crufty way forced on us by the ()-less
 * definition of BEGIN.
 */
#define BEGIN yy_start = 1 + 2 *

/* Translate the current start state into a value that can be later handed
 * to BEGIN to return to the state.  The YYSTATE alias is for lex
 * compatibility.
 */
#define YY_START ((yy_start - 1) / 2)
#define YYSTATE YY_START

/* Action number for EOF rule of a given start state. */
#define YY_STATE_EOF(state) (YY_END_OF_BUFFER + state + 1)

/* Special action meaning "start processing a new file". */
#define YY_NEW_FILE yyrestart( yyin )

#define YY_END_OF_BUFFER_CHAR 0

/* Size of default input buffer. */
#define YY_BUF_SIZE 16384

typedef struct yy_buffer_state *YY_BUFFER_STATE;

extern int yyleng;
extern FILE *yyin, *yyout;

#define EOB_ACT_CONTINUE_SCAN 0
#define EOB_ACT_END_OF_FILE 1
#define EOB_ACT_LAST_MATCH 2

/* The funky do-while in the following #define is used to turn the definition
 * int a single C statement (which needs a semi-colon terminator).  This
 * avoids problems with code like:
 *
 * 	if ( condition_holds )
 *		yyless( 5 );
 *	else
 *		do_something_else();
 *
 * Prior to using the do-while the compiler would get upset at the
 * "else" because it interpreted the "if" statement as being all
 * done when it reached the ';' after the yyless() call.
 */

/* Return all but the first 'n' matched characters back to the input stream. */

#define yyless(n) \
	do \
		{ \
		/* Undo effects of setting up yytext. */ \
		*yy_cp = yy_hold_char; \
		yy_c_buf_p = yy_cp = yy_bp + n - YY_MORE_ADJ; \
		YY_DO_BEFORE_ACTION; /* set up yytext again */ \
		} \
	while ( 0 )

#define unput(c) yyunput( c, yytext_ptr )

/* The following is because we cannot portably get our hands on size_t
 * (without autoconf's help, which isn't available because we want
 * flex-generated scanners to compile on their own).
 */
typedef unsigned int yy_size_t;

struct yy_buffer_state
	{
	FILE *yy_input_file;

	char *yy_ch_buf;		/* input buffer */
	char *yy_buf_pos;		/* current position in input buffer */

	/* Size of input buffer in bytes, not including room for EOB
	 * characters.
	 */
	yy_size_t yy_buf_size;

	/* Number of characters read into yy_ch_buf, not including EOB
	 * characters.
	 */
	int yy_n_chars;

	/* Whether we "own" the buffer - i.e., we know we created it,
	 * and can realloc() it to grow it, and should free() it to
	 * delete it.
	 */
	int yy_is_our_buffer;

	/* Whether this is an "interactive" input source; if so, and
	 * if we're using stdio for input, then we want to use getc()
	 * instead of fread(), to make sure we stop fetching input after
	 * each newline.
	 */
	int yy_is_interactive;

	/* Whether we're considered to be at the beginning of a line.
	 * If so, '^' rules will be active on the next match, otherwise
	 * not.
	 */
	int yy_at_bol;

	/* Whether to try to fill the input buffer when we reach the
	 * end of it.
	 */
	int yy_fill_buffer;

	int yy_buffer_status;
#define YY_BUFFER_NEW 0
#define YY_BUFFER_NORMAL 1
	/* When an EOF's been seen but there's still some text to process
	 * then we mark the buffer as YY_EOF_PENDING, to indicate that we
	 * shouldn't try reading from the input source any more.  We might
	 * still have a bunch of tokens to match, though, because of
	 * possible backing-up.
	 *
	 * When we actually see the EOF, we change the status to "new"
	 * (via yyrestart()), so that the user can continue scanning by
	 * just pointing yyin at a new input file.
	 */
#define YY_BUFFER_EOF_PENDING 2
	};

static YY_BUFFER_STATE yy_current_buffer = 0;

/* We provide macros for accessing buffer states in case in the
 * future we want to put the buffer states in a more general
 * "scanner state".
 */
#define YY_CURRENT_BUFFER yy_current_buffer

/* yy_hold_char holds the character lost when yytext is formed. */
static char yy_hold_char;

static int yy_n_chars;		/* number of characters read into yy_ch_buf */

int yyleng;

/* Points to current character in buffer. */
static char *yy_c_buf_p = (char *) 0;
static int yy_init = 1;		/* whether we need to initialize */
static int yy_start = 0;	/* start state number */

/* Flag which is used to allow yywrap()'s to do buffer switches
 * instead of setting up a fresh yyin.  A bit of a hack ...
 */
static int yy_did_buffer_switch_on_eof;

void yyrestart YY_PROTO(( FILE *input_file ));

void yy_switch_to_buffer YY_PROTO(( YY_BUFFER_STATE new_buffer ));
void yy_load_buffer_state YY_PROTO(( void ));
YY_BUFFER_STATE yy_create_buffer YY_PROTO(( FILE *file, int size ));
void yy_delete_buffer YY_PROTO(( YY_BUFFER_STATE b ));
void yy_init_buffer YY_PROTO(( YY_BUFFER_STATE b, FILE *file ));
void yy_flush_buffer YY_PROTO(( YY_BUFFER_STATE b ));
#define YY_FLUSH_BUFFER yy_flush_buffer( yy_current_buffer )

YY_BUFFER_STATE yy_scan_buffer YY_PROTO(( char *base, yy_size_t size ));
YY_BUFFER_STATE yy_scan_string YY_PROTO(( yyconst char *str ));
YY_BUFFER_STATE yy_scan_bytes YY_PROTO(( yyconst char *bytes, int len ));

static void *yy_flex_alloc YY_PROTO(( yy_size_t ));
static void *yy_flex_realloc YY_PROTO(( void *, yy_size_t ));
static void yy_flex_free YY_PROTO(( void * ));

#define yy_new_buffer yy_create_buffer

#define yy_set_interactive(is_interactive) \
	{ \
	if ( ! yy_current_buffer ) \
		yy_current_buffer = yy_create_buffer( yyin, YY_BUF_SIZE ); \
	yy_current_buffer->yy_is_interactive = is_interactive; \
	}

#define yy_set_bol(at_bol) \
	{ \
	if ( ! yy_current_buffer ) \
		yy_current_buffer = yy_create_buffer( yyin, YY_BUF_SIZE ); \
	yy_current_buffer->yy_at_bol = at_bol; \
	}

#define YY_AT_BOL() (yy_current_buffer->yy_at_bol)

typedef unsigned char YY_CHAR;
FILE *yyin = (FILE *) 0, *yyout = (FILE *) 0;
typedef int yy_state_type;
extern char *yytext;
#define yytext_ptr yytext

static yy_state_type yy_get_previous_state YY_PROTO(( void ));
static yy_state_type yy_try_NUL_trans YY_PROTO(( yy_state_type current_state ));
static int yy_get_next_buffer YY_PROTO(( void ));
static void yy_fatal_error YY_PROTO(( yyconst char msg[] ));

/* Done after the current pattern has been matched and before the
 * corresponding action - sets up yytext.
 */
#define YY_DO_BEFORE_ACTION \
	yytext_ptr = yy_bp; \
	yyleng = (int) (yy_cp - yy_bp); \
	yy_hold_char = *yy_cp; \
	*yy_cp = '\0'; \
	yy_c_buf_p = yy_cp;

#define YY_NUM_RULES 1
#define YY_END_OF_BUFFER 2
static yyconst short int yy_accept[6] =
    {   0,
        0,    0,    2,    1,    0
    } ;

static yyconst int yy_ec[256] =
    {   0,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,

        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,

        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1,    1,    1,    1,    1,    1,
        1,    1,    1,    1,    1
    } ;

static yyconst int yy_meta[2] =
    {   0,
        1
    } ;

static yyconst short int yy_base[7] =
    {   0,
        0,    0,    2,    3,    3,    0
    } ;

static yyconst short int yy_def[7] =
    {   0,
        6,    6,    5,    5,    0,    5
    } ;

static yyconst short int yy_nxt[5] =
    {   0,
        4,    5,    3,    5
    } ;

static yyconst short int yy_chk[5] =
    {   0,
        6,    3,    5,    5
    } ;

static yy_state_type yy_last_accepting_state;
static char *yy_last_accepting_cpos;

/* The intent behind this definition is that it'll catch
 * any uses of REJECT which flex missed.
 */
#define REJECT reject_used_but_not_detected
#define yymore() yymore_used_but_not_detected
#define YY_MORE_ADJ 0
char *yytext;
#line 1 "<stdin>"
#define INITIAL 0
#line 361 "lex.yy.c"

/* Macros after this point can all be overridden by user definitions in
 * section 1.
 */

#ifndef YY_SKIP_YYWRAP
#ifdef __cplusplus
extern "C" int yywrap YY_PROTO(( void ));
#else
extern int yywrap YY_PROTO(( void ));
#endif
#endif

#ifndef YY_NO_UNPUT
static void yyunput YY_PROTO(( int c, char *buf_ptr ));
#endif

#ifndef yytext_ptr
static void yy_flex_strncpy YY_PROTO(( char *, yyconst char *, int ));
#endif

#ifndef YY_NO_INPUT
#ifdef __cplusplus
static int yyinput YY_PROTO(( void ));
#else
static int input YY_PROTO(( void ));
#endif
#endif

#if YY_STACK_USED
static int yy_start_stack_ptr = 0;
static int yy_start_stack_depth = 0;
static int *yy_start_stack = 0;
#ifndef YY_NO_PUSH_STATE
static void yy_push_state YY_PROTO(( int new_state ));
#endif
#ifndef YY_NO_POP_STATE
static void yy_pop_state YY_PROTO(( void ));
#endif
#ifndef YY_NO_TOP_STATE
static int yy_top_state YY_PROTO(( void ));
#endif

#else
#define YY_NO_PUSH_STATE 1
#define YY_NO_POP_STATE 1
#define YY_NO_TOP_STATE 1
#endif

#ifdef YY_MALLOC_DECL
YY_MALLOC_DECL
#else
#if __STDC__
#ifndef __cplusplus
#include <stdlib.h>
#endif
#else
/* Just try to get by without declaring the routines.  This will fail
 * miserably on non-ANSI systems for which sizeof(size_t) != sizeof(int)
 * or sizeof(void*) != sizeof(int).
 */
#endif
#endif

/* Amount of stuff to slurp up with each read. */
#ifndef YY_READ_BUF_SIZE
#define YY_READ_BUF_SIZE 8192
#endif

/* Copy whatever the last rule matched to the standard output. */

#ifndef ECHO
/* This used to be an fputs(), but since the string might contain NUL's,
 * we now use fwrite().
 */
#define ECHO (void) fwrite( yytext, yyleng, 1, yyout )
#endif

/* Gets input and stuffs it into "buf".  number of characters read, or YY_NULL,
 * is returned in "result".
 */
#ifndef YY_INPUT
#define YY_INPUT(buf,result,max_size) \
	if ( yy_current_buffer->yy_is_interactive ) \
		{ \
		int c = '*', n; \
		for ( n = 0; n < max_size && \
			     (c = getc( yyin )) != EOF && c != '\n'; ++n ) \
			buf[n] = (char) c; \
		if ( c == '\n' ) \
			buf[n++] = (char) c; \
		if ( c == EOF && ferror( yyin ) ) \
			YY_FATAL_ERROR( "input in flex scanner failed" ); \
		result = n; \
		} \
	else if ( ((result = fread( buf, 1, max_size, yyin )) == 0) \
		  && ferror( yyin ) ) \
		YY_FATAL_ERROR( "input in flex scanner failed" );
#endif

/* No semi-colon after return; correct usage is to write "yyterminate();" -
 * we don't want an extra ';' after the "return" because that will cause
 * some compilers to complain about unreachable statements.
 */
#ifndef yyterminate
#define yyterminate() return YY_NULL
#endif

/* Number of entries by which start-condition stack grows. */
#ifndef YY_START_STACK_INCR
#define YY_START_STACK_INCR 25
#endif

/* Report a fatal error. */
#ifndef YY_FATAL_ERROR
#define YY_FATAL_ERROR(msg) yy_fatal_error( msg )
#endif

/* Default declaration of generated scanner - a define so the user can
 * easily add parameters.
 */
#ifndef YY_DECL
#define YY_DECL int yylex YY_PROTO(( void ))
#endif

/* Code executed at the beginning of each rule, after yytext and yyleng
 * have been set up.
 */
#ifndef YY_USER_ACTION
#define YY_USER_ACTION
#endif

/* Code executed at the end of each rule. */
#ifndef YY_BREAK
#define YY_BREAK break;
#endif

#define YY_RULE_SETUP \
	YY_USER_ACTION

YY_DECL
	{
	register yy_state_type yy_current_state;
	register char *yy_cp, *yy_bp;
	register int yy_act;

#line 1 "<stdin>"

#line 510 "lex.yy.c"

	if ( yy_init )
		{
		yy_init = 0;

#ifdef YY_USER_INIT
		YY_USER_INIT;
#endif

		if ( ! yy_start )
			yy_start = 1;	/* first start state */

		if ( ! yyin )
			yyin = stdin;

		if ( ! yyout )
			yyout = stdout;

		if ( ! yy_current_buffer )
			yy_current_buffer =
				yy_create_buffer( yyin, YY_BUF_SIZE );

		yy_load_buffer_state();
		}

	while ( 1 )		/* loops until end-of-file is reached */
		{
		yy_cp = yy_c_buf_p;

		/* Support of yytext. */
		*yy_cp = yy_hold_char;

		/* yy_bp points to the position in yy_ch_buf of the start of
		 * the current run.
		 */
		yy_bp = yy_cp;

		yy_current_state = yy_start;
yy_match:
		do
			{
			register YY_CHAR yy_c = yy_ec[YY_SC_TO_UI(*yy_cp)];
			if ( yy_accept[yy_current_state] )
				{
				yy_last_accepting_state = yy_current_state;
				yy_last_accepting_cpos = yy_cp;
				}
			while ( yy_chk[yy_base[yy_current_state] + yy_c] != yy_current_state )
				{
				yy_current_state = (int) yy_def[yy_current_state];
				if ( yy_current_state >= 6 )
					yy_c = yy_meta[(unsigned int) yy_c];
				}
			yy_current_state = yy_nxt[yy_base[yy_current_state] + (unsigned int) yy_c];
			++yy_cp;
			}
		while ( yy_base[yy_current_state] != 3 );

yy_find_action:
		yy_act = yy_accept[yy_current_state];
		if ( yy_act == 0 )
			{ /* have to back up */
			yy_cp = yy_last_accepting_cpos;
			yy_current_state = yy_last_accepting_state;
			yy_act = yy_accept[yy_current_state];
			}

		YY_DO_BEFORE_ACTION;

do_action:	/* This label is used only to access EOF actions. */

		switch ( yy_act )
	{ /* beginning of action switch */
			case 0: /* must back up */
			/* undo the effects of YY_DO_BEFORE_ACTION */
			*yy_cp = yy_hold_char;
			yy_cp = yy_last_accepting_cpos;
			yy_current_state = yy_last_accepting_state;
			goto yy_find_action;

case 1:
YY_RULE_SETUP
#line 2 "<stdin>"
ECHO;
	YY_BREAK
#line 598 "lex.yy.c"
case YY_STATE_EOF(INITIAL):
	yyterminate();

	case YY_END_OF_BUFFER:
		{
		/* Amount of text matched not including the EOB char. */
		int yy_amount_of_matched_text = (int) (yy_cp - yytext_ptr) - 1;

		/* Undo the effects of YY_DO_BEFORE_ACTION. */
		*yy_cp = yy_hold_char;

		if ( yy_current_buffer->yy_buffer_status == YY_BUFFER_NEW )
			{
			/* We're scanning a new file or input source.  It's
			 * possible that this happened because the user
			 * just pointed yyin at a new source and called
			 * yylex().  If so, then we have to assure
			 * consistency between yy_current_buffer and our
			 * globals.  Here is the right place to do so, because
			 * this is the first action (other than possibly a
			 * back-up) that will match for the new input source.
			 */
			yy_n_chars = yy_current_buffer->yy_n_chars;
			yy_current_buffer->yy_input_file = yyin;
			yy_current_buffer->yy_buffer_status = YY_BUFFER_NORMAL;
			}

		/* Note that here we test for yy_c_buf_p "<=" to the position
		 * of the first EOB in the buffer, since yy_c_buf_p will
		 * already have been incremented past the NUL character
		 * (since all states make transitions on EOB to the
		 * end-of-buffer state).  Contrast this with the test
		 * in input().
		 */
		if ( yy_c_buf_p <= &yy_current_buffer->yy_ch_buf[yy_n_chars] )
			{ /* This was really a NUL. */
			yy_state_type yy_next_state;

			yy_c_buf_p = yytext_ptr + yy_amount_of_matched_text;

			yy_current_state = yy_get_previous_state();

			/* Okay, we're now positioned to make the NUL
			 * transition.  We couldn't have
			 * yy_get_previous_state() go ahead and do it
			 * for us because it doesn't know how to deal
			 * with the possibility of jamming (and we don't
			 * want to build jamming into it because then it
			 * will run more slowly).
			 */

			yy_next_state = yy_try_NUL_trans( yy_current_state );

			yy_bp = yytext_ptr + YY_MORE_ADJ;

			if ( yy_next_state )
				{
				/* Consume the NUL. */
				yy_cp = ++yy_c_buf_p;
				yy_current_state = yy_next_state;
				goto yy_match;
				}

			else
				{
				yy_cp = yy_c_buf_p;
				goto yy_find_action;
				}
			}

		else switch ( yy_get_next_buffer() )
			{
			case EOB_ACT_END_OF_FILE:
				{
				yy_did_buffer_switch_on_eof = 0;

				if ( yywrap() )
					{
					/* Note: because we've taken care in
					 * yy_get_next_buffer() to have set up
					 * yytext, we can now set up
					 * yy_c_buf_p so that if some total
					 * hoser (like flex itself) wants to
					 * call the scanner after we return the
					 * YY_NULL, it'll still work - another
					 * YY_NULL will get returned.
					 */
					yy_c_buf_p = yytext_ptr + YY_MORE_ADJ;

					yy_act = YY_STATE_EOF(YY_START);
					goto do_action;
					}

				else
					{
					if ( ! yy_did_buffer_switch_on_eof )
						YY_NEW_FILE;
					}
				break;
				}

			case EOB_ACT_CONTINUE_SCAN:
				yy_c_buf_p =
					yytext_ptr + yy_amount_of_matched_text;

				yy_current_state = yy_get_previous_state();

				yy_cp = yy_c_buf_p;
				yy_bp = yytext_ptr + YY_MORE_ADJ;
				goto yy_match;

			case EOB_ACT_LAST_MATCH:
				yy_c_buf_p =
				&yy_current_buffer->yy_ch_buf[yy_n_chars];

				yy_current_state = yy_get_previous_state();

				yy_cp = yy_c_buf_p;
				yy_bp = yytext_ptr + YY_MORE_ADJ;
				goto yy_find_action;
			}
		break;
		}

	default:
		YY_FATAL_ERROR(
			"fatal flex scanner internal error--no action found" );
	} /* end of action switch */
		} /* end of scanning one token */
	} /* end of yylex */

/* yy_get_next_buffer - try to read in a new buffer
 *
 * Returns a code representing an action:
 *	EOB_ACT_LAST_MATCH -
 *	EOB_ACT_CONTINUE_SCAN - continue scanning from current position
 *	EOB_ACT_END_OF_FILE - end of file
 */

static int yy_get_next_buffer()
	{
	register char *dest = yy_current_buffer->yy_ch_buf;
	register char *source = yytext_ptr;
	register int number_to_move, i;
	int ret_val;

	if ( yy_c_buf_p > &yy_current_buffer->yy_ch_buf[yy_n_chars + 1] )
		YY_FATAL_ERROR(
		"fatal flex scanner internal error--end of buffer missed" );

	if ( yy_current_buffer->yy_fill_buffer == 0 )
		{ /* Don't try to fill the buffer, so this is an EOF. */
		if ( yy_c_buf_p - yytext_ptr - YY_MORE_ADJ == 1 )
			{
			/* We matched a singled characater, the EOB, so
			 * treat this as a final EOF.
			 */
			return EOB_ACT_END_OF_FILE;
			}

		else
			{
			/* We matched some text prior to the EOB, first
			 * process it.
			 */
			return EOB_ACT_LAST_MATCH;
			}
		}

	/* Try to read more data. */

	/* First move last chars to start of buffer. */
	number_to_move = (int) (yy_c_buf_p - yytext_ptr) - 1;

	for ( i = 0; i < number_to_move; ++i )
		*(dest++) = *(source++);

	if ( yy_current_buffer->yy_buffer_status == YY_BUFFER_EOF_PENDING )
		/* don't do the read, it's not guaranteed to return an EOF,
		 * just force an EOF
		 */
		yy_n_chars = 0;

	else
		{
		int num_to_read =
			yy_current_buffer->yy_buf_size - number_to_move - 1;

		while ( num_to_read <= 0 )
			{ /* Not enough room in the buffer - grow it. */
#ifdef YY_USES_REJECT
			YY_FATAL_ERROR(
"input buffer overflow, can't enlarge buffer because scanner uses REJECT" );
#else

			/* just a shorter name for the current buffer */
			YY_BUFFER_STATE b = yy_current_buffer;

			int yy_c_buf_p_offset =
				(int) (yy_c_buf_p - b->yy_ch_buf);

			if ( b->yy_is_our_buffer )
				{
				int new_size = b->yy_buf_size * 2;

				if ( new_size <= 0 )
					b->yy_buf_size += b->yy_buf_size / 8;
				else
					b->yy_buf_size *= 2;

				b->yy_ch_buf = (char *)
					/* Include room in for 2 EOB chars. */
					yy_flex_realloc( (void *) b->yy_ch_buf,
							 b->yy_buf_size + 2 );
				}
			else
				/* Can't grow it, we don't own it. */
				b->yy_ch_buf = 0;

			if ( ! b->yy_ch_buf )
				YY_FATAL_ERROR(
				"fatal error - scanner input buffer overflow" );

			yy_c_buf_p = &b->yy_ch_buf[yy_c_buf_p_offset];

			num_to_read = yy_current_buffer->yy_buf_size -
						number_to_move - 1;
#endif
			}

		if ( num_to_read > YY_READ_BUF_SIZE )
			num_to_read = YY_READ_BUF_SIZE;

		/* Read in more data. */
		YY_INPUT( (&yy_current_buffer->yy_ch_buf[number_to_move]),
			yy_n_chars, num_to_read );
		}

	if ( yy_n_chars == 0 )
		{
		if ( number_to_move == YY_MORE_ADJ )
			{
			ret_val = EOB_ACT_END_OF_FILE;
			yyrestart( yyin );
			}

		else
			{
			ret_val = EOB_ACT_LAST_MATCH;
			yy_current_buffer->yy_buffer_status =
				YY_BUFFER_EOF_PENDING;
			}
		}

	else
		ret_val = EOB_ACT_CONTINUE_SCAN;

	yy_n_chars += number_to_move;
	yy_current_buffer->yy_ch_buf[yy_n_chars] = YY_END_OF_BUFFER_CHAR;
	yy_current_buffer->yy_ch_buf[yy_n_chars + 1] = YY_END_OF_BUFFER_CHAR;

	yytext_ptr = &yy_current_buffer->yy_ch_buf[0];

	return ret_val;
	}

/* yy_get_previous_state - get the state just before the EOB char was reached */

static yy_state_type yy_get_previous_state()
	{
	register yy_state_type yy_current_state;
	register char *yy_cp;

	yy_current_state = yy_start;

	for ( yy_cp = yytext_ptr + YY_MORE_ADJ; yy_cp < yy_c_buf_p; ++yy_cp )
		{
		register YY_CHAR yy_c = (*yy_cp ? yy_ec[YY_SC_TO_UI(*yy_cp)] : 1);
		if ( yy_accept[yy_current_state] )
			{
			yy_last_accepting_state = yy_current_state;
			yy_last_accepting_cpos = yy_cp;
			}
		while ( yy_chk[yy_base[yy_current_state] + yy_c] != yy_current_state )
			{
			yy_current_state = (int) yy_def[yy_current_state];
			if ( yy_current_state >= 6 )
				yy_c = yy_meta[(unsigned int) yy_c];
			}
		yy_current_state = yy_nxt[yy_base[yy_current_state] + (unsigned int) yy_c];
		}

	return yy_current_state;
	}

/* yy_try_NUL_trans - try to make a transition on the NUL character
 *
 * synopsis
 *	next_state = yy_try_NUL_trans( current_state );
 */

#ifdef YY_USE_PROTOS
static yy_state_type yy_try_NUL_trans( yy_state_type yy_current_state )
#else
static yy_state_type yy_try_NUL_trans( yy_current_state )
yy_state_type yy_current_state;
#endif
	{
	register int yy_is_jam;
	register char *yy_cp = yy_c_buf_p;

	register YY_CHAR yy_c = 1;
	if ( yy_accept[yy_current_state] )
		{
		yy_last_accepting_state = yy_current_state;
		yy_last_accepting_cpos = yy_cp;
		}
	while ( yy_chk[yy_base[yy_current_state] + yy_c] != yy_current_state )
		{
		yy_current_state = (int) yy_def[yy_current_state];
		if ( yy_current_state >= 6 )
			yy_c = yy_meta[(unsigned int) yy_c];
		}
	yy_current_state = yy_nxt[yy_base[yy_current_state] + (unsigned int) yy_c];
	yy_is_jam = (yy_current_state == 5);

	return yy_is_jam ? 0 : yy_current_state;
	}

#ifndef YY_NO_UNPUT
#ifdef YY_USE_PROTOS
static void yyunput( int c, register char *yy_bp )
#else
static void yyunput( c, yy_bp )
int c;
register char *yy_bp;
#endif
	{
	register char *yy_cp = yy_c_buf_p;

	/* undo effects of setting up yytext */
	*yy_cp = yy_hold_char;

	if ( yy_cp < yy_current_buffer->yy_ch_buf + 2 )
		{ /* need to shift things up to make room */
		/* +2 for EOB chars. */
		register int number_to_move = yy_n_chars + 2;
		register char *dest = &yy_current_buffer->yy_ch_buf[
					yy_current_buffer->yy_buf_size + 2];
		register char *source =
				&yy_current_buffer->yy_ch_buf[number_to_move];

		while ( source > yy_current_buffer->yy_ch_buf )
			*--dest = *--source;

		yy_cp += (int) (dest - source);
		yy_bp += (int) (dest - source);
		yy_n_chars = yy_current_buffer->yy_buf_size;

		if ( yy_cp < yy_current_buffer->yy_ch_buf + 2 )
			YY_FATAL_ERROR( "flex scanner push-back overflow" );
		}

	*--yy_cp = (char) c;

	yytext_ptr = yy_bp;
	yy_hold_char = *yy_cp;
	yy_c_buf_p = yy_cp;
	}
#endif	/* ifndef YY_NO_UNPUT */

#ifdef __cplusplus
static int yyinput()
#else
static int input()
#endif
	{
	int c;

	*yy_c_buf_p = yy_hold_char;

	if ( *yy_c_buf_p == YY_END_OF_BUFFER_CHAR )
		{
		/* yy_c_buf_p now points to the character we want to return.
		 * If this occurs *before* the EOB characters, then it's a
		 * valid NUL; if not, then we've hit the end of the buffer.
		 */
		if ( yy_c_buf_p < &yy_current_buffer->yy_ch_buf[yy_n_chars] )
			/* This was really a NUL. */
			*yy_c_buf_p = '\0';

		else
			{ /* need more input */
			yytext_ptr = yy_c_buf_p;
			++yy_c_buf_p;

			switch ( yy_get_next_buffer() )
				{
				case EOB_ACT_END_OF_FILE:
					{
					if ( yywrap() )
						{
						yy_c_buf_p =
						yytext_ptr + YY_MORE_ADJ;
						return EOF;
						}

					if ( ! yy_did_buffer_switch_on_eof )
						YY_NEW_FILE;
#ifdef __cplusplus
					return yyinput();
#else
					return input();
#endif
					}

				case EOB_ACT_CONTINUE_SCAN:
					yy_c_buf_p = yytext_ptr + YY_MORE_ADJ;
					break;

				case EOB_ACT_LAST_MATCH:
#ifdef __cplusplus
					YY_FATAL_ERROR(
					"unexpected last match in yyinput()" );
#else
					YY_FATAL_ERROR(
					"unexpected last match in input()" );
#endif
				}
			}
		}

	c = *(unsigned char *) yy_c_buf_p;	/* cast for 8-bit char's */
	*yy_c_buf_p = '\0';	/* preserve yytext */
	yy_hold_char = *++yy_c_buf_p;

	return c;
	}

#ifdef YY_USE_PROTOS
void yyrestart( FILE *input_file )
#else
void yyrestart( input_file )
FILE *input_file;
#endif
	{
	if ( ! yy_current_buffer )
		yy_current_buffer = yy_create_buffer( yyin, YY_BUF_SIZE );

	yy_init_buffer( yy_current_buffer, input_file );
	yy_load_buffer_state();
	}

#ifdef YY_USE_PROTOS
void yy_switch_to_buffer( YY_BUFFER_STATE new_buffer )
#else
void yy_switch_to_buffer( new_buffer )
YY_BUFFER_STATE new_buffer;
#endif
	{
	if ( yy_current_buffer == new_buffer )
		return;

	if ( yy_current_buffer )
		{
		/* Flush out information for old buffer. */
		*yy_c_buf_p = yy_hold_char;
		yy_current_buffer->yy_buf_pos = yy_c_buf_p;
		yy_current_buffer->yy_n_chars = yy_n_chars;
		}

	yy_current_buffer = new_buffer;
	yy_load_buffer_state();

	/* We don't actually know whether we did this switch during
	 * EOF (yywrap()) processing, but the only time this flag
	 * is looked at is after yywrap() is called, so it's safe
	 * to go ahead and always set it.
	 */
	yy_did_buffer_switch_on_eof = 1;
	}

#ifdef YY_USE_PROTOS
void yy_load_buffer_state( void )
#else
void yy_load_buffer_state()
#endif
	{
	yy_n_chars = yy_current_buffer->yy_n_chars;
	yytext_ptr = yy_c_buf_p = yy_current_buffer->yy_buf_pos;
	yyin = yy_current_buffer->yy_input_file;
	yy_hold_char = *yy_c_buf_p;
	}

#ifdef YY_USE_PROTOS
YY_BUFFER_STATE yy_create_buffer( FILE *file, int size )
#else
YY_BUFFER_STATE yy_create_buffer( file, size )
FILE *file;
int size;
#endif
	{
	YY_BUFFER_STATE b;

	b = (YY_BUFFER_STATE) yy_flex_alloc( sizeof( struct yy_buffer_state ) );
	if ( ! b )
		YY_FATAL_ERROR( "out of dynamic memory in yy_create_buffer()" );

	b->yy_buf_size = size;

	/* yy_ch_buf has to be 2 characters longer than the size given because
	 * we need to put in 2 end-of-buffer characters.
	 */
	b->yy_ch_buf = (char *) yy_flex_alloc( b->yy_buf_size + 2 );
	if ( ! b->yy_ch_buf )
		YY_FATAL_ERROR( "out of dynamic memory in yy_create_buffer()" );

	b->yy_is_our_buffer = 1;

	yy_init_buffer( b, file );

	return b;
	}

#ifdef YY_USE_PROTOS
void yy_delete_buffer( YY_BUFFER_STATE b )
#else
void yy_delete_buffer( b )
YY_BUFFER_STATE b;
#endif
	{
	if ( ! b )
		return;

	if ( b == yy_current_buffer )
		yy_current_buffer = (YY_BUFFER_STATE) 0;

	if ( b->yy_is_our_buffer )
		yy_flex_free( (void *) b->yy_ch_buf );

	yy_flex_free( (void *) b );
	}

#ifndef YY_ALWAYS_INTERACTIVE
#ifndef YY_NEVER_INTERACTIVE
extern int isatty YY_PROTO(( int ));
#endif
#endif

#ifdef YY_USE_PROTOS
void yy_init_buffer( YY_BUFFER_STATE b, FILE *file )
#else
void yy_init_buffer( b, file )
YY_BUFFER_STATE b;
FILE *file;
#endif

	{
	yy_flush_buffer( b );

	b->yy_input_file = file;
	b->yy_fill_buffer = 1;

#if YY_ALWAYS_INTERACTIVE
	b->yy_is_interactive = 1;
#else
#if YY_NEVER_INTERACTIVE
	b->yy_is_interactive = 0;
#else
	b->yy_is_interactive = file ? (isatty( fileno(file) ) > 0) : 0;
#endif
#endif
	}

#ifdef YY_USE_PROTOS
void yy_flush_buffer( YY_BUFFER_STATE b )
#else
void yy_flush_buffer( b )
YY_BUFFER_STATE b;
#endif

	{
	b->yy_n_chars = 0;

	/* We always need two end-of-buffer characters.  The first causes
	 * a transition to the end-of-buffer state.  The second causes
	 * a jam in that state.
	 */
	b->yy_ch_buf[0] = YY_END_OF_BUFFER_CHAR;
	b->yy_ch_buf[1] = YY_END_OF_BUFFER_CHAR;

	b->yy_buf_pos = &b->yy_ch_buf[0];

	b->yy_at_bol = 1;
	b->yy_buffer_status = YY_BUFFER_NEW;

	if ( b == yy_current_buffer )
		yy_load_buffer_state();
	}

#ifndef YY_NO_SCAN_BUFFER
#ifdef YY_USE_PROTOS
YY_BUFFER_STATE yy_scan_buffer( char *base, yy_size_t size )
#else
YY_BUFFER_STATE yy_scan_buffer( base, size )
char *base;
yy_size_t size;
#endif
	{
	YY_BUFFER_STATE b;

	if ( size < 2 ||
	     base[size-2] != YY_END_OF_BUFFER_CHAR ||
	     base[size-1] != YY_END_OF_BUFFER_CHAR )
		/* They forgot to leave room for the EOB's. */
		return 0;

	b = (YY_BUFFER_STATE) yy_flex_alloc( sizeof( struct yy_buffer_state ) );
	if ( ! b )
		YY_FATAL_ERROR( "out of dynamic memory in yy_scan_buffer()" );

	b->yy_buf_size = size - 2;	/* "- 2" to take care of EOB's */
	b->yy_buf_pos = b->yy_ch_buf = base;
	b->yy_is_our_buffer = 0;
	b->yy_input_file = 0;
	b->yy_n_chars = b->yy_buf_size;
	b->yy_is_interactive = 0;
	b->yy_at_bol = 1;
	b->yy_fill_buffer = 0;
	b->yy_buffer_status = YY_BUFFER_NEW;

	yy_switch_to_buffer( b );

	return b;
	}
#endif

#ifndef YY_NO_SCAN_STRING
#ifdef YY_USE_PROTOS
YY_BUFFER_STATE yy_scan_string( yyconst char *str )
#else
YY_BUFFER_STATE yy_scan_string( str )
yyconst char *str;
#endif
	{
	int len;
	for ( len = 0; str[len]; ++len )
		;

	return yy_scan_bytes( str, len );
	}
#endif

#ifndef YY_NO_SCAN_BYTES
#ifdef YY_USE_PROTOS
YY_BUFFER_STATE yy_scan_bytes( yyconst char *bytes, int len )
#else
YY_BUFFER_STATE yy_scan_bytes( bytes, len )
yyconst char *bytes;
int len;
#endif
	{
	YY_BUFFER_STATE b;
	char *buf;
	yy_size_t n;
	int i;

	/* Get memory for full buffer, including space for trailing EOB's. */
	n = len + 2;
	buf = (char *) yy_flex_alloc( n );
	if ( ! buf )
		YY_FATAL_ERROR( "out of dynamic memory in yy_scan_bytes()" );

	for ( i = 0; i < len; ++i )
		buf[i] = bytes[i];

	buf[len] = buf[len+1] = YY_END_OF_BUFFER_CHAR;

	b = yy_scan_buffer( buf, n );
	if ( ! b )
		YY_FATAL_ERROR( "bad buffer in yy_scan_bytes()" );

	/* It's okay to grow etc. this buffer, and we should throw it
	 * away when we're done.
	 */
	b->yy_is_our_buffer = 1;

	return b;
	}
#endif

#ifndef YY_NO_PUSH_STATE
#ifdef YY_USE_PROTOS
static void yy_push_state( int new_state )
#else
static void yy_push_state( new_state )
int new_state;
#endif
	{
	if ( yy_start_stack_ptr >= yy_start_stack_depth )
		{
		yy_size_t new_size;

		yy_start_stack_depth += YY_START_STACK_INCR;
		new_size = yy_start_stack_depth * sizeof( int );

		if ( ! yy_start_stack )
			yy_start_stack = (int *) yy_flex_alloc( new_size );

		else
			yy_start_stack = (int *) yy_flex_realloc(
					(void *) yy_start_stack, new_size );

		if ( ! yy_start_stack )
			YY_FATAL_ERROR(
			"out of memory expanding start-condition stack" );
		}

	yy_start_stack[yy_start_stack_ptr++] = YY_START;

	BEGIN(new_state);
	}
#endif

#ifndef YY_NO_POP_STATE
static void yy_pop_state()
	{
	if ( --yy_start_stack_ptr < 0 )
		YY_FATAL_ERROR( "start-condition stack underflow" );

	BEGIN(yy_start_stack[yy_start_stack_ptr]);
	}
#endif

#ifndef YY_NO_TOP_STATE
static int yy_top_state()
	{
	return yy_start_stack[yy_start_stack_ptr - 1];
	}
#endif

#ifndef YY_EXIT_FAILURE
#define YY_EXIT_FAILURE 2
#endif

#ifdef YY_USE_PROTOS
static void yy_fatal_error( yyconst char msg[] )
#else
static void yy_fatal_error( msg )
char msg[];
#endif
	{
	(void) fprintf( stderr, "%s\n", msg );
	exit( YY_EXIT_FAILURE );
	}

/* Redefine yyless() so it works in section 3 code. */

#undef yyless
#define yyless(n) \
	do \
		{ \
		/* Undo effects of setting up yytext. */ \
		yytext[yyleng] = yy_hold_char; \
		yy_c_buf_p = yytext + n - YY_MORE_ADJ; \
		yy_hold_char = *yy_c_buf_p; \
		*yy_c_buf_p = '\0'; \
		yyleng = n; \
		} \
	while ( 0 )

/* Internal utility routines. */

#ifndef yytext_ptr
#ifdef YY_USE_PROTOS
static void yy_flex_strncpy( char *s1, yyconst char *s2, int n )
#else
static void yy_flex_strncpy( s1, s2, n )
char *s1;
yyconst char *s2;
int n;
#endif
	{
	register int i;
	for ( i = 0; i < n; ++i )
		s1[i] = s2[i];
	}
#endif

#ifdef YY_USE_PROTOS
static void *yy_flex_alloc( yy_size_t size )
#else
static void *yy_flex_alloc( size )
yy_size_t size;
#endif
	{
	return (void *) malloc( size );
	}

#ifdef YY_USE_PROTOS
static void *yy_flex_realloc( void *ptr, yy_size_t size )
#else
static void *yy_flex_realloc( ptr, size )
void *ptr;
yy_size_t size;
#endif
	{
	/* The cast to (char *) in the following accommodates both
	 * implementations that use char* generic pointers, and those
	 * that use void* generic pointers.  It works with the latter
	 * because both ANSI C and C++ allow castless assignment from
	 * any pointer type to void*, and deal with argument conversions
	 * as though doing an assignment.
	 */
	return (void *) realloc( (char *) ptr, size );
	}

#ifdef YY_USE_PROTOS
static void yy_flex_free( void *ptr )
#else
static void yy_flex_free( ptr )
void *ptr;
#endif
	{
	free( ptr );
	}

#if YY_MAIN
int main()
	{
	yylex();
	return 0;
	}
#endif
#line 2 "<stdin>"

extern char *yytext;
int main() {

; return 0; }
configure:3251: checking for bison
configure:3284: checking for ANSI C header files
configure:3297: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3364: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3388: checking for sys/wait.h that is POSIX.1 compatible
configure:3409: gcc -c -g -O2  conftest.c 1>&5
configure:3433: checking for stdlib.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for fcntl.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for limits.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for malloc.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for string.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for memory.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for unistd.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3473: checking for getopt.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3479: getopt.h: No such file or directory
configure: failed program was:
#line 3478 "configure"
#include "confdefs.h"
#include <getopt.h>
configure:3473: checking for sys/select.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3473: checking for sys/systeminfo.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3511: checking for working const
configure:3565: gcc -c -g -O2  conftest.c 1>&5
configure:3586: checking for inline
configure:3600: gcc -c -g -O2  conftest.c 1>&5
configure:3626: checking for off_t
configure:3659: checking for pid_t
configure:3692: checking for size_t
configure:3726: checking return type of signal handlers
configure:3748: gcc -c -g -O2  conftest.c 1>&5
configure:3767: checking for strftime
configure:3795: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for gettimeofday
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for mkfifo
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for putenv
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for select
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for setvbuf
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for socket
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
Undefined			first referenced
 symbol  			    in file
socket                              /tmp/cc0_wIws1.o
ld: fatal: Symbol referencing errors. No output written to conftest
configure: failed program was:
#line 3870 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
    which can conflict with char socket(); below.  */
#include <assert.h>
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char socket();

int main() {

/* The GNU C library defines this for functions which it implements
    to always fail with ENOSYS.  Some functions are actually named
    something starting with __ and the normal name is an alias.  */
#if defined (__stub_socket) || defined (__stub___socket)
choke me
#else
socket();
#endif

; return 0; }
configure:3865: checking for waitpid
configure:3920: checking for strdup
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for strstr
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for strtol
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for memmove
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for memcpy
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3932: warning: conflicting types for built-in function `memcpy'
configure:3920: checking for strchr
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for sysconf
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for uname
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for div
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3975: checking for sigaction
configure:4003: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3975: checking for siginterrupt
configure:4003: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4029: checking for sig_atomic_t
configure:4065: checking whether setvbuf arguments are reversed
configure:4087: gcc -o conftest -g -O2   conftest.c  1>&5
configure: In function `main':
configure:4080: warning: passing arg 2 of `setvbuf' makes pointer from integer without a cast
configure:4080: warning: passing arg 3 of `setvbuf' makes integer from pointer without a cast
configure: failed program was:
#line 4073 "configure"
#include "confdefs.h"
#include <stdio.h>
/* If setvbuf has the reversed format, exit 0. */
main () {
  /* This call has the arguments reversed.
     A reversed system may check and see that the address of main
     is not _IOLBF, _IONBF, or _IOFBF, and return nonzero.  */
  if (setvbuf(stdout, _IOLBF, (char *) main, BUFSIZ) != 0)
    exit(1);
  putc('\r', stdout);
  exit(0);			/* Non-reversed systems segv here.  */
}
configure:4117: checking for sys/types.h
configure:4127: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:4117: checking for sys/time.h
configure:4127: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:4117: checking for sys/select.h
configure:4117: checking for sys/socket.h
configure:4127: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:4154: checking types of arguments for select()
configure:4187: gcc -c -g -O2  conftest.c 1>&5
configure:4230: checking for gethostname
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4230: checking for strcasecmp
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4230: checking for strncasecmp
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4230: checking for strerror
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4230: checking for usleep
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4230: checking for atexit
configure:4258: gcc -o conftest -g -O2   conftest.c  1>&5
configure:4382: checking for XpmReadFileToXpmImage in -lXpm
configure:4401: gcc -o conftest -g -O2   conftest.c -lXpm -L/usr/X11R6/lib -lXpm  -L/usr/openwin/lib -R/usr/openwin/lib  -lSM -lICE -lX11 -lsocket  -lnsl  1>&5
configure:4446: checking for X11/xpm.h
configure:4456: gcc -E  -I/usr/X11R6/include  -I/usr/openwin/include conftest.c >/dev/null 2>conftest.out
configure:4508: checking for Xpm 3.4f or better
configure:4525: gcc -o conftest -g -O2  -I/usr/X11R6/include  -I/usr/openwin/include  conftest.c  -L/usr/X11R6/lib -lXpm  -L/usr/openwin/lib -R/usr/openwin/lib  -lSM -lICE -lX11 -lsocket  -lnsl 1>&5
configure:4611: checking for rplay_create in -lrplay
configure:4630: gcc -o conftest -g -O2   conftest.c -lrplay -lrplay -lsocket  -lnsl  1>&5
ld: fatal: library -lrplay: not found
ld: fatal: library -lrplay: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
#line 4619 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char rplay_create();

int main() {
rplay_create()
; return 0; }
configure:4776: checking for readline in -lreadline
configure:4795: gcc -o conftest -g -O2   conftest.c -lreadline -L/usr/local/lib -lreadline -ltermcap  1>&5
configure:4840: checking for readline/readline.h
configure:4850: gcc -E  -I/usr/local/include conftest.c >/dev/null 2>conftest.out
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
# scripts and configure runs.  It is not useful on other systems.
# If it contains results you don't want to keep, you may remove or edit it.
#
# By default, configure uses ./config.cache as the cache file,
# creating it if it does not exist already.  You can give configure
# the --cache-file=FILE option to use a different cache file; that is
# what configure does when it calls configure scripts in
# subdirectories, so they share the cache.
# Giving --cache-file=/dev/null disables caching, for debugging configure.
# config.status only pays attention to the cache file if you give it the
# --recheck option to rerun configure.
#
ac_cv_c_const=${ac_cv_c_const='yes'}
ac_cv_c_inline=${ac_cv_c_inline='inline'}
ac_cv_func_atexit=${ac_cv_func_atexit='yes'}
ac_cv_func_connect=${ac_cv_func_connect='no'}
ac_cv_func_div=${ac_cv_func_div='yes'}
ac_cv_func_gethostbyname=${ac_cv_func_gethostbyname='no'}
ac_cv_func_gethostname=${ac_cv_func_gethostname='yes'}
ac_cv_func_gettimeofday=${ac_cv_func_gettimeofday='yes'}
ac_cv_func_memcpy=${ac_cv_func_memcpy='yes'}
ac_cv_func_memmove=${ac_cv_func_memmove='yes'}
ac_cv_func_mkfifo=${ac_cv_func_mkfifo='yes'}
ac_cv_func_putenv=${ac_cv_func_putenv='yes'}
ac_cv_func_remove=${ac_cv_func_remove='yes'}
ac_cv_func_select=${ac_cv_func_select='yes'}
ac_cv_func_select_arg1=${ac_cv_func_select_arg1='int'}
ac_cv_func_select_arg234=${ac_cv_func_select_arg234='fd_set *'}
ac_cv_func_select_arg5=${ac_cv_func_select_arg5='struct timeval *'}
ac_cv_func_setvbuf=${ac_cv_func_setvbuf='yes'}
ac_cv_func_setvbuf_reversed=${ac_cv_func_setvbuf_reversed='no'}
ac_cv_func_shmat=${ac_cv_func_shmat='yes'}
ac_cv_func_sigaction=${ac_cv_func_sigaction='yes'}
ac_cv_func_siginterrupt=${ac_cv_func_siginterrupt='yes'}
ac_cv_func_socket=${ac_cv_func_socket='no'}
ac_cv_func_strcasecmp=${ac_cv_func_strcasecmp='yes'}
ac_cv_func_strchr=${ac_cv_func_strchr='yes'}
ac_cv_func_strdup=${ac_cv_func_strdup='yes'}
ac_cv_func_strerror=${ac_cv_func_strerror='yes'}
ac_cv_func_strftime=${ac_cv_func_strftime='yes'}
ac_cv_func_strncasecmp=${ac_cv_func_strncasecmp='yes'}
ac_cv_func_strstr=${ac_cv_func_strstr='yes'}
ac_cv_func_strtol=${ac_cv_func_strtol='yes'}
ac_cv_func_sysconf=${ac_cv_func_sysconf='yes'}
ac_cv_func_uname=${ac_cv_func_uname='yes'}
ac_cv_func_usleep=${ac_cv_func_usleep='yes'}
ac_cv_func_vfprintf=${ac_cv_func_vfprintf='yes'}
ac_cv_func_waitpid=${ac_cv_func_waitpid='yes'}
ac_cv_have_x=${ac_cv_have_x='have_x=yes 		ac_x_includes=/usr/openwin/include ac_x_libraries=/usr/openwin/lib'}
ac_cv_header_X11_xpm_h=${ac_cv_header_X11_xpm_h='yes'}
ac_cv_header_fcntl_h=${ac_cv_header_fcntl_h='yes'}
ac_cv_header_getopt_h=${ac_cv_header_getopt_h='no'}
ac_cv_header_limits_h=${ac_cv_header_limits_h='yes'}
ac_cv_header_malloc_h=${ac_cv_header_malloc_h='yes'}
ac_cv_header_memory_h=${ac_cv_header_memory_h='yes'}
ac_cv_header_minix_config_h=${ac_cv_header_minix_config_h='no'}
ac_cv_header_readline_readline_h=${ac_cv_header_readline_readline_h='yes'}
ac_cv_header_stdarg_h=${ac_cv_header_stdarg_h='yes'}
ac_cv_header_stdc=${ac_cv_header_stdc='yes'}
ac_cv_header_stdlib_h=${ac_cv_header_stdlib_h='yes'}
ac_cv_header_string_h=${ac_cv_header_string_h='yes'}
ac_cv_header_sys_select_h=${ac_cv_header_sys_select_h='yes'}
ac_cv_header_sys_socket_h=${ac_cv_header_sys_socket_h='yes'}
ac_cv_header_sys_systeminfo_h=${ac_cv_header_sys_systeminfo_h='yes'}
ac_cv_header_sys_time_h=${ac_cv_header_sys_time_h='yes'}
ac_cv_header_sys_types_h=${ac_cv_header_sys_types_h='yes'}
ac_cv_header_sys_wait_h=${ac_cv_header_sys_wait_h='yes'}
ac_cv_header_unistd_h=${ac_cv_header_unistd_h='yes'}
ac_cv_lib_ICE_IceConnectionNumber=${ac_cv_lib_ICE_IceConnectionNumber='yes'}
ac_cv_lib_Xpm_XpmReadFileToXpmImage=${ac_cv_lib_Xpm_XpmReadFileToXpmImage='yes'}
ac_cv_lib_dnet_dnet_ntoa=${ac_cv_lib_dnet_dnet_ntoa='no'}
ac_cv_lib_dnet_stub_dnet_ntoa=${ac_cv_lib_dnet_stub_dnet_ntoa='no'}
ac_cv_lib_fl_yywrap=${ac_cv_lib_fl_yywrap='no'}
ac_cv_lib_nsl_gethostbyname=${ac_cv_lib_nsl_gethostbyname='yes'}
ac_cv_lib_readline_readline=${ac_cv_lib_readline_readline='yes'}
ac_cv_lib_rplay_rplay_create=${ac_cv_lib_rplay_rplay_create='no'}
ac_cv_lib_socket_connect=${ac_cv_lib_socket_connect='yes'}
ac_cv_path_FVWM_CPP=${ac_cv_path_FVWM_CPP='/usr/ccs/lib/cpp'}
ac_cv_prog_CC=${ac_cv_prog_CC='gcc'}
ac_cv_prog_CPP=${ac_cv_prog_CPP='gcc -E'}
ac_cv_prog_LEX=${ac_cv_prog_LEX='flex'}
ac_cv_prog_LN_S=${ac_cv_prog_LN_S='ln -s'}
ac_cv_prog_RANLIB=${ac_cv_prog_RANLIB='ranlib'}
ac_cv_prog_YACC=${ac_cv_prog_YACC='bison -y'}
ac_cv_prog_cc_cross=${ac_cv_prog_cc_cross='no'}
ac_cv_prog_cc_g=${ac_cv_prog_cc_g='yes'}
ac_cv_prog_cc_works=${ac_cv_prog_cc_works='yes'}
ac_cv_prog_gcc=${ac_cv_prog_gcc='yes'}
ac_cv_prog_lex_root=${ac_cv_prog_lex_root='lex.yy'}
ac_cv_prog_lex_yytext_pointer=${ac_cv_prog_lex_yytext_pointer='no'}
ac_cv_prog_make_make_set=${ac_cv_prog_make_make_set='yes'}
ac_cv_type_off_t=${ac_cv_type_off_t='yes'}
ac_cv_type_pid_t=${ac_cv_type_pid_t='yes'}
ac_cv_type_sig_atomic_t=${ac_cv_type_sig_atomic_t='yes'}
ac_cv_type_signal=${ac_cv_type_signal='void'}
ac_cv_type_size_t=${ac_cv_type_size_t='yes'}

---

From: Danek Duvall <[email-masked]>
Date: Fri, 22 Jan 1999 08:23:50 -0800

On Thu, Jan 21, 1999 at 10:49:55PM +0100, Dominik Vogt wrote:

> library, looking for 'core' and I searched the directory tree manually
> looking for any strange files.
> 

He might not have a core file because he's set his core file limit to zero
(I do, when I'm not doing a lot of debugging, as I tend not to want to
leave twenty meg netscape cores lying around ... ).

Unless his sysadmin has set a hard limit for core files (and few do), then
temporarily putting

    unlimit core

in some shell file that gets sourced before exec'ing fvwm (.xsession,
.cshrc, .zshenv, wherever), should allow the core to happen.

Alternately, trussing or attaching a debugger to the process once it's
started (like Paul suggested) will give you some idea of where it dies.

Danek

---

From: Tim Phipps <[email-masked]>
Date: Fri, 22 Jan 1999 16:46:02 +0000

> I'm getting a crash in ReadFvwmPipe when I pop up a transient.

Now I'm reaaly confused. The crash happens in malloc()! specifically
malloc() thats called to make space for the read of a message from fvwm,
from safemalloc(), from ReadFvwmPacket().

I'm off for the weekend so nothing more from me 'til Monday.
Cheers,
Tim.

---

From: [email-masked] (Paul D. Smith)
Date: 22 Jan 1999 12:14:59 -0500

tp> Now I'm reaaly confused. The crash happens in malloc()! specifically
  tp> malloc() thats called to make space for the read of a message from fvwm,
  tp> from safemalloc(), from ReadFvwmPacket().

How much space is it trying to alloc?

Sounds like some kind of heap corruption to me...

---

From: Dan Espen <[email-masked]>
Date: Fri, 22 Jan 1999 12:37:30 -0500

> Sounds like some kind of heap corruption to me...

Thats what Purify thinks:

ABW: Array bounds write (12 times):
  * This is occurring while in:
	strcpy         [rtlib.o]
	UpdateString   [Mallocs.c:55]
	UpdateItemName [List.c:90]
	ProcessMessage [FvwmWinList.c:337]
	ReadFvwmPipe   [FvwmWinList.c:270]
	MainEventLoop  [FvwmWinList.c:252]
	main           [FvwmWinList.c:228]
	_start         [crt1.o]
  * Writing 20 bytes to 0x93ff0 in the heap (2 bytes at 0x94002 illegal).
  * Address 0x93ff0 is at the beginning of a malloc'd block of 18 bytes.
  * This block was allocated from:
	malloc         [rtlib.o]
	realloc        [rtlib.o]
	saferealloc    [Mallocs.c:43]
	UpdateString   [Mallocs.c:54]
	UpdateItemName [List.c:90]
	ProcessMessage [FvwmWinList.c:337]
	ReadFvwmPipe   [FvwmWinList.c:270]
	MainEventLoop  [FvwmWinList.c:252]
	main           [FvwmWinList.c:228]
	_start         [crt1.o]

> -- 
>  Paul D. Smith <[email-masked]>         Network Management Developmen

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 22 Jan 1999 12:59:46 -0500

%% Dan Espen <[email-masked]> writes:

  tp> Now I'm reaaly confused. The crash happens in malloc()! specifically
  tp> malloc() thats called to make space for the read of a message from fvwm
  >> ,
  >> Sounds like some kind of heap corruption to me...

  de> Thats what Purify thinks:

  de> ABW: Array bounds write (12 times):
  de>   * This is occurring while in:
  de> 	strcpy         [rtlib.o]
  de> 	UpdateString   [Mallocs.c:55]

DOH!!!!

Change this line:

 Mallocs.c:54:  *string = saferealloc(*string,strlen(value+1));
                                                    ^^^^^^^^^

to this:

 Mallocs.c:54:  *string = saferealloc(*string,strlen(value)+1);
                                                    ^^^^^^^^^

*sigh*.

---

From: Chris Rankin <[email-masked]>
Date: Fri, 22 Jan 1999 21:08:37 -0500 (EST)

> My mistake.

Nope; mine, I think :-/

> It was fvwm that was hanging. An XFlush() just before the select nicely fixes my problems.
> 

But doesn't this mean that it's still FvwmWinList's fault for not
emptying its input queue? fvwm seems to be the innocent victim.

Chris.

---

From: Tim Phipps <[email-masked]>
Date: Mon, 25 Jan 1999 13:19:37 +0000

> *sigh*.

This fixes my core dumps thanks.  I thought I was going nuts on Friday
having core dumps from malloc. I did hope someone would run purify and
find a memory problem.

Cheers,
Tim.