Subject: 2.2 ?

From: [email-masked] (Paul D. Smith)
Date: 25 Jan 1999 09:51:52 -0500

I think it's up to Dominik to decide how to proceed.  I changed the heap
corruption bug because it was a completely trivial fix to a serious bug
and I didn't think it would absolutely require another beta (or, perhaps
just a very, very short one).

I agree that these other problems that are coming to light are also
serious (to those using FvwmWinList and recapture, at least) but the
fixes aren't as obvious and trivial.  My opinion is they would require
another beta, if anyone is asking.

So, this is where the pumpking comes in: how do we move forward?

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 25 Jan 1999 10:16:19 -0500

> So, this is where the pumpking comes in: how do we move forward?

Perhaps you are referring to the change I just committed?
I'll remove it if I get enough negative feedback.  It really does
seem safe to me.

I took  Bob's comment "This  sounds good to  me." as  approval for the
change in the release.

> -- 
>  Paul D. Smith <[email-masked]>         Network Management Developmen

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 25 Jan 1999 11:34:36 -0500

>> So, this is where the pumpking comes in: how do we move forward?

  de> Perhaps you are referring to the change I just committed?

No, I posted this before I saw your change go through.

I just haven't heard much from Dominik lately and I'm not sure what we
should be doing to push 2.2 out at this point :)

---

From: Dan Espen <[email-masked]>
Date: Mon, 25 Jan 1999 12:25:02 -0500

> should be doing to push 2.2 out at this point :)

I hope Dominik is taking a well earned break.

If questions come up about what goes in or doesn't go in,
lets let fvwm-workers resolve it.

I think we need 2.1.10 to get a week or more of testing before
we decide on a beta or 2.2 as our next release.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 25 Jan 1999 23:31:42 +0100

> > should be doing to push 2.2 out at this point :)

I just noticed that the mails I send from work don't get
through to the list. There seems to be some trouble with
our network.

> I hope Dominik is taking a well earned break.

I am. At the moment I feel very tired. And my kittens have a way
of letting me know they don't like it whe I spend my evenings before
the machine. Seeing this amount of bugs coming up when we thought
it would be only a week or so to 2.2 makes me scream. Seems we're
close to going back into development mode. 

I have completely lost track of open problems, but I am
aware of two things that should be done:

1) Apply the same fix to FvwmIconMan that repaired FvwmWinList.
   If I'm talking rubbish just tell me, I didn't the discussion
   about FvwmWinList thoroughly.

2) Remove that code that changed mouse button 2 for FvwmPager.
   I remember vaguely I worked on mouse buttons in the pager,
   but the ChangeLog says it was button 3. One thing I could
   imagine is that this slipped in when I applied the Red Hat
   patches (I checked the ones I still have on my disk but
   found nothing). There's a suspicious amount of patches
   between 2.1.4 and 2.1.7.

> lets let fvwm-workers resolve it.

Yes. One thing I have learned on my way from a green fvwm2
development newbie (is it really just three month?) to the
battle scarred bug hunting veteran is that things are still
happening even if I am away for a while. I think I will
relax another week (at least until I'm through the Protoss
campaign in Star Craft ;-) ) and come back with renewed
energy then. I.e. I won't write a lot of mails or fix bugs.

> we decide on a beta or 2.2 as our next release.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Mon, 25 Jan 1999 21:13:31 -0500 (EST)

>    found nothing). There's a suspicious amount of patches

	If this is in reference to bug reports 140 & 141, I'll
have a go at it. I'm not sure this was all caused by one simple
set of changes to Pager. I think there may have been a series of
changes, and not all to the Pager, that brought this on.

	The button2-drag-warps problem is easy to fix. I can commit
this right away, if you like. The button2-click-warps looks a
little more involved, and I'm not sure it's confined to the code
in Pager. I'll look into it, though.

	The other button2 issue mentioned recently - Pager tries to
give focus to a no-input window - isn't really a Pager issue. Depend-
ing on the Lenience setting, the focus code shouln't try to give
such a window the focus. I'm not sure whether that one was answered
satisfactorily - I don't recall any follow-up.

- Bob

---

From: Steve Robbins <[email-masked]>
Date: Tue, 26 Jan 1999 00:08:46 -0500 (EST)

> lets let fvwm-workers resolve it.

I haven't been following the discussion of the last 2-3 days closely, and
I certainly don't know the code being discussed, so I'll defer to Bob and
Dan's judgement on this matter. 

But I have to say that all the code proposals being floated / committed
make me nervous.  Non-local changes, in particular, make me very nervous.

As for me, at this point, I'd include only fixes for bugs that: 

  1) cause a build failure,
  2) cause a coredump, or
  3) render the default setup unusable.

As I say, I haven't been following the grabbing and the
iconic/starts-on-window discussions closely enough to know whether they
pass test (3) or not.  If it causes a problem only to specialised setups,
maybe it can just be documented to be fixed in 2.0.1? 

> we decide on a beta or 2.2 as our next release.

There has already been non-trivial changes to 2.1.10, with the grab stuff. 
I reckon we'd better have another beta -- particularly if the
iconic/starts-on-window stuff or any signal stuff goes in.

---

From: Steve Robbins <[email-masked]>
Date: Tue, 26 Jan 1999 00:32:47 -0500 (EST)

>   3) render the default setup unusable.

About point #3 ... has anyone actually tested what comes in
"sample.fvwmrc" lately?  I haven't...

--
Steve Robbins                              <[email-masked]>

If I had a rocket launcher, some son of a bitch would die.

---

From: Matthias Clasen <[email-masked]>
Date: Tue, 26 Jan 1999 10:23:15 +0100

> satisfactorily - I don't recall any follow-up.

I think it was me who reported this. I proposed to fix it by
changing the pager to send a "Focus" to fvwm instead of trying to
set the focus directly. That seemed to work nicely. I even sent
a patch for that.

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 11:44:11 +0100

On Mon, Jan 25, 1999 at 09:13:31PM -0500, Bob Woodside wrote:
> have a go at it.

Yes it is.

> I'm not sure this was all caused by one simple

The button2-drag-warps should definitely be fixed. I wonder how
this came in. The button2-click-warps problem is another
story however. As a developer I in fact use it most of the
time to give the focus to a window on another page (for testing).
But I think the average user has no need of focussing windows
off screen. This seems like an improvement to me (but it has to
be documented if we keep it this way). Matthias' reasoning that
sending fvwm2 a Focus command looks more logical seems right
to me too.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 11:45:50 +0100

>   3) render the default setup unusable.

4) change behaviour that would be changed back after 2.2
   (just like this pager 'bugs')

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 11:47:44 +0100

> "sample.fvwmrc" lately?  I haven't...

I assisted a friend of mine to migrate from 1.24 to 2.1.7 and
he tried it. He was shocked by the colour choice (as I am) and
threw it away without having another look.

Bye

Dominik

---

From: Bob Woodside <[email-masked]>
Date: Tue, 26 Jan 1999 06:26:57 -0500 (EST)

> set the focus directly. That seemed to work nicely. I even sent

	Great! Now I know where to look to fix bug # 141 (I think it
is), and we'll have all three squashed. I'll get to it this evening.

	I know it's disappointing, because we all want to get this
release out, but there's a lot of stuff that's just not quite right.
I agree with Dominik - let's not succumb to buck fever (fire - ready -
aim!), but take a few more days to fix these things we know will have
to be done right away.

- Bob

---

From: Tim Phipps <[email-masked]>
Date: Tue, 26 Jan 1999 11:58:44 +0000

> is), and we'll have all three squashed. I'll get to it this evening.

Could we have FlipFocus instead of Focus?

Cheers,
Tim.

---

From: Dan Espen <[email-masked]>
Date: Tue, 26 Jan 1999 08:43:42 -0500

> maybe it can just be documented to be fixed in 2.0.1? 

The grab stuff is  in category 2  or  3, any FvwmAnimate user  doing a
recapture would get a lockup.  A lockup is just as bad as a core dump.

> iconic/starts-on-window stuff or any signal stuff goes in. 

If you do  diffs on the grab  changes, libs/Grab.c, fvwm/modules.c,  I
think you  will see that they  are  trivial.  I'm  less sure about the
iconic stuff.   I  am  aware  that changes  to   code  I don't   fully
understand seem more complex.

In the next few days, I'm starting a new project at work.
This may impact the time I can devote to fvwm2.