Subject: Menu Doesn't always catch buttonpress event

From: [email-masked]
Date: Wed, 6 Jan 1999 17:20:21 -0600 (CST)

Full_Name: David Ronis
Version: 2.1.5
CVS_Date: 
OS: Linux 2.2.0-pre4/2.0.36
X_Server: XFree86 Version 3.3.3
Submission from: (NULL) (132.206.20.6)

The main utilities menu (the relevant part of my .fvwm2rc file is pasted
below) 
sometimes misses ButtonPress events (especially when the system is more
loaded).  
This happens on both an i486 and an i586.

The problem only seems to happen with the 1st entry (xterm) in the menu
listed below
although, it's probably the most heavily used one.  

If I move the mouse cursor on the menu, and then click on Xterm--it always
seems to 
work.

Two possibilities:

a)  Events are really being dropped.
b)  There is some error in the calculation of where the event is really
happening
     (probably saying that I've clicked on the menu title).

------------------------------------------------------------------------------------
AddToMenu "utilities" "Utilities" Title
+              "Xterm" Exec /usr/bin/X11/xterm -T `hostname`  -n `hostname`
-sb 
-sl 500 -j +ls -fn 10x20 +ls 
+              "Calculator" Exec xcalc -rpn 
+              "Mail" Exec ssh -n onsager /usr/dt/bin/dtmail  
+              "News" Exec ssh -n gibbs "xterm -T News -j -fn 10x20
-geometry 90
x25+0+10  -e /usr/local/bin/rtin"
+              "Netscape" Exec netscape -geometry +0+0
+              "Tkman" Exec tkman 
+              "Tkinfo" Exec tkinfo 
+              "" Nop
+              "Remotes" Popup Remotes
+              "" Nop
+              "Applications" Popup Applications
+              "System Utilities"  Popup sysutilities
+              "" Nop
+              "Exit Fvwm" Popup Quit-Verify
+              "Quit" Quit
+              "" Nop
+              "Refresh Screen" Refresh

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Jan 1999 09:31:36 +0100

>      (probably saying that I've clicked on the menu title).

Actually it's (c). No error happening, no events being dropped,
not a bug. You are using the 'Popup' command to open the root menu.
Menu items won't be invoked it the pointer starts on a menu item
and you release the pointer fast. In the latest code there's some
option to tune this delay (duble click time or so, see MenuStyle).
If you absolutely need this action always you can bind a default
action to your Popup menu:

  Popup Utilities Exec xterm

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]