Subject: Status update

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Jan 1999 10:22:42 +0100

Things left to do before 2.2 (update/fix/verify):

1) the key/mouse binding problems (not all in Jitterbug)
   [investigate bug reports]

2) the XPM problems (probably in 'configure', bugs #31,
   #40 and perhaps others)
   [in progress (PDS)]

3) verify the XGetImage problem I encountered
   [pending]

4) apply latest signal handling patches
   [pending]

5) verify the 'growing windows' bugfix
   [pending]

6) verify the num-lock/key binding bugfix (bug #54)
   [pending]

7) document install-strip problem (bug #33)
   [pending (PDS?)]

8) closing a panel closes FvwmButtons
   [to be verified]

9) FvwmCpp does not know where cpp is (bug #95)
   can you say something about this, Paul (PDS)?
   [investigation pending]

10) crash with xclock (bug #56)
    [investigation pending]

11) hanging up asmodem kills FvwmButtons (perhaps related to 8)
    [investigation pending]

12) this 'serious bug' RedHat found (I'd like to see the patch).
    [investigation in progress]

13) the FvwmCommandS problem discussed recently
    [investigation in progress]

Summary:

6 investigate
1 update patch
1 document bug
1 in progress
4 verify fix

There are five problems left where we don't have an idea
how to fix them (1, 10, 11, 12, 13).

----

stuff done since last update:

 - Fix the remaining memory leaks (95%)
   The remaining leaks won't be done for 2.2

 - snap attraction patch update

----

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Jan 1999 11:53:42 +0100

> 11) hanging up asmodem kills FvwmButtons (perhaps related to 8)

Fixed thanks to the signal handling patches.

I've to add another item:

14) Integrate this StaysOnTop related patch by Matthias Clasen
    [in progress (Bob W.)]

Bye

Dominik