Subject: Notification: incoming/128

From: [email-masked]
Date: Wed, 13 Jan 1999 11:58:49 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/128

Message summary for PR#128
	From: Jonathan Ryshpan <[email-masked]>
	Subject: fvwm2-2.1.7-1 vs FvwmTaskBar
	Date: Wed, 13 Jan 1999 09:45:36 -0800
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Thu, 14 Jan 1999 14:59:23 +0000

> There are some bugs in the way fvwm2-2.1.7-1 handles FvwmTaskBar:

What is fvwm2-2.1.7-1?

> (1) FvwmTaskBarAutoHide doesn't work.  The task bar is never hidden.
> 
> (2) The task bar is updated only when the cursor is on it.  Ie. when you
> exit a window, the change only shows up on the task bar when the cursor
> is on the task bar.

With fvwm version 2.1.7 I can't reproduce either of these.  There may be
a problem with not being able to auto unhidden the task bar due to the
panhandles but it always manages to hide itself.

> I am running AnotherLevel-0.7.3-1.  Do I need to upgrade it?

I have absolutely no idea, better ask the person that you got it from.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 14 Jan 1999 09:21:38 -0600

>>>>> "TP" == Tim Phipps <[email-masked]> writes:

TP> What is fvwm2-2.1.7-1?

Probably someone has turned it into an RPM; that would be version 1 of the
fvwm2-2.1.7 RPM.  The problem is in people thinking that these come from
us.  (It would be nice if they did come from us, but I don't know anything
about making RPMs.)

 - J<

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 14 Jan 1999 10:27:47 -0500

> us.  (It would be nice if they did come from us, but I don't know anything

I can whip up the spec file needed to make it an rpm, but My linux box has much to slow
of a connection to pull in the tarballs and make rpms.

So if someone else has a linux box, and would be willing to create an rpm for each release
I can give directions.

Brad

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Jan 1999 16:52:47 +0100

> So if someone else has a linux box, and would be willing to create an rpm for each release

Could it be done as a script?

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 14 Jan 1999 11:01:59 -0500

> Could it be done as a script?
it basically requires having all the source then just running 
rpm <with some switches>

so yes it could easily be scripted

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Jan 1999 17:17:02 +0100

> so yes it could easily be scripted

Of course it would be best to do it on the same location as
the ftp server. You don't happen to have a Linux available
there that could do the job automatically, Jason? I'd
volunteer to write scripts for whatever is needed, but
making the rpm at home is no real option for me.

Bye

Dominik

---

From: Jason L Tibbitts III <[email-masked]>
Date: 14 Jan 1999 10:40:04 -0600

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

DV> Of course it would be best to do it on the same location as the ftp
DV> server. You don't happen to have a Linux available there that could do
DV> the job automatically, Jason?

If someone tells me what to type, I can make the packages on my desktop
machine.  I only have Linux/Intel, though (and Redhat 5.1, not 5.2 yet).

 - J<

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 18 Jan 1999 21:59:50 -0500

> machine.  I only have Linux/Intel, though (and Redhat 5.1, not 5.2 yet).

Jason,
I didn't forget I just need to remind myself what to type 
what we basically need is to for you to keep the rpm spec file your self or add it to the CVS tree so we can access it from the tar file 

Once we have the spec file which I just pulled out of the rpm from redhat's site you simply move the source to
/usr/src/redhat/SOURCES
then type rpm -bb /usr/src/redhat/SPECS/fvwm2.spec  # or
rpm -tb fvwm2.spec #if it is in the tar.gz file 
then move /usr/src/redhat/RPMS/i386/fvmw2-* to ftp site

this spec file builds a package for fvwm2 and fvwm2-icons

Now two questions there are two patches that get applied in the rpm the first is 
to adjust the path to perl on redhat systems
the second makes a change to FvwmM4 and FvwmCPP
this second one someone needs to look at to see if it should go into CVS

as for perl is there a way in config to set the path to perl in the scripts?

--- fvwm-2.1.4/extras/FvwmConsole/FvwmConsoleC.pl.perl	Fri Nov 13 14:36:14 1998
+++ fvwm-2.1.4/extras/FvwmConsole/FvwmConsoleC.pl	Sun Dec  6 03:25:18 1998
@@ -1,4 +1,4 @@
-#!/usr/local/bin/perl
+#!/usr/bin/perl
 #    $0 - Front end of FvwmConsole
 #    FvwmConsole server must be running
 
--- fvwm-2.1.4/utils/BuildXLockMenu.perl	Tue Oct 13 19:03:21 1998
+++ fvwm-2.1.4/utils/BuildXLockMenu	Sun Dec  6 03:26:01 1998
@@ -1,5 +1,4 @@
-#!/afs/eda/u/hines/bin/perl
-#!/bin/perl
+#!/usr/bin/perl
 #
 # Author: Charles K. Hines
 #
--- fvwm-2.1.4/modules/FvwmCpp/FvwmCpp.c.FVWMDIR	Thu Nov  5 21:23:00 1998
+++ fvwm-2.1.4/modules/FvwmCpp/FvwmCpp.c	Mon Dec  7 02:06:43 1998
@@ -335,6 +335,7 @@
 
     fputs(MkDef("OPTIONS", options), tmpf);
 
+    fputs(MkDef("FVWMDIR", FVWM_MODULEDIR), tmpf);
     fputs(MkDef("FVWM_MODULEDIR", FVWM_MODULEDIR), tmpf);
     fputs(MkDef("FVWM_CONFIGDIR", FVWM_CONFIGDIR), tmpf);
     
--- fvwm-2.1.4/modules/FvwmM4/FvwmM4.c.FVWMDIR	Thu Nov  5 21:23:04 1998
+++ fvwm-2.1.4/modules/FvwmM4/FvwmM4.c	Mon Dec  7 02:05:51 1998
@@ -364,6 +364,7 @@
 
   fputs(MkDef("OPTIONS", options), tmpf);
 
+  fputs(MkDef("FVWMDIR", FVWM_MODULEDIR), tmpf);
   fputs(MkDef("FVWM_MODULEDIR", FVWM_MODULEDIR), tmpf);
   fputs(MkDef("FVWM_CONFIGDIR", FVWM_CONFIGDIR), tmpf);

---

From: Tim Phipps <[email-masked]>
Date: Tue, 19 Jan 1999 15:22:29 +0000

> this second one someone needs to look at to see if it should go into CVS

This shouldn't go into CVS.  I'm fairly sure this is for the
AnotherLevel stuff that RedHat ships.  It's a config manager based on m4
and it probably uses the env variable FVWMDIR.  The man pages for
FvwmCpp/M4 both mention FVWM_MODULEDIR and neither mention FVWMDIR.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 19 Jan 1999 10:40:49 -0500

bg> as for perl is there a way in config to set the path to perl in
  bg> the scripts?

This can certainly be done (we can find perl during configure time, then
create these scripts using that pathname), but it's too late for 2.2
(IMO).

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 19 Jan 1999 10:48:32 -0500

> create these scripts using that pathname), but it's too late for 2.2

So it sounds like we are saying to leave both patches as patches and not mygrate them in, maybe bringing the perl stuff into config later.

So Jason or whoever is building the rpm needs to 

cp poth patches plus the icons tar ball into
/usr/src/redhat/SOURCES
then when a new fvwm2 release hits it will need to be placed there as well
then 
rpm -bb /usr/src/redhat/SPECS/fvwm2.spec 
of course the version number in the spec file will be need to be edited as well and an entry put in the changelog at the bottom of the file.

Then you can ftp /usr/src/redhat/RPMS/fvwm2.... to 
our ftp site as well as incoming.redhat.com to publish the rpm to the redhat mirrors .

Brad

---

From: Michael Han <[email-masked]>
Date: Tue, 19 Jan 1999 10:36:26 -0800

Previously...
>what we basically need is to for you to keep the rpm spec file your
>self or add it to the CVS tree so we can access it from the tar file 
>
>Once we have the spec file which I just pulled out of the rpm from
>redhat's site you simply move the source to
>/usr/src/redhat/SOURCES

Do you think we should just use the RedHat-provided spec file? Thing
about it is that ISTR that it does the Imake-style install to
/usr/X11R6 tree. Not only that, fvwm being GNU-style, things would end
up in odd places like /usr/X11R6/libexec/fvwm/... Just an observation.

While we're on the subject of the spec file, IMHO it belongs in the
CVS tree as fvwm.spec.in (there's version-specific stuff in it that
would be nicely handled by auto*. That way the rpm will build an fvwm
the way fvwm-workers expect... Just a thought.
-- 
[email-masked]
I will not skateboard in the halls
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 19 Jan 1999 15:04:06 -0500

> up in odd places like /usr/X11R6/libexec/fvwm/... Just an observation.

As i said above I did just pull out the spec file from the current run of rpms that redhat creates for fvwm2, so everything should end up where it is expected to.
> the way fvwm-workers expect... Just a thought.

I would second this there is only one line that refrences the current version and this could easily be filled in by config.

Brad