Subject: Re: mouse bindings

From: Kent Howard <[email-masked]>
Date: Fri, 1 Jan 1999 14:17:58 -0800

I carefully began to comment out stuff in my .fvwm2rc to see if
the problem would clear up.  When I commented out the line

Style "*" ClickToFocus

with everything else being the same as before, the bindings began
to work properly.  If you want to reproduce the bug, this minimal
.fvwm2rc works for me.

Style "*" ClickToFocus
Mouse 0  T N Move
Mouse 0  T M WindowShade
Mouse 0 FS A Resize

When you meta-click in the title bar, you'll be put into Resize.
Comment out the Style line and then WindowShade will work.

On Thu, Dec 31, 1998 at 10:19:38AM +0100, Dominik Vogt wrote:
+----------
| I still can't reproduce it. I need some more information:
| 
| 1) Are you 100% sure there are no other bindings in your .fvwm2rc
|    that interfere with this?
+----------

Don't know how to be 100% sure, but it sure doesn't look like
there are any bindings that would interfere.

+----------
| 2) Does it fail with a .fvwm2rc that has nothing more than these
|    three lines?
+----------

Nope, but YES if 'Style "*" ClickToFocus'

+----------
| 3) What X server do you use? Which version number?
+----------

XFree86 3.3.2 on Linux 2.0.36 (x86)

+----------
| 4) Is your num-lock key active? Does it work if you press it once?
+----------

Nope, Nope.

Thanks,
- Kent
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Jan 1999 07:00:07 +0100

> Comment out the Style line and then WindowShade will work.

Ah, thanks. That should suffice to track the problem.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].