Subject: FvwmPager & focus handling

From: Matthias Clasen <[email-masked]>
Date: Sat, 9 Jan 1999 22:04:40 +0100

Is it a known problem that the focus handling of the pager isn't
quite icccm compliant ? Clicking with the middle button on  xclock 
in the pager takes the focus away from my xterm although xclock
uses the "No Input" model.  

Matthias

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 10 Jan 1999 00:48:14 +0100

> uses the "No Input" model.  

I don't see anything like this in the TODO/BUGS files. This
might be a limitation of the module interface. I don't think
the pager can tell fvwm to focus the window only if it accepts
input.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 11 Jan 1999 21:39:35 +0100

> the pager can tell fvwm to focus the window only if it accepts

The little patch below seems to do it (but it has been only minimally
tested).

Matthias

--- x_pager.c.orig	Mon Jan 11 21:10:11 1999
+++ x_pager.c		Mon Jan 11 21:10:34 1999
@@ -1558,9 +1558,9 @@
           usleep(5000);
           XSync(dpy,0);
	     if(t->flags & ICONIFIED)
-	         XSetInputFocus (dpy, t->icon_w, RevertToParent,
Event->xbutton.time);
+            SendInfo(fd, "Focus", t->icon_w);
	       else
-	           XSetInputFocus (dpy, t->w, RevertToParent,
Event->xbutton.time);
+            SendInfo(fd, "Focus", t->w);
	     }
     }
 }
@@ -1889,9 +1889,9 @@
       SendInfo(fd,"Raise",t->w);
 
       if(t->flags & ICONIFIED)
-      XSetInputFocus (dpy, t->icon_w, RevertToParent, Event->xbutton.time);
+        SendInfo(fd, "Focus", t->icon_w);
       else
-      XSetInputFocus (dpy, t->w, RevertToParent, Event->xbutton.time);
+        SendInfo(fd, "Focus", t->w);
     }
 
 }

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Jan 1999 21:32:33 +0100

> The little patch below seems to do it (but it has been only minimally

I have applied the patch but had a little problem with it.
It seemed to be strangely formatted and could only be applied
by hand. Could that be some strange setting of your editor?
You should send your patches as attachment so that the mail
program doesn't touch it to break long lines.

Bye

Dominik

---

From: Matthias Clasen <[email-masked]>
Date: Mon, 11 Jan 1999 21:39:35 +0100

Matthias

       if(t->flags & ICONIFIED)
 
 }

--k1lZvvs/B4yU6o8G--

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].