Subject: Re: FVWM: restart with no decor

From: "Randall S. Winchester" <[email-masked]>
Date: Fri, 8 Jan 1999 10:47:14 -0500 (EST)

On Fri, 8 Jan 1999, Dominik Vogt wrote:

: On Thu, Jan 07, 1999 at 01:36:12PM -0800, Frederic Barrat wrote:
: > 
: > Hi,
: > 
: > I'm having a problem whenever I restart fvwm2. I get some default
: > decoration on the windows instead of what is in my .fvwm2rc file. Yet,
: > everything works fine when I start fvwm2 the first time.
: > 
: > I get the following error:
: > [FVWM][executeModule]: <<ERROR>> No such module
: > /home/fxb/fvwm2/libexec/fvwm/2.1.4/ BorderStyle
: > (the list goes on and on with all the commands related to style).
: > 
: > I don't quite understand why "BorderSytle" is interpreted as a module.
: > 
: > Does anyone have the same problem?
: 
: I remember somebody had the same problem but with
: SnapAttraction instead of BorderStyle. Perhaps
: we can reproduce it with your config file.
: 
: ---- 10 minutes later ----
: 
: No, I don't get this. Is it possible you have some
: very old fvwm somewhere in the PATH that gets
: executed when you restart?

The reason is that there is a subtle change in the requiremnets in the
.fvwm2rc file that were accepted previously. I think the nuance may
have occurred when I ran the conversion script to go from fvwm1 to fvwm2
but it has been so long that I forget now.

Here is what I had to change in our global fvwm2rc file. It works correctly
with fvwm2*.

< *FvwmButtons(2x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 1
< # *FvwmButtons(4x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 3
---
> *FvwmButtons(2x1 Swallow "FvwmPager" "FvwmPager 0 1")
> # *FvwmButtons(4x1 Swallow "FvwmPager" "FvwmPager 0 3")

Randall

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Jan 1999 17:19:42 +0100

> > # *FvwmButtons(4x1 Swallow "FvwmPager" "FvwmPager 0 3")

I don't catch what this has to do with the BorderStyle/Restart
problem. Please elaborate. Apart from this I think the problem
was solved.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].