Subject: WindowShade vs. FocusFollowsMouse

From: Matthias Clasen <[email-masked]>
Date: Fri, 15 Jan 1999 02:28:54 +0100

Another WindowShade buglet with focus-follows-mouse and shading/unshading
added to the Window-Ops menu: 

1) pop up the Window-Ops menu of a shaded window 
  (the window will have the focus while the menu is open)

2) select "unshade". 

3) The menu pops down and the window is unshaded

4) the focus ends up on the window which was under
   the "unshade" item in the menu.

-- 
Matthias Clasen, 
Tel. 0761/203-5606
Email: [email-masked]
Mathematisches Institut, Albert-Ludwigs-Universitaet Freiburg
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Jan 1999 02:43:19 +0100

>    the "unshade" item in the menu.

I see no bug. If the shaded window was raised above the other
window it will still be and receive the focus. If it was lowered
below it the other window will get the focus. May be a bit
unintuitive if the window and the shaded window don't overlap
but 100% correct. Surely we don't want to raise a window
because it's being unshaded.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Matthias Clasen <[email-masked]>
Date: Fri, 15 Jan 1999 21:48:44 +0100

Sorry, it seems to be not my day... I tried again and could not 
reproduce it...but I swear it was there...