Subject: Key + Mouse

From: Tomas Ogren <[email-masked]>
Date: Wed, 6 Jan 1999 03:52:54 +0100

I'm having some serious problems with my key+mouse bindings...

For instance..

Mouse 1 W       M       Move

Meta+mouse1 should be move.. but I only get a changed cursor, but no
movement etc.. Seems like no binding that involves a key + mouse works..
Worked fine cvs -1week...

Keybindings works.. Mousebindings works... but not together..

Anyone..?

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 6 Jan 1999 04:09:39 +0100

> I'm having some serious problems with my key+mouse bindings...

Ok.. nailed it down...

events.c:203
#if 0
  /* domivogt (2-Jan-1999): Why were button presses treated differently here?
   * Causes a bug with ClickToFocus. */
  if((e->type == KeyPress)&&(e->xkey.subwindow != None))
    *w = e->xkey.subwindow;

  if((e->type == ButtonPress)&&(e->xbutton.subwindow != None)&&
     ((e->xbutton.subwindow == t->w)||(e->xbutton.subwindow == t->Parent)))
    *w = e->xbutton.subwindow;
#else
  if(e->xkey.subwindow != None)
    *w = e->xkey.subwindow;
#endif

If I change this to #if 1, the bindings works again...

<wild speculations>
The e->type == ButtonPress must be triggered when it's key + mouse, and
thus applies the op to a different window...
</wild speculations>

/Tomas

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Jan 1999 10:55:29 +0100

>   if(e->xkey.subwindow != None)

Oops, have to use e->xbutton.subwindow for a button press.

> thus applies the op to a different window...

I don't understand exactly what you mean, but what happened is:
When you click into the window the subwindow has a completely
weird id that is not related with any visible part of the window.
This has nothing to do with key presses. The difference between
key and button presses is that button presses are bound to
the client window (or its parent) while keystrokes are bound to
the frame window. I've no idea why.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 06 Jan 1999 08:40:31 -0500

Dominik Vogt <[email-masked]> writes:
> The difference between

Perhaps because button presses on the frame have a purpose,
but keypresses while the mouse is on the frame should be passed
to the window.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].