Subject: Test Center (InfoWorld) -- A challenge for fvwm2

From: "Randall S. Winchester" <[email-masked]>
Date: Thu, 21 Jan 1999 14:16:59 -0500

http://www.infoworld.com/cgi-bin/displayTC.pl?/990118spotlight.htm

This article is about Linux on the Desktop, but there are some
interesting comments on the Window managers avaliable on Linux.

Though fvwm2 is the default on RedHat, it was downplayed infavor of KDE.

FYI,
Randall

<!-- for no Iframes Layers Capable Browsers --> <A HREF="http://ad.doubleclick.net/jump/idg.infoworld.com/tc;sz=468x60;ord="> <IMG SRC="http://ad.doubleclick.net/ad/idg.infoworld.com/tc;sz=468x60;ord="></A>

January 18, 1999
Tech Spotlight: Insight into cutting-edge technologies
Next stop, the desktop?

AT A GLANCE
Linux on the desktop

The variety and maturity of Linux applications and desktop environments has never been greater -- and more are in the pipeline for 1999. However, for those who are not comfortable at a command line, Linux can be inscrutable to install and configure. The result is that Linux is not yet a viable alternative for corporate desktops. Working within Linux nearly equals the Windows 98 experience, but working with Linux is more difficult than using Windows 3.1.
Pros: Growing number of free or inexpensive, full-featured productivity applications; sophisticated, attractive desktop environments.
Cons: Command line required to make system changes; hardware incompatibilities; no versions of many corporate applications.

Related article:
One user's first kernel shows where Linux needs work to become a desktop alternative

By Chip Brookshaw

At issue: Linux on the desktop - The open-source operating system has been so wildly popular on many types of servers that some think it could be a credible alternative to Microsoft Windows on the desktop.

As the Linux phenomenon has spread, visions of its success have grown as well, fed by a perennial desire for an alternative to Windows. Several platforms, including OS/2 and the Macintosh, have already battled Windows for the desktop, and in 1998 Linux was enlisted for the same campaign. One year ago, few outside the Linux developer community had even heard of the upstart OS, and longtime users can claim that this Unix variant for inexpensive PC hardware was neither intended nor engineered to be a desktop Windows-killer. Regardless, there is a growing view that if Linux can take share on the server (as it has), it could take seats on the desktop.
There are a number of perceived benefits to Linux becoming a desktop alternative to Windows. Linux is free to use and distribute, which could save companies a bundle in licensing fees. Several Linux productivity applications are also free or inexpensive, potentially saving even more money. Many also feel that Linux is a far more stable platform than Windows' shaky tower of DLLs and registry settings. And because the Linux kernel is not proprietary, the playing field for application vendors is level. No vendor controls the source code, so no vendor can leverage Linux to its benefit.
Linux has a powerful Unix-like command line, and many Linux pros have no need or desire for a GUI. But if Linux is to become a giant-killer on the desktop, it must be judged against Windows by mainstream users. Given the state of Linux development though, the experience of such users fluent with WIMP (windows, icons, menus, pointer), but not with text prompts, is likely to be a mixed one.
On one hand, several popular window managers provide Linux with WIMP interfaces and file managers that echo many Windows conventions. There are also numerous productivity applications, such as browsers and office suites, available for Linux. For the most part, these applications have a Windows look and feel and offer functionality that is comparable to their Windows counterparts.
Despite the slew of impressive applications and interfaces though, Linux will not be an acceptable corporate alternative to Windows until hardware-compatibility issues are resolved and all aspects of installation and configuration are achievable in the desktop environment. For most users, the learning curve required to transform a Linux box into a "personal" computer is too steep.

HOW IT WORKS. Those interested in using Linux as a desktop OS should acquire one of the prepackaged distributions, which typically comprise a stable kernel and a set of tools and applications that make Linux easier and more worthwhile to use. Depending on the distribution, these sets of extras vary widely. Differences include processor support, installation and configuration utilities, window managers, and bundled applications. There are at least a dozen distributions, but Red Hat Software and Caldera supply two of the most popular. Red Hat Linux 5.2 and Caldera OpenLinux 1.3, respectively, are their most recent versions.
To create a graphical desktop for Linux, a window manager (also called a desktop environment) must be installed atop the kernel. There are scores of window managers. Some are little more than garage hacks; others are the result of large collaborative efforts. Many window managers are further customizable with a vast number of plug-in themes, ranging from functional (a Mac OS look) to whimsical (a carnival motif). Generally, any window manager can be used with any distribution, although there may be installation issues or other incompatibilities.
Red Hat's latest distribution includes three window managers; the default is FVWM2 with a Windows 95 look-alike interface. FVWM2 is functional, but it is only a crude approximation of Windows 95. Although it uses a start button and taskbar along the lower edge of the display, FVWM2 has so many oddities that migrating Windows 95 users to it would be disastrous.
For instance, menus that cascade off the start button often overlap each other, obscuring navigation. Using the scroll bars is frustrating as well. The left mouse button scrolls down, but the right mouse button is required to scroll up. Also, selecting a window's close box briefly turns the cursor into a skull and crossbones -- not very reassuring for a new user.
The K Desktop Environment (KDE), on the other hand, is much more inviting. KDE is the handiwork of the KDE project, a collection of software developers using the open-source model, and Caldera has integrated the software into its OpenLinux distribution. (KDE can also run on Red Hat Linux 5.2.) The Common Desktop Interface (CDE), a window manager that has been available for years on Unix, is another widely used GUI, but KDE has won over many in the Linux community.
With minor differences, KDE follows most standard Windows conventions. For instance, the two-paned file manager has icon and tree views and can be used to browse the Web just like Windows Explorer. Drag-and-drop functionality is available for moving and copying files, and there is a trash can for deleting them. KDE does not have the zooming, sliding menus of Windows 98, but it keeps many other touches, including subtly shaded title bars and tool tips that pop up when the cursor lingers over an icon.
There are two major interface differences between Windows and KDE. By default, KDE uses two taskbars along the display edges: One is a dynamic list of open windows, and one acts as a dedicated application and utility launcher. Although it takes up more screen real estate, KDE's design is more logical. Also, it is easier to customize the launcher taskbar than it is to configure the Programs menu that drops from Windows' start button.
The other important difference, virtual desktops, is something all Linux window managers/desktop environments -- not just KDE -- offer to some degree. FVWM2 and KDE come with as many as eight virtual desktops by default, accessible via buttons on a taskbar. Part of the X Window graphical subsystem, Linux's virtual desktops are a descendant of the days when scarce Unix workstations had to be shared, but they can help individual users organize their work as well. As the name implies, virtual desktops offer separate workspaces that can include any combination of open files, folders, and applications. For instance, you could have a calculator and spreadsheet open in one, a browser open in another, and a command line and file manager open in a third.

THE ENTERPRISE ROLE. Linux desktop environments are relatively mature, but without applications all of those pretty faces are not much use in a corporate setting. Fortunately, several vendors have developed free, or relatively inexpensive, Linux versions of their software. They are the reason that Linux can even be considered a desktop alternative to Windows.
Most Linux distributions include Netscape Communicator, with its standard package of browser, e-mail, discussion group, and HTML editor clients. The browser matches the features of the Windows version, including Java and Secure Sockets Layer (SSL) support, and provides an easy way for users to download the productivity applications that many vendors have made available.
The first program some will want to grab off the Web is Corel's WordPerfect 8 for Linux, Personal Edition. The downloadable version is free, although it is limited to personal use and does not include documentation or charting/drawing functions. Still, the Personal Edition is a powerful word processor that can translate Microsoft Word documents. For business customers, a full-featured, shrink-wrapped version will soon be available priced at about $50 retail.
Another useful download is Star Division's new StarOffice 5.0, Personal Edition, a productivity package that mimics the look and feel of Windows 98 so closely that it could be one's primary desktop interface for most situations. It is a little confusing at first, but StarOffice puts its Windows 98-like shell over your Linux window manager of choice. StarOffice employs a browserlike file manager, similar to KDE and Windows Explorer, that can be used to navigate both local and Internet content.
StarOffice also includes Microsoft Officelike and Outlook-like applications: word processor, spreadsheet, presentation graphics program, e-mail package, calendar, and so on. It is an impressive bundle, and it is free for personal use. (Star Division is also selling a version for corporate customers priced at $169.) Our preliminary tests on StarOffice revealed some bugs, but it is worth a trial.
Another popular Linux office suite is Applix's Applixware, which includes a word processor, spreadsheet, presentation graphics application, paint program, and other tools. Red Hat Linux comes with a demo version of Applixware; the fully functional edition is bundled with S.u.S.E.'s Linux distribution, or it can be purchased from Applix's Web site for $99.

TECHNOLOGY TIME LINE. Two important desktop-related releases are expected this year from leading Linux developers, but other vendors remain uncommitted to the platform. This could change if Linux grows as exponentially in 1999 as it did in 1998, but for now many of the applications that corporate users rely on are not available for Linux.
The lack of a Linux version of Lotus Notes is particularly glaring, given that product's large share of the corporate desktop messaging market. Lotus offers a version of Notes for Solaris but will say only that it is considering a Linux port. Also, despite a Linux image-editing tool called GNU Image Manipulation Program (GIMP), graphics professionals have little choice but to stick with Macintosh or Windows machines. Adobe and Quark officials said they have no plans to offer Linux versions of Photoshop and Quark, respectively. (Even if they did, substandard font support makes Linux an unattractive graphics platform.)
Not surprisingly, Microsoft has no plans to port its applications, including Internet Explorer, to a potential rival. On the bright side, Netscape said it will keep the Linux version of Communicator up to date, despite the company's acquisition by America Online.
One important software release scheduled for 1999 is the KDE project's KOffice, currently in alpha stage. KOffice includes familiar productivity applications (a word processor, spreadsheet, presentation graphics program, and so on) and may turn out to be a better alternative for KDE users than StarOffice or Applixware because of its integration with that desktop environment.
The most anticipated development, however, is Red Hat's next Linux distribution, due in the first half of the year. The new Red Hat release will use GNU Network Object Model Environment (GNOME) instead of FVWM2 as its default desktop environment. GNOME is not tied to any one window manager, but it is most often used with Enlightenment, a slick KDE-like interface. Although Red Hat has not officially committed to using Enlightenment, a GNOME/Enlightenment combination would be a huge improvement over FVWM2, both in looks and brains.
Still, regardless of the variety and sophistication of its desktop environments and applications, Linux will not be a credible desktop alternative for corporate users until configuration and hardware-compatibility issues are greatly improved. It is a lot to expect so soon -- especially considering Microsoft, Apple, and others have been working on similar issues since the mid-1980s. But given the success thus far of the open-source model, and the size and enthusiasm of the developer community, nothing that happens surrounding Linux should be a surprise. Just look how far things came in 1998.
Chip Brookshaw is an editor at large at the InfoWorld Test Center. He can be reached at [email-masked]. Technology Analyst Kevin Railsback, Senior Analyst Jeff Symoens, and InfoWorld contributor Tom Yager provided background for this article.

Your two cents. Tell the lab what you want to see tested.

Copyright © 1999 InfoWorld Media Group Inc.

| SiteMap | Search | PageOne | Reader/Ad Services |
| Enterprise Careers | Opinions | Test Center | Features |
| Forums | Interviews | InfoWorld Print | InfoQuote |

---

From: [email-masked] (Paul D. Smith)
Date: 21 Jan 1999 16:25:14 -0500

%% "Randall S. Winchester" <[email-masked]> writes:

  rsw> http://www.infoworld.com/cgi-bin/displayTC.pl?/990118spotlight.htm

  rsw> This article is about Linux on the Desktop, but there are some
  rsw> interesting comments on the Window managers avaliable on Linux.

  rsw> Though fvwm2 is the default on RedHat, it was downplayed infavor
  rsw> of KDE.

Of course, comparing fvwm2 (a window manager) to KDE (a desktop
environment) is like comparing your kitchen to your neighbor's house
("Wow!  He has a bathroom!" :).

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Thu, 21 Jan 1999 18:28:24 -0500

On 21 Jan 1999 16:25:14 -0500
[email-masked] (Paul D. Smith) 
> ("Wow!  He has a bathroom!" :).

Oh, just another journalist who hasn't done his research properly and
has no idea what he's talking about. For example:

  "GNOME is not tied to any one window manager, but it is most often
   used with Enlightenment, a slick KDE-like interface."

Hmmmm. My advice: ignore it.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].