Subject: cvs checkout a single file?

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Jan 1999 19:06:18 +0100

Any ideas how I can check out a single file or multiple
files in cvs instead of a whole module?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Wed, 27 Jan 1999 19:14:23 +0100

> files in cvs instead of a whole module?

cvs co module/the/file/you/want

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 28 Jan 1999 22:34:16 +0100

> cvs co module/the/file/you/want

Er, umm, I think this was the first thing I tried. Or is it
important to start above the local tree and specify the module?

Bye

Dominik

---

From: Steve Robbins <[email-masked]>
Date: Thu, 28 Jan 1999 21:06:45 -0500 (EST)

> important to start above the local tree and specify the module?

Yes.

Or you can be *IN* the tree and use "update" instead:

	(from "module" directory)
	cvs update the/file/you/want

This way has the advantage that you don't need to specify the cvs root
directory (via CVSROOT or '-d').

By the way: "cvs checkout --help" will tell you all sorts of amazing
things.