Subject: Re: 2.2

From: Bob Woodside <[email-masked]>
Date: Tue, 26 Jan 1999 09:46:33 -0500

Dominik Vogt <[email-masked]> wrote:
> The button2-drag-warps should definitely be fixed. I wonder how
> this came in.

    Probably just getting in a hurry at the last minute. It's an easy
fix - don't issue the Focus if moved - and I'll put this in this
evening.

> The button2-click-warps problem is another story however. As
> a developer I in fact use it most of the time to give the focus to
> a window on another page (for testing). But I think the average
> user has no need of focussing windows off screen. This seems
> like an improvement to me (but it has to be documented if we
> keep it this way).

    That's why I suggested that it be an option: FVWM needs to
keep both the power users and the average users happy. I'd like
to look at this this evening, but I think for 2.2 I'd be happy enough
with documenting the change. I'm not sure average users will
be using the Pager to set focus on windows, anyway, but you never
know...till you change something.

> Matthias' reasoning that sending fvwm2 a Focus command looks more
> logical seems right to me too.

    I agree.

- Bob

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 17:45:35 +0100

On Tue, Jan 26, 1999 at 09:46:33AM -0500, [email-masked] wrote:
> with documenting the change.

No, that's what I want to avoid. There is no need to break the old
behaviour which may upset some people and then give it back with
a patch in a later version. It's better to do it in one step to
avoid confusion. I'd like to remove this fix for focussing no-focus
icons and do it right immediately after 2.2.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Tue, 26 Jan 1999 21:50:15 -0500 (EST)

> icons and do it right immediately after 2.2.

	OK. Could you or Matthias lend a hand on this one, then?
I have no idea what the code looked like before the change.

- Bob

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Jan 1999 18:41:41 +0100

> I have no idea what the code looked like before the change.

I've attached the mail with the original patch.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 27 Jan 1999 19:09:09 +0100

> I've attached the mail with the original patch.

THe patch is malformed so you'll have to make the changes
by hand (only whitespace trouble).

Bye

Dominik

---

From: Bob Woodside <[email-masked]>
Date: Wed, 27 Jan 1999 18:18:52 -0500 (EST)

> by hand (only whitespace trouble).

	Thanks, Dominik. I'll put the un-patch in later this evening.
I still hate to do it, but I think you're probably right: it's a
little too late in the game to try to figure out how to do this one
right before 2.2. We have enough bug-squashing to do without possibly
introducing more of the little critters.

- Bob

---

From: Bob Woodside <[email-masked]>
Date: Wed, 27 Jan 1999 22:12:52 -0500 (EST)

Dominik Vogt <[email-masked]> wrote:
> > > > 
> > > > I'd like to remove this fix for focussing no-focus icons
> > > > and do it right immediately after 2.2.
> > > > 

	Done. (The first part, that is.)

- Bob