Subject: FVWM CVS: fvwm steve

From: CVS <[email-masked]>
Date: Sun, 17 Jan 1999 17:28:21 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	steve	99/01/17 17:28:21

Modified files:
	.              : Makefile.in README aclocal.m4 configure 
	docs           : BUGS ChangeLog FAQ 
	extras         : Makefile.in 
	extras/FvwmCommand: Makefile.in 
	extras/FvwmConfig: Makefile.in 
	extras/FvwmConsole: Makefile.in 
	extras/FvwmDebug: Makefile.in 
	extras/FvwmGoodStuff: Makefile.in 
	extras/FvwmPipe: Makefile.in 
	extras/FvwmScript: Makefile.in 
	extras/FvwmScript/Scripts: Makefile.in 
	extras/FvwmScript/Scripts/some_nice_icons: Makefile.in 
	extras/FvwmScript/Widgets: Makefile.in 
	extras/FvwmTaskBar: Makefile.in 
	extras/FvwmWharf: Makefile.in 
	fvwm           : Makefile.in 
	icons          : Makefile.in 
	libs           : Makefile.in 
	modules        : Makefile.in 
	modules/FvwmAnimate: Makefile.in 
	modules/FvwmAudio: Makefile.in 
	modules/FvwmAuto: Makefile.in 
	modules/FvwmBacker: Makefile.in 
	modules/FvwmBanner: Makefile.in 
	modules/FvwmButtons: Makefile.in 
	modules/FvwmCpp: Makefile.in 
	modules/FvwmEvent: Makefile.in 
	modules/FvwmForm: Makefile.in 
	modules/FvwmIconBox: Makefile.in 
	modules/FvwmIconMan: Makefile.in 
	modules/FvwmIdent: Makefile.in 
	modules/FvwmM4 : Makefile.in 
	modules/FvwmPager: Makefile.in 
	modules/FvwmRearrange: Makefile.in 
	modules/FvwmSave: Makefile.in 
	modules/FvwmSaveDesk: Makefile.in 
	modules/FvwmScroll: Makefile.in 
	modules/FvwmTalk: Makefile.in 
	modules/FvwmWinList: Makefile.in 
	sample.fvwmrc  : Makefile.in 
	utils          : Makefile.in 

Log message:
Fiddled with some FAQ answers.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 18 Jan 1999 02:05:02 -0500

Whoops; all the makefile.in's are changed back to 1.3d.

Everyone please upgrade to automake 1.4 ASAP, and until you do please
run commit specifying only those files you've changed so you don't flop
the Makefile.in's back again (remember that in 1.3d, etc. the
install-strip is still broken).

I'll commit new 1.4 Makefile.in's again with Chris's patch to
FvwmWinList tomorrow morning (it's building but I need to go to bed :-/)

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Mon, 18 Jan 1999 12:17:24 +0100

> Whoops; all the makefile.in's are changed back to 1.3d.

I'm sorry if this offends anyone, but I don't understand how people
manage to do this all the time. Just run
cvs commit <the files you modified>
instead of just 'cvs commit' and there will be _no_ problem...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Mon, 18 Jan 1999 06:36:35 -0500 (EST)

> Whoops; all the makefile.in's are changed back to 1.3d.

Yeah, I know.  Some of my machines have 1.3d, some have 1.4.  I'm
installing 1.4 on all of them eventually ...

I don't think it is really a problem EXCEPT that the person who builds the
dist tarball should use 1.4.  

--
Steve Robbins                              <[email-masked]>

When I was dead, I wore a strong perfume.
When I was dead, I never left the room.

---

From: [email-masked] (Paul D. Smith)
Date: 18 Jan 1999 10:01:05 -0500

%% Steve Robbins <[email-masked]> writes:

  >> Whoops; all the makefile.in's are changed back to 1.3d.

  sr> I don't think it is really a problem EXCEPT that the person who
  sr> builds the dist tarball should use 1.4.

Well, it's _something_ of a problem in that the wrong stuff is checked
into the tree, and everyone will get a large update when they cvs update
(perhaps with merges or conflicts), and when I make my commit later
it'll re-checkin all the new versions of files.  Also, I don't think
automake will be forced to run every time, only if there are changes
which require it, so it's possible that the person who builds the dist
might still keep the wrong versions of the files.

I guess it only matters for the rest of the week :).