Subject: configure - still no -lncurses

From: Chris Rankin <[email-masked]>
Date: Fri, 15 Jan 1999 22:29:25 -0500 (EST)

Hi,
I have just tried the ncurses support in the ./configure script. The
results are as follows:

Configuration:

  FVWM Version:             2.1.8

  Build extra modules?      yes
  Have ReadLine support?    no
  Have RPlay support?       yes
  Have XPM support?         yes

The output goes like this:
checking for rplay_create in -lrplay... yes
checking for rplay.h... yes
checking for readline in -lreadline... no
checking for readline in -lreadline... (cached) no

The config.log says:
configure:4776: checking for readline in -lreadline
configure:4795: gcc -o conftest -O2 -fomit-frame-pointer -march=pentium   conftest.c -lreadline -lreadline -ltermcap  1>&5
/usr/i586-pc-linux-gnu/bin/ld: cannot open -ltermcap: No such file or directory
collect2: ld returned 1 exit status
configure: failed program was:
#line 4784 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char readline();

int main() {
readline()
; return 0; }
configure:4941: checking for readline in -lreadline
[EOF]

I'm a complete newbie at autoconf etc, but it looks like it didn't
attempt to find ncurses when it couldn't find termcap (cached :-) ?)

Chris.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Sat, 16 Jan 1999 15:37:41 -0500 (EST)

> checking for readline in -lreadline... (cached) no

[ ... ]

> attempt to find ncurses when it couldn't find termcap (cached :-) ?)

Yup!  I checked in a fix for this today.  Please try it when you get a
chance and let us know if it works.