Subject: Fvwm from CVS does not compile.

From: Johan Bengtsson <[email-masked]>
Date: Wed, 20 Jan 1999 09:08:01 +0100 (CET)

The current version in the CVS tree does not compile because of an
error in the automatic configuration files. The error message, and a
suggested fix is attached to this message.

	/ Johan

---

From: Steve Robbins <[email-masked]>
Date: Wed, 20 Jan 1999 08:40:39 -0500 (EST)

> suggested fix is attached to this message.

Sorry, this is my doing.  The correct fix, however is to install autoconf
2.13: 

stever@jeff{fvwm}autoheader
configure.in:159: warning: AC_TRY_RUN called without default to allow  cross compiling
configure.in:213: warning: AC_TRY_RUN called without default to allow cross compiling
stever@jeff{fvwm}grep VERSION config.h.in 
#undef VERSION
stever@jeff{fvwm}autoheader --version
Autoconf version 2.13

[I don't _think_ it also requires automake 1.4 for this to work, but it
might.]

--
Steve Robbins                              <[email-masked]>

When I was dead, I wore a strong perfume.
When I was dead, I never left the room.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johan Bengtsson <[email-masked]>
Date: Wed, 20 Jan 1999 14:51:10 +0100 (CET)

> [I don't _think_ it also requires automake 1.4 for this to work, but it

Toker:~/src/fvwm > autoheader --version
Autoconf version 2.13

Toker:~/src/fvwm > automake --version
automake (GNU automake) 1.3b

I'll upgrade automake to 1.4 and see what happens. 

	/ Johan

---

From: Steve Robbins <[email-masked]>
Date: Wed, 20 Jan 1999 09:03:02 -0500 (EST)

> [I don't _think_ it also requires automake 1.4 for this to work, but it

My mistake.  You DO need automake 1.4 to correctly build the cvs source
tree now.  You can pick it up from ftp://ftp.gnu.org/pub/gnu/automake/

Well, you tried it just once, and found it alright for kicks,
Now you found out that it's a habit that sticks,
And you're an orgasm addict.