Subject: Window options and gradients

From: bjk <[email-masked]>
Date: Mon, 11 Jan 1999 19:06:01 -0800 (PST)

hey folks,

I seem to be having a problem with V/HGradients in a MenuFace with the popup
bound to a titlebar button. Here's what I have:

MenuStyle	"*" Background rgb:4d/42/53, Foreground rgb:ac/a4/bf, \
		    ActiveFore rgb:e5/e1/33, Greyed Grey40, mwm, Animation, \
		    MenuFace HGradient 40 rgb:00/00/00 rgb:00/40/50,\
		    HilightBackOff, SeparatorsShort, Hilight3DOff, \
		    Font -*-helvetica-bold-r-normal--12-*-120-120-*-*-iso8859-1

AddToMenu Window-Ops
+	"Move &To"				PopUp	MoveTo
+	"&Move Window"				Move
+	"&Identify"				Module	FvwmIdent
+	"&Close"				Close
+	"De&lete"				Delete
+	"&Destroy"				Destroy
+	"&Refresh Desktop"			Refresh		

AddToMenu MoveTo
+	"&Text Processing"			MoveToPage 0 0
+	"&Internet & Network"			MoveToPage 0 1
+	"&Multimedia"				MoveToPage 1 0
+	"&Development"				MoveToPage 1 1

It works fine on my 'root menu' but not the popup for button 1 on the titlebar.
Whats wierd is that the root menu looks fine after a fresh start or restart,
but after I start a rxvt terminal or an application and click button 1, the
root menu will change to the solid 'Background' with my MiniIcon from button 1
stuck on the upper-left corner of the root menu. Not sure if this is a bug, or
if I am not using the right sequence for MenuStyle attributes or what.

-- 
bjk <[email-masked]>
FA 8D 92 41 5C 06 1C 70  8C DE 39 C4 61 9A 2C C9

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Mon, 11 Jan 1999 22:28:46 -0800

Previously...
>It works fine on my 'root menu' but not the popup for button 1 on the titlebar

I may be misunderstanding/misremembering here, but I seem to recall
AddTo* lines that don't actually have anything to add causing trouble
for the rcfile parser. So you may want to try closing up the lines I
left unsnipped, into:

AddToMenu Window-Ops    "Move &To"  PopUp MoveTo
...

AddToMenu MoveTo    "&Text Processing"  MoveToPage 0 0

Or it could be something entirely different.
-- 
[email-masked]
I will not teach others to fly
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Jan 1999 16:59:43 +0100

> if I am not using the right sequence for MenuStyle attributes or what.

Great. You're the fourth person to report this and we did not
find a way to reproduce it up to now. You even get two of the
mysterious problems at once (the mini icon and the missing
background). You could do as a *big* favour and try the following:

1) Tell us which version you are using.

2) Rebuild the whole tree in a fresh diretory so we can be sure
   it is a bug in fvwm and not a build problem (that might still
   be an fvwm bug).

3) Mutilate your .fvwm2rc but removing all lines that do not
   influence this bug.

Your help would be appreciated. We can't fix this unless we
know how to reproduce the problem.

Thank you

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Jan 1999 21:19:37 +0100

> for the rcfile parser. So you may want to try closing up the lines I

You remember correctly but I fixed this problem a few months ago.

Bye

Dominik

---

From: bjk <[email-masked]>
Date: Tue, 12 Jan 1999 17:58:44 -0800 (PST)

> 1) Tell us which version you are using.

2.1.7

>    it is a bug in fvwm and not a build problem (that might still

Do you mean just unpack everything and recompile?:

./configure ; make ; make install

I didnt use any special options. Not sure what you mean exactly.

> know how to reproduce the problem.

I think the problem is with the MiniIcon attribute in 'ButtonStyle' or
the MiniIcon attribute in 'Style'. Heres what I have for a minimal
config file for the bug to 'work':

ModulePath /usr/local/libexec/fvwm/2.1.7
PixmapPath /usr/X11R6/include/X11/pixmaps:/usr/local/include/pixmaps
IconPath /usr/X11R6/include/bitmaps
MenuStyle "*" MenuFace HGradient 40 rgb:00/00/00 rgb:00/40/50
ButtonStyle 1 MiniIcon
Style "*" MiniIcon mini-question.xpm
Mouse 2 R A Menu Window-Ops
Mouse 0 1 A Menu Window-Ops
AddToMenu Window-Ops
+ "terminal" Exec rxvt

Clicking button 3 will bring up the menu and it looks ok, then clicking
on 'terminal' and then the titlebar button will screw up. The Window-ops
menu retrieved from the root window wont be messed up anymore because the
focus will be out of the terminal. On my original post, the root menu
was messed up because 'SloppyFocus' was set in a 'Style'. But starting a
program that doesnt have a SloppyFocus attribute then moving the pointer
out to the root window, the root menu looks fine. So it must be something
with a screen/window refresh?

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Jan 1999 12:07:29 +0100

> ./configure ; make ; make install

Yes. but move the old sources to some other place first.

> Mouse 0 1 A Menu Window-Ops

Thanks. Perhaps this will bring us closer to the problem.

> with a screen/window refresh?

Thanks

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Jan 1999 01:52:11 +0100

> Thanks. Perhaps this will bring us closer to the problem.

Nope, no chance. Everything works fine for me. My only hope
is that it's a build problem on your system. Have you tried
rebuilding yet? And if this solves your problem:

a) Did you compile the buggy version in a fresh directory
   or did you recycle your previous source tree? (which
   release?)

b) Did you rerun configure?

c) Did you 'make clean'

d) Did you remove config.cache?

Bye

Dominik

---

From: bjk <[email-masked]>
Date: Mon, 18 Jan 1999 15:19:01 -0800 (PST)

> > with a screen/window refresh?

No problems in 2.1.9 for me anymore (from version 2.1.7). Thanks folks!

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].