Subject: What happened to *FvwmTaskBarQuickFocus

From: Mohsin_Ahmed <[email-masked]>
Date: Fri, 29 Jan 1999 15:49:34 +0530

I had sent a patch for taskbar, which raises a window as soon
as mouse moves to that icon in taskbar. This patch saves me
enornormous time by not ever having to click or keypress to
move between windows.   

thanks, Mohsin.

> From .fvwm2rc new option

*FvwmTaskBarQuickFocus

> addition to FvwmTaskBar.c
int QuickFocus     = False,      // mosh     

> change to goodies.c function

void RedrawTipWindow() 
{
  if (Tip.text) {
    XDrawString(dpy, Tip.win, dategc, 3, Tip.th-4,
                     Tip.text, strlen(Tip.text));
    XRaiseWindow(dpy, Tip.win);  /*****************/

    // 98-11-20 21:28, Mohsin_Ahmed, mailto:[email-masked].
    if( Tip.type > 0 )
        SendFvwmPipe("Focus 0", Tip.win );
  }
}

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 29 Jan 1999 10:55:34 -0600

>>>>> "MA" == Mohsin Ahmed <[email-masked]> writes:

MA> I had sent a patch for taskbar, which raises a window as soon as mouse
MA> moves to that icon in taskbar.

It sounds like a feature.  We're not adding new features, being so close to
a release.  You may wish to keep your patch up to date with CVS and
resubmit it later when we're accepting things other than bug fixes again.

 - J<

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 29 Jan 1999 18:23:20 +0100

> enornormous time by not ever having to click or keypress to

It's queued up along with about twenty other patches that
arrived after we had some kind of 'feature freeze'. Sorry
that I didn't respond to your original mail but I had too
much to do back then. It will not be forgotten and probably
go in right after 2.2 is released.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].