Subject: Notification: incoming/136

From: [email-masked]
Date: Sat, 16 Jan 1999 10:56:28 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/136

Message summary for PR#136
	From: [email-masked]
	Subject: mouse action on window doesn't work
	Date: Sat, 16 Jan 1999 10:56:26 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Tim Phipps <[email-masked]>
Date: Mon, 18 Jan 1999 11:39:19 +0000

> The following entry in my .fvwmrc stopped working in 2.1.7 (was OK in
> 2.1.5):
> 
> Mouse 1         W       M       Function "Move-or-Raise"
> 
Could you send you definition of "Move-or-Raise" and any other functions
that it calls?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 18 Jan 1999 08:15:31 -0500

> > Mouse 1         W       M       Function "Move-or-Raise"
                            ^
> Could you send you definition of "Move-or-Raise" and any other functions

I don't believe thats necessary.  This looks like the well known
2.1.7 Mouse Modifier problem.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 18 Jan 1999 09:53:17 -0800

> Could you send you definition of "Move-or-Raise" and any other functions

OK, but that was not the issue.  The 'Function' can be changed to anything and
still not work (I tested that already).  I isolated the problem the the removed
code in events.c.  The events associated with the application window are lost.

Also, this is not a mouse modifier problem (the 'M' could be 'A' or anything
else and the problem is still there).  This is a problem with lost events
using the 'W'.  Events from the 'X Window' within an 'X Window' (to establish
the frames the app is in a nested window) are lost.

---

From: Dan Espen <[email-masked]>
Date: Mon, 18 Jan 1999 13:17:26 -0500

> the frames the app is in a nested window) are lost.

Perhaps.  However when I changed the above to:

Mouse 1 W M Exec echo "Mouse 1 W M"

It worked with the current CVS source but not with 2.1.7.
Probably just another manifestation of the problem.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 19 Jan 1999 00:34:57 +0100

> Probably just another manifestation of the problem.

Definitely. I believe I've moved this report to duplicate
already and sent a notice to the reporter. Nothing to worry
about unless it fails with 2.1.8 too.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]