Subject: mouseless configurations

From: [email-masked]
Date: Sun, 24 Jan 1999 12:24:47 -0600 (CST)

Full_Name: Neil Zanella
Version: 2.0.46
CVS_Date: 
OS: Linux 2.0.36
X_Server: XF86_Mach64
Submission from: (NULL) (209.128.28.190)

Fvwm2 should have a way to bind movements of the mouse pointer to the
keyboard.
That way Fvwm2 users could work without a mouse.

Theoretically, achieving this configuration should be possible since with
menus that stick to to the root window one can move the pointer to
anywhere
within the viewable area. Hence there must be a way to implement a similar
mechanism
in a more general setting.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 25 Jan 1999 03:08:10 +0100

> Fvwm2 should have a way to bind movements of the mouse pointer to the

It has. Try the CursorMove command:

  Key Left  A S CursorMove -1 0
  Key Right A S CursorMove +1 0
  Key Up    A S CursorMove +0 -1
  Key Down  A S CursorMove +0 +1

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Mon, 25 Jan 1999 20:49:12 -0330 (NST)

Thanks,

That works...

Now, I have a standard 104-key keyboard.
I would like to be able to use the keypad on the right exclusively for 
this purpose. My keypad looks like this:

Num /   *   -

7   8   9   +
            +
4   5   6   +

1   2   3   E
            n
zero  .     t

I would like the buttons to do the following:

/*8 up
9 up-right
6 right
3 down-right
2 down
1 down-left
4 left
7 up-left

5 mouse 1
Zero mouse 2
. mouse 3

Is this possible?

These keypad bindings must however not affect the behavior of parts of 
the keyboard out of the keypad.

Is this possible?

Thanks,

Neil Zanella
[email-masked]

---

From: Neil Zanella <[email-masked]>
Date: Mon, 25 Jan 1999 21:08:20 -0330 (NST)

>   Key Down  A S CursorMove +0 +1

... and what about mouse clicks. Can I bind them to the 
keys F1, F2, and F3?

It looks like it will soon be time to get rid of this mouse ;-)

Thanks for your help,

Neil Zanella

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Jan 1999 10:03:20 +0100

> the keyboard out of the keypad.
 
Only in part. The keys are called KP_n where n is the number.
However there's no command to bind mouse clicks and there is
no way to write one that really works: If fvwm2 creates its
own mouse events they are 'synthetic'. Many badly written
applications ignore synthetic events completely :(

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].