Subject: Re: $(topdir) clutter

From: Dominik Vogt <[email-masked]>
Date: Fri, 15 Jan 1999 17:24:08 +0100

On Fri, Jan 15, 1999 at 10:50:30AM -0500, Steve Robins wrote:
> Hi,
> 
> There are a lot of things accumulating in the top-level directory.  Are
> there any objections to me moving the following to docs:
> 
> FAQ
> BUGS
> TODO
> Y2K-Compliance
> DEVELOPERS

No objections at all.

> Also, the stuff currently in archive look like good candidates for docs:
> 
> announcement-x.y.z (could be renamed docs/ANNOUNCE, as is common practice)
> cvs-howto.txt      (maybe should be incorporated into docs/cvs.html, if
>                     not already)

You can remove the cvs-howto from the tree as it is only a template
that has never been filled. The announcements should be removed too
except the most current beta announcement. This one can go to docs
but should be called ANNOUNCEMENT then.

> automated-tests
> purify
> 
> These last two look like (I haven't used them) good things to distribute
> --- certainly with beta tarfiles, if not with all releases --- because
> they encourage testing.  Hopefully, a suitably motivated person would use
> them, and generate better-quality bug-reports.

Is docs the right place for such things? I would object putting
the purify stuff into the distribution. It creates huge error
output that we don't want to get as bug reports since it is what
is expected. Furthermore it is not machine dependent so there is
not much gain in having people run it. Nobody not on the workers
list should run this test. Apart from this it's 50k big. The
documentation isn't good enough either and the script does not
supports obsolete syntax (e.g. SetMenuStyle).

I have no problem with the automated tests.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Sat, 16 Jan 1999 10:59:19 -0500 (EST)

On Fri, 15 Jan 1999, Dominik Vogt wrote:

> Is docs the right place for such things?

No, I guess not.  I created a new directory "tests" for them.

> I would object putting
> the purify stuff into the distribution.

OK, for now, it is NOT distributed.

> It creates huge error

I guess that it could be distributed with a README describing these
caveats.  This would not cost us so much: the distributed sources are over
4MB, so 50kb more will not be noticed.

--
Steve Robbins                              <[email-masked]>

I'm a member of the Elvis Death Cult.