Subject: Fix (1999-01-02 * fvwm/events.c) is broken

From: [email-masked]
Date: Sun, 17 Jan 1999 11:57:30 -0800

>From ChangeLog:

>1999-01-02  Dominik Vogt  <[email-masked]>
>
>    * fvwm/events.c (HandleButtonPress): removed unnecessary code

The comment in the code says:
/* domivogt (2-Jan-1999): Why were button presses treated differently here?
   * Causes a bug with ClickToFocus. */

However, removing this code make events headed to the application window
that are intended to be handled my the window manager disappear.  For
example I have in my .fvwm2rc (I use a borderless config to save screen space):

Mouse 1         W       CM      PopUp "Window-Ops"
Mouse 1         W       M       Function "Move-or-Raise"
Mouse 2         W       M       Function "Resize-or-Lower"
Mouse 3         W       M       Iconify

These no longer work.  The events are gone, and the application doesnt even
get them.  Simply changing the code back in events.c fixes both aspects of this
problem.  Hopefully whatever the ClickToFocus bug is can be fixed some other
way.

--
Visit the official FVWM web page at <URL:http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 19 Jan 1999 00:26:04 +0100

> problem.  Hopefully whatever the ClickToFocus bug is can be fixed some other

I need to know what code you are using. If you are running 2.1.7
the answer is: yes it's buggy and it has been fixed properly
in CVS. If it's current CVS source you are using we'll have to
fix it.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]