Subject: Patch: FvwmButtons

From: Jui-Hsuan Feng <[email-masked]>
Date: Wed, 16 Dec 1998 23:37:54 CST

Hi folks,

After a panel pops up, it is supposed to close up in the same manner. The
patch at the end of this mail will make FvwmButton remember which direction
to close up, if it's not told explicitly.

--
J. Joshua Feng                            (O)608/262-3640
Electrical & Computer Engr., Univ. of Wisconsin - Madison
http://www.cae.wisc.edu/~fengj  [email-masked]

Index: FvwmButtons.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmButtons/FvwmButtons.c,v
retrieving revision 1.12
diff -u -r1.12 FvwmButtons.c
--- FvwmButtons.c       1998/12/16 18:04:44     1.12
+++ FvwmButtons.c       1998/12/17 04:57:58
@@ -1729,6 +1729,8 @@
  *   uber->y       = y position to start the panel wrt the button b
  *   uber->w       = xneg
  *   uber->h       = yneg
+ *   uber->n       = cast to 'char' to record of the direction
+ *   
  *   CurrentPanel  = the panel where the button b was pressed to popup a new
  *                   panel
  */
@@ -1759,7 +1761,7 @@
   /* PanelWin is found */
   PanelWin = p->uber->IconWinParent;
 
-  direction = b ? b->action[0][6] : 'u';
+  direction = b ? b->action[0][6] : (char) p->uber->n;
 
   if (p->uber->swallow)
   {
@@ -1895,6 +1897,7 @@
       XMoveResizeWindow(Dpy, PanelWin, x, y, w, h);
     }
 
+    p->uber->n = (int) direction;
     p->uber->swallow = 1;
   }
 }
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Dec 1998 22:18:11 +0100

> to close up, if it's not told explicitly.

applied

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]