Subject: Creeping FvwmWinList

From: Dan Espen <[email-masked]>
Date: Thu, 03 Dec 1998 08:34:18 -0500

I almost never use this module,  but yesterday I  found that it creeps
up and to the left on resizes.  I seem to remember  more than one time
this module has been fixed for this problem.

Here's my config:

*FvwmWinListBack CadetBlue
*FvwmWinListFore White
*FvwmWinListFont 7x14bold
*FvwmWinListAction Click1 Iconify -1,WarpToWindow 50 50
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry -0-0

It does come up with the correct SouthEast Geometry.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Thu, 03 Dec 1998 14:21:00 +0000

> It does come up with the correct SouthEast Geometry.

I did some fixes for initial placement.  I use MWM style borders and it
doesn't wander.  I just tried FVWMBorder and it does wander.  I'll have a
go at narrowing this down.

I've attached some window grabs of the FVWMBorder frame around
FvwmWinList.  FVWMBorders style windows have a one pixel width border on
the frame.  Is this really how they are supposed to look? What I mean is
that the top and left frames have a 2 pixel relief of topshadow surrounded
by the one pixel border, the right and bottom frames have a one pixel
relief of bottomshadow that with the one pixel border looks like a two
pixel relief. There's an extra pixel of bottomshadow at the top and left
of the bottom and right frames and one at the bottom of the titlebar.

Cheers,
Tim.

---

From: Tim Phipps <[email-masked]>
Date: Thu, 03 Dec 1998 17:48:55 +0000

Don't hold the presses!

Here's a little patch to fix some creeping and also to help FvwmTaskBar
autohiding.

Could you try this out Dan and see if it fixes your creeping FvwmWinList?

Jason, could I have update access?

Cheers,
Tim.

Index: fvwm/borders.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/borders.c,v
retrieving revision 1.3
diff -u -B -b -u -r1.3 borders.c
--- fvwm/borders.c	1998/11/06 02:22:50	1.3
+++ fvwm/borders.c	1998/12/03 17:42:35
@@ -1338,10 +1338,10 @@
     tmp_win->orig_wd = w;
     tmp_win->orig_ht = h;
   }
-  if (x >= Scr.MyDisplayWidth + Scr.VxMax - Scr.Vx-16)
-    x = Scr.MyDisplayWidth + Scr.VxMax -Scr.Vx - 16;
-  if (y >= Scr.MyDisplayHeight+Scr.VyMax - Scr.Vy -16)
-    y = Scr.MyDisplayHeight + Scr.VyMax - Scr.Vy - 16;
+  if (x >= Scr.MyDisplayWidth + Scr.VxMax - Scr.Vx + tmp_win->bw)
+    x = Scr.MyDisplayWidth + Scr.VxMax -Scr.Vx - 1 + tmp_win->bw;
+  if (y >= Scr.MyDisplayHeight + Scr.VyMax - Scr.Vy + tmp_win ->bw)
+    y = Scr.MyDisplayHeight + Scr.VyMax - Scr.Vy - 1 + tmp_win->bw;
 
   if((w != tmp_win->frame_width) || (h != tmp_win->frame_height))
     Resized = True;
@@ -1569,7 +1569,7 @@
     client_event.xconfigure.height =h-2*tmp_win->boundary_width -
       tmp_win->title_height;
 
-    client_event.xconfigure.border_width =tmp_win->bw;
+    client_event.xconfigure.border_width = 0;
     /* Real ConfigureNotify events say we're above title window, so ... */
     /* what if we don't have a title ????? */
     client_event.xconfigure.above = tmp_win->frame;
Index: fvwm/events.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/events.c,v
retrieving revision 1.13
diff -u -B -b -u -r1.13 events.c
--- fvwm/events.c	1998/12/02 16:29:49	1.13
+++ fvwm/events.c	1998/12/03 17:42:53
@@ -1373,9 +1373,9 @@
   /* override even if border change */
 
   if (cre->value_mask & CWX)
-    x = cre->x - Tmp_win->boundary_width - Tmp_win->bw;
+    x = cre->x - Tmp_win->boundary_width;
   if (cre->value_mask & CWY)
-    y = cre->y - Tmp_win->boundary_width - Tmp_win->title_height - Tmp_win->bw;
+    y = cre->y - Tmp_win->boundary_width - Tmp_win->title_height;
   if (cre->value_mask & CWWidth)
     width = cre->width + 2*Tmp_win->boundary_width;
   if (cre->value_mask & CWHeight)
Index: extras/FvwmTaskBar/FvwmTaskBar.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/extras/FvwmTaskBar/FvwmTaskBar.c,v
retrieving revision 1.4
diff -u -B -b -u -r1.4 FvwmTaskBar.c
--- extras/FvwmTaskBar/FvwmTaskBar.c	1998/12/02 19:09:37	1.4
+++ extras/FvwmTaskBar/FvwmTaskBar.c	1998/12/03 17:43:11
@@ -3,6 +3,8 @@
  * (Much reworked version of FvwmWinList)
  *  Copyright 1994,  Mike Finger ([email-masked] or
  *                               [email-masked])
+ * Minor hack by TKP to enable autohide to work with pages (leaves 2 pixels
+ * visible so that the 1 pixel panframes don't get in the way)
  *
  * The author makes not guarantees or warantees, either express or
  * implied.  Feel free to use any contained here for any purpose, as long
@@ -341,9 +343,9 @@
 	win_x = win_border = (int)body[10];
 
         if (win_y > Midline)
-          win_y = ScreenHeight - (AutoHide ? 1 : win_height + win_border);
+          win_y = ScreenHeight - (AutoHide ? 2 : win_height + win_border);
         else 
-          win_y = AutoHide ? 1-win_height : win_border;
+          win_y = AutoHide ? 2 - win_height : win_border;
 
         XMoveResizeWindow(dpy, win, win_x, win_y,
                           ScreenWidth-(win_border<<1), win_height);
@@ -1402,9 +1404,9 @@
   ClearAlarm();
 
   if (win_y < Midline) 
-    win_y = /*1*/ - win_height;
+    win_y = 2 - win_height;
   else
-    win_y = (int)ScreenHeight /*- 1*/;
+    win_y = (int)ScreenHeight - 2;
 
   XMoveWindow(dpy, win, win_x, win_y);
 }

---

From: Dan Espen <[email-masked]>
Date: Thu, 03 Dec 1998 13:27:55 -0500

> Could you try this out Dan and see if it fixes your creeping FvwmWinList?

Works fine with my -0-0 geometry with either Fvwm or MWM borders.
Nice work.

The taskbar   seems OK too, although  I  didn't find the old  one that
broken.

> Jason, could I have update access?

Cheers are heard all over fvwm land...

---

From: [email-masked] (Paul D. Smith)
Date: 03 Dec 1998 15:34:49 -0500

%% Tim Phipps <[email-masked]> writes:

  tp> Don't hold the presses!

Does this mean you don't want me to hold 2.1.4 for this?

  tp> Jason, could I have update access?

Hah!  We wore you down at last! :)

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 04 Dec 1998 09:46:23 +0000

> Does this mean you don't want me to hold 2.1.4 for this?

Yes, I don't think these bugs are serious enough and there are still bugs in there.

> Hah!  We wore you down at last! :)

There's an old Irish saying: "When two people tell you you're drunk, go and lie
down"

Cheers,
Tim.