Subject: [PATCH] rebound after draging a window to edges

From: Jui-Hsuan Feng <[email-masked]>
Date: Fri, 18 Dec 1998 22:30:44 CST

Hi folks,

When driging a window to the right edge or bottom edge, it will rebound by
16 pixels, but not on the left or top edges. Here is the patch to change
this behavior. Since I don't know the reason to keep them there, so I just
commented out those lines. Think about this situation: drag a window such
that the top part of the window is out of the display, then 'shade' it.
It's gone! Except for restarting fvwm2, there seems no way to call it back.
Hope some wizard can modify 'WindowList' feature to drag those out of
display windows back (I haven't figure out how :( ).

Regards

--
J. Joshua Feng                            (O)608/262-3640
Electrical & Computer Engr., Univ. of Wisconsin - Madison
http://www.cae.wisc.edu/~fengj  [email-masked]

Index: borders.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/borders.c,v
retrieving revision 1.3
diff -u -r1.3 borders.c
--- borders.c   1998/11/06 02:22:50     1.3
+++ borders.c   1998/12/19 03:03:46
@@ -1338,11 +1338,15 @@
     tmp_win->orig_wd = w;
     tmp_win->orig_ht = h;
   }
+  
+  /* Doesn't seem to help if using unshape to exile a window */
+  /*
   if (x >= Scr.MyDisplayWidth + Scr.VxMax - Scr.Vx-16)
     x = Scr.MyDisplayWidth + Scr.VxMax -Scr.Vx - 16;
   if (y >= Scr.MyDisplayHeight+Scr.VyMax - Scr.Vy -16)
     y = Scr.MyDisplayHeight + Scr.VyMax - Scr.Vy - 16;
-
+  */
+  
   if((w != tmp_win->frame_width) || (h != tmp_win->frame_height))
     Resized = True;
   if ((x != tmp_win->frame_x || y != tmp_win->frame_y))
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 19 Dec 1998 17:31:35 +0100

> When driging a window to the right edge or bottom edge, it will rebound by
       ^^^^^^^
Do you mean 'dragging' or 'bringing'?

> display windows back (I haven't figure out how :( ).

Where is the problem about this? The bug you describe has nothing
to do with the bouncing, does it? And I don't see a way how you
could drag a window completely off the screen.

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]