Subject: Re: FVWM: Problem when 2.0.46 -> 2.1.5, keybindings

From: Dominik Vogt <[email-masked]>
Date: Sat, 12 Dec 1998 12:40:14 +0100

On Sat, Dec 12, 1998 at 10:21:41AM +0200, [email-masked] wrote:
> I have this(and buch of others) in my .fvwm2rc:
> 
> Key Left        A       C       Scroll -100 0
> 
> It worked absolutely fine with 2.0.46. When i changed to 2.1.5 it stopped
> working.

We had a number of these complaints and I found out the reason
for this behaviour: When your application (like rxvt or xterm)
is in application keypad/cursor mode fvwm gets no key events
for certain keys and thus cannot process a key binding. This
happens when you start with a pressed num-lock. My naive
assumption (without any actual knowledge) would be that this is
absolutely correct. Isn't this what 'application cursor mode'
means?

The big question is: did this change between 2.0.46 and 2.1.5?
I can remember that I had this problem myself with rxvt (but not
xterm) and solved it by putting it out of app-mode by a control
sequence from the shell. I think this was some early 2.1.x or late
2.0.47x.

Apart from documenting this I wonder if we can do something about
that (apart from ignoring app-mode (if possible at all)). Could
we just disable application mode when fvwm starts up?

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Sat, 12 Dec 1998 21:25:36 +0100

On 12 December, 1998 - Dominik Vogt sent me these 1.5K bytes:

> for certain keys and thus cannot process a key binding.

I get this in all apps... Xterm, Eterm.. netscape.. gimp.. gtk-stuff..
everything.. I have ctrl-meta-del to popup an FvwmForm, but since
2.1.something the keypress is sent to the app instead of parsed by
fvwm....

> The big question is: did this change between 2.0.46 and 2.1.5?

"Everything" worked in 2.0.46, things stopped working when I jumped onto
the fvwm-cvs bandwagon...

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Austin Donnelly <[email-masked]>
Date: Mon, 14 Dec 1998 10:36:07 +0000

> absolutely correct. Isn't this what 'application cursor mode'

A while ago XFree86 changed the way num-lock was handled.  Previously,
num-lock was never shown to applications, and the Xserver looked after
doing the translation from numbers to cursor commands as appropriate.

Now, num-lock is just another modifier.  This means that if you say in
a config file:

Then this only works when the control modifier only is set.  If you
have num-lock turned on, then both control and num-lock modifiers are
set and this binding is (correctly) ignored.

This is quite an old problem, however.  The change to the X server was
over a year ago now.

Austin

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 14 Dec 1998 20:03:45 +0100

> This is quite an old problem, however.  The change to the X server was

And I don't think that is the reason for the problem.
Fvwm does not even receive a key event and thus cannot
process a binding even if it wanted to. The input seems
to go directly to the application.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Dec 1998 01:00:35 +0100

> the fvwm-cvs bandwagon...

I'm running out of ideas. If you run 2.0.46 and start X, is the
num lock key on or off? What if you start 2.1.x? Is there a change?
I've done a thorough comparison of the changes between 2.0.46 and
2.1.5 and cannot find anything remotely related to keys (except
a patch by me in bindings.c, but I don't see a difference with or
without that). BTW, 2.1.5 and 2.0.46 behave the same for me.
Can you send me the output of 'xmodmap -pk' and 'xmodmap -pke'
from the buggy system? And could you please try to replace
bindings.c with the one from 2.0.46? You'll have to make a small
change: instead of including "../configure.h" in line one you have
to include "config.h".

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 18 Dec 1998 00:10:13 +0100

> > It worked absolutely fine with 2.0.46. When i changed to 2.1.5 it stopped

I've fixed an older patch concerned with key bindings.
Could everyone who saw the problem try again and tell
me if it's gone away?

Bye

Dominik