Subject: Re: crash in menu handling (PR#56)

From: "Philip J. Hollenback" <[email-masked]>
Date: Mon, 7 Dec 1998 18:18:28 -0800

Hello Dominik,

I get the crash with any .fvwm2rc.  Specifically, a .fvwm2rc with just
the line

Exec xclock

produces the crash.

I've compiled and run 2.1.4 on both Linux 2.1.122 and SCO OpenServer
5.0.4c.  The crash only occurs on OpenServer.  I believe that this
configuration may be exposing a bug in the new menu handling code.

Enabling debugging doesn't produce much better info - I included the
tail of my debug log in the problem report.

I have attached the full debug info to this mail.

Any hints on how to better isolate this would be very appreciated.

Later,
Phil.

On 12/07/98, Dominik Vogt wrote:
> I can't reproduce this crash. Would you send me your
> .fvwm2rc please?
> 
> Dominik

-- 
Phil Hollenback
Engineering Services
The Santa Cruz Operation
831-427-7358

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 Dec 1998 04:08:08 -0600 (CST)

Sorry, I didn't mean .fvwm2rc. I need a stack trace:

 -> make fvwm2 coredump
 -> in the directory with the core:
      gdb fvwm2 core
    (you may have to add a path thi get the right fvwm2)
 -> on the gdb propt:
      where
Dominik Vogt (domivogt) <[email-masked]>
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].