Subject: Re: Growing Windows

From: Tim Phipps <[email-masked]>
Date: Tue, 01 Dec 1998 11:22:21 +0000

Hiya,
	just poking around in events.c and there is a bit of code I'm not sure
about.  Line 1370 has the following bit, it's handling a configure
window request. cre is a pointer to the configure request event, tmp_win
is the window being reconfigured.

  if (cre->value_mask & CWX)
    x = cre->x - Tmp_win->boundary_width - Tmp_win->bw;
  if (cre->value_mask & CWY)
    y = cre->y - Tmp_win->boundary_width - Tmp_win->title_height -
Tmp_win->bw;

What looks funny is Tmp_win->bw.  ->bw is always 0.  I'm not sure but
should the fudge factor be Tmp_win->old_bw which is the borderwidth of
the cre window?  I don't think this is the cause of the growing window
problems since it is not using or setting any globals but it might be
messing up in some other circumstances.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 1 Dec 1998 13:05:08 +0100

> messing up in some other circumstances.

Note that cre->window is the client window and Tmp_win is the
fvwm window. I could debug the xterm/active icon bug by putting
lots of fprintfs in this function. If the bug is caused here,
print x/y/w/h whenever they change and you'll probably find
what piece of the logic causes the wrong size. It may help
to print the window ids (plus the window ids of the FvwmWindow).
Perhaps the wrong subwindow of Tmp_win is resized (that was in
fact the case with xterm).

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 02 Dec 1998 16:54:46 +0000

I wrote:
> What looks funny is Tmp_win->bw.  ->bw is always 0.

This is rubbish. Style FvwmBorder windows have a ->bw of one.  I use
MWMBorder so I'd forgotten about the original border decorations.

To the people experiencing growing/wandering windows: are you using
FvwmBorders?
Cheers,
Tim.

---

From: Bob Woodside <[email-masked]>
Date: Wed, 2 Dec 1998 18:03:01 -0500 (EST)

> To the people experiencing growing/wandering windows: are you using

	Yes!  Hmmm....

- Bob

---

From: Tomas Ogren <[email-masked]>
Date: Thu, 3 Dec 1998 08:25:02 +0100

> > To the people experiencing growing/wandering windows: are you using

I'm using MWMBorder and I get (at some times) growing windows and
increased frame in xbuffy. Darn.

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 3 Dec 1998 07:43:53 -0500 (EST)

> increased frame in xbuffy. Darn.

I haven't noticed th frame problem in xbuffy but Idefinetlly get growers
with MWMBorders.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous