Subject: OUTSTANDING!

From: German Jose Gomez Garcia <[email-masked]>
Date: Wed, 23 Dec 1998 03:58:14 +0100 (MET)

Just that, I have downloaded the lastes changes from the CVS tree 
and I have to say that Dominik has made a great work with the new 
SetMenuStyle, if we keep fvwm development at this rate it will be the 
best windowmanager under the sun (IMHO of course :-).
	The problem I have has been resolved, so no more on it.
	I also have a suggestion (well maybe I do it myself tomorrow)
what about regular expresion matching on the ChangeMenuStyle ? 

	And finally... soon I will make available a complete distribution
of fvwm2-(last CVS) + icons + .fvwm2rc + some wmapps that should serve as
an intro to fvwm2 wondwerfull world :-)

	I repeat it...

	Great work Dominik, you deserve all the confidence we put on you!

<>-------------------------------------+-----------------------------------<>
   One O.S. to rule them all,          |  German Gomez Garcia
      One O.S. to find them.           |  [email-masked]
   One O.S. to bring them all          |
      and in the darkness bind them.   |  "Wur Qanar Wur Stilor Wur Kas"
<>-------------------------------------+-----------------------------------<>

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 10:44:52 +0100

On Wed, Dec 23, 1998 at 03:58:14AM +0100, [email-masked] wrote:
> SetMenuStyle,

Thanks for the confidence. I'm so embarrassed for all this praise.
But don't hide your light under a bushel. I did no more than
rewriting the syntax. You are the one who did the real work.

> if we keep fvwm development at this rate it will be the 

Isn't it already :) ? I have to confess that I'm nearly burnt
out. In the last months I've spent almost my whole leisure time
on fvwm development (and my cats don't like that a bit :( ).
And the to-do list is growing longer and longer. I may have to
take a few weeks off soon.

> 	The problem I have has been resolved, so no more on it.

You mean the menu width problem?

> what about regular expresion matching on the ChangeMenuStyle ? 

Hmm, not a bad idea. As a shell freak (zsh forever :) ) I'd like
to see more consistent parsing (quoting!) anyway. Regular expressions
could be used in many places: Styles, SetMenuStyle, Next/Prev...,
Decors and so on.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: German Jose Gomez Garcia <[email-masked]>
Date: Wed, 23 Dec 1998 15:55:19 +0100 (MET)

> take a few weeks off soon.
	As you wish Sir :-)

> You mean the menu width problem?
	Yes.	(short is nice)

> could be used in many places: Styles, SetMenuStyle, Next/Prev...,
	I'm currently working on a reduced version (with no so much 
features as grep regular expresions, but with more of the features 
releated to searching) I'm implementing it as a new kind of strncmp so we 
could just change the function call and get it working. I'll keep you 
informed.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 15:57:33 +0100

> could just change the function call and get it working. I'll keep you 

There must be complete regexp sourcecode available somewhere.
If we can find an open source implementation (preferrably not
GPL) that might save you the effort of writing everything from
scratch.

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 10:15:36 -0500

> GPL) that might save you the effort of writing everything from

I assume you know about the current logic in libs/wild.c.

Always seemed like enough wildcarding to me.  I was hoping for
more control over what it matched against, rather than how
it matched.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 10:25:30 -0500

> take a few weeks off soon.

Burn out is a serious issue.  Please only work on fvwm2 when you
are enjoying it.

My cat loves when I work on fvwm.  It is a struggle to keep her off
the keyboard...

Hey, wait, I can blame my mistakes on my cat...

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 16:31:31 +0100

> Burn out is a serious issue.  Please only work on fvwm2 when you

I love it but I need a break soon.

> My cat loves when I work on fvwm.  It is a struggle to keep her off

Yup. I could handle one cat, but three can give you
a hard time. In fact my 'mice' are 14 and a half weeks young
and one of them is fanatically chasing my mouse pointer
while jumping up and down on the keyboard :-) Not very
nice if you're in vi.

> Hey, wait, I can blame my mistakes on my cat...

Never thought of that ;-)

Bye

Dominik

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 23 Dec 1998 10:51:18 -0500 (EST)

> more control over what it matched against, rather than how

Well if you insist on using regex why not use
regcmp  regex
they are standard c library functions 
try man -s 3c regex

Brad

-- 
There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Danek Duvall <[email-masked]>
Date: Wed, 23 Dec 1998 13:10:06 -0800

On Wed, Dec 23, 1998 at 03:57:33PM +0100, Dominik Vogt wrote:

> There must be complete regexp sourcecode available somewhere.  If we can
> find an open source implementation (preferrably not GPL) that might save
> you the effort of writing everything from scratch.

There's a library called pcre, which is the perl extended regexp code
pulled out into a library.  I believe it was brought up recently on the zsh
mailing list as a possible implementation for zsh to use.  I'm not sure
what the license is on the library (the copy that comes with recent betas
of tin don't mention a license), but it's possible that it comes under the
same artistic license that Perl does.

I'd find the url, but I'm on a dog slow connection, and I'm hesitant to
touch the web at all.  (DSL has spoiled me even more than my connection at
school did! ;-)

Hppy holidays, everyone!

Danek