Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Wed, 9 Dec 1998 20:04:15 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	98/12/09 20:04:15

Modified files:
	.              : ChangeLog 
	fvwm           : builtins.c functions.c fvwm.c fvwm2.1 misc.h 
	                 move.c parse.h placement.c screen.h 

Log message:
applied SnapAttraction patch update
backed out miniicons memory leak fix. this is too complicated for now,
so let fvwm2 leak rather than coredump :(

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 09 Dec 1998 21:27:10 -0500

> so let fvwm2 leak rather than coredump :(

I definitely  agree  that we  can drop   this  for now.  I  don't  yet
understand the code, but it looks like  when the ButtonFont storage is
acquired, its not cleared. If so, that could lead to the fix trying to
free a non-existant pixmap.  But I think that  u.p being a union is an
issue also.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 10 Dec 1998 03:35:46 +0100

> free a non-existant pixmap.  But I think that  u.p being a union is an

Oops, a UNION? I never bothered to look at the structure.
That explains a lot. That is evil, evil, evil.

Dominik
-- 
Dominik Vogt, [email-masked]