Subject: Re: Fvwm with VMS

From: [email-masked] (Fabien Villard)
Date: Tue, 15 Dec 1998 13:48:44 +0100

Hello.
	Excuse me for my silence, my provider got down for 4 days :-((((

>Sounds like work ;-)
	:-) Yes it does...

>Could you enlighten me what kind of OS this OpenVms is?
>Sounds vaguely familiar, but I really don't know what it is
>(some kind of UNIX?).
	No, definitely not :-) Open VMS is the other OS from Compaq-Digital 
(formely Digital Equipment Corporation). It's another family of OS where it 
stands alone :-) It was born with the PDP11 family of computers and since then 
is a fully multitasking, multiuser, now multithreading OS with a great (but old) 
cluster solution completely integrated in the kernel. Perhaps you will hear of 
it with the Galaxy technologie... It is a robust, reliable system dedicated now 
to 24/24-7/7 systems.

>Like Dominik, I  have no real VMS exposure.   Since you are trying  to
>use fvwm2, I assume it uses X?
	Yes and DecWindow under it wich is a Motif implementation. But it's kind 
of a black box, and because OpenVms is so different from Unix (file system, IPC, 
process scheduling, and so on...) it is not so easy :-)

>VMS, so I think you should give it a try and see how far you can get.
	For now, I have recompiled the code whithout modules (to start :-). No 
problems, except that I could'nt use the configure script. I hacked in the 
config.h wondering what I could answer to the "HAVE_something" questions. Now it 
goes.
	When I execute it, I have a probleme with the XConnectionNumber function 
returning a file descriptor (I think). What is it exactly ? In fact, I get a 
number, but when I feed the fcntl function with it, I get a "bad file number"... 
Can you explain what is under the two functions ? (fvwm.c)
	I bypassed the exit function to go ahead.
	NOw I'm just near the vision of fvwm under VMS, but I have to make a 
pause, 'cause I've crashed the X server many times, and the sysadmin here is a 
little bored of me :-))))))
	Fab.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 Dec 1998 16:19:20 -0500

> Can you explain what is under the two functions ? (fvwm.c)

I don't  know much about it,  but managed to  find some info thru "man
XAddConnectionWatch".  It does appear to be a file descriptor.

You must be refering to this code:

  x_fd = XConnectionNumber(dpy);

  fd_width = GetFdWidth();
  if (fcntl(x_fd, F_SETFD, 1) == -1)
  {
    fvwm_msg(ERR,"main","close-on-exec failed");
    exit (1);
  }

I assume you saw the "bad file number" message when you added a perror
call?

Since the "1" would  make the file close  after an "exec", my guess is
that  this  will somehow  limit   the available  file descriptors  for
processes that fvwm starts.

Bypassing the exit sounds like a logical first step.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].