Subject: just an idea

From: BJ Goodwin <[email-masked]>
Date: Wed, 23 Dec 1998 23:03:18 -0800 (PST)

Hey all,

I dont know if this is the place to post ideas (please let me know otherwise if
not), but I have a couple. Normally snap attraction snaps a window (or button)
right on the border of another window. How about a padding for the snapped
window instead of right on the border of surrounding windows. Also, what about
command aliasing? Like I have a button in FvwmButtons that has the same command
as an entry in one of my menus. It'd be nice to alias commands rather typing
out long drawn-out ones. Just a thought.

-- 
BJ Goodwin
[email-masked]
http://www.cutlet.ddns.org

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Dec 1998 14:28:45 +0100

> out long drawn-out ones. Just a thought.

It is the right place. Your enhancement request concerning
padding for SnapAttraction has come up before. We'll see
after the release (2.2). Some kind of 'aliasing' can already
be done with the preprocessor modules. In my .fvwm2rc I have:

  #define CMDPPPUP exec su - root -c "/usr/local/sbin/ppp up pi debug"
  #define CMDPPPDOWN exec su - root -c "/usr/local/sbin/ppp down"

  AddToMenu WorkMenu "Work menu"   Title
   + "PPP up" Exec CMDPPPUP
   + "PPP down" Exec CMDPPPDOWN

  *FvwmButtons(3x2+15+3, Icon my_ppp.xpm, Action (Mouse 1) `Exec CMDPPPUP`, Action (Mouse 3) `Exec CMDPPPDOWN`)

Have a look at the FvwmM4 and FvwmCpp manpages.

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]