Subject: 2.1.4 PagerBalloon problem

From: "Robert H. Ford II" <[email-masked]>
Date: Fri, 04 Dec 1998 13:30:46 -0600

I just built and installed fvwm-2.1.4 on Solaris 2.5.1, X11R6.1, gcc 2.8.1, make
3-77 with no problems.

The only thing I have noticed is that when my FvwmPagerBalloon pops up the
background color is always the same as the setting of the foreground color.

Here is what I have:
##########################FvwmPagerBalloon############################
*FvwmPagerBalloons            All
*FvwmPagerBalloonBack         yellow
*FvwmPagerBalloonFore         black
*FvwmPagerBalloonFont         lucidasanstypewriter-12
*FvwmPagerBalloonYOffset      +2
*FvwmPagerBalloonBorderWidth  1
*FvwmPagerBalloonBorderColor  black

This produces a solid black box.  If I change FvwmPagerBalloonFore to red and
restart fvwm2 then it produces a box with a black border filled with solid red.

I looked at FvwmPager.c and found this at line 1240:

      else if (StrEquals(resource, "BalloonBack"))
        {
          if (Scr.d_depth > 1)
            {
              if (BalloonBack)
                free(BalloonBack);
              CopyString(&BalloonBack, arg1);
            }
        }

      else if (StrEquals(resource, "BalloonFore"))
        {
          if (Scr.d_depth > 1)
            {
              if (BalloonBack)
                free(BalloonBack);
              CopyString(&BalloonFore, arg1);
            }
        }

I fixed this be changing the second "else if" look like this:

      else if (StrEquals(resource, "BalloonFore"))
        {
          if (Scr.d_depth > 1)
            {
              if (BalloonFore)
                free(BalloonFore);
              CopyString(&BalloonFore, arg1);
            }
        }

--
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     mailto:[email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 04 Dec 1998 18:04:15 -0500

I checked in this fix to CVS.  Thanks for catching this!

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].