Subject: Re[4]: Bug #48 -- Window under mouse at startup doesn't get focus

From: Bob Woodside <[email-masked]>
Date: Fri, 11 Dec 1998 03:53:32 -0500 (EST)

Dominik Vogt <[email-masked]> wrote:
> I don't think so. I don't throw away events...

	Maybe we should....  ;-)

	What was happening was that when the "coerced" EnterNotify
was handled, an old LeaveNotify was found on the event queue, and
StashEventTime was called, presumably for the first time, and
stored this old value in lastTimestamp. When the XSetInputFocus
was issued, the timestamp insured that the focus would never take
effect. I changed HandleEnterNotify to bypass the stash if we
are in startup.

	So, Tim and Dominik appear blameless. What I don't understand
is what could have changed to cause this to start happening. But,
then, quite a lot has changed in the last few weeks!

	Do I recall a suggestion a while back that maybe we should
flush all pending events at startup?

- Bob

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 Dec 1998 19:13:00 +0100

> flush all pending events at startup?

Yes, I made the suggestion (I believe), but I think that isn't a good idea.
There will definitely be *some* events that are needed. But
perhaps we could weed out certain types of events?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].