Subject: Re: FvwmPager & negative desk numbers

From: Dominik Vogt <[email-masked]>
Date: Tue, 1 Dec 1998 14:23:32 +0100

On Mon, Nov 30, 1998 at 03:05:44PM +0100, [email-masked] wrote:
> Hi,
> 
> "FvwmPager" has a little Bug:
> 
> When the range of desks to show contains negative desk numbers
> (something like "Module FvwmPager -1 1"), it doesn't react to
> mouse button 3 anymore (everything else seems to work as usual)

Which fvwm revision do you use?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Peter Daum" <[email-masked]>
Date: Wed, 2 Dec 1998 00:57:12 +0100 (MET)

Hi,

> Which fvwm revision do you use?

I was referring to the current (short before 2.1.3) CVS tree.

Regards,
              Peter

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Dec 1998 14:05:42 +0100

> mouse button 3 anymore (everything else seems to work as usual)

Are you sure that happens only with negative desktop numbers?
Looking at the code I'd say mouse button 3 does not work
properly with more than one desk. That's what I see at home.
The problem is that it does not switch desks and expects the
mouse in the first desktop.

Bye

Dominik

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 4 Dec 1998 11:39:51 -0500 (EST)

Straight from man FvwmPager esp. the last sentence.

 Clicking mouse button 3 on a  location  within  the  current
     desktop  will  cause  the  viewport  to move to the selected
     location, but will not align the viewport to  a  page  boun-
     dary.  Dragging  button 3 will cause the viewport to move as
     you drag. Button 3 operations are  limited  to  the  current
     desktop only.

One unfortunate effect of this as I just noticed in seeing if it worked
for my 2 desk setup is that it works fine on the 1st desk but if you do it
in the pager for the second desk all the windows on the first desk got
moved around, hosing all my geometries.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Dec 1998 17:45:50 +0100

>      you drag. Button 3 operations are  limited  to  the  current

Aha. Anyway, I don't see a reason why that should be limited
to the current page. If I find something working smoothly
I will change that.

Bye

Dominik

---

From: "Peter Daum" <[email-masked]>
Date: Fri, 4 Dec 1998 18:59:59 +0100 (MET)

Hi,

[...]
> mouse in the first desktop.

at least that is what it looked like to me:

With "FvwmPager -1 1" the right mouse button doesn't work at all, when I
change it to "FvwmPager 0 2", everything works as described in the
documentation.

regards,
           Peter
-- 
     | Peter Daum ([email-masked])        __o   (+49 30)
     | http://www.cs.tu-berlin.de/~gator       _'\<_  691 46 35
     | pgp messages welcome!                 _(_)/(_) ___________

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Dec 1998 11:55:31 +0100

> change it to "FvwmPager 0 2", everything works as described in the

Problem solved. Button 3 didn't work properly not only with
negative desk numbers but in general when the first desk
number was != 0 (the fix didn't make it into 2.1.4 however).

Bye

Dominik