Subject: FvwmButtons does not clean up after itself

From: [email-masked]
Date: Mon, 14 Dec 1998 23:32:19 -0600 (CST)

Full_Name: Chris Rankin
Version: 2.1.4
CVS_Date: 
OS: Linux 2.0.36
X_Server: XF86_SVGA
Submission from: (NULL) (209.214.16.185)

This message is FYI only: patches have been submitted to Brady Montz

On my system I have FvwmButtons which has swallowed (amongst others)
FvwmIconMan and
xbiff. When I restarted fvwm2, FvwmIconMan wrote errors to the console log
and left
the xbiff process running.

This error came in 2 parts: firstly, the clean-up code had been commented
out of
FvwmButtons since it is indeed non-reentrant. This problem can be solved by
calling
sigsetjmp before calling the event-loop, putting siglongjmp in the signal
handler and
then performing clean-up once the event-loop "returns". The second part was
in
FvwmIconMan itself - it wasn't exiting when told to terminate and so caused
an X
error when FvwmButtons' clean-up code called XSync. This in turn made
FvwmButtons exit
before it could kill xbiff.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Dec 1998 19:49:11 +0100

> This message is FYI only: patches have been submitted to Brady Montz

It's nice that you provide patches, but you should definitely
send them to the list. Brady has quit the job as maintainer a
while ago and fvwm2 is now maintained by a few people on the
on the list (me being one of them). Most of the time I am the
one apllying patches. So please repost your patches to the list
so that I can incorporate them ti 2.1.6.

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Dec 1998 19:57:43 +0100

> before it could kill xbiff.

Great. We were living with these ugly workarounds for quite a while now.
Thanks.

Dominik

---

From: Michael M Han <[email-masked]>
Date: Tue, 15 Dec 1998 17:38:36 -0800

Previously...
>so that I can incorporate them ti 2.1.6.

I have a small patch for IconMan that allows the IconMan next & prev
actions to wrap around the end of the windowlist... i.e., an IconMan
action for 'next' at the end of the list or 'prev' at the beginning of
the list won't just sit there, but will instead wrap around. It's a
really trivial patch. I can submit it to the list... I'd already
suggested it to Brady, since he's still IconMan's author, even if not
the fvwm maintainer. Thoughts?
_________
mike ([email-masked])
"Bart Bucks" are not legal tender
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Dec 1998 11:28:16 +0100

> the fvwm maintainer. Thoughts?

We haven't heard anything from Brady for about two months now.
So unless he tells us otherwise I'd assume sending IconMan
patches to the list is the right thing to do. We've changed
a lot in IconMan anyway and things have already built up
movement of their own.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].