Subject: Notification: incoming/103

From: [email-masked]
Date: Wed, 23 Dec 1998 07:44:08 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/103

Message summary for PR#103
	From: [email-masked]
	Subject: regular expressions
	Date: Wed, 23 Dec 1998 07:44:06 -0600 (CST)
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 23 Dec 1998 10:40:32 -0500 (EST)

> Why not allow regexp syntax to match window/syle/decor names.
> 

Not sure what you mean here you can already use ? * for Style, Current,
Next, and Prev.  I don't think anyone would want something like
Style [a-m]win;foo   ...
Style [n-z]win;bar   ...
do you?

I get by nicelly with a 
Style "xb?f*" -- to match all my mailbox watchers.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 17:35:11 +0100

> Next, and Prev.  I don't think anyone would want something like

But perhaps Style "[Nn]etscape.*" ?

> Style "xb?f*" -- to match all my mailbox watchers.

I don't think that is documented, isn't it? Anyway, if it does not
cost us much, why not use the regex library. Are you sure it is
standard?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 23 Dec 1998 12:18:55 -0500 (EST)

> I don't think that is documented, isn't it? Anyway, if it does not
yes it is documented, whatch those double negatives :)

> cost us much, why not use the regex library. Are you sure it is
My docs say it is standard C, and I caan find it on Solaris, SunOs and
OSF (that is all I have on hand right now) and it is located in libc.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 18:35:51 +0100

> yes it is documented, whatch those double negatives :)

I am watching the -- but they dont move. What do you mean?
The ? and * are documented in the manpage. But I noticed
one thing:

  (from the manpage)

  windowname can be a window's name, class, or resource string.  It
  can contain the wildcards * and/or ?, which are matched in the
  usual Unix filename manner.  They are searched in the reverse    <--
  order stated, so that Style commands based on the name override  <--
  or augment those based on the class, which override or augment   <--
  those based on the resource string.

This implies that when I have these Styles:

  Style "*" Title
  Style "mutt" NoTitle

and fire up vim from mutt (this changes the title to
'Thaks for flying VIM') and then recapture, I get a
title on my mutt window because "*" matches the name
and "mutt" only matches the resource. Not very nice
(in fact I don't even have to use 'Title' since this
seems to be the default when any "*" style is defined).

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 12:55:34 -0500

> seems to be the default when any "*" style is defined).

I don't think you described that right, and the documentation
is a little misleading.  The resource/class/name match is
done for each style.  Then it goes on to the next style.

In your example, it should match "mutt" on resource.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 19:07:40 +0100

> In your example, it should match "mutt" on resource.

Well, perhaps in theory. In reality it does happen. I do get
a title on my mutt window after a refresh. Or could vim
set the resource/class of the window too?

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 13:35:38 -0500

> set the resource/class of the window too?

I do something similar to what you do above,
the windows I don't want titles on don't have titles.

Do you have more "Style xx Titles" after the one for "mutt"?
If not, the NoTitle should override, providing it matches
on name, resource OR class.

I've seen applications that can change "name" (title), and "iconname".
I don't know about class and resource.

The setting  of flags takes place in  style.c, the matching/merging of
the flags is in "add_window.c".

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 22:37:40 +0100

> on name, resource OR class.

No. The only line with Title/NoTitle is the mutt line. All the
Style lines that should affect mutt are:

  Style * BorderWidth 4, HandleWidth 4
  Style * SloppyFocus
  Style * DecorateTransient
  Style * Icon small.Template.xpm, IconBox +580 +708 +1023 +767
  Style * SmartPlacement,RandomPlacement
  Style * NoPPosition
  Style * MWMBorder, MWMDecor, HintOverride, MWMFunctions, MWMButtons

  #define MAIL mutt
  Style MAIL StartsOnPage 0 1, NoTitle

1) I start mutt, all is ok (mutt has no title)
2) I write a mail (wit vim as my editor), icon and window names
   change to "VIM - <some path>" (I can see it in IconMan)
3) I leave vim with :q! and abort the mail
4) I refresh the screen and mutt gets a title bar this time
   with the title set by VIM :(

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Dec 1998 08:38:30 -0500

>    with the title set by VIM :(

Check out the window with FvwmIdentify.

---

From: Michael M Han <[email-masked]>
Date: Thu, 24 Dec 1998 10:18:28 -0800

Previously...
>Check out the window with FvwmIdentify.

Furthermore, when you build vim, there's an option (in some releases
not enabled by default --I think it was all the pre autoconf releases)
to have vim restore your xterm's title after resetting it. I know it
doesn't address the fvwm problem, but just thought I'd mention it...
_________
mike ([email-masked])
Nerve gas is not a toy
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Dec 1998 23:49:58 +0100

> Check out the window with FvwmIdentify.

That gives me:

  Just after starting mutt (without title bar):
  ---------------------------------------------
  Name: mutt
  Icon name: mutt
  Class: XTerm
  Resource: rxvt.tty
  NoTitle: Yes

  After writing a mail with vim (still no title bar):
  ---------------------------------------------------
  Name: Thanks for flying Vim
  Icon name: mutt
  Class: XTerm
  Resource: rxvt.tty
  NoTitle: Yes

  After a Refresh (it now has a title bar):
  -----------------------------------------
  Name: Thanks for flying Vim
  Icon name: mutt
  Class: XTerm
  Resource: rxvt.tty
  NoTitle: No

So it seems the icon name is not used for matching.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Dec 1998 23:41:55 +0100

> doesn't address the fvwm problem, but just thought I'd mention it...

Thanks for the hint. I was reading the vim documentation up and
down to find out how to disable this 'feature'.

Bye

Dominik