Subject: ["Brandon S. Allbery" <[email-masked]>] Re: 1998-12-29 buglist

From: Jason L Tibbitts III <[email-masked]>
Date: 30 Dec 1998 12:59:35 -0600

There's a bit of talk on the Gnome list about a bug in fvwm 2.0.46; I asked
if they could duplicate it with a recent version like 2.1.5 but there were
snide remarks about using development versions.  Of course, 2.0.46 is a
development version and has more bugs than 2.1.5, so I corrected them.

In any case, I have no additional info on this, and can't find a way to
duplicate it.
-- 
Jason L Tibbitts III - [email-masked] - 713/743-3486 - 660PGH - 94 PC800
   System Manager:  University of Houston Department of Mathematics 
      "I survived while Ruby died in Jackie's trashy fantasy..."

------- Start of forwarded message -------
Resent-Date: 30 Dec 1998 17:06:05 -0000
Resent-Cc: recipient list not shown: ;
Message-Id: <[email-masked]>
To: [email-masked] (Elliot Lee)
cc: [email-masked]
Subject: Re: 1998-12-29 buglist 
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Date: Wed, 30 Dec 1998 11:50:08 -0500
From: "Brandon S. Allbery" <[email-masked]>
Resent-Message-ID: <"308CC2.0.kE1.yrbYs"@lists.redhat.com>
Resent-From: [email-masked]
Resent-Sender: [email-masked]

In message <[email-masked]>, Elliot Lee writes:
+-----
| On 29 Dec 1998 22:05:30 -0600, Jason L Tibbitts III <[email-masked]> wrote:
| >>>>>> "EL" == Elliot Lee <[email-masked]> writes:
| >EL> fvwm2 2.0.46 seems to barf on gtk_window_set_policy().
| >
| >Could someone elaborate here?  FVWM-workers has seen no mention of this,
| >and if it doesn't happen to any other WM then it's probably an FVWM bug.
| 
| It creates a window frame but does not reparent the app window into that
| frame, so there is this blank grey window frame sitting there, and then the
| app window is in top left corner with no frame.
+--->8

Aha.  Yes, I've seen *that* one.  mahjongg does this.

-- 
brandon s. allbery	[os/2][linux][solaris][japh]	 [email-masked]
system administrator	     [WAY too many hats]	   [email-masked]
electrical and computer engineering					 KF8NH
carnegie mellon university	      ["God, root, what is difference?" -Pitr]

-- 
        FAQ: Frequently-Asked Questions at http://www.gnome.org/gnomefaq
         To unsubscribe: mail [email-masked] with 
                       "unsubscribe" as the Subject.

------- End of forwarded message -------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randall S. Winchester" <[email-masked]>
Date: Wed, 30 Dec 1998 14:39:20 -0500 (EST)

On 30 Dec 1998, Jason L Tibbitts III wrote:

: There's a bit of talk on the Gnome list about a bug in fvwm 2.0.46; I asked
: if they could duplicate it with a recent version like 2.1.5 but there were
: snide remarks about using development versions.

Hah! pretty funny the kettle calling the pot black. Talk about your
development versions...

Randall

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 31 Dec 1998 11:42:45 +0100

> Hah! pretty funny the kettle calling the pot black. Talk about your

This is getting us nowhere. We can start exchanging insults or
cooperate to get things running. There is a tool to report bugs
on our homepage ( http://fvwm.math.uh.edu/ ). It would help
immensely if you would use it or at least post to the
fvwm-workers list ( [email-masked] ). Contrary to any
experience you might have had with fvwm in the past all bug
reports are taken serious and will be worked on.

Some of us had a look at some GNOME-compliance draft and found
it quite unclear, so we didn't start making fvwm2 GNOME- (or
KDE-compliant) and I think other window managers have the same
problem. As you have noticed there hasn't been an official
fvwm2 release for ages and we're all working very hard to complete
2.2 as soon as possible (hopefully in January). We have about 40
open bug reports and enhancement requests and perhaps you can
understand that making 2.2 GNOME-compliant is no issue for us
since it would only make 2.2 even later.

In the meantime it would help your team and mine if you'd
forward bug reports to the fvwm developers. And perhaps you
can imagine that I've not much time left for installing
and configuring GNOME after 40 hours working plus 50 hours
hacking fvwm2 a week. Downloading, building and installing a
recent fvwm2 version on a current Linux system should take
about 20 minutes (2.1.5 is the right choice) thanks to autoconf.
You can use the same config file as for 2.0.46 and have it
running very fast. OK, for a clean installation you will need
some more work, but that's probably not what you need.

Thanks and Bye

Dominik
(speaking for the fvwm2 development team)

P.S.: Please be so kind and forward this mail to your list.
-- 
Dominik Vogt