Subject: IconMan cordumps and kills FvwmButtons

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Dec 1998 04:15:21 +0100

I was experimenting with an FvwmButtons line
when I got a coredump:

*FvwmButtons(3x2+12+3, Icon my_errors.xpm, \
Action (Mouse 1) 'Function RunXMessages', \
Action (Mouse 2) `Style \\"XMessages\\" Sticky`, \
Action (Mouse 2) `Style \\"XMessages\\" Slippery`)

(The backslashes are there for readability only.
In my .fvwm2rc it's one line).

I know that this line is badly broken. What
happens is: when I press button 3 over this
item, FvwmIconMan coredumps with this message:

-------------------------------------------------------

FvwmIconMan: X Error:
FvwmIconMan:          error code: 9
FvwmIconMan:          request code: 70
FvwmIconMan:          minor code: 0
FvwmIconMan: Leaving a core dump now
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  12 (X_ConfigureWindow)
  Resource id in failed request:  0x240001d
  Serial number of failed request:  555
  Current serial number in output stream:  583
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  70 (X_PolyFillRectangle)
  Resource id in failed request:  0x3000002
  Serial number of failed request:  430
  Current serial number in output stream:  441

The new signal handling stuff doesn't prevent that
FvwmButtons dies too.

-------------------------------------------------------

My IconMan config:

*FvwmIconMan*Action Mouse 3 N sendcommand close
*FvwmIconMan*Background CBACK
*FvwmIconMan*Foreground CFORE
*FvwmIconMan*ButtonGeometry 57x11
*FvwmIconMan*FocusButton up CFORE CFOCUS
*FvwmIconMan*FollowFocus true
*FvwmIconMan*Font FONTXXXS
*FvwmIconMan*Format "%t"
*FvwmIconMan*ManagerGeometry 2x5
*FvwmIconMan*PlainButton up CFORE CBACK
*FvwmIconMan*Resolution page
*FvwmIconMan*SelectButton flat CFORE CBACK
*FvwmIconMan*FocusAndSelectButton flat CFORE CFOCUS
*FvwmIconMan*Title ""
*FvwmIconMan*TitleButton flat CBACK CBACK
*FvwmIconMan*UseWinList true

-------------------------------------------------------

My FvwmButtons config:

Style "FvwmButtons" HandleWidth 2, BorderWidth 2

*FvwmButtonsFont        FONTXXXS
*FvwmButtonsBack        CBACK
*FvwmButtonsFore        CFORE
*FvwmButtonsFrame       1
# 8x11 pixels per button, 4x4 pixels for the frame
*FvwmButtonsGeometry    572x59+0-0
*FvwmButtonsRows        5
*FvwmButtonsColumns     71
*FvwmButtonsBoxSize     fixed
*FvwmButtonsPadding     1 1

# Menu Popups
*FvwmButtons(9x1+0+0, Padding 0, Title "Modules", Action `Menu ModuleMenu mouse c+5p -8p Nop`)
*FvwmButtons(9x1+9+0, Padding 0, Title "Window", Action `Menu WindowMenu mouse c+5p -8p Nop`)
# first row of buttons from left to right:
*FvwmButtons(3x2+0+1, Icon my_lock.xpm, Action `Exec CMDSAVER`)
*FvwmButtons(3x2+3+1, Icon my_recapture.xpm, Action Recapture)
*FvwmButtons(3x2+6+1, Icon my_resize.xpm, Action Resize)
*FvwmButtons(3x2+12+1, Icon my_fvwmconsole.xpm, Action 'Exec killall FvwmConsole
 || FvwmCommand Module FvwmConsole')
*FvwmButtons(3x2+15+1, Icon my_netscape.xpm, Action (Mouse 1) `Exec CMDBROWSER`,
 Action (Mouse 2) `Exec killall -9 bROWSER; rm /home/avatar/.netscape/lock`, Action (Mouse 3) `Exec exec killall -15 bROWSER`)
# second row of buttons from left to right:
*FvwmButtons(3x2+0+3, Icon my_exit.xpm, Action QuitSave)
*FvwmButtons(3x2+3+3, Icon my_restart.xpm, Action Restart)
*FvwmButtons(3x2+6+3, Icon my_kill.xpm, Action Destroy)
*FvwmButtons(3x2+9+3, Icon my_shell.xpm, Action 'Exec rxvt')
*FvwmButtons(3x2+12+3, Icon my_errors.xpm, Action (Mouse 1) 'Function RunXMessages', Action (Mouse 2) `Style \\"XMessages\\" Sticky`, Action (Mouse 2) `Style \\"XMessages\\" Slippery`)
*FvwmButtons(3x2+15+3, Icon my_ppp.xpm, Action (Mouse 2) `Exec CMDPPPUP`, Action
 (Mouse 3) `Exec CMDPPPDOWN`)
# big items
*FvwmButtons(11x5, Swallow (NoKill, NoCLose) "FvwmPager" 'FvwmPager * * -geometry 40x40-2000-2000')
*FvwmButtons(6x5, Swallow "FvwmXclock" `Exec exec xclock -name FvwmXclock -geometry 40x40+2000+2000 -padding 1 -analog -chime -bg CBACK`)
*FvwmButtons(22x5, Swallow "xosview" `Exec echo 'xosview*background:' CBACK | xrdb -merge; exec /usr/X11R6/bin/xosview +load +mem -net -cpu -int -swap +page -geometry 100x50+0-0 -font FONTXXXS`)
*FvwmButtons(14x5, Left, Swallow (NoClose) "FvwmIconMan" 'Module FvwmIconMan')

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 10:47:14 +0100

> I was experimenting with an FvwmButtons line

I must correct myself: it wasn't FvwmIconMan that coredumped
but FvwmButtons. I've fixed that bug already.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].