Subject: Re: Menus...

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Dec 1998 02:56:47 +0100

On Mon, Dec 07, 1998 at 12:18:59PM -0600, [email-masked] wrote:
> Full_Name: Tomas Ögren
> Version: cvs
> CVS_Date: 18:30 MET
> OS: Solaris 2.6
> X_Server: Xsun
> Submission from: (NULL) (130.239.117.83)
> 
> 
> AddToMenu       "Main"
> +       "XTerm" Exec exec xterm &
> +       "XTerm (no titlebar)" Exec exec xterm -title "SBorder" &
> 
> AddToMenu       "auth"
> +       "Ing"     Exec exec fixxauth.pl tekla.ing
> 
> "XTerm" doesn't do anything, "XTerm (no titlebar)" works, and "Ing"
> works..
> Any ideas? (It worked fine in pre-2.1.x)

Do you by any chance invoke the menu with a mouse button
and as a Popup menu?

If this is the case you won't get the first entry working unless
you wait about half a second before releasing the button.
I made this change to prevent activation of menu items by accident.
Whenever you land on an item when bringing up the menu you'll have
to wait for a moment. To get a similar behaviour you can bind
a default action to your popup menu just like with Menu and
WindowList. The only difference is that you don't need to
double click (which is impossible) but only have to release the
button fast:

  AddToMenu       "Main"
  +       "XTerm" Exec exec xterm &
  +       "XTerm (no titlebar)" Exec exec xterm -title "SBorder" &

and then

  Mouse 1 R A Popup Main Exec exec xterm &

Bye

Dominik

P.S.: Please tell me if it was your problem so that I know
      what to do with the bug report.
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 25 Dec 1998 20:20:42 +0100

> Do you by any chance invoke the menu with a mouse button

It's the root-menu, invoked with mouse...

> you wait about half a second before releasing the button.

Hm.. Seems to work... Is this documented somewhere?

>       what to do with the bug report.

Undocumented feature -or- user unable to RTFM 8)

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 Dec 1998 00:11:17 +0100

> It's the root-menu, invoked with mouse...

I'll place your report under duplicates then.

> Hm.. Seems to work... Is this documented somewhere?

Well, when you reported is wasn't. In the meantime I have
updated the manpage for the Popup default-action.

> Undocumented feature -or- user unable to RTFM 8)

Sigh, who knows how menus really work. The code is such a hack that
nobody understands what is going on there (and I have even written
a good chunk of it). Surely I can document that, but that will leave
twenty other undocumented 'features'. I'm not sure that we can possibly
ever describe all of this stuff and neither I do believe we should.
I thought what I implemented was the intuitive behaviour.

Any ideas what we should do about that? (FAQ?)

Bye

Dominik