Subject: Re: FvwmButtons does not swallow Pager (PR#32)

From: job bogan <[email-masked]>
Date: Fri, 04 Dec 1998 10:07:13 -0600

Your message dated: Fri, 04 Dec 1998 09:39:26 CST
>Please, I need more info on this. Can you reproduce it with
>the latest distribution? Please send me your .fvwm2rc if you
>can.

sorry, i got busy at work.

but, now when i try to build 2.1.4 i get this

pepper:/fvwm-2.1.4# ./configure --prefix=/opt/pkgs/fvwm-2.1.4 --with-xpm-library=/opt/pkgs/xpm/lib --with-xpm-includes=/opt/pkgs/xpm/include --with-readline-library=/opt/pkgs/readline/lib --with-readline-includes=/opt/pkgs/readline/include
....
Using xpm library
checking for rplay_create in -lrplay... no
Not using rplay library
configure: error: argument must be boolean
#

here's the end of config.log:

configure:3009: checking for rplay_create in -lrplay
configure:3028: gcc -o conftest -g -O2   conftest.c -lrplay -lrplay
1>&5
ld: fatal: library -lrplay: not found
ld: fatal: library -lrplay: not found
ld: fatal: File processing errors. No output written to conftest
collect2: ld returned 1 exit status
configure: failed program was:
#line 3017 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char rplay_create();

int main() {
rplay_create()
; return 0; }

And i did mail you my config w/ the 1st message.  I'll mail you another
copy directly.

job
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Dec 1998 17:33:00 +0100

> configure: error: argument must be boolean

I had something similar myself. I rerun configure and then it worked.
Don't know why. If that doesn't help, try defining the rplay library
too.

> And i did mail you my config w/ the 1st message.  I'll mail you another

Yes, I know. But I need it with the correct whitespace. Please
resend it directly to me as a gzipped attachment, just to make
sure.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].