Subject: What has happened to the CVS code?

From: Dominik Vogt <[email-masked]>
Date: Sun, 20 Dec 1998 20:48:39 +0100

I just updated my working code for the MenuStyle
changes from the CVS tree and not I get lots of errors:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libs -I/usr/X11R6/include     -g -O2 -c functions.c
functions.c:102: `echo_func' undeclared here (not in a function)
functions.c:102: initializer element for `func_config[32].action' is not constant
functions.c:107: `flip_focus_func' undeclared here (not in a function)
functions.c:107: initializer element for `func_config[37].action' is not constant
functions.c:108: `focus_func' undeclared here (not in a function)
functions.c:108: initializer element for `func_config[38].action' is not constant
functions.c:110: `SetGlobalOptions' undeclared here (not in a function)
functions.c:110: initializer element for `func_config[40].action' is not constant
functions.c:121: `staysup_func' undeclared here (not in a function)
functions.c:121: initializer element for `func_config[51].action' is not constant

and so on.

What has happened?

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Dec 1998 20:22:50 -0500

> functions.c:121: initializer element for `func_config[51].action' is not cons

Apparently I uploaded something I neglected to test.
Give me a few minutes...

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Dec 1998 20:33:23 -0500

Dan Espen <[email-masked]> writes:
> > gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../libs -I/usr/X11R6/include     -g -O2 
> -c
> >  functions.c
> > functions.c:102: initializer element for `func_config[32].action' is not co
> > 
> > and so on.
> > 
> > What has happened?
> 

Well, maybe not.  I just uploaded functions.c where I made a mistake
that would cause a run-time error.

(Someone take my keyboard away.)

Looks to me like a change I made in misc.h is affecting you.

I put in a #DEFINE F_CMD_ARGS for all the fuctions in the command
table.  Does that name conflict with something?