Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Wed, 2 Dec 1998 10:11:11 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	98/12/02 10:11:11

Modified files:
	fvwm           : events.c 

Log message:
small enhancement to get xterm/active icon straight
could somebody verify that it compiles?

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 2 Dec 1998 11:23:38 -0500 (EST)

Well it compiles but that isn't what I sent you as the diff.
You comitted 
if((Tmp_win)&&((Tmp_win->icon_w == cre->window)))
    {  
      .
      .
      .
      if((Tmp_win)&&((Tmp_win->icon_pixmap_w == cre->window)))
      .
      .
      .
     }
Think about it will that work.
what you wanted was 
    if((Tmp_win)&&((Tmp_win->icon_pixmap_w == cre->window)))
    {  
      Tmp_win->icon_p_height = cre->height+ cre->border_width +
cre->border_width;
    }  
    if((Tmp_win)&&((Tmp_win->icon_w == cre->window)))
    {

with the first 4 lines being the new code. Inserted before the existing
if ...->icon_w

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 2 Dec 1998 17:28:29 +0100

> Well it compiles but that isn't what I sent you as the diff.

Sigh, that's why I don't like to apply patches at work.

Bye

Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].