Subject: 2.1.5 FvwmWinList button text

From: [email-masked]
Date: Tue, 15 Dec 1998 12:38:24 -0600 (CST)

Full_Name: Nadim Saeed
Version: 2.1.5
CVS_Date: 
OS: SunOS 5.5.1 Generic_105428-01 sun4u sparc SUNW,Ultra-5_10

X_Server: 
Submission from: (NULL) (206.71.186.98)

With 2.1.5 the WinList buttons show their entries with 2 extra spaces that
weren't there in 2.0.45.  These 2 spaces were introduced, unnecessarily,
in
the MINI_ICON patch in 2.0.46
 
To clarify,
 
  was (2.0.45):         " TITLE "
  now (2.1.5) :         "  TITLE  "
 
It's taking up more room than is really necessary; a single space ought to
do.
 
NOTE: I do not use MINI_ICONS and so the titles are center-justified :-)

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Dec 1998 21:27:16 +0100

> NOTE: I do not use MINI_ICONS and so the titles are center-justified :-)

Well, that's the extra space reserved for the mini icons ;-)
Take a look at line 700 in FvwmWinList.c:

	tw+=14; /* for title icon */ /* Magic Number ? */

I'll put this in '#ifdef MINI_ICONS/#endif' so you can at
least compile FvwmWinList without this extra space. I see
no easy way to avoid this. Mini icons might be added or
removed at any time, so even if you can find out if there
is no mini icon in use you might pop up one a second later
and then your WinList would have to resize.

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]