Subject: 2.1.6 cores out

From: Dan Espen <[email-masked]>
Date: Tue, 22 Dec 1998 13:11:48 -0500

Today's download gives me:

(gdb) where
#0  0x36d08 in SetFocus (w=0, Fw=0x0, FocusByMouse=0)
    at ../../version-2_1_6/fvwm/focus.c:139
#1  0x49c6c in GrabEm (cursor=7) at ../../version-2_1_6/fvwm/misc.c:748
#2  0x30634 in ComplexFunction (eventp=0x76a60, w=0, tmp_win=0x0, 
    context=8, action=0xd2158 "", Module=0xefffd19c)
    at ../../version-2_1_6/fvwm/complex.c:187
#3  0x374b0 in ExecuteFunction (Action=0xd2128 "RemoveAllButtons", 
    tmp_win=0x0, eventp=0x76a60, context=8, Module=-2)
    at ../../version-2_1_6/fvwm/functions.c:275
#4  0x304a4 in ComplexFunction (eventp=0x76a60, w=0, tmp_win=0x0, 
    context=8, action=0xcdd54 "", Module=0xefffd394)
    at ../../version-2_1_6/fvwm/complex.c:159
#5  0x374b0 in ExecuteFunction (Action=0xefffd3b0 "DecorCustom\n", 
    tmp_win=0x0, eventp=0x76a60, context=8, Module=-1)
    at ../../version-2_1_6/fvwm/functions.c:275
#6  0x52cd8 in ReadSubFunc (eventp=0x76a60, junk=40, tmp_win=0x0, 
    context=8, action=0x7d065 ".fvwm2rc", Module=0xefffd96c, piperead=0)
    at ../../version-2_1_6/fvwm/read.c:164
#7  0x52dc4 in ReadFile (eventp=0x76a60, junk=40, tmp_win=0x0, context=8, 
    action=0x7d065 ".fvwm2rc", Module=0xefffd96c)
    at ../../version-2_1_6/fvwm/read.c:185
#8  0x37474 in ExecuteFunction (Action=0x63540 "Read .fvwm2rc", 
    tmp_win=0x0, eventp=0x76a60, context=8, Module=-1)
    at ../../version-2_1_6/fvwm/functions.c:269
#9  0x38520 in main (argc=1, argv=0xefffddbc)
    at ../../version-2_1_6/fvwm/fvwm.c:429

I keep trying to find time to look at the source, but things
are hectic here.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 14:24:53 +0100

> I keep trying to find time to look at the source, but things

Hm, line 139 can't be the reason:

    }

  if((Scr.Ungrabbed != NULL)&&              <--- 139
     (Scr.Ungrabbed->flags & ClickToFocus)
     && (Scr.Ungrabbed != Fw))

Can you give me a hint how to reproduce this?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 09:55:32 -0500

> Can you give me a hint how to reproduce this?

Not yet, and every attempt I make to close in on it
makes it core or hang somewhere else.

Must be something in my environment.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 15:59:49 +0100

> Must be something in my environment.

Have you tried to 'make distclean; ./configure'? This
sometimes works for me. builtins.c seems not always to
rebuild properly when one of its dependencies changed
(or pehaps the deps are not rebuilt). I changed some
of the dependencies recently.

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Dec 1998 10:11:01 -0500

> of the dependencies recently.

Very close to the right answer.
'Make clean;make install' fixed the problem.

Something's not right...