Subject: Coredump with ButtonStyle 1 MiniIcon

From: Tim Phipps <[email-masked]>
Date: Tue, 08 Dec 1998 17:32:21 +0000

Hi All,
    something changed between 2.1.3 and 2.1.4 that stopped my decors
working. I have the following bit in my fvwm2rc

AddToDecor my_decor WindowFont BOLD_MEDIUM

DestroyFunc decor_fvwm
AddToFunc decor_fvwm "I" Echo decor_fvwm
+   "I" AddToDecor my_decor HilightColor FG BG
+   "I" AddToDecor my_decor BorderStyle Simple -- HiddenHandles NoInset
+   "I" AddToDecor my_decor TitleStyle LeftJustified Height 16
+   "I" AddToDecor my_decor TitleStyle -- Flat
+   "I" AddToDecor my_decor TitleStyle ActiveDown -- Raised
+   "I" AddToDecor my_decor TitleStyle Inactive Solid HL -- Flat
+   "I" AddToDecor my_decor ButtonStyle 1 /*MiniIcon*/ -- UseBorderStyle
Flat
+   "I" UpdateDecor

DestroyFunc decor_pixmap
AddToFunc decor_pixmap "I" Echo decor_pixmap
+   "I" AddToDecor my_decor HilightColor Black HL
+   "I" AddToDecor my_decor BorderStyle Inactive TiledPixmap PT_004.xpm
-- HiddenHandles NoInset
+   "I" AddToDecor my_decor BorderStyle Active TiledPixmap PT_003.xpm --
HiddenHandles NoInset
+   "I" AddToDecor my_decor TitleStyle Inactive TiledPixmap PT_004.xpm
-- Flat
+   "I" UpdateDecor

I can switch between plain and pixmap frames without a recapture by
using the two functions.  Since 2.1.4 if I don't have the MiniIcon bit
commented out I get a coredump.  Funny thing is that typing that line
into FvwmConsole followed by a UpdateDecor works.

Any ideas?
Tim.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Dec 1998 19:04:53 +0100

> into FvwmConsole followed by a UpdateDecor works.

Yes. That sounds like a parsing problem and I bet it has
something to do with mine or Paul's memory leak fixes.
You might want to check the changes from 1st to 5th of
December.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 Dec 1998 11:41:00 +0100

fixed

Dominik