Subject: Re: menu delays

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 00:36:52 +0100

Date: Tue, 22 Dec 1998 02:43:54 +0100
From: Dominik Vogt <[email-masked]>
To: [email-masked]
Subject: Re: menu delays
Reply-To: [email-masked]
Mail-Followup-To: [email-masked]
X-Mailer: Mutt 0.93.1i
In-Reply-To: <[email-masked]>; from Dan Espen on Mon, Dec 21, 1998 at 04:38:56PM -0500

On Mon, Dec 21, 1998 at 04:38:56PM -0500, Dan Espen wrote:
> Kent Howard <[email-masked]> writes:
> > My current version of FVWM is up to date with CVS as of this
> > morning.  I wondering if someone could verify a problem that I'm
> > having.
> > 
> > Add the following menu to your config
> > 
> > AddToMenu test "window list" WindowList
> > 
> > and bind it to a button
> > 
> > Mouse 3 R A Popup test
> > 
> > Then try clicking that mouse button in the root menu and release
> > the button before about a half second.  The WindowList will not
> > appear.  There seems to be a minimum amount of time that the menu
> > has to be mapped before any of the elements will do anything.  My
> > root menu is setup so that I can do things really quickly, but
> > version 2.1.x has this delay.  Is this something that was
> > intended or a bug?
> 
> Now that I can reproduce this, it looks like  more of a feature than a
> problem.
> 
> I assume  the reason you  have "WindowList" in  a menu, rather than on
> Mouse 3 as a command,  is you have  other things in  the menu that you
> can  get to  thru mouse  motion,  but a  simple  click/release is  for
> WindowList.
> 
> If thats the case,  I would guess that  you wouldn't try this when the
> pointer is near the bottom of the screen?
> 
> It doesn't look to  me like  "ClickTime"  or "SetMenuDelay"  help with
> this.  Maybe someone that  knows the new menu  code better  has deeper
> insight.

Sorry, I take everything back. I can see it too. At the beginning
of menus.c (MenuInteraction) there's a line:

      usleep(MICRO_S_FOR_10MS);

with MICRO_S_FOR_10MS defines as:

      #define MICRO_S_FOR_10MS 10000

This looks right to me but obviously it does not work
as expected. Ore are we doing so much unnecessary stuff
above that?

Bye

Dominik
-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 10:11:48 +0100

> as expected. Ore are we doing so much unnecessary stuff

Ah, that is not the same problem. What I was talking about
is that on my system sub-menus take about twice as long
to pop up as I told them.

ANy ideas?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].