Subject: Re: StartsOnPage fails if application starts iconic (PR#96)

From: Bob Woodside <[email-masked]>
Date: Fri, 18 Dec 1998 09:24:41 -0600 (CST)

Thanks for the quick follow-up. I think I see what went
wrong, and it's definitely my doing (or maybe undoing?).
I'll check in the fix this evening (I have to do it from
home). StartsOnPage has a set of tests that was blindly
copied from another section of the placement code (the
very old part!), and the test for IconicState shouldn't
have been replicated, but it was.

    Can you elaborate on what you mean when you say "it
works with the former release"? I presume you mean that
all the other placement logic worked, not StartsOnPage.
If you applied the StartsOnPage unofficial patch and
actually had it working with -iconic windows, then there
is another level to the problem that I haven't seen yet.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Fri, 18 Dec 1998 11:24:18 -0600 (CST)

Philippe BOURDEU d'AGUERRE wrote:
> In conclusion, the deffect appears only in the page part
> (last 2 digits) of StartsOnPage.

	Great! This is exactly what I'm observing. I'll
check in the fix this evening.