Subject: Pixmap/transparent in FvwmButtons

From: Tore Morkemo <[email-masked]>
Date: 24 Nov 1998 18:18:13 +0100

Hi!

I'm having problems with this, from FvwmButtons.1:

       *FvwmButtonsPixmap pixmapfile
              Specifies a  background  pixmap  to  use.   Specify
              "none" for a transparent background.

>From fvwm-2.1.2

I have tried:

*FvwmButtonsPixmap none

And

*FvwmButtonsPixmap None /home/tore/pixmap/totd.xpm

None of them seems to work.

Tore.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Nov 1998 14:51:58 +0100

> None of them seems to work.

That depends on the pixmaps you use. First of all you need
pixmaps with a transparent background (i.e. a background
at all, normal icons don't have a background). Second the
transparent background does not work in containers, only
plain buttons.

All this should be valid with any other background too.
Could you try with a background pixmap?

Please send me you FvwmButtons config and one of the used
pixmaps so I can check this problem.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 25 Nov 1998 10:40:07 -0500

> pixmaps so I can check this problem.

The correct syntax appears to be:

*FvwmButtonsPixmap none

for my FvwmButtons,  this makes  anything  in a "Button"  float on the
root window.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].