Subject: unofficial patches

From: Dominik Vogt <[email-masked]>
Date: Fri, 27 Nov 1998 15:41:42 +0100

Hi folks,

can anybody tell me which of the patches in the 'unofficial
patches' directory have been or should be applied?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 27 Nov 1998 15:08:17 +0000

> patches' directory have been or should be applied?

My guestimate:

  DontFocusOffscreen.patch
	don't know

  FvwmTaskBar_with_plugins_au...
	don't know (Is there anything FvwmTaskbar does that can't be done with
FvwmButtons + FvwmIconMan etc?).

  MouseFocusOnStartup.patch
	In

  StackingOrder.patch
	In (and very nice it is too) (there is a note at the end about closing
the windowlist into a loop, I don't think we should do this but we could
use Scr.FvwmRoot.prev as the pointer to the last item now that nothing
uses it. It would be a performance gain but it would probably not be
noticeable until you start the 100th xterm on a slow computer).

  iconboxes.patch
	In (and great)

  miniicons.patch
	In

  new_anim_shade.patch
  shade_anim_1.3.patch
	Out (I tried it on 2.0.46 and it worked)

---

From: Bob Woodside <[email-masked]>
Date: Fri, 27 Nov 1998 10:20:29 -0500 (EST)

> > patches' directory have been or should be applied?

 	Definitely In.  (It was in the, um, nonexistent 2.0.47d.)

> 	Out (I tried it on 2.0.46 and it worked)

	Which one did you use? I've been looking into trying
to resurrect this one (post-2.2) using the FvwmAnimate module
technique.

- Bob

---

From: Tim Phipps <[email-masked]>
Date: Fri, 27 Nov 1998 15:23:54 +0000

> to resurrect this one (post-2.2) using the FvwmAnimate module
Sorry, I can't remember.
Tim.

---

From: Tomas Ogren <[email-masked]>
Date: Fri, 27 Nov 1998 17:25:57 +0100

> > patches' directory have been or should be applied?
[lotsofpatches]
> 	Out (I tried it on 2.0.46 and it worked)

new_anim_shade is built upon shade_anim_1.3 and fixes some serious
visual and semantic glitches (1.3 can turn into a while(1) loop if not
careful with parameters)... I have brought this patch along, and have it
up-to-date with current cvs if it's wanted.

I use it every day and it has caused no harm what-so-ever (since my
patches). I find it more pleasing to watch it zip together (and I use it
a lot on Sparcstation LX's and such, which has very limited cpu power).

It's not bloat, and it would be nice if it went in (I'll send an
up-to-date version if so)... diffstat:
 5 files changed, 101 insertions, 23 deletions

/Tomas
-- 
Tomas Ögren, [email-masked], http://www.ing.umu.se/~stric/
|- Student of Computer Science at the University of Umeå
`- Sysadmin at {ing,acc}.umu.se
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].