Subject: Background icon rendering.

From: German Jose Gomez Garcia <[email-masked]>
Date: Fri, 20 Nov 1998 00:57:31 +0100 (MET)

More ideas to the TODO list (this should be easy enough, maybe 
even I make it before starting the big change to MenuStyle).
	What about an option to render an Icon (a MiniIcon should not be 
necessary) by rendering first a background icon, for example BackIcon 
template_3d.xpm, and then rendering the icon specify by Icon. It would be
a very nice feature, and certainly very usefull.
	Another nice feature, not so easy as the first should be 
something I would call MagneticIcons <force> , with this command you 
could specify a "magnetic" force between icons, so when you move an icon 
near another it will be attracted and put side by side, we could use a 
rectangular attraction pattern, and the <force> parameter should specify 
how far one icon get attracted by others.

	Well, as you can see my brain is going faster than my fingers 
(and that isn't usual in my case :)

<>-------------------------------------+-----------------------------------<>
   One O.S. to rule them all,          |  German Gomez Garcia
      One O.S. to find them.           |  [email-masked]
   One O.S. to bring them all          |
      and in the darkness bind them.   |  "Wur Qanar Wur Stilor Wur Kas"
<>-------------------------------------+-----------------------------------<>

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Nov 1998 14:46:11 +0100

> a very nice feature, and certainly very usefull.

I don't understand what you mean with 'rendering'. Could you explain
this again for complete cretins?

> how far one icon get attracted by others.

That's SnapAttraction for Icons. Have you tried this? It's
in the CVS tree for a few days now. Works only for windows
at the moment but may not be too hard to patch for icons
too.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 20 Nov 1998 09:39:05 -0800

> how far one icon get attracted by others.

Sounds like SnapAttraction for Icons.  The underlying snap grid concept could
be applied to both classic SnapAttraction and that for Icons.
(I actually played with the underlying grid thing when I did SnapAttraction, 
but wasnt satisfied with the initial results due mainly to my personal usage 
patterns.  Therefore, I didnt really test it and therefore didnt submit the 
patch.  If there is interest I can submit the patch.)

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Nov 1998 18:44:15 +0100

> patch.  If there is interest I can submit the patch.)

Why not. Go ahead.

Dominik