Subject: Core in FvwmButtons

From: Brad Giaccio <[email-masked]>
Date: Thu, 12 Nov 1998 09:47:21 -0500 (EST)

I just grabbed the latest CVS 11/12 and everything seems okay except for
FvwmButtons during initilization it dumps core.  Unfortunatelly the best I
can get is a stack trace.  I can't seem to figure out what went wrong
from there so here it is.

Note: strings on my Xpm lib says
$XpmVersion: 3.4g $
$Id: xpm.shar,v 3.52 95/10/09 02:23:53 lehors Exp $

Program terminated with signal 9, Killed.
Reading symbols from /home/bgiaccio/lib/libXpm.so.4.7...done.
Reading symbols from /usr/local/X11R6/lib/libXext.so.6.0...done.
Reading symbols from /usr/local/X11R6/lib/libX11.so.6.0...done.
Reading symbols from /usr/lib/libsocket.so.1...done.
Reading symbols from /usr/lib/libnsl.so.1...done.
Reading symbols from /usr/lib/libc.so.1...done.
Reading symbols from /usr/lib/libthread.so.1...done.
Reading symbols from /usr/lib/libdl.so.1...done.
Reading symbols from /usr/lib/libmp.so.2...done.
Reading symbols from /usr/platform/SUNW,Ultra-1/lib/libc_psr.so.1...done.
#0  0xef7925d0 in xpmNextWord ()
(gdb) where
#0  0xef7925d0 in xpmNextWord ()
#1  0xef792570 in xpmNextUI ()
#2  0xef796d98 in ParseValues ()
#3  0xef796ae0 in xpmParseData ()
#4  0xef79a6a0 in XpmCreateXpmImageFromData ()
#5  0xef79a60c in XpmCreateImageFromData ()
#6  0x15d48 in PleaseAllocColor (color=0xeffff530) at FvwmButtons.c:1325
#7  0x160a0 in GetColor (name=0x30c68 "rgb:51/51/78") at
FvwmButtons.c:1415
#8  0x15248 in RecursiveLoadData (b=0x32eb8, maxx=0xeffff65c,
maxy=0xeffff658)
    at FvwmButtons.c:979
#9  0x14558 in main (argc=-1, argv=0x2fc00) at FvwmButtons.c:535

sorry I can't be more specific.
But Dominik, since you were the last one in there (accoring to the
Changelog) I thought you would have a better idea of what you did.

Brad

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 12 Nov 1998 17:11:07 +0100

On Thu, Nov 12, 1998 at 09:47:21AM -0500, [email-masked] wrote:
>...

I'll have a look.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Nov 1998 14:25:15 -0500

> #9  0x14558 in main (argc=-1, argv=0x2fc00) at FvwmButtons.c:535

Try as I might, I can't create the problem.  If you could recompile
the Xpm library with the -g flag, that would probably help a lot.

Never saw  that color  logic in  FvwmButtons  before, (using  the  XPM
library   to allocate  close  colors).  It   looks  too generic  to be
embedded in FvwmButtons.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 13 Nov 1998 08:09:49 -0500 (EST)

> 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]

I just tried building libxpm with -g and now I can't reproduce it with the
new library.  Perhaps my library was to old I had 4.7 and what I built -g
made 4.11.  With 4.11 Everything seems to work with or without -g 

Brad

---

From: [email-masked]
Date: Fri, 13 Nov 1998 14:15:54 +0100

> made 4.11.  With 4.11 Everything seems to work with or without -g 

If this is the case it must be documented somewhere (BUGS file?).

Dominik