Subject: fvwm 2.1.2 package

From: Dan Espen <[email-masked]>
Date: Thu, 19 Nov 1998 11:47:28 -0500

It appears that I can now make a package.  At least "make dist"
creates a tar.gz file that I can unpack and looks complete.

Let me know when you want to create one, and where I should put it.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 19 Nov 1998 17:49:23 +0100

> creates a tar.gz file that I can unpack and looks complete.

I think I got this far too (don't remember exactly), but
make distcheck failed. Have you tested that?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 19 Nov 1998 12:26:48 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> Let me know when you want to create one, and where I should put it.

When it does get built OK, upload it to ftp.hpc.uh.edu in
/pub/incoming/fvwm, let me know, and I'll move it to
pub/fvwm/version-2/testing.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Fri, 20 Nov 1998 10:54:32 -0500

> pub/fvwm/version-2/testing.

OK, I've completed a make distcheck and put the result in

/pub/incoming/fvwm/de-2.1.2.tar.gz

Why the funny name?  Seemed to be something in the way.  The transcript
is below.

I had a problem with "make distcheck" with tar vs. gtar.
The only way I could get the make to work is:

gnumake TAR=gtar distcheck

I think somethings wrong, some of the Makefiles call for gtar and
some call for tar.

ftp> cd /pub/incoming/fvwm
250-
250-Place FVWM related items here.
250-You cannot download files from here.  After uploading,
250-send mail to [email-masked] and the files will
250-be moved appropriately.
250-
250-
250 CWD command successful.
ftp> put fvwm-2.1.2.tar.gz
200 PORT command successful.
150 Opening BINARY mode data connection for fvwm-2.1.2.tar.gz.
ftp: accept: Protocol error
426 Data Connection: Connection reset by peer.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
mlistarc.tgz
.message
fvwm-griff-0.2.00.lsm
fvwm-griff-0.2.00.tar.gz
fvwm-2.1.2.tar.gz
226 Transfer complete.
92 bytes received in 0.019 seconds (4.6 Kbytes/s)
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
total 992
drwxrwxr-x   2 ftp      ftp           512 Nov 20 15:45 .
drwxrwxr-x  15 ftp      staff         512 Aug 25 00:04 ..
-rw-r--r--   1 tibbs    staff         166 Nov 23  1995 .message
-rw-rw----   1 tibbs    260             0 Nov 20 15:45 fvwm-2.1.2.tar.gz
-rw-rw----   1 tibbs    260           406 Oct 27  1997 fvwm-griff-0.2.00.lsm
-rw-rw----   1 tibbs    260          3761 Oct 27  1997 fvwm-griff-0.2.00.tar.gz
-rw-rw----   1 tibbs    260        992047 May 30  1996 mlistarc.tgz
226 Transfer complete.
495 bytes received in 0.025 seconds (20 Kbytes/s)
ftp> put fvwm-2.1.2.tar.gz
200 PORT command successful.
553 fvwm-2.1.2.tar.gz: Permission denied. (Overwrite)
ftp> put fvwm-2.1.2.tar.gz de-2.1.2.tar.gz
200 PORT command successful.
150 Opening BINARY mode data connection for de-2.1.2.tar.gz.
226 Transfer complete.
local: fvwm-2.1.2.tar.gz remote: de-2.1.2.tar.gz
1003926 bytes sent in 75 seconds (13 Kbytes/s)

---

From: Jason L Tibbitts III <[email-masked]>
Date: 20 Nov 1998 10:34:17 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> OK, I've completed a make distcheck and put the result in

DE> /pub/incoming/fvwm/de-2.1.2.tar.gz

It's been moved and named appropriately.  I don't know what the problem
with the zero-length file was.

 - J<

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Nov 1998 17:39:17 +0100

Thanks, Dan. But remember to tag the sources before making
the distribution. Otherwise the sources might change while
you 'make distcheck' and the tree cannot be tagged correctly
anymore. I'll write this into the DEVELOPERS file.

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Fri, 20 Nov 1998 12:16:53 -0500

> anymore. I'll write this into the DEVELOPERS file.

Disposing of  old  mail,   I  see  that  the  next   step is  to  edit
configure.in and update the version.

Perhaps you will add that to the DEVELOPERS file?

You can update configure.in if you want to.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Nov 1998 18:20:17 +0100

> configure.in and update the version.

As I read this everything is already committed :)

Dominik

---

From: Steve Robbins <[email-masked]>
Date: Sat, 21 Nov 1998 00:12:27 -0500 (EST)

On Fri, 20 Nov 1998, Dan Espen wrote:

> I think somethings wrong,

Yeah, it's an automake oddity.  What you did is the best way to handle
this for now.  I think automake should be fixed, and I've raised the issue
on the automake mailing list. 

The deal is: automake was envisaged for a "single maintainer" to use.  As
such, it hardcodes the value of TAR in the _maintainer_ makefiles.  By
checking in the Makefile.in files to CVS, we broke this single-maintainer
model.  I chose to do this, so as NOT to force every sundry developer to
have all the auto tools lying around. 

> some of the Makefiles call for gtar and some call for tar. 

The makefiles inherit the TAR setting from the Makefile.in's, which means
it is set by whoever last checked in the Makefile.in. 

--
Steve Robbins                              <[email-masked]>

I'd probably be famous now, if I wasn't such a good waitress.