Subject: FvwmButtons Panel direction bug

From: Tore Morkemo <[email-masked]>
Date: 24 Nov 1998 12:30:00 +0100

Hi!

I tried the dierction stuff on Panels, like this:

    *FvwmButtons(Title Tools,Panel (Left) Tools)

and the Panel got lost.

I found the bug in fvwm-2.1.2/modules/FvwmButtons/parse.c

I fixed the problem with this patch:

***************
*** 648,656 ****
--- 648,658 ----
              {
                s++;
                t = seekright(&s);
+ /*
                while(*s && *s!=')')
                  s++;
                if(*s==')')s++;
+ */
              }
              if      (strncasecmp(t,"right",5)==0) t = "panel-r";
              else if (strncasecmp(t,"left" ,4)==0) t = "panel-l";

Comment out/delete the while loop and the test for ')'.

Now everything works fine. Nice panels!

--
Tore.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Nov 1998 13:01:05 +0100

> I fixed the problem with this patch:

Oops, you cannot just remove the test for ')'. Parsing might
lose track of the number of '('s open. But thanks for the hint.
I will fix this.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].