Subject: More changes to 2.1.0?

From: Dan Espen <[email-masked]>
Date: Tue, 03 Nov 1998 10:47:52 -0500

Now that I'm able to build, and I've caught up on my job again,
I'd like to publish the web page updates.

Any objection to:

1)  Adding  the changes   to the main   branch?  I  don't  see how new
documentation can de-stabilize 2.1.0....

2) Removing ChangeLog from the web documentation.

3) Removing the FAQ and TO-DO text files, to be replaced with
docs/FAQ.html and docs/TO-DO.html.

4) Removing docs/modules.css and docs/modules.tex.

5) Having the web documentation in the docs directory.  I know it will
add size, but I think it belongs there.  Here is the current size:

    1729 Oct 30 16:24 black-stone1.jpg
     793 Nov  1 22:54 docs.html
    1445 Nov  1 16:29 download.html
   49413 Nov  1 16:28 FAQ.html
    2159 Nov  1 16:29 features.html
    1615 Oct 30 16:11 ftp.html
    2807 Nov  1 16:29 fvwm.gif
    1343 Nov  1 16:29 index.html
    4123 Nov  1 16:30 links.html
    1615 Nov  1 16:30 mailinglist.html
    1626 Nov  1 16:30 mod_changes.html
    1324 Nov  1 16:31 mod_concept.html
   18776 Nov  1 16:31 mod_f2m_communication.html
    5916 Nov  1 16:31 mod_initialization.html
    5984 Nov  1 16:31 mod_m2f_communication.html
     933 Nov  1 16:32 mod_security.html
    1258 Nov  1 22:54 modules.html
    8868 Nov  3  1998 news.html
    1628 Nov  1 22:54 README
    1135 Oct 30 16:01 version.html
   11133 Nov  3  1998 TO-DO.html

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: /users/domivogt <[email-masked]>
Date: Tue, 3 Nov 1998 16:56:04 +0100

> Any objection to:
...

No, ok by me.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randall S. Winchester" <[email-masked]>
Date: Tue, 3 Nov 1998 11:44:50 -0500 (EST)

I would rather see this all in a format that could be converted to HTML,
MAN, TEX, or TXT type formats. Perl's "pod" (perlpod) is one of these. I
personally do not want to grock an html file while installing new releases
of anything. I do like to put them up for users however. I also like to
print them out once in a while and read them while helping the kids with
their homework.

Randall

On Tue, 3 Nov 1998, Dan Espen wrote:

: 
: Now that I'm able to build, and I've caught up on my job again,
: I'd like to publish the web page updates.
: 
: Any objection to:
: 
: 1)  Adding  the changes   to the main   branch?  I  don't  see how new
: documentation can de-stabilize 2.1.0....
: 
: 2) Removing ChangeLog from the web documentation.
: 
: 3) Removing the FAQ and TO-DO text files, to be replaced with
: docs/FAQ.html and docs/TO-DO.html.
: 
: 4) Removing docs/modules.css and docs/modules.tex.
: 
: 5) Having the web documentation in the docs directory.  I know it will
: add size, but I think it belongs there.  Here is the current size:
: 
:     1729 Oct 30 16:24 black-stone1.jpg
:      793 Nov  1 22:54 docs.html
:     1445 Nov  1 16:29 download.html
:    49413 Nov  1 16:28 FAQ.html
:     2159 Nov  1 16:29 features.html
:     1615 Oct 30 16:11 ftp.html
:     2807 Nov  1 16:29 fvwm.gif
:     1343 Nov  1 16:29 index.html
:     4123 Nov  1 16:30 links.html
:     1615 Nov  1 16:30 mailinglist.html
:     1626 Nov  1 16:30 mod_changes.html
:     1324 Nov  1 16:31 mod_concept.html
:    18776 Nov  1 16:31 mod_f2m_communication.html
:     5916 Nov  1 16:31 mod_initialization.html
:     5984 Nov  1 16:31 mod_m2f_communication.html
:      933 Nov  1 16:32 mod_security.html
:     1258 Nov  1 22:54 modules.html
:     8868 Nov  3  1998 news.html
:     1628 Nov  1 22:54 README
:     1135 Oct 30 16:01 version.html
:    11133 Nov  3  1998 TO-DO.html
: 
: --
: Dan Espen                                Phone: (732) 699-5570
: 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
: Piscataway, NJ 08854
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
: body of a message to [email-masked].
: To report problems, send mail to [email-masked].
:

---

From: Steve Robbins <[email-masked]>
Date: Tue, 3 Nov 1998 12:25:39 -0500 (EST)

> docs/FAQ.html and docs/TO-DO.html.

I'd rather leave TODO as a straight text file.  I think of it as a
developer-kind of file -- like a ChangeLog -- used for jotting down short
notes.  Having to write stuff in HTML makes it cumbersome to use in this
way.

As for FAQ; is there no way we could keep it in text?  I find it helpful
if what I need to know to install a package is available in text.  This
would be the files INSTALL*, README*, but the FAQ file is also often
useful.  If you prefer to write the FAQ in HTML, you can always use "lynx
-dump" to derive a reasonable text file from it. 

> 4) Removing [...] docs/modules.tex.

I assume the content of modules.tex is somewhere in the html files?  If
so, then I have no problem removing it.

---

From: Dan Espen <[email-masked]>
Date: Tue, 03 Nov 1998 13:38:37 -0500

> -dump" to derive a reasonable text file from it. 

The old technology was a script called "txt2html" which I guess Jason
ran that wrapped some html around the FAQ, TO-DO and ChangeLog.

I made a version of that shell and we could go that way.  However,
this is what the front of the new FAQ looks like:

<html>
<head>
<title>The Official FVWM Homepage - FAQ Information</title>
</head>
  <body BACKGROUND="black-stone1.jpg"
    bgcolor="#000000" text="#ffffff"
    link="#FFFF88" vlink="#EEDDDD" alink="#ff0000">
<center>
<h1><font color="pink">The Official FVWM Homepage - FAQ Information</font></h1>
</center>
<pre>

======================================================================
                   FVWM Frequently Asked Questions
======================================================================

INDEX

        1) What does FVWM stand for?
        2) Where do I find the current versions of fvwm?
        3) Any WWW Sites about FVWM?
        4) Where do I ask questions about FVWM?
        5) What are the differences between FVWM 1.xx and 2.xx?

I didn't think that was any  harder to edit, and  it eliminates a step
in the release process.

Whether we like black stone backgrounds  pink titles and white text is
another issue, which I imagine we will be addressing soon.

> so, then I have no problem removing it.

Of  course, no information has  been lost, and its  even a little more
complete and correct than it was before.

---

From: Jason L Tibbitts III <[email-masked]>
Date: 03 Nov 1998 12:48:49 -0600

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> The old technology was a script called "txt2html" which I guess Jason
DE> ran that wrapped some html around the FAQ, TO-DO and ChangeLog.

Actually that was all Chuck's doing.  The web pages are originally his;
I've just done minor editing by hand.

 - J<

---

From: Steve Robbins <[email-masked]>
Date: Tue, 3 Nov 1998 14:27:37 -0500 (EST)

> > -dump" to derive a reasonable text file from it. 

[ ... ]

> this is what the front of the new FAQ looks like:

[ ... ]

> I didn't think that was any  harder to edit, and  it eliminates a step

I take back what I said about the FAQ.  I'm okay with it as HTML.
Whatever the FAQ-maintainer feels is easiest for him/her to maintain is
the way to go.

However, I do think the NEWS and TODO (not "TO-DO") should be straight
text files in the toplevel, as per GNU standards.  ;-) 

> another issue, which I imagine we will be addressing soon.

Ah, the joys and perils of HTML!  ;-)

--
Steve Robbins                              <[email-masked]>

I was looking back to see
if you were looking back at me
to see me looking back at you.

---

From: Dan Espen <[email-masked]>
Date: Tue, 03 Nov 1998 14:42:25 -0500

> text files in the toplevel, as per GNU standards.  ;-) 

OK, I'm back to the txt2html approach.  If I use txt2html for NEWS and
TODO, I might as well do the FAQ the same way.  Yes,  I got it, rename
the TO-DO file.

> Ah, the joys and perils of HTML!  ;-)

Oh, oh, doesn't sound like an auspicious start.