Subject: Re: More newmenu stuff

From: Bob Woodside <[email-masked]>
Date: Fri, 6 Nov 1998 01:27:51 -0500 (EST)

[email-masked] wrote:
> On Tue, Nov 03, 1998 at 09:47:31PM -0500, [email-masked] wrote:
> > I saw this a while ago, then it went away, now its back.
> 
> When?
> 
> > I have a menu like this:
> > 
> > AddToMenu "Misc-Utilities" "Misc-Utilities" Title
> > +  "&A. audiotool - Sound Editor" Exec cd $HOME/audio;nice audiotool
> > ...
> > +  "Monitoring" Title
> > +  "%mini.chart.xpm%&S. sysinfo - prompt" Sysstatsprompt
> > 
> > Only the part from "Monitoring" down displays.
> 
> Does this mean not all menu entries are shown? Or are you just
> missing the title? Can you send me the complete Menu definition?

	What happens is that the second title and everything below it
display; everything above the line containing the second title gets lost.

> I changed the behaviour when 'Title' was used within a menu.
> This sould mess up the menu under certain circumstances, so
> I rewrote that so that the title *always* goes to the top.
> I recommend using separators for a fake Title withing the menu.

 	I don't think this is really going to be a palatable solution.
The reason that people like to use additional titles is appearance -
they're neatly centered. I vote for trying to find a better way around
the problem (whatever it was) than removing an attractive feature:
people just hate that.

- Bob

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 06 Nov 1998 08:34:49 -0500

Just a thought about the menus.

We may be tyring to support too many options.

One of the things I control for most of my users is menu
action and appearance.  I fully intend to change the default
behavior to animated, I don't expect to get any resistance
to that.

Perhaps that should be the ONLY choice?

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 6 Nov 1998 15:36:41 +0100

> Perhaps that should be the ONLY choice?

I think animated menus are fancy, but I don't like them very
much because on my desktop the only place to pop up menus is
near the right edge, so my menus do alway animate. I definitely
want to be able to turn them off.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].