Subject: Lower Bug

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Nov 1998 13:54:11 -0500 (EST)

Thought I should through this out, has anyone else noticed a problem using
Lower and Sometimes Raise from a menu, Keyboard shortcuts work but, menus
don't seem to

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 19:57:12 +0100

On Mon, Nov 30, 1998 at 01:54:11PM -0500, [email-masked] wrote:
> don't seem to                                                       ^^^^^
                                                                        |
I assume you mean mouse? -----------------------------------------------|

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 30 Nov 1998 14:27:39 -0500 (EST)

> I assume you mean mouse? -----------------------------------------------|
you're right I did mean mouse.

With some checking a straight
Mouse 3 T A Lower   -- does work
but a call Move-or-Lower that looks like

AddToFunc Move-or-Lower 
+ "C" Lower
+ "M" Move

now if I add an "I" Lower it will lower but I get a move start.
if I do give Motion then it does a Move.

So the problem seems to be on the click, and with further investigation it
does seem to be related to functions that use "C".

Now I do recall some discussion, about half clicks but I don't think
anything was done but I'm sure someone else can tell me.

I do know that these functions worked with a cvs grab from Monday shortlly
after the tag change to 2_1_3 was made.  So can someone help me out here.

After looking at the changelog I see two refrences to SetClick in
builtins.c and a bunch of stuff hapened in events.c to handle ClickToFocus
windows. So Dominik does this help any or should I start digging (I only
singled you out because your name is on the comment in the ChangeLog, Tim
may have created the patches I lost track overthe holidays).

 Brad

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 20:39:01 +0100

> anything was done but I'm sure someone else can tell me.

Something *was* done. I created an enhancement request in 
Jitterbug 8-)
 
> windows.

SetClick has nothing to do with it. I changed the parser and
changed Scr.ClickTime - hmm, come to think of it, should I
have forgotten...? Oh shit, I introduced a fFvwmInStartup
global in fvwm.c that indicates if fvwm has reached the
HandleEvents loop or not. Click time is set to -ClickTime
during startup and obviously I forgot to reset fFvwnInStartup.

I'll see to this immediately.

Bye

Dominik