Subject: Compile on FreeBSD?

From: "Viren R. Shah" <[email-masked]>
Date: Tue, 24 Nov 1998 11:54:45 -0500 (EST)

[i'm not on the -workers list. Please cc: me on replies]

Hi,
  I just tried 2.1.2, and it still fails to compile on FreeBSD. Could
  someone take a look at my previous msg, please. It's in the fvwm
  archive as :
  http://www.hpc.uh.edu/fvwm/archive/9811/msg00846.html
  
  If someone has already changed this, thanks. Otherwise, I've
  attached a diff to the 2.1.2 files below. 

--- libs/ModParse.h.orig	Tue Nov 24 11:33:53 1998
+++ libs/ModParse.h	Tue Nov 24 11:30:40 1998
@@ -33,7 +33,9 @@
 #include <assert.h>
 #include <stdio.h>
 #include <string.h>
+#if !defined(__FreeBSD__)
 #include <search.h>
+#endif
 #include <stdlib.h>                     /* for free() */
 
 char *PeekArgument(const char *pstr);
--- ./modules/FvwmEvent/Parse.h.orig	Tue Nov 24 11:32:58 1998
+++ ./modules/FvwmEvent/Parse.h	Tue Nov 24 11:33:17 1998
@@ -27,7 +27,9 @@
 #include <assert.h>
 #include <stdio.h>
 #include <string.h>
+#if !defined(__FreeBSD__)
 #include <search.h>
+#endif
 /*#include "../../libs/fvwmlib.h"*/
 
 char *PeekArgument(const char *pstr);
--- ./extras/FvwmConsole/FvwmConsole.h.orig	Tue Nov 24 11:34:58 1998
+++ ./extras/FvwmConsole/FvwmConsole.h	Tue Nov 24 11:35:45 1998
@@ -4,6 +4,8 @@
 #include <sys/bsdtypes.h>
 #endif
 
+#include <sys/types.h>
+
 #if HAVE_SYS_SELECT_H
 #include <sys/select.h>
 #endif
@@ -14,7 +16,6 @@
 #include <sys/stat.h>
 #include <fcntl.h>
 #include <sys/time.h>
-#include <sys/types.h>
 #include <sys/un.h>
 #include <sys/socket.h>
 #include <signal.h>
--- ./extras/FvwmScript/types.h.orig	Tue Nov 24 11:36:26 1998
+++ ./extras/FvwmScript/types.h	Tue Nov 24 11:36:51 1998
@@ -9,7 +9,9 @@
 #include <unistd.h>
 #include <ctype.h>
 #include <stdlib.h>
+#if !defined(__FreeBSD__)
 #include <malloc.h>
+#endif
 #include <sys/time.h>
 
 #define XK_MISCELLANY

Thanks
Viren
-- 
Viren R. Shah                  | "Are those numbers measured values,
[email-masked]              |  or are you engaging in proctonumerology?"
http://www.rstcorp.com/~vshah/ |  -- Bill Garrett in raswrj

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Nov 1998 17:59:28 +0100

>   http://www.hpc.uh.edu/fvwm/archive/9811/msg00846.html

It hasn't get lost. It just takes some time (I'm not myself
concerned with compiling issues and had hoped someone else
would look after this).

To all: there was some discussion about ifdefs that I didn't follow.
Is this patch the correct things to do? 

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 24 Nov 1998 12:17:23 -0500

%% Dominik Vogt <[email-masked]> writes:

  dv> To all: there was some discussion about ifdefs that I didn't follow.
  dv> Is this patch the correct things to do? 

No, these shouldn't be applied as-is.

In the World of Autoconf you _never_ want to see specific system tests
like that.  It does sometimes happen, but it always leads to tears.

I'll try to look at it, since Steve is underwater.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].