Subject: [[email-masked]: New module]

From: [email-masked]
Date: Wed, 18 Nov 1998 11:29:07 +0100

----- Forwarded message from [email-masked] -----

Date: Wed, 18 Nov 1998 00:05:57 +0900
Subject: New module
From: [email-masked]
To: [email-masked]

--------- snip ---------

What I need to know first of all is how to contribute it. Is it OK (for the
fvwm mailing list's netiquette and reader's bandwidth) to send a whole
module in an e-mail? What do you recommend? (For instance: you or another
maintainer could put it in the unofficial patches directory, and after that
I could announce it in the mailing list and have people try it for a while).

By the way, below is an announcement of the module, so you will know what it
is about before unpacking it...

---------------------------------

The attached files have FvwmStyleCmd.pl, a module that I created which I
hope to have distributed with Fvwm. This module works like a Style function
that accepts any Fvwm command instead of only style options. Some examples
of what can be done (in the format used in the .fvwm2rc file) are:

# Maximize ghostview by default
*FvwmStyleCmd  -resource  "ghostview"   Maximize
# Maximize emacs and xdvi on the vertical by default
*FvwmStyleCmd  -resource  "emacs"  Maximize 0 100
*FvwmStyleCmd  -resource  "xdvi"   Maximize 0 100
# Move Netscape's download windows to the right and return focus to
# the browser window
*FvwmStyleCmd  -name "Netscape Download" Move 50 75, Prev [*] Focus
# Move Netscape's Find window to the right, and place the mouse pointer
# on the input field
*FvwmStyleCmd  -name "Netscape: Find" Move 60 50, WarpToWindow 80 30

The module is simple, but it answers some requests that I found in the
mailing list (e.g., maximize by default) and has the potential to do a lot
more (without any programming by the user). Please give a try.

By the way, this module uses the fvwmmod.pl in extras/fvwmperl. I know that
fvwmperl has reached a dead end, I have already talked to Dan Astoorian and
Randy Ray (the author of X11::Fvwm). Porting this module to X11::Fvwm might
be The Right Thing, but:
- I am worried that since X11::Fvwm is distributed separately from Fvwm
(Randy prefers it this way) it will reach far less people.
- I am using Perl to make the initial development of the module faster. I
want to make a C language version as soon as I get some feedback.

All comments are welcome.

---------------------------------

Thanks in advance,

                         Fred Maciel
                         E-mail  [email-masked]

Disclaimer:
I don't speak for Hitachi,
I don't know who speaks for Hitachi,
I don't want to know who speaks for Hitachi.

----- End forwarded message -----

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 18 Nov 1998 10:07:43 -0500

> I could announce it in the mailing list and have people try it for a while).

You don't need a maintainer  to get things  in the unofficial  patches
directory.  Right now I can't put my fingers  on the instructions, but
I'm sure someone else on this list can supply them.

I see there is a copy attached, perhaps you won't need to do that.
> is about before unpacking it...

Neat!  I've been  thinking  of revising  the builtin "sytle"   command
wildcard matching rules, and you came up with a possible syntax.

That would give us:

Style -class "XTerm" Icon xterm.xpm
Style -class "XTerm" -name "AIX*" Icon aix-xterm.xpm

Did you happen to use wildcard matches in the FvwmStyle module?

Perhaps there is a way to integrate this with FvwmEvent?

> want to make a C language version as soon as I get some feedback.

I would prefer a C implementation also.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].