Subject: More newmenu stuff

From: Dan Espen <[email-masked]>
Date: Tue, 03 Nov 1998 21:47:31 -0500

I saw this a while ago, then it went away, now its back.

I have a menu like this:

AddToMenu "Misc-Utilities" "Misc-Utilities" Title
+  "&A. audiotool - Sound Editor" Exec cd $HOME/audio;nice audiotool
...
+  "Monitoring" Title
+  "%mini.chart.xpm%&S. sysinfo - prompt" Sysstatsprompt

Only the part from "Monitoring" down displays.

Here's another one.

mwm style menus without animation when trying to pop up a submenu near
the right edge  of the screen, pop up  the submenu all  the way to the
left of the screen.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: /users/domivogt <[email-masked]>
Date: Wed, 4 Nov 1998 10:09:10 +0100

> the right edge  of the screen, pop up  the submenu all  the way to the

I'll check these.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 4 Nov 1998 19:39:13 +0100

> I saw this a while ago, then it went away, now its back.

When?

> Only the part from "Monitoring" down displays.

Does this mean not all menu entries are shown? Or are you just
missing the title? Can you send me the complete Menu definition?

I changed the behaviour when 'Title' was used within a menu.
This sould mess up the menu under certain circumstances, so
I rewrote that so that the title *always* goes to the top.
I recommend using separators for a fake Title withing the menu.

> the right edge  of the screen, pop up  the submenu all  the way to the

That was a stupid bug in my menu position code. I'll fix it today.

Dominik