Subject: misc.c fails to compile without mini-icons

From: Tim Phipps <[email-masked]>
Date: Tue, 17 Nov 1998 09:40:54 +0000

Morning,
	While trying to track something down I found that fvwm/misc.c is
missing an ifdef.  Patch attached.

Cheers,
Tim.

Index: misc.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/misc.c,v
retrieving revision 1.12
diff -u -B -b -r1.12 misc.c
--- misc.c	1998/11/16 09:41:54	1.12
+++ misc.c	1998/11/17 09:36:25
@@ -140,10 +140,12 @@
       XFreePixmap(dpy, Tmp_win->icon_maskPixmap);
     }
 
+#ifdef MINI_ICONS
   if (Tmp_win->mini_icon)
     {
       DestroyPicture(dpy, Tmp_win->mini_icon);
     }
+#endif
 
   if (Tmp_win->icon_w)
     {

---

From: Tim Phipps <[email-masked]>
Date: Tue, 17 Nov 1998 09:57:19 +0000

> missing an ifdef.  Patch attached.

Just another thought: there are 14 on/off switches that configure can
use do you think we should test all combinations (16384) to make sure it
will always compile.  My guess is that trying all-on, all-off, (all-on
minus one) * 14, (all-off plus one) * 14 would probably find all
problems.

Any thoughts?
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 17 Nov 1998 20:21:41 +0100

done

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].