Subject: More problems in fvwm 2.1.2 build...

From: [email-masked]
Date: Mon, 23 Nov 1998 09:36:49 -0500 (EST)

fvwm/builtins.c:  Line 2394
	- looks like the line was broken in the middle of a string.

extras/FvwmCommand/FvwmCommand.c:  Line 177:

  if ((Frun = fopen (Fr_name,"w" )) >= 0) {

	- Can somebody tell me what kind of programming construct this
	  is?  I mean, is there any definition of the signed'ness of
	  pointers?  This elicits a compile error with DEC C.

-- 
Larry Gensch					      [email-masked]

               "May I have ten thousand marbles, please?"

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 23 Nov 1998 09:46:09 -0500 (EST)

>   if ((Frun = fopen (Fr_name,"w" )) >= 0) {
should be 
   if ((Frun = fopen (Fr_name,"w" )) != NULL) {

> 	  pointers?  This elicits a compile error with DEC C.
A bad one, it is probably a leftover from when file routines returned an
unsigned long on success or 0 on failure, in which case the test is valid,
it also still works, I guess, since NULL == 0, under most compilers. But
none the less someone should commint the change to !=NULL.

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Nov 1998 16:00:11 +0100

> 	- looks like the line was broken in the middle of a string.

Can you post the line? There's no string at all on line 2394
of my copy.

> 	  pointers?  This elicits a compile error with DEC C.

I'd say it's a bug. Pointers should be unsigned.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 23 Nov 1998 11:44:16 -0500 (EST)

> Can you post the line? There's no string at all on line 2394

Typo:  Line 2934 (so much for short-term memory).

I changed the line to read (some initial spaces removed):

          "expected number of colors to allocate in gradient");