Subject: CursorMove and paging

From: Tim Phipps <[email-masked]>
Date: Mon, 23 Nov 1998 14:54:55 +0000

Does anyone use CursorMove to switch pages?  The man page implies that
CursorMove 200 0 will move two pages to the right but all that happens
is that the cursor gets banged up against the right hand side.  The code
in builtins.c (routine: movecursor) has some weird stuff starting at
line 628:
#ifndef NON_VIRTUAL
  if(x >= Scr.MyDisplayWidth -2 && val1 > 0)
  {
    delta_x = Scr.EdgeScrollX;
    warp_x = Scr.EdgeScrollX - 4;
  }

The 2 I think refers to the pan frame width so it ought to use that
macro, I have no idea what the 4 is for.

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Nov 1998 16:08:34 +0100

> macro, I have no idea what the 4 is for.

I added the val1 > 0 test recently to fix another bug (sorry, can't
remember what it was). You remove it and try again. You'll probably
find something in the ChangeLog.

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Nov 1998 16:11:53 +0100

On Mon, Nov 23, 1998 at 04:08:34PM +0100, [email-masked] wrote:
> You remove it and try again.
  ^^^^^^^^^^^^^

Oops, I meant 'You could remove it...' ;-)

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Nov 1998 11:26:44 +0100

On Mon, Nov 23, 1998 at 02:54:55PM +0000, [email-masked] wrote:
> is that the cursor gets banged up against the right hand side.

I rewrote the function to do what is described in the manpage.
This was a tough one :)

> The code

I think it's a typo. Anyway, you won't find anything like this
in the new function.

Bye

Dominik