Subject: Minor problem...

From: [email-masked] (Paul D. Smith)
Date: 04 Nov 1998 01:14:53 -0500

I'm trying to compile the whole tree with -DDEBUG; I get an error in
extras/FvwmScript/FvwmScript.c because when DEBUG is defined it assumes
you have some kind of heap debugging library which I don't have.

1998-11-04  Paul D. Smith  <[email-masked]>

    * extras/FvwmScript/FvwmScript.c: Change DEBUG to MEMDEBUG where
    it masks the heap debugging library references, so you don't have
    to have it to compile fvwm2 with -DDEBUG.

--- extras/FvwmScript/FvwmScript.c        1998/10/14 00:03:28     1.1.1.1
+++ extras/FvwmScript/FvwmScript.c        1998/11/04 06:12:54
@@ -6,7 +6,7 @@
 
 #include "types.h"
 
-#ifdef DEBUG                   /* For debugging */
+#ifdef MEMDEBUG                        /* For debugging */
 #include <unchecked.h>
 #endif
 
@@ -19,7 +19,7 @@
 extern int TabIdObj[101];
 extern Bloc **TabIObj;
 extern CaseObj *TabCObj;
-#ifdef DEBUG
+#ifdef MEMDEBUG
 extern int __bounds_debug_no_checking;
 #endif
 
@@ -127,7 +127,7 @@
  int i=16;
 
  /* Connextion au serveur X */
-#ifdef DEBUG
+#ifdef MEMDEBUG
  __bounds_debug_no_checking=True;
 #endif
 
@@ -138,7 +138,7 @@
   exit(1);
  }
 
-#ifdef DEBUG
+#ifdef MEMDEBUG
  __bounds_debug_no_checking=False;
 #endif

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 10 Nov 1998 18:47:27 +0100

Have you committed that patch, Paul?

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 10 Nov 1998 13:13:06 -0500

Yes, that's in there already.

I've successfully built the entire tree with --enable-extras and
CFLAGS=-DDEBUG :)

Now, how _useful_ that was is questionable, given the varying levels of
debugging (and the fact that fvwm itself seems to have a different way
to enable debugging), but it all compiled.

Someday, someone should look into unifying this and providing a
flexible, basic debugging capability.  I made a start on this with the
DB(()) macro in fvwmlib.h and libs/debug.c, but more needs to be done:

 1) The debugging output should (optionally?) go to a file and the
    filename should (optionally?) be based on the app name, so you can
    keep separate files for each module if you want.  This is the
    biggest pain with Purify, since the logfile is stored in an
    env. variable and so all the modules try to use the same logfile
    :-/.  If I want to purify multiple modules I have to run it with the
    graphical tool, then write the logfiles by hand.

 2) There should probably be different levels of debugging you can set;
    some of the debugging statements I added while testing the module
    packet stuff generated so much output I had to comment them out;
    being able to specify verbosity would be much better.

Just whistling in the wind...

---

From: [email-masked]
Date: Tue, 10 Nov 1998 19:59:19 +0100

> DB(()) macro in fvwmlib.h and libs/debug.c, but more needs to be done:

If you document this stuff we could put it in the instructions
for developers. The biggest problem is that everything has already
been written twice, but you don't know where.

>     keep separate files for each module if you want.
>...
> 
>...
 
> Just whistling in the wind...

*Sigh* So much to do and so little time. I'd like to do lots
of cleanups for parsing and debugging if I only had the time.
But this must probably wait until 2.2.

Bye

Dominik