Subject: FvwmIconMan broken today 10th November

From: Tim Phipps <[email-masked]>
Date: Tue, 10 Nov 1998 10:47:43 +0000

Don't know what happened but FvwmIconMan crashes on start-up.  The
following is all that it prints. The complaint about /dev/console has
been around for yonks and is almost certainly not the problem though it
should be fixed one day.
This is without any configuration lines at all.

*FvwmIconMan: cannot open /dev/console
screen width: 1280
screen height: 1024
I'm assuming you only want one manager
in parse_function
parse_function: 0x13bb0
in parse_function
Mouse: 0 0 sendcommand Iconify
Manager 1:
ShowPage
DontShow:
        mask = 0xf
Show:
        mask = 0xf
Font: 

It doesn't complete the Font: line

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 11 Nov 1998 09:36:35 +0100

> been around for yonks and is almost certainly not the problem though it

Never seen this. What was the last revision that worked for you (date)?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 11 Nov 1998 15:17:31 +0000

> Never seen this. What was the last revision that worked for you (date)?

Seems like someone else has seen this.  Follows is a quick path to turn
off the debug printing.  This stops it from core dumping on me.

I still get the following complaint that I think is due to the new
parsing:

FvwmIconMan: bif: too few arguments
FvwmIconMan: No function defined
FvwmIconMan: Bad action: Bif Next 3, GotoButton 0, Select, Ret,
GotoButton Next, Select
FvwmIconMan: Offending line: *FvwmIconMan*Action Mouse 2 N Bif Next 3,
GotoButton 0, Select, Ret, GotoButton 

Cheers,
Tim.

Index: modules/FvwmIconMan/debug.h
===================================================================
RCS file: /home/cvs/fvwm/fvwm/modules/FvwmIconMan/debug.h,v
retrieving revision 1.4
diff -u -r1.4 debug.h
--- modules/FvwmIconMan/debug.h	1998/11/10 09:21:25	1.4
+++ modules/FvwmIconMan/debug.h	1998/11/11 15:08:09
@@ -1,14 +1,12 @@
 #ifndef IN_DEBUG_H
 #define IN_DEBUG_H
 
-#if 1
+#if 0
 #define PRINT_DEBUG      
 #endif
 
-#if 1
+#if 0
 #define OUTPUT_FILE "/dev/console"
-#else
-#define OUTPUT_FILE "/usr/bradym/log"
 #endif

---

From: [email-masked]
Date: Wed, 11 Nov 1998 16:48:37 +0100

> GotoButton 0, Select, Ret, GotoButton 

Didn't I fix this yesterday? The commas were not parsed correctly,
but I fixed this (hope so).

Can youc check this?

Bye

Dominik

---

From: Tim Phipps <[email-masked]>
Date: Wed, 11 Nov 1998 17:25:44 +0000

> but I fixed this (hope so).
It still complains.

Cheers,
Tim.

---

From: [email-masked]
Date: Thu, 12 Nov 1998 10:56:36 +0100

Both problems are solved. The coredump was caused only
by the debugging code, the other one was indeed a parsing
bug.

Bye

Dominik