Subject: FvwmScript does not build

From: [email-masked]
Date: Mon, 9 Nov 1998 15:48:03 +0100

When I try to build a distribution (--enable-extras),
FvwmScript does not build anymore during the initial
make (right after the configure). Sorry, I don't have
the error output at the moment.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 9 Nov 1998 16:07:09 +0100

I remember the error now. It was something like:

  no rule to create 'y.foobar.c' needed for target 'y.foobar.o'.

Bye

Dominik

---

From: Steve Robbins <[email-masked]>
Date: Mon, 9 Nov 1998 10:59:17 -0500 (EST)

>   no rule to create 'y.foobar.c' needed for target 'y.foobar.o'.

foobar = "tab", perhaps?  I see a "y.tab.c" in extras/FvwmScript. 

It sounds like the file is missing, or at least "make" thinks so.  Despite
the name, it is NOT a built file, so there is no reason for it to be
missing.  Maybe just update your sources?

--
Steve Robbins                              <[email-masked]>

When love is gone, there's always justice.
And when justice is gone, there's always force.
And when force is gone, there's always Mom.

---

From: [email-masked] (Paul D. Smith)
Date: 09 Nov 1998 12:43:23 -0500

%% Steve Robbins <[email-masked]> writes:

  >> no rule to create 'y.foobar.c' needed for target 'y.foobar.o'.

  sr> foobar = "tab", perhaps?  I see a "y.tab.c" in extras/FvwmScript. 

  sr> It sounds like the file is missing, or at least "make" thinks so.
  sr> Despite the name, it is NOT a built file, so there is no reason
  sr> for it to be missing.  Maybe just update your sources?

The problem is in FvwmScript/Makefile.in:

  distclean-compile:
          -rm -f *.tab.c

This is probably how that file disappeared.  Since there's nothing in
Makefile.am that should introduce that, I guess automake is "helpfully"
adding it for you.

My best advice, if you want to keep that file a source file instead of a
derived file, is to rename it so it doesn't look like a yacc output file.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 10 Nov 1998 10:23:05 +0100

> derived file, is to rename it so it doesn't look like a yacc output file.

Good. Who does this?

Bye

Dominik

---

From: Steve Robbins <[email-masked]>
Date: Tue, 10 Nov 1998 09:38:41 -0500 (EST)

> derived file, is to rename it so it doesn't look like a yacc output file.

I found that the yacc & lex sources were included, in the "Compiler"
subdir.  So, I stuck them in the same FvwmScript directory and changed the
makefile to build the scanner & parser .c and .h files.

The automake docs claim that the yacc-constructed files will end up in the
distribution, but that doesn't seem to be happening.  This is probably
because I am NOT building in the source directory. 

By the way: is anyone using FvwmScript?  I'm not.  When I ran yacc (or was
it bison) on the grammar, I got a slightly different C source file.  It'd
be good to know if it still works correctly.

---

From: [email-masked]
Date: Tue, 10 Nov 1998 17:46:06 +0100

> By the way: is anyone using FvwmScript?

No, not me.

Dominik

---

From: "Eddy J. Gurney" <[email-masked]>
Date: Tue, 10 Nov 1998 12:29:57 -0500

On Nov 10 at  9:38, Steve Robbins wrote:
,--
| By the way: is anyone using FvwmScript?  I'm not.  When I ran yacc (or was
| it bison) on the grammar, I got a slightly different C source file.  It'd
| be good to know if it still works correctly.
`--
Attached is a rather lengthy FvwmScript that I wrote for fvwm-2.0.45.
The number of widgets here greatly exceeded the default in the version
of FvwmScript that shipped with fvwm-2.0.45, so I patched up FvwmScript
and sent the changes to the author. I'm hoping the version of FvwmScript
that is in the repository works without any source changes.

FvwmScript is a really nice tool, IMHO. I wrote the script below to allow
people at my work to open "customized" X terminals (basically, it is a
GUI for setting foreground/background color, picking amongst 8 decent
xterm fonts, setting the window title, etc.)

I wouldn't mind having the script (or a variant of it, if somebody has
some changes/suggestions) included with the next release of fvwm; I think
it would be a nice addition, and it may show people the possibilities
of using FvwmScript. The fact that it is in the "extras" directory doesn't
help, since a lot of people don't compile with "--enable-extras".

This is my first message to the fvwm-workers list. Is there a "Getting
Started" document that would show me how to pull the latest-and-greatest
fvwm from CVS and play with it? I'd like to see if some features I requested
(WarpToTransient for example :-) have been implemented via the "Style"
flags... it is an incredibly useful feature (think about Netscape's "Find"
window, for example.) The other thing I hacked in fvwm-2.0.45/46 was the
ability to use the middle and right mouse buttons during ActivePlacement
to allow resizing the window (before placing it) by clicking-and-dragging
the middle button (click drops the window, and dragging allows you to resize
it before the window is actually mapped), and "resize to bottom of screen"
with the right mouse button (that is, during active placment, you drag
around the outline of the window, click the right button, and the height
of the window is adjusted to within a few pixels of the bottom of the
screen. Great for creating "tall" xterms!)

Finally, there is a "bug" in fvwm-2.0.45/.46 that prevents you from "grabbing"
the outline of a window if it touching the edge of the screen. Instead,
fvwm "passes" the click through to the root window, as if the window border
wasn't even there. This has something to do with the "invisible" window around
the edge of the screen that is used for something (I can't remember what.)
But is something I'm hoping is fixed as well.

Anyway, here is my "Terminal Settings" FvwmScript. Comments/feedback welcome.
(.fss = FvwmScript Script :-)

Eddy

# TerminalSettings.fss
#
# FvwmScript to set up and save terminal (xterm) settings
#
# Eddy J. Gurney
# <[email-masked]>
#

WindowTitle	{Terminal Settings}
WindowSize	460 400
WindowPosition	400 400
ForeColor	{Black}
BackColor	{rgb:ae/b2/c3}
ShadowColor	{rgb:92/96/a6}
HilightColor	{White}
# A very small default font, since we want small color push buttons w/ no title
Font		5x7

Init
 Begin
  WarpPointer	3
  Set $CustColor = {rgb:ae/b2/c3}
#If you change these, also change the defaults for Widgets 56/57
  Set $ForeColor = {Black}
  Set $BackColor = {AntiqueWhite}
  Set $ForeSelected = 0
  Set $Font = {6x13}
  Set $BoldFont = {6x13bold}
  Set $options = {}
  Set $remoteCmd = {}
  Set $geometry = {}
 End

Widget 3
Property
 Size 20 20
 Position 20 20
 Type PushButton
 BackColor {White}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {White}
    End
   Else
    Begin
     Set $BackColor = {White}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 4
Property
 Size 20 20
 Position 45 20
 Type PushButton
 BackColor {RosyBrown2}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {RosyBrown2}
    End
   Else
    Begin
     Set $BackColor = {RosyBrown2}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 5
Property
 Size 20 20
 Position 70 20
 Type PushButton
 BackColor {HotPink}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {HotPink}
    End
   Else
    Begin
     Set $BackColor = {HotPink}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 6
Property
 Size 20 20
 Position 95 20
 Type PushButton
 BackColor {VioletRed}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {VioletRed}
    End
   Else
    Begin
     Set $BackColor = {VioletRed}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 7
Property
 Size 20 20
 Position 120 20
 Type PushButton
 BackColor {Red}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Red}
    End
   Else
    Begin
     Set $BackColor = {Red}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 8
Property
 Size 20 20
 Position 145 20
 Type PushButton
 BackColor {Brown}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Brown}
    End
   Else
    Begin
     Set $BackColor = {Brown}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 9
Property
 Size 20 20
 Position 170 20
 Type PushButton
 BackColor {RosyBrown4}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {RosyBrown4}
    End
   Else
    Begin
     Set $BackColor = {RosyBrown4}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 10
Property
 Size 20 20
 Position 195 20
 Type PushButton
 BackColor {Tan}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Tan}
    End
   Else
    Begin
     Set $BackColor = {Tan}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 11
Property
 Size 20 20
 Position 220 20
 Type PushButton
 BackColor {Wheat}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Wheat}
    End
   Else
    Begin
     Set $BackColor = {Wheat}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 12
Property
 Size 20 20
 Position 245 20
 Type PushButton
 BackColor {AntiqueWhite}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {AntiqueWhite}
    End
   Else
    Begin
     Set $BackColor = {AntiqueWhite}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 13
Property
 Size 20 20
 Position 270 20
 Type PushButton
 BackColor {GoldenRod}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Goldenrod}
    End
   Else
    Begin
     Set $BackColor = {Goldenrod}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 14
Property
 Size 20 20
 Position 295 20
 Type PushButton
 BackColor {Orange}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Orange}
    End
   Else
    Begin
     Set $BackColor = {Orange}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 15
Property
 Size 20 20
 Position 320 20
 Type PushButton
 BackColor {Gold}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Gold}
    End
   Else
    Begin
     Set $BackColor = {Gold}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 16
Property
 Size 20 20
 Position 345 20
 Type PushButton
 BackColor {Yellow}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Yellow}
    End
   Else
    Begin
     Set $BackColor = {Yellow}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 17
Property
 Size 20 20
 Position 370 20
 Type PushButton
 BackColor {Green}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Green}
    End
   Else
    Begin
     Set $BackColor = {Green}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 18
Property
 Size 20 20
 Position 395 20
 Type PushButton
 BackColor {LimeGreen}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LimeGreen}
    End
   Else
    Begin
     Set $BackColor = {LimeGreen}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 19
Property
 Size 20 20
 Position 420 20
 Type PushButton
 BackColor {MediumAquaMarine}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {MediumAquaMarine}
    End
   Else
    Begin
     Set $BackColor = {MediumAquaMarine}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 20
Property
 Size 20 20
 Position 20 45
 Type PushButton
 BackColor {SeaGreen}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SeaGreen}
    End
   Else
    Begin
     Set $BackColor = {SeaGreen}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 21
Property
 Size 20 20
 Position 45 45
 Type PushButton
 BackColor {OliveDrab}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {OliveDrab}
    End
   Else
    Begin
     Set $BackColor = {OliveDrab}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 22
Property
 Size 20 20
 Position 70 45
 Type PushButton
 BackColor {DarkOliveGreen}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {DarkOliveGreen}
    End
   Else
    Begin
     Set $BackColor = {DarkOliveGreen}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 23
Property
 Size 20 20
 Position 95 45
 Type PushButton
 BackColor {LightCyan4}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LightCyan4}
    End
   Else
    Begin
     Set $BackColor = {LightCyan4}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 24
Property
 Size 20 20
 Position 120 45
 Type PushButton
 BackColor {CadetBlue}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {CadetBlue}
    End
   Else
    Begin
     Set $BackColor = {CadetBlue}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 25
Property
 Size 20 20
 Position 145 45
 Type PushButton
 BackColor {Aquamarine}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Aquamarine}
    End
   Else
    Begin
     Set $BackColor = {Aquamarine}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 26
Property
 Size 20 20
 Position 170 45
 Type PushButton
 BackColor {Turquoise}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Turquoise}
    End
   Else
    Begin
     Set $BackColor = {Turquoise}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 27
Property
 Size 20 20
 Position 195 45
 Type PushButton
 BackColor {Cyan}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Cyan}
    End
   Else
    Begin
     Set $BackColor = {Cyan}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 28
Property
 Size 20 20
 Position 220 45
 Type PushButton
 BackColor {LightCyan2}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LightCyan2}
    End
   Else
    Begin
     Set $BackColor = {LightCyan2}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 29
Property
 Size 20 20
 Position 245 45
 Type PushButton
 BackColor {LightSteelBlue1}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LightSteelBlue1}
    End
   Else
    Begin
     Set $BackColor = {LightSteelBlue1}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 30
Property
 Size 20 20
 Position 270 45
 Type PushButton
 BackColor {LightSteelBlue2}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LightSteelBlue2}
    End
   Else
    Begin
     Set $BackColor = {LightSteelBlue2}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 31
Property
 Size 20 20
 Position 295 45
 Type PushButton
 BackColor {LightSteelBlue4}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {LightSteelBlue4}
    End
   Else
    Begin
     Set $BackColor = {LightSteelBlue4}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 32
Property
 Size 20 20
 Position 320 45
 Type PushButton
 BackColor {SteelBlue}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SteelBlue}
    End
   Else
    Begin
     Set $BackColor = {SteelBlue}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 33
Property
 Size 20 20
 Position 345 45
 Type PushButton
 BackColor {SkyBlue4}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SkyBlue4}
    End
   Else
    Begin
     Set $BackColor = {SkyBlue4}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 34
Property
 Size 20 20
 Position 370 45
 Type PushButton
 BackColor {SkyBlue3}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SkyBlue3}
    End
   Else
    Begin
     Set $BackColor = {SkyBlue3}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 35
Property
 Size 20 20
 Position 395 45
 Type PushButton
 BackColor {SkyBlue2}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SkyBlue2}
    End
   Else
    Begin
     Set $BackColor = {SkyBlue2}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 36
Property
 Size 20 20
 Position 420 45
 Type PushButton
 BackColor {SkyBlue1}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {SkyBlue1}
    End
   Else
    Begin
     Set $BackColor = {SkyBlue1}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 37
Property
 Size 20 20
 Position 20 70
 Type PushButton
 BackColor {Blue}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Blue}
    End
   Else
    Begin
     Set $BackColor = {Blue}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 38
Property
 Size 20 20
 Position 45 70
 Type PushButton
 BackColor {Navy}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Navy}
    End
   Else
    Begin
     Set $BackColor = {Navy}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 39
Property
 Size 20 20
 Position 70 70
 Type PushButton
 BackColor {Purple}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Purple}
    End
   Else
    Begin
     Set $BackColor = {Purple}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 40
Property
 Size 20 20
 Position 95 70
 Type PushButton
 BackColor {Magenta}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Magenta}
    End
   Else
    Begin
     Set $BackColor = {Magenta}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 41
Property
 Size 20 20
 Position 120 70
 Type PushButton
 BackColor {Violet}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Violet}
    End
   Else
    Begin
     Set $BackColor = {Violet}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 42
Property
 Size 20 20
 Position 145 70
 Type PushButton
 BackColor {Plum}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Plum}
    End
   Else
    Begin
     Set $BackColor = {Plum}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 43
Property
 Size 20 20
 Position 170 70
 Type PushButton
 BackColor {grey90}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey90}
    End
   Else
    Begin
     Set $BackColor = {grey90}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 44
Property
 Size 20 20
 Position 195 70
 Type PushButton
 BackColor {grey83}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey83}
    End
   Else
    Begin
     Set $BackColor = {grey83}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 45
Property
 Size 20 20
 Position 220 70
 Type PushButton
 BackColor {grey75}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey75}
    End
   Else
    Begin
     Set $BackColor = {grey75}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 46
Property
 Size 20 20
 Position 245 70
 Type PushButton
 BackColor {grey65}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey65}
    End
   Else
    Begin
     Set $BackColor = {grey65}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 47
Property
 Size 20 20
 Position 270 70
 Type PushButton
 BackColor {grey50}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey50}
    End
   Else
    Begin
     Set $BackColor = {grey50}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 48
Property
 Size 20 20
 Position 295 70
 Type PushButton
 BackColor {grey40}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey40}
    End
   Else
    Begin
     Set $BackColor = {grey40}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 49
Property
 Size 20 20
 Position 320 70
 Type PushButton
 BackColor {grey35}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey35}
    End
   Else
    Begin
     Set $BackColor = {grey35}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 50
Property
 Size 20 20
 Position 345 70
 Type PushButton
 BackColor {grey25}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {grey25}
    End
   Else
    Begin
     Set $BackColor = {grey25}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 51
Property
 Size 20 20
 Position 370 70
 Type PushButton
 BackColor {Black}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = {Black}
    End
   Else
    Begin
     Set $BackColor = {Black}
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 52
Property
 Size 20 20
 Position 420 70
 Type PushButton
#If you change this, change the "Value" entries for 53/55/57!
 BackColor {rgb:ae/b2/c3}
Main
 Case message of
  UserAction :
  Begin
   If $ForeSelected == 1 Then
    Begin
     Set $ForeColor = $CustColor
    End
   Else
    Begin
     Set $BackColor = $CustColor
    End
   ChangeForeColor 60 $ForeColor
   ChangeBackColor 60 $BackColor
  End
End

Widget 53
Property
 Size 128 1
 Position 20 95
 Type HScrollBar
 Value 174
 MinValue 0
 MaxValue 255
 Font lucidasans-10
Main
 Case message of
  UserAction :
  Begin
   Set $CustColor = {rgb:} (NumToHex (GetValue 53) 2) {/} (NumToHex (GetValue
55) 2) {/} (NumToHex (GetValue 57) 2)
   ChangeBackColor 52 $CustColor
  End
End

Widget 54
Property
 Size 1 1
 Position 72 134
 Type ItemDraw
 Font lucidasans-10
 Title {Red}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 55
Property
 Size 128 1
 Position 165 95
 Type HScrollBar
 Value 178
 MinValue 0
 MaxValue 255
 Font lucidasans-10
Main
 Case message of
  UserAction :
  Begin
   Set $CustColor = {rgb:} (NumToHex (GetValue 53) 2) {/} (NumToHex (GetValue
55) 2) {/} (NumToHex (GetValue 57) 2)
   ChangeBackColor 52 $CustColor
  End
End

Widget 56
Property
 Size 1 1
 Position 210 134
 Type ItemDraw
 Font lucidasans-10
 Title {Green}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 57
Property
 Size 128 1
 Position 310 95
 Type HScrollBar
 Value 195
 MinValue 0
 MaxValue 255
 Font lucidasans-10
Main
 Case message of
  UserAction :
  Begin
   Set $CustColor = {rgb:} (NumToHex (GetValue 53) 2) {/} (NumToHex (GetValue
55) 2) {/} (NumToHex (GetValue 57) 2)
   ChangeBackColor 52 $CustColor
  End
End

Widget 58
Property
 Size 1 1
 Position 360 134
 Type ItemDraw
 Font lucidasans-10
 Title {Blue}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 60
Property
 Size 260 30
 Position 175 152
 Type ItemDraw
#If you change these, also change the defaults in "Init" above
 ForeColor {Black}
 BackColor {AntiqueWhite}
 Font 6x13
 MinValue -1
 MaxValue -1
 Title {The quick BROWN fox! O0l1S5}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 61
Property
 Size 50 30
 Position 25 150
 Type RadioButton
 Title {Background color}
 Font LucidaSans-Bold-12
 Value 1
Main
 Case message of
  UserAction :
  Begin
   Set $ForeSelected = 0
   ChangeValue 62 0
  End
End

Widget 62
Property
 Size 50 30
 Position 25 165
 Type RadioButton
 Title {Foreground color}
 Font LucidaSans-Bold-12
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $ForeSelected = 1
   ChangeValue 61 0
  End
End

Widget 63
Property
 Size 50 30
 Position 20 210
 Type RadioButton
 Title {6x13}
 Font 6x13bold
 Value 1
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {6x13}
   Set $BoldFont = {6x13bold}
   ChangeFont 60 $Font
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 64
Property
 Size 50 30
 Position 20 226
 Type RadioButton
 Title {7x13}
 Font 7x13bold
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {7x13}
   Set $BoldFont = {7x13bold}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 65 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 65
Property
 Size 50 30
 Position 20 242
 Type RadioButton
 Title {7x14}
 Font 7x14bold
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {7x14}
   Set $BoldFont = {7x14bold}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 66
Property
 Size 50 30
 Position 20 258
 Type RadioButton
 Title {8x13}
 Font 8x13bold
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {8x13}
   Set $BoldFont = {8x13bold}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 67
Property
 Size 50 30
 Position 20 274
 Type RadioButton
 Title {9x15}
 Font 9x15bold
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {9x15}
   Set $BoldFont = {9x15bold}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 65 0
   ChangeValue 68 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 68
Property
 Size 50 30
 Position 20 299
 Type RadioButton
 Title {LST-10}
 Font lucidasanstypewriter-bold-10
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {lucidasanstypewriter-10}
   Set $BoldFont = {lucidasanstypewriter-bold-10}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 69 0
   ChangeValue 70 0
  End
End

Widget 69
Property
 Size 50 30
 Position 20 315
 Type RadioButton
 Title {LST-12}
 Font lucidasanstypewriter-bold-12
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {lucidasanstypewriter-12}
   Set $BoldFont = {lucidasanstypewriter-bold-12}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 70 0
  End
End

Widget 70
Property
 Size 50 30
 Position 20 330
 Type RadioButton
 Title {LST-14}
 Font lucidasanstypewriter-bold-14
 Value 0
Main
 Case message of
  UserAction :
  Begin
   Set $Font = {lucidasanstypewriter-14}
   Set $BoldFont = {lucidasanstypewriter-bold-14}
   ChangeFont 60 $Font
   ChangeValue 63 0
   ChangeValue 64 0
   ChangeValue 65 0
   ChangeValue 66 0
   ChangeValue 67 0
   ChangeValue 68 0
   ChangeValue 69 0
  End
End

Widget 71
Property
 Size 1 1
 Position 120 215
 Type ItemDraw
 Title {Window title:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 72
Property
 Size 220 35
 Position 220 208
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {xterm}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 73
Property
 Size 1 1
 Position 120 294
 Type ItemDraw
 Title {Host:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 74
Property
 Size 145 35
 Position 160 287
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 75
Property
 Size 1 1
 Position 310 294
 Type ItemDraw
 Title {User:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 76
Property
 Size 90 35
 Position 350 287
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 77
Property
 Size 1 1
 Position 120 324
 Type ItemDraw
 Title {Program:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 78
Property
 Size 250 35
 Position 190 317
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 79
Property
 Size 170 35
 Position 140 365
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 80
Property
 Size 1 1
 Position 120 244
 Type ItemDraw
 Title {Cols:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 81
Property
 Size 40 30
 Position 165 237
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {80}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 82
Property
 Size 1 1
 Position 210 244
 Type ItemDraw
 Title {Rows:}
 Font LucidaSans-Bold-12
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 83
Property
 Size 40 30
 Position 255 237
 Type TextField
# This font doesn't exhibit weird drawing problems in the edit field
 Font -adobe-helvetica-bold-r-*-*-12-*
 Title {25}
 Value 255
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 84
Property
 Size 50 30
 Position 310 235
 Type CheckBox
 Title {No scroll bars}
 Font LucidaSans-Bold-12
 Value 0
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 85
Property
 Size 50 30
 Position 310 251
 Type CheckBox
 Title {Start iconic}
 Font LucidaSans-Bold-12
 Value 0
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 87
Property
 Size		50 25
 Position	390 365
 Type		PushButton
 Font		LucidaSans-Bold-12
 Title		{Cancel}
Main
 Case message of
  UserAction :
  Begin
   Quit
  End
End

Widget 88
Property
 Size		50 25
 Position	330 365
 Type		PushButton
 Font		LucidaSans-Bold-12
 Title		{Open}
Main
 Case message of
  UserAction :
  Begin
   Set $options = {}
   If (GetValue 84) == 1 Then
    Begin
     Set $options = $options {+sb }
    End

   If (GetValue 85) == 1 Then
    Begin
     Set $options = $options {-iconic }
    End

   If (GetTitle 74) == {} Then
    Begin
     Set $remoteCmd = {}
    End
   Else
    Begin
     Set $remoteCmd = {-e krsh } (GetTitle 74)
     If (GetTitle 76) == {} Then
      Begin
      End
     Else
      Begin
       Set $remoteCmd = $remoteCmd { -l } (GetTitle 76)
      End
     If (GetTitle 78) == {} Then
      Begin
      End
     Else
      Begin
       Set $remoteCmd = $remoteCmd { '} (GetTitle 78) {'}
      End
    End

   Set $geometry = (GetTitle 81) {x} (GetTitle 83)

   Do {Exec xterm -fg } $ForeColor { -bg } $BackColor { -fn } $Font { -fb }
$BoldFont { -T "} (GetTitle 72) {" -n "} (GetTitle 72) {" -geometry } $geometry
{ } $options { } $remoteCmd { &}

   Quit
  End
End

Widget 89
Property
 Size		50 25
 Position	10 365
 Type		PushButton
 Font		LucidaSans-Bold-12
 Title		{Add to menu as:}
Main
 Case message of
  UserAction :
  Begin
   Set $options = {}
   If (GetValue 84) == 1 Then
    Begin
     Set $options = $options {+sb }
    End

   If (GetValue 85) == 1 Then
    Begin
     Set $options = $options {-iconic }
    End

   If (GetTitle 74) == {} Then
    Begin
     Set $remoteCmd = {}
    End
   Else
    Begin
     Set $remoteCmd = {-e krsh } (GetTitle 74)
     If (GetTitle 76) == {} Then
      Begin
      End
     Else
      Begin
       Set $remoteCmd = $remoteCmd { -l } (GetTitle 76)
      End
     If (GetTitle 78) == {} Then
      Begin
      End
     Else
      Begin
       Set $remoteCmd = $remoteCmd { '} (GetTitle 78) {'}
      End
    End

   Set $geometry = (GetTitle 81) {x} (GetTitle 83)

   Do {Exec UpdateFvwm2TermMenu "} (GetTitle 79) {" xterm } $ForeColor { }
$BackColor { } $Font { } $BoldFont { "} (GetTitle 72) {" } $geometry { "}
$options {" "} $remoteCmd {" &}
   Do {AddToMenu Terms "} (GetTitle 79) {" Exec xterm -fg } $ForeColor { -bg }
$BackColor { -fn } $Font { -fb } $BoldFont { -T "} (GetTitle 72) {" -n "}
(GetTitle 72) {" -geometry } $geometry { } $options { } $remoteCmd
#This doesn't work... Bummer
#  ChangeTitle 79 {}
  End
End

Widget 90
Property
 Size 440 180
 Position 10 10
 Type Rectangle
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 91
Property
 Size 1 1
 Position 15 5
 Type ItemDraw
 Font lucidasans-12
 Title {Colors}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 92
Property
 Size 90 152
 Position 10 200
 Type Rectangle
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 93
Property
 Size 1 1
 Position 15 195
 Type ItemDraw
 Font lucidasans-12
 Title {Font}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 94
Property
 Size 340 75
 Position 110 277
 Type Rectangle
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 95
Property
 Size 1 1
 Position 115 272
 Type ItemDraw
 Font lucidasans-12
 Title {Remote}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 96
Property
 Size 340 70
 Position 110 200
 Type Rectangle
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 97
Property
 Size 1 1
 Position 115 195
 Type ItemDraw
 Font lucidasans-12
 Title {Options}
Main
 Case message of
  UserAction :
  Begin
  End
End

Widget 99
Property
 Size 265 35
 Position 172 149
 Type Rectangle
Main
 Case message of
  UserAction :
  Begin
  End
End

Oh, here is my shell script called UpdateFvwm2TermMenu which is sourced in
our default .fvwm2rc configuration:

#! /bin/sh
#
# UpdateFvwm2TermMenu
#
# Eddy J. Gurney
# <[email-masked]>
#
# Script to handle updating of .fvwm2-term-file
# (Meant to be called from FvwmScript scripts...)

if [ $# -lt 8 ]
then
    echo $0': Incorrect number of parameters!'
    exit
fi

menuName=$1
terminal=$2
foreColor=$3
backColor=$4
font=$5
boldFont=$6
title=$7
geometry=$8
options=$9
# stupid sh can't handle more than 9 parameters!
shift 9
remoteCmd=$1

if [ -r $HOME/.fvwm2-term-menu ]
then
    mv $HOME/.fvwm2-term-menu $HOME/.fvwm2-term-menu~
    egrep -v -i '^AddToMenu[ 	]+Terms[ 	]+"'"$menuName"'"[ 	]+'
$HOME/.fvwm2-term-menu~ > $HOME/.fvwm2-term-menu
fi

echo 'AddToMenu Terms "'$menuName'" Exec '$terminal' -fg '$foreColor' -bg
'$backColor' -fn "'$font'" -fb "'$boldFont'" -T "'$title'" -n "'$title'"
-geometry '$geometry' '$options' '$remoteCmd >> $HOME/.fvwm2-term-menu

sort -o .fvwm2-term-menu .fvwm2-term-menu

---

From: [email-masked] (Paul D. Smith)
Date: 10 Nov 1998 13:22:31 -0500

%% "Eddy J. Gurney" <[email-masked]> writes:

  eg> This is my first message to the fvwm-workers list. Is there a
  eg> "Getting Started" document that would show me how to pull the
  eg> latest-and-greatest fvwm from CVS and play with it?

Well... there's the one in the docs directory!  Oh, wait, you need CVS
access to get it ;).

Here's something Jason sent out back when he first created the archive;
this'll get you going:

  jt> Here's some CVS info:
  jt> 
  jt> The FVWM CVS server is served from cvs.hpc.uh.edu.  The repository is:
  jt> 
  jt>   :pserver:[email-masked]:/home/cvs/fvwm
  jt> 
  jt> If you just want to check out the current distribution, do the following:
  jt> 
  jt> cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm login
  jt> (the password is 'guest')
  jt> cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm checkout fvwm
  jt> 
  jt> To keep your local copy up to date, just use the command
  jt> 
  jt>   cvs -z3 update -dP
  jt> 
  jt> from the fvwm directory.  It will remember the repository location
  jt> for you.
  jt> 
  jt> You can also check out http://www.hpc.uh.edu/cgi-bin/cvsweb.cgi.  I just
  jt> installed the newest version and it is quite nice. 
  jt> 
  jt> CVS and its documentation is available from www.cyclic.com; check
  jt> there for more in-depth info.

Once you get a copy, look in docs/cvs.html for more hints.

---

From: Steve Robbins <[email-masked]>
Date: Tue, 10 Nov 1998 13:41:32 -0500 (EST)

> Once you get a copy, look in docs/cvs.html for more hints.

And DEVELOPERS!  Don't forget DEVELOPERS (which admittedly overlaps
cvs.html and should be reconciled some day)

There's a little bit of Elvis in everybody.
Except Michael J. Fox -- he's the anti-Elvis.

---

From: [email-masked]
Date: Tue, 10 Nov 1998 20:01:51 +0100

>   jt>...

Isn't that on the (updated) web-page?

Bye

Dominik