Subject: RE: [no subject]

From: [email-masked]
Date: Sun, 8 Nov 1998 11:14:26 -0500 (EST)

The merge I did on saturday has a bug producing
a coredump. I don't have the sources now, so I
can give you no patch, but what you have to do is:

in module.c, executeModule (or ExecutMeodule) there
are two lines deleting cptr (in fact there are several
places in the function, but I refer to the LAST occurence
in the function).

The lines have to be deleted (cptr is already deleted
earlier).

  if (cptr)
    free(cptr);

This was caused by concurrent fixed by me and Paul
(I think) for a memory leak.

There is another problem in libs/Picture.c,
CachePicture (or something like this). The list
of cached Icons seems to be corrupted (you can 
see this if you have lots of icons in FvwmButtons).

Bye

Dominik

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Sun, 08 Nov 1998 22:37:46 -0500 (EST)

> The lines have to be deleted (cptr is already deleted

        Done.

- Bob