Subject: move.c

From: Dan Espen <[email-masked]>
Date: Wed, 11 Nov 1998 15:05:14 -0500

I could fix this, but I see other activity going on for move.c,
and I don't want to confuse the issue.

My download from a few hours ago cores out in move.c, line 506:

  x_move_size = Scr.Hilite->hints.width_inc;

In this case, Scr.Hilite is zero.

Other places in the source code where Scr.Hilite is referenced, there
is first a test for zero.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 11 Nov 1998 21:09:50 +0100

> is first a test for zero.

Might be my doing, but can't remember exactly. I'll check it.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 12 Nov 1998 11:01:54 +0100

> is first a test for zero.

Don't know why it comes up now, but it's been in the code for
long.

Fixed.

Bye

Dominik