Subject: FVWM CVS: fvwm domivogt

From: CVS <[email-masked]>
Date: Mon, 23 Nov 1998 04:40:23 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	domivogt	98/11/23 04:40:23

Modified files:
	.              : ChangeLog FAQ NEWS TODO 
	docs           : Makefile.in 
	fvwm           : Makefile.in add_window.c builtins.c complex.c 
	                 functions.c fvwm.c menus.c menus.h misc.c 
	                 misc.h read.c style.c virtual.c windows.c 
	icons          : Makefile.in 
	libs           : Makefile.in Parse.c 
	modules        : ChangeLog Makefile.in 
	modules/FvwmAnimate: Makefile.in 
	modules/FvwmAudio: Makefile.in 
	modules/FvwmAuto: Makefile.in 
	modules/FvwmBacker: Makefile.in 
	modules/FvwmBanner: Makefile.in 
	modules/FvwmButtons: FvwmButtons.1 Makefile.in 
	modules/FvwmCpp: Makefile.in 
	modules/FvwmEvent: Makefile.in 
	modules/FvwmForm: Makefile.in 
	modules/FvwmIconBox: Makefile.in 
	modules/FvwmIconMan: Makefile.in 
	modules/FvwmIdent: Makefile.in 
	modules/FvwmM4 : Makefile.in 
	modules/FvwmPager: Makefile.in 
	modules/FvwmRearrange: Makefile.in 
	modules/FvwmSave: Makefile.in 
	modules/FvwmSaveDesk: Makefile.in 
	modules/FvwmScroll: Makefile.in 
	modules/FvwmTalk: Makefile.in 
	modules/FvwmWinList: Makefile.in 
	sample.fvwmrc  : Makefile.in 
	utils          : Makefile.in 
	xpmroot        : Makefile.in 

Log message:
* fvwm/**:
* libs/**: removed trailing spaces from the files I touched since 11-20

* fvwm/fvwm.c (StartupStuff): Added call to checkPanFrames to make
page flipping via EdgeScroll work with FvwmCpp too.

* fvwm/misc.c (Destroy): remove window from window list before doing
anything else. Should fix race condition coredump with
Close/Delete/Destroy.

* TODO: updated

* FAQ (44): added section for FvwmButtons/Swallow

* fvwm/menus.c (AddToMenu): fixed uninitialised memory read in item2
and s.

* fvwm/builtins.c (DirectionFunc):
(Circulate): fixed free of possible NULL pointer.

* fvwm/style.c (ProcessNewStyle): fixed uninitialised memory read:
'BUTTON'/'NOBUTTON' with invalid button number

* fvwm/add_window.c (AddWindow): fixed uninitialised memory read:
attributes.background_pixmap not set.

* libs/Parse.c (DoGetNextToken): cleaned up a bit because of the
array bounds violation in SetGlobalOptions, but I don't believe that
fixes it. Reformatted for further debugging.

* fvwm/functions.c (find_func_type): a little speedup

* fvwm/complex.c (expand): a little speedup

* fvwm/functions.c (ExecuteFunction): a little speedup

* fvwm/menus.c (NewMenuRoot):
(FMenuMapped):
fixed uninitialised memory reads

* fvwm/menus.c (NewMenuRoot):
put parentheses around macro parameters

* fvwm/menus.c (NewMenuRoot):
(MakeMenu):
* fvwm/windows.c (do_windowList):
* fvwm/misc.h:
* fvwm/builtins.c (add_item_to_func):
(add_item_to_menu):
changed NewMenuRoot signature

* configure.in: Version 2.1.2 released (CVS tag = version-2_1_2)
and current version bumped to 2.1.3.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 23 Nov 1998 11:48:36 +0100

Before anyone asks: I didn't touch the Makefile.in files. I assume
they were changed automatically during the last build.

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].