Subject: FVWM CVS: fvwm dane

From: CVS <[email-masked]>
Date: Sun, 15 Nov 1998 09:40:56 -0600 (CST)

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	dane	98/11/15 09:40:55

Modified files:
	.              : AUTHORS 

Log message:
start of authors update

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Robbins <[email-masked]>
Date: Sun, 15 Nov 1998 17:45:14 -0500 (EST)

> Changes by:	dane	98/11/15 09:40:55

Excellent!

I also started thinking about AUTHORS yesterday.  I thought it would be
good of us to "prime the pump" by putting in all the *past* contributors,
as well as present.

I put in the names I know, then I started going through files looking for
other names.  I have done one pass through ChangeLog, FAQ, NEWS, and
README.  I also went through the sources and manpages under modules.  I
have yet to look in the directories fvwm and libs. 

Perhaps it is appropriate to pause now and think about the criteria for
inclusion.  I favour being very inclusive.  I was including anyone who is: 

  * listed as an author in the manpage, or a source file
  * noted as supplying a "patch" or "fix"

There were some notes (especially in the old ChangeLog entries) that
thanked people for bug reports, or for nothing in particular.  I didn't
include them.  Sometimes packages have a file named THANKS for this kind
of thing.  Should we?

What shall we do about modules?  I included all authors of those in the
"modules" directory.  I have mixed feelings about the "extra" modules.  In
principle, modules should be considered independent of fvwm.  However, it
seems mean-spirited to not include those traditionally distributed with
fvwm, even if not "core" modules.  On the other hand, if all the "extra" 
module authors are included, need we also acknowledge authors of other
modules available elsewhere on the net? 

More important than the above questions, I'm not sure of what exactly is
the purpose of the AUTHORS file.  I had assumed it would be a simple list
of names.  On the other hand, as Dan points out, GNU has some definite
ideas about what should go in here.  Their standards document
(maintain.texi) states: 

---------------------------- GNU maintain.texi ---------------------------
   *Keep records of which portions were written by whom.*

   These records don't need to be as detailed as a change log.  They
don't need to distinguish work done at different times, only different
people.

   They should say which files or functions were written by each person,
and which files or functions were revised by each person.  They don't
need to say what the purpose of the change was.  The Register of
Copyrights doesn't care what the program does.
--------------------------------------------------------------------------

I came up with 66 names (see attached file).  Getting detailed information
like the above seems like a lot of work!  Is it useful?  Necessary from a
legalistic point of view?

--
Steve Robbins                              <[email-masked]>

Don't play cards with the Devil.  He'll deal you an awful hand.

Dan Astoorian
John Aughey
Greg Badros
Graham Barr
Mike Blatchley
Mark Boyns
Eli Burke
Martin Cartwright
Frederic Cordier
Andrew Davison
Frederic Devernay
Austin Donnelly
Dan Espen
Thomas Zuwei Feng
Mike Finger
Pete Forman
Patrice Fortier
Todd Fries
German Jose Gomez Garcia
lar3ry gensch
Peter Gray
Kaj Groner
Markus Gutschke
John Heidemann
Charles Hines
Sverre H. Huseby
Toshi Isogai
Thimo Jansen
Albrecht Kadlec
Alfredo Kengi Kojima
Chris Laas
Ric Lister
Don Mahurin
Pekka Marjola
Anthony Martin
Christophe Martin
Makoto Matushita
Grant McDorman
Brady Montz
Robert Nation
Dan Niles
Ludvig A. Norin
Bill Oswald
Carsten Paeth
Per Persson
Tim Phipps
Mark Powell
Randy Ray
Steven M. Robbins
Frank Scheelen
Eric Schott
Mark Scott
Paul D. Smith
Kit Smithers
Nobutaka Suzuki
Szijarto Szabolcs
Andrew Taylor
Jason L. Tibbitts
Jarl Totland
Ilkka E T Tuohela
Andrew Veliath
Dominik Vogt
Barry Warsaw
Rob Whapham
Alan Wild
Randall Winchester

---

From: Dan Espen <[email-masked]>
Date: Sun, 15 Nov 1998 20:12:17 -0500

> include them.  Sometimes packages have a file named THANKS for this kind

Sounds OK.

> modules available elsewhere on the net? 

For modules on the net, if its not  in the fvwm2 distribution, I don't
think "author" applies.

> ideas about what should go in here.  Their standards document
...

Thanks for getting a copy.   I think it would make  a nice footnote in
the authors file.  No, wait, it is a footnote in the authors file.

> like the above seems like a lot of work!  Is it useful?

The more names in the  author file, the better.   Thanks for doing the
work.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].