Subject: announcement, known bugs and beta

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 12:21:35 +0100

Hi all,

I want to make the beta today. There are two files in the
archive directory:

 - announcement-2.1.3
 - known_bugs

The announcement file needs some work. Dan, Jason, could you
both look at the file and fill in the missing URLs? Proof
reading it might not be wrong either. The known_bugs file
should be accessible in the download directory also. It
should contain bugs that we are aware of and that are
going to be fixed in 2.2. The file is not yet ready but
I will fill it today (if I forgot something, please add it).

Paul, Dan, one of you should make the 2.1.3 distribution
today. Please coordinate your efforts so you don't work
concurrently. Remeber to write an email first, then tag
the CVS tree with 'version-2_1_3'.

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 30 Nov 1998 09:20:53 -0500

%% Dominik Vogt <[email-masked]> writes:

  dv> The announcement file needs some work. Dan, Jason, could you
  dv> both look at the file and fill in the missing URLs? Proof
  dv> reading it might not be wrong either.

I'll take a look.

  dv> The known_bugs file should be accessible in the download directory
  dv> also. It should contain bugs that we are aware of and that are
  dv> going to be fixed in 2.2. The file is not yet ready but I will
  dv> fill it today (if I forgot something, please add it).

Why do we want a known-bugs file?  I'd _MUCH_ prefer to simply document
the Jitterbug page and leave it at that.  Any bug list we supply with a
release will be very, very quickly out-of-date and the entire point of
having a globally accessible bug tracking system is so everyone can use
it.

Plus, it saves us the hassle of compiling the bug list every time :)

My $0.02.

  dv> Paul, Dan, one of you should make the 2.1.3 distribution
  dv> today.

'K, I'll talk to Dan.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Nov 1998 09:23:24 -0500

> I will fill it today (if I forgot something, please add it).

I know you asked for updates, but I think a little mailing back and
forth might speed things up...

> recipients:
>   [email-masked]
>   [email-masked]
>   [email-masked]
>   gnu.announce
> 
> The F???? Virtual Window Manager Group is pleased to announce the first
                                   ^^^^^ - "workers list"?

> official beta test version of Fvwm2.2. Available at
                                    ^^^ 2.1.3?
> <URL for home page>
  http://fvwm.math.uh.edu/

> it includes the following features:
> 
  *) New web site, overhauled documentation and a new Bug tracking system.

> *) Improved menu handling with animated menus, cursor key navigation,
                                                ^ improved

>      individual menu styles and better overall flexibility.
> *) Enhanced window and focus handling (SnapAttraction and Direction commands).
> *) New commands for desks and pages (MoveToPage, MoveToDesk, FvwmPager showing
>      the current desk).
> *) Proper Windoze95 style Alt-Tab behaviour.
> *) Animated iconification and window movement and animated panels in
>      FvwmButtons (like CDE).
> *) Mini Icons.
     ^^^^^^^^^^  I don't think this is new to 2.1.3 at all.

> *) Mini title windows for FvwmPager (aka Balloons).
> *) FvwmEvent is the successor of FvwmAudio.
                                               ^(FvwmAudio is still available.)

> *) FvwmTile and FvwmCascade modules were replaced by FvwmRearrange.
     Shells for FvwmTile and FvwmCascade provide backward compatibility.

> *) Improved FvwmButtons button placement to give absolute control over where
>      the buttons are placed.
> *) Faster startup.
> *) Lots of bug fixes to improve stability.
> *) Many small enhancements too numerous to list here.
> *) The pixmaps and icons directories are now in a separate distribution.
     (Remove this one. I think this refers to the "BradyMontz" stuff
     which I don't believe was ever in a released beta.

> *) Consistent copying policy.
> *) GNU autoconf support.

  *) Color limiting (previously available thru patches).
  *) Multiple Icon Boxes, Icon box grids, and Icon box fill direction control
     (previously available thru patches).
> 
> <URL to the news file, ChangeLog>
More detailed information on the contents of this release can be found at
http://fvwm.math.uh.edu/NEWS.html

> 
> Although the maintainers feel this beta is quite stable there are
> some known problems that shall be fixed before the final release
> (and some that will have to wait). A list of known bugs is available
> at <URL to known bugs file>.

Why are we creating a bugs file, shouldn't we point to Jitterbug?

(Go to the Official home page and follow the links to Jitterbug.)

> 
> Before you report a bug, please read the manpages, the NEWS file,
> the ChangeLog and the FAQ. If you can solve your problem this way
  ^^^^^^^^^^^^^  (Remove, I don't see how the ChangeLog would help.)

> but still feel the information was too hard to find, please tell us.
> 
> Bugs can be submitted at:
> 
> <URL/mail address for bug submissions>

Shouldn't we ask for the bug to be entered into Jitterbug?

> Beta testers needed:
> 
> You like fvwm and want to help? Become a beta tester. You can just
> download the distribution and run your latest setup with the new beta,
> but I you feel like doing something really helpful, pick an area
> from the following list, try to test it as completely as you can and
> report your test setup to the fvwm-workers mailing list.
> 
> <[email-masked]>
> 
>  - Compile fvwm2 on as many different platforms and with as many combinations
>    of options as you can (see INSTALL.fvwm for a list of options).
> 
>  - Try to break fvwm with exotic setups and syntax errors in the configuration
>    file.
> 
>  - Play with the new menu features (animated menus, individual menu styles,
>    position hints, cursor key movement etc.)
> 
>  - Test the new features in FvwmButtons (animated panels, button geometries,
>    button placement algorithm). Panels are somewhat difficult to understand
>    so please read the manpage (there are some examples).
> 
>  - Thorough test of FvwmPager. The configuration parser has been changed
>    so every option should be tested.
> 
>  - Thorough test of FvwmIconMan. The configuration parser has been changed
>    so every option should be tested.
> 
>  - Test the new module FvwmAnimate.
> 
>  - Test the new module FvwmEvent.
> 

I may be able to do this today.  If I start, I'll send mail before I
do.  I certainly wouldn't mind anyone else doing this.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 15:29:14 +0100

On Mon, Nov 30, 1998 at 09:20:53AM -0500, Paul Smith wrote:
> the Jitterbug page and leave it at that.

Only during the beta test. I'll throw it away as soon the 2.2 release
is out.

> Any bug list we supply with a release will be very, very quickly
> out-of-date and the entire point of having a globally accessible
> bug tracking system is so everyone can use it.

I agree with you. The reason is that I want to reduce unnecessary
bug reports as much as possible. We all don't have the time to
read the same reports over and over again. People will rather
look into an easily accessible file than start using Jitterbug.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 15:37:57 +0100

>      ^^^^^^^^^^  I don't think this is new to 2.1.3 at all.

In the ChangeLog is seems to be new after 2.0.46?
 
> > A list of known bugs is available
>...

Please see my reply to Paul's mail. We could give the URL of the
report form in Jitterbug, right?

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Nov 1998 09:46:28 -0500

> In the ChangeLog is seems to be new after 2.0.46?

I'm not looking at ChangeLogs, in the NEWS file, mini-icons appear for
the first time in 2.0.38.

> report form in Jitterbug, right?

I saw your reply to Paul, but I still agree with Paul.  Lets encourage
the use of Jitterbug  and see how  that goes.   It might save  us some
work.  As far as the URL, I think its best to just give out the URL to
the home page, and say, "follow the link to ...".

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 15:54:48 +0100

> the home page, and say, "follow the link to ...".

Ok, could you fill this in then? I've incorporated the other changes
already. I'm not opposed to using Jitterbug. My whole concern is that
I don't want to be swamped in bug reports. If I can talk you and Paul
into my idea this one time I'd be grateful. In the end I will be the
one that reads most of the bug reports, so please, please, *please*
let's do it my way.

Bye

Dominik

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Nov 1998 10:14:27 -0500

> one that reads most of the bug reports, so please, please, *please*

OK, you've got me confused.

Do you want to get bug reports thru Jitterbug, and encourage people to
check Jitterbug before submitting   bug reports, or have people  check
the   "./BUGS" file or   the  "./archive/known_bugs" file?  Thats  not
counting:

./extras/FvwmScript/BUGS
./modules/FvwmButtons/BUGS

I  don't  see why  we  should get  swamped with  bug reports, no prior
release was particularly bad in that respect.

I don't see  why  you are taking it   on yourself to handle every  bug
report.   I  don't want you to  get  burned out,  trying to take final
responsibility  for   every bug.   If you  let   some of  these things
languish for a while, one of us will jump in.

---

From: [email-masked] (Paul D. Smith)
Date: 30 Nov 1998 10:06:19 -0500

%% Dan Espen <[email-masked]> writes:

  de> I may be able to do this today.  If I start, I'll send mail before I
  de> do.  I certainly wouldn't mind anyone else doing this.

I'll get this one.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 16:37:31 +0100

> ./modules/FvwmButtons/BUGS
 
OK, now you've got me confused too. I didn't realize there were more
BUGS files. Note that the archive directory isn't in the distribution
so I'd suggest to but the file in the save directory as the tar file
on the ftp server (perhaps name it 2.1.3). It should only track
progress of the betas. I don't think 2.1.3 will be the only one
before the release.

> release was particularly bad in that respect.

It's bugs like the growing windows that I am concerned about. This stuff
is *not* in the BUGS file and users *will* report it. I can't imagine
anyone is willing to page through 50 bugs in Jitterbug which is a bit
user-unfriendly when it comes to this. BTW, I'm not sure giving Jitterbug
access to the world is too smart. Personally I like filtering bug reports
and let someone who knows what's going on enter them (but I don't want
to start a discussion about this right now, I don't think we have the
time to do this).

> languish for a while, one of us will jump in.

Hmm, perhaps you didn't do much with Jitterbug until know. Putting
all these old bug reports into Jitterbug and moving them to the right
directories cost me hours. Much more time than I'd been willing to
invest.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 16:46:01 +0100

> release was particularly bad in that respect.

Sorry, I didn't really answer this in my previous posting. If you can
give me at least a 90% guarantee that my horror scenario won't happen
I agree and let go of the know_bugs file. But still:
 - there are bugs described nowhere, not even in Jitterbug
 - have you really done an *announced* beta test in the past?
   This time we'll be asking for help in testing and we know
   we have lots of new features.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Nov 1998 16:50:21 +0100

>  - known_bugs

Hmm, after all this discussion about this known_bugs files
I suggest we copy the list therein into the BUGS file for
2.1.3 and keep that up to date during the beta phase.
Afterwards we can throw this away.

Dominik

---

From: "Randall S. Winchester" <[email-masked]>
Date: Mon, 30 Nov 1998 11:12:37 -0500 (EST)

On Mon, 30 Nov 1998, Dominik Vogt wrote:

: On Mon, Nov 30, 1998 at 12:21:35PM +0100, Dominik Vogt wrote:
: >  - known_bugs
: 
: Hmm, after all this discussion about this known_bugs files
: I suggest we copy the list therein into the BUGS file for
: 2.1.3 and keep that up to date during the beta phase.
: Afterwards we can throw this away.

It would be nice if "jitterbug" could produce a report that could go in to a
BUGS or known_bugs file for the release. This would help the maintainance of
the file as well as not forcing everyone to get into jitterbug.

I ment to imply by the above that I think a BUGS list is helpful and a quick
reference when installing new software versions, and should be considered
for the release if there are infact bugs which we would be expecting users
to report. 

Maybe with some comment, that if people are looking at placees to contribute
to the fvwm effort, this would be an appreciated place to start.

I personally scan BUGS file to get a clue of what to expect from a package
or from user complaints. 

Randall

---

From: Jason L Tibbitts III <[email-masked]>
Date: 30 Nov 1998 10:26:34 -0600

>>>>> "RSW" == Randall S Winchester <[email-masked]> writes:

RSW> It would be nice if "jitterbug" could produce a report that could go
RSW> in to a BUGS or known_bugs file for the release.

I could whip up a script, but the problem is that there isn't enough
information in the subject and way too much information in the bug reports
themselves, so it would still take a human to digest things.

 - J<