Subject: Re: I18N patches?

From: Dan Espen <[email-masked]>
Date: Fri, 02 Oct 1998 10:20:17 -0400

Makoto MATSUSHITA (=?ISO-2022-JP?B?GyRCJF4kRCQ3JD8kXiQzJEgbKEI=?=) <matusita@ic
s.es.osaka-u.ac.jp> writes:
> 
> dane> I didn't look at the 2.x patch.
> 
> <URL:ftp://ftp.ics.es.osaka-u.ac.jp/pub/CFAN/fvwm-users-jp/kits;type=d>.
> 
> dane> while(isspace(*tline & 0xff))tline++;
> dane>                      ^^^^^^
> dane> in non-international code just doesn't satisfy me.
> 
> I forgot about that, but some compilers/C-preprocessors may confuse if
> not masked with 0xff. I do NOT also satisfied with this code... however,
> it should be needed in some environments (sigh).

Did you try:

#ifdef I18N
#define I18N_M & 0xff
#else
#define I18N_M
#endif

and then:

while(isspace(*tline I18N_M))tline++;

Not that I think this is an ideal way to go, nicer would be a set of library
routines that hide all this stuff in 1 file.

Ie.:

i18n.c:

i18n_isspace() {
...
}

118n_write_text () {
...
}

> dane> I just don't ever use double byte characters.
> 
> I think so too :-) I18N code is slow for north american and european,
> so it should be ignored :-)
> 
> -- -
> Makoto `MAR' MATSUSHITA
> --

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Makoto MATSUSHITA (まつしたまこと) <[email-masked]>
Date: Sat, 03 Oct 1998 20:12:50 +0900

dane> Did you try:

Good way, but 

dane> while(isspace(*tline I18N_M))tline++;

I do not want to code so; "(*tline I18N_M)" seems invalid C code :-)

dane> Not that I think this is an ideal way to go, nicer would be a
dane> set of library routines that hide all this stuff in 1 file.

There are lots of window managers which does know about FontSet
handling; Window Maker, AfterStep (in fact, these i18n code is
imported from the fvwm's i18n code which I currently maintain :-),
qvwm (Windows95 like window manager), mlvwm (MacOS finder-like), etc...

There is ONLY ONE ideal way: Use 'FontSet'. Others are not (including
the *patch* of i18n which I currently maintain).

-- -
Makoto `MAR' MATSUSHITA