Subject: Re: FvwmPager

From: Dan Espen <[email-masked]>
Date: Wed, 28 Oct 1998 23:57:55 -0500

The fix for the pager problem is in x_pager.c.

Around line 727:

                                desk_w,window_h);
was changed to:
				desk_w,desk_h);

(it shouldn't have been changed.)

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Oct 1998 08:12:18 +0100

> (it shouldn't have been changed.)

Woe, that was a fix I made for another problem. If you have
a 2x2 pager but only one desktop and have set the
background color of this desktop, not just this one
desktop but the free space bleow it uses the background
color. I hope we can find another way to fix that.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Oct 1998 13:16:52 +0100

> (it shouldn't have been changed.)

I just had a chance to look at the jpg with the screenshot.
The problem arises because the title height is not taken
into account, but the version with window_h is buggy too.
Will look at this when I have time.

Bye

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Oct 1998 13:39:56 +0100

> Will look at this when I have time.

Don't have a chance to test it now, but this might work:

  XMoveResizeWindow(dpy,Desks[i].title_w,
                    (desk_w+1)*j-1,(desk_h+label_h+1)*k-1,
                    desk_w,desk_h+label_h);
                           ^^^^^^^^^^^^^^

Could someone test this for me today?

Ciao

Dominik

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Oct 1998 13:51:37 +0100

On Thu, Oct 29, 1998 at 07:48:09AM -0500, [email-masked] wrote:
> That fixed it.
> Good work.
> I just made this change not Dan's

OK, we have a fix, I will put it in the animicons_menupos
branch.