Subject: FvwmButtons geometry fix!!!!

From: Brad Giaccio <[email-masked]>
Date: Thu, 29 Oct 1998 08:02:29 -0500 (EST)

I believe I and a few others sent this out earlier but it still hasn't
made it into the code yet.  And I have lost track of who last made changes
to FvwmButtons (either Dan or Dominik).

But could you please insert into FvwmButtons/parse.c around 753
 
    if(i==1)
      {
        flags=XParseGeometry(geom,&g_x,&g_y,&width,&height);
+       UberButton->w = 0;
+       UberButton->h = 0;
        if(flags&WidthValue) w=width;
        if(flags&HeightValue) h=height;
        if(flags&XValue)    UberButton->x = g_x;

I recall one of you saying that you always run your FvwmButton at -0-0
which is fine for you because that is what the code does by default.  But
for the rest of us this code would be helpful.

Thanks,
Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Oct 1998 15:18:04 +0100

> to FvwmButtons (either Dan or Dominik).

It was me.

>         if(flags&XValue)    UberButton->x = g_x;

Done.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].