Subject: CVS branch: menu_position

From: Dominik Vogt <[email-masked]>
Date: Sun, 25 Oct 1998 16:58:37 +0100

We now have a second cvs branch named "menu_position".
Despite it's name it contains much more than my
original patch. I must apologize that I cannot present
a nice overview of what is in there exactly, but I have
lost orientation myself. You will find three READMEs
explaining everything in detail (sorry, that is a lot
to read):

./README.pager-patch
./fvwm/README.position
./modules/FvwmButtons/README.FvwmButtons

I'll be grateful for every adventurous soul willing
to TEST these patches O:-)

> To get a copy, you need "cvs".  Use this command:
> 
> cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm \
>   checkout -P -r menu_position fvwm
> 
> (The backslash is for readibility, put the whole command
> on one line.)

Ciao

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883,
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 27 Oct 1998 08:01:59 -0500 (EST)

I think there is a slight problem here
If I try to checkout both sets of brnaches at once one removes the other.
That is if I issue
cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm checkout -P -r
animate_icons fvwm
cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm checkout -P -r
menu_position fvwm

The second one removes all the files that the first one extracts.  My
guess is this beacause I have no idea what I'm doing with CVS.  Now I'm
more than happy to test why you guys put out, but I would also like to be
able to test both branches in one executable.

To Dominik, 
	I noticed that you had put some files from FvwmCommand in your
branch, do you have any guess as to what changed in there or is that just
upping us to version 1.5? Since the old distibution had 1.4

Brad

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous

---

From: Dan Espen <[email-masked]>
Date: Tue, 27 Oct 1998 08:14:22 -0500

> able to test both branches in one executable.

Use -P -r as you did for the first checkout, then follow it with:

cvs -z3 -d :pserver:[email-masked]:/home/cvs/fvwm \
  checkout -j menu_position fvwm

The "-j" does a merge.

...

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 Oct 1998 14:51:41 +0100

[email-masked] wrote:
> I noticed that you had put some files from FvwmCommand
> in your branch, do you have any guess as to what changed
> in there or is that just upping us to version 1.5? Since
> the old distibution had 1.4

I must confess I do not have the slightest idea what has
happened there. The code I started working with originally
was a tared-gzipped 47d (I got that from Tim because I could
not get a connection to the server back then).
However, I noticed that a bunch of files that I never
touched
were updated during my checkin session with CVS. I thought
the CVS tree was 47d too, but apparently that is wrong (?)

Some hints from someone who has a deeper knowledge of the
CVS tree will be appreciated (remember I missed most of the
discussion about CVS).

Thanks

Dominik

---

From: Maciej Stachowiak <[email-masked]>
Date: Tue, 27 Oct 1998 11:42:25 EST

> CVS tree will be appreciated (remember I missed most of the

You can see what the changes were with `cvs diff'. CVS does not ignore
formatting/whitespace changes, so that could be it.

 - Maciej

---

From: Magnus & Tina <[email-masked]>
Date: Wed, 28 Oct 1998 13:18:33 +0100 (GMT+0100)

A very stupid question.
How do I check what branches are available?

animate_icons
menu_position
????

BR Magnus Back

---

From: Magnus & Tina <[email-masked]>
Date: Wed, 28 Oct 1998 14:41:20 +0100 (GMT+0100)

When trying out FvwmAnimate from CVS I run into a problem with FvwmAnimateColor.
The module crashes when I set it. I am runing 16 bits color if that helps.
I read this in FvwmAnimate.c so maybe it shouldn't work.

*   I couldn't get the color feature to generate colors,
*   perhaps because I have 8-bit color only?

Bare with me, how do I debug this?

Error message:

 Error of failed request:  BadValue (integer parameter out of range for
 operation)
 Major opcode of failed request:  88 (X_FreeColors)
 Value in failed request:  0xffffffff
 Serial number of failed request:  17
 Current serial number in output stream:  18         

Settings in .fvwm2rc

# FvwmAnimate
*FvwmAnimateEffect Random
*FvwmAnimateIterations 12
*FvwmAnimateWidth 1
*FvwmAnimateTwist 0.500000
*FvwmAnimateDelay 1
*FvwmAnimateColor Gold2

BR Magnus Back

> upping us to version 1.5? Since the old distibution had 1.4

      .---.        .----------- Magnus Back
     /     \  __  /    ------   Nippon Ericsson K.K
    / /     \(  )/    -----     SY/NRJ/SV/F MBK
   //////   ' \/ `   ---        [email-masked] (work)
  //// / // :    : ---          [email-masked]             (home)
 // /   /  /`    '--            +81-45-475-0418 phone
//          //..\\              +81-45-475-0040 fax
       ====UU====UU====         http://www2.gol.com/users/magnus/
           '//||\\`            
             ''``
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 28 Oct 1998 08:31:30 -0500

>  Current serial number in output stream:  18         

Looks like it didn't like the X_FreeColors call I added to the code.
Here is the comment I put next to that:

    /*
     * This may not work.  My experience  with this is zero.  The example
     * I used is in builtins.c, and it is commented out !  dje 10/10/98.
     */
    XFreeColors(dpy, DefaultColormap(dpy,scr),
                &xcol.pixel,
                1,                      /* # of pixels? */
                AllPlanes);

And here is the commented out code in builtins.c:

	/* - should we check visual is not TrueColor before doing this? 
	   XFreeColors(dpy, Scr.FvwmRoot.attr.colormap, 
		    bf->u.grad.pixels, bf->u.grad.npixels,
		    AllPlanes); */

Strangely enough, I tested this without a problem.

I suggest you comment out the X_FreeColors call.  Let me know
if this fixes the problem.

I am very interested in whether this option will  give you any kind of
color effect, and  under   what  conditions.   I found  some   limited
success, only when the area the animation was traversing was black.

If it works under any condition I can document, I will make it a fully
supported option.  Somewhere along the line, I will have to figure out
how to free the color.

---

From: Dan Espen <[email-masked]>
Date: Wed, 28 Oct 1998 10:05:45 -0500

> How do I check what branches are available?

I don't think it's a stupid question, but then I don't understand
much about CVS.

This seems to do the job:

fork> cvs log -b README   

RCS file: /home/cvs/fvwm/fvwm/README,v
Working file: README
head: 1.1
branch: 1.1.1
locks: strict
access list:
symbolic names:
        menu_position: 1.1.1.1.0.4
        menu_position_start: 1.1.1.1
        animate_icons: 1.1.1.1.0.2
        animate_icons_start: 1.1.1.1
        start: 1.1.1.1
        fvwm: 1.1.1
keyword substitution: kv
total revisions: 2;     selected revisions: 1
description:
----------------------------
revision 1.1.1.1
date: 1998/10/14 00:03:21;  author: tibbs;  state: Exp;  lines: +0 -0
Import from 2.0.47d
=============================================================================

It doesn't seem to matter which file you pick.
I'm not sure why it shows revisions to this file,
I don't believe I made any change to it.

I think in general, you  would only want to access  a branch after  it
has been announced.  Otherwise, who knows what state it will be in.

---

From: Magnus & Tina <[email-masked]>
Date: Thu, 29 Oct 1998 22:23:55 +0100 (GMT+0100)

I turned on debugging for FvwmAnimate and this is what i got.
Note that when *FvwmAnimateColor is undefined color is 65535 (Hex FFFF).

Something else I should do to debug this?

/// Magnus Back

FvwmAnimate: Starting, argv[0] is /usr/X11R6/lib/X11/fvwm2/FvwmAnimate, len 12
xbackdrop v1.02
Reading options
Found line for me: *FvwmAnimateEffect Random
Found line for me: *FvwmAnimateIterations 12
Found line for me: *FvwmAnimateWidth 1
Creating GC
Color is 65535
Found line for me: *FvwmAnimateTwist 0.500000
Found line for me: *FvwmAnimateDelay 1
Found line for me: *FvwmAnimateColor Gold2
Creating GC
Color is 60992
Creating GC
X Error of failed request:  BadValue (integer parameter out of range for
operation)
Major opcode of failed request:  88 (X_FreeColors)
Value in failed request:  0xffffffff
Serial number of failed request:  17
Current serial number in output stream:  18

---

From: Dan Espen <[email-masked]>
Date: Thu, 29 Oct 1998 08:41:10 -0500

> Something else I should do to debug this?

No, this morning I found that I can create the error.
I also found that if I remove the X_freecolor, I get color leakage.

The amount to leakage shouldn't be significant for this module, but
I wouldn't advocate releasing code with any amount of color leakage.

I'm either going to find the correct way to free the colors, or remove
the color logic completely.

I'm pretty  much convinced that  the  color feature can't  really work
anyway.   The  color value is   "ored" into the  background, and can't
really give you the color you ask for.

---

From: Dan Espen <[email-masked]>
Date: Thu, 29 Oct 1998 13:50:52 -0500

> Current serial number in output stream:  18

I've  uploaded a  change  to FvwmAnimate.c  in the "animicons_menupos"
branch that should fix this problem.

Remember that the "color feature" is not actually a feature, I removed
it from the documentation for that reason.

I've also updated the ChangeLog with the changes I've made so far in
this release.