Subject: Re: Getting KeyRelease Events?

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 Sep 1998 11:54:38 +0200

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]

Subject: Re: Getting KeyRelease Events?
From: Dominik Vogt <[email-masked]>
To: [email-masked]
Date: Fri, 11 Sep 1998 11:52:08 +0200

[email-masked] wrote:
> 
> Dominik Vogt wrote:
> > I was thinking about a more general way to do that. Menu und
> > Popup (and perhaps WinList) would have the following parameters:
> >
> >  Popup Name [ [<context>] x y ]
> >  Menu  Name [ [<context>] x y ] DoubleClickAction
> >
> >  Value       Reference rectangle:
> > ----------------------------------------------------------------------
> >  context     the x/y/w/h values of the spawning window/menu
> >  root        the screen
> >  mouse       a 1x1 rectangle at the mouse position
> >  <geometry>  a rectangle specified in XGeometry style
> >
> > The plus of this syntax is that you can place a menu relative
> > to a button of FvwmButtons (with some enhancement of the
> > Buttons syntax).
> 
> I think I'm being dim but I don't get how this specifies which part of a
> menu is being positioned or is it always the top left?

Just like in a geometry spec, if the value is +, the left/top edge
of the menu if aligned to the left/top edge of the context. If the
value is -, bottom/right is aligned with bottom/right, if the 'c'
is present, centers are aligned (sign does not matter here).

> I think it would
> be nice to say "top left of menu in top left of window" or "centre of
> window in centre of screen" or "top right of menu in top left of
> window". It's 81 (3^4) possible combinations plus x,y signed offsets.

> How do you get a root centred menu?

 Menu foo root c+0 c+0 <doubleclick action>

> How do you get a menu abutted to the
> left side of a window if you don't know it's width?

 Popup bar context +0 c+0

> I like the context
> bit but I don't think just x y is enough unless you start special casing
> certain numbers like 0<=x<50:-"left edge", x=50:-"horizontally centred",
> 50<x<100:="right edge", 100<x:="left edge".

It is enough if you use values > 100 and < -100 (or big values
with the 'p' prefix). E.g. '+150' means: the left (top) edge of
the menu is 150% right (down) from the left (top) edge of the
context area (where 100% is the width (height) of the context
area).

I hope my weird logic is a little clearer know. Mathmacitians like
me sometimes have problems with logic, you know? ;-) If not,
please
ask.

> > > This scheme will not allow menu to be positioned outside the
> > > edges of windows.
> > If you have seen CDE or VUE, you *have* seen it.
> 
> Duh! Sorry, VUE frontpanel = deeply repressed memory.

Say what you will, I *like* it. Anyway, if you work for HP
you haven't much of a chance to avoid it (except using
windoze of course) ;-)

> > I am already working with the 2.0.47d source to implement
> > this, just give me some time.
> 
> Go for it, patch away and I'll be a Guinea pig.

Ha Ha Ha! You'll regret that 8-)). I think I'll get it done
this weekend.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]

---

From: Tim Phipps <[email-masked]>
Date: Fri, 11 Sep 1998 11:19:24 +0100

>  Menu foo root c+0 c+0 <doubleclick action>
OK I ge your drift now, I thought you weren't going to have 'c' in the
(x y) bit.

> > I like the context
> > bit but I don't think just x y is enough

Problems with speeling too 8-).

OK so a menu next to but not overlapping the left side would be
popup menu_name context -100 +0

Just to push you over the edge and not because I want to be able to do
this but what if I wanted a 6 pixel gap between the window and the menu?

popup menu_name context -100-6p +0 ???

Cheers,
Tim.

<digress>

> you haven't much of a chance to avoid it (except using
In my last job a HP my boss bought a PC for me to work at home (cheers
Greg). I ran Linux and I liked it so much I tossed my HP-UX box into a
corner and used a spare Pentium that was lying around to run my work
desktop so I had the same setup at work and at home.

</digress>
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 Sep 1998 13:30:24 +0200

[email-masked] wrote:
> 
> > Mathmacitians like
> > me sometimes have problems with logic, you know? ;-)
> 

No, not raelly spellnig, there are just so many keys and I can
never decide which to hit next 8-)
lkjsadhlkuf][]43*&^dhgrhgkdh324gesagie spw
Hehe! I think I got them all!

> this but what if I wanted a 6 pixel gap between the window and the menu?

That point *is* valid. You might want that because of the
window borders.

> popup menu_name context -100-6p +0 ???

Hmm, why not. Als long as I don't have to write the
description in the man page :)
 
> desktop so I had the same setup at work and at home.

Argh! I was just talking about the front panel (it's nearly
the same in CDE). After one and a half year as AIX sysadmin
I wouldn't care to run an HP-UX. Linux is the coming
standard!

Bye

Dominik