Subject: Small patch to get latest cvs to compile on my MkLinux

From: Mikey <tadpol@lilypad>
Date: Wed, 23 Sep 1998 00:10:43 -0500 (CDT)

ok, here is just a small patch with the changes I had to make to get the
latest cvs pull to compile under MkLinux DR3 for PPC.  I'm not completely
sure of the effects of the changes, but I can now make a runnable binary.
(I'm still trying to find out why it cores when ever I try to move a window
though. any ideas?)

Index: builtins.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/builtins.c,v
retrieving revision 1.1.1.1
diff -u -r1.1.1.1 builtins.c
--- builtins.c	1998/07/20 17:44:11	1.1.1.1
+++ builtins.c	1998/09/23 04:59:26
@@ -3096,7 +3096,7 @@
     while((fw != NULL)&&(found==NULL)&&(fw != &Scr.FvwmRoot))
     {
 #ifdef FVWM_DEBUG_MSGS
-      fvwm_msg(DBG,"Circulate","Trying %s",fw->name)
+      fvwm_msg(DBG,"Circulate","Trying %s",fw->name);
 #endif /* FVWM_DEBUG_MSGS */
       /* Make CirculateUp and CirculateDown take args. by Y.NOMURA */
       if ((onFlags & fw->flags) == onFlags &&
Index: module.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/module.c,v
retrieving revision 1.2
diff -u -r1.2 module.c
--- module.c	1998/09/22 14:01:22	1.2
+++ module.c	1998/09/23 04:59:27
@@ -23,7 +23,8 @@
 #include <X11/keysym.h>
 #include <sys/types.h>
 #include <sys/socket.h>
-#include <sys/varargs.h>                /* for Broadcast_v */
+/* #include <sys/varargs.h>*/
+#include <varargs.h>                /* for Broadcast_v */
 
 #include "fvwm.h"
 #include "menus.h"
@@ -450,7 +451,8 @@
   body[1] = event_type;
   body[2] = num_datum+HEADER_SIZE;
   body[3] = lastTimestamp;    
-  va_start(ap,num_datum);               /* init va_list w. starting point */
+/*  va_start(ap,num_datum);             init va_list w. starting point */
+  va_start(ap);               /* init va_list w. starting point */
   for (i=HEADER_SIZE;i < num_datum+HEADER_SIZE; i++) {
     body[i] = va_arg(ap, u_long);       /* copy args */
   }

--
Mike Tilstra                                   Tadpol
[email-masked]  http://www.tc.umn.edu/~tils0007/
   Sanity is the playground for the unimaginative.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 23 Sep 1998 00:19:38 -0500

>>>>> "M" == Mikey  <tadpol@lilypad> writes:

M> (I'm still trying to find out why it cores when ever I try to move a
M> window though. any ideas?)

Compile with debugging and get a backtrace from the core.

 - J<

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Sep 1998 10:04:12 -0400

> +++ module.c	1998/09/23 04:59:27

I had a feeling using "varargs"  was going to  do this.  I had a small
hope  that   UNIX was  getting  mature enough    that the old ifdefing
solution wouldn't be required.

Before I change anything, does this work?

#ifdef __STDC__
#include <stdarg.h>
#else
#include <varargs.h>
#endif

#ifdef __STDC__
    va_start(ap,num_datum);
#else
    va_start(ap);
#endif

Any other guidance on doing this portably would be appreciated.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikey <tadpol@lilypad>
Date: Wed, 23 Sep 1998 12:35:50 -0500 (CDT)

> Before I change anything, does this work?

yes, it compiles without complaint.

Mike Tilstra                                   Tadpol

---

From: Dan Espen <[email-masked]>
Date: Wed, 23 Sep 1998 15:42:16 -0400

> sure of the effects of the changes, but I can now make a runnable binary.

Both problems from above are now fixed in the animate_icons branch.
You can update your copy from within the fvwm directory with:

cvs -z3 update -dP

Thanks Mike.

---

From: Steven Robbins <[email-masked]>
Date: Thu, 24 Sep 1998 09:30:02 +0200

> Any other guidance on doing this portably would be appreciated.

Two words: automake & autoconf.