Subject: positionable menu patch (large)

From: Dominik Vogt <[email-masked]>
Date: Mon, 21 Sep 1998 16:56:45 +0200

Hi folks,

I have written a rather large patch to the 2.0.47d code
that allows to place menus, popup menus, the windowlist
and any submenu somewhere on the screen, relative to the
mouse, other menus, menu items, any part of a window,
icon etc. For example you can open the windowlist in the
center of the screen or dropping down from a window title.

Along with the patches I made a whole lot of
bugfixes in the original code. I think it is really
useful and I have tested it thoroughly, but since it
the diffs are 60k I can't assure I found everything.
Along with the patches (attachment) there is a readme
file that explains how exactly this works and which
bugfixes I did make. Please don't hesitate to send me
any problems or bugs or questions if the readme isn't
clear enough. The documentation isn't at complete as
one could wish. There is no explanation how exactly
warping or menu animation do work with the patch.
I will write some lines about that as soon as possible.

I am still thinking about some enhancements to the
patch, so if anybody has a good idea, do tell me.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Sep 1998 11:20:19 +0200

Oops,

that weren't the diffs but the whole files. Sorry.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].