Subject: Tiny patch to stop AnimatedMove moving the cursor

From: Tim Phipps <[email-masked]>
Date: Tue, 07 Jul 1998 15:20:28 +0100

Here's a one-liner that stops the AnimatedMove function moving the
cursor.  Animated menus are not affected.  

*** move.c.orig Tue Jul  7 14:54:15 1998
--- move.c      Tue Jul  7 14:54:20 1998
***************
*** 170,176 ****
          XMapWindow(dpy,tmp_win->icon_w);
          if (fAnimated) {
            AnimatedMoveOfWindow(tmp_win->icon_pixmap_w, -1,-1,
!                               
tmp_win->icon_x_loc,FinalY,TRUE,-1,NULL);
          } else {
            XMoveWindow(dpy, tmp_win->icon_pixmap_w,
tmp_win->icon_x_loc,FinalY);
          }
--- 170,176 ----
          XMapWindow(dpy,tmp_win->icon_w);
          if (fAnimated) {
            AnimatedMoveOfWindow(tmp_win->icon_pixmap_w, -1,-1,
!                               
tmp_win->icon_x_loc,FinalY,FALSE,-1,NULL);
          } else {
            XMoveWindow(dpy, tmp_win->icon_pixmap_w,
tmp_win->icon_x_loc,FinalY);
          }

Subject: diff
From: [email-masked] (Tim Phipps)
To: [email-masked]
Date: Tue, 7 Jul 1998 15:15:10 +0100

*** move.c.orig	Tue Jul  7 14:54:15 1998
--- move.c	Tue Jul  7 14:54:20 1998
***************
*** 170,176 ****
  	  XMapWindow(dpy,tmp_win->icon_w);
  	  if (fAnimated) {
     	    AnimatedMoveOfWindow(tmp_win->icon_pixmap_w, -1,-1,
! 				 tmp_win->icon_x_loc,FinalY,TRUE,-1,NULL);
  	  } else {
  	    XMoveWindow(dpy, tmp_win->icon_pixmap_w, tmp_win->icon_x_loc,FinalY);
  	  }
--- 170,176 ----
  	  XMapWindow(dpy,tmp_win->icon_w);
  	  if (fAnimated) {
     	    AnimatedMoveOfWindow(tmp_win->icon_pixmap_w, -1,-1,
! 				 tmp_win->icon_x_loc,FinalY,FALSE,-1,NULL);
  	  } else {
  	    XMoveWindow(dpy, tmp_win->icon_pixmap_w, tmp_win->icon_x_loc,FinalY);
  	  }

---

From: Greg Badros <[email-masked]>
Date: 07 Jul 1998 10:08:41 -0700

Tim Phipps <[email-masked]> writes:

> This is a multi-part message in MIME format.
> --------------B5A655C24F1809480743E651
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 

You have to make the moving of the cursor an option -- you can't just
turn it off.  Sometimes it's the wrong thing, as you (or someone else?)
has pointed out, but just as often it's the right thing.  Just add an
extra argument to the move primitive and select the right behaviour with 
a test on that argument at run-time.  It'll be a much more useful patch.

Greg
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 08 Jul 1998 10:55:33 +0100

> a test on that argument at run-time.  It'll be a much more useful patch.

I don't think it's worth changing at this stage, after fvwm3 starts
maybe.

Cheers,
Tim.