Subject: Re: fvwm 2.0.47b

From: Albrecht Kadlec <[email-masked]>
Date: 01 Jul 1998 20:15:29 +0200

Brady Montz <[email-masked]> writes:

> Albrecht Kadlec <[email-masked]> writes:
> 
> > Bugs 
> 
> Oh my. I'll have to wade through these. I'll release the next alpha version
> though first.

> > -) resizing FvwmButtons doesn't resize the bottons inside any more.

btw: I'm giving full geometry to my fvwmbuttons. I don't care so much about
the aspect ratio (it's about right).

> >    in 2.0.45 (don't know of .46) my swallowed xterm, buttons & pager
> >    were resized, if I resized Fvwmbuttons.
> >    2.0.47b doesn't do that. Instead there's a bigger / smaller 
> >    lower & right margin (background color)

also the new FvwmButtons keeps starting up new copies of xload & xbiff...
despite my using "UseOld,NoClose,Respawn"

*FvwmButtons (	Action "X @@", Swallow (UseOld, NoClose, Respawn) xclock "X xclock")

> > -) the old bug of a second pager appearing after a time is still there.

also started with UseOld,NoClose,Respawn.

I noticed a third pager at one occasion:
oddly enough 2 pagers had the same pipe filedescriptors, while the third
had another one (the first number was different).

if you need my .fvwm2rc, it's on my homepage:
<http://www.auto.tuwien.ac.at/~albrecht>
-- 
Albrecht Kadlec
Vienna University of Technology / Department of Automation
----------------------------------------------------------
Did you expect that code you gave me would work?	-- Adam Hammer
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brady Montz <[email-masked]>
Date: 02 Jul 1998 10:01:58 -0700

> *FvwmButtons (	Action "X @@", Swallow (UseOld, NoClose, Respawn) xclock "X xclock")

I'm not sure if this ever has worked for me. I've tried for years to prevent
FvwmButtons from starting a new xdaliclock when I restart.

-- 
 Brady Montz
 [email-masked]

---

From: "Peter J. Weyers" <[email-masked]>
Date: Tue, 7 Jul 1998 10:36:46 +0200 (MST)

> *FvwmButtons (	Action "X @@", Swallow (UseOld, NoClose, Respawn) xclock "X xclock")

I never got this working. Last time I tried was with 2.0.45

Peter

---

From: [email-masked] (David S. Goldberg)
Date: 07 Jul 1998 11:12:49 -0400

>> also the new FvwmButtons keeps starting up new copies of xload &
>> xbiff...  despite my using "UseOld,NoClose,Respawn"
>> 

Try it without Respawn.  UseOld,NoClose only works well for me and
eliminates the extra copies across Restarts.  If the app dies, I do a
killmodule FvwmButtons and then run it again (all in one Function!),
which isn't pretty, but happens rarely enough that I can live with it
as a workaround.

--
Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 781-271-3887
Email: [email-masked]

---

From: Albrecht Kadlec <[email-masked]>
Date: 08 Jul 1998 10:54:57 +0200

> I never got this working. Last time I tried was with 2.0.45

you have to allow for a little bit time to really unswallow these apps
(re-map on desktop, I suppose, after unmapping Fvwmbuttons.)

2 wait FvwmBanners (in restart- & ... functions) worked for me all the
time, until 2.0.47

see my .fvwm2rc on my homepage.

-- 
Albrecht Kadlec
Vienna University of Technology / Department of Automation
----------------------------------------------------------
Welcome my son, welcome to the machine.
Where have you been? It's alright we know where you've been.
You've been in the pipeline, filling in time, provided with toys and
   'Scouting for Boys'.
You bought a guitar to punish your ma,
And you didn't like school, and you know you're nobody's fool,
So welcome to the machine.				-- Pink Floyd
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].