Subject: colors.c: increased contrast between shadow/normal/hilight (making fvwm2 more mwm like)

From: Smokey <[email-masked]>
Date: Mon, 15 Jun 1998 20:49:58 -0400

fvwm/colors.c.diff:
(a good idea would be to be able to change the contrast in .fvwm2rc)

a1,7
> /* fixed (increased) shadow/hilight contrast (looks more like mwm now)

>    patch by Jakub Jasinski ([email-masked])
>
>    -- this makes the windows look much much much better, esp with the
default
>       mwm color (#59659e79a699)
> */
>
60,63c67,71
<
<   bg_color.red = r;
<   bg_color.green = g;
<   bg_color.blue = b;
---
>
> /* the shadow is darkened here (more contrast than before) */
>   bg_color.red = (int)((double)r * 0.8);
>   bg_color.green = (int)((double)g * 0.8);
>   bg_color.blue = (int)((double)b * 0.8);
97,103c105,112
<   bg_color.red = max((white_p.red/5), bg_color.red);
<   bg_color.green = max((white_p.green/5), bg_color.green);
<   bg_color.blue = max((white_p.blue/5), bg_color.blue);
<
<   bg_color.red = min(white_p.red, (bg_color.red*140)/100);
<   bg_color.green = min(white_p.green, (bg_color.green*140)/100);
<   bg_color.blue = min(white_p.blue, (bg_color.blue*140)/100);
---
> /* the hilight is made lighter here (more contrast than before) */
>   bg_color.red = max((white_p.red/4), bg_color.red);
>   bg_color.green = max((white_p.green/4), bg_color.green);
>   bg_color.blue = max((white_p.blue/4), bg_color.blue);
>
>   bg_color.red = min(white_p.red, (bg_color.red*160)/100);
>   bg_color.green = min(white_p.green, (bg_color.green*160)/100);
>   bg_color.blue = min(white_p.blue, (bg_color.blue*160)/100);

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 15 Jun 1998 23:25:18 -0500

>>>>> "S" == Smokey  <[email-masked]> writes:

S> fvwm/colors.c.diff:

Note that anything but context or unified diffs is essentially useless.
Please use diff -u or diff -c to generate patches so that they can be
applied automatically.

 - J<