Subject: Anyone want my FvwmTaskBar improvements?

From: [email-masked] (Michael L. Raymer)
Date: Tue, 12 May 1998 09:46:32 -0400

I have written a patch for FvwmTaskBar which allows the following behavior:
  - Only windows on the current desk (including sticky windows)
    show up in the taskbar
  - When the desktop is switched, the taskbar updates to show only windows which
    are associated with the new desk

This allows the taskbar to be much less crowded, and I find this behavior to be
more useful than having taskbar entries for every window known to FVWM.

If there is any interest in this patch, I'd be happy to make the above behavior
optional and then submit the patch to the public domain.  I have two questions:

1) Is there any interest?
2) Who would be the appropriate person to send such a submission to?  I checked
   the source code, but none of the email addresses listed there exist anymore.
   I also checked the FAQ, which said that the mailing lists were the current
   forum for new code submissions.

Thanks for any info,

Michael L. Raymer
Depts. of Computer Science and Biochemistry
Michigan State University
[email-masked]

p.s. - I'm not subscribed to the mailing lists, but I check the archive regularly,
 for a faster response, email me directly.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Clegg <[email-masked]>
Date: Tue, 12 May 1998 20:33:10 -0700 (MST)

>   - Only windows on the current desk (including sticky windows)

I don't know about everybody else, but I think a far more useful property
of a task bar would be one that only included iconized applications.  If
they aren't iconized, they are easy to find.