Subject: FvwmWinList

From: Tomi Sarvela <[email-masked]>
Date: Thu, 2 Apr 1998 12:48:03 +0300 (EEST)

Hi!

	I noticed that the RESIZE_BUG_HACK is not needed in my
	configuration (linux-2.0.33, XFree86 3.3, fvwm-2.0.46),
	in fact, the window moves 2 pixels up and left when
	refreshed, and therefore made very simple patch to move
	the ugly compile-flag to the rc-options.

	Also, if there's active maintainer for this module,
	I'd like a reply .. I have couple of ideas, but I'm
	not sure how to carry them out by myself.

	Tomi

[email-masked]  Ideas and thoughts expressed herein are mine, all mine!
[email-masked]  An NT server can be run by an idiot, and usually is.
__________________________________________________________________________resizebug.diff
--- FvwmWinList.c~	Thu Apr  2 12:41:40 1998
+++ FvwmWinList.c	Thu Apr  2 12:32:53 1998
@@ -116,7 +116,7 @@
       *ForeColor[MAX_COLOUR_SETS] = { "black" },
       *geometry="";
 char *font_string = "fixed";
-int UseSkipList=0,Anchor=1,UseIconNames=0,LeftJustify=0,TruncateLeft=1;
+int UseSkipList=0,Anchor=1,UseIconNames=0,LeftJustify=0,TruncateLeft=1,UseResizeBugHack=0;
 
 long CurrentDesk = 0;
 int ShowCurrentDesk = 0;
@@ -399,7 +399,7 @@
 	CurrentDesk = body[0];
 	if(ShowCurrentDesk)
 	{
-	  RESIZE_BUG_HACK = 1;
+	  RESIZE_BUG_HACK = UseResizeBugHack;
 	  AdjustWindow();
 	  RESIZE_BUG_HACK = 0;
 	  RedrawWindow(1);
@@ -549,6 +549,8 @@
 	    CopyString(&BackColor[2],&tline[Clength+9]);
 	  else if(mystrncasecmp(tline,CatString3(Module, "NoAnchor",""),
 				Clength+8)==0) Anchor=0;
+	  else if(mystrncasecmp(tline,CatString3(Module, "UseResizeBugHack",""),
+				Clength+16)==0) UseResizeBugHack=1;
 	  else if(mystrncasecmp(tline,CatString3(Module, "Action",""), Clength+6)==0)
 	    LinkAction(&tline[Clength+6]);
 	  else if(mystrncasecmp(tline,CatString3(Module, "UseSkipList",""),

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Austin Donnelly <[email-masked]>
Date: Fri, 17 Apr 1998 22:51:32 +0100 (BST)

> 	not sure how to carry them out by myself.

I too have looked at the code in question.  It's not pretty, and not
at all clear when the resize hack needs to be used (if at all).

Until someone claims to have a full(er) understanding of all the
issues involved, I think it would be better if people didn't go
dashing in with quick fixes.  If you _do_, please add comments
describing exactly what the problem you were fixing was.  I believe
this is the only way co-operative development can take place.

Austin