Subject: copyright position with modules/manpages

From: Austin Donnelly <[email-masked]>
Date: Sat, 24 Jan 1998 13:30:33 +0000 (GMT)

Hi,

Although the spirit of fvwm has been free development, several of the
modules currently distributed with fvwm2 have surprisingly tight copy
restrictions.

In order to be able to legally distribute this stuff, it would be
worthwhile finding the authors of the following modules, and asking
them to clarify their copyright position.

Here is a list of the prime culprits:

------------------------------------------------------------

FvwmAudio:
---*---
       Copyright 1994, Mark Boyns and Mark Scott.  No  guarantees
       or  warranties  or anything are provided or implied in any
       way whatsoever.  Use this program at your own risk.   Per
       mission  to  use this program for any purpose is given, as
       long as the copyright is kept intact.
---*---
Bug: Only use is explicit allowed. I don't know if this allows
redistributing, because I'm no lawyer.

FvwmBacker:
FvwmButtons:
FvwmForm:
FvwmIconBox:
FvwmIdent:
FvwmPager:
FvwmScroll:
FvwmWinList:
FvwmSave:
FvwmTalk:
Fall into a situation similar to FvwmAudio.

FvwmAuto:
---*---
AUTHOR
       FvwmAuto just appeared one day, nobody knows how.
       FvwmAuto was simply rewritten 09/96, nobody knows by whom.
---*---
Bug: This is bad: That means there is no explicit copyright, so
therefore it is fully protected by international law.

FvwmBanner:
---*---
COPYRIGHTS
       None.
---*---
Bug: This is very bad. It says that we have *no* right to
copy/redistribute this.  Ouch!

FvwmCascade:
FvwmTile:
---*---
AUTHOR
       Andrew Veliath
---*---
Bug:  No Copyright Statement.

FvwmIconMan:
---*---
AUTHOR
       Brady Montz ([email-masked]).
---*---
Bug: No copyright statement.

FvwmSaveDesk:
---*---
AUTHOR
       Carsten Paeth ([email-masked])
---*---
Bug: No copyright statement.

For those modules with no copyright statement, would a BSD-style
copyright be suitable?  Ie, something like:

/*
 * Copyright (c) <DATE>
 *	<AUTHORNAME>.  All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in the
 *    documentation and/or other materials provided with the distribution.
 * 3. The name of the author, contributors or their associated
 *    organisation(s) may not be used to endorse or promote products
 *    derived from this software without specific prior written
 *    permission.
 *
 * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
 * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
 * ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
 * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
 * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
 * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
 * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
 * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
 * SUCH DAMAGE.
 */

Austin
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Albrecht Kadlec <[email-masked]>
Date: 28 Jan 1998 11:21:28 +0100

> Here is a list of the prime culprits:

Especially Mark Boyns <[email-masked]> was very helpful during the time I
rewrote / enhanced FvwmAudio.
I guess the original authors will, as well as I do, agree to any
free-distribution-copyright notice.

BTW: has somebody changed anything since Oct. 1996 ??
Been away for a while (military service).

> therefore it is fully protected by international law.

I'm `whom'. 
I just continued in the original tune on the man page, as I liked the
humor.

The code says:

/* This module, and the entire FvwmAuto program, and the concept for
 * interfacing this module to the Window Manager, are all original work
 * by Robert Nation
 *
 * Copyright 1994, Robert Nation. No guarantees or warantees or anything
 * are provided or implied in any way whatsoever. Use this program at your
 * own risk. Permission to use this program for any purpose is given,
 * as long as the copyright is kept intact.
 * 
 * reworked by A.Kadlec ([email-masked]) 09/96
 * to support an arbitrary enter_fn & leave_fn (command line arguments)
 * completely reworked, while I was there.
 * 
 * Modified by John Aughey ([email-masked]) 11/96
 * to not perform any action when entering the root window
 *
 * Minor patch by C. Hines 12/96.
 *
 * Bugfixes by A.Kadlec 01-02/96:
 * 	dot cursor from raise not knowing which window
 * 	(long timeout & window already closed):
 * 	changed default function to : WindowId $w Raise
 *
 *	fast raise-toggling for small timeout (100)
 *	and reentering original window, before raise is finished
 */

So if it's ok with rob, I won't stand in the way ;-).

>  * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF

That's ok for the code.
I wouldn't put that clump on the man page-though.
Something shorter. (3 -5 lines at the bottom should suffice)
I would probably add some 
	Bugreports-to: 
or 
	Maintainer:
email address.
(how about a relay station for this at hpc.uh.edu ?)

	Bugreports-to: [email-masked]

and they are forwarded to me (for FvwmAudio & FvwmAuto).
Makes changing the maintainer transparent and insensitive to
address-changes.
And if some maintainer goes dead :-), messages can easily be routed to
chuck or someone else for a while / forever / till someone else volonteers.

albrecht
(Albrecht Kadlec)
-- 
Night after night		     |	What's done is done
Going round and round my brain	     |	We cannot just write off his final scene
His dream is driving me insane	     |	Take heed of the dream
In the corner of some foreign field  |	Take heed
The gunner sleeps tonight		-- Pink Floyd, "The Gunners Dream"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Boyns <[email-masked]>
Date: 28 Jan 1998 08:12:45 -0800

> free-distribution-copyright notice.

The above copyright is *not* correct.  If you look at FvwmAudio.c
you'll find that there is a GPL copyright notice at the top.  Later in
the file it says:

/*
 * This module is based on FvwmModuleDebugger which has the following
 * copyright:
 *
 * This module, and the entire ModuleDebugger program, and the concept for
 * interfacing this module to the Window Manager, are all original work
 * by Robert Nation
 *
 * Copyright 1994, Robert Nation. No guarantees or warantees or anything
 * are provided or implied in any way whatsoever. Use this program at your
 * own risk. Permission to use this program for any purpose is given,
 * as long as the copyright is kept intact.
 */

This was added to give Rob Nation proper credit and if I remember
correctly almost all of the modules at that time had such a copyright.
In this case "This module" does not refer to FvwmAudio.

[snip]

> chuck or someone else for a while / forever / till someone else volonteers.

Does this mean you want to be the official maintainer for FvwmAudio?