Subject: fvwm-2.0.44-almost, finally...

From: "Charles Hines" <[email-masked]>
Date: Mon, 6 Jan 1997 13:26:22 -0500

Howdy all.

Ok, at long last I finally have 2.0.44-almost ready for you guys to
try out.  It's in the usual place:

   ftp://ftp.hpc.uh.edu/pub/fvwm/version-2/.test/fvwm-2.0.44-almost.tar.gz

Looks like:

-rw-rw-r--   1 chines   fvwm      655429 Jan  6 12:04 fvwm-2.0.44-almost.tar.gz

It does not contain all of the fixes and stuff that I wanted to get in
there, but it's close enough for now (check out the ChangeLog entry).

Let me & the rest of the list know how it goes for each of your
platforms, and if all goes well I'll get 2.0.44 out to everyone else
in a few days.

Thanks,
Chuck

ps - I'm looking for a few good examples of various things to put in
the sample rc files for 2.1.0, if anyone would like to provide them:

  * Motif like keybinding examples
  * Various cool Borderstyle/TitleStyle/UseDecor examples (and more
    xpm's of course)
  * More good FvwmForm & FvwmButtons examples (like a simpler version
    of the Copy Desktop Environment version of the COSE toolbar)

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 06 Jan 1997 16:01:32 -0500

> platforms, and if all goes well I'll get 2.0.44 out to everyone else

Seems to build and run OK on Solaris 2.5.

-DLEFT_MENUS is still required to get the "Left Menus" functionality.

The documentation for this is buried in the change log.  I can see no
reason why this isn't built in without the ability to turn it off.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Makoto MATSUSHITA <[email-masked]>
Date: Tue, 07 Jan 1997 12:48:39 +0900

Wonderful work, Chuck!

chuck_hines> Ok, at long last I finally have 2.0.44-almost ready for
chuck_hines> you guys to try out.

In some environments, function is*() is ONLY implemented as a macro
(not in libc), so we'd better include <ctype.h>. Here is a patch.

--- libs/Parse.c.dist	Thu Dec 12 07:23:34 1996
+++ libs/Parse.c	Tue Jan  7 12:40:01 1997
@@ -4,6 +4,7 @@
 
 #include <stdio.h>
 #include <string.h>
+#include <ctype.h>
 #include "fvwmlib.h"
 
 /*

With this patch, I successfully compile (sorry does not execute yet to
report this as quick as possible) fvwm-2.0.44-almost with NEWS-OS 4.x.

-- -
Makoto `MAR_kun' MATSUSHITA

---

From: "Charles Hines" <[email-masked]>
Date: Tue, 7 Jan 1997 09:39:56 -0500

>>>>> "Dan" == Dan Espen <[email-masked]> writes:

>> platforms, and if all goes well I'll get 2.0.44 out to everyone else

Dan> Seems to build and run OK on Solaris 2.5.

Good.

Dan> -DLEFT_MENUS is still required to get the "Left Menus" functionality.

That is correct and intentional.

Dan> The documentation for this is buried in the change log.  I can see no
Dan> reason why this isn't built in without the ability to turn it off.

It is an "undocumented feature" right now until I get a chance to go
over it some more.  Actually, I left it in there in ifdef's primarily
so I wouldn't lose the idea in the reams of email that I have...

It currently only really works correctly for mwm menu functionality
(which I don't use) and I think it should work for both types of menus
with behavior appropriate to each.  Plus I hit some other bugs with it
when I played with it when it was submitted originally (don't recall
exactly what they were now).

Chuck

---

From: Dan Espen <[email-masked]>
Date: Tue, 07 Jan 1997 13:56:35 -0500

> exactly what they were now).

Right again.

I've been using "mwm" style and I didn't see any problems (while using
mwm style).

I just tried it with "fvwm" style menus and it seemed inconsistent and
a little weird.  Sometimes the menus pop to  the right and overlap the
menu, and sometimes they  pop to the  left.

I  also now see with both  styles, that there  are times when there is
plenty of room to pop up a  menu, but if the  menu is popped up thru a
keypress, the mouse pointer warps to 0,0 and the menu pops up there.

Sorry  to see that that  left_menus are not in  such  good shape after
all.   I thought this was  a closed problem.   I don't see anything in
the TODO list.

I don't  know if this will  ever get fixed, but  I can't help but feel
that supporting 2 menu types with the same code is  one of the reasons
this has  been so hard  to get right.   I know it blew  my mind when I
made my feeble attempt.

I guess we would have a  menu war if we tried  to eliminate one of the
types...

---

From: "Randall S. Winchester" <[email-masked]>
Date: Wed, 8 Jan 1997 13:06:05 -0500 (EST)

Here is a patch from "Markus Gutschke <[email-masked]>" which will
allow clicking in a window to raise the window as fvwm-2 already does in
clicktofocus mode.

This patch has been extremely well recieved by our user base. I hope this
will make it into the release. 

Thanks,
Randall

rcsdiff -u Fvwm.tmpl
===================================================================
RCS file: RCS/Fvwm.tmpl,v
retrieving revision 1.1
diff -u -r1.1 Fvwm.tmpl
--- 1.1 1997/01/07 01:21:04
+++ Fvwm.tmpl   1997/01/08 17:57:36
@@ -237,6 +237,12 @@
  * up so only the title-bar remains.  See the man page entry for
  * "WindowShade" for more information.
  *
+ *
+ * -DCLICKTORAISE
+ * 
+ * Enables ClickToRaise in a window in all focus modes. The default is
+ * to just do this for the the ClickToFocus mode.
+ *

***************************************************************************/
 
 /* note - not all build environments like the '+=' useage below... */
@@ -246,7 +252,7 @@
 OPTION_DEFINES += -DACTIVEDOWN_BTNS -DINACTIVE_BTNS -DMINI_ICONS
 OPTION_DEFINES += -DVECTOR_BUTTONS -DPIXMAP_BUTTONS -DGRADIENT_BUTTONS
 OPTION_DEFINES += -DMULTISTYLE -DEXTENDED_TITLESTYLE 
-OPTION_DEFINES += -DBORDERSTYLE -DUSEDECOR -DWINDOWSHADE
+OPTION_DEFINES += -DBORDERSTYLE -DUSEDECOR -DWINDOWSHADE -DCLICKTORAISE
 
 /* the works, not using '+=': */
 /* OPTION_DEFINES  = -DSHAPE -DACTIVEDOWN_BTNS -DINACTIVE_BTNS -DMINI_ICONS
-DVECTOR_BUTTONS -DPIXMAP_BUTTONS -DGRADIENT_BUTTONS -DMULTISTYLE
-DEXTENDED_TITLESTYLE -DBORDERSTYLE -DUSEDECOR -DWINDOWSHADE */

rcsdiff -u fvwm/events.c 
===================================================================
RCS file: fvwm/RCS/events.c,v
retrieving revision 1.1
diff -u -r1.1 fvwm/events.c
--- 1.1 1997/01/08 16:20:25
+++ fvwm/events.c       1997/01/08 17:26:04
@@ -978,6 +978,25 @@
       
     }
   }
+#ifdef CLICKTORAISE
+  else if ((Tmp_win) && !(Tmp_win->flags & ClickToFocus) &&
+          Event.xbutton.window == Tmp_win->frame)
+    {
+      if (Tmp_win != Scr.LastWindowRaised &&
+         (Event.xbutton.state &
+          (ControlMask|Mod1Mask|Mod2Mask|Mod3Mask|Mod4Mask|Mod5Mask)) == 0 &&
+         GetContext(Tmp_win,&Event, &PressedW) == C_WINDOW)
+           {
+             RaiseWindow(Tmp_win);
+             KeepOnTop();
+           }
+      XSync(dpy,0);
+      XAllowEvents(dpy,ReplayPointer,CurrentTime);
+      XSync(dpy,0);
+      return;
+    }
+#endif
+ 
   XSync(dpy,0);
   XAllowEvents(dpy,ReplayPointer,CurrentTime);
   XSync(dpy,0);

rcsdiff -u fvwm/add_window.c 
===================================================================
RCS file: fvwm/RCS/add_window.c,v
retrieving revision 1.1
diff -u -r1.1 fvwm/add_window.c
--- 1.1 1997/01/08 16:20:14
+++ fvwm/add_window.c   1997/01/08 16:23:40
@@ -621,8 +621,10 @@
                        &a,&b,&JunkChild);
   tmp_win->xdiff -= a;
   tmp_win->ydiff -= b;
+#ifndef CLICKTORAISE
   if(tmp_win->flags & ClickToFocus)
     {
+#endif
       /* need to grab all buttons for window that we are about to
        * unhighlight */
       for(i=0;i<3;i++)
@@ -635,7 +637,9 @@
                        ButtonPressMask, GrabModeSync,GrabModeAsync,None,
                        Scr.FvwmCursors[SYS]);
          }
+#ifndef CLICKTORAISE
     }
+#endif
   BroadcastConfig(M_ADD_WINDOW,tmp_win);
 
   BroadcastName(M_WINDOW_NAME,tmp_win->w,tmp_win->frame,

---

From: Bob Woodside <[email-masked]>
Date: Thu, 9 Jan 1997 01:36:09 -0500 (EST)

Great stuff, Chuck! Hope you're feeling well again.

    Compiles & runs without a hitch on my Linux 2.0.0 (just call me
old-fashioned) sorta Slackwarish system.

    Special congrats to Andrew & Brady. I've only just begun to play
with your new decor options, but, well, um... Wow!

    This is indeed a great way to start the New Year!

        Cheers!
        Bob

---

From: [email-masked] (Albrecht Kadlec)
Date: Thu, 9 Jan 97 15:27:20 +0100

>>>>> Makoto MATSUSHITA writes:

M> Wonderful work, Chuck!

M> In some environments, function is*() is ONLY implemented as a macro
M> (not in libc), so we'd better include <ctype.h>. Here is a patch.

Chuck simply removed the 

	#include <ctype.h>

from the fvwmlib.h, I sent to him.
Put it back in there, it's used in more places:

fvwm-2.0.44-almost> find . -exec grep -s isspace {} \; -print

yields:
./extras/FvwmGoodStuff/FvwmGoodStuff.c
./fvwm/builtins.c
./fvwm/menus.c
./fvwm/read.c
./fvwm/style.c
./libs/Module.c
./libs/Parse.c
./libs/Strings.c
./libs/fvwmlib.h
./modules/FvwmBacker/FvwmBacker.c
./modules/FvwmButtons/FvwmButtons.c
./modules/FvwmButtons/parse.c
./modules/FvwmForm/FvwmForm.c
./modules/FvwmIconBox/FvwmIconBox.c
./modules/FvwmIconMan/readconfig.c
./modules/FvwmPager/FvwmPager.c
./modules/FvwmSave/FvwmSave.c
./modules/FvwmSaveDesk/FvwmSaveDesk.c
./modules/FvwmWinList/FvwmWinList.c

M> --- libs/Parse.c.dist	Thu Dec 12 07:23:34 1996
M> +++ libs/Parse.c	Tue Jan  7 12:40:01 1997
M> @@ -4,6 +4,7 @@
 
M>  #include <stdio.h>
M>  #include <string.h>
M> +#include <ctype.h>
M>  #include "fvwmlib.h"
 
M>  /*

M> With this patch, I successfully compile (sorry does not execute yet to
M> report this as quick as possible) fvwm-2.0.44-almost with NEWS-OS 4.x.

albrecht (whose 2.0.44 is still not working)
-- 
We all know Santa as a fat, jolly old man. Well, he may be fat and he
may be old, but he ain't always jolly. There was this one year when
Mrs. Claus decided she wanted to be a feminist, the reindeer went on
strike, and the elves sued because they wanted to be called
"vertically challenged toy manufacturers".
So Santa retreated to his office to rest, when an angel entered and
said, "Santa..."
"What do you want?" was the reply.
"Well," the angel answered,"The Christmas Tree arrived today."
"So?" Santa said.
"Well, I was wondering where you wanted me to put it."
And that, my friends, is why Angels sit on top of trees.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].