Subject: fvwm 2.0.44

From: Andrew Veliath <[email-masked]>
Date: Wed, 15 Jan 1997 22:04:41 -0500

Hi Chuck and workers,

Great work!  It is running fine here.

Here are two real small changes which were in the patches I sent to
the workers list that got overlooked.  The first one is evident when
you shade a window (the second one is a non-problem in typical usage).

I am happy to discover that you were able to integrate all of the
workers-list patches as nicely as you did.

Again, great work!!

diff -ur orig/fvwm-2.0.44/fvwm/borders.c fvwm-2.0.44/fvwm/borders.c
--- orig/fvwm-2.0.44/fvwm/borders.c	Tue Jan 14 09:45:14 1997
+++ fvwm-2.0.44/fvwm/borders.c	Wed Jan 15 21:45:35 1997
@@ -1485,7 +1485,10 @@
         else
           xwc.y = 0;
 
-        XConfigureWindow(dpy, tmp_win->corners[i], xwcm, &xwc);
+#ifdef WINDOWSHADE
+	if (!shaded||(i==0)||(i==1))
+#endif
+	    XConfigureWindow(dpy, tmp_win->corners[i], xwcm, &xwc);
       }
 
     }
diff -ur orig/fvwm-2.0.44/fvwm/colors.c fvwm-2.0.44/fvwm/colors.c
--- orig/fvwm-2.0.44/fvwm/colors.c	Tue Jan 14 09:06:32 1997
+++ fvwm-2.0.44/fvwm/colors.c	Wed Jan 15 16:07:30 1997
@@ -138,11 +138,8 @@
   Scr.ScratchGC2 = XCreateGC(dpy, Scr.Root, gcm, &gcv);
   Scr.ScratchGC3 = XCreateGC(dpy, Scr.Root, gcm, &gcv);
 
-#ifdef XPM
-#if defined(PIXMAP_BUTTONS) || defined(PIXMAP_TITLEBARS)
-  /* create button transparency GC */
+#if defined(PIXMAP_BUTTONS) || defined(GRADIENT_BUTTONS)
   Scr.TransMaskGC = XCreateGC(dpy, Scr.Root, gcm, &gcv);
-#endif
 #endif
 }
 
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Makoto MATSUSHITA <[email-masked]>
Date: Thu, 16 Jan 1997 21:03:42 +0900

Very great work!

veliaa> Here are two real small changes which were in the patches I sent to
veliaa> the workers list that got overlooked.  The first one is evident when
veliaa> you shade a window (the second one is a non-problem in typical usage).

And the last one. FvwmIconMan uses sysconf().

--- modules/FvwmIconMan/FvwmIconMan.c.dist	Thu Oct 17 03:12:09 1996
+++ modules/FvwmIconMan/FvwmIconMan.c	Thu Jan 16 21:00:32 1997
@@ -6,6 +6,7 @@
 #else
 #include "../../fvwm/module.h"
 #endif
+#include "../../libs/fvwmlib.h"
 
 static int fd_width;
 static FILE *console = NULL;
@@ -211,7 +212,7 @@
   read_in_resources (argv[3]);
   
   assert (globals.managers);
-  fd_width = sysconf(_SC_OPEN_MAX);
+  fd_width = GetFdWidth();
 
   SetMessageMask(Fvwm_fd,M_CONFIGURE_WINDOW | M_RES_CLASS | M_RES_NAME |
                  M_ADD_WINDOW | M_DESTROY_WINDOW | M_ICON_NAME |

-- -
Makoto `MAR_kun' MATSUSHITA

---

From: Makoto MATSUSHITA <[email-masked]>
Date: Thu, 16 Jan 1997 21:20:22 +0900

matusita> And the last one. FvwmIconMan uses sysconf().

And, if you do NOT define 'MINI_ICONS', FvwmAudio plays 'shutdown'
sound when startup (i.e., it's broken). FvwmAudio handles 'MINI_ICONS'
definiton properly, but fvwm does not (check fvwm/module.h for more detail).

I don't know which (FvwmAudio or fvwm) should be fixed, so no patches
are available, sorry. IMHO, FvwmAudio does not handle 'MINI_ICON'
definition is a better solution (FvwmAudio works with whether fvwm
does handle mini_icons or not).

-- -

---

From: Andrew Veliath <[email-masked]>
Date: Thu, 16 Jan 1997 20:31:04 -0500 (EST)

> does handle mini_icons or not).

It's probably best as you say that FvwmAudio remove the ifdef so that it
is always assumed to be there, since fvwm2 definately keeps the message
numbering no matter what is defined.

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08