Subject: fvwm 2.0.45 ready (long)

From: "Charles Hines" <[email-masked]>
Date: Wed, 22 Jan 1997 14:30:48 -0500

Howdy again all.

Ok, since there were some nasty bugs in 2.0.44, version 2.0.45 is now
ready to replace it, found in the usual spot:

               ftp://ftp.hpc.uh.edu/pub/fvwm/version-2/

It is essentially just a quick bugfix version.  The rather small
ChangeLog entry:

2.0.45
       1. Patches to WindowShade stuff, from Andrew Veliath
       2. Man page corrections & updates
       3. UseStyle fixes from Andrew
       4. CleverPlacement and RandomPlacement fixes from Anthony Martin
       5. Added (De)WindowShade module msgs
       6. FvwmAudio fix (for MINI_ICON & (DE)WINDOWSHADE)
       7. FvwmAuto fixes from Albrecht
       8. DestroyDecor window shrinkage fix, from Andrew
       9. Fix to Wait command lockup (from Makoto Matushita)
       10. Fix to undocumented LEFT_MENUS stuff (from Dan Espen)
       11. Updated FvwmIconMan to Brady's latest, and made it use
           GetFdWidth instead of sysconf for portability (patch from
           Makoto Matushita)
       12. Patch to make CLICKTORAISE define be GlobalOpts
           MouseFocusClickRaises option, from Randal Winchester
       13. Fixes for problems w/ B&W visuals with new
           EXTENED_TITLESTYLE stuff, patch from Andrew
       14. WindowsDesk patch from Pekka Marjola to be able to move
           relative to current desk (now matches Desk builtin, plus
           handles old behavior)
       15. Added decor_examples in sample.fvwmrc dir, which contains a
           few examples of the new Decor/BorderStyle/TitleStyle stuff
           (from lar3ry gensch, Martin Cartwright, Paul Smith)

I would like some more stuff for the decor_examples as well, as people
come up with more.

Chuck

ps - here's gzipped uuencoded patch to go from 2.0.44 to 2.0.45, if
you don't want to download it all.  I won't always do this, but this
one is pretty small, and it might relieve some of the burden on
ftp.hpc.uh.edu.

--------------->8 '44-to-55.patch.gz.uue' cut here 8<---------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randall S. Winchester" <[email-masked]>
Date: Wed, 22 Jan 1997 17:59:15 -0500 (EST)

I have to apologize for not catching this. I neglected to send in a patch to
add_window.c for:
       12. Patch to make CLICKTORAISE define be GlobalOpts
           MouseFocusClickRaises option, from Randal Winchester

****Also the credit for this should not go to me. It should be given to;
Markus Gutschke <[email-masked]>

I just tried to make it easier for Chuck to put in the release...

Randall

diff -u -r1.2 add_window.c
--- 1.2 1997/01/22 22:31:52
+++ add_window.c        1997/01/22 22:34:34
@@ -622,10 +622,8 @@
                        &a,&b,&JunkChild);
   tmp_win->xdiff -= a;
   tmp_win->ydiff -= b;
-#ifndef CLICKTORAISE
-  if(tmp_win->flags & ClickToFocus)
+  if((tmp_win->flags & ClickToFocus) || Scr.MouseFocusClickRaises)
     {
-#endif
      /* need to grab all buttons for window that we are about to
        * unhighlight */
       for(i=0;i<3;i++)
@@ -638,9 +636,7 @@
                        ButtonPressMask, GrabModeSync,GrabModeAsync,None,
                        Scr.FvwmCursors[SYS]);
          }
-#ifndef CLICKTORAISE
     }
-#endif
   BroadcastConfig(M_ADD_WINDOW,tmp_win);
 
   BroadcastName(M_WINDOW_NAME,tmp_win->w,tmp_win->frame,