Subject: is this reasonable?

From: Andrew Veliath <[email-masked]>
Date: Thu, 16 Jan 1997 15:38:08 -0500 (EST)

Is this reasonable?  I'm not sure if it's intentional, but it seems
suspicious to me.

--- orig/fvwm-2.0.44/fvwm/style.c	Tue Jan 14 09:06:35 1997
+++ fvwm-2.0.44/fvwm/style.c	Thu Jan 16 14:38:49 1997
@@ -749,7 +749,7 @@
   name_list *nptr,*lastptr = NULL;
 
   if((name == NULL)||((off_flags == 0)&&(on_flags == 0)&&(on_buttons == 0)&&
- 		      (off_buttons == 0)&(IconBox[0] < 0)
+ 		      (off_buttons == 0)&&(IconBox[0] < 0)
 #ifdef MINI_ICONS
 		      &&(miniicon_name == NULL)
 #endif

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Fri, 17 Jan 1997 09:25:38 -0500

>>>>> "AV" == Andrew Veliath <[email-masked]> writes:

AV> Is this reasonable?  I'm not sure if it's intentional, but it seems
AV> suspicious to me.

AV> --- orig/fvwm-2.0.44/fvwm/style.c   Tue Jan 14 09:06:35 1997
AV> +++ fvwm-2.0.44/fvwm/style.c        Thu Jan 16 14:38:49 1997
AV> @@ -749,7 +749,7 @@
AV>    name_list *nptr,*lastptr = NULL;

AV>    if((name == NULL)||((off_flags == 0)&&(on_flags == 0)&&(on_buttons == 0)&&
AV> -                 (off_buttons == 0)&(IconBox[0] < 0)
AV> +                 (off_buttons == 0)&&(IconBox[0] < 0)
AV>  #ifdef MINI_ICONS
AV>                   &&(miniicon_name == NULL)
AV>  #endif

Hm...yeah, that does kinda look like a bug...