Subject: Server Bell / Bell Module Message Patch

From: Andrew Veliath <[email-masked]>
Date: Fri, 17 Jan 1997 16:07:52 -0500 (EST)

I wrote this patch after someone suggested it in an email today.  After he
mentioned it, it did seem to be a missing thing.

Here is a simple patch which does a few replacements of XBell with MyBell,
adds a MyBell function to fvwm.c (and proto in misc.h), and puts a
ServerBellIsOn global option in ScreenInfo which can be changed with
GlobalOpts. 

The main meat is that you can turn the server bell off (optionally) and
have FvwmAudio play an error bell.

It is pretty straightforward, and I hope Chuck might consider it for
inclusion.  Albrecht would be required to modify FvwmAudio slightly to add
the "bell" message if this gets included. 

It is in the following directory (bellmsg):

http://www.rpi.edu/~veliaa/projects/fvwm_patches/dist/

(the diff is unified and off of andrew4 diff... the only place where I
suspect may be trouble in patching is module.h)

Regards,
Andrew

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 17 Jan 97 23:04:35 +0100

>>>>> Andrew Veliath writes:

A> I wrote this patch after someone suggested it in an email today.  After he
A> mentioned it, it did seem to be a missing thing.

A> Here is a simple patch which does a few replacements of XBell with MyBell,
A> adds a MyBell function to fvwm.c (and proto in misc.h), and puts a
A> ServerBellIsOn global option in ScreenInfo which can be changed with
A> GlobalOpts. 

A> The main meat is that you can turn the server bell off (optionally) and
A> have FvwmAudio play an error bell.

A> It is pretty straightforward, and I hope Chuck might consider it for
A> inclusion.  Albrecht would be required to modify FvwmAudio slightly to add
A> the "bell" message if this gets included. 

done:

	"default_icon",
	"string",
#ifdef M_BELL
	"beep",		/* BEEP function or internal error */
#endif
        "mini_icon",
#ifdef WINDOWSHADE
	"windowshade",
	"dewindowshade",
#endif
/* add builtins here */
	"startup",
	"shutdown",
	"unknown"
};

I called the event 'BEEP' to go with the 'BEEP' fvwm internal function.

the dependence of M_BELL (module.h #define) is necessary for everybody who
hasn't yet applied all patches in the correct order.
(if the patches keep appearing every odd hour, we'll need a 2.0.45 before
next friday to sync up again.)

The two #ifdefs will probably disappear for 2.1.0.

cheers,
albrecht
-- 
One of the first radio news messages, after austria joined the EC was
that the EC was struggling for a common condom length:
The English voted for 18, the German for 20 and the French for 22cm
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].