Subject: Re: FVWM: (long) startup timing bug patch to test

From: "Charles Hines" <[email-masked]>
Date: Mon, 5 Aug 1996 09:24:51 -0400

>>>>> "Manoj" == Manoj Kasichainula <[email-masked]> writes:

....
Manoj> Now, I've applied this patch, but I'm still getting the same timing
Manoj> problem with a window not getting Style flags. :(

I know it's been a few weeks, but getting back to this problem - I
think I missed one little thing that could cause the timing bug if
you're starting w/ FvwmM4 or FvwmCpp, which I don't know since I
couldn't access the URL which you specified as containing your
..fvwm2rc file.

I've really got to walk through all the code and verify all of the
server grabs and ungrabs too, but I think this is the last big
problem...  Whoops!  Spoke too soon - just found one more potential
problem.

Ok, please try applying this patch on top of the one I already sent:

----------------------------------------------------------------------
--- fvwm.c-patch1      Mon Aug  5 09:02:23 1996
+++ fvwm.c    Mon Aug  5 08:58:53 1996
@@ -492,10 +492,15 @@
   unsigned int nchildren;
   Window root, parent, *children;

+  MyXGrabServer(dpy);
+
   PPosOverride = TRUE;

   if(!XQueryTree(dpy, Scr.Root, &root, &parent, &children, &nchildren))
+  {
+    MyXUngrabServer(dpy);
     return;
+  }

   /*
    * weed out icon windows
@@ -546,7 +551,7 @@
   PPosOverride = FALSE;
   Scr.flags |= WindowsCaptured;
   KeepOnTop();
-
+  MyXUngrabServer(dpy);
 }

 /*
--- builtins.c-patch1  Mon Aug  5 09:02:21 1996
+++ builtins.c        Mon Aug  5 09:00:34 1996
@@ -987,6 +987,15 @@
   Done(0,NULL);
 }

+void echo_func(XEvent *eventp,Window w,FvwmWindow *tmp_win,
+               unsigned long context, char *action,int *Module)
+{
+  if (action && *action)
+  {
+    fvwm_msg(INFO,"Echo",action);
+  }
+}
+
 void raiselower_func(XEvent *eventp,Window w,FvwmWindow *tmp_win,
                     unsigned long context, char *action,int *Module)
 {
@@ -2024,14 +2033,19 @@
   unsigned long nitems, bytes_remain;
   Window root, parent, *children;

+  MyXGrabServer(dpy);
+
   if(!XQueryTree(dpy, Scr.Root, &root, &parent, &children, &nchildren))
+  {
+    MyXUngrabServer(dpy);
     return;
+  }

   BlackoutScreen();

   PPosOverride = True;
+
   /* put a border back around all windows */
-  MyXGrabServer(dpy);
   tmp = Scr.FvwmRoot.next;
   for(i=0;i<nchildren;i++)
   {
@@ -2074,5 +2088,4 @@
   KeepOnTop();
   MyXUngrabServer(dpy);
   XSync(dpy,0);
-
 }
----------------------------------------------------------------------

Let me know if this helps.  If it does then I may be able to move
around some of the other grabs that I put in.

Thanks,
Chuck

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Manoj Kasichainula <[email-masked]>
Date: Mon, 5 Aug 1996 14:29:49 -0400 (EDT)

> couldn't access the URL which you specified as containing your

Hmmm. My web server was down for about a day a couple of weeks ago, and
the fvwm2rc file was missing for a few days after that, but it is there
now. Just in case I put the URL down incorrectly, here it is again

http://dosa.ini.cmu.edu/~manojk/fvwm2rc

I just verified this in Lynx, so you should be able to access it. I am
using FvwmCpp. 

> problem...  Whoops!  Spoke too soon - just found one more potential

No luck... Still getting the same Style problems as before with the
starting rxvt. :(

If I get a chance, I will try to reformat the fvwm2rc so it doesn't need
FvwmCpp, and report on what happens.

_________________________________________________________________________
Manoj Kasichainula - [email-masked] | "Violence is the first refuge
http://dosa.ini.cmu.edu/~manojk/           |  of the violent."
Finger for PGP public key & Geek Code      |     - Aaron Allston