Subject: problem when complied in SunOS and Open Win

From: [email-masked] (Tuan Le)
Date: Fri, 26 Jul 1996 08:54:12 -0400

Hi every one

	I try to complied fvwm 2.043 in SunOS I can make the make file
	but when I try to run make Makefiles, it gave me and error
	even when I try to run a simple test like make clean
	I this get an error
	This is the state past by imake
	imake -I/usr/lib/X11/config
	and here is the error

[tif531]%@>make clean
rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log 
MakeOut "#"*
cleaning in ./libs...
make: Fatal error: Don't know how to make target `clean'
Current working directory /tmp_mnt/home/tif252/tle/temp/fvwm-2.0.43/libs
*** Error code 1
make: Fatal error: Command failed for target `clean'

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Fri, 26 Jul 1996 09:47:24 -0400

>>>>> "Tuan" == Tuan Le <[email-masked]> writes:

Tuan> Hi every one
Tuan>   I try to complied fvwm 2.043 in SunOS I can make the make file
Tuan>   but when I try to run make Makefiles, it gave me and error
Tuan>   even when I try to run a simple test like make clean
Tuan>   I this get an error
Tuan>   This is the state past by imake
Tuan>   imake -I/usr/lib/X11/config
Tuan>   and here is the error

Tuan> [tif531]%@>make clean
Tuan> rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log
Tuan> MakeOut "#"*
Tuan> cleaning in ./libs...
Tuan> make: Fatal error: Don't know how to make target `clean'
Tuan> Current working directory /tmp_mnt/home/tif252/tle/temp/fvwm-2.0.43/libs
Tuan> *** Error code 1
Tuan> make: Fatal error: Command failed for target `clean'

Hm.  Someone else reported to me that they were having similiar
troubles with 'make Makefiles'.  I normally just run the MakeMakefiles
shell script myself, but I just tried 'make Makefiles' and it worked
fine for me, and so did 'make' and 'make clean' in libs...

Perhaps something in your Imake setup is messed up.  Is 'make
Makefiles' producing correct makefiles for everyone else?

Chuck

---

From: "Randall S. Winchester" <[email-masked]>
Date: Fri, 26 Jul 1996 13:40:50 -0400 (EDT)

I just ran the following on SunOS 4.1.4 and X11R6 with no problems.
xmkmf
make Makefiles
make clean
make
make install
make clean

I did not have any problems.

Randall

On Fri, 26 Jul 1996, Charles Hines wrote:

: >>>>> "Tuan" == Tuan Le <[email-masked]> writes:
: 
: Tuan> Hi every one
: Tuan>   I try to complied fvwm 2.043 in SunOS I can make the make file
: Tuan>   but when I try to run make Makefiles, it gave me and error
: Tuan>   even when I try to run a simple test like make clean
: Tuan>   I this get an error
: Tuan>   This is the state past by imake
: Tuan>   imake -I/usr/lib/X11/config
: Tuan>   and here is the error
: 
: Tuan> [tif531]%@>make clean
: Tuan> rm -f *.CKP *.ln *.BAK *.bak *.o core errs ,* *~ *.a .emacs_* tags TAGS make.log
: Tuan> MakeOut "#"*
: Tuan> cleaning in ./libs...
: Tuan> make: Fatal error: Don't know how to make target `clean'
: Tuan> Current working directory /tmp_mnt/home/tif252/tle/temp/fvwm-2.0.43/libs
: Tuan> *** Error code 1
: Tuan> make: Fatal error: Command failed for target `clean'
: 
: Hm.  Someone else reported to me that they were having similiar
: troubles with 'make Makefiles'.  I normally just run the MakeMakefiles
: shell script myself, but I just tried 'make Makefiles' and it worked
: fine for me, and so did 'make' and 'make clean' in libs...
: 
: Perhaps something in your Imake setup is messed up.  Is 'make
: Makefiles' producing correct makefiles for everyone else?
: 
: Chuck
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
: body of a message to [email-masked].
: To report problems, send mail to [email-masked].
:

---

From: Andrew Veliath <[email-masked]>
Date: Fri, 26 Jul 1996 13:56:26 -0400

Tuan> Hi every one I try to complied fvwm 2.043 in SunOS I can
    Tuan> make the make file but when I try to run make Makefiles, it
    Tuan> gave me and error even when I try to run a simple test like
    Tuan> make clean I this get an error This is the state past by
    Tuan> imake imake -I/usr/lib/X11/config and here is the error
...
    Charles> Perhaps something in your Imake setup is messed up.  Is
    Charles> 'make Makefiles' producing correct makefiles for everyone
    Charles> else?

I think at some point, I forget which, make Makefiles ceased to work
on my machine and on the school machines :(.  I'll see what I can
look into why it happens / what the chnage was here...

Andrew