Subject: Re: Ok, it's time (was Re: Just a heads up)

From: Dan Espen <[email-masked]>
Date: Fri, 21 Jun 1996 11:47:25 -0400

<[email-masked]> writes:
> Glad to hear it, because now I am too.
> 
> I just copied the tar file to ftp.hpc.uh.edu in
> /pub/fvwm/version-2/.test/ and it looks like so:
> 
> -rw-rw-r--   1 chines   users     542234 Jun 20 17:06 fvwm-2.0.43-almost.tar.
> gz
> 
> And here is the rather substantial ChangeLog entry:

My testing is Solaris 2.5, on a Sparc.

> ======================================================================
> 2.0.43 (not done yet)
>        1. More man page updates & Imake fixes

If you  install the  man pages in  a place  that  has a  "windex", the
install process does not create a new windex.

When you do create the windex (with catman -w), the windex entry looks
like:

fvwm		fvwm (1)	- F(?) Virtual Window Manager for X11

Because it says "fvwm", instead of fvwm2, "man fvwm2" does not work.

The fix is:

*** /opt/public/man/man1/fvwm2.1	Fri Jun 21 11:38:57 1996
--- fvwm2.man	Wed Jun 19 22:55:43 1996
***************
*** 17,25 ****
  .TH FVWM 2.xx "late 20th century"
  .UC
  .SH NAME
! fvwm2 \- F(?) Virtual Window Manager for X11
  .SH SYNOPSIS
! \fBfvwm2\fP [ \fIoptions\fP ]
  .SH DESCRIPTION
  \fIFvwm\fP is a window manager for X11.  It is a derivative of
  \fItwm\fP, redesigned to minimize memory consumption, provide a 3-D
--- 17,25 ----
  .TH FVWM 2.xx "late 20th century"
  .UC
  .SH NAME
! fvwm \- F(?) Virtual Window Manager for X11
  .SH SYNOPSIS
! \fBfvwm\fP [ \fIoptions\fP ]
  .SH DESCRIPTION
  \fIFvwm\fP is a window manager for X11.  It is a derivative of
  \fItwm\fP, redesigned to minimize memory consumption, provide a 3-D

(I previously submitted  diffs  where  every  reference  to fvwm   was
changed to fvwm2.  I still think that is a good idea.)

>        27. Added ability to remove mouse and key bindings without
>            restart (do the binding but specify '-' as the function).
>            Probably needs more checking for removing mouse bindings
>            from title bar buttons correctly, though.

I don't   know if this   change is  responsible, but   a number of  my
keybindings stopped working.  Eg:

Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

They still  work when  the mouse pointer  is on  the root, but  if the
mouse  pointer   is in a window,   the  keystroke gets  passed  to the
application.  (Which is not what I want.)

> still working on:
> 
>        -  FvwmDebug was missing some stuff

FvwmDebug was not  in the package.  As  long as that was  intentional,
OK.

> Chuck
--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 21 Jun 1996 14:13:19 -0500

>>>>> "DE" == Dan Espen <[email-masked]> writes:

DE> If you install the man pages in a place that has a "windex", the
DE> install process does not create a new windex.

I have never seen a package that does this.  I would certainly hope that I
never do, as having replaced Sun's screwy man with a nice perl replacement
I don't see how it would know how to build the index files.

DE> When you do create the windex (with catman -w), the windex entry looks
DE> like:

DE> fvwm fvwm (1) - F(?) Virtual Window Manager for X11

DE> Because it says "fvwm", instead of fvwm2, "man fvwm2" does not work.

Sun's man again.  man -F would probably find it, but you're right; the NAME
section should match the filename.  catman complains about the mismatch.

 - J<

---

From: Todd Tyrone Fries <[email-masked]>
Date: Fri, 21 Jun 1996 16:28:03 -0500 (CDT)

> changed to fvwm2.  I still think that is a good idea.)

I guess here is where we must decide.  Is 'fvwm2' forever to be the
binary used with fvwm?  Or is it a temporary measure to wean people away
from fvwm 1.xx ??

I guess when there is autoconf we can say '--name=fvwm' or '--name\fvwm2'
or something similar and it can automatically update the man pages.  Ifnot,
it can be in the Makefiles to sed the man pages or something.  Or we
can do something like that now.

I guess it wouldn't hurt me very much, as I don't use windex's, but just
thought I'd bring this up.

--
Todd Fries .. [email-masked]

---

From: "Randall S. Winchester" <[email-masked]>
Date: Sun, 23 Jun 1996 01:51:49 -0400 (EDT)

I have succesfully (With the following patches) compiled fvwm-2.0.43-almost
on the following platforms and X11R6.

Ultrix 4.4	cc
DU 3.2c		cc
HPUX 9.05	cc
IRIX 5.3	cc
SunOS 4.1.4	gcc
Solaris 2.5	gcc

And on the following with the vendors supplied X distribution.

DU 3.2c         cc
IRIX 5.3        cc
Solaris 2.5     gcc

I could not build it on the following with the vendors X distribution.

Ultrix 4.4	Could not find xmkmf.
HPUX 9.05	Could not find xmkmf.
SunOS 4.1.4	too man include files missing from /usr/openwin/include.
(maybe others who know these systems default X more then I can have some 
success, but I have never used these vendors X to build anything....)

Regaurding the patches:
The last couple in the modules were just to stop some compiler warnings. 
However the "colors" change in FvwmForm.c was needed on DU 3.2c.

Randall

*** 1.1	1996/06/21 03:39:44
--- configure.h	1996/06/21 03:40:34
***************
*** 21,27 ****
   *
   **************************************************************************/
  
! #if defined _POSIX_SOURCE || defined SYSV || defined __sun__
  
  #define HAVE_WAITPID  1
  #define HAVE_SYSCONF 1
--- 21,27 ----
   *
   **************************************************************************/
  
! #if defined _POSIX_SOURCE || defined SYSV || defined __sun__ || defined sgi
  
  #define HAVE_WAITPID  1
  #define HAVE_SYSCONF 1
*** 1.1	1996/06/21 03:50:03
--- fvwm/builtins.c	1996/06/21 03:50:29
***************
*** 717,723 ****
    extern char *sys_errlist[];
  
    if (num >= 0 && num < sys_nerr)
!     return(sys_errlist[errnum]);
    else
      return "Unknown error number";
  }
--- 717,723 ----
    extern char *sys_errlist[];
  
    if (num >= 0 && num < sys_nerr)
!     return(sys_errlist[num]);
    else
      return "Unknown error number";
  }
*** 1.1	1996/06/21 04:05:24
--- modules/FvwmForm/FvwmForm.c	1996/06/21 04:22:05
***************
*** 158,164 ****
  char *color_names[4] = {
    "Light Gray", "Black", "Gray50", "Wheat"
  };
! long colors[6];
  
  enum { f_text, f_input, f_button };
  char *font_names[3] = {
--- 158,164 ----
  char *color_names[4] = {
    "Light Gray", "Black", "Gray50", "Wheat"
  };
! unsigned long colors[6];
  
  enum { f_text, f_input, f_button };
  char *font_names[3] = {
***************
*** 168,173 ****
--- 168,174 ----
  };
  Font fonts[3];
  XFontStruct *xfs[3];
+ XFontStruct *GetFontOrFixed();
  
  Cursor xc_ibeam, xc_hand;
  
*** 1.1	1996/06/23 03:15:53
--- modules/FvwmTalk/FvwmTalk.c	1996/06/23 03:16:01
***************
*** 434,440 ****
  {
    Atom actual_type;
    int actual_format,i;
!   long nitems, bytes_after, nread;
    unsigned char *data, *data2;
  
    if (property == None)
--- 434,440 ----
  {
    Atom actual_type;
    int actual_format,i;
!   unsigned long nitems, bytes_after, nread;
    unsigned char *data, *data2;
  
    if (property == None)
*** 1.1	1996/06/23 03:24:00
--- modules/FvwmButtons/FvwmButtons.c	1996/06/23 03:25:06
***************
*** 1503,1509 ****
    Window root;
    Window rp=None;
    Window *children;
!   int n;
  
    if(!XGetGeometry(dpy,win,&root,x,y,w,h,bw,d))
      return None;
--- 1503,1509 ----
    Window root;
    Window rp=None;
    Window *children;
!   unsigned int n;
  
    if(!XGetGeometry(dpy,win,&root,x,y,w,h,bw,d))
      return None;
*** 1.1	1996/06/23 03:25:26
--- modules/FvwmButtons/parse.c	1996/06/23 03:38:21
***************
*** 703,709 ****
      case 0:/* Geometry */
        {
  	char geom[64];
! 	int flags,g_x,g_y,width,height;
  	i=sscanf(s,"%63s",geom);
  	if(i==1)
  	  {
--- 703,710 ----
      case 0:/* Geometry */
        {
  	char geom[64];
! 	int flags,g_x,g_y;
! 	unsigned int width,height;
  	i=sscanf(s,"%63s",geom);
  	if(i==1)
  	  {
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].