Subject: X11R4 install process

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 21 Jun 96 16:01:41 +0200

well our site is still missing the 
InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
macro :-(

our sysadmin says it's named InstallNonExec() under X11R4 (installed on the
suns here)

so either change sample.fvwmrc/Imakefile
	#if InstallSample
	-InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
	+InstallNonExec(system.fvwmrc,$(FVWMDIR))
	#endif

or use InstallNamedNonExec()  - defined in Fvwm.tmpl if it doesn't exist -
in sample.fvwm/Imakefile 

also the Bug I reported already twice, but nobody ever answered :-(

MANPATH is settable in Fvwm.tmpl (~ Line 278) but in Line 414 
	InstallManPage(program,$(MANDIR))
is used to install the pages.

in the generated Makefile, I find:
       DESTDIR = /XTech
	MANDIR = $(DESTDIR)/man/mann
which tries to install them globally (which is not permitted to me!)

so I see three possibilities:

1.) maybe our (X11R4) setup is ruined, if so the tell me what is wrong, please.
    Should I mail the generated Makefile here?

2.) Fvwm.tmpl messes up MANDIR & MANPATH
   (it seems to me that FvwmManPath should be FvwmManDir, and
    MANPATH should be MANDIR throughoutall of Fvwm.tmpl)

3.) MANDIR should also be configurable in Fvwm.tmpl,
   for those who want to install Fvwm binary & documentation in ~/anyname/

I think it's 2) at least all things went smooth when I did this.

cheers,
albrecht
-- 
Clothes of brass and hair of brown.
Seldom needs to breathe,
Don't need no wings to fly.
And a heart of stone
And a fear of fire and water.
Who am I?		-- Lurker, Genesis
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Todd Tyrone Fries <[email-masked]>
Date: Fri, 21 Jun 1996 13:20:46 -0500 (CDT)

>      +InstallNonExec(system.fvwmrc,$(FVWMDIR))

How about:

#ifndef InstallNonExecFile()
#define InstallNonExecFile(x,y) InstallNonExec(x,y)
endif

Will some flavor of that work?
--
> 1.) maybe our (X11R4) setup is ruined, if so the tell me what is wrong,
> please.     Should I mail the generated Makefile here?
> 

Todd Fries .. [email-masked]

---

From: [email-masked] (Albrecht Kadlec)
Date: Mon, 24 Jun 96 13:51:07 +0200

>>>>> Todd Tyrone Fries writes:

> or use InstallNamedNonExec()  - defined in Fvwm.tmpl if it doesn't exist -

T> How about:

T> #ifndef InstallNonExecFile()
T> #define InstallNonExecFile(x,y) InstallNonExec(x,y)
T> endif

T> Will some flavor of that work?

Yes.

> I think it's 2) at least all things went smooth when I did this.

I've been doing this, since I found fvwm2.0.39, but nobody answered my
repeated inquiries on the list.

albrecht
-- 
Hi!  Darren's answering machine is broken.  This is his refrigerator.
Please speak very slowly, and I'll stick your message to myself with
one of these magnets.
				-- answering machine message
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].