Subject: Re: Notification: incoming/1578

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 1 Feb 2005 23:55:49 +0000

On 29 Jan 2005 16:30:33 -0600, [email-masked] wrote:
> 
> Message summary for PR#1578
> 
> From: [email-masked]
> Subject: fvwm segfault upon startup after keypress
> Full_Name: Will Jhun
> OS: debian unstable
> 
> 
> Upon performing an 'apt-get dist-upgrade', I picked up fvwm 2.5.12-4. The
> following happens upon starting fvwm:
> 
> - Mouse cursor changes to watch icon
> - No response to mouse clicks
> - fvwm crashes and dumps core upon any keypress
> 
> Downgrading to 2.5.8-2 (.deb package linked from fvwm.org) seems to
> temporarily remedy the problem.
> 
> Since the machine went through a major upgrade, it is possible the problem
> exists in another component.

We need someone with Debian (preferable stock) to run "make deb-inplace"
inside the unpacked fvwm-2.5.12 directory, and submit us the deb file.

Maybe you may even do this yourself (either create deb file this way or
otherwise compile from the sources). As you descibe it, this is a system
dependent problem.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Alex Wallis <[email-masked]>
Date: Wed, 2 Feb 2005 21:23:32 +1030

On Tue, 1 Feb 2005 23:55:49 +0000

> inside the unpacked fvwm-2.5.12 directory, and submit us the deb file.

I run stock debian sarge on my latop producing the following results from ./configure in the unpacked fvwm-2.5.12 directory....

FVWM Configuration:

  Version:     2.5.12

  Executables: /usr/local/bin
  Man pages:   /usr/local/man
  Modules:     /usr/local/libexec/fvwm/2.5.12
  Data files:  /usr/local/share/fvwm
  Perl lib:    /usr/local/share/fvwm/perllib
  Locale msg:  /usr/local/share/locale  ar de fr sv_SE zh_CN

  With Asian bi-direct. text support? yes
  With Gettext Native Lang support?   yes (libc)
  With GTK+ required for FvwmGtk?     yes
  With GDK image support in FvwmGtk?  yes
  With GNOME libs support in FvwmGtk? yes
  With Iconv support?                 yes (from C library)
  With Mouse strokes (gestures)?      yes
  With PNG image support?             yes
  With ReadLine sup. in FvwmConsole?  yes
  With RPlay support in FvwmEvent?    yes
  With Shaped window support?         yes
  With Shared memory for XImage?      yes
  With Session Management support?    yes
  With Xinerama multi-head support?   yes
  With Xft anti-alias font support?   yes (version 2)
  With XPM image support?             yes
  With Xrender image support?         yes

The results of make deb-inplace including the resulting config.log can be found at....

http://wombat.awol.net.au/awol/debian/

HTH

Alex

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 2 Feb 2005 16:47:12 +0000

On 02 Feb 2005 21:23:32 +1030, Alex Wallis wrote:
> 
> On Tue, 1 Feb 2005 23:55:49 Mikhael Goikhman <[email-masked]> wrote:
> 
> I run stock debian sarge on my latop producing the following results

> http://wombat.awol.net.au/awol/debian/

By stock I meant at least several years ago (to be usable for more
users). Also, I am not sure that depending on gnome and rplay is good.
Anyway, if you rerun "make deb-dist release=1" that disables some
dependencies, then I will put a link to the resulting packages. Thanks.

To Will Jhun: do you still experience the crash with the packages above,
and no with the 2.5.8 packages created by the same procedure? If yes,
then the only way to try to find the problem is to build from the
sources, use the minimal fvwm config (or no config), get the dumped core
file, run "gdb fvwm core" and then send the output of "where" command.

Regards,
Mikhael.

---

From: Alex Wallis <[email-masked]>
Date: Thu, 3 Feb 2005 12:29:39 +1030

On Wed, 2 Feb 2005 16:47:12 +0000

> dependencies, then I will put a link to the resulting packages. Thanks.

Done. Same url as above.

Alex