Subject: Re: FVWM: FvwmButtons and fullscreenmodes in recent fvwm broken?

From: Olivier Chapuis <[email-masked]>
Date: Sun, 16 Jan 2005 07:16:47 +0100

On Fri, Jan 14, 2005 at 06:02:08PM +0100, Trilobit wrote:
> Hi,
> 
> I recently updated my Debian Linux Box.
> And so I got version 2.5.12 of fvwm installed.
> After starting X11 with the new fvwm and my old working configuration
> for 2.5.x FvwmButtons hangs using 99percent of CPU time.
> And, after moving a window (in not opaque style), seems to freeze fvwm
> for some seconds. And so, giving after the freeze following error message
>  (the only on in the whole .xsession-errors file):
> ----------------------------
> FVWM][FlushMessageQueue]: <<ERROR>> Failed to write descriptor to 'FvwmButtons':
> - select rc=0
> - terminate signal=N
> ---------------------------
> So I installed, just for testing, version 2.5.8 from www.fvwm.org, the problem
> had gone.
> 

Here I switch to the workers list ([email-masked]).

Can you post your FvwmButtons config (with the related functions/styles
...etc config).

Regards, Olivier

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Trilobit <[email-masked]>
Date: Mon, 17 Jan 2005 11:48:58 +0100

> Can you post your FvwmButtons config (with the related functions/styles

Gladly. My configuration for FvwmButtons (related) is actually quite simple. 
No functions related to FvwmButtons. :-)

################# begin of config #############
#default styles & behavior, you might want to know these:
Style * MinOverlapPercentPlacement
Style * MinOverlapPlacementPenalties 1 150 0 50 0 70
Style * MinOverlapPercentPlacementPenalties 50 6 1 1
Style * ClickToFocus, ClickToFocusPassesClick, ClickToFocusRaisesOff
Style * GrabFocus, GrabFocusTransient
Style * NoUSPosition, NoPPosition
Style * BorderWidth 2, HandleWidth 2
Style * Title, Handles, DecorateTransient
Style * RaiseTransient, LowerTransient
Style * Color Black/gray
Style * HilightFore White
Style * HilightBack RoyalBlue3
Style * NoIcon,EWMHMiniIconOverride,EWMHDontDonateIcon,\
EWMHDontDonateMiniIcon
Style * EWMHUseStackingOrderHints

#FvwmButton Styles:
Style "FvwmButtons" UseUSPosition,UsePPosition,NoHandles,\
NoTitle,Sticky,WindowListSkip,CirculateSkip,BorderWidth 0,NeverFocus,\
FixedPosition,StaysOnTop

#erstellt von Trilobit
*FvwmButtons: Font		none
*FvwmButtons: Fore		White
*FvwmButtons: Back		RoyalBlue
*FvwmButtons: Geometry	+0+0
*FvwmButtons: ButtonGeometry	62x62
*FvwmButtons: Frame		0
*FvwmButtons: Padding	0 0
*FvwmButtons: Pixmap	none
*FvwmButtons: BoxSize	smart

# Layout: specify rows or columns, not both
*FvwmButtons: Columns		1

###### this are usefull tools in the button bar
#cut down to fit fit mailing list style, looks bit mixed up now :-)

*FvwmButtons: (Swallow(UseOld,Nokill) "FvwmPager" \
"Module FvwmPager *")

*FvwmButtons: (Swallow(UseOld,Nokill) "wmCalClock" \
'Exec wmCalClock -l -24 -tc lightgreen -b 30 -e "sylpheed"')

*FvwmButtons: (Swallow(UseOld,Nokill) "asmon" \
'Exec asmon -u -e "qps"')

*FvwmButtons: (Swallow(UseOld,Nokill) "wmnet_ LAN Eth0" \
'Exec wmnet.patched --maxrate=13000000 -W eth0 -L " LAN Eth0" \
-e "xlogmaster -geometry 1080x450 -terse -silent"')

*FvwmButtons: (Swallow(UseOld,Nokill) "wmnet_ WAN Eth1" \
'Exec wmnet.patched --maxrate=1300000 -W eth1 -L " WAN Eth1" \
-e "gentoo"')

*FvwmButtons: (Swallow(UseOld,Nokill) "wmmixer" \
'Exec wmmixer -s -a')

*FvwmButtons: (Swallow(UseOld,Nokill) "wmusic" \
'Exec wmusic -u -t -l -a')

*FvwmButtons: (Swallow(NoClose,UseOld,Nokill) "LicqWharf" \
"Exec licq >/dev/null")

*FvwmButtons: (Swallow(UseOld,Nokill) "wmpinboard" \
'Exec wmpinboard')

*FvwmButtons: (Swallow(UseOld,Nokill) "wmcliphist" \
'Exec wmcliphist')

###### container for icons
*FvwmButtons: (1x1, Container(Frame 1, Rows 1)) 
*FvwmButtons: (Title Shell,	Icon kshell.xpm,	Action 'exec rxvt')
*FvwmButtons: (End)

## start functions cut down to FvwmButtons related
AddToFunc InitFunction
+			I Module FvwmButtons
AddToFunc RestartFunction
+			I Module FvwmButtons
################# end of config #############

Regards, Mario