Subject: Notification: incoming/1550

From: [email-masked]
Date: Fri, 7 Jan 2005 11:10:41 -0600 (CST)

FVWM Bug Tracking notification

new message incoming/1550

Message summary for PR#1550
	From: [email-masked]
	Subject: Working Area breaks with GNOME & Xinerama
	Date: Fri, 7 Jan 2005 11:10:09 -0600
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Jan 07 11:10:20 2005
Date: Fri, 7 Jan 2005 11:10:09 -0600
From: [email-masked]
To: [email-masked]
Subject: Working Area breaks with GNOME & Xinerama

Full_Name: Hans Fugal
Version: 2.5.12
CVS_Date: 
OS: Debian Testing
X_Server: XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-8 20040928112350 fabbione@fabbione.
net)
Submission from: (NULL) (204.96.22.194)

I use FVWM as the GNOME window manager. Crazy, I know, but it works great.
When I switched to Xinerama (actually NVIDIA TwinView, but it looks like
Xinerama to X clients) the GNOME panel started getting covered by new
windows. I believe this is because the Working Area is not being adjusted
properly according to the _NET_WM_STRUT hints. 

$ fvwm -V
fvwm 2.5.12 compiled on Nov 20 2004 at 21:30:52
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM, Bidi
text, Xinerama, XRender, XFT, NLS

$ xprop | grep STRUT # top panel
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 0, 0, 0, 0
_NET_WM_STRUT_PARTIAL(CARDINAL) = 0, 0, 34, 0, 0, 0, 0, 0, 1280, 2559, 0,
0
_NET_WM_STRUT(CARDINAL) = 0, 0, 34, 0

$ xprop | grep STRUT # bottom panel
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 0, 0, 0, 0
_NET_WM_STRUT_PARTIAL(CARDINAL) = 0, 0, 0, 34, 0, 0, 0, 0, 0, 0, 1280,
2559
_NET_WM_STRUT(CARDINAL) = 0, 0, 0, 34

Relevant section of /etc/X11/XF86Config-4
Section "Device"
        Identifier      "NVIDIA Quadro4 NVS AGP 8x"
        Driver          "nvidia"
        Option "TwinView"
        Option "MetaModes" "1280x1024,1280x1024"
        Option "TwinViewOrientation" "LeftOf"
EndSection

Again, things worked fine with only one screen. If I use "EwmhBaseStruts 0
0 34 34" behavior is as before but because the panels only span one screen,
I lose 68 pixels of useful mapping space on the left screen.

Screenshot at http://www.xmission.com/~fugalh/fvwm.png

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 7 Jan 2005 22:48:36 +0100

On Fri, Jan 07, 2005 at 11:10:41AM -0600, [email-masked] wrote:
> SNIP 

This is not so crazy, we have work a lot so that can be possible.

> SNIP
> SNIP 

Yes, fvwm does not support _NET_WM_STRUT_PARTIAL. So your report is a valid
bug (or a miss feature). I do not know when we will have the time to fix it.

Thanks, Olivier