Subject: Single click RootMenu, double click WindowList

From: William Paul Vrotney <[email-masked]>
Date: Sun, 12 Dec 2004 21:09:15 -0800

This function works fine if bound to almost anything (like a button):

    Single click RootMenu, double click WindowList
    DestroyFunc RootMenu-or-WindowList
    AddToFunc RootMenu-or-WindowList
    + I Menu Root-Menu mouse -1p -1p
    + D WindowList mouse -1p -1p NoGeometry

If bound to mouse 1 on the root plane

    Mouse 1		R   	N       Menu Root-Menu mouse -1p -1p

it also works fine but, after executing it successfully, fvwm hangs until
the mouse is moved.

Is this a bug? Is there another way of achieving this?  It seems like a bug
because it seems to imply that one can not have a flawless binding to a
single and double click on the root plane.

Bill

-- 
William P. Vrotney - [email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: William Paul Vrotney <[email-masked]>
Date: Fri, 17 Dec 2004 15:10:37 -0800

I discovered a workaround to the below bug that I posted Dec 12.  The only
caveat is that there is a slight delay to the single click.

     # Single click RootMenu, double click WindowList
     DestroyFunc RootMenu-or-WindowList
     AddToFunc RootMenu-or-WindowList
     + C Menu Root-Menu mouse -1p -1p
     + D WindowList mouse -1p -1p NoGeometry

By replacing the "I" immediate action modifier with the "C" click modifier
the bug goes away.  This might also give a clue as to the nature of the bug.

Bill

> Date: 12 Dec 2004 21:18:25 -0800
> From: William Paul Vrotney <[email-masked]>
> 
> 
>     # Single click RootMenu, double click WindowList
> the mouse is clicked.  For example if you launch an application using this
> it will not come up until the mouse is clicked again on the root.
>