Subject: CVS olicha: * Added a set of functions for implementing tool tips

From: FVWM CVS <[email-masked]>
Date: Fri, 3 Dec 2004 02:47:49 -0600

CVSROOT:	/home/cvs/fvwm
Module name:	fvwm
Changes by:	olicha	04/12/03 02:47:49

Modified files:
	.              : ChangeLog NEWS 
	libs           : Makefile.am defaults.h 
	modules        : ChangeLog 
	modules/FvwmIconMan: FvwmIconMan.1.in FvwmIconMan.c 
	                     FvwmIconMan.h fvwm.c globals.c readconfig.c 
	                     x.c xmanager.c xmanager.h 
Added files:
	libs           : FTips.c FTips.h 

Log message:
* Added a set of functions for implementing tool tips
* Implemented tips in IconMan
* New options IconMan MaxButtonWidth and MaxButtonWidthByColumns
* Fixed bug #1480 by updating EWMHUseStackingOrderHints documentation
* One needs_lang_check in fvwm.1.in and one in FvwmIconMan.1.in

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Sun, 05 Dec 2004 19:44:40 -0500

> * One needs_lang_check in fvwm.1.in and one in FvwmIconMan.1.in

fvwm.1.in is not checked in.  Did you really change it?

For FvwmIconMan, I adjusted the first  paragraph, but got stuck on the
second:

.IP "*FvwmIconMan: [id] MaxButtonWidth \fIwidth\fP"
Defines a maximum for the width of a button (in pixels). By default there
is no maximum. A value of 0 resets the default. The maximum is only used
with a non growing manager (the ManagerGeometry option
specifies non zero width and height).

.IP "*FvwmIconMan: [id] MaxButtonWidthByColumns \fIcol\fP"
This is equivalent to MaxButtonWidth ManWidth/col where ManWidth is
the width of the Manager. 

What is "ManWidth"?

Should this be "MaxWidthInColumns", or just "MaxColumns"?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 6 Dec 2004 10:11:07 +0100

> fvwm.1.in is not checked in.  Did you really change it?

Yes, but I probably forget to save the file before the commit
I will commit again soon.

> Should this be "MaxWidthInColumns", or just "MaxColumns"?

ManWidth is the width of the full FvwmIconMan. For example if the
width of the FvwmIconMan manager is 1024, "MaxButtonWidthByColumns 4"
is equivalent to "MaxButtonWidth 256". This is useful when you do not
know, at config time, the width of the manager (e.g., for swallowed
IconMan). In a certain sense you will never have less than 4 columns.
So maybe, MinColumns is good. I used MaxButtonWidthByColumns to say
that the MaxButtonWidth is expressed in terms of columns (or computed
from a number of columns. I like the idea to use something like
MaxButtonWidth_something_good to express the fact that this option
is just an other way to set the MaxButtonWidth option.

I will follow any suggestion.

Thanks Dan, Olivier

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 6 Dec 2004 10:35:49 +0000

> is just an other way to set the MaxButtonWidth option.

I think, "MinColumns" name is more intuitive. You should probably mention
that setting "MinColumns" disables "MaxButtonWidth" (or vice versa), so
it would be clear that they describe more or less the same thing.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Wed, 08 Dec 2004 22:26:27 -0500

> is just an other way to set the MaxButtonWidth option.

I think I have it now.  Please check and see.

In another part of the same man page, I don't follow
part of the TipsJustification description.  The part
between the lang_check markers (which I did modify a little):

.IP "*FvwmIconMan: [id] TipsJustification \fIvalue\fP"
where \fIvalue\fP can be leftup, rightdown or center.
Specifies
the justification (direction) of the tips window relative to its button after
the tips window has been placed.
\."#needs_lang_check
Default is leftup which means that if a tip is placed above or below
(respectively, on the left or on the right of)
its button, 
then the left
(respectively, the top)
border of the tip 
and of the button are aligned.
\."#end_needs_lang_check
The alignment is adjusted by the TipsOffset option.
See next option.

The way you use "respectively" is very hard to read
in english.
Just describe leftup then
start a new sentence and say
rightdown and center work like leftup but in different directions.

I tried to read it ignoring the repectively stuff and
still couldn't follow it.
If you just expand on it or give an example like you
did above that would help.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 11 Dec 2004 14:12:39 +0100

> I think I have it now.  Please check and see.

Yep, Thanks.
 
> did above that would help.

I Followed your suggestion. Can you check?

Thanks, Olivier