Subject: Re: FVWM website error

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 6 Dec 2004 22:53:52 +0000

On 06 Dec 2004 16:54:54 -0500, David Mandelberg wrote:
> 
> There's a major error on fvwm.sourceforge.net:

This is an automatically updated mirror. Please use the original site at
http://fvwm.org/ until this error is fixed. (There is an indication that
this is a mirror at the botton, but it is not shown because of the error.)

> Fatal error: Cannot redeclare my_get_global() in
> /var/local/home/groups/f/fv/fvwm/htdocs/definitions.inc on line 50
> 
> I've grep'ed for other definitions of my_get_global with:
> 
> egrep 'function( |\t)+my_get_global' `find \
> /home/groups/f/fv/fvwm/htdocs/ -iname '*.php' \
> -or -iname '*.inc' -print`
> 
> but it doesn't show any other definitions.

I think Uwe may take a look at this error.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Tue, 7 Dec 2004 08:44:48 +0100

Hi there,

On 06 Dec 2004 at 22:53:52 +0000, Mikhael Goikhman wrote:

> This is an automatically updated mirror. Please use the
> original site at http://fvwm.org/ until this error is
> fixed. (There is an indication that this is a mirror at
> the botton, but it is not shown because of the error.)
> 
> > /var/local/home/groups/f/fv/fvwm/htdocs/definitions.inc
> > /on line 50

Thanks for the hint.

It seems to me that this was caused by different php
versions. On fvwm.sourceforge.net php 4.3.9 is installed
while fvwm.org and my servers use version 4.3.8. Maybe
this broke the construct which avoided double loading of
the definition file.

I use now the new php4 construct include_once in all files
to avoid double loading of the definiton file. This should
work on all php4 or higher versions.

Regards, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise your mail is discarded by a filter.
=-"-"-= http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]