Subject: Please Help on Customizing Start-Menu

From: David Sun <[email-masked]>
Date: 26 Nov 2004 10:51:54 +0800

Hi all
I'm planning to customize the Start Menu on the taskbar based on fvwm
2.4.18.The thing I would like to do is:

when people left-mouse-click on the Start Menu, fvwm will look for
certain place on local disk for some certain files, and spawn the menu
on the fly according to the lookup result.

Could you please advise which files/functions I should look into? And
how can I look into a running FVWM for what call-chains are performed
when certain event happens? The more detailed is more appreciated^_^

thanks for your help
David Sun

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: David Sun <[email-masked]>
Date: 29 Nov 2004 16:40:21 +0800

Hi Dominik
在 2004-11-29 一 的 01:23， Dominik Vogt 写道：
> On Fri, Nov 26, 2004 at 10:51:54AM +0800, David Sun wrote:
> > Hi all
> > Could you please advise which files/functions I should look into?
> 
> Take a look at the DynamicPopUpAction menu option and the
> fvwm-menu-directory script.
thanks for your advice, unfortuantely, my target machine is too
size-limited to have perl. I have achieved the purpose by playing with
the FvwmTaskBar code which get called when the "Start" button is pressed
> > And
> You can attach a debugger to the running fvwm process from a
> console or a second X server (*not* from the X server running
> fvwm).  With gdb:
> 
>   $ gdb fvwm <processid>
> 
> Ciao
> 
> Dominik ^_^  ^_^
> 
>  --
> Dominik Vogt, [email-masked]