Subject: SnapAttraction does not work properly since 2.5.11

From: [email-masked]
Date: Tue, 26 Oct 2004 00:32:38 -0700

Starting with version 2.5.11 SnapAttraction no longer works for me.

I have narrowed it down to the transition from 2.5.10 to 2.5.11 in
fvwm/move_resize.c.

In particular the __move_loop function has changed some event management
stuff in the proximity of lines 2100-2200.  I switched it back to the
2.5.10 code in a test and SnapAttraction went back to working.

However, I do not have time to look into why the code changed in the first
place, so I have no proper patch to fix this.

-- 
AJ Weber
[email-masked]
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Oct 2004 09:47:10 +0200

> 2.5.10 code in a test and SnapAttraction went back to working.

2.5.12 should work fine.

> place, so I have no proper patch to fix this.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Manoj Srivastava <[email-masked]>
Date: Tue, 26 Oct 2004 12:36:02 -0500

Hi,

        [Please retain the CC to [email-masked], so
        that the debian BTS may have a record of your input]

> 2.5.12 should work fine.

 SnapAttraction 20 SameType
 SnapGrid 10 10

	It actually works, but only if no modifier is pressed. So, if
 one has a binding like 

Mouse 1 T A move-or-raise 
 one has to release alt before getting attraction.

	manoj

-- 
Home on the Range was originally written in beef-flat.
Manoj Srivastava   <[email-masked]>  <http://www.datasync.com/%7Esrivasta/>
1024D/BF24424C print 4966 F272 D093 B493 410B  924B 21BA DABB BF24 424C
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]