Subject: Notification: incoming/1451

From: [email-masked]
Date: Fri, 1 Oct 2004 10:34:32 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1451

Message summary for PR#1451
	From: [email-masked]
	Subject: PRIVATE: The State flags gets over-written
	Date: Fri, 1 Oct 2004 10:34:22 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Fri Oct 01 10:34:25 2004
Date: Fri, 1 Oct 2004 10:34:22 -0500
From: [email-masked]
To: [email-masked]
Subject: PRIVATE: The State flags gets over-written

Full_Name: Rouben Rostamian
Version: 2.5.11
CVS_Date: 
OS: SuSE Linux 9.0
X_Server: XFree86-4.3.0.1
Submission from: (NULL) (68.55.20.208)

I have encountered what seems to be a bug in fvwm 2.5.11.
I have verified that the bug is not present in 2.5.10 and 2.5.8.

I have a short script to demo the bug.  The script calls for two
pixmaps.  I don't know how to submit the script along with pixmaps
through this web interface.  If you give me an email address
where I can send the three files and the description of the problem,
I will be glad to do so.

Rouben Rostamian

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Oct 2004 13:33:40 +0200

> where I can send the three files and the description of the problem,

Send the report to [email-masked]

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Rouben Rostamian <[email-masked]>
Date: Sat, 2 Oct 2004 09:39:15 -0400

Hello Dominik,

Following your advice, I am sending this bug report to you.
The problem is described in one of the attachments.
I hope you will be able to make sense out of it.

Rouben

---

From: Rouben Rostamian <[email-masked]>
Date: Sun, 3 Oct 2004 20:34:26 -0400

Hello Dominik,

Thanks for your instantaneous response to the problems I had noted
in my two previous messages.

It's support and dedication like this that makes fvwm stand
out among other software.

Best regards,

Rouben

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Oct 2004 05:28:05 +0200

On Sat, Oct 02, 2004 at 09:39:15AM -0400, Rouben Rostamian wrote:
> I encountered what seems to be a bug that was introduced in 2.5.11.
> The bug was not present in 2.5.10 and 2.5.8.
> 
> Unfortunately it is somewhat complicated to describe the situation.
> I have tried to localize the problem to a minimal script.  Couldn't get
> the script any smaller.  Sorry.  The script is extracted from a much
> larger script which is my fvwm configuration.
> 
> I have shown the script below with line numbers added so that I can
> refer to them.
> 
> In line 26, I bind a mouse click to titlebar's button 4 to execute
> the function "MaximizeHeight".
> 
> The function "MaximizeHeight", defined in lines 21-24 is a toggle;
> if the window's "State" is 4, it calls the function MaximizeHeightOff
> (which returns the window to its normal size and sets State 4 to
> False).  Otherwise, it calls the function MaximizeHeightOn (which
> stretches the window in the vertical direction and sets State 4
> to True).
> 
>  1   DestroyDecor StateNormal
>  2   AddToDecor StateNormal
>  3   + AddButtonStyle 4 Pixmap button-vert-off.xpm
>  4   
>  5   DestroyDecor StateMaxHeight
>  6   AddToDecor StateMaxHeight
>  7   + AddButtonStyle 4 Pixmap button-vert-on.xpm
>  8   
>  9   DestroyFunc MaximizeHeightOn
> 10   AddToFunc MaximizeHeightOn
> 11   + I State 4 True
> 12   + I ResizeMoveMaximize frame keep 85 keep 5
> 13   + I ChangeDecor StateMaxHeight
> 14   
> 15   DestroyFunc MaximizeHeightOff
> 16   AddToFunc MaximizeHeightOff
> 17   + I State 4 False
> 18   + I Maximize False
> 19   + I ChangeDecor StateNormal
> 20   
> 21   DestroyFunc MaximizeHeight
> 22   AddToFunc MaximizeHeight
> 23   + I Current (State 4) MaximizeHeightOff
> 24   + I TestRc (NoMatch) MaximizeHeightOn
> 25   
> 26   Mouse 0  4  A  MaximizeHeight
> 
> 
> The script, as shown, works in fvwm 2.5.8 and 2.5.10, but fails in
> 2.5.11.  In 2.5.8 and 2.5.10, mouse clicks on titilebar button 4 toggle
> the window's maximized state.  In 2.5.11 the window gets maximized,
> but subsequent clicks do not return it to its normal state.
> 
> The problem in 2.5.11 can be narrowed to lines 11-13: the State
> which is set in line 11 gets clobbered when line 13 is executed.
> You can verify this by inserting a few "Echo" commands in the code.
> 
> I can work around the problem by putting line 11 after line 13, as in:
> 
>  9   DestroyFunc MaximizeHeightOn
> 10   AddToFunc MaximizeHeightOn
> 12   + I ResizeMoveMaximize frame keep 85 keep 5
> 13   + I ChangeDecor StateMaxHeight
> 11   + I State 4 True
> 
> Although this solves my problem, I don't see why the original
> arrangement doesn't work in 2.5.11.  If it is a bug, then it
> may have other consequences which I haven't yet seen.

Fixed.

Ciao

Dominik ^_^  ^_^