Subject: Notification: incoming/1453

From: [email-masked]
Date: Sat, 2 Oct 2004 14:48:49 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1453

Message summary for PR#1453
	From: [email-masked]
	Subject: Enhance FakeKeyPress please
	Date: Sat, 2 Oct 2004 14:48:39 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Sat Oct 02 14:48:41 2004
Date: Sat, 2 Oct 2004 14:48:39 -0500
From: [email-masked]
To: [email-masked]
Subject: Enhance FakeKeyPress please

Full_Name: Tommy C. Li
Version: 2.5.11
CVS_Date: 
OS: Gentoo Linux
X_Server: Xorg
Submission from: (NULL) (69.172.241.119)

It would be great if FakeKeyPress was enhanced a bit. Specifically, I'd
find very useful the following enhancements:

-Send keys not just to specific windows, but the currently active window
-Allow sending of keys modified with Ctrl, Meta, etc.

Perhaps this could be put into an executable or script. XMacro had a good
concept, but is unfortunately way too old, and doesn't work for me at all.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Oct 2004 04:19:08 +0200

On Sat, Oct 02, 2004 at 02:48:49PM -0500, fvwm-bug wrote:
> It would be great if FakeKeyPress was enhanced a bit.

It does not need to be enhanced, it already supports what you are
looking for.

> Specifically, I'd find very useful the following enhancements:
> 

Try

  Current FakeKeyPress ...

> -Allow sending of keys modified with Ctrl, Meta, etc.

  FakeKeyPress modifiers 8 press xyz release xyz modifiers -8

> concept, but is unfortunately way too old, and doesn't work for me at all.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: "Tommy C. Li" <[email-masked]>
Date: Mon, 04 Oct 2004 21:20:58 -0700

Dominik Vogt wrote:
> <snip>

Sorry, I didn't think to look at the manpage, but rather checked the 
online documentation.

Regarding the title-bar at the side, is it possible to have rotated 
text? So the title would look like:

M
o
z
i
l
l
a

?

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 5 Oct 2004 08:29:26 +0000

> text? So the title would look like:

If you actually mean the text that looks exactly as shown here, then this
is not currently possible, and there are technical reasons why. We would
need to implement our own divider to chars (not trivial at all with i18n)
and our own rendering of individual chars rather than the whole text
(this is doable except for some languages like Arabic).

This is also arguably less readable for long text. I would not do this.

Or maybe you don't ask for T in the side titlebars, but for |-- vus --|.
Then take a look at Style LeftTitleRotatedCW and LeftTitleRotatedCCW
in the man page.

Feel free to ask questions on fvwm @ fvwm.org list.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Oct 2004 10:53:41 +0200

> text? So the title would look like:

No.  When we wrote the rotated titles feature, we first
implemented it with upright letters.  But it looks absolutely
awful, so we replaced it with the rotated strings.

Ciao

Dominik ^_^  ^_^