Subject: Notification: incoming/1474

From: [email-masked]
Date: Mon, 18 Oct 2004 11:12:06 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1474

Message summary for PR#1474
	From: [email-masked]
	Subject: Crash in "Wait"-Function
	Date: Mon, 18 Oct 2004 11:11:55 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Mon Oct 18 11:11:56 2004
Date: Mon, 18 Oct 2004 11:11:55 -0500
From: [email-masked]
To: [email-masked]
Subject: Crash in "Wait"-Function

Full_Name: Peter Daum
Version: 2.5.11 / 2.5.12
CVS_Date: 
OS: Linux 2.6.8
X_Server: X.org 6.8.1
Submission from: (NULL) (217.231.94.145)

starting with fvwm 2.5.11 when fvwm is executing something like
"Wait NoSuchWindowName"
it shows a "busy cursor" and waits forever.
Well, not really forever: as soon as I hit any key, it crashes.

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Oct 2004 10:36:29 +0200

> Well, not really forever: as soon as I hit any key, it crashes.

Can you please fetch me a stack trace?  Look for the "core" file,
then run

  $ gdb fvwm core
  (gdb) where

and post the output to [email-masked]

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Peter Daum <[email-masked]>
Date: Sun, 31 Oct 2004 22:31:25 +0100 (MET)

here's a stacktrace for bug #1474
(Line numbers are for version 2.5.12, the segfault obviously occurs in:

>			escape = CheckBinding(
>				Scr.AllBindings, STROKE_ARG(0)
>				e.xkey.keycode, e.xkey.state,
>				GetUnusedModifiers(), context,
>				BIND_KEYPRESS, &t->class, t->name.name);

#0  0x0807491f in CMD_Wait (cond_rc=0xbfffe2a0, exc=0x81876a0,
    action=0x818396d "Mozillaxx") at builtins.c:2559
#1  0x0809ffac in __execute_function (cond_rc=0xbfffe2a0, exc=0x8113400,
    action=Variable "action" is not available.
) at functions.c:630
#2  0x080a09b7 in __run_complex_function_items (cond_rc=0xbfffe2a0,
    cond=105 'i', func=Variable "func" is not available.
) at functions.c:820
#3  0x080a03f1 in __execute_function (cond_rc=0x0, exc=0x8113380, action=Variabl
)
    at functions.c:1001
#4  0x080a084d in execute_function (cond_rc=0x8, exc=0x0, action=0x0,
    exec_flags=0 '\0') at functions.c:1241
#5  0x08085d07 in StartupStuff () at fvwm.c:1531
#6  0x08062574 in My_XNextEvent (dpy=0x80f6b30, event=0xbfffe580)
    at events.c:3883
#7  0x080628db in HandleEvents () at events.c:3802
#8  0x0808865e in main (argc=3, argv=0xbffff1b4) at fvwm.c:2520