Subject: Re: man pages have wrong date

From: Scott Smedley <[email-masked]>
Date: Sat, 4 Sep 2004 21:35:06 +1000

> The very last line of all the
> man pages (with the notable exception of fvwm.1) appears to have an arbitary
> date (hardcoded from the source man page).

I just commited a patch to parse all man pages through config.status.

This involved renaming most *.1 files to *.1.in. Several man pages
appear to be auto-generated by Perl scripts:

./bin/fvwm-menu-directory.1
./bin/fvwm-menu-headlines.1
./bin/fvwm-menu-xlock.1
./bin/fvwm-perllib.1
./modules/FvwmDebug/FvwmDebug.1
./modules/FvwmDebug/FvwmGtkDebug.1
./modules/FvwmPerl/FvwmPerl.1
./modules/FvwmWindowMenu/FvwmWindowMenu.1

So I've not changed these.

I'm not sure if I need to make any further changes to complete this
patch. For example, when making a release, will scripts automatically
pickup the new *.1.in files & ignore the *.1 files?

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Sep 2004 10:27:14 +0200

> pickup the new *.1.in files & ignore the *.1 files?

Yes.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]