Subject: CVS broken for Xinerama systems

From: Scott Smedley <[email-masked]>
Date: Sat, 4 Sep 2004 21:46:23 +1000

Hi all,

The current version of FVWM in CVS seg faults on my Xinerama system:

Program received signal SIGSEGV, Segmentation fault.
0x080b6804 in FScreenInit (dpy=0x2b8300) at FScreen.c:444
444                     memcpy(screens_xi + 1, info,
(gdb) p info
$1 = (XineramaScreenInfo *) 0x0

It works fine if I configure X for single screen setup.

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Sep 2004 12:10:11 +0200

> Subject: CVS broken for Xinerama systems

(By the way, if the subject starts with "CVS" it looks like a
message generated by CVS, lowering the chance that anybody reads
that message).

> It works fine if I configure X for single screen setup.

Fixed.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]