Subject: fvwm and AMD64

From: Borut Kersevan <[email-masked]>
Date: Wed, 15 Sep 2004 18:22:01 +0200

Hi,

fvwm has quite some problems with AMD64, specifically module communication is wrong; for example the window_flags in  ConfigWinPacket 
do not get passed to modules (empty?) so FvwmIconMan and Pager or Identify show wrong info (iconified windows are still visible in pager or similar).. I would hazard a guess that the error is somewhere in
make_new_vpacket (fvwm/module_interface.c), probably due to some  conversion assumptions which do not work in 64bit env.. alas, fvwm was(is) my editior of choice but I can't spare the time fixing it myself..

Best,

Borut 

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Borut Kersevan <[email-masked]>
Date: Thu, 16 Sep 2004 14:11:09 +0200

Hm, yes.. however the package transport is still broken; specifically I 
think the stuff in 'newpackage' composition/conversion is faulty..
suggestions..?

Best,

Borut

Dominik Vogt wrote:

>On Wed, Sep 15, 2004 at 06:22:01PM +0200, Borut Kersevan wrote:
>  
>
>>Hi,
>>
>>fvwm has quite some problems with AMD64, specifically module communication 
>>is wrong; for example the window_flags in  ConfigWinPacket do not get 
>>passed to modules (empty?) so FvwmIconMan and Pager or Identify show wrong 
>>info (iconified windows are still visible in pager or similar).. I would 
>>hazard a guess that the error is somewhere in
>>make_new_vpacket (fvwm/module_interface.c), probably due to some  
>>conversion assumptions which do not work in 64bit env.. alas, fvwm was(is) 
>>my editior of choice but I can't spare the time fixing it myself..
>>    
>>
>
>Have you tried the current CVS code?  There are some 64 bit fixes
>in there, but some problems definitely remain.
>
>Ciao
>
>Dominik ^_^  ^_^
>
> --
>Dominik Vogt, [email-masked]
>  
>

-- 

--------------------------------------------------------------------------
dr. Borut Paul Kersevan                       Tel.: +386 1 477 3454
Experimental Particle Physics Department(F9)  Fax.: +386 1 425 7074
Jozef Stefan Institute, P.P. 3000             E-mail:[email-masked]
Jamova 39, 1001 Ljubljana, Slovenia