Subject: Re: man pages have wrong date

From: Scott Smedley <[email-masked]>
Date: Sat, 14 Aug 2004 12:53:47 +1000

> > Create FvwmButtons.1.in, a Makefile entry & run it through config.status?
> > (like the fvwm.1 man page)

I'm having trouble determining the configuration (in fvwm/Makefile.am?)
that creates this target in fvwm/Makefile.in:

fvwm.1: $(top_builddir)/config.status fvwm.1.in
    cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@

Can anyone offer a clue on how the fvwm.1 target is created?

Initially, I created an explicit target:

FvwmButtons.1: $(top_builddir)/config.status FvwmButtons.1.in
    cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@

in fvwm/modules/FvwmButtons/Makefile.am, but this seems kinda hackish
given that the fvwm.1 target is generated automatically. (somehow)

SCoTT. :)
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 14 Aug 2004 10:57:31 +0200

> Can anyone offer a clue on how the fvwm.1 target is created?

It's the rule

  man_MANS = fvwm.1

> given that the fvwm.1 target is generated automatically. (somehow)

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Aug 2004 09:50:22 +0000

> Can anyone offer a clue on how the fvwm.1 target is created?

This is done by configure (or more precisely config.status), it converts
fvwm.1.in to fvwm.1 and automatically handles Makefile rules.

You should just add a name of file to AC_OUTPUT section of configure.in
if you want it to be automatically (re)generated.

Regards,
Mikhael.