Subject: Notification: incoming/1393

From: [email-masked]
Date: Wed, 11 Aug 2004 12:57:25 -0500 (CDT)

FVWM Bug Tracking notification

new message incoming/1393

Message summary for PR#1393
	From: Manoj Srivastava <[email-masked]>
	Subject: Bug#263945: When starting fvwm, FvwmWinList contains random windows
	Date: Wed, 11 Aug 2004 12:55:53 -0500
	0 replies 	0 followups

====> ORIGINAL MESSAGE FOLLOWS <====

>From [email-masked] Wed Aug 11 12:57:25 2004
To: [email-masked]
Cc: Vincent Lefevre <[email-masked]>, [email-masked]
Subject: Bug#263945: When starting fvwm, FvwmWinList contains random windows
From: Manoj Srivastava <[email-masked]>
Organization: The Debian Project
Mail-Copies-To: nobody
Date: Wed, 11 Aug 2004 12:55:53 -0500

--=-=-=

Hi,

        [Please retain the CC to [email-masked], so
        that the Debian BTS has a record of your input]

        The attached email and .fvwmrc file were sent in by a Debian
 user, and talk about a wrong set of windows in FvwmWinList on
 restart. I have not been able to reproduce the error personally, but
 I figured I'd pass it on to see if anyone else had better ideas for
 diagnosing this.

	manoj

--=-=-=
Content-Type: message/rfc822
Content-Disposition: inline

Subject: Bug#263945: When starting fvwm, FvwmWinList contains random windows
Reply-To: Vincent Lefevre <[email-masked]>, [email-masked]
Resent-From: Vincent Lefevre <[email-masked]>
Original-Sender: Vincent Lefevre <[email-masked]>
Resent-To: [email-masked]
Resent-CC: Manoj Srivastava <[email-masked]>
Resent-Date: Fri, 06 Aug 2004 11:33:03 UTC
Resent-Message-ID: <[email-masked]>
Date: Fri, 6 Aug 2004 13:19:40 +0200
From: Vincent Lefevre <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Sender: Vincent Lefevre <[email-masked]>
Resent-Sender: Debian BTS <[email-masked]>
Lines: 399
Xref: glaurung.internal.golden-gryphon.com debian:12126

--===-=-=
Content-Disposition: inline

Package: fvwm
Version: 2.5.10-10
Severity: normal

When I first started fvwm, FvwmWinList contained two windows:
  * FvwmButtons
  * Desk 0

I quit fvwm and restarted it, and I also got two windows in the list,
corresponding to two terminals, including the console (that shouldn't
be there).

I've attached my config file. I start fvwm with:

    exec fvwm2 -cmd "FvwmM4 $HOME/etc/fvwm2rc.m4"

from my .xinitrc file. The domain.m4 file contains:

define(AY,1)dnl

Note: two is the correct number of windows, but these are not the
right windows...

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (900, 'testing'), (200, 'unstable')
Architecture: powerpc (ppc)
Kernel: Linux 2.6.7-powerpc
Locale: LANG=POSIX, LC_CTYPE=en_US.ISO8859-1

Versions of packages fvwm depends on:
ii  libc6                     2.3.2.ds1-13   GNU C Library: Shared libraries an
ii  libfontconfig1            2.2.3-1        generic font configuration library
ii  libfreetype6              2.1.7-2.1      FreeType 2 font engine, shared lib
ii  libfribidi0               0.10.4-3       Free Implementation of the Unicode
ii  libglib1.2                1.2.10-9       The GLib library of C routines
ii  libgtk1.2                 1.2.10-17      The GIMP Toolkit set of widgets fo
ii  libice6                   4.3.0.dfsg.1-4 Inter-Client Exchange library
ii  libncurses5               5.4-4          Shared libraries for terminal hand
ii  libpng12-0                1.2.5.0-6      PNG library - runtime
ii  libreadline4              4.3-11         GNU readline and history libraries
ii  librplay3                 3.3.2-8        Shared libraries for the rplay net
ii  libsm6                    4.3.0.dfsg.1-4 X Window System Session Management
ii  libstroke0                0.5.1-4        support for mouse strokes like tho
ii  libx11-6                  4.3.0.dfsg.1-4 X Window System protocol client li
ii  libxext6                  4.3.0.dfsg.1-4 X Window System miscellaneous exte
ii  libxft2                   2.1.2-6        FreeType-based font drawing librar
ii  libxi6                    4.3.0.dfsg.1-4 X Window System Input extension li
ii  libxpm4                   4.3.0.dfsg.1-4 X pixmap library
ii  libxrender1               0.8.3-7        X Rendering Extension client libra
ii  xlibs                     4.3.0.dfsg.1-4 X Window System client libraries m
ii  zlib1g                    1:1.2.1.1-5    compression library - runtime

-- debconf information:
* fvwm/upgrade/pre_2.5.8: true

--===-=-=
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: attachment; filename=fvwm2rc.m4
Content-Transfer-Encoding: quoted-printable
X-MIME-Autoconverted: from 8bit to quoted-printable by glaurung.internal.golden-gryphon.com id i7BHu4Op000937

# Vincent Lef=E8vre's .fvwm2rc

include(HOME/etc/domain.m4)dnl
define(BG,HOME/wd/www-new/contents/images/chat2.jpg)dnl

### Paths ##############################################################

ModulePath	FVWM_MODULEDIR:/usr/local/lib/fvwm2
ImagePath	HOME/images:/usr/local/lib/fvwm2/icons:+

### Desktop ############################################################

DeskTopSize	2x2
OpaqueMoveSize	80
EdgeResistance	10000 20

### C
====> MESSAGE TRUNCATED AT 8192 <====

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Vincent Lefevre <[email-masked]>
Date: Thu, 12 Aug 2004 15:21:14 +0200

On 2004-08-12 13:21:05 +0200, Dominik Vogt wrote:
> I'm almost sure that you restarted fvwm with a different
> configuration file.  Please double check

No, same configuration file.

>  * the options given to the fvwm command

(executed by startx, via the .xinitrc file), as said in my bug report.

>  * that the same fvwm binary is restarted (you may have multiple
>    versions installed).

I've only one version installed.

>  * the right modules are executed, i.e. the ones that came with
>    the running fvwm version (check the ModulePath carefully).

Only one version of these modules are installed on this machine.
They come from the Debian fvwm package.

> Note that 2.5.8 is not an fvwm version I recommend to use.  If you
> need the features from the 2.5.x series, use 2.5.10.

I'm using the 2.5.10 version, as the bug report mentionned. The
"fvwm/upgrade/pre_2.5.8: true" is just debconf information saying
that I upgraded from a version < 2.5.8 in the past or something
like that.

> This looks highly suspicious.  Unless you're using FvwmCpp,

I don't use FvwmCpp, just FvwmM4.

> FVWM_MODULEDIR is definitely not expanded to what you think it is.
> The right syntax is 
> 
>   ModulePath $FVWM_MODULEDIR:/usr/local/lib/fvwm2
>             ^^^

I removed the ModulePath anyway, but have the same problem (after
testing several times, quitting fvwm and X first before retrying).

> Same problem as above.  I think you want
> 
>   ImagePath $HOME/images:/usr/local/lib/fvwm2/icons:+
>            ^^^

No, this is incorrect. With the $, the images are not found (probably
because HOME has already been replaced by the value of its macro and
there is a $ in front of the path).

-- 
Vincent Lefèvre <[email-masked]> - Web: <http://www.vinc17.org/>
100% validated (X)HTML - Acorn / RISC OS / ARM, free software, YP17,
Championnat International des Jeux Mathématiques et Logiques, etc.
Work: CR INRIA - computer arithmetic / SPACES project at LORIA
--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Vincent Lefevre <[email-masked]>
Date: Tue, 17 Aug 2004 15:28:07 +0200

I noticed the same problem on another machine (fvwm package version
2.5.10-12 on a Debian/unstable x86 machine): the number of items was
correct (3 on this machine), but the windows bound to them were not
the correct ones.

This problem disappeared after rebooting the machine.