Subject: patch for 64bit support (e.g. amd64)

From: "Harald Dunkel" <[email-masked]>
Date: Fri, 06 Aug 2004 20:59:24 +0200

Hi folks,

I've got a problem with some XWindow applications using
an AMD64 machine as XServer: The window cannot be moved,
the decorations are wrong, etc. Sample applications:
acroread, openoffice.

The attached patch for fvwm seems to fix the problem.

I am not the specialist for window manager hints, but
maybe some of you folks could verify this?

Many thanx

Harri
--- fvwm/decorations.c.orig	2003-10-21 07:52:33.000000000 +0200
+++ fvwm/decorations.c	2004-08-06 20:30:05.605756454 +0200
@@ -94,10 +94,10 @@
 /* Motif  window hints */
 typedef struct
 {
-	int      flags;
-	int      functions;
-	int      decorations;
-	int      inputMode;
+	long      flags;
+	long      functions;
+	long      decorations;
+	long      inputMode;
 } PropMotifWmHints;
 
 typedef PropMotifWmHints PropMwmHints;

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Aug 2004 21:43:57 +0200

> maybe some of you folks could verify this?

I have checked the OpenOffice.org and the lesstif sources.  Both
use long values for the data elements.  According to the X
protocol specification, only 8, 16 and 32 bit quantities are
allowed, so strictly speaking these applications are buggy.

*But* The X sources do exactly the same and thus they work on 64
bit platforms.  It looks like the X folks spent an awful lot of
time to break the X spec on purpose.  Actually, only 32 bits are
sent over the network, but the data is expected in 64 bit format
when setting a property and converted to 64 bits when reading on
the client side.  Replacing the ints with longs seems to be the
right fix for the moment.  

> +++ fvwm/decorations.c	2004-08-06 20:30:05.605756454 +0200

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]