Subject: configure extra cflags?

From: Chris Ross <[email-masked]>
Date: Thu, 26 Aug 2004 12:34:06 -0400

Hey there.  I have a small problem, that will require
changes to configure to solve.  On my Solaris machine,
there are #pragma's in some of the openwin X headers
that gcc (3.3.2) doesn't like.  This is easily solvable
with "-wunknown-pragmas", but if I put that in CFLAGS
on the configure command-line environment, it will
append "-Wall", thus cancelling it out.

   I thought it might be more useful to be able to
put arbitrary things on the CFLAGS (and/or CPPFLAGS),
but have them go after the -Wall.

   Anyone else have any thoughts on this issue?

                          - Chris

--
Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Thu, 26 Aug 2004 20:11:23 -0400

>    Anyone else have any thoughts on this issue?

If I understand the question, I'd ifdef in the pragmas,
only when the sun compiler is being used.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Danek Duvall <[email-masked]>
Date: Thu, 26 Aug 2004 17:50:25 -0700

> only when the sun compiler is being used.

At least on my Solaris boxes, #pragma ident is the only pragma in
/usr/openwin/include.  Gcc (3.3.3 here) seems to warn about those if either
-Wall or -Wunknown-pragmas is used, but passes through it just fine; i.e.,
it's just build noise.

I assume, Chris, that what you would like to do here is

    gcc ... -Wall -Wno-unknown-pragmas ...

?

Note that almost all Solaris include files have #pragma ident; it's just
part of the version control stuff that Sun uses.

Danek

---

From: Chris Ross <[email-masked]>
Date: Thu, 26 Aug 2004 23:38:14 -0400

> part of the version control stuff that Sun uses.

   Yes.  That's exactly what I'd like to do, to reduce the build noise
so I can more easily track real warnings or errors I care about.

   But, as noted, there's no way to put something in CFLAGS without
putting it before -Wall.  This is what I was asking for thoughts 
about...

                        - Chris

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 2004 10:28:57 +0200

> putting it before -Wall.  This is what I was asking for thoughts 

I've moved the user specified CFLAGS behind -Wall
-Wno-implicit-int in configure.in.  That should solve the problem.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]